Получение информации

Поиск необходимой информации
Справочная система организована так, чтобы можно было легко найти нужный раздел.


Поиск необходимой информации - Понятия

Получение информации
Поиск необходимой информации
Понятия
Процедуры
Команды

Справочная система организована так, чтобы можно было легко найти нужный раздел.

  • Установка программы
    Программа легко устанавливается на автономном компьютере.
  • Эффективное использование справочной системы
    Умение эффективно использовать справочную систему может быть полезным при использовании программы.
  • Использование "Быстрой справки" на информационной палитре
    "Быстрая справка" располагается на "Информационной палитре" и является удобным средством получения информации из справочной системы. С помощью "Быстрой справки" можно отобразить процедуры на компактной палитре, занимающей немного места в области рисования.
  • Обучение работе с программой
    Обучающие программы и продукты от Autodesk помогают пользователям осваивать ключевые технические характеристики и повышать производительность. Для получения последних сведений об обучающих программах Autodesk training посетите веб-сайт http://www.autodesk.com/training-rus или обратитесь в местный офис Autodesk.
  • Доступ к Центру подписки
    Подписчики могут обращаться в Центр подписки непосредственно из программы. Если пользователь является подписчиком Autodesk, получить доступ к услугам, предоставляемым по подписке, можно, выбрав раздел справки "Ресурсы по подписке". Информацию о том, как стать подписчиком Autodesk, см. по адресу http://www.autodesk.com/subscription-rus.
  • Получение новостей и обновлений программы
    Коммуникационный центр обеспечивает доступ с экрана компьютера к последним сведениям о программном продукте, обновлениям программ, новостям службы технической поддержки и т.д. Тип и регулярность получения информации могут регулироваться в зависимости от требований пользователя.
  • Просмотр файла дополнительных сведений (Readme)
    Последние сведения об этой программе см. в файле Readme.
Ваш комментарий об этой странице


Поиск необходимой информации - Процедуры

Получение информации
Поиск необходимой информации
Понятия
Процедуры
Команды

Вызов справочной системы

Использование панели содержания справочной системы

Поиск информации в справочной системе (поиск на естественном языке)

Перенаправление запросов в Интернет (поиск на естественном языке)

Поиск информации в справочной системе (функция поиска Microsoft )

Смена типа отображаемой справочной информации

Печать раздела справочной системы

Печать выбранного раздела и всех вложенных разделов

Вывод "Быстрой справки"

Перемещение по разделам "Быстрой справки"

Печать "Быстрой справки"

Фиксирование раздела "Быстрой справки"

Вызов "Центра подписки" из программы

Установка "Центра подписки" (компонент утилиты "Диспетчер Интернет-компонентов")

Установка сервисной программы Коммуникационный центр (часть программы "Диспетчер Интернет-компонентов")

Настройка параметров "Коммуникационного центра"

Открытие окна "Коммуникационный центр"


Поиск необходимой информации - Команды

Получение информации
Поиск необходимой информации
Понятия
Процедуры
Команды
Команды
ПОМОЩНИК | Открывает в информационной палитре "Быструю справку", которая отображает контекстную информацию
ПОМОЩНИКЗАКР | Закрывает "Быструю справку" в информационной палитре
СПРАВКА | Вызов справочной системы
Системные переменные
ASSISTSTATE | Указывает состояние активности информационной палитры, отображающей краткую справку.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Установка программы - Понятия

Получение информации
Поиск необходимой информации
Установка программы
Понятия
Процедуры
Команды

Программа легко устанавливается на автономном компьютере.

Вставить установочный компакт-диск в устройство чтения. Затем в обозревателе диска на вкладке "Установка" выберите элемент "Отдельная установка". Нажмите кнопку "Установка". Запускается "Мастер установки", который направляет дальнейшие действия по установке программы. В обозревателе диска отображаются также инструкции по сетевой установке и получению доступа к информации о технической поддержке и лицензировании.

Подробную информацию об автономной установке AutoCAD®, можно найти в Руководстве по автономной установке. Чтобы открыть данное руководство, выберите вкладку "Документация" в обозревателе диска. Далее выберите файл Stand-Alone Installation Guide (PDF).

Дополнительную информацию о развертывании этой программы в сети см. в Руководстве сетевого администратора. Чтобы открыть данное руководство, выберите вкладку "Документация" в обозревателе диска. Далее выберите файл Network Administrator's Guide (PDF).

После того как программа установлена, в справочной системе можно открыть Руководство по однопользовательской установке или Руководство сетевого администратора.

Утилиты переноса

Утилиты переноса помогают пользователю сохранить при обновлении программы свои наработки, выполненные в прежней версии. Их можно загрузить с веб-сайта Autodesk, где они доступны на нескольких языках.

Примечание Отдельные настройки и файлы можно перенести из прежней версии при помощи диалогового окна "Перенос пользовательских настроек". Для получения дополнительных сведений о диалоговом окне "Перенос пользовательских настроек" см. Руководство по однопользовательской установке.

В число утилит переноса входят:

  • Утилита преобразования конфигураций слоёв (Layer State Converter)
  • DWG TrueConvert
  • Утилита анализа совместимости AutoLISP (AutoLISP Compatibility Analyzer)
  • ScriptPro

На веб-сайте Autodesk® http://www.autodesk.comвыполните поиск по ключевой фразе "Утилиты переноса".

Примечание Поскольку утилиты переноса являются общедоступными, их поддержка предоставляется только на уровне групп пользователей Autodesk.


Поиск необходимой информации

Получение информации
Поиск необходимой информации
Поиск необходимой информации
Понятия
Процедуры
Команды

Нет процедур.


Установка программы - Команды

Поиск необходимой информации
Поиск необходимой информации
Установка программы
Понятия
Процедуры
Команды

Команды
СПРАВКА | Вызов справочной системы
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Эффективное использование справочной системы - Понятия

Получение информации
Поиск необходимой информации
Эффективное использование справочной системы
Понятия
Процедуры
Команды

Умение эффективно использовать справочную систему может быть полезным при использовании программы.

Справка содержит полную информацию об этой программе. Для выбора темы служит левая область окна справочной системы. С помощью вкладок в верхней части левой области можно выбирать способ поиска информации. В правой области окна выводится справочная информация по выбранной теме.

  • Поиск информации в справочной системе
    Поиск информации может выполняться различными способами в зависимости от того, какая вкладка активна в левой области окна.
  • Средства поиска
    Для поиска тем, относящихся к введённому слову или фразе, используется вкладка "Поиск".
  • Организация разделов справочной системы
    В большинстве разделов справки в верхней части правой панели окна справки есть три вкладки. На вкладках отображаются различные виды информации.
  • Использование стрелки вверх для перемещения по разделам справочной системы
    В правом верхнем углу раздела может отображаться символ стрелки вверх.
  • Печать разделов справочной системы
    Самый простой способ печати текущего раздела - нажмите на нем правую кнопку мыши и выберите "Печать".
  • Показ и скрытие панели содержания
    Кнопкой "Скрыть" на панели инструментов справочной системы окно справки уменьшается до компактных размеров за счёт исчезновения панели, содержащей вкладки "Содержание", "Указатель" и "Поиск".
  • Получение дополнительной информации
    Существует ряд дополнительных способов получения справочной информации.


Эффективное использование справочной системы - Процедуры

Получение информации
Поиск необходимой информации
Эффективное использование справочной системы
Понятия
Процедуры
Команды

Вызов справочной системы

Использование панели содержания справочной системы

Поиск информации в справочной системе (поиск на естественном языке)

Перенаправление запросов в Интернет (поиск на естественном языке)

Поиск информации в справочной системе (функция поиска Microsoft )

Смена типа отображаемой справочной информации

Печать раздела справочной системы

Печать выбранного раздела и всех вложенных разделов


Эффективное использование справочной системы - Команды

Получение информации
Поиск необходимой информации
Эффективное использование справочной системы
Понятия
Процедуры
Команды
Команды
СПРАВКА | Вызов справочной системы
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Поиск информации в справочной системе - Понятия

Получение информации
Поиск необходимой информации
Поиск информации в справочной системе
Понятия
Процедуры
Команды

Поиск информации может выполняться различными способами в зависимости от того, какая вкладка активна в левой области окна.

Чтобы найти определенное слово или фразу в текущем разделе, выберите раздел и нажмите сочетание клавиш CTRL+F.

Вкладка "Содержание"
  • На этой вкладке представлен список глав и разделов, дающий общее представление о содержании справочной системы.
  • Перемещение по темам осуществляется путем выбора и разворачивания разделов.
  • Благодаря структурированности содержания пользователь не теряет ориентации и может быстро найти нужный раздел.
Вкладка "Указатель"
  • На этой вкладке представлен алфавитный список ключевых слов для всех разделов, перечисленных на вкладке "Содержание".
  • Эта вкладка позволяет быстро получить информацию, если известно название функции, команды или операции или понятно, какое действие необходимо выполнить в программе.
Вкладка "Поиск" (функция поиска Microsoft)
  • Обеспечивает полнотекстовый поиск по всем разделам справочной системы.
  • Позволяет найти все вхождения заданного слова или выражения.
  • Результатом поиска является отсортированный список разделов, в которых встречаются заданные слова.
Вкладка "Поиск" (поиск на естественном языке)
  • Предоставляется возможность поиска информации по запросам, составленным на обычном разговорном языке.
  • Результатом поиска является отсортированный список разделов, соответствующих введенному пользователем вопросу.
  • Существует возможность переадресации поиска, т.е. вовлечения в него поисковых машин из Интернета.

Примечание В зависимости от версии языка продукта, на вкладке "Поиск" предоставляется либо традиционная функция поиска Microsoft, выполняющая поиск ключевых слов и точных фраз, либо функция поиска с использованием естественного языка, выполняющая анализ фраз или вопросов.


Поиск информации в справочной системе - Процедуры

Получение информации
Поиск необходимой информации
Поиск информации в справочной системе
Понятия
Процедуры
Команды

Вызов справочной системы

Использование панели содержания справочной системы


Вызов справочной системы - Процедуры

Получение информации
Поиск необходимой информации
Поиск информации в справочной системе
Понятия
Процедуры
Команды

Вызов справочной системы

  • Выберите "Справка" » "Справка" или нажмите клавишу F1.

    • Для получения доступа к документации для разработчиков выберите "Справка" » "Дополнительные ресурсы" » "Документация для разработчиков".

Примечание Для получения справки по текущей операции можно нажмите F1 во время работы в командной строке или при открытом диалоговом окне.


Использование панели содержания справочной системы - Процедуры

Получение информации
Поиск необходимой информации
Поиск информации в справочной системе
Понятия
Процедуры
Команды

Использование панели содержания справочной системы

  1. Если требуется, нажмите кнопку "Показать" для отображения левой области окна справочной системы. Затем для отображения содержания справочной системы выберите вкладку "Содержание".
  2. Чтобы развернуть список разделов по какой-либо теме, применяется любой из перечисленных ниже способов:
    • Дважды нажмите на значке закрытой книги или рядом с ним на значке "+".
    • Нажмите правую кнопку мыши на панели содержания справки. Выберите "Открыть все".
  3. Чтобы свернуть список разделов, можно применить любой из перечисленных ниже способов:
    • Дважды нажмите на значке открытой книги или рядом с ним на значке "-".
    • Нажмите правую кнопку мыши на панели содержания справки. Выберите "Закрыть все".
  4. Чтобы просмотреть раздел, можно применить любой из перечисленных ниже способов:
    • В содержании справочной системы нажмите на имени раздела.
    • Внутри раздела нажмите на любой подчеркнутый текст синего цвета.


Поиск информации в справочной системе - Команды

Поиск необходимой информации
Поиск необходимой информации
Поиск информации в справочной системе
Понятия
Процедуры
Команды

Команды
СПРАВКА | Вызов справочной системы
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Средства поиска - Понятия

Получение информации
Поиск необходимой информации
Средства поиска
Понятия
Процедуры
Команды

Для поиска тем, относящихся к введённому слову или фразе, используется вкладка "Поиск".

В зависимости от версии языка продукта, на вкладке "Поиск" предоставляется либо традиционная функция поиска Microsoft, выполняющая поиск ключевых слов и точных фраз, либо функция поиска с использованием естественного языка, выполняющая анализ фраз или вопросов.

Вариант используемой продуктом версии определяется по цвету фона и типу подсказки.

  • Для поиска на естественном языке используется синий цвет фона и предложение ввести вопрос.
  • В традиционной функции поиска Microsoft используется серый цвет фона и предложение ввести одно или несколько слов.
Вкладка поиска на естественном языке

Эта вкладка предоставляет возможность поиска информации по запросам, составленным на естественном языке.

Запрос на естественном языке вводится в форме вопроса, слова или фразы. Например, можно ввести: Как создать лист?

Если среди нескольких первых тем нет нужной информации, попытаться переформулировать свой вопрос. Запрос на обычном языке можно переадресовать в Интернет.

Вкладка традиционной функции поиска Microsoft

Для простого поиска существуют следующие правила:

  • Запрос на поиск можно вводить как в нижнем, так и в верхнем регистре; поиск производится без учета регистра.
  • Можно использовать любую комбинацию из букв (a-z) и цифр (0-9).
  • Не следует использовать знаки препинания, такие как точка, двоеточие, точка с запятой, запятая, дефис и одинарные кавычки; они игнорируются при поиске.
  • Чтобы поиск проводился по отдельным словам, а не по целой фразе, каждое слово следует заключить в двойные кавычки или скобки.

Примечание При использовании вкладки "Поиск" отображается список всех разделов, в которых встречается введенный текст. Это относится не только к тексту внутри раздела, но и к тексту в названиях разделов.

Для расширенного поиска можно использовать логические операторы и символы-шаблоны. При этом область поиска можно сужать, ограничивая её результатами предыдущего поиска, похожими словами или только заголовками разделов. Если в искомом тексте несколько слов, и требуется найти их вхождения именно в таком порядке, текст необходимо заключить в двойные кавычки. Например, для поиска разделов, в которых содержится фраза "задающий единицы измерения", следует ввести данные слова именно в этом порядке. Если вокруг этого текста не поставить кавычек, отыскиваются все разделы, в которых встречается любое из перечисленных слов, т.е. все разделы, содержащие "задающий", все разделы, содержащие "единицы" и все разделы, содержащие "измерения".

Более точно условия поиска можно задать с помощью логических операторов И, ИЛИ, НЕ и БЛИ. Правила и примеры использования операторов приведены в таблице. Если оператор не задан, подразумевается И. Например, запрос "отступ границы печать" эквивалентен запросу "отступ И границы И печать".

Что искать | Пример | Результат
Оба термина в одном разделе | "просмотр структуры" И "палитра" | Разделы, в которых встречаются как слова "просмотр структуры", так и "палитра".
Любой из терминов в разделе | "растровый" ИЛИ "векторный" | Разделы, в которых встречается хотя бы одно (или оба) из слов "растровый" и "векторный".
Первый термин без второго | "ole" НЕ "dde" | Разделы, содержащие слово "OLE", но не содержащие слова "DDE".
Оба термина в одном разделе, один вблизи другого | "пользовательское" БЛИ "ядро" | Разделы, в которых слова "пользовательское" и "ядро" отстоят друг от друга не более чем на 8 слов.

Примечание Символы |, & и ! не являются логическими операторами. Необходимо использовать И, ИЛИ либо НЕ.


Средства поиска - Процедуры

Получение информации
Поиск необходимой информации
Средства поиска
Понятия
Процедуры
Команды

Поиск информации в справочной системе (поиск на естественном языке)

Перенаправление запросов в Интернет (поиск на естественном языке)

Поиск информации в справочной системе (функция поиска Microsoft )


Поиск информации в справочной системе (поиск на естественном языке) - Процедуры

Получение информации
Поиск необходимой информации
Средства поиска
Понятия
Процедуры
Команды

Поиск информации в справочной системе (поиск на естественном языке)

  1. На вкладке "Поиск" ввести вопрос, на который нужно получить ответ. Вместо вопроса можно ввести фразу или отдельное слово.
  2. Чтобы ограничить область поиска, выберите конкретный документ или совокупность документов из списка "Список компонентов для поиска".
  3. Нажмите на имени раздела, который предполагается просмотреть.

Примечание С советами по грамотному составлению запросов можно ознакомиться, нажав кнопку мыши на ссылке "Советы по составлению запросов" вкладки "Поиск".


Перенаправление запросов в Интернет (поиск на естественном языке) - Процедуры

Получение информации
Поиск необходимой информации
Средства поиска
Понятия
Процедуры
Команды

Перенаправление запросов в Интернет (поиск на естественном языке)

  1. Если в результатах запроса на естественном языке нет требуемой информации, прокрутить до конца список соответствующих разделов, найденных по запросу.
  2. Нажмите на ссылке "Поиск в Интернете" в нижней части списка.

На экране отображаются результаты поиска в Интернете.

Примечание С советами по грамотному составлению запросов можно ознакомиться, нажав кнопку мыши на ссылке "Советы по составлению запросов" вкладки "Поиск".


Поиск информации в справочной системе (функция поиска Microsoft ) - Процедуры

Получение информации
Поиск необходимой информации
Средства поиска
Понятия
Процедуры
Команды

Поиск информации в справочной системе (функция поиска Microsoft )

  1. Выберите вкладку "Поиск". Ввести искомое слово или фразу.
  2. (Не обязательно) Уточнить поисковый запрос с помощью логических операторов:
    • Нажмите [image], чтобы добавить логические операторы в поисковый запрос.
    • Введите слово или фразу, которые должны следовать после логического оператора.
  3. (Не обязательно) Детализируйте поиск, установив флажки внизу вкладки "Поиск":
    • Искать в результатах предыдущего поиска.Уточняет поиск, применяя новые критерии поиска к результатам предыдущего поиска.
    • Похожие слова. Границы поиска расширяются: поиск производится также по схожим с критериями поиска словам, не ограничиваясь точными совпадениями.
    • Искать только заголовки. Поиск производится только в заголовках разделов, а их содержимое не просматривается.
  4. Нажмите "Список разделов" и выберите нужный раздел. Нажмите кнопку "Показать".
  5. Для сортировки результатов по названию, расположению и значимости нажмите соответственно на заголовке столбца "Название", "Местонахождение" или "Ранг".

Примечание Чтобы ознакомиться только с процедурами, нажмите заголовок столбца "Название" и прокрутить список вниз до элементов, начинающихся со слова “Для.”


Средства поиска - Команды

Поиск необходимой информации
Поиск необходимой информации
Средства поиска
Понятия
Процедуры
Команды

Команды
СПРАВКА | Вызов справочной системы
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Организация разделов справочной системы - Понятия

Получение информации
Поиск необходимой информации
Организация разделов справочной системы
Понятия
Процедуры
Команды

В большинстве разделов справки в верхней части правой панели окна справки есть три вкладки. На вкладках отображаются различные виды информации.

На вкладках отображаются различные виды информации.

  • Вкладка "Понятия". Содержит описание элемента или функции. Если выберите вкладку "Понятия", в левой панели окна справки откроется список разделов, а текущий раздел будет выделен. На вкладке "Содержание" отображается структура справочной системы по данному разделу. Нажав кнопку мыши на соседних с выбранным разделах, можно отобразить их структуру.
  • Вкладка "Процедуры". Содержит пошаговые инструкции для выполнения стандартных процедур, относящихся к текущему разделу. После вывода на экран процедуры очередное нажатие кнопки мыши на вкладке "Процедуры" отображает текущий список процедур.
  • Вкладка "Команды". Содержит список команд и системных переменных, относящихся к данному разделу, со ссылками на подробное описание команд. Если нажмите на запись на вкладке "Команды", Справочник команд откроется на выбранной команде или переменной.

При смене вкладки не происходит перехода к другому разделу; Изменяется только тип отображаемой информации—понятия, процедуры или ссылки на команды—.

Структура вкладки "Понятия"

На вкладке "Понятия" отображаются два типа информации: навигационный текст и конечный текст. Навигационный текст представляет собой ссылки с краткими описаниями. Навигационный текст помогает выполнить пошаговый переход к необходимой информации. Ссылки на навигационных страницах ведут к более глубоко расположенным навигационным страницам справочной системы до тех пор, пока не будет достигнута искомая страница. В каждой последующей ссылке содержится более подробная информация.

Структура вкладок "Процедуры" и "Команды"

При переходе на каждый следующий уровень справки на вкладке "Содержание" информация на вкладках "Процедуры" и "Команды", соответствующая запросу, становится более конкретной, а количество отображаемых записей уменьшается.


Смена типа отображаемой справочной информации - Процедуры

Получение информации
Поиск необходимой информации
Организация разделов справочной системы
Понятия
Процедуры
Команды

Смена типа отображаемой справочной информации

  • Для изменения типа отображаемой информации на правой панели окна справки следует выберите вкладку "Понятия", "Процедуры" или "Команды".


Организация разделов справочной системы - Команды

Поиск необходимой информации
Поиск необходимой информации
Организация разделов справочной системы
Понятия
Процедуры
Команды

Команды
СПРАВКА | Вызов справочной системы
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование стрелки вверх для перемещения по разделам справочной системы - Понятия

Получение информации
Поиск необходимой информации
Использование стрелки вверх для перемещения по разделам справочной системы
Понятия
Процедуры
Команды

В правом верхнем углу раздела может отображаться символ стрелки вверх.

Следует нажмите на эту стрелку, чтобы перейти из текущего раздела на уровень выше, содержащий более широкий круг информации.


Эффективное использование справочной системы

Получение информации
Поиск необходимой информации
Эффективное использование справочной системы
Понятия
Процедуры
Команды

Нет процедур.


Использование стрелки вверх для перемещения по разделам справочной системы - Команды

Поиск необходимой информации
Поиск необходимой информации
Использование стрелки вверх для перемещения по разделам справочной системы
Понятия
Процедуры
Команды

Команды
СПРАВКА | Вызов справочной системы
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Печать разделов справочной системы - Понятия

Получение информации
Поиск необходимой информации
Печать разделов справочной системы
Понятия
Процедуры
Команды

Самый простой способ печати текущего раздела - нажмите на нем правую кнопку мыши и выберите "Печать".

Кнопка "Печать" на панели инструментов предоставляет следующие возможности:

  • Печать выбранного раздела (рекомендуется).
  • Печать выбранного раздела и всех вложенных разделов.

Примечание Если текущий раздел имеет много вложенных, выбор второго варианта может привести к печати большого числа страниц.


Печать разделов справочной системы - Процедуры

Получение информации
Поиск необходимой информации
Печать разделов справочной системы
Понятия
Процедуры
Команды

Печать раздела справочной системы

Печать выбранного раздела и всех вложенных разделов


Печать раздела справочной системы - Процедуры

Получение информации
Поиск необходимой информации
Печать разделов справочной системы
Понятия
Процедуры
Команды

Печать раздела справочной системы

  1. Выведите раздел, который нужно напечатать.
  2. Нажмите правую кнопку мыши на панели раздела. выберите "Печать".
  3. Нажмите кнопку "Печать" в диалоговом окне вывода на печать.


Печать выбранного раздела и всех вложенных разделов - Процедуры

Получение информации
Поиск необходимой информации
Печать разделов справочной системы
Понятия
Процедуры
Команды

Печать выбранного раздела и всех вложенных разделов

  1. Выведите раздел, который нужно напечатать, и убедитесь, что вкладка "Содержание" активна.
  2. На панели инструментов окна справочной системы нажмите кнопку "Печать".
  3. В диалоговом окне "Печать разделов" выберите "Печать выбранного раздела и всех подразделов".
  4. Нажмите "OK".


Печать разделов справочной системы - Команды

Поиск необходимой информации
Поиск необходимой информации
Печать разделов справочной системы
Понятия
Процедуры
Команды

Команды
СПРАВКА | Вызов справочной системы
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Показ и скрытие панели содержания - Понятия

Получение информации
Поиск необходимой информации
Показ и скрытие панели содержания
Понятия
Процедуры
Команды

Кнопкой "Скрыть" на панели инструментов справочной системы окно справки уменьшается до компактных размеров за счёт исчезновения панели, содержащей вкладки "Содержание", "Указатель" и "Поиск".

Такой размер окна предпочтителен для отображения процедур во время работы.

Кнопкой "Показать" окно справки увеличивается для отображения панели, содержащей вкладки "Содержание", "Указатель" и "Поиск". Такой размер окна предпочтителен при поиске информации.


Показ и скрытие панели содержания - Команды

Поиск необходимой информации
Поиск необходимой информации
Показ и скрытие панели содержания
Понятия
Процедуры
Команды

Команды
СПРАВКА | Вызов справочной системы
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Получение дополнительной информации - Понятия

Получение информации
Поиск необходимой информации
Получение дополнительной информации
Понятия
Процедуры
Команды

Существует ряд дополнительных способов получения справочной информации.

  • Нажать клавишу F1 в процессе выполнения команды, работы с системной переменной или в диалоговом окне. Отображается полная информация из Справочника команд.
  • Нажать имеющуюся во многих диалоговых окнах кнопку с вопросительным знаком. Отображается описание выбранного параметра диалогового окна.
  • Получить информацию из раздела "Дополнительные сведения" справки (Readme). Отображаются последние сведения об этом продукте.
  • Отобразить "Быструю справку" на информационной палитре.Отображаются процедуры, соответствующие текущей команде на небольшой по размеру палитре.

Информацию о продуктах Autodesk и помощь при работе с данной программой можно получить с помощью других ресурсов.

  • Веб-сайт компании Autodesk. См. http://www.autodesk.com.
  • Местная служба поддержки.Обратитесь к дилеру или в региональный офис Autodesk.


Получение дополнительной информации - Команды

Поиск необходимой информации
Поиск необходимой информации
Получение дополнительной информации
Понятия
Процедуры
Команды

Команды
СПРАВКА | Вызов справочной системы
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование "Быстрой справки" на информационной палитре - Понятия

Получение информации
Поиск необходимой информации
Использование "Быстрой справки" на информационной палитре
Понятия
Процедуры
Команды

"Быстрая справка" располагается на "Информационной палитре" и является удобным средством получения информации из справочной системы. С помощью "Быстрой справки" можно отобразить процедуры на компактной палитре, занимающей немного места в области рисования.

При выполнении любой команды "Быстрая справка" отображает список процедур, соответствующих текущей команде. С помощью "Быстрой справки" можно выберать процедуру для отображения на информационной палитре, имеющей небольшие размеры и занимающей немного места в области рисования.

Этой информации часто бывает достаточно для начала работы с незнакомыми или редко используемыми командами.

Обычно информация "Быстрой справки", отображаемая на информационной палитре, обновляется при запуске новых команд. Однако при необходимости зафиксировать отображаемую информацию информационную палитру можно заблокировать.


Использование "Быстрой справки" на информационной палитре - Процедуры

Получение информации
Поиск необходимой информации
Использование "Быстрой справки" на информационной палитре
Понятия
Процедуры
Команды

Вывод "Быстрой справки"

Перемещение по разделам "Быстрой справки"

Печать "Быстрой справки"

Фиксирование раздела "Быстрой справки"


Вывод "Быстрой справки" - Процедуры

Получение информации
Поиск необходимой информации
Использование "Быстрой справки" на информационной палитре
Понятия
Процедуры
Команды

Вывод "Быстрой справки"

  • Выберите меню "Справка" » "Информационная палитра".

    • Ввод команды: ПОМОЩНИК


Перемещение по разделам "Быстрой справки" - Процедуры

Получение информации
Поиск необходимой информации
Использование "Быстрой справки" на информационной палитре
Понятия
Процедуры
Команды

Перемещение по разделам "Быстрой справки"

  1. Нажмите правую кнопку мыши в пределах информационной палитры.
  2. Для перемещения по разделам нажмите "Домашняя", "Назад" или "Вперед", так же, как в обозревателе Интернета.

Ввод команды: ПОМОЩНИК


Печать "Быстрой справки" - Процедуры

Получение информации
Поиск необходимой информации
Использование "Быстрой справки" на информационной палитре
Понятия
Процедуры
Команды

Печать "Быстрой справки"

  1. Выведите на экран информацию "Быстрой справки" для распечатки.
  2. Нажмите правую кнопку мыши в пределах информационной палитры. Нажмите кнопку "Печать".
  3. Нажмите "OK" в диалоговом окне вывода на печать.


Фиксирование раздела "Быстрой справки" - Процедуры

Получение информации
Поиск необходимой информации
Использование "Быстрой справки" на информационной палитре
Понятия
Процедуры
Команды

Фиксирование раздела "Быстрой справки"

  1. Выведите на экран нужную информацию "Быстрой справки".
  2. Нажмите правую кнопку мыши в пределах информационной палитры. Нажмите кнопку "Блокировать".

    3. Отображаемая информация "Быстрой справки" остаётся в текущем месте до тех пор, пока пользователь не разблокирует её.

    Ввод команды: ПОМОЩНИК


Использование "Быстрой справки" на информационной палитре - Команды

Поиск необходимой информации
Поиск необходимой информации
Использование "Быстрой справки" на информационной палитре
Понятия
Процедуры
Команды

Команды
ПОМОЩНИК | Открывает в информационной палитре "Быструю справку", которая отображает контекстную информацию
ПОМОЩНИКЗАКР | Закрывает "Быструю справку" в информационной палитре
Системные переменные
ASSISTSTATE | Указывает состояние активности информационной палитры, отображающей краткую справку.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обучение работе с программой - Понятия

Получение информации
Поиск необходимой информации
Обучение работе с программой
Понятия
Процедуры
Команды

Обучающие программы и продукты от Autodesk помогают пользователям осваивать ключевые технические характеристики и повышать производительность. Для получения последних сведений об обучающих программах Autodesk training посетите веб-сайт http://www.autodesk.com/training-rus или обратитесь в местный офис Autodesk.

Авторизованные учебные центры Autodesk

Сеть учебных центров Autodesk® Authorized Training Center (ATC®) предоставляет авторизованный курс обучения с инструктором для профессиональных конструкторов, использующих программное обеспечение Autodesk. В авторизованных учебных центрах Autodesk преподают опытные и знающие специалисты. Во всем мире насчитывается более 1200 Авторизованных учебных центров для организации профильного локального обучения.

Для получения сведений о ближайшем учебном центре обратитесь в местный офис Autodesk или посетите веб-сайт http://www.autodesk.com/atc.

Официальные учебные материалы Autodesk

Официальные учебные материалы Autodesk (Autodesk Official Training Courseware; AOTC) являются пособием по техническому обучению, разработанным в Autodesk. Пособие AOTC, ориентированное на обучение длительностью от 1/2 до 5 дней в классе под руководством преподавателя и применяемое авторизованными центрами обучения и другими партнерами Autodesk, хорошо адаптируется к нужным темпам индивидуального обучения. В пособиях излагаются ключевые понятия и функциональные возможности программного обеспечения на практических примерах пошаговой работы в реальном окружении. Официальные учебные материалы (AOTC) можно приобрести у местного торгового посредника или дистрибьютора или заказать в Интернет-магазине Autodesk по адресу http://www.autodesk.com/aotc .

Обучение через Интернет (e-Learning)

Обучение через Интернет для пользователей службы подписки на Autodesk организовано в виде интерактивных уроков, приводимых в каталогах на продукты. В течение каждого урока продолжительностью от 20 до 40 минут пользователь выполняет практические упражнения на программном продукте или в режиме эмулирования. Интерактивный оценочный инструмент позволяет пользователю выявлять пробелы в его подготовке, определять наиболее насущные для него упражнения и оценивать свои успехи.

Если пользователь является подписчиком Autodesk, то с помощью используемого продукта Autodesk можно получить доступ к электронным учебникам e-Learning и другим услугам, предоставляемым по подписке. Дополнительную информацию о получении доступа к электронным учебникам e-Learning в программе см. в разделе Доступ к Центру подписки. Информацию о том, как стать подписчиком Autodesk, см. по адресу http://www.autodesk.com/subscriptionrus.

Autodesk Developer Network

Программа Autodesk Developer (ADN) для подписчиков ADN является средством поддержки профессиональных разработчиков, специализирующихся на создании программного обеспечения на основе продуктов Autodesk. Подписчику ADN предоставляются деловые инструменты, программы, поддержка и обучение, необходимые для решения его задач. Разработчики могут посетить веб-сайт http://www.autodesk.com/adn.

Autodesk Consulting

Autodesk Consulting предоставляет услуги по организации процессов обучения, включая обучение по критическим предметам, способствующее повышению производительности с целью получения прибыли за счет ценности выпускаемых изделий. Дополнительную информацию по вопросам общего консультирования, системной интеграции или услуг по обучению можно найти на веб-сайте http://www.autodesk.com/consulting.

Услуги и программные продукты партнёров

Autodesk работает по всему миру совместно с тысячами партнёров, выпускающими программные продукты. Партнёрские компании предоставляют профессиональным конструкторам программы и услуги, расширяющие возможности программного обеспечения Autodesk. На веб-сайте "Услуги и программные продукты партнёров" по адресу http://www.autodesk.com/partnerproducts можно найти список доступных ресурсов по программам Autodesk и различным отраслям.


Обучение работе с программой - Команды

Поиск необходимой информации
Поиск необходимой информации
Обучение работе с программой
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Доступ к Центру подписки - Понятия

Получение информации
Поиск необходимой информации
Доступ к Центру подписки
Понятия
Процедуры
Команды

Подписчики могут обращаться в Центр подписки непосредственно из программы. Если пользователь является подписчиком Autodesk, получить доступ к услугам, предоставляемым по подписке, можно, выбрав раздел справки "Ресурсы по подписке". Информацию о том, как стать подписчиком Autodesk, см. по адресу http://www.autodesk.com/subscription-rus.

  • Центр подписки
  • Объединение с системой Vault


Доступ к Центру подписки - Процедуры

Получение информации
Поиск необходимой информации
Доступ к Центру подписки
Понятия
Процедуры
Команды

Вызов "Центра подписки" из программы

Установка "Центра подписки" (компонент утилиты "Диспетчер Интернет-компонентов")


Доступ к Центру подписки - Команды

Получение информации
Поиск необходимой информации
Доступ к Центру подписки
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Центр подписки - Понятия

Получение информации
Поиск необходимой информации
Центр подписки
Понятия
Процедуры
Команды

Программа подписки Autodesk обеспечивает доступ к последним версиям программных продуктов, программам-расширениям, технической поддержке для оформивших подписку и электронному обучению (e-Learning). Услуги по подписке предоставляются только подписчикам.

Через меню "Cправка" подписчики могут получить доступ к следующим ресурсам:

  • Каталог электронных учебников e-Learning по подписке. Интерактивные уроки по функциональным возможностям программ, организованные в каталоги, соответствующие конкретным программам. Продолжительность каждого урока от 15 до 30 минут; в урок включены практические упражнения, которые можно выполнять, используя эмуляцию приложения. С помощью интерактивного средства оценки результатов пользователь может выявить пробелы в своей подготовке, определить, какие ему необходимы упражнения и оценить свои успехи.
  • Создать запрос о поддержке. Обеспечивается прямое общение со специалистами технической поддержки Autodesk. Пользователь быстро получает исчерпывающие ответы на вопросы по установке, настройке и устранению неполадок программы.
  • Просмотр запросов о поддержке. Обеспечивается возможность отслеживания и управления вопросами и ответами с помощью современной системы поддержки Autodesk.
  • Изменение профиля центра подписки. Предоставляется возможность создавать учетную запись подписки и управлять ею.
Ресурсы по подписке и конфиденциальная информация

По подписке через Интернет можно получить интерактивные компоненты продукта. Каждый раз при обращении к ресурсам по подписке (например электронным учебникам или службе технической поддержки) из меню "Cправка" программы Autodesk информация о программе (серийный номер, версия, язык и идентификационный номер договора подписки) отправляется в Autodesk для проверки, обслуживается ли данная программа по подписке.

Autodesk ведет статистику информации, отправляемой при обращении к ресурсам по подписке для контроля их использования и определения направления их усовершенствования. Autodesk использует информацию, предоставленную пользователем или полученную от него, в соответствии с политикой конфиденциальности Autodesk, с которой можно ознакомиться на веб-сайте http://www.autodesk.com/privacy-rus

Включение ресурсов по подписке

Для включения и отключения ресурсов по подписке в меню "Справка" можно использовать утилиту "Диспетчер Интернет-компонентов". Подробнее об установке утилиты см. в "Установка "Центра подписки" (компонент утилиты "Диспетчер Интернет-компонентов")". Дополнительную информацию об использовании программы после её установки можно получить, выбрав "Справка" в окне утилиты "Диспетчер Интернет-компонентов".


Центр подписки - Процедуры

Получение информации
Поиск необходимой информации
Центр подписки
Понятия
Процедуры
Команды

Вызов "Центра подписки" из программы

Установка "Центра подписки" (компонент утилиты "Диспетчер Интернет-компонентов")


Вызов "Центра подписки" из программы - Процедуры

Получение информации
Поиск необходимой информации
Центр подписки
Понятия
Процедуры
Команды

Вызов "Центра подписки" из программы

  • Выберите "Справка", затем выберите требуемый ресурс, предоставляемый по подписке.

Примечание Не все пользователи программы могут обращаться в "Центр подписки". Если ресурсы по подписке недоступны в меню "Справка" используемой программы, это означает, что данная программа не обслуживается по подписке.


Установка "Центра подписки" (компонент утилиты "Диспетчер Интернет-компонентов") - Процедуры

Получение информации
Поиск необходимой информации
Центр подписки
Понятия
Процедуры
Команды

Установка "Центра подписки" (компонент утилиты "Диспетчер Интернет-компонентов")

  1. Нажмите кнопку мыши два раза на файле setup.exe на компакт-диске продукта.
  2. В обозревателе диска на вкладке "Установка" выберите либо пункт "Автономная установка на несколько пользователей", либо пункт "Сетевое развертывание".
  3. В разделе "Установка дополнительных средств" выберите "Autodesk CAD Manager Tools 4.0".
  4. На открывшейся странице "Autodesk CAD Manager Tools 4.0" нажмите кнопку "Установка".

    5. После установки утилиты "Диспетчер Интернет-компонентов" его можно вызывать через меню "Пуск" Windows.


Центр подписки - Команды

Поиск необходимой информации
Поиск необходимой информации
Центр подписки
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Объединение с системой Vault - Понятия

Получение информации
Поиск необходимой информации
Объединение с системой Vault
Понятия
Процедуры
Команды

Для пользователя службы подписки утилита управления файлами Autodesk Vault является хранилищем, в котором можно хранить документы и файлы и управлять ими. Система Vault предоставляет мощные средства управления файлами и отслеживания их изменений. Поддерживается архив копий главных файлов, что облегчает возврат к более ранним версиям файлов. Предусмотрена возможность выборки файлов для внесения изменений и последующего возврата их в архив. Главная копия недоступна для непосредственного редактирования. Во время процедуры возврата файла его можно снабдить комментариями, относящимися к внесённым изменениям, для информирования других пользователей о выполненных изменениях. Это обеспечивает возможность быстро ознакомиться с этапами разработки проекта и его журналом.

Autodesk Vault содержит два необходимых компонента: сервер Vault Data Management и клиент Vault. Дополнительно можно установить Vault Office Add-in.

За информацией об использовании системы Vault обратитесь к справочной системе Vault.

Примечание Возможна загрузка омновных компонентов для Autodesk Vault из узла Autodesk Subscription.

Сервер Vault Data Management

На сервере Vault Data Management хранятся главные копии всех пользовательских документов и проектов. Благодаря централизованному хранению всех данных в одном месте группа пользователей получает удобную возможность совместного использования информации и управления ею.

Клиент Vault

В клиентское ПО Vault входит средство Autodesk Vault Explorer. Vault Explorer является автономным приложением, предоставляющим инструменты для доступа к данным, хранящимся в сервере Autodesk Data Management. Работая в программе AutoCAD, можно войти в систему Vault, открыть в ней файлы, вставить их и выйти из Vault. Предусмотрена также возможность доступа к Vault с помощью Vault Explorer. С помощью Vault Explorer можно выполнять следующие действия:

  • Управлять системой Vault.
  • Управлять учётными записями пользователей Vault.
  • Задавать рабочие папки.
  • Создавать папки в системе Vault.
  • Добавлять, извлекать и возвращать файлы (включая файлы, отличные от файлов Inventor и DWG; исключением являются файлы AutoCAD Electrical)
  • Перемещать файлы в системе Vault.
  • Переименовывать файлы в системе Vault.
  • Просматривать журнал учёта изменений в проекте.
  • Создавать объединения файлов в рамках системы Vault, связывая два или более файлов.
  • Выбирать самую последнюю версию файла.
  • Упаковывать файлы с помощью команд "Упаковать" и "Выполн".
Vault Office Add-in (возможное дополнение)

Дополнительный компонент обеспечивает доступ из системы Vault в продукты пакета программ Microsoft® Office (Word, Excel). Доступ из системы Vault в программы Microsoft Office осуществляется аналогично доступу из AutoCAD. Для использования этого компонента необходимо произвести установку клиента Vault.


Доступ к Центру подписки

Получение информации
Поиск необходимой информации
Доступ к Центру подписки
Понятия
Процедуры
Команды

Нет процедур.


Объединение с системой Vault - Команды

Поиск необходимой информации
Поиск необходимой информации
Объединение с системой Vault
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Получение новостей и обновлений программы - Понятия

Получение информации
Поиск необходимой информации
Получение новостей и обновлений программы
Понятия
Процедуры
Команды

Коммуникационный центр обеспечивает доступ с экрана компьютера к последним сведениям о программном продукте, обновлениям программ, новостям службы технической поддержки и т.д. Тип и регулярность получения информации могут регулироваться в зависимости от требований пользователя.

  • Коммуникационный центр
  • Настройка параметров получения обновлений и уведомлений
    После установки программы Autodesk необходимо настроить "Коммуникационный центр" для задания типа получаемой из Интернета информации.
  • Получение уведомлений о наличии новой информации
    При появлении новой информации "Коммуникационный центр" выводит уведомление над строкой состояния.


Получение новостей и обновлений программы - Процедуры

Получение информации
Поиск необходимой информации
Получение новостей и обновлений программы
Понятия
Процедуры
Команды

Установка сервисной программы Коммуникационный центр (часть программы "Диспетчер Интернет-компонентов")

Настройка параметров "Коммуникационного центра"

Открытие окна "Коммуникационный центр"


Получение новостей и обновлений программы - Команды

Получение информации
Поиск необходимой информации
Получение новостей и обновлений программы
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Коммуникационный центр - Понятия

Получение информации
Поиск необходимой информации
Коммуникационный центр
Понятия
Процедуры
Команды

С помощью Коммуникационного центра можно получать следующую информацию:

  • Вставки техобслуживания для обновлений по сети Получение автоматических уведомлений о новых вставках техобслуживания, выпускаемых Autodesk.
  • Информация о подписке и объявления о выходе расширенных версий. Уведомления и новости о программах по подписке, если вы являетесь подписчиком Autodesk (доступно только в странах и регионах, где предоставляется подписка).
  • Статьи и советы. Уведомления о появлении свежих статей и советов на веб-сайте Autodesk.
  • Информация о поддержке программы. Последние новости от службы технической поддержки Autodesk.

При первом запуске "Коммуникационный центр" для страны/региона пользователя настраивается с помощью Мастера. При этом можно выберите регулярность получения обновлений и каналы информации.

Для открытия Коммуникационного центра нужно нажмите кнопку мыши на его значке, который расположен в области уведомлений в правой части строки состояния.

Политика конфиденциальности в Коммуникационном центре

Для получения последней информации Коммуникационный центр должен быть подключен к Интернету. При подключении к Интернету Коммуникационный центр посылает данные в компанию Autodesk, для того чтобы получаемая в ответ информация была более конкретной. При этом частные права владельца экземпляра программного продукта не нарушаются, так как обмен информацией происходит анонимно.

В Autodesk отправляются следующие сведения:

  • Название программы. Название программы, частью которой является Коммуникационный центр.
  • Номер версии программы. Номер версии устанавливаемого продукта
  • Язык пользовательского интерфейса. Код языка пользовательского интерфейса установленной программы.
  • Страна/Регион. Страна или регион, выбранные при настройке Коммуникационного центра.
  • Номер договора подписки. Эта информация отправляется в Autodesk, если она была введена в диалоговом окне "Отчет об ошибке".

Autodesk ведет статистику информации, передаваемой Коммуникационным центром для контроля его использования и определения направлений его усовершенствования. Autodesk использует информацию, предоставленную пользователем или полученную от него, в соответствии с политикой конфиденциальности Autodesk, с которой можно ознакомиться на веб-сайте http://www.autodesk.com/privacy-rus.

Включение и отключение Коммуникационного центра

Коммуникационный центр включается и отключается с помощью утилиты "Диспетчер Интернет-компонентов". Например, в случае отсутствия необходимости посылать информацию в Autodesk Коммуникационный центр рекомендуется отключить. Для получения информации о том, как использовать утилиту "Диспетчер Интернет-компонентов", необходимо установить его, а затем выбрать в его окне пункт "Справка".


Установка сервисной программы Коммуникационный центр (часть программы "Диспетчер Интернет-компонентов") - Процедуры

Получение информации
Поиск необходимой информации
Коммуникационный центр
Понятия
Процедуры
Команды

Установка сервисной программы Коммуникационный центр (часть программы "Диспетчер Интернет-компонентов")

  1. Нажмите два раза кнопку мыши на файле setup.exe на компакт-диске программы.
  2. В обозревателе диска на вкладке "Установка" выберите либо пункт "Автономная установка на несколько пользователей", либо пункт "Сетевое развертывание".
  3. В разделе "Установка дополнительных средств" выберите "Autodesk CAD Manager Tools 4.0".
  4. На открывшейся странице "Autodesk CAD Manager Tools 4.0" нажмите кнопку "Установка".

    5. После установки утилиты "Диспетчер Интернет-компонентов" её можно вызывать через меню "Пуск" (Windows).


Коммуникационный центр - Команды

Поиск необходимой информации
Поиск необходимой информации
Коммуникационный центр
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Настройка параметров получения обновлений и уведомлений - Понятия

Получение информации
Поиск необходимой информации
Настройка параметров получения обновлений и уведомлений
Понятия
Процедуры
Команды

После установки программы Autodesk необходимо настроить "Коммуникационный центр" для задания типа получаемой из Интернета информации.

  • Страна/Регион. Страна/регион указывается для того, чтобы "Коммуникационный центр" мог предоставлять данные, предназначенные именно для территории местонахождения пользователя.
  • Проверка обновлений. Задает частоту синхронизации "Коммуникационного центра" с серверами Autodesk.
  • Всплывающие уведомления. Включает всплывающие уведомления Коммуникационного центра, так что при получении нового уведомления они отображаются над строкой состояния. Если всплывающие уведомления отключены при настройке области уведомлений, то сделанная в "Коммуникационном центре" настройка для всплывающих уведомлений игнорируется.
  • Каналы. Указываются данные для отображения в "Коммуникационном центре".


Настройка параметров "Коммуникационного центра" - Процедуры

Получение информации
Поиск необходимой информации
Настройка параметров получения обновлений и уведомлений
Понятия
Процедуры
Команды

Настройка параметров "Коммуникационного центра"

  1. Нажмите кнопку мыши на значке "Коммуникационный центр" в области уведомлений в правой части строки состояния.
  2. В окне "Коммуникационный центр" нажмите кнопку "Настройка".
  3. В диалоговом окне "Параметры" выберите требуемые значения параметров. Нажмите кнопку "Применить".
  4. Нажмите "OK" для выхода из диалогового окна "Параметры". Затем закройте окно "Коммуникационный центр".


Настройка параметров получения обновлений и уведомлений - Команды

Поиск необходимой информации
Поиск необходимой информации
Настройка параметров получения обновлений и уведомлений
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Получение уведомлений о наличии новой информации - Понятия

Получение информации
Поиск необходимой информации
Получение уведомлений о наличии новой информации
Понятия
Процедуры
Команды

При появлении новой информации "Коммуникационный центр" выводит уведомление над строкой состояния.

Для открытия окна "Коммуникационный центр" нажмите на всплывающем сообщении. Если всплывающие уведомления отключены в настройке, о наличии новой информации сигнализирует значок "Коммуникационного центра".

Если в строке состояния не выводится значок "Коммуникационного центра", необходимо связаться с сетевым администратором.


Открытие окна "Коммуникационный центр" - Процедуры

Получение информации
Поиск необходимой информации
Получение уведомлений о наличии новой информации
Понятия
Процедуры
Команды

Открытие окна "Коммуникационный центр"

  • Нажмите кнопку мыши на значке "Коммуникационный центр" в области уведомлений в правой части строки состояния.


Получение уведомлений о наличии новой информации - Команды

Поиск необходимой информации
Поиск необходимой информации
Получение уведомлений о наличии новой информации
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Просмотр файла дополнительных сведений (Readme) - Понятия

Получение информации
Поиск необходимой информации
Просмотр файла дополнительных сведений (Readme)
Понятия
Процедуры
Команды

Последние сведения об этой программе см. в файле Readme.

Рекомендуется прочитать файл Readme для получения обновленных инструкций по установке, сведений о требуемом аппаратном обеспечении и об известных неполадках программы.

  • См. файл Readme


Просмотр файла дополнительных сведений (Readme) - Команды

Поиск необходимой информации
Поиск необходимой информации
Просмотр файла дополнительных сведений (Readme)
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Пользовательский интерфейс

Панели и меню
Для доступа к часто используемым командам, параметрам и режимам предусмотрен набор меню, контекстных меню и панелей инструментов.

Окно команд
Возможно отображение команд, системных переменных и опций, сообщений и подсказок в закрепляемом и изменяемом по размеру окне, именуемом окном команд.

Центр управления DesignCenter
С помощью центра управления DesignCenter осуществляется управление вхождениями блоков, внешними ссылками и другими элементами содержимого чертежей, такими как описания слоёв, листы и текстовые стили.

Настройка рабочей среды
Различные элементы рабочей среды могут быть адаптированы под нужды пользователя.

Инструментальные палитры
Инструментальные палитры представлены отдельными вкладками в окне "Палитры инструментов - все палитры". Они являются эффективным средством упорядочения, распределения и размещения блоков, штриховок и других инструментов. Палитры могут содержать инструменты, предоставленные сторонними разработчиками.


Пользовательский интерфейс - Понятия

Пользовательский интерфейс
Пользовательский интерфейс
Пользовательский интерфейс
Понятия
Процедуры
Команды

Использование раскрывающихся меню, контекстных меню, палитр и панелей инструментов для вызова команд и настройки режимов.

Окно команд предназначено для ввода команд, просмотра значений системных переменных и опций, вывода сообщений и подсказок. Окно команд может быть закреплено в указанном месте; разрешается также изменять его размеры.

С помощью DesignCenter™ можно управлять вхождениями блоков, внешними ссылками и другими компонентами чертежей, например, определениями слоев, листами и текстовыми стилями.

Многие элементы рабочей среды могут быть адаптированы для нужд пользователя.

При работе могут использоваться такие устройства указания, как мышь, дигитайзер или перо, с различным количеством кнопок.


Пользовательский интерфейс - Процедуры

Пользовательский интерфейс
Пользовательский интерфейс
Пользовательский интерфейс
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Пользовательский интерфейс - Команды

Пользовательский интерфейс
Пользовательский интерфейс
Пользовательский интерфейс
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Панели и меню - Понятия

Пользовательский интерфейс
Панели и меню
Понятия
Процедуры
Команды

Для доступа к часто используемым командам, параметрам и режимам предусмотрен набор меню, контекстных меню и панелей инструментов.

  • Панели
    Кнопки панелей используются для выполнения команд, вызова подменю и отображения всплывающих подсказок. Пользователь может выводить на экран и скрывать панели инструментов, закреплять их, изменять размер панелей.
  • Строка меню
    В строке меню можно различными способами открывать выпадающие меню. Предусмотрена возможность создания альтернативных меню.
  • Контекстные меню
    Контекстные меню используются для быстрого доступа к командам, относящимся к текущим операциям.
  • Пульт управления
    Пульт управления представляет собой специальную палитру, на которой отображаются кнопки и элементы управления, связанные с задачно ориентированным рабочим пространством. Пульт управления используется в основном для 3D моделирования, просмотра и тонирования.

См. также

Настройка панелей инструментов

Создание раскрывающихся и контекстных меню


Панели и меню - Процедуры

Пользовательский интерфейс
Панели и меню
Понятия
Процедуры
Команды

Отображение панели

Закрепление панели

Открепление панели

Изменение размеров панели

Закрытие панели

Использование меню

Вызов контекстного меню

Отключение вызова контекстных меню в области построения чертежа

Включение вариативности реакции на нажатие правой кнопки мыши в зависимости от длительности нажатия

Для управления выводом значков и уведомлений в лотке строки состояния

Управление отображением кнопок в строке состояния

Отображение координат в строке состояния

Управление отображением последних введенных команд

Отображение пульта управления

Изменение режима разворачивания/сворачивания пульта управления

Отображение или скрытие управляющей панели

Отображение или скрытие выплывающей панели

Связывание группы инструментальных палитр с управляющей панелью


Панели и меню - Команды

Пользовательский интерфейс
Панели и меню
Понятия
Процедуры
Команды
Команды
ВБУФЕР | Занесение объектов в буфер обмена с удалением их из чертежа
ВСТБУФЕР | Вставка содержимого буфера обмена
КБУФЕР | Копирует объекты или текст из командной строки в буфер обмена
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
ПАН | Перемещение изображения на текущем видовом экране
ПОКАЗАТЬ | Увеличение или уменьшение видимого размера объектов на текущем видовом экране
ПУЛЬТУПР | Открывает окно "Пульт управления"
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
CMDINPUTHISTORYMAX | Установка максимального числа предыдущих значений ввода, которые хранятся в команде для запроса
DASHBOARDSTATE | Указывает состояние окна Пульта управления: активно или нет
INPUTHISTORYMODE | Управляет содержанием и положением отображения последних введенных пользователем команд
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
SHORTCUTMENU | Управляет доступностью контекстных меню (стандартного, режимов редактирования и команд) в области рисования
TOOLTIPS | Управляет отображением подсказок
TRAYICONS | Управляет отображением панели в строке состояния
TRAYNOTIFY | Управляет отображением уведомлений служб в панели строки состояния
TRAYTIMEOUT | Управляет временем (в секундах), в течение которого отображаются уведомления служб
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Панели - Понятия

Пользовательский интерфейс
Панели и меню
Панели
Понятия
Процедуры
Команды

Кнопки панелей используются для выполнения команд, вызова подменю и отображения всплывающих подсказок. Пользователь может выводить на экран и скрывать панели инструментов, закреплять их, изменять размер панелей.

Панели инструментов содержат кнопки, которые служат для запуска команд. Если на кнопку панели навести курсор мыши или другое устройство указания, выводится всплывающая подсказка с именем указанной кнопки. С кнопками, имеющими в своем правом нижнем углу маленький черный треугольник, связаны подменю, содержащие наборы родственных команд. Для вызова подменю необходимо подвести курсор к кнопке панели, связанной с подменю, и удерживать нажатой левую кнопку мыши.

По умолчанию панель "Стандартная" располагается сверху над областью построения чертежа. Эта панель аналогична панелям программ Microsoft® Office. Она содержит такие часто используемые команды AutoCAD®, как СВОЙСТВА, ПАНОРАМИРОВАНИЕ и ПОКАЗАТЬ, а также такие стандартные команды Microsoft Office, как Создать, Открыть и Сохранить.

Отображение, скрытие, закрепление и изменение размеров панелей

В AutoCAD первоначально отображаются несколько панелей, например:

  • Стандартная
  • Стили
  • Слои

Возможно отображение или скрытие этих панелей и дополнительных панелей, и возможно сохранение выбираемых пользователем панелей в качестве рабочего пространства. Существует также возможность создания новых панелей.

Панель инструментов может быть плавающей или закрепленной. Плавающая панель может находиться в любом месте области рисования, её можно перемещать в пределах этой области, изменять её размеры или закреплять её положение. Закреплённые панели примыкают к одному из краев области построения чертежа. Закреплённую панель можно перетаскивать в другие зоны закрепления.

См. также

Создание рабочего пространства для конкретной задачи

Настройка панелей инструментов в документе Руководство по адаптации


Панели - Процедуры

Пользовательский интерфейс
Панели и меню
Панели
Понятия
Процедуры
Команды

Отображение панели

Закрепление панели

Открепление панели

Изменение размеров панели

Закрытие панели


Отображение панели - Процедуры

Пользовательский интерфейс
Панели и меню
Панели
Понятия
Процедуры
Команды

Отображение панели

  • Нажмите правую кнопку мыши на любой панели инструментов и выберите панель в контекстном меню.


Закрепление панели - Процедуры

Пользовательский интерфейс
Панели и меню
Панели
Понятия
Процедуры
Команды

Закрепление панели

  1. Поместите курсор на заголовок панели или в любом свободном от кнопок месте. Нажмите и удерживайте нажатой кнопку устройства указания.
  2. Перетащите панель в одну из зон закрепления вверху, внизу окна или у любого края области рисования.
  3. Когда контур панели появится в зоне закрепления, отпустите кнопку.

    4. Для перемещения панели в область закрепления без выполнения закрепления нужно во время перетаскивания удерживать нажатой клавишу CTRL.


Открепление панели - Процедуры

Пользовательский интерфейс
Панели и меню
Панели
Понятия
Процедуры
Команды

Открепление панели

  1. Поместите курсор на ручку переноса на краю панели, нажмите и удерживайте нажатой кнопку устройства указания.
  2. Перетащите панель из места закрепления, затем отпустите кнопку.


Изменение размеров панели - Процедуры

Пользовательский интерфейс
Панели и меню
Панели
Понятия
Процедуры
Команды

Изменение размеров панели

  1. Поместите курсор на край плавающей панели таким образом, чтобы курсор принял форму горизонтальной или вертикальной двойной стрелки.
  2. Удерживайте нажатой кнопку устройства указания и перемещайте курсор, пока панель не примет требуемые размеры.


Закрытие панели - Процедуры

Пользовательский интерфейс
Панели и меню
Панели
Понятия
Процедуры
Команды

Закрытие панели

  1. Если панель закреплена, то открепите ее.
  2. Нажмите кнопку "Закрыть" в верхнем правом углу панели.


Панели - Команды

Панели и меню
Панели и меню
Панели
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
TOOLTIPS | Управляет отображением подсказок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Строка меню - Понятия

Пользовательский интерфейс
Панели и меню
Строка меню
Понятия
Процедуры
Команды

В строке меню можно различными способами открывать выпадающие меню. Предусмотрена возможность создания альтернативных меню.

Доступ к меню можно получить из строки меню, расположенной наверху в области построения чертежа AutoCAD.

Меню, которые должны отображаться в программе, можно указать в настройках файла НПИ при загрузке его в программу.

См. также

Создание раскрывающихся и контекстных меню в документе Руководство по адаптации


Использование меню - Процедуры

Пользовательский интерфейс
Панели и меню
Строка меню
Понятия
Процедуры
Команды

Использование меню

Действуйте одним из следующих способов:

  • В строке меню выберите имя меню для открытия списка пунктов. В меню либо выберите один из пунктов, либо с помощью значка СТРЕЛКА ВНИЗ переместитесь вниз по списку, затем нажмите клавишу ENTER.
  • Нажмите клавишу ALT и клавишу с буквой, подчёркнутой в имени меню; затем нажмите подчёркнутую букву в имени пункта. Например, для открытия нового чертежа нажмите клавишу ALT и "Ф", чтобы открыть меню "Файл"; затем нажмите "Н" для выбора пункта "Новый".


Строка меню - Команды

Панели и меню
Панели и меню
Строка меню
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Контекстные меню - Понятия

Пользовательский интерфейс
Панели и меню
Контекстные меню
Понятия
Процедуры
Команды

Контекстные меню используются для быстрого доступа к командам, относящимся к текущим операциям.

Контекстные меню вызываются нажатием правой кнопки мыши в различных зонах экрана, таких как:

  • область построения чертежа с выбранными объектами или без них
  • область построения во время выполнения команд
  • текстовое окно и окно команд
  • области и значки центра управления DesignCenter
  • область текстового редактора вхождения, включая текст
  • Панель инструментов или инструментальная палитра
  • Вкладки "Модель" или "Разметка листа"
  • Строка состояния или кнопки строки состояния
  • Некоторые диалоговые окна

Как правило, контекстные меню предлагают следующие действия:

  • повтор последней команды
  • прерывание текущей команды
  • отображение списка последних команд, введенных пользователем
  • вырезание, копирование и вставка из буфера обмена
  • выбор различных вариантов команды
  • вызов диалоговых окон, таких как "Настройка" или "Адаптация"
  • отмена результата действия последней выполненной команды

Существует возможность настройки реакции системы на длительность нажатия правой кнопки мыши, чтобы быстрое нажатие (щелчок) срабатывало так же, как нажатие клавиши ENTER, а более длительное нажатие приводило к отображению контекстного меню.

Контекстные меню можно адаптировать с помощью файла адаптации (НПИ). Оосновной файл НПИ (CUI) именуется по умолчанию acad.cui.

См. также

Создание подменю в документе Руководство по адаптации


Контекстные меню - Процедуры

Пользовательский интерфейс
Панели и меню
Контекстные меню
Понятия
Процедуры
Команды

Вызов контекстного меню

Отключение вызова контекстных меню в области построения чертежа

Включение вариативности реакции на нажатие правой кнопки мыши в зависимости от длительности нажатия

Для управления выводом значков и уведомлений в лотке строки состояния

Управление отображением кнопок в строке состояния

Отображение координат в строке состояния

Управление отображением последних введенных команд


Вызов контекстного меню - Процедуры

Пользовательский интерфейс
Панели и меню
Контекстные меню
Понятия
Процедуры
Команды

Вызов контекстного меню

  1. В ответ на подсказку "Команда" поместите курсор в нужной области экрана.
  2. Нажмите правую кнопку мыши или нажмите эквивалентную кнопку на устройстве указания.

    3. Тип контекстного меню зависит от местонахождения курсора при вызове меню. Если меню вызвано в области построения с выделенными объектами, то в контекстном меню предлагаются функции редактирования. Контекстное меню можно вызвать также при работе в режиме "Панорамирование" или "Зумирование".


Отключение вызова контекстных меню в области построения чертежа - Процедуры

Пользовательский интерфейс
Панели и меню
Контекстные меню
Понятия
Процедуры
Команды

Отключение вызова контекстных меню в области построения чертежа

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" выберите вкладку "Пользовательские". В разделе "Соответствие стандартам Windows" снимите флажок "Контекстные меню в области рисования".
  3. Чтобы по отдельности управлять контекстными меню, такими как "По умолчанию", "Редактирование" и "Команды", установите флажок "Контекстные меню в области рисования". Выберите "Настройка правой кнопки мыши..."
  4. В диалоговом окне "Настройка правой кнопки мыши" в группе "Режим по умолчанию" или группе "Режим редактирования" выберите один из указанных вариантов реакции программы на нажатие правой кнопки мыши в области чертежа в тот момент, когда системой не выполняются никакие команды:
    • Повтор последней команды.Повторяется последняя команда. При выборе этого варианта отключается возможность вызова контекстных меню "По умолчанию" и "Редактирование". Кратковременное нажатие правой кнопки мыши соответствует нажатию клавиши ENTER.
    • Контекстное меню.Включается возможность вызова контекстного меню обычного режима и режима редактирования.
  5. В группе "Командный режим" для задания реакции на нажатие правой кнопки мыши, осуществленного в области построения чертежа, выберите один из следующих вариантов:
    • Ввод. Отключается возможность вызова контекстного меню командного режима. Кратковременное нажатие правой кнопки мыши соответствует нажатию клавиши ENTER.
    • Контекстное меню: всегда доступно.Включается возможность вызова контекстного меню командного режима.
    • Контекстное меню: доступно, если у команды есть параметры. Контекстное меню командного режима вызывается только в том случае, если в текущий момент в командной строке доступны какие-либо параметры. В командной строке параметры команд заключаются в квадратные скобки. Если параметров нет, нажатие правой кнопки мыши соответствует нажатию клавиши ENTER.

    Кроме включения/отключения контекстных меню режима по умолчанию, режима редактирования и командного режима, можно настраивать перечень режимов, доступных в этих меню. Например, в контекстное меню режима редактирования можно добавить функции, которые отображаются только при выборе объектов-окружностей.


Включение вариативности реакции на нажатие правой кнопки мыши в зависимости от длительности нажатия - Процедуры

Пользовательский интерфейс
Панели и меню
Контекстные меню
Понятия
Процедуры
Команды

Включение вариативности реакции на нажатие правой кнопки мыши в зависимости от длительности нажатия

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" выберите вкладку "Пользовательские". В разделе "Соответствие стандартам Windows" нажмите "Настройка правой кнопки мыши...".
  3. В диалоговом окне "Настройка правой кнопки мыши" установите флажок "Учитывать длительность нажатия".

    4. Можно задать продолжительность нажатия, при которой оно считается долгим. По умолчанию действует значение 250 миллисекунд.

  4. Выберите "Принять".
  5. В диалоговом окне "Настройка" нажмите "OK".

Ввод команды: НАСТРОЙКА


Для управления выводом значков и уведомлений в лотке строки состояния - Процедуры

Пользовательский интерфейс
Панели и меню
Контекстные меню
Понятия
Процедуры
Команды

Для управления выводом значков и уведомлений в лотке строки состояния

  1. Нажмите на стрелке, расположенной у правого края строки состояния, затем в контекстном меню выберите пункт "Установки области уведомлений".
  2. В диалоговом окне "Установки области уведомлений" установите или снимите следующие флажки:
    • Показывать значки служб. Подключается отображение области уведомлений в правой части строки состояния и отображение в ней значков служб. Если этот флажок снят, область уведомлений не отображается.
    • Показывать уведомления от служб. Подключается вывод уведомлений, получаемых от служб, например от Коммуникационного центра. Если флажок "Показывать значки служб" снят, данная возможность не доступна.
  3. Если флажок "Показывать уведомления от служб" установлен, следует задать время отображения уведомлений, или выбрать "До явного закрытия".
  4. Нажмите "ОК".

Контекстное меню: Нажмите правую кнопку в незаполненной части строки состояния. Выберите "Установки области уведомлений".

Ввод команды: ЛОТОКНАСТР


Управление отображением кнопок в строке состояния - Процедуры

Пользовательский интерфейс
Панели и меню
Контекстные меню
Понятия
Процедуры
Команды

Управление отображением кнопок в строке состояния

  • Для изменения статуса отображения кнопки нажмите на стрелке на правом краю строки состояния, а затем на имени кнопки.

В строке состояния отображаются элементы, около имен которых стоят галочки в меню.

Контекстное меню: Нажмите правую кнопку мыши в незаполненной части строки состояния. Нажмите на имени кнопки.


Отображение координат в строке состояния - Процедуры

Пользовательский интерфейс
Панели и меню
Контекстные меню
Понятия
Процедуры
Команды

Отображение координат в строке состояния

  • Нажмите на стрелке на правом краю строки состояния и выберите "Координаты курсора".

В строке состояния отображаются элементы, около имен которых стоят галочки в меню.

Контекстное меню: Нажмите правую кнопку мыши в незаполненной части строки состояния. Нажмите "Координаты курсора".


Управление отображением последних введенных команд - Процедуры

Пользовательский интерфейс
Панели и меню
Контекстные меню
Понятия
Процедуры
Команды

Управление отображением последних введенных команд

  1. В командной строке введите inputhistorymode.
  2. Введите сумму из одного или нескольких указанных значений:
    • 0. Последние введенные команды не отображаются.
    • 1. Последние введенные команды отображаются в командной строке; просматривать и выбирать их можно с помощью клавиш СТРЕЛКА ВВЕРХ, СТРЕЛКА ВНИЗ.
    • 2. Последняя введенная текущая команда отображается в контекстном меню.
    • 4. Все последние введенные команды в текущем сеансе отображаются в контекстном меню.
    • 8. Маркеры для последнего ввода местоположений точки отображаются на чертеже.

    По умолчанию используется значение 15.

  3. (Дополнительно) В командной строке введите cmdinputhistorymax.
  4. Введите значение, задающее число уникальных значений, введенных в командной строке, которые система будет запоминать и отображать как последние введенные команды.


Контекстные меню - Команды

Панели и меню
Панели и меню
Контекстные меню
Понятия
Процедуры
Команды

Команды
ВБУФЕР | Занесение объектов в буфер обмена с удалением их из чертежа
ВСТБУФЕР | Вставка содержимого буфера обмена
КБУФЕР | Копирует объекты или текст из командной строки в буфер обмена
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
ПАН | Перемещение изображения на текущем видовом экране
ПОКАЗАТЬ | Увеличение или уменьшение видимого размера объектов на текущем видовом экране
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
CMDINPUTHISTORYMAX | Установка максимального числа предыдущих значений ввода, которые хранятся в команде для запроса
INPUTHISTORYMODE | Управляет содержанием и положением отображения последних введенных пользователем команд
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
SHORTCUTMENU | Управляет доступностью контекстных меню (стандартного, режимов редактирования и команд) в области рисования
TRAYICONS | Управляет отображением панели в строке состояния
TRAYNOTIFY | Управляет отображением уведомлений служб в панели строки состояния
TRAYTIMEOUT | Управляет временем (в секундах), в течение которого отображаются уведомления служб
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Пульт управления - Понятия

Пользовательский интерфейс
Панели и меню
Пульт управления
Понятия
Процедуры
Команды

Пульт управления представляет собой специальную палитру, на которой отображаются кнопки и элементы управления, связанные с задачно ориентированным рабочим пространством. Пульт управления используется в основном для 3D моделирования, просмотра и тонирования.

Обзор

На пульте управления представлен элемент единственного интерфейса для операций моделирования и тонирования. Это избавляет от необходимости отображать избыточные панели и уменьшает загромождённость окна приложения. Таким образом, для работы в режиме 3D можно высвободить максимальное пространство и пользоваться единственным интерфейсом, что ускоряет работу и делает её более удобной.

При использовании рабочего пространства 3D моделирования пульт управления отображается автоматически. Возможно отображение пульта управления вручную путем выбора меню "Сервис" » "Палитры" или путем ввода ПУЛЬТУПР по запросу команды.

Структура пульта управления и работа с ним

Пульт управления организован в виде набора управляющих панелей. На каждой управляющей панели имеются соответствующие инструменты и элементы управления, аналогичные инструментам панелей и элементам управления диалоговых окон.

Большие значки, отображаемые на пульте слева, называются значками управляющей панели. Каждый значок управляющей панели обозначает назначение управляющей панели, и при нажатии значка открывается всплывающая панель с дополнительными инструментами и элементами управления. Открытая всплывающая панель автоматически закрывается при нажатии другого значка управляющей панели. Невозможно отобразить более одной всплывающей панели.

С каждой управляющей панелью можно связать группу инструментальных палитр. Для отображения соответствующей группы инструментальных палитр выберите инструмент или откройте всплывающую панель.

Настройка пульта управления

Существуют следующие способы настройки пульта управления:

  • Пользователь может выбрать, должны ли конкретные управляющие панели отображаться после нажатия правой кнопкой мыши на пульте управления и после выбора или отмены выбора имён управляющих панелей с помощью контекстного меню.
  • С каждой панелью пульта управления можно связать адаптируемую группу инструментальных палитр. По нажатию на управляющей панели правой кнопки мыши отображается список существующих групп инструментальных палитр.
  • Предусмотрено изменение размера пульта управления по горизонтали. Если не хватает места для отображения всех инструментов в один ряд, отображается чёрный значок "стрелка-вниз", который называется элементом управления переполнением.
  • В контекстном меню пульта управления можно управлять характеристиками автоматического скрытия, закрепления и якорной привязки.

Якорная привязка пульта управления приводит к тому, что пульт управления отображается в виде узкой (для экономии пространства) полоски вдоль левой или правой кромки области чертежа. Подробнее о палитрах и окнах закрепления и якорной привязки см. Задание параметров интерфейса.


Пульт управления - Процедуры

Пользовательский интерфейс
Панели и меню
Пульт управления
Понятия
Процедуры
Команды

Отображение пульта управления

Изменение режима разворачивания/сворачивания пульта управления

Отображение или скрытие управляющей панели

Отображение или скрытие выплывающей панели

Связывание группы инструментальных палитр с управляющей панелью


Отображение пульта управления - Процедуры

Пользовательский интерфейс
Панели и меню
Пульт управления
Понятия
Процедуры
Команды

Отображение пульта управления

  • Выберите "Сервис" » "Палитры" » "Пульт управления".

Ввод команды: ПУЛЬТУПР


Изменение режима разворачивания/сворачивания пульта управления - Процедуры

Пользовательский интерфейс
Панели и меню
Пульт управления
Понятия
Процедуры
Команды

Изменение режима разворачивания/сворачивания пульта управления

  • Нажмите кнопку "Авто-скрытие" внизу заголовка окна "Пульт управления".

Режим разворачивания/сворачивания включён.

Режим разворачивания/сворачивания отключен.

Примечание Режим разворачивания/сворачивания доступен только при откреплённом окне "Пульт управления", или если оно закреплено якорем.


Отображение или скрытие управляющей панели - Процедуры

Пользовательский интерфейс
Панели и меню
Пульт управления
Понятия
Процедуры
Команды

Отображение или скрытие управляющей панели

  • Нажмите правую кнопку мыши в любой точке окна "Пульт управления". В контекстном меню в пункте "Панели управления" выберите или отмените выбор управляющей панели.


Отображение или скрытие выплывающей панели - Процедуры

Пользовательский интерфейс
Панели и меню
Пульт управления
Понятия
Процедуры
Команды

Отображение или скрытие выплывающей панели

  • Нажмите на значке управляющей панели слева на пульте управления.


Связывание группы инструментальных палитр с управляющей панелью - Процедуры

Пользовательский интерфейс
Панели и меню
Пульт управления
Понятия
Процедуры
Команды

Связывание группы инструментальных палитр с управляющей панелью

  1. Нажмите правую кнопку мыши на значке управляющей панели на пульте управления.
  2. Выберите пункт "Группа инструментальных палитр" и выберите в списке одну из имеющихся групп инструментальных палитр.


Пульт управления - Команды

Панели и меню
Панели и меню
Пульт управления
Понятия
Процедуры
Команды

Команды
ПУЛЬТУПР | Открывает окно "Пульт управления"
Системные переменные
DASHBOARDSTATE | Указывает состояние окна Пульта управления: активно или нет
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Окно команд - Понятия

Пользовательский интерфейс
Окно команд
Понятия
Процедуры
Команды

Возможно отображение команд, системных переменных и опций, сообщений и подсказок в закрепляемом и изменяемом по размеру окне, именуемом окном команд.

  • Ввод команд в командной строке
    Команда вызывается с помощью клавиатуры. Некоторые команды имеют также сокращённые псевдонимы.
  • Ввод значений системных переменных в командной строке
    Значения системных переменных определяют характер работы определённых команд.
  • Перемещение и редактирование в окне команд
    В окне команд можно перемещаться и выполнять редактирование текста для исправления и повторного ввода команд.
  • Переключение между диалоговыми окнами и командной строкой
    С некоторыми командами можно работать как в командной строке, так в диалоговых окнах. Эта возможность особенно полезна при использовании сценариев.
  • Закрепление, изменение размера и скрытие окна команд
    Необходимость открытия окна команд и изменения его положения определяется характером работы пользователя.


Окно команд - Процедуры

Пользовательский интерфейс
Окно команд
Понятия
Процедуры
Команды

Копирование недавно использованной команды

Изменение значения системной переменной

Вывод списка всех системных переменных

Открытие текстового окна

Закрытие текстового окна

Копирование текста из текстового окна в командную строку

Выполнение команд в режиме командной строки

Открепление окна команд

Включение режима прозрачности плавающего окна команд

Закрепление окна команд

Изменение размеров закрепленного окна команд

Скрытие окна команд


Окно команд - Команды

Пользовательский интерфейс
Окно команд
Понятия
Процедуры
Команды
Команды
ВСТБУФЕР | Вставка содержимого буфера обмена
ГРАФЭКР | Переключение из текстового окна в графическую область
ЖУРНАЛВКЛ | Включение записи содержимого текстового окна в файл
ЖУРНАЛОТКЛ | Закрывает текстовое окно файла журнала, открытое командой ЖУРНАЛВКЛ.
КБУФЕР | Копирует объекты или текст из командной строки в буфер обмена
КОМСТР | Отображает командную строку
КОМСТРСКРЫТЬ | Скрывает командную строку
КПРОТОКОЛ | Копирование текста из окна протокола командной строки в буфер обмена
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ТЕКСТЭКР | Открытие текстового окна
УСТПЕРЕМ | Вывод списка системных переменных, изменение их значений
Системные переменные
ATTDIA | Контроль команды ВСТАВИТЬ: используется ли диалоговое окно для указания значения атрибута.
CMDNAMES | Отображает имена активной и прозрачной команд
EXPERT | Управляет отображением определенных подсказок
FILEDIA | Подавляет отображение диалоговых окон навигации к файлу
LOGFILEMODE | Указывает, производится ли запись содержимого текстового окна в файл журнала.
LOGFILENAME | Задает путь и имя файла журнала текстового окна для текущего чертежа
LOGFILEPATH | Задает путь к файлам журналов текстового окна для всех чертежей в сеансе
PALETTEOPAQUE | Управляет прозрачностью окон
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Ввод команд в командной строке - Понятия

Пользовательский интерфейс
Окно команд
Ввод команд в командной строке
Понятия
Процедуры
Команды

Команда вызывается с помощью клавиатуры. Некоторые команды имеют также сокращённые псевдонимы.

Для ввода команды с клавиатуры наберите полное имя команды в командной строке и нажмите клавишу ENTER или ПРОБЕЛ.

Примечание Когда включён параметр "Динамический ввод" и подключено отображение динамических подсказок, можно ввести несколько команд из подсказок рядом с курсором.

Некоторые команды имеют также сокращённые имена. Например, вместо того, чтобы вводить слово отрезок для выполнения команды ОТРЕЗОК, можно ввести l. Сокращенные имена команд называются псевдонимами и расшифровываются в файле acad.pgp.

Подробнее о создании новых псевдонимов команд см. раздел Псевдоимена команд в документе Руководство по адаптации.

Чтобы найти команду, введите букву в командной строке и нажмите клавишу TAB для циклического переключения между всеми командами, начинающимися с этой буквы. Нажмите клавишу ENTER или ПРОБЕЛ. Повторно запустите недавно использованную команду нажатием правой кнопкой мыши в командной строке.

Задание параметров команд

При вводе команд в командной строке отображается либо набор параметров, либо диалоговое окно. Например, при вводе команды круг в командной строке отображается подсказка следующего вида:

Центр круга или [3Т/2Т/ККР (кас, кас, радиус)]:

Для задания центра круга можно ввести значения координат X,Y или указать нужную точку на экране с помощью устройства указания.

Выбор другого параметра выполняется вводом соответствующих прописных букв, перечисленных в квадратных скобках. Эти буквы можно вводить в любом регистре. Например, для выбора параметра "три точки" (3Т) введите 3р.

Выполнение команд

Для выполнения команды нажмите клавишу ПРОБЕЛ или ENTER или нажмите правую кнопку устройства указания после ввода имени команды или ответов на запросы. В инструкциях справочной системы подразумевается выполнение этих действий пользователем и отсутствует напоминание о необходимости нажатия клавиши ENTER после каждого ввода.

Повтор и отмена команд

Для повторного вызова последней команды нажмите клавишу ENTER или ПРОБЕЛ или нажмите правую кнопку устройства указания на индикаторе подсказки команды.

Кроме того, для повтора команды можно ввести нескольк и, через пробел, имя нужной команды так, как это показано в следующем примере:

Команда: нескольк круг

Для отмены выполняющейся команды нажмите клавишу ESC.

Прерывание выполнения команды вводом другой команды или изменением значения системной переменной

Многие команды можно использовать в прозрачном режиме, т.е. вызывать их в ходе выполнения другой команды. Прозрачные команды, например СЕТКА или ПОКАЗАТЬ, обычно предназначены для изменения параметров чертежа или параметров отображения. В Справочнике команд прозрачные команды отмечены апострофом перед именем команды.

Для использования команды в прозрачном режиме нужно нажать соответствующую кнопку на панели инструментов или перед вводом команды в ответ на любую из подсказок программы введите апостроф ('). В командной строке перед подсказками, которые отображаются для прозрачных команд, выводятся двойные угловые скобки (>>). После завершения прозрачной команды возобновляется работа исходной. Например, для включения сетки с интервалом в 1 единицу в ходе рисования отрезка нужно ввести:

Команда: отрезок

Первая точка: 'сетка

>>Интервал сетки (X) или [Вкл/Откл/Шаг/Аспект] <0,000>: 1

Возобновляется команда ОТРЕЗОК

Первая точка:

Как правило, в прозрачном режиме можно пользоваться командами, которые не выполняют выбора объектов, не создают новых объектов или не завершают сеанс работы. В прозрачном режиме можно открывать некоторые из диалоговых окон, но произведённые с их помощью изменения не вступают в силу до завершения приостановленной команды. Точно так же, если при выполнении некоторой команды в прозрачном режиме изменяется значение системной переменной, её новое значение проявляется только в следующей команде.

См. также

Задание клавиш быстрого вызова и временной замены в документе Руководство по адаптации


Копирование недавно использованной команды - Процедуры

Пользовательский интерфейс
Окно команд
Ввод команд в командной строке
Понятия
Процедуры
Команды

Копирование недавно использованной команды

  1. Нажмите на командной строке правую кнопку мыши. Выберите "Журнал последних команд".
  2. Выберите нужную команду.


Ввод команд в командной строке - Команды

Окно команд
Окно команд
Ввод команд в командной строке
Понятия
Процедуры
Команды

Команды
ВСТБУФЕР | Вставка содержимого буфера обмена
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
CMDNAMES | Отображает имена активной и прозрачной команд
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Ввод значений системных переменных в командной строке - Понятия

Пользовательский интерфейс
Окно команд
Ввод значений системных переменных в командной строке
Понятия
Процедуры
Команды

Значения системных переменных определяют характер работы определённых команд.

С их помощью осуществляется включение и отключение различных режимов, например "Шаг", "Сетка" или "Орто". Они задают используемые по умолчанию масштабы для образцов штриховки. Они используются для хранения сведений о текущем чертеже или настройке программы. Системные переменные могут использоваться для изменения настроек или для отображения информации о текущем состоянии.

Например, изменение значения системной переменной GRIDMODE приводит к включению и отключению режима отображения сетки в виде точек. В этом случае воздействие, оказываемое системной переменной GRIDMODE, эквивалентно команде СЕТКА. DATE, являясь системной переменной, допускает только чтение и предназначена для хранения текущей даты. Значение даты можно вывести, но нельзя изменить.

Проверять или изменять значения системной переменной можно в прозрачном режиме, т.е. во время выполнения другой команды; однако новые значения вступают в силу только после завершения приостановленной команды.


Ввод значений системных переменных в командной строке - Процедуры

Пользовательский интерфейс
Окно команд
Ввод значений системных переменных в командной строке
Понятия
Процедуры
Команды

Изменение значения системной переменной

Вывод списка всех системных переменных


Изменение значения системной переменной - Процедуры

Пользовательский интерфейс
Окно команд
Ввод значений системных переменных в командной строке
Понятия
Процедуры
Команды

Изменение значения системной переменной

  1. В командной строке введите имя системной переменной. Например, для переключения режима сетки введите gridmode.
  2. Для изменения состояния переменной GRIDMODE введите 1 , чтобы включить сетку, или 0 для её отключения. Для сохранения текущего значения системной переменной нажмите клавишу ENTER.


Вывод списка всех системных переменных - Процедуры

Пользовательский интерфейс
Окно команд
Ввод значений системных переменных в командной строке
Понятия
Процедуры
Команды

Вывод списка всех системных переменных

  1. В командной строке введите устперем.
  2. В ответ на запрос имени переменной введите ?.
  3. В ответ на подсказку "Список переменных для вывода" нажмите клавишу ENTER.

Ввод команды: УСТПЕРЕМ


Ввод значений системных переменных в командной строке - Команды

Окно команд
Окно команд
Ввод значений системных переменных в командной строке
Понятия
Процедуры
Команды

Команды
УСТПЕРЕМ | Вывод списка системных переменных, изменение их значений
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Перемещение и редактирование в окне команд - Понятия

Пользовательский интерфейс
Окно команд
Перемещение и редактирование в окне команд
Понятия
Процедуры
Команды

В окне команд можно перемещаться и выполнять редактирование текста для исправления и повторного ввода команд.

Для этого используются стандартные клавиши:

  • СТРЕЛКИ ВВЕРХ, ВНИЗ, ВЛЕВО и ВПРАВО
  • INSERT, DELETE
  • PAGE UP, PAGE DOWN
  • HOME, END
  • ПРОБЕЛ

Допускается повторение любых команд, использованных в текущем сеансе, путем циклического прохода по командам в окне команд с помощью клавиш СТРЕЛКА ВВЕРХ, СТРЕЛКА ВНИЗ и ENTER. По умолчанию нажатием сочетания клавиш CTRL+C выполняется копирование выделенного текста в буфер обмена. При нажатии сочетания клавиш CTRL+V текст из буфера обмена вставляется в текстовое или командное окно.

При нажатии правой кнопки мыши в области окна команд или текстового окна отображается контекстное меню, в котором содержатся шесть недавно использованных команд, можно скопировать выделенный текст или весь протокол команд, вставить текст, а также открыть диалоговое окно "Настройка".

Для большинства команд вполне достаточно видеть в командном окне текущую командную строку и две-три предыдущих (так называемый протокол команд). Перемещаясь по окну команд, можно просматривать несколько строк протокола команд. Размеры окна команд изменяются путем растягивания его рамки. Для команд, осуществляющих вывод текстовой информации, например СПИСОК, можно увеличить размер окна команд или, нажав клавишу F2, направить вывод в текстовое окно.

Использование текстового окна

Текстовое окно подобно окну команд; в нём также можно вводить команды и наблюдать подсказки и сообщения. В текстовом окне отображается полный протокол команд текущего сеанса работы. Текстовое окно используется для просмотра результатов работы команд с большим объёмом вывода, таких как СПИСОК, в котором приводится подробная информация о выбранных объектах. Для перемещения по протоколу команд служат стрелки для прокрутки на правом краю окна.

Выделение текста выполняется с помощью клавиши SHIFT и стандартных клавиш перемещения. Например, комбинация клавиш SHIFT+HOME позволяет выделить текст от позиции курсора до начала строки.

Для копирования в буфер обмена всего содержимого текстового окна используется команда КПРОТОКОЛ.

См. также

Закрепление, изменение размера и скрытие окна команд

Использование динамического ввода


Перемещение и редактирование в окне команд - Процедуры

Пользовательский интерфейс
Окно команд
Перемещение и редактирование в окне команд
Понятия
Процедуры
Команды

Открытие текстового окна

Закрытие текстового окна

Копирование текста из текстового окна в командную строку


Открытие текстового окна - Процедуры

Пользовательский интерфейс
Окно команд
Перемещение и редактирование в окне команд
Понятия
Процедуры
Команды

Открытие текстового окна

  • Находясь в области построения чертежа, нажмите клавишу F2.

Текстовое окно отображается перед областью построения.

Ввод команды: ТЕКСТЭКР


Закрытие текстового окна - Процедуры

Пользовательский интерфейс
Окно команд
Перемещение и редактирование в окне команд
Понятия
Процедуры
Команды

Закрытие текстового окна

  • Находясь в текстовом окне, нажмите клавишу F2.

Текстовое окно закрывается. Для этих же целей можно использовать и стандартные средства Windows.

Ввод команды: ГРАФЭКР


Копирование текста из текстового окна в командную строку - Процедуры

Пользовательский интерфейс
Окно команд
Перемещение и редактирование в окне команд
Понятия
Процедуры
Команды

Копирование текста из текстового окна в командную строку

  1. Если текстовое окно ещё не открыто, нажмите для его открытия клавишу F2.
  2. Выделите текст, который нужно скопировать.
  3. Нажмите правую кнопку мыши в пределах окна команд или текстового окна. Выберите "Вставить в командную строку".

    4. Текст копируется в буфер обмена, а затем вставляется в командную строку. После нажатия клавиши ENTER команды выполняются по порядку, как сценарий. Для копирования и вставки текста используются также сочетания клавиш CTRL+C и CTRL+V.

    Ввод команды: КБУФЕР, ВСТБУФЕР


Перемещение и редактирование в окне команд - Команды

Окно команд
Окно команд
Перемещение и редактирование в окне команд
Понятия
Процедуры
Команды

Команды
ВСТБУФЕР | Вставка содержимого буфера обмена
ГРАФЭКР | Переключение из текстового окна в графическую область
ЖУРНАЛВКЛ | Включение записи содержимого текстового окна в файл
ЖУРНАЛОТКЛ | Закрывает текстовое окно файла журнала, открытое командой ЖУРНАЛВКЛ.
КБУФЕР | Копирует объекты или текст из командной строки в буфер обмена
КПРОТОКОЛ | Копирование текста из окна протокола командной строки в буфер обмена
ТЕКСТЭКР | Открытие текстового окна
Системные переменные
LOGFILEMODE | Указывает, производится ли запись содержимого текстового окна в файл журнала.
LOGFILENAME | Задает путь и имя файла журнала текстового окна для текущего чертежа
LOGFILEPATH | Задает путь к файлам журналов текстового окна для всех чертежей в сеансе
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Переключение между диалоговыми окнами и командной строкой - Понятия

Пользовательский интерфейс
Окно команд
Переключение между диалоговыми окнами и командной строкой
Понятия
Процедуры
Команды

С некоторыми командами можно работать как в командной строке, так в диалоговых окнах. Эта возможность особенно полезна при использовании сценариев.

С некоторыми командами можно работать как в командной строке, так в диалоговых окнах. Для многих команд отмена открытия диалогового окна и переход к работе в командной строке осуществляется путем ввода дефиса перед именем команды. Например, ввод команды слой в командной строке приводит к открытию диалогового окна "Диспетчер свойств слоев". Если же ввести -слой, эквивалентный набор параметров для управления свойствами слоёв выводится в командной строке. Подавление вывода диалоговых окон полезно для обеспечения совместимости с более ранними версиями AutoCAD® и для использования пакетных файлов. Параметры, отображаемые в диалоговом окне, могут незначительно отличаться от выводимых в командной строке.

Следующие системные переменные оказывают влияние на открытие диалоговых окон:

  • ATTDIA указывает, должно ли использоваться диалоговое окно для ввода атрибутов команды ВСТАВКА.
  • CMDNAMES задаёт вывод имён (английских) текущей активной команды и прозрачной команды.
  • EXPERT указывает, нужно ли выводить диалоговые окна с предупреждениями.
  • FILEDIA управляет появлением диалоговых окон для чтения и записи файлов. Например, если для переменной FILEDIA задано значение 1, при выполнении командыСОХРАН В открывается диалоговое окно "Сохранение чертежа". Если для переменной FILEDIA задано значение 0, выполнение команды СОХРАН В приводит к отображению подсказки в командной строке. При описании процедур в этом документе предполагается, что переменная FILEDIA равна 1. Даже если FILEDIA равна 0, можно открыть диалоговое окно, введя тильду (~) в ответ на первую подсказку.

Переменные FILEDIA и EXPERT полезны при выполнении команд с помощью сценариев.


Выполнение команд в режиме командной строки - Процедуры

Пользовательский интерфейс
Окно команд
Переключение между диалоговыми окнами и командной строкой
Понятия
Процедуры
Команды

Выполнение команд в режиме командной строки

  • Для большинства команд нужно вводить знак минус (-) перед именем команды.
  • Для работы с диалоговыми окнами, в которых выполняется открытие и сохранение файлов, системная переменная FILEDIA должна иметь значение 0.


Переключение между диалоговыми окнами и командной строкой - Команды

Окно команд
Окно команд
Переключение между диалоговыми окнами и командной строкой
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
ATTDIA | Контроль команды ВСТАВИТЬ: используется ли диалоговое окно для указания значения атрибута.
CMDNAMES | Отображает имена активной и прозрачной команд
EXPERT | Управляет отображением определенных подсказок
FILEDIA | Подавляет отображение диалоговых окон навигации к файлу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Закрепление, изменение размера и скрытие окна команд - Понятия

Пользовательский интерфейс
Окно команд
Закрепление, изменение размера и скрытие окна команд
Понятия
Процедуры
Команды

Необходимость открытия окна команд и изменения его положения определяется характером работы пользователя.

Закрепление окна команд

По умолчанию окно команд закреплено. Ширина закреплённого окна команд совпадает с шириной окна AutoCAD. Если текстовая строка не помещается в командной строке, то выводится всплывающее окошко с полным содержимым строки.

Открепление окна команд (оно становится плавающим) выполняется путем его перетаскивания из зоны закрепления. Зоной закрепления является кромка окна приложения AutoCAD, к которой можно прикреплять панель инструментов, палитру или окно команд. Плавающее окно можно перемещать в любое место экрана; пользователь может произвольно изменять его ширину и высоту.

Повторное закрепление окна команд выполняется путем его перетаскивания в зону закрепления окна AutoCAD.

Якорная привязка окна команд

Возможна якорная привязка окна команд к левой или правой стороне окна AutoCAD. После якорной привязки окно команд остается на экране (но в минимизированном состоянии), что позволяет при необходимости восстановить его. Это способствует также увеличению видимой области рисования. Перед выбором стороны якорной привязки необходимо обеспечить плавающее состояние окна команд. Перед якорной привязкой окна команд необходимо убедиться в его плавающем состоянии, далее нажать правую кнопку мыши на его заголовке и выбрать опцию "Якорь слева" или "Якорь справа".

Изменение размера окна команд

Возможно изменение размера окна команд по вертикали путем перетаскивания разделительной черты, расположенной на верхней кромке окна, когда окно команд закреплено внизу, и на нижней кромке окна, когда окно закреплено вверху.

Скрытие окна команд

Для скрытия командной строки выберите "Сервис" » "Командная строка" (или нажмите сочетание клавиш CTRL+9). Если скрыть командную строку, ввод команд по-прежнему возможен. Однако для некоторых команд и системных переменных в командную строку выводятся значения, поэтому в этих случаях может потребоваться отобразить командную строку. Для отображения скрытой командной строки выберите "Сервис" » "Командная строка" (или нажмите сочетание клавиш CTRL+9).

Примечание Сведения о режимах отображения (таких как автоматическое скрытие или прозрачность) закрепляемых окон см. раздел Задание параметров интерфейса в документе “Управление отображением закрепляемых окон”.


Закрепление, изменение размера и скрытие окна команд - Процедуры

Пользовательский интерфейс
Окно команд
Закрепление, изменение размера и скрытие окна команд
Понятия
Процедуры
Команды

Открепление окна команд

Включение режима прозрачности плавающего окна команд

Закрепление окна команд

Изменение размеров закрепленного окна команд

Скрытие окна команд


Открепление окна команд - Процедуры

Пользовательский интерфейс
Окно команд
Закрепление, изменение размера и скрытие окна команд
Понятия
Процедуры
Команды

Открепление окна команд

  • Нажмите на ручке переноса (двойная полоса) на левом ребре закреплённого окна команд и перетаскивайте его из области закрепления до тех пор, пока не появится утолщённая контурная рамка. Расположите окно команд в области построения окна AutoCAD.


Включение режима прозрачности плавающего окна команд - Процедуры

Пользовательский интерфейс
Окно команд
Закрепление, изменение размера и скрытие окна команд
Понятия
Процедуры
Команды

Включение режима прозрачности плавающего окна команд

  1. Нажмите правую кнопку мыши в плавающем окне команд. Выберите "Прозрачность".
  2. В диалоговом окне "Прозрачность" переместите указатель шкалы влево, чтобы сделать окно команд менее прозрачным или вправо, чтобы сделать его более прозрачным.

    3. Степень прозрачности окна может варьироваться от полной непрозрачности до полной прозрачности. Окно команд нельзя сделать прозрачным, если включён режим "Отключить режим прозрачности окна".


Закрепление окна команд - Процедуры

Пользовательский интерфейс
Окно команд
Закрепление, изменение размера и скрытие окна команд
Понятия
Процедуры
Команды

Закрепление окна команд

  • Нажмите на заголовке окна команд и, удерживая кнопку, перетащите его в верхнюю или нижнюю зону закрепления окна AutoCAD. Когда окно команд сравнивается по ширине с окном AutoCAD, отпустите кнопку мыши для закрепления окна.

    • Зоной закрепления является кромка окна приложения AutoCAD, что позволяет закреплять панель, палитру или окно команд.

  • Нажмите правую кнопку мыши на заголовке окна "Команда" и выберите "Разрешить закрепление".

    • Примечание Для управления закреплением окна команд можно нажать правую кнопку мыши на заголовке окна команд и далее нажать левую кнопку на "Разрешить закрепление".


Изменение размеров закрепленного окна команд - Процедуры

Пользовательский интерфейс
Окно команд
Закрепление, изменение размера и скрытие окна команд
Понятия
Процедуры
Команды

Изменение размеров закрепленного окна команд

  1. Расположите курсор на горизонтальной разделительной черте, чтобы курсор принял форму двойной черты со стрелками.
  2. Перетащите разделительную черту по вертикали, пока не будет достигнут нужный размер.


Скрытие окна команд - Процедуры

Пользовательский интерфейс
Окно команд
Закрепление, изменение размера и скрытие окна команд
Понятия
Процедуры
Команды

Скрытие окна команд

  • В меню "Сервис" выберите "Командная строка".

    • Примечание Для некоторых команд и системных переменных в командную строку выводятся значения, поэтому в этих случаях может потребоваться отобразить командную строку. Для отображения скрытой командной строки нажмите сочетание клавиш CTRL+9 или выберите "Сервис" » "Командная строка".


Закрепление, изменение размера и скрытие окна команд - Команды

Окно команд
Окно команд
Закрепление, изменение размера и скрытие окна команд
Понятия
Процедуры
Команды

Команды
КОМСТР | Отображает командную строку
КОМСТРСКРЫТЬ | Скрывает командную строку
Системные переменные
PALETTEOPAQUE | Управляет прозрачностью окон
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Центр управления DesignCenter - Понятия

Пользовательский интерфейс
Центр управления DesignCenter
Понятия
Процедуры
Команды

С помощью центра управления DesignCenter осуществляется управление вхождениями блоков, внешними ссылками и другими элементами содержимого чертежей, такими как описания слоёв, листы и текстовые стили.

  • Краткий обзор центра управления DesignCenter
  • Приёмы работы в окне "DesignCenter"
    Пользователь может управлять размерами, местоположением и видом окна "DesignCenter".
  • Доступ к содержимому с помощью DesignCenter
    Область структуры в левой части окна "DesignCenter" и четыре вкладки DesignCenter позволяют находить и заносить элементы в область содержимого.
  • Добавление содержимого с помощью центра управления DesignCenter
    Правая область окна "DesignCenter" предназначена для работы с отображаемым содержимым.
  • Загрузка содержимого из Интернета с помощью Интернет-модуля DesignCenter
    Вкладка центра управления "Интернет-модуль центра управления" предоставляет доступ к таким элементам содержимого, как блоки, библиотеки компонентов, каталоги производителей и Интернет-каталоги.


Центр управления DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Понятия
Процедуры
Команды

Изменение режима разворачивания/сворачивания окна "DesignCenter"

Для запрета закрепления окна "DesignCenter"

Отображение и скрытие области структуры центра управления

Изменение источника содержимого, отображаемого в окне "DesignCenter"

Изменение папки, назначенной в центре управления DesignCenter для кнопки "Вернуть"

Добавление элементов в папку "Избранное" в центре управления DesignCenter

Отображение содержимого папки "Избранное" в центре управления DesignCenter

Упорядочение элементов в папке "Избранное" центра управления DesignCenter

Создание инструментальной палитры из содержимого центра управления DesignCenter

Загрузка области содержимого из диалогового окна "Поиск" центра управления DesignCenter

Загрузка библиотеки компонентов в область содержимого центра управления DesignCenter

Загрузка образцов штриховки в область содержимого центра управления DesignCenter

Открытие чертежа из центра управления DesignCenter

Обновление описания блока с помощью центра управления DesignCenter

Установка утилиты "Диспетчер Интернет-компонентов"

Просмотр папок Интернет-содержимого в списке категорий

Поиск содержимого в Интернет-модуле DesignCenter

Задание коллекций содержимого

Загрузка содержимого на компьютер

Загрузка содержимого в чертеж


Центр управления DesignCenter - Команды

Пользовательский интерфейс
Центр управления DesignCenter
Понятия
Процедуры
Команды
Команды
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
ЦУПЕРЕЙТИ | Загружает указанный файл чертежа, папку или сетевой путь DesignCenter
Системные переменные
ADCSTATE | Указывает на состояние DesignCenter™: активно или нет
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Краткий обзор центра управления DesignCenter - Понятия

Пользовательский интерфейс
Центр управления DesignCenter
Краткий обзор центра управления DesignCenter
Понятия
Процедуры
Команды

С помощью DesignCenter можно организовать доступ к чертежам, блокам, штриховкам и другим типам графического содержимого. С его помощью можно перетащить в текущий чертёж содержимое из любого другого чертежа. Чертежи, блоки и штриховки можно также перемещать на инструментальную палитру. Чертёж, из которого осуществляется перенос содержимого, может находиться как на локальном компьютере, так и на веб-сайте. Кроме того, если в сеансе открыто несколько чертежей, DesignCenter даёт возможность ускорить процесс рисования за счёт копирования и вставки таких элементов, как слои, листы и текстовые стили, из одного чертежа в другой.

DesignCenter даёт возможность:

  • Просматривать содержимое чертежей, включая библиотеки компонентов, на локальном диске, сетевом диске и веб-страницах.
  • Просматривать таблицы описаний таких именованных объектов, как блоки и слои в любом файле чертежа; вставлять и копировать эти описания в текущий чертеж.
  • Обновлять (переопределять) описания блоков.
  • Создавать ярлыки для часто используемых чертежей, папок и Интернет-адресов.
  • Дополнять содержимое чертежа блоками, внешними ссылками, образцами штриховки и т.п.
  • Открывать файлы чертежей в новом окне.
  • Перетаскивать чертежи, блоки и штриховки на инструментальные палитры для быстрого доступа к ним.


Центр управления DesignCenter

Пользовательский интерфейс
Центр управления DesignCenter
Центр управления DesignCenter
Понятия
Процедуры
Команды

Нет процедур.


Краткий обзор центра управления DesignCenter - Команды

Центр управления DesignCenter
Центр управления DesignCenter
Краткий обзор центра управления DesignCenter
Понятия
Процедуры
Команды

Команды
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
ЦУПЕРЕЙТИ | Загружает указанный файл чертежа, папку или сетевой путь DesignCenter
Системные переменные
ADCSTATE | Указывает на состояние DesignCenter™: активно или нет
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Приёмы работы в окне "DesignCenter" - Понятия

Пользовательский интерфейс
Центр управления DesignCenter
Приёмы работы в окне "DesignCenter"
Понятия
Процедуры
Команды

Пользователь может управлять размерами, местоположением и видом окна "DesignCenter".

Структура окна "DesignCenter"

Окно "DesignCenter" состоит из двух частей. Левая часть называется областью структуры, правая часть - областью содержимого. В области структуры отображаются всевозможные источники содержимого. Для добавления элементов в чертёж или на инструментальную палитру используется правая часть окна.

Незакреплённое окно "DesignCenter" имеет следующий вид.

В части окна, расположенной под областью содержимого, можно просматривать образец и пояснение к выбранному чертёжу, блоку, штриховке или внешней ссылке. Панель инструментов вверху окна предоставляет доступ к набору режимов и операций.

Изменение размеров и местоположения окна "DesignCenter"

Пользователь может изменять размеры и местоположение окна "DesignCenter", а также включать и отключать его. Многие из этих параметров настраиваются с помощью контекстного меню, вызываемого правой кнопкой мыши, и выбора в нём одной из возможностей.

  • Размеры окна "DesignCenter" изменяются путём перетаскивания разделителя между областью содержимого и областью дерева папок или с помощью перетаскивания края окна.
  • Для закрепления окна "DesignCenter" нужно перетаскивать его в левую или правую область закрепления до тех пор, пока оно не окажется в зафиксированном положении. Можно также дважды нажать кнопку мыши на заголовке плавающего окна "DesignCenter" .
  • Для открепления окна "DesignCenter" нажмите кнопку мыши в области над панелью инструментов окна и перетащите окно за пределы зоны закрепления. Нажатие клавиши CTRL в процессе перетаскивания предотвращает закрепление.
  • Привязка окна "DesignCenter" осуществляется выбором в контекстном меню пункта "Прикрепить якорем справа" или "Прикрепить якорем слева". Когда курсор пересекает привязанное окно, оно разворачивается или сворачивается. Содержимое открытого прикрепленного якорем окна "DesignCenter" перекрывает область рисования. Не существует настройки, позволяющей держать открытым такое окно.
  • чтобы плавающее окно "DesignCenter" сворачивалось и разворачивалось при пересечении его курсором, используется настройка "Auto-hide".
Панель инструментов DesignCenter

С помощью панели осуществляется навигация внутри окна "DesignCenter" и просмотр информации в области структуры и области содержимого. Подробнее о возможностях панели см. команду ЦУВКЛ . Точно такие же режимы навигации и отображения присутствуют в контекстном меню. Для открытия меню нажмите правую кнопку мыши в области содержимого окна "DesignCenter".


Приёмы работы в окне "DesignCenter" - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Приёмы работы в окне "DesignCenter"
Понятия
Процедуры
Команды

Изменение режима разворачивания/сворачивания окна "DesignCenter"

Для запрета закрепления окна "DesignCenter"

Отображение и скрытие области структуры центра управления


Изменение режима разворачивания/сворачивания окна "DesignCenter" - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Приёмы работы в окне "DesignCenter"
Понятия
Процедуры
Команды

Изменение режима разворачивания/сворачивания окна "DesignCenter"

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. Нажмите правую кнопку мыши на заголовке окна "DesignCenter". Выберите "Авто-скрытие".

    3. Если режим разворачивания/сворачивания включен, окно "DesignCenter" исчезает при уходе курсора из него; видимым остается только заголовок. Окно центра управления восстанавливается при возврате курсора в строку заголовка.

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Для запрета закрепления окна "DesignCenter" - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Приёмы работы в окне "DesignCenter"
Понятия
Процедуры
Команды

Для запрета закрепления окна "DesignCenter"

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. На заголовке центра управления нажмите кнопку мыши и удерживайте её нажатой. Начав перемещение мыши, нажмите клавишу CTRL.

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Отображение и скрытие области структуры центра управления - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Приёмы работы в окне "DesignCenter"
Понятия
Процедуры
Команды

Отображение и скрытие области структуры центра управления

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. На панели окна "DesignCenter" нажмите кнопку "Область структуры".

Панель "Стандартная"

Ввод команды: ЦУВКЛ

Контекстное меню: Нажмите правую кнопку мыши в незаполненной части области содержимого и выберите из контекстного меню пункт "Область структуры".


Приёмы работы в окне "DesignCenter" - Команды

Центр управления DesignCenter
Центр управления DesignCenter
Приёмы работы в окне "DesignCenter"
Понятия
Процедуры
Команды

Команды
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
ЦУПЕРЕЙТИ | Загружает указанный файл чертежа, папку или сетевой путь DesignCenter
Системные переменные
ADCSTATE | Указывает на состояние DesignCenter™: активно или нет
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Доступ к содержимому с помощью DesignCenter - Понятия

Пользовательский интерфейс
Центр управления DesignCenter
Доступ к содержимому с помощью DesignCenter
Понятия
Процедуры
Команды

Область структуры в левой части окна "DesignCenter" и четыре вкладки DesignCenter позволяют находить и заносить элементы в область содержимого.

Вкладка "Папки"

На вкладке "Папки" отображается дерево иерархической структуры папок, по которой можно передвигаться. В структуре отображаются значки следующих элементов:

  • сети и компьютеры
  • веб-адреса
  • диски компьютера
  • папки
  • чертежи и связанные с ними вспомогательные файлы
  • внешние ссылки, листы, стили штриховок и именованные объекты, включая блоки, слои, типы линий, текстовые стили и стили размеров, а также стили печати, хранимые внутри чертежей

Содержимое выбранного мышью в области структуры элемента отображается в области содержимого. Нажатие на знаке "плюс" (+) или "минус" (-) соответственно разворачивает и сворачивает вложенные уровни структуры. Развернуть один вложенный уровень можно также двойным нажатием кнопки мыши на имени элемента. Нажатие правой кнопкой мыши в области структуры открывает контекстное меню, содержащее несколько соответствующих режимов.

Вкладки "Открытые чертежи", "Журнал" и "Интернет-модуль центра управления"

Вкладки центра управления - "Открытые чертежи", "Журнал" и "Интернет-модуль" - предоставляют альтернативные способы размещения содержимого.

  • Открытые чертежи. Отображение списка чертежей, открытых в текущий момент. Для загрузки элементов в область содержимого необходимо выбрать файл чертежа, а затем выбрать из списка одну из таблиц описаний.
  • Журнал. Список последних файлов, открывавшихся с помощью DesignCenter. Двойное нажатие в списке на файле чертежа открывает этот чертёж во вкладке "Папки" и загружает его элементы в область содержимого.
  • Интернет-модуль центра управления. Обеспечивается доступ к содержимому на веб-страницах, включая блоки, библиотеки компонентов, библиотеки разработчиков и Интернет-каталоги.
Обеспечение быстрого доступа к часто используемому содержимому

Центр управления DesignCenter позволяет упростить обращение к элементам содержимого, требующим регулярного и быстрого доступа. Как в области структуры, так и в области содержимого предусмотрены режимы, позволяющие работать с папкой "Избранное". В папке "Избранное" можно хранить ярлыки для доступа к содержимому, находящемуся на локальных и сетевых дисках, а также в Интернете.

Если в центре управления выделить папку, чертёж или другой элемент содержимого и выбрать в контекстном меню пункт "Добавить в Избранное", ярлык для доступа к этому элементу заносится в папку "Избранное". При этом физического перемещения файлов и папок не происходит; в папке "Избранное " хранятся только ярлыки. Ярлыки, сохранённые в папке "Избранное", можно перемещать, копировать или удалять с помощью программы Windows® Explorer.


Доступ к содержимому с помощью DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Доступ к содержимому с помощью DesignCenter
Понятия
Процедуры
Команды

Изменение источника содержимого, отображаемого в окне "DesignCenter"

Изменение папки, назначенной в центре управления DesignCenter для кнопки "Вернуть"

Добавление элементов в папку "Избранное" в центре управления DesignCenter

Отображение содержимого папки "Избранное" в центре управления DesignCenter

Упорядочение элементов в папке "Избранное" центра управления DesignCenter


Изменение источника содержимого, отображаемого в окне "DesignCenter" - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Доступ к содержимому с помощью DesignCenter
Понятия
Процедуры
Команды

Изменение источника содержимого, отображаемого в окне "DesignCenter"

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. В окне центра управления перейдите на одну из вкладок:
    • Папки. Отображается перечень локальных и сетевых дисков.
    • Открытые чертежи. Отображается перечень чертежей, открытых в текущий момент.
    • Журнал. Отображается перечень последних 20 элементов, открытых с помощью центра управления.
    • Интернет-модуль. Отображается перечень содержимого из Интернета.

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Изменение папки, назначенной в центре управления DesignCenter для кнопки "Вернуть" - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Доступ к содержимому с помощью DesignCenter
Понятия
Процедуры
Команды

Изменение папки, назначенной в центре управления DesignCenter для кнопки "Вернуть"

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. В области структуры центра управления найдите папку, которую требуется сделать основной.
  3. Нажмите правую кнопку мыши на папке. Выберите "Сделать основной папкой".

При нажатии кнопки "Вернуть" центр управления DesignCenter будет автоматически переходить в эту папку.

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Добавление элементов в папку "Избранное" в центре управления DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Доступ к содержимому с помощью DesignCenter
Понятия
Процедуры
Команды

Добавление элементов в папку "Избранное" в центре управления DesignCenter

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. Нажмите правую кнопку мыши на элементе в области структуры или области содержимого центра управления. Выберите "Добавить в Избранное".

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Отображение содержимого папки "Избранное" в центре управления DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Доступ к содержимому с помощью DesignCenter
Понятия
Процедуры
Команды

Отображение содержимого папки "Избранное" в центре управления DesignCenter

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. В центре управления нажмите кнопку "Избранное".

    3. В области структуры переход к папке "Избранное" осуществляется с помощью вкладки "Папки".

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Упорядочение элементов в папке "Избранное" центра управления DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Доступ к содержимому с помощью DesignCenter
Понятия
Процедуры
Команды

Упорядочение элементов в папке "Избранное" центра управления DesignCenter

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. В центре управления нажмите кнопку "Избранное".
  3. Нажмите правую кнопку мыши в области содержимого. Выберите "Упорядочить Избранное".

    4. В окне откроется папка "Autodesk", вложенная в папку "Избранное".

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Доступ к содержимому с помощью DesignCenter - Команды

Центр управления DesignCenter
Центр управления DesignCenter
Доступ к содержимому с помощью DesignCenter
Понятия
Процедуры
Команды

Команды
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
ЦУПЕРЕЙТИ | Загружает указанный файл чертежа, папку или сетевой путь DesignCenter
Системные переменные
ADCSTATE | Указывает на состояние DesignCenter™: активно или нет
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление содержимого с помощью центра управления DesignCenter - Понятия

Пользовательский интерфейс
Центр управления DesignCenter
Добавление содержимого с помощью центра управления DesignCenter
Понятия
Процедуры
Команды

Правая область окна "DesignCenter" предназначена для работы с отображаемым содержимым.

Двойным нажатием на элементе в области содержимого разворачиваются вложенные уровни, детализирующие данный элемент. Например, после двойного нажатия на значке чертежа появляются значки элементов содержимого - "Блоки" и др. Далее двойное нажатие на значке "Блоки" приводит к выводу изображений всех блоков в чертеже.

Добавление содержимого в чертеж

Существует несколько способов добавления элементов из области содержимого в текущий чертеж:

  • Для вставки содержимого с параметрами по умолчанию (если они есть) элемент нужно перетащить в графическую область чертежа.
  • Нажатием правой кнопки на элементе в области содержимого вызывается контекстное меню, содержащее несколько вариантов действий.
  • Для отображения диалогового окна "Вставка" дважды нажмите кнопку мыши на блоке; для отображения диалогового окна "Штриховка контура и закрашивание" дважды нажмите на штриховке.

В области содержимого можно просматривать такие графические элементы содержимого, как чертежи, внешние ссылки и блоки, включая имеющиеся текстовые пояснения к ним.

Обновление описаний блоков с помощью центра управления DesignCenter

В отличие от внешних ссылок, описания блоков, вставленных в чертеж, не обновляются автоматически при изменении описания блока в файле источника. Однако с помощью центра управления можно применить изменения в описании блока к текущему чертежу. Источником описания блока может быть файл чертежа или вложенный блок, размещенный в библиотеке компонентов чертежа.

Нажав правую кнопку мыши на блоке или файле чертежа в области содержимого, выберите в контекстном меню "Переопределить" или "Вставить с переопределением" для обновления выбранного блока.

Открытие чертежей с помощью центра управления DesignCenter

В окне "DesignCenter" можно открыть чертёж из области содержимого, используя контекстное меню, перетаскивая чертёж при нажатой клавише CTRL, или перетаскивая значок чертежа в любое место за пределами графической области. Имя загружаемого чертежа сохраняется в журнале центра управления для быстрого доступа к нему в дальнейшем.

Добавление элементов в инструментальные палитры с помощью центра управления DesignCenter

Из центра управления можно перетаскивать чертежи, блоки и штриховки на текущую инструментальную палитру.

  • На текущую инструментальную палитру из области содержимого центра управления можно перетащить один или несколько элементов.
  • Нажмите правую кнопку мыши в области структуры центра управления, затем с помощью контекстного меню создайте новую палитру из текущей папки, файла чертежа или значка блока.

Если на инструментальную палитру добавляются чертежи, то при перетаскивании их из палитры в текущий чертёж они вставляются в виде блоков.

Примечание Блоки или штриховки можно добавлять на инструментальную палитру целыми группами.


Добавление содержимого с помощью центра управления DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Добавление содержимого с помощью центра управления DesignCenter
Понятия
Процедуры
Команды

Создание инструментальной палитры из содержимого центра управления DesignCenter

Загрузка области содержимого из диалогового окна "Поиск" центра управления DesignCenter

Загрузка библиотеки компонентов в область содержимого центра управления DesignCenter

Загрузка образцов штриховки в область содержимого центра управления DesignCenter

Открытие чертежа из центра управления DesignCenter

Обновление описания блока с помощью центра управления DesignCenter


Создание инструментальной палитры из содержимого центра управления DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Добавление содержимого с помощью центра управления DesignCenter
Понятия
Процедуры
Команды

Создание инструментальной палитры из содержимого центра управления DesignCenter

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. Выполните одно из следующих действий:
    • Нажмите правую кнопку мыши на элементе в области структуры центра управления. Выберите "Создать инструментальную палитру". Новая палитра содержит чертежи, блоки или штриховки из выбранного элемента.
    • Нажмите правую кнопку мыши в незаполненной части области содержимого центра управления. Выберите "Создать инструментальную палитру". Новая палитра содержит чертежи, блоки или штриховки из области содержимого центра управления.
    • Нажмите правую кнопку мыши на чертеже в области структуры или содержимого центра управления. Выберите "Создать палитру блоков". Новая палитра содержит блоки из выбранного чертежа.

    Впоследствии на палитру можно перетащить другие чертежи, блоки или штриховки из области содержимого центра управления.

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Загрузка области содержимого из диалогового окна "Поиск" центра управления DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Добавление содержимого с помощью центра управления DesignCenter
Понятия
Процедуры
Команды

Загрузка области содержимого из диалогового окна "Поиск" центра управления DesignCenter

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. Воспользуйтесь одним из следующих способов:
    • Перетащите элемент из списка результатов поиска в область содержимого.
    • Дважды нажмите на элементе в списке результатов поиска.
    • Нажмите правую кнопку мыши на элементе в списке результатов поиска. Выберите "Загрузить в содержимое".
  3. Дважды нажмите на значке "Блоки" в области содержимого центра управления.

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Загрузка библиотеки компонентов в область содержимого центра управления DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Добавление содержимого с помощью центра управления DesignCenter
Понятия
Процедуры
Команды

Загрузка библиотеки компонентов в область содержимого центра управления DesignCenter

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. На панели центра управления нажмите кнопку "Вернуть".
  3. В области содержимого дважды нажмите на чертеже библиотеки компонентов, которую необходимо загрузить в центр управления, затем дважды нажмите кнопку мыши на значке "Блоки".

    4. Библиотека компонентов загружается в область содержимого центра управления.

Примечание Любую папку, содержащую библиотеку компонентов, можно сделать основной. Если задан другой путь к основной папке, перейдите в папку, содержащую чертежи библиотеки компонентов, и дважды нажмите на ней мышью. Выберите "Сделать основной папкой".

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Загрузка образцов штриховки в область содержимого центра управления DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Добавление содержимого с помощью центра управления DesignCenter
Понятия
Процедуры
Команды

Загрузка образцов штриховки в область содержимого центра управления DesignCenter

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. На панели центра управления нажмите кнопку "Поиск".
  3. В диалоговом окне "Поиск" откройте список "Что искать". Выберите "Файлы образцов штриховки".
  4. На вкладке "Файлы образцов штриховки" в поле "Искать имя" введите *.
  5. Нажмите кнопку "Поиск".
  6. Нажмите два раза кнопку мыши на одном из найденных файлов образцов штриховки.

    7. Выбранный файл с образцами штриховки загружается в центр управления.

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Открытие чертежа из центра управления DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Добавление содержимого с помощью центра управления DesignCenter
Понятия
Процедуры
Команды

Открытие чертежа из центра управления DesignCenter

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. Воспользуйтесь одним из следующих способов:
    • Нажмите правую кнопку мыши на значке чертежа в области содержимого центра управления. Выберите "Открыть в окне приложения".
    • Нажмите клавишу CTRL и перетащите значок из области содержимого центра управления в область рисования.
    • Перетащите значок чертежа из области содержимого центра управления за пределы графической области в окне приложения. (При перемещении значка чертежа в область рисования он вставляется в текущий чертёж как блок.)

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Обновление описания блока с помощью центра управления DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Добавление содержимого с помощью центра управления DesignCenter
Понятия
Процедуры
Команды

Обновление описания блока с помощью центра управления DesignCenter

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "DesignCenter".
  2. Нажмите правую кнопку мыши на блоке в области содержимого центра управления. Выберите "Переопределить" или "Вставить с переопределением".

    3. Примечание Если источником блока, который необходимо обновить, является целый файл чертежа, а не описание отдельного блока в файле чертежа, нажмите правую кнопку мыши на значке чертежа в области содержимого центра управления. Выберите "Вставить как блок".

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Добавление содержимого с помощью центра управления DesignCenter - Команды

Центр управления DesignCenter
Центр управления DesignCenter
Добавление содержимого с помощью центра управления DesignCenter
Понятия
Процедуры
Команды

Команды
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
ЦУПЕРЕЙТИ | Загружает указанный файл чертежа, папку или сетевой путь DesignCenter
Системные переменные
ADCSTATE | Указывает на состояние DesignCenter™: активно или нет
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Загрузка содержимого из Интернета с помощью Интернет-модуля DesignCenter - Понятия

Пользовательский интерфейс
Центр управления DesignCenter
Загрузка содержимого из Интернета с помощью Интернет-модуля DesignCenter
Понятия
Процедуры
Команды

Вкладка центра управления "Интернет-модуль центра управления" предоставляет доступ к таким элементам содержимого, как блоки, библиотеки компонентов, каталоги производителей и Интернет-каталоги.

  • Краткий обзор Интернет-модуля
  • Типы содержимого Интернет-модуля DesignCenter
    В модуле содержимое распределено по отдельным папкам в зависимости от категории.
  • Загрузка содержимого из Интернета
    Можно загружать содержимое из Интернета и использовать его для чертежей.


Загрузка содержимого из Интернета с помощью Интернет-модуля DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Загрузка содержимого из Интернета с помощью Интернет-модуля DesignCenter
Понятия
Процедуры
Команды

Установка утилиты "Диспетчер Интернет-компонентов"

Просмотр папок Интернет-содержимого в списке категорий

Поиск содержимого в Интернет-модуле DesignCenter

Задание коллекций содержимого

Загрузка содержимого на компьютер

Загрузка содержимого в чертеж


Загрузка содержимого из Интернета с помощью Интернет-модуля DesignCenter - Команды

Пользовательский интерфейс
Центр управления DesignCenter
Загрузка содержимого из Интернета с помощью Интернет-модуля DesignCenter
Понятия
Процедуры
Команды
Команды
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Краткий обзор Интернет-модуля - Понятия

Пользовательский интерфейс
Центр управления DesignCenter
Краткий обзор Интернет-модуля
Понятия
Процедуры
Команды

Вкладка центра управления "Интернет-модуль" предоставляет доступ к таким элементам содержимого, как блоки, библиотеки компонентов, каталоги производителей и Интернет-каталоги. Эти элементы могут использоваться при коллективной разработке проекта, что повышает эффективность процесса создания чертежей.

Для доступа к модулю DesignCenter нужно перейти в центре управления на вкладку "Интернет-модуль". После открытия окна "Интернет-модуль центра управления", можно просматривать, искать и загружать содержимое в чертёж.

В окне "Интернет-модуль" отображаются две панели—правая и левая. Правая область называется областью содержимого. В ней отображаются элементы или папки, выбранные в левой области. Левая область может иметь четыре вида:

  • Список по категориям. Папки, содержащие библиотеки стандартных деталей, специализированное содержимое и каталоги поставщиков.
  • Поиск. Поиск содержимого в Интернете. Можно задать запрос с помощью логических операций или строк поиска их нескольких слов.
  • Установки. Управление количеством категорий и элементов, отображаемых на каждой странице при поиске или навигации по папкам.
  • Коллекции. Задание содержимого для различных отраслей, отображаемого в модуле DesignCenter.

Вид выбирается нажатием кнопки мыши в верхней части левой области.

После выбора папки в левой области все её элементы загружаются в область содержимого. В области содержимого можно выбрать элемент и загрузить его в область предварительного просмотра. Элементы из области предварительного просмотра можно перетаскивать мышью в область построения или на инструментальные палитры, а также сохранять их на диске компьютера.

Примечание Если в центре управления отсутствует вкладка "Интернет-модуль", необходимо обратиться к сетевому администратору или администратору САПР.

Политика конфиденциальности при использовании Интернет-модуля DesignCenter

Для обновления информации и содержимого Интернет-модуля DesignCenter его необходимо подключить к Интернету. При подключении к Интернету центр управления посылает некоторые данные в компанию Autodesk, для того чтобы получаемая в ответ информация была более конкретной. При этом частные права владельца экземпляра программного продукта никоим образом не нарушаются, так как обмен информацией происходит анонимно.

В Autodesk отправляются следующие сведения:

  • Название программного продукта. Название программного продукта, в котором используется Интернет-модуль DesignCenter
  • Номер версии продукта. Версия продукта
  • Язык пользовательского интерфейса. Код языка пользовательского интерфейса установленной программы
  • Идентификационный код. Интернет-Модуль DesignCenter присваивает каждому пользователю идентификационный код в виде псевдослучайного числа. Код помогает выбрать необходимые для пользователя наборы данных и настройки.

На основе информации, посылаемой из Интернет-модуля, компания Autodesk ведет статистический учёт использования модуля с целью его усовершенствования. Autodesk использует информацию, предоставленную пользователем или полученную от него, в соответствии с политикой конфиденциальности Autodesk, с которой можно ознакомиться на веб-сайте http://www.autodesk.com/privacy-rus .

Включение и отключение вкладки "Интернет-модуль центра управления"

Включение и отключение вкладки "Интернет-модуль" окна "DesignCenter" выполняется с помощью утилиты "Диспетчер Интернет-компонентов". Для получения информации об использовании утилиты "Диспетчер Интернет-компонентов" необходимо её установить и запустить, а затем выбрать пункт "Справка" в окне утилиты.


Краткий обзор Интернет-модуля - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Краткий обзор Интернет-модуля
Понятия
Процедуры
Команды

Установка утилиты "Диспетчер Интернет-компонентов"


Установка утилиты "Диспетчер Интернет-компонентов" - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Краткий обзор Интернет-модуля
Понятия
Процедуры
Команды

Установка утилиты "Диспетчер Интернет-компонентов"

  1. Нажмите два раза кнопку мыши на файле setup.exe на компакт-диске программы.
  2. В обозревателе диска на вкладке "Установка" выберите либо элемент "Автономная установка на несколько пользователей", либо элемент "Сетевое развертывание".
  3. В разделе "Установка дополнительных средств" выберите Autodesk CAD Manager Tools 4.0.
  4. На открывшейся странице "Autodesk CAD Manager Tools 4.0" нажмите кнопку "Установка".

    5. После установки утилиты "Диспетчер Интернет-компонентов" её можно вызывать через меню "Пуск" (Windows).


Краткий обзор Интернет-модуля - Команды

Центр управления DesignCenter
Центр управления DesignCenter
Краткий обзор Интернет-модуля
Понятия
Процедуры
Команды

Команды
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Типы содержимого Интернет-модуля DesignCenter - Понятия

Пользовательский интерфейс
Центр управления DesignCenter
Типы содержимого Интернет-модуля DesignCenter
Понятия
Процедуры
Команды

В модуле содержимое распределено по отдельным папкам в зависимости от категории.

Из папок Интернет-модуля DesignCenter можно загружать содержимое для различных отраслей. Содержимое включает в себя следующее:

  • Стандартные детали. Стандартные детали, которые часто используются в проектировании. Эти детали включают в себя архитектурные, машиностроительные и ГИС-блоки.
  • Каталоги производителей. Блоки и 3D модели, которые можно найти и загрузить, перейдя по ссылке на сайт производителя.
  • Каталоги поставщиков. Список библиотек поставщиков коммерческих каталогов, в которых можно найти детали и блоки.

Чтобы выбрать категории Интернет-содержимого для отображения в списке категорий, используйте вид "Коллекции".


Просмотр папок Интернет-содержимого в списке категорий - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Типы содержимого Интернет-модуля DesignCenter
Понятия
Процедуры
Команды

Просмотр папок Интернет-содержимого в списке категорий

  • Нажмите кнопку мыши на заголовке в верхней части левой области Интернет-модуля DesignCenter, затем выберите "Список категорий".

Папки категорий отображаются в левой области окна.


Типы содержимого Интернет-модуля DesignCenter - Команды

Центр управления DesignCenter
Центр управления DesignCenter
Типы содержимого Интернет-модуля DesignCenter
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Загрузка содержимого из Интернета - Понятия

Пользовательский интерфейс
Центр управления DesignCenter
Загрузка содержимого из Интернета
Понятия
Процедуры
Команды

Можно загружать содержимое из Интернета и использовать его для чертежей.

Обзор содержимого

При активном виде "Список категорий" в правой части окна можно просмотреть содержимое папок из левой области. В эти папки могут вкладываться другие папки.

Нажатие кнопки мыши на папке или элементе внутри папки позволяет увидеть то, чем она наполнена, в области содержимого. Нажатие кнопки мыши на блоке приводит к отображению информации графического или описательного характера о нём в области предварительного просмотра.

Поиск содержимого

При поиске содержимого в Интернете с помощью Интернет-модуля DesignCenter можно в окне "Поиск" задавать критерии поиска с использованием логических операторов и строк, состоящих из нескольких слов. Доступ к функции поиска осуществляется через кнопку в виде лупы или посредством выбора пункта "Поиск" в раскрывающемся заголовке вверху левой области окна модуля.

Управление количеством категорий и элементов на странице

С помощью вида "Параметры" можно управлять количеством категорий и элементов, отображаемых при поиске или навигации по папкам на каждой странице.

Коллекции

Можно выбирать тип содержимого для навигации и поиска. Тип содержимого, отображаемого в Интернет-модуле DesignCenter, можно задавать в области "Коллекции". Например, при использовании архитектурных блоков в чертежах можно выбирать коллекции архитектурных элементов. Указанные при выборе категории отображаются всякий раз при открытии модуля.

Загрузка содержимого

Для загрузки содержимого из Интернета следует выбрать папку, содержащую необходимую информацию. Далее нажмите кнопку мыши на образце изображения содержимого в области содержимого. В области предварительного просмотра появится содержимое и информация о нем. Из области предварительного просмотра можно перетащить блок непосредственно в чертёж или на инструментальную палитру, либо сохранить его на диске компьютера для использования в дальнейшем.

Подробнее о загрузке содержимого из Интернета см. раздел Вставка содержимого с веб-страниц.


Загрузка содержимого из Интернета - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Загрузка содержимого из Интернета
Понятия
Процедуры
Команды

Поиск содержимого в Интернет-модуле DesignCenter

Задание коллекций содержимого

Загрузка содержимого на компьютер

Загрузка содержимого в чертеж


Поиск содержимого в Интернет-модуле DesignCenter - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Загрузка содержимого из Интернета
Понятия
Процедуры
Команды

Поиск содержимого в Интернет-модуле DesignCenter

  1. В окне Интернет-модуля DesignCenter нажмите кнопку мыши на заголовке вверху левой области, затем выберите "Поиск".
  2. Введите в строку поиска слово или словосочетание.

    3. Примечание Более подробная информация о поиске, включая примеры с поиском логических операторов, дана в справочной системе.


Задание коллекций содержимого - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Загрузка содержимого из Интернета
Понятия
Процедуры
Команды

Задание коллекций содержимого

  1. Нажмите кнопку мыши на заголовке вверху левой области окна модуля DesignCenter Online, затем выберите "Коллекции".
  2. В окне "Коллекции" выберите нужные коллекции.
  3. Нажмите кнопку "Обновить коллекции".

    4. Выбранные категории отображаются в левой области.


Загрузка содержимого на компьютер - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Загрузка содержимого из Интернета
Понятия
Процедуры
Команды

Загрузка содержимого на компьютер

  1. Нажмите кнопку мыши на заголовке вверху левой области окна Интернет-модуля DesignCenter, затем выберите "Список категорий".
  2. В папке категорий выберите элемент содержимого.
  3. В области предварительного просмотра под изображением элемента содержимого выберите "Сохранить этот символ как".
  4. В диалоговом окне сохранения файла задайте имя файла и путь к нему.
  5. Нажмите кнопку "Сохранить".

    6. Содержимое загружается на компьютер.


Загрузка содержимого в чертеж - Процедуры

Пользовательский интерфейс
Центр управления DesignCenter
Загрузка содержимого из Интернета
Понятия
Процедуры
Команды

Загрузка содержимого в чертеж

  1. Нажмите кнопку мыши на заголовке вверху части левой области окна Интернет-модуля DesignCenter, затем выберите "Список категорий".
  2. Для отображения элемента содержимого в области предварительного просмотра выберите его мышью в папке категорий.
  3. Перетащите изображение из области предварительного просмотра в чертёж или на инструментальную палитру.


Загрузка содержимого из Интернета - Команды

Центр управления DesignCenter
Центр управления DesignCenter
Загрузка содержимого из Интернета
Понятия
Процедуры
Команды

Команды
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка рабочей среды - Понятия

Пользовательский интерфейс
Настройка рабочей среды
Понятия
Процедуры
Команды

Различные элементы рабочей среды могут быть адаптированы под нужды пользователя.

  • Задание параметров интерфейса
    Пользователь может настраивать интерфейс приложения в соответствии с характером работы.
  • Создание рабочего пространства для конкретной задачи
    Рабочие пространства представляют собой наборы меню, инструментальных панелей и палитр, сгруппированных и упорядоченных специальным образом для создания среды рисования, отвечающей целям конкретной задачи.
  • Сохранение и восстановление параметров интерфейса (профилей)
    В профилях хранятся параметры среды рисования. Можно создать профили для разных пользователей или проектов и организовать их совместное использование посредством импорта и экспорта их в виде файлов.
  • Настройка запуска
    Индивидуальную процедуру запуска программы для каждого проекта можно настроить с помощью аргументов командной строки.


Настройка рабочей среды - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Понятия
Процедуры
Команды

Настройка параметров

Для настройки цветов элементов окна приложения

Перевод вкладок "Модель" и "Разметка листа" в кнопки строки состояния

Включение режима использования вкладок "Модель" и "Разметка листа"

Изменение шрифта в окне команд

Фиксация положения и размеров панелей инструментов и закрепляемых окон

Привязка закрепляемого окна

Перевод привязанного окна в плавающее

Изменение вида базовой точки значка якоря

Закрепление окна или палитры

Открепление окна или палитры

Включение и отключение режима "Авто-скрытие" для плавающей палитры или окна.

Изменение вида окна "Просмотр переходов"

Переключение рабочих пространств

Изменение параметров рабочего пространства

Сохранение рабочего пространства

Назначение текущего профиля

Сохранение профиля

Назначение текущего профиля до запуска программы

Запуск программы с аргументом командной строки


Настройка рабочей среды - Команды

Пользовательский интерфейс
Настройка рабочей среды
Понятия
Процедуры
Команды
Команды
ГРАФНАСТР | Обеспечивает конфигурационные установки системы 3D-графики
ЖУРНАЛВКЛ | Включение записи содержимого текстового окна в файл
ЖУРНАЛОТКЛ | Закрывает текстовое окно файла журнала, открытое командой ЖУРНАЛВКЛ.
НАСТРВИД | Задание точности аппроксимации объектов на текущем видовом экране
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПАРАМЕТРЫПВ | Отображает изменение в виде плавного перехода
РПСОХРАНИТЬ | Сохранение рабочего пространства
ЧИСТЭКРВКЛ | Убирает с экрана панели инструментов и закрепляемые окна (за исключением командной строки)
ЧИСТЭКРОТКЛ | Восстанавливает отображение панели инструментов и закрепляемых окон (за исключением командной строки)
Системные переменные
CALCINPUT | Управление вычислением математических выражений и глобальных констант в полях для ввода текстовых или числовых данных
CPROFILE | Отображает имя текущего профиля
CURSORSIZE | Определение размера перекрестья в процентном отношении от размера экрана
DCTCUST | Отображает путь и имя файла текущего настраиваемого орфографического словаря.
DCTMAIN | Отображает имя файла текущего основного орфографического словаря.
DEFPLSTYLE | Указывает стиль печати по умолчанию для новых объектов.
DRAGMODE | Управляет отображением объектов при перетаскивании
EXTNAMES | Устанавливает параметры для имен именованных объектов (например, типов линий и слоев), которые хранятся в таблицах описаний
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
GRIPBLOCK | Управляет ручками внутри блоков
GRIPCOLOR | Управляет цветом невыбранных ручек
GRIPHOT | Управляет цветом выбранных ручек
INSUNITS | Указывает значение в единицах чертежа для автоматического масштабирования блоков, изображений или вставленных или прикрепленных к чертежу внешних ссылок
INSUNITSDEFSOURCE | Устанавливает единицы измерения исходного содержимого, когда переменная INSUNITS имеет значение, равное 0
INSUNITSDEFTARGET | Устанавливает единицы измерения в целевом чертеже, когда переменная INSUNITS имеет значение, равное 0
INTELLIGENTUPDATE | Управляет скоростью обновления графики
ISAVEBAK | Повышает скорость последовательных сохранений, особенно для больших чертежей
ISAVEPERCENT | Определяет количество неиспользуемого дискового пространства, допустимого в файле чертежа
LAYOUTREGENCTL | Указывает режим обновления списка отображения на вкладке "Модель" и вкладках "Лист"
LOCALE | Отображает код, указывающий текущее место
LOCALROOTPREFIX | Сохраняет полный путь к корневой папке, в которую были установлены локальные адаптируемые файлы
LOCKUI | Блокирует положение и размер панелей инструментов и плавающих окон, таких как "DesignCenter" и "Палитра свойств"
LOGFILEMODE | Указывает, производится ли запись содержимого текстового окна в файл журнала.
LOGFILENAME | Задает путь и имя файла журнала текстового окна для текущего чертежа
LOGFILEPATH | Задает путь к файлам журналов текстового окна для всех чертежей в сеансе
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
OLEQUALITY | Устанавливает качества печати объектов OLE по умолчанию
OLESTARTUP | Управляет загрузкой исходного приложения, в котором был создан внедренный OLE объект, при печати
OSNAPCOORD | Управляет приоритетом ввода координат с клавиатуры над текущими режимами привязки
PAPERUPDATE | Управление выводом диалогового окна предупреждения при попытке вывести на печать лист, формат которого не совпадает с форматом, заданным по умолчанию в файле параметров плоттера
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
PICKBOX | Устанавливает размер прицела выбора объектов (в пикселах)
PICKDRAG | Управляет методом создания рамки выбора
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
PSTYLEPOLICY | Управляет ассоциативностью свойства цвета объекта с его стилем печати
QTEXTMODE | Управляет отображением текста
RASTERPREVIEW | Управляет сохранением вместе с чертежом образцов для просмотра в формате BMP
SAVEFILE | Сохраняет имя текущего файла автоматического сохранения
SAVEFILEPATH | Указывает путь к папке всех файлов автоматического сохранения для текущего сеанса
SAVETIME | Задает интервал автоматического сохранения (в минутах)
SDI | Управляет режимом работы программы (одно- или многодокументный интерфейс)
SPLINESEGS | Задает количество сегментов линии, генерируемых для каждой сглаженной сплайном полилинии, созданной с помощью параметра "Сплайн" команды ПОЛРЕД
TDUSRTIMER | Сохраняет счетчик времени работы пользователя
TOOLTIPMERGE | Объединяет подсказки на чертеже в одну подсказку
TOOLTIPS | Управляет отображением подсказок
VISRETAIN | Управляет свойствами зависимых от внешних ссылок слоев.
VTFPS | Задает минимальную скорость плавного перехода видов в кадрах в секунду
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание параметров интерфейса - Понятия

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Пользователь может настраивать интерфейс приложения в соответствии с характером работы.

Доступ ко различным настройкам обеспечивается контекстными меню и диалоговым окном "Настройка". Некоторые элементы рабочего пространства, такие как вид и положение панелей и палитр, задаются и сохраняются с помощью диалогового окна "Настройка интерфейса пользователя".

Настройка области построения чертежа

Некоторые параметры определяют способ работы в области черчения:

  • Цвет фона (диалоговое окно "Настройка", вкладка "Экран", "Цвета"). Пользователь задает цвета фона для использования в пространстве модели, на листах и в редакторе блоков. Цвета фона на вкладке "Модель" меняются, указывая на вариант работы с проектом: 2D моделирование, 3D моделирование с параллельным проецированием или 3D моделирование с перспективным проецированием.
  • Значок ПСК и курсор в виде перекрестия (диалоговое окно "Настройка", вкладка "3D моделирование"). Пользователь указывает, что опции 3D отображения и метки для знака ПСК могут быть заданы во вкладке "3D моделирование" диалогового окна "Настройка".
  • Назначение цвета для осей X, Y, и Z (диалоговое окно "Настройка", вкладка "Экран", "Цвета"). На 3D видах в любых элементах интерфейса, связанных с X-, Y- и Z-осью ПСК, используются специальные назначения цвета. Оси X назначается красный цвет или оттенок, ось Y имеет зеленый, а ось Z - синий цвет или оттенок. Включение и отключение использования этих оттенков выполняется в диалоговом окне "Цветовая гамма окна чертежа".
  • Очистить экран. Для разворачивания области отображения чертежа выберите "Вид" » "Очистить экран", чтобы отображались только строка меню, строка состояния и окно команд. Рядом с параметром отображается флажок. Нажмите "Очистить экран" ещё раз, чтобы восстановить предыдущий вид. Кнопка очистки экрана находится в правом нижнем углу окна приложения.
  • Просмотр переходов. При панорамировании, зумировании или смены одного вида на другой (команда ПАРАМЕТРЫПВ) можно задавать характер перехода: плавный или мгновенный. По умолчанию используется плавный переход.
  • Всплывающие подсказки. Всплывающие подсказки сообщают информацию о различных вспомогательных средствах построения, например объектной привязке и динамическом вводе. Включение и отключение вывода этой информации регулируется системной переменной TOOLTIPS. Системная переменная TOOLTIPMERGE позволяет объединить выводимую информацию в одной всплывающей подсказке. Общий внешний вид всплывающих подсказок можно настроить в диалоговом окне "Внешний вид подсказок".
3D моделирование с перспективным проецированием
  • Опущенная нулевая плоскость (диалоговое окно "Настройка", вкладка "Экран", "Цвета"). Если включено перспективное проецирование, плоскость ПСК XY отображается в виде опущенной нулевой плоскости с градиентным цветом. На опущенной нулевой плоскости отображается градиент от опущенного дальнего плана до опущенного ближнего плана.
  • Цвет неба (диалоговое окно "Настройка", вкладка "Экран", "Цвета"). Область, не покрытая опущенной нулевой плоскостью, является небом, на котором отображается градиентный цвет от дальнего плана неба до ближнего плана неба.
  • Поднятая нулевая плоскость(диалоговое окно "Настройка", вкладка "Экран", "Цвета"). Если опущенная нулевая плоскость рассматривается снизу, на ней отображается градиент от поднятого дальнего плана до поднятого ближнего плана.
  • Сетка опущенной нулевой плоскости (диалоговое окно "Настройка", вкладка "Экран", "Цвета"). Если перспективное проецирование включено, сетка отображается в виде сетки опущенной нулевой плоскости. Цвета задаются для линий главной сетки, линий малой сетки и линий осей.
Переключение между режимами "Пространство модели" и "Листы"

Пользователь имеет возможность переключения между пространством модели и одной или несколькими разметками листа. Классический интерфейс содержит вкладку "Модель" и одну или несколько вкладок разметки листа. Для оптимального использования области рисования можно отключить эти вкладки и пользоваться эквивалентными кнопками в строке состояния. Элемент управления для переключения между двумя вариантами интерфейса включён одним из пунктов в контекстное меню вкладок "Модель" и "Разметки листа", а также в контекстное меню кнопки "Модель/Разметка листа" в строке состояния.

Примечание Доступ ко всем опциям контекстного меню возможен только из вкладок.

Задание шрифтов приложения
  • Шрифт (диалоговое окно "Настройка", вкладка "Экран"). Изменение шрифтов, используемых в окне приложения и в текстовом окне. Данная настройка не влияет на отображение текста внутри чертежа.
Управление отображением закрепляемых окон

Закрепляемыми являются многие окна, включая палитру "Свойства", палитру инструментов и DesignCenter. Это означает, что их можно закреплять, прикреплять якорями или откреплять.

Изменения настроек для этих и других режимов обычно выполняются в контекстном меню, открывающемся нажатием правой кнопки на заголовке палитры или окна.

  • Изменение размера Чтобы изменить размер окна, перетащите кромку панели. Если окно разделено на области, то для изменения их размера перетаскивается разделитель областей.
  • Разрешить закрепление. Выберите этот вариант, если требуется закрепить или прикрепить якорем окно. Закреплённое окно присоединяется к одной стороне окна приложения, приводя к необходимости изменения размеров области рисования.
  • Привязать. Закрепление или прикрепление якорем окна или палитры к левой или правой стороне области рисования. Прикрепляемое якорем окно сворачивается и разворачивается, когда его пересекает курсор. Когда прикрепленное якорем окно открыто, его содержимое перекрывает область рисования. Не существует настройки, позволяющей держать открытым прикрепленное якорем окно. Перед тем как прикрепить якорем окно, необходимо выбрать режим "Разрешить закрепление").
  • Автоскрытие. Плавающее окно открывается и закрывается по мере перемещения по нему курсора. Если этот режим отменён, окно всё время остаётся открытым.
  • Прозрачность. Окно становится прозрачным, и через него видны находящиеся под ним объекты. Этот параметр доступен не для всех окон.
Управление отображением панелей

Чтобы отобразить или скрыть панели инструментов, нажмите правую кнопку мыши на любой из панелей инструментов для отображения их списка. Если после имени панели инструментов стоит флажок, панель отображается. Нажмите на имени панели в списке, чтобы установить или снять флажок.

Панель инструментов может быть плавающей или закрепленной. Закрепленные панели примыкают к одному из краев области рисования. Открепите панель, нажав кнопку мыши на ручке переноса (двойная полоса) и перетащив её в область рисования. Нажав кнопку мыши на заголовке, можно переместить панель или закрепить её. Измените размер плавающей панели инструментов, перетащив мышью кромку панели.

Фиксация местоположения панелей инструментов и закрепляемых окон

После того как панели упорядочены и окна закреплены, назначены плавающими или привязаны нужным образом, можно зафиксировать их положение. Зафиксированные панели инструментов и окна могут оставаться открытыми и закрытыми, к ним можно добавлять элементы или удалять их. Чтобы временно их разблокировать, удерживайте нажатой клавишу CTRL.

См. также

Настройка интерфейса пользователя в документе Руководство по адаптации


Задание параметров интерфейса - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Настройка параметров

Для настройки цветов элементов окна приложения

Перевод вкладок "Модель" и "Разметка листа" в кнопки строки состояния

Включение режима использования вкладок "Модель" и "Разметка листа"

Изменение шрифта в окне команд

Фиксация положения и размеров панелей инструментов и закрепляемых окон

Привязка закрепляемого окна

Перевод привязанного окна в плавающее

Изменение вида базовой точки значка якоря

Закрепление окна или палитры

Открепление окна или палитры

Включение и отключение режима "Авто-скрытие" для плавающей палитры или окна.

Изменение вида окна "Просмотр переходов"


Настройка параметров - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Настройка параметров

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" выберите нужную вкладку.
  3. Настройте параметры, как это требуется для работы.
  4. Выполните одно или оба следующих действия:
    • Нажмите кнопку "Применить" для сохранения текущих настроек в системном реестре.
    • Нажмите кнопку "OK" для сохранения текущих настроек в системном реестре и закрытия диалогового окна "Настройка".

Ввод команды: НАСТРОЙКА


Для настройки цветов элементов окна приложения - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Для настройки цветов элементов окна приложения

  1. Выберите "Сервис" » "Настройка".
  2. На вкладке "Экран" диалогового окна "Настройка" выберите "Цвета".
  3. В диалоговом окне "Цветовая гамма окна чертежа" выберите контекст, а затем элемент интерфейса, который нужно изменить.
  4. Выберите нужный цвет в списке "Цвета".

    5. Для задания пользовательского цвета выберите параметр "Выбор цвета..." из списка цветов.

  5. Если требуется заменить цвета на цвета по умолчанию, выберите "Восстановить текущий элемент", "Восстановить текущий контекст" или "Восстановить все контексты"
  6. Нажмите кнопки "Применить" и "Закрыть" для сохранения текущих настроек в системном реестре и закрытия диалогового окна.
  7. Нажмите кнопку "OK", чтобы закрыть диалоговое окно "Настройка".

Ввод команды: НАСТРОЙКА


Перевод вкладок "Модель" и "Разметка листа" в кнопки строки состояния - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Перевод вкладок "Модель" и "Разметка листа" в кнопки строки состояния

  • Нажмите правую кнопку мыши на вкладке "Модель" или вкладке разметки листа. Выберите опцию "Скрыть вкладки разметки листа и модели".


Включение режима использования вкладок "Модель" и "Разметка листа" - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Включение режима использования вкладок "Модель" и "Разметка листа"

  • В строке состояния нажмите правую кнопку мыши на вкладке "Модель" или "Разметка листа". Выберите опцию "Отобразить вкладки разметки листа и модели".


Изменение шрифта в окне команд - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Изменение шрифта в окне команд

  1. Выберите "Сервис" » "Настройка".
  2. На вкладке "Экран" диалогового окна "Настройка" нажмите кнопку "Шрифты", находящуюся под элементами окна.
  3. В диалоговом окне "Шрифт командной строки" выберите подходящий шрифт, начертание и размер.

    4. Образец текущих настроек отображается под заголовком "Образец шрифта командной строки".

  4. Нажмите кнопки "Применить" и "Закрыть" для сохранения текущих настроек в системном реестре и закрытия диалогового окна.
  5. Нажмите кнопку "OK", чтобы закрыть диалоговое окно "Настройка".

Ввод команды: НАСТРОЙКА


Фиксация положения и размеров панелей инструментов и закрепляемых окон - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Фиксация положения и размеров панелей инструментов и закрепляемых окон

  1. Выберите "Окно" » "Место фиксации".
  2. Установите флажки в одном или нескольких из следующих окошек или выберите "Все" » "Зафиксировано:"
    • Плавающие панели инструментов
    • Закрепленные панели инструментов
    • Плавающие окна
    • Закрепленные окна

Значок фиксации в области уведомлений указывает, зафиксированы ли панели инструментов или закрепляемые окна. Для временной отмены их фиксации нужно удерживать нажатой клавишу CTRL.

Ввод команды: LOCKUI

Контекстное меню: Нажмите правую кнопку мыши на значке фиксации в панели задач. Установите флажок у одного или нескольких следующих параметров или выберите "Все" » "Заблокировано".


Привязка закрепляемого окна - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Привязка закрепляемого окна

  1. Нажмите правую кнопку мыши на плавающем окне или заголовке палитры. Выберите "Разрешить закрепление".
  2. Нажмите правую кнопку мыши на окне или заголовке палитры. Выберите "Прикрепить якорем справа" или "Прикрепить якорем слева".


Перевод привязанного окна в плавающее - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Перевод привязанного окна в плавающее

Выполните одно из следующих действий:

  • Если привязанное окно открыто, оттащите заголовок окна от базовой точки значка якоря.
  • Нажмите дважды на значке якоря.
  • Правую кнопку мыши нажмите на заголовке окна. Снимите флажок "Разрешить закрепление".

Окно отделяется от соответствующей стороны области рисования.


Изменение вида базовой точки значка якоря - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Изменение вида базовой точки значка якоря

Выполните одно из следующих действий:

  • Для представления привязанных окон в виде значка нажмите правую кнопку мыши на базовой точке значка якоря. Выберите "Только значки".
  • Для отображения как значка, так и текста для заякоренных окон, нажмите правую кнопку мыши на базовой точке значка якоря. Выберите "Значок и текст".


Закрепление окна или палитры - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Закрепление окна или палитры

  1. Нажмите правую кнопку мыши на плавающем окне или заголовке палитры. Убедитесь в том, что выбран режим "Разрешить закрепление".
  2. Поместите курсор на заголовок и удерживайте левую кнопку устройства указания.
  3. Перетащите окно или палитру в место закрепления в правой или левой стороне области рисования.
  4. Когда контур окна отобразится в области закрепления, отпустите кнопку.

    5. Примечание Для помещения панели в область закрепления без выполнения закрепления нужно во время перетаскивания удерживать нажатой клавишу CTRL.


Открепление окна или палитры - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Открепление окна или палитры

Воспользуйтесь одним из следующих способов:

  • Дважды нажмите кнопку мыши на ручке переноса (двойная полоса) вверху или внизу окна.
  • Поместите курсор на ручке переноса вверху или внизу окна, удерживайте левую кнопку устройства указания и перетащите окно из места закрепления.


Включение и отключение режима "Авто-скрытие" для плавающей палитры или окна. - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Включение и отключение режима "Авто-скрытие" для плавающей палитры или окна.

Выполните одно из следующих действий:

  • Нажмите правую кнопку мыши на плавающей палитре или окне. Выберите "Авто-скрытие".
  • На заголовке плавающей палитры или окна нажмите кнопку "Авто-скрытие".

    • Если выбран режим "Авто-скрытие", плавающие окна разворачиваются и сворачиваются при пересечении их курсором. Если этот режим отменён, постоянно отображается полностью открытое окно.

    Примечание Эта процедура применима к инструментальной палитре, DesignCenter, палитре свойств и нескольким другим палитрам.


Изменение вида окна "Просмотр переходов" - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Изменение вида окна "Просмотр переходов"

  1. В командной строке введите параметрыпв.
  2. В диалоговом окне "Просмотр переходов" выберите один или несколько параметров из числа указанных ниже.
    • Включить анимацию для перемещения и увеличения. Включается плавный переход из одного вида в другой при панорамировании и увеличении.
    • Включить анимацию при повороте вида. Включается плавный переход при изменении угла обзора.
    • Включить анимацию во время сценариев. Включается плавный переход во время выполнения сценариев.
  3. Задайте скорость перехода, перемещая ползунок.
  4. Чтобы производительность не уменьшилась, установите для отображения плавной смены вида минимальную частоту кадров в секунду. Если отображение плавных переходов не поддерживает эту скорость, используется мгновенный переход.
  5. Нажмите "ОК".


Задание параметров интерфейса - Команды

Настройка рабочей среды
Настройка рабочей среды
Задание параметров интерфейса
Понятия
Процедуры
Команды

Команды
ГРАФНАСТР | Обеспечивает конфигурационные установки системы 3D-графики
ЖУРНАЛВКЛ | Включение записи содержимого текстового окна в файл
ЖУРНАЛОТКЛ | Закрывает текстовое окно файла журнала, открытое командой ЖУРНАЛВКЛ.
НАСТРВИД | Задание точности аппроксимации объектов на текущем видовом экране
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПАРАМЕТРЫПВ | Отображает изменение в виде плавного перехода
ЧИСТЭКРВКЛ | Убирает с экрана панели инструментов и закрепляемые окна (за исключением командной строки)
ЧИСТЭКРОТКЛ | Восстанавливает отображение панели инструментов и закрепляемых окон (за исключением командной строки)
Системные переменные
CALCINPUT | Управление вычислением математических выражений и глобальных констант в полях для ввода текстовых или числовых данных
CURSORSIZE | Определение размера перекрестья в процентном отношении от размера экрана
DCTCUST | Отображает путь и имя файла текущего настраиваемого орфографического словаря.
DCTMAIN | Отображает имя файла текущего основного орфографического словаря.
DEFPLSTYLE | Указывает стиль печати по умолчанию для новых объектов.
DRAGMODE | Управляет отображением объектов при перетаскивании
EXTNAMES | Устанавливает параметры для имен именованных объектов (например, типов линий и слоев), которые хранятся в таблицах описаний
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
GRIPBLOCK | Управляет ручками внутри блоков
GRIPCOLOR | Управляет цветом невыбранных ручек
GRIPHOT | Управляет цветом выбранных ручек
INSUNITS | Указывает значение в единицах чертежа для автоматического масштабирования блоков, изображений или вставленных или прикрепленных к чертежу внешних ссылок
INSUNITSDEFSOURCE | Устанавливает единицы измерения исходного содержимого, когда переменная INSUNITS имеет значение, равное 0
INSUNITSDEFTARGET | Устанавливает единицы измерения в целевом чертеже, когда переменная INSUNITS имеет значение, равное 0
INTELLIGENTUPDATE | Управляет скоростью обновления графики
ISAVEBAK | Повышает скорость последовательных сохранений, особенно для больших чертежей
ISAVEPERCENT | Определяет количество неиспользуемого дискового пространства, допустимого в файле чертежа
LAYOUTREGENCTL | Указывает режим обновления списка отображения на вкладке "Модель" и вкладках "Лист"
LOCALE | Отображает код, указывающий текущее место
LOCALROOTPREFIX | Сохраняет полный путь к корневой папке, в которую были установлены локальные адаптируемые файлы
LOCKUI | Блокирует положение и размер панелей инструментов и плавающих окон, таких как "DesignCenter" и "Палитра свойств"
LOGFILEMODE | Указывает, производится ли запись содержимого текстового окна в файл журнала.
LOGFILENAME | Задает путь и имя файла журнала текстового окна для текущего чертежа
LOGFILEPATH | Задает путь к файлам журналов текстового окна для всех чертежей в сеансе
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
OLEQUALITY | Устанавливает качества печати объектов OLE по умолчанию
OLESTARTUP | Управляет загрузкой исходного приложения, в котором был создан внедренный OLE объект, при печати
OSNAPCOORD | Управляет приоритетом ввода координат с клавиатуры над текущими режимами привязки
PAPERUPDATE | Управление выводом диалогового окна предупреждения при попытке вывести на печать лист, формат которого не совпадает с форматом, заданным по умолчанию в файле параметров плоттера
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
PICKBOX | Устанавливает размер прицела выбора объектов (в пикселах)
PICKDRAG | Управляет методом создания рамки выбора
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
PSTYLEPOLICY | Управляет ассоциативностью свойства цвета объекта с его стилем печати
QTEXTMODE | Управляет отображением текста
RASTERPREVIEW | Управляет сохранением вместе с чертежом образцов для просмотра в формате BMP
SAVEFILE | Сохраняет имя текущего файла автоматического сохранения
SAVEFILEPATH | Указывает путь к папке всех файлов автоматического сохранения для текущего сеанса
SAVETIME | Задает интервал автоматического сохранения (в минутах)
SDI | Управляет режимом работы программы (одно- или многодокументный интерфейс)
SPLINESEGS | Задает количество сегментов линии, генерируемых для каждой сглаженной сплайном полилинии, созданной с помощью параметра "Сплайн" команды ПОЛРЕД
TDUSRTIMER | Сохраняет счетчик времени работы пользователя
TOOLTIPMERGE | Объединяет подсказки на чертеже в одну подсказку
TOOLTIPS | Управляет отображением подсказок
VISRETAIN | Управляет свойствами зависимых от внешних ссылок слоев.
VTFPS | Задает минимальную скорость плавного перехода видов в кадрах в секунду
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание рабочего пространства для конкретной задачи - Понятия

Пользовательский интерфейс
Настройка рабочей среды
Создание рабочего пространства для конкретной задачи
Понятия
Процедуры
Команды

Рабочие пространства представляют собой наборы меню, инструментальных панелей и палитр, сгруппированных и упорядоченных специальным образом для создания среды рисования, отвечающей целям конкретной задачи.

При использовании рабочего пространства отображаются только необходимые для конкретной задачи меню, инструментальные панели и палитры. Кроме этого в некоторых рабочих пространствах автоматически отображается пульт управления - специальная палитра с управляющими панелями, характерными для конкретной задачи.

Подробные сведения об использовании пульта управления см. в Пульт управления.

Предусмотрено удобное переключение между рабочими пространствами. В программном продукте заранее определены следующие рабочие пространства, ориентированные на конкретную задачу:

  • 3D моделирование
  • Классический AutoCAD

Например, при создании 3D моделей можно использовать рабочее пространство "3D моделирование", содержащее только ориентированные на работу с 3D объектами инструментальные панели, меню и палитры. Элементы интерфейса, не являющиеся необходимыми для 3D моделирования, скрываются, максимально освобождая область экрана, доступную для работы.

После того, как в область построения чертежа внесены изменения (например перемещены, скрыты, отображены панели инструментов или группы палитр) и требуется сохранить настройки отображения для последующего использования, можно сохранить текущие параметры рабочего пространства.

Переключение рабочих пространств

Рабочие пространства можно переключать в зависимости от выполняемых задач.

Создание и изменение рабочих пространств

Предусмотрена возможность создания собственных рабочих пространств и изменение рабочих пространств по умолчанию. Для создания или изменения рабочего пространства применяется любой из следующих способов:

  • Выведите на экран, уберите с экрана или переупорядочите инструментальные панели и окна, затем сохраните текущее рабочее пространство из панели "Рабочие пространства" или из меню "Окно" либо с помощью команды РАБОЧЕЕ ПРОСТРАНСТВО.
  • Для более обширных изменений откройте диалоговое окно "Настройка интерфейса пользователя".

В диалоговом окне "Параметры рабочих пространств" предусмотрена возможность управления порядком отображения сохранённых рабочих пространств и другими настройками.

Примечание Подробнее о создании или редактировании рабочих пространств и о способах, которыми панели и меню взаимодействуют с рабочими пространствами, см. Создание рабочего пространства для конкретной задачи и Настройка рабочего пространства в Руководстве по адаптации.

Выберите "Образец рабочего пространства"

Поэкспериментируйте с образцом рабочего пространства, входящего в программный продукт. Это стандартное рабочее пространство иллюстрирует возможность использования рабочего пространства для ускорения работы.

Образец рабочего пространства находится в:

C:\Documents and Settings\<имя пользователя>\Application Data\Autodesk\AutoCAD 2007\R17.0\<язык продукта>\Support\acadSampleWorkspaces.CUI

Для использования образца рабочего пространства нужно сначала перенести его в главный файл настройки (НПИ). Для получения дополнительной информации о переносе рабочего пространства см. раздел Перенос и передача настроек в документе Руководство по адаптации.

Рабочие пространства и профили

Рабочие пространства работают со средствами управления средой рисования, обеспечиваемыми профилями, и дополняют эти средства.

Рабочие пространства управляют отображением в области рисования меню, панелей и инструментальных палитр. При включении или переключении рабочего пространства изменяется внешний вид области построения чертежа. Управление рабочими пространствами осуществляется из диалогового окна "Настройка интерфейса пользователя".

Профили сохраняют параметры среды, включая разные пользовательские параметры, настройки режимов рисования, пути и другие значения. Профили обновляются при каждом изменении параметра, настройки или другого значения. Управление пользовательскими профилями выполняется в диалоговом окне "Настройка".

Примечание При внесении изменений в область построения изменения сохраняются в профиле и, независимо от параметров рабочего пространства, отображаются после следующего запуска программы. Изменения профиля не будут автоматически сохраняться в рабочем пространстве до тех пор, пока в диалоговом окне "Параметры рабочего пространства" не будет выбран параметр "Автоматически сохранять изменения". Для сохранения настроек профилей в рабочем пространстве выберите "Окно" » "Рабочие пространства" » "Сохранить текущее как".

Дополнительную информацию о профилях см. в Сохранение и восстановление параметров интерфейса (профилей).


Создание рабочего пространства для конкретной задачи - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Создание рабочего пространства для конкретной задачи
Понятия
Процедуры
Команды

Переключение рабочих пространств

Изменение параметров рабочего пространства

Сохранение рабочего пространства


Переключение рабочих пространств - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Создание рабочего пространства для конкретной задачи
Понятия
Процедуры
Команды

Переключение рабочих пространств

  1. Выберите "Окно" » "Рабочие пространства".
  2. Выберите из списка рабочее пространство, на которое необходимо переключиться.

Ввод команды: РАБОЧЕЕ ПРОСТРАНСТВО


Изменение параметров рабочего пространства - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Создание рабочего пространства для конкретной задачи
Понятия
Процедуры
Команды

Изменение параметров рабочего пространства

  1. Выберите "Окно" » "Рабочие пространства" » "Параметры рабочего пространства".
  2. В диалоговом окне "Параметры рабочего пространства" внесите необходимые изменения в параметры.
  3. Нажмите "ОК".

Ввод команды: РАБОЧЕЕ ПРОСТРАНСТВО

Ввод команды: РППАРАМЕТРЫ


Сохранение рабочего пространства - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Создание рабочего пространства для конкретной задачи
Понятия
Процедуры
Команды

Сохранение рабочего пространства

  1. В области рисования создайте среду рисования путем перемещения, удаления или отображения тех панелей инструментов и закрепляемых окон, которые потребуются в будущем.
  2. Выберите "Окно" » "Рабочие пространства" » "Сохранить текущее как".
  3. В диалоговом окне "Сохранить рабочее пространство" введите имя нового рабочего пространства или выберите имя из раскрывающегося списка.
  4. Нажмите кнопку "Сохранить".

Ввод команды: РАБОЧЕЕ ПРОСТРАНСТВО

Ввод команды: РПСОХРАНИТЬ


Создание рабочего пространства для конкретной задачи - Команды

Настройка рабочей среды
Настройка рабочей среды
Создание рабочего пространства для конкретной задачи
Понятия
Процедуры
Команды

Команды
РПСОХРАНИТЬ | Сохранение рабочего пространства
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение и восстановление параметров интерфейса (профилей) - Понятия

Пользовательский интерфейс
Настройка рабочей среды
Сохранение и восстановление параметров интерфейса (профилей)
Понятия
Процедуры
Команды

В профилях хранятся параметры среды рисования. Можно создать профили для разных пользователей или проектов и организовать их совместное использование посредством импорта и экспорта их в виде файлов.

Параметры хранятся в профилях в следующем виде:

  • Пути по умолчанию для поиска файлов и для файла проекта
  • Местоположение файла шаблона
  • Исходная папка, выбираемая в диалоговых окнах навигации к файлам
  • Файл типов линий по умолчанию и файл образцов штриховки по умолчанию
  • Настройки по умолчанию для принтера

Информация о профиле обычно задаётся на вкладке "Профили" диалогового окна "Настройка", хранится в системном реестре и может быть экспортирована в текстовый файл (файл ARG).

Применение профилей для компьютеров общего пользования или разных проектов

На вкладке "Профили" в диалоговом окне "Настройка" задайте параметры среды рисования и сохраните в качестве профиля. Различные пользователи, входящие в систему под одним именем, могут загружать свои настройки из различных профилей. Профили можно использовать также для сохранения настроек, присущих различным проектам. По умолчанию текущие параметры хранятся в профиле с именем UNNAMEDPROFILE. Имена текущего профиля и чертежа отображаются в диалоговом окне "Настройка".

Обмен профилями между компьютерами

Данные из сохраненного профиля можно экспортировать или импортировать в виде файла формата ARG на различные компьютеры. Это удобно для копирования, восстановления или стандартизации проектно-ориентированных рабочих сред по сети.

Если изменения, внесённые в текущий профиль в сеансе работы, нужно сохранить в файле формата ARG, необходимо выполнить повторный экспорт профиля. При экспорте профиля в текущий файл профиля файл ARG обновляется, и в него записываются новые параметры.

Подробнее о профилях см. описание команды НАСТРОЙКА в документе Справочник команд.


Сохранение и восстановление параметров интерфейса (профилей) - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Сохранение и восстановление параметров интерфейса (профилей)
Понятия
Процедуры
Команды

Назначение текущего профиля

Сохранение профиля

Назначение текущего профиля до запуска программы


Назначение текущего профиля - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Сохранение и восстановление параметров интерфейса (профилей)
Понятия
Процедуры
Команды

Назначение текущего профиля

  1. Выберите "Сервис" » "Настройка".
  2. На вкладке "Профили" диалогового окна "Настройка" выберите профиль, который нужно сделать текущим.
  3. Нажмите кнопку "Установить".
  4. Нажмите "ОК".

Ввод команды: НАСТРОЙКА


Сохранение профиля - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Сохранение и восстановление параметров интерфейса (профилей)
Понятия
Процедуры
Команды

Сохранение профиля

  1. Выберите "Сервис" » "Настройка".
  2. На вкладке "Профили" диалогового окна "Настройка" выберите "Добавить в список".
  3. В диалоговом окне "Добавление профиля" введите имя профиля и его описание.
  4. Нажмите кнопки "Применить" и "Закрыть" для сохранения текущих настроек в системном реестре и закрытия диалогового окна.
  5. Нажмите "ОК".

Ввод команды: IONS


Назначение текущего профиля до запуска программы - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Сохранение и восстановление параметров интерфейса (профилей)
Понятия
Процедуры
Команды

Назначение текущего профиля до запуска программы

  1. На рабочем столе Windows нажмите правую кнопку мыши на значке программы. Выберите "Свойства".
  2. В поле "Объект" вкладки "Ярлык" диалогового окна "Свойства " программы AutoCAD после текущей целевой папки введите/p текущий профиль. Например, чтобы сделать текущим профиль User12, следует ввести в поле "Объект" следующую строку.

    3. "c:\Program Files\<имя текущей версии>\acad.exe"/p user12

  3. Нажмите "ОК".

    4. Указанный таким образом профиль будет текущим при каждом запуске программы.


Сохранение и восстановление параметров интерфейса (профилей) - Команды

Настройка рабочей среды
Настройка рабочей среды
Сохранение и восстановление параметров интерфейса (профилей)
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
CPROFILE | Отображает имя текущего профиля
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка запуска - Понятия

Пользовательский интерфейс
Настройка рабочей среды
Настройка запуска
Понятия
Процедуры
Команды

Индивидуальную процедуру запуска программы для каждого проекта можно настроить с помощью аргументов командной строки.

Параметры для запуска программы задаются с помощью аргументов командной строки. Например, можно запустить сценарий, открыть новый чертёж на основе указанного шаблона и отобразить заданный вид при открытии чертежа. При помощи аргументов командной строки можно также создать несколько ярлыков с различными параметрами запуска программы.

Аргументы командной строки являются параметрами, которые добавляются к командной строке acad.exe, обрабатываемой в ярлыке Microsoft® Windows® в диалоговом окне Windows "Выполнить". В одной командной строке может присутствовать несколько аргументов. Все допустимые аргументы перечислены ниже.

/b

Имя пакетного файла

Указывает сценарий, который запускается после запуска программы (b указывает на процесс пакетной обработки). В сценариях может выполняться настройка параметров для нового чертежа. Файл должен иметь расширение SCR.

/t

Имя файла шаблона

Создаётся новый чертёж на основе шаблона или прототипа чертежа. Файл должен иметь расширение DWT.

/c

Папка конфигурации

Указывается путь к файлу конфигурации оборудования, который должен использоваться. Можно задать здесь папку или конкретное имя файла. Файл должен иметь расширение CFG.

Если переключатель /c не указан, то происходит поиск в папке самого приложения, и для определения файла конфигурации и пути к нему используются переменные среды ACADCFGW или ACADCFG.

/v

Имя вида

Задаётся вид чертежа, отображаемый при запуске.

/ld

Приложение ARX или DBX

Загружается приложение ARX или DBX. Нужно использовать следующий формат:

<путь>\<имя_файла>.ARX

Если имя файла или путь содержат пробелы, следует заключить их в двойные кавычки. Если путь не указан, для поиска используется путь к программе.

/s

Папки вспомогательных файлов

Задаются папки вспомогательных файлов, отличные от текущей. Во вспомогательных файлах хранятся текстовые шрифты, меню, AutoLISP-программы, типы линий и образцы штриховок, используемые в чертежах. Можно указывать не более 15 папок. Имена папок разделяются точкой с запятой.

/r

Устройство указания по

умолчанию

Восстановление системного устройства указания, принятого по умолчанию. Создается новый файл настройки (acad2007.cfg), а предыдущий переименовывается acad2007.cfg в acad.bak.

/nologo

Отключение экрана с логотипом AutoCAD

Программа запускается программу без вывода экрана с логотипом.

/p

Заданный пользователем профиль реестра

профиль для запуска

программы

Задаётся определяемый пользователем профиль реестра для запуска программы. Указанный профиль действует только в текущем сеансе программы. В данном сеансе можно задать другой текущий профиль в диалоговом окне "Настройка".

Для этого в диалоговом окне "Настройка" предназначена вкладка "Профили", где можно создавать и импортировать файлы профилей. С помощью параметра /p можно задавать только профили, отображающиеся в списке диалогового окна "Настройка". Если указанный профиль не существует, используется текущий профиль.

/nossm

Без окна

"Диспетчер подшивок"

Подавляется вывод на экран диалогового окна "Диспетчер подшивок" при запуске программы.

/set

Подшивка

Загружается указанная подшивка при запуске программы. Нужно использовать следующий формат:

<путь>\<файл_данных_подшивки>.DST

/w

Рабочее пространство по умолчанию

Определяется, какое рабочее пространство из загруженных файлов НПИ должно быть восстановлено при запуске.

/pl

Фоновая печать/публикация

Публикуется файл описаний наборов чертежей (DSD) в фоновом режиме. Нужно использовать следующий формат:

<путь>\<файл описаний наборов чертежей>.DSD

Командная строка вызова программы с использованием аргументов выглядит следующим образом:

"устройство:путь\ acad.exe" ["имя чертежа"] [/аргумент "имя"]

За каждым аргументом должен следовать символ пробела, а затем - имя файла, пути или вида в кавычках. Приведённая в следующем примере командная строка запускает программу из папки AutoCAD 2007, после чего открывается шаблон arch1.dwt, восстанавливается именованный вид PLAN1 и выполняется запуск файла сценария.scr.

"d:\ AutoCAD 2007\acad.exe”/t "d:\AutoCAD 2007\template\arch1" /v "plan1" /b "startup"

Параметры среды обрабатываются следующим образом:

  • Если параметр задается аргументом в командной строке, то его значение имеет приоритет перед значениями, установленными в диалоговом окне "Настройка" или с помощью переменной среды.
  • Если аргумент в командной строке не задан, используется значение соответствующего параметра диалогового окна "Настройка".
  • Если параметр не задан ни в командной строке, ни в диалоговом окне "Настройка", то используется значение соответствующей переменной среды.

Примечание Аргументы командной строки и переменные среды изменяют параметры, заданные с помощью диалогового окна "Настройка", только для текущего сеанса работы. Эти изменения не отражаются в системном реестре.


Запуск программы с аргументом командной строки - Процедуры

Пользовательский интерфейс
Настройка рабочей среды
Настройка запуска
Понятия
Процедуры
Команды

Запуск программы с аргументом командной строки

  1. На рабочем столе Windows нажмите правую кнопку мыши на значке программы. Выберите "Свойства".
  2. В поле "Объект " вкладки "Ярлык" диалогового окна "Свойства" программы AutoCAD измените параметры атрибута, используя следующий синтаксис.

    3. "устройство:путь\ acad.exe" ["имя чертежа"] [/аргумент "имя"]

    Допустимы следующие аргументы:

    /b | Имя пакета (b обозначает пакетный процесс)
/t | Имя файла шаблона
/c | Папка конфигурации
/v | Имя вида
/s | Папки вспомогательных файлов
/r | Стандартное системное устройство указания
/nologo | Отключение экрана с логотипом AutoCAD
/p | Задаваемый пользователем профиль реестра
/nossm | Без диалогового окна "Диспетчер подшивок"
/set | Имя подшивки
/w | Рабочее пространство по умолчанию
/pl | Фоновая печать/публикация для файла описаний наборов чертежей (DSD)

    Например, введите "d:\ AutoCAD 2007\ acad.exe" /t "d:\ AutoCAD 2007\template\arch1" /v "plan1" /b "startup"

  3. Нажмите "ОК".


Настройка запуска - Команды

Настройка рабочей среды
Настройка рабочей среды
Настройка запуска
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Инструментальные палитры - Понятия

Пользовательский интерфейс
Инструментальные палитры
Понятия
Процедуры
Команды

Инструментальные палитры представлены отдельными вкладками в окне "Палитры инструментов - все палитры". Они являются эффективным средством упорядочения, распределения и размещения блоков, штриховок и других инструментов. Палитры могут содержать инструменты, предоставленные сторонними разработчиками.

  • Создание инструментов из объектов и работа с ними
    Инструмент может быть создан простым перетаскиванием объектов из чертежа в область инструментальной палитры. С помощью такого инструмента можно впоследствии быстро строить объекты с теми же свойствами, что и исходный объект.
  • Создание и использование инструментов-команд
    На палитрах можно создавать инструменты, выполняющие одну команду или последовательность команд.
  • Изменение настроек инструментальных палитр
    Параметры и настройки инструментальных палитр могут быть изменены с помощью контекстных меню. Следует отметить, что вид контекстных меню зависит от того, в какой области инструментальной палитры нажать кнопку мыши.
  • Изменение свойств инструментов
    Можно изменять свойства любого из инструментов на палитре.
  • Адаптация инструментальных палитр
    Существует несколько способов добавления инструментов в палитру.
  • Организация инструментальных палитр
    Инструментальные палитры можно группировать по темам, а также задавать, какая группа палитр будет отображаться на экране.
  • Сохранение и совместное использование инструментальных палитр
    Инструментальные палитры можно экспортировать и импортировать как файлы.


Инструментальные палитры - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Понятия
Процедуры
Команды

Открытие окна "Инструментальные палитры"

Создание инструмента из объекта текущего чертежа

Использование инструмента, созданного из геометрического объекта

Использование инструмента, созданного из размера

Использование инструмента из подменю палитры

Добавление или удаление подменю

Настройка подменю инструмента

Использование инструмента, созданного из штриховки

Использование инструмента, созданного из градиентной заливки

Использование инструмента, созданного из блока, внешней ссылки или растрового изображения

Запрос угла поворота при вставке блока или внешней ссылки из инструментальной палитры

Создание инструмента-команды на основе кнопки инструментальной панели.

Создание инструмента-команды из окна "Настройка интерфейса пользователя"

Для создания инструмента-команды, выполняющего несколько команд или специальные команды (расширенные)

Использование инструмента-команды

Изменение режима сворачивания и разворачивания окна инструментальных палитр

Изменение степени прозрачности окна инструментальных палитр

Изменение стиля отображения значков в окне инструментальных палитр

Вывод информации о свойствах инструмента из палитры

Изменение свойства инструмента на палитре

Обновление изображения инструмента-блока на инструментальной палитре

Изменение изображения инструмента на палитре

Возврат к используемым по умолчанию изображению, названию и пояснению для инструмента-подменю

Создание инструментальной палитры

Создание инструментальной палитры из папки или чертежа

Переименование инструментальной палитры

Удаление инструментальной палитры

Изменение расположения инструментальной палитры

Добавление текста на инструментальную палитру

Добавление разделительной линии на инструментальную палитру

Сортировка элементов на инструментальной палитре

Создание группы инструментальных палитр

Добавление инструментальной палитры в группу палитр

Исключение инструментальной палитры из группы палитр

Вывод группы инструментальных палитр на экран

Удаление группы инструментальных палитр

Удаление всех групп инструментальных палитр

Переименование группы инструментальных палитр

Переупорядочение группы палитр

Создание группы инструментальных палитр, вложенной в другую группу

Копирование и вставка палитры из одной группы в другую

Изменение порядка расположения палитр внутри группы

Изменение порядка расположения палитр, когда все они выведены на экран

Вывод всех инструментальных палитр на экран


Инструментальные палитры - Команды

Пользовательский интерфейс
Инструментальные палитры
Понятия
Процедуры
Команды
Команды
АДАПТАЦИЯ | Изменяет инструментальные палитры
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
ИНСТРПАЛОТКЛ | Закрытие окна инструментальных палитр
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
INSUNITSDEFSOURCE | Устанавливает единицы измерения исходного содержимого, когда переменная INSUNITS имеет значение, равное 0
INSUNITSDEFTARGET | Устанавливает единицы измерения в целевом чертеже, когда переменная INSUNITS имеет значение, равное 0
PALETTEOPAQUE | Управляет прозрачностью окон
TPSTATE | Определяет активность окна инструментальных палитр
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание инструментов из объектов и работа с ними - Понятия

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Инструмент может быть создан простым перетаскиванием объектов из чертежа в область инструментальной палитры. С помощью такого инструмента можно впоследствии быстро строить объекты с теми же свойствами, что и исходный объект.

Инструментальные палитры представлены отдельными вкладками в специальном окне. Каждая инструментальная палитра содержит один или более инструментов. Инструменты можно создавать перетаскиванием объектов следующих типов (по одному объекту за одно перетаскивание):

  • отрезки, круги, полилинии и другие геометрические объекты
  • размеры
  • блоки
  • штриховки
  • сплошные заливки
  • градиентные заливки
  • растровые изображения
  • внешние ссылки

С помощью такого инструмента можно впоследствии быстро строить объекты с теми же свойствами, что и исходный объект. Примером инструмента, созданного с помощью перетаскивания объекта, может служить круг красного цвета, имеющий вес линий 0,05 мм. Так же можно создавать инструменты из имеющихся блоков и внешних ссылок.

При перетаскивании геометрического объекта или размера на палитру автоматически создается новый инструмент с соответствующим подменю. Например, инструменты, созданные на основе размеров, содержат подменю, с помощью которого можно наносить размеры различных типов. Подменю раскрываются нажатием на символе стрелки справа от значка инструмента на палитре. Независимо от того, какой инструмент выбран из подменю, построенный с его помощью объект имеет те же свойства, что и объект, по которому создано это подменю на палитре.

Для инструментов на основе блоков и внешних ссылок можно установить режим запроса угла поворота. Отсчет величины угла начинается с нуля. Запрос выводится в командной строке после того, как местоположение объекта указано мышью. В этом режиме угол поворота, заданный в диалоговом окне "Свойства инструмента", игнорируется при создании объекта в чертеже. Если пользователь перетаскивает блок или внешнюю ссылку либо вводит команду поворот по начальному запросу вставки командной строки, запрос об угле поворота не отображается.

Блоки, которые пользователь перетаскивает мышью из палитры в область рисования, можно масштабировать и поворачивать после того, как они размещены на чертеже. При перетаскивании блоков из инструментальной палитры можно использовать объектную привязку; шаговая привязка при этом подавляется. Для инструментов на основе блоков и штриховок можно задать вспомогательный масштаб. (Вспомогательный масштаб умножает текущее значение масштаба на масштаб печати или масштаб размера.)

Автоматическое масштабирование блоков

При перетаскивании блока из инструментальной палитры в чертёж он автоматически масштабируется в соответствии с соотношением заданных единиц блока и единиц текущего чертежа. Например, если для измерения единиц данного чертежа используются метры, а для измерения единиц блока сантиметры, коэффициент пересчёта составляет 1 к 100. Соответственно, при перетаскивании блока в чертёж его размеры меняются в пропорции 1:100.

Примечание В диалоговом окне "Настройка" на вкладке "Пользовательские" находятся раскрывающиеся списки "Единицы исходного чертежа" и "Единицы целевого чертежа". Выбранные в них единицы используются в том случае, если в исходном блоке или целевом чертеже для параметра "Единицы вставки" задано значение "Безразмерный".

См. также

Изменение свойств инструментов

Адаптация инструментальных палитр

Создание рабочего пространства для конкретной задачи

Добавление содержимого с помощью центра управления DesignCenter


Создание инструментов из объектов и работа с ними - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Открытие окна "Инструментальные палитры"

Создание инструмента из объекта текущего чертежа

Использование инструмента, созданного из геометрического объекта

Использование инструмента, созданного из размера

Использование инструмента из подменю палитры

Добавление или удаление подменю

Настройка подменю инструмента

Использование инструмента, созданного из штриховки

Использование инструмента, созданного из градиентной заливки

Использование инструмента, созданного из блока, внешней ссылки или растрового изображения

Запрос угла поворота при вставке блока или внешней ссылки из инструментальной палитры


Открытие окна "Инструментальные палитры" - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Открытие окна "Инструментальные палитры"

  • Выберите "Сервис" » "Палитры" » "Инструментальные палитры". Можно также нажать комбинацию клавиш CTRL+3.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Создание инструмента из объекта текущего чертежа - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Создание инструмента из объекта текущего чертежа

  1. Выберите объект в текущем чертеже, например размер, блок, штриховку, градиентную заливку, растровое изображение, внешнюю ссылку или любой геометрический объект.
  2. Перетащите объект из области рисования на инструментальную палитру и, не отпуская кнопку мыши, укажите местоположение инструмента на палитре.

    3. Черная линия на палитре отмечает возможное местоположение инструмента.

  3. Отпустите кнопку мыши.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Использование инструмента, созданного из геометрического объекта - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Использование инструмента, созданного из геометрического объекта

  1. Нажмите кнопку мыши на инструменте-объекте, расположенном на палитре.
  2. Следуйте подсказкам в командной строке, как если бы соответствующая команда была вызвана из меню "Рисование" или из панели инструментов.

    3. Построенный геометрический объект имеет те же свойства, что и выбранный инструмент на палитре.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Использование инструмента, созданного из размера - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Использование инструмента, созданного из размера

  1. Нажмите кнопку мыши на инструменте-размере, расположенном на палитре.
  2. Следуйте подсказкам в командной строке, как если бы соответствующая команда была вызвана из меню "Размеры" или из панели инструментов.

    3. Построенный размер будет иметь те же свойства и стиль, что и выбранный инструмент на палитре.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Использование инструмента из подменю палитры - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Использование инструмента из подменю палитры

  1. На палитре нажмите кнопку мыши на символе стрелки справа от нужного инструмента-размера или инструмента-объекта.
  2. Из раскрывшегося подменю выберите инструмент.
  3. Следуйте подсказкам в командной строке, как если бы соответствующая команда была вызвана из меню или из панели инструментов.

    4. Построенный объект будет иметь те же свойства, что и выбранный из раскрывшегося подменю инструмент.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Добавление или удаление подменю - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Добавление или удаление подменю

  1. Нажмите правую кнопку мыши на инструменте-объекте, расположенном на палитре, к которому необходимо добавить (или удалить) подменю. Выберите "Свойства".
  2. В диалоговом окне "Свойства инструмента" в разделе команд нажмите кнопку мыши в поле "Использование подменю".
  3. Из раскрывающегося списка выберите "Да", если нужно добавить подменю, и "Нет", если нужно удалить его.
  4. Нажмите "ОК".

    5. Примечание Если удалить подменю из инструмента, а затем вновь добавить его, то изображение значка, название и пояснение (всплывающая подсказка) для этого инструмента могут измениться по сравнению с исходными. В этом случае следует восстановить стандартные значения параметров: значок, название и пояснение инструмента. См. раздел Возврат к используемым по умолчанию изображению, названию и пояснению для инструмента-подменю .

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Настройка подменю инструмента - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Настройка подменю инструмента

  1. На палитре нажмите правую кнопку мыши на инструменте-объекте или инструменте-размере, подменю которого нужно настроить. Выберите "Свойства".
  2. В диалоговом окне "Свойства инструмента" в разделе команд нажмите кнопку мыши в поле "Настройка". Нажмите кнопку [...].
  3. В диалоговом окне "Параметры" выберите инструменты, которые должны отображаться в подменю. Нажмите "OK". (Необходимо выбрать хотя бы один инструмент.)
  4. В диалоговом окне "Свойства инструмента" нажмите "ОК".

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Использование инструмента, созданного из штриховки - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Использование инструмента, созданного из штриховки

  1. С помощью мыши перетащите инструмент-штриховку из палитры на чертёж в пределы объекта, который необходимо заштриховать.
  2. Отпустите кнопку мыши для выполнения штриховки объекта.

    3. Нанесенная штриховка будет иметь те же свойства и стиль, что и выбранный инструмент на палитре.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Использование инструмента, созданного из градиентной заливки - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Использование инструмента, созданного из градиентной заливки

  1. С помощью мыши перетащите инструмент градиентной заливки из палитры на чертёж в пределы объекта, к которому её следует применить.
  2. Отпустите кнопку мыши для применения градиентной закраски к объекту чертежа.

    3. Градиентная закраска будет иметь те же свойства и стиль, что и выбранный инструмент на палитре.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Использование инструмента, созданного из блока, внешней ссылки или растрового изображения - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Использование инструмента, созданного из блока, внешней ссылки или растрового изображения

  1. На инструментальной палитре нажмите кнопку мыши на элементе, который нужно вставить в чертёж: блоке, внешней ссылке или растровом изображении.
  2. Перетащите блок, ссылку или растровое изображение в нужное место чертежа.
  3. Отпустите кнопку мыши.

    4. Вставленный блок, внешняя ссылка или растровое изображение будут иметь те же свойства, что и выбранный инструмент на палитре.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Запрос угла поворота при вставке блока или внешней ссылки из инструментальной палитры - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Запрос угла поворота при вставке блока или внешней ссылки из инструментальной палитры

  1. Нажмите правую кнопку мыши на инструменте, созданном из блока или внешней ссылки. Выберите "Свойства".
  2. В группе "Вставка" диалогового окна "Свойства инструмента" нажмите кнопку мыши в строке "Запрос угла поворота".
  3. Выберите "Да" в раскрывающемся списке.
  4. Нажмите "ОК".

    5. Примечание В этом режиме угол поворота, заданный в диалоговом окне "Свойства инструмента", игнорируется при создании объекта в чертеже. Если перетаскивается блок или внешняя ссылка или, в ответ на подсказку командной строки при первоначальной вставке объекта, вводится поворот, запрос угла поворота не выводится.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Создание инструментов из объектов и работа с ними - Команды

Инструментальные палитры
Инструментальные палитры
Создание инструментов из объектов и работа с ними
Понятия
Процедуры
Команды

Команды
АДАПТАЦИЯ | Изменяет инструментальные палитры
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
ИНСТРПАЛОТКЛ | Закрытие окна инструментальных палитр
Системные переменные
INSUNITSDEFSOURCE | Устанавливает единицы измерения исходного содержимого, когда переменная INSUNITS имеет значение, равное 0
INSUNITSDEFTARGET | Устанавливает единицы измерения в целевом чертеже, когда переменная INSUNITS имеет значение, равное 0
PALETTEOPAQUE | Управляет прозрачностью окон
TPSTATE | Определяет активность окна инструментальных палитр
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и использование инструментов-команд - Понятия

Пользовательский интерфейс
Инструментальные палитры
Создание и использование инструментов-команд
Понятия
Процедуры
Команды

На палитрах можно создавать инструменты, выполняющие одну команду или последовательность команд.

Часто используемые команды можно помещать на инструментальную палитру. Если открыто диалоговое окно "Адаптация", инструменты можно перетаскивать на инструментальную палитру с панели инструментов или из редактора "Настройка интерфейса пользователя" (НПИ).

После того, как команда помещена на палитру в качестве инструмента, её можно вызывать нажатием кнопки мыши на инструменте. Например, можно поместить на палитру команду сохранения чертежа. Тогда эта команда при вызове с палитры будет выполняться так же, как если бы она была вызвана с помощью кнопки стандартной панели инструментов.

Можно также создать инструмент, выполняющий цепочку команд или специально настроенных команд, например процедуру на языке AutoLISP®, макрос, приложение или сценарий на языке VBA.

Примечание Хотя инструменты на палитрах можно активизировать при открытом редакторе "Настройка интерфейса пользователя" (НПИ), конечные результаты могут оказаться непредсказуемыми. Рекомендуется отказаться от использования инструментов палитры на то время, пока отображается редактор "Настройка интерфейса пользователя" (НПИ).


Создание и использование инструментов-команд - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание и использование инструментов-команд
Понятия
Процедуры
Команды

Создание инструмента-команды на основе кнопки инструментальной панели.

Создание инструмента-команды из окна "Настройка интерфейса пользователя"

Для создания инструмента-команды, выполняющего несколько команд или специальные команды (расширенные)

Использование инструмента-команды


Создание инструмента-команды на основе кнопки инструментальной панели. - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание и использование инструментов-команд
Понятия
Процедуры
Команды

Создание инструмента-команды на основе кнопки инструментальной панели.

  1. Убедитесь, что отображена панель инструментов, содержащая команду, которую необходимо добавить в палитру.

    2. Если требуемая панель инструментов не отображается, нажмите правую кнопку мыши на любой отображенной панели и выберите в списке другую панель.

  2. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Для открытия диалогового окна "Адаптация" выберите "Настроить палитры".

    3. Примечание Даже если во время этой процедуры не требуется выполнять никаких изменений в диалоговом окне "Адаптация", оно должно быть отображено во время добавления инструментов-команд на инструментальную палитру.

  3. В программе перетащите команду (кнопку), не отпуская кнопку мыши, с панели инструментов на инструментальную палитру; поместите курсор в то место палитры, куда требуется поместить инструмент.

    4. Черная горизонтальная линия указывает возможное местоположение инструмента.

  4. Отпустите кнопку мыши.
  5. В диалоговом окне "Адаптация" нажмите кнопку "Закрыть".

Ввод команды: АДАПТАЦИЯ


Создание инструмента-команды из окна "Настройка интерфейса пользователя" - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание и использование инструментов-команд
Понятия
Процедуры
Команды

Создание инструмента-команды из окна "Настройка интерфейса пользователя"

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Для открытия диалогового окна "Настройка интерфейса пользователя" (НПИ) выберите "Адаптация команд".

    2. Если окно "Палитры инструментов - все палитры" перекрывается, сместите в сторону окно НПИ.

  2. Из области "Списка команд" перетащите команду на инструментальную палитру и, не отпуская кнопку мыши, переместите курсор в то место палитры, куда требуется поместить инструмент.

    3. Черная горизонтальная линия указывает возможное местоположение инструмента.

  3. Отпустите кнопку мыши.
  4. В диалоговом окне НПИ нажмите кнопку "Закрыть".

Ввод команды: НПИ


Для создания инструмента-команды, выполняющего несколько команд или специальные команды (расширенные) - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание и использование инструментов-команд
Понятия
Процедуры
Команды

Для создания инструмента-команды, выполняющего несколько команд или специальные команды (расширенные)

  1. Нажмите правую кнопку мыши на заголовке инструментальной палитры. Выберите "Палитры инструментов - все палитры".
  2. В программе перетащите команду, не отпуская кнопку мыши, с панели инструментов на инструментальную палитру; поместите курсор в то место палитры, куда требуется поместить инструмент.
  3. Отпустите кнопку мыши.
  4. На инструментальной палитре нажмите на инструменте правую кнопку мыши. Выберите "Свойства".
  5. В диалоговом окне "Свойства инструмента" измените имя и описание последовательности команд на подходящее имя и описание строки, процедуры AutoLISP или сценария.
  6. В разделе команд, в поле "Командная строка", введите последовательность команд или специальные команды, такие как процедура AutoLISP, макрос или приложение VBA, или сценарий.
  7. Нажмите "ОК".

Ввод команды: АДАПТАЦИЯ


Использование инструмента-команды - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Создание и использование инструментов-команд
Понятия
Процедуры
Команды

Использование инструмента-команды

  1. Нажмите на инструменте-команде, расположенной на палитре.
  2. Следуйте подсказкам в командной строке.


Создание и использование инструментов-команд - Команды

Инструментальные палитры
Инструментальные палитры
Создание и использование инструментов-команд
Понятия
Процедуры
Команды

Команды
АДАПТАЦИЯ | Изменяет инструментальные палитры
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
ИНСТРПАЛОТКЛ | Закрытие окна инструментальных палитр
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение настроек инструментальных палитр - Понятия

Пользовательский интерфейс
Инструментальные палитры
Изменение настроек инструментальных палитр
Понятия
Процедуры
Команды

Параметры и настройки инструментальных палитр могут быть изменены с помощью контекстных меню. Следует отметить, что вид контекстных меню зависит от того, в какой области инструментальной палитры нажать кнопку мыши.

Можно закрепить окно инструментальных палитр у правого или левого края окна приложения. Для того, чтобы избежать закрепления окна, при его перемещении нужно держать нажатой клавишу CTRL .

Настройки инструментальной палитры сохраняются в профиле.

К этим настройкам относятся:

  • Разрешить закрепление. Включение/отключение возможности закрепления или привязки окон палитр. Если выбран этот режим, окно закрепляется, когда его перетаскивают в область закрепления на одной из сторон чертежа. Закреплённое окно присоединяется к одной стороне окна приложения, приводя к необходимости изменения размеров области рисования. При выборе этого режима становятся доступными пункты "Прикрепить якорем справа" и "Прикрепить якорем слева".
  • Прикрепить якорем слева или Прикрепить якорем справа. Палитра прикрепляется к базовой точке значка якоря с левой или правой стороны области рисования. Палитра сворачивается и разворачивается, когда её пересекает курсор. Когда привязанная палитра открыта, её содержимое перекрывает область рисования. Не существует настройки, позволяющей держать открытой привязанную палитру.
  • Авто-скрытие.Управление отображением плавающей палитры. Если выбран этот режим, то при уходе курсора за пределы палитры на экране остается только заголовок палитры. Если этот режим отменён, палитра всё время остаётся открытой.
  • Прозрачность. Задаётся параметр прозрачности окна "Палитры инструментов - все палитры", чтобы оно не скрывало находящиеся под ним объекты.
  • Виды. Изменение стиля отображения и размера значков на инструментальной палитре.


Изменение настроек инструментальных палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Изменение настроек инструментальных палитр
Понятия
Процедуры
Команды

Изменение режима сворачивания и разворачивания окна инструментальных палитр

Изменение степени прозрачности окна инструментальных палитр

Изменение стиля отображения значков в окне инструментальных палитр


Изменение режима сворачивания и разворачивания окна инструментальных палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Изменение настроек инструментальных палитр
Понятия
Процедуры
Команды

Изменение режима сворачивания и разворачивания окна инструментальных палитр

  • Нажмите кнопку "Авто-скрытие" в нижней части заголовка окна инструментальных палитр.

Режим разворачивания/сворачивания включён.

Режим разворачивания/сворачивания отключен.

Примечание Режим разворачивания/сворачивания доступен только в случае, когда окно инструментальных палитр не закреплено.


Изменение степени прозрачности окна инструментальных палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Изменение настроек инструментальных палитр
Понятия
Процедуры
Команды

Изменение степени прозрачности окна инструментальных палитр

  1. Нажмите правой кнопкой мыши на заголовке окна инструментальных палитр. Выберите "Прозрачность".
  2. В диалоговом окне "Прозрачность" задайте степень прозрачности для окна инструментальных палитр. Нажмите "ОК".

    3. Примечание Параметр прозрачности доступен только в том случае, когда окно инструментальных палитр не закреплено.


Изменение стиля отображения значков в окне инструментальных палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Изменение настроек инструментальных палитр
Понятия
Процедуры
Команды

Изменение стиля отображения значков в окне инструментальных палитр

  1. Нажмите правую кнопку мыши в незаполненной части окна инструментальных палитр. Выберите "Параметры отображения".
  2. В диалоговом окне "Параметры отображения" выберите вариант отображения элементов, который требуется задать. Можно также изменять размер значков.
  3. В списке "Применить для" выберите "Палитра - текущая" или "Палитры - все".
  4. Нажмите "ОК".


Изменение настроек инструментальных палитр - Команды

Инструментальные палитры
Инструментальные палитры
Изменение настроек инструментальных палитр
Понятия
Процедуры
Команды

Команды
АДАПТАЦИЯ | Изменяет инструментальные палитры
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
ИНСТРПАЛОТКЛ | Закрытие окна инструментальных палитр
Системные переменные
PALETTEOPAQUE | Управляет прозрачностью окон
TPSTATE | Определяет активность окна инструментальных палитр
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение свойств инструментов - Понятия

Пользовательский интерфейс
Инструментальные палитры
Изменение свойств инструментов
Понятия
Процедуры
Команды

Можно изменять свойства любого из инструментов на палитре.

После создания инструмента на палитре его свойства можно изменять. К таким свойствам, например, относятся масштаб блока при вставке в чертёж и угол поворота образца штриховки.

Для изменения свойств инструмента нажмите на нем правую кнопку мыши и в контекстном меню выберите пункт "Свойства объекта". Появляется диалоговое окно "Свойства инструмента". Это диалоговое окно содержит две категории свойств:

  • Свойства вставки или образца. Свойства, относящиеся к управлению объектом, например масштаб, поворот и угол.
  • Общие свойства.Отмена текущих настроек, относящихся к свойствам чертежа, например слой, цвет и тип линии.

Можно сворачивать и разворачивать категории свойств, нажимая на кнопках со стрелками.

Обновление значков инструментов

Значки инструментов палитры, созданных из блоков, внешних ссылок или растровых изображений, не обновляются автоматически при изменении их описаний. При изменении описания блока, ссылки или растрового изображения можно обновить и значок. Для этого нажмите правую кнопку мыши на инструменте в палитре и выберите команду "Обновить изображение инструмента". Перед обновлением изображения инструмента чертёж необходимо сохранить.

Другой способ заключается в удалении инструмента и последующей замене его с помощью модуля DesignCenter™.

Переопределения свойств инструментов

В некоторых случаях бывает необходимо присвоить инструменту специфические переопределения свойств. Например, может возникнуть необходимость автоматического размещения штриховки на определённом слое, независимо от того, какой слой является текущим. Эта возможность помогает сэкономить время и уменьшить количество ошибок.

С помощью диалогового окна "Свойства инструмента" можно переопределить любое свойство.

Переопределение свойств слоя может повлиять на цвет, тип линий, вес линий, стиль печати и саму печать. Переопределение свойств слоя происходит следующим образом:

  • Если слой отсутствует в чертеже, то он автоматически создается.
  • Если слой отключён или заморожен, то он временно включается или размораживается.


Изменение свойств инструментов - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Изменение свойств инструментов
Понятия
Процедуры
Команды

Вывод информации о свойствах инструмента из палитры

Изменение свойства инструмента на палитре

Обновление изображения инструмента-блока на инструментальной палитре

Изменение изображения инструмента на палитре

Возврат к используемым по умолчанию изображению, названию и пояснению для инструмента-подменю


Вывод информации о свойствах инструмента из палитры - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Изменение свойств инструментов
Понятия
Процедуры
Команды

Вывод информации о свойствах инструмента из палитры

  1. На инструментальной палитре нажмите на инструменте правой кнопкой мыши. Выберите "Свойства".
  2. В диалоговом окне "Свойства инструмента", используя полосу прокрутки, просмотрите все свойства инструмента.

    3. Можно изменять размер диалогового окна с помощью мыши или сворачивать и разворачивать категории свойств, нажимая кнопку мыши на двойных стрелках рядом с их названиями.

  3. Нажмите "ОК".


Изменение свойства инструмента на палитре - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Изменение свойств инструментов
Понятия
Процедуры
Команды

Изменение свойства инструмента на палитре

  1. На инструментальной палитре нажмите на инструменте правую кнопку мыши. Выберите "Свойства".
  2. В диалоговом окне "Свойства инструмента" выберите свойство из списка и задайте новое значение.
    • Свойства, перечисленные в категории "Вставка" или "Образец", задают такие специфические свойства объекта, как масштаб, поворот и угол.
    • Свойства, перечисленные в категории "Общие", переопределяют настройки текущих свойств чертежа, таких как слой, цвет и тип линий.
    • Свойство "Вспомогательный масштаб", заданное для инструмента-блока или образца штриховки, применяется при использовании данного инструмента вместо обычного его масштаба.

    Можно изменять размер диалогового окна с помощью мыши или сворачивать и разворачивать категории свойств, нажимая мышью на двойных стрелках рядом с их названиями.

  3. Нажмите "ОК".

    4. Примечание Если для инструмента, имеющего подменю, задать изображение значка, название и пояснение, то они отображаются для каждого из инструментов подменю. Для восстановления стандартных изображений значка, названия и пояснения следует оставить незаполненными соответствующие текстовые поля диалогового окна "Свойства инструмента".

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Обновление изображения инструмента-блока на инструментальной палитре - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Изменение свойств инструментов
Понятия
Процедуры
Команды

Обновление изображения инструмента-блока на инструментальной палитре

  1. На инструментальной палитре нажмите на инструменте правую кнопку мыши.
  2. Выберите "Обновить изображение инструмента".

    3. Примечание Перед обновлением изображения инструмента чертеж необходимо сохранить.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Изменение изображения инструмента на палитре - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Изменение свойств инструментов
Понятия
Процедуры
Команды

Изменение изображения инструмента на палитре

  1. На инструментальной палитре нажмите на инструменте правую кнопку мыши.
  2. Выберите "Свойства".
  3. В диалоговом окне "Свойства инструмента" нажмите правую кнопку мыши в области изображения. Выберите "Выбрать изображение".

    4. Примечание В AutoCAD эта возможность доступна только инструментов-объектов, инструментов-размеров и инструментов-команд.

  4. В диалоговом окне "Выбор файла изображения" выберите файл изображения для значка.
  5. Для вставки нового изображения нажмите кнопку "Открыть".
  6. В диалоговом окне "Свойства инструмента" нажмите "ОК".

    7. Примечание Если для инструмента, имеющего подменю, задать изображение значка, то оно отображается для каждого инструмента из подменю. Подробнее о восстановлении стандартных значков для инструментов подменю см. раздел Возврат к используемым по умолчанию изображению, названию и пояснению для инструмента-подменю .

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Возврат к используемым по умолчанию изображению, названию и пояснению для инструмента-подменю - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Изменение свойств инструментов
Понятия
Процедуры
Команды

Возврат к используемым по умолчанию изображению, названию и пояснению для инструмента-подменю

  1. На инструментальной палитре нажмите на инструменте правую кнопку мыши. Выберите "Свойства".
  2. В диалоговом окне "Свойства инструмента" нажмите правую кнопку мыши в области изображения. Выберите пункт "Удалить изображение".
  3. Поместите курсор в поле "Название" и удалите текст.
  4. Поместите курсор в поле "Пояснение" и удалите текст.
  5. Нажмите "ОК".

    6. Примечание Задание пустых значений в полях "Значок", "Название" и "Пояснение" диалогового окна "Свойства инструмента" вызывает возврат к стандартным значениям для значка, названия и пояснения.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Изменение свойств инструментов - Команды

Инструментальные палитры
Инструментальные палитры
Изменение свойств инструментов
Понятия
Процедуры
Команды

Команды
АДАПТАЦИЯ | Изменяет инструментальные палитры
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
ИНСТРПАЛОТКЛ | Закрытие окна инструментальных палитр
Системные переменные
PALETTEOPAQUE | Управляет прозрачностью окон
TPSTATE | Определяет активность окна инструментальных палитр
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Адаптация инструментальных палитр - Понятия

Пользовательский интерфейс
Инструментальные палитры
Адаптация инструментальных палитр
Понятия
Процедуры
Команды

Существует несколько способов добавления инструментов в палитру.

Новую палитра создаётся с помощью кнопки "Свойства" в заголовке окна "Инструментальные палитры - все палитры". Добавление инструментов в инструментальную палитру подразумевает следующие методы:

  • Перетаскивание на палитру любого из следующих элементов чертежа: геометрических объектов (отрезков, кругов и полилиний), размеров, штриховок, градиентных заливок, блоков, внешних ссылок, растровых изображений.
  • Перетаскивание чертежей, блоков и штриховок из центра управления DesignCenter. Если на палитру добавлен целый чертеж, то при перетаскивании его из палитры в графическую область он вставляется как блок.
  • Перетаскивание команд из диалогового окна "Адаптация" на палитры (так же, как и на панели инструментов).
  • Перетаскивание команд на инструментальную палитру из области "Списка команд" окна редактора "Настройка интерфейса пользователя" (НПИ).
  • Копирование и перемещение инструментов с других палитр. Для этого служат пункты контекстного меню "Вырезать", "Копировать" и "Вставить".
  • Управление инструментальными палитрами путём создания новых палитр с нуля, переименования, удаления или перемещения палитр с помощью контекстного меню.

    • Примечание Не рекомендуется создавать или переименовывать инструментальные палитры, когда отображается редактор "Настройка интерфейса пользователя" (НПИ).

  • Для создания палитры, заполненной предусмотренными инструментами, нажмите правую кнопку мыши на папке, файле чертежа или блоке в области структуры центра управления DesignCenter, затем в контекстном меню выберите пункт "Создать инструментальную палитру".

Примечание Если исходный файл чертежа, из которого создан инструмент в виде блока, внешней ссылки или растрового изображения, перемещён в другую папку, необходимо изменить параметры инструмента, который ссылается на него. Для этого нажмите правую кнопку мыши на инструменте и задайте новый путь к папке исходного файла в окне "Свойства инструмента".

После того как инструменты помещены на инструментальную палитру, их можно переупорядочить. Для этого перетащите их в нужные положения или отсортируйте. В инструментальные палитры можно также добавлять текст и разделительные линии.

Любую инструментальную палитру можно перемещать вверх или вниз в последовательности вкладок с помощью контекстного меню или вкладки "Палитры инструментов - все палитры" диалогового окна "Адаптация". Инструментальные палитры, необходимость в которых отпала, можно удалить. Удаленные инструментальные палитры легко восстанавливаются, если перед удалением они были экспортированы в файл. Путь поиска инструментальных палитр задается на вкладке "Файлы" диалогового окна "Настройка". Данный путь может вести и к сетевому источнику.

Инструментальные палитры только для чтения

Если файлу инструментальной палитры присвоен атрибут "только чтение", в нижнем углу палитры высвечивается значок замка. Это означает, что разрешены только изменения, ограничивающиеся заданием параметров отображения и переупорядочением значков инструментов.

Для присвоения инструментальной палитре атрибута "только чтение" нажмите правую кнопку мыши на файле инструментальной палитры (ATC) в следующей папке: C:\documents and settings\<имя пользователя>\application data\autodesk\AutoCAD 2007\r17.0\enu\support\ToolPalette\Palettes. В контекстном меню выберите "Свойства". На вкладке "Общие" выберите "Только для чтения" и нажмите кнопку "ОК".


Адаптация инструментальных палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Адаптация инструментальных палитр
Понятия
Процедуры
Команды

Создание инструментальной палитры

Создание инструментальной палитры из папки или чертежа

Переименование инструментальной палитры

Удаление инструментальной палитры

Изменение расположения инструментальной палитры

Добавление текста на инструментальную палитру

Добавление разделительной линии на инструментальную палитру

Сортировка элементов на инструментальной палитре


Создание инструментальной палитры - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Адаптация инструментальных палитр
Понятия
Процедуры
Команды

Создание инструментальной палитры

  1. Нажмите правую кнопку мыши в незаполненной части окна инструментальных палитр. Выберите "Новая палитра".
  2. В текстовое поле введите имя для новой палитры.
  3. Если нужно изменить последовательность вкладок, нажмите на вкладке правую кнопку мыши и выберите "Вверх" или "Вниз".

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Создание инструментальной палитры из папки или чертежа - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Адаптация инструментальных палитр
Понятия
Процедуры
Команды

Создание инструментальной палитры из папки или чертежа

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "Палитры" » "DesignCenter".
  2. В области структуры или в области содержимого центра управления DesignCenter нажмите правую кнопку мыши на папке, файле чертежа или блоке. Выберите "Создать инструментальную палитру".

    3. Создается новая палитра, включающая все блоки и штриховки, которые имелись в выбранной папке или чертеже.

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Переименование инструментальной палитры - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Адаптация инструментальных палитр
Понятия
Процедуры
Команды

Переименование инструментальной палитры

  1. Нажмите правой кнопкой мыши в незаполненной части окна инструментальных палитр. Выберите "Переименовать палитру".
  2. В текстовое поле введите новое имя для палитры.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Удаление инструментальной палитры - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Адаптация инструментальных палитр
Понятия
Процедуры
Команды

Удаление инструментальной палитры

  1. Нажмите правую кнопку мыши в незаполненной части окна инструментальных палитр. Выберите "Удалить палитру".
  2. Для удаления инструментальной палитры нажмите "OK" в окне сообщения "Палитра - подтверждение удаления".

    3. Примечание Отмена выполненного удаления инструментальной палитры невозможна. Перед любыми удалениями рекомендуется экспортировать инструментальную палитру. Используйте опцию "Экспорт" в диалоговом окне "Адаптация".

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Изменение расположения инструментальной палитры - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Адаптация инструментальных палитр
Понятия
Процедуры
Команды

Изменение расположения инструментальной палитры

  1. Нажмите правую кнопку мыши на вкладке, отображающей инструментальную палитру, которую следует переместить, в окне инструментальных палитр. Выберите "Вверх" или "Вниз".
  2. Повторяйте шаг 1 до тех пор, пока инструментальная палитра не окажется на нужном месте.

    3. Примечание Порядок инструментальных палитр можно изменить также в диалоговом окне "Адаптация".

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Добавление текста на инструментальную палитру - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Адаптация инструментальных палитр
Понятия
Процедуры
Команды

Добавление текста на инструментальную палитру

  1. Нажмите правую кнопку мыши в незаполненной части окна инструментальных палитр. Выберите "Добавить текст".
  2. В текстовое поле вставьте текст, который должен отображаться в окне.
  3. При необходимости перетащите текст в соответствующее положение в окне.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Добавление разделительной линии на инструментальную палитру - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Адаптация инструментальных палитр
Понятия
Процедуры
Команды

Добавление разделительной линии на инструментальную палитру

  1. Нажмите правую кнопку мыши в незаполненной части окна инструментальных палитр. Выберите "Добавить разделитель".
  2. При необходимости перетащите разделитель в соответствующее положение в окне.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Сортировка элементов на инструментальной палитре - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Адаптация инструментальных палитр
Понятия
Процедуры
Команды

Сортировка элементов на инструментальной палитре

  • Нажмите правую кнопку мыши в незаполненной части окна инструментальных палитр. Выберите "Сортировать по"» "Имя" или "Сортировать по"» "Тип".

    • Примечание Элементы сортируются по порядку, тексту, разделителю и инструменту.

Панель "Стандартная"

Ввод команды: ИНСТРПАЛВКЛ


Адаптация инструментальных палитр - Команды

Инструментальные палитры
Инструментальные палитры
Адаптация инструментальных палитр
Понятия
Процедуры
Команды

Команды
АДАПТАЦИЯ | Изменяет инструментальные палитры
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
ИНСТРПАЛОТКЛ | Закрытие окна инструментальных палитр
Системные переменные
PALETTEOPAQUE | Управляет прозрачностью окон
TPSTATE | Определяет активность окна инструментальных палитр
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Организация инструментальных палитр - Понятия

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Инструментальные палитры можно группировать по темам, а также задавать, какая группа палитр будет отображаться на экране.

Например, можно создать группу палитр "Штриховка", предназначенную для хранения образцов штриховки. Впоследствии можно добавлять новые палитры в эту группу. Если сделать группу палитр "Штриховка" активной, то окно будет содержать только палитры из этой группы.


Организация инструментальных палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Создание группы инструментальных палитр

Добавление инструментальной палитры в группу палитр

Исключение инструментальной палитры из группы палитр

Вывод группы инструментальных палитр на экран

Удаление группы инструментальных палитр

Удаление всех групп инструментальных палитр

Переименование группы инструментальных палитр

Переупорядочение группы палитр

Создание группы инструментальных палитр, вложенной в другую группу

Копирование и вставка палитры из одной группы в другую

Изменение порядка расположения палитр внутри группы

Изменение порядка расположения палитр, когда все они выведены на экран

Вывод всех инструментальных палитр на экран


Создание группы инструментальных палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Создание группы инструментальных палитр

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Настроить палитры".
  2. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов - все палитры". В разделе "Группы палитр" нажмите правую кнопку мыши в нижней, пустой области. Выберите "Новая группа".

    3. Если в списке "Группы палитр" пока нет ни одной группы, группу можно создать путем перетаскивания инструментальной палитры из списка "Палитры инструментов - все палитры " в список "Группы палитр".

  3. Введите имя группы.
  4. Нажмите кнопку "Закрыть".

Ввод команды: АДАПТАЦИЯ


Добавление инструментальной палитры в группу палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Добавление инструментальной палитры в группу палитр

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Настроить палитры".
  2. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов - все палитры". Перетащите палитру из области "Палитры" в нужную группу в списке "Группы палитр".
  3. Нажмите кнопку "Закрыть".

Ввод команды: АДАПТАЦИЯ


Исключение инструментальной палитры из группы палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Исключение инструментальной палитры из группы палитр

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Настроить палитры".
  2. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов - все палитры ". В списке "Группы палитр" нажмите правую кнопку мыши на названии палитры, которую нужно исключить из группы. Выберите "Исключить".

    3. Для исключения палитры из группы можно также перетащить её обратно в область "Палитры инструментов".

  3. Нажмите кнопку "Закрыть".

Ввод команды: АДАПТАЦИЯ


Вывод группы инструментальных палитр на экран - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Вывод группы инструментальных палитр на экран

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры.
  2. Выберите имя группы инструментальных палитр, которую требуется отобразить.

Это можно сделать также с помощью диалогового окна "Адаптация". В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов". В списке "Группы палитр" нажмите правую кнопку мыши на группе, которую требуется отобразить. Выберите "Установить".

Ввод команды: АДАПТАЦИЯ


Удаление группы инструментальных палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Удаление группы инструментальных палитр

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Настроить палитры".
  2. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов". В списке "Группы палитр" нажмите правую кнопку мыши на названии группы палитр, которую необходимо удалить. Нажмите кнопку "Удалить".

    3. Примечание Нельзя удалить группу палитр, которая является текущей в данный момент. В этом случае сначала нужно сделать текущей другую группу.

  3. Нажмите кнопку "Закрыть".

Ввод команды: АДАПТАЦИЯ


Удаление всех групп инструментальных палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Удаление всех групп инструментальных палитр

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Все палитры".

    2. Примечание Необходимо вывести на экран все палитры, чтобы ни одна группа палитр не являлась текущей.

  2. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Настроить палитры".
  3. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов - все палитры ". В списке "Группы палитр" нажмите правую кнопку мыши на названии группы палитр. Нажмите кнопку "Удалить".
  4. Повторите шаг 3 для всех групп палитр.
  5. По завершении нажмите кнопку "Закрыть".

Ввод команды: АДАПТАЦИЯ


Переименование группы инструментальных палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Переименование группы инструментальных палитр

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Настроить палитры".
  2. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов". В списке "Группы палитр" нажмите правую кнопку мыши на названии группы палитр, которую необходимо переименовать. Выберите "Переименовать".
  3. Введите новое имя группы.
  4. Нажмите кнопку "Закрыть".

Ввод команды: АДАПТАЦИЯ


Переупорядочение группы палитр - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Переупорядочение группы палитр

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Настроить палитры".
  2. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов - все палитры". В списке "Группы палитр" нажмите кнопку мыши на названии группы палитр и перетащите ее в новое положение.

    3. Все группы, вложенные в перемещаемую группу, также передвигаются на новое место.

  3. Нажмите кнопку "Закрыть".

    4. Примечание Нельзя перетащить группу палитр в группу, вложенную в нее.

Ввод команды: АДАПТАЦИЯ


Создание группы инструментальных палитр, вложенной в другую группу - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Создание группы инструментальных палитр, вложенной в другую группу

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Настроить палитры".
  2. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов". В списке "Группы палитр" нажмите правую кнопку мыши на названии группы палитр, в которую необходимо добавить новую группу. Выберите "Новая группа".
  3. Введите имя для новой группы.
  4. Нажмите кнопку "Закрыть".

Ввод команды: АДАПТАЦИЯ


Копирование и вставка палитры из одной группы в другую - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Копирование и вставка палитры из одной группы в другую

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Настроить палитры".
  2. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов". В списке "Группы палитр" выберите инструментальную палитру, которую нужно скопировать.
  3. Нажмите клавишу CTRL и, удерживая ее, перетащите выбранную палитру в другую группу.

    4. Отпустите кнопку мыши. Копия палитры появляется в новом месте.

  4. Нажмите кнопку "Закрыть".

Ввод команды: АДАПТАЦИЯ


Изменение порядка расположения палитр внутри группы - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Изменение порядка расположения палитр внутри группы

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Настроить палитры".
  2. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов". В списке "Группы палитр" перетащите палитру в новое положение внутри группы.
  3. Нажмите кнопку "Закрыть".

Ввод команды: АДАПТАЦИЯ


Изменение порядка расположения палитр, когда все они выведены на экран - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Изменение порядка расположения палитр, когда все они выведены на экран

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Настроить палитры".
  2. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов - все палитры". В списке "Палитры инструментов" перетащите палитру в нужное положение.

    3. Когда все палитры выведены на экран, они отображаются в том порядке, в котором они находятся в списке.

  3. Нажмите кнопку "Закрыть".

Ввод команды: АДАПТАЦИЯ


Вывод всех инструментальных палитр на экран - Процедуры

Пользовательский интерфейс
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Вывод всех инструментальных палитр на экран

  • Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Все палитры".


Организация инструментальных палитр - Команды

Инструментальные палитры
Инструментальные палитры
Организация инструментальных палитр
Понятия
Процедуры
Команды

Команды
АДАПТАЦИЯ | Изменяет инструментальные палитры
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
ИНСТРПАЛОТКЛ | Закрытие окна инструментальных палитр
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение и совместное использование инструментальных палитр - Понятия

Пользовательский интерфейс
Инструментальные палитры
Сохранение и совместное использование инструментальных палитр
Понятия
Процедуры
Команды

Инструментальные палитры можно экспортировать и импортировать как файлы. Для импорта и экспорта инструментальной палитры нужно правую кнопку мыши нажать на палитре в диалоговом окне "Адаптация", затем выбрать "Импорт" или "Экспорт". Файлы инструментальных палитр имеют расширение .xtp.

В некоторых случаях при экспорте настроенной инструментальной палитры в том же месте, где и файл XTP, автоматически создаётся папка с изображениями, имеющая такое же имя, как экспортируемая инструментальная палитра. В папке с изображениями содержатся изображения значков, используемых экспортируемой инструментальной палитрой. Такая папка создаётся, если экспортируется инструментальная палитра, содержащая какой-нибудь из следующих элементов:

  • созданные пользователем инструменты содержимого;
  • инструменты-команды, содержащие заданные пользователем (пользовательские) значки палитры (изображения).

Чтобы на импортированной инструментальной палитре присутствовали значки, при импорте настроенной инструментальной палитры папка с изображениями должна находиться в том же месте, что и импортируемый файл XTP.

Инструментальные палитры можно использовать только в версии AutoCAD, в которой они были созданы. Например, инструментальную палитру, созданную в AutoCAD 2007 невозможно использовать в AutoCAD 2005.

Путь к файлам инструментальных палитр по умолчанию задаётся элементом "Папки с файлами инструментальных палитр" на вкладке "Файлы" диалогового окна "Настройка".

Группы инструментальных палитр сохраняются в профилях.

При использовании в AutoCAD LT инструментальных палитр, созданных в AutoCAD, следует помнить о том, что работа некоторых инструментов в этих продуктах различается. Обратите внимание на следующие ограничения:

  • цвет в инструменте должен быть задан по индексу цветов AutoCAD (ACI). Иначе при использовании инструмента в AutoCAD LT для цвета инструмента будет использоваться значение ПОСЛОЮ.
  • Инструменты, созданные из градиентных закрасок, преобразуются в AutoCAD LT в инструменты-штриховки.
  • Инструменты, созданные из растровых изображений, в AutoCAD LT не работают.

Примечание Если файлу инструментальной палитры присвоен атрибут "только чтение", в нижнем углу палитры высвечивается значок замка. Это означает, что разрешены только изменения, ограничивающиеся заданием параметров отображения и переупорядочением значков инструментов.

См. также

Сохранение и восстановление параметров интерфейса (профилей)


Инструментальные палитры

Пользовательский интерфейс
Инструментальные палитры
Инструментальные палитры
Понятия
Процедуры
Команды

Нет процедур.


Сохранение и совместное использование инструментальных палитр - Команды

Инструментальные палитры
Инструментальные палитры
Сохранение и совместное использование инструментальных палитр
Понятия
Процедуры
Команды

Команды
АДАПТАЦИЯ | Изменяет инструментальные палитры
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
ИНСТРПАЛОТКЛ | Закрытие окна инструментальных палитр
Системные переменные
PALETTEOPAQUE | Управляет прозрачностью окон
TPSTATE | Определяет активность окна инструментальных палитр
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание, организация и сохранение чертежей

Создание чертежа
Новый чертёж можно создать несколькими способами: с использованием простейшего шаблона или с помощью файла шаблона. В обоих случаях можно выбрать единицы измерения и соглашения по формату единиц.

Открытие или сохранение чертежа
Существуют различные способы поиска и открытия чертежей, в том числе поврежденных. Чертежи можно сохранять и архивировать автоматически.

Восстановление файлов чертежей
В случае повреждения файла чертежа или аварийного завершения работы программы можно восстановить все данные или их часть с помощью команд, позволяющих найти и исправить ошибки или вернуться к файлу резервной копии.

Соблюдение стандартов в чертежах
Для удобства чтения чертежей задаются стандарты, обеспечивающие единство их оформления. Пользователь может устанавливать стандарты для имён слоев, размерных стилей и других элементов, проверять чертежи на соответствие этим стандартам и, в случае обнаружения нарушений, изменять свойства.


Создание, организация и сохранение чертежей - Понятия

Создание, организация и сохранение чертежей
Создание, организация и сохранение чертежей
Создание, организация и сохранение чертежей
Понятия
Процедуры
Команды

При создании чертежа можно указать тип используемых единиц измерения и другие параметры.

Существуют различные способы поиска и открытия чертежей, в том числе поврежденных. Возможна также установка различных режимов для сохранения чертежа, включая создание резервных копий.

Для каждого создаваемого чертежа задаются единицы измерения, формат представления результатов измерений и устанавливаются другие соглашения.

Для удобства обработки чертежей задаются стандарты, предъявляющие определенные требования Можно задавать стандарты имен слоев, стилей размеров и других элементов; проверять чертежи на соответствие этим стандартам и, в случае обнаружения нарушений, изменять определенные свойства.


Создание, организация и сохранение чертежей - Процедуры

Создание, организация и сохранение чертежей
Создание, организация и сохранение чертежей
Создание, организация и сохранение чертежей
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Создание, организация и сохранение чертежей - Команды

Создание, организация и сохранение чертежей
Создание, организация и сохранение чертежей
Создание, организация и сохранение чертежей
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Создание чертежа - Понятия

Создание, организация и сохранение чертежей
Создание чертежа
Понятия
Процедуры
Команды

Новый чертёж можно создать несколькими способами: с использованием простейшего шаблона или с помощью файла шаблона. В обоих случаях можно выбрать единицы измерения и соглашения по формату единиц.

  • Использование простейшего шаблона
    Простейший шаблон позволяет быстро подготовить и начать новый чертёж со стандартными параметрами, содержащимися в файле шаблона чертежа.
  • Использование Мастера для создания чертежа
    С помощью Мастера подготовки выполняется пошаговая настройка параметров создаваемого чертежа.
  • Использование файла шаблона для создания чертежа
    В файле шаблона чертежа хранятся стандартные параметры. Файл шаблона можно выбрать из комплекта поставки или создать новый.
  • Задание единиц и формата единиц
    Прежде чем начать рисование, определите единицы измерения, которые будут использоваться для чертежа, и установите формат, точность и другие соглашения для координат и расстояний.
  • Добавление идентификационных сведений к чертежам
    Поиск, учет и обработку чертежей можно упростить, если добавить к ним ключевые слова или другие данные.


Создание чертежа - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Понятия
Процедуры
Команды

Создание чертежа на основе простейшего шаблона с помощью диалогового окна "Создание чертежа"

Создание чертежа по простейшему шаблону с помощью файла шаблона по умолчанию

Создание чертежа с помощью Мастера

Создание чертежа на основе выбранного шаблона

Создание шаблона на основе чертежа

Восстановление параметров простейших шаблонов

Задание формата и точности единиц

Преобразование дюймов в сантиметры

Преобразование сантиметров в дюймы

Задание формата и точности единиц

Преобразование дюймов в сантиметры

Преобразование сантиметров в дюймы

Для задания формата и точности измерения углов

Для просмотра свойств активного чертежа

Описание свойств чертежа


Создание чертежа - Команды

Создание, организация и сохранение чертежей
Создание чертежа
Понятия
Процедуры
Команды
Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОТКРЫТЬ | Открытие существующего файла чертежа
СВОЙСТВАРИС | Задание и просмотр свойств текущего чертежа
СОЗДАТЬ | Создание нового чертежа
Системные переменные
ANGBASE | Задание для базового угла значения 0 в соответствии с текущей ПСК
ANGDIR | Задание направления для положительных углов.
AUNITS | Установка единиц измерения для углов
AUPREC | Установка количества десятичных знаков для всех значений углов со статусом "только для чтения", отображаемых в строке состояния, а также для всех редактируемых значений углов, точность которых меньше или равна текущему значению AUPREC
CDATE | Сохраняет текущие дату и время в десятичном формате
DATE | Сохраняет текущие дату и время в формате модифицированной даты по юлианскому календарю.
FILEDIA | Подавляет отображение диалоговых окон навигации к файлу
LUNITS | Устанавливает линейные единицы
LUPREC | Определяет количество десятичных знаков, отображаемых для нередактируемых линейных единиц и для всех редактируемых линейных единиц, исходная точность которых меньше или равна значению текущей системной переменной LUPREC.
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
MEASUREMENT | Определяет, какие единицы используются в файлах образцов штриховки или типов линий текущего чертежа
STARTUP | Управляет отображением диалогового окна "Создание нового чертежа" при создании нового чертежа с помощью команды НОВЫЙ или БСОЗДАТЬ
UNITMODE | Управляет отображением формата единиц
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование простейшего шаблона - Понятия

Создание, организация и сохранение чертежей
Создание чертежа
Использование простейшего шаблона
Понятия
Процедуры
Команды

Простейший шаблон позволяет быстро подготовить и начать новый чертёж со стандартными параметрами, содержащимися в файле шаблона чертежа.

Создать чертёж на основе простейшего шаблона можно с помощью диалогового окна "Создание нового чертежа" или диалогового окна "Выбор шаблона", а также без использования диалоговых окон. В любом случае можно использовать как команду НОВЫЙ, так и команду СОЗДАТЬ.

Использование диалогового окна "Создание нового чертежа"

Для вызова диалогового окна "Создание нового чертежа" необходимо:

  • Системной переменной STARTUP присвоить значение 1 (Вкл).
  • Системной переменной FILEDIA присвоить значение 1 (Вкл).
  • Выберите пункт "Создать" из меню "Файл" или нажмите кнопку "Создать" на панели "Стандартная"; при этом в диалоговом окне "Настройка" не нужно указывать файл шаблона чертежа.

Используя диалоговое окно "Создание нового чертежа", можно создать новый чертёж несколькими способами.

При создании чертежа на основе простейшего шаблона выбирается британская или метрическая система единиц. Этим выбором определяются значения по умолчанию многих системных переменных, отвечающих за управление текстом, размерами, сеткой, шагом и файлом типа линий по умолчанию и файлом образцов штриховки.

  • Британские. Создание нового чертежа на основе британской системы единиц измерения. При создании чертежа используются внутренние значения по умолчанию, а для контура отображения сетки, называемого границамисетки, устанавливаются значения, равные 12 х 9 дюймов.
  • Метрические. Создание нового чертежа на основе метрической системы единиц измерения. При создании чертежа используются внутренние значения по умолчанию, а для контура отображения сетки по умолчанию устанавливаются значения, равные 420 х 290 миллиметров.
Использование диалогового окна "Выбор шаблона"

Диалоговое окно "Выбор шаблона" отображается при выполнении следующих условий:

  • Системной переменной STARTUP присвоено значение 0 (Откл).
  • Системной переменной FILEDIA присвоено значение 1 (Вкл).
  • Выбирается пункт "Новый" в меню "Файл" или, по умолчанию, "Создать" на стандартной панели инструментов.

В правом нижнем углу диалогового окна "Выбор шаблона" находится кнопка "Открыть" со стрелкой. Нажав на стрелку, можно выбрать один из двух стандартных шаблонов чертежа: на основе метрических единиц или на основе британских единиц.

Использование файла шаблона по умолчанию

С помощью файла шаблона по умолчанию можно автоматически создать новый чертеж. Диалоговые окна в данном методе не используются.

  • Системной переменной STARTUP присваивается значение 0 (Откл).
  • Системной переменной FILEDIA присваивается значение 1 (Вкл).
  • Файл шаблона чертежа по умолчанию задаётся в диалоговом окне "Настройка" на вкладке "Файлы". Выберите узел с ярлыком “Параметры шаблона чертежа” и укажите путь и файл шаблона чертежа.
  • Нажмите кнопку "Создать" на панели "Стандартная".

Теперь чертёж будет создаваться на основе параметров из указанного файла шаблона чертежа.

Если в диалоговом окне "Настройка" не указан файл шаблона, то командой СОЗДАТЬ вызывается диалоговое окно "Выбор шаблона".


Использование простейшего шаблона - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Использование простейшего шаблона
Понятия
Процедуры
Команды

Создание чертежа на основе простейшего шаблона с помощью диалогового окна "Создание чертежа"

Создание чертежа по простейшему шаблону с помощью файла шаблона по умолчанию


Создание чертежа на основе простейшего шаблона с помощью диалогового окна "Создание чертежа" - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Использование простейшего шаблона
Понятия
Процедуры
Команды

Создание чертежа на основе простейшего шаблона с помощью диалогового окна "Создание чертежа"

  1. При необходимости системным переменным STARTUP и FILEDIA присваивается значение 1. В командной строке введите startup и 1, затем введите filedia и 1.
  2. Выберите "Файл" » "Новый".
  3. В диалоговом окне "Создание нового чертежа" выберите "Простейший шаблон".
  4. Установите переключатель "Единицы по умолчанию" в положение "Британские" или "Метрические".

    5. Создаётся новый чертёж с именем drawing1.dwg. Имя, предлагаемое по умолчанию при создании нового чертежа, основано на его порядковом номере в последовательности начатых новых чертежей. Например, для следующего чертежа по умолчанию предлагается имя drawing2.dwg.

Ввод команды: НОВЫЙ


Создание чертежа по простейшему шаблону с помощью файла шаблона по умолчанию - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Использование простейшего шаблона
Понятия
Процедуры
Команды

Создание чертежа по простейшему шаблону с помощью файла шаблона по умолчанию

  1. Если требуется, задайте для системной переменной STARTUP значение 0, а для системной переменноё FILEDIA - 1. В командной строке введите startup и 0; затем введите filedia и 1.
  2. Выберите "Сервис" » "Настройка".
  3. В диалоговом окне "Настройка" откройте вкладку "Файлы" и в списке узлов нажмите кнопку мыши на значке "плюс" (+) рядом с элементом "Параметры шаблонов". Нажмите на значке "плюс" (+) рядом с элементом параметра "Папка для шаблона чертежа" и укажите путь к папке.
  4. Нажмите на значке "плюс" (+) для параметра "Шаблон по умолчанию для команды БСОЗДАТЬ" и укажите имя файла с шаблоном по умолчанию.
  5. Нажмите "ОК".
  6. Нажмите кнопку "Создать" на панели "Стандартная".

    7. Создается новый чертёж с именем drawing1.dwg. Имя, предлагаемое по умолчанию при создании нового чертежа, основано на его порядковом номере в последовательности начатых новых чертежей. Например, для следующего чертежа по умолчанию предлагается имя drawing2.dwg.

Панель "Стандартная"

Ввод команды: БСОЗДАТЬ


Использование простейшего шаблона - Команды

Создание чертежа
Создание чертежа
Использование простейшего шаблона
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
СОЗДАТЬ | Создание нового чертежа
Системные переменные
FILEDIA | Подавляет отображение диалоговых окон навигации к файлу
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
MEASUREMENT | Определяет, какие единицы используются в файлах образцов штриховки или типов линий текущего чертежа
STARTUP | Управляет отображением диалогового окна "Создание нового чертежа" при создании нового чертежа с помощью команды НОВЫЙ или БСОЗДАТЬ
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование Мастера для создания чертежа - Понятия

Создание, организация и сохранение чертежей
Создание чертежа
Использование Мастера для создания чертежа
Понятия
Процедуры
Команды

С помощью Мастера подготовки выполняется пошаговая настройка параметров создаваемого чертежа.

Существует два вида Мастеров подготовки.

  • Мастер быстрой подготовки.Устанавливает единицы измерения, точность отображаемых единиц и границы сетки.
  • Мастер детальной подготовки. Устанавливает единицы измерения, точность отображаемых единиц и границы сетки. Кроме того, обеспечивает задание параметров угловых величин, таких как формат и точность представления углов, направление нулевого угла и направление отсчета углов.

Эти мастера доступны в диалоговом окне "Создание нового чертежа".


Создание чертежа с помощью Мастера - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Использование Мастера для создания чертежа
Понятия
Процедуры
Команды

Создание чертежа с помощью Мастера

  1. Если необходимо, присвойте системным переменным STARTUP и FILEDIA значение 1.
  2. Выберите "Файл" » "Создать".
  3. В диалоговом окне "Создание нового чертежа" нажмите кнопку "Вызов мастера".
  4. Выберите "Быстрая подготовка" или "Детальная подготовка".
  5. Задайте нужные значения параметров, используя кнопки "Назад" и "Далее" для перехода между страницами Мастера.
  6. На последней странице нажмите кнопку "Готово".

Ввод команды: НОВЫЙ


Использование Мастера для создания чертежа - Команды

Создание чертежа
Создание чертежа
Использование Мастера для создания чертежа
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
MEASUREMENT | Определяет, какие единицы используются в файлах образцов штриховки или типов линий текущего чертежа
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование файла шаблона для создания чертежа - Понятия

Создание, организация и сохранение чертежей
Создание чертежа
Использование файла шаблона для создания чертежа
Понятия
Процедуры
Команды

В файле шаблона чертежа хранятся стандартные параметры. Файл шаблона можно выбрать из комплекта поставки или создать новый.

Файл шаблона чертежа имеет расширение .dwt.

Изменения, вносимые в созданный на основе шаблона чертеж, на сам шаблон влияния не оказывают. Можно использовать один из файлов шаблонов, прилагаемых к программе , или создавать собственные файлы шаблонов.

Создание файла шаблона чертежа

Вместо того, чтобы каждый раз задавать параметры при создании однотипных чертежей, достаточно один раз создать файл шаблона. Обычно в шаблоне хранятся следующие соглашения и параметры:

  • тип и точность представления единиц
  • основные надписи, рамки и логотипы
  • имена слоев
  • значения параметров "Шаг", "Сетка" и "Орто"
  • границы сетки
  • размерные стили
  • текстовые стили
  • типы линий

По умолчанию файлы шаблонов хранятся в папке template, поэтому их достаточно просто найти.

Восстановление файла шаблонов чертежа по умолчанию

Если исходные значения по умолчанию параметров файла шаблона чертежа acad.dwt или acadiso.dwt были изменены, их можно восстановить, создав новый чертёж без шаблона, а затем сохранить его как файл шаблона чертежа, заменяя файлы acad.dwt или acadiso.dwt.

Если пользователем задано рабочее пространство 3D моделирования, то файлами шаблона чертежа по умолчанию являются acad3d.dwt и acadiso3d.dwt.

Можно создать новый чертёж с исходными параметрами по умолчанию, используя команду НОВЫЙ для вызова диалогового окна "Выбор шаблона". Для этого нажмите на стрелке у кнопки "Открыть" и выберите из списка один из вариантов "Открыть без шаблона".


Использование файла шаблона для создания чертежа - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Использование файла шаблона для создания чертежа
Понятия
Процедуры
Команды

Создание чертежа на основе выбранного шаблона

Создание шаблона на основе чертежа

Восстановление параметров простейших шаблонов


Создание чертежа на основе выбранного шаблона - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Использование файла шаблона для создания чертежа
Понятия
Процедуры
Команды

Создание чертежа на основе выбранного шаблона

  1. Выберите "Файл" » "Создать".
  2. В диалоговом окне "Выбор шаблона" выберите шаблон из списка.
  3. Нажмите кнопку "Открыть".

    4. Создаётся чертёж с именем drawing1.dwg. Имя, предлагаемое по умолчанию при создании нового чертежа, основано на его порядковом номере среди нескольких созданных чертежей. Например, имя, предложенное по умолчанию для следующего чертежа, созданного на основе шаблона, будет drawing2.dwg.

    Если необходимо создать чертеж, не используя шаблон, нажмите на стрелке рядом с кнопкой "Открыть". Выберите в списке один из вариантов "без шаблона".

Ввод команды: НОВЫЙ


Создание шаблона на основе чертежа - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Использование файла шаблона для создания чертежа
Понятия
Процедуры
Команды

Создание шаблона на основе чертежа

  1. Выберите "Файл" » "Открыть".
  2. В диалоговом окне "Выбор файла" выберите файл, который будет использоваться в качестве шаблона.
  3. Нажмите кнопку "OK".
  4. Если необходимо удалить содержимое существующего файла, выберите "Редактирование" » "Стереть".
  5. На запрос "Выберите объекты" введите all, чтобы выбрать все объекты, затем введите r (для удаления) и выберите рамку и основную надпись, чтобы исключить их из набора.
  6. Выберите "Файл" » "Сохранить как".
  7. В диалоговом окне "Сохранение чертежа" в списке "Тип файла" выберите тип файла шаблона чертежа.

    8. DWT-файлы необходимо сохранять в формате текущей версии программы. Чтобы создать файл DWT в формате предыдущей версии, сначала сохраните чертёж в формате DWG, а затем переименуйте его, сменив расширение .dwg на .dwt.

  8. В поле "Имя файла" введите имя шаблона.
  9. Нажмите кнопку "Сохранить".
  10. Введите пояснения к шаблону.
  11. Нажмите "OK".

    12. Созданный шаблон сохраняется в папке template.

Панель "Стандартная"

Ввод команды: ОТКРЫТЬ


Восстановление параметров простейших шаблонов - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Использование файла шаблона для создания чертежа
Понятия
Процедуры
Команды

Восстановление параметров простейших шаблонов

  1. Выберите "Файл" » "Новый".
  2. В диалоговом окне "Выбор шаблона" нажмите на стрелке рядом с кнопкой "Открыть". Выберите из списка один из параметров:
    • "Открыть без шаблона - британские" для восстановления acad.dwt
    • "Открыть без шаблона - метрические" для восстановления acadiso.dwt

    Создаётся чертёж с параметрами по умолчанию.

  3. Выберите "Файл" » "Сохранить как".
  4. В диалоговом окне "Сохранение чертежа" в качестве типа файла выберите "Шаблон чертежа". Сохраните чертёж под исходным именем или под именем acad.dwt с британскими единицами измерения или acadiso.dwt - с метрическими.
  5. Нажмите кнопку "Сохранить".

    6. Примечание Для рабочего пространства 3D моделирования файлами шаблона чертежа по умолчанию являются acad3d.dwt и acadiso3d.dwt

Ввод команды: НОВЫЙ


Использование файла шаблона для создания чертежа - Команды

Создание чертежа
Создание чертежа
Использование файла шаблона для создания чертежа
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОТКРЫТЬ | Открытие существующего файла чертежа
Системные переменные
MEASUREMENT | Определяет, какие единицы используются в файлах образцов штриховки или типов линий текущего чертежа
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание единиц и формата единиц - Понятия

Создание, организация и сохранение чертежей
Создание чертежа
Задание единиц и формата единиц
Понятия
Процедуры
Команды

Прежде чем начать рисование, определите единицы измерения, которые будут использоваться для чертежа, и установите формат, точность и другие соглашения для координат и расстояний.

  • Определение единиц измерения
    Перед началом рисования необходимо указать физический смысл единицы чертежа, исходя из того, какой чертёж требуется создать. Можно преобразовать чертёж в соответствии с различными системами измерения, изменив его масштаб.
  • Соглашения по линейным единицам
    Перед началом рисования необходимо установить формат и количество десятичных знаков для ввода и отображения линейных единиц.
  • Соглашения по угловым единицам
    Соглашения по угловым единицам определяют нулевой угол и направление измерений: по часовой стрелке или против часовой стрелки. Кроме того, следует задать тип единиц и точность представления значений.


Задание единиц и формата единиц - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Задание единиц и формата единиц
Понятия
Процедуры
Команды

Задание формата и точности единиц

Преобразование дюймов в сантиметры

Преобразование сантиметров в дюймы

Задание формата и точности единиц

Преобразование дюймов в сантиметры

Преобразование сантиметров в дюймы

Для задания формата и точности измерения углов


Задание единиц и формата единиц - Команды

Создание, организация и сохранение чертежей
Создание чертежа
Задание единиц и формата единиц
Понятия
Процедуры
Команды
Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
Системные переменные
ANGBASE | Задание для базового угла значения 0 в соответствии с текущей ПСК
ANGDIR | Задание направления для положительных углов.
AUNITS | Установка единиц измерения для углов
AUPREC | Установка количества десятичных знаков для всех значений углов со статусом "только для чтения", отображаемых в строке состояния, а также для всех редактируемых значений углов, точность которых меньше или равна текущему значению AUPREC
LUNITS | Устанавливает линейные единицы
LUPREC | Определяет количество десятичных знаков, отображаемых для нередактируемых линейных единиц и для всех редактируемых линейных единиц, исходная точность которых меньше или равна значению текущей системной переменной LUPREC.
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
MEASUREMENT | Определяет, какие единицы используются в файлах образцов штриховки или типов линий текущего чертежа
UNITMODE | Управляет отображением формата единиц
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Определение единиц измерения - Понятия

Создание, организация и сохранение чертежей
Создание чертежа
Определение единиц измерения
Понятия
Процедуры
Команды

Каждый создаваемый объект измеряется в единицах чертежа. Перед началом рисования необходимо указать физический смысл единицы чертежа, исходя из того, какой чертёж требуется создать. Затем на основе этого соглашения создается чертёж в натуральную величину. Например, расстояние одной единицы чертежа, как правило, соответствует одному миллиметру, сантиметру, дюйму или футу.

Преобразование единиц чертежа

Если чертёж создан в одной системе измерений (британской или метрической), а затем необходимо перейти в другую систему, с помощью команды МАСШТАБ измените масштаб модели с соответствующим коэффициентом преобразования, чтобы получить правильные значения расстояний и размеров.

Например, чтобы преобразовать чертеж, созданный в дюймах, в чертеж в сантиметрах, нужно изменить масштаб модели с коэффициентом 2,54. Для преобразования сантиметров в дюймы масштабный коэффициент должен быть равен 1/2,54 или 0,3937.

См. также

Задание масштаба размеров


Определение единиц измерения - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Определение единиц измерения
Понятия
Процедуры
Команды

Задание формата и точности единиц

Преобразование дюймов в сантиметры

Преобразование сантиметров в дюймы


Задание формата и точности единиц - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Определение единиц измерения
Понятия
Процедуры
Команды

Задание формата и точности единиц

  1. Выберите "Формат" » "Единицы".
  2. В диалоговом окне "Единицы чертежа" на вкладке "Длина" выберите формат и точность единицы.

    3. Параметры единиц и точность иллюстрируются в группе "Пример".

  3. Нажмите "ОК".

Ввод команды: ЕДИНИЦЫ


Преобразование дюймов в сантиметры - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Определение единиц измерения
Понятия
Процедуры
Команды

Преобразование дюймов в сантиметры

  1. Выберите "Редактирование" » "Масштаб".
  2. В ответ на запрос "Выберите объекты" введите все.

    3. Выделяются все объекты чертежа для масштабирования.

  3. Введите координаты базовой точки *0,0.

    4. Масштабирование выполняется относительно Мировой системы координат, и в дальнейшем базовые точки чертежа и МСК совпадают.

  4. Введите масштабный коэффициент 2,54 (так как 1 дюйм равен 2,54 сантиметра).

    5. Все объекты чертежа увеличиваются с коэффициентом 2,54 для приведения к размерам в сантиметрах.

Панель "Редактирование"

Ввод команды: МАСШТАБ


Преобразование сантиметров в дюймы - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Определение единиц измерения
Понятия
Процедуры
Команды

Преобразование сантиметров в дюймы

  1. Выберите "Редактирование" » "Масштаб".
  2. В ответ на запрос "Выберите объекты" введите все.

    3. Выделяются все объекты чертежа для масштабирования.

  3. Введите координаты базовой точки *0,0.

    4. Масштабирование выполняется относительно Мировой системы координат, и в дальнейшем базовые точки чертежа и МСК совпадают.

  4. Введите масштабный коэффициент 0,3937 (величину, обратную значению 2,54 - количеству сантиметров в 1 дюйме ).

    5. Все объекты чертежа уменьшаются для приведения к размерам в дюймах.

Панель "Редактирование"

Ввод команды: МАСШТАБ


Определение единиц измерения - Команды

Создание чертежа
Создание чертежа
Определение единиц измерения
Понятия
Процедуры
Команды

Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
Системные переменные
LUNITS | Устанавливает линейные единицы
LUPREC | Определяет количество десятичных знаков, отображаемых для нередактируемых линейных единиц и для всех редактируемых линейных единиц, исходная точность которых меньше или равна значению текущей системной переменной LUPREC.
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
MEASUREMENT | Определяет, какие единицы используются в файлах образцов штриховки или типов линий текущего чертежа
UNITMODE | Управляет отображением формата единиц
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Соглашения по линейным единицам - Понятия

Создание, организация и сохранение чертежей
Создание чертежа
Соглашения по линейным единицам
Понятия
Процедуры
Команды

Перед началом рисования необходимо установить формат и количество десятичных знаков для ввода и отображения линейных единиц.

Представление стиля отображения и точности расстояний и координат можно выбрать исходя из определенных общепринятых соглашений. Для ввода и отображения значений можно использовать десятичный формат, формат обычной дроби или другое обозначение. Эти параметры влияют на следующие элементы интерфейса

  • Палитра свойств
  • Динамический ввод
  • Команда СПИСОК
  • Команда КООРД
  • Отображение координат в строке состояния
  • Диалоговые окна, в которых отображаются координаты

Тип единиц и точность задаются в диалоговом окне "Единицы чертежа", с помощью Мастера быстрой подготовки или Мастера детальной подготовки.

Округление и точность.

При задании точности единиц значения координат и расстояний округляются. Однако внутренняя точность координат и расстояний всегда сохраняется независимо от отображаемой точности.

Например, если задается точность отображения единиц в десятичном формате, равная 1 (или 0,0), то координаты округляются до одного знака после запятой. Так координаты 0,000, 1,375 отображаются как 0,0, 1,4, но внутренняя точность при этом сохраняется.

Ввод значений расстояния в британском архитектурном формате

При использовании архитектурного формата для ввода футов и дюймов нужно после значения футов поставить символ апострофа ('), например, 72'3. Символ (“) после значения дюймов ставить не обязательно.

Примечание Формат единиц для представления размерных величин задается отдельно от форматов для построения объектов, измерения расстояний и отображения координат точек.

См. также

Задание масштаба размеров


Соглашения по линейным единицам - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Соглашения по линейным единицам
Понятия
Процедуры
Команды

Задание формата и точности единиц

Преобразование дюймов в сантиметры

Преобразование сантиметров в дюймы


Задание формата и точности единиц - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Соглашения по линейным единицам
Понятия
Процедуры
Команды

Задание формата и точности единиц

  1. Выберите "Формат" » "Единицы".
  2. В диалоговом окне "Единицы чертежа" на вкладке "Длина" выберите формат и точность единицы.

    3. Параметры единиц и точность иллюстрируются в группе "Пример".

  3. Нажмите "ОК".

Ввод команды: ЕДИНИЦЫ


Преобразование дюймов в сантиметры - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Соглашения по линейным единицам
Понятия
Процедуры
Команды

Преобразование дюймов в сантиметры

  1. Если необходимо, выберите вкладку "Модель", чтобы сделать её текущей.
  2. Выберите "Редактирование" » "Масштаб".
  3. В ответ на запрос "Выберите объекты" введите все.

    4. Выделяются все объекты чертежа для масштабирования.

  4. Введите координаты базовой точки *0,0.

    5. Масштабирование выполняется относительно Мировой системы координат, и в дальнейшем базовые точки чертежа и МСК совпадают.

  5. Введите масштабный коэффициент 2,54 (так как 1 дюйм равен 2,54 сантиметра).

    6. Все объекты чертежа увеличиваются с коэффициентом 2,54 для приведения к размерам в сантиметрах.

Панель "Редактирование"

Ввод команды: МАСШТАБ


Преобразование сантиметров в дюймы - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Соглашения по линейным единицам
Понятия
Процедуры
Команды

Преобразование сантиметров в дюймы

  1. Если необходимо, выберите вкладку "Модель", чтобы сделать ее текущей.
  2. Выберите "Редактирование" » "Масштаб".
  3. В ответ на запрос "Выберите объекты" введите "all".

    4. Выделяются все объекты чертежа для масштабирования.

  4. Введите координаты базовой точки *0,0.

    5. Масштабирование выполняется относительно Мировой системы координат, и в дальнейшем базовые точки чертежа и МСК совпадают.

  5. Введите масштабный коэффициент 0,3937 (величину, обратную значению 2,54 - количеству сантиметров в 1 дюйме ).

    6. Все объекты чертежа уменьшаются для приведения к размерам в дюймах.

Панель "Редактирование"

Ввод команды: МАСШТАБ


Соглашения по линейным единицам - Команды

Создание чертежа
Создание чертежа
Соглашения по линейным единицам
Понятия
Процедуры
Команды

Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
Системные переменные
LUNITS | Устанавливает линейные единицы
LUPREC | Определяет количество десятичных знаков, отображаемых для нередактируемых линейных единиц и для всех редактируемых линейных единиц, исходная точность которых меньше или равна значению текущей системной переменной LUPREC.
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
MEASUREMENT | Определяет, какие единицы используются в файлах образцов штриховки или типов линий текущего чертежа
UNITMODE | Управляет отображением формата единиц
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Соглашения по угловым единицам - Понятия

Создание, организация и сохранение чертежей
Создание чертежа
Соглашения по угловым единицам
Понятия
Процедуры
Команды

Соглашения по угловым единицам определяют нулевой угол и направление измерений: по часовой стрелке или против часовой стрелки. Кроме того, следует задать тип единиц и точность представления значений.

Представление отображения углов на чертеже можно выбрать исходя из определенных общепринятых соглашений. Можно указать, что измерение положительных значений для углов производится по часовой стрелке или против часовой стрелки, а для нулевого угла может быть задано любое направление (обычно "на восток" или "на север"). Значения углов могут вводиться в градах, радианах, топографических единицах, а также в градусах, минутах и секундах.

Работа с топографическими углами

При использовании топографических единиц измерения углов нужно указывать буквы, обозначающие граничные направления квадранта, в котором находится румб (север, юг, восток, запад). Например, для указания относительных координат конца отрезка длиной 72 фута 8 дюймов с румбом направления N 45° 20'6"E, нужно ввести

@72'8"<n45d20'6"e


Для задания формата и точности измерения углов - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Соглашения по угловым единицам
Понятия
Процедуры
Команды

Для задания формата и точности измерения углов

  1. Выберите "Формат" » "Единицы".
  2. В диалоговом окне "Единицы чертежа" на вкладке "Угол" выберите тип угла и точность.

    3. Тип угла и точность иллюстрируются в группе "Пример".

  3. Для задания направления отсчета угла нажмите кнопку "Направление".

    4. Направление отсчета определяет точку, от которой измеряются все остальные углы, и направление, в котором они измеряются. По умолчанию нулевым считается направление вправо, а положительное значение угла - против часовой стрелки.

  4. Выберите требуемые параметры.
  5. Нажмите "OK" для закрытия каждого диалогового окна.

Ввод команды: ЕДИНИЦЫ


Соглашения по угловым единицам - Команды

Создание чертежа
Создание чертежа
Соглашения по угловым единицам
Понятия
Процедуры
Команды

Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
Системные переменные
ANGBASE | Задание для базового угла значения 0 в соответствии с текущей ПСК
ANGDIR | Задание направления для положительных углов.
AUNITS | Установка единиц измерения для углов
AUPREC | Установка количества десятичных знаков для всех значений углов со статусом "только для чтения", отображаемых в строке состояния, а также для всех редактируемых значений углов, точность которых меньше или равна текущему значению AUPREC
UNITMODE | Управляет отображением формата единиц
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление идентификационных сведений к чертежам - Понятия

Создание, организация и сохранение чертежей
Создание чертежа
Добавление идентификационных сведений к чертежам
Понятия
Процедуры
Команды

Поиск, учет и обработку чертежей можно упростить, если добавить к ним ключевые слова или другие данные.

Использование проводника Windows

Свойства чертежа помогают распознать его среди остальных. Некоторые свойства чертежа хранятся в операционной системе; например, тип чертежа, его расположение и размер. В файле чертежа эти значения доступны только для чтения, а изменить их можно только из проводника Windows.

Использование инструмента "Найти"

Эти данные могут быть использованы для поиска с помощью инструмента "Найти" в стандартном диалоговом окне выбора файлов. Например, можно осуществлять поиск файлов по определенной дате создания или файлов, редактировавшихся накануне.

Использование центра управления DesignCenter

В файлах чертежей можно создавать дополнительные свойства. Файл может содержать сведения об авторе, заголовке, теме, о присвоенных ключевые словах, адресах гиперссылок или путях к папкам, а также прочие свойства. Эти свойства могут использоваться при поиске файлов с помощью вкладки "Дополнительно" окна поиска в центре управления DesignCenter. Для получения дополнительных сведений о центре управления DesignCenter см. раздел, посвященный командеЦУВКЛ, и Доступ к содержимому с помощью DesignCenter.

Использование свойств модуля "Диспетчер подшивок"

С помощью "Диспетчера подшивок" можно присваивать название, номер и описание любому листу в подшивке. Дополнительные информацию о подшивках см. в разделе Добавление дополнительных сведений для листов и подшивок.

Отображение свойств в полях

Все эти свойства чертежа могут быть заданы в поле текстового объекта. Дополнительную информацию о полях см. в разделе Использование полей в тексте.


Добавление идентификационных сведений к чертежам - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Добавление идентификационных сведений к чертежам
Понятия
Процедуры
Команды

Для просмотра свойств активного чертежа

Описание свойств чертежа


Для просмотра свойств активного чертежа - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Добавление идентификационных сведений к чертежам
Понятия
Процедуры
Команды

Для просмотра свойств активного чертежа

  1. Выберите "Файл" » "Свойства чертежа...".
  2. В диалоговом окне свойств чертежа для получения сведений о свойствах чертежа выберите нужную вкладку.

Ввод команды: СВОЙСТВАРИС


Описание свойств чертежа - Процедуры

Создание, организация и сохранение чертежей
Создание чертежа
Добавление идентификационных сведений к чертежам
Понятия
Процедуры
Команды

Описание свойств чертежа

  1. Выберите "Файл" » "Свойства чертежа...".
  2. Введите информацию о свойствах чертежа на следующих вкладках диалогового окна "Свойства чертежа":
    • Вкладка "Документ".Введите название чертежа, тему, автора, ключевые слова, пояснения и адрес по умолчанию для гиперссылок чертежа. Например, можно указать для чертежей ключевое слово Autodesk, а затем найти все файлы с этим ключевым словом с помощью центра управления DesignCenter. В качестве базы гиперссылки можно указать адрес в Интернете или путь к папке на сетевом диске.
    • Вкладка "Прочие".Нажмите кнопку "Добавить". В диалоговом окне "Новое свойство" введите имя и значение для свойства, определяемого пользователем. Нажмите "OK". Новое свойство и его значение отображаются на вкладке "Прочие". Эти сведения могут использоваться для расширенного поиска с помощью центра управления DesignCenter.
  3. Нажмите "ОК".

Ввод команды: СВОЙСТВАРИС


Добавление идентификационных сведений к чертежам - Команды

Создание чертежа
Создание чертежа
Добавление идентификационных сведений к чертежам
Понятия
Процедуры
Команды

Команды
СВОЙСТВАРИС | Задание и просмотр свойств текущего чертежа
Системные переменные
CDATE | Сохраняет текущие дату и время в десятичном формате
DATE | Сохраняет текущие дату и время в формате модифицированной даты по юлианскому календарю.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Открытие или сохранение чертежа - Понятия

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Понятия
Процедуры
Команды

Существуют различные способы поиска и открытия чертежей, в том числе поврежденных. Чертежи можно сохранять и архивировать автоматически.

  • Открытие чертежа
    Открытие чертежей выполняется так же, как и в других приложениях Windows. Кроме того, возможен выбор одного из альтернативных методов.
  • Частичное открытие и частичная загрузка
    Для увеличения производительности при работе с большими чертежами можно открывать только отдельные слои и виды чертежа.
  • Работа с несколькими чертежами
    Информацию можно легко перемещать между чертежами, открытыми в одном сеансе.
  • Сохранение чертежей
    Сохранение чертежей для дальнейшего использования выполняется так же, как и в других приложениях Microsoft Windows. Можно установить режим автоматического сохранения файлов и резервных копий, а также сохранения только выбранных объектов.
  • Поиск чертежей
    С помощью фильтров, задающих имя искомого файла, папку, дату, а также значения определенных свойств, таких как ключевые слова в чертежах, можно выполнять поиск чертежей или текстовых строк, содержащих определенное слово или фразу.
  • Укажите "Пути поиска" и "Местоположения файлов"
    Имеется возможность задания путей доступа для поиска вспомогательных файлов, таких как шрифты, чертежи, типы линий, образцы штриховки и т.д. Можно также указать папку для хранения временных файлов, что важно при работе в сети.


Открытие или сохранение чертежа - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Понятия
Процедуры
Команды

Открытие чертежа

Изменение папки чертежей, используемой по умолчанию

Частичное открытие чертежа

Загрузка дополнительной геометрии в частично открытый чертеж

Переключение между открытыми чертежами

Сохранение чертежа

Автоматическое сохранение чертежа

Сохранение резервных копий чертежей

Сохранение выбранных объектов в новом файле

Сохранение описания блока в новом файле чертежа

Поиск файлов

Изменение пути поиска


Открытие или сохранение чертежа - Команды

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Понятия
Процедуры
Команды
Команды
БЛОК | Создание описания блока из выбранных объектов
ЗАГРЧАСТЬ | Дополнительная загрузка геометрии в частично открытый чертеж
КЕМОТКРЫТ | Вывод информации о том, кем открыт тот или иной файл чертежа
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОТКРЧАСТЬ | Загрузка геометрии и именованных объектов в чертеж из выбранного вида или слоя.
ОТКРЫТЬ | Открытие существующего файла чертежа
ПАНЗАДАЧ | Управление отображением чертежей на панели задач Windows
ПБЛОК | Запись объектов или блока в новый файл чертежа
ПОКИНУТЬ | Завершение работы программы
СОХРАНИТЬ | Сохранение чертежа под текущим или заданным именем
Системные переменные
DWGCHECK | Управляет проверкой чертежей на потенциальные ошибки при их открытии
DWGNAME | Сохраняет имя чертежа, введенное пользователем
DWGPREFIX | Сохраняет путь к чертежу (диск и папка)
DWGTITLED | Указывает, присвоено ли текущему чертежу имя
ISAVEBAK | Повышает скорость последовательных сохранений, особенно для больших чертежей
ISAVEPERCENT | Определяет количество неиспользуемого дискового пространства, допустимого в файле чертежа
MYDOCUMENTSPREFIX | Хранит полный путь к папке "Мои документы" текущего пользователя
RASTERPREVIEW | Управляет сохранением вместе с чертежом образцов для просмотра в формате BMP
REMEMBERFOLDERS | Управляет путем по умолчанию, который отображается в стандартных диалоговых окнах выбора файлов
ROAMABLEROOTPREFIX | Сохраняет полный путь к корневой папке, в которую были установлены перемещаемые адаптируемые файлы
SAVEFILE | Сохраняет имя текущего файла автоматического сохранения
SAVEFILEPATH | Указывает путь к папке всех файлов автоматического сохранения для текущего сеанса
SAVENAME | Сохраняет имя файла и путь к папке самого последнего сохраненного чертежа
SAVETIME | Задает интервал автоматического сохранения (в минутах)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Открытие чертежа - Понятия

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Открытие чертежа
Понятия
Процедуры
Команды

Открытие чертежей выполняется так же, как и в других приложениях Windows. Кроме того, возможен выбор одного из альтернативных методов.

Для открытия чертежа можно

  • Отобразить диалоговое окно "Выбор файла", воспользовавшись пунктом "Открыть" в меню "Файл".
  • Дважды нажмите на чертеже в проводнике Windows, чтобы запустить AutoCAD® и открыть чертеж. Если программа уже запущена, то чертёж откроется в текущем, а не во втором сеансе.
  • Перетащите чертёж из проводника Windows в AutoCAD.

    • Чертёж откроется, если поместить его за пределами области рисования— например, в командной строке или в пустом месте рядом с панелями инструментов—. Если же перетащить чертёж в область рисования другого, уже открытого чертежа, то произойдет его вставка в текущий чертёж в качестве блока.

  • Для открытия чертежей используется центр управления DesignCenter
  • Для поиска и открытия чертежей в подшивке используется модуль "Диспетчер подшивок"
Проверка версии формата чертежа

Если системная переменная DWGCHECK имеет значение "Вкл" (1), выполняется проверка формата файла DWG и отображается предупреждающее сообщение в следующих случаях:

  • Файл чертежа имеет формат AutoCAD LT 97 или AutoCAD Release 14 или более поздних их версий и
  • Файл был сохранен в программах, отличных от AutoCAD LT 97 или AutoCAD Release 14 или более поздних их версий

Чтобы формат чертежа не проверялся, необходимо при появлении окна с сообщением о версии формата отключить параметр "Всегда выводить это окно". Другой способ отключения проверки заключается в присвоении переменной DWGCHECK значения "Откл" (0).

Изменение папки чертежей, используемой по умолчанию

При работе с AutoCAD папка Мои документы является путем по умолчанию во всех стандартных диалоговых окнах выбора файлов. Кроме того, можно сконфигурировать AutoCAD на постоянный выбор по умолчанию указанного пути, заменив папку чертежа по умолчанию с помощью системной переменной REMEMBERFOLDERS.

См. также

Краткий обзор центра управления DesignCenter

Настройка запуска

Работа с листами в подшивке


Открытие чертежа - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Открытие чертежа
Понятия
Процедуры
Команды

Открытие чертежа

Изменение папки чертежей, используемой по умолчанию


Открытие чертежа - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Открытие чертежа
Понятия
Процедуры
Команды

Открытие чертежа

  1. Выберите "Файл" » "Открыть".
  2. В диалоговом окне "Выбор файла" выделите один или несколько файлов. Нажмите кнопку "Открыть".

    3. Для быстрого доступа к часто используемым файлам и папкам можно использовать значки в левой части диалогового окна. Путем перетаскивания значков можно изменять порядок их расположения. Добавление, редактирование и удаление значков выполняется с помощью контекстного меню, вызываемого щелчком правой кнопки мыши на нужном значке.

Панель "Стандартная"

Ввод команды: ОТКРЫТЬ


Изменение папки чертежей, используемой по умолчанию - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Открытие чертежа
Понятия
Процедуры
Команды

Изменение папки чертежей, используемой по умолчанию

  1. В командной строке введите rememberfolders, а затем 0.
  2. На рабочем столе Windows нажмите правой кнопкой мыши на значке AutoCAD. Выберите "Свойства".
  3. Перейдите на вкладку "Ярлык".
  4. В поле "Рабочий каталог" введите путь, который должен устанавливаться текущим по умолчанию при открытии или сохранении чертежей.
  5. Нажмите "ОК".


Открытие чертежа - Команды

Открытие или сохранение чертежа
Открытие или сохранение чертежа
Открытие чертежа
Понятия
Процедуры
Команды

Команды
КЕМОТКРЫТ | Вывод информации о том, кем открыт тот или иной файл чертежа
ОТКРЫТЬ | Открытие существующего файла чертежа
Системные переменные
REMEMBERFOLDERS | Управляет путем по умолчанию, который отображается в стандартных диалоговых окнах выбора файлов
ROAMABLEROOTPREFIX | Сохраняет полный путь к корневой папке, в которую были установлены перемещаемые адаптируемые файлы
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Частичное открытие и частичная загрузка - Понятия

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Частичное открытие и частичная загрузка
Понятия
Процедуры
Команды

Для увеличения производительности при работе с большими чертежами можно открывать только отдельные слои и виды чертежа.

При работе с большими чертежами можно пользоваться режимом "Открыть частично" команды ОТКРЫТЬ, чтобы выбрать геометрию вида и слоя (только графические объекты), с которыми предполагается работать в чертеже. Например, при загрузке геометрической структуры из вида ГРАНИЦЫ и слоя SITE, в чертёж загружаются все объекты этого слоя, попадающие в вид "Границы".

Редактировать можно только те объекты, которые загружены в файл чертежа, но доступны все именованные объекты частично открытого чертежа. К именованным объектам относятся слои, виды, блоки, размерные стили, текстовые стили, конфигурации видовых экранов, описания компоновки листов, ПСК и типы линий.

Разделив большой чертёж на секторы, можно загружать и редактировать отдельные части чертежа. Например, пусть на карте города необходимо отредактировать юго-восточный сектор (сектор D3 на рисунке). Задание отдельного вида для этого сектора избавляет пользователя от необходимости загружать весь чертёж целиком. Другой пример: чтобы изменить номера земельных участков на карте, можно загрузить информацию только с одного конкретного слоя.

Использование команды ЗАГРЧАСТЬ позволяет загружать в частично открытый чертёж дополнительные объекты из вида, выбранной области или слоя. Частично открывать можно только чертежи формата AutoCAD 2000 и более поздних версий.


Частичное открытие и частичная загрузка - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Частичное открытие и частичная загрузка
Понятия
Процедуры
Команды

Частичное открытие чертежа

Загрузка дополнительной геометрии в частично открытый чертеж


Частичное открытие чертежа - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Частичное открытие и частичная загрузка
Понятия
Процедуры
Команды

Частичное открытие чертежа

  1. Выберите "Файл" » "Открыть".
  2. В диалоговом окне "Выбор файла" выберите чертеж.
  3. Нажмите на стрелке рядом с кнопкой "Открыть". Выберите "Открыть частично".
  4. В диалоговом окне "Частичное открытие" выберите вид. По умолчанию предлагается вид ГРАНИЦЫ.

    5. Геометрию можно загрузить только из видов пространства модели, имеющихся в данном чертеже.

  5. Выберите один или несколько слоев.

    6. Если не выбран ни один слой, загружается только структура слоёв чертежа, но не объекты, содержащиеся в нем. Если не заданы слои, объекты не загружаются даже в том случае, если указан вид для загрузки. Следует иметь в виду, что создавая объекты на слое, геометрия с которого не загружена, пользователь может осуществлять построения поверх имеющихся, но не загруженных в чертёж объектов.

    Примечание Слои, зависимые от внешних ссылок, появляются в списке "Загрузка объектов по слоям", только если при сохранении выбранного чертежа системной переменной VISRETAIN было присвоено значение 1. Слои, созданные во внешнем файле после загрузки ссылки в чертеж, в этом списке не выводятся.

  6. Если чертёж содержит пространственный индекс, можно установить флажок "По пространственному индексу".

    7. Пространственный индекс - это список объектов и их положений в пространстве. Пространственный индекс используется для поиска фрагмента считываемого чертежа. Это сокращает время, необходимое для открытия чертежа.

  7. Если в чертеже есть внешние ссылки, но загружать их не требуется, установите флажок "Выгрузить ссылки при открытии".

    8. Примечание Если частично открывается чертеж, содержащий внедренную внешнюю ссылку, то только загруженная ее часть (определяемая выбранным видом) связывается с частично открытым чертежом.

  8. Нажмите кнопку "Открыть".

    9. В частично открытый чертёж можно загружать дополнительную информацию.

Ввод команды: ОТКРЧАСТЬ


Загрузка дополнительной геометрии в частично открытый чертеж - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Частичное открытие и частичная загрузка
Понятия
Процедуры
Команды

Загрузка дополнительной геометрии в частично открытый чертеж

  1. Выберите "Файл" » "Частичная загрузка".

    2. Пункт меню "Частичная загрузка" становится доступен только после выполнения частичного открытия текущего чертежа.

  2. В диалоговом окне "Частичная загрузка" выберите вид или нажмите кнопку "Указать рамкой" для задания вида.

    3. По умолчанию предлагается вид "Границы". Геометрию можно загрузить только из видов пространства модели, имеющихся в данном чертеже.

  3. Выберите один или несколько слоев.

    4. Если не выбрано ни одного слоя для загрузки, геометрия слоев в чертёж не загружается, но все слои присутствуют в чертеже. Если не задана геометрия слоя для загрузки в чертёж, геометрия не загружается даже в том случае, если для загрузки задана геометрия из вида. Следует иметь в виду, что создавая объекты на слое, геометрия с которого не загружена, пользователь может осуществлять построения поверх имеющейся, но не загруженной в чертёж геометрии. Выгрузить геометрию, загруженную в текущий чертеж, нельзя.

  4. Нажмите кнопку "Открыть".

Ввод команды: ЗАГРЧАСТЬ


Частичное открытие и частичная загрузка - Команды

Открытие или сохранение чертежа
Открытие или сохранение чертежа
Частичное открытие и частичная загрузка
Понятия
Процедуры
Команды

Команды
ЗАГРЧАСТЬ | Дополнительная загрузка геометрии в частично открытый чертеж
ОТКРЧАСТЬ | Загрузка геометрии и именованных объектов в чертеж из выбранного вида или слоя.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с несколькими чертежами - Понятия

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Работа с несколькими чертежами
Понятия
Процедуры
Команды

Информацию можно легко перемещать между чертежами, открытыми в одном сеансе.

При открытии нескольких чертежей в одном сеансе можно

  • Быстро просматривать другие чертежи
  • Копировать и вставлять элементы из одного чертежа в другой
  • С помощью правой кнопки мыши перетаскивать выделенные объекты из одного чертежа в другой
  • Использовать функцию "Копирование свойств" (КОПИРОВАТЬСВ) для копирования свойств из объектов одного чертежа в объекты другого
  • Использовать объектные привязки, команду копирования с запоминанием базовой точки (БТКОПИРОВАТЬ), а также команду вставки из буфера с восстановлением исходных координат (ВСТИСХОД) для точного позиционирования объектов

Задайте для команды ПАНЗАДАЧ значение 1, чтобы несколько открытых чертежей отобразить в виде отдельных элементов на панели задач Windows. Далее можно нажать ALT+TAB для быстрого переключения между чертежами. Если на панели задач требуется отображать только активный чертеж, задайте для команды ПАНЗАДАЧ задач значение 0.


Переключение между открытыми чертежами - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Работа с несколькими чертежами
Понятия
Процедуры
Команды

Переключение между открытыми чертежами

Для переключения между открытыми чертежами выполните одно из следующих действий:

  • Нажмите в любом месте чертежа для его активации.
  • Используйте сочетания клавиш CTRL+F6 или CTRL+TAB.
  • Задайте для команды ПАНЗАДАЧ значение 1, чтобы несколько открытых чертежей отобразить в виде отдельных элементов на панели задач Windows. После этого быстрое переключение между чертежами осуществляется нажатием сочетания клавиш Alt+TAB.

Ввод команды: ПАНЗАДАЧ


Работа с несколькими чертежами - Команды

Открытие или сохранение чертежа
Открытие или сохранение чертежа
Работа с несколькими чертежами
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПАНЗАДАЧ | Управление отображением чертежей на панели задач Windows
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение чертежей - Понятия

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Сохранение чертежей
Понятия
Процедуры
Команды

Сохранение чертежей для дальнейшего использования выполняется так же, как и в других приложениях Microsoft Windows. Можно установить режим автоматического сохранения файлов и резервных копий, а также сохранения только выбранных объектов.

При работе с чертежом рекомендуется периодически сохранять его. Это позволит избежать потери данных при возникновении непредвиденных ситуаций, например, при сбое питания. Если требуется создать новую версию чертежа, можно сохранить исходный чертёж под другим именем.

Расширением имени файла для файлов чертежей является .dwg и, пока пользователь не изменит формат файла по умолчанию, в котором сохраняются чертежи, они сохраняются в последнем заданном формате файла чертежа. Этот формат имеет высокую степень сжатия и хорошо подходит для использования в сети.

Длина имени файла DWG (включая путь) не может превышать 256 символов.

Сохранение части чертежа

Для сохранения части имеющегося чертежа в новом файле используются команды БЛОК и ПБЛОК. С помощью этих команд можно выделить несколько объектов или определить блок, а затем сохранить их в новом файле чертежа. Кроме того, наряду с новым чертежом можно сохранить текстовое пояснение.

Сохранение чертежа в различных форматах

Чертежи можно сохранять в прежних версиях формата чертежа (DWG) и формата графического обмена (DXF), а также в виде шаблонов. Формат сохраняемого файла чертежа задается в списке "Тип файла" диалогового окна "Сохранение чертежа".

Повышение скорости сохранения чертежей

Для повышения скорости сохранения файлов чертежей можно использовать режим сохранения изменений вместо режима полной записи. В режиме сохранения изменений обновляются только те фрагменты сохраненного файла чертежа, которые подверглись изменениям.

При использовании режима сохранения изменений файлы чертежей содержат определенный процент неиспользуемого дискового пространства. Этот процент увеличивается с каждым сохранением, пока не достигнет установленного максимума, после чего производится полное сохранение. Процент неиспользуемого дискового пространства, допустимый в файле чертежа, можно установить на вкладке "Открытие/Сохранение" диалогового окна "Настройка" или с помощью присвоения значения системной переменной ISAVEPERCENT. Если переменной ISAVEPERCENT присвоено значение 0, то файлы всегда сохраняются полностью.

Для уменьшения размера файлов чертежей рекомендуется производить полное сохранение (переменной ISAVEPERCENT должно быть присвоено значение 0) перед отправкой или архивацией файлов.

Международное сотрудничество

При совместном использовании файлов чертежей с иностранными компаниями имена файлов чертежей могут содержать символы, отсутствующие в других языках.

Если файл чертежа создан в версии Windows с другим языком, происходит следующее:

  • Если установлена поддержка соответствующего языка, символы имени файла видны в проводнике Windows.
  • Если поддержка языка не установлена, то символы имени файла отображаются в проводнике Windows в форме прямоугольников и на экран выводится диалоговое окно с запросом установки языкового пакета.

В любом случае пользователь имеет возможность открыть начало файла чертежа с помощью AutoCAD 2007 или AutoCAD LT 2007, поскольку эти продукты являются приложениями, поддерживающими кодовую таблицу Unicode.

Примечание Если файлы чертежей используются совместно с компаниями, работающими с более ранними версиями продукта, предусмотрена возможность избежать проблем с именами файлов для азиатских языков и языков, использующих диакритические знаки. В этих условиях нельзя использовать символы с большими значениями кодов ASCII или значениями, равными или превышающими шестнадцатеричное значение 80, при создании имени файла.

См. также

Сохранение чертежей в форматах прежних версий

Создание файлов в других форматах

Сохранение блока в отдельном файле

Добавление идентификационных сведений к чертежам

Создание файлов архива и восстановление

Совместное использование файлов пользователями из разных стран


Сохранение чертежей - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Сохранение чертежей
Понятия
Процедуры
Команды

Сохранение чертежа

Автоматическое сохранение чертежа

Сохранение резервных копий чертежей

Сохранение выбранных объектов в новом файле

Сохранение описания блока в новом файле чертежа


Сохранение чертежа - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Сохранение чертежей
Понятия
Процедуры
Команды

Сохранение чертежа

  1. Выберите "Файл" » "Сохранить".

    2. Если данный чертеж сохраняется не в первый раз, то все выполненные изменения сохраняются, и снова отображается командная строка. При первом сохранении вызывается диалоговое окно "Сохранение чертежа".

  2. В диалоговом окне "Сохранение чертежа" в поле "Имя файла" введите имя чертежа. Ввод расширения не требуется. Нажмите кнопку "Сохранить".

Панель "Стандартная"

Ввод команды: СОХРАНИТЬ


Автоматическое сохранение чертежа - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Сохранение чертежей
Понятия
Процедуры
Команды

Автоматическое сохранение чертежа

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" установите флажок "Автосохранение".
  3. Введите значение временного интервала сохранения в минутах.
  4. Нажмите "ОК".


Сохранение резервных копий чертежей - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Сохранение чертежей
Понятия
Процедуры
Команды

Сохранение резервных копий чертежей

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" установите флажок "Создавать резервные копии".
  3. Нажмите "ОК".


Сохранение выбранных объектов в новом файле - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Сохранение чертежей
Понятия
Процедуры
Команды

Сохранение выбранных объектов в новом файле

  1. В командной строке введите пблок.
  2. В группе "Объекты" диалогового окна "Запись блока на диск" выберите параметр "Объекты".
  3. В группе "Базовая точка" нажмите кнопку "Указать".
  4. Выберите базовую точку в области рисования или введите значения координат в поля X, Y и Z.
  5. В группе "Объекты" нажмите кнопку "Выбрать объекты".
  6. Выберите объекты в области рисования.
  7. В группе "Объекты" выберите вариант обработки выбранных объектов (оставить, сделать блоком или удалить из чертежа).
  8. В поле "Имя файла" введите имя нового файла чертежа.
  9. В поле "Размещение" укажите папку для сохранения нового файла чертежа.
  10. В раскрывающемся списке "Единицы измерения" можно выбрать другую базовую единицу. Этот параметр позволяет автоматически задавать масштаб объектов в новом файле чертежа.
  11. Нажмите "ОК".

    12. Выбранные объекты сохраняются в новом файле чертежа.

Ввод команды: ПБЛОК


Сохранение описания блока в новом файле чертежа - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Сохранение чертежей
Понятия
Процедуры
Команды

Сохранение описания блока в новом файле чертежа

  1. В командной строке введите пблок.
  2. В диалоговом окне "Запись блока на диск" поставьте переключатель в положение "Блок".
  3. Нажмите кнопку мыши в клетке рядом с кнопкой "Блок". Выберите описание блока, которое требуется сохранить.
  4. В поле "Имя файла" введите имя нового файла чертежа.
  5. В поле "Размещение" укажите папку для сохранения нового файла чертежа.
  6. В раскрывающемся списке "Единицы измерения" можно выбрать другую базовую единицу. Этот параметр позволяет автоматически задавать масштаб объектов в новом файле чертежа.
  7. Нажмите "ОК".

    8. Объекты выбранного описания блока сохраняются в новом файле чертежа. Базовая точка вставки описания блока имеет в новом чертеже координаты (0, 0, 0).

Ввод команды: ПБЛОК


Сохранение чертежей - Команды

Открытие или сохранение чертежа
Открытие или сохранение чертежа
Сохранение чертежей
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПБЛОК | Запись объектов или блока в новый файл чертежа
ПОКИНУТЬ | Завершение работы программы
СОХРАНИТЬ | Сохранение чертежа под текущим или заданным именем
Системные переменные
DWGCHECK | Управляет проверкой чертежей на потенциальные ошибки при их открытии
DWGNAME | Сохраняет имя чертежа, введенное пользователем
DWGPREFIX | Сохраняет путь к чертежу (диск и папка)
DWGTITLED | Указывает, присвоено ли текущему чертежу имя
ISAVEBAK | Повышает скорость последовательных сохранений, особенно для больших чертежей
ISAVEPERCENT | Определяет количество неиспользуемого дискового пространства, допустимого в файле чертежа
RASTERPREVIEW | Управляет сохранением вместе с чертежом образцов для просмотра в формате BMP
SAVEFILE | Сохраняет имя текущего файла автоматического сохранения
SAVEFILEPATH | Указывает путь к папке всех файлов автоматического сохранения для текущего сеанса
SAVENAME | Сохраняет имя файла и путь к папке самого последнего сохраненного чертежа
SAVETIME | Задает интервал автоматического сохранения (в минутах)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Поиск чертежей - Понятия

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Поиск чертежей
Понятия
Процедуры
Команды

С помощью фильтров, задающих имя искомого файла, папку, дату, а также значения определенных свойств, таких как ключевые слова в чертежах, можно выполнять поиск чертежей или текстовых строк, содержащих определенное слово или фразу.

  • Для поиска чертежей по фильтрам имён, папок и дат создания используется инструмент поиска Microsoft® Windows®. Можно также указать слово или фразу, содержащуюся в файле чертежа. Можно выполнить поиск любой текстовой информации, кроме текста в таблицах и полях, а также внешних ссылок в файлах чертежей. Поддерживаются следующие типы файлов чертежей: DWG, DWF, DWT и DWS.
  • Для поиска свойств файлов Microsoft Windows используется диалоговое окно поиска центра управления DesignCenter™: например, для поиска заголовков или ключевых слов, имеющихся в чертежах.
  • Для предварительного просмотра файла чертежа с помощью команды ОТКРЫТЬ используйте диалоговое окно "Выбор файла". Если системная переменная RASTERPREVIEW имеет значение "Вкл", то при сохранении чертежей автоматически создаются и сохраняются растровые изображения предварительного просмотра.

См. также

Добавление идентификационных сведений к чертежам

Доступ к содержимому с помощью DesignCenter

Работа с листами в подшивке


Поиск файлов - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Поиск чертежей
Понятия
Процедуры
Команды

Поиск файлов

  1. Выберите "Файл" » "Открыть".
  2. В диалоговом окне "Выбор файла" выберите "Сервис" » "Найти".
  3. В диалоговом окне "Поиск файлов" перейдите на вкладку "Имя и размещение" и укажите тип искомого файла, его имя и путь поиска.

    4. Для указания имен файлов можно использовать символы-шаблоны.

  4. Для выполнения поиска по дате выберите на вкладке "Дата" параметр "Все файлы" или "Найти все файлы, созданные или измененные".

    5. Для поиска можно указать период между датами или число последних месяцев или дней.

  5. Нажмите кнопку "Найти".
  6. В результатах поиска выберите один или несколько файлов. Нажмите "ОК".
  7. В окне "Выбор файла" нажмите кнопку "Открыть".

Панель "Стандартная"

Ввод команды: ОТКРЫТЬ


Поиск чертежей - Команды

Открытие или сохранение чертежа
Открытие или сохранение чертежа
Поиск чертежей
Понятия
Процедуры
Команды

Команды
ОТКРЫТЬ | Открытие существующего файла чертежа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Укажите "Пути поиска" и "Местоположения файлов" - Понятия

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Укажите "Пути поиска" и "Местоположения файлов"
Понятия
Процедуры
Команды

Имеется возможность задания путей доступа для поиска вспомогательных файлов, таких как шрифты, чертежи, типы линий, образцы штриховки и т.д. Можно также указать папку для хранения временных файлов, что важно при работе в сети.

На вкладке "Файлы" диалогового окна "Настройка" указывается путь поиска, который используется программой для поиска файлов поддержки чертежей, например шрифтов, чертежей, типов линий и образцов штриховки. В системной переменной MYDOCUMENTSPREFIX хранится путь к папке Мои документы для текущего пользователя.

На вкладке "Файлы" также перечисляются все пути доступа к папкам, которые существуют в текущей структуре папок локальных и сетевых дисков. Использование этих параметров позволяет увеличить эффективность загрузки файлов.

На вкладке "Файлы" диалогового окна "Настройка" задается также путь доступа к временным файлам. Временные файлы создаются на диске, а затем удаляются при выходе из программы. Временные файлы помещаются в ту же папку, где хранятся временные файлы Microsoft Windows. Если предполагается запуск этой программы из папки, защищенной от записи (например, по сети или с компакт-диска), то для временных файлов следует назначить другую папку.

Необходимо, чтобы в эту временную папку была разрешена запись. Нужно также убедиться в том, что на выбранном диске достаточно места для размещения временных файлов. Рекомендуется вручную регулярно удалять файлы из этой папки, чтобы для временных файлов всегда было достаточно свободного места на диске. Если на диске недостаточно места для временных файлов, то при работе программы могут возникать сбои и ошибки.

Если требуется использовать файл, который содержит специальные элементы интерфейса, укажите его в элементе "Файлы адаптаций" на вкладке "Файлы" диалогового окна "Настройка". По умолчанию файлом адаптации является файл acad.cui.


Изменение пути поиска - Процедуры

Создание, организация и сохранение чертежей
Открытие или сохранение чертежа
Укажите "Пути поиска" и "Местоположения файлов"
Понятия
Процедуры
Команды

Изменение пути поиска

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" на вкладке "Файлы" нажмите кнопку мыши на значке "плюс" (+) слева от заголовка пути доступа, который нужно изменить.
  3. Выберите путь, который требуется изменить.
  4. Нажмите "Обзор", а затем выполните поиск нужных дисков и папок.
  5. Выберите нужный диск и папку.
  6. Нажмите "ОК".

Ввод команды: НАСТРОЙКА


Укажите "Пути поиска" и "Местоположения файлов" - Команды

Открытие или сохранение чертежа
Открытие или сохранение чертежа
Укажите "Пути поиска" и "Местоположения файлов"
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
MYDOCUMENTSPREFIX | Хранит полный путь к папке "Мои документы" текущего пользователя
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Восстановление файлов чертежей - Понятия

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Понятия
Процедуры
Команды

В случае повреждения файла чертежа или аварийного завершения работы программы можно восстановить все данные или их часть с помощью команд, позволяющих найти и исправить ошибки или вернуться к файлу резервной копии.

  • Восстановление поврежденного файла чертежа
    В случае повреждения файла чертежа можно восстановить все данные или их часть с помощью команд, позволяющих найти и исправить ошибки.
  • Создание файлов архива и восстановление
    Файлы архива гарантируют безопасность хранения данных чертежа. При возникновении проблем можно восстановить чертёж с помощью файла архива.
  • Восстановление после системного сбоя
    Неполадки в работе оборудования или программного обеспечения и перебои в питании могут привести к аварийному завершению работы программы. Если это случится, файлы чертежей, которые были открыты, можно восстановить.


Восстановление файлов чертежей - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Понятия
Процедуры
Команды

Восстановление поврежденного файла чертежа

Восстановление файла чертежа, повреждённого в результате системного сбоя

Восстановление открытого чертежа

Восстановление чертежа из файла архива

Восстановление чертежа из файла архива

Открытие модуля "Диспетчер восстановления чертежей"

Восстановление чертежа с помощью модуля "Диспетчер восстановления чертежей"

Удаление чертежа из окна "Диспетчер восстановления чертежей"

Развертывание или свёртывание всех элементов в окне "Диспетчер восстановления чертежей"

Для активизации/отключения возможности отправки в компанию Autodesk отчётов об ошибках


Восстановление файлов чертежей - Команды

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Понятия
Процедуры
Команды
Команды
ВОССТАН | Восстановление поврежденного чертежа
ВОССТАНЧЕРТЕЖА | Отображает список имен файлов чертежей, подлежащих восстановлению после сбоя системы
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПРОВЕРИТЬ | Проверяет целостность чертежа и исправляет некоторые ошибки
СКРЫТЬВОССТАНЧЕРТЕЖА | Закрытие диспетчера восстановления чертежей
Системные переменные
AUDITCTL | Контроль создания файла отчета проверки (ADT) с помощью команды ПРОВЕРИТЬ
DRSTATE | Определяет, активно ли окно "Восстановление чертежа"
ISAVEBAK | Повышает скорость последовательных сохранений, особенно для больших чертежей
RECOVERYMODE | Управляет записью информации о восстановлении чертежа после системного сбоя
REPORTERROR | Управляет возможностью отправки отчета об ошибке в компанию Autodesk при неожиданном закрытии программы
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Восстановление поврежденного файла чертежа - Понятия

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление поврежденного файла чертежа
Понятия
Процедуры
Команды

В случае повреждения файла чертежа можно восстановить все данные или их часть с помощью команд, позволяющих найти и исправить ошибки.

Исправление и восстановление

При возникновении ошибки диагностические сведения записываются в файл acad.err, который затем можно использовать для изучения проблемы.

Если обнаружены поврежденные данные или запрос на сохранение чертежа осуществляется после программного сбоя, файл чертежа помечается как поврежденный. Если повреждение незначительно, то иногда чертёж автоматически восстанавливается при следующем открытии. В противном случае можно использовать следующие команды:

  • ВОССТАН. Выполняет проверку и пытается открыть любой файл чертежа.
  • ПРОВЕРИТЬ. Находит и исправляет ошибки в текущем открытом файле чертежа.
Пример: проверка файлов

В результате проверки файла создается отчёт с описанием ошибок в файле чертежа и рекомендациями по их устранению. При запуске проверки пользователь может указать, должна ли программа пытаться исправить имеющиеся ошибки. Отчёт может выглядеть следующим образом:

Проверка заголовка

ИМЯ DXF Текущее значение Проверка По умолчанию

PDMODE 990 - 2040

UCSFOLLOW 811 or 0

При проверке переменных заголовка обнаружена ошибка

Проверено блоков: 4

Проход 1: проверено объектов: 4

Проход 2: проверено объектов: 4

Всего найдено ошибок: 2, исправлено: 2

Если проверка выполняется без устранения ошибок, то вместо последнего блока сообщений будет выведено:

Всего найдено ошибок: 2, исправлено: 0

Выходные данные аудита восстановления записываются в файл регистрационного журнала аудита (ADT) в случае, если системная переменная AUDITCTL равняется 1 (Вкл).

Полное восстановление поврежденных файлов не гарантировано. Программа, насколько это возможно, восстанавливает данные поврежденных файлов.

См. также

Создание файлов архива и восстановление


Восстановление поврежденного файла чертежа - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление поврежденного файла чертежа
Понятия
Процедуры
Команды

Восстановление поврежденного файла чертежа

Восстановление файла чертежа, повреждённого в результате системного сбоя

Восстановление открытого чертежа

Восстановление чертежа из файла архива


Восстановление поврежденного файла чертежа - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление поврежденного файла чертежа
Понятия
Процедуры
Команды

Восстановление поврежденного файла чертежа

  1. Выберите "Файл" » "Утилиты" » "Восстан".
  2. В диалоговом окне "Выбор файла" выберите файл. Нажмите кнопку "Открыть".

    3. Для удобного доступа к объектам, в которых обнаружены ошибки, команда ВОССТАН помещает их все в предыдущий набор объектов. Выходные данные аудита восстановления записываются в файл регистрационного журнала аудита (ADT) в случае, если системная переменная AUDITCTL равняется 1 (вкл).

Ввод команды: ВОССТАН


Восстановление файла чертежа, повреждённого в результате системного сбоя - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление поврежденного файла чертежа
Понятия
Процедуры
Команды

Восстановление файла чертежа, повреждённого в результате системного сбоя

  1. Если программа обнаруживает ошибку и не может продолжать работу, то появляется сообщение об ошибке, а для некоторых ошибок - код ошибки. Запишите числовой код ошибки, затем, если это возможно, сохраните изменения чертежа и выйдите из программы.
  2. Перезапустите программу.
  3. В окне "Восстановление чертежа", в разделе "Файлы архива", дважды нажмите кнопку мыши на элементе чертежа, чтобы его развернуть. В списке дважды нажмите на одном из файлов чертежей или архива, чтобы его открыть.

    4. Если программа обнаружит, что чертёж поврежден, появится соответствующее сообщение с запросом о продолжении работы.

  4. Для продолжения введите y.

    5. После попытки восстановления чертежа, предпринятой программой, появится диагностический отчёт о проверке. Выходные данные аудита восстановления записываются в файл регистрационного журнала аудита (ADT) в случае, если системная переменная AUDITCTL равняется 1 (вкл).

  5. В зависимости от степени успеха восстановления выполните следующее:
    • Если восстановление полностью завершено, чертёж открывается. Сохраните файл чертежа.
    • Если программе не удастся восстановить файл, появится сообщение. В этом случае, начиная с шага 3, выберите другой файл чертежа или архива из списка "Восстановление чертежа".

Ввод команды: ВОССТАН


Восстановление открытого чертежа - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление поврежденного файла чертежа
Понятия
Процедуры
Команды

Восстановление открытого чертежа

  1. Выберите "Файл" » "Утилиты" » "Проверить".
  2. По запросу "Исправить все обнаруженные ошибки?" введите y или n.

    3. Для удобного доступа к объектам, в которых обнаружены ошибки, команда ПРОВЕРИТЬ помещает их все в предыдущий набор объектов. Выходные данные аудита восстановления записываются в файл регистрационного журнала аудита (ADT) в случае, если системная переменная AUDITCTL равняется 1 (вкл).

    Примечание Если с помощью команды AUDIT не удаётся исправить ошибки в чертеже, следует воспользоваться командой ВОССТАН. Команда ВОССТАН восстанавливает любой указанный DWG-файл, не являющийся текущим файлом чертежа.

Ввод команды: ПРОВЕРИТЬ


Восстановление чертежа из файла архива - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление поврежденного файла чертежа
Понятия
Процедуры
Команды

Восстановление чертежа из файла архива

  1. С помощью Проводника Windows найдите файл резервной копии чертежа с расширением bak.
  2. Нажмите правую кнопку мыши на файле архива. Выберите "Переименовать".
  3. Введите новое имя с расширением dwg.
  4. Откройте файл как обычный файл чертежа.


Восстановление поврежденного файла чертежа - Команды

Восстановление файлов чертежей
Восстановление файлов чертежей
Восстановление поврежденного файла чертежа
Понятия
Процедуры
Команды

Команды
ВОССТАН | Восстановление поврежденного чертежа
ВОССТАНЧЕРТЕЖА | Отображает список имен файлов чертежей, подлежащих восстановлению после сбоя системы
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПРОВЕРИТЬ | Проверяет целостность чертежа и исправляет некоторые ошибки
Системные переменные
AUDITCTL | Контроль создания файла отчета проверки (ADT) с помощью команды ПРОВЕРИТЬ
REPORTERROR | Управляет возможностью отправки отчета об ошибке в компанию Autodesk при неожиданном закрытии программы
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание файлов архива и восстановление - Понятия

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Создание файлов архива и восстановление
Понятия
Процедуры
Команды

При работе над чертежом могут возникать различные сбои, вызванные неполадками оборудования или программного обеспечения, неожиданным отключением питания или неверными действиями самого пользователя. Потери данных в таких случаях можно свести к минимуму, если периодически выполнять сохранение результатов работы. При возникновении проблем можно восстановить чертёж с помощью файла архива.

Создание резервных копий файлов

В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" можно указать, что при сохранении чертежей должны создаваться файлы архива. В этом случае при каждом сохранении чертежа предыдущая его версия сохраняется в файле с тем же именем с расширением .bak. Файл архива располагается в той же папке, что и файл чертежа.

Чтобы выполнить восстановление из архивной версии, можно переименовать .bak-файл в проводнике Windows в файл с расширением .dwg. В этом случае, если необходимо сохранить последнюю версию чертежа, резервную копию можно скопировать в другую папку.

Периодическое автосохранение чертежа.

Если режим автосохранения включён, чертёж сохраняется периодически по истечении установленного интервала времени. По умолчанию автосохранение происходит во временные файлы с именем в виде имя_a_b_nnnn.sv$.

  • Имя - это текущее название чертежа.
  • a - это число открытых копий одного и того же файла чертежа в одном сеансе.
  • b - это число открытых копий одного и того же чертежа в разных сеансах.
  • nnnn - произвольное число.

При успешном закрытии чертежа удаляются все временные файлы, созданные в результате автосохранения. В случае программного сбоя или перебоя в энергоснабжении эти файлы не удаляются.

Чтобы восстановить предыдущую версию чертежа из автоматически сохраненного файла, необходимо до завершения работы программы переименовать файл, используя расширение .dwg вместо расширения .sv$.

См. также

Восстановление после системного сбоя


Восстановление чертежа из файла архива - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Создание файлов архива и восстановление
Понятия
Процедуры
Команды

Восстановление чертежа из файла архива

  1. С помощью Проводника Windows найдите файл резервной копии чертежа с расширением .bak.
  2. Выделите найденный файл. Открывать его не обязательно.
  3. Выберите "Файл" » "Переименовать".
  4. Введите новое имя с расширением .dwg.
  5. Откройте файл как обычный файл чертежа.


Создание файлов архива и восстановление - Команды

Восстановление файлов чертежей
Восстановление файлов чертежей
Создание файлов архива и восстановление
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
ISAVEBAK | Повышает скорость последовательных сохранений, особенно для больших чертежей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Восстановление после системного сбоя - Понятия

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление после системного сбоя
Понятия
Процедуры
Команды

Неполадки в работе оборудования или программного обеспечения и перебои в питании могут привести к аварийному завершению работы программы. Если это случится, файлы чертежей, которые были открыты, можно восстановить.

В случае сбоя программы результаты выполненной работы могут быть сохранены в другом файле. Для этого файла используется формат DrawingFileName_recover.dwg, где DrawingFileName - это имя файла текущего чертежа.

Решение проблем файлов чертежей

После программного или системного сбоя при следующем запуске AutoCAD открывается "Диспетчер восстановления чертежей". Модуль "Диспетчер восстановления чертежей" отображает список всех файлов чертежей, которые были открыты, включая файлы чертежей следующих типов.

  • Файлы чертежей (DWG)
  • Файлы шаблонов чертежей (DWT)
  • Файлы стандартов оформления (DWS)

Примечание Несохраненные чертежи, открытые в момент сбоя, модулем "Диспетчер восстановления чертежей" не отслеживаются. Обязательно сохраняйте файл после начала работы и регулярно во время работы над ним.

Для каждого чертежа можно открыть и выбрать какой-нибудь из следующих файлов, если они существуют:

  • DrawingFileName_recover.dwg
  • DrawingFileName_a_b_nnnn.sv$
  • DrawingFileName.dwg
  • DrawingFileName.bak

Примечание Файлы чертежей, архива и файлы восстановления приводятся в списке в последовательности, соответствующей времени их последнего сохранения.

Дважды нажмите на элементе чертежа верхнего уровня, указанного в разделе "Файлы архива", чтобы отобразить до четырех файлов, перечисленных выше. Нажмите правую кнопку мыши на любом элементе в разделе "Файлы архива" для отображения параметров контекстного меню.

Если окно "Восстановление чертежа" закрыто до разрешения проблем во всех поврежденных файлах, его можно открыть позже с помощью команды ВОССТАНЧЕРТЕЖА.

Автоматическая отправка отчёта об ошибке в компанию Autodesk

В программе имеется возможность послать отчёт об ошибке в компанию Autodesk, где он будет использован для устранения подобных проблем в будущем. Отчёт об ошибке содержит информацию о состоянии системы на момент сбоя. Кроме того, можно ввести дополнительную информацию, например, о действиях пользователя, предшествовавших сбою. Системная переменная REPORTERROR управляет возможностью отправки в Autodesk отчётов об ошибках в работе AutoCAD.


Восстановление после системного сбоя - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление после системного сбоя
Понятия
Процедуры
Команды

Открытие модуля "Диспетчер восстановления чертежей"

Восстановление чертежа с помощью модуля "Диспетчер восстановления чертежей"

Удаление чертежа из окна "Диспетчер восстановления чертежей"

Развертывание или свёртывание всех элементов в окне "Диспетчер восстановления чертежей"

Для активизации/отключения возможности отправки в компанию Autodesk отчётов об ошибках


Открытие модуля "Диспетчер восстановления чертежей" - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление после системного сбоя
Понятия
Процедуры
Команды

Открытие модуля "Диспетчер восстановления чертежей"

  • Выберите "Файл" » "Утилиты" » "Диспетчер восстановления чертежей".

    • В разделе "Файлы архива" указаны чертежи, которые требуется восстановить после неожиданного программного или системного сбоя.

Ввод команды: ВОССТАНЧЕРТЕЖА


Восстановление чертежа с помощью модуля "Диспетчер восстановления чертежей" - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление после системного сбоя
Понятия
Процедуры
Команды

Восстановление чертежа с помощью модуля "Диспетчер восстановления чертежей"

  1. В случае необходимости откройте окно "Диспетчер восстановления чертежей".
  2. В окне "Диспетчер восстановления чертежей", в разделе "Файлы архива", дважды нажмите на элементе чертежа, чтобы отобразился список всех имеющихся файлов чертежей и архива.
  3. Дважды нажмите на файле, чтобы его открыть.

    4. Если файл чертежа поврежден, исправления в чертеже по возможности выполняются автоматически.

Ввод команды: ВОССТАНЧЕРТЕЖА


Удаление чертежа из окна "Диспетчер восстановления чертежей" - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление после системного сбоя
Понятия
Процедуры
Команды

Удаление чертежа из окна "Диспетчер восстановления чертежей"

  1. Если потребуется, выберите "Файл" » "Утилиты" » "Диспетчер восстановления чертежей".
  2. Выполните одно из следующих действий:
    • Восстановите чертеж, а затем сохраните его.
    • Нажмите правую кнопку мыши на элементе чертежа. Выберите "Исключить".

Ввод команды: ВОССТАНЧЕРТЕЖА


Развертывание или свёртывание всех элементов в окне "Диспетчер восстановления чертежей" - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление после системного сбоя
Понятия
Процедуры
Команды

Развертывание или свёртывание всех элементов в окне "Диспетчер восстановления чертежей"

  • Нажмите правую кнопку мыши в области раздела "Файлы архива" ниже последнего элемента чертежа в списке. Выберите "Свернуть все".

Ввод команды: ВОССТАНЧЕРТЕЖА


Для активизации/отключения возможности отправки в компанию Autodesk отчётов об ошибках - Процедуры

Создание, организация и сохранение чертежей
Восстановление файлов чертежей
Восстановление после системного сбоя
Понятия
Процедуры
Команды

Для активизации/отключения возможности отправки в компанию Autodesk отчётов об ошибках

  1. В командной строке введите reporterror.
  2. Введите 0 для отключения возможности отправки отчетов об ошибках; введите 1 для активизации возможности отправки отчетов об ошибках.


Восстановление после системного сбоя - Команды

Восстановление файлов чертежей
Восстановление файлов чертежей
Восстановление после системного сбоя
Понятия
Процедуры
Команды

Команды
ВОССТАН | Восстановление поврежденного чертежа
ВОССТАНЧЕРТЕЖА | Отображает список имен файлов чертежей, подлежащих восстановлению после сбоя системы
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
СКРЫТЬВОССТАНЧЕРТЕЖА | Закрытие диспетчера восстановления чертежей
Системные переменные
DRSTATE | Определяет, активно ли окно "Восстановление чертежа"
ISAVEBAK | Повышает скорость последовательных сохранений, особенно для больших чертежей
RECOVERYMODE | Управляет записью информации о восстановлении чертежа после системного сбоя
REPORTERROR | Управляет возможностью отправки отчета об ошибке в компанию Autodesk при неожиданном закрытии программы
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Соблюдение стандартов в чертежах - Понятия

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Понятия
Процедуры
Команды

Для удобства чтения чертежей задаются стандарты, обеспечивающие единство их оформления. Пользователь может устанавливать стандарты для имён слоев, размерных стилей и других элементов, проверять чертежи на соответствие этим стандартам и, в случае обнаружения нарушений, изменять свойства.

  • Обзор стандартов оформления
  • Описание стандартов
    Задаваемые стандарты сохраняются в виде файла стандартов, описывающего свойства слоев, размерных стилей, типов линий и текстовых стилей. Стандарты сохраняются в файле с расширением .dws.
  • Проверка чертежей на соответствие стандартам
    Файлы чертежей можно проверять на соответствие стандартам и затем корректировать, устраняя нарушения. Утилита пакетного нормоконтроля позволяет одновременно проверять несколько файлов.
  • Преобразование имен и свойств слоев
    С помощью модуля "Транслятор слоев" можно выполнять преобразования слоёв чертежа для приведения их к стандартам, устанавливаемым пользователем.

См. также

Работа со слоями

Работа с текстовыми стилями

Работа с типами линий

Размерные стили


Соблюдение стандартов в чертежах - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Понятия
Процедуры
Команды

Создание файла стандартов

Связывание файла стандартов с текущим чертежом

Для разрыва связи текущего чертежа с файлом стандартов

Изменение порядка файлов стандартов, связанных с текущим чертежом

Выбор подключаемых модулей для проверки чертежей на соответствие стандартам

Проверка чертежа на соответствие стандартам

Включение и отключение показа проигнорированных нарушений

Включение и отключение показа уведомлений о нарушениях стандартов

Запуск утилиты пакетного нормоконтроля

Создание файла нормоконтроля для утилиты пакетного нормоконтроля

Открытие существующего файла нормоконтроля

Переопределение стандартов в файле нормоконтроля

Проверка нескольких чертежей на соответствие стандартам

Добавление комментариев к отчёту

Просмотр отчёта о ранее проведённом нормоконтроле

Экспорт отчёта о пакетном нормоконтроле

Преобразование слоёв чертежа в соответствии с заданными стандартами

Выбор слоя для отображения его в области рисования

Очистка чертежа от всех неиспользуемых слоев


Соблюдение стандартов в чертежах - Команды

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Понятия
Процедуры
Команды
Команды
НОРМОКОНТРОЛЬ | Проверка текущего чертежа на соответствие установленным стандартам оформления
СЛОЙТРАНС | Изменение системы слоев чертежа в соответствии с установленными пользователем стандартами
СТАНДАРТЫ | Управляет подключением файлов стандартов к чертежам.
Системные переменные
STANDARDSVIOLATION | Указывает режим оповещения пользователя о нарушениях стандартов в текущем чертеже при создании или изменении нестандартного объекта
Утилиты
Утилита пакетного нормоконтроля | Проверка набора чертежей на соблюдение стандартов оформления
Ключевые слова для команд
Нет. |


Обзор стандартов оформления - Понятия

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Обзор стандартов оформления
Понятия
Процедуры
Команды

Файл стандартов, в котором определяются общие свойства, служит для обеспечения единства оформления файлов чертежей. С помощью стандартов определяются наборы общих свойств именованных объектов, таких как слои и текстовые стили. Пользователь или администратор может создавать, использовать и проверять стандарты, заданные в чертежах . Применение стандартов особенно рекомендуется при совместной работе коллектива над одним проектом, так как стандарты упрощают понимание чертежей другими членами коллектива.

Проверка именованных объектов на соответствие стандартам

Стандарты можно создавать для следующих именованных объектов:

  • слои
  • текстовые стили
  • типы линий
  • размерные стили
Файл стандартов

После того как стандарт определен, его следует сохранить в файле стандартов. Файл стандартов может быть связан с несколькими файлами чертежей. Чертеж, связанный с файлом стандартов, следует периодически проверять на соответствие этим стандартам.

Процедура проверки на соответствие стандартам

При проверке чертежа на соответствие стандартам параметры каждого именованного объекта определенного типа сравниваются с соответствующими параметрами в соответствующих файлах стандартов. Например, параметры каждого слоя чертежа проверяются на соответствие параметрам слоев, заданным в файле стандартов.

В результате проверки могут быть выявлены два типа ошибок:

  • Нестандартное имя объекта в проверяемом чертеже. Например, слой с именем WALL присутствует в чертеже, но не найден ни в одном связанном файле стандартов.
  • Именованный объект со стандартным именем обладает нестандартными свойствами. Например, в чертеже слой WALL имеет желтый цвет, в то время как в файле стандартов для слоя WALL задан красный цвет.

Обнаруженные элементы с нестандартными именами удаляются из чертежа. Все объекты, имевшие связь с нестандартным элементом, связываются с другим элементом, который заменяет удаляемый. Например, при обнаружении нестандартного слоя WALL можно заменить его стандартным слоем АRCH-WALL. В этом случае в режиме "Исправить" диалогового окна "Нормоконтроль" все объекты со слоя WALL переносятся на слой АRCH-WALL, затем слой WALL удаляется из чертежа.

Надстройки для работы со стандартами

Для проверки используются подключаемые модули нормоконтроля, т.е. приложения, описывающие правила проверки свойств именованных объектов. Таким образом, слои, размерные стили, типы линий и текстовые стили проверяются на соответствие стандартам, задаваемым подключаемыми модулями, соответствующими данному типу объекта. Можно указывать, какие подключаемые модули следует использовать при проверке чертежа на соответствие стандартам. Autodesk или другие разработчики имеют возможность добавлять подключаемые модули стандартов для проверки дополнительных свойств чертежа.

Все подключаемые модули (кроме подключаемого модуля проверки слоев) проверяют все свойства каждого именованного объекта на соответствие стандартам. При проверке с использованием подключаемого модуля слоёв проверяются следующие свойства слоев:

  • цвет
  • тип линий
  • вес линий
  • режим стилей печати
  • имя стиля печати (если системная переменная PSTYLEMODE равна 0)

Следующие свойства слоёв не проверяются подключаемым модулем проверки слоев:

  • вкл/откл
  • заморозить/разморозить
  • блокировать
  • печатать/не печатать
Параметры нормоконтроля

С помощью диалогового окна "Параметры нормоконтроля" менеджер по САПР может изменять множество параметров. Для вызова диалогового окна "Параметры нормоконтроля" следует выбрать "Параметры" в диалоговом окне "Нормоконтроль" или "Настройка стандартов".


Соблюдение стандартов в чертежах

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Соблюдение стандартов в чертежах
Понятия
Процедуры
Команды

Нет процедур.


Обзор стандартов оформления - Команды

Соблюдение стандартов в чертежах
Соблюдение стандартов в чертежах
Обзор стандартов оформления
Понятия
Процедуры
Команды

Команды
НОРМОКОНТРОЛЬ | Проверка текущего чертежа на соответствие установленным стандартам оформления
СТАНДАРТЫ | Управляет подключением файлов стандартов к чертежам.
Системные переменные
STANDARDSVIOLATION | Указывает режим оповещения пользователя о нарушениях стандартов в текущем чертеже при создании или изменении нестандартного объекта
Утилиты
Утилита пакетного нормоконтроля | Проверка набора чертежей на соблюдение стандартов оформления
Ключевые слова для команд
Нет. |


Описание стандартов - Понятия

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Описание стандартов
Понятия
Процедуры
Команды

Задаваемые стандарты сохраняются в виде файла стандартов, описывающего свойства слоев, размерных стилей, типов линий и текстовых стилей. Стандарты сохраняются в файле с расширением .dws.

В зависимости от метода организации работы над проектом для одного чертежа можно создать и назначить несколько файлов стандартов. В связи с этим, во время проверки чертежа могут возникать конфликты между параметрами в разных файлах стандартов. Например, пусть в одном файле стандартов для слоя WALL задан желтый цвет, а в другом файле - красный. В таких случаях больший приоритет имеет первый файл стандартов, связанный с чертежом. При необходимости можно поменять порядок файлов стандартов для изменения приоритета параметров.

Когда требуется проверить чертежи на соответствие стандартам с использованием определенного подключаемого модуля, можно указать этот подключаемый модуль при описании файла стандартов. Например, если последние изменения, внесённые в чертеж, касались только текста, то для экономии времени можно ограничиться проверкой чертежа с помощью подключаемых модулей слоёв и подключаемого модуля текстовых стилей. По умолчанию для проверки чертежей на соответствие стандартам используются все подключаемые модули.


Описание стандартов - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Описание стандартов
Понятия
Процедуры
Команды

Создание файла стандартов

Связывание файла стандартов с текущим чертежом

Для разрыва связи текущего чертежа с файлом стандартов

Изменение порядка файлов стандартов, связанных с текущим чертежом

Выбор подключаемых модулей для проверки чертежей на соответствие стандартам


Создание файла стандартов - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Описание стандартов
Понятия
Процедуры
Команды

Создание файла стандартов

  1. Выберите "Файл" » "Создать".
  2. Введите имя файла шаблона или нажмите клавишу ENTER для продолжения.
  3. В новом чертеже создайте необходимые слои, размерные стили, типы линий и текстовые стили, которые должны храниться в файле стандартов.
  4. Выберите "Файл" » "Сохранить как".
  5. В поле "Имя файла" введите имя файла стандартов.
  6. В списке "Тип файла" выберите "Стандарты оформления AutoCAD (*.dws)".

    7. DWS-файлы необходимо сохранять в формате текущей версии программы. Для сохранения DWS-файла в формате предыдущей версии необходимо сначала сохранить файл в DWG-формате требуемой версии, а затем переименовать его, сменив расширение .dwg на .dws.

  7. Нажмите кнопку "Сохранить".


Связывание файла стандартов с текущим чертежом - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Описание стандартов
Понятия
Процедуры
Команды

Связывание файла стандартов с текущим чертежом

  1. В командной строке введите слово стандарты.
  2. В диалоговом окне "Настройка стандартов" на вкладке "Стандарты" нажмите кнопку "+" ("Добавить файл стандартов").
  3. В диалоговом окне "Выбор файла стандартов" найдите и выберите файл стандартов.
  4. Нажмите кнопку "Открыть".
  5. (Не обязательно) Повторите пункты 2 и 3, если нужно связать дополнительные файлы стандартов с текущим чертежом.
  6. Нажмите "ОК".

Панель "Стандарты оформления"


Для разрыва связи текущего чертежа с файлом стандартов - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Описание стандартов
Понятия
Процедуры
Команды

Для разрыва связи текущего чертежа с файлом стандартов

  1. В командной строке введите слово стандарты.
  2. В диалоговом окне "Настройка стандартов" на вкладке "Стандарты" выберите файл стандартов из списка "Файлы стандартов, подключенные к текущему чертежу".
  3. Нажмите кнопку "Отключить файл стандартов".
  4. (Не обязательно) Повторите пункты 2 и 3, если нужно разорвать связи с другими файлами стандартов.
  5. Нажмите "ОК".

Панель "Стандарты оформления"


Изменение порядка файлов стандартов, связанных с текущим чертежом - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Описание стандартов
Понятия
Процедуры
Команды

Изменение порядка файлов стандартов, связанных с текущим чертежом

  1. В командной строке введите слово стандарты.
  2. В диалоговом окне "Настройка стандартов" на вкладке "Стандарты" из списка "Файлы стандартов, подключенные к текущему чертежу" выберите файл стандартов, положение которого нужно изменить.
  3. Выполните одно из следующих действий:
    • Нажмите кнопку со стрелкой вверх ("Вверх") для перемещения файла стандартов в списке на одну позицию вверх.
    • Нажмите кнопку со стрелкой вниз ("Вниз") для перемещения файла стандартов в списке на одну позицию вниз.
  4. (Не обязательно) Повторите пункты 2 и 3, если нужно изменить положение в списке других файлов стандартов.
  5. Нажмите "ОК".

Панель "Стандарты оформления"


Выбор подключаемых модулей для проверки чертежей на соответствие стандартам - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Описание стандартов
Понятия
Процедуры
Команды

Выбор подключаемых модулей для проверки чертежей на соответствие стандартам

  1. В командной строке введите слово стандарты.
  2. В диалоговом окне "Настройка стандартов" на вкладке "Надстройки" выполнить одно из следующих действий:
    • Установить флажок для одного или нескольких подключаемых модулей, которые необходимо задействовать при проверке чертежей на соответствие стандартам.
    • Для выбора всех подключаемых модулей нажмите правой кнопкой мыши в списке подключаемых модулей. Выберите элемент "Выбрать все". (Для отмены выбора всех подключаемых модулей нажмите правую кнопку мыши в списке надстроек и выберите элемент "Отменить выбор".)
  3. Нажмите "ОК".

Панель "Стандарты оформления"


Описание стандартов - Команды

Соблюдение стандартов в чертежах
Соблюдение стандартов в чертежах
Описание стандартов
Понятия
Процедуры
Команды

Команды
НОРМОКОНТРОЛЬ | Проверка текущего чертежа на соответствие установленным стандартам оформления
СТАНДАРТЫ | Управляет подключением файлов стандартов к чертежам.
Системные переменные
STANDARDSVIOLATION | Указывает режим оповещения пользователя о нарушениях стандартов в текущем чертеже при создании или изменении нестандартного объекта
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Проверка чертежей на соответствие стандартам - Понятия

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Файлы чертежей можно проверять на соответствие стандартам и затем корректировать, устраняя нарушения. Утилита пакетного нормоконтроля позволяет одновременно проверять несколько файлов.

Чертеж, связанный с файлом стандартов, следует периодически проверять на соответствие этим стандартам. Это особенно важно в тех случаях, когда над проектом работает целый коллектив. Например, может возникнуть ситуация, когда один из проектировщиков создаёт новые слои, которые не соответствуют стандартам, принятым его коллегами. Поэтому необходимо иметь возможность обнаружения и исправления нестандартных слоев.

Существует возможность уведомления пользователя о возникающих нарушениях стандартов непосредственно во время работы над чертежом. Эта функция позволяет исправлять нарушения стандартов сразу после их возникновения, что намного облегчает соблюдение соответствия стандартам.

Проверка одного чертежа

Для выявления нарушений стандартов в текущем чертеже используется команда НОРМОКОНТРОЛЬ. Перечень нестандартных объектов и варианты исправления нарушений отображаются в диалоговом окне "Нормоконтроль".

Каждое обнаруженное нарушение можно исправить или оставить без изменений. Сведения о каждом обнаруженном, но не исправленном нарушении стандартов сохраняются в чертеже. Можно отключить вывод сведений о таких проигнорированных объектах при последующих проверках чертежа.

Если для текущего нарушения стандартов нет предпочтительного варианта исправления, то в списке "Заменить на" не будет отмеченных вариантов, а кнопка "Исправить" будет недоступна. Если исправляется нарушение, которое в данный момент выведено в диалоговом окне "Нормоконтроль", то это нарушение будет отображаться в нём, пока не нажата кнопка "Исправить" или "Далее".

После того как весь чертёж проверен, отображается окно "Проверка завершена". В этом окне выводится отчёт о всех нарушениях стандартов, обнаруженных в чертеже, а также подробная информация по нарушениям: исправленным автоматически, исправленным вручную, проигнорированным.

Примечание Если нестандартный слой имеет два разных нарушения стандартов (нестандартное имя и нестандартные свойства), то при выборе варианта "Исправить" оба нарушения исправляются одновременно. Это приводит к тому, что информация в окне отчёта "Проверка завершена" не соответствует информации в диалоговом окне "Нормоконтроль": в окне отчёта количество нарушений стандартов будет меньшим, чем в диалоговом окне "Нормоконтроль".

Проверка нескольких чертежей

Для проверки нескольких чертежей применяется утилита пакетного нормоконтроля, которая объединяет все обнаруженные нарушения стандартов в один отчёт, помещаемый в HTML-файл. Перед запуском утилиты необходимо создать файл нормоконтроля (с расширением CHX). CHX-файл предназначен для настройки и отчётности; он содержит список файлов чертежей и стандартов, а также отчёт о результатах проверки чертежей на соответствие стандартам.

По умолчанию для проверки каждого чертежа используются связанные с ним файлы стандартов. Можно также задать иной набор файлов стандартов, отличный от принятого по умолчанию.

После завершения пакетной проверки результаты можно просмотреть в HTML-файле отчёта. Кроме того, в этот отчёт можно включить комментарии. Отчёт можно экспортировать и распечатать. Подобные отчёты с комментариями передаются другим разработчикам проекта для устранения ими нарушений, имеющих отношение к данному участку проекта.

Использование уведомлений о нарушениях стандартов при работе над чертежом

Параметры уведомлений задаются в диалоговом окне "Параметры нормоконтроля" и с помощью системной переменной STANDARDSVIOLATION. Если в диалоговом окне "Параметры нормоконтроля" отмечен пункт "Предупреждать при нарушениях стандартов", то уведомления о нарушениях будут выводиться при обнаружении нарушений стандартов во время работы над чертежом. Если отмечен пункт "Отображать значок стандартов в строке состояния", то в строке состояния будет отображаться значок при открытии файла, связанного с файлом стандартов, и при создании или изменении нестандартных объектов.

По умолчанию, если связанный файл стандартов не найден или обнаружено нарушение стандартов во время работы, в нижнем правом углу окна программы (в строке состояния) появляется сообщение.

Перед началом использования режимов уведомления следует проверить чертёж на соответствие стандартам с помощью диалогового окна "Нормоконтроль". В этом случае предупреждающие сообщения, перешедшие из предыдущего сеанса работы, не выводятся. После того как чертёж прошел проверку и были внесены исправления, предупреждающие сообщения выводятся только при обнаружении новых нарушений стандартов.

Вывод предупреждающих сообщений о нарушениях стандартов для именованных объектов

Если в диалоговом окне "Параметры нормоконтроля" установлен флажок "Предупреждать при нарушениях стандартов", то уведомления о нарушениях выводятся только при работе с именованными объектами (типы линий, текстовые стили, слои, размерные стили). Уведомления не выводятся в случае появления нарушений стандартов, не относящихся к именованным объектам. Кроме того, если в диалоговом окне "Нормоконтроль" именованный объект был помечен как "игнорируемый", то относительно этого объекта также не выводятся уведомления об обнаруженных нарушениях. При изменении нестандартных именованных объектов (например, при задании нестандартного слоя текущим) предупреждающее сообщение выводится.

После появления предупреждающего сообщения можно сделать выбор: исправить нарушение или оставить его без изменений. Если выбрано исправление нарушения, то открывается диалоговое окно "Нормоконтроль". Если оно уже открыто, то исправляться будут только что обнаруженные нарушения. После исправления нарушений можно продолжить прерванную работу в диалоговом окне "Нормоконтроль". Если исправлять нарушение не требуется, то при появлении предупреждающего сообщения следует выбрать "Не исправлять".

При открытии чертежа с одним или несколькими связанными файлами стандартов в строке состояния появляется значок связи с файлом стандартов. Если связанный файл стандартов не найден, то в строке состояния появляется значок отсутствия файла стандартов. Если дважды нажать на значке отсутствия файла стандартов, а затем восстановить или разорвать связи с не найденными файлами стандартов, то вместо значка отсутствия файла стандартов появляется значок связи с файлом стандартов.

Примечание Если в диалоговом окне "Нормоконтроль" выбрать режим "Предупреждать при нарушениях стандартов" и исправить нарушение, то можно вернуться к процедуре исправления на том месте, где она была прервана. Если же активна режим "Отображать значок стандартов в строке состояния", а нарушение исправляется нажатием на значке, то процедуру исправления необходимо начать сначала.


Проверка чертежей на соответствие стандартам - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Проверка чертежа на соответствие стандартам

Включение и отключение показа проигнорированных нарушений

Включение и отключение показа уведомлений о нарушениях стандартов

Запуск утилиты пакетного нормоконтроля

Создание файла нормоконтроля для утилиты пакетного нормоконтроля

Открытие существующего файла нормоконтроля

Переопределение стандартов в файле нормоконтроля

Проверка нескольких чертежей на соответствие стандартам

Добавление комментариев к отчёту

Просмотр отчёта о ранее проведённом нормоконтроле

Экспорт отчёта о пакетном нормоконтроле


Проверка чертежа на соответствие стандартам - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Проверка чертежа на соответствие стандартам

  1. Откройте чертёж с одним или несколькими связанными файлами стандартов.

    2. В строке состояния появляется значок связи с файлом стандартов. Если связанный файл стандартов не найден, то в строке состояния появляется значок отсутствия файла стандартов.

    Примечание Если нажать на значке отсутствия файла стандартов, а затем восстановить или разорвать связи с не найденными файлами стандартов, то вместо значка отсутствия файла стандартов появляется значок связи с файлом стандартов.

  2. Для чертежа с одним или несколькими связанными файлами стандартов в командной строке введите слово нормоконтроль.

    3. В диалоговом окне "Нормоконтроль" в группе "Нарушение" появляется сообщение о первом обнаруженном нарушении.

  3. Выполните одно из следующих действий:
    • Если необходимо исправить нарушение, используя выделенный вариант из списка "Заменить на", то нажмите кнопку "Исправить". Если в списке "Заменить на" имеется рекомендуемый вариант исправления, то слева от него устанавливается флажок. Если рекомендуемых вариантов исправления для данного нарушения нет, то кнопка "Исправить" недоступна.

      • В группе "Нарушение" автоматически выводится сообщение о следующем обнаруженном нарушении стандартов.

    • Исправьте вручную обнаруженное нарушение стандартов. Нажмите кнопку "Далее" для вывода информации о следующем нарушении.
    • Установите флажок "Игнорировать нарушение в дальнейшем". Нажмите кнопку "Далее" для вывода информации о следующем нарушении.

      • Выбор значения "Игнорировать нарушение в дальнейшем" позволяет подавлять вывод сообщения о данном нарушении при очередной проверке командой НОРМОКОНТРОЛЬ.

    • Нажмите кнопку "Далее" для вывода информации о следующем нарушении.
  4. Повторяйте пункты 2 и 3, пока не будут обработаны все нарушения стандартов.
  5. Нажмите кнопку "Закрыть".

Панель "Стандарты оформления"


Включение и отключение показа проигнорированных нарушений - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Включение и отключение показа проигнорированных нарушений

  1. Для чертежа с одним или несколькими связанными файлами стандартов в командной строке введите слово нормоконтроль.
  2. В диалоговом окне "Нормоконтроль" выберите "Параметры".
  3. В диалоговом окне "Параметры нормоконтроля" установите или снимите флажок "Показывать проигнорированные нарушения".
  4. Нажмите "ОК".

Панель "Стандарты оформления"


Включение и отключение показа уведомлений о нарушениях стандартов - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Включение и отключение показа уведомлений о нарушениях стандартов

  1. В командной строке введите слово стандарты.
  2. В диалоговом окне "Настройка стандартов" выберите "Параметры".
  3. Выполните одно из следующих действий:
    • Для отключения уведомлений выберите "Отменить уведомления о стандартах".
    • Для включения уведомлений-предупреждений выберите "Предупреждать при нарушениях стандартов".
    • Для включения уведомлений через значок в строке состояния выберите "Отображать значок стандарта в строке состояния".
  4. Нажмите "ОК".

Панель "Стандарты оформления"


Запуск утилиты пакетного нормоконтроля - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Запуск утилиты пакетного нормоконтроля

  • Выберите меню "Пуск" (Windows) » "Все программы" » Autodesk » AutoCAD 2007 » Утилита пакетного нормоконтроля.

Примечание При запуске утилиты пакетного нормоконтроля из командной строки DOS командой DWGCHECKSTANDARDS можно указывать различные параметры командной строки, используемые при выполнении пакетной проверки на соответствие стандартам.


Создание файла нормоконтроля для утилиты пакетного нормоконтроля - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Создание файла нормоконтроля для утилиты пакетного нормоконтроля

  1. Запустите утилиту пакетного нормоконтроля.
  2. В окне утилиты пакетного нормоконтроля выберите "Файл" » "Создать файл нормоконтроля". (Можно также нажать кнопку "Создать" на панели утилиты пакетного нормоконтроля.)
  3. На вкладке "Чертежи" нажмите кнопку "+" ("Добавить чертеж").
  4. В диалоговом окне "Открытие файла" выберите файл, который нужно проверить.
  5. (Не обязательно) Повторите пункты 3 и 4, если нужно добавить другие чертежи в файл нормоконтроля.
  6. Выберите "Файл" » "Сохранить как". (Можно также нажать кнопку "Сохранить как" на панели утилиты пакетного нормоконтроля.)
  7. В диалоговом окне "Сохранение файла" в поле "Имя файла" введите имя файла.
  8. Нажмите кнопку "Сохранить".


Открытие существующего файла нормоконтроля - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Открытие существующего файла нормоконтроля

  1. Запустите утилиту пакетного нормоконтроля.
  2. В окне утилиты пакетного нормоконтроля выберите "Файл" » "Открыть файл нормоконтроля". (Можно также нажать кнопку "Открыть" на панели утилиты пакетного нормоконтроля.)
  3. В диалоговом окне "Открытие файла" найдите и выберите файл нормоконтроля.
  4. Нажмите кнопку "Открыть".


Переопределение стандартов в файле нормоконтроля - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Переопределение стандартов в файле нормоконтроля

  1. Запустите утилиту пакетного нормоконтроля.
  2. Создайте новый или откройте существующий файл нормоконтроля.
  3. В окне утилиты пакетного нормоконтроля на вкладке "Стандарты" выберите параметр "Использовать для проверки всех чертежей следующие файлы стандартов".
  4. Нажмите кнопку "+" ("Добавить файл стандартов").
  5. В диалоговом окне "Открытие файла" выберите файл стандартов, используемых для замены. Нажмите кнопку "Открыть".
  6. (Не обязательно) Повторите пункты 5 и 6, если нужно добавить другие файлы нормоконтроля для задания переопределений.
  7. В окне утилиты пакетного нормоконтроля выберите "Файл" » "Сохранить файл нормоконтроля". (Можно также нажать кнопку "Сохранить" на панели утилиты пакетного нормоконтроля.)


Проверка нескольких чертежей на соответствие стандартам - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Проверка нескольких чертежей на соответствие стандартам

  1. Запустите утилиту пакетного нормоконтроля.
  2. Откройте существующий или создать новый файл нормоконтроля.
  3. В окне утилиты пакетного нормоконтроля выберите "Проверка" » "Начать проверку". (Можно также нажать кнопку "Сохранить" на панели утилиты пакетного нормоконтроля.)

    4. Результаты проверки появляются в окне просмотра.

    Процесс пакетной проверки можно прервать в любое время нажатием кнопки "Остановить проверку".

    Примечание Утилита пакетного нормоконтроля не может проверять зашифрованные файлы.


Добавление комментариев к отчёту - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Добавление комментариев к отчёту

  1. Запустите утилиту пакетного нормоконтроля.
  2. Создайте новый или откройте существующий файл нормоконтроля.
  3. В окне утилиты пакетного нормоконтроля на вкладке "Замечания" введите текст комментария, включаемого в отчёт.
  4. Выберите "Файл" » "Сохранить файл нормоконтроля". (Можно также нажать кнопку "Сохранить" на панели утилиты пакетного нормоконтроля.)


Просмотр отчёта о ранее проведённом нормоконтроле - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Просмотр отчёта о ранее проведённом нормоконтроле

  1. Запустите утилиту пакетного нормоконтроля.
  2. Откройте файл нормоконтроля, который ранее использовался для проверки.
  3. В окне утилиты пакетного нормоконтроля выберите "Проверка" » "Просмотреть отчёт". (Можно также нажать кнопку "Просмотреть отчёт" на панели утилиты пакетного нормоконтроля.)

    4. В окне просмотра появляется отчёт.

  4. Для задания фильтра отображения отчёта выберите один из следующих вариантов:
    • Общие сведения. Вывод общих данных о количестве нарушений в каждом проверяемом чертеже.
    • Надстройки. Вывод сведений об установленных в системе подключаемых модулей для пакетного нормоконтроля.
    • Стандарты. Вывод сведений о файлах стандартов, используемых для пакетного нормоконтроля.
    • Нарушения. Вывод подробных сведений о каждом нарушении, обнаруженном в чертежах.
    • Проигнорированные нарушения. Вывод подробных сведений обо всех проигнорированных нарушениях.
    • Все. Вывод всех имеющихся данных о проверке на соответствие стандартам.
  5. Для показа отчёта по отдельному чертежу в списке "Включая:" выберите нужный чертеж.


Экспорт отчёта о пакетном нормоконтроле - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Экспорт отчёта о пакетном нормоконтроле

  1. Запустите утилиту пакетного нормоконтроля.
  2. Создайте новый или откройте существующий файл нормоконтроля.
  3. В окне утилиты пакетного нормоконтроля выберите "Проверка" » "Экспорт отчёта". (Можно также нажать кнопку "Экспорт отчета" на панели утилиты пакетного нормоконтроля.)


Проверка чертежей на соответствие стандартам - Команды

Соблюдение стандартов в чертежах
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Понятия
Процедуры
Команды

Команды
НОРМОКОНТРОЛЬ | Проверка текущего чертежа на соответствие установленным стандартам оформления
СТАНДАРТЫ | Управляет подключением файлов стандартов к чертежам.
Системные переменные
STANDARDSVIOLATION | Указывает режим оповещения пользователя о нарушениях стандартов в текущем чертеже при создании или изменении нестандартного объекта
Утилиты
Утилита пакетного нормоконтроля | Проверка набора чертежей на соблюдение стандартов оформления
Ключевые слова для команд
Нет. |


Преобразование имен и свойств слоев - Понятия

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Преобразование имен и свойств слоев
Понятия
Процедуры
Команды

С помощью модуля "Транслятор слоев" можно выполнять преобразования слоёв чертежа для приведения их к стандартам, устанавливаемым пользователем.

  • Преобразование слоёв в соответствии с заданными стандартами
    "Транслятор слоев" позволяет выполнять преобразования слоёв в чертеже в соответствии со стандартами, устанавливаемым пользователем.
  • Просмотр выбранных слоёв чертежа
    С помощью модуля "Транслятор слоев" можно указывать слои, которые должны отображаться в области рисования.
  • Очистка чертежа от неиспользуемых слоев
    С помощью модуля "Транслятор слоев" можно удалять из чертежа все неиспользуемые слои.


Преобразование имен и свойств слоев - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Преобразование имен и свойств слоев
Понятия
Процедуры
Команды

Преобразование слоёв чертежа в соответствии с заданными стандартами

Выбор слоя для отображения его в области рисования

Очистка чертежа от всех неиспользуемых слоев


Преобразование имен и свойств слоев - Команды

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Преобразование имен и свойств слоев
Понятия
Процедуры
Команды
Команды
СЛОЙТРАНС | Изменение системы слоев чертежа в соответствии с установленными пользователем стандартами
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Преобразование слоёв в соответствии с заданными стандартами - Понятия

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Преобразование слоёв в соответствии с заданными стандартами
Понятия
Процедуры
Команды

"Транслятор слоев" позволяет выполнять преобразования слоёв в чертеже в соответствии со стандартами, устанавливаемым пользователем.

С помощью модуля "Транслятор слоев" можно выполнять преобразования слоёв в чертеже для приведения их к стандартам, устанавливаемым пользователем. Слои текущего чертежа можно поставить в соответствие слоям другого чертежа или файла стандартов, а затем выполнить преобразование текущих слоев. Если чертеж содержит слои с тем же именем, "Транслятор слоев" может автоматически привести свойства слоёв текущего чертежа в соответствие со свойствами этих слоев.

Заданные соответствия для преобразования слоёв можно сохранить в файле и затем повторно использовать при работе с другими чертежами.


Преобразование слоёв чертежа в соответствии с заданными стандартами - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Преобразование слоёв в соответствии с заданными стандартами
Понятия
Процедуры
Команды

Преобразование слоёв чертежа в соответствии с заданными стандартами

  1. Выберите "Сервис" » "Стандарты оформления" » "Транслятор слоев".
  2. В окне "Транслятор слоев" выполните одно из следующих действий:
    • Нажмите кнопку "Загрузить" для загрузки слоёв из чертежа, шаблона или файла стандартов оформления. В диалоговом окне "Выбор файла чертежа" выберите необходимый файл. Нажмите кнопку "Открыть".
    • Нажмите кнопку "Создать", чтобы задать новый слой. В диалоговом окне "Новый слой" введите имя нового слоя и выберите его свойства. Нажмите "ОК".

    При необходимости, пункт 2 можно повторить несколько раз. При загрузке файлов с одноименными стандартными слоями в список "Слои назначения" для определения стандартов используются свойства слоя из файла, загруженного первым; свойства одноименных слоёв из последующих файлов игнорируются.

  3. Для выполнения преобразований слои текущего чертежа поставьте в соответствие стандартным слоям. Можно использовать один или оба из следующих методов назначения слоев:
    • Для сопоставления всех одноименных слоёв одного списка со слоями другого списка выберите "Одноименные".
    • Для сопоставления отдельных слоёв в списке "Исходные слои" выберите один или несколько слоев. В списке "Слои назначения" выберите слой, свойства которого требуется использовать. Нажмите "Сопоставить" для выполнения сопоставления. Данный метод можно использовать для каждого слоя или группы слоев, которые необходимо преобразовать.

    Для исключения сопоставления выберите соответствующий элемент в списке "Таблица соответствий слоев". Выберите "Исключить". Для исключения всех сопоставлений нажмите правой кнопкой мыши в этом списке. Выберите "Исключить все".

  4. (Не обязательно) С помощью модуля "Транслятор слоев" можно выполнять следующие задачи:
    • Для изменения свойств назначаемого слоя в списке "Таблица соответствий слоев" выберите необходимое сопоставление. Нажмите кнопку "Изменить". В диалоговом окне "Редактирование слоя" измените тип, цвет и толщину линий или стиль печати назначаемого слоя. Нажмите "ОК".
    • Для настройки процесса преобразования слоёв нажмите кнопку "Параметры". В диалоговом окне "Параметры" выберите необходимые значения параметров. Нажмите "ОК".
    • Для сохранения соответствий слоёв в файле нажмите кнопку "Сохранить". В диалоговом окне "Сохранение соответствий слоев" введите имя файла. Нажмите "ОК".
  5. Нажмите кнопку "Преобразовать" для запуска процедуры преобразования.

Панель "Стандарты оформления"

Ввод команды: СЛОЙТРАНС


Преобразование слоёв в соответствии с заданными стандартами - Команды

Соблюдение стандартов в чертежах
Соблюдение стандартов в чертежах
Преобразование слоёв в соответствии с заданными стандартами
Понятия
Процедуры
Команды

Команды
СЛОЙТРАНС | Изменение системы слоев чертежа в соответствии с установленными пользователем стандартами
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Просмотр выбранных слоёв чертежа - Понятия

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Просмотр выбранных слоёв чертежа
Понятия
Процедуры
Команды

С помощью модуля "Транслятор слоев" можно указывать слои, которые должны отображаться в области рисования.

Таким образом, можно просматривать объекты как на всех слоях чертежа, так и только на заданных слоях. Это позволяет визуально контролировать содержимое отдельных слоев.


Выбор слоя для отображения его в области рисования - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Просмотр выбранных слоёв чертежа
Понятия
Процедуры
Команды

Выбор слоя для отображения его в области рисования

  1. Выберите "Сервис" » "Стандарты оформления" » "Транслятор слоев".
  2. В окне "Транслятор слоев" выберите "Параметры".
  3. В диалоговом окне "Параметры" выполнить одно из действий:
    • Для отображения объектов на выбранных слоях чертежа установите флажок "Показывать содержимое выбранного слоя". В области рисования будут отображены только те слои, которые выбраны в диалоговом окне "Транслятор слоев".
    • Для отображения объектов всех слоёв чертежа отключите режим "Показывать содержимое выбранного слоя".
  4. Нажмите "ОК".

Панель "Стандарты оформления"

Ввод команды: СЛОЙТРАНС


Просмотр выбранных слоёв чертежа - Команды

Соблюдение стандартов в чертежах
Соблюдение стандартов в чертежах
Просмотр выбранных слоёв чертежа
Понятия
Процедуры
Команды

Команды
СЛОЙТРАНС | Изменение системы слоев чертежа в соответствии с установленными пользователем стандартами
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Очистка чертежа от неиспользуемых слоев - Понятия

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Очистка чертежа от неиспользуемых слоев
Понятия
Процедуры
Команды

С помощью модуля "Транслятор слоев" можно удалять из чертежа все неиспользуемые слои.

Часто так поступают со слоями, которые были созданы для каких-либо целей, но более не нужны. Уменьшение числа слоев облегчает управление ими при дальнейшей работе над чертежом.


Очистка чертежа от всех неиспользуемых слоев - Процедуры

Создание, организация и сохранение чертежей
Соблюдение стандартов в чертежах
Очистка чертежа от неиспользуемых слоев
Понятия
Процедуры
Команды

Очистка чертежа от всех неиспользуемых слоев

  1. Выберите "Сервис" » "Стандарты оформления" » "Транслятор слоев".
  2. В окне "Транслятор слоев" нажмите правой кнопкой мыши в списке "Исходные слои". Выберите "Удалить неиспользуемые". Все неиспользуемые слои удаляются из текущего чертежа.

Панель "Стандарты оформления"

Ввод команды: СЛОЙТРАНС


Очистка чертежа от неиспользуемых слоев - Команды

Соблюдение стандартов в чертежах
Соблюдение стандартов в чертежах
Очистка чертежа от неиспользуемых слоев
Понятия
Процедуры
Команды

Команды
СЛОЙТРАНС | Изменение системы слоев чертежа в соответствии с установленными пользователем стандартами
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление видами чертежей

Изменение видов
Можно изменять экранное увеличение выводимого изображения для более детального его рассмотрения или перемещать чертеж по видовому экрану. Виды, сохраненные с заданием имени, впоследствии могут быть восстановлены на экране.

Использование инструментов 3D просмотра
При работе в 3D часто требуется отображение различных видов, позволяющее просматривать и проверять 3D эффекты в пользовательском чертеже.

Работа с несколькими видами в пространстве модели
Для того, чтобы одновременно просматривать несколько видов одного чертежа, область построения чертежа на вкладке "Модель" можно разбить на отдельные области просмотра, называемые видовыми экранами пространства модели. Конфигурации видовых экранов пространства модели можно сохранять для повторного использования.


Управление видами чертежей - Понятия

Управление видами чертежей
Управление видами чертежей
Управление видами чертежей
Понятия
Процедуры
Команды

Можно изменять экранное увеличение выводимого изображения для более детального его рассмотрения или перемещать чертеж по видовому экрану. Виды, сохраненные с заданием имени, впоследствии могут быть восстановлены на экране.

Во время работы в трехмерном пространстве часто требуется возможность просмотра нескольких видов для удобства контроля 3D эффектов от выполненного редактирования.

Для того чтобы одновременно просматривать несколько видов одного чертежа, графическую область на вкладке "Модель" можно разбить на отдельные области просмотра, называемые видовыми экранами пространства модели. Конфигурации видовых экранов можно сохранять для повторного использования.


Управление видами чертежей - Процедуры

Управление видами чертежей
Управление видами чертежей
Управление видами чертежей
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Управление видами чертежей - Команды

Управление видами чертежей
Управление видами чертежей
Управление видами чертежей
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Изменение видов - Понятия

Управление видами чертежей
Изменение видов
Понятия
Процедуры
Команды

Можно изменять экранное увеличение выводимого изображения для более детального его рассмотрения или перемещать чертеж по видовому экрану. Виды, сохраненные с заданием имени, впоследствии могут быть восстановлены на экране.

  • Панорамирование или зумирование вида
    Можно использовать панорамирование для перемещения вида по области рисования или зумирование для изменения экранного увеличения.
  • Панорамирование и зумирование в окне "Общий вид"
    При работе с большим чертежом для выполнения зумирования и панорамирования можно воспользоваться окном, в котором схематично отображается чертеж целиком.
  • Сохранение и восстановление видов
    При сохранении конкретных видов по имени можно восстанавливать их для разметки или распечатки либо при необходимости соотнесения их с конкретными деталями. Можно создавать и сохранять виды с помощью команд ВИД или КАМЕРА.
  • Управление стилем 3D проекции
    Можно просматривать как параллельную, так и перспективную проекцию 3D модели.
  • Раскраска модели и использование эффектов кромок
    Скрытие линий улучшает чертеж и проясняет конструкцию. При добавлении теней создается более реалистичное изображение модели.

См. также

Поворот видов на видовых экранах листа


Изменение видов - Процедуры

Управление видами чертежей
Изменение видов
Понятия
Процедуры
Команды

Панорамирование перетаскиванием

Панорамирование путем указания точек

Зумирование в реальном времени

Для зумирования с помощью рамки

Отображение чертежа в его границах

Отображение чертежа в его границах

Восстановление предыдущего вида

Зумирование с помощью окна "Общий вид"

Панорамирование с помощью окна "Общий вид"

Отображение всего чертежа в окне "Общий вид"

Увеличение или уменьшение изображения в окне "Общий вид"

Включение и отключения динамического обновления

Включение и отключение динамического обновления

Отображение предыдущего вида

Отображение предыдущего вида во время панорамирования или зумирования в реальном времени

Сохранение вида с присвоением имени

Восстановление сохраненного вида

Переименование вида

Изменение свойств вида

Удаление именованного вида

Просмотр списка конфигураций видовых экранов

Определение вида в перспективе 3D модели с помощью команды ДВИД

Отключение вида в перспективе с помощью команды ДВИД

Динамическая установка параллельной проекции

Установка стандартного 3D вида

Установка вида указанием координат точки зрения

Установка вида заданием двух углов поворота

Установка видов командой ТЗРЕНИЯ (архитектурный стиль)

Установка видов командой ТЗРЕНИЯ (технический стиль)

Изменение текущего вида на вид в плане XY.

Сохранение стиля отображения в чертеже

Применение стиля отображения к видовому экрану

Сохранение стиля отображения на панели инструментов

Использование стиля отображения в различных чертежах

Восстановление исходных параметров стиля отображения по умолчанию

Изменение отображения граней со сглаженного на фасетное

Управление стилем грани

Управление отображением цветов на гранях

Обеспечение прозрачности всех граней на видовом экране

Управление отображением теней на видовом экране

Управление отображением ребер и цветом ребер

Добавление эффекта выступания к ребрам

Добавление эффекта мерцания к ребрам

Управление отображением кромок силуэта

Установка уровня производительности для адаптивного ухудшения качества

Изменение порядка адаптивного ухудшения

Просмотр протокола мастера оптимизации параметров

Оптимизация параметров вручную

Проверка обновлений графической карты и сертификации драйверов

Проверка физической памяти (RAM)

Проверка распределения файла подкачки


Изменение видов - Команды

Управление видами чертежей
Изменение видов
Понятия
Процедуры
Команды
Команды
3DОРБИТА | Интерактивный просмотр объектов в 3D пространстве
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ГРАФНАСТР | Обеспечивает конфигурационные установки системы 3D-графики
ДВИД | Установка параллельной проекции или вида в перспективе с помощью камеры и цели
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
НАСТРВИД | Задание точности аппроксимации объектов на текущем видовом экране
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОБЩИЙВИД | Вызов окна "Общий вид"
ОТМЕНИТЬ | Отмена действия команд
ПАН | Перемещение изображения на текущем видовом экране
ПАРАМЕТРЫПВ | Отображает изменение в виде плавного перехода
ПЛАН | Отображение вида в плане указанной ПСК
ПОКАЗАТЬ | Увеличение или уменьшение видимого размера объектов на текущем видовом экране
ТЗРЕНИЯ | Задание направления взгляда для трехмерных видов
Системные переменные
BACKZ | Сохранение смещения задней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа).
CSHADOW | Задает свойство отображения теней для 3D объекта
EXTMAX | Сохраняет верхнюю правую точку границ чертежа
EXTMIN | Сохраняет левую нижнюю точку границ чертежа
FRONTZ | Сохраняет смещение передней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа)
INTERSECTIONCOLOR | Управляет цветом полилиний на пересечении 3D поверхностей, если визуальному стилю установлено значение 2D Каркас.
INTERSECTIONDISPLAY | Управляет отображением полилиний на пересечении 3D поверхностей, если визуальному стилю установлено значение 2D Каркас.
LENSLENGTH | Сохраняет фокусное расстояние объектива (в мм), используемого при построении вида в перспективе
MBUTTONPAN | Управляет действиями третьей кнопки или колесика на устройстве указания.
PERSPECTIVE | Указывает, отображает текущий видовой экран рабочий вид в перспективе или нет
RTDISPLAY | Управляет отображением растровых изображений и объектов OLE при выполнении команды МАСШТАБ или ПАН в режиме реального времени
SHADOWPLANELOCATION | Управляет расположением скрытой опущенной нулевой плоскости, используемой для отображения теней
TARGET | Сохраняет положение точки цели (в координатах ПСК) на текущем видовом экране
VIEWDIR | Сохраняет направление взгляда в текущем видовом экране, выраженное в координатах ПСК
VIEWMODE | Сохраняет режим "Вид" для текущего видового экрана
VIEWTWIST | Сохраняет угол поворота вида на текущем видовом экране
VSBACKGROUNDS | Управляет отображением фонов в стиле отображения, применяемом к текущему видовому экрану
VSEDGECOLOR | Устанавливает цвет граней в стиле отображения текущего видового экрана
VSEDGEJITTER | Управляет степенью проявления линий сквозь карандашную зарисовку
VSEDGEOVERHANG | Отрезки продлеваются за их пересечения для создания эффекта рисования от руки
VSEDGES | Управляет типом граней, отображаемых в видовом экране
VSEDGESMOOTH | Задает угол, под которым отображаются загнутые грани
VSFACECOLORMODE | Управляет вычислением цвета граней
VSFACEHIGHLIGHT | Управляет отображением бликующей подсветки на гранях, не заполненных материалом, в текущем видовом экране
VSFACEOPACITY | Управляет прозрачностью граней в текущем видовом экране
VSFACESTYLE | Управляет отображением граней в текущем видовом экране
VSHALOGAP | Устанавливает коэффициент недовода в стиле отображения, применяемом к текущему видовому экрану
VSINTERSECTIONCOLOR | Указывает цвет полилиний пересечения в стиле отображения, применяемом к текущему видовому экрану
VSINTERSECTIONEDGES | Управляет отображением ребер пересечения в стиле отображения, применяемом к текущему видовому экрану
VSINTERSECTIONLTYPE | Устанавливает тип линии для линий пересечения в визуальном стиле, применяемом в текущем видовом экране
VSLIGHTINGQUALITY | Устанавливает качество освещения в текущем видовом экране
VSMONOCOLOR | Устанавливает цвет монохромного и тонированного отображения граней в стиле отображения, применяемом в текущем видовом экране
VSOBSCUREDCOLOR | Задает цвет линий заднего плана в стиле отображения, применяемом в текущем видовом экране
VSOBSCUREDEDGES | Управляет отображением граней заднего плана (скрытых)
VSOBSCUREDLTYPE | Задает тип линии для линий заднего плана в стиле отображения, применяемом в текущем видовом экране
VSSHADOWS | Управляет отображением теней в стиле отображения
VSSILHEDGES | Управляет отображением контуров силуэта твердотельных объектов в визуальном стиле, применяемом в текущем видовом экране
VSSILHWIDTH | Управляет шириной контуров силуэта в текущем видовом экране
VTENABLE | Управляет использованием плавной смены вида
VTFPS | Задает минимальную скорость плавного перехода видов в кадрах в секунду
WHIPARC | Управляет сглаживанием кругов и дуг на экране
WHIPTHREAD | Управляет использованием дополнительного процессора для повышения скорости операций (например ПОКАЗАТЬ), выполняющих перерисовку или регенерацию чертежа
WORLDVIEW | Управляет интерпретацией координат, вводимых в командах ДВИД и ТЗРЕНИЯ, относительно МСК (по умолчанию) или текущей ПСК
ZOOMFACTOR | Управляет степенью увеличения при прокрутке колесика мыши
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Панорамирование или зумирование вида - Понятия

Управление видами чертежей
Изменение видов
Панорамирование или зумирование вида
Понятия
Процедуры
Команды

Можно использовать панорамирование для перемещения вида по области рисования или зумирование для изменения экранного увеличения.

С помощью параметра "В реальном времени" команды ПАН можно просматривать различные участки чертежа, перемещая курсор в нужном направлении. Команда ПАН, как при панорамировании камерой, не изменяет расположения и абсолютных размеров объектов; изменяются лишь размеры отображаемой части чертежа, т. е. вида.

Увеличение или уменьшение вида достигается путем изменения коэффициента экранного увеличения, как и при увеличении или уменьшении камерой. ПОКАЗАТЬ не изменяет абсолютных размеров объектов; изменяется лишь кратность увеличения вида на экране, т.е. размеры отображаемого фрагмента чертежа.

При работе с мелкими деталями чертежа часто возникает необходимость уменьшить чертеж, чтобы просмотреть сделанные изменения на общем виде. Для быстрого возврата к предыдущему виду служит команда ПОКАЗАТЬ с параметром "Предыдущий".

Здесь даются описания функций, наиболее часто используемых в работе. Подробнее обо всех параметрах команды ПОКАЗАТЬ см. Справочник команд.

Показ прямоугольной области крупным планом

Зумирование определенной прямоугольной области удобно выполнять, указывая два противоположных угла этой области.

Нижний левый угол заданной области становится нижним левым углом вида. Другой указанный угол может не совпадать с углом нового вида, так как вид приобретает такие размеры, чтобы точно покрывать область видового экрана.

Зумирование в реальном времени

С помощью функции "Реальное время" можно динамически зумировать вид, перемещая курсор вверх или вниз. Нажатием правой кнопки мыши можно вызвать контекстное меню с дополнительными параметрами управления видом.

Показ увеличенного изображения одного или нескольких объектов

ПОКАЗАТЬ с параметром "Объекты" - вывод с максимальным возможным коэффициентом экранного увеличения всех выбранных объектов так, чтобы они заполнили графическую область или текущий видовой экран.

Отображение всего чертежа

ПОКАЗАТЬ с параметром "Границы" - вывод с максимальным возможным коэффициентом экранного увеличения всех объектов чертежа так, чтобы они заполнили графическую область или текущий видовой экран. Расчет коэффициента выполняется с учетом объектов на отключенных слоях. Объекты на замороженных слоях не учитываются.

ПОКАЗАТЬ с параметром "Все" - вывод пользовательских лимитов чертежа или границ чертежа, в зависимости от того, какой вид больше.

См. также

Кнопки устройств указания

Масштабирование видов на видовых экранах листа

Панели


Панорамирование или зумирование вида - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование или зумирование вида
Понятия
Процедуры
Команды

Панорамирование перетаскиванием

Панорамирование путем указания точек

Зумирование в реальном времени

Для зумирования с помощью рамки

Отображение чертежа в его границах

Отображение чертежа в его границах

Восстановление предыдущего вида


Панорамирование перетаскиванием - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование или зумирование вида
Понятия
Процедуры
Команды

Панорамирование перетаскиванием

  1. Выберите "Вид" » "Панорамирование" » "Реал вр".
  2. Когда отображается курсор в виде кисти руки, удерживайте нажатой кнопку устройства указания при перемещении.

    3. Для мыши с функцией прокрутки при перемещении следует удерживать в нажатом состоянии кнопку-колесико.

  3. Нажмите ENTER, ESC или правую кнопку мыши для выхода.

Панель "Стандартная"

Ввод команды: ПАН


Панорамирование путем указания точек - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование или зумирование вида
Понятия
Процедуры
Команды

Панорамирование путем указания точек

  1. Выберите "Вид" » "Панорамирование" » "Точка"
  2. Укажите базовую точку. Эта точка будет сдвинута в новое положение.
  3. Укажите вторую точку для выполнения панорамирования. Заданная до этого базовая точка смещается в нее.

Ввод команды: ПАН


Зумирование в реальном времени - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование или зумирование вида
Понятия
Процедуры
Команды

Зумирование в реальном времени

  1. Выберите "Вид" » "Зумирование" » "Реал вр".
  2. Когда отображается курсор в виде кисти руки, удерживайте нажатой кнопку устройства указания и перемещайте его вертикально для увеличения и уменьшения.
  3. Нажмите ENTER, ESC или правую кнопку мыши для выхода.

Панель "Стандартная"

Ввод команды: ПОКАЗАТЬ


Для зумирования с помощью рамки - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование или зумирование вида
Понятия
Процедуры
Команды

Для зумирования с помощью рамки

  1. Выберите "Вид" » "Зумирование" » "Рамка".
  2. Укажите первый угол области вида.
  3. Укажите противоположный угол.

    4. Команда ПОКАЗАТЬ автоматически переходит в режим "Рамка", если сразу после вызова команды указать точку.

Панель "Стандартная"

Ввод команды: ПОКАЗАТЬ

Контекстное меню: Когда активна команда ПОКАЗАТЬ, нажмите правую кнопку мыши в области рисования. Нажмите "Показать рамкой".


Отображение чертежа в его границах - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование или зумирование вида
Понятия
Процедуры
Команды

Отображение чертежа в его границах

  • Выберите "Вид" » "Зумирование" » "Границы".

Выводятся все объекты с максимально возможным коэффициентом экранного увеличения так, чтобы заполнить графическую область или текущий видовой экран.

Панель "Стандартная"

Ввод команды: ПОКАЗАТЬ

Контекстное меню: Когда активна команда ПОКАЗАТЬ, нажмите правую кнопку мыши в области рисования. Нажмите "Показать в границах".


Отображение чертежа в его границах - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование или зумирование вида
Понятия
Процедуры
Команды

Отображение чертежа в его границах

  • Выберите "Вид" » "Зумирование" » "Все".

Весь чертеж в его лимитах отображается на текущем видовом экране или в графической области. Если имеются объекты, выходящие за лимиты, область вида увеличивается так, чтобы вместить и эти объекты.

Панель "Стандартная"

Ввод команды: ПОКАЗАТЬ


Восстановление предыдущего вида - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование или зумирование вида
Понятия
Процедуры
Команды

Восстановление предыдущего вида

  • Выберите "Вид" » "Зумирование" » "Предыдущий".

Команда ПОКАЗАТЬ с параметром "Предыдущий" восстанавливает только экранное увеличение и положение вида, но не предыдущее содержимое редактируемого чертежа.

Панель "Стандартная"

Ввод команды: ПОКАЗАТЬ

Контекстное меню: Когда активна команда ПОКАЗАТЬ, нажмите правую кнопку мыши в области рисования. Выберите "Исходный вид".


Панорамирование или зумирование вида - Команды

Изменение видов
Изменение видов
Панорамирование или зумирование вида
Понятия
Процедуры
Команды

Команды
НАСТРВИД | Задание точности аппроксимации объектов на текущем видовом экране
ОБЩИЙВИД | Вызов окна "Общий вид"
ОТМЕНИТЬ | Отмена действия команд
ПАН | Перемещение изображения на текущем видовом экране
ПАРАМЕТРЫПВ | Отображает изменение в виде плавного перехода
ПОКАЗАТЬ | Увеличение или уменьшение видимого размера объектов на текущем видовом экране
Системные переменные
EXTMAX | Сохраняет верхнюю правую точку границ чертежа
EXTMIN | Сохраняет левую нижнюю точку границ чертежа
MBUTTONPAN | Управляет действиями третьей кнопки или колесика на устройстве указания.
RTDISPLAY | Управляет отображением растровых изображений и объектов OLE при выполнении команды МАСШТАБ или ПАН в режиме реального времени
VTENABLE | Управляет использованием плавной смены вида
VTFPS | Задает минимальную скорость плавного перехода видов в кадрах в секунду
WHIPARC | Управляет сглаживанием кругов и дуг на экране
WHIPTHREAD | Управляет использованием дополнительного процессора для повышения скорости операций (например ПОКАЗАТЬ), выполняющих перерисовку или регенерацию чертежа
ZOOMFACTOR | Управляет степенью увеличения при прокрутке колесика мыши
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Панорамирование и зумирование в окне "Общий вид" - Понятия

Управление видами чертежей
Изменение видов
Панорамирование и зумирование в окне "Общий вид"
Понятия
Процедуры
Команды

При работе с большим чертежом для выполнения зумирования и панорамирования можно воспользоваться окном, в котором схематично отображается чертеж целиком.

Окно "Общий вид" отображает общий вид чертежа и служит для быстрого перемещения в любую его часть на текущем видовом экране. В ходе работы в окне "Общий вид" можно производить панорамирование и зумирование, не прерывая выполнения текущей команды. Кроме того, можно задавать новые виды, не прибегая к выбору вариантов меню и не вводя команд.

Использование рамки вида для панорамирования и зумирования

Внутри окна "Общий вид" имеется рамка вида в форме жирного прямоугольника, задающая границы вида на текущем видовом экране. Изменение вида может выполняться путем изменения рамки вида в окне "Общий вид". Для увеличения видимых размеров чертежа рамка вида должна быть сделана меньше. Для уменьшения видимых размеров чертежа рамка вида должна быть сделана больше. Все действия, связанные с панорамированием и зумированием, выполняются при нажатии левой кнопки мыши. При нажатии правой кнопки мыши действия панорамирования и зумирования завершаются.

Панорамирование чертежа выполняется перемещением рамки вида.

Изменение размера изображения в окне "Общий вид"

С помощью кнопок на панели окна "Общий вид" можно изменять экранное увеличение его изображения, а также выполнять постепенное увеличение или уменьшение. Эти изменения не отражаются на виде в области построения чертежа.

Использование окна "Общий вид" при наличии нескольких видовых экранов

В окне "Общий вид" можно управлять видом только текущего видового экрана.

Изображение окна "Общий вид" каждый раз обновляется при внесении изменений в чертеж или переключении на другой видовой экран. При работе со сложными чертежами для повышения производительности можно отключить динамическое обновление изображения в окне "Общий вид". Если отключить эту функцию, изображение "Общий вид" обновляется только при активации окна "Общий вид".


Панорамирование и зумирование в окне "Общий вид" - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование и зумирование в окне "Общий вид"
Понятия
Процедуры
Команды

Зумирование с помощью окна "Общий вид"

Панорамирование с помощью окна "Общий вид"

Отображение всего чертежа в окне "Общий вид"

Увеличение или уменьшение изображения в окне "Общий вид"

Включение и отключения динамического обновления

Включение и отключение динамического обновления


Зумирование с помощью окна "Общий вид" - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование и зумирование в окне "Общий вид"
Понятия
Процедуры
Команды

Зумирование с помощью окна "Общий вид"

  1. Выберите "Вид" » "Общий вид".
  2. В окне "Общий вид" нажимайте кнопку мыши внутри рамки вида до тех пор, пока не появится стрелка.
  3. Переместите курсор вправо для уменьшения видимых размеров объектов. Переместите курсор влево для увеличения видимых размеров объектов.
  4. Нажмите правую кнопку мыши для завершения операции зумирования.

Ввод команды: ОБЩИЙВИД


Панорамирование с помощью окна "Общий вид" - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование и зумирование в окне "Общий вид"
Понятия
Процедуры
Команды

Панорамирование с помощью окна "Общий вид"

  1. Выберите "Вид" » "Общий вид".
  2. В окне "Общий вид" нажимайте кнопку мыши внутри рамки вида до тех пор, пока не появится перекрестье.
  3. Переместите курсор для смены вида.
  4. Нажмите правую кнопку мыши для завершения операции панорамирования.

Ввод команды: ОБЩИЙВИД


Отображение всего чертежа в окне "Общий вид" - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование и зумирование в окне "Общий вид"
Понятия
Процедуры
Команды

Отображение всего чертежа в окне "Общий вид"

  1. Выберите "Вид" » "Общий вид".
  2. В окне "Общий вид" откройте меню "Вид" » "Глобально".

Ввод команды: ОБЩИЙВИД


Увеличение или уменьшение изображения в окне "Общий вид" - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование и зумирование в окне "Общий вид"
Понятия
Процедуры
Команды

Увеличение или уменьшение изображения в окне "Общий вид"

  1. Нажмите "Вид" » "Общий вид".
  2. На панели окна "Общий вид" нажмите кнопку "Увеличить" или "Уменьшить".

Примечание Если в окне "Общий вид" виден чертеж полностью, пункт меню "Уменьшить" и соответствующая кнопка панели становятся недоступны. Если текущий вид примерно совпадает с показанной в окне частью чертежа, недоступными становятся пункт и кнопка "Увеличить".

Ввод команды: ОБЩИЙВИД


Включение и отключения динамического обновления - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование и зумирование в окне "Общий вид"
Понятия
Процедуры
Команды

Включение и отключения динамического обновления

  • В окне "Общий вид" откройте меню "Параметры" » "Динамическое обновление".

    • Установленный флажок указывает на то, что изображение в окне "Общий вид" обновляется по мере внесения изменений в чертеж.


Включение и отключение динамического обновления - Процедуры

Управление видами чертежей
Изменение видов
Панорамирование и зумирование в окне "Общий вид"
Понятия
Процедуры
Команды

Включение и отключение динамического обновления

  • В окне "Общий вид" откройте меню "Параметры" » "Автоматический видовой экран".

    • Установленный флажок указывает, что изображение в окне "Общий вид" обновляется по мере переключения видовых экранов.


Панорамирование и зумирование в окне "Общий вид" - Команды

Изменение видов
Изменение видов
Панорамирование и зумирование в окне "Общий вид"
Понятия
Процедуры
Команды

Команды
ОБЩИЙВИД | Вызов окна "Общий вид"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение и восстановление видов - Понятия

Управление видами чертежей
Изменение видов
Сохранение и восстановление видов
Понятия
Процедуры
Команды

При сохранении конкретных видов по имени можно восстанавливать их для разметки или распечатки либо при необходимости соотнесения их с конкретными деталями. Можно создавать и сохранять виды с помощью команд ВИД или КАМЕРА.

Именованный вид, созданный с помощью команды ВИД, содержит указанное увеличение, положение и ориентацию. В каждом сеансе работы с чертежом на любом видовом экране можно легко восстановить вид, который отображался там ранее, а также последовательно до 10 предыдущих видов.

Именованные виды и камеры сохраняются с чертежом и могут использоваться в любой момент. При компоновке листа можно восстановить именованный вид или камеру на видовом экране листа.

Сохранение вида

При присвоении виду имени и его сохранении запоминаются следующие параметры:

  • экранное увеличение вида, его центральная точка и направление взгляда;
  • категория вида, назначенная виду (не обязательно);
  • местоположение вида: вкладка "Модель" или вкладка определенной разметки листа;
  • видимость слоев в чертеже на момент сохранения вида;
  • пользовательская система координат;
  • 3D перспектива;
  • псевдоразрез;
  • визуальный стиль;
  • фон.
Восстановление именованного вида

Восстановление именованного вида происходит на текущем видовом экране. Именованные виды можно использовать для следующих целей:

  • Компоновка листа.
  • Восстановление вида, часто используемого при работе в пространстве модели.
  • Задание начального вида модели при открытии чертежа.


Сохранение и восстановление видов - Процедуры

Управление видами чертежей
Изменение видов
Сохранение и восстановление видов
Понятия
Процедуры
Команды

Отображение предыдущего вида

Отображение предыдущего вида во время панорамирования или зумирования в реальном времени

Сохранение вида с присвоением имени

Восстановление сохраненного вида

Переименование вида

Изменение свойств вида

Удаление именованного вида

Просмотр списка конфигураций видовых экранов


Отображение предыдущего вида - Процедуры

Управление видами чертежей
Изменение видов
Сохранение и восстановление видов
Понятия
Процедуры
Команды

Отображение предыдущего вида

  • На панели "Стандартная" нажмите кнопку "Показать предыдущий".

Ввод команды: ПОКАЗАТЬ


Отображение предыдущего вида во время панорамирования или зумирования в реальном времени - Процедуры

Управление видами чертежей
Изменение видов
Сохранение и восстановление видов
Понятия
Процедуры
Команды

Отображение предыдущего вида во время панорамирования или зумирования в реальном времени

  • Нажмите правую кнопку мыши в области построения. Выберите "Исходный вид".


Сохранение вида с присвоением имени - Процедуры

Управление видами чертежей
Изменение видов
Сохранение и восстановление видов
Понятия
Процедуры
Команды

Сохранение вида с присвоением имени

  1. Выполните одно из следующих действий:
    • Если в пространстве модели используется несколько видовых экранов, нажмите кнопку мыши в пределах видового экрана, в котором содержится сохраняемый вид.
    • При работе на листе выберите видовой экран.
  2. Нажмите "Вид" » "Именованные виды".
  3. В диалоговом окне "Диспетчер видов" нажмите "Создать".
  4. В диалоговом окне "Новый вид" в поле "Имя вида" введите имя вида.

    5. Если чертеж входит в подшивку, выводится список категорий видов для этой подшивки. Можно добавить новую категорию или выбрать в списке существующую.

  5. В разделе "Границы" выберите одну из следующих функций для задания области вида:
    • Текущий экран. Включает всю видимую часть чертежа.
    • Задать рамкой. Сохранение части текущего вида. Диалоговое окно закрывается на время указания на чертеже двух противоположных углов вида. Для переопределения окна нажмите кнопку "Задать окно вида".
  6. Дважды нажмите "ОК" для сохранения нового вида.

Ввод команды: ВИД

Пульт управления: Панель "3D навигация", "Предыдущий вид"


Восстановление сохраненного вида - Процедуры

Управление видами чертежей
Изменение видов
Сохранение и восстановление видов
Понятия
Процедуры
Команды

Восстановление сохраненного вида

  1. Выполните одно из следующих действий:
    • Если в пространстве модели используется несколько видовых экранов, нажмите кнопку мыши в пределах видового экрана, в котором содержится восстанавливаемый вид.
    • При работе с разметкой листа выберите видовой экран.
  2. Нажмите "Вид" » "Именованные виды".
  3. В диалоговом окне "Диспетчер видов" в списке "Виды" выберите вид, который требуется восстановить.
  4. Нажмите кнопку "Установить".
  5. Нажмите "ОК".

Панель "Вид"

Ввод команды: ВИД

Пульт управления: Панель "3D навигация", "Предыдущий вид"


Переименование вида - Процедуры

Управление видами чертежей
Изменение видов
Сохранение и восстановление видов
Понятия
Процедуры
Команды

Переименование вида

  1. Нажмите "Вид" » "Именованные виды".
  2. В диалоговом окне "Диспетчер видов" нажмите имя вида, которое требуется изменить. Если вид не отображается, разверните соответствующий список "Вид" и нажмите имя вида.
  3. В разделе "Общие" на панели "Свойства" выберите имя вида. Введите новое имя.
  4. Нажмите "ОК".

Панель "Вид"

Ввод команды: ВИД

Пульт управления: Панель "3D навигация", "Предыдущий вид"


Изменение свойств вида - Процедуры

Управление видами чертежей
Изменение видов
Сохранение и восстановление видов
Понятия
Процедуры
Команды

Изменение свойств вида

  1. Нажмите "Вид" » "Именованные виды".
  2. В диалоговом окне "Диспетчер видов" нажмите имя вида, которое требуется изменить. Если вид не отображается, разверните соответствующий список "Вид" и нажмите имя вида.
  3. На панели "Свойства" нажмите свойство, которое требуется изменить.
  4. Укажите новое значение свойства, введя новое значение или выбрав его в списке значений.
  5. Нажмите "ОК".

Панель "Вид"

Ввод команды: ВИД

Пульт управления: Панель "3D навигация", "Предыдущий вид"


Удаление именованного вида - Процедуры

Управление видами чертежей
Изменение видов
Сохранение и восстановление видов
Понятия
Процедуры
Команды

Удаление именованного вида

  1. Нажмите "Вид" » "Именованные виды".
  2. В диалоговом окне "Диспетчер видов" выберите вид и затем нажмите "Удалить".
  3. Нажмите "ОК".

Панель "Вид"

Ввод команды: ВИД

Пульт управления: Панель "3D навигация", "Предыдущий вид"


Просмотр списка конфигураций видовых экранов - Процедуры

Управление видами чертежей
Изменение видов
Сохранение и восстановление видов
Понятия
Процедуры
Команды

Просмотр списка конфигураций видовых экранов

  • Выберите "Вид" » "Видовые экраны" » "Именованные ВЭкраны".

Список сохраненных видовых экранов отображается в диалоговом окне "Видовые экраны", вкладка "Именованные ВЭкраны".

Панель "Видовые экраны"

Ввод команды: ВЭКРАН


Сохранение и восстановление видов - Команды

Изменение видов
Изменение видов
Сохранение и восстановление видов
Понятия
Процедуры
Команды

Команды
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ПОКАЗАТЬ | Увеличение или уменьшение видимого размера объектов на текущем видовом экране
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление стилем 3D проекции - Понятия

Управление видами чертежей
Изменение видов
Управление стилем 3D проекции
Понятия
Процедуры
Команды

Можно просматривать как параллельную, так и перспективную проекцию 3D модели.

  • Обзор параллельных и перспективных видов
    На чертеже можно создавать реалистичные визуальные эффекты, задавая параллельные или перспективные проекции модели.
  • Определение перспективной проекции (ДВИД)
  • Определение параллельной проекции
  • Выбор установленных 3D видов
    Существует несколько стандартных ортогональных и изометрических видов, которые можно выбирать по именам или по определениям.
  • Задание координат и углов для 3D видов
    Направление взгляда можно задать либо координатами точки зрения, либо двумя углами относительно координатных осей и плоскостей.
  • Выберите вид в плоскости XY
    Изменив положение текущей точки зрения, можно установить вид в плане текущей ПСК, предварительно сохраненной ПСК или МСК.


Управление стилем 3D проекции - Процедуры

Управление видами чертежей
Изменение видов
Управление стилем 3D проекции
Понятия
Процедуры
Команды

Определение вида в перспективе 3D модели с помощью команды ДВИД

Отключение вида в перспективе с помощью команды ДВИД

Динамическая установка параллельной проекции

Установка стандартного 3D вида

Установка вида указанием координат точки зрения

Установка вида заданием двух углов поворота

Установка видов командой ТЗРЕНИЯ (архитектурный стиль)

Установка видов командой ТЗРЕНИЯ (технический стиль)

Изменение текущего вида на вид в плане XY.


Управление стилем 3D проекции - Команды

Управление видами чертежей
Изменение видов
Управление стилем 3D проекции
Понятия
Процедуры
Команды
Команды
3DОРБИТА | Интерактивный просмотр объектов в 3D пространстве
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
ДВИД | Установка параллельной проекции или вида в перспективе с помощью камеры и цели
ПЛАН | Отображение вида в плане указанной ПСК
ТЗРЕНИЯ | Задание направления взгляда для трехмерных видов
Системные переменные
BACKZ | Сохранение смещения задней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа).
FRONTZ | Сохраняет смещение передней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа)
LENSLENGTH | Сохраняет фокусное расстояние объектива (в мм), используемого при построении вида в перспективе
PERSPECTIVE | Указывает, отображает текущий видовой экран рабочий вид в перспективе или нет
TARGET | Сохраняет положение точки цели (в координатах ПСК) на текущем видовом экране
VIEWDIR | Сохраняет направление взгляда в текущем видовом экране, выраженное в координатах ПСК
VIEWMODE | Сохраняет режим "Вид" для текущего видового экрана
VIEWTWIST | Сохраняет угол поворота вида на текущем видовом экране
WORLDVIEW | Управляет интерпретацией координат, вводимых в командах ДВИД и ТЗРЕНИЯ, относительно МСК (по умолчанию) или текущей ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор параллельных и перспективных видов - Понятия

Управление видами чертежей
Изменение видов
Обзор параллельных и перспективных видов
Понятия
Процедуры
Команды

На чертеже можно создавать реалистичные визуальные эффекты, задавая параллельные или перспективные проекции модели.

Разница между видом в перспективе и параллельной проекцией заключается в том, что для создания перспективной проекции дополнительно требуется информация о расстоянии между камерой и целью. Малое расстояние позволяет усилить эффект перспективы; и наоборот, большое расстояние снижает эффект.

На следующем рисунке показана одна и та же модель в параллельной проекции и в перспективе. Оба вида сформированы с одинаковым направлением взгляда.


Управление стилем 3D проекции

Управление видами чертежей
Изменение видов
Управление стилем 3D проекции
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Обзор параллельных и перспективных видов - Команды

Изменение видов
Изменение видов
Обзор параллельных и перспективных видов
Понятия
Процедуры
Команды

Команды
3DОРБИТА | Интерактивный просмотр объектов в 3D пространстве
ДВИД | Установка параллельной проекции или вида в перспективе с помощью камеры и цели
Системные переменные
BACKZ | Сохранение смещения задней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа).
FRONTZ | Сохраняет смещение передней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа)
LENSLENGTH | Сохраняет фокусное расстояние объектива (в мм), используемого при построении вида в перспективе
TARGET | Сохраняет положение точки цели (в координатах ПСК) на текущем видовом экране
VIEWDIR | Сохраняет направление взгляда в текущем видовом экране, выраженное в координатах ПСК
VIEWMODE | Сохраняет режим "Вид" для текущего видового экрана
VIEWTWIST | Сохраняет угол поворота вида на текущем видовом экране
WORLDVIEW | Управляет интерпретацией координат, вводимых в командах ДВИД и ТЗРЕНИЯ, относительно МСК (по умолчанию) или текущей ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Определение перспективной проекции (ДВИД) - Понятия

Управление видами чертежей
Изменение видов
Определение перспективной проекции (ДВИД)
Понятия
Процедуры
Команды

Для перспективной проекции требуется указать расстояние между камерой и целью. Малое расстояние позволяет усилить эффект перспективы; и наоборот, большое расстояние снижает эффект.

Режим перспективы можно отключить или отменить установкой иного вида.


Определение перспективной проекции (ДВИД) - Процедуры

Управление видами чертежей
Изменение видов
Определение перспективной проекции (ДВИД)
Понятия
Процедуры
Команды

Определение вида в перспективе 3D модели с помощью команды ДВИД

Отключение вида в перспективе с помощью команды ДВИД


Определение вида в перспективе 3D модели с помощью команды ДВИД - Процедуры

Управление видами чертежей
Изменение видов
Определение перспективной проекции (ДВИД)
Понятия
Процедуры
Команды

Определение вида в перспективе 3D модели с помощью команды ДВИД

  1. В командной строке введите двид.
  2. Выберите объекты для отображения.
  3. Введите к (Камера).

    4. По умолчанию камера установлена в центре чертежа.

  4. Настройте вид, указав положение и направление камеры.

    5. Стандартная модель домика иллюстрирует текущее направление взгляда. Настройка вида может осуществляться динамически перемещением перекрестья курсора и нажатием кнопки устройства указания.

  5. Для выбора режима ввода углов введите п (переключение).

    6. Настройка вида выполняется в одном из двух режимов ввода углов.

    • В ответ на приглашение "Введите угол от плоскости XY" введите значение угла для установки положения камеры относительно плоскости XY текущей ПСК. Угол 90 градусов, принятый по умолчанию, направлен сверху вниз.

      • После ввода угла камера устанавливается на заданной высоте. Можно поворачивать камеру вокруг цели на углом поворота, измеренный относительно оси X в текущей ПСК.

    • В ответ на приглашение "Введите угол в плоскости XY от оси X" поверните камеру относительно цели, если угол поворота измерен относительно оси X текущей ПСК.
  6. Для включения перспективы вида введите d (distance -расстояние).
  7. Укажите расстояние или нажмите ENTER для включения перспективного вида.

    8. Расстояние от камеры до выбранных объектов можно устанавливать на скользящей шкале или путем ввода вещественного числового значения. При близко расположенных камере и цели или при большом фокусном расстоянии после задания нового расстояния на экране может оказаться видна лишь небольшая часть чертежа.

Ввод команды: ДВИД


Отключение вида в перспективе с помощью команды ДВИД - Процедуры

Управление видами чертежей
Изменение видов
Определение перспективной проекции (ДВИД)
Понятия
Процедуры
Команды

Отключение вида в перспективе с помощью команды ДВИД

  1. В командной строке введите двид.
  2. Выберите объекты для отображения.
  3. Введите о (Откл).

    4. Вид в перспективе отключается, и восстанавливается параллельная проекция.

Ввод команды: ДВИД


Определение перспективной проекции (ДВИД) - Команды

Изменение видов
Изменение видов
Определение перспективной проекции (ДВИД)
Понятия
Процедуры
Команды

Команды
3DОРБИТА | Интерактивный просмотр объектов в 3D пространстве
ДВИД | Установка параллельной проекции или вида в перспективе с помощью камеры и цели
Системные переменные
BACKZ | Сохранение смещения задней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа).
FRONTZ | Сохраняет смещение передней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа)
LENSLENGTH | Сохраняет фокусное расстояние объектива (в мм), используемого при построении вида в перспективе
TARGET | Сохраняет положение точки цели (в координатах ПСК) на текущем видовом экране
VIEWDIR | Сохраняет направление взгляда в текущем видовом экране, выраженное в координатах ПСК
VIEWMODE | Сохраняет режим "Вид" для текущего видового экрана
VIEWTWIST | Сохраняет угол поворота вида на текущем видовом экране
WORLDVIEW | Управляет интерпретацией координат, вводимых в командах ДВИД и ТЗРЕНИЯ, относительно МСК (по умолчанию) или текущей ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Определение параллельной проекции - Понятия

Управление видами чертежей
Изменение видов
Определение параллельной проекции
Понятия
Процедуры
Команды

Задание точки зрения и направления в пространстве модели

  • Выберите один из стандартных 3D видов на панели "Вид".
  • Введите координаты или углы, описывающие положение точки зрения в 3D пространстве.
  • Выберите вид в плане (т.е. перпендикулярно плоскости XY) текущей ПСК, сохраненной ПСК или МСК.
  • Измените динамический 3D вид с помощью устройства указания.
  • Задайте переднюю и заднюю секущие плоскости для ограничения отображаемых объектов.

Просмотр 3D проекций возможен только в пространстве модели. В пространстве листа нельзя задавать виды с помощью таких команд работы с 3D видами, как ТЗРЕНИЯ, ДВИД или ПЛАН. В пространстве листа чертеж всегда отображается в плане.


Динамическая установка параллельной проекции - Процедуры

Управление видами чертежей
Изменение видов
Определение параллельной проекции
Понятия
Процедуры
Команды

Динамическая установка параллельной проекции

  1. В командной строке введите двид.
  2. Выполните одно из следующих действий:
    • Выберите объекты для отображения и нажмите ENTER.
    • Нажмите ENTER без выбора объекта; при этом стандартная модель домика иллюстрирует текущее направление взгляда.
  3. Введите к (камера).

    4. По умолчанию камера установлена в центре чертежа.

  4. Настройте вид, указав положение и направление камеры.

    5. Настройка вида может осуществляться динамически перемещением перекрестья курсора и нажатием кнопки устройства указания.

  5. Для выбора режима ввода углов введите п (переключение угла).

    6. Настройка вида выполняется в одном из двух режимов ввода углов.

    • В ответ на приглашение "Введите угол от плоскости XY" введите значение угла для установки положения камеры относительно плоскости XY текущей ПСК. Угол 90 градусов, принятый по умолчанию, направлен сверху вниз.

      • После ввода угла камера устанавливается на заданной высоте. Можно поворачивать камеру вокруг цели на углом поворота, измеренный относительно оси X в текущей ПСК.

    • В ответ на приглашение "Введите угол в плоскости XY от оси X" поверните камеру относительно цели, если угол поворота измерен относительно оси X текущей ПСК.
  6. По завершении установки параллельной проекции нажмите ENTER.

Ввод команды: ДВИД


Определение параллельной проекции - Команды

Изменение видов
Изменение видов
Определение параллельной проекции
Понятия
Процедуры
Команды

Команды
ДВИД | Установка параллельной проекции или вида в перспективе с помощью камеры и цели
ПЛАН | Отображение вида в плане указанной ПСК
ТЗРЕНИЯ | Задание направления взгляда для трехмерных видов
Системные переменные
PERSPECTIVE | Указывает, отображает текущий видовой экран рабочий вид в перспективе или нет
VIEWDIR | Сохраняет направление взгляда в текущем видовом экране, выраженное в координатах ПСК
WORLDVIEW | Управляет интерпретацией координат, вводимых в командах ДВИД и ТЗРЕНИЯ, относительно МСК (по умолчанию) или текущей ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор установленных 3D видов - Понятия

Управление видами чертежей
Изменение видов
Выбор установленных 3D видов
Понятия
Процедуры
Команды

Существует несколько стандартных ортогональных и изометрических видов, которые можно выбирать по именам или по определениям.

Быстрый способ установки вида заключается в выборе его из числа уже имеющихся стандартных 3D видов. Существует несколько стандартных ортогональных и изометрических видов, которые можно выбирать по именам или по определениям. Ортогональные виды отображают модель в проекциях сверху, снизу, спереди, слева, справа и сзади. Изометрические виды позволяют рассматривать следующие проекции: ЮЗ (юго-западная), ЮВ (юго-восточная), СВ (северо-восточная) и СЗ (северо-западная).

Для понимания сущности изометрических видов можно представить себе прямоугольный ящик, рассматриваемый сверху. Если, например, сместить точку зрения к нижнему левому углу ящика, получится изометрический юго-западный вид (ЮЗ). Если же сместить точку зрения к переднему верхнему углу ящика, получится изометрический северо-восточный вид (СВ).


Установка стандартного 3D вида - Процедуры

Управление видами чертежей
Изменение видов
Выбор установленных 3D видов
Понятия
Процедуры
Команды

Установка стандартного 3D вида

  • Выберите "Вид" » "3D виды". Выберите стандартный вид ("Сверху", "Снизу", "Слева" и т.д.).

Панель "Вид"

Ввод команды: ВИД


Выбор установленных 3D видов - Команды

Изменение видов
Изменение видов
Выбор установленных 3D видов
Понятия
Процедуры
Команды

Команды
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание координат и углов для 3D видов - Понятия

Управление видами чертежей
Изменение видов
Задание координат и углов для 3D видов
Понятия
Процедуры
Команды

Направление взгляда можно задать либо координатами точки зрения, либо двумя углами относительно координатных осей и плоскостей.

Точка зрения задает положение в 3D пространстве, откуда направляется взгляд при рассмотрении модели в сторону точки начала координат (0,0,0). Координаты точки зрения задаются в Мировой системе координат, если не изменено значение системной переменной WORLDVIEW. Для стандартных видов предусмотрено два стиля: архитектурный (AEC) и технический. В архитектурном конструировании нормальный вид к плоскости XY - это вид сверху или план; в механическом конструировании нормальный вид к плоскости XY - это вид спереди.

Можно повернуть вид с помощью ДИАЛТЗР. На следующем чертеже показан вид, определенный двумя углами относительно оси X и плоскости XY МСК.


Задание координат и углов для 3D видов - Процедуры

Управление видами чертежей
Изменение видов
Задание координат и углов для 3D видов
Понятия
Процедуры
Команды

Установка вида указанием координат точки зрения

Установка вида заданием двух углов поворота

Установка видов командой ТЗРЕНИЯ (архитектурный стиль)

Установка видов командой ТЗРЕНИЯ (технический стиль)


Установка вида указанием координат точки зрения - Процедуры

Управление видами чертежей
Изменение видов
Задание координат и углов для 3D видов
Понятия
Процедуры
Команды

Установка вида указанием координат точки зрения

  1. Выберите "Вид" » "3D виды" » "Точка зрения".
  2. Задайте точку зрения нажав кнопку мыши внутри компаса. Заданная точка зрения определяет направление взгляда на чертеж в сторону точки (0,0,0).

Ввод команды: ТЗРЕНИЯ


Установка вида заданием двух углов поворота - Процедуры

Управление видами чертежей
Изменение видов
Задание координат и углов для 3D видов
Понятия
Процедуры
Команды

Установка вида заданием двух углов поворота

  1. В командной строке введите тзрения.
  2. Введите п (повернуть) для задания нового направления двумя углами.
  3. Введите угол с положительной осью X в плоскости XY.
  4. Введите угол с плоскостью XY для указания положения при рассмотрении модели в сторону точки (0,0,0).

Ввод команды: ТЗРЕНИЯ


Установка видов командой ТЗРЕНИЯ (архитектурный стиль) - Процедуры

Управление видами чертежей
Изменение видов
Задание координат и углов для 3D видов
Понятия
Процедуры
Команды

Установка видов командой ТЗРЕНИЯ (архитектурный стиль)

  1. В командной строке введите тзрения.
  2. Введите координаты необходимой точки зрения.
    • Введите 0,0,1 для задания вида сверху (плана).
    • Введите 0,-1,0 для задания вида спереди.
    • Введите 1,0,0 для задания вида справа.
    • Введите 1,-1,1 для задания изометрического вида.

Ввод команды: ТЗРЕНИЯ


Установка видов командой ТЗРЕНИЯ (технический стиль) - Процедуры

Управление видами чертежей
Изменение видов
Задание координат и углов для 3D видов
Понятия
Процедуры
Команды

Установка видов командой ТЗРЕНИЯ (технический стиль)

  1. В командной строке введите тзрения.
  2. Введите координаты необходимой точки зрения.
    • Введите 0,0,1 для задания вида сверху (плана).
    • Введите 0,-1,0 для задания вида спереди.
    • Введите 1,0,0 для задания вида справа.
    • Введите 1,-1,1 для задания изометрического вида. Точка зрения для этого вида смещена вправо на 45 градусов и вверх на 35,267 градусов.

Ввод команды: ТЗРЕНИЯ


Задание координат и углов для 3D видов - Команды

Изменение видов
Изменение видов
Задание координат и углов для 3D видов
Понятия
Процедуры
Команды

Команды
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
Системные переменные
WORLDVIEW | Управляет интерпретацией координат, вводимых в командах ДВИД и ТЗРЕНИЯ, относительно МСК (по умолчанию) или текущей ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выберите вид в плоскости XY - Понятия

Управление видами чертежей
Изменение видов
Выберите вид в плоскости XY
Понятия
Процедуры
Команды

Изменив положение текущей точки зрения, можно установить вид в плане текущей ПСК, предварительно сохраненной ПСК или МСК.

Вид сверху - это вид, полученный при взгляде из любой точки положительной половины оси Z в сторону точки начала координат (0,0,0). Полученный таким образом вид ортогонален плоскости XY.

Вид и систему координат, принятые по умолчанию во многих чертежах, можно восстановить с помощью установки для ориентации ПСК значения МСК, а затем установки вида сверху вместо 3D вида.


Изменение текущего вида на вид в плане XY. - Процедуры

Управление видами чертежей
Изменение видов
Выберите вид в плоскости XY
Понятия
Процедуры
Команды

Изменение текущего вида на вид в плане XY.

  1. Выберите "Вид" » "3D виды". Нажмите "Вид сверху".
  2. Выберите одну из следующих функций:
    • Текущая ПСК
    • МСК
    • По имени (для сохраненного ранее вида)

    Примечание Команда ПЛАН изменяет направление взгляда и отключает перспективу и сечение, но не меняет текущую ПСК. Все координаты, вводимые или отображаемые после команды ПЛАН, отсчитываются относительно текущей ПСК.

Ввод команды: ПЛАН


Выберите вид в плоскости XY - Команды

Изменение видов
Изменение видов
Выберите вид в плоскости XY
Понятия
Процедуры
Команды

Команды
ДВИД | Установка параллельной проекции или вида в перспективе с помощью камеры и цели
ПЛАН | Отображение вида в плане указанной ПСК
Системные переменные
BACKZ | Сохранение смещения задней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа).
FRONTZ | Сохраняет смещение передней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа)
VIEWDIR | Сохраняет направление взгляда в текущем видовом экране, выраженное в координатах ПСК
VIEWTWIST | Сохраняет угол поворота вида на текущем видовом экране
WORLDVIEW | Управляет интерпретацией координат, вводимых в командах ДВИД и ТЗРЕНИЯ, относительно МСК (по умолчанию) или текущей ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Раскраска модели и использование эффектов кромок - Понятия

Управление видами чертежей
Изменение видов
Раскраска модели и использование эффектов кромок
Понятия
Процедуры
Команды

Скрытие линий улучшает чертеж и проясняет конструкцию. При добавлении теней создается более реалистичное изображение модели.

  • Использование стиля отображения для модели
    Стиль отображения - это набор параметров, который управляет отображением кромок и теней на видовом экране. Вместо использования команд и установки системных переменных можно изменять свойства стиля отображения. При применении стиля отображения или изменении параметров результат сразу виден на видовом экране.
  • Настройка стиля отображения
    Можно создавать собственные стили отображения, изменяя настройки граней и кромок и используя затенение и фон.
  • Управление производительностью
    Отображение 3D графики и распределение памяти могут замедлить работу пользовательской системы. Адаптивное ухудшение качества, оптимизация параметров и настройка памяти - это разные подходы к обеспечению максимально возможной производительности.


Раскраска модели и использование эффектов кромок - Процедуры

Управление видами чертежей
Изменение видов
Раскраска модели и использование эффектов кромок
Понятия
Процедуры
Команды

Сохранение стиля отображения в чертеже

Применение стиля отображения к видовому экрану

Сохранение стиля отображения на панели инструментов

Использование стиля отображения в различных чертежах

Восстановление исходных параметров стиля отображения по умолчанию

Изменение отображения граней со сглаженного на фасетное

Управление стилем грани

Управление отображением цветов на гранях

Обеспечение прозрачности всех граней на видовом экране

Управление отображением теней на видовом экране

Управление отображением ребер и цветом ребер

Добавление эффекта выступания к ребрам

Добавление эффекта мерцания к ребрам

Управление отображением кромок силуэта

Установка уровня производительности для адаптивного ухудшения качества

Изменение порядка адаптивного ухудшения

Просмотр протокола мастера оптимизации параметров

Оптимизация параметров вручную

Проверка обновлений графической карты и сертификации драйверов

Проверка физической памяти (RAM)

Проверка распределения файла подкачки


Раскраска модели и использование эффектов кромок - Команды

Управление видами чертежей
Изменение видов
Раскраска модели и использование эффектов кромок
Понятия
Процедуры
Команды
Команды
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
ГРАФНАСТР | Обеспечивает конфигурационные установки системы 3D-графики
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
CSHADOW | Задает свойство отображения теней для 3D объекта
INTERSECTIONCOLOR | Управляет цветом полилиний на пересечении 3D поверхностей, если визуальному стилю установлено значение 2D Каркас.
INTERSECTIONDISPLAY | Управляет отображением полилиний на пересечении 3D поверхностей, если визуальному стилю установлено значение 2D Каркас.
SHADOWPLANELOCATION | Управляет расположением скрытой опущенной нулевой плоскости, используемой для отображения теней
VSBACKGROUNDS | Управляет отображением фонов в стиле отображения, применяемом к текущему видовому экрану
VSEDGECOLOR | Устанавливает цвет граней в стиле отображения текущего видового экрана
VSEDGEJITTER | Управляет степенью проявления линий сквозь карандашную зарисовку
VSEDGEOVERHANG | Отрезки продлеваются за их пересечения для создания эффекта рисования от руки
VSEDGES | Управляет типом граней, отображаемых в видовом экране
VSEDGESMOOTH | Задает угол, под которым отображаются загнутые грани
VSFACECOLORMODE | Управляет вычислением цвета граней
VSFACEHIGHLIGHT | Управляет отображением бликующей подсветки на гранях, не заполненных материалом, в текущем видовом экране
VSFACEOPACITY | Управляет прозрачностью граней в текущем видовом экране
VSFACESTYLE | Управляет отображением граней в текущем видовом экране
VSHALOGAP | Устанавливает коэффициент недовода в стиле отображения, применяемом к текущему видовому экрану
VSINTERSECTIONCOLOR | Указывает цвет полилиний пересечения в стиле отображения, применяемом к текущему видовому экрану
VSINTERSECTIONEDGES | Управляет отображением ребер пересечения в стиле отображения, применяемом к текущему видовому экрану
VSINTERSECTIONLTYPE | Устанавливает тип линии для линий пересечения в визуальном стиле, применяемом в текущем видовом экране
VSLIGHTINGQUALITY | Устанавливает качество освещения в текущем видовом экране
VSMONOCOLOR | Устанавливает цвет монохромного и тонированного отображения граней в стиле отображения, применяемом в текущем видовом экране
VSOBSCUREDCOLOR | Задает цвет линий заднего плана в стиле отображения, применяемом в текущем видовом экране
VSOBSCUREDEDGES | Управляет отображением граней заднего плана (скрытых)
VSOBSCUREDLTYPE | Задает тип линии для линий заднего плана в стиле отображения, применяемом в текущем видовом экране
VSSHADOWS | Управляет отображением теней в стиле отображения
VSSILHEDGES | Управляет отображением контуров силуэта твердотельных объектов в визуальном стиле, применяемом в текущем видовом экране
VSSILHWIDTH | Управляет шириной контуров силуэта в текущем видовом экране
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование стиля отображения для модели - Понятия

Управление видами чертежей
Изменение видов
Использование стиля отображения для модели
Понятия
Процедуры
Команды

Стиль отображения - это набор параметров, который управляет отображением кромок и теней на видовом экране. Вместо использования команд и установки системных переменных можно изменять свойства стиля отображения. При применении стиля отображения или изменении параметров результат сразу виден на видовом экране.

На рисунке Диспетчер визуальных стилей показаны примеры изображений со стилями отображения, доступными на чертеже. Выбранный стиль отображения обозначается желтой рамкой, а его параметры отображаются на панели под примерами изображений.

Когда отображается пульт управления, можно непосредственно изменять наиболее часто используемые параметры, либо открыть "Диспетчер стилей отображения".

В состав продукта входит пять стилей отображения по умолчанию:

  • 2D каркас. Объекты представляются в виде отрезков и кривых (как кромки граней и тел). Видны растровые и OLE-объекты, учитываются типы и веса линий.
  • 3D каркас (вверху слева на рисунке) Объекты представляются в виде отрезков и кривых (как кромки граней и тел).
  • 3D скрытые (вверху справа) Объекты представляются в каркасном виде; линии, относящиеся к задним граням, не отображаются.
  • Реалистичные (внизу слева) Раскрашиваются объекты и сглаживаются кромки между гранями многоугольника. Отображаются материалы объектов.
  • Концептуальные (внизу справа) Раскрашиваются объекты и сглаживаются кромки между гранями многоугольника. Для раскрашивания используется стиль грани Гуч с переходом не от тени к свету, а между холодным и теплым цветовыми тонами. Этот эффект менее реалистичен, но он лучше отображает подробности модели.

В стилях отображения с раскрашиванием грань освещается двумя удаленными источниками, которые перемещаются при изменении направления взгляда на модель. Освещение по умолчанию предназначено для такого освещения всех граней модели, чтобы они были визуально различимы. Освещение по умолчанию доступно только тогда, когда все остальные источники света, включая солнечный цвет, выключены.

В любой момент можно выбрать стиль отображения или изменить его параметры. Вносимые изменения отражаются на видовых экранах при применении этого стиля отображения. Подробнее о параметрах граней, параметрах среды и параметрах кромок см. Настройка стиля отображения. Все вносимые в стиль отображения изменения сохраняются на чертеже.


Использование стиля отображения для модели - Процедуры

Управление видами чертежей
Изменение видов
Использование стиля отображения для модели
Понятия
Процедуры
Команды

Сохранение стиля отображения в чертеже

Применение стиля отображения к видовому экрану

Сохранение стиля отображения на панели инструментов

Использование стиля отображения в различных чертежах

Восстановление исходных параметров стиля отображения по умолчанию


Сохранение стиля отображения в чертеже - Процедуры

Управление видами чертежей
Изменение видов
Использование стиля отображения для модели
Понятия
Процедуры
Команды

Сохранение стиля отображения в чертеже

  • Введите vssave по запросу команды.


Применение стиля отображения к видовому экрану - Процедуры

Управление видами чертежей
Изменение видов
Использование стиля отображения для модели
Понятия
Процедуры
Команды

Применение стиля отображения к видовому экрану

  1. Нажмите "Сервис" » "Палитры" » "Стили отображения".
  2. Нажмите кнопку мыши на видовом экране для установки его в качестве текущего.
  3. В "Диспетчере стилей отображения" дважды нажмите кнопку мыши на примере изображения для требуемого стиля отображения.

    4. Выбранный стиль отображения применяется к модели на видовом экране.

    Значок на примере изображения указывает, что этот стиль отображения используется на текущем видовом экране. При изменении видового экрана значок изменяется и указывает, что этот стиль отображения используется на текущем чертеже.

    Панель "Стили отображения":

    Контекстное меню: В "Диспетчере стилей отображения" выберите правой кнопкой мыши стиль отображения. Нажмите " Применить к текущему видовому экрану".

    Ввод команды: ВИЗСТИЛИ

    Пульт управления: Панель "Стиль отображения", "Диспетчер стилей отображения"


Сохранение стиля отображения на панели инструментов - Процедуры

Управление видами чертежей
Изменение видов
Использование стиля отображения для модели
Понятия
Процедуры
Команды

Сохранение стиля отображения на панели инструментов

  1. Нажмите "Сервис" » "Палитры" » "Стили отображения".
  2. Нажмите "Сервис" » "Палитры" » "Инструментальные палитры".
  3. В окне "Инструментальные палитры" выберите вкладку "Стили отображения".
  4. В "Диспетчере стилей отображения" выберите пример изображения для требуемого стиля отображения.
  5. Нажмите кнопку "Экспортировать выбранный визуальный стиль в инструментальную палитру" под изображениями.

    6. Панель "Стили отображения":

    Контекстное меню: В "Диспетчере стилей отображения" выберите правой кнопкой мыши стиль отображения. Нажмите " Экспортировать в активную инструментальную палитру".

    Ввод команды: ВИЗСТИЛИ

    Пульт управления: Панель "Стиль отображения", "Диспетчер стилей отображения"


Использование стиля отображения в различных чертежах - Процедуры

Управление видами чертежей
Изменение видов
Использование стиля отображения для модели
Понятия
Процедуры
Команды

Использование стиля отображения в различных чертежах

  1. Откройте чертеж со стилем отображения, который следует использовать.
  2. Нажмите "Сервис" » "Палитры" » "Стили отображения".
  3. Нажмите "Сервис" » "Палитры" » "Инструментальные палитры".
  4. В окне "Инструментальные палитры" выберите вкладку "Стили отображения".
  5. В "Диспетчере стилей отображения" выберите пример изображения для требуемого стиля отображения.
  6. Нажмите кнопку "Экспортировать выбранный визуальный стиль в инструментальную палитру" под изображениями.
  7. Откройте чертеж, в котором требуется использовать этот стиль отображения.
  8. На панели инструментов выберите стиль отображения.
  9. Нажмите правую кнопку мыши и нажмите "Добавить к текущему чертежу".

    10. Стиль отображения добавляется к изображениям примеров в "Диспетчере стилей отображения" и на пульте управления.

    Панель "Стили отображения":

    Контекстное меню: В "Диспетчере стилей отображения" выберите правой кнопкой мыши стиль отображения. Нажмите " Экспортировать в активную инструментальную палитру".

    Ввод команды: ВИЗСТИЛИ

    Пульт управления: Панель "Стиль отображения", "Диспетчер стилей отображения"


Восстановление исходных параметров стиля отображения по умолчанию - Процедуры

Управление видами чертежей
Изменение видов
Использование стиля отображения для модели
Понятия
Процедуры
Команды

Восстановление исходных параметров стиля отображения по умолчанию

  1. Нажмите "Сервис" » "Палитры" » "Стили отображения".
  2. Выберите стиль отображения по умолчанию.

    3. Для стиля отображения по умолчанию в левом нижнем углу изображения примера отображается значок чертежа.

  3. Нажмите правую кнопку мыши и нажмите "Восстановить значения по умолчанию".

    4. Панель "Стили отображения":

    Ввод команды: ВИЗСТИЛИ

    Пульт управления: Панель "Стиль отображения", "Диспетчер стилей отображения"


Использование стиля отображения для модели - Команды

Изменение видов
Изменение видов
Использование стиля отображения для модели
Понятия
Процедуры
Команды

Команды
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка стиля отображения - Понятия

Управление видами чертежей
Изменение видов
Настройка стиля отображения
Понятия
Процедуры
Команды

Можно создавать собственные стили отображения, изменяя настройки граней и кромок и используя затенение и фон.

  • Затенение и цвет граней
    Эффекты затенения и цвета управляют отображением граней модели.
  • Отображение фонов и теней
    Стиль отображения определяет также отображение фонов и теней на видовом экране.
  • Управление отображением кромок
    Кромки разных типов отображаются с использованием линий различного типа и цвета. Можно также указать специальные эффекты, например мерцание и выступ за кромки.


Настройка стиля отображения - Процедуры

Управление видами чертежей
Изменение видов
Настройка стиля отображения
Понятия
Процедуры
Команды

Изменение отображения граней со сглаженного на фасетное

Управление стилем грани

Управление отображением цветов на гранях

Обеспечение прозрачности всех граней на видовом экране

Управление отображением теней на видовом экране

Управление отображением ребер и цветом ребер

Добавление эффекта выступания к ребрам

Добавление эффекта мерцания к ребрам

Управление отображением кромок силуэта


Настройка стиля отображения - Команды

Управление видами чертежей
Изменение видов
Настройка стиля отображения
Понятия
Процедуры
Команды
Команды
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
Системные переменные
CSHADOW | Задает свойство отображения теней для 3D объекта
INTERSECTIONCOLOR | Управляет цветом полилиний на пересечении 3D поверхностей, если визуальному стилю установлено значение 2D Каркас.
INTERSECTIONDISPLAY | Управляет отображением полилиний на пересечении 3D поверхностей, если визуальному стилю установлено значение 2D Каркас.
SHADOWPLANELOCATION | Управляет расположением скрытой опущенной нулевой плоскости, используемой для отображения теней
VSBACKGROUNDS | Управляет отображением фонов в стиле отображения, применяемом к текущему видовому экрану
VSEDGECOLOR | Устанавливает цвет граней в стиле отображения текущего видового экрана
VSEDGEJITTER | Управляет степенью проявления линий сквозь карандашную зарисовку
VSEDGEOVERHANG | Отрезки продлеваются за их пересечения для создания эффекта рисования от руки
VSEDGES | Управляет типом граней, отображаемых в видовом экране
VSEDGESMOOTH | Задает угол, под которым отображаются загнутые грани
VSFACECOLORMODE | Управляет вычислением цвета граней
VSFACEHIGHLIGHT | Управляет отображением бликующей подсветки на гранях, не заполненных материалом, в текущем видовом экране
VSFACESTYLE | Управляет отображением граней в текущем видовом экране
VSHALOGAP | Устанавливает коэффициент недовода в стиле отображения, применяемом к текущему видовому экрану
VSINTERSECTIONCOLOR | Указывает цвет полилиний пересечения в стиле отображения, применяемом к текущему видовому экрану
VSINTERSECTIONEDGES | Управляет отображением ребер пересечения в стиле отображения, применяемом к текущему видовому экрану
VSINTERSECTIONLTYPE | Устанавливает тип линии для линий пересечения в визуальном стиле, применяемом в текущем видовом экране
VSLIGHTINGQUALITY | Устанавливает качество освещения в текущем видовом экране
VSMONOCOLOR | Устанавливает цвет монохромного и тонированного отображения граней в стиле отображения, применяемом в текущем видовом экране
VSOBSCUREDCOLOR | Задает цвет линий заднего плана в стиле отображения, применяемом в текущем видовом экране
VSOBSCUREDEDGES | Управляет отображением граней заднего плана (скрытых)
VSOBSCUREDLTYPE | Задает тип линии для линий заднего плана в стиле отображения, применяемом в текущем видовом экране
VSSHADOWS | Управляет отображением теней в стиле отображения
VSSILHEDGES | Управляет отображением контуров силуэта твердотельных объектов в визуальном стиле, применяемом в текущем видовом экране
VSSILHWIDTH | Управляет шириной контуров силуэта в текущем видовом экране
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Затенение и цвет граней - Понятия

Управление видами чертежей
Изменение видов
Затенение и цвет граней
Понятия
Процедуры
Команды

Эффекты затенения и цвета управляют отображением граней модели.

Стили граней

Стиль грани определяет затенение грани. Реальный (см. внизу слева) означает создание реалистичного эффекта. Гуч (см. внизу справа) лучше отображает детали, смягчая контраст между освещенными и затененными областями. В освещенных областях используются теплые оттенки, а в темных областях - холодные оттенки.

Когда активен стиль "Нет граней", отсутствует затенение и отображаются только кромки граней.

Качество освещения

Мягкое освещение сглаживает кромки между гранями многоуольника (см. внизу слева). Это придает объектам реалистичный вид с гладкими переходами. Освещение граней затеняет объекты между гранями многоуольника (см. внизу справа). Объекты выглядят более плоскими и менее гладкими.

Подсветка

Размер источников подсветки объекта влияет на ощущение блеска (см. ниже). При использовании меньших и более ярких источников подсветки объекты выглядят блестящими. Интенсивность подсветки, установленная в стиле отображения, не применяется к объекту с наложенными материалами.

Прозрачность

Свойство непрозрачности определяет кажущуюся степень прозрачности объекта (см. ниже).

Режимы цвета грани

Цвет может отображаться, как обычно, либо можно изменить режим цвета грани. В монохромнои режиме все грани отображаются одним и тем же цветом с одинаковым оттенком. В режиме цветовых оттенков используется один и тот же цвет для раскрашивания всех граней с изменением значений оттенка и интенсивности цвета. Режим разбавления смягчает цвета.


Затенение и цвет граней - Процедуры

Управление видами чертежей
Изменение видов
Затенение и цвет граней
Понятия
Процедуры
Команды

Изменение отображения граней со сглаженного на фасетное

Управление стилем грани

Управление отображением цветов на гранях

Обеспечение прозрачности всех граней на видовом экране


Изменение отображения граней со сглаженного на фасетное - Процедуры

Управление видами чертежей
Изменение видов
Затенение и цвет граней
Понятия
Процедуры
Команды

Изменение отображения граней со сглаженного на фасетное

  1. Нажмите "Сервис" » "Палитры" » "Стили отображения".
  2. Для текущего стиля отображения, выбранного в примерах изображений, замените "Сглаженное" на "Фасетное" в пункте "Качество освещения" в "Параметрах грани".

Панель "Стили отображения":

Ввод команды: ВИЗСТИЛИ

Пульт управления: Панель "Стиль отображения" (разверните нажатием левой кнопки); выберите "Фасетное" или "Сглаженное"


Управление стилем грани - Процедуры

Управление видами чертежей
Изменение видов
Затенение и цвет граней
Понятия
Процедуры
Команды

Управление стилем грани

  1. Нажмите "Сервис" » "Палитры" » "Стили отображения".
  2. Для текущего стиля отображения, выбранного в примерах изображений, выберите одну из указанных ниже опций в меню "Стиль грани" в "Параметрах грани".
    • Опция "Реалистичная" (по умолчанию) с максимально возможным приближением отображает то, как грань выглядит на самом деле.
    • Опция "Гуч" определяет использование гаммы холодных и теплых цветов вместо темных и светлых для улучшения отображения граней, которые могли бы быть затенены и плохо видимы в реалистичном представлении.
    • "Нет" не применяется к стилю грани. Другие параметры грани заблокированы.

Панель "Стили отображения":

Ввод команды: ВИЗСТИЛИ

Пульт управления: Панель "Стиль отображения" (разверните нажатием левой кнопки), высплывающее меню "Стиль грани"


Управление отображением цветов на гранях - Процедуры

Управление видами чертежей
Изменение видов
Затенение и цвет граней
Понятия
Процедуры
Команды

Управление отображением цветов на гранях

  1. Нажмите "Сервис" » "Палитры" » "Стили отображения".
  2. Для текущего стиля отображения, выбранного в примерах изображений, выберите одну из указанных ниже опций в меню "Режим цвета грани" раздела "Материалы и цвет" в "Параметрах грани".
    • Нормальный Не применяется к модификатору цвета грани.
    • Монохромное Модель отображается в оттенках заданного пользователем цвета.
    • Оттенок Изменяются оттенок и насыщенность цвета грани.
    • Уменьшение насыщенности Цвет смягчается путем сокращения компоненты его насыщенности на 30 процентов.
  3. Если выбран "Монохромный" или "Оттенок", укажите цвет. При выборе цвета открывается диалоговое окно "Выбор цвета".

Панель "Стили отображения":

Ввод команды: ВИЗСТИЛИ

Пульт управления: Панель "Стиль отображения" (разверните нажатием левой кнопки), всплывающее меню "Режим цвета грани"


Обеспечение прозрачности всех граней на видовом экране - Процедуры

Управление видами чертежей
Изменение видов
Затенение и цвет граней
Понятия
Процедуры
Команды

Обеспечение прозрачности всех граней на видовом экране

  1. Выберите "Сервис" » "Палитры" » "Пульт управления".
  2. На панели управления "Стиль отображения" нажмите на "Режим рентгеновскиъх лучей".


Затенение и цвет граней - Команды

Изменение видов
Изменение видов
Затенение и цвет граней
Понятия
Процедуры
Команды

Команды
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
Системные переменные
VSFACECOLORMODE | Управляет вычислением цвета граней
VSFACEHIGHLIGHT | Управляет отображением бликующей подсветки на гранях, не заполненных материалом, в текущем видовом экране
VSFACESTYLE | Управляет отображением граней в текущем видовом экране
VSLIGHTINGQUALITY | Устанавливает качество освещения в текущем видовом экране
VSMONOCOLOR | Устанавливает цвет монохромного и тонированного отображения граней в стиле отображения, применяемом в текущем видовом экране
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Отображение фонов и теней - Понятия

Управление видами чертежей
Изменение видов
Отображение фонов и теней
Понятия
Процедуры
Команды

Стиль отображения определяет также отображение фонов и теней на видовом экране.

Фон

В качестве фона на видовом экране можно использовать цвет, градиентную заливку или изображение в любом из стилей 3D отображения, даже в стиле без затенения объектов. Чтобы использовать фон, необходимо вначале создать именованный вид с фоном и установить именованный вид в качестве текущего вида на видовом экране. Если "Фон" активизирован (Вкл) в текущем стиле отображения, отображается фон.

С тенями

Для затеняемых объектов на видовом экране возможно отображение теней. Тени на земле представляют собой тени, отбрасываемые объектами на землю. Полными тенями считаются тени, отбраываемые объектами на другие объекты. Для отображения полных теней на видовом экране требуется освещенность в направлении от создаваемого пользователем источника света или от солнца. Тени, накладываемые одна на другую, выглядят затемненными.

Примечание Для отображения полных теней требуется аппаратное ускорение. Если выключено "Ускорение для геометрии", полные тени не отображаются. (Для входа в эти установки введите графнастр по подсказке о вводе команды. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" установите флажок "Ручная настройка.)

Отображение теней может привести к замедлению работы. Можно отключать тени в текущем стиле отображения на время работы и затем восстанавливать их при появлении необходимости в них.

В палитре "Свойства" можно задать свойство "Отображение тени" для объекта: "отбрасываемая тень", "принимаемая тень", "отбрасываемая и принимаемая тень" или "игнорирetn тени".

Для теней, используемых в тонировании, имеются дополнительные опции.

См. также

Тонирование с тенями


Управление отображением теней на видовом экране - Процедуры

Управление видами чертежей
Изменение видов
Отображение фонов и теней
Понятия
Процедуры
Команды

Управление отображением теней на видовом экране

  1. Нажмите "Сервис" » "Палитры" » "Стили отображения".
  2. Для текущего стиля отображения, выбранного в примерах изображений, выберите "Откл", "Полные тени" или "Тени на земле" в меню "Отображение теней" в "Параметрах среды".

Панель "Стили отображения":

Ввод команды: ВИЗСТИЛИ

Пульт управления: Панель "Стиль отображения", всплывающее меню "Тени"


Отображение фонов и теней - Команды

Изменение видов
Изменение видов
Отображение фонов и теней
Понятия
Процедуры
Команды

Команды
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
Системные переменные
CSHADOW | Задает свойство отображения теней для 3D объекта
SHADOWPLANELOCATION | Управляет расположением скрытой опущенной нулевой плоскости, используемой для отображения теней
VSBACKGROUNDS | Управляет отображением фонов в стиле отображения, применяемом к текущему видовому экрану
VSSHADOWS | Управляет отображением теней в стиле отображения
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление отображением кромок - Понятия

Управление видами чертежей
Изменение видов
Управление отображением кромок
Понятия
Процедуры
Команды

Кромки разных типов отображаются с использованием линий различного типа и цвета. Можно также указать специальные эффекты, например мерцание и выступ за кромки.

Для модели с тенями или каркасной модели стиль отображения устанавливает видимость и вид изолиний, кромок граней, контуров, скрытых кромок и кромок пересечений. Кромки граней отображаются только в том случае, когда угол между гранями меньше заданного значения угла сгиба.

Модификаторы кромок, например "Выступание" и "Мерцание" придают модели вид, характерный для этапа выработки концепции. Мерцание придает линиям такой вид, будто они нарисованы карандашом. Выступание - это другой эффект черчения вручную.

Примечание Стили печати не доступны для объектов, к которым применяется модификатор ребра с мерцанием.


Управление отображением кромок - Процедуры

Управление видами чертежей
Изменение видов
Управление отображением кромок
Понятия
Процедуры
Команды

Управление отображением ребер и цветом ребер

Добавление эффекта выступания к ребрам

Добавление эффекта мерцания к ребрам

Управление отображением кромок силуэта


Управление отображением ребер и цветом ребер - Процедуры

Управление видами чертежей
Изменение видов
Управление отображением кромок
Понятия
Процедуры
Команды

Управление отображением ребер и цветом ребер

  1. Нажмите "Сервис" » "Палитры" » "Стили отображения".
  2. Для текущего стиля отображения, выбранного в примерах изображения, выберите "Ребра граней", "Изолинии" или "Нет" в пункте "Режим ребер" в "Параметрах ребер".
  3. Если выбраны "Изолинии", укажите число линий.
  4. В пункте "Цвет" укажите цвет. При выборе цвета открывается диалоговое окно "Выбор цвета".

Панель "Стили отображения":

Ввод команды: ВИЗСТИЛИ

Пульт управления: Панель "Стиль отображения" (разверните нажатием левой кнопки), "Ребра и цвет"


Добавление эффекта выступания к ребрам - Процедуры

Управление видами чертежей
Изменение видов
Управление отображением кромок
Понятия
Процедуры
Команды

Добавление эффекта выступания к ребрам

  1. Нажмите "Сервис" » "Палитры" » "Стили отображения".
  2. Для текущего стиля отображения, выбранного в примерах изображений, нажмите кнопку "Выступающие ребра" в "Ребрах-модификаторах" и откорректируйте величину выступа в пункте "Выступание".

Примечание Выступание масштабируется так, чтобы оно адекватно выглядело на видовых экранах различных размеров. Эффект выступания не применяется к линиям, которые короче удвоенной величины выступа.

Панель "Стили отображения":

Ввод команды: ВИЗСТИЛИ

Пульт управления: Панель "Стиль отображения" (разверните нажатием левой кнопки), кнопка "Выступание ребра" и ползунок.


Добавление эффекта мерцания к ребрам - Процедуры

Управление видами чертежей
Изменение видов
Управление отображением кромок
Понятия
Процедуры
Команды

Добавление эффекта мерцания к ребрам

  1. Нажмите "Сервис" » "Палитры" » "Стили отображения".
  2. Для текущего стиля отображения, выбранного в примерах изображений, нажмите кнопку "Мерцающие ребра" в "Ребрах-модификаторах" и откорректируйте степень мерцания в пункте "Мерцание".

Панель "Стили отображения":

Ввод команды: ВИЗСТИЛИ

Пульт управления: Панель "Стиль отображения" (разверните нажатием левой кнопки), кнопка "Мерцание ребра" и ползунок.


Управление отображением кромок силуэта - Процедуры

Управление видами чертежей
Изменение видов
Управление отображением кромок
Понятия
Процедуры
Команды

Управление отображением кромок силуэта

  1. Нажмите "Сервис" » "Палитры" » "Стили отображения".
  2. Для текущего стиля отображения, выбранного в примерах изображений, выберите "Да" или "Нет" в пункте "Ребра быстрых силуэтов, Видимые".
  3. Если выбрано "Да", укажите ширину для кромок силуэта.

Панель "Стили отображения":

Ввод команды: ВИЗСТИЛИ

Пульт управления: Панель "Стиль отображения" (разверните нажатием левой кнопки), кнопка "Кромки силуэта" и ползунок


Управление отображением кромок - Команды

Изменение видов
Изменение видов
Управление отображением кромок
Понятия
Процедуры
Команды

Команды
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
Системные переменные
INTERSECTIONCOLOR | Управляет цветом полилиний на пересечении 3D поверхностей, если визуальному стилю установлено значение 2D Каркас.
INTERSECTIONDISPLAY | Управляет отображением полилиний на пересечении 3D поверхностей, если визуальному стилю установлено значение 2D Каркас.
VSEDGECOLOR | Устанавливает цвет граней в стиле отображения текущего видового экрана
VSEDGEJITTER | Управляет степенью проявления линий сквозь карандашную зарисовку
VSEDGEOVERHANG | Отрезки продлеваются за их пересечения для создания эффекта рисования от руки
VSEDGES | Управляет типом граней, отображаемых в видовом экране
VSEDGESMOOTH | Задает угол, под которым отображаются загнутые грани
VSHALOGAP | Устанавливает коэффициент недовода в стиле отображения, применяемом к текущему видовому экрану
VSINTERSECTIONCOLOR | Указывает цвет полилиний пересечения в стиле отображения, применяемом к текущему видовому экрану
VSINTERSECTIONEDGES | Управляет отображением ребер пересечения в стиле отображения, применяемом к текущему видовому экрану
VSINTERSECTIONLTYPE | Устанавливает тип линии для линий пересечения в визуальном стиле, применяемом в текущем видовом экране
VSOBSCUREDCOLOR | Задает цвет линий заднего плана в стиле отображения, применяемом в текущем видовом экране
VSOBSCUREDEDGES | Управляет отображением граней заднего плана (скрытых)
VSOBSCUREDLTYPE | Задает тип линии для линий заднего плана в стиле отображения, применяемом в текущем видовом экране
VSSILHEDGES | Управляет отображением контуров силуэта твердотельных объектов в визуальном стиле, применяемом в текущем видовом экране
VSSILHWIDTH | Управляет шириной контуров силуэта в текущем видовом экране
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление производительностью - Понятия

Управление видами чертежей
Изменение видов
Управление производительностью
Понятия
Процедуры
Команды

Отображение 3D графики и распределение памяти могут замедлить работу пользовательской системы. Адаптивное ухудшение качества, оптимизация параметров и настройка памяти - это разные подходы к обеспечению максимально возможной производительности.

  • Адаптивное ухудшение
    Адаптивное ухудшение - это способ управления производительностью функций по мере их использования.
  • Оптимизация параметров
    Мастер оптимизации параметров производительности проверяет графическую плату и драйвер 3D дисплея и принимает решение об использовании программной либо аппаратной реализации тех функций, которые поддерживают оба варианта.
  • Настройка памяти
    Производительность может быть повышена также путем добавления в пользовательскую систему увеличенных объемов памяти. Это особенно справедливо при работе с крупногабаритными моделями.


Управление производительностью - Процедуры

Управление видами чертежей
Изменение видов
Управление производительностью
Понятия
Процедуры
Команды

Установка уровня производительности для адаптивного ухудшения качества

Изменение порядка адаптивного ухудшения

Просмотр протокола мастера оптимизации параметров

Оптимизация параметров вручную

Проверка обновлений графической карты и сертификации драйверов

Проверка физической памяти (RAM)

Проверка распределения файла подкачки


Управление производительностью - Команды

Управление видами чертежей
Изменение видов
Управление производительностью
Понятия
Процедуры
Команды
Команды
ГРАФНАСТР | Обеспечивает конфигурационные установки системы 3D-графики
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
VSBACKGROUNDS | Управляет отображением фонов в стиле отображения, применяемом к текущему видовому экрану
VSFACEOPACITY | Управляет прозрачностью граней в текущем видовом экране
VSINTERSECTIONEDGES | Управляет отображением ребер пересечения в стиле отображения, применяемом к текущему видовому экрану
VSSHADOWS | Управляет отображением теней в стиле отображения
VSSILHEDGES | Управляет отображением контуров силуэта твердотельных объектов в визуальном стиле, применяемом в текущем видовом экране
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Адаптивное ухудшение - Понятия

Управление видами чертежей
Изменение видов
Адаптивное ухудшение
Понятия
Процедуры
Команды

Адаптивное ухудшение - это способ управления производительностью функций по мере их использования.

Если производительность падает ниже указанного уровня при включенной функции адаптивного ухудшения качества, использование эффектов отключается или сокращается в определенном порядке до тех пор, пока производительность не восстановится до приемлемого уровня. В каждом стиле отображения устанавливается порядок ухудшения, соответствующий стилю, на базе основного порядка, который можно настраивать вручную.

Уровень производительности устанавливается в кадрах в секунду в диалоговом окне "Адаптивное ухудшение и оптимизация параметров". Можно также менять порядок отключения функций при снижении производительности. Например, при работе на модели со стилем отображения, содержащим тени и фон, можно переместить операции затенения и фона в верхнюю часть списка для того, чтобы они отключались первыми и сохраняли эффекты краев, необходимые для работы.


Адаптивное ухудшение - Процедуры

Управление видами чертежей
Изменение видов
Адаптивное ухудшение
Понятия
Процедуры
Команды

Установка уровня производительности для адаптивного ухудшения качества

Изменение порядка адаптивного ухудшения


Установка уровня производительности для адаптивного ухудшения качества - Процедуры

Управление видами чертежей
Изменение видов
Адаптивное ухудшение
Понятия
Процедуры
Команды

Установка уровня производительности для адаптивного ухудшения качества

  1. Выберите "Сервис" » "Настройки" » вкладка "Система" » "Режимы производительности".
  2. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" установите флажок "Адаптивное ухудшение".
  3. Введите или выберите значение в кадрах в секунду. Ухудшение отображения начинается, когда производительность опускается ниже этого значения.
  4. Нажмите "ОК".

Ввод команды: графнастр

Пульт управления: Панель "Стиль отображения", диалоговое окно "Настройка"


Изменение порядка адаптивного ухудшения - Процедуры

Управление видами чертежей
Изменение видов
Адаптивное ухудшение
Понятия
Процедуры
Команды

Изменение порядка адаптивного ухудшения

  1. Выберите "Сервис" » "Настройки" » вкладка "Система" » "Режимы производительности".
  2. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" выберите функцию в списке.
  3. Нажмите "Вверх" или "Вниз" для изменения ее положения в списке.

    4. Ухудшение начинается сверху и выполняется по списку.

  4. Нажмите "ОК".

Ввод команды: графнастр

Пульт управления: Панель "Стиль отображения", диалоговое окно "Настройка"


Адаптивное ухудшение - Команды

Изменение видов
Изменение видов
Адаптивное ухудшение
Понятия
Процедуры
Команды

Команды
ГРАФНАСТР | Обеспечивает конфигурационные установки системы 3D-графики
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
VSBACKGROUNDS | Управляет отображением фонов в стиле отображения, применяемом к текущему видовому экрану
VSFACEOPACITY | Управляет прозрачностью граней в текущем видовом экране
VSINTERSECTIONEDGES | Управляет отображением ребер пересечения в стиле отображения, применяемом к текущему видовому экрану
VSSHADOWS | Управляет отображением теней в стиле отображения
VSSILHEDGES | Управляет отображением контуров силуэта твердотельных объектов в визуальном стиле, применяемом в текущем видовом экране
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Оптимизация параметров - Понятия

Управление видами чертежей
Изменение видов
Оптимизация параметров
Понятия
Процедуры
Команды

Мастер оптимизации параметров производительности проверяет графическую плату и драйвер 3D дисплея и принимает решение об использовании программной либо аппаратной реализации тех функций, которые поддерживают оба варианта.

Функции, которые не могут правильно работать в данной системе, отключаются. Возможно, некоторые функции могут работать, но не рекомендуются для использовании с данной графической платой или драйвером графического 3D дисплея. Эти функции можно включить на свой риск.

Мастер оптимизации параметров создает журнал, в котором регистрируются графическая карта и драйвер 3D отображения, имеющиеся в текущей системе, и включенное или выключенное состояние эффектов. Ниже приведен пример структуры раздела "Эффекты".

Ускорение для геометрии: имеется и включено
Отображение сглаженной линии: имеется и включено
Модуль тонирования Гуч: имеется и использует аппаратные средства
Полнотеневое отображение: имеется и включено

Можно вручную включать и отключать характеристики (рекомендрванные или не рекомендованные), поддерживаемые системой.

Примечание Для отображения полных теней требуется аппаратное ускорение. Если "Ускорение для геометрии" выключено, отображение полных теней не обеспечивается. (Для входа в эти установки введите графнастр по подсказке о вводе команды. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" установите флажок "Ручная настройка".)

Обновления сертификации

Протестированные графические карты и драйверы 3D отображения добавляются в список на веб-сайте Autodesk. Можно контролировать обновления и в любой момент загружать последний по времени список. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" нажмите "Проверка обновлений".


Оптимизация параметров - Процедуры

Управление видами чертежей
Изменение видов
Оптимизация параметров
Понятия
Процедуры
Команды

Просмотр протокола мастера оптимизации параметров

Оптимизация параметров вручную

Проверка обновлений графической карты и сертификации драйверов


Просмотр протокола мастера оптимизации параметров - Процедуры

Управление видами чертежей
Изменение видов
Оптимизация параметров
Понятия
Процедуры
Команды

Просмотр протокола мастера оптимизации параметров

  1. Выберите "Сервис" » "Настройки" » вкладка "Система" » "Режимы производительности".
  2. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" нажмите "Просмотр протокола оптимизации".
  3. Для выхода из каждого диалогового окна нажмите "ОК".

Ввод команды: графнастр

Пульт управления: Панель "Стиль отображения", диалоговое окно "Настройка"


Оптимизация параметров вручную - Процедуры

Управление видами чертежей
Изменение видов
Оптимизация параметров
Понятия
Процедуры
Команды

Оптимизация параметров вручную

  1. Выберите "Сервис" » "Настройки" » вкладка "Система" » "Режимы производительности".
  2. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" установите флажок "Ручная настройка".
  3. В диалоговом окне "Ручная оптимизация параметров" можно вводить в действие аппаратное ускорение, если значком по соседству с флажком является зеленая контрольная метка или желтый предупредительный знак.
  4. В окне "Общие параметры" можно отменять параметры или изменять их значения для повышения производительности.
  5. (Дополнительно) Использовать опцию "Сброс до рекомендуемых значений"
  6. Для выхода из каждого диалогового окна нажмите "ОК".

Ввод команды: графнастр

Пульт управления: Панель "Стиль отображения", диалоговое окно "Настройка"


Проверка обновлений графической карты и сертификации драйверов - Процедуры

Управление видами чертежей
Изменение видов
Оптимизация параметров
Понятия
Процедуры
Команды

Проверка обновлений графической карты и сертификации драйверов

  1. Выберите "Сервис" » "Настройки" » вкладка "Система" » "Режимы производительности".
  2. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" нажмите "Проверка обновлений".

    3. Откроется веб-страница с описанием программы сертификации.

  3. Найдите в списке свою графическую карту и драйвер. Если они имеются в списке, следуйте инструкциям по загрузке.
  4. Для выхода из каждого диалогового окна нажмите "ОК".

Ввод команды: графнастр

Пульт управления: Панель "Стиль отображения", диалоговое окно "Настройка"


Оптимизация параметров - Команды

Изменение видов
Изменение видов
Оптимизация параметров
Понятия
Процедуры
Команды

Команды
ГРАФНАСТР | Обеспечивает конфигурационные установки системы 3D-графики
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
VSSHADOWS | Управляет отображением теней в стиле отображения
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка памяти - Понятия

Управление видами чертежей
Изменение видов
Настройка памяти
Понятия
Процедуры
Команды

Производительность может быть повышена также путем добавления в пользовательскую систему увеличенных объемов памяти. Это особенно справедливо при работе с крупногабаритными моделями.

Согласно требованиям к системе AutoCAD, необходимо наличие не менее 512 Мбайт физической памяти (RAM) при работе в режиме 2D. При создании 3D моделей требуется RAM объемом не менее 2 Гбайт.

Эффективность работы приложения часто определяется размером и сложностью модели. Если наблюдается повышенная активность дисковода жесткого диска, это указывает на превышение лимита физической памяти и на перенос данных в файл подкачки, виртуальную память.

Файл подкачки является областью в накопителе на жестком диске, используемой системой Windows в качестве замены физической памяти. Объем файла подкачки является фактически лимитом, ограничивающим суммарный виртуальный размер процесса AutoCAD. На практике рекомендуется выбирать объем файла подкачки равным трехкратному объему физической памяти в пользовательской системе. Данный лимит является обычно достаточно высоким для того, чтобы система AutoCAD не выходила за пределы пространства подкачки.

Как правило, объем виртуальной памяти ограничивается для систем максимумом 2 Гбайт. В некоторых системах можно устанавливать переключатель /3GB, предоставляющий приложениям виртуальную память объемом до 3 Гбайт. Перед установкой переключателя необходимо выяснить следующее:

  • поддерживает ли используемая система данный переключатель;
  • не помешает ли установка переключателя работе других драйверов устройств (драйверов плоттера, видеокарты и др.).
  • Установка переключателя

Переключатель /3GB подробно описывается на веб-сайте Microsoft.


Настройка памяти - Процедуры

Управление видами чертежей
Изменение видов
Настройка памяти
Понятия
Процедуры
Команды

Проверка физической памяти (RAM)

Проверка распределения файла подкачки


Проверка физической памяти (RAM) - Процедуры

Управление видами чертежей
Изменение видов
Настройка памяти
Понятия
Процедуры
Команды

Проверка физической памяти (RAM)

  1. Нажмите правую кнопку на значке "Мой компьютер" на рабочем столе и выберите пункт меню "Свойства".
  2. На панели "Общие" просмотрите информацию о своем компьютере. На данной панели должен быть указан объем RAM.


Проверка распределения файла подкачки - Процедуры

Управление видами чертежей
Изменение видов
Настройка памяти
Понятия
Процедуры
Команды

Проверка распределения файла подкачки

  1. Нажмите правую кнопку на значке "Мой компьютер" на рабочем столе и выберите пункт меню "Свойства".
  2. Раскройте вкладку "Дополнительные" и нажмите кнопку "Параметры производительности".
  3. Нажмите на вкладку "Дополнительные" и установите флажок "Суммарный объем файла подкачки страниц для всех дисководов" в группе "Виртуальная память".


Настройка памяти - Команды

Изменение видов
Изменение видов
Настройка памяти
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Использование инструментов 3D просмотра - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Понятия
Процедуры
Команды

При работе в 3D часто требуется отображение различных видов, позволяющее просматривать и проверять 3D эффекты в пользовательском чертеже.

  • Определение 3D видов
    Можно управлять инструментами отображения 3D графики, проекции и визуализации.
  • Определение трехмерного вида с помощью камеры
    Для определения 3D вида поместите камеру в пространство модели и откорректируйте параметры камеры для привязки к своим потребностям.
  • Создание анимаций предварительного просмотра
    Перед созданием анимаций перемещения по траектории можно создавать анимации 3D просмотра и корректировать параметры.
  • Создание анимации перемещением по траектории
    Анимации перемещением по траектории, например трехмерные анимации обхода модели, позволяют демонстрировать модель техническим специалистам и другим зрителям. Можно записывать и воспроизводить перемещение с целью динамического доведения цели своего проекта до других пользователей.


Использование инструментов 3D просмотра - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Понятия
Процедуры
Команды

Запуск 3D орбитального вида

Включение режима трехмерного перемещения

Выбор параллельной или перспективной проекции на трехмерном виде

Изменение стиля отображения на трехмерном виде

Для запуска постоянного вращения по орбите

Восстановление начального вида

Использование стандартных видов

Отображение именованного вида

Запуск режима обхода

Запуск режима облета

Задание параметров обхода или облета

Изменение позиции просмотра в окне "Локатор положения"

Отключение окна "Локатор положения"

Установка секущих плоскостей (ДВИД)

Восстановление вида по умолчанию и ПСК

Создание камеры

Создание камеры на панели инструментов

Отображение камеры

Изменение фокусного расстояния объектива камеры

Установка секущих плоскостей камеры

Переименование камеры

Изменение местоположения камеры

Изменение цели камеры

Указание печати изображения символа камеры

Создание анимации предварительного просмотра

Запись анимации предварительного просмотра

Создание анимации перемещения по траектории

Просмотр анимации обратного перемещения по траектории

Управление скоростью и длительностью анимации.

Установка разрешения анимации

Задание формата видеоотображения

Просмотр и сохранение анимации перемещения по траектории


Использование инструментов 3D просмотра - Команды

Управление видами чертежей
Использование инструментов 3D просмотра
Понятия
Процедуры
Команды
Команды
3DОБЛЕТ | Интерактивно изменяет пользовательский вид 3D чертежей так, что наблюдатель, как бы пролетает сквозь модель
3DОБХОД | Интерактивно меняет вид 3D чертежа, при этом кажется, что наблюдатель обходит модель
3DОРБИТА | Интерактивный просмотр объектов в 3D пространстве
3DОРБЦЕНТР | Задает центр вращения на 3D орбитальных видах
3DПАН | Если чертеж имеет вид "Перспектива", команда включает интерактивный 3D вид и позволяет пользователю перемещать вид горизонтально или вертикально
3DПОКАЗАТЬ | Увеличивает или уменьшает изображение, если чертеж имеет вид "Перспектива".
3DПОРБИТА | Запускает интерактивный 3D вид и задает непрерывное движение объектов
3DРАССТ | Установка режима интерактивного 3D просмотра, приближение к объектам и удаление от них
3DСЕКПЛ | Запускает режим интерактивного 3D просмотра и открывает окно "Регулировка секущих плоскостей"
3DСОРБИТА | Управляет интерактивным просмотром объектов в 3D режиме, используя неограниченную орбиту
3DШАРНИР | Изменяет цель вида в направлении перетаскивания мыши.
АНИМТРАЕКТ | Сохраняет анимацию вдоль траектории в 3D модели
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
ДВИД | Установка параллельной проекции или вида в перспективе с помощью камеры и цели
КАМЕРА | Устанавливает камеру и положение цели для создания и сохранения 3D вида объектов в перспективе
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОБХОДОБЛЕТНАСТР | Задает параметры обхода и облета
ПЛАН | Отображение вида в плане указанной ПСК
Системные переменные
CAMERAHEIGHT | Задает значение высоты по умолчанию для новых объектов камеры
VIEWDIR | Сохраняет направление взгляда в текущем видовом экране, выраженное в координатах ПСК
VIEWTWIST | Сохраняет угол поворота вида на текущем видовом экране
WORLDVIEW | Управляет интерпретацией координат, вводимых в командах ДВИД и ТЗРЕНИЯ, относительно МСК (по умолчанию) или текущей ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Определение 3D видов - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Определение 3D видов
Понятия
Процедуры
Команды

Можно управлять инструментами отображения 3D графики, проекции и визуализации.

  • Обзор 3D видов
    На текущем видовом экране можно создать интерактивный вид чертежа.
  • Использование инструментов 3D перемещения.
    Инструменты 3D перемещения позволяют просматривать объекты в чертежах под различными углами, с различных высот и с различных расстояний.
  • Обход и облет всего чертежа
    Возможна имитация обхода и облета всего 3D чертежа.
  • Создание трехмерного динамического вида
    Вид можно изменять с помощью функции, объединяющей в себе панорамирование и зумирование, без прерывания текущих операций.


Определение 3D видов - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Определение 3D видов
Понятия
Процедуры
Команды

Запуск 3D орбитального вида

Включение режима трехмерного перемещения

Выбор параллельной или перспективной проекции на трехмерном виде

Изменение стиля отображения на трехмерном виде

Для запуска постоянного вращения по орбите

Восстановление начального вида

Использование стандартных видов

Отображение именованного вида

Запуск режима обхода

Запуск режима облета

Задание параметров обхода или облета

Изменение позиции просмотра в окне "Локатор положения"

Отключение окна "Локатор положения"

Установка секущих плоскостей (ДВИД)

Восстановление вида по умолчанию и ПСК


Определение 3D видов - Команды

Управление видами чертежей
Использование инструментов 3D просмотра
Определение 3D видов
Понятия
Процедуры
Команды
Команды
3DОБЛЕТ | Интерактивно изменяет пользовательский вид 3D чертежей так, что наблюдатель, как бы пролетает сквозь модель
3DОБХОД | Интерактивно меняет вид 3D чертежа, при этом кажется, что наблюдатель обходит модель
3DОРБИТА | Интерактивный просмотр объектов в 3D пространстве
3DОРБЦЕНТР | Задает центр вращения на 3D орбитальных видах
3DПАН | Если чертеж имеет вид "Перспектива", команда включает интерактивный 3D вид и позволяет пользователю перемещать вид горизонтально или вертикально
3DПОКАЗАТЬ | Увеличивает или уменьшает изображение, если чертеж имеет вид "Перспектива".
3DПОРБИТА | Запускает интерактивный 3D вид и задает непрерывное движение объектов
3DРАССТ | Установка режима интерактивного 3D просмотра, приближение к объектам и удаление от них
3DСЕКПЛ | Запускает режим интерактивного 3D просмотра и открывает окно "Регулировка секущих плоскостей"
3DСОРБИТА | Управляет интерактивным просмотром объектов в 3D режиме, используя неограниченную орбиту
3DШАРНИР | Изменяет цель вида в направлении перетаскивания мыши.
АНИМТРАЕКТ | Сохраняет анимацию вдоль траектории в 3D модели
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
ДВИД | Установка параллельной проекции или вида в перспективе с помощью камеры и цели
КАМЕРА | Устанавливает камеру и положение цели для создания и сохранения 3D вида объектов в перспективе
ОБХОДОБЛЕТНАСТР | Задает параметры обхода и облета
ПЛАН | Отображение вида в плане указанной ПСК
Системные переменные
CAMERAHEIGHT | Задает значение высоты по умолчанию для новых объектов камеры
VIEWDIR | Сохраняет направление взгляда в текущем видовом экране, выраженное в координатах ПСК
VIEWTWIST | Сохраняет угол поворота вида на текущем видовом экране
WORLDVIEW | Управляет интерпретацией координат, вводимых в командах ДВИД и ТЗРЕНИЯ, относительно МСК (по умолчанию) или текущей ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор 3D видов - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Обзор 3D видов
Понятия
Процедуры
Команды

На текущем видовом экране можно создать интерактивный вид чертежа.

С помощью инструментов 3D просмотра и навигации пользователь может перемещаться по чертежу, настраивать камеру на определенный вид и создавать анимации для обеспечения параллельного доступа к своему проекту другим пользователям. Можно перемещаться по всей 3D модели в режиме движения по кругу, разворота, обхода или облета, настраивать камеру, создавать анимацию предарительного просмотра и записывать анимации траектории перемещения, которые можно передавать другим пользователям для визуального ознакомления с целями своего проекта.


Определение 3D видов

Управление видами чертежей
Использование инструментов 3D просмотра
Определение 3D видов
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Обзор 3D видов - Команды

Использование инструментов 3D просмотра
Использование инструментов 3D просмотра
Обзор 3D видов
Понятия
Процедуры
Команды

Команды
3DОБЛЕТ | Интерактивно изменяет пользовательский вид 3D чертежей так, что наблюдатель, как бы пролетает сквозь модель
3DОБХОД | Интерактивно меняет вид 3D чертежа, при этом кажется, что наблюдатель обходит модель
3DОРБИТА | Интерактивный просмотр объектов в 3D пространстве
3DОРБЦЕНТР | Задает центр вращения на 3D орбитальных видах
3DПАН | Если чертеж имеет вид "Перспектива", команда включает интерактивный 3D вид и позволяет пользователю перемещать вид горизонтально или вертикально
3DПОКАЗАТЬ | Увеличивает или уменьшает изображение, если чертеж имеет вид "Перспектива".
3DПОРБИТА | Запускает интерактивный 3D вид и задает непрерывное движение объектов
3DРАССТ | Установка режима интерактивного 3D просмотра, приближение к объектам и удаление от них
3DСЕКПЛ | Запускает режим интерактивного 3D просмотра и открывает окно "Регулировка секущих плоскостей"
3DСОРБИТА | Управляет интерактивным просмотром объектов в 3D режиме, используя неограниченную орбиту
3DШАРНИР | Изменяет цель вида в направлении перетаскивания мыши.
АНИМТРАЕКТ | Сохраняет анимацию вдоль траектории в 3D модели
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
КАМЕРА | Устанавливает камеру и положение цели для создания и сохранения 3D вида объектов в перспективе
ОБХОДОБЛЕТНАСТР | Задает параметры обхода и облета
Системные переменные
CAMERAHEIGHT | Задает значение высоты по умолчанию для новых объектов камеры
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование инструментов 3D перемещения. - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Использование инструментов 3D перемещения.
Понятия
Процедуры
Команды

Инструменты 3D перемещения позволяют просматривать объекты в чертежах под различными углами, с различных высот и с различных расстояний.

Указанные ниже 3D инструменты используются для движения по кругу, разворота, корректировки расстояний, зумирования и панорамирования на 3D виде.

  • 3D орбита. Перемещение вокруг цели. Цель на изображении остается неподвижной, тогда как камера (точка зрения) перемещается. Точкой цели считается не центр совокупности рассматриваемых объектов., а центр видового экрана.
  • Ограниченная орбита. Ограниченная 3D орбита в плоскости XY или вокруг оси Z. (3DОРБИТА)
  • Свободная орбита. Движение по кругу в любом направлении без привязки к плоскости. Точка зрения не ограничена плоскостью XY или осью Z. (3DСОРБИТА)
  • Непрерывная орбита Непрерывное движение по кругу. Нажмите кнопку мыши и перетащите в направлении требуемого непрерывного движения, затем отпустите кнопку мыши. Движение по кругу продолжается в этом направлении. (3DПОРБИТА)
  • Регулировка расстояния Изменение расстояния до объектов при вертикальном перемещении курсора. Можно увеличивать и уменьшать изображение объектов и настраивать расстояние до них. (3DРАССТ)
  • Шарнир Имитация панорамирования камерой в направлении перетаскивания. Направление обзора изменяется. Можно выполнять шарнирное перемещение камеры в плоскости XY или вдоль оси Z. (3DШАРНИР)
  • Зумирование. Имитация приближения камеры к объекту или отдаления от объекта. При приближении объектов их видимые размеры увеличиваются. (3DПОКАЗАТЬ)
  • Панорамирование. Установка режима интерактивного 3D просмотра с возможностью перетаскивания вида по горизонтали и по вертикали. (3DПАН)
Анимация перемещения

Возможно создание анимации предварительного просмотра Перед созданием анимации перемещения по траектории необходимо создавать образец предварительного просмотра с целью точной настройки своей анимации. Можно создавать, записывать, воспроизводить и сохранять анимации. Подробнее о предварительном просмотре анимации см. Создание анимаций предварительного просмотра Подробнее о создании анимаций перемещения по траектории см.Создание анимации перемещением по траектории


Использование инструментов 3D перемещения. - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Использование инструментов 3D перемещения.
Понятия
Процедуры
Команды

Запуск 3D орбитального вида

Включение режима трехмерного перемещения

Выбор параллельной или перспективной проекции на трехмерном виде

Изменение стиля отображения на трехмерном виде

Для запуска постоянного вращения по орбите

Восстановление начального вида

Использование стандартных видов

Отображение именованного вида


Запуск 3D орбитального вида - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Использование инструментов 3D перемещения.
Понятия
Процедуры
Команды

Запуск 3D орбитального вида

  1. Выберите один или несколько объектов, просматриваемых с помощью 3DОРБИТА, либо не выбирайте объекты, если требуется просмотр чертежа в целом.

    2. Примечание OLE-объекты и растровые объекты не отображаются на орбитальных видах.

  2. Выберите в меню "Вид" » "Орбита" » "Ограниченная орбита".
  3. Для перемещения вокруг объектов используйте один из следующих способов:
    • Для поворота в плоскости XY нажмите кнопку мыши на чертеже и переместите курсор влево или вправо.
    • Для поворота вокруг оси Z нажмите кнопку мыши на чертеже и переместите курсор вверх или вниз.
    • Для обеспечения вращения по кругу в плоскости XY и вокруг оси Z удерживайте нажатой клавишу SHIFT во время перетаскивания курсора. Появляется орбитальное кольцо, позволяющее использовать команды режима свободной трехмерной орбиты (3DСОРБИТА).
  4. Нажмите ENTER.

Панель инструментов 3D навигации

Меню "Вид": "Орбита" » "Ограниченная орбита"

Ввод команды: 3DОРБИТА

Пульт управления: Панель "3D Навигация" » "Ограниченная орбита"


Включение режима трехмерного перемещения - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Использование инструментов 3D перемещения.
Понятия
Процедуры
Команды

Включение режима трехмерного перемещения

  • Введите любую команду 3D навигации и нажмите правую кнопку мыши в области рисования. Нажмите "Другие режимы перемещения" и выберите другой режим перемещения.

Ввод команды: 3DОРБИТА

Пульт управления: Панель "3D Навигация" » "Ограниченная орбита"


Выбор параллельной или перспективной проекции на трехмерном виде - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Использование инструментов 3D перемещения.
Понятия
Процедуры
Команды

Выбор параллельной или перспективной проекции на трехмерном виде

  1. Введите любую команду 3D навигации и нажмите правую кнопку мыши в области рисования. Нажмите "Параллельная" или "Перспективная".

    2. Рядом с текущим типом проекции устанавливается флажок.

Ввод команды: 3DОРБИТА, PERSPECTIVE

Пульт управления: Панель "3D Навигация" » "Перспективная проекция" или "Параллельная проекция"


Изменение стиля отображения на трехмерном виде - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Использование инструментов 3D перемещения.
Понятия
Процедуры
Команды

Изменение стиля отображения на трехмерном виде

  1. Введите любую команду 3D навигации и нажмите правую кнопку мыши в области рисования. Нажмите "Стили отображения".
  2. Выберите стиль отображения.

Подробнее о стилях отображения см. Использование стиля отображения для модели.

Меню "Вид": "Стили отображения"

Ввод команды: 3DОРБИТА


Для запуска постоянного вращения по орбите - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Использование инструментов 3D перемещения.
Понятия
Процедуры
Команды

Для запуска постоянного вращения по орбите

  1. Введите любую команду 3D навигации и нажмите правую кнопку мыши в области рисования. Нажмите "Другие режимы перемещения" » "Непрерывная орбита".
  2. Нажмите кнопку мыши на чертеже и переместите курсор для запуска непрерывного движения. При отпускании курсора движение по орбите продолжается в направлении перемещения.

Ввод команды: 3DПОРБИТА

Пульт управления: Панель "3D Навигация" » "Ограниченная орбита"


Восстановление начального вида - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Использование инструментов 3D перемещения.
Понятия
Процедуры
Команды

Восстановление начального вида

  • Введите любую команду 3D навигации и нажмите правую кнопку мыши в области рисования. Нажмите "Восстановить вид".

Восстанавливается вид, который отображался перед входом в режим 3D навигации.

Ввод команды: 3DОРБИТА


Использование стандартных видов - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Использование инструментов 3D перемещения.
Понятия
Процедуры
Команды

Использование стандартных видов

  1. Введите любую команду 3D навигации и нажмите правую кнопку мыши в области рисования. Нажмите "Стандартные виды".
  2. Нажмите вид.

"3D Навигация": "Управление видом"

Меню "Вид": "3D Виды"

Ввод команды: 3DОРБИТА

Пульт управления: Панель "3D Навигация"» "Предыдущий вид"


Отображение именованного вида - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Использование инструментов 3D перемещения.
Понятия
Процедуры
Команды

Отображение именованного вида

  1. Введите любую команду 3D навигации и нажмите правую кнопку мыши в области рисования. Нажмите "Именованные виды".
  2. Выберите именованный вид или камеру.

Меню "Вид": "Именованные виды"

Ввод команды: 3DОРБИТА

Пульт управления: Панель "3D Навигация" » "Предыдущий вид"


Использование инструментов 3D перемещения. - Команды

Использование инструментов 3D просмотра
Использование инструментов 3D просмотра
Использование инструментов 3D перемещения.
Понятия
Процедуры
Команды

Команды
3DОРБИТА | Интерактивный просмотр объектов в 3D пространстве
3DОРБЦЕНТР | Задает центр вращения на 3D орбитальных видах
3DПАН | Если чертеж имеет вид "Перспектива", команда включает интерактивный 3D вид и позволяет пользователю перемещать вид горизонтально или вертикально
3DПОКАЗАТЬ | Увеличивает или уменьшает изображение, если чертеж имеет вид "Перспектива".
3DПОРБИТА | Запускает интерактивный 3D вид и задает непрерывное движение объектов
3DРАССТ | Установка режима интерактивного 3D просмотра, приближение к объектам и удаление от них
3DСОРБИТА | Управляет интерактивным просмотром объектов в 3D режиме, используя неограниченную орбиту
3DШАРНИР | Изменяет цель вида в направлении перетаскивания мыши.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обход и облет всего чертежа - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Обход и облет всего чертежа
Понятия
Процедуры
Команды

Возможна имитация обхода и облета всего 3D чертежа.

Обход всей модели выполняется перемещением в плоскости XY. Облет всей модели не ограничивается перемещением в плоскости XY, поэтому создается ощущение "полета" над площадью модели.

"Показать: Обход всего чертежа"

Нажмите стрелку "Просмотр" для запуска анимации.

Использование клавиатуры и манипуляций мышью для обхода и облета

Для обхода и облета всего чертежа можно использовать стандартный набор клавиш и манипуляций мышью. Используются четыре клавиши "стрелка" или клавиши W, A, S и В для перемещения вверх, вниз, влево или вправо. Переключение между режимами обхода и облета осуществляется нажатием клавиши F. Чтобы указать направление вида, пользователь должен перетащить мышь в требуемом направлении просмотра.

Отображение вида на модель сверху во время обхода или облета

AutoCAD предоставляет пользователю удобный способ отслеживания текущей позиции на 3D модели в процессе обхода или облета модели. Когда запускается команда 3DОБХОД или 3DОБЛЕТ, в окне "Локатор положения" отображается вид на модель сверху. Указатель положения отображает текущую позицию в привязке к модели, а указатель цели отображает модель, по которой выполняется обход или облет. Перед запуском режима обхода или облета либо во время перемещения по модели можно редактировать установки позиции в окне "Локатор положения".

Примечание Если при отображении окна "Локатор положения" замедляется работа, можно закрыть это окно.

Задание параметров обхода и облета

Задайте параметры обхода и облета в панели управления "3D Навигация" на Пульте управления либо в диалоговом окне "Параметры обхода и облета". Можно установить размер шага по умолчанию, количество шагов в секунду и другие параметры для отображения.

Анимации перемещений при обходе и облете

Можно создать анимацию предварительного просмотра любого перемещения, включая обход и облет чертежа. Перед созданием анимации перемещения по траектории необходимо создать образец предварительного просмотра с целью точной настройки своей анимации. Можно создавать, записывать, воспроизводить и сохранять анимации. Подробнее о предварительном просмотре анимации см. Создание анимаций предварительного просмотра Подробнее о создании анимаций перемещения по траектории см. Создание анимации перемещением по траектории.


Обход и облет всего чертежа - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Обход и облет всего чертежа
Понятия
Процедуры
Команды

Запуск режима обхода

Запуск режима облета

Задание параметров обхода или облета

Изменение позиции просмотра в окне "Локатор положения"

Отключение окна "Локатор положения"


Запуск режима обхода - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Обход и облет всего чертежа
Понятия
Процедуры
Команды

Запуск режима обхода

  • Нажмите "Вид" » "Обход и облет" » "Обход".

Панель инструментов 3D навигации

Контекстное меню: Введите любую команду 3D навигации, нажмите правую кнопку мыши в области рисования и выберите "Другие навигационные режимы" » "Обход".

Ввод команды: 3DОБХОД

Пульт управления: Панель "3D Навигация" » "Обход"


Запуск режима облета - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Обход и облет всего чертежа
Понятия
Процедуры
Команды

Запуск режима облета

  • Нажмите "Вид" » "Обход и облет" » "Облет".

Панель инструментов 3D навигации

Контекстное меню: Введите любую команду 3D навигации, нажмите правую кнопку мыши в области рисования и выберите "Другие навигационные режимы" » "Облет".

Ввод команды: 3DОБЛЕТ

Пульт управления: Панель "3D Навигация" » "Облет"


Задание параметров обхода или облета - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Обход и облет всего чертежа
Понятия
Процедуры
Команды

Задание параметров обхода или облета

  1. Нажмите "Вид" » "Обход и облет" » "Параметры обхода и облета".
  2. В диалоговом окне "Параметры обхода и облета" в разделе "Параметры" выполните следующие действия:
    • Нажмите кнопку рядом с вариантом "Окно команд".
    • Снимите флажок опции "Отображать окно локатора положения", если не требуется отображать это окно. Если при отображении этого окна производительность снижается, окно "Локатор положения" можно закрыть.
  3. В разделе "Параметры текущего чертежа" выполните следующие действия:
    • В поле "Величина шага обхода/облета" введите число для размера шага в единицах чертежа.
    • В поле "Шагов в секунду" введите число от 1 до 30.
  4. Нажмите "ОК".

Панель инструментов 3D навигации

Ввод команды: ОБХОДОБЛЕТНАСТР

Пульт управления: Панель "3D Навигация" » "Обход" » "Параметры обхода и облета"


Изменение позиции просмотра в окне "Локатор положения" - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Обход и облет всего чертежа
Понятия
Процедуры
Команды

Изменение позиции просмотра в окне "Локатор положения"

  1. Нажмите "Вид" » "Обход и облет" » "Обход или облет".
  2. В области предварительного просмотра в окне "Локатор положения" нажмите на указатель положения (цветную точку) и перетащите его на новую позицию.
  3. Если отображается указатель цели, нажмите на указатель и перетащите его на позицию новой цели.
  4. В разделе "Общие" внесите требуемые изменения в текущие установки.
  5. Продолжите обход или облет модели.

Панель инструментов 3D навигации

Ввод команды: 3DОБХОД, 3DОБЛЕТ

Пульт управления: Панель "3D Навигация" » "Обход" » "Обход или облет"


Отключение окна "Локатор положения" - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Обход и облет всего чертежа
Понятия
Процедуры
Команды

Отключение окна "Локатор положения"

  1. Нажмите "Вид" » "Обход и облет" » "Параметры обхода и облета".
  2. В диалоговом окне "Параметры обхода и облета" снимите флажок рядом с "Локатором положения".
  3. Нажмите "ОК".

Панель инструментов 3D навигации

Контекстное меню: Нажмите правую кнопку мыши в любом из режимов 3D навигации. Выберите "Параметры обхода и облета"

Ввод команды: ОБХОДОБЛЕТНАСТР

Пульт управления: Панель "3D Навигация" » "Обход" » "Параметры обхода и облета"


Обход и облет всего чертежа - Команды

Использование инструментов 3D просмотра
Использование инструментов 3D просмотра
Обход и облет всего чертежа
Понятия
Процедуры
Команды

Команды
3DОБЛЕТ | Интерактивно изменяет пользовательский вид 3D чертежей так, что наблюдатель, как бы пролетает сквозь модель
3DОБХОД | Интерактивно меняет вид 3D чертежа, при этом кажется, что наблюдатель обходит модель
ОБХОДОБЛЕТНАСТР | Задает параметры обхода и облета
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание трехмерного динамического вида - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Создание трехмерного динамического вида
Понятия
Процедуры
Команды

Вид можно изменять с помощью функции, объединяющей в себе панорамирование и зумирование, без прерывания текущих операций.

Динамический вид позволяет сразу же наблюдать результаты перемещения точки зрения. Для того, чтобы упростить расчет экранного представления объектов при динамической смене вида, повысив тем самым производительность, можно задать лишь отдельные объекты для рассмотрения. Если же нажать ENTER без выбора объектов, в режиме трехмерного динамического вида вместо элементов текущего чертежа отображается стандартная модель домика. Модель домика можно использовать для задания угла и расстояния для рассмотрения модели. По окончании настройки и завершении команды изменения применяются ко всей 3D модели текущего вида.

Примечание В команде 3DОРБИТА имеются дополнительные эффективные опции для динамического просмотра в 3D. Подробнее см. Использование инструментов 3D перемещения..

Задание секущих плоскостей

На видах можно устанавливать переднюю и заднюю секущие плоскости для того, чтобы отображались только объекты, расположенные в пределах определенного расстояния от камеры. Секущие плоскости можно перемещать, сохраняя их нормальное положение относительно линии, соединяющей цель с направленной на нее камерой. Отображение объектов, которые расположены вне пространства между этими плоскостями, подавляется. Следующий чертеж иллюстрирует работу с секущими плоскостями:

Примечание Можно также задать секущие плоскости при создании изображения символа камеры. Подробнее см. Изменение свойств камеры.


Создание трехмерного динамического вида - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Создание трехмерного динамического вида
Понятия
Процедуры
Команды

Установка секущих плоскостей (ДВИД)

Восстановление вида по умолчанию и ПСК


Создание трехмерного динамического вида

Управление видами чертежей
Использование инструментов 3D просмотра
Создание трехмерного динамического вида
Понятия
Процедуры
Команды

Ввод команды: ДВИД


Установка секущих плоскостей (ДВИД) - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Создание трехмерного динамического вида
Понятия
Процедуры
Команды

Установка секущих плоскостей (ДВИД)

  1. В командной строке выберите двид.
  2. Выбрать объекты для включения в вид.
  3. В командной строке выберите с(сечение).
  4. Введите п для установки передней секущей плоскости или з для установки задней секущей плоскости, или нажмите ENTER.
  5. Расположить секущую плоскость с помощью бегунка или путем ввода расстояния от цели.
  6. Для выхода из команды нажмите ENTER.

    7. Примечание Можно также задать секущие плоскости при создании изображения символа камеры. Подробнее см. Изменение свойств камеры.

Ввод команды: ДВИД


Восстановление вида по умолчанию и ПСК - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Создание трехмерного динамического вида
Понятия
Процедуры
Команды

Восстановление вида по умолчанию и ПСК

  1. Выберите "Вид" » "3D виды".
  2. Нажмите "Вид сверху".
  3. Нажмите "МСК".

Ввод команды: ПЛАН


Создание трехмерного динамического вида - Команды

Использование инструментов 3D просмотра
Использование инструментов 3D просмотра
Создание трехмерного динамического вида
Понятия
Процедуры
Команды

Команды
ДВИД | Установка параллельной проекции или вида в перспективе с помощью камеры и цели
ПЛАН | Отображение вида в плане указанной ПСК
Системные переменные
VIEWDIR | Сохраняет направление взгляда в текущем видовом экране, выраженное в координатах ПСК
VIEWTWIST | Сохраняет угол поворота вида на текущем видовом экране
WORLDVIEW | Управляет интерпретацией координат, вводимых в командах ДВИД и ТЗРЕНИЯ, относительно МСК (по умолчанию) или текущей ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Определение трехмерного вида с помощью камеры - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Определение трехмерного вида с помощью камеры
Понятия
Процедуры
Команды

Для определения 3D вида поместите камеру в пространство модели и откорректируйте параметры камеры для привязки к своим потребностям.

  • Обзор камер
    Для определения трехмерного вида можно поместить камеру на чертеж.
  • Создание камеры
    Установка местоположения камеры и цели для создания трехмерных перспективных видов объектов.
  • Изменение свойств камеры
    Можно изменять фокусное расстояние объектива камеры, местоположение передней и задней секущей плоскости, имя камеры, а также включать и отключать отображение камер на чертеже.


Определение трехмерного вида с помощью камеры - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Определение трехмерного вида с помощью камеры
Понятия
Процедуры
Команды

Создание камеры

Создание камеры на панели инструментов

Отображение камеры

Изменение фокусного расстояния объектива камеры

Установка секущих плоскостей камеры

Переименование камеры

Изменение местоположения камеры

Изменение цели камеры

Указание печати изображения символа камеры


Определение трехмерного вида с помощью камеры - Команды

Управление видами чертежей
Использование инструментов 3D просмотра
Определение трехмерного вида с помощью камеры
Понятия
Процедуры
Команды
Команды
КАМЕРА | Устанавливает камеру и положение цели для создания и сохранения 3D вида объектов в перспективе
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
CAMERAHEIGHT | Задает значение высоты по умолчанию для новых объектов камеры
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор камер - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Обзор камер
Понятия
Процедуры
Команды

Для определения трехмерного вида можно поместить камеру на чертеж.

На чертеже можно включать и выключать камеру, использовать ручки для изменения местоположения камеры и цели или фокусного расстояния объектива. Камера определяется координатами ее местоположения XYZ, местоположения цели XYZ и полем зрения или фокусным расстоянием объектива, который определяет увеличение или коэффициент масштабирования. Можно также определить секущие плоскости, которые устанавливают переднюю и заднюю границу соответствующего вида.

  • Расположение. Определяет точку, из которой рассматривается трехмерная модель.
  • Цель. Определяет рассматриваемую точку: координаты центра вида.
  • Фокусное расстояние. Определяет свойства объектива камеры. Чем больше фокусное расстояние объектива, тем ближе поле зрения.
  • Передняя и задняя секущие плоскости. Указывает положение секущих плоскостей. Секущие плоскости - это границы, которые определяют (отсекают) вид. На виде камеры все объекты, расположенные между камерой и передней секущей плоскостью, не отображаются. Аналогичным образом не отображаются объекты, расположенные за задней секущей плоскостью.

По умолчанию сохраненные камеры получают имена, например Камера1, Камера2 и т. д. Для лучшего описания вида можно переименовать камеру. Диспетчер видов содержит список камер, имеющихся на чертеже, а также на других именованных видах.

Используйте диалоговое окно "Вид изображения символа камеры" служит для настройки цвета и размера изображения символа камеры.


Определение трехмерного вида с помощью камеры

Управление видами чертежей
Использование инструментов 3D просмотра
Определение трехмерного вида с помощью камеры
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Обзор камер - Команды

Использование инструментов 3D просмотра
Использование инструментов 3D просмотра
Обзор камер
Понятия
Процедуры
Команды

Команды
КАМЕРА | Устанавливает камеру и положение цели для создания и сохранения 3D вида объектов в перспективе
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
CAMERAHEIGHT | Задает значение высоты по умолчанию для новых объектов камеры
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание камеры - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Создание камеры
Понятия
Процедуры
Команды

Установка местоположения камеры и цели для создания трехмерных перспективных видов объектов.

Для создания камеры определите ее местоположение и цель, затем задайте ее имя, высоту, фокусное расстояние объектива и секущие плоскости. Можно также использовать один или несколько предварительно определенных типов камеры, предусмотренных на панели инструментов.


Создание камеры - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Создание камеры
Понятия
Процедуры
Команды

Создание камеры

Создание камеры на панели инструментов

Отображение камеры


Создание камеры - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Создание камеры
Понятия
Процедуры
Команды

Создание камеры

  1. Нажмите "Вид" » "Создать камеру".
  2. Нажмите кнопку мыши на чертеже для указания местоположения камеры.
  3. Нажмите кнопку мыши на чертеже еще раз для указания местоположения цели.
  4. Выполнить одно из следующих действий:
    • Если установка камеры завершена, нажмите ENTER.
    • Для определения дополнительных свойств камеры нажимайте правую кнопку мыши и выбирайте параметры в списке. Затем нажмите ENTER для завершения установки камеры.

    Панель "Вид"

    Ввод команды: КАМЕРА

    Пульт управления: Панель "3D навигация" , "Создать камеру"


Создание камеры на панели инструментов - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Создание камеры
Понятия
Процедуры
Команды

Создание камеры на панели инструментов

  1. Нажмите "Сервис" » "Палитры" » "Инструментальные палитры".
  2. Нажмите вкладку "Инструмент камеры" и активизируйте ее.
  3. Выберите тип камеры. Перетащите значок камеры с панели инструментов и нажмите кнопку мыши на чертеже в том месте, куда требуется ее поместить.
  4. Нажмите кнопку мыши еще раз в том месте, куда требуется поместить цель.

Ввод команды: КАМЕРА


Отображение камеры - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Создание камеры
Понятия
Процедуры
Команды

Отображение камеры

  • Нажмите "Вид" » "Отображать" » "Камеры".

    • Ввод команды: ОТОБРКАМЕРЫ


Создание камеры - Команды

Использование инструментов 3D просмотра
Использование инструментов 3D просмотра
Создание камеры
Понятия
Процедуры
Команды

Команды
КАМЕРА | Устанавливает камеру и положение цели для создания и сохранения 3D вида объектов в перспективе
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
CAMERAHEIGHT | Задает значение высоты по умолчанию для новых объектов камеры
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение свойств камеры - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Изменение свойств камеры
Понятия
Процедуры
Команды

Можно изменять фокусное расстояние объектива камеры, местоположение передней и задней секущей плоскости, имя камеры, а также включать и отключать отображение камер на чертеже.

При выборе камеры открывается диалоговое окно "Предварительный просмотр камеры" для просмотра вида камеры.

Предусмотрено несколько способов изменения параметров камеры:

  • Нажмите и перетащите ручки для изменения размера, положения, фокусного расстояния объектива или поля зрения.

  • Для ввода значений координат Х, Y, Z служит всплывающая подсказка "Динамический ввод".

  • Для изменения свойств камеры служит панель "Свойства камеры".


Изменение свойств камеры - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Изменение свойств камеры
Понятия
Процедуры
Команды

Изменение фокусного расстояния объектива камеры

Установка секущих плоскостей камеры

Переименование камеры

Изменение местоположения камеры

Изменение цели камеры

Указание печати изображения символа камеры


Изменение фокусного расстояния объектива камеры - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Изменение свойств камеры
Понятия
Процедуры
Команды

Изменение фокусного расстояния объектива камеры

  1. Если камеры не отображаются на чертеже, выберите "Вид" » "Экран" » "Камеры".
  2. Нажмите кнопку мыши на изображении символа камеры.
  3. Нажмите инструмент ручки "Фокусное расстояние/Поле зрения".
  4. Переместите курсор и нажмите кнопку мыши в требуемом положении объектива.
  5. Нажмите ENTER.

    6. Примечание Для точной настройки фокусного расстояния дважды нажмите кнопку мыши на изображении символа камеры для открытия панели "Свойства". В разделе "Камеры" введите числовое значение в поле "Фокусное расстояние (мм)".

Ввод команды: КАМЕРА

Пульт управления: Панель "3D Навигация", "Расстояние линзы"


Установка секущих плоскостей камеры - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Изменение свойств камеры
Понятия
Процедуры
Команды

Установка секущих плоскостей камеры

  1. Если камеры не отображаются на чертеже, выберите "Вид" » "Экран" » "Камеры".
  2. Дважды нажмите кнопку мыши на камере, для которой требуется установить секущие плоскости.
  3. На панели "Свойства" в разделе "Сечение" для параметра "Секущие плоскости" выберите "Передняя вкл", "Задняя вкл" или "Передняя и задняя вкл".
  4. В поле "Передняя плоскость" или "Задняя плоскость" введите числовое значение.
  5. Нажмите ENTER.

    6. Ввод команды: КАМЕРА


Переименование камеры - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Изменение свойств камеры
Понятия
Процедуры
Команды

Переименование камеры

  1. Если камеры не отображаются на чертеже, выберите "Вид" » "Экран" » "Камеры".
  2. Дважды нажмите кнопку мыши на изображении символа камеры.
  3. Введите новое имя в поле "Имя", расположенное на панели "Свойства" в разделе "Общие".
  4. Нажмите ENTER.

Ввод команды: КАМЕРА


Изменение местоположения камеры - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Изменение свойств камеры
Понятия
Процедуры
Команды

Изменение местоположения камеры

  1. Если камеры не отображаются на чертеже, выберите "Вид" » "Экран" » "Камеры".
  2. Нажмите кнопку мыши на изображении символа камеры, перетащите его в новое местоположение и нажмите кнопку мыши для размещения камеры.
  3. Нажмите ENTER.

Ввод команды: КАМЕРА

Пульт управления: Панель "3D Навигация", "Положение камеры"


Изменение цели камеры - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Изменение свойств камеры
Понятия
Процедуры
Команды

Изменение цели камеры

  1. Если камеры не отображаются на чертеже, выберите "Вид" » "Экран" » "Камеры".
  2. Нажмите кнопку мыши на изображении символа камеры, цель которой требуется изменить.
  3. Нажмите ручку "Расстояние до цели" (синяя ручка в центре), перетащите ее в новое положение и нажмите кнопку мыши для размещения цели.
  4. Нажмите ENTER.

Ввод команды: КАМЕРА

Пульт управления: Панель "3D Навигация", "Положение цели"


Указание печати изображения символа камеры - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Изменение свойств камеры
Понятия
Процедуры
Команды

Указание печати изображения символа камеры

  1. Если камеры не отображаются на чертеже, выберите "Вид" » "Экран" » "Камеры".
  2. Дважды нажмите кнопку мыши на камере.
  3. На панели "Свойства" в разделе "Камера" выберите для параметра "Печатать" значение "Да" или "Нет".

Ввод команды: КАМЕРА


Изменение свойств камеры - Команды

Использование инструментов 3D просмотра
Использование инструментов 3D просмотра
Изменение свойств камеры
Понятия
Процедуры
Команды

Команды
КАМЕРА | Устанавливает камеру и положение цели для создания и сохранения 3D вида объектов в перспективе
Системные переменные
CAMERAHEIGHT | Задает значение высоты по умолчанию для новых объектов камеры
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание анимаций предварительного просмотра - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Создание анимаций предварительного просмотра
Понятия
Процедуры
Команды

Перед созданием анимаций перемещения по траектории можно создавать анимации 3D просмотра и корректировать параметры.

Для создания анимаций предварительного просмотра используется панель управления "3D Навигация" на Пульте управления.


Создание анимаций предварительного просмотра - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Создание анимаций предварительного просмотра
Понятия
Процедуры
Команды

Создание анимации предварительного просмотра

Запись анимации предварительного просмотра


Создание анимации предварительного просмотра - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Создание анимаций предварительного просмотра
Понятия
Процедуры
Команды

Создание анимации предварительного просмотра

  1. Введите любую команду 3D навигации и нажмите на панель управления 3D Навигация на пульте управления.
  2. На панели управления "3D Навигация" нажмите кнопку "Начать запись анимации".
  3. Перемещение по модели чертежа В режтие обхода или облета можно использовать окно "Локатор положения" в качестве визуального руководства.
  4. (Дополнительно) Выполните одно из следующих действий:
    • Нажмите правую кнопку мыши на чертеже и выберите "Другие режимы перемещения". Выберите другой режим перемещения.
    • Нажмите кнопку "Приостановить запись анимации" для установки нового режима перемещения или корректировки параметров анимации. В режиме обхода иои облета можно также корректировать установки для окна "Локатор положения".
  5. Нажмите кнопку "Воспроизвести анимацию".
  6. В диалоговом окне "Предварительный просмотр анимации" просмотрите анимацию и выполните следующие операции:
    • Если необходимо просмотреть анимацию в другом стиле отображения, выберите из списка новый стиль.
    • При удовлетворительном качестве воспроизводимой анимации нажмите кнопку "Сохранить".
  7. В диалоговом окне "Сохранить как" выберите местоположение файла, имя файла и тип файла (AVI, MPG, MOV или WMV)
  8. Нажмите кнопку "Сохранить".

Ввод команды: 3DОРБИТА, ПУЛЬТУПРАВЛЕНИЯ

Пульт управления: Панель "3D Навигация", "Начать запись анимации"


Запись анимации предварительного просмотра - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Создание анимаций предварительного просмотра
Понятия
Процедуры
Команды

Запись анимации предварительного просмотра

  1. Введите любую команду анимации и нажмите на панель управления ''3D Навигация" на пульте управления.
  2. На пульте управления нажмите кнопку "Начать запись анимации".
  3. Перемещайтесь по модели для записи перемещения.
  4. По окончании записи анимации нажмите кнопку "Приостановить запись анимации".
  5. Нажмите кнопку "Воспроизвести анимацию". В диалоговом окне "Предварительный просмотр анимации" просмотрите запись и проверьте, что анимация подходит для презентации.

    6. Примечание При воспроизведении анимации дается общее представление об окончательном результате. При этом может не воспроизводиться стиль отображения или отображаться с качеством окончательного вывода.

  6. При удовлетворительном качестве анимации нажмите кнопку "Сохранить анимацию".
  7. В диалоговом окне "Сохранить как" выберите местоположение и имя файла.

    8. Примечание Для изменения типа файла нажмите кнопку "Параметры анимации". В диалоговом окне "Параметры анимации" для параметра "Формат" выберите тип файла. Нажмите "OK" для возврата в диалоговое окно "Сохранить как".

  8. Нажмите кнопку "Сохранить".

Ввод команды: 3DОРБИТА, ПУЛЬТУПРАВЛЕНИЯ

Пульт управления: Панель "3D Навигация", "Начать запись анимации"


Создание анимаций предварительного просмотра - Команды

Использование инструментов 3D просмотра
Использование инструментов 3D просмотра
Создание анимаций предварительного просмотра
Понятия
Процедуры
Команды

Команды
3DОБЛЕТ | Интерактивно изменяет пользовательский вид 3D чертежей так, что наблюдатель, как бы пролетает сквозь модель
3DОБХОД | Интерактивно меняет вид 3D чертежа, при этом кажется, что наблюдатель обходит модель
3DОРБИТА | Интерактивный просмотр объектов в 3D пространстве
3DОРБЦЕНТР | Задает центр вращения на 3D орбитальных видах
3DПАН | Если чертеж имеет вид "Перспектива", команда включает интерактивный 3D вид и позволяет пользователю перемещать вид горизонтально или вертикально
3DПОКАЗАТЬ | Увеличивает или уменьшает изображение, если чертеж имеет вид "Перспектива".
3DПОРБИТА | Запускает интерактивный 3D вид и задает непрерывное движение объектов
3DРАССТ | Установка режима интерактивного 3D просмотра, приближение к объектам и удаление от них
3DСЕКПЛ | Запускает режим интерактивного 3D просмотра и открывает окно "Регулировка секущих плоскостей"
3DСОРБИТА | Управляет интерактивным просмотром объектов в 3D режиме, используя неограниченную орбиту
3DШАРНИР | Изменяет цель вида в направлении перетаскивания мыши.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание анимации перемещением по траектории - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Создание анимации перемещением по траектории
Понятия
Процедуры
Команды

Анимации перемещением по траектории, например трехмерные анимации обхода модели, позволяют демонстрировать модель техническим специалистам и другим зрителям. Можно записывать и воспроизводить перемещение с целью динамического доведения цели своего проекта до других пользователей.

Настраивая анимацию перемещения по траектории, можно:

  • Указать начальную точку или траекторию
  • Указать точку или траекторию назначения (цели)
  • Просматривать соотношение между текущей камерой и траекторией
  • Корректировать параметры анимации
  • Записывать анимацию
  • Управление траекторией перемещения камеры
    Движением камеры (а следовательно, и анимацией) можно управлять, привязывая камеру и ее цель к точке или траектории.
  • Указание параметров траектории движения
    Формат файла анимации перемещения по траектории определяется указанием параметров в диалоговом окне "Анимация перемещением по траектории".
  • Запись анимации перемещения по траектории
    Перед записью анимации ее можно просмотреть и затем сохранить в требуемом формате.


Создание анимации перемещением по траектории - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Создание анимации перемещением по траектории
Понятия
Процедуры
Команды

Создание анимации перемещения по траектории

Просмотр анимации обратного перемещения по траектории

Управление скоростью и длительностью анимации.

Установка разрешения анимации

Задание формата видеоотображения

Просмотр и сохранение анимации перемещения по траектории


Создание анимации перемещением по траектории - Команды

Управление видами чертежей
Использование инструментов 3D просмотра
Создание анимации перемещением по траектории
Понятия
Процедуры
Команды
Команды
АНИМТРАЕКТ | Сохраняет анимацию вдоль траектории в 3D модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление траекторией перемещения камеры - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Управление траекторией перемещения камеры
Понятия
Процедуры
Команды

Движением камеры (а следовательно, и анимацией) можно управлять, привязывая камеру и ее цель к точке или траектории.

Для создания анимации с использованием траектории движения необходимо привязать камеру и ее цель к точке или траектории. Если камера должна быть неподвижной, необходима ее привязка к точке Если требуется перемещение камеры вдоль траектории, необходима ее привязка к траектории.

Если цель должна быть неподвижной, необходима ее привязка к точке Если требуется перемещение цели, необходима ее привязка к траектории. Одновременная привязка к точке и камеры, и цели не допускается.

Одна и та же траектория используется в том случае, когда анимационный вид должен проходить по траектории камеры. В этом случае для параметра траектории цели установите значение "Нет" в диалоговом окне "Анимация перемещением по траектории". Данная опция используется по умолчанию.

Примечание Для привязки камеры или цели к траектории необходимо создать объект траектории перед созданием аномации перемещения по траектории. Траектория может представлять собой отрезок, дугу, эллиптическую дугу, окружность, полилинию, трехмерную полилинию или сплайн.


Создание анимации перемещения по траектории - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Управление траекторией перемещения камеры
Понятия
Процедуры
Команды

Создание анимации перемещения по траектории

  1. На чертеже создайте объект траектории либо для камеры, либо для цели. Траектория может представлять собой отрезок, дугу, эллиптическую дугу, окружность, полилинию, трехмерную полилинию или сплайн.

    2. Примечание Созданная траектория не отображается в анимации.

  2. Выберите "Вид" » "Анимации перемещения по траектории".
  3. В разделе "Камера" диалогового окна "Анимация перемещения по траектории" выберите либо "Точку", либо "Траекторию".
  4. Выполните одно из следующих действий:
    • Для обозначения новой точки камеры нажмите кнопку "Указать точку" и укажите точку на чертеже. Введите имя для точки. Нажмите "OK".
    • Для обозначения новой траектории камеры нажмите кнопку "Указать траекторию" и укажите траекторию на чертеже. Введите имя для траектории. Нажмите "ОК".
    • Для обозначения имеющейся точки или траектории камеры выберите точку или траекторию из раскрывающегося списка.
  5. В разделе "Цель" диалогового окна "Анимация перемещения по траектории" выберите "Точку" или "Траектории".
  6. Выполнить одно из следующих действий:
    • Для обозначения новой точки цели нажмите кнопку "Указать точку" и укажите точку на чертеже. Введите имя для точки. Нажмите "OK".
    • Для обозначения новой траектории цели нажмите кнопку "Указать траекторию" и укажите траекторию на чертеже. Введите имя для тракетории. Нажмите "ОК".
    • Для обозначения имеющейся точки или траектории цели выберите точку или траекторию из ниспадающего списка.
  7. В разделе "Параметры анимации" откорректируйте параметры анимации с целью создания анимации в соответствии со своими потребностям.
  8. По окончании корректировки точек, траекторий и параметров нажмите "Просмотр" для просмотра анимации или "OK" для ее сохранения.

Ввод команды: АНИМТРАЕКТ


Управление траекторией перемещения камеры - Команды

Использование инструментов 3D просмотра
Использование инструментов 3D просмотра
Управление траекторией перемещения камеры
Понятия
Процедуры
Команды

Команды
АНИМТРАЕКТ | Сохраняет анимацию вдоль траектории в 3D модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Указание параметров траектории движения - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Указание параметров траектории движения
Понятия
Процедуры
Команды

Формат файла анимации перемещения по траектории определяется указанием параметров в диалоговом окне "Анимация перемещением по траектории".

Предусмотрено несколько параметров: частота кадров, длительность, разрешение, стиль отображения, формат файла и сжатие.


Указание параметров траектории движения - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Указание параметров траектории движения
Понятия
Процедуры
Команды

Просмотр анимации обратного перемещения по траектории

Управление скоростью и длительностью анимации.

Установка разрешения анимации

Задание формата видеоотображения


Просмотр анимации обратного перемещения по траектории - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Указание параметров траектории движения
Понятия
Процедуры
Команды

Просмотр анимации обратного перемещения по траектории

  1. Выберите "Вид" » "Анимации перемещением по траектории".
  2. В разделе "Параметры анимации" диалогового окна "Анимация перемещения по траектории" установите флажок "Обратное".
  3. Нажмите "ОК".

Ввод команды: АНИМТРАЕКТ


Управление скоростью и длительностью анимации. - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Указание параметров траектории движения
Понятия
Процедуры
Команды

Управление скоростью и длительностью анимации.

  1. Выберите "Вид" » "Анимации перемещением по траектории".
  2. В разделе "Параметры анимации" диалогового окна "Анимация перемещения по траектории" укажите частоту кадров (кадр/с).
  3. Выполните одно из следующих действий:
    • Укажите число кадров.
    • Укажите длительность в секундах.
  4. Нажмите "Просмотр" или "OK".

    5. Ввод команды: АНИМТРАЕКТ


Установка разрешения анимации - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Указание параметров траектории движения
Понятия
Процедуры
Команды

Установка разрешения анимации

  1. Выберите "Вид" » "Анимации перемещением по траектории".
  2. В диалоговом окне "Анимация перемещения по траектории" в разделе "Параметры анимации" укажите разрешение, выбрав его в раскрывающемся списке "Разрешение".

Ввод команды: АНИМТРАЕКТ


Задание формата видеоотображения - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Указание параметров траектории движения
Понятия
Процедуры
Команды

Задание формата видеоотображения

  1. Выберите "Вид" » "Анимации перемещением по траектории".
  2. В разделе "Параметры анимации" диалогового окна "Анимация перемещения по траектории" выберите видеоформат (AVI, MPG, MOV или WMV) из раскрывающегося списка "Формат".

Ввод команды: АНИМТРАЕКТ


Указание параметров траектории движения - Команды

Использование инструментов 3D просмотра
Использование инструментов 3D просмотра
Указание параметров траектории движения
Понятия
Процедуры
Команды

Команды
АНИМТРАЕКТ | Сохраняет анимацию вдоль траектории в 3D модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Запись анимации перемещения по траектории - Понятия

Управление видами чертежей
Использование инструментов 3D просмотра
Запись анимации перемещения по траектории
Понятия
Процедуры
Команды

Перед записью анимации ее можно просмотреть и затем сохранить в требуемом формате.


Просмотр и сохранение анимации перемещения по траектории - Процедуры

Управление видами чертежей
Использование инструментов 3D просмотра
Запись анимации перемещения по траектории
Понятия
Процедуры
Команды

Просмотр и сохранение анимации перемещения по траектории

  1. Выберите "Вид" » "Анимации перемещением по траектории".
  2. В диалоговом окне "Анимации перемещения по траектории" выполните следующие операции:
    • Укажите точку или траекторию для камеры.
    • Укажите точку или траекторию для цели.
    • Откорректируйте любые требуемые параметры анимации.
  3. Для просмотра анимации нажмите кнопку "Просмотр".
  4. В окне "Предварительный просмотр анимации" просмотрите анимацию. Закончив предварительный просмотр анимации, закройте окно "Предварительный просмотр анимации".
  5. В диалоговом окне "Анимации перемещения по траектории" нажмите "OK".
  6. В диалоговом окне "Сохранить как" укажите имя и адрес для сохранения файла анимации.
  7. Нажмите кнопку "Сохранить".

Ввод команды: АНИМТРАЕКТ


Запись анимации перемещения по траектории - Команды

Использование инструментов 3D просмотра
Использование инструментов 3D просмотра
Запись анимации перемещения по траектории
Понятия
Процедуры
Команды

Команды
АНИМТРАЕКТ | Сохраняет анимацию вдоль траектории в 3D модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с несколькими видами в пространстве модели - Понятия

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Понятия
Процедуры
Команды

Для того, чтобы одновременно просматривать несколько видов одного чертежа, область построения чертежа на вкладке "Модель" можно разбить на отдельные области просмотра, называемые видовыми экранами пространства модели. Конфигурации видовых экранов пространства модели можно сохранять для повторного использования.

  • Видовые экраны пространства модели
    Графическую область на вкладке "Модель" можно разбить на несколько неперекрывающихся прямоугольных областей, называемых видовыми экранами пространства модели.
  • Выбор текущего видового экрана и работа с ним
    При использовании нескольких видовых экранов один из них является текущим; именно он воспринимает команды управления видом и действия с применением курсора.
  • Сохранение и восстановление конфигураций видовых экранов
    Конфигурации видовых экранов пространства модели можно сохранять, присваивая им имена, и впоследствии восстанавливать их.

См. также

Работа в пространствах модели и листа

Создание и изменение видовых экранов листа


Работа с несколькими видами в пространстве модели - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Понятия
Процедуры
Команды

Разделение видового экрана пространства модели

Объединение двух видовых экранов на вкладке "Модель"

Восстановление одного видового экрана на вкладке "Модель"

Перехода со вкладки разметки листа на вкладку "Модель"

Установка видового экрана текущим

Циклический перебор видовых экранов без нажатия

Сохранение именованной конфигурации видовых экранов

Восстановление именованной конфигурации видовых экранов

Удаление именованной конфигурации видовых экранов

Просмотр списка конфигураций видовых экранов


Работа с несколькими видами в пространстве модели - Команды

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Понятия
Процедуры
Команды
Команды
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
Системные переменные
CTAB | Отображение имени текущей вкладки (модель или лист) в чертеже.
CVPORT | Отображает идентификационный номер текущего видового экрана
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
TILEMODE | Устанавливает вкладку "Модель" или последнюю вкладку листа текущей
VIEWCTR | Сохраняет центр вида на текущем видовом экране
VIEWSIZE | Сохраняет высоту вида на текущем видовом экране, выраженную в единицах чертежа
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Видовые экраны пространства модели - Понятия

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Видовые экраны пространства модели
Понятия
Процедуры
Команды

На видовых экранах отображаются различные виды модели. Графическую область на вкладке "Модель" можно разбить на несколько неперекрывающихся прямоугольных областей, называемых видовыми экранами пространства модели. В больших или сложных чертежах использование различных видов позволяет избежать частого выполнения операций зумирования и панорамирования. Кроме того, ошибки, незаметные на одном виде, могут быть обнаружены на другом.

Видовые экраны на вкладке "Модель" полностью занимают графическую область, не перекрывая друг друга. Во время редактирования чертежа на одном видовом экране тут же происходит обновление изображений на других видовых экранах. На следующей иллюстрации показаны три видовых экрана на вкладке "Модель".

На вкладке разметки листа также можно создавать видовые экраны. Эти видовые экраны, называемые видовыми экранами разметки листа, используются для компоновки чертежа, выводимого на печать. Видовые экраны листа можно перемещать, можно также изменять их размеры. Возможности управления видовыми экранами на листе достаточно разнообразны. Подробнее о листах и видовых экранах листа см. Создание многовидовых чертежей (в пространстве листа).

Работа с видовым экраном пространства модели

На видовом экране пространства модели можно:

  • Выполнять панорамирование, зумирование, задавать режимы сетки, шаговой привязки и изображения знака ПСК, а также восстанавливать именованные виды.
  • Сохранять расположение системы координат для каждого видового экрана.
  • Переключаться с одного видового экрана на другой в ходе выполнения команд построения чертежа.
  • Сохранять именованную конфигурацию видовых экранов и повторно использовать ее на вкладке "Модель" или применять на вкладке разметки листа.

Задание различных систем координат для отдельных видовых экранов обычно требуется при работе с трехмерными моделями. См. Назначение пользовательской системы координат видовому экрану.

Разделение и объединение видовых экранов пространства модели

На следующей иллюстрации показано несколько стандартных конфигураций видовых экранов пространства модели.

Видовые экраны пространства модели можно изменять, разбивая их на части и объединяя друг с другом. Объединяемые видовые экраны должны иметь общую границу одной длины.


Видовые экраны пространства модели - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Видовые экраны пространства модели
Понятия
Процедуры
Команды

Разделение видового экрана пространства модели

Объединение двух видовых экранов на вкладке "Модель"

Восстановление одного видового экрана на вкладке "Модель"

Перехода со вкладки разметки листа на вкладку "Модель"


Разделение видового экрана пространства модели - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Видовые экраны пространства модели
Понятия
Процедуры
Команды

Разделение видового экрана пространства модели

  1. Если имеется насколько видовых экранов, нажмите кнопку мыши внутри видового экрана, который требуется разделить.
  2. Нажмите "Вид" » "Видовые экраны", а затем "2 ВЭкрана", "3 ВЭкрана" или "4 ВЭкрана" для того, чтобы указать количество создаваемых видовых экранов в пространстве модели.
  3. На запрос в командной строке укажите порядок расположения новых видовых экранов.

Ввод команды: ВЭКРАН


Объединение двух видовых экранов на вкладке "Модель" - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Видовые экраны пространства модели
Понятия
Процедуры
Команды

Объединение двух видовых экранов на вкладке "Модель"

  1. Нажмите "Вид" » "Видовые экраны" » "Соединить".
  2. Нажмите кнопку мыши на видовом экране пространства модели, содержащем сохраняемый вид.
  3. Нажмите кнопку мыши внутри смежного видового экрана, который требуется присоединить к первому.

Ввод команды: ВЭКРАН


Восстановление одного видового экрана на вкладке "Модель" - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Видовые экраны пространства модели
Понятия
Процедуры
Команды

Восстановление одного видового экрана на вкладке "Модель"

  • Нажмите "Вид" » "Видовые экраны" » "1 ВЭкран".

Ввод команды: ВЭКРАН


Перехода со вкладки разметки листа на вкладку "Модель" - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Видовые экраны пространства модели
Понятия
Процедуры
Команды

Перехода со вкладки разметки листа на вкладку "Модель"

  • Нажмите вкладку "Модель" внизу области рисования.

Ввод команды: TILEMODE


Видовые экраны пространства модели - Команды

Работа с несколькими видами в пространстве модели
Работа с несколькими видами в пространстве модели
Видовые экраны пространства модели
Понятия
Процедуры
Команды

Команды
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
Системные переменные
CTAB | Отображение имени текущей вкладки (модель или лист) в чертеже.
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
TILEMODE | Устанавливает вкладку "Модель" или последнюю вкладку листа текущей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор текущего видового экрана и работа с ним - Понятия

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Выбор текущего видового экрана и работа с ним
Понятия
Процедуры
Команды

При использовании нескольких видовых экранов один из них является текущим; именно он воспринимает команды управления видом и действия с применением курсора.

На текущем видовом экране курсор меняет свою форму со стрелки на перекрестье, а граница видового экрана выделена. Переключиться с одного видового экрана на другой можно в любой момент, кроме тех случаев, когда выполняется какая-либо команда работы с видами.

Для установки видового экрана текущим, нажмите кнопку мыши на нем или нажмите CTRL + R для переключения между существующими видовыми экранами.

Например, в случае построения отрезка можно указать его начало на первом видовом экране пространства модели, затем переключиться нажатием кнопки мыши на второй видовой экран и указать на нем конечную точку отрезка. Этот метод особенно удобен на больших чертежах, когда требуется построить отрезок, соединяющий удаленные точки.


Выбор текущего видового экрана и работа с ним - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Выбор текущего видового экрана и работа с ним
Понятия
Процедуры
Команды

Установка видового экрана текущим

Циклический перебор видовых экранов без нажатия


Установка видового экрана текущим - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Выбор текущего видового экрана и работа с ним
Понятия
Процедуры
Команды

Установка видового экрана текущим

  • Нажмите кнопку мыши в пределах видового экрана.


Циклический перебор видовых экранов без нажатия - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Выбор текущего видового экрана и работа с ним
Понятия
Процедуры
Команды

Циклический перебор видовых экранов без нажатия

  • Нажимайте CTRL + R.


Выбор текущего видового экрана и работа с ним - Команды

Работа с несколькими видами в пространстве модели
Работа с несколькими видами в пространстве модели
Выбор текущего видового экрана и работа с ним
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
CVPORT | Отображает идентификационный номер текущего видового экрана
VIEWCTR | Сохраняет центр вида на текущем видовом экране
VIEWSIZE | Сохраняет высоту вида на текущем видовом экране, выраженную в единицах чертежа
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение и восстановление конфигураций видовых экранов - Понятия

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Сохранение и восстановление конфигураций видовых экранов
Понятия
Процедуры
Команды

Конфигурации видовых экранов пространства модели можно сохранять, присваивая им имена, и впоследствии восстанавливать их.

Избегайте необходимости каждый раз заново настраивать видовые экраны и виды на чертеже. С помощью команды ВЭКРАН конфигурации видовых экранов могут быть сохранены и позже восстановлены по имени. К характеристикам сохраняемых конфигураций видовых экранов относятся:

  • число видовых экранов и их расположение
  • виды, установленные внутри видовых экранов
  • сетка и шаг привязки для каждого видового экрана
  • Настройки знака ПСК для каждого видового экрана

Сохраненные конфигурации видовых экранов можно просматривать в списке, восстанавливать и удалять. Конфигурация видовых экранов, сохраненная на вкладке "Модель", может применяться и на вкладке разметки листа.


Сохранение и восстановление конфигураций видовых экранов - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Сохранение и восстановление конфигураций видовых экранов
Понятия
Процедуры
Команды

Сохранение именованной конфигурации видовых экранов

Восстановление именованной конфигурации видовых экранов

Удаление именованной конфигурации видовых экранов

Просмотр списка конфигураций видовых экранов


Сохранение именованной конфигурации видовых экранов - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Сохранение и восстановление конфигураций видовых экранов
Понятия
Процедуры
Команды

Сохранение именованной конфигурации видовых экранов

  1. Нажмите "Вид" » "Видовые экраны" » "Новые ВЭкраны".
  2. В диалоговом окне "Видовые экраны" на вкладке "Новые ВЭкраны" введите имя сохраняемой конфигурации.

    3. Имя должно иметь в длину не более 255 символов; оно может состоять из букв, цифр и специальных символов (знак доллара ($), минус (-) и знак подчеркивания (_)).

  3. Нажмите "ОК".

Примечание Конфигурацию видовых экранов можно сохранять только на вкладке "Модель".

Ввод команды: ВЭКРАН


Восстановление именованной конфигурации видовых экранов - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Сохранение и восстановление конфигураций видовых экранов
Понятия
Процедуры
Команды

Восстановление именованной конфигурации видовых экранов

  1. Выберите "Вид" » "Видовые экраны" » "Именованные ВЭкраны".
  2. В диалоговом окне "Видовые экраны" на вкладке "Именованные ВЭкраны" выберите конфигурацию видовых экранов в списке.
  3. Нажмите "ОК".

Ввод команды: ВЭКРАН


Удаление именованной конфигурации видовых экранов - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Сохранение и восстановление конфигураций видовых экранов
Понятия
Процедуры
Команды

Удаление именованной конфигурации видовых экранов

  1. Выберите "Вид" » "Видовые экраны" » "Именованные ВЭкраны".
  2. В диалоговом окне "Видовые экраны" на вкладке "Именованные ВЭкраны" выберите имя конфигурации видовых экранов в списке.
  3. Нажмите клавишу Delete.

Ввод команды: ВЭКРАН


Просмотр списка конфигураций видовых экранов - Процедуры

Управление видами чертежей
Работа с несколькими видами в пространстве модели
Сохранение и восстановление конфигураций видовых экранов
Понятия
Процедуры
Команды

Просмотр списка конфигураций видовых экранов

  • Нажмите "Вид" » "Видовые экраны" » "Именованные ВЭ" для отображения диалогового окна "Видовые экраны".

На вкладке "Именованные ВЭкраны" диалогового окна "Видовые экраны" отображается список всех именованных конфигураций видовых экранов чертежа.

Ввод команды: ВЭКРАН


Сохранение и восстановление конфигураций видовых экранов - Команды

Работа с несколькими видами в пространстве модели
Работа с несколькими видами в пространстве модели
Сохранение и восстановление конфигураций видовых экранов
Понятия
Процедуры
Команды

Команды
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор рабочего процесса

Создание одновидовых чертежей (в пространстве модели)
Для создания двумерного чертежа, имеющего один вид, и нанесения всех пояснительных элементов достаточно пространства модели. Это обычный метод создания чертежей в AutoCAD®.

Создание многовидовых чертежей (в пространстве листа)
Пространство листа - это среда листа, в которой можно задавать формат, добавлять основную надпись, отображать различные виды модели, а также наносить размеры и примечания к чертежу.

Работа с листами в подшивке
С помощью Диспетчера подшивок пользователь может организовывать листы чертежей в именованные подшивки. Листы в подшивке можно передавать, публиковать и архивировать как одно целое.


Выбор рабочего процесса - Понятия

Выбор рабочего процесса
Выбор рабочего процесса
Выбор рабочего процесса
Понятия
Процедуры
Команды

Чертеж может быть полностью расположен в пространстве модели. Обычно такой чертеж имеет единственный вид и единый масштаб. Это традиционный способ создания чертежей.

Пространство листа представляет собой имитирующую лист бумаги среду, в которой можно указать размер используемого листа, добавить основную надпись, отобразить пользовательскую модель во множестве видов и создать размеры и примечания для пользовательского чертежа.

С помощью Диспетчера подшивок можно организовывать листы чертежей в именованные подшивки. Входящие в подшивку листы и их группы можно включать в передаваемые другим пользователям комплекты, публиковать и архивировать.


Выбор рабочего процесса - Процедуры

Выбор рабочего процесса
Выбор рабочего процесса
Выбор рабочего процесса
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Выбор рабочего процесса - Команды

Выбор рабочего процесса
Выбор рабочего процесса
Выбор рабочего процесса
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Создание одновидовых чертежей (в пространстве модели) - Понятия

Выбор рабочего процесса
Создание одновидовых чертежей (в пространстве модели)
Понятия
Процедуры
Команды

Для создания двумерного чертежа, имеющего один вид, и нанесения всех пояснительных элементов достаточно пространства модели. Это обычный метод создания чертежей в AutoCAD®.

  • Коротко о черчении в пространстве модели
    Процесс создания и вывода на печать файла чертежа в пространстве модели отличается от процесса черчения вручную.
  • Рисование, масштабирование и пояснения в пространстве модели
    При создании чертежа и вывода его на печать из пространства модели необходимо перед выводом на печать задать и применить масштабный коэфициент к объектам пояснений.


Создание одновидовых чертежей (в пространстве модели) - Процедуры

Выбор рабочего процесса
Создание одновидовых чертежей (в пространстве модели)
Понятия
Процедуры
Команды

Определение режима отображения единиц чертежа


Создание одновидовых чертежей (в пространстве модели) - Команды

Выбор рабочего процесса
Создание одновидовых чертежей (в пространстве модели)
Понятия
Процедуры
Команды
Команды
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
МОДЕЛЬ | Переключение со вкладки "Лист" на вкладку "Модель"
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
РЗМСТИЛЬ | Создание и модификация размерных стилей
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
ТИПЛИН | Загрузка, установка и изменение типов линий
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
CELTSCALE | Установка текущего коэффициента масштабирования для типа линий объекта.
CVPORT | Отображает идентификационный номер текущего видового экрана
DIMSCALE | Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения
HPSCALE | Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым
HPSPACE | Указывает расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть ненулевым
INSUNITS | Указывает значение в единицах чертежа для автоматического масштабирования блоков, изображений или вставленных или прикрепленных к чертежу внешних ссылок
INSUNITSDEFSOURCE | Устанавливает единицы измерения исходного содержимого, когда переменная INSUNITS имеет значение, равное 0
INSUNITSDEFTARGET | Устанавливает единицы измерения в целевом чертеже, когда переменная INSUNITS имеет значение, равное 0
LTSCALE | Глобальный масштаб типов линий
LUNITS | Устанавливает линейные единицы
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
TEXTSIZE | Устанавливает высоту по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля
TILEMODE | Устанавливает вкладку "Модель" или последнюю вкладку листа текущей
VIEWCTR | Сохраняет центр вида на текущем видовом экране
VIEWSIZE | Сохраняет высоту вида на текущем видовом экране, выраженную в единицах чертежа
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о черчении в пространстве модели - Понятия

Выбор рабочего процесса
Создание одновидовых чертежей (в пространстве модели)
Коротко о черчении в пространстве модели
Понятия
Процедуры
Команды

Процесс создания и вывода на печать файла чертежа в пространстве модели отличается от процесса черчения вручную.

В AutoCAD имеются две различные рабочие среды, отображаемые на вкладках модели и разметки листа. Эти вкладки расположены внизу окна.

Двумерный чертеж, имеющий один вид, может быть полностью создан в пространстве модели. Здесь же, без использования пространства листа, к нему можно добавлять пояснения. Это обычный метод создания чертежей AutoCAD. Данный способ очень прост, однако имеет ряд ограничений:

  • Он применяется только для двумерных чертежей
  • Он не позволяет создавать несколько видов или использовать настройки слоев, зависимые от вида
  • Необходимо выполнять специальные вычисления для масштабирования пояснений и основных надписей

При использовании данного способа геометрические объекты рисуются в масштабе 1:1, а текст, размеры и пояснения - в том масштабе, который будет соответствовать печатной версии чертежа.

См. также

Создание многовидовых чертежей (в пространстве листа)

Работа с листами в подшивке


Создание одновидовых чертежей (в пространстве модели)

Выбор рабочего процесса
Создание одновидовых чертежей (в пространстве модели)
Создание одновидовых чертежей (в пространстве модели)
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Коротко о черчении в пространстве модели - Команды

Создание одновидовых чертежей (в пространстве модели)
Создание одновидовых чертежей (в пространстве модели)
Коротко о черчении в пространстве модели
Понятия
Процедуры
Команды

Команды
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
МОДЕЛЬ | Переключение со вкладки "Лист" на вкладку "Модель"
Системные переменные
CVPORT | Отображает идентификационный номер текущего видового экрана
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
TILEMODE | Устанавливает вкладку "Модель" или последнюю вкладку листа текущей
VIEWCTR | Сохраняет центр вида на текущем видовом экране
VIEWSIZE | Сохраняет высоту вида на текущем видовом экране, выраженную в единицах чертежа
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Рисование, масштабирование и пояснения в пространстве модели - Понятия

Выбор рабочего процесса
Создание одновидовых чертежей (в пространстве модели)
Рисование, масштабирование и пояснения в пространстве модели
Понятия
Процедуры
Команды

При создании чертежа и вывода его на печать из пространства модели необходимо перед выводом на печать задать и применить масштабный коэфициент к объектам пояснений.

Для создания чертежа и вывода его на печать можно пользоваться только пространством модели. Данный способ применим для двумерных чертежей, имеющих один вид. Он включает в себя следующие действия:

  • Установка единиц измерения (единиц чертежа) для чертежа.
  • Установка режима отображения единиц чертежа.
  • Вычисление и задание масштаба размеров, пояснений и блоков.
  • Построение чертежа в масштабе 1:1 в пространстве модели.
  • Создание пояснений и вставка блоков в пространстве модели.
  • Вывод чертежа на печать в заранее заданном масштабе.
Установка единиц изменения

Перед началом работы в пространстве модели необходимо определить, какие будут использоваться единицы изменения (единицы чертежа). Единицей чертежа может быть дюйм, миллиметр, километр и т.д. Например, при вычерчивании детали двигателя единица чертежа может соответствовать одному миллиметру, а при составлении карты местности — одному километру.

Режим отображения единиц чертежа

После выбора единицы чертежа необходимо задать режим ее отображения, включающий в себя тип единицы и точность. Например, значение 14,5 может отображаться как 14,500, 14-1/2, или 1'2-1/2".

Режим отображения единиц чертежа задается с помощью команды ЕДИНИЦЫ. По умолчанию тип единиц чертежа задается как десятичный.

Задание масштаба для пояснений и блоков

Прежде чем приступить к работе над чертежом, следует задать масштаб для размеров, пояснений и блоков. Необходимые размеры этих элементов сохраняются и после масштабирования при выводе окончательного чертежа на печать.

Масштаб задается для следующих объектов:

  • Текст. Высота символов задается при создании текста или заданием фиксированного размера в текстовом стиле (СТИЛЬ).
  • Размеры. Масштаб размеров задается в размерном стиле (команда РЗМСТИЛЬ) или с помощью системной переменной DIMSCALE.
  • Типы линий. Масштаб прерывистых линий задается системными переменными CELTSCALE и LTSCALE.
  • Образцы штриховок. Масштаб образцов штриховок задается в диалоговом окне "Штриховка и градиент" (ШТРИХ) или с помощью системной переменной HPSCALE.
  • Блоки. Масштаб вставки блоков задается непосредственно при их вставке, либо в диалоговом окне "Вставка" (ВСТАВИТЬ), либо в DesignCenter (ЦУВКЛ). Для вставки блоков используются системные переменные INSUNITS, INSUNITSDEFSOURCE и INSUNITSDEFTARGET. То же самое относится к границам и основной надписи чертежа.
Задание масштаба вывода на печать

Для вывода чертежа в пространстве модели на печать можно точно вычислить масштабный коэффициент, выразив масштаб чертежа в виде отношения 1:n. Это отношение показывает связь между единицей получаемого при печати чертежа и единицей чертежа, отражающей реальные размеры изображаемых объектов.

Например, если чертеж выводится на печать при масштабе 1/4 дюйма = 1 фут, то масштабный коэффициент равен 48. Расчеты выглядят следующим образом:

1/4" = 12"

1 = 12 x 4

1 (единица чертежа на бумаге) = 48 (единиц чертежа)

Аналогичным образом можно убедиться, что для масштаба 1 сантиметр = 1 метр масштабный коэффициент равен 100, а для масштаба 1 дюйм = 20 футов масштабный коэффициент равен 240.

Примеры масштабных коэффициентов

В следующей таблице приводятся примеры масштабных коэффициентов, которые можно использовать для расчета размера текста в архитектурном формате единиц в пространстве модели.

Масштаб | Масштабный коэффициент | Для печати текста с размером | Установите размер текста чертежа равным
1 см = 1 м | 100 | 3 мм | 30 см
1/8" = 1'-0" | 96 | 1/8" | 12"
3/16" = 1'-0" | 64 | 1/8" | 8"
1/4" = 1'-0" | 48 | 1/8" | 6"
3/8" = 1'-0" | 32 | 1/8" | 4"
1/2" = 1'-0" | 24 | 1/8" | 3"
3/4" = 1'-0" | 16 | 1/8" | 2"
1" = 1'-0" | 12 | 1/8" | 1.5"
1 1/2" = 1'-0" | 8 | 1/8" | 1,0"

При использовании метрических единиц для формата листа 210 x 297 мм (A4) масштабный коэффициент будет составлять 20. Расчет лимитов сетки:

210 x 20 = 4200 мм

297 x 20 = 5900 мм

См. также

Задание единиц и формата единиц


Определение режима отображения единиц чертежа - Процедуры

Выбор рабочего процесса
Создание одновидовых чертежей (в пространстве модели)
Рисование, масштабирование и пояснения в пространстве модели
Понятия
Процедуры
Команды

Определение режима отображения единиц чертежа

  1. Выберите "Формат" » "Единицы".
  2. В диалоговом окне "Единицы чертежа" задайте значения единиц для чертежа.
  3. Изменения параметров единиц отображаются в группе "Пример".
    • В группе "Линейные" выберите формат единиц и уровень точности. Это задает режим отображения линейных единиц чертежа.
    • В группе "Единицы для масштабирования блоков при вставке" выберите единицы, которые необходимо использовать для масштабирования блоков, изображений и других элементов, вставляемых в чертеж. Если масштабировать вставляемые элементы не требуется, выберите "Безразмерный".
    • В группе "Угловые" выберите формат угловых единиц и уровень точности. Это задает режим отображения угловых единиц чертежа. По умолчанию нулевым считается направление вправо.
    • Для задания направления угла нажмите кнопку "Направление", а затем в диалоговом окне "Выбор направления" выберите базовый угол. Направление угла управляет точкой и направлением, относительно которых измеряются углы. При выборе "Другой" можно ввести угол или нажать кнопку "Угол", чтобы задать его с помощью устройства указания. По умолчанию углы отсчитываются против часовой стрелки.
  4. Для выхода из каждого диалогового окна необходимо нажимать кнопку "ОК".

Ввод команды: ЕДИНИЦЫ


Рисование, масштабирование и пояснения в пространстве модели - Команды

Создание одновидовых чертежей (в пространстве модели)
Создание одновидовых чертежей (в пространстве модели)
Рисование, масштабирование и пояснения в пространстве модели
Понятия
Процедуры
Команды

Команды
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
РЗМСТИЛЬ | Создание и модификация размерных стилей
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
ТИПЛИН | Загрузка, установка и изменение типов линий
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
CELTSCALE | Установка текущего коэффициента масштабирования для типа линий объекта.
DIMSCALE | Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения
HPSCALE | Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым
HPSPACE | Указывает расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть ненулевым
INSUNITS | Указывает значение в единицах чертежа для автоматического масштабирования блоков, изображений или вставленных или прикрепленных к чертежу внешних ссылок
INSUNITSDEFSOURCE | Устанавливает единицы измерения исходного содержимого, когда переменная INSUNITS имеет значение, равное 0
INSUNITSDEFTARGET | Устанавливает единицы измерения в целевом чертеже, когда переменная INSUNITS имеет значение, равное 0
LTSCALE | Глобальный масштаб типов линий
LUNITS | Устанавливает линейные единицы
TEXTSIZE | Устанавливает высоту по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание многовидовых чертежей (в пространстве листа) - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Понятия
Процедуры
Команды

Пространство листа - это среда листа, в которой можно задавать формат, добавлять основную надпись, отображать различные виды модели, а также наносить размеры и примечания к чертежу.

  • Коротко о работе на листах
    Существуют две различных рабочих среды, которые отображаются на вкладках "Модель" и "Лист".
  • Процесс работы с листами
    Процесс подготовки чертежа к печати из вкладки "Лист" подразделяется на несколько этапов.
  • Работа в пространствах модели и листа
    Возможность переключаться между пространством модели и пространством листа для выполнении определенных задач дает пользователю целый ряд преимуществ. Для создания и редактирования модели используется пространство модели. Для компоновки листа и установки видов используется пространство листа.
  • Создание и изменение видовых экранов листа
    На листе может создаваться один видовой экран, занимающий весь лист, или несколько видовых экранов. Размеры, свойства, масштаб и расположение видовых экранов могут меняться.
  • Управление видами на видовых экранах листа
    В процессе создания листа можно создавать видовые экраны, которые рассматриваются как "окна" в пространстве модели. Отображаемым видом каждого видового экрана можно управлять.
  • Повторное использование листов и их параметров
    При создании листа можно использовать информацию из существующего шаблона.


Создание многовидовых чертежей (в пространстве листа) - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Понятия
Процедуры
Команды

Выбор вкладки "Модель"

Указание параметров текущего листа

Создание нового листа

Импорт листа из шаблона

Создание листа с помощью Мастера

Создание копии листа

Переименование листа

Удаление листа

Перемещение вкладок листов

Установка листа текущим

Перемещение объекта из пространства модели в пространство листа (или наоборот)

Переход к предыдущему листу

Выделение всех листов

Печать листа

Переключение между пространством модели и пространством листа

Редактирование объектов в развернутом видовом экране листа

Создание нового видового экрана на листе

Создание конфигурации видового экрана на листе

Вставка на лист именованной конфигурации видовых экранов

Изменение свойств видового экрана с помощью палитры "Свойства"

Подрезка границ видового экрана

Изменение масштаба видового экрана с помощью палитры "Свойства"

Включение блокирования масштаба на видовом экране

Замораживание или размораживание слоев на текущем видовом экране листа

Просмотр списка слоев, замороженных на текущем экране

Замораживание или размораживание слоев на всех видовых экранах

Замораживание или размораживание слоев в пространстве листа

Замораживание или размораживание слоев на новых видовых экранах

Создание новых слоев, замороженных на всех видовых экранах

Задание интенсивности вывода объектам на видовом экране листа

Включение и отключение видовых экранов с помощью палитры "Свойства"

Установка единого масштаба линий в пространстве листа

Выравнивание объектов на разных видовых экранах с помощью вспомогательной линии

Выравнивание объектов на разных видовых экранах с помощью команды ФОРМАТЛ

Поворот вида путем изменения ПСК

Поворот вида с помощью команды ФОРМАТЛ

Создание листа на основе шаблона

Сохранение шаблона листа

Вставка листа с помощью Центра управления


Создание многовидовых чертежей (в пространстве листа) - Команды

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Понятия
Процедуры
Команды
Команды
ВСЛОЙ | Управление видимостью слоев для отдельных видовых экранов
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ВЭКРЕЗ | Подрезает объекты на видовых экранах и границы видового экрана.
ВЭКРМАКС | Развертывает текущий видовой экран листа для редактирования
ВЭКРМИН | Восстанавливает текущий видовой экран листа
ДИСПСК | Управление заданными пользовательскими системами координат
ЗНАКПСК | Управление видимостью и расположением знака ПСК
ИМПОРТПЛ | Импорт набора параметров листа из другого файла чертежа во вновь создаваемый лист
ЛИСТ | Переключение видовых экранов из пространства модели в пространство листа
МАСТЕРЛИСТ | Создание нового листа, задание параметров листа и печати
МАСТЕРПЕЧ | Вызов Мастера для импорта параметров печати из PCP- и PC2-файлов настройки для вкладки "Модель" или текущего листа
МОДЕЛЬ | Переключение со вкладки "Лист" на вкладку "Модель"
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПЛАН | Отображение вида в плане указанной ПСК
ПОКАЗАТЬ | Увеличение или уменьшение видимого размера объектов на текущем видовом экране
ПСК | Управление пользовательскими системами координат
РЛИСТ | Создание и изменение вкладок разметок листа в чертеже
СВИД | Создание видовых экранов на листах и управление ими
СВОЙСТВА | Изменяет свойства объекта
СЛОЙ | Управление слоями и их свойствами
СПИСМАСШТРЕД | Управление списком доступных значений масштаба для видовых экранов, листа и печати
ТИПЛИН | Загрузка, установка и изменение типов линий
ФОРМАТЛ | Задание параметров чертежа
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
CTAB | Отображение имени текущей вкладки (модель или лист) в чертеже.
CVPORT | Отображает идентификационный номер текущего видового экрана
LAYOUTREGENCTL | Указывает режим обновления списка отображения на вкладке "Модель" и вкладках "Лист"
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
PLOTROTMODE | Управляет ориентацией чертежа
PSLTSCALE | Управляет масштабированием типов линий в пространстве листа
TDCREATE | Сохраняет дату и время (местное) создания чертежа
TDUCREATE | Сохраняет дату и время (всемирное) создания чертежа
TDUPDATE | Сохраняет дату и время (местное) последнего сохранения/обновления
TDUUPDATE | Сохраняет дату и время (всемирное) последнего сохранения/обновления
TILEMODE | Устанавливает вкладку "Модель" или последнюю вкладку листа текущей
UCSVP | Определяет, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана
VPMAXIMIZEDSTATE | Сохраняет значение, которое указывает, что видовой экран развернут
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о работе на листах - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Коротко о работе на листах
Понятия
Процедуры
Команды

Существуют две отдельные среды ("пространства"), в которых можно создавать объекты чертежа.

Обычно модель, состоящая из геометрических объектов, создается в трехмерном пространстве, называемом пространством модели. Готовый лист чертежа с определенными видами и надписями создается в двумерном пространстве, называемом пространством листа. Переключение между данными пространствами осуществляется с помощью вкладок, расположенных в нижней части окна чертежа: вкладка "Модель" и одна или несколько вкладок "Лист".

Примечание Эти вкладки могут быть скрыты и отображаться в виде кнопок в строке состояния в центре внизу окна приложения.

На вкладке "Модель" создание чертежа выполняется в масштабе 1:1. На вкладке "Лист" размещаются видовые экраны, наносятся размеры, примечания и основная надпись.

На вкладке "Лист" каждый видовой экран представляет собой определенную "фотографию" модели. Каждый видовой экран содержит вид, отображающий модель с заданным масштабом и ориентацией. Для каждого видового экрана задаются свои видимые слои.

После завершения компоновки листа можно отключить слой, содержащий объекты видового экрана листа. Виды остаются видимыми, и лист можно распечатать, не отображая границ видового экрана.


Создание многовидовых чертежей (в пространстве листа)

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Коротко о работе на листах - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Коротко о работе на листах
Понятия
Процедуры
Команды

Команды
ВСЛОЙ | Управление видимостью слоев для отдельных видовых экранов
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ИМПОРТПЛ | Импорт набора параметров листа из другого файла чертежа во вновь создаваемый лист
ЛИСТ | Переключение видовых экранов из пространства модели в пространство листа
МАСТЕРЛИСТ | Создание нового листа, задание параметров листа и печати
МОДЕЛЬ | Переключение со вкладки "Лист" на вкладку "Модель"
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
РЛИСТ | Создание и изменение вкладок разметок листа в чертеже
СВИД | Создание видовых экранов на листах и управление ими
Системные переменные
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
PSLTSCALE | Управляет масштабированием типов линий в пространстве листа
TILEMODE | Устанавливает вкладку "Модель" или последнюю вкладку листа текущей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Процесс работы с листами - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Процесс работы с листами
Понятия
Процедуры
Команды

Процесс подготовки чертежа к печати из вкладки "Лист" подразделяется на несколько этапов.

Чертеж обычно создается в пространстве модели, а к печати подготавливается в пространстве листа.

В нижней части экрана имеется одна вкладка "Модель" и одна или несколько вкладок "Лист".

Примечание Эти вкладки могут быть скрыты и отображаться в виде кнопок в строке состояния в центре внизу окна приложения.

Краткий обзор процесса

Весь процесс подготовки листа сводится к следующим этапам:

  • Создание модели во вкладке "Модель".
  • Перейдите на вкладку разметки листа.
  • Задание параметров печати: устройство печати, формат, область печати, масштаб, ориентация чертежа.
  • Вставка основной надписи на лист (если при создании чертежа не использовался шаблон, в котором уже имеется основная надпись).
  • Создание нового слоя для видового экрана листа.
  • Создание и размещение на листе видовых экранов.
  • Установка ориентации, масштаба и видимых слоев для каждого видового экрана листа.
  • Нанесение размеров и пояснений на лист, если это необходимо.
  • Отключение слоя, содержащего видовые экраны листа.
  • Печать листа.


Процесс работы с листами - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Процесс работы с листами
Понятия
Процедуры
Команды

Команды
ВСЛОЙ | Управление видимостью слоев для отдельных видовых экранов
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ВЭКРМАКС | Развертывает текущий видовой экран листа для редактирования
ВЭКРМИН | Восстанавливает текущий видовой экран листа
ИМПОРТПЛ | Импорт набора параметров листа из другого файла чертежа во вновь создаваемый лист
ЛИСТ | Переключение видовых экранов из пространства модели в пространство листа
МАСТЕРЛИСТ | Создание нового листа, задание параметров листа и печати
МОДЕЛЬ | Переключение со вкладки "Лист" на вкладку "Модель"
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
РЛИСТ | Создание и изменение вкладок разметок листа в чертеже
СВИД | Создание видовых экранов на листах и управление ими
Системные переменные
LAYOUTREGENCTL | Указывает режим обновления списка отображения на вкладке "Модель" и вкладках "Лист"
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
TILEMODE | Устанавливает вкладку "Модель" или последнюю вкладку листа текущей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа в пространствах модели и листа - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа в пространствах модели и листа
Понятия
Процедуры
Команды

Возможность переключаться между пространством модели и пространством листа для выполнении определенных задач дает пользователю целый ряд преимуществ. Для создания и редактирования модели используется пространство модели. Для компоновки листа и установки видов используется пространство листа.

  • Работа на вкладке "Модель"
    Вкладка "Модель" обеспечивает доступ к безграничной области, называемой пространством модели. В пространстве модели можно создавать, просматривать и редактировать модель.
  • Работа на вкладке "Лист"
    Набор вкладок "Лист" обеспечивает доступ к пространству, называемому пространством листа. В пространстве листа можно размещать основную надпись, создавать видовые экраны листа для отображения различных видов, задавать размеры чертежа, а также добавлять примечания.
  • Переход в пространство модели из видового экрана листа
    Для редактирования объектов, замораживания и размораживания слоев, а также изменения вида необходимо перейти из видового экрана в пространство модели.


Работа в пространствах модели и листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа в пространствах модели и листа
Понятия
Процедуры
Команды

Выбор вкладки "Модель"

Указание параметров текущего листа

Создание нового листа

Импорт листа из шаблона

Создание листа с помощью Мастера

Создание копии листа

Переименование листа

Удаление листа

Перемещение вкладок листов

Установка листа текущим

Перемещение объекта из пространства модели в пространство листа (или наоборот)

Переход к предыдущему листу

Выделение всех листов

Печать листа

Переключение между пространством модели и пространством листа

Редактирование объектов в развернутом видовом экране листа


Работа в пространствах модели и листа - Команды

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа в пространствах модели и листа
Понятия
Процедуры
Команды
Команды
ВСЛОЙ | Управление видимостью слоев для отдельных видовых экранов
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ВЭКРМАКС | Развертывает текущий видовой экран листа для редактирования
ВЭКРМИН | Восстанавливает текущий видовой экран листа
ИМПОРТПЛ | Импорт набора параметров листа из другого файла чертежа во вновь создаваемый лист
ЛИСТ | Переключение видовых экранов из пространства модели в пространство листа
МАСТЕРЛИСТ | Создание нового листа, задание параметров листа и печати
МОДЕЛЬ | Переключение со вкладки "Лист" на вкладку "Модель"
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
РЛИСТ | Создание и изменение вкладок разметок листа в чертеже
СВИД | Создание видовых экранов на листах и управление ими
Системные переменные
CTAB | Отображение имени текущей вкладки (модель или лист) в чертеже.
CVPORT | Отображает идентификационный номер текущего видового экрана
LAYOUTREGENCTL | Указывает режим обновления списка отображения на вкладке "Модель" и вкладках "Лист"
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
PLOTROTMODE | Управляет ориентацией чертежа
TILEMODE | Устанавливает вкладку "Модель" или последнюю вкладку листа текущей
VPMAXIMIZEDSTATE | Сохраняет значение, которое указывает, что видовой экран развернут
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа на вкладке "Модель" - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Модель"
Понятия
Процедуры
Команды

В пространстве модели можно чертить модель в масштабе 1:1, и задавать значение одной единицы чертежа - один миллиметр, сантиметр, метр и т.д.

На вкладке "Модель" пользователь может просматривать и редактировать объекты модели. При этом манипуляции выполняются с помощью перекрестья курсора, действующего в графической области окна.

В пространстве модели можно также задавать те виды, которые будут отображаться в видовых экранах на листе.


Выбор вкладки "Модель" - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Модель"
Понятия
Процедуры
Команды

Выбор вкладки "Модель"

Выполнить одно из следующих действий:

  • Перейти на вкладку "Модель".
  • Нажать правую кнопку мыши на любой вкладке "Модель" или "Лист". Выбрать "Активизировать модель".
  • Если вкладки "Модель" и "Лист" скрыты, нажмите кнопку "Модель" в строке состояния в центре нижней части экрана приложения.


Работа на вкладке "Модель" - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Модель"
Понятия
Процедуры
Команды

Команды
ЛИСТ | Переключение видовых экранов из пространства модели в пространство листа
МОДЕЛЬ | Переключение со вкладки "Лист" на вкладку "Модель"
Системные переменные
LAYOUTREGENCTL | Указывает режим обновления списка отображения на вкладке "Модель" и вкладках "Лист"
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
TILEMODE | Устанавливает вкладку "Модель" или последнюю вкладку листа текущей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа на вкладке "Лист" - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Набор вкладок "Лист" обеспечивает доступ к пространству, называемому пространством листа. В пространстве листа можно размещать основную надпись, создавать видовые экраны листа для отображения различных видов, задавать размеры чертежа, а также добавлять примечания.

В пространстве листа одна единица соответствует расстоянию на распечатанном листе. Единицы задаются в миллиметрах или дюймах, в зависимости от настроек печати плоттера.

На вкладке "Лист" можно просматривать чертеж и редактировать объекты пространства листа, такие как видовые экраны листа и основные надписи. Можно также перемещать объект (например, выноску или основную надпись) из пространства модели в пространство листа и обратно. При этом манипуляции выполняются с помощью перекрестья курсора, действующего в пространстве листа.

Примечание Эти вкладки могут быть скрыты и отображаться в виде кнопок в строке состояния в центре внизу окна приложения. Для отображения вкладок нажмите правую кнопку мыши на кнопке "Модель" или "Лист" и выберите "Отображать вкладки листа и модели" в контекстном меню.

Создание дополнительной вкладки "Лист"

По умолчанию новый чертеж содержит две вкладки листов - "Лист1" и "Лист2". При использовании шаблона чертежа или открытии существующего чертежа вкладки листов могут называться иначе.

Для создания новой вкладки "Лист" можно использовать один из следующих способов:

  • Создать новую вкладку "Лист" без параметров, затем установить параметры с помощью Диспетчера параметров листа.
  • Использовать Мастер компоновки листа для создания новой вкладки "Лист" и установки параметров.
  • Копировать вкладку "Лист" и ее параметры из текущего файла чертежа.
  • Импортировать вкладку "Лист" из существующего шаблона чертежа (DWT-файла) или ранее созданного файла чертежа (DWG-файла).

Нажать правую кнопкой мыши на вкладке "Лист" для отображения контекстного меню.

Примечание В чертеже можно создавать несколько листов, причем листы могут иметь разные параметры и соответствовать разным форматам бумаги. Однако во избежание недоразумений при передаче и распечатке чертежа рекомендуется создавать по одному листу для каждого чертежа.

Задание параметров листа с помощью Мастера компоновки листа

Новый лист можно создать с помощью Мастера компоновки листа. При использовании Мастера процесс создания листа разбивается на несколько этапов, при прохождении которых пользователь задает следующие параметры:

  • Имя нового листа
  • Принтер, назначаемый листу
  • Формат бумаги, используемый для листа
  • Ориентация чертежа на листе бумаги
  • Основная надпись
  • Параметры видового экрана
  • Расположение видового экрана на листе

Заданные в окне Мастера параметры можно в дальнейшем отредактировать, указав лист и выбрав из меню "Файл" пункт "Параметры листа".


Работа на вкладке "Лист" - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Указание параметров текущего листа

Создание нового листа

Импорт листа из шаблона

Создание листа с помощью Мастера

Создание копии листа

Переименование листа

Удаление листа

Перемещение вкладок листов

Установка листа текущим

Перемещение объекта из пространства модели в пространство листа (или наоборот)

Переход к предыдущему листу

Выделение всех листов

Печать листа


Указание параметров текущего листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Указание параметров текущего листа

  • Нажать правую кнопку мыши на вкладке текущего листа и выбрать в контекстном меню "Параметры листа".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ


Создание нового листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Создание нового листа

  1. Нажмите "Вставить" » "Лист" » "Новый лист".
  2. В командной строке ввести имя нового листа.

    3. Появляется новая вкладка "Лист". Для перехода на новый лист выберите его вкладку.

Панель "Листы"

Ввод команды: РЛИСТ


Импорт листа из шаблона - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Импорт листа из шаблона

  1. Нажмите "Вставить" » "Разметка листа" » "Разметка листа по шаблону".
  2. В диалоговом окне "Выбор файла" выбрать файл DWT или DWG, из которого необходимо импортировать лист.
  3. Нажмите "Открыть".
  4. В диалоговом окне "Вставка листов" выбрать импортируемый лист.

    5. Появляется новая вкладка "Лист". Для перехода на новый лист выберите вкладку листа.

Панель "Листы"

Ввод команды: РЛИСТ


Создание листа с помощью Мастера - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Создание листа с помощью Мастера

  1. Нажмите "Вставить" » "Разметка листа" » "Мастер компоновки".
  2. На каждой странице Мастера создания листа необходимо задать соответствующие настройки для нового листа.

    3. После завершения работы Мастера вновь созданный лист станет текущим.

Ввод команды: МАСТЕРЛИСТ


Создание копии листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Создание копии листа

  1. Нажать правую кнопку мыши на вкладке листа, который необходимо скопировать. Выберите "Переместить/Копировать".
  2. В диалоговом окне "Перемещение/копирование" указать положение новой вкладки листа.
  3. Установить флажок "Создать копию".
  4. Нажмите "ОК".

Примечание К вкладке "Модель" операция создания копии не применима.

Ввод команды: РЛИСТ


Переименование листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Переименование листа

  1. Нажать правую кнопку мыши на вкладке листа, который необходимо переименовать. Выбрать "Переименовать".
  2. В диалоговом окне "Переименование листа" ввести новое имя листа.
  3. Нажмите "ОК".

Примечание К вкладке "Модель" операция переименования не применима.

Ввод команды: РЛИСТ


Удаление листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Удаление листа

  1. Нажать правую кнопку мыши на вкладке листа, который необходимо удалить и выбрать в контекстном меню "Удалить".
  2. В окне предупреждения нажать "OK" для удаления листа.

    3. При удалении листа автоматически удаляются все связанные с ним виды.

Примечание К вкладке "Модель" такая операция неприменима.

Ввод команды: РЛИСТ


Перемещение вкладок листов - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Перемещение вкладок листов

  1. Нажать правую кнопку мыши на вкладке листа, который необходимо переместить. Выберите "Переместить/Копировать".
  2. В диалоговом окне "Перемещение/копирование" выбрать лист, перед которым должен быть установлен перемещаемый лист. Для перемещения листа в конец списка установите флажок "Переместить в конец".
  3. Нажмите "ОК".

Примечание К вкладке "Модель" операция перемещения не применима.

Ввод команды: РЛИСТ


Установка листа текущим - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Установка листа текущим

Выполните одно из следующих действий:

  • Нажать кнопку мыши на ярлыке вкладки листа, который требуется установить текущим.
  • Нажимайте CTRL+Page Down для циклического перемещения по вкладкам листов слева направо, или CTRL+Page Up для циклического перемещения по вкладкам листов справа налево. Остановиться на вкладке нужного листа.


Перемещение объекта из пространства модели в пространство листа (или наоборот) - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Перемещение объекта из пространства модели в пространство листа (или наоборот)

  1. Выберите "Изменить" » "Смена пространства".
  2. Выберите один или несколько объектов для перемещения.
  3. Нажмите ENTER для завершения команды.

Ввод команды: СМЕНАПРОСТР


Переход к предыдущему листу - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Переход к предыдущему листу

  1. Нажать правую кнопку мыши на любой вкладке "Модель" или "Лист".
  2. Выберите "Активизировать последний лист".


Выделение всех листов - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Выделение всех листов

  • Нажать правую кнопку мыши на вкладке любого листа. Выбрать в контекстном меню "Выбрать все листы".

Ввод команды: РЛИСТ


Печать листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Печать листа

  1. Выполнить одно из следующих действий:
    • Нажмите правую кнопку мыши на вкладке разметки листа. Нажмите "Печать".
    • Удерживая нажатой клавишу SHIFT, выбрать несколько вкладок листов. Нажмите правую кнопку мыши на вкладке разметки листа. Выбрать в контекстном меню "Опубликовать выбранные листы".
  2. В диалоговом окне "Печать или публикация" выбрать необходимые параметры. Нажмите "OK" или "Опубликовать".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Работа на вкладке "Лист" - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Лист"
Понятия
Процедуры
Команды

Команды
ВСЛОЙ | Управление видимостью слоев для отдельных видовых экранов
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ИМПОРТПЛ | Импорт набора параметров листа из другого файла чертежа во вновь создаваемый лист
ЛИСТ | Переключение видовых экранов из пространства модели в пространство листа
МАСТЕРЛИСТ | Создание нового листа, задание параметров листа и печати
МОДЕЛЬ | Переключение со вкладки "Лист" на вкладку "Модель"
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
РЛИСТ | Создание и изменение вкладок разметок листа в чертеже
СВИД | Создание видовых экранов на листах и управление ими
Системные переменные
CTAB | Отображение имени текущей вкладки (модель или лист) в чертеже.
CVPORT | Отображает идентификационный номер текущего видового экрана
LAYOUTREGENCTL | Указывает режим обновления списка отображения на вкладке "Модель" и вкладках "Лист"
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
PLOTROTMODE | Управляет ориентацией чертежа
TILEMODE | Устанавливает вкладку "Модель" или последнюю вкладку листа текущей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Переход в пространство модели из видового экрана листа - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Переход в пространство модели из видового экрана листа
Понятия
Процедуры
Команды

Для редактирования объектов, замораживания и размораживания слоев, а также изменения вида необходимо перейти из видового экрана в пространство модели.

После создания объектов видового экрана можно перейти в пространство модели для выполнения следующих действий:

  • Создание и изменение объектов в пространстве модели внутри видового экрана.
  • Панорамирование вида внутри видового экрана и изменение режима видимости слоя.

Способ переключения из видового экрана в пространство модели зависит от дальнейших планируемых действий.

Создание и изменение объектов внутри видового экрана

Для создания и изменения объектов видовой экран разворачивается на все окно с помощью кнопки на панели состояния. Видовой экран занимает всю область рисования. Настройки видимости слоев и центральных точек видового экрана сохраняются, при этом также отображаются соседние объекты.

При работе в пространстве модели можно панорамировать и зумировать объекты, однако при восстановлении видового экрана и возврате в пространство листа расположение и масштаб объектов на видовом экране листа восстанавливаются.

Примечание Если в режиме развернутого видового экрана задается команда "Печать", размеры вкладки "Лист" восстанавливаются до появления диалогового окна "Печать". Если сохранить и закрыть чертеж в режиме развернутого видового экрана, при последующем открытии чертежа вкладка "Лист" восстанавливается.

При переключении в пространство модели для внесения изменений, настройки видимости слоев применяются ко всему чертежу, а не только к отдельному видовому экрану. При этом вид не центрируется и не увеличивается, как это происходит в видовом экране.

Выравнивание вида на видовом экране листа

Для панорамирования вида и изменения видимости слоев дважды нажмите кнопку мыши на видовом экране и перейдите в пространство модели. Границы видового экрана становятся толще, а перекрестье курсора видимым только в текущем видовом экране. Все видовые экраны слоя остаются видимыми. В текущем видовом экране можно замораживать и размораживать слои с помощью Диспетчера свойств слоев, а также можно панорамировать вид. Для возврата в пространство листа дважды нажмите кнопку мыши на пустой области листа вне видового экрана. Все изменения будут отображаться в видовом экране.

Если до переключения в пространство модели в видовом экране листа задан определенный масштаб, его можно заблокировать во избежание изменений. При блокировке масштабе из пространства модели не доступна команда ПОКАЗАТЬ.


Переход в пространство модели из видового экрана листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Переход в пространство модели из видового экрана листа
Понятия
Процедуры
Команды

Переключение между пространством модели и пространством листа

Редактирование объектов в развернутом видовом экране листа


Переключение между пространством модели и пространством листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Переход в пространство модели из видового экрана листа
Понятия
Процедуры
Команды

Переключение между пространством модели и пространством листа

На листе можно воспользоваться любым из следующих способов:

  • В пространстве листа дважды нажать кнопку мыши на видовом экране.

    • Это вызывает пространство модели. Выбранный видовой экран листа становится текущим, и в нем можно панорамировать вид или изменять свойства слоя. Для внесения серьезных изменений в модель рекомендуется развернуть видовой экрана листа на весь экран с помощью команды ВЭКРМАКС, либо переключиться на вкладку "Модель".

  • В пространстве модели дважды нажать кнопку мыши вне видового экрана.

    • Это вызывает пространство листа. На листе можно создавать и изменять объекты.

  • Если необходимо перейти на другой видовой экран листа из пространства модели, дважды нажмите кнопку мыши на другом видовом экране листа или нажмите CTRL + R для циклического прохода по имеющимся видовым экранам листов.


Редактирование объектов в развернутом видовом экране листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Переход в пространство модели из видового экрана листа
Понятия
Процедуры
Команды

Редактирование объектов в развернутом видовом экране листа

  1. Для активизации видового экрана листа нажать кнопку мыши на его границе.

    2. Примечание Блокированный видовой экран можно развернуть для редактирования в нем объектов. При восстановлении размеров видового экрана он вновь блокируется.

  2. В строке состояния нажать кнопку "Развернуть видовой экран".

    3. Стрелки рядом с кнопкой "Развернуть видовой экран" используются для восстановления текущего и развертывания другого видового экрана.

  3. Внести любые изменения.
  4. Для возврата в видовой экран листа нажать кнопку "Восстановить видовой экран".

    5. При этом восстанавливаются прежние значения центральной точки и коэффициента экранного увеличения.

Строка состояния

Ввод команды: ВЭКРМАКС, ВЭКРМИН

Контекстное меню: Нажмите правую кнопку мыши. Выбрать в контекстном меню "Развернуть ВЭкран".


Переход в пространство модели из видового экрана листа - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Переход в пространство модели из видового экрана листа
Понятия
Процедуры
Команды

Команды
ВЭКРМАКС | Развертывает текущий видовой экран листа для редактирования
ВЭКРМИН | Восстанавливает текущий видовой экран листа
ЛИСТ | Переключение видовых экранов из пространства модели в пространство листа
МОДЕЛЬ | Переключение со вкладки "Лист" на вкладку "Модель"
Системные переменные
VPMAXIMIZEDSTATE | Сохраняет значение, которое указывает, что видовой экран развернут
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и изменение видовых экранов листа - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Создание и изменение видовых экранов листа
Понятия
Процедуры
Команды

На листе может создаваться один видовой экран, занимающий весь лист, или несколько видовых экранов. Размеры, свойства, масштаб и расположение видовых экранов могут меняться.

Примечание Видовой экран листа должен создаваться на определенном слое. При выводе листа на печать слой можно отключить, и границы видового экрана не будут отображаться при печати.

Команда СВИД позволяет получить несколько вариантов создания одного или нескольких видовых экранов листа. Для создания нескольких видовых экранов листа могут также использоваться команды КОПИРОВАТЬ и МАССИВ.

Создание видовых экранов произвольной формы на листах

С помощью преобразования объекта пространства листа пользователь может получить видовой экран произвольной формы на листе.

Команда СВИД содержит два параметра для помощи в определении видовых экранов произвольной формы.

Опция "Объект" позволяет преобразовать в видовой экран замкнутый объект, например, окружность или полилинию. Объект описывает границу вновь создаваемого видового экрана; в результате получается видовой экран неправильной формы.

Опция "Многоугольный" позволяет описать границу видового экрана путем указания точек-вершин. Последовательность запросов при этом аналогична используемой при построении полилиний.

Примечание Для подавления отображения границ видового экрана листа можно просто отключить слой видового экрана неправильной формы, вместо того, чтобы замораживать его. Замораживание слоя, на котором находится граница видового экрана произвольной формы, приводит к снятию подрезки видового экрана. Если же слой просто отключить, граница также будет не видна, но подрезка сохранится.

Изменение размеров видовых экранов листа

Как и любые другие объекты, границы видовых экранов произвольной формы можно редактировать с помощью ручек.

Подрезка видовых экранов листа

Границы видового экрана листа можно переопределить с помощью команды ВЭКРЕЗ. Для подрезки видового экрана листа используется устройство указания, с помощью которого выбирается объект, определяющий новые границы, либо точки новых границ.


Создание и изменение видовых экранов листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Создание и изменение видовых экранов листа
Понятия
Процедуры
Команды

Создание нового видового экрана на листе

Создание конфигурации видового экрана на листе

Вставка на лист именованной конфигурации видовых экранов

Изменение свойств видового экрана с помощью палитры "Свойства"

Подрезка границ видового экрана


Создание нового видового экрана на листе - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Создание и изменение видовых экранов листа
Понятия
Процедуры
Команды

Создание нового видового экрана на листе

  1. На вкладке листа нажмите "Вид" » "Видовые экраны" » "1 ВЭкран".
  2. Задать первый угол видового экрана.
  3. Задать противоположный угол видового экрана.

    4. Новый объект видового экрана листа создан и отображается на виде по умолчанию. Для регулировки вида дважды нажать кнопку мыши на видовом экране листа, чтобы перейти в пространство модели.

Панель Видовые экраны

Ввод команды: ВЭКРАН, СВИД


Создание конфигурации видового экрана на листе - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Создание и изменение видовых экранов листа
Понятия
Процедуры
Команды

Создание конфигурации видового экрана на листе

  1. Перейдите на вкладку разметки листа.
  2. Нажмите "Вид" » "Видовые экраны" » "Новые ВЭкраны".
  3. В диалоговом окне "Видовые экраны" на вкладке "Новые ВЭ" выбрать конфигурацию видовых экранов из списка.
  4. В опции "Настройка" выбрать 2D или 3D.

    5. Если выбран 3D-режим, на создаваемых видовых экранах сразу же будут установлены стандартные виды модели.

  5. В опции "Расстояние" задать расстояние между видовыми экранами.
  6. Для изменения вида выбрать видовой экран в режиме предварительного просмотра. В опции "Сменить вид на" выбрать вид из списка.

    7. Список включает в себя вид сверху, снизу, спереди, сзади, слева, справа, а также изометрические и любые другие виды. Выбранный вид отображается в области предварительного просмотра.

  7. Нажмите "ОК".
  8. В области рисования задать две точки для обозначения области, содержащей конфигурацию видового экрана.

Панель Видовые экраны

Ввод команды: ВЭКРАН


Вставка на лист именованной конфигурации видовых экранов - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Создание и изменение видовых экранов листа
Понятия
Процедуры
Команды

Вставка на лист именованной конфигурации видовых экранов

  1. Перейдите на вкладку разметки листа.
  2. Нажмите "Вид" » "Видовые экраны" » "Новые ВЭкраны".
  3. В диалоговом окне "Видовые экраны" на вкладке "Именованные ВЭ" выбрать именованную конфигурацию видового экрана из списка.
  4. Нажмите "ОК".
  5. Указать положение вставляемой конфигурации на листе.

Панель Видовые экраны

Ввод команды: ВЭКРАН


Изменение свойств видового экрана с помощью палитры "Свойства" - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Создание и изменение видовых экранов листа
Понятия
Процедуры
Команды

Изменение свойств видового экрана с помощью палитры "Свойства"

  1. Выбрать границу видового экрана листа, свойства которой необходимо изменить.
  2. Нажать правую кнопку мыши и выбрать в контекстном меню "Свойства".
  3. В палитре свойств выбрать значение, которое необходимо изменить. Ввести новое значение или выбрать новый параметр из списка.

    4. Новые параметры или значение свойства присваиваются текущему видовому экрану.

Панель "Стандартная"

Ввод команды: СВОЙСТВА

Контекстное меню: Выберите видовой экран и нажмите правую кнопку мыши в области рисования. Нажмите "Свойства".


Подрезка границ видового экрана - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Создание и изменение видовых экранов листа
Понятия
Процедуры
Команды

Подрезка границ видового экрана

  1. В командной строке ввести вэкрез.
  2. Выбрать видовой экран для подрезки.
  3. Ввести у (Удалить) для удаления контура подрезки.
  4. Ввести м (Многоугольный).
  5. Задать точки либо выбрать объект для определения границ видового экрана.

Ввод команды: Выбрать видовой экран, который необходимо подрезать и нажать правую кнопку мыши в области рисования. Выбрать в контекстном меню "Подрезать видовой экран".


Создание и изменение видовых экранов листа - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Создание и изменение видовых экранов листа
Понятия
Процедуры
Команды

Команды
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ВЭКРЕЗ | Подрезает объекты на видовых экранах и границы видового экрана.
СВИД | Создание видовых экранов на листах и управление ими
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление видами на видовых экранах листа - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Управление видами на видовых экранах листа
Понятия
Процедуры
Команды

В процессе создания листа можно создавать видовые экраны, которые рассматриваются как "окна" в пространстве модели. Отображаемым видом каждого видового экрана можно управлять.

  • Масштабирование видов на видовых экранах листа
    Для точного масштабирования каждого отображаемого вида в печатаемом чертеже установить масштаб каждого вида в соответствии с пространством листа.
  • Управление видимостью на видовых экранах листа
    Существует несколько способов управления видимостью объектов на видовом экране. С их помощью можно сократить число обновлений экрана, а также выделить или скрыть различные элементы чертежа.
  • Масштабирование типов линий на видовых экранах листа
    В пространстве листа масштаб типа линий может быть задан на основе единиц измерения чертежа пространства, где был создан объект или на основе единиц пространства листа.
  • Выравнивание видов на видовых экранах листа
    В целях улучшения внешнего вида чертежа можно выровнять (горизонтально, вертикально или под углом) виды на различных видовых экранах друг относительно друга.
  • Поворот видов на видовых экранах листа
    Можно выполнять поворот всего вида на видовом экране листа путем изменения ПСК или с помощью команды ПЛАН.


Управление видами на видовых экранах листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Управление видами на видовых экранах листа
Понятия
Процедуры
Команды

Изменение масштаба видового экрана с помощью палитры "Свойства"

Включение блокирования масштаба на видовом экране

Замораживание или размораживание слоев на текущем видовом экране листа

Просмотр списка слоев, замороженных на текущем экране

Замораживание или размораживание слоев на всех видовых экранах

Замораживание или размораживание слоев в пространстве листа

Замораживание или размораживание слоев на новых видовых экранах

Создание новых слоев, замороженных на всех видовых экранах

Задание интенсивности вывода объектам на видовом экране листа

Включение и отключение видовых экранов с помощью палитры "Свойства"

Установка единого масштаба линий в пространстве листа

Выравнивание объектов на разных видовых экранах с помощью вспомогательной линии

Выравнивание объектов на разных видовых экранах с помощью команды ФОРМАТЛ

Поворот вида путем изменения ПСК

Поворот вида с помощью команды ФОРМАТЛ


Управление видами на видовых экранах листа - Команды

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Управление видами на видовых экранах листа
Понятия
Процедуры
Команды
Команды
ВСЛОЙ | Управление видимостью слоев для отдельных видовых экранов
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ДИСПСК | Управление заданными пользовательскими системами координат
ЗНАКПСК | Управление видимостью и расположением знака ПСК
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПЛАН | Отображение вида в плане указанной ПСК
ПОКАЗАТЬ | Увеличение или уменьшение видимого размера объектов на текущем видовом экране
ПСК | Управление пользовательскими системами координат
СВИД | Создание видовых экранов на листах и управление ими
СВОЙСТВА | Изменяет свойства объекта
СЛОЙ | Управление слоями и их свойствами
СПИСМАСШТРЕД | Управление списком доступных значений масштаба для видовых экранов, листа и печати
ТИПЛИН | Загрузка, установка и изменение типов линий
ФОРМАТЛ | Задание параметров чертежа
Системные переменные
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
PSLTSCALE | Управляет масштабированием типов линий в пространстве листа
UCSVP | Определяет, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Масштабирование видов на видовых экранах листа - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Масштабирование видов на видовых экранах листа
Понятия
Процедуры
Команды

Для точного масштабирования каждого отображаемого вида в печатаемом чертеже установить масштаб каждого вида в соответствии с пространством листа.

Можно изменить масштаб вида видового экрана с помощью параметра

  • палитры свойств
  • XЛ (x латинское) команды ПОКАЗАТЬ
  • Панель "Видовые экраны"

Примечание Можно изменить список масштабов, отображающихся во всех списках видов и масштабов печати, с помощью команды СПИСМАСШТРЕД.

При работе на листе масштабный коэффициент вида на видовом экране листа представляет соотношение действительного размера модели, отображаемой на видовом экране, и размера листа. Для определения величины коэффициента разделите единицу длины пространства листа на единицу длины пространства модели. Например, чтобы вывести чертеж в масштабе 1:4, в качестве коэффициента указывается отношение одной единицы пространства листа к четырем единицам пространства модели.

Масштаб вида внутри видового экрана не зависит от масштабирования или растягивания границы видового экрана листа.

Блокирование масштаба на видовых экранах листа

После установки масштаба видового экрана выполнять увеличение на видовом экране невозможно, не изменив масштаб видового экрана. Для того, чтобы зумирование внутри видового экрана не влияло на ранее заданный масштаб, можно заблокировать масштаб выбранного видового экрана.

Блокирование масштаба оставляет неизменным заданный масштаб видового экрана. После того как масштаб блокирован, можно изменять геометрию видового экрана, не влияя на его размеры. При включении функции блокировки масштаба большинство команд (например, ТЗРЕНИЯ, ДВИД, 3DОРБИТА, ПЛАН и ВИД) перестает действовать.

Примечание Блокирование масштаба можно выполнять и на видовых экранах произвольной формы. Для этого необходимо произвести дополнительные действия на палитре "Свойства", связанные с выбором видового экрана до блокирования масштаба в нем.


Масштабирование видов на видовых экранах листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Масштабирование видов на видовых экранах листа
Понятия
Процедуры
Команды

Изменение масштаба видового экрана с помощью палитры "Свойства"

Включение блокирования масштаба на видовом экране


Изменение масштаба видового экрана с помощью палитры "Свойства" - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Масштабирование видов на видовых экранах листа
Понятия
Процедуры
Команды

Изменение масштаба видового экрана с помощью палитры "Свойства"

  1. Перейти на вкладку "Лист" в пространстве листа.
  2. Выбрать границу видового экрана, масштаб которого необходимо изменить.
  3. Нажать правую кнопку мыши и выбрать в контекстном меню "Свойства".
  4. На вкладке "Свойства" выбрать "Стандартный масштаб", далее выбрать новый масштаб из списка.

    5. Выбранный масштаб будет применен к видовому экрану.

    Примечание Для использования пользовательского масштаба введите масштаб в поле "Пользовательский масштаб" на панели "Свойства".

Панель "Стандартная"

Ввод команды: СВОЙСТВА

Контекстное меню: Выберите видовой экран и нажмите правую кнопку мыши в области рисования. Нажмите "Свойства".


Включение блокирования масштаба на видовом экране - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Масштабирование видов на видовых экранах листа
Понятия
Процедуры
Команды

Включение блокирования масштаба на видовом экране

  1. Выбрать на листе видовой экран, масштаб которого необходимо блокировать.
  2. Если необходимо, откройте палитру свойств.
  3. На палитре "Свойства" выполнить одно из следующих действий:
    • Для прямоугольного видового экрана выбрать свойство "Показ блокированного" и присвоить ему значение "Да".
    • На палитре "Свойства", "Показ блокированного" нажать "Да". Затем выбрать "Показ блокированного" и нажать "Да".

    Масштаб текущего видового экрана блокирован. Теперь любые операции зумирования и панорамирования будут действовать только на объекты пространства листа.

Панель "Стандартная"

Ввод команды: СВОЙСТВА

Контекстное меню: Выберите видовой экран и нажмите правую кнопку мыши в области рисования. Нажмите "Свойства".


Масштабирование видов на видовых экранах листа - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Масштабирование видов на видовых экранах листа
Понятия
Процедуры
Команды

Команды
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ПОКАЗАТЬ | Увеличение или уменьшение видимого размера объектов на текущем видовом экране
СВИД | Создание видовых экранов на листах и управление ими
СВОЙСТВА | Изменяет свойства объекта
СПИСМАСШТРЕД | Управление списком доступных значений масштаба для видовых экранов, листа и печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление видимостью на видовых экранах листа - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Управление видимостью на видовых экранах листа
Понятия
Процедуры
Команды

Существует несколько способов управления видимостью объектов на видовом экране. С их помощью можно сократить число обновлений экрана, а также выделить или скрыть различные элементы чертежа.

  • Замораживание слоев на видовых экранах листа
    Преимуществом использования видовых экранов листа является возможность выборочного замораживания различных слоев на любом из видовых экранов. Настройки видимости для новых видовых экранов и для новых слоев могут задаваться по умолчанию. Как следствие этого, в каждом из видовых экранов листа можно просматривать различные объекты.
  • Изменение интенсивности света объектов на видовых экранах листа
    Интенсивность регулирует количество красящего вещества, которое затрачивается на печать объекта. Это позволяет представлять объекты на экране и на бумаге в разных оттенках серого цвета, не изменяя при этом их цветовых свойств.
  • Включение и отключение видовых экранов листа
    Отключение некоторых видовых экранов листа или ограничение числа активных видовых экранов позволяет сэкономить время.


Управление видимостью на видовых экранах листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Управление видимостью на видовых экранах листа
Понятия
Процедуры
Команды

Замораживание или размораживание слоев на текущем видовом экране листа

Просмотр списка слоев, замороженных на текущем экране

Замораживание или размораживание слоев на всех видовых экранах

Замораживание или размораживание слоев в пространстве листа

Замораживание или размораживание слоев на новых видовых экранах

Создание новых слоев, замороженных на всех видовых экранах

Задание интенсивности вывода объектам на видовом экране листа

Включение и отключение видовых экранов с помощью палитры "Свойства"


Управление видимостью на видовых экранах листа - Команды

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Управление видимостью на видовых экранах листа
Понятия
Процедуры
Команды
Команды
ВСЛОЙ | Управление видимостью слоев для отдельных видовых экранов
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
СВИД | Создание видовых экранов на листах и управление ими
СВОЙСТВА | Изменяет свойства объекта
СЛОЙ | Управление слоями и их свойствами
Системные переменные
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Замораживание слоев на видовых экранах листа - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Замораживание слоев на видовых экранах листа
Понятия
Процедуры
Команды

Преимуществом использования видовых экранов листа является возможность выборочного замораживания различных слоев на любом из видовых экранов. Настройки видимости для новых видовых экранов и для новых слоев могут задаваться по умолчанию. Как следствие этого, в каждом из видовых экранов листа можно просматривать различные объекты.

Можно заморозить или разморозить слои на текущем или последующем видовом экране, не меняя видимости слоев на других видовых экранах. Замороженные слои невидимы, объекты на замороженных слоях не выводятся на экран, не печатаются и не регенерируются. На чертеже показан результат замораживания слоя с изображением ландшафта на одном из видовых экранов.

При размораживании восстанавливается видимость слоя. Наиболее простой способ замораживания и размораживания слоев на текущем видовом экране обеспечивает Диспетчер свойств слоев.

В правой части окна "Диспетчер свойств слоев" установить или сбросить флажок "Заморозить на текущем ВЭкране" для замораживания одного или более слоев. Для выполнения данных действий необходимо работать на вкладке "Лист". Сделать активным видовой экран листа, дважды нажав на нем кнопку мыши.

Автоматическое замораживание и размораживание слоев на новых видовых экранах

При создании новых видовых экранов листа можно автоматически замораживать на них определенные слои. Например, можно скрыть размеры путем замораживания слоя РАЗМЕРЫ для всех новых видовых экранов. Если же на одном из видовых экранов размеры должны присутствовать, то для этого видового экрана можно переопределить состояние замороженности. Включение или отключение замораживания слоев для новых видовых экранов не изменяет видимость слоев на уже имеющихся видовых экранах.

Создание новых слоев, замороженных на всех видовых экранах

Можно создавать слои, которые будут заморожены на всех имеющихся и вновь создаваемых видовых экранах листа. В дальнейшем эти слои можно разморозить на определенных видовых экранах. Таким способом можно быстро создать новый слой, который должен быть видимым только на одном видовом экране.


Замораживание слоев на видовых экранах листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Замораживание слоев на видовых экранах листа
Понятия
Процедуры
Команды

Замораживание или размораживание слоев на текущем видовом экране листа

Просмотр списка слоев, замороженных на текущем экране

Замораживание или размораживание слоев на всех видовых экранах

Замораживание или размораживание слоев в пространстве листа

Замораживание или размораживание слоев на новых видовых экранах

Создание новых слоев, замороженных на всех видовых экранах


Замораживание или размораживание слоев на текущем видовом экране листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Замораживание слоев на видовых экранах листа
Понятия
Процедуры
Команды

Замораживание или размораживание слоев на текущем видовом экране листа

  1. Дважды нажать кнопку мыши на видовом экране листа для установки его в качестве текущего.
  2. Нажмите "Формат" » "Слой".
  3. В окне "Диспетчер свойств слоев" выделить слои, которые необходимо заморозить или разморозить.

    4. Для выбора нескольких слоев удерживайте нажатой клавишу CTRL. Для выбора нескольких слоев, идущих в списке один за другим, удерживайте нажатой клавишу SHIFT.

  4. Установить флажок "Заморозить на текущем Вэкране" для одного из выбранных слоев.
  5. Нажмите "ОК".

Панель Слои

Ввод команды: СЛОЙ


Просмотр списка слоев, замороженных на текущем экране - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Замораживание слоев на видовых экранах листа
Понятия
Процедуры
Команды

Просмотр списка слоев, замороженных на текущем экране

  1. Перейдите на вкладку разметки листа.
  2. Дважды нажать кнопку мыши на видовом экране листа для установки его в качестве текущего.
  3. Нажмите "Формат" » "Слой".
  4. В столбце "Замороженный на текущем ВЭ" Диспетчера свойств слоев найти значок, обозначающий замороженное/размороженное состояние слоя на текущем видовом экране.
  5. Нажмите "ОК".

Панель "Слои"

Ввод команды: СЛОЙ, ВСЛОЙ


Замораживание или размораживание слоев на всех видовых экранах - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Замораживание слоев на видовых экранах листа
Понятия
Процедуры
Команды

Замораживание или размораживание слоев на всех видовых экранах

  1. Перейдите на вкладку разметки листа.
  2. Нажмите "Формат" » "Слой".
  3. В окне "Диспетчер свойств слоев" выделить один или несколько слоев, которые необходимо заморозить или разморозить.

    4. Для выбора нескольких слоев удерживайте нажатой клавишу CTRL. Для выбора нескольких слоев, идущих в списке один за другим, удерживайте нажатой клавишу SHIFT.

  4. В столбце "Заморозить" нажмите кнопку мыши на значке для замораживания/размораживания.

Панель Слои

Ввод команды: СЛОЙ


Замораживание или размораживание слоев в пространстве листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Замораживание слоев на видовых экранах листа
Понятия
Процедуры
Команды

Замораживание или размораживание слоев в пространстве листа

  1. Перейдите на вкладку разметки листа.
  2. Проверьте, что активно пространство листа (в строке состояния должна быть метка "ЛИСТ").
  3. Нажмите "Формат" » "Слой".
  4. В окне "Диспетчер свойств слоев" выделить слои, которые необходимо заморозить или разморозить.
  5. В столбце "Заморозить" нажмите значок для замораживания или размораживания слоя. Значок с изображением солнца означает, что слой разморожен; значок со снежинкой - слой заморожен.
  6. Нажмите "ОК".

Панель "Слои"

Ввод команды: СЛОЙ


Замораживание или размораживание слоев на новых видовых экранах - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Замораживание слоев на видовых экранах листа
Понятия
Процедуры
Команды

Замораживание или размораживание слоев на новых видовых экранах

  1. Перейдите на вкладку разметки листа.
  2. Нажмите "Формат" » "Слой".
  3. В окне "Диспетчер свойств слоев" выделить слои, которые необходимо заморозить или разморозить на новых видовых экранах.

    4. Для выбора нескольких слоев удерживайте нажатой клавишу CTRL. Для выбора нескольких слоев, идущих в списке один за другим, удерживайте нажатой клавишу SHIFT.

  4. В столбце "Замороженный на новых ВЭ" нажмите значок для изменения состояния слоя. Значок с изображением солнца означает, что слой разморожен; значок со снежинкой - слой заморожен.
  5. Нажмите "ОК".

Панель "Слои"

Ввод команды: СЛОЙ


Создание новых слоев, замороженных на всех видовых экранах - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Замораживание слоев на видовых экранах листа
Понятия
Процедуры
Команды

Создание новых слоев, замороженных на всех видовых экранах

  1. Перейдите на вкладку разметки листа.
  2. Нажмите "Формат" » "Слой".
  3. Нажать кнопку "Новый" и создать слой.
  4. Ввести новое имя слоя.
  5. В столбце "Заморозить" нажмите значок для изменения состояния слоя на замороженное. Значок с изображением солнца означает, что слой разморожен; значок со снежинкой - слой заморожен.
  6. Нажмите "ОК".

Панель Слои

Ввод команды: СЛОЙ, ВСЛОЙ


Замораживание слоев на видовых экранах листа - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Замораживание слоев на видовых экранах листа
Понятия
Процедуры
Команды

Команды
ВСЛОЙ | Управление видимостью слоев для отдельных видовых экранов
СЛОЙ | Управление слоями и их свойствами
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение интенсивности света объектов на видовых экранах листа - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Изменение интенсивности света объектов на видовых экранах листа
Понятия
Процедуры
Команды

Интенсивность регулирует количество красящего вещества, которое затрачивается на печать объекта. Это позволяет представлять объекты на экране и на бумаге в разных оттенках серого цвета, не изменяя при этом их цветовых свойств.

Для присвоения объекту значения интенсивности необходимо назначить ему тип печати, а затем значение интенсивности вывода для данного стиля.

Значение интенсивности задается в пределах от 0 до 100. По умолчанию задается значение 100, которое соответствует полной интенсивности. Значение интенсивности 0 соответствует выводу белым цветом.

См. также

Задание параметров печати объектов


Задание интенсивности вывода объектам на видовом экране листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Изменение интенсивности света объектов на видовых экранах листа
Понятия
Процедуры
Команды

Задание интенсивности вывода объектам на видовом экране листа

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Нажмите правую кнопку мыши на файле CTB или STB. Нажмите "Открыть".
  3. На вкладке "Карточка" Редактора таблиц стилей печати выбрать стиль для редактирования.
  4. В поле параметра "Интенсивность" указать значение от 1 до 100.
  5. Нажать кнопку "Принять".
  6. На листе нажмите "Файл" » "Параметры листа".
  7. В диалоговом окне "Диспетчер параметров листов" нажать кнопку "Изменить". В открывшемся диалоговом окне "Параметры листа" выбрать из списка "Таблица стилей печати" отредактированный стиль печати.
  8. Дважды нажать кнопку мыши на видовом экране листа, содержащем объекты, интенсивность которых необходимо изменить.
  9. Выбрать объекты, стиль печати которых необходимо изменить.
  10. Нажать правую кнопку мыши в области рисования и выбрать из контекстного меню "Свойства".
  11. На палитре "Свойства" воспользоваться одним их следующих приемов:
    • При использовании именованных таблиц стилей печати установить для свойства "Стиль печати" отредактированный стиль печати. Если этот стиль печати отсутствует в списке, выбрать пункт "Другой" и установить текущей таблицу, в которой содержится ранее отредактированный стиль печати. В диалоговом окне "Выбор стиля печати" из списка "Стили печати" выбрать требуемый стиль печати.
    • При использовании цветозависимых таблиц стилей печати для свойства "Цвет" установить цвет, для которого и был отредактирован стиль печати.


Изменение интенсивности света объектов на видовых экранах листа - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Изменение интенсивности света объектов на видовых экранах листа
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Включение и отключение видовых экранов листа - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Включение и отключение видовых экранов листа
Понятия
Процедуры
Команды

Отключение некоторых видовых экранов листа или ограничение числа активных видовых экранов позволяет сэкономить время.

Большое число активных видовых экранов может замедлять работу системы, так как значительное время тратится на регенерацию изображений. Отключение некоторых видовых экранов листа или ограничение числа активных видовых экранов позволяет сэкономить время. На следующей иллюстрации показан результат отключения двух видовых экранов.

Вновь создаваемые видовые экраны по умолчанию включены. Отключив видимость не используемых в данный момент видовых экранов, можно перемещать видовые экраны и изменять их размеры, не тратя время на ожидание завершения регенерации.

Кроме того, видовой экран можно отключить, если он не должен вычерчиваться на плоттере.


Включение и отключение видовых экранов с помощью палитры "Свойства" - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Включение и отключение видовых экранов листа
Понятия
Процедуры
Команды

Включение и отключение видовых экранов с помощью палитры "Свойства"

  1. Перейти на вкладку "Лист" в пространстве листа.
  2. Выбрать границу видового экрана, который необходимо включить или выключить.
  3. Нажать правую кнопку мыши и выбрать в контекстном меню "Свойства".
  4. На палитре "Свойства" в группе "Разное" выбрать свойство "Вкл" и присвоить ему значение "Да" или "Нет".

    5. Для изменения свойств непрямоугольного видового экрана на палитре "Свойства" следует сначала из списка, где отображается значение "Все (2)", выбрать элемент "ВЭкран (1)".

Панель "Стандартная"

Ввод команды: СВОЙСТВА

Контекстное меню: Выберите видовой экран и нажмите правую кнопку мыши в области рисования. Выбрать в контекстном меню "Видимость объектов на ВЭкранах".


Включение и отключение видовых экранов листа - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Включение и отключение видовых экранов листа
Понятия
Процедуры
Команды

Команды
ВЭКРАН | Создает несколько видовых экранов в пространстве модели и в пространстве листа.
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
СВИД | Создание видовых экранов на листах и управление ими
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
MAXACTVP | Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Масштабирование типов линий на видовых экранах листа - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Масштабирование типов линий на видовых экранах листа
Понятия
Процедуры
Команды

В пространстве листа масштаб типа линий может быть задан на основе единиц измерения чертежа пространства, где был создан объект или на основе единиц пространства листа.

Для сохранения одинакового масштаба типа линий у объектов, которые отображаются с различным масштабом на листе и в видовом экране, можно использовать системную переменную PSLTSCALE. Например, если системной переменной PSLTSCALE задано значение 1 (по умолчанию), можно установить текущий тип линий как штрихованный, а затем провести отрезок в пространстве листа. После этого на листе создается видовой экран с коэффициентом экранного увеличения 1x. Он устанавливается текущим, и на нем тем же самым штриховым типом линий проводится отрезок. Обе штриховые линии должны выглядеть одинаково. Если изменить коэффициент экранного увеличения видового экрана на 2x, масштаб типа линий у обоих отрезков останется одинаковым, несмотря на различие в коэффициентах экранного увеличения.

При включенной функции PSLTSCALE можно управлять длиной штриховки с помощью системных переменных LTSCALE и CELTSCALE. На левом чертеже установлен одинаковый масштаб типа линии, независимо от масштабов видов. На правом чертеже масштаб типа линии соответствует масштабу вида.

См. также

Задание масштаба весов линий


Установка единого масштаба линий в пространстве листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Масштабирование типов линий на видовых экранах листа
Понятия
Процедуры
Команды

Установка единого масштаба линий в пространстве листа

  1. Нажмите "Формат" » "Тип линий".
  2. В окне "Диспетчер типов линий" выбрать "Вкл подробности".
  3. Ввести значение глобального масштаба в поле "Глобальный масштаб".
  4. Нажмите "ОК".

Ввод команды: ТИПЛИН


Масштабирование типов линий на видовых экранах листа - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Масштабирование типов линий на видовых экранах листа
Понятия
Процедуры
Команды

Команды
ТИПЛИН | Загрузка, установка и изменение типов линий
Системные переменные
PSLTSCALE | Управляет масштабированием типов линий в пространстве листа
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выравнивание видов на видовых экранах листа - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Выравнивание видов на видовых экранах листа
Понятия
Процедуры
Команды

В целях улучшения внешнего вида чертежа можно выровнять (горизонтально, вертикально или под углом) виды на различных видовых экранах друг относительно друга.

Это достигается панорамированием вида на одном видовом экране относительно базовой точки, расположенной на другом.

Для точного выравнивания видов на листе можно воспользоваться вспомогательной геометрией, объектной привязкой к объектам пространства модели, отображаемым на видовых экранах листа, или любым из режимов ограничения передвижения курсора, включаемым с помощью панели состояния.


Выравнивание видов на видовых экранах листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Выравнивание видов на видовых экранах листа
Понятия
Процедуры
Команды

Выравнивание объектов на разных видовых экранах с помощью вспомогательной линии

Выравнивание объектов на разных видовых экранах с помощью команды ФОРМАТЛ


Выравнивание объектов на разных видовых экранах с помощью вспомогательной линии - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Выравнивание видов на видовых экранах листа
Понятия
Процедуры
Команды

Выравнивание объектов на разных видовых экранах с помощью вспомогательной линии

  1. Перейти на вкладку "Лист".
  2. Нажмите "Рисование" » "Прямая".
  3. Указать точку на первом видовом экране. Указать вторую точку для определения вспомогательной линии выравнивания.

    4. Указать точку для выравнивания объектов на втором видовом экране. Для обеспечения точности указания можно использовать объектную привязку.

  4. Нажмите "Редактировать" » "Переместить".
  5. Выбрать видовой экран для выравнивания относительно первого видового экрана. Нажмите ENTER.
  6. На запрос базовой точки указать точку на втором видовом экране. Указать точку, соответствующую заданной точке на первом видовом экране.
  7. На запрос второй точки нажать правую кнопку мыши, удерживая в нажатой клавишу SHIFT. Выберите "Объектная привязка" » "Нормаль". Выбрать вспомогательную линию.

    8. Два заданных видовых экрана и объекты на них выравниваются.

    Примечание Для выравнивания объектов масштабы выравниваемых видовых экранов должны быть одинаковыми.

Панель "Редактирование"


Выравнивание объектов на разных видовых экранах с помощью команды ФОРМАТЛ - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Выравнивание видов на видовых экранах листа
Понятия
Процедуры
Команды

Выравнивание объектов на разных видовых экранах с помощью команды ФОРМАТЛ

  1. В командной строке ввести форматл.
  2. Ввести в (Выровнять).
  3. Выбрать один из следующих способов выравнивания.
    • Горизонтальное. Выравнивание по горизонтали точки на одном видовом экране с базовой точкой на другом видовом экране.
    • Вертикальное. Выравнивание по вертикали точки на одном видовом экране с базовой точкой на другом видовом экране.
    • Угловое. Выравнивание точки на одном видовом экране на заданном расстоянии и под заданным углом от базовой точки на другом видовом экране.
  4. Сделать текущим видовой экран, относительно которого будут выравниваться все остальные. Указать базовую точку.
  5. Выбрать выравниваемый видовой экран. Затем указать на нем точку для выравнивания.
  6. Если производится угловое выравнивание, задать для выравниваемой точки расстояние и угол относительно базовой.


Выравнивание видов на видовых экранах листа - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Выравнивание видов на видовых экранах листа
Понятия
Процедуры
Команды

Команды
ДИСПСК | Управление заданными пользовательскими системами координат
ЗНАКПСК | Управление видимостью и расположением знака ПСК
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПСК | Управление пользовательскими системами координат
ФОРМАТЛ | Задание параметров чертежа
Системные переменные
UCSVP | Определяет, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Поворот видов на видовых экранах листа - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Поворот видов на видовых экранах листа
Понятия
Процедуры
Команды

Можно выполнять поворот всего вида на видовом экране листа путем изменения ПСК или с помощью команды ПЛАН.

С помощью команды ПСК можно поворачивать плоскость XY на любой угол вокруг оси Z. При вводе команды ПЛАН выполняется поворот вида в соответствии с ориентацией плоскости XY.

Для ускорения процесса можно использовать параметры "Выровнять" и "Повернуть вид" команды ФОРМАТЛ.

Примечание Команда ПОВЕРНУТЬ поворачивает только отдельные объекты и не может использоваться для поворота всего вида.


Поворот видов на видовых экранах листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Поворот видов на видовых экранах листа
Понятия
Процедуры
Команды

Поворот вида путем изменения ПСК

Поворот вида с помощью команды ФОРМАТЛ


Поворот вида путем изменения ПСК - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Поворот видов на видовых экранах листа
Понятия
Процедуры
Команды

Поворот вида путем изменения ПСК

  1. Перейти на вкладку "Лист".
  2. Дважды нажать кнопку мыши на видовом экране, объекты которого необходимо повернуть.
  3. Текущая ПСК должна располагаться параллельно плоскости поворота (знак ПСК должен иметь нормальный вид). Если ПСК не параллельна плоскости вращения, выберите "Сервис" » "Новая ПСК" » "Вид".
  4. Выберите "Сервис" » "Новая ПСК" » Z. Для поворота вида на 90 градусов по часовой стрелке введите 90. Для поворота вида на 90 градусов против часовой стрелки введите -90.
  5. Нажмите "Вид" » "3D виды" » "Вид в плане". Выбрать "Текущая ПСК".

    6. Происходит поворот вида в целом внутри видового экрана. Возможно, потребуется изменить масштаб видового экрана.

Панель ПСК

Ввод команды: ПСК


Поворот вида с помощью команды ФОРМАТЛ - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Поворот видов на видовых экранах листа
Понятия
Процедуры
Команды

Поворот вида с помощью команды ФОРМАТЛ

  1. В командной строке ввести форматл.
  2. Ввести в (Выровнять).
  3. Ввести п для поворота вида.
  4. Выбрать видовой экран, вид на котором требуется повернуть.
  5. Указать базовую точку поворота.
  6. Задать угол поворота.

    7. Происходит поворот вида в целом внутри видового экрана.


Поворот видов на видовых экранах листа - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Поворот видов на видовых экранах листа
Понятия
Процедуры
Команды

Команды
ДИСПСК | Управление заданными пользовательскими системами координат
ЗНАКПСК | Управление видимостью и расположением знака ПСК
ПЛАН | Отображение вида в плане указанной ПСК
ПСК | Управление пользовательскими системами координат
ФОРМАТЛ | Задание параметров чертежа
Системные переменные
UCSVP | Определяет, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Повторное использование листов и их параметров - Понятия

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Повторное использование листов и их параметров
Понятия
Процедуры
Команды

При создании листа можно использовать информацию из существующего шаблона.

Шаблон листа это лист, импортированный из DWG- или DWT-файла. При создании листа можно использовать информацию из существующего шаблона. В программе содержатся шаблоны для использования при разработке новой среды листа. На новый лист переносятся все объекты пространства листа и все параметры листа. В число используемых объектов здесь включаются и видовые экраны. Пользователь может по своему усмотрению сохранить импортированные объекты или удалить их. Объекты пространства модели из шаблона не импортируются.

Файлы шаблонов листов имеют расширение .dwt. В текущий чертеж можно импортировать любой шаблон листа из любого другого чертежа.

Сохранение шаблона листа

Любой чертеж, включая все объекты и параметры листа, можно сохранить как шаблон (файл DWT). Отдельно сохранить лист в новом шаблоне можно с помощью функции "Сохранить" команды РЛИСТ. DWT-файл записывается в папку, отведенную для шаблонов в диалоговом окне "Настройка" на вкладке "Файлы". Файл шаблона листа, как и файл чертежа или шаблона чертежа, имеет расширение .dwt или .dwg и содержит, помимо прочего, некоторый объем информации, не используемый листом.

При создании нового шаблона листа в него записываются все именованные объекты, такие как блоки, слои и размерные стили, используемые на листе. Все эти объекты в виде описаний символьных таблиц импортируются с шаблоном как часть параметров листа при создании нового листа. Для создания нового шаблона листа рекомендуется использовать команду РЛИСТ с параметром "Сохранить как". Только в этом случае гарантируется, что в шаблоне не будут присутствовать неиспользуемые описания символьных таблиц, которые окажутся совершенно бесполезными и будут только загромождать базу данных чертежа при дальнейшем импорте.

Если шаблон сохранен без использования параметра "Сохранить как" команды РЛИСТ, то при вставке листа из такого шаблона импортируются все неиспользуемые на листе описания символьных таблиц. Для удаления неиспользуемых описаний символьных таблиц применяется команда ОЧИСТИТЬ.

Вставка листа с помощью Центра управления

Центр управления (DesignCenter™) позволяет перетаскивать в текущий чертеж листы вместе с находящимися на них объектами.

Физически процесс вставки листа с помощью Центра управления сводится к созданию в чертеже нового листа, на который копируются все объекты, символьные таблицы и описания блоков из исходного. После этого можно удалить ненужные объекты пространства листа. Для того, чтобы удалить из созданного листа неиспользуемые элементы символьных таблиц, следует применить команду ОЧИСТИТЬ.


Повторное использование листов и их параметров - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Повторное использование листов и их параметров
Понятия
Процедуры
Команды

Создание листа на основе шаблона

Сохранение шаблона листа

Вставка листа с помощью Центра управления


Создание листа на основе шаблона - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Повторное использование листов и их параметров
Понятия
Процедуры
Команды

Создание листа на основе шаблона

  1. Нажмите "Вставить" » "Разметка листа" » "Разметка листа по шаблону".
  2. В диалоговом окне "Выбор файла" выбрать файл шаблона из списка.
  3. Нажмите "Открыть".
  4. В диалоговом окне "Вставка листов" выбрать шаблон листа из списка. Нажмите "ОК".

    5. Новый лист создается на основе выбранного шаблона. Новому листу автоматически присваивается имя, состоящее из слова "Лист", первого незанятого порядкового номера, а также (через дефис) имени листа в шаблоне.

    Например, если в чертеже, где уже имеются листы "Лист1" и "Лист2", вставляется третий лист из шаблона, где лист имеет имя "ANSI D", то новому листу присваивается имя "Лист3 - ANSI D".

Панель Листы

Ввод команды: РЛИСТ

Контекстное меню: Нажать правую кнопку мыши на вкладке листа. Выбрать в контекстном меню "По шаблону".


Сохранение шаблона листа - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Повторное использование листов и их параметров
Понятия
Процедуры
Команды

Сохранение шаблона листа

  1. В командной строке ввести рлист.
  2. В ответ на запрос команды ввести с для сохранения текущего листа в качестве шаблона.
  3. Ввести имя сохраняемого листа.
  4. В диалоговом окне "Создание файла чертежа" указать имя, под которым должен быть сохранен шаблон.
  5. В списке "Тип файла" выбрать "Шаблоны чертежей (*.dwt)".
  6. Нажмите "Сохранить".


Вставка листа с помощью Центра управления - Процедуры

Выбор рабочего процесса
Создание многовидовых чертежей (в пространстве листа)
Повторное использование листов и их параметров
Понятия
Процедуры
Команды

Вставка листа с помощью Центра управления

  1. Нажмите "Сервис" » "DesignCenter".
  2. В дереве вида найти чертеж, содержащий лист, который требуется повторно использовать.
  3. Дважды нажать кнопку мыши на имени чертежа, чтобы развернуть меню опций.
  4. Выбрать значок "Лист" для отображения листов в области содержимого.
  5. Воспользоваться одним из следующих способов для вставки листа в текущий чертеж:
    • Перетащить значок листа из области содержимого в чертеж.
    • Выбрать лист в области содержимого и нажать правую кнопку мыши. Выбрать в контекстном меню "Добавить листы".
    • Дважды нажать кнопку мыши на листе в области содержимого.

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Повторное использование листов и их параметров - Команды

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Повторное использование листов и их параметров
Понятия
Процедуры
Команды

Команды
МАСТЕРПЕЧ | Вызов Мастера для импорта параметров печати из PCP- и PC2-файлов настройки для вкладки "Модель" или текущего листа
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
РЛИСТ | Создание и изменение вкладок разметок листа в чертеже
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
TDCREATE | Сохраняет дату и время (местное) создания чертежа
TDUCREATE | Сохраняет дату и время (всемирное) создания чертежа
TDUPDATE | Сохраняет дату и время (местное) последнего сохранения/обновления
TDUUPDATE | Сохраняет дату и время (всемирное) последнего сохранения/обновления
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с листами в подшивке - Понятия

Выбор рабочего процесса
Работа с листами в подшивке
Понятия
Процедуры
Команды

С помощью Диспетчера подшивок пользователь может организовывать листы чертежей в именованные подшивки. Листы в подшивке можно передавать, публиковать и архивировать как одно целое.

  • Быстрый запуск подшивок
    Подшивка представляет собой организованный особым образом набор листов, принадлежащих различным файлам чертежей. Каждый лист подшивки представляет собой определенный лист-вкладку из файла чертежа.
  • Интерфейс Диспетчера подшивок
    Диспетчер подшивок позволяет создавать и организовывать листы в подшивках.
  • Создание и управление подшивкой
    Существует несколько способов настройки и организации подшивки. В подшивку можно включить информацию о самой подшивке или ее компонентах.
  • Публикация, комплектование и архивация подшивок
    Готовую подшивку можно опубликовать, укомплектовать для пересылки или заархивировать.
  • Коллективная работа с подшивками
    Коллективная работа с подшивками может осуществляться по локальной сети, через Интернет или по электронной почте. В группу могут также входить пользователи, использующие программное обеспечение без Диспетчера подшивок.


Работа с листами в подшивке - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Понятия
Процедуры
Команды

Открытие Диспетчера подшивок

Создание новой подшивки

Открытие подшивки

Закрытие подшивки

Перегруппирование листов в списке листов

Создание новой группы в списке листов

Создание новой категории видов в списке видов

Удаление группы из списка листов

Удаление категории видов из списка видов

Импорт листов из существующих чертежей

Создание нового листа

Открытие файла чертежа в подшивке

Открытие файла чертежа в подшивке в режиме "только чтение"

Исключение листа из подшивки

Переприкрепление листа к подшивке

Добавление вида на лист

Добавление ведомости листов

Изменение ведомости листов

Обновление ведомости листов

Добавление блока, используемого для идентификаторов видов листов

Изменение блока, используемого по умолчанию для идентификаторов видов листов

Добавление на лист блока-идентификатора

Создание ведомости листов на титульном листе

Изменение свойств подшивки, группы листов, листа или категории вида

Создание дополнительного свойства для подшивки

Создание дополнительного свойства листа

Сохранение набора листов подшивки

Восстановление набора листов

Переименование или удаление набора листов

Изменение существующего набора листов

Включение слоя, блока, информации о листе или о подшивке в публикуемый файл DWF

Использование файла шаблона блока для включения свойств и атрибутов в публикуемый файл DWF

Сохранение всех листов в подшивке


Работа с листами в подшивке - Команды

Выбор рабочего процесса
Работа с листами в подшивке
Понятия
Процедуры
Команды
Команды
АРХИВАЦИЯ | Упаковывает файлы текущей подшивки для архивирования
ПОДШИВКА | Вызов диспетчера подшивок
ПОДШИВКАОТКЛ | Закрытие диспетчера подшивок
ПШОТКРЫТЬ | Открывает выбранную подшивку
ПШСОЗДАТЬ | Создание новой подшивки
Системные переменные
SSFOUND | Отображает имя файла и путь, полученные при успешном поиске подшивки
SSLOCATE | Управляет местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа.
SSMAUTOOPEN | Управляет режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой.
SSMSTATE | Определяет активность окна Диспетчера подшивок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Быстрый запуск подшивок - Понятия

Выбор рабочего процесса
Работа с листами в подшивке
Быстрый запуск подшивок
Понятия
Процедуры
Команды

Подшивка представляет собой организованный особым образом набор листов, принадлежащих различным файлам чертежей. Каждый лист подшивки представляет собой определенный лист-вкладку из файла чертежа.

Наборы чертежей являются основным итогом работы большинства проектных коллективов. Наборы чертежей представляют все содержание проекта вместе с его техническим описанием. В то же время управлять наборами чертежей вручную довольно сложно.

Управлять подшивками листов можно с помощью Диспетчера подшивок. Подшивка представляет собой организованный особым образом именованный набор листов из нескольких файлов чертежей. Каждый лист подшивки представляет собой определенный лист-вкладку из файла чертежа. Пользователь может импортировать в подшивку и пронумеровать любой лист из любого чертежа.

Подшивки можно передавать, публиковать и архивировать как единое целое.


Работа с листами в подшивке

Выбор рабочего процесса
Работа с листами в подшивке
Работа с листами в подшивке
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Быстрый запуск подшивок - Команды

Работа с листами в подшивке
Работа с листами в подшивке
Быстрый запуск подшивок
Понятия
Процедуры
Команды

Команды
ПОДШИВКА | Вызов диспетчера подшивок
ПОДШИВКАОТКЛ | Закрытие диспетчера подшивок
ПШОТКРЫТЬ | Открывает выбранную подшивку
ПШСОЗДАТЬ | Создание новой подшивки
Системные переменные
SSFOUND | Отображает имя файла и путь, полученные при успешном поиске подшивки
SSLOCATE | Управляет местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа.
SSMAUTOOPEN | Управляет режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой.
SSMSTATE | Определяет активность окна Диспетчера подшивок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Интерфейс Диспетчера подшивок - Понятия

Выбор рабочего процесса
Работа с листами в подшивке
Интерфейс Диспетчера подшивок
Понятия
Процедуры
Команды

Диспетчер подшивок позволяет создавать и организовывать листы в подшивках.

В Диспетчере подшивок имеются следующие вкладки и настройки:

Меню команд. Содержит список параметров меню для создания новой подшивки, открытия существующей подшивки или переключения между открытыми подшивками.

Вкладка "Список листов". Содержит организованный список всех листов в подшивке. Каждый лист в подшивке представляет собой определенный лист-вкладку в файле чертежа.

Вкладка "Виды листа". Содержит организованный список всех видов на листах, включенных в подшивку. В списке отображаются только те виды, которые были созданы AutoCAD 2005 или более поздних версиях.

Вкладка "Виды моделей". Содержит список путей и имен папок для чертежей, содержащих виды пространства модели, используемые в подшивке.

  • Нажмите кнопку мыши на папке для просмотра списка файлов чертежей, которые расположены в данной папке.
  • Выберите файл чертежа для просмотра списка именованных видов в пространстве модели, которые можно расположить на текущем листе.
  • Дважды нажмите кнопку мыши на виде для открытия чертежа, содержащего этот вид.
  • Нажмите правую кнопку мыши или перетащите вид для расположения его на текущем листе.

Кнопки. Предоставляют удобный доступ к наиболее часто используемым операциям над текущей выделенной вкладкой.

Древовидное представление. Представляет содержание вкладки.

Подробности/Просмотр. Представляет либо описательную информацию, либо образец для просмотра текущего выбранного в области структуры элемента.

Действия, используемые в области структуры

В области структуры можно выполнить следующие действия:

  • Используйте команды контекстного меню, относящиеся к текущему выделенному элементу.
  • Дважды нажмите кнопку мыши на элементе для его открытия. Этим способом удобно открывать файлы чертежей, перечисленные на вкладке списка листов или на вкладке видов модели. Для того, чтобы развернуть или свернуть элемент в области структуры, дважды нажмите на нем кнопку мыши.
  • Выделите один или несколько элементов и выполните с ними такие операции, как открытие, публикация или передача.
  • Выберите отдельный элемент для просмотра описательной информации или отображения образца для просмотра выбранного листа, вида или файла чертежа.
  • Перетащите элементы внутри области структуры и измените их порядок.

Примечание Для удобства в Диспетчере подшивок предусмотрено контекстное меню, вызываемое по нажатию правой кнопки мыши на элементе в области структуры. Для доступа к контекстным меню в области рисования, необходимым для работы с подшивками, в диалоговом окне "Параметры" на вкладке "Пользовательские" установите флажок "Контекстные меню в области рисования".


Интерфейс Диспетчера подшивок - Команды

Работа с листами в подшивке
Работа с листами в подшивке
Интерфейс Диспетчера подшивок
Понятия
Процедуры
Команды

Команды
ПОДШИВКА | Вызов диспетчера подшивок
ПОДШИВКАОТКЛ | Закрытие диспетчера подшивок
ПШОТКРЫТЬ | Открывает выбранную подшивку
ПШСОЗДАТЬ | Создание новой подшивки
Системные переменные
SSFOUND | Отображает имя файла и путь, полученные при успешном поиске подшивки
SSLOCATE | Управляет местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа.
SSMAUTOOPEN | Управляет режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой.
SSMSTATE | Определяет активность окна Диспетчера подшивок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и управление подшивкой - Понятия

Выбор рабочего процесса
Работа с листами в подшивке
Создание и управление подшивкой
Понятия
Процедуры
Команды

Существует несколько способов настройки и организации подшивки. В подшивку можно включить информацию о самой подшивке или ее компонентах.

  • Создание подшивки
    Подшивка создается с помощью Мастера создания подшивок. Мастер позволяет создать подшивку с самого начала на основе существующих чертежей, либо по образцу другой подшивки.
  • Организация подшивки
    Пользователь может организовывать подшивку в иерархическом порядке с использованием групп и категорий Листы могут быть объединены в группы. Виды могут быть объединены в категории.
  • Создание и изменение листов
    Для создания листов и добавления видов используется несколько функций. Изменение листа должно всегда проводиться из открытой подшивки.
  • Добавление дополнительных сведений для листов и подшивок
    В подшивках, группах и листах содержится информация различного типа. Эта информация называется свойствами и включает в себя названия, пояснения, пути к папкам с файлами, а также иные дополнительные сведения.


Создание и управление подшивкой - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и управление подшивкой
Понятия
Процедуры
Команды

Открытие Диспетчера подшивок

Создание новой подшивки

Открытие подшивки

Закрытие подшивки

Перегруппирование листов в списке листов

Создание новой группы в списке листов

Создание новой категории видов в списке видов

Удаление группы из списка листов

Удаление категории видов из списка видов

Импорт листов из существующих чертежей

Создание нового листа

Открытие файла чертежа в подшивке

Открытие файла чертежа в подшивке в режиме "только чтение"

Исключение листа из подшивки

Переприкрепление листа к подшивке

Добавление вида на лист

Добавление ведомости листов

Изменение ведомости листов

Обновление ведомости листов

Добавление блока, используемого для идентификаторов видов листов

Изменение блока, используемого по умолчанию для идентификаторов видов листов

Добавление на лист блока-идентификатора

Создание ведомости листов на титульном листе

Изменение свойств подшивки, группы листов, листа или категории вида

Создание дополнительного свойства для подшивки

Создание дополнительного свойства листа


Создание и управление подшивкой - Команды

Выбор рабочего процесса
Работа с листами в подшивке
Создание и управление подшивкой
Понятия
Процедуры
Команды
Команды
ПОДШИВКА | Вызов диспетчера подшивок
ПОДШИВКАОТКЛ | Закрытие диспетчера подшивок
ПШОТКРЫТЬ | Открывает выбранную подшивку
ПШСОЗДАТЬ | Создание новой подшивки
Системные переменные
SSFOUND | Отображает имя файла и путь, полученные при успешном поиске подшивки
SSLOCATE | Управляет местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа.
SSMAUTOOPEN | Управляет режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой.
SSMSTATE | Определяет активность окна Диспетчера подшивок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание подшивки - Понятия

Выбор рабочего процесса
Работа с листами в подшивке
Создание подшивки
Понятия
Процедуры
Команды

Подшивка создается с помощью Мастера создания подшивок. Мастер позволяет создать подшивку с самого начала на основе существующих чертежей, либо по образцу другой подшивки.

Листы из указанных файлов чертежей импортируются в подшивку. Информация, описывающая подшивку, хранится в файле данных подшивки (с расширением DST).

При создании новой подшивки с помощью Мастера создания пошивок для ее хранения создается новая папка. Эта новая папка, именуемая Подшивки AutoCAD, располагается в папке Мои документы. Местоположение файла подшивки по умолчанию можно изменить. Файл DST рекомендуется хранить вместе с файлами проекта.

Примечание Файл DST должен храниться в папке, доступной всем пользователям подшивки в сети, и быть подключенным с использованием одного логического диска. Настоятельно рекомендуется хранить файл DST и чертежи в одной папке. При перемещении всей подшивки или изменении имени сервера или папки, файл DST сможет найти листы подшивки по информации об их относительном пути.

Подготовительные действия.

Перед созданием подшивки необходимо предпринять следующие действия:

  • Компактное размещение файлов чертежей. Соберите файлы чертежей, которые будут использоваться в подшивке, в небольшом числе папок. Это упростит администрирование подшивки.
  • Исключение многолистовых чертежей. Используйте только по одному листу из каждого чертежа в подшивке. Это важно для обеспечения многопользовательского доступа к листам. Одновременно в чертеже может быть открыт только один лист.
  • Создание файла шаблона чертежа. Создайте или укажите файл шаблона чертежа (DWT), используемый подшивкой для создания новых листов. Этот файл шаблона чертежа называется шаблоном для создания листов. Укажите файл шаблона в диалоговом окне "Свойства подшивки" или "Свойства группы листов".
  • Создание файла переопределения параметров листа. Создайте или укажите файл DWT для хранения параметров страницы для печати или публикации. Этот файл, называемый файлом переопределения параметров листов, может быть использован для применения одних и тех же параметров листа ко всем листам в подшивке, независимо от индивидуальных настроек листов, хранящихся в каждом чертеже.

Примечание Не рекомендуется использовать в подшивке несколько листов из одного и того же файла чертежа, несмотря на то, что такая организация подшивки возможна. В этом случае параллельная работа с листами нескольких пользователей невозможна. Кроме того, это усложняет организацию подшивок и затрудняет работу с ними.

Создание подшивки по образцу

Функция создания подшивки по образцу в Мастере создания подшивок позволяет использовать в новой подшивке структуру и настройки образца. Можно также создавать папки в соответствии с путями к группам листов подшивки.

Листы для созданной с помощью этой функции пустой подшивки можно импортировать из чертежей или создать отдельно.

Создание подшивки из существующих файлов чертежей

При выборе в Мастере создания подшивок функции создания подшивки из существующих файлов чертежей укажите одну или несколько папок, содержащих файлы чертежей. При этом подшивку можно организовать таким образом, чтобы структура групп листов подшивки дублировала структуру папок файлов чертежей. Листы из этих чертежей могут быть импортированы в подшивку автоматически.

Для добавления дополнительных папок с чертежами можно воспользоваться кнопкой "Обзор".

Резервное копирование и восстановление файлов данных подшивки

Данные, хранящиеся в файлах данных подшивок, представляют собой значительную часть работы. Поэтому для файлов DST, так же как и для файлов чертежей следует создавать резервные копии.

В случае повреждения файла DST или серьезной ошибки пользователя предварительно сохраненный файл данных подшивки может быть восстановлен. Каждый раз при открытии файла данных подшивки текущий файл данных подшивки копируется в файл резервной копии (DS$). Этот резервный файл имеет то же имя файла и расположен в той же папке, что и текущий файл данных подшивки.

Для восстановления предыдущей версии файла данных подшивки сначала необходимо убедиться, что с данной подшивкой никто не работает. Затем рекомендуется скопировать существующий файл DST под другим именем. И, наконец, измените расширение резервного файла с DS$ на DST.


Создание подшивки - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание подшивки
Понятия
Процедуры
Команды

Открытие Диспетчера подшивок

Создание новой подшивки

Открытие подшивки

Закрытие подшивки


Открытие Диспетчера подшивок - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание подшивки
Понятия
Процедуры
Команды

Открытие Диспетчера подшивок

  • Нажмите "Сервис" » "Палитры" » "Диспетчер подшивок".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Создание новой подшивки - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание подшивки
Понятия
Процедуры
Команды

Создание новой подшивки

  1. Для создания новой подшивки необходимо выполнить одно из следующих действий:
    • Нажмите "Файл" » "Создать подшивку".
    • В Диспетчере подшивок выберите меню команд, затем команду "Новая подшивка".
  2. Выполнить инструкции Мастера создания подшивок.

Панель "Стандартная"

Ввод команды: ПШСОЗДАТЬ


Открытие подшивки - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание подшивки
Понятия
Процедуры
Команды

Открытие подшивки

  1. Для открытия подшивки необходимо выполнить одно из следующих действий:
    • Нажмите "Файл" » "Открыть подшивку".
    • В Диспетчере подшивок выберите меню команд, затем команду "Открыть".
    • Дважды нажмите кнопку мыши на файле данных подшивки (DST).
  2. В диалоговом окне "Открыть подшивку" перейти к папке, содержащей файл DST. Выберите файл DST и затем нажмите "Открыть".

    3. В Диспетчере подшивок открываются данные подшивки.

    Примечание Можно открыть несколько подшивок и переключаться между ними с помощью меню команд.

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Закрытие подшивки - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание подшивки
Понятия
Процедуры
Команды

Закрытие подшивки

  1. В Диспетчере подшивок на вкладке "Список листов" нажмите правую кнопку мыши на узле подшивки (наверху листа). Выберите в контекстном меню "Закрыть подшивку".

    2. Данная подшивка исключается из Диспетчера подшивок.

    Примечание Чтобы уменьшить количество подшивок в списке меню команд, рекомендуется закрыть неиспользуемые подшивки. Но если закрыть подшивку, у которой остались открыты листы, невозможно будет обновить ведомость листов и некоторые поля.

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Создание подшивки - Команды

Работа с листами в подшивке
Работа с листами в подшивке
Создание подшивки
Понятия
Процедуры
Команды

Команды
ПОДШИВКА | Вызов диспетчера подшивок
ПОДШИВКАОТКЛ | Закрытие диспетчера подшивок
ПШОТКРЫТЬ | Открывает выбранную подшивку
ПШСОЗДАТЬ | Создание новой подшивки
Системные переменные
SSFOUND | Отображает имя файла и путь, полученные при успешном поиске подшивки
SSLOCATE | Управляет местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа.
SSMAUTOOPEN | Управляет режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой.
SSMSTATE | Определяет активность окна Диспетчера подшивок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Организация подшивки - Понятия

Выбор рабочего процесса
Работа с листами в подшивке
Организация подшивки
Понятия
Процедуры
Команды

Пользователь может организовывать подшивку в иерархическом порядке с использованием групп и категорий Листы могут быть объединены в группы. Виды могут быть объединены в категории.

В большой подшивке листы и виды удобнее организовать в виде древовидной структуры. На вкладке "Список листов" листы можно объединять в группы. На вкладке "Виды листов" виды можно объединять в категории.

Использование групп листов

Логика формирования групп листов часто определяется дисциплинарной спецификой проекта. Например, в архитектуре пользователь может использовать группу с именем "Несущие элементы"; а в машиностроении - группу с именем "Стандартный крепеж". В некоторых случаях бывает полезной организация групп листов по состоянию их готовности (на стадии рассмотрения или завершения).

При необходимости группы могут быть вложены в другие группы. После создания или импорта листов или групп листов можно перегруппировать их путем перетаскивания в области структуры.

Использование категорий вида

Категории видов часто определяются функционально. Например, в архитектуре уместна категория видов с названием "Уровни"; а в машиностроении - категория видов с названием "Расчлененные".

Виды можно отображать по категориям или по листам, на которых они расположены.

При необходимости категории могут быть вложены в другие категории. Для перемещения вида в другую категорию его можно перетащить в области структуры или использовать команду контекстном меню "Установить категорию".


Организация подшивки - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Организация подшивки
Понятия
Процедуры
Команды

Перегруппирование листов в списке листов

Создание новой группы в списке листов

Создание новой категории видов в списке видов

Удаление группы из списка листов

Удаление категории видов из списка видов


Перегруппирование листов в списке листов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Организация подшивки
Понятия
Процедуры
Команды

Перегруппирование листов в списке листов

  • В Диспетчере подшивок на вкладке "Список листов" перетащить лист в списке вверх или вниз.

Лист будет перемещен выше или ниже своего предшествующего положения в списке листов. Лист также может быть перемещен в группу листов или из нее.

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Создание новой группы в списке листов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Организация подшивки
Понятия
Процедуры
Команды

Создание новой группы в списке листов

  1. В Диспетчере подшивок на вкладке "Список листов" нажмите правую кнопку мыши на узле подшивки (наверху листа) или существующей группы листов. Выберите в контекстном меню "Создать группу".
  2. В диалоговом окне "Свойства группы листов" в поле "Имя группы листов" введите имя новой группы. Нажмите "OK".

    3. Можно перетащить новую группу листов в любое место в списке листов, или даже поместить ее в другие группы листов.

    Примечание Для создания подгруппы в существующей группе листов, нажмите правую кнопку мыши на существующей группе и выберите в контекстном меню "Создать группу".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Создание новой категории видов в списке видов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Организация подшивки
Понятия
Процедуры
Команды

Создание новой категории видов в списке видов

  1. В режиме "Диспетчер подшивок" на вкладке "Виды листов" нажмите кнопку "Просмотр по категориям".
  2. Нажмите правую кнопку мыши на узле подшивки (наверху листа) и выберите в контекстном меню "Создать категорию видов".
  3. В диалоговом окне "Категория видов" в поле "Имя категории" введите имя новой категории вида.
  4. Если имеется список блоков-идентификаторов, то необходимо выбрать блоки, которые должны использоваться для видов в данной категории. Пользователь может добавить блоки в данный список, нажав кнопку "Добавить блоки".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Удаление группы из списка листов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Организация подшивки
Понятия
Процедуры
Команды

Удаление группы из списка листов

  1. В Диспетчере подшивок на вкладке "Список листов" перетащить все листы из группы, которую необходимо удалить.
  2. Нажмите правую кнопки мыши на группе, которую надо удалить и выберите в контекстном меню "Удалить группу".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Удаление категории видов из списка видов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Организация подшивки
Понятия
Процедуры
Команды

Удаление категории видов из списка видов

  1. В режиме "Диспетчер подшивок" на вкладке "Виды листов" нажмите кнопку "Просмотр по категориям".
  2. Перетащить все листы из категории видов, которую необходимо удалить.
  3. Нажмите правую кнопку мыши на категории видов, которую требуется удалить. Выберите в контекстном меню "Удалить категорию".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Организация подшивки - Команды

Работа с листами в подшивке
Работа с листами в подшивке
Организация подшивки
Понятия
Процедуры
Команды

Команды
ПОДШИВКА | Вызов диспетчера подшивок
ПОДШИВКАОТКЛ | Закрытие диспетчера подшивок
ПШОТКРЫТЬ | Открывает выбранную подшивку
ПШСОЗДАТЬ | Создание новой подшивки
Системные переменные
SSFOUND | Отображает имя файла и путь, полученные при успешном поиске подшивки
SSLOCATE | Управляет местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа.
SSMAUTOOPEN | Управляет режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой.
SSMSTATE | Определяет активность окна Диспетчера подшивок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и изменение листов - Понятия

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

В Диспетчере подшивок предусмотрено несколько функций и возможностей для создания листов и добавления видов, как через контекстное меню, так и с помощью одной из кнопок, расположенных на вкладке.

Далее представлено описание часто выполняемых операций с листами. Доступ к командам можно получить с помощью контекстного меню для элемента в области структуры.

  • Импорт листа. После создания подшивки можно импортировать один или несколько листов из существующих чертежей. Это быстрый способ создания нескольких листов из листов нескольких чертежей.
  • Создание нового листа. В качестве альтернативы импорту существующих листов можно создать новый лист. При расположении видов на таком листе, файлы чертежей, связанные с видами, вставляются на лист чертежа как внешние ссылки. Файл чертежа листа создается с использованием либо формата AutoCAD 2004, либо формата AutoCAD 2007 в зависимости от того, какой формат указан во вкладке "Открытие/Сохранение" в диалоговом окне "Настройка".
  • Редактирование листа. Дважды нажмите кнопку мыши на листе на вкладке "Список листов" для открытия чертежа из подшивки. Для выбора нескольких листов используются клавиши SHIFT или CTRL. Для просмотра листа откройте чертеж с помощью контекстного меню в режиме "только чтение".

    • Примечание При редактировании листа подшивка, в которую он входит, должна быть открыта в Диспетчере подшивок. Это обеспечит обновление всех данных, связанных с листом.

  • Переименование и перенумерация листов После создания листа можно изменять заголовок и номер листа. Можно также задавать другой файл чертежа, связываемый с листом.
  • Исключение листа из подшивки. Удаление листа из подшивки разрывает связь листа с подшивкой, но не удаляет файл чертежа или лист.
  • Переприкрепление листа. Если лист был перемещен в другую папку, его необходимо заново связать с подшивкой в диалоговом окне "Свойства листа" для того, чтобы указать правильный путь. Для перемещенных чертежей их пути указаны в диалоговом окне "Свойства листа" в полях "Ожидаемый лист чертежа" и "Реальный лист чертежа". Для переприкрепления листа выберите путь в поле "Ожидаемый лист чертежа" и укажите новое местоположение листа.

    • Примечание Поле "Подробности", расположенное внизу вкладки "Список листов" позволяет быстро узнать, находится ли лист в ожидаемой папке. Если выбранный лист не найден по ожидаемому пути, то информация об ожидаемой и реальной папке отобразится в поле "Подробности".

  • Добавление вида на лист. На вкладке "Виды моделей" можно удобно добавлять вид на лист, помещая именованный вид пространства модели или весь чертеж на текущий лист.

    • Примечание После создания именованного вида пространства модели и сохранения чертежа вид добавляется на вкладку "Виды моделей". Нажмите "Обновить" на вкладке "Чертежи с ресурсами" для обновления области структуры Диспетчера подшивок.

  • Добавление блоков-меток для видов. С помощью Диспетчера подшивок можно автоматически присваивать видам и деталям имена при размещении их на листе. Каждая метка содержит данные о соответствующем виде.

  • Добавление блоков-идентификаторов для видов. Блоками-идентификаторами называются символы, которые ссылаются на другие листы. Блоки-идентификаторы могут называться по-разному (в зависимости от отрасли промышленности): ссылочные метки, коды выносных элементов, метки выносных элементов, коды разрезов зданий и т.д. Блоки-идентификаторы содержат данные, связанные с листом и видом, на которые происходит ссылка.

    • Примечание При размещении на листе блока-идентификатора с полями или видом следует убедиться, что текущий слой разблокирован.

  • Создание титульного листа и оглавления. Первым листом в подшивке обычно является титульный лист, содержащий описание подшивки и таблицу с перечнем всех листов подшивки. Пользователь может создать такую таблицу, называемую ведомостью листов, на открытом листе. В ведомость автоматически включаются все листы подшивки. Создать ведомость листов с помощью контекстного меню подшивки можно только при открытом листе. После создания ведомости листов подшивки можно использовать опции для изменения, обновления или удаления содержимого ячеек ведомости.

    • Примечание Для доступа к контекстным меню в области рисования, необходимым для операций с перечнем списком листов, в диалоговом окне "Параметры" на вкладке "Пользовательские" необходимо установить флажок "Контекстные меню в области рисования".

Создание блоков-идентификаторов и блоков меток (дополнительно)

При создании блока, который будет использоваться как блок-идентификатор или блок метки, можно использовать поле заменителя для отображения такой информации, как название вида или номер листа. Блок-идентификатор или блок метки необходимо определить в файле DWG или DWT, указанном в диалоговом окне "Свойства подшивки". В дальнейшем блок-идентификатор или блок метки можно вставить с помощью контекстных меню на вкладке "Виды листов" Диспетчера подшивок.

Для отображения в поле правильной информации о виде или листах, на которых в дальнейшем оно будет размещено, при определении блока поле должно быть включено в атрибут блока, а не в текст. Для определения атрибута блока вставить в качестве значения поле заменитель, выберите параметр "Установленный" и задать метку.

Примечание При создании пользовательских меток и блоков-идентификаторов во избежание выдачи запросов при размещении этих блоков на чертеже, в описании атрибутов необходимо установить стандартные параметры.

Дополнительную информацию о полях см. в разделе Вставка полей.

Размещение вида на листе (дополнительно)

Диспетчер подшивок автоматизирует и облегчает процесс добавления видов на листы подшивки. Вид на листе, называемый видом листа, состоит из нескольких согласованных объектов: внешней ссылки или геометрического объекта в пространстве модели, видового экрана листа и именованного вида в пространстве листа.

  • Вид листа может представлять пространство модели из внешнего файла чертежа. В этом случае внешний чертеж вставляется в текущий как файл с внешней ссылкой. Слои файла внешнего чертежа отображаются только в создаваемом виде листа.

    • Примечание Внешняя ссылка подключается с использованием относительного пути. Если требуется замена пути на абсолютный путь, используется палитра "Внешние ссылки".

  • На текущем листе создается видовой экран листа, отображающий вид пространства модели.
  • В пространстве листа создается именованный вид, охватывающий область видового экрана листа.

При помещении вида листа на лист все слои текущего чертежа (включая слой 0) замораживаются в новом видовом экране, созданном видом. Слои отображаются в замороженном виде в столбце "Замороженный на текущем ВЭ" Диспетчера свойств слоев.

Для удаления вида листа из листа подшивки можно удалить видовой экран листа. Однако для удаления всех неиспользуемых элементов необходимо отсоединить внешнюю ссылку и удалить именованный вид пространства листа.

Примечание Проще всего удалить вид листа сразу же после его размещения с помощью команды ОТМЕНИТЬ.

См. также

Создание многовидовых чертежей (в пространстве листа)


Создание и изменение листов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Импорт листов из существующих чертежей

Создание нового листа

Открытие файла чертежа в подшивке

Открытие файла чертежа в подшивке в режиме "только чтение"

Исключение листа из подшивки

Переприкрепление листа к подшивке

Добавление вида на лист

Добавление ведомости листов

Изменение ведомости листов

Обновление ведомости листов

Добавление блока, используемого для идентификаторов видов листов

Изменение блока, используемого по умолчанию для идентификаторов видов листов

Добавление на лист блока-идентификатора

Создание ведомости листов на титульном листе


Импорт листов из существующих чертежей - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Импорт листов из существующих чертежей

  1. В Диспетчере подшивок на вкладке "Список листов" нажмите правую кнопку мыши на узле подшивки, узле группы или узле листа. Выберите в контекстном меню "Импортировать лист".
  2. В диалоговом окне "Импорт листов в подшивку" нажмите кнопку "Поиск чертежей" и выберите требуемый чертеж.

    3. Выбор нескольких чертежей выполняется с помощью клавиш SHIFT или CTRL.

  3. Установить флажки для листов, которые необходимо импортировать в текущую подшивку. Нажмите кнопку "Импорт".
  4. (Дополнительно) На вкладке "Список листов" нажмите правую кнопку мыши на импортированном листе. Выберите в контекстном меню "Сменить название и номер".
  5. (Дополнительно) В диалоговом окне "Смена названия и номера листа" внести изменения в номер и заголовок листа. Нажмите "OK".

    6. Примечание Изменение номера и названия листа не влияет на имя файла чертежа, если не установлен флажок для параметра переименования файла.

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Создание нового листа - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Создание нового листа

  1. В Диспетчере подшивок на вкладке "Список листов" нажмите правую кнопку мыши на узле подшивки, узле группы или узле листа. Выберите "Новый лист".
  2. В диалоговом окне "Новый лист" введите номер и название листа. Нажмите "OK".

    3. По умолчанию новый лист создается на основе файла шаблона чертежа, заданного в диалоговом окне "Свойства подшивки".

    Примечание И местоположение по умолчанию папки для новых листов можно в диалоговых окнах "Свойства подшивки" или "Свойства группы листов".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Открытие файла чертежа в подшивке - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Открытие файла чертежа в подшивке

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" дважды нажмите кнопку мыши на листе. Выбор нескольких чертежей выполняется с помощью клавиш SHIFT или CTRL.

    3. Открывается выбранный файл чертежа. Любые изменения, сделанные в чертеже и относящиеся к списку листов, сохраняются в файле данных подшивки (DST).

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Открытие файла чертежа в подшивке в режиме "только чтение" - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Открытие файла чертежа в подшивке в режиме "только чтение"

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" нажмите правую кнопку мыши на листе. Выберите "Открыть только для чтения".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Исключение листа из подшивки - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Исключение листа из подшивки

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" нажмите правую кнопку мыши на на листе, который надо исключить. Выберите в контекстном меню "Исключить лист".

    3. Указанный лист будет удален из списка листов. Однако сам лист и файл чертежа при этом не удаляются. Этот лист можно добавить в другую подшивку.

    Примечание Файл DWG, связанный с листом, не будет доступен для удаляемого из подшивки листа.

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Переприкрепление листа к подшивке - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Переприкрепление листа к подшивке

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" откройте лист, который требуется переприкрепить.
  3. В Диспетчере подшивок нажмите на листе правую кнопку мыши. Выберите в контекстном меню "Исключить лист".
  4. Сохранить чертеж.
  5. В Диспетчере подшивок нажмите на подшивке правую кнопку мыши. Выберите в контекстном меню "Импортировать лист".
  6. В диалоговом окне "Импорт листов в подшивку" нажмите "Поиск чертежей". Выберите требуемый чертеж.
  7. Установить флажок для листа, который требуется переприкрепить в текущей подшивке. Нажмите кнопку "Импорт".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Добавление вида на лист - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Добавление вида на лист

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" необходимо выполнить одно из следующих действий:
    • Дважды нажмите кнопку мыши на листе для его открытия.
    • Создайте подшивку и откройте ее.
  3. Для просмотра чертежей в папке на вкладке "Виды моделей" нажмите знак плюс (+) рядом с папкой.
  4. В списке файлов чертежей необходимо выполнить одно из следующих действий:
    • Для добавления вида пространства модели на лист нажмите знак плюс (+) около файла чертежа с целью просмотра списка именованных видов пространства модели. Нажмите правую кнопку мыши на требуемом виде пространства модели.
    • Для добавления на лист подшивки всего чертежа в качестве вида нажмите правую кнопку мыши на файле чертежа.
  5. Выберите в контекстном меню "Вставить на лист".

    6. Примечание В качестве альтернативы можно перетащить на лист подшивки вид пространства модели или чертеж из вкладки "Виды моделей".

  6. Нажмите на листе правую кнопку мыши. Выберите масштаб для вида листа.
  7. Указать точку вставки для вида листе.

    8. Заданный вид будет добавлен на лист. Если в свойствах подшивки задан блок марки, то на листе автоматически располагается марка вида, содержащая информацию о виде.

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Добавление ведомости листов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Добавление ведомости листов

  1. В Диспетчере подшивок откройте подшивку.
  2. Нажмите правую кнопку мыши на имени подшивки. Выберите в контекстном меню "Вставить ведомость листов".
  3. В диалоговом окне "Вставить ведомость листов" выполните следующие действия:
    • Установите "Стиль таблицы" в группе "Параметры стиля таблицы".
    • Укажите "Текст заголовка" для таблицы в группе "Параметры данных таблицы".
    • Добавьте, удалите или измените порядок записей столбцов.
  4. Нажмите "ОК" для закрытия диалогового окна и добавления таблицы в чертеж.

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Изменение ведомости листов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Изменение ведомости листов

  1. Выберите ячейку в существующей ведомости листов.
  2. Нажмите правую кнопку мыши на ячейке. Выберите "Изменить параметры ведомости листов".
  3. В диалоговом окне "Изменить параметры ведомости листов" выполните одно или несколько из следующих действий:
    • Измените "Стиль таблицы", если текущий формат не нравится.
    • Измените "Текст заголовка" таблицы.
    • Добавьте, удалите или измените порядок записей столбцов.
    • Измените тип данных или текст заголовков столбцов.
  4. Нажмите "ОК" для закрытия диалогового окна и изменения таблицы в чертеже.

Контекстное меню: Выберите любую ячейку в ведомости листов » нажмите правую кнопку мыши для открытия контекстного меню » "Изменить параметры ведомости листов".


Обновление ведомости листов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Обновление ведомости листов

  1. Выберите ячейку в существующей ведомости листов.
  2. Нажмите правую кнопку мыши на ячейке. Выберите "Обновить ведомость листов".

Контекстное меню: Выберите любую ячейку в ведомости листов » Нажмите правую кнопку мыши для открытия контекстного меню » "Обновить ведомость листов".


Добавление блока, используемого для идентификаторов видов листов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Добавление блока, используемого для идентификаторов видов листов

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Виды листов" выберите правой кнопкой мыши узел подшивки.
  3. В диалоговом окне "Свойства подшивки" нажмите "Блоки-идентификаторы". Нажмите кнопку [...].
  4. В диалоговом окне "Список блоков" необходимо выполнить одно из следующих действий:
    • Выберите блок из списка блоков.
    • Нажмите кнопку "Добавить" и задать новый блок для добавления в список.
  5. Нажмите "OK".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Изменение блока, используемого по умолчанию для идентификаторов видов листов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Изменение блока, используемого по умолчанию для идентификаторов видов листов

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Виды листов" выберите правой кнопкой мыши узел подшивки.
  3. В диалоговом окне "Свойства подшивки" выберите "Блок метки для видов". Нажмите кнопку [...].
  4. В диалоговом окне "Выбор блока" задать новый блок, который должен использоваться по умолчанию в качестве блока-идентификатора вида.
  5. Нажмите "OK".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Добавление на лист блока-идентификатора - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Добавление на лист блока-идентификатора

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Виды листов" нажмите правую кнопку мыши на виде, с которым необходимо связать идентификатор. Выберите в контекстном меню "Вставить блок-идентификатор".
  3. Задать точку вставки блока-идентификатора.

    4. Блок-идентификатор вставляется на лист. Блок-идентификатор автоматически отображает информацию о виде, с которым он связан.

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Создание ведомости листов на титульном листе - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Создание ведомости листов на титульном листе

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" дважды нажмите кнопку мыши на листе, который должен использоваться в качестве титульного.
  3. Нажмите правую кнопку мыши на узле подшивки. Выберите в контекстном меню "Вставить ведомость листов".
  4. В диалоговом окне "Ведомость листов" введите название ведомости и задать параметры форматирования.
  5. Нажмите "ОК".
  6. Указать точку вставки ведомости.

    7. Автоматически генерируется ведомость листов, содержащая сведения о всех листах подшивки.

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Создание и изменение листов - Команды

Работа с листами в подшивке
Работа с листами в подшивке
Создание и изменение листов
Понятия
Процедуры
Команды

Команды
ПОДШИВКА | Вызов диспетчера подшивок
ПОДШИВКАОТКЛ | Закрытие диспетчера подшивок
ПШОТКРЫТЬ | Открывает выбранную подшивку
ПШСОЗДАТЬ | Создание новой подшивки
Системные переменные
SSFOUND | Отображает имя файла и путь, полученные при успешном поиске подшивки
SSLOCATE | Управляет местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа.
SSMAUTOOPEN | Управляет режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой.
SSMSTATE | Определяет активность окна Диспетчера подшивок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление дополнительных сведений для листов и подшивок - Понятия

Выбор рабочего процесса
Работа с листами в подшивке
Добавление дополнительных сведений для листов и подшивок
Понятия
Процедуры
Команды

В подшивках, группах и листах содержится информация различного типа. Эта информация называется свойствами и включает в себя названия, пояснения, пути к папкам с файлами, а также иные дополнительные сведения.

Различные свойства для различных уровней (владельцев)

Подшивки, группы и листы представляют собой различные уровни организации и содержат различные типы свойств. Значения этих свойств задаются при создании подшивки, группы или листа.

Кроме того, пользователь может определить дополнительные свойства для листа и подшивки. Значения дополнительных свойств для листов обычно индивидуальны для каждого листа. Например, в качестве дополнительного свойства для листа можно указать имя разработчика. Значения дополнительных свойств для подшивки обычно индивидуальны для каждого проекта. Например, в качестве дополнительного свойства для подшивки можно указать номер контракта.

Нельзя создать дополнительные свойства для групп.

Просмотр и изменение свойств

Просмотреть и изменить свойства можно на вкладке "Список листов", нажав правой кнопкой мыши на имени подшивки, группы или листа В контекстном меню выберите "Свойства". Свойства и их значения, отображаемые в диалоговом окне "Свойства", зависят от выбора пользователя. Для изменения значения нужно нажать на нем кнопку мыши.


Добавление дополнительных сведений для листов и подшивок - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Добавление дополнительных сведений для листов и подшивок
Понятия
Процедуры
Команды

Изменение свойств подшивки, группы листов, листа или категории вида

Создание дополнительного свойства для подшивки

Создание дополнительного свойства листа


Изменение свойств подшивки, группы листов, листа или категории вида - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Добавление дополнительных сведений для листов и подшивок
Понятия
Процедуры
Команды

Изменение свойств подшивки, группы листов, листа или категории вида

  1. В Диспетчере подшивок откройте подшивку.
  2. Выполнить одно из следующих действий:
    • На вкладке "Список листов" нажмите правую кнопку мыши на узле подшивки, группы или листа.
    • На вкладке "Список видов" нажмите правую кнопку мыши на категории вида.
  3. Нажмите "Свойства".
  4. В открывшемся диалоговом окне нажмите кнопку мыши на любом поле и введите изменения.
  5. Нажмите "ОК".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Создание дополнительного свойства для подшивки - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Добавление дополнительных сведений для листов и подшивок
Понятия
Процедуры
Команды

Создание дополнительного свойства для подшивки

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" нажмите правую кнопку мыши на узле подшивки. Нажмите "Свойства".
  3. В диалоговом окне "Свойства подшивки" нажмите кнопку "Дополнительные свойства".
  4. В диалоговом окне "Дополнительные свойства" необходимо выполнить одно из следующих действий:
    • Нажмите кнопку "Добавить" для создания нового дополнительного свойства для подшивки. В поля имени и значения по умолчанию введите новые данные. Для назначения нового свойства подшивке необходимо убедиться, что в группе "Владелец" установлен флажок "Подшивка".
    • В поля имени и значения по умолчанию введите новые данные.
    • Выберите дополнительное свойство из списка. Нажмите кнопку "Удалить" для его удаления.
  5. Нажмите "OK".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Создание дополнительного свойства листа - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Добавление дополнительных сведений для листов и подшивок
Понятия
Процедуры
Команды

Создание дополнительного свойства листа

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" нажмите правую кнопку мыши на узле подшивки.
  3. В диалоговом окне "Свойства подшивки" нажмите кнопку "Дополнительные свойства".
  4. В диалоговом окне "Дополнительные свойства" необходимо выполнить одно из следующих действий:
    • Нажмите кнопку "Добавить" для создания нового пользовательского свойства для листа. В поля имени и значения по умолчанию введите новые данные. Для назначения нового свойства подшивке необходимо убедиться, что в группе "Владелец" установлен флажок "Подшивка".
    • В поля имени и значения по умолчанию введите новые данные. Таким образом можно изменить значение для каждого листа в подшивке.
    • Выберите дополнительное свойство из списка. Нажмите кнопку "Удалить" для его удаления.
  5. Нажмите "OK".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Добавление дополнительных сведений для листов и подшивок - Команды

Работа с листами в подшивке
Работа с листами в подшивке
Добавление дополнительных сведений для листов и подшивок
Понятия
Процедуры
Команды

Команды
ПОДШИВКА | Вызов диспетчера подшивок
ПОДШИВКАОТКЛ | Закрытие диспетчера подшивок
ПШОТКРЫТЬ | Открывает выбранную подшивку
ПШСОЗДАТЬ | Создание новой подшивки
Системные переменные
SSFOUND | Отображает имя файла и путь, полученные при успешном поиске подшивки
SSLOCATE | Управляет местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа.
SSMAUTOOPEN | Управляет режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой.
SSMSTATE | Определяет активность окна Диспетчера подшивок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Публикация, комплектование и архивация подшивок - Понятия

Выбор рабочего процесса
Работа с листами в подшивке
Публикация, комплектование и архивация подшивок
Понятия
Процедуры
Команды

Готовую подшивку можно опубликовать, укомплектовать для пересылки или заархивировать.

  • Публикация подшивки. Функция "Публикация" служит для создания одно- и многостраничных файлов формата Design Web Format™ (DWF™) из подшивки или части подшивки. Можно также напечатать подшивку. Подробнее см. Публикация подшивки. Подробнее о DWF-файлах см. в разделе Печать в DWF-файлы.
  • Задать параметры свойств, которые требуется включить в файл DWF. Можно определить, какая информация будет содержаться в опубликованных файлах DWF. В метаданные, которые можно включить в файл, входят свойства листа и подшивки, свойства и атрибуты блока, свойства и атрибуты динамических блоков и свойства настраиваемых объектов. Метаданные отображаются только при публикации в файл DWF; при печати в файл DWF они недоступны.
  • Комплектование подшивки. Архивация и отправка подшивки или части подшивки через Интернет. Подробнее см. Формирование комплектов файлов.
  • Архивация подшивки. Архивация подшивки или части подшивки для хранения. Данная команда действует так же, как и команда передачи подшивки, за исключением того, что здесь пользователь должен определить папку для архива, а не посылает полученный пакет. Подробнее см. команду АРХИВАЦИЯ.
Использование параметров листов

Параметры листов предоставляют собой настройки, используемые для публикации и печати. При создании подшивки пользователь задает файл шаблона чертежа (DWT), содержащий один или более наборов параметров листов для всех новых листов. Этот файл DWT называется шаблоном для создания листов.

Другой DWT файл, называемый файлом переопределения параметров листа, содержит параметры, переопределяющие индивидуальные настройки листов подшивки. Файл переопределения параметров листа задается пользователем в диалоговом окне "Свойства подшивки".

При публикации подшивки можно использовать параметры страницы, определенные в каждом файле чертежа, применить для всех файлов переопределения параметров страницы или опубликовать в файл DWF. Дополнительную информацию о параметрах страницы см. в разделе Использование наборов параметров листов в подшивках.

Сохранение набора листов

Пользователь может выбрать часть подшивки для публикации или передачи. На вкладке "Список листов" можно выбрать отдельные листы с использованием стандартных способов выбора в системе Microsoft® Windows®: при выборе используйте клавиши CTRL или SHIFT. Можно указать все листы в группе листов, нажав кнопку мыши на узле группы.

Как правило, операции с одной и той же выборкой листов в подшивке приходится выполнять неоднократно. Для ускорения выбора листов и обеспечения единообразия в Диспетчере подшивок предусмотрена возможность выбора подмножества листов по имени. Именованное подмножество листов подшивки называется набором листов. Для создания наборов листов подшивки и управления ими используется кнопка "Наборы листов", расположенная наверху вкладки "Список листов".


Публикация, комплектование и архивация подшивок - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Публикация, комплектование и архивация подшивок
Понятия
Процедуры
Команды

Сохранение набора листов подшивки

Восстановление набора листов

Переименование или удаление набора листов

Изменение существующего набора листов

Включение слоя, блока, информации о листе или о подшивке в публикуемый файл DWF

Использование файла шаблона блока для включения свойств и атрибутов в публикуемый файл DWF


Сохранение набора листов подшивки - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Публикация, комплектование и архивация подшивок
Понятия
Процедуры
Команды

Сохранение набора листов подшивки

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" выберите листы и группы листов, которые требуется включить в набор листов.

    3. Для выбора нескольких элементов в списке используются клавиши CTRL или SHIFT.

  3. В Диспетчере подшивок нажмите кнопку "Наборы листов", расположенную в правом верхнем углу. Нажмите "Создать".
  4. В диалоговом окне "Новый набор листов" введите имя набора листов и нажмите "OK".

Окно "Диспетчер подшивки"

Ввод команды: ПОДШИВКА


Восстановление набора листов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Публикация, комплектование и архивация подшивок
Понятия
Процедуры
Команды

Восстановление набора листов

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" нажмите кнопку "Наборы листов", расположенную в правом верхнем углу. Выберите имя набора листов, который требуется восстановить.

    3. Выбранный набор листов становится доступным для операций публикации и комплектования.

Окно "Диспетчер подшивки"

Ввод команды: ПОДШИВКА


Переименование или удаление набора листов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Публикация, комплектование и архивация подшивок
Понятия
Процедуры
Команды

Переименование или удаление набора листов

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" нажмите кнопку "Наборы листов", расположенную в правом верхнем углу. Нажмите "Управление".
  3. В диалоговом окне "Набор листов" выберите имя набора листов и выполнить одно из следующих действий:
    • Нажмите "Переименовать" для переименования набора листов. Введите новое имя для набора листов.
    • Нажмите "Удалить" для удаления имени набора листов из списка. Нажмите "Да" для подтверждения удаления набора листов.
  4. Нажмите "ОК".

Окно Диспетчера подшивки

Ввод команды: ПОДШИВКА


Изменение существующего набора листов - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Публикация, комплектование и архивация подшивок
Понятия
Процедуры
Команды

Изменение существующего набора листов

Примечание Изменить набор листов непосредственно невозможно. Вместо этого необходимо активировать набор листов и изменить его, а затем удалить имя набора листов и создать вместо него новый набор листов.

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" нажмите кнопку "Наборы листов", расположенную в правом верхнем углу. Выберите имя набора листов, который требуется изменить.
  3. Для добавления и удаления элементов в наборе листов можно использовать клавишу CTRL.
  4. В Диспетчере подшивок нажмите кнопку "Наборы листов", расположенную в правом верхнем углу. Нажмите "Управление".
  5. Нажмите "Удалить" для удаления имени набора листов из списка. Нажмите "Да" для подтверждения удаления набора листов.
  6. Нажмите "OK" для закрытия диалогового окна "Наборы листов".
  7. В Диспетчере подшивок нажмите кнопку "Наборы листов", расположенную в правом верхнем углу. Нажмите "Создать".
  8. В диалоговом окне "Новый набор листов" введите имя набора листов и нажмите "OK".

Окно "Диспетчер подшивки"

Ввод команды: ПОДШИВКА


Включение слоя, блока, информации о листе или о подшивке в публикуемый файл DWF - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Публикация, комплектование и архивация подшивок
Понятия
Процедуры
Команды

Включение слоя, блока, информации о листе или о подшивке в публикуемый файл DWF

  1. В Диспетчере подшивок на вкладке "Список листов" выберите подшивку для публикации в файл DWF.
  2. Нажмите кнопку "Публикация". Нажмите "Параметры публикации подшивки".
  3. В диалоговом окне "Параметры публикации подшивки" в поле "Параметры данных DWF" выберите значение включаемого параметра в зависимости от того, что требуется включить в публикуемый файл DWF.”
    • Информация о слоях
    • Сведения о подшивке (для включения можно выбрать описание и настраиваемые свойства)
    • Сведения о подшивке (для включения можно выбрать название листа, номер листа, описание, подшивку, группу и настраиваемые свойства листа)
    • Сведения о блоке

      • Примечание Некоторые свойства листа всегда публикуются в файле DWF (независимо от того, установлен флажок "Параметры публикации подшивки" или нет). Это имя листа, формат листа, автор, создатель, время создания и время изменения.

  4. Нажмите "ОК".

Окно "Диспетчер подшивки"

Ввод команды: ПОДШИВКА


Использование файла шаблона блока для включения свойств и атрибутов в публикуемый файл DWF - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Публикация, комплектование и архивация подшивок
Понятия
Процедуры
Команды

Использование файла шаблона блока для включения свойств и атрибутов в публикуемый файл DWF

  1. В Диспетчере подшивок на вкладке "Список листов" выберите подшивку для публикации в файл DWF.
  2. Нажмите кнопку "Публикация". Нажмите "Параметры публикации подшивки".
  3. В диалоговом окне "Параметры публикации подшивки" нажмите в разделах "Параметры данных DWF" и "Сведения о блоке" для отображения раскрывающегося списка и выберите "Включить".”
  4. В группах "Параметры данных DWF" и "Файл шаблона блока" выберите требуемый файл шаблона блока или создать новый. Нажмите "ОК".

    5. Файл шаблона блока, определяющий блоки, их свойства и атрибуты, будет включен в публикуемый файл DWF.

Окно "Диспетчер подшивки"

Ввод команды: ПОДШИВКА


Публикация, комплектование и архивация подшивок - Команды

Работа с листами в подшивке
Работа с листами в подшивке
Публикация, комплектование и архивация подшивок
Понятия
Процедуры
Команды

Команды
АРХИВАЦИЯ | Упаковывает файлы текущей подшивки для архивирования
ПОДШИВКА | Вызов диспетчера подшивок
ПОДШИВКАОТКЛ | Закрытие диспетчера подшивок
ПШОТКРЫТЬ | Открывает выбранную подшивку
ПШСОЗДАТЬ | Создание новой подшивки
Системные переменные
SSFOUND | Отображает имя файла и путь, полученные при успешном поиске подшивки
SSLOCATE | Управляет местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа.
SSMAUTOOPEN | Управляет режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой.
SSMSTATE | Определяет активность окна Диспетчера подшивок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коллективная работа с подшивками - Понятия

Выбор рабочего процесса
Работа с листами в подшивке
Коллективная работа с подшивками
Понятия
Процедуры
Команды

Коллективная работа с подшивками может осуществляться по локальной сети, через Интернет или по электронной почте. В группу могут также входить пользователи, использующие программное обеспечение без Диспетчера подшивок.

Работа в группе с использованием Диспетчера подшивок

Для совместной работы с подшивками каждый участник проектной группы должен иметь доступ к файлу данных подшивки (DST) и связанным файлам шаблонов чертежей (DWT) по локальной сети. Каждый проектировщик может загрузить в Диспетчер подшивок информацию о подшивке из файла DST.

При внесении в проект кем-либо из членов команды изменений файл DST кратковременно открывается, а информация, хранящаяся в этом файле, обновляется. При открытии файла DST рядом с именем подшивки в левом верхнем углу окна Диспетчера подшивок отображается значок блокировки.

Зеленая точка на значке блокировки указывает, что сеанс Диспетчера подшивок на компьютере временно заблокировал файл DST.

Красная точка указывает, что сеанс Диспетчера подшивок на компьютере участника группы временно заблокировал файл DST.

Желтая точка на значке блокировки означает, что лист находится в специальном состоянии, например, для свойств его файла установлен атрибут "Только чтение".

Другие члены группы автоматически могут просматривать изменения в подшивке в области структуры Диспетчере подшивок .

Если доступ к файлам DWT подшивки имеется у всех участников группы, новые файлы чертежей и их листы создаются с помощью одних и тех же файлов шаблонов чертежей. Параметры страницы для этих чертежей также стандартизированы.

Примечание Если одни и те же файлы листов, расположенные на разных логических диска локальной сети, запрошены несколькими пользователями, каждый из них получит запрос на сохранение подшивки на логических дисках своих компьютеров. Во избежание излишнего сохранения пользователи должны по возможности подключать одинаковые логические диски.

Другие пользователя также имеют доступ к данным о состоянии для листов в текущей подшивке. Данные о состоянии отображаются в области структуры и указывают на одно из следующих состояний.

Лист доступен для изменения.

Лист заблокирован.

Лист отсутствует или находится в неизвестной папке.

Опрос активных листов других участников коллектива выполняется автоматически; область структуры обновляется в сеансе пользователя Диспетчера подшивок. Если команда активна, в цикле опроса интервал в сеансе пользователя пропускается. Для принудительного обновления состояния листа на вкладке "Список листов" нажмите "Обновить состояние листа".

Для отображения дополнительной информации в области "Подробности" Диспетчера подшивок выберите любой лист.

Примечание В случае сбоя сетевого соединения или неожиданного завершения работы программы может отображаться ложный значок блокировки. Если есть подозрения на наличие неполадок, выберите лист для отображения дополнительной информации.

Работа в группе без использования Диспетчера подшивок

При определенных ограничениях можно работать с подшивками в группах, в которых не все члены имеют доступ к локальной сети или к Диспетчеру подшивок. Возможно, эти участники команды используют программу AutoCAD LT или более раннюю версию AutoCAD. Это значит, что не все члены группы будут иметь доступ к файлу DST. Однако соответствующая информация из файла DST хранится (кэшируется) в каждом файле чертежа, а информация о подшивке, например настраиваемые свойства, сохраняется при совместном использовании файла чертежа членами группы.

При изменении информации в DST-файле членом группы может понадобиться обновление сведений в нескольких файлах чертежей. Для обновления листа подшивки следует при открытой подшивке открыть и сохранить этот лист.

Обновить все листы в подшивке автоматически можно с помощью команды контекстного меню подшивки "Сохранить все листы". Файлы чертежей, хранящиеся в формате предыдущего файла DWG, сохраняются без изменения формата.

Примечание При работе в сетевом окружении перед выполнением операции "Сохранить все листы" следует убедиться, что все файлы чертежей в текущей подшивке закрыты.


Сохранение всех листов в подшивке - Процедуры

Выбор рабочего процесса
Работа с листами в подшивке
Коллективная работа с подшивками
Понятия
Процедуры
Команды

Сохранение всех листов в подшивке

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" нажмите правую кнопку мыши на узле подшивки. Выберите в контекстном меню "Сохранить все листы".

    3. Все листы подшивки сохраняются. Эта операция приводит к обновлению хранимой в каждом файле чертежа информации, относящейся к подшивке.

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Коллективная работа с подшивками - Команды

Работа с листами в подшивке
Работа с листами в подшивке
Коллективная работа с подшивками
Понятия
Процедуры
Команды

Команды
ПОДШИВКА | Вызов диспетчера подшивок
ПОДШИВКАОТКЛ | Закрытие диспетчера подшивок
ПШОТКРЫТЬ | Открывает выбранную подшивку
ПШСОЗДАТЬ | Создание новой подшивки
Системные переменные
SSFOUND | Отображает имя файла и путь, полученные при успешном поиске подшивки
SSLOCATE | Управляет местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа.
SSMAUTOOPEN | Управляет режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой.
SSMSTATE | Определяет активность окна Диспетчера подшивок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и редактирование объектов

Свойства объектов
Управление объектами чертежа, их отображением и выводом на печать осуществляется путем изменения свойств объектов: слоя, типа линии, цвета, веса линии и стиля печати.

Средства обеспечения точности
В распоряжении пользователя имеются различные средства, обеспечивающие быстрое и точное построение чертежей без выполнения утомительных расчетов.

Построение геометрических объектов
Все чертежи состоят из объектов. Как правило, при рисовании объектов точки задаются либо с помощью устройства указания, либо вводом значений координат в командной строке.

Создание и использование блоков (символов)
Блоком называется совокупность связанных объектов чертежа, обрабатываемых как единый объект. Объединение объектов в блоки облегчает повторное использование их как внутри одного чертежа, так и в других чертежах.

Методы редактирования
В данной главе описывается, как выбирать объекты, просматривать и редактировать их свойства, а также выполнять различные действия по редактированию объектов.


Создание и редактирование объектов - Понятия

Создание и редактирование объектов
Создание и редактирование объектов
Создание и редактирование объектов
Понятия
Процедуры
Команды

Управление объектами чертежа, их отображением и выводом на печать осуществляется путем изменения свойств объектов: слоя, типа линии, цвета, веса линии и стиля печати.

В распоряжении пользователя имеются различные средства, обеспечивающие быстрое и точное построение чертежей без выполнения утомительных расчетов.

Все чертежи состоят из объектов. Как правило, при рисовании объектов точки задаются либо с помощью устройства указания, либо вводом значений координат в командной строке.

Управление объектами чертежа, их отображением и выводом на печать осуществляется путем изменения свойств объектов: слоя, типа линии, цвета, веса линии и стиля печати.


Создание и редактирование объектов - Процедуры

Создание и редактирование объектов
Создание и редактирование объектов
Создание и редактирование объектов
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Создание и редактирование объектов - Команды

Создание и редактирование объектов
Создание и редактирование объектов
Создание и редактирование объектов
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Свойства объектов - Понятия

Создание и редактирование объектов
Свойства объектов
Понятия
Процедуры
Команды

Управление объектами чертежа, их отображением и выводом на печать осуществляется путем изменения свойств объектов: слоя, типа линии, цвета, веса линии и стиля печати.

  • Коротко о свойствах объектов
  • Отображение и редактирование свойств объектов
    Пользователь имеет возможность просматривать и редактировать текущие значения свойств любого объекта чертежа.
  • Копирование свойств объектов
    Для частичного или полного копирования свойств одного объекта в другой или несколько других объектов используется функция "Копирование свойств".
  • Работа со слоями
    Слои подобны лежащим друг на друге прозрачным листам кальки, на которых размещаются различные группы данных чертежа.
  • Работа с цветом
    Цвет помогает группировать объекты визуально. Пользователь может назначать цвета объектам по слоям или индивидуально.
  • Работа с типами линий
    Типы линий применяются для того, чтобы можно было отличить один объект от другого, тем самым, делая работу с чертежом более удобной.
  • Работа с весами линий
    Веса линий могут применяться для графического выделения различных объектов как на экране, так и при выводе на печать.
  • Управление отображением отдельных объектов
    Пользователь имеет возможность управлять экранным отображением и выводом на печать объектов (включая перекрывающиеся).


Свойства объектов - Процедуры

Создание и редактирование объектов
Свойства объектов
Понятия
Процедуры
Команды

Для отключения области пояснений на палитре "Свойства"

Для просмотра свойств одного объекта

Для получения информации из базы данных чертежа о нескольких выбранных объектах

Для отображения координат точки

Для изменения свойств объектов в палитре "Свойства"

Для копирования свойств объекта в другие объекты

Для установки текущего слоя

Копирование объекта на другой слой

Динамическое отображение слоев

Фильтры списка слоев

Создание и сохранение фильтра слоев в диалоговом окне "Обход слоя"

Включение или выключение активного фильтра слоев

Включение или выключение опции "Показывать всегда" в диалоговом окне "Обход слоя"

Очистка неиспользуемых слоев с помощью диалогового окна "Обход слоя"

Перемещение объекта в текущий слой

Удаление слоя методом выбора объекта слоя

Замораживание слоя методом выбора объекта слоя

Размораживание всех слоев

Отображение выбранных слоев и отключение всех остальных слоев

Восстановление параметров слоя при закрытии диалогового окна "Обход слоя"

Восстановление состояний слоя чертежа после изолирования слоя

Изолирование слоя объекта в текущий видовой экран

Включение и отключение слоя с помощью панели "Слои"

Включение всех слоев

Отключение слоя путем выбора объекта слоя

Копирование свойств слоя в другие слои

Объединение выбранных слоев в слое назначения

Для назначения цвета слою

Изменение свойств нескольких слоев

Скрытие области структуры в окне "Диспетчер свойств слоев"

Скрытие столбца в окне "Диспетчер свойств слоев"

Для создания нового слоя

Для удаления неиспользуемого слоя

Для удаления всех неиспользуемых слоев

Для изменения слоя одного или нескольких объектов

Для назначения слою типа линий для использования по умолчанию

Для переименования слоя

Для переименования более одного слоя

Для отмены изменений параметров слоя

Для включения и отключения режима отслеживания состояний слоев

Для быстрой фильтрации отображения слоев по именам

Для фильтрации отображения слоев по свойствам

Для фильтрации отображения имен слоев путем явного выбора

Для вложения фильтра слоев в другой фильтр слоев

Для сортировки списка слоев в "Диспетчере свойств слоев"

Для удаления слоя из группового фильтра слоев

Для сохранения именованной конфигурации слоев

Экспорт конфигураций слоев

Для восстановления сохраненной конфигурации слоев

Для изменения именованной конфигурации слоев

Для импорта сохраненных конфигураций слоев из другого чертежа

Для задания цвета создаваемых объектов по ИЦА

Для задания цвета создаваемых объектов из полной палитры

Для задания цвета создаваемых объектов из альбома

Перенос объекта на другой слой

Для назначения цвета слою

Для явного назначения цвета объекту

Для подключения альбома цветов

Для поиска цвета в альбоме

Для изменения местоположения альбома цветов, принятого по умолчанию

Для задания нескольких папок с альбомами цветов

Загрузка типа линий

Для получения списка типов линий, загруженных в текущий чертеж

Для получения списка типов линий из файла описаний типов линий

Для удаления неиспользуемого типа линий

Для очистки чертежа от неиспользуемых типов линий

Для задания типа линий вновь создаваемых объектов

Для назначения типа линий слою

Для назначения слою типа линий, которые будут использоваться по умолчанию

Для назначения типа линий объекту для использования вместо типа линий слоя

Для изменения масштаба типа линий объектов

Для задания масштаба типа линий новых объектов

Для задания глобального масштаба типов линий

Для задания режима генерации типов линий во вновь создаваемых полилиниях

Для изменения режима генерации типов линий в имеющихся полилиниях

Для назначения ширины полилиниям

Назначение веса линий слою

Для задания масштаба экранного отображения весов линий в пространстве модели

Для отображения объектов с учетом весов линий

Для установки веса линий вновь создаваемых объектов

Изменение толщины линий, из которых состоят полилинии, кольца, прямоугольники и многоугольники

Для включения и отключения закраски

Включение и отключение вывода текста

Включение и отключение весов линий

Для изменения порядка следования перекрывающихся объектов


Свойства объектов - Команды

Создание и редактирование объектов
Свойства объектов
Понятия
Процедуры
Команды
Команды
БВЫБОР | Быстрое создание набора объектов на основе заданных критериев фильтрации
ВЕСЛИН | Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
ЗАКРАСИТЬ | Управление закрашиванием таких объектов, как штриховки, фигуры и широкие полилинии
КООРД | Определение координат точек
КОПИРОВАТЬСВ | Копирование свойств выбранного объекта в другие объекты
КОПИЯВСЛОЙ | Копирует один или более объектов в другой слой
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
НОВОЕИМЯ | Изменяет имена именованных объектов
ОКНОСВЗАКР | Закрытие палитры свойств
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
ПБЛОК | Запись объектов или блока в новый файл чертежа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПЛИНИЯ | Построение двумерных полилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
ПОРЯДОК | Изменение порядка прорисовки растровых изображений и других объектов на экран
РЕГЕН | Регенерация чертежа и перерисовка содержимого текущего видового экрана
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
СВОЙСТВА | Изменяет свойства объекта
СЛОЙ | Управление слоями и их свойствами
СЛОЙВКЛ | Включает все слои
СЛОЙЗМР | Замораживает слой выбранных объектов
СЛОЙИЗМНЕСК | Делает слой выбранных объектов соответствующим слою назначения.
СЛОЙОБЪЕД | Объединение выбранных слоев в слое назначения
СЛОЙОТД | Изолирует слой выбранных объектов так, что все другие слои выключаются.
СЛОЙОТДОТМ | Включает слои, которые были выключены последней командой СЛОЙОТД
СЛОЙОТКЛ | Выключает слой выбранного объекта
СЛОЙП | Отмена последних изменений состояний и свойств слоев
СЛОЙПРЕЖИМ | Включение и отключение режима записи последовательности изменений свойств слоев.
СЛОЙРМР | Размораживает все слои
СЛОЙТЕК | Делает слой выбранных объектов текущим
СЛОЙУДАЛ | Удаляет слой выбранных объектов и все объекты на слое, удаляет слой с чертежа
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
ТЕКСТПЕРПЛАН | Размещение текста и размеров поверх всех остальных объектов чертежа
ТИПЛИН | Загрузка, установка и изменение типов линий
Цвет | Установка цвета для вновь создаваемых объектов
Системные переменные
CECOLOR | Установка цвета для новых объектов.
CELTSCALE | Установка текущего коэффициента масштабирования для типа линий объекта.
CELTYPE | Установка типа линии для новых объектов.
CLAYER | Установка имени текущего слоя
DRAWORDERCTL | Управляет порядком отображения перекрывающихся объектов
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPDRAWORDER | Управляет порядком прорисовки штриховки или заливки
LUPREC | Определяет количество десятичных знаков, отображаемых для нередактируемых линейных единиц и для всех редактируемых линейных единиц, исходная точность которых меньше или равна значению текущей системной переменной LUPREC.
LWDISPLAY | Управляет отображением веса линий
MAXSORT | Устанавливает максимальное количество имен символов или имен файлов, которое можно отсортировать с помощью команд вывода списков
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
MEASUREMENT | Определяет, какие единицы используются в файлах образцов штриховки или типов линий текущего чертежа
OPMSTATE | Сохраняет значение, которое указывает состояние Палитры свойств: открыта или нет
PALETTEOPAQUE | Управляет прозрачностью окон
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
PLINEGEN | Управляет созданием типа линии вокруг вершин двухмерных полилиний
PLINEWID | Хранит значение ширины полилинии по умолчанию
PSLTSCALE | Управляет масштабированием типов линий в пространстве листа
QTEXTMODE | Управляет отображением текста
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о свойствах объектов - Понятия

Создание и редактирование объектов
Свойства объектов
Коротко о свойствах объектов
Понятия
Процедуры
Команды

Все объекты обладают теми или иными свойствами. Некоторые свойства являются общими для большинства объектов - например, слой, цвет, тип линий и стиль печати. Другие же свойства характерны только для определенных объектов - например, окружность характеризуется радиусом и площадью, а отрезок - длиной и углом наклона.

Общие свойства объекта определяются либо описанием слоя, на котором он создается, либо задаются пользователем.

  • В случае, когда установлено значение ПОСЛОЮ, свойства объекта определяются свойствами слоя, на котором он создается.

    • Например, если отрезок создан на слое 0 и этому слою присвоен красный цвет, то при значении цвета ПОСЛОЮ отрезок также будет красным.

  • В случае, когда свойство задается явно, оно обладает преимуществом перед свойством, унаследованным от слоя.

    • Например, если отрезку, созданному на слое 0, явно назначен синий цвет, а слою 0 назначен красный цвет, то отрезок будет синим.

См. также

Цвета и типы линий объектов в блоках


Свойства объектов

Создание и редактирование объектов
Свойства объектов
Свойства объектов
Понятия
Процедуры
Команды

Нет процедур, относящихся к этому разделу.


Коротко о свойствах объектов - Команды

Свойства объектов
Свойства объектов
Коротко о свойствах объектов
Понятия
Процедуры
Команды

Команды
ОКНОСВЗАКР | Закрытие палитры свойств
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Отображение и редактирование свойств объектов - Понятия

Создание и редактирование объектов
Свойства объектов
Отображение и редактирование свойств объектов
Понятия
Процедуры
Команды

Для просмотра и редактирования текущих значений свойств любого объекта чертежа имеются следующие способы:

  • Откройте палитру свойств; просмотрите и при необходимости внесите изменения в свойства объекта.
  • Просмотрите и внесите необходимые изменения в списке "Слои" панели "Слои", а также при необходимости измените цвет, тип линий, вес линий и стиль печати в списках панели "Свойства".
  • Воспользуйтесь командой СПИСОК для просмотра данных в текстовом окне.
  • Воспользуйтесь командой ID для просмотра координат объектов.
Воспользуйтесь палитрой свойств

В палитре "Свойства" указаны текущие свойства выбранного объекта или набора объектов. Любое свойство объекта может быть изменено путем задания нового значения.

  • В случае, когда выбраны несколько объектов, палитра "Свойства" отображает только свойства, характерные для всех выбранных объектов.
  • В случае, когда не выбран ни один объект, палитра "Свойства" отображает общие свойства текущего слоя, название таблицы стилей печати, подключенной к слою, а также свойства вида и данные о ПСК.

Если системная переменная DBLCLKEDIT активна (по умолчанию), можно для большинства объектов открывать палитру "Свойства" двойным нажатием на объекте. Исключением являются блоки и атрибуты, штриховка, градиентная заливка, текст, мультилинии и внешние ссылки. При двойном щелчке мышью на любом из этих объектов вместо палитры "Свойства" будет вызвано диалоговое окно для данного объекта.

Примечание Двойное нажатие действует при условии, что активна системная переменная DBLCLKEDIT и активна (переведена в состояние 1, состояние по умолчанию) системная переменная PICKFIRST.

См. также

Цвета и типы линий объектов в блоках

Фильтрация наборов объектов

Задание параметров интерфейса


Отображение и редактирование свойств объектов - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение и редактирование свойств объектов
Понятия
Процедуры
Команды

Для отключения области пояснений на палитре "Свойства"

Для просмотра свойств одного объекта

Для получения информации из базы данных чертежа о нескольких выбранных объектах

Для отображения координат точки

Для изменения свойств объектов в палитре "Свойства"


Для отключения области пояснений на палитре "Свойства" - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение и редактирование свойств объектов
Понятия
Процедуры
Команды

Для отключения области пояснений на палитре "Свойства"

  1. На палитре свойства нажмите правую кнопку мыши на титульной строке.
  2. В контекстном меню отключите опцию "Пояснение".


Для просмотра свойств одного объекта - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение и редактирование свойств объектов
Понятия
Процедуры
Команды

Для просмотра свойств одного объекта

  1. Выберите объект.
  2. Нажмите правой кнопкой мыши на чертеже. Нажмите кнопку "Свойства".

    3. В палитре "Свойства" отображаются свойства выбранного объекта.

    Для большинства объектов палитру "Свойства" можно также вызвать двойным щелчком на объекте.

Панель "Стандартная"

Ввод команды: ОКНОСВ


Для получения информации из базы данных чертежа о нескольких выбранных объектах - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение и редактирование свойств объектов
Понятия
Процедуры
Команды

Для получения информации из базы данных чертежа о нескольких выбранных объектах

  1. Выберите в меню "Сервис" » "Сведения" » "Список".
  2. Выберите один или несколько объектов и нажмите ENTER.

    3. Сведения о выбранных объектах выводятся в текстовое окно.

Панель "Сведения"

Ввод команды: СПИСОК


Для отображения координат точки - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение и редактирование свойств объектов
Понятия
Процедуры
Команды

Для отображения координат точки

  1. Выберите в меню "Сервис" » "Сведения" » "Координаты".
  2. Укажите точку, значения координат которой необходимо отобразить.

    3. Значения координат X, Y и Z выводятся в командной строке.

Панель "Сведения"

Ввод команды: КООРД


Для изменения свойств объектов в палитре "Свойства" - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение и редактирование свойств объектов
Понятия
Процедуры
Команды

Для изменения свойств объектов в палитре "Свойства"

  1. Выберите один или несколько объектов.
  2. Нажмите правой кнопкой мыши на чертеже. Нажмите кнопку "Свойства".
  3. Для просмотра перечня свойств можно пользоваться полосой прокрутки, которая расположена в палитре "Свойства" рядом со строкой заголовка. Нажатие стрелки справа от каждой категории сворачивает и разворачивает перечень относящихся к ней свойств.
  4. Выберите значение, которое требуется изменить; для его изменения воспользуйтесь одним из следующих способов:
    • Введите новое значение.
    • Нажмите стрелку вниз справа от свойства и выберите необходимое значение из списка.
    • Нажмите кнопку "Указать точку" и с помощью курсора измените значения координат.
    • Нажмите кнопку калькулятора QuickCalc, чтобы вычислить новое значение.
    • Чтобы увеличить или уменьшить значение, нажмите стрелку влево или вправо.
    • Нажмите кнопку [...] и измените значение свойства в диалоговом окне.

    Вносимые изменения тут же отображаются на чертеже.

  5. Чтобы отменить изменение, нажмите правой кнопкой мыши в пустой области в палитре "Свойства". Выберите команду "Отменить".
  6. Для отмены выбора нажмите ESC.

Панель "Стандартная"

Ввод команды: ОКНОСВ


Отображение и редактирование свойств объектов - Команды

Свойства объектов
Свойства объектов
Отображение и редактирование свойств объектов
Понятия
Процедуры
Команды

Команды
КООРД | Определение координат точек
ОКНОСВЗАКР | Закрытие палитры свойств
СВОЙСТВА | Изменяет свойства объекта
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
Системные переменные
LUPREC | Определяет количество десятичных знаков, отображаемых для нередактируемых линейных единиц и для всех редактируемых линейных единиц, исходная точность которых меньше или равна значению текущей системной переменной LUPREC.
OPMSTATE | Сохраняет значение, которое указывает состояние Палитры свойств: открыта или нет
PALETTEOPAQUE | Управляет прозрачностью окон
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Копирование свойств объектов - Понятия

Создание и редактирование объектов
Свойства объектов
Копирование свойств объектов
Понятия
Процедуры
Команды

Для частичного или полного копирования свойств одного объекта в другой или несколько других объектов используется функция "Копирование свойств".

Можно копировать цвет, слой, тип линий, масштаб типа линий, вес линий, стиль печати, трехмерную высоту и другие свойства.

По умолчанию все переносимые свойства копируются из первого выбранного объекта в другие объекты. Для того, чтобы запретить копирование определенных свойств, можно воспользоваться опцией "Настройки", указав свойства, которые нельзя копировать. Опцию "Настройки" можно применять в любое время выполнения команды копирования свойств.


Для копирования свойств объекта в другие объекты - Процедуры

Создание и редактирование объектов
Свойства объектов
Копирование свойств объектов
Понятия
Процедуры
Команды

Для копирования свойств объекта в другие объекты

  1. Выберите панель "Стандартная" » "Копировать свойства".
  2. Выберите объект, свойства которого необходимо скопировать.
  3. Если необходимо, для задания копируемых свойств введите н (Настройки). В диалоговом окне "Настройки свойств" сбросьте флажки свойств, которые не должны копироваться. По умолчанию все флажки установлены. Нажмите "ОК".
  4. Укажите объекты для применения выбранных свойств и нажмите ENTER.

Панель "Стандартная"

Ввод команды: КОПИРОВАТЬСВ


Копирование свойств объектов - Команды

Свойства объектов
Свойства объектов
Копирование свойств объектов
Понятия
Процедуры
Команды

Команды
КОПИРОВАТЬСВ | Копирование свойств выбранного объекта в другие объекты
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа со слоями - Понятия

Создание и редактирование объектов
Свойства объектов
Работа со слоями
Понятия
Процедуры
Команды

Слои подобны лежащим друг на друге прозрачным листам кальки, на которых размещаются различные группы данных чертежа.

  • Коротко о слоях
    Слои позволяют структурировать чертеж, что упрощает управление данными чертежа и различными свойствами, такими как типы линий, цвета и др.
  • Применение слоев для организации чертежей
    С помощью слоев можно управлять свойствами и отображением объектов. Блокируя отдельные слои, можно запрещать редактирование объектов.
  • Создание и именование слоев
    Послойная организация чертежа упрощает управление объектами и их редактирование.
  • Редактирование параметров и свойств слоев
    Пользователь имеет возможность изменять имя слоя и его свойства, такие как цвет и тип линий. Кроме того, объекты, расположенные на слое, можно перенести на другой слой.
  • Фильтрация и сортировка слоев в списке
    Диспетчер свойств слоев позволяет задавать условия для ограничения числа отображаемых слоев в списке, а также сортировать слои по именам или свойствам (например, по цвету или по признаку видимости).
  • Сохранение и восстановление конфигураций слоев
    Имеется возможность сохранения конфигураций слоев в чертеже и их последующего восстановления.


Работа со слоями - Процедуры

Создание и редактирование объектов
Свойства объектов
Работа со слоями
Понятия
Процедуры
Команды

Для установки текущего слоя

Копирование объекта на другой слой

Динамическое отображение слоев

Фильтры списка слоев

Создание и сохранение фильтра слоев в диалоговом окне "Обход слоя"

Включение или выключение активного фильтра слоев

Включение или выключение опции "Показывать всегда" в диалоговом окне "Обход слоя"

Очистка неиспользуемых слоев с помощью диалогового окна "Обход слоя"

Перемещение объекта в текущий слой

Удаление слоя методом выбора объекта слоя

Замораживание слоя методом выбора объекта слоя

Размораживание всех слоев

Отображение выбранных слоев и отключение всех остальных слоев

Восстановление параметров слоя при закрытии диалогового окна "Обход слоя"

Восстановление состояний слоя чертежа после изолирования слоя

Изолирование слоя объекта в текущий видовой экран

Включение и отключение слоя с помощью панели "Слои"

Включение всех слоев

Отключение слоя путем выбора объекта слоя

Копирование свойств слоя в другие слои

Объединение выбранных слоев в слое назначения

Для назначения цвета слою

Изменение свойств нескольких слоев

Скрытие области структуры в окне "Диспетчер свойств слоев"

Скрытие столбца в окне "Диспетчер свойств слоев"

Для создания нового слоя

Для удаления неиспользуемого слоя

Для удаления всех неиспользуемых слоев

Для изменения слоя одного или нескольких объектов

Для назначения слою типа линий для использования по умолчанию

Для переименования слоя

Для переименования более одного слоя

Для отмены изменений параметров слоя

Для включения и отключения режима отслеживания состояний слоев

Для быстрой фильтрации отображения слоев по именам

Для фильтрации отображения слоев по свойствам

Для фильтрации отображения имен слоев путем явного выбора

Для вложения фильтра слоев в другой фильтр слоев

Для сортировки списка слоев в "Диспетчере свойств слоев"

Для удаления слоя из группового фильтра слоев

Для сохранения именованной конфигурации слоев

Экспорт конфигураций слоев

Для восстановления сохраненной конфигурации слоев

Для изменения именованной конфигурации слоев

Для импорта сохраненных конфигураций слоев из другого чертежа


Работа со слоями - Команды

Создание и редактирование объектов
Свойства объектов
Работа со слоями
Понятия
Процедуры
Команды
Команды
КОПИЯВСЛОЙ | Копирует один или более объектов в другой слой
НОВОЕИМЯ | Изменяет имена именованных объектов
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
СВОЙСТВА | Изменяет свойства объекта
СЛОЙ | Управление слоями и их свойствами
СЛОЙВКЛ | Включает все слои
СЛОЙЗМР | Замораживает слой выбранных объектов
СЛОЙИЗМНЕСК | Делает слой выбранных объектов соответствующим слою назначения.
СЛОЙОБЪЕД | Объединение выбранных слоев в слое назначения
СЛОЙОТД | Изолирует слой выбранных объектов так, что все другие слои выключаются.
СЛОЙОТДОТМ | Включает слои, которые были выключены последней командой СЛОЙОТД
СЛОЙОТКЛ | Выключает слой выбранного объекта
СЛОЙП | Отмена последних изменений состояний и свойств слоев
СЛОЙПРЕЖИМ | Включение и отключение режима записи последовательности изменений свойств слоев.
СЛОЙРМР | Размораживает все слои
СЛОЙТЕК | Делает слой выбранных объектов текущим
СЛОЙУДАЛ | Удаляет слой выбранных объектов и все объекты на слое, удаляет слой с чертежа
Системные переменные
CLAYER | Установка имени текущего слоя
MAXSORT | Устанавливает максимальное количество имен символов или имен файлов, которое можно отсортировать с помощью команд вывода списков
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о слоях - Понятия

Создание и редактирование объектов
Свойства объектов
Коротко о слоях
Понятия
Процедуры
Команды

Слои позволяют структурировать чертеж, что упрощает управление данными чертежа и различными свойствами, такими как типы линий, цвета и др.

Слои напоминают лежащие друг на друге прозрачные листы кальки. Слои являются основным средством упорядочивания на чертеже. Они позволяют сгруппировать информацию по функциям и упрощают управление различными свойствами, такими как типы линий, цвета и др.

Слои позволяют группировать однотипные объекты. Например, такие объекты, как вспомогательные линии, тексты, размеры и основные надписи можно разместить на отдельных слоях. Послойная организация объектов позволяет:

  • Легко подавлять и включать отображение объектов слоя на видовых экранах
  • Разрешать, запрещать и настраивать вывод объектов на печать
  • Назначать цвет одновременно всем объектам слоя
  • Задавать тип и вес линий по умолчанию для всех объектов слоя
  • Разрешать или запрещать редактирование объектов слоя

Каждый чертеж имеет слой с именем 0. Слой 0 не может быть ни удален, ни переименован. Он предназначен для двух целей:

  • Обеспечение того, чтобы каждый чертеж содержал, по крайней мере, один слой
  • Предоставление специального слоя, связанного с управлением цветами в блоках

Примечание Вместо того чтобы создавать весь чертеж на слое 0, рекомендуется для организации чертежа создать несколько новых слоев.


Работа со слоями

Создание и редактирование объектов
Свойства объектов
Работа со слоями
Понятия
Процедуры
Команды

Нет процедур, относящихся к этому разделу.


Коротко о слоях - Команды

Свойства объектов
Свойства объектов
Коротко о слоях
Понятия
Процедуры
Команды

Команды
СЛОЙ | Управление слоями и их свойствами
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Применение слоев для организации чертежей - Понятия

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

С помощью слоев можно управлять свойствами и отображением объектов. Блокируя отдельные слои, можно запрещать редактирование объектов.

Пользователь имеет возможность управлять сложностью отображаемого чертежа и ускорять прорисовку путем определения объектов, которые надо включить или напечатать. Например, слои позволяют работать со свойствами и отображением однотипных объектов, таких, например, как детали электрических цепей или размеры. Кроме того, выборочное блокирование слоев позволяет предотвратить случайный выбор и редактирование тех или иных объектов.

Управление видимостью объектов на слое

Отключая или замораживая слои чертежа, можно подавлять их отображение. Это позволяет упростить вид для работы с определенным слоем или упростить выводимый на печать чертеж, запретив, например, вывод вспомогательных линий. Выбор способа отключения видимости слоев зависит от характера использования слоев и от сложности чертежа.

  • Вкл/Откл. Объекты на отключенных слоях невидимы, но они по-прежнему скрывают объекты при использовании команды СКРЫТЬ. При включении или отключении слоев чертеж не регенерируется.
  • Замораживание/Размораживание. Объекты на замороженных слоях невидимы и не скрывают другие объекты. Операция размораживания одного или более слоев приводит к регенерации чертежа. Операции замораживания и размораживания слоев отнимает больше времени, чем простое включение и отключение слоев.

В пространстве листа можно делать слои видимыми на отдельных видовых экранах.

Задание слою цвета и типа линий по умолчанию

Любому слою можно назначить такие свойства, как цвет и тип линий, которые наследуются всеми объектами данного слоя. Например, если на панели свойств в списке "Цвет" указать значение ПОСЛОЮ, цвет новых объектов определяется настройкой цвета слоя в "Диспетчере свойств слоев".

Если в управляющем списке "Цвета" задать определенный цвет, то он будет назначаться всем новым объектам вместо цвета, назначенного текущему слою. То же самое можно сказать и об управляющих списках "Типы линий", "Веса линий" и "Стили печати" панели "Свойства".

Значение ПОБЛОКУ можно использовать только при создании блоков. См. раздел Цвета и типы линий объектов в блоках.

Запрет редактирования объектов на слое

Блокирование слоя позволяет запретить редактирование всех объектов на слое до тех пор, пока слой не будет разблокирован. Таким образом можно устанавливать защиту чертежа от случайного внесения в него нежелательных изменений. На блокированных слоях по-прежнему имеется возможность использования режимов объектной привязки и выполнения других операций, не связанных с редактированием объектов.


Применение слоев для организации чертежей - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Для установки текущего слоя

Копирование объекта на другой слой

Динамическое отображение слоев

Фильтры списка слоев

Создание и сохранение фильтра слоев в диалоговом окне "Обход слоя"

Включение или выключение активного фильтра слоев

Включение или выключение опции "Показывать всегда" в диалоговом окне "Обход слоя"

Очистка неиспользуемых слоев с помощью диалогового окна "Обход слоя"

Перемещение объекта в текущий слой

Удаление слоя методом выбора объекта слоя

Замораживание слоя методом выбора объекта слоя

Размораживание всех слоев

Отображение выбранных слоев и отключение всех остальных слоев

Восстановление параметров слоя при закрытии диалогового окна "Обход слоя"

Восстановление состояний слоя чертежа после изолирования слоя

Изолирование слоя объекта в текущий видовой экран

Включение и отключение слоя с помощью панели "Слои"

Включение всех слоев

Отключение слоя путем выбора объекта слоя

Копирование свойств слоя в другие слои

Объединение выбранных слоев в слое назначения

Для назначения цвета слою

Изменение свойств нескольких слоев

Скрытие области структуры в окне "Диспетчер свойств слоев"

Скрытие столбца в окне "Диспетчер свойств слоев"


Для установки текущего слоя - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Для установки текущего слоя

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Сделать текущим слой с объектами".
  2. Выберите объект на слое, который нужно сделать текущим.

Панель "Слои"

Ввод команды: СЛОЙУСТЕК


Копирование объекта на другой слой - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Копирование объекта на другой слой

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Копировать объекты в новый слой".
  2. Выберите объекты для копирования.
  3. Нажмите ENTER.
  4. Выберите объект на слое, в который требуется поместить скопированный объект.
  5. Выполните одно из следующих действий:
    • Для размещения объекта на слое назначения укажите базовую точку, затем вторую точку.
    • Введите значения относительных координат смещения в декартовой, полярной, цилиндрической или сферической системе координат. На запрос второй точки смещения нажмите ENTER.

Панель "Слои II"

Ввод команды: КОПИЯВСЛОЙ


Динамическое отображение слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Динамическое отображение слоев

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Обход слоя".
  2. Чтобы просмотреть объекты слоя, выберите его в диалоговом окне "Обход слоя". Для просмотра нескольких слоев, выберите их при нажатой клавише CTRL.

    3. На чертеже отображаются объекты на выбранных слоях.

  3. Нажмите кнопку "Закрыть".

Панель "Слои II"

Ввод команды: СЛОЙОБХ


Фильтры списка слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Фильтры списка слоев

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Обход слоя".
  2. В списке "Фильтр" диалогового окна "Обход слоя" выполните одно из следующих действий:
    • Введите имя существующего фильтра или выберите фильтр в раскрывающемся списке "Фильтр".
    • Введите критерии фильтра (используя специальные символы) для создания списка требуемых слоев. Например, если требуется показать слои с именами от 0 до 3, введите критерий фильтра [0-3]*.

      • Примечание Подробней об использовании специальных символов см. раздел "Специальные символы" в Фильтрация и сортировка слоев в списке.

    Список слоев содержит слои, определенные фильтром.

  3. Нажмите кнопку "Закрыть".

Панель "Слои II"

Ввод команды: СЛОЙОБХ


Создание и сохранение фильтра слоев в диалоговом окне "Обход слоя" - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Создание и сохранение фильтра слоев в диалоговом окне "Обход слоя"

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Обход слоя".
  2. В списке "Фильтр" диалогового окна "Обход слоя" введите (используя специальные символы) критерии фильтра для отображения нужных слоев. Например, если требуется показать слои с именами от 0 до 3, введите критерий фильтра [0-3]*.

    3. Примечание Подробней об использовании специальных символов см. раздел "Специальные символы" в Фильтрация и сортировка слоев в списке.

  3. Нажмите правую кнопку мыши, затем выберите "Сохранить текущий фильтр".
  4. Нажмите кнопку "Закрыть".

Панель "Слои II"

Ввод команды: СЛОЙОБХ


Включение или выключение активного фильтра слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Включение или выключение активного фильтра слоев

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Обход слоя".
  2. В списке "Фильтр" диалогового окна "Обход слоя" введите имя существующего фильтра или выберите фильтр в раскрывающемся списке "Фильтр".
  3. Чтобы отобразить или скрыть слои в списке слоев текущего фильтра, установите или снимите флажок "Фильтр". Отображение слоев в чертеже при этом не меняется.
  4. Нажмите кнопку "Закрыть".

Панель "Слои II"

Ввод команды: СЛОЙОБХ


Включение или выключение опции "Показывать всегда" в диалоговом окне "Обход слоя" - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Включение или выключение опции "Показывать всегда" в диалоговом окне "Обход слоя"

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Обход слоя".
  2. В списке "Слои" диалогового окна "Обход слоя" дважды нажмите имя слоя, для которого нужно установить опцию "Показывать всегда". Для выбора нескольких слоев, нажмите SHIFT и дважды нажмите на дополнительных слоях.

    3. Слева от слоя с включенной опцией "Показывать всегда" отображается символ звездочки (*). Эти слои отображаются в чертеже независимо от условий активного фильтра.

  3. Нажмите кнопку "Закрыть".

Панель "Слои II"

Ввод команды: СЛОЙОБХ


Очистка неиспользуемых слоев с помощью диалогового окна "Обход слоя" - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Очистка неиспользуемых слоев с помощью диалогового окна "Обход слоя"

  1. Откройте чертеж с одним или несколькими неиспользуемыми слоями, которые требуется очистить.
  2. Выберите в меню "Формат" » "Инструменты слоя" » "Обход слоя".
  3. Нажмите правую кнопку мыши в диалоговом окне "Обход слоя". Выберите опцию "Выбрать неиспользуемые".

    4. Выбираются все неиспользуемые слои.

    Примечание Кнопка "Очистить" активна только в том случае, если выбранные слои являются неиспользуемыми.

  4. Нажмите "Очистить".
  5. Нажмите кнопку "Закрыть".

Примечание Кроме того, очистку слоев можно выполнить с помощью "Диспетчера свойств слоев". См. раздел "Удаление неиспользуемых слоев"

Ввод команды: СЛОЙОБХ

Панель "Слои II"


Перемещение объекта в текущий слой - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Перемещение объекта в текущий слой

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Сменить на текущий слой".
  2. Выберите объекты, которые нужно переместить в текущий слой.
  3. Нажмите ENTER.

Панель "Слои II"

Ввод команды: СЛОЙТЕК


Удаление слоя методом выбора объекта слоя - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Удаление слоя методом выбора объекта слоя

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Удалить слой".
  2. Выберите объект на слое, который требуется удалить.
  3. Нажмите ENTER.

    4. Все объекты на выбранном слое, а также сам слой, будут удалены.

Ввод команды: СЛОЙУДАЛ


Замораживание слоя методом выбора объекта слоя - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Замораживание слоя методом выбора объекта слоя

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Заморозить слой".
  2. Выберите объекты на слое, который требуется заморозить.
  3. Нажмите ENTER.

    4. Выбранный слой заморожен.

Панель "Слои II"

Ввод команды: СЛОЙЗМР


Размораживание всех слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Размораживание всех слоев

  • Выберите в меню "Формат" » "Инструменты слоя" » "Разморозить все слои".

    • Все слои (кроме замороженных в видовом экране) размораживаются.

Ввод команды: СЛОЙРМР


Отображение выбранных слоев и отключение всех остальных слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Отображение выбранных слоев и отключение всех остальных слоев

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Изолировать слой".
  2. Выберите объект на слое, который требуется изолировать.
  3. Нажмите ENTER.

    4. Выбранный слой изолируется.

    Примечание Для восстановления исходного состояния слоев (до изолирования) используется команда СЛОЙОТДОТМ. Все измененные параметры слоя сохраняются.

Панель "Слои II"

Ввод команды: СЛОЙОТД


Восстановление параметров слоя при закрытии диалогового окна "Обход слоя" - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Восстановление параметров слоя при закрытии диалогового окна "Обход слоя"

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Обход слоя".
  2. В диалоговом окне "Обход слоя" выберите слой для просмотра его объектов. Для выбора нескольких слоев нажмите слой в списке и протащите курсор по слоям, которые требуется просмотреть.
  3. Выполните одно из следующих действий:
    • Для возврата к первоначальному виду при закрытии диалогового окна установите флажок "Восстановить при выходе".
    • Для отображения только выбранных слоев при возврате к чертежу, снимите флажок "Восстановить при выходе".
  4. Нажмите кнопку "Закрыть".

Панель "Слои II"

Ввод команды: СЛОЙОБХ


Восстановление состояний слоя чертежа после изолирования слоя - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Восстановление состояний слоя чертежа после изолирования слоя

  • После изолирования слоя и (при необходимости) других его изменений введите в командную строку команду СЛОЙОТДОТМ.

    • Чертеж будет восстановлен до конфигурации слоев, сохраненной перед изолированием.

Панель "Слои II"

Ввод команды: СЛОЙОТДОТМ


Изолирование слоя объекта в текущий видовой экран - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Изолирование слоя объекта в текущий видовой экран

  1. Перейдите на вкладку "Лист".
  2. Выберите в меню "Формат" » "Инструменты слоя" » "Изолировать слой в текущий видовой экран".
  3. Выберите объект на слое, который требуется изолировать. Нажмите ENTER.

    4. Выбранный слой изолируется во всех видовых экранах, кроме текущего.

Ввод команды: СЛОЙОВЭ


Включение и отключение слоя с помощью панели "Слои" - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Включение и отключение слоя с помощью панели "Слои"

  1. На панели "Слои" выберите "Диспетчер свойств слоев".
  2. В "Диспетчере свойств слоев" нажмите значок с изображением лампочки у имени того слоя, который требуется включить или отключить.

    3. Если значок желтый, то слой включен.

Панель "Слои"

Ввод команды: СЛОЙ


Включение всех слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Включение всех слоев

  • Выберите в меню "Формат" » "Инструменты слоя" » "Включить все слои".

    • Все слои в чертеже включаются.

Ввод команды: СЛОЙВКЛ


Отключение слоя путем выбора объекта слоя - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Отключение слоя путем выбора объекта слоя

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Отключить слой".
  2. Выберите объект на слое, который требуется отключить. Нажмите ENTER.

Панель "Слои II"

Ввод команды: СЛОЙОТКЛ


Копирование свойств слоя в другие слои - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Копирование свойств слоя в другие слои

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Соответствие слоев".
  2. Выберите объекты на слое, который требуется изменить. Нажмите ENTER.
  3. Выберите объект на слое, на который требуется переместить объект.

    4. Объект перемещается на выбранный слой.

Панель "Слои II"

Ввод команды: СЛОЙИЗМНЕСК


Объединение выбранных слоев в слое назначения - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Объединение выбранных слоев в слое назначения

  1. Выберите в меню "Формат" » "Инструменты слоя" » "Объединить слой".
  2. Выберите объект на слое, который требуется удалить. Нажмите ENTER.
  3. Выберите объект слоя, на котором требуется объединить все объекты из первого слоя.

    4. Объекты из первого слоя перемещаются на выбранный слой, а первый слой удаляется.

Ввод команды: СЛОЙОБЪЕД


Для назначения цвета слою - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Для назначения цвета слою

  1. Выберите в меню "Формат" » "Слои".
  2. В области "Диспетчер свойств слоев" выберите слой. Выберите значок цвета.
  3. В диалоговом окне "Выбор цвета" выберите цвет.
  4. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.

Панель "Слои II"

Ввод команды: СЛОЙ


Изменение свойств нескольких слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Изменение свойств нескольких слоев

  1. Выберите в меню "Формат" » "Слои".
  2. В списке окна "Диспетчер свойств слоев" для выбора нескольких слоев можно воспользоваться одним из следующих способов:
    • Нажмите клавишу CTRL и выберите имена нужных слоев.
    • Нажмите правую кнопку мыши. Выберите "Показать фильтры в списке", чтобы появился флажок, а затем выберите фильтр слоев.
  3. Выберите значки свойств, которые требуется изменить.
  4. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.

Панель "Слои"

Ввод команды: СЛОЙ


Скрытие области структуры в окне "Диспетчер свойств слоев" - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Скрытие области структуры в окне "Диспетчер свойств слоев"

  • Нажмите правую кнопку мыши на списке. Снимите флажок "Показать дерево фильтров".


Скрытие столбца в окне "Диспетчер свойств слоев" - Процедуры

Создание и редактирование объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Скрытие столбца в окне "Диспетчер свойств слоев"

  • Перетащите правую разделительную линию столбца налево до тех пор, пока столбец не окажется скрыт.

Чтобы вновь показать столбец, необходимо перетащить разделительную линию столбца направо.


Применение слоев для организации чертежей - Команды

Свойства объектов
Свойства объектов
Применение слоев для организации чертежей
Понятия
Процедуры
Команды

Команды
КОПИЯВСЛОЙ | Копирует один или более объектов в другой слой
СЛОЙ | Управление слоями и их свойствами
СЛОЙВКЛ | Включает все слои
СЛОЙЗМР | Замораживает слой выбранных объектов
СЛОЙИЗМНЕСК | Делает слой выбранных объектов соответствующим слою назначения.
СЛОЙОБЪЕД | Объединение выбранных слоев в слое назначения
СЛОЙОТД | Изолирует слой выбранных объектов так, что все другие слои выключаются.
СЛОЙОТДОТМ | Включает слои, которые были выключены последней командой СЛОЙОТД
СЛОЙОТКЛ | Выключает слой выбранного объекта
СЛОЙРМР | Размораживает все слои
СЛОЙТЕК | Делает слой выбранных объектов текущим
СЛОЙУДАЛ | Удаляет слой выбранных объектов и все объекты на слое, удаляет слой с чертежа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и именование слоев - Понятия

Создание и редактирование объектов
Свойства объектов
Создание и именование слоев
Понятия
Процедуры
Команды

Послойная организация чертежа упрощает управление объектами и их редактирование.

Для каждой связанной группы элементов чертежа (стен, размеров и т.п.) можно создать отдельный слой с определенными свойствами. Послойная организация чертежа упрощает управление объектами и их редактирование.

Число слоев в чертеже и объектов на каждом слое не ограничено. Как правило, слои объединяют однотипные объекты (например, стены или размеры). Имена слоев могут включать в себя до 255 алфавитно-цифровых символов. Во многих случаях имена слоев задаются согласно определенным соглашениям, принятым в организации, отрасли или у заказчика.

В списке "Диспетчера свойств слоев" имена слоев сортируются в алфавитном порядке. К выбору имен для создаваемых слоев следует подходить продуманно. Для того чтобы эффективно применять для поиска слоев фильтры со специальными символами, в именах слоев можно использовать префиксы, логически объединяющие связанные компоненты чертежа.

Примечание Если в различных чертежах приходится часто применять один и тот же набор слоев с определенными параметрами (цветами, типами, толщиной линий, стилями печати), то этот набор слоев целесообразно сохранить в шаблоне. Подробнее о создании шаблонов см. раздел Использование файла шаблона для создания чертежа.

Копирование слоев из других чертежей

Для копирования слоев из одного чертежа в другой методом перетаскивания ™ можно использовать DesignCenter. Пусть, например, имеется базовый чертеж, в котором уже созданы все необходимые для проекта слои. Пользователь может создать новый чертеж и с помощью DesignCenter перетащить в новый чертеж все описания слоев из базового. Это экономит время и гарантирует соблюдение установленной системы слоев во всем проекте.

Перетаскивать слои или копировать слои можно также двойным нажатием мыши или путем выбора команды "Вставить" в контекстном меню.

Примечание При перетаскивании слоев из DesignCenter AutoCAD необходимо разрешать конфликты, связанные с повторяющимися именами.

Выбор слоя для рисования

В процессе рисования вновь создаваемые объекты располагаются на текущем слое. Текущим может быть слой 0 или любой другой слой, созданный и именованный пользователем. Пользователь может переключаться с одного слоя на другой, меняя тем самым текущий слой; все создаваемые далее объекты размещаются на новом текущем слое и используют его цвет, тип линий и другие свойства. Замороженные слои и слои, описанные во внешних ссылках, нельзя сделать текущими.

Удаление слоев

Неиспользуемые слои можно удалять командой ОЧИСТИТЬ или удалением их имен из списка в "Диспетчере свойств слоев". Можно удалять только неиспользуемые слои. Невозможно удалить слои 0 и DEFPOINTS, слои с объектами (включая объекты в определениях блоков), текущий слой, а также слои, зависимые от внешних ссылок.

Предупреждение Следует с особой осторожностью удалять слои, совместно используемые несколькими пользователями, или применяемые в качестве стандартных.


Создание и именование слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Создание и именование слоев
Понятия
Процедуры
Команды

Для создания нового слоя

Для удаления неиспользуемого слоя

Для удаления всех неиспользуемых слоев


Для создания нового слоя - Процедуры

Создание и редактирование объектов
Свойства объектов
Создание и именование слоев
Понятия
Процедуры
Команды

Для создания нового слоя

  1. Выберите в меню "Формат" » "Слои".
  2. В "Диспетчере свойств слоев" нажмите кнопку "Создать слой".

    3. В список слоев автоматически добавляется слой, например, СЛОЙ1.

  3. Введите новое имя вместо предложенного по умолчанию.

    4. Имя слоя не должно превышать 255 знаков. Оно может состоять из букв, цифр и специальных символов (знак доллара ($), минус (-) и знак подчеркивания (_). Перед другими специальными символами следует ввести обратный апостроф (`), чтобы эти символы не интерпретировались как специальные. В именах нельзя использовать пробелы.

  4. Для изменения свойств слоя щелкните мышью на нужном значке.

    5. Нажатие значков "Цвет", "Тип линий", "Вес линий" или "Стиль печати" приводит к вызову соответствующего диалогового окна.

  5. (Если требуется) Выберите столбец "Пояснение" и введите текст.
  6. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.

Панель "Слои"

Ввод команды: СЛОЙ


Для удаления неиспользуемого слоя - Процедуры

Создание и редактирование объектов
Свойства объектов
Создание и именование слоев
Понятия
Процедуры
Команды

Для удаления неиспользуемого слоя

  1. На панели "Слои" нажмите кнопку "Диспетчер свойств слоев".
  2. В "Диспетчере свойств слоев" выберите слой. Нажмите кнопку "Удалить слой".

    3. Слой, на котором размещаются объекты, удалить нельзя. Необходимо сначала перенести объекты на другой слой или стереть их. Слои 0 и DEFPOINTS, а также текущий слой, удалить нельзя.

  3. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.

    4. Выбранный слой удаляется.

Панель "Слои"

Ввод команды: СЛОЙ


Для удаления всех неиспользуемых слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Создание и именование слоев
Понятия
Процедуры
Команды

Для удаления всех неиспользуемых слоев

  1. Выберите в меню "Файл" » "Утилиты » "Очистить".

    2. Открывается диалоговое окно "Очистка чертежа", отображающее дерево объектов, которые можно удалить из чертежа.

  2. Для удаления неиспользуемых слоев можно воспользоваться одним из следующих способов:
    • Для очистки чертежа от всех неиспользуемых слоев выберите "Слои".
    • Для очистки чертежа от определенных слоев дважды щелкните на элементе "Слои" для раскрытия следующего уровня. Выберите слои для удаления из списка.
  3. Если нужные элементы отсутствуют в списке, включите опцию "Просмотреть элементы, которые нельзя удалить", выбрерите слой и прочитайте объяснение.
  4. Удаление каждого элемента из списка требуется подтвердить. Для подавления запросов перед каждым удалением можно предварительно отключить опцию "Удаление элементов с подтверждением".
  5. Нажмите "Очистить".
  6. В ответ на запрос перед каждым удалением следует нажимать "Да", "Нет" или "Да для всех" для удаления сразу всех выбранных элементов.
  7. Нажмите кнопку "Закрыть".

Ввод команды: ОЧИСТИТЬ


Создание и именование слоев - Команды

Свойства объектов
Свойства объектов
Создание и именование слоев
Понятия
Процедуры
Команды

Команды
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
СЛОЙ | Управление слоями и их свойствами
Системные переменные
CLAYER | Установка имени текущего слоя
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование параметров и свойств слоев - Понятия

Создание и редактирование объектов
Свойства объектов
Редактирование параметров и свойств слоев
Понятия
Процедуры
Команды

Пользователь имеет возможность изменять имя слоя и его свойства, такие как цвет и тип линий. Кроме того, объекты, расположенные на слое, можно перенести на другой слой.

Поскольку все элементы чертежа связаны со слоями, при планировании и создании чертежа, возможно, потребуется изменить состав элементов, размещаемых на слоях или способ просмотра комбинации слоев. Пользователь может:

  • Переносить объекты с одного слоя на другой.
  • Изменять имя слоя.
  • Изменять принятые по умолчанию цвет, тип линий и другие свойства слоя.

Возможность переноса объектов может оказаться полезной в случае создания объекта не на том слое или при необходимости перераспределения объектов между слоями. Если свойства объекта не заданы явно, то после переноса он получает свойства того слоя, на котором он теперь расположен.

Свойства слоя можно изменять в "Диспетчере свойств слоев" или в управляющем списке "Слои" на панели "Слои". Для этого следует выбрать соответствующий значок. Для редактирования имен и цветов слоев использовать управляющий список "Слои" нельзя. Эти операции выполняются только в "Диспетчере свойств слоев".

Отмена изменений параметров слоя

Изменения параметров слоя можно отменить командой возврата к предыдущему состоянию слоев (СЛОЙП). Например, с ее помощью после замораживания слоев и редактирования каких-то геометрических объектов чертежа можно достаточно просто разморозить слои, не затрагивая изменений геометрии. Команда также полезна, если изменено множество свойств слоев (цвета, типы линий и др.), но затем принято решение о возврате к исходным параметрам.

Команда возврата к предыдущему состоянию слоев позволяет отменить самые последние изменения, внесенные в параметры и свойства слоев с помощью управляющего списка "Слои" или "Диспетчера свойств слоев". Это возможно благодаря постоянному отслеживанию каждого вносимого в параметры слоя изменения. Когда отслеживать изменения не нужно, - например, при работе со сценариями большого размера, - отслеживание можно отключить с помощью команды СЛОЙПРЕЖИМ. Отключение отслеживания несколько увеличивает производительность.

Команда возврата к предыдущему состоянию слоев не может отменять следующие действия:

  • Переименование слоев. После переименования слоя и изменения его свойств команда "Предыдущее состояние слоев" восстанавливает исходные свойства, но не имя слоя.
  • Удаление слоев. После удаления или очистки слоя он не восстанавливается с помощью команды "Предыдущее состояние слоев".
  • Создание слоев. После создания нового слоя он не удаляется с помощью команды "Предыдущее состояние слоев".


Редактирование параметров и свойств слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Редактирование параметров и свойств слоев
Понятия
Процедуры
Команды

Для изменения слоя одного или нескольких объектов

Для назначения слою типа линий для использования по умолчанию

Для переименования слоя

Для переименования более одного слоя

Для отмены изменений параметров слоя

Для включения и отключения режима отслеживания состояний слоев


Для изменения слоя одного или нескольких объектов - Процедуры

Создание и редактирование объектов
Свойства объектов
Редактирование параметров и свойств слоев
Понятия
Процедуры
Команды

Для изменения слоя одного или нескольких объектов

  1. Выберите объекты, которые необходимо перенести на другой слой.
  2. На панели "Слои" выберите управляющий список "Слои".
  3. Выберите слой, на который требуется перенести объекты.
  4. Нажмите ESC для отмены выделения.

Панель "Слои"


Для назначения слою типа линий для использования по умолчанию - Процедуры

Создание и редактирование объектов
Свойства объектов
Редактирование параметров и свойств слоев
Понятия
Процедуры
Команды

Для назначения слою типа линий для использования по умолчанию

  1. Выберите в меню "Формат" » "Слои".
  2. В окне "Диспетчер свойств слоев" выберите заменяемый тип линий для слоя.
  3. Если необходимого типа линий нет в диалоговом окне "Выбор типа линий", нажмите кнопку "Загрузить" и используйте один из следующих способов:
    • В диалоговом окне "Загрузка/перезагрузка типов линий" выберите один или более типов линий для загрузки. Нажмите кнопку "ОК" для возврата в диалоговое окно "Выбор типа линий".
    • В диалоговом окне "Загрузка/перезагрузка типов линий" выберите "Файл" для открытия дополнительных файлов определения типов линий (LIN). Выберите один или несколько типов линий для загрузки. Нажмите кнопку "ОК" для возврата в диалоговое окно "Выбор типа линий".
  4. Выберите наобходимый тип линии. Нажмите кнопку "ОК" для возврата в "Диспетчер свойств слоев".
  5. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.

Панель "Слои"

Ввод команды: СЛОЙ


Для переименования слоя - Процедуры

Создание и редактирование объектов
Свойства объектов
Редактирование параметров и свойств слоев
Понятия
Процедуры
Команды

Для переименования слоя

  1. Выберите в меню "Формат" » "Слои".
  2. В области "Диспетчер свойств слоев" выберите слой. Выберите имя или нажмите клавишу F2.
  3. Введите новое имя.
  4. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.

Панель "Слои"

Ввод команды: СЛОЙ


Для переименования более одного слоя - Процедуры

Создание и редактирование объектов
Свойства объектов
Редактирование параметров и свойств слоев
Понятия
Процедуры
Команды

Для переименования более одного слоя

  1. В командной строке введите rename.
  2. В диалоговом окне "Задание нового имени" в списке именованных объектов выберите "Слои".
  3. В поле "Старое имя" введите старое имя, используя специальные символы; например, введите stairs$*.
  4. В поле "Новое имя" введите новое имя, используя специальные символы; например, введите s_*.

    5. В этом примере будут следующие результаты: слои STAIR$LEVEL-1, STAIR$LEVEL-2, STAIR$LEVEL-3 будут переименованы в S_LEVEL-1, S_LEVEL-2, S_LEVEL-3.

  5. Нажмите кнопку "Новое имя" для применения изменений и продолжения операции для других слоев, или нажмите "ОК".


Для отмены изменений параметров слоя - Процедуры

Создание и редактирование объектов
Свойства объектов
Редактирование параметров и свойств слоев
Понятия
Процедуры
Команды

Для отмены изменений параметров слоя

  • На панели "Слои" нажмите кнопку "Предыдущее состояние слоев".

В командной строке появляется сообщение “Предыдущее состояние слоев восстановлено. ”

Примечание Команда СЛОЙП не восстанавливает удаленные или очищенные слои и не удаляет добавленные в чертеж слои. После переименования слоя и изменения его свойств команда СЛОЙП восстанавливает исходные свойства, но не имя слоя.

Панель "Слои"

Ввод команды: СЛОЙП


Для включения и отключения режима отслеживания состояний слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Редактирование параметров и свойств слоев
Понятия
Процедуры
Команды

Для включения и отключения режима отслеживания состояний слоев

  1. В командной строке введите слойпрежим.

    2. Выводится текущее состояние режима отслеживания.

  2. Введите вкл для включения режима слежения за состоянием слоев или откл для его отключения.

Ввод команды: СЛОЙПРЕЖИМ


Редактирование параметров и свойств слоев - Команды

Свойства объектов
Свойства объектов
Редактирование параметров и свойств слоев
Понятия
Процедуры
Команды

Команды
НОВОЕИМЯ | Изменяет имена именованных объектов
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
СВОЙСТВА | Изменяет свойства объекта
СЛОЙ | Управление слоями и их свойствами
СЛОЙП | Отмена последних изменений состояний и свойств слоев
СЛОЙПРЕЖИМ | Включение и отключение режима записи последовательности изменений свойств слоев.
Системные переменные
CLAYER | Установка имени текущего слоя
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Фильтрация и сортировка слоев в списке - Понятия

Создание и редактирование объектов
Свойства объектов
Фильтрация и сортировка слоев в списке
Понятия
Процедуры
Команды

Диспетчер свойств слоев позволяет задавать условия для ограничения числа отображаемых слоев в списке, а также сортировать слои по именам или свойствам (например, по цвету или по признаку видимости).

Фильтр слоев ограничивает отображение имен слоев в окне "Диспетчера свойств слоев" и в управляющем списке слоев на панели "Слои". В большом чертеже пользователь может использовать фильтры слоев для отображения только тех слоев, которые нужны для работы.

Есть два типа фильтров слоев:

  • Фильтры по свойствам: Включают слои, имеющие сходные имена или другие свойства. Например, пользователь может определить фильтр, который включает все красные слои, в чьих именах есть последовательность mech.
  • Групповые фильтры: Включают слои, явно заданные пользователем, вне зависимости от их имен и свойств.

В области структуры "Диспетчера свойств слоев" отображены стандартные фильтры слоев и все именованные фильтры, созданные и сохраненные в текущем чертеже. Тип фильтра обозначается значком около фильтра слоев. Имеется три стандартных фильтра:

  • Все. Задает отображение всех слоев текущего чертежа.
  • Все используемые слои. Задает отображение всех слоев текущего чертежа, на которых нарисованы объекты.
  • Внешние ссылки. Если в чертеж вставлены внешние ссылки, фильтр задает отображение всех определенных в них слоев.

Задав имя и определив фильтр слоев, пользователь может выбрать его в области структуры для отображения слоев, удовлетворяющих фильтру, в списке. Можно применить фильтр к панели "Слои", чтобы в списке "Слой" отображались только те слои, которые определяются текущим фильтром.

При выборе фильтра в области структуры и нажатии правой кнопкой мыши появляется контекстное меню, опции которого можно использовать для удаления, переименования и изменения фильтров. Например, пользователь может преобразовать какой-либо фильтр слоев по свойствам в групповой фильтр. Пользователь может также изменить свойства всех слоев в фильтре. Опция "Выделить группу" отключает все слои чертежа, которые не находятся в выбранном фильтре.

Определение фильтра слоев по свойствам

Фильтр по свойствам определяется в диалоговом окне "Свойства фильтра слоев", где пользователь может выбрать любые из следующих свойств, определяющих фильтр:

  • Имена, цвета, типы линий, веса линий и стили печати
  • Используются ли слои
  • Включены/отключены ли слои
  • Заморожены/разморожены слои на текущем видовом экране или на всех видовых экранах
  • Блокированы/разблокированы
  • Печатаемые/не печатаемые

Для фильтрации слоев по именам можно использовать специальные символы. Например, если необходимо отобразить только те слои, имена которых начинаются с символов mech, то надо ввести mech*. Полный список специальных символов см. в разделе “Символы-шаблоны”.

Набор слоев в фильтре по свойствам может меняться при изменения свойств слоев. Например, если пользователь определил фильтр по свойствам с именем "Участок", включающий все слои с именами, где есть подстрока участок, и типом линий CONTINUOUS, а затем изменил тип линий некоторых из этих слоев, то слои с измененными типами линий уже не будут входить в фильтр "Участок" и не будут отображаться при использовании данного фильтра.

Фильтры по свойствам могут быть вложенными в другие фильтры по свойствам или в групповые фильтры.

Определение группового фильтра слоев

Групповой фильтр слоев включает только те слои, которые были явно занесены туда пользователем. Если свойства слоев, назначенных данному фильтру, были изменены, то, несмотря на это, данные слои будут продолжать входить в этот фильтр. Групповые фильтры слоев могут быть вложенными, но только в другие групповые фильтры (а не в фильтры по свойствам).

Инвертирование фильтра слоев

Пользователь может инвертировать фильтр слоев. Например, если все элементы плана участка располагаются на слоях, имена которых содержат слово участок, то для отображения всех остальных слоев необходимо создать фильтр, который отфильтровывает слои по строке *участок*, и установить флажок "Инвертировать фильтр".

Сортировка слоев

Создав слои, пользователь может отсортировать их по именам или по другим свойствам. Для сортировки списка следует в "Диспетчере свойств слоев" нажать на заголовке столбца того свойства, по которому должны сортироваться слои. Имена слоев могут быть отсортированы по возрастанию или по убыванию.

Специальные символы

Для сортировки слоев по именам можно использовать специальные символы.

Символ | Пояснение
# (Решетка) | Соответствует любой одиночной цифре
@ (At) | Соответствует любой одиночной букве
. (Точка) | Соответствует любому символу, кроме букв и цифр
* (Звездочка) | Соответствует любой последовательности символов. Может использоваться в любой позиции строки
? (Знак вопроса) | Соответствует любому одиночному символу; например, ?BC соответствует ABC, 3BC и т.п.
~ (Тильда) | Соответствует всем строкам, кроме отвечающих следующему после тильды шаблону; например, ~*AB* соответствует всем строкам, не содержащим последовательности AB
[ ] | Соответствует любому из символов в скобках; например, [AB]C соответствует AC и BC
[~] | Соответствует любому из символов, кроме заключенных в скобки; например, [~AB]C соответствует XC, но не соответствует BC
[-] | Задает диапазон для одиночного символа; например, [A-G]C соответствует AC, BC и так далее до GC, но не соответствует HC
' (Апостроф) | Следующий за ним специальный символ трактуется как обычный; например, '~AB соответствует ~AB

Примечание Если необходимо использовать специальный символ в имени объекта, то для того, чтобы этот символ не интерпретировался как специальный, необходимо поставить перед ним апостроф (').


Фильтрация и сортировка слоев в списке - Процедуры

Создание и редактирование объектов
Свойства объектов
Фильтрация и сортировка слоев в списке
Понятия
Процедуры
Команды

Для быстрой фильтрации отображения слоев по именам

Для фильтрации отображения слоев по свойствам

Для фильтрации отображения имен слоев путем явного выбора

Для вложения фильтра слоев в другой фильтр слоев

Для сортировки списка слоев в "Диспетчере свойств слоев"

Для удаления слоя из группового фильтра слоев


Для быстрой фильтрации отображения слоев по именам - Процедуры

Создание и редактирование объектов
Свойства объектов
Фильтрация и сортировка слоев в списке
Понятия
Процедуры
Команды

Для быстрой фильтрации отображения слоев по именам

  1. Выберите в меню "Формат" » "Слои".
  2. В "Диспетчере свойств слоев" нажмите в поле "Поиск слоя" под областью структуры.
  3. (Если потребуется) Для ограничения поиска выберите фильтр в области структуры.
  4. Введите текст для поиска, включая специальные символы.

    5. В списке отображаются только те слои, имена которых совпадают с введенной строкой. Например, если ввести *mech*, то отобразятся все слои, имена которых содержат подстроку mech.

    Этот быстрый фильтр сбрасывается при закрытии Диспетчера свойств слоев.


Для фильтрации отображения слоев по свойствам - Процедуры

Создание и редактирование объектов
Свойства объектов
Фильтрация и сортировка слоев в списке
Понятия
Процедуры
Команды

Для фильтрации отображения слоев по свойствам

  1. Выберите в меню "Формат" » "Слои".
  2. В "Диспетчере свойств слоев" нажмите кнопку "Новый фильтр по свойствам".
  3. В диалоговом окне "Свойства фильтра слоев" введите имя фильтра.
  4. В области "Описание фильтра" установите свойства слоя, которые необходимо использовать для определения фильтра.
    • Для фильтрации по именам можно использовать специальные символы.
    • Для фильтрации по свойствам следует нажать соответствующий столбец таблицы.

      • При нажатии на кнопку [...] около некоторых свойств происходит вызов диалогового окна.

    • Для выбора более одного значения свойства необходимо щелкнуть правой кнопкой мыши на строке в описании фильтра. Выберите "Создать копию строки". Выберите другое значение для данного свойства в следующей строке.

      • Например, определение для фильтра, отображающего только включенные и либо желтые, либо красные слои, имеет две строки. Первая строка определения фильтра имеет значок "Вкл", а в качестве цвета в ней установлен красный. Вторая строка имеет значок "Вкл", а в качестве цвета в ней установлен желтый.

  5. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.

Панель "Слои"

Ввод команды: СЛОЙ


Для фильтрации отображения имен слоев путем явного выбора - Процедуры

Создание и редактирование объектов
Свойства объектов
Фильтрация и сортировка слоев в списке
Понятия
Процедуры
Команды

Для фильтрации отображения имен слоев путем явного выбора

  1. На панели "Слои" выберите "Диспетчер свойств слоев".
  2. В "Диспетчере свойств слоев" нажмите кнопку "Новый групповой фильтр".

    3. В области структуры создается новый групповой фильтр слоев с именем ГРУППОВОЙ ФИЛЬТР1.

  3. Введите имя фильтра.
  4. В области структуры щелкнуть на узле "Все" или одном из других узлов для отображения слоев в списке.
  5. В списке выделите слои, которые надо добавить в фильтр, и перетащите их на имя фильтра в области структуры.
  6. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.

Панель "Слои"

Ввод команды: СЛОЙ


Для вложения фильтра слоев в другой фильтр слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Фильтрация и сортировка слоев в списке
Понятия
Процедуры
Команды

Для вложения фильтра слоев в другой фильтр слоев

  1. На панели "Слои" выберите "Диспетчер свойств слоев".
  2. В области структуры окна "Диспетчер свойств слоев" выделите фильтр слоев.
    • Фильтр слоев по свойствам может быть вложен в групповой фильтр или другой фильтр по свойствам.
    • Групповой фильтр слоев может быть вложен только в другой групповой фильтр.
  3. Нажмите правую кнопку мыши. Выберите "Новый фильтр по свойствам" или "Новый групповой фильтр".
  4. Воспользуйтесь одним из следующих способов:
    • Для нового фильтра по свойствам открывается диалоговое окно "Свойства фильтра слоев". В области "Описание фильтра" установите свойства слоя, которые необходимо использовать для определения фильтра. Нажмите "ОК".
    • Для нового группового фильтра в области структуры добавляется новый фильтр. Следует задать ему имя, выбрать фильтр, в который он вкладывается (для отображения его слоев в списке), и затем перетащить слои из списка в новый групповой фильтр слоев.
  5. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.

Панель "Слои"

Ввод команды: СЛОЙ


Для сортировки списка слоев в "Диспетчере свойств слоев" - Процедуры

Создание и редактирование объектов
Свойства объектов
Фильтрация и сортировка слоев в списке
Понятия
Процедуры
Команды

Для сортировки списка слоев в "Диспетчере свойств слоев"

  • Нажмите на заголовке любого столбца.

Для изменения порядка сортировки на обратный нажмите второй раз.

Панель "Слои"

Ввод команды: СЛОЙ


Для удаления слоя из группового фильтра слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Фильтрация и сортировка слоев в списке
Понятия
Процедуры
Команды

Для удаления слоя из группового фильтра слоев

  1. На панели "Слои" выберите "Диспетчер свойств слоев".
  2. В области структуры окна "Диспетчер свойств слоев" выделите групповой фильтр.
  3. Выберите слой для удаления.
  4. Нажмите правой кнопкой мыши в списке. Выберите "Удалить из группового фильтра".

Панель "Слои"

Ввод команды: СЛОЙ


Фильтрация и сортировка слоев в списке - Команды

Свойства объектов
Свойства объектов
Фильтрация и сортировка слоев в списке
Понятия
Процедуры
Команды

Команды
СЛОЙ | Управление слоями и их свойствами
Системные переменные
MAXSORT | Устанавливает максимальное количество имен символов или имен файлов, которое можно отсортировать с помощью команд вывода списков
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение и восстановление конфигураций слоев - Понятия

Создание и редактирование объектов
Свойства объектов
Сохранение и восстановление конфигураций слоев
Понятия
Процедуры
Команды

Имеется возможность сохранения конфигураций слоев в чертеже в виде состояний слоев и их последующего восстановления. Сохранение конфигурации слоев удобно, когда есть необходимость в быстром возвращении к конкретным настройкам всех слоев в ходе различных этапов создания чертежа или для печати.

Сохранение конфигураций слоев

Конфигурации слоев включают такие настройки, как состояние включенности или блокировки, и такие свойства слоев, как цвет или тип линий. В именованной конфигурации слоев пользователь может выбрать состав запоминаемых состояний и свойств слоев, которые необходимо будет восстановить позднее. Например, можно сохранять только признак замороженности слоя, игнорируя все остальные параметры. В этом случае при восстановлении все параметры слоев, кроме признака замороженности каждого слоя, останутся без изменений.

С помощью "Диспетчера конфигураций слоев" именованные конфигурации слоев можно экспортировать в LAS-файл для использования в других чертежах. Состояния слоев, зависимых от внешних ссылок, в экспорте не участвуют.

Восстановление конфигураций слоев

При восстановлении именованной конфигурации слоев, настройки слоев (из состава запоминаемых состояний и свойств слоев), которые были текущими при сохранении этой конфигурации слоев, восстанавливаются. Поскольку все свойства слоев сохраняются в именованной конфигурации слоев, пользователь может определять различные свойства в момент восстановления. Все свойства слоев, которые не были выделены для восстановления, остаются без изменения.

Слой, который был текущим при сохранении именованной конфигурации, при восстановлении назначается текущим. Если этот слой уже не существует, то текущий слой не изменяется.

Пользователь может импортировать именованные конфигурации слоев, которые были ранее экспортированы в LAS-файлы.


Сохранение и восстановление конфигураций слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Сохранение и восстановление конфигураций слоев
Понятия
Процедуры
Команды

Для сохранения именованной конфигурации слоев

Экспорт конфигураций слоев

Для восстановления сохраненной конфигурации слоев

Для изменения именованной конфигурации слоев

Для импорта сохраненных конфигураций слоев из другого чертежа


Для сохранения именованной конфигурации слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Сохранение и восстановление конфигураций слоев
Понятия
Процедуры
Команды

Для сохранения именованной конфигурации слоев

  1. Выберите в меню "Формат" » "Слои".
  2. В "Диспетчере свойств слоев" нажмите кнопку "Диспетчер конфигураций слоев".
  3. В "Диспетчере конфигураций слоев"Диспетчер конфигураций слоев нажмите кнопку "Создать".
  4. В диалоговом окне "Сохранение новой конфигурации слоев" введите имя новой конфигурации слоев или выберите имя из списка.
  5. (Не обязательно) Добавьте текстовое пояснение.
  6. Нажмите "ОК".
  7. В "Диспетчере конфигураций слоев" выберите настройки слоев, которые будут впоследствии восстанавливаться.
  8. (Не обязательно) Выберите опцию "Отключить слои, отсутствующие в конфигурации".

    9. Если эта опция выбрана, то при восстановлении именованной конфигурации слоев чертеж будет выглядеть так же, как он выглядел при сохранении именованной конфигурации слоев.

  9. Нажмите кнопку "Закрыть" для выхода из Диспетчера конфигураций слоев. Нажмите "ОК" для выхода из Диспетчера свойств слоев.

Панель "Слои"

Ввод команды: СЛОЙ


Экспорт конфигураций слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Сохранение и восстановление конфигураций слоев
Понятия
Процедуры
Команды

Экспорт конфигураций слоев

  1. Выберите в меню "Формат" » "Слои".
  2. В "Диспетчере свойств слоев" нажмите кнопку "Диспетчер конфигураций слоев".
  3. В "Диспетчере конфигураций слоев" выберите именованную конфигурацию слоев. Нажмите кнопку "Экспорт".
  4. В диалоговом окне "Экспорт конфигурации слоев" введите имя файла. Определите расположение для файла конфигурации (LAS).

    5. Расширение имени файла .las добавляется автоматически.

  5. Для выхода из диалогового окна нажмите кнопку "Сохранить".
  6. Нажмите кнопку "Закрыть" для выхода из Диспетчера конфигураций слоев. Нажмите "ОК" для выхода из Диспетчера свойств слоев.

Панель "Слои"

Ввод команды: СЛОЙ


Для восстановления сохраненной конфигурации слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Сохранение и восстановление конфигураций слоев
Понятия
Процедуры
Команды

Для восстановления сохраненной конфигурации слоев

  1. Выберите в меню "Формат" » "Слои".
  2. В "Диспетчере свойств слоев" нажмите кнопку "Диспетчер конфигураций слоев".
  3. В "Диспетчере конфигураций слоев" выберите именованную конфигурацию слоев.
  4. Выберите параметры для восстановления. Нажмите кнопку "Восстановить".

    5. Диспетчер конфигураций слоев закрывается.

  5. Нажмите "ОК".

Панель "Слои"

Ввод команды: СЛОЙ


Для изменения именованной конфигурации слоев - Процедуры

Создание и редактирование объектов
Свойства объектов
Сохранение и восстановление конфигураций слоев
Понятия
Процедуры
Команды

Для изменения именованной конфигурации слоев

  1. Выберите в меню "Формат" » "Слои".
  2. В "Диспетчере свойств слоев" нажмите кнопку "Диспетчер конфигураций слоев".
  3. В "Диспетчере конфигураций" слоев выберите именованную конфигурацию слоев, которую надо изменить, переименовать или удалить.
  4. Воспользуйтесь одним из следующих способов:
    • Для переименования именованной конфигурации слоев нажмите на имени и введите новое имя.
    • Для изменения текстового пояснения нажмите на пояснении и введите новый текст.
    • Для удаления сохраненной конфигурации слоев нажмите "Удалить".
    • Для изменения восстанавливаемых по умолчанию настроек слоев установите или снимите соответствующие флажки в группе "Сохраняемые состояния слоев".
  5. Нажмите кнопку "Закрыть" для выхода из "Диспетчера конфигураций слоев". Нажмите "ОК" для выхода из "Диспетчера свойств слоев".

Панель "Слои"

Ввод команды: СЛОЙ


Для импорта сохраненных конфигураций слоев из другого чертежа - Процедуры

Создание и редактирование объектов
Свойства объектов
Сохранение и восстановление конфигураций слоев
Понятия
Процедуры
Команды

Для импорта сохраненных конфигураций слоев из другого чертежа

  1. Выберите в меню "Формат" » "Слои".
  2. В "Диспетчере свойств слоев" нажмите кнопку "Диспетчер конфигураций слоев".
  3. В "Диспетчере конфигураций слоев" нажмите кнопку "Импорт".
  4. В диалоговом окне "Импорт конфигурации слоев" выберите имя файла с расширением имени .las. Нажмите "Открыть".
  5. Нажмите "Да" для восстановления именованной конфигурации слоев. Нажмите "Нет" для добавления ее в "Диспетчере конфигураций слоев" без восстановления конфигурации.

    6. Если было выбрано восстановление именованной конфигурации слоев, то "Диспетчер конфигураций слоев" закрывается.

  6. Нажмите кнопку "Закрыть" для выхода из Диспетчера конфигураций слоев. Нажмите "ОК" для выхода из "Диспетчера свойств слоев".

Панель "Слои"

Ввод команды: СЛОЙ


Сохранение и восстановление конфигураций слоев - Команды

Свойства объектов
Свойства объектов
Сохранение и восстановление конфигураций слоев
Понятия
Процедуры
Команды

Команды
СЛОЙ | Управление слоями и их свойствами
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с цветом - Понятия

Создание и редактирование объектов
Свойства объектов
Работа с цветом
Понятия
Процедуры
Команды

Цвет помогает группировать объекты визуально. Пользователь может назначать цвета объектам по слоям или индивидуально.

  • Установка текущего цвета
    Использование различных цветов позволяет визуально идентифицировать объекты, облегчая тем самым работу с чертежом. Цвета можно присваивать как слоям, так и отдельным объектам чертежа.
  • Изменение цвета объекта
    Цвет объекта можно изменять, перенося объект на другой слой, изменяя цвет слоя, на котором расположен объект, или явно присваивая цвет самому объекту.
  • Работа с альбомами цветов
    При назначении цвета объектам можно пользоваться альбомами цветов. Работа с альбомами цветов позволяет оперировать широкой палитрой цвета. Альбомы цветов представляют собой файлы от стороннего производителя или пользовательские файлы, которые содержат именованные образцы цветов. Использование цветов из альбомов позволяет улучшить вид чертежа и готовить высококачественные презентационные материалы. Назначение цвета объекту осуществляется с помощью вкладки "Альбомы цветов" в диалоговом окне "Выбор цвета".


Работа с цветом - Процедуры

Создание и редактирование объектов
Свойства объектов
Работа с цветом
Понятия
Процедуры
Команды

Для задания цвета создаваемых объектов по ИЦА

Для задания цвета создаваемых объектов из полной палитры

Для задания цвета создаваемых объектов из альбома

Перенос объекта на другой слой

Для назначения цвета слою

Для явного назначения цвета объекту

Для подключения альбома цветов

Для поиска цвета в альбоме

Для изменения местоположения альбома цветов, принятого по умолчанию

Для задания нескольких папок с альбомами цветов


Работа с цветом - Команды

Создание и редактирование объектов
Свойства объектов
Работа с цветом
Понятия
Процедуры
Команды
Команды
СВОЙСТВА | Изменяет свойства объекта
Цвет | Установка цвета для вновь создаваемых объектов
Системные переменные
CECOLOR | Установка цвета для новых объектов.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Установка текущего цвета - Понятия

Создание и редактирование объектов
Свойства объектов
Установка текущего цвета
Понятия
Процедуры
Команды

Использование различных цветов позволяет визуально идентифицировать объекты, облегчая тем самым работу с чертежом. Цвета можно присваивать как слоям, так и отдельным объектам чертежа.

Цвета можно присваивать как слоям, так и отдельным объектам чертежа. Назначение определенного цвета каждому слою помогает идентифицировать слои в чертеже. Для того, чтобы создать дополнительные визуальные различия между объектами одного слоя, можно присвоить отдельные цвета объектам и их группам. Использование цветов позволяет идентифицировать линии различного назначения, когда чертеж выводится на плоттер с использованием цветозависимых стилей печати.

При назначении цвета объекту можно использовать разнообразные палитры. К ним относятся

  • &Индекс цветов AutoCAD (ACI)
  • Реалистичное цветовоспроизведение®, PANTONE®
  • Альбомы цветов RAL™ Classic и RAL Design
  • DIC® Color Guide
  • Цвета из импортированных альбомов цветов.
Цвета по ИЦА

ИЦА это стандартный набор цветов, используемых в AutoCAD. Задание цвета производится по стандартному имени или с помощью индекса цветов AutoCAD (ИЦА) в виде целого числового значения от 1 до 255. Стандартные имена присвоены только цветам с номерами от 1 до 7. Цвета назначаются следующим образом: 1 красный, 2 желтый, 3 зеленый, 4 голубой, 5 синий, 6 фиолетовый, 7 белый/черный.

Полная палитра цветов True Color

Полноцветный режим дает возможность выбора из 16 миллионов цветов. При назначении цвета в полноцветном режиме можно воспользоваться цветовой моделью RGB и HSL. В цветовой модели RGB задаются красная, зеленая, и синяя составляющие цвета; в цветовой модели HSL задаются оттенок, насыщенность и яркость цвета.

Альбомы цветов

Эта программа включает в себя несколько стандартных альбомов цветов Pantone. Пользователь также может импортировать другие альбомы, такие как цветовой справочник DIC или набор цветов RAL. Импортирование дополнительных альбомов цветов позволяет расширить палитру доступных цветов.

Примечание Pantone содержит новые описания цветов для альбомов цветов Architectural & Interiors Cotton и Architectural & Interiors Paper. Если вы использовали эти альбомы цветов в версиях до AutoCAD 2006, то вы можете заметить изменения в цветах.

Подключение альбомов цветов осуществляется с помощью вкладки "Файл" в диалоговом окне "Настройка". После загрузки альбома цветов выбранный цвет можно применить к любому объекту на чертеже.

Все новые объекты создаются с использованием текущего цвета, установленного в управляющем списке "Цвета" панели "Свойства". Текущий цвет можно установить не только с помощью управляющего списка "Цвета", но и в диалоговом окне "Выбор цвета".

Если установлен текущий цвет ПОСЛОЮ, то все вновь создаваемые объекты используют цвет, присвоенный текущему слою. Вместо того, чтобы использовать текущий цвет слоя, можно назначать цвета явным образом.

Если установлен текущий цвет ПОБЛОКУ, то объекты имеют цвет 7 (белый или черный) до тех пор, пока не будут объединены в блок. Вставляемым в чертеж блокам присваивается текущий цвет.


Установка текущего цвета - Процедуры

Создание и редактирование объектов
Свойства объектов
Установка текущего цвета
Понятия
Процедуры
Команды

Для задания цвета создаваемых объектов по ИЦА

Для задания цвета создаваемых объектов из полной палитры

Для задания цвета создаваемых объектов из альбома


Для задания цвета создаваемых объектов по ИЦА - Процедуры

Создание и редактирование объектов
Свойства объектов
Установка текущего цвета
Понятия
Процедуры
Команды

Для задания цвета создаваемых объектов по ИЦА

  1. На панели "Свойства" выберите управляющий список "Цвета".
  2. Выберите нужный цвет для использования при создании новых объектов или нажмите на пункте "Выбор цвета" для вызова одноименного диалогового окна, где выполните одно из действий:
    • На вкладке "Номер цвета" выберите цвет или введите в поле "Цвет" имя или порядковый номер цвета.
    • На вкладке "Номер цвета" выберите значение ПОСЛОЮ для построения новых объектов с текущим цветом слоя.
    • На вкладке "Номер цвета" выберите значение ПОБЛОКУ для построения новых объектов с текущим цветом слоя до их объединения в блок. При вставке блока его объектам присваивается текущий цвет, заданный в чертеже.
  3. Нажмите "ОК".

    4. Установленный текущий цвет отображается в управляющем списке "Цвета".

Ввод команды: ЦВЕТ


Для задания цвета создаваемых объектов из полной палитры - Процедуры

Создание и редактирование объектов
Свойства объектов
Установка текущего цвета
Понятия
Процедуры
Команды

Для задания цвета создаваемых объектов из полной палитры

  1. На панели "Свойства" выберите управляющий список "Цвета".
  2. Нажмите на пункте "Выбор цвета" для вызова окна "Выбор цвета".
  3. В диалоговом окне "Выбор цвета" на вкладке "Вся палитра" выполните следующее:
    • Выберите цветовую модель HSL в списке "Цветовая модель". Задайте цвет путем введения его значения в поле "Цвет" или введением значений в полях "Оттенок", "Насыщенность" и "Яркость".
    • Выберите цветовую модель RGB в списке "Цветовая модель". Задайте цвет путем введения его значения в поле "Цвет" или введением значений в полях "Красный", "Зеленый" и "Синий".
  4. Нажмите "ОК".

    5. Установленный текущий цвет отображается в управляющем списке "Цвета".

Ввод команды: ЦВЕТ


Для задания цвета создаваемых объектов из альбома - Процедуры

Создание и редактирование объектов
Свойства объектов
Установка текущего цвета
Понятия
Процедуры
Команды

Для задания цвета создаваемых объектов из альбома

  1. На панели "Свойства" выберите управляющий список "Цвета".
  2. Нажмите на пункте "Выбор цвета".
  3. В диалоговом окне "Выбор цвета" на вкладке "Альбомы цветов" выберите нужный альбом.
  4. Щелчком мыши выберите требуемый цвет. Просмотр всей палитры цветов осуществляется с помощью полос прокрутки окна.
  5. Нажмите "ОК".

    6. Установленный текущий цвет отображается в управляющем списке "Цвета".

Ввод команды: ЦВЕТ


Установка текущего цвета - Команды

Свойства объектов
Свойства объектов
Установка текущего цвета
Понятия
Процедуры
Команды

Команды
Цвет | Установка цвета для вновь создаваемых объектов
Системные переменные
CECOLOR | Установка цвета для новых объектов.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение цвета объекта - Понятия

Создание и редактирование объектов
Свойства объектов
Изменение цвета объекта
Понятия
Процедуры
Команды

Цвет объекта можно изменять, перенося объект на другой слой, изменяя цвет слоя, на котором расположен объект, или явно присваивая цвет самому объекту.

Цвет объекта можно изменить тремя способами:

  • Перенести объект на другой слой, для которого установлен иной цвет. Если цвет объекта имеет значение ПОСЛОЮ, то после переноса на другой слой объект примет цвет нового слоя.
  • Изменить цвет слоя, на котором расположен объект. Если в свойствах объекта задан цвет ПОСЛОЮ, объект примет цвет слоя. При изменении цвета слоя все объекты, цвета которых заданы значением ПОСЛОЮ, автоматически обновляются, приобретая измененный цвет слоя.
  • Явно присвоить цвет самому объекту вместо того, чтобы использовать цвет слоя. Каждому объекту можно явно присвоить цвет. Если требуется переопределить цвет объекта, назначенный слоем, следует изменить существующий цвет объекта ПОСЛОЮ на другой цвет, например, красный или любой другой цвет из полной палитры.

Для установки цвета, назначаемого всем вновь создаваемым объектам, следует воспользоваться панелью свойств, указав нужный цвет вместо значения ПОСЛОЮ.


Изменение цвета объекта - Процедуры

Создание и редактирование объектов
Свойства объектов
Изменение цвета объекта
Понятия
Процедуры
Команды

Перенос объекта на другой слой

Для назначения цвета слою

Для явного назначения цвета объекту


Перенос объекта на другой слой - Процедуры

Создание и редактирование объектов
Свойства объектов
Изменение цвета объекта
Понятия
Процедуры
Команды

Перенос объекта на другой слой

  1. Выберите объекты, которые необходимо перенести на другой слой.
  2. На панели "Слои" выберите управляющий список "Слои".
  3. Выберите слой, на который требуется перенести объекты.

Панель "Слои"


Для назначения цвета слою - Процедуры

Создание и редактирование объектов
Свойства объектов
Изменение цвета объекта
Понятия
Процедуры
Команды

Для назначения цвета слою

  1. На панели "Слои" выберите "Диспетчер свойств слоев".
  2. В окне "Диспетчера свойств слоев" выберите цвет, который нужно изменить.
  3. В диалоговом окне "Выбор цвета" выполните одну из следующих операций:
    • На вкладке "Номер цвета" выберите цвет или введите в поле "Цвет" его имя или числовое значение в системе ИЦА (от 1 до 255). Нажмите "ОК".
    • На вкладке "Вся палитра" выберите цветовую модель "HSL" и введите значение цвета или задайте значения "H (оттенок)", "S (насыщенность)" и "L (яркость)". Нажмите "OK".
    • На вкладке "Альбомы цветов" выберите альбом цветов в окне "Альбом цветов", выберите цвет нажатием на цветовую полоску при перемещении по альбому цветов (с помощью стрелок вверх или вниз). Нажмите "OK".
  4. Нажмите "OK" для закрытия каждого диалогового окна.

Панель "Слои"

Ввод команды: СЛОЙ


Для явного назначения цвета объекту - Процедуры

Создание и редактирование объектов
Свойства объектов
Изменение цвета объекта
Понятия
Процедуры
Команды

Для явного назначения цвета объекту

  1. Выберите объекты, цвета которых необходимо изменить.
  2. Нажмите правой кнопкой мыши на одном из объектов. Выберите "Свойства".
  3. В панели "Свойства" выберите свойство "Цвет".

    4. Справа от поля располагается кнопка со стрелкой.

  4. Нажмите на стрелку и выберите цвет из списка или воспользуйтесь пунктом "Выбор цвета" для вызова диалогового окна "Выбор цвета". В этом случае выполните одно из следующих действий:
    • На вкладке "Номер цвета" выберите цвет или введите в поле "Цвет" его имя или числовое значение в системе ИЦА (от 1 до 255).
    • На вкладке "Вся палитра" выберите цветовую модель "HSL" и введите значение цвета или задайте значения "H (оттенок)", "S (насыщенность)" и "L (яркость)". Нажмите "OK".
    • На вкладке "Вся палитра" выберите цветовую модель RGB в списке "Цветовая модель". Задайте цвет путем введения его номера в поле "Цвет" или введением значений в полях "Красный", "Зеленый" и "Синий".
    • На вкладке "Альбомы цветов" выберите альбом цветов в окне "Альбом цветов", выберите цвет нажатием на цветовую полоску при перемещении по альбому цветов (с помощью стрелок вверх или вниз). Нажмите "OK".

Ввод команды: ОКНОСВ


Изменение цвета объекта - Команды

Свойства объектов
Свойства объектов
Изменение цвета объекта
Понятия
Процедуры
Команды

Команды
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
CECOLOR | Установка цвета для новых объектов.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с альбомами цветов - Понятия

Создание и редактирование объектов
Свойства объектов
Работа с альбомами цветов
Понятия
Процедуры
Команды

При назначении цвета объектам можно пользоваться альбомами цветов. Работа с альбомами цветов позволяет оперировать широкой палитрой цвета. Альбомы цветов представляют собой файлы от стороннего производителя или пользовательские файлы, которые содержат именованные образцы цветов. Использование цветов из альбомов позволяет улучшить вид чертежа и готовить высококачественные презентационные материалы. Назначение цвета объекту осуществляется с помощью вкладки "Альбомы цветов" в диалоговом окне "Выбор цвета".

Подключение альбомов цветов

Данная программа распознает файлы альбомов цветов только с расширением .acb. Для того, чтобы иметь доступ к цветам из альбомов, необходимо сначала скопировать файлы альбомов в предназначенную для них папку. Расположение альбомов цветов указывается на вкладке "Файлы" диалогового окна "Настройка". Альбомы цветов могут находиться в нескольких папках. Пути к альбомам сохраняются в профиле пользователя.

После подключения нового альбома цветов необходимо закрыть диалоговое окно "Выбор цвета" и открыть его снова. Новый альбом цветов появляется на вкладке "Альбомы цветов". Загрузив альбом цветов, пользователь может применить любой цвет, определенный в этом альбоме цветов, к объектам в своем чертеже.

Просмотр альбомов цветов

Страницы альбомов цветов расположены в порядке возрастания их номеров. На каждой странице представлено до десяти цветов. Если используемый альбом представлен не в виде страниц, цвета распределятся по страницам, при этом на каждой странице будет представлено до семи цветов.


Работа с альбомами цветов - Процедуры

Создание и редактирование объектов
Свойства объектов
Работа с альбомами цветов
Понятия
Процедуры
Команды

Для подключения альбома цветов

Для поиска цвета в альбоме

Для изменения местоположения альбома цветов, принятого по умолчанию

Для задания нескольких папок с альбомами цветов


Для подключения альбома цветов - Процедуры

Создание и редактирование объектов
Свойства объектов
Работа с альбомами цветов
Понятия
Процедуры
Команды

Для подключения альбома цветов

  1. Выберите в меню "Сервис" » "Параметры".
  2. В диалоговом окне "Настройка" на вкладке "Файлы" выберите "Папки для альбомов цветов".
  3. Выберите "Добавить".
  4. Введите новое местоположение альбома.
  5. Нажмите "ОК".

Ввод команды: НАСТРОЙКА


Для поиска цвета в альбоме - Процедуры

Создание и редактирование объектов
Свойства объектов
Работа с альбомами цветов
Понятия
Процедуры
Команды

Для поиска цвета в альбоме

  1. Выберите в меню "Формат" » "Слои".
  2. В диалоговом окне "Цвет", на вкладке "Альбомы цветов" выберите необходимый альбом в списке "Альбом цветов".

    3. Для активизации текстового поля "Цвет" необходимо выбрать образец цвета из альбома.

  3. Введите номер образца цвета и нажмите ТАВ.

    4. В альбоме выделяется требуемый цвет или цвет, наиболее близкий к требуемому.

  4. Нажмите "ОК".

Ввод команды: ЦВЕТ


Для изменения местоположения альбома цветов, принятого по умолчанию - Процедуры

Создание и редактирование объектов
Свойства объектов
Работа с альбомами цветов
Понятия
Процедуры
Команды

Для изменения местоположения альбома цветов, принятого по умолчанию

  1. Выберите в меню "Сервис" » "Параметры".
  2. В диалоговом окне "Настройка" на вкладке "Файлы" дважды нажмите "Папки для альбомов цветов".
  3. Выберите следующее местоположение альбома цветов:

    4. C:\Program Files\[текущий номер версии AutoCAD]\support\color

  4. Выберите имя папки для редактирования адреса.
  5. Введите новое местоположение альбома.
  6. Нажмите "ОК".

Ввод команды: НАСТРОЙКА


Для задания нескольких папок с альбомами цветов - Процедуры

Создание и редактирование объектов
Свойства объектов
Работа с альбомами цветов
Понятия
Процедуры
Команды

Для задания нескольких папок с альбомами цветов

  1. Выберите в меню "Сервис" » "Параметры".
  2. В диалоговом окне "Настройка" на вкладке "Файлы" выберите "Папки для альбомов цветов".
  3. Выберите "Добавить".
  4. Введите новое местоположение альбома.
  5. Нажмите "ОК".

Ввод команды: НАСТРОЙКА


Работа с альбомами цветов - Команды

Свойства объектов
Свойства объектов
Работа с альбомами цветов
Понятия
Процедуры
Команды

Команды
СВОЙСТВА | Изменяет свойства объекта
Цвет | Установка цвета для вновь создаваемых объектов
Системные переменные
CECOLOR | Установка цвета для новых объектов.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с типами линий - Понятия

Создание и редактирование объектов
Свойства объектов
Работа с типами линий
Понятия
Процедуры
Команды

Типы линий применяются для того, чтобы можно было отличить один объект от другого, тем самым, делая работу с чертежом более удобной.

  • Коротко о типах линий
  • Загрузка типов линий
    В начале работы с проектом происходит загрузка всех типов линий, используемых в чертеже.
  • Установка текущего типа линий
    Все новые объекты создаются с использованием текущего типа линий, установленного в управляющем списке "Типы линий" панели "Свойства".
  • Изменение типа линий объекта
    Тип линий объекта можно изменять, перенося объект на другой слой, изменяя тип линий слоя, где расположен объект, или явно присваивая тип линий самому объекту.
  • Масштабирование типов линий
    Один и тот же тип линий может использоваться в различных масштабах. При этом коэффициент масштабирования пользователь может задавать как для всех объектов сразу, так и отдельно для каждого объекта.
  • Отображение типов линий для коротких сегментов и полилиний
    Пользователь имеет возможность центрировать образец типа линий в пределах каждого сегмента полилинии, а также задавать способ отображения типов линий для коротких сегментов.


Работа с типами линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Работа с типами линий
Понятия
Процедуры
Команды

Загрузка типа линий

Для получения списка типов линий, загруженных в текущий чертеж

Для получения списка типов линий из файла описаний типов линий

Для удаления неиспользуемого типа линий

Для очистки чертежа от неиспользуемых типов линий

Для задания типа линий вновь создаваемых объектов

Для назначения типа линий слою

Для назначения слою типа линий, которые будут использоваться по умолчанию

Для назначения типа линий объекту для использования вместо типа линий слоя

Для изменения масштаба типа линий объектов

Для задания масштаба типа линий новых объектов

Для задания глобального масштаба типов линий

Для задания режима генерации типов линий во вновь создаваемых полилиниях

Для изменения режима генерации типов линий в имеющихся полилиниях


Работа с типами линий - Команды

Создание и редактирование объектов
Свойства объектов
Работа с типами линий
Понятия
Процедуры
Команды
Команды
НОВОЕИМЯ | Изменяет имена именованных объектов
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
СВОЙСТВА | Изменяет свойства объекта
СЛОЙ | Управление слоями и их свойствами
ТИПЛИН | Загрузка, установка и изменение типов линий
Системные переменные
CELTSCALE | Установка текущего коэффициента масштабирования для типа линий объекта.
CELTYPE | Установка типа линии для новых объектов.
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
MEASUREMENT | Определяет, какие единицы используются в файлах образцов штриховки или типов линий текущего чертежа
PLINEGEN | Управляет созданием типа линии вокруг вершин двухмерных полилиний
PSLTSCALE | Управляет масштабированием типов линий в пространстве листа
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о типах линий - Понятия

Создание и редактирование объектов
Свойства объектов
Коротко о типах линий
Понятия
Процедуры
Команды

Тип линий описывается повторяющейся последовательностью штрихов, точек и пробелов, наносимых вдоль прямой или кривой. Типы линий можно присваивать как слоям, так и отдельным объектам чертежа.

В описании типа линий можно задавать масштаб для регулирования относительных длин штрихов и пробелов. Пользователь имеет возможность создавать собственные типы линий.

Примечание Встроенные в продукт типы линий не следует путать со штриховыми линиями, которые позволяют чертить некоторые типы плоттеров. Штриховая линия AutoCAD и штриховая линия плоттера выглядят одинаково, однако одновременно их использовать не следует, так как результат может оказаться непредсказуемым.

См. также

См. раздел Настройка типов линий в документе Руководстве по адаптации


Работа с типами линий

Создание и редактирование объектов
Свойства объектов
Работа с типами линий
Понятия
Процедуры
Команды

Нет процедур, относящихся к этому разделу.


Коротко о типах линий - Команды

Свойства объектов
Свойства объектов
Коротко о типах линий
Понятия
Процедуры
Команды

Команды
ТИПЛИН | Загрузка, установка и изменение типов линий
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Загрузка типов линий - Понятия

Создание и редактирование объектов
Свойства объектов
Загрузка типов линий
Понятия
Процедуры
Команды

В начале работы с проектом происходит загрузка всех типов линий, используемых в чертеже.

При необходимости можно получить список всех типов линий, загруженных в чертеж или содержащихся в LIN-файле описаний типов линий.

Эта программа содержит файлы описаний типов линий acad.lin и acadiso.lin. Каждый из них предназначен для определенной системы измерений.

  • Для британских единиц необходимо использовать файл acad.lin.
  • Для метрической системы следует использовать файл acadiso.lin.

Оба файла содержат несколько сложных типов линий.

При выборе типа линий, имя которого начинается с ACAD_ISO, во время печати можно устанавливать толщину пера по ISO.

Неиспользуемые типы линий можно удалять командой ОЧИСТИТЬ или с помощью Диспетчера типов линий. Нельзя удалить типы линий ПОБЛОКУ, ПОСЛОЮ и CONTINUOUS.


Загрузка типов линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Загрузка типов линий
Понятия
Процедуры
Команды

Загрузка типа линий

Для получения списка типов линий, загруженных в текущий чертеж

Для получения списка типов линий из файла описаний типов линий

Для удаления неиспользуемого типа линий

Для очистки чертежа от неиспользуемых типов линий


Загрузка типа линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Загрузка типов линий
Понятия
Процедуры
Команды

Загрузка типа линий

  1. Выберите в меню "Формат" » "Тип линий".
  2. В "Диспетчере типов линий" нажмите кнопку "Загрузить".
  3. В диалоговом окне "Загрузка/перезагрузка типов линий" выберите тип линий. Нажмите "ОК".

    4. Если в списке отсутствует необходимый тип линий, щелкнуть "Файл". В диалоговом окне "Выбор файла типов линий" выберите LIN-файл, список типов линий которого нужно получить, и нажмите. Типы линий из выбранного LIN-файла появляются в списке. Выберите тип линий. Нажмите "ОК".

    Для выделения нескольких типов линий используется клавиша CTRL; для выделения диапазона типов линий - SHIFT.

  4. Нажмите "ОК".

Ввод команды: ТИПЛИН


Для получения списка типов линий, загруженных в текущий чертеж - Процедуры

Создание и редактирование объектов
Свойства объектов
Загрузка типов линий
Понятия
Процедуры
Команды

Для получения списка типов линий, загруженных в текущий чертеж

  1. Выберите управляющий список "Типы линий" панели "Свойства".

    2. Все загруженные типы линий отображаются в виде списка. Для просмотра всего списка можно воспользоваться полосой прокрутки.

  2. Для закрытия списка щелкните мышью вне области списка.


Для получения списка типов линий из файла описаний типов линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Загрузка типов линий
Понятия
Процедуры
Команды

Для получения списка типов линий из файла описаний типов линий

  1. Выберите в меню "Формат" » "Тип линий".
  2. В "Диспетчере типов линий" нажмите кнопку "Загрузить".
  3. В диалоговом окне "Загрузка или перезагрузка типов линий" нажмите "Файл".
  4. В диалоговом окне "Выбор файла типов линий" выберите LIN-файл описаний, список типов линий которого нужно получить. Нажмите "Открыть".

    5. Типы линий из выбранного LIN-файла появляются в списке.

  5. В диалоговом окне "Загрузка/перезагрузка типов линий" нажмите "Отмена".
  6. Нажмите "Отмена" для закрытия "Диспетчера типов линий".

Ввод команды: ТИПЛИН


Для удаления неиспользуемого типа линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Загрузка типов линий
Понятия
Процедуры
Команды

Для удаления неиспользуемого типа линий

  1. Выберите в меню "Формат" » "Тип линий".
  2. В списке окна "Диспетчер типов линий" выберите тип линий. Выберите "Удалить".

    3. Выбранный тип линий удаляется. Некоторые типы линий нельзя выгрузить: ПОСЛОЮ, ПОБЛОКУ, CONTINUOUS и все типы линий, которые в настоящий момент используются.

Ввод команды: ТИПЛИН


Для очистки чертежа от неиспользуемых типов линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Загрузка типов линий
Понятия
Процедуры
Команды

Для очистки чертежа от неиспользуемых типов линий

  1. Выберите в меню "Файл" » "Утилиты" » "Очистить".

    2. Появляется диалоговое окно "Очистка чертежа", отображающее дерево объектов, которые можно удалить.

  2. Для удаления неиспользуемых типов линий воспользуйтесь одним из способов:
    • Для очистки чертежа от всех неиспользуемых типов линий выберите "Типы линий".
    • Для очистки чертежа от определенных типов линий дважды щелкните на пункте "Типы линий" для раскрытия списка следующего уровня. Затем выделите типы линий для удаления.

    Если нужные элементы отсутствуют в списке, включить опцию "Просмотреть элементы, которые нельзя удалить".

  3. Удаление каждого элемента из списка требуется подтвердить. Для подавления запросов перед каждым удалением можно предварительно отключить опцию "Удаление элементов с подтверждением".
  4. Нажмите "Удалить".

    5. В ответ на запрос перед каждым удалением следует нажимать "Да", "Нет" или "Да для всех" для удаления сразу всех выбранных элементов.

  5. Нажмите кнопку "Закрыть".

Ввод команды: ОЧИСТИТЬ


Загрузка типов линий - Команды

Свойства объектов
Свойства объектов
Загрузка типов линий
Понятия
Процедуры
Команды

Команды
НОВОЕИМЯ | Изменяет имена именованных объектов
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
ТИПЛИН | Загрузка, установка и изменение типов линий
Системные переменные
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
MEASUREMENT | Определяет, какие единицы используются в файлах образцов штриховки или типов линий текущего чертежа
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Установка текущего типа линий - Понятия

Создание и редактирование объектов
Свойства объектов
Установка текущего типа линий
Понятия
Процедуры
Команды

Все новые объекты создаются с использованием текущего типа линий, установленного в управляющем списке "Типы линий" панели "Свойства".

С помощью управляющего списка типов линий пользователь может установить текущий тип линий.

Если установлен текущий тип линий ПОСЛОЮ, то все создаваемые объекты используют тип линий, присвоенный текущему слою.

Если установлен текущий тип линий ПОБЛОКУ, то объекты имеют тип линий CONTINUOUS, пока они не объединены в блок. Объектам вставляемых в чертеж блоков присваивается текущий тип линий.

Вместо использования текущего типа линий слоя можно назначать тип линий явным образом.

Программа не отображает тип линии определенных объектов: текст, точки, видовые экраны, штриховки и блоки.


Установка текущего типа линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Установка текущего типа линий
Понятия
Процедуры
Команды

Для задания типа линий вновь создаваемых объектов

Для назначения типа линий слою


Для задания типа линий вновь создаваемых объектов - Процедуры

Создание и редактирование объектов
Свойства объектов
Установка текущего типа линий
Понятия
Процедуры
Команды

Для задания типа линий вновь создаваемых объектов

  1. Выберите в меню "Формат" » "Тип линий".
  2. При необходимости загрузки дополнительных типов линий нажмите "Загрузить", выберите один или несколько типов линий. Нажмите "OK".

    3. Для выделения нескольких типов линий используется клавиша CTRL; для выделения диапазона типов линий - клавиша SHIFT.

  3. В окне Диспетчера типов линий выполните одно из следующих действий:
    • Выделите тип линий и нажать кнопку "Текущий" для назначения выбранного типа линий всем вновь создаваемым объектам.
    • Выберите значение ПОСЛОЮ для построения новых объектов с текущим типом линий слоя.
    • Выберите значение ПОБЛОКУ для построения новых объектов с типом линий текущего слоя, пока они не объединены в блок. При вставке блока объектам присваивается текущий тип линий, заданный в чертеже.
  4. Нажмите "ОК".

Примечание Установленный текущий тип линий отображается в управляющем списке "Типы линий". Для установки текущим уже загруженного типа линий нужно раскрыть управляющий список "Типы линий" и выберите нужный тип линий.

Ввод команды: ТИПЛИН


Для назначения типа линий слою - Процедуры

Создание и редактирование объектов
Свойства объектов
Установка текущего типа линий
Понятия
Процедуры
Команды

Для назначения типа линий слою

  1. На панели "Слои" выберите "Диспетчер свойств слоев".
  2. В окне "Диспетчер свойств слоев" выберите заменяемый тип линий.
  3. В диалоговом окне "Выбор типа линий" выделите нужный тип линий. Нажмите "OK".
  4. Нажмите "ОК" еще раз.

Панель "Слои"

Ввод команды: СЛОЙ


Установка текущего типа линий - Команды

Свойства объектов
Свойства объектов
Установка текущего типа линий
Понятия
Процедуры
Команды

Команды
ТИПЛИН | Загрузка, установка и изменение типов линий
Системные переменные
CELTYPE | Установка типа линии для новых объектов.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение типа линий объекта - Понятия

Создание и редактирование объектов
Свойства объектов
Изменение типа линий объекта
Понятия
Процедуры
Команды

Тип линий объекта можно изменять, перенося объект на другой слой, изменяя тип линий слоя, где расположен объект, или явно присваивая тип линий самому объекту.

Тип линий объекта можно изменить тремя способами:

  • Перенести объект на другой слой, для которого установлен иной тип линий. Если тип линий объекта имеет значение ПОСЛОЮ, то после переноса на другой слой объект примет тип линий нового слоя.
  • Изменить тип линий слоя, на котором расположен объект. Объект примет тип линий слоя, если в свойствах объекта для типа линий установлено значение ПОСЛОЮ. При изменении типа линий слоя все объекты слоя, типы линий которых заданы значением ПОСЛОЮ, автоматически обновляются с учетом вновь назначенного слою типа линий.
  • Явно присвоить тип линий самому объекту. Каждому объекту можно явно присвоить тип линий. Если требуется переопределить тип линий объекта, назначенный слоем, следует изменить существующий тип линий объекта ПОСЛОЮ на другой тип линий, например, ШТРИХОВАЯ.

Для установки типа линий, назначаемого всем вновь создаваемым объектам, следует воспользоваться панелью "Свойства", указав нужный тип линий вместо значения ПОСЛОЮ.


Изменение типа линий объекта - Процедуры

Создание и редактирование объектов
Свойства объектов
Изменение типа линий объекта
Понятия
Процедуры
Команды

Для назначения слою типа линий, которые будут использоваться по умолчанию

Для назначения типа линий объекту для использования вместо типа линий слоя


Для назначения слою типа линий, которые будут использоваться по умолчанию - Процедуры

Создание и редактирование объектов
Свойства объектов
Изменение типа линий объекта
Понятия
Процедуры
Команды

Для назначения слою типа линий, которые будут использоваться по умолчанию

  1. На панели "Слои" выберите "Диспетчер свойств слоев".
  2. В окне "Диспетчер свойств слоев" выберите заменяемый тип линий.
  3. В диалоговом окне "Выбор типа линий" выберите тип линий.

    4. Если в списке отсутствует необходимый тип линий, нажмите кнопку "Загрузить". Выберите тип линий и нажмите "OK", либо нажмите кнопку "Файл" для открытия дополнительных LIN-файлов описаний типов линий.

  4. Для выхода из каждого диалогового окна необходимо нажимать кнопку "ОК".

Панель "Слои"

Ввод команды: СЛОЙ


Для назначения типа линий объекту для использования вместо типа линий слоя - Процедуры

Создание и редактирование объектов
Свойства объектов
Изменение типа линий объекта
Понятия
Процедуры
Команды

Для назначения типа линий объекту для использования вместо типа линий слоя

  1. Выберите объекты, типы линий которых необходимо изменить.
  2. Выберите управляющий список "Типы линий" панели "Свойства".
  3. Выберите тип линий для назначения объектам.

Ввод команды: ТИПЛИН


Изменение типа линий объекта - Команды

Свойства объектов
Свойства объектов
Изменение типа линий объекта
Понятия
Процедуры
Команды

Команды
СВОЙСТВА | Изменяет свойства объекта
СЛОЙ | Управление слоями и их свойствами
ТИПЛИН | Загрузка, установка и изменение типов линий
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Масштабирование типов линий - Понятия

Создание и редактирование объектов
Свойства объектов
Масштабирование типов линий
Понятия
Процедуры
Команды

Один и тот же тип линий может использоваться в различных масштабах. При этом коэффициент масштабирования пользователь может задавать как для всех объектов сразу, так и отдельно для каждого объекта.

По умолчанию коэффициенты масштабирования равны 1.0, как глобально, так и по-отдельности. Чем меньше масштаб, тем больше повторений элементарного фрагмента линии генерируется на единицу чертежа. Так, например, при коэффициенте 0.5 в одной единице длины умещается два элементарных фрагмента типа линий. Если длина объекта меньше длины элементарного фрагмента типа линий, то такой объект отрисовывается сплошной линией. В таких случаях для отображения слишком коротких отрезков можно использовать малые значения коэффициента масштабирования типов линий.

В "Диспетчере типов линий" отображаются значения глобального масштаба и масштаба текущего объекта.

  • Глобальный коэффициент масштабирования управляет системной переменной LTSCALE, которая используется для глобального изменения масштаба типа линий для всех объектов - как новых, так и существовавших до этого.
  • Значение масштаба текущего объекта управляет системной переменной CELTSCALE, которая задает изменяет масштаб типа линий новых объектов.

Отображаемый масштаб типов линий определяется путем умножения значения CELTSCALE на значение LTSCALE. Пользователь может легко изменять в чертеже как текущий, так и глобальный масштабы типов линий.

Настройка масштаба типов линий на различных видовых экранах листа выполняется с помощью системной переменной PSLTSCALE.


Масштабирование типов линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Масштабирование типов линий
Понятия
Процедуры
Команды

Для изменения масштаба типа линий объектов

Для задания масштаба типа линий новых объектов

Для задания глобального масштаба типов линий


Для изменения масштаба типа линий объектов - Процедуры

Создание и редактирование объектов
Свойства объектов
Масштабирование типов линий
Понятия
Процедуры
Команды

Для изменения масштаба типа линий объектов

  1. Выберите объекты, масштаб типов линий которых необходимо изменить.
  2. Нажмите правой кнопкой мыши на одном из объектов. Выберите "Свойства".
  3. В палитре "Свойства" в поле "Масштаб типа линий" введите новое значение.

Панель "Стандартная"

Ввод команды: ОКНОСВ


Для задания масштаба типа линий новых объектов - Процедуры

Создание и редактирование объектов
Свойства объектов
Масштабирование типов линий
Понятия
Процедуры
Команды

Для задания масштаба типа линий новых объектов

  1. Выберите в меню "Формат" » "Тип линий".
  2. В окне "Диспетчер типов линий" нажмите кнопку "Вкл подробности".
  3. Ввести значение в поле "Текущий масштаб".
  4. Нажмите "ОК".

Ввод команды: ТИПЛИН


Для задания глобального масштаба типов линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Масштабирование типов линий
Понятия
Процедуры
Команды

Для задания глобального масштаба типов линий

  1. Выберите в меню "Формат" » "Тип линий".
  2. В окне "Диспетчер типов линий" нажмите кнопку "Вкл подробности".
  3. Введите значение в поле "Глобальный масштаб".
  4. Нажмите "ОК".

Ввод команды: ТИПЛИН


Масштабирование типов линий - Команды

Свойства объектов
Свойства объектов
Масштабирование типов линий
Понятия
Процедуры
Команды

Команды
ТИПЛИН | Загрузка, установка и изменение типов линий
Системные переменные
CELTSCALE | Установка текущего коэффициента масштабирования для типа линий объекта.
PSLTSCALE | Управляет масштабированием типов линий в пространстве листа
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Отображение типов линий для коротких сегментов и полилиний - Понятия

Создание и редактирование объектов
Свойства объектов
Отображение типов линий для коротких сегментов и полилиний
Понятия
Процедуры
Команды

Пользователь имеет возможность центрировать образец типа линий в пределах каждого сегмента полилинии, а также задавать способ отображения типов линий для коротких сегментов.

Если линия слишком коротка для того, чтобы вместить одну штриховую последовательность, то между двумя конечными точками будет проведена непрерывная линия, как показано на иллюстрации ниже.

Рекомендуется уменьшать масштаб типов линий для подобных сегментов. Подробней см. в Масштабирование типов линий.

Для полилинии имеется возможность центрировать образец типа линий в пределах каждого сегмента, либо размещать его непрерывно по всей ее длине. Управляет этими режимами системная переменная PLINEGEN.


Отображение типов линий для коротких сегментов и полилиний - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение типов линий для коротких сегментов и полилиний
Понятия
Процедуры
Команды

Для задания режима генерации типов линий во вновь создаваемых полилиниях

Для изменения режима генерации типов линий в имеющихся полилиниях


Для задания режима генерации типов линий во вновь создаваемых полилиниях - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение типов линий для коротких сегментов и полилиний
Понятия
Процедуры
Команды

Для задания режима генерации типов линий во вновь создаваемых полилиниях

  1. В командной строке введите plinegen.
  2. Введите 1 для разрешения непрерывной генерации образца типа линий по всей длине двумерной полилинии. Чтобы расположить образец типа линии по центру на каждом сегмента, введите 0.

Ввод команды: PLINEGEN


Для изменения режима генерации типов линий в имеющихся полилиниях - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение типов линий для коротких сегментов и полилиний
Понятия
Процедуры
Команды

Для изменения режима генерации типов линий в имеющихся полилиниях

  1. Двойным щелчком выберите полилинию, для которой нужно изменить режим генерации типа линий.
  2. В палитре "Свойства" задайте для свойства "Генерация типа линий" значение "Вкл" или "Откл".

Панель "Стандартная"

Ввод команды: ОКНОСВ


Отображение типов линий для коротких сегментов и полилиний - Команды

Свойства объектов
Свойства объектов
Отображение типов линий для коротких сегментов и полилиний
Понятия
Процедуры
Команды

Команды
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
PLINEGEN | Управляет созданием типа линии вокруг вершин двухмерных полилиний
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с весами линий - Понятия

Создание и редактирование объектов
Свойства объектов
Работа с весами линий
Понятия
Процедуры
Команды

Веса линий могут применяться для графического выделения различных объектов как на экране, так и при выводе на печать.

  • Коротко о весах линий
  • Отображение весов линий
    Способы отображения весов линий в пространствах модели и листа несколько различаются.
  • Установка текущего веса линий
    Текущий вес линий используется при построении всех объектов.
  • Изменение веса линий объекта
    Вес линий объекта можно изменять, перенося объект на другой слой, изменяя вес линий слоя, на котором расположен объект, или явно присваивая вес линий самому объекту.


Работа с весами линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Работа с весами линий
Понятия
Процедуры
Команды

Для назначения ширины полилиниям

Назначение веса линий слою

Для задания масштаба экранного отображения весов линий в пространстве модели

Для отображения объектов с учетом весов линий

Для установки веса линий вновь создаваемых объектов

Изменение толщины линий, из которых состоят полилинии, кольца, прямоугольники и многоугольники


Работа с весами линий - Команды

Создание и редактирование объектов
Свойства объектов
Работа с весами линий
Понятия
Процедуры
Команды
Команды
ВЕСЛИН | Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПЛИНИЯ | Построение двумерных полилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
СЛОЙ | Управление слоями и их свойствами
Системные переменные
LWDISPLAY | Управляет отображением веса линий
PLINEWID | Хранит значение ширины полилинии по умолчанию
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о весах линий - Понятия

Создание и редактирование объектов
Свойства объектов
Коротко о весах линий
Понятия
Процедуры
Команды

Веса линий позволяют получать тонкие и толстые линии, что полезно при оформлении чертежей (построение разрезов и сечений, показ уровней, нанесение размеров, засечек, отображение различий в деталях). Например, назначив слоям различные веса линий, можно облегчить идентификацию зданий, находящихся в эксплуатации, строящихся или подлежащих сносу. Для отображения линий по весам следует включить кнопку "ВЕС" в строке состояния.

Веса линий могут использоваться при выводе любых объектов, за исключением шрифтов True Type, растровых изображений, точек и заливок (для 2D фигур). На виде в плане толщина начертания широкой полилинии определяется ее шириной, а не весом линий. Однако на других видах отображение широких полилиний выполняется с учетом установленных весов линий. Информация о весе линий сохраняется при экспорте чертежа в другие форматы и при копировании объектов в буфер обмена.

В пространстве модели каждому значению веса линий соответствует определенное число пикселов, определяющих видимую на экране толщину линий, независимую от выполнения зумирования. В связи с этим, в пространстве модели видимая толщина линий может не соответствовать их действительной толщине. Так, например, для отображения полилинии с действительной толщиной 5 миллиметров следует устанавливать не вес линий, а толщину полилинии в соответствующее значение.

Веса линий можно также использовать для управления выводом объектов на печать. Это делается с помощью Редактора таблиц стилей печати.

Масштабирование весов линий в чертежах

При выводе на печать толщина начертания объекта определяется назначенным ему весом линий. Стандартные параметры для этих значений: ПОСЛОЮ, ПОБЛОКУ и "По умолчанию". Значения весов линий могут выражаться в миллиметрах или дюймах (по умолчанию используются миллиметры). Начальный вес линий для всех слоев определяется системной переменной LWDEFAULT и по умолчанию равен 0.25 мм.

В пространстве модели значение веса линий, равное или меньшее 0.025 мм, соответствует линии толщиной в один пиксел, а при выводе на печать - наименьшей величине, обеспечиваемой данным печатающим устройством. Значения весов линий, вводимые в командной строке, округляются до ближайшего стандартного значения.

Выберите единицы представления веса линий и задайте значение для веса ОБЫЧНЫЙ можно в диалоговом окне "Параметры весов линий". К диалоговому окну "Параметры весов линий" можно получить доступ с помощью команды LWEIGHT, нажав правую кнопку мыши на кнопке LWT в строке состояния и выбрав "Параметры", или выбрав "Параметры весов линий" в таблице "Предпочтения пользователя" диалогового окна "Настройка".

См. также

Построение полилиний


Коротко о весах линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Коротко о весах линий
Понятия
Процедуры
Команды

Для назначения ширины полилиниям

Назначение веса линий слою

Для задания масштаба экранного отображения весов линий в пространстве модели


Для назначения ширины полилиниям - Процедуры

Создание и редактирование объектов
Свойства объектов
Коротко о весах линий
Понятия
Процедуры
Команды

Для назначения ширины полилиниям

  1. Выберите в меню "Рисование" » "Полилинии".
  2. Укажите начальную точку первого сегмента полилинии.
  3. Введите ш (Ширина).
  4. Введите значение ширины в начале линейного сегмента.
  5. Введите значение ширины в конце линейного сегмента.
  6. Укажите конечную точку первого сегмента полилинии.
  7. Введите ш для задания ширины следующего сегмента или нажмите ENTER для завершения команды.

Панель "Рисование"

Ввод команды: ПЛИНИЯ


Назначение веса линий слою - Процедуры

Создание и редактирование объектов
Свойства объектов
Коротко о весах линий
Понятия
Процедуры
Команды

Назначение веса линий слою

  1. Выберите в меню "Формат" » "Слои".
  2. В области "Диспетчер свойств слоев" выберите слой. Выберите толщину линии, назначенную для этого слоя.
  3. В диалоговом окне "Вес линий" выберите из списка вес линий.
  4. Нажмите "OK" для закрытия каждого диалогового окна.

Ввод команды: СЛОЙ


Для задания масштаба экранного отображения весов линий в пространстве модели - Процедуры

Создание и редактирование объектов
Свойства объектов
Коротко о весах линий
Понятия
Процедуры
Команды

Для задания масштаба экранного отображения весов линий в пространстве модели

  1. Выберите в меню "Формат" » "Вес линий".
  2. В диалоговом окне "Параметры весов линий" в группе "Масштаб экранного отображения" изменить положение указателя скользящей шкалы.
  3. Нажмите "ОК".

Ввод команды: СЛОЙ, ВЕСЛИН


Коротко о весах линий - Команды

Свойства объектов
Свойства объектов
Коротко о весах линий
Понятия
Процедуры
Команды

Команды
ВЕСЛИН | Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий
ПЛИНИЯ | Построение двумерных полилиний
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Отображение весов линий - Понятия

Создание и редактирование объектов
Свойства объектов
Отображение весов линий
Понятия
Процедуры
Команды

Способы отображения весов линий в пространствах модели и листа несколько различаются.

  • Значению веса линий 0 в пространстве модели всегда соответствует линия толщиной в один пиксел. Толщина отображения остальных весов линий (в пикселах) устанавливается пропорционально их точным значениям.
  • В пространстве листа видимая на экране толщина начертания объекта устанавливается равной точному значению его веса линий.
Отображение весов линий в пространстве модели

В пространстве модели соединения отрезков, отображаемых с учетом весов линий, строятся в виде скосов без использования торцевых ограничителей. Однако при выводе на печать с использованием стилей печати можно задавать различные типы соединений и окончаний линий для различных весов линий.

Примечание Корректное экранное отображение участков соединений и окончаний объектов с весом линий возможно лишь при выполнении полного просмотра.

В пространстве модели в режиме отображения весов линий толщина начертания любого объекта не зависит от коэффициента экранного увеличения. Например, если весу линий соответствует толщина в четыре пиксела, то объекты с таким весом всегда отрисовываются линией толщиной четыре пиксела, даже при увеличении экранного изображения до максимально возможного значения. Для изменения масштаба отображения веса линий в пространстве модели следует использовать команду ВЕСЛИН. Изменение масштаба отображения не влияет на толщину линий при выводе на печать.

Следует отметить, что если используемые веса линий представляются более чем одним пикселом, то время регенерации чертежа возрастает. Чтобы оптимизировать производительность программы, отключите отображение толщины линий. Во вкладке "Модель" можно включать и отключать отображение весов линий нажатием кнопки "ВЕС" в строке состояния.

Отображение весов линий в пространстве листа

В пространстве листа и в режиме предварительного просмотра видимая на экране толщина начертания отдельного объекта пропорциональна значению веса линий и текущему коэффициенту экранного увеличения. Поэтому при зуммировании видимая толщина объектов изменяется. Учет весов линий при выводе чертежа на печать можно включать/отключать на вкладке "Параметры печати" диалогового окна "Печать".

В пространстве листа можно включать и отключать режим отображения весов линий нажатием кнопки "ВЕС" в строке состояния. Данная опция не влияет на вывод весов линий при печати.


Для отображения объектов с учетом весов линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение весов линий
Понятия
Процедуры
Команды

Для отображения объектов с учетом весов линий

Воспользуйтесь одним из следующих способов:

  • Нажмите кнопку "ВЕС" в строке состояния.
  • Установите или сбросьте флажок "Отображать линии в соответствии с весами" в диалоговом окне "Параметры весов линий".
  • Присвойте системной переменной LWDISPLAY значение 0 (Откл) или 1 (Вкл).

Ввод команды: ВЕСЛИН


Отображение весов линий - Команды

Свойства объектов
Свойства объектов
Отображение весов линий
Понятия
Процедуры
Команды

Команды
ВЕСЛИН | Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПЛИНИЯ | Построение двумерных полилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
СЛОЙ | Управление слоями и их свойствами
Системные переменные
LWDISPLAY | Управляет отображением веса линий
PLINEWID | Хранит значение ширины полилинии по умолчанию
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Установка текущего веса линий - Понятия

Создание и редактирование объектов
Свойства объектов
Установка текущего веса линий
Понятия
Процедуры
Команды

Текущий вес линий используется при построении всех объектов.

Все новые объекты создаются с использованием текущего веса линий, установленного в управляющем списке "Веса линий" панели "Свойства". Пользователь может также установить текущий вес линий с помощью управляющего списка весов линий.

Если установлен текущий вес линий ПОСЛОЮ, то все создаваемые объекты используют вес линий, присвоенный текущему слою.

Если установлен текущий вес линий ПОБЛОКУ, то объекты, пока они не объединены в блок, создаются с весом линий, установленным по умолчанию. Вставляемым в чертеж блокам присваивается текущий вес линий.

Вместо того, чтобы строить объекты, наследуя вес линий слоя, можно назначать вес линий явным образом.

Объектам чертежей, созданных в предыдущих версиях AutoCAD, назначается вес линий ПОСЛОЮ, а всем слоям таких чертежей назначается вес линий ОБЫЧНЫЙ. Отображение объекта с использованием присвоенного ему веса линий подобно включению закрашивания, которое поддерживают некоторые типы объектов.


Для установки веса линий вновь создаваемых объектов - Процедуры

Создание и редактирование объектов
Свойства объектов
Установка текущего веса линий
Понятия
Процедуры
Команды

Для установки веса линий вновь создаваемых объектов

  1. Выберите в меню "Формат" » "Вес линий".
  2. В диалоговом окне "Параметры весов линий" выберите в списке вес линий.
  3. Нажмите "ОК".

Примечание Для отображения текущего значения веса линий установите флажок "Отображать линии в соответствии с весами" в диалоговом окне "Параметры весов линий".

Ввод команды: СЛОЙ, ВЕСЛИН


Установка текущего веса линий - Команды

Свойства объектов
Свойства объектов
Установка текущего веса линий
Понятия
Процедуры
Команды

Команды
ВЕСЛИН | Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПЛИНИЯ | Построение двумерных полилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
СЛОЙ | Управление слоями и их свойствами
Системные переменные
LWDISPLAY | Управляет отображением веса линий
PLINEWID | Хранит значение ширины полилинии по умолчанию
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение веса линий объекта - Понятия

Создание и редактирование объектов
Свойства объектов
Изменение веса линий объекта
Понятия
Процедуры
Команды

Вес линий объекта можно изменять, перенося объект на другой слой, изменяя вес линий слоя, на котором расположен объект, или явно присваивая вес линий самому объекту.

Вес линий объекта можно изменить тремя способами:

  • Перенести объект на другой слой, для которого установлен иной вес линий. В этом случае, если вес линий объекта имеет значение ПОСЛОЮ, то после переноса объект примет вес линий нового слоя.
  • Изменить вес линий слоя, на котором расположен объект. Объект примет вес линий слоя, если в свойствах объекта установлено значение веса линий ПОСЛОЮ. При изменении веса линий слоя все объекты, веса линий которых заданы значением ПОСЛОЮ, обновляются с учетом измененного веса линий.
  • Явно присвоить вес линий самому объекту. Каждому объекту можно явно присвоить вес линий. Если требуется переопределить вес линий, назначенный слоем, следует изменить существующий вес линий объекта ПОСЛОЮ на другой.

Для установки веса линий, назначаемого всем вновь создаваемым объектам, следует воспользоваться панелью "Свойства", указав нужный вес линий вместо значения ПОСЛОЮ.


Изменение толщины линий, из которых состоят полилинии, кольца, прямоугольники и многоугольники - Процедуры

Создание и редактирование объектов
Свойства объектов
Изменение веса линий объекта
Понятия
Процедуры
Команды

Изменение толщины линий, из которых состоят полилинии, кольца, прямоугольники и многоугольники

  1. Выберите в меню "Изменить" » "Объект" » "Полилиния".
  2. Выберите одну или несколько полилиний.
  3. Введите ш (Ширина), затем укажите значение ширины для всех сегментов.
  4. Нажмите ENTER для завершения команды.

Панель "Редактирование-2"

Ввод команды: ПОЛРЕД


Изменение веса линий объекта - Команды

Свойства объектов
Свойства объектов
Изменение веса линий объекта
Понятия
Процедуры
Команды

Команды
ВЕСЛИН | Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПЛИНИЯ | Построение двумерных полилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
СЛОЙ | Управление слоями и их свойствами
Системные переменные
LWDISPLAY | Управляет отображением веса линий
PLINEWID | Хранит значение ширины полилинии по умолчанию
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление отображением отдельных объектов - Понятия

Создание и редактирование объектов
Свойства объектов
Управление отображением отдельных объектов
Понятия
Процедуры
Команды

Пользователь имеет возможность управлять экранным отображением и выводом на печать объектов (включая перекрывающиеся).

  • Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
    Для повышения производительности можно упростить отображение некоторых объектов.
  • Управление отображением перекрывающихся объектов
    Пользователь имеет возможность указывать, какие из перекрывающихся объектов должны располагаться на переднем плане.


Управление отображением отдельных объектов - Процедуры

Создание и редактирование объектов
Свойства объектов
Управление отображением отдельных объектов
Понятия
Процедуры
Команды

Для включения и отключения закраски

Включение и отключение вывода текста

Включение и отключение весов линий

Для изменения порядка следования перекрывающихся объектов


Управление отображением отдельных объектов - Команды

Создание и редактирование объектов
Свойства объектов
Управление отображением отдельных объектов
Понятия
Процедуры
Команды
Команды
БВЫБОР | Быстрое создание набора объектов на основе заданных критериев фильтрации
ВЕСЛИН | Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
ЗАКРАСИТЬ | Управление закрашиванием таких объектов, как штриховки, фигуры и широкие полилинии
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
ПБЛОК | Запись объектов или блока в новый файл чертежа
ПОРЯДОК | Изменение порядка прорисовки растровых изображений и других объектов на экран
РЕГЕН | Регенерация чертежа и перерисовка содержимого текущего видового экрана
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
ТЕКСТПЕРПЛАН | Размещение текста и размеров поверх всех остальных объектов чертежа
Системные переменные
DRAWORDERCTL | Управляет порядком отображения перекрывающихся объектов
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPDRAWORDER | Управляет порядком прорисовки штриховки или заливки
LWDISPLAY | Управляет отображением веса линий
QTEXTMODE | Управляет отображением текста
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Отображение полилиний, штриховок, градиентных заливок, весов линий и текста - Понятия

Создание и редактирование объектов
Свойства объектов
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Понятия
Процедуры
Команды

Для повышения производительности можно упростить отображение некоторых объектов.

Производительность отображения можно повысить за счет упрощения отображения широких полилиний, колец, закрашенных двумерных многоугольников (фигур), штриховок, градиентных заливок и текста. В таком виде чертеж вполне пригоден для печати черновых экземпляров.

Отключение режима заливки

При отключении режима закраски широкие полилинии, закрашенные многоугольники, градиентные заливки и штриховки отображаются в виде контуров. На видах с подавленными скрытыми линиями, а также на видах, не являющихся видами в плане, отображение закраски (кроме штриховок по образцам и градиентных закрасок) автоматически отключается.

Использование режима контурного текста

Если включить режим контурного текста в чертеже, содержащем текстовые надписи, то на экран и на печать будут выводиться только их ограничивающие прямоугольники.

Отключение весов линий

Все линии на экране, имеющие более одного пиксела в ширину, замедляют производительность обработки чертежа. Если необходимо повысить производительность отображения, то можно отключить веса линий. Веса линий можно включать и отключать, нажимая кнопку "ВЕС" в строке состояния или используя диалоговое окно "Параметры весов линий". На печать веса линий выводятся всегда, отображая тем самым действительную толщину линий на чертеже.

Обновление экрана

При создании новых объектов автоматически используются текущие настройки отображения закраски и текста. Но для изменения свойств отображения (кроме весов линий) уже имеющихся объектов требуется вызвать команду РЕГЕН.

См. также

Применение слоев для организации чертежей

Отображение весов линий

Использование шрифтов TrueType


Отображение полилиний, штриховок, градиентных заливок, весов линий и текста - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Понятия
Процедуры
Команды

Для включения и отключения закраски

Включение и отключение вывода текста

Включение и отключение весов линий


Для включения и отключения закраски - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Понятия
Процедуры
Команды

Для включения и отключения закраски

  1. Выберите в меню "Сервис" » "Параметры".
  2. В диалоговом окне "Настройка" на вкладке "Отображение" в разделе "Производительность отображения" выберите "Показывать закраску".

    3. Если флажок активен, закраска отображается.

  3. Нажмите "ОК".
  4. Для отображения изменений выберите меню "Вид" » "Регенерировать".

Ввод команды: НАСТРОЙКА, РЕГЕН


Включение и отключение вывода текста - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Понятия
Процедуры
Команды

Включение и отключение вывода текста

  1. Выберите меню "Сервис" » "Параметры".
  2. В диалоговом окне "Настройка" на вкладке "Отображение" в разделе "Производительность отображения" выберите "Только границы текстов".

    3. Если флажок активен, вместо текста выводится окружающая его рамка.

  3. Нажмите "ОК".
  4. Для отображения изменений выберите меню "Вид" » "Регенерировать".

Ввод команды: НАСТРОЙКА, РЕГЕН


Включение и отключение весов линий - Процедуры

Создание и редактирование объектов
Свойства объектов
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Понятия
Процедуры
Команды

Включение и отключение весов линий

  1. Выберите в меню "Формат" » "Вес линий".
  2. Установите или сбросбте флажок "Отображать линии в соответствии с весами" в диалоговом окне "Параметры весов линий".
  3. Нажмите "ОК".

Ввод команды: ВЕСЛИН


Отображение полилиний, штриховок, градиентных заливок, весов линий и текста - Команды

Свойства объектов
Свойства объектов
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Понятия
Процедуры
Команды

Команды
ВЕСЛИН | Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий
ЗАКРАСИТЬ | Управление закрашиванием таких объектов, как штриховки, фигуры и широкие полилинии
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
РЕГЕН | Регенерация чертежа и перерисовка содержимого текущего видового экрана
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
LWDISPLAY | Управляет отображением веса линий
QTEXTMODE | Управляет отображением текста
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление отображением перекрывающихся объектов - Понятия

Создание и редактирование объектов
Свойства объектов
Управление отображением перекрывающихся объектов
Понятия
Процедуры
Команды

Пользователь имеет возможность указывать, какие из перекрывающихся объектов должны располагаться на переднем плане.

Как правило, такие объекты, как тексты, широкие полилинии и закрашенные многоугольники выводятся на экран в порядке их создания, т.е. ранее созданные объекты отображаются позади новых объектов. Команда ТЕКСТПЕРПЛАН изменяет порядок прорисовки (т.е. отображения на экране и вывода на плоттер) всех текстов и размеров в чертеже. ТЕКСТПЕРПЛАН изменяет порядок прорисовки всех текстовых и размерных надписей на чертеже.

Примечание Задание порядка вывода перекрывающихся объектов, общего для пространств модели и листа, невозможно. Для каждого пространства порядок вывода объектов устанавливается отдельно.


Для изменения порядка следования перекрывающихся объектов - Процедуры

Создание и редактирование объектов
Свойства объектов
Управление отображением перекрывающихся объектов
Понятия
Процедуры
Команды

Для изменения порядка следования перекрывающихся объектов

  1. На панели "Порядок прорисовки" выберите одну из опций порядка следования.
  2. Выберите объекты, чей порядок прорисовки необходимо изменить и нажмите ENTER.
  3. Выберите объекты, относительно которых устанавливается порядок и нажмите ENTER. (Этот шаг необходим только для опций "Перед объектами" и "За объектами".)

Меню "Сервис": "Порядок прорисовки"

Ввод команды: ПОРЯДОК

Контекстное меню: Выберите объект и нажмите на нем правой кнопкой мыши. Выберите "Порядок прорисовки"


Управление отображением перекрывающихся объектов - Команды

Свойства объектов
Свойства объектов
Управление отображением перекрывающихся объектов
Понятия
Процедуры
Команды

Команды
БВЫБОР | Быстрое создание набора объектов на основе заданных критериев фильтрации
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
ПБЛОК | Запись объектов или блока в новый файл чертежа
ПОРЯДОК | Изменение порядка прорисовки растровых изображений и других объектов на экран
РЕГЕН | Регенерация чертежа и перерисовка содержимого текущего видового экрана
ТЕКСТПЕРПЛАН | Размещение текста и размеров поверх всех остальных объектов чертежа
Системные переменные
DRAWORDERCTL | Управляет порядком отображения перекрывающихся объектов
HPDRAWORDER | Управляет порядком прорисовки штриховки или заливки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Средства обеспечения точности - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Понятия
Процедуры
Команды

В распоряжении пользователя имеются различные средства, обеспечивающие быстрое и точное построение чертежей без выполнения утомительных расчетов.

  • Координаты и системы координат (ПСК)
    Для точного ввода координат можно использовать методы записи в нескольких системах координат.. Можно также использовать перемещаемую систему координат, пользовательскую систему координат (ПСК), обеспечивающую удобство записи координат и размещения плоскостей видов чертежа.
  • Использование динамического ввода
    Функция динамического ввода обеспечивает командный интерфейс в области курсора, позволяющий удерживать фокус в области построения.
  • Объектная привязка
    Вместо ввода значений координат пользователь имеет возможность задавать точки, привязывая курсор к характерным точками имеющихся объектов (к конечным точкам отрезков, центрам кругов и т.д.).
  • Ограничение перемещения курсора
    Пользователю предоставляются различные средства для ограничения и блокирования перемещения курсора.
  • Комбинирование и смещение точек и координат
    Чтобы задать новое положение точки, можно объединить координатные значения из нескольких точек или указать смещения от существующих объектов.
  • Задание расстояний
    При указании точек можно вводить значения расстояний, смещений и интервалов.
  • Получение геометрической информации от объектов
    Пользователю предоставлен ряд команд для получения справочной информации об объектах чертежа и выполнения математических расчетов.
  • Использование калькулятора
    При работе с программой можно пользоваться функциями калькулятора. Можно использовать интерфейс калькулятора QuickCalc или калькулятор командной строки.


Средства обеспечения точности - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятия
Процедуры
Команды

Для отображения координат точки

Для визуального определения местоположения точки

Для переключения режима отображения координат в строке состояния

Для ввода абсолютных декартовых координат (2D)

Для ввода относительных декартовых координат (2D)

Для ввода абсолютных полярных координат (2D)

Для ввода относительных полярных координат (2D)

Для ввода абсолютных координат (3D)

Для ввода относительных координат (3D)

Для ввода относительных цилиндрических координат

Для ввода относительных сферических координат

Определение новой исходной точки ПСК в 2D

Изменение угла поворота ПСК

Востановление ПСК для совмещения с МСК

Для восстановления предыдущей ПСК

Для сохранения ПСК

Для восстановления именованной ПСК

Для переименования ПСК

Удаление именованной ПСК

Для ввода координат относительно МСК

Определение новой ПСК заданием трех точек

Поворот ПСК вокруг большой оси

Определение новой исходной точки ПСК в 3D

Определение новой ПСК с заданной осью Z

Определение новой ПСК с заданными осями X и Y

Для переноса плоскости XY

Для установки стандартной ПСК

Для восстановления местоположения и ориентации предыдущей ПСК

Замена ПСК динамическим способом

Для применения текущей ПСК к другим видовым экранам

Для включения и отключения знака ПСК

Для установки знака ПСК в начало координат

Для настройки параметров знака ПСК

Для ввода значений координат в подсказках динамического ввода

Для исправления ошибок ввода в подсказках динамического ввода

Для указания относительных или абсолютных координат в подсказках для ввода с помощью мыши

Для выбора параметров в динамической подсказке

Для изменения цвета, размера или прозрачности подсказок

Объединение информации из всех подсказок о построениях в одну подсказку.

Для включения или отключения динамического ввода

Для изменения настроек ввода с помощью мыши

Для изменения настроек ввода размеров

Для отображения запросов в подсказках

Для включения привязки к характерным точкам объектов

Для задания текущих режимов объектной привязки

Для включения и отключения текущих режимов объектной привязки в процессе работы

Для игнорирования объектов штриховки объектными привязками

Для вызова контекстного меню объектной привязки

Для изменения параметров автопривязки

Для временной отмены текущих настроек объектной привязки

Изменение времени реакции клавиатуры для кнопок временного переопределения

Для включения сетки и задания ее шага

Для включения режима шаговой привязки и задания шага

Установка границ сетки

Для временной отмены режима привязки

Поворот угла привязки и сетки и изменение базовой точки

Изменение отображения сетки в виде линий и точек

Изменение частоты главных линий сетки

Для включения и отключения режима "Орто"

Для включения и отключения полярного отслеживания

Для задания шага полярной привязки

Для построения объектов с помощью полярного отслеживания

Для построения объектов с помощью полярной привязки

Для задания углов полярного отслеживания

Для задания 2D точки с использованием координатных фильтров

Для задания 3D точки с использованием координатных фильтров

Для включения и отключения объектного отслеживания

Для изменения параметров автоотслеживания

Для задания точки с помощью отслеживания

Для построения отрезка методом "направление-расстояние"

Для смещения точки от временной опорной точки

Для разметки объекта с помощью точек

Для разметки объекта с помощью блоков

Для деления объекта точками на равные сегменты

Для деления объекта на равные сегменты с помощью блоков

Для вычисления расстояния и угла

Для вычисления площади заданной области

Для вычисления площади объекта

Для суммирования площадей

Для вычитания площади из подсчитанной общей площади

Для очистки поля ввода

Для использования основных математических функций в калькуляторе QuickCalc

Для использования научных функций в калькуляторе QuickCalc

Для получения абсолютного значения числа с помощью QuickCalc

Для округления числа до ближайшего целого с помощью QuickCalc

Для отображения только целой части числа с помощью QuickCalc

Для сохранения значения в памяти QuickCalc

Для добавления текущего значения к значению, сохраненному в памяти QuickCalc

Для восстановления значения, сохраненного в памяти QuickCalc

Для очистки значения, сохраненного в памяти QuickCalc

Для использования калькулятора QuickCalc

Для использования калькулятора QuickCalc в рамках команды

Для использования калькулятора QuickCalc вместе с палитрой свойств

Для копирования/вставки значения в поле ввода QuickCalc

Для вставки значения из поля ввода QuickCalc в командную строку

Для очистки области журнала

Для повторного использования значения или выражения, сохраненного в области журнала калькулятора QuickCalc

Для изменения цвета шрифта значений или выражений в области журнала QuickCalc

Для копирования/вставки выражения в область журнала QuickCalc

Для добавления значения или выражения из области журнала калькулятора QuickCalc в поле ввода

Для изменения свойства в палитре свойств с помощью QuickCalc

Для получения значений координат X, Y, Z для точки с помощью QuickCalc

Для измерения расстояния между двумя точками с помощью QuickCalc

Для получения угла наклона отрезка, заданного двумя точками, с помощью QuickCalc

Для получения точки пересечения отрезков, заданной четырьмя точками, с помощью QuickCalc

Для преобразования единиц измерения с помощью QuickCalc

Для копирования результатов преобразования единиц в поле ввода калькулятора QuickCalc

Для преобразования радианов в градусы с помощью QuickCalc

Для преобразования градусов в радианы с помощью QuickCalc

Для использования стандартной переменной в выражении QuickCalc

Для создания новой переменной в QuickCalc

Для редактирования переменной в QuickCalc

Для удаления переменной в QuickCalc

Для создания новой глобальной константы в поле ввода калькулятора QuickCalc

Для обращения к глобальной константе из диалогового окна или обычного окна

Чтобы вычислять математические выражения в диалоговом окне


Средства обеспечения точности - Команды

Создание и редактирование объектов
Средства обеспечения точности
Понятия
Процедуры
Команды
Команды
АДАПТАЦИЯ | Изменяет инструментальные палитры
АПЕРТУРА | Изменение размера прицела объектной привязки
БКЗАКРЫТЬ | Закрытие калькулятора QuickCalc
БЛОК | Создание описания блока из выбранных объектов
БЫСТРКАЛЬК | Вызов калькулятора QuickCalc
ДИАЛТТОЧ | Задание стиля отображения и величины точечных объектов
ДИСПСК | Управление заданными пользовательскими системами координат
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
ЗНАКПСК | Управление видимостью и расположением знака ПСК
КАЛЬК | Вычисление математических и геометрических выражений
КООРД | Определение координат точек
ЛИМИТЫ | Установка и регулирование границ отображения сетки на текущей вкладке разметки листа или "Модель"
МАРКЕР | Управление простановкой маркеров при рисовании
МАСС-ХАР | Вычисление массовых характеристик областей и тел
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
ОРТО | Ограничивает перемещение курсора в вертикальном или горизонтальном направлении
ОТРЕЗОК | Построение отрезков
ПБЛОК | Запись объектов или блока в новый файл чертежа
ПЛАНШЕТ | Настройка, калибровка, включение и отключение графического планшета
ПЛОЩАДЬ | Вычисление площадей и периметров объектов или заданных областей
ПОДЕЛИТЬ | Размещение по длине или периметру объекта на равном расстоянии точек или блоков
ПРИВЯЗКА | Установка текущих режимов объектной привязки
ПСК | Управление пользовательскими системами координат
РАЗМЕТИТЬ | Размещение на объекте точек или блоков с равными интервалами
РЕЖИМРАСКР | Запускает команду ТЕКВИЗСТИЛЬ
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
СВОЙСТВА | Изменяет свойства объекта
СЕТКА | Отображение точечной сетки на текущем видовом экране, которая не выводится на печать
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
УРОВЕНЬ | Задание уровня и трехмерной высоты для вновь создаваемых объектов
ШАГ | Ограничение перемещения курсора определенными интервалами
Системные переменные
ANGBASE | Задание для базового угла значения 0 в соответствии с текущей ПСК
ANGDIR | Задание направления для положительных углов.
APBOX | Включает или отключает отображение прицела AutoSnap™
AREA | Сохранение значения последней области, вычисленного с помощью команды ПЛОЩАДЬ
AUTOSNAP | Управление отображением маркера, всплывающей подсказки и магнита автопривязки
CALCINPUT | Управление вычислением математических выражений и глобальных констант в полях для ввода текстовых или числовых данных
COORDS | Управляет форматом и частотой обновления координат на статусной строке
DISTANCE | Сохраняет значение расстояния, вычисленное с помощью команды DIST
DYNDIGRIP | Управляет отображением динамических размеров во время растягивания ручками
DYNDIVIS | Управляет отображением количества динамических размеров во время растягивания ручками
DYNMODE | Включает и отключает функции динамического ввода
DYNPICOORDS | Контролирует, используются ли для ввода с помощью мыши абсолютные или относительные координаты
DYNPIFORMAT | Контролирует, используется ли для ввода с помощью мыши формат полярных или декартовых координат
DYNPIVIS | Управляет отображением ввода с помощью мыши
DYNPROMPT | Управляет отображением подсказок динамического ввода
DYNTOOLTIPS | Управляет выбором подсказок, на которые влияют параметры внешнего вида подсказок
ELEVATION | Сохраняет текущий уровень новых объектов относительно текущей ПСК
ERRNO | Отображает номер соответствующего кода ошибки, когда вызов функции AutoLISP приводит к ошибки, определенной AutoCAD
GRIDDISPLAY | Управляет режимом работы дисплея и лимитами отображения сетки
GRIDMAJOR | Управляет частотой основных линий сетки по сравнению с второстепенными линиями сетки
GRIDMODE | Указывает, включена или отключена сетка
GRIDUNIT | Указывает размер ячейки сетки на текущем видовом экране по X и Y
LASTPOINT | Сохраняет последнюю введенную точку, выраженную в координатах ПСК в текущем пространстве. Для того чтобы координаты отсчитывались от нее, необходимо начать ввод с клавиатуры с символа @
LIMCHECK | Управляет созданием объектов за пределами лимитов чертежа
LIMMIN | Сохраняет левую нижнюю точку лимитов чертежа, выраженную в мировых координатах
ORTHOMODE | Управляет перемещением курсора в перпендикулярном направлении
OSMODE | Определяет выполнение объектных привязок
OSNAPCOORD | Управляет приоритетом ввода координат с клавиатуры над текущими режимами привязки
OSNAPHATCH | Устар.
OSNAPZ | Управляет автоматической проекцией объектной привязки на плоскость, параллельную плоскости XY текущей ПСК, на текущем уровне
OSOPTIONS | Автоматически подавляет объектную привязку на объектах штриховки и геометрию с отрицательными значениями Z при использовании динамической ПСК
PDMODE | Управляет отображением точечных объектов
PDSIZE | Устанавливает размер отображения точечных объектов
PERIMETER | Хранит последнее значение периметра, вычисленное с помощью команды ПЛОЩАДЬ или СПИСОК
POLARANG | Задает шаг для полярных углов
POLARDIST | Задает шаг привязки в случае, если для системной переменной SNAPTYPE установлено значение 1 (полярная привязка)
POLARMODE | Управляет полярным и объектным отслеживанием
PUCSBASE | Сохраняет имя ПСК, которая определяет параметры исходной точки и ориентации ортогональной ПСК (только для пространства листа)
SNAPMODE | Включает и отключает режим привязки
SNAPTYPE | Задает тип привязки для текущего видового экрана
SNAPUNIT | Задает интервал привязки для текущего видового экрана
TABMODE | Управляет использованием режима "Планшет"
TEMPOVERRIDES | Включает и отключает клавиши временной отмены
TOOLTIPMERGE | Объединяет подсказки на чертеже в одну подсказку
TRACKPATH | Управляет отображением линий выравнивания для полярного отслеживания и отслеживания объектной привязки
UCSDETECT | Управляет активность сбора данных динамической ПСК
UCSFOLLOW | Устанавливает вид в плане при переходе от одной ПСК к другой
UCSNAME | Сохраняет имя текущей системы координат для текущего видового экрана в текущем пространстве
UCSORG | Сохраняет исходную точку текущей системы координат для текущего видового экрана в текущем пространстве
UCSORTHO | Определяет режим восстановления ортогональной ПСК в момент установки соответствующего ортогонального вида
UCSVP | Определяет, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана
UCSXDIR | Сохраняет направление X текущей ПСК на текущем видовом экране в текущем пространстве
UCSYDIR | Сохраняет направление Y текущей ПСК на текущем видовом экране в текущем пространстве
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Координаты и системы координат (ПСК) - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Координаты и системы координат (ПСК)
Понятия
Процедуры
Команды

Для точного ввода координат можно использовать методы записи в нескольких системах координат.. Можно также использовать перемещаемую систему координат, пользовательскую систему координат (ПСК), обеспечивающую удобство записи координат и размещения плоскостей видов чертежа.

  • Методы записи координат
  • 2D декартовы координаты
    С помощью абсолютных и относительных декартовых и полярных 2D координат определяются точные положения объектов на чертеже.
  • 3D координаты
    При создании объектов в 3D пространстве для указания точек используются декартовы, цилиндрические или сферические координаты.
  • Понятие о пользовательской системе координат (ПСК)
    Пользовательскую систему координат можно перемещать и поворачивать для обеспечения удобства записи координат, отображения сетки, привязки к сетке, реализации режима "Орто" и использования других инструментов создания чертежей.
  • Задание плоскостей видов чертежа в 3D (ПСК)
    Возможность управления пользовательской системой координат (ПСК) является важным условием для эффективного построения моделей в трехмерном пространстве.
  • Назначение пользовательской системы координат видовому экрану
    Чтобы облегчить редактирование объектов на различных видах, можно определить отличную от других ориентацию ПСК для каждого вида.
  • Знак пользовательской системы координат
    Для облегчения работы с ПСК можно воспользоваться знаком пользовательской системы координат. Имеется несколько вариантов этого знака. Можно изменять его размеры, расположение и цвет.


Координаты и системы координат (ПСК) - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Координаты и системы координат (ПСК)
Понятия
Процедуры
Команды

Для отображения координат точки

Для визуального определения местоположения точки

Для переключения режима отображения координат в строке состояния

Для ввода абсолютных декартовых координат (2D)

Для ввода относительных декартовых координат (2D)

Для ввода абсолютных полярных координат (2D)

Для ввода относительных полярных координат (2D)

Для ввода абсолютных координат (3D)

Для ввода относительных координат (3D)

Для ввода относительных цилиндрических координат

Для ввода относительных сферических координат

Определение новой исходной точки ПСК в 2D

Изменение угла поворота ПСК

Востановление ПСК для совмещения с МСК

Для восстановления предыдущей ПСК

Для сохранения ПСК

Для восстановления именованной ПСК

Для переименования ПСК

Удаление именованной ПСК

Для ввода координат относительно МСК

Определение новой ПСК заданием трех точек

Поворот ПСК вокруг большой оси

Определение новой исходной точки ПСК в 3D

Определение новой ПСК с заданной осью Z

Определение новой ПСК с заданными осями X и Y

Для переноса плоскости XY

Для установки стандартной ПСК

Для восстановления местоположения и ориентации предыдущей ПСК

Замена ПСК динамическим способом

Для применения текущей ПСК к другим видовым экранам

Для включения и отключения знака ПСК

Для установки знака ПСК в начало координат

Для настройки параметров знака ПСК


Координаты и системы координат (ПСК) - Команды

Создание и редактирование объектов
Средства обеспечения точности
Координаты и системы координат (ПСК)
Понятия
Процедуры
Команды
Команды
ДИСПСК | Управление заданными пользовательскими системами координат
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
ЗНАКПСК | Управление видимостью и расположением знака ПСК
КООРД | Определение координат точек
МАРКЕР | Управление простановкой маркеров при рисовании
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПЛАНШЕТ | Настройка, калибровка, включение и отключение графического планшета
ПСК | Управление пользовательскими системами координат
СЕТКА | Отображение точечной сетки на текущем видовом экране, которая не выводится на печать
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
УРОВЕНЬ | Задание уровня и трехмерной высоты для вновь создаваемых объектов
ШАГ | Ограничение перемещения курсора определенными интервалами
Системные переменные
COORDS | Управляет форматом и частотой обновления координат на статусной строке
ELEVATION | Сохраняет текущий уровень новых объектов относительно текущей ПСК
ERRNO | Отображает номер соответствующего кода ошибки, когда вызов функции AutoLISP приводит к ошибки, определенной AutoCAD
LASTPOINT | Сохраняет последнюю введенную точку, выраженную в координатах ПСК в текущем пространстве. Для того чтобы координаты отсчитывались от нее, необходимо начать ввод с клавиатуры с символа @
OSOPTIONS | Автоматически подавляет объектную привязку на объектах штриховки и геометрию с отрицательными значениями Z при использовании динамической ПСК
PUCSBASE | Сохраняет имя ПСК, которая определяет параметры исходной точки и ориентации ортогональной ПСК (только для пространства листа)
TABMODE | Управляет использованием режима "Планшет"
UCSDETECT | Управляет активность сбора данных динамической ПСК
UCSFOLLOW | Устанавливает вид в плане при переходе от одной ПСК к другой
UCSNAME | Сохраняет имя текущей системы координат для текущего видового экрана в текущем пространстве
UCSORG | Сохраняет исходную точку текущей системы координат для текущего видового экрана в текущем пространстве
UCSORTHO | Определяет режим восстановления ортогональной ПСК в момент установки соответствующего ортогонального вида
UCSVP | Определяет, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана
UCSXDIR | Сохраняет направление X текущей ПСК на текущем видовом экране в текущем пространстве
UCSYDIR | Сохраняет направление Y текущей ПСК на текущем видовом экране в текущем пространстве
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Методы записи координат - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Методы записи координат
Понятия
Процедуры
Команды

В ответ на запросы ввода координат пользователь имеет возможность указывать точки с помощью устройства указания или путем ввода значений координат в командной строке. Когда включен параметр "Динамический ввод", можно ввести значения координат в подсказках рядом с курсором. Двумерные координаты могут вводиться как в декартовой (прямоугольной), так и в полярной системе.

Декартовы и полярные координаты

Декартова система координат представляет собой три взаимно перпендикулярные оси: X, Y и Z. При вводе значений координат указывается расстояние для точки (в единицах) и его направление (+ или -) по осям X, Y и Z относительно исходной точки системы координат (0,0,0).

В системе 2D указываются точки в плоскости XY, именуемой также плоскостью видов чертежа. Плоскость видов чертежа подобна листу бумаги в клетку. Значение X в декартовых координатах определяет расстояние по горизонтали, а значение Y определяет расстояние по вертикали. Началом координат считается точка пересечения координатных осей, имеющая координаты (0,0).

В полярной системе координаты точки представляют собой расстояние и угол, отсчитываемые от начала координат. В обоих случаях координаты можно задавать либо в абсолютной, либо в относительной форме. Абсолютные координаты отсчитываются от начала координат (0,0). Относительные координаты отсчитываются от последней указанной точки.

Относительные координаты могут также задаваться путем указания направления с помощью курсора и ввода значения расстояния. Такой способ называется методом "направление-расстояние".

Имеется возможность вводить координаты в следующих форматах: научном, десятичном, инженерном, архитектурном и дробном. Углы могут вводиться в градах, радианах, топографических единицах (в виде румбов), а также в градусах, минутах и секундах. Управление форматом единиц осуществляется командой ЕДИНИЦЫ.

Вывод координат в строке состояния

Текущее положение курсора отображается в виде значения координаты в строке состояния.

В строке состояния координаты могут отображаться в следующих режимах: статическом, динамическом и с представлением линейных и угловых единиц.

  • Статическое отображение. Обновляется только при указании точки.
  • Динамическое отображение. Обновляется по мере движения курсора.
  • Отображение с представлением линейных и угловых единиц. Относительное расстояние обновляется (расстояние<угол) по мере перемещения курсора. Этот режим доступен только при рисовании отрезков и других объектов, требующих ввода более одной точки.

См. также

Задание декартовых координат

Задание полярных координат

3D координаты

Использование динамического ввода


Методы записи координат - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Методы записи координат
Понятия
Процедуры
Команды

Для отображения координат точки

Для визуального определения местоположения точки

Для переключения режима отображения координат в строке состояния


Для отображения координат точки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Методы записи координат
Понятия
Процедуры
Команды

Для отображения координат точки

  1. Выберите в меню "Сервис" » "Сведения" » "Координаты".
  2. Указать точку, координаты которой нужно определить.

    3. Значения координат X, Y, Z выводятся в командной строке.

Панель Сведения

Ввод команды: КООРД


Для визуального определения местоположения точки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Методы записи координат
Понятия
Процедуры
Команды

Для визуального определения местоположения точки

  1. Выберите в меню "Сервис" » "Сведения" » "Координаты".
  2. В командной строке ввести значения координат точки, местоположение которой нужно визуально определить.

    3. Если системная переменная BLIPMODE активна, в заданной точке ставится маркер в виде маленького крестика.

Панель Сведения

Ввод команды: КООРД


Для переключения режима отображения координат в строке состояния - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Методы записи координат
Понятия
Процедуры
Команды

Для переключения режима отображения координат в строке состояния

Воспользоваться одним из следующих способов:

  • В ответ на запрос следующей точки, отображаемый в командной строке, нажмите мышью на индикаторе координат в строке состояния.
  • Нажмите CTRL+L.
  • Установите системную переменную COORDS равной 0 для статического отображения, 1 для динамического отображеия или равной 2 для отображения расстояния и угла.


Методы записи координат - Команды

Средства обеспечения точности
Средства обеспечения точности
Методы записи координат
Понятия
Процедуры
Команды

Команды
КООРД | Определение координат точек
МАРКЕР | Управление простановкой маркеров при рисовании
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
Системные переменные
COORDS | Управляет форматом и частотой обновления координат на статусной строке
LASTPOINT | Сохраняет последнюю введенную точку, выраженную в координатах ПСК в текущем пространстве. Для того чтобы координаты отсчитывались от нее, необходимо начать ввод с клавиатуры с символа @
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


2D декартовы координаты - Понятия

Создание и редактирование объектов
Средства обеспечения точности
2D декартовы координаты
Понятия
Процедуры
Команды

С помощью абсолютных и относительных декартовых и полярных 2D координат определяются точные положения объектов на чертеже.

  • Задание декартовых координат
    Для указания точек при создании объектов можно вводить абсолютные и относительные декартовы (прямоугольные) координаты.
  • Задание полярных координат
    Для указания точек при создании объектов можно вводить абсолютные и относительные полярные координаты.


2D декартовы координаты - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
2D декартовы координаты
Понятия
Процедуры
Команды

Для ввода абсолютных декартовых координат (2D)

Для ввода относительных декартовых координат (2D)

Для ввода абсолютных полярных координат (2D)

Для ввода относительных полярных координат (2D)


2D декартовы координаты - Команды

Создание и редактирование объектов
Средства обеспечения точности
2D декартовы координаты
Понятия
Процедуры
Команды
Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
Системные переменные
COORDS | Управляет форматом и частотой обновления координат на статусной строке
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание декартовых координат - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Задание декартовых координат
Понятия
Процедуры
Команды

Для указания точек при создании объектов можно вводить абсолютные и относительные декартовы (прямоугольные) координаты.

Чтобы воспользоваться декартовыми координатами для задания точки, введите значения X и Y, разделенные запятой (X,Y). Координата X определяет расстояние от начала координат по горизонтали, Y - по вертикали. Значения расстояний могут быть положительными или отрицательными.

Абсолютные координаты базируются на исходной точке ПСК (0,0), которая является пересечением осей X и Y. Такой способ ввода можно применять, если известны точные координаты X и Y точки.

При использовании динамического ввода можно задавать абсолютные координаты с префиксом #. Если координаты вводятся не в подсказке, а в командной строке, префикс # не используется. Например, ввод значения #3,4 указывает на точку, удаленную от исходной точки ПСК на 3 единицы по оси X и на 4 единицы по оси Y. Дополнительную информацию о динамическом вводе см. в разделе Использование динамического ввода.

В приведенном ниже примере проводится линия с началом в точке X= -2 и Y= 1 и с конечной точкой (3,4). Введите в подсказке следующее:

Команда: отрезок

От точки: #-2,1

К точке: #3,4

Линия располагается следующим образом:

Относительные координаты отсчитываются относительно последней введенной точки. Относительные декартовы координаты применяются, если известны значения смещений координат точки относительно предыдущей точки.

Для обозначения относительных координат используется знак @ перед числовыми значениями. Например, чтобы указать точку, удаленную от последней заданной точки по оси X на 3 единицы и по оси Y на 4 единицы, необходимо ввести @3,4.

В приведенном ниже примере показано построение сторон треугольника. Первая сторона представляет собой линию с началом в точке с абсолютными координатами (-2,1) и с конечной точкой, удаленной от начальной точки на 5 единиц по оси X и на 0 единиц по оси Y. Вторая сторона представляет собой линию, начинающуюся в конечной точке первой линии и заканчивающуюся в точке 0 единиц по оси X и 3 единицы по оси Y. Для возврата в начальную точку в конечном сегменте линии используются относительные координаты.

Команда: отрезок

От точки: #-2,1

К точке: @5,0

К точке: @0,3

К точке: @-5,-3


Задание декартовых координат - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание декартовых координат
Понятия
Процедуры
Команды

Для ввода абсолютных декартовых координат (2D)

Для ввода относительных декартовых координат (2D)


Для ввода абсолютных декартовых координат (2D) - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание декартовых координат
Понятия
Процедуры
Команды

Для ввода абсолютных декартовых координат (2D)

  • На запрос координат точки введите координаты в подсказке, используя следующий формат:

    • #x,y

    Если динамический ввод отключен, введите координаты в командной строке, используя следующий формат:

    x,y


Для ввода относительных декартовых координат (2D) - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание декартовых координат
Понятия
Процедуры
Команды

Для ввода относительных декартовых координат (2D)

  • На запрос координат точки в командной строке ввести значения координат в формате:

    • @x,y


Задание декартовых координат - Команды

Средства обеспечения точности
Средства обеспечения точности
Задание декартовых координат
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
COORDS | Управляет форматом и частотой обновления координат на статусной строке
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание полярных координат - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Задание полярных координат
Понятия
Процедуры
Команды

Для указания точек при создании объектов можно вводить абсолютные и относительные полярные координаты.

Чтобы воспользоваться полярными координатами для задания точки, введите значения расстояния и угла, отделяемые друг от друга символом угловой скобки (<).

По умолчанию в AutoCAD возрастание величин углов происходит при движении против часовой стрелки. Чтобы указать направление по часовой стрелке, введите отрицательное значение для угла. Например, введенные значения 1<315 эквивалентны точке со значениями 1<-45. Порядок угловых измерений можно изменять с помощью команды ЕДИНИЦЫ.

Абсолютные полярные координаты измеряются от исходной точки ПСК (0,0), которая является пересечением осей X и Y. Абсолютные полярные координаты используются в том случае, когда известны точные координаты точки, выраженные линейными и угловыми единицами.

При использовании динамического ввода можно задавать абсолютные координаты с префиксом #. Если координаты вводятся не в подсказке, а в командной строке, префикс # не используется. Например, чтобы указать точку, удаленную от начала координат на 3 единицы и под углом 45 градусов от оси X, необходимо ввести #3<45. Дополнительную информацию о динамическом вводе см. в разделе Использование динамического ввода.

Следующий пример иллюстрирует построение двух отрезков в абсолютных полярных координатах с использованием текущего направления отсчета углов. Введите в подсказке следующее:

Команда: отрезок

От точки: #0,0

К точке: #4<120

К точке: #5<30

Относительные координаты отсчитываются относительно последней введенной точки. Относительные декартовы координаты применяются, если известны значения смещений координат точки относительно предыдущей точки.

Для обозначения относительных координат используется знак @ перед числовыми значениями. Например, чтобы указать точку, удаленную от последней заданной точки на 1 единицу и находящуюся под углом 45 градусов от оси X, необходимо ввести @1<45.

Следующий пример иллюстрирует построение двух отрезков в относительных полярных координатах. В каждой иллюстрации отрезок начинается в местоположении, обозначенном как предыдущая точка.

Команда: отрезок

От точки: @3<45

К точке: @5<285


Задание полярных координат - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание полярных координат
Понятия
Процедуры
Команды

Для ввода абсолютных полярных координат (2D)

Для ввода относительных полярных координат (2D)


Для ввода абсолютных полярных координат (2D) - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание полярных координат
Понятия
Процедуры
Команды

Для ввода абсолютных полярных координат (2D)

  • На запрос координат точки введите координаты в подсказке, используя следующий формат:

    • #расстояние<угол

    Если динамический ввод отключен, введите координаты в командной строке, используя следующий формат:

    расстояние<угол


Для ввода относительных полярных координат (2D) - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание полярных координат
Понятия
Процедуры
Команды

Для ввода относительных полярных координат (2D)

  • На запрос координат точки в командной строке ввести значения координат в формате:

    • @расстояние<угол


Задание полярных координат - Команды

Средства обеспечения точности
Средства обеспечения точности
Задание полярных координат
Понятия
Процедуры
Команды

Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
Системные переменные
COORDS | Управляет форматом и частотой обновления координат на статусной строке
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


3D координаты - Понятия

Создание и редактирование объектов
Средства обеспечения точности
3D координаты
Понятия
Процедуры
Команды

При создании объектов в 3D пространстве для указания точек используются декартовы, цилиндрические или сферические координаты.

  • Задание 3D декартовых координат
    3D декартовы координаты указывают на точное расположение с помощью трех координат: X, Y и Z.
  • Задание цилиндрических координат
    3D цилиндрические координаты описывают точное местоположение по расстоянию от начала ПСК в плоскости XY, углу относительно оси X в плоскости XY и значению Z.
  • Задание сферических координат
    3D сферические координаты задают расположение от начала координат текущей ПСК, угол к оси X в плоскости XY и угол в плоскости XY.


3D координаты - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
3D координаты
Понятия
Процедуры
Команды

Для ввода абсолютных координат (3D)

Для ввода относительных координат (3D)

Для ввода относительных цилиндрических координат

Для ввода относительных сферических координат


3D координаты - Команды

Создание и редактирование объектов
Средства обеспечения точности
3D координаты
Понятия
Процедуры
Команды
Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
ЗНАКПСК | Управление видимостью и расположением знака ПСК
ПЛАНШЕТ | Настройка, калибровка, включение и отключение графического планшета
ПСК | Управление пользовательскими системами координат
СЕТКА | Отображение точечной сетки на текущем видовом экране, которая не выводится на печать
ШАГ | Ограничение перемещения курсора определенными интервалами
Системные переменные
COORDS | Управляет форматом и частотой обновления координат на статусной строке
ELEVATION | Сохраняет текущий уровень новых объектов относительно текущей ПСК
TABMODE | Управляет использованием режима "Планшет"
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание 3D декартовых координат - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Задание 3D декартовых координат
Понятия
Процедуры
Команды

3D декартовы координаты указывают на точное расположение с помощью трех координат: X, Y и Z.

Трехмерные декартовы координаты (X,Y,Z) задаются аналогично двухмерным (X,Y) координатам. К двум составляющим по осям X и Y добавляется третья по оси Z. Таким образом, 3D координаты вводятся в формате:

X,Y,Z

Примечание В следующих примерах предполагается, что этот динамический вид отключен, или что координаты введены в командной строке. При использовании динамического ввода можно задавать абсолютные координаты с префиксом #.

В приведенной ниже иллюстрации значения координат 3,2,5 определяют точку в следующем местоположении: 3 единицы вдоль положительной оси X, 2 единицы вдоль положительной оси Y и 5 единиц вдоль положительной оси Z.

Использование значения по оси Z по умолчанию

Если координаты вводятся в формате X,Y, значение Z копируется из ввода для последней точки. В результате, можно ввести местонахождение в формате X,Y,Z, а затем ввести последующие местоположения с использованием формата X,Y со значением Z, которое остается постоянным. Например, для построения отрезка можно ввести следующие координаты:

От точки: 0,0,5

К точке: 3,4

Обе конечные точки отрезка будут иметь одинаковое значение координаты Z, равное 5 единицам. Когда пользователь начинает или открывает любой чертеж, исходное значение по умолчанию координаты Z превышает 0.

Использование абсолютных и относительных координат

Как и в случае 2D координат, можно вводить как абсолютные координаты (отсчитываемые от начала координат), так и относительные (отсчитываемые от последней указанной точки). Для ввода координат в относительной форме используется знак @, указываемый перед числовыми значениями координат. Например, для указания точки, смещенной от предыдущей точки на одну единицу по оси X, следует ввести @1,0,0. Для ввода абсолютных координат никаких предваряющих знаков не требуется. Для ввода абсолютных координат в командной строке никаких предваряющих знаков не требуется.

Задание координат с помощью дигитайзера

При вводе координат дигитайзером координата Z ПСК сохраняет значение 0. Для задания иного значения Z по умолчанию, отличного от 0, без перемещения ПСК можно воспользоваться командой УРОВЕНЬ.


Задание 3D декартовых координат - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание 3D декартовых координат
Понятия
Процедуры
Команды

Для ввода абсолютных координат (3D)

Для ввода относительных координат (3D)


Для ввода абсолютных координат (3D) - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание 3D декартовых координат
Понятия
Процедуры
Команды

Для ввода абсолютных координат (3D)

  • На запрос координат точки введите координаты в подсказке, используя следующий формат:

    • #x,y,z

    Если динамический ввод отключен, введите координаты в командной строке, используя следующий формат:

    x,y,z


Для ввода относительных координат (3D) - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание 3D декартовых координат
Понятия
Процедуры
Команды

Для ввода относительных координат (3D)

  • На запрос координат точки в командной строке ввести значения координат в формате:

    • @x,y,z


Задание 3D декартовых координат - Команды

Средства обеспечения точности
Средства обеспечения точности
Задание 3D декартовых координат
Понятия
Процедуры
Команды

Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
ЗНАКПСК | Управление видимостью и расположением знака ПСК
ПЛАНШЕТ | Настройка, калибровка, включение и отключение графического планшета
ПСК | Управление пользовательскими системами координат
СЕТКА | Отображение точечной сетки на текущем видовом экране, которая не выводится на печать
ШАГ | Ограничение перемещения курсора определенными интервалами
Системные переменные
COORDS | Управляет форматом и частотой обновления координат на статусной строке
ELEVATION | Сохраняет текущий уровень новых объектов относительно текущей ПСК
TABMODE | Управляет использованием режима "Планшет"
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание цилиндрических координат - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Задание цилиндрических координат
Понятия
Процедуры
Команды

3D цилиндрические координаты описывают точное местоположение по расстоянию от начала ПСК в плоскости XY, углу относительно оси X в плоскости XY и значению Z.

Задание цилиндрических координат аналогично заданию полярных координат для 2D пространства. Дополнительно добавляется значение расстояния от указанной полярной координаты до требуемой точки пространства перпендикулярно плоскости XY. Цилиндрические координаты определяют расстояние от начала координат ПСК до проекции точки на плоскость XY, угол относительно оси X и расстояние от точки до плоскости XYпо оси Z. Цилиндрические координаты точки указываются в формате: Цилиндрические координаты точки указываются в формате:

X<[угол к оси X],Z

Примечание В следующих примерах предполагается, что этот динамический вид отключен, или что координаты введены в командной строке. При использовании динамического ввода можно задавать абсолютные координаты с префиксом #.

В приведенной ниже иллюстрации координатами 5<60,6 определяется точка, лежащая на расстоянии 5 единиц от начала текущей ПСК, под углом 60 градусов к оси X в плоскости XY и 6 единиц по оси Z. Координатами 8<30,1 определяется точка, лежащая на расстоянии 8 единиц от начала текущей ПСК в плоскости XY, под углом 30 градусов к оси X в плоскости XY и на расстоянии 1 единицы по оси Z.

Для задания координат относительно предыдущей точки можно использовать относительные цилиндрические координаты, предваряя числовые значения знаком @. В приведенной ниже иллюстрации координатами @4<45,5 определяется точка, лежащая в плоскости XY на расстоянии 4 единицы от последней введенной точки, под углом 45 градусов от положительной оси X и на расстоянии 5 единиц в направлении Z.


Для ввода относительных цилиндрических координат - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание цилиндрических координат
Понятия
Процедуры
Команды

Для ввода относительных цилиндрических координат

  • На запрос координат точки в командной строке ввести значения координат в формате:

    • @x<угол к оси X,z

Например, координаты @4<60,2 задают точку, лежащую от последней измеренной точки на расстоянии 4 единицы по оси X под углом 60 от положительного направления оси X и на 2 единицы в положительном направлении оси Z .


Задание цилиндрических координат - Команды

Средства обеспечения точности
Средства обеспечения точности
Задание цилиндрических координат
Понятия
Процедуры
Команды

Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
Системные переменные
COORDS | Управляет форматом и частотой обновления координат на статусной строке
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание сферических координат - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Задание сферических координат
Понятия
Процедуры
Команды

3D сферические координаты задают расположение от начала координат текущей ПСК, угол к оси X в плоскости XY и угол в плоскости XY.

Ввод сферических координат в 3D пространстве подобен вводу полярных координат в двумерном. Положение точки определяется ее расстоянием от начала координат текущей ПСК, углом к оси X в плоскости XY и углом к плоскости XY.

X<[угол к оси X]<[угол к плоскости XY]

Примечание В следующих примерах предполагается, что этот динамический вид отключен, или что координаты введены в командной строке. При использовании динамического ввода можно задавать абсолютные координаты с префиксом #.

В приведенной ниже иллюстрации координатами 8<60<30 определяется точка, лежащая на расстоянии 8 единиц от начала текущей ПСК в плоскости XY, под углом 60 градусов к оси X в плоскости XY и под углом 30 градусов выше оси Z от плоскости XY. Координатами 5<45<15 определяется точка, лежащая на расстоянии 5 единиц от начала координат, под углом 45 градусов к оси X в плоскости XY и под углом 15 градусов к этой плоскости.

Для задания координат относительно предыдущей точки можно использовать относительные сферические координаты, предваряя числовые значения знаком @.


Для ввода относительных сферических координат - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание сферических координат
Понятия
Процедуры
Команды

Для ввода относительных сферических координат

  • На запрос координат точки в командной строке ввести значения координат в формате:

    • @x<угол к оси X<угол к плоскости XY

Например, координаты @4<60<30 задают точку, лежащую на расстоянии 4 единицы от последней измеренной точки под углом 60 градусов положительного направления оси X в плоскости XY и под углом 30 градусов к плоскости XY.


Задание сферических координат - Команды

Средства обеспечения точности
Средства обеспечения точности
Задание сферических координат
Понятия
Процедуры
Команды

Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
Системные переменные
COORDS | Управляет форматом и частотой обновления координат на статусной строке
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Понятие о пользовательской системе координат (ПСК) - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат (ПСК)
Понятия
Процедуры
Команды

Пользовательскую систему координат можно перемещать и поворачивать для обеспечения удобства записи координат, отображения сетки, привязки к сетке, реализации режима "Орто" и использования других инструментов создания чертежей.

Понятие о мировой и пользовательской системах координат

Существует две системы координат: неподвижная мировая система координат (МСК) и подвижная пользовательская система координат (ПСК). По умолчанию, в новом чертеже две эти системы совпадают между собой.

Как правило, на 2D видах в МСК ось X является горизонтальной осью, а ось Y является вертикалью. Началом ПСК является точка, в которой пересекаются ось X и ось Y (точка 0,0). Все объекты в файле чертежа определяются их МСК-координатами. Однако, более удобным является обычно создание и редактирование объектов на основе перемещаемой ПСК.

Работа с пользовательской системой координат (ПСК)

Практически все записи координат, а также многие другие инструменты и операции соотносятся с текущей ПСК. К 2D инструментам и операциям, зависимым от местоположения и ориентации ПСК, относятся следующие:

  • Запись в абсолютных и относительных координатах
  • Абсолютные углы отсчета
  • Определение горизонтали и вертикали для режима "Орто", полярное отслеживание, отслеживание объектной привязки, отображение сетки и привязка к сетке
  • Ориентация размеров по горизонтали и вертикали
  • Ориентация текстовых объектов
  • Поворот вида с использованием команды ПЛАН

Перемещение или вращение ПСК способно облегчить работу на конкретных площадях чертежа.

Для перемещения пользовательской системы координат можно использовать, например, следующие методы:

  • Перемещение ПСК путем определения новой исходной точки.
  • Выравнивание ПСК по существующему объекту.
  • Поворот ПСК путем обозначения новой исходной точки и точки на новой оси X.
  • Поворот текущей ПСК на указанный угол вокруг оси Z.
  • Возврат к предыдущей ПСК
  • Востановление ПСК для совмещения с МСК.

Каждому из этих методов соответствует опция в команде ПСК. ПСК можно присваивать имя для возможности ее повторного использования в дальнейшем (восстановления).


Понятие о пользовательской системе координат (ПСК) - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат (ПСК)
Понятия
Процедуры
Команды

Определение новой исходной точки ПСК в 2D

Изменение угла поворота ПСК

Востановление ПСК для совмещения с МСК

Для восстановления предыдущей ПСК

Для сохранения ПСК

Для восстановления именованной ПСК

Для переименования ПСК

Удаление именованной ПСК


Определение новой исходной точки ПСК в 2D - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат (ПСК)
Понятия
Процедуры
Команды

Определение новой исходной точки ПСК в 2D

  1. Выберите в меню "Сервис" » "Новая ПСК" » "3 точки"
  2. Укажите точку, в которую нужно переместить начало координат.

    3. Исходная точка ПСК (0,0) заново определяется в точке, указанной пользователем.

Панель ПСК

Ввод команды: ПСК


Изменение угла поворота ПСК - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат (ПСК)
Понятия
Процедуры
Команды

Изменение угла поворота ПСК

  1. Выберите в меню "Сервис" » "Новая ПСК" » Z.
  2. Укажите угол поворота.

Панель ПСК

Ввод команды: ПСК


Востановление ПСК для совмещения с МСК - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат (ПСК)
Понятия
Процедуры
Команды

Востановление ПСК для совмещения с МСК

  1. Выберите в меню "Сервис" » "Именованная ПСК".
  2. В диалоговом окне "ПСК" на вкладке "Именованные ПСК" выделите "Мировая СК".
  3. Нажмите кнопку "Установить".
  4. Нажмите "ОК".

Панель ПСК

Ввод команды: ДИСПСК


Для восстановления предыдущей ПСК - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат (ПСК)
Понятия
Процедуры
Команды

Для восстановления предыдущей ПСК

  1. Выберите в меню "Сервис" » "Именованная ПСК".
  2. В диалоговом окне "ПСК" на вкладке "Именованные ПСК" выберите "Предыдущая".
  3. Нажмите кнопку "Установить".
  4. Нажмите "ОК".

Панель ПСК

Ввод команды: ДИСПСК


Для сохранения ПСК - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат (ПСК)
Понятия
Процедуры
Команды

Для сохранения ПСК

  1. Выберите в меню "Сервис" » "Именованная ПСК".

    2. Новая ПСК отображается в списке ПСК в качестве системы БЕЗ ИМЕНИ.

  2. Во вкладке "Именованные ПСК" диалогового окна "ПСК" выберите "БЕЗ ИМЕНИ" и введите новое имя. (Можно выбрать также опцию БЕЗ ИМЕНИ и нажать правую кнопку мыши. Выберите "Переименовать".)
  3. Нажать "ОК".

    4. Имя может быть длиной до 255 символов, содержать буквенные символы, цифры и специальные символы (знак доллара ($), минус (-) и знак подчеркивания (_)). Все имена ПСК преобразуются в верхний регистр.

Панель ПСК

Ввод команды: ДИСПСК


Для восстановления именованной ПСК - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат (ПСК)
Понятия
Процедуры
Команды

Для восстановления именованной ПСК

  1. Выберите в меню "Сервис" » "Именованная ПСК".
  2. В диалоговом окне "ПСК" на вкладке "Именованные ПСК" пользователь может увидеть начало координат и направление осей указанной ПСК. Выберите имя ПСК. Щелкните "Подробности".

    3. Нажать кнопку "OK" для завершения просмотра данных о ПСК и возврата в диалоговое окно "ПСК".

  3. Выберите систему координат, которую нужно восстановить. Выберите "Установить".
  4. Нажмите "ОК".

Панель ПСК

Ввод команды: ДИСПСК


Для переименования ПСК - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат (ПСК)
Понятия
Процедуры
Команды

Для переименования ПСК

  1. Выберите в меню "Сервис" » "Именованная ПСК".
  2. В диалоговом окне "ПСК" на вкладке "Именованные ПСК" выделите ПСК, которую нужно переименовать. (Можно выбрать также опцию БЕЗ ИМЕНИ и нажать правую кнопку мыши. Выбрать "Переименовать".)
  3. Введите новое имя.
  4. Нажмите "ОК".

Панель ПСК

Ввод команды: ДИСПСК


Удаление именованной ПСК - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат (ПСК)
Понятия
Процедуры
Команды

Удаление именованной ПСК

  1. Выберите в меню "Сервис" » "Именованная ПСК".
  2. В диалоговом окне "ПСК" перейдите на вкладку "Именованные ПСК" и выделите ПСК, которую нужно удалить.
  3. Нажмите клавишу Delete.

    4. Нельзя удалять текущую ПСК и ПСК с именем по умолчанию БЕЗ ИМЕНИ.

Панель ПСК

Ввод команды: ДИСПСК


Понятие о пользовательской системе координат (ПСК) - Команды

Средства обеспечения точности
Средства обеспечения точности
Понятие о пользовательской системе координат (ПСК)
Понятия
Процедуры
Команды

Команды
ДИСПСК | Управление заданными пользовательскими системами координат
ЗНАКПСК | Управление видимостью и расположением знака ПСК
ПСК | Управление пользовательскими системами координат
Системные переменные
ERRNO | Отображает номер соответствующего кода ошибки, когда вызов функции AutoLISP приводит к ошибки, определенной AutoCAD
PUCSBASE | Сохраняет имя ПСК, которая определяет параметры исходной точки и ориентации ортогональной ПСК (только для пространства листа)
UCSFOLLOW | Устанавливает вид в плане при переходе от одной ПСК к другой
UCSNAME | Сохраняет имя текущей системы координат для текущего видового экрана в текущем пространстве
UCSORG | Сохраняет исходную точку текущей системы координат для текущего видового экрана в текущем пространстве
UCSORTHO | Определяет режим восстановления ортогональной ПСК в момент установки соответствующего ортогонального вида
UCSXDIR | Сохраняет направление X текущей ПСК на текущем видовом экране в текущем пространстве
UCSYDIR | Сохраняет направление Y текущей ПСК на текущем видовом экране в текущем пространстве
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание плоскостей видов чертежа в 3D (ПСК) - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Задание плоскостей видов чертежа в 3D (ПСК)
Понятия
Процедуры
Команды

Возможность управления пользовательской системой координат (ПСК) является важным условием для эффективного построения моделей в трехмерном пространстве.

  • Понятие о пользовательской системе координат в 3D
    При работе в 3D пользовательская система координат полезна для записи координат, создания 3D объектов на 2D плоскостях видов чертажа и для поворота объектов в 3D.
  • Задание пользовательской системы координат в 3D пространстве
    Существует несколько способов задания пользовательской системы координат. Положение координатной системы можно сохранять и восстанавливать.
  • Использование динамической ПСК с моделями тел
    С помощью функции динамической ПСК можно на время автоматически выровнять XY-плоскость ПСК по плоскости в модели тела при создании объектов.


Задание плоскостей видов чертежа в 3D (ПСК) - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание плоскостей видов чертежа в 3D (ПСК)
Понятия
Процедуры
Команды

Для ввода координат относительно МСК

Определение новой ПСК заданием трех точек

Поворот ПСК вокруг большой оси

Определение новой исходной точки ПСК в 3D

Определение новой ПСК с заданной осью Z

Определение новой ПСК с заданными осями X и Y

Для переноса плоскости XY

Для установки стандартной ПСК

Для восстановления местоположения и ориентации предыдущей ПСК

Замена ПСК динамическим способом


Задание плоскостей видов чертежа в 3D (ПСК) - Команды

Создание и редактирование объектов
Средства обеспечения точности
Задание плоскостей видов чертежа в 3D (ПСК)
Понятия
Процедуры
Команды
Команды
ДИСПСК | Управление заданными пользовательскими системами координат
ЗНАКПСК | Управление видимостью и расположением знака ПСК
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПСК | Управление пользовательскими системами координат
УРОВЕНЬ | Задание уровня и трехмерной высоты для вновь создаваемых объектов
Системные переменные
ELEVATION | Сохраняет текущий уровень новых объектов относительно текущей ПСК
OSOPTIONS | Автоматически подавляет объектную привязку на объектах штриховки и геометрию с отрицательными значениями Z при использовании динамической ПСК
UCSDETECT | Управляет активность сбора данных динамической ПСК
UCSVP | Определяет, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Понятие о пользовательской системе координат в 3D - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат в 3D
Понятия
Процедуры
Команды

При работе в 3D пользовательская система координат полезна для записи координат, создания 3D объектов на 2D плоскостях видов чертажа и для поворота объектов в 3D.

При создании или редактировании объектов в 3D среде можно перемещать и переориентировать ПСК в 3D пространстве модели с целью упрощения работы. XY-плоскость ПСК именуется плоскостью видов чертежа.

Важными операциями на объектах в 3D среде, зависимыми от местоположения и ориентации ПСК, являются следующие:

  • Определение плоскости видов чертежа для создания и редактирования объектов
  • Определение плоскости видов чертежа, содержащей отображение сетки и привязку к сетке
  • Определение новой Z-оси ПСК в качестве оси для вращения объектов в 3D
  • Определение направлений вверх и вниз, а также горизонтального и вертикального направлений для режима "Орто", полярного отслеживания и отслеживания объектной привязки
  • Определение 3D вида напрямую в плоскости видов чертежа с помощью команды ПЛАН
Правило правой руки

Правило правой руки позволяет задать положительное направление оси Z, если в 3D системе координат известны направления осей X и Y. Кроме того, данное правило определяет положительное направление вращения вокруг любой из 3D осей координат. Если ориентировать большой палец правой руки согласно положительному направлению оси и согнуть остальные пальцы, то положительное направление вращения будет совпадать с направлением, указываемым согнутыми пальцами. Средний палец указывает на направление положительной оси Z. При повороте кисти руки можно наблюдать, как меняется положение осей X, Y и Z во время аналогичного вращения ПСК.

Кроме того, правило правой руки можно использовать с целью определения положительного направления вращения по умолчанию вокруг оси в 3D пространстве. Если ориентировать большой палец правой руки согласно положительному направлению оси и согнуть остальные пальцы, то положительное направление вращения будет совпадать с направлением, указываемым согнутыми пальцами.

Примечание По умолчанию, определяемый в 3D вид устанавливается по отношению не к перемещаемой ПСК, а к неподвижной МСК.


Понятие о пользовательской системе координат в 3D - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат в 3D
Понятия
Процедуры
Команды

Для ввода координат относительно МСК

Определение новой ПСК заданием трех точек

Поворот ПСК вокруг большой оси


Для ввода координат относительно МСК - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат в 3D
Понятия
Процедуры
Команды

Для ввода координат относительно МСК

  • Поместите перед значениями координат символ звездочки (*).

Ввод @*2,0,0 указывает на точку, отстоящую на 2 единицы в направлении X от последней точки, введенной относительно МСК. Ввод @2,0,0 указывает на точку, отстоящую на 2 единицы в направлении X от последней точки, введенной относительно ПСК.

Как правило, в большинстве случаев координаты задаются не относительно МСК, а относительно ПСК.


Определение новой ПСК заданием трех точек - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат в 3D
Понятия
Процедуры
Команды

Определение новой ПСК заданием трех точек

  1. Выберите в меню "Сервис" » "Новая ПСК" » "3 точки".
  2. Укажите новую исходную точку. Это точка (0,0,0) в новой ПСК.
  3. Укажите точку на положительной оси X новой ПСК.
  4. Укажите точку в положительной плоскости XY новой ПСК.


Поворот ПСК вокруг большой оси - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Понятие о пользовательской системе координат в 3D
Понятия
Процедуры
Команды

Поворот ПСК вокруг большой оси

  1. Выберите в меню "Сервис" » "Новая ПСК" » Z (иначе, можно выбрать X или Y).
  2. Введите угол поворота. Угол поворота обычно равен 90.


Понятие о пользовательской системе координат в 3D - Команды

Средства обеспечения точности
Средства обеспечения точности
Понятие о пользовательской системе координат в 3D
Понятия
Процедуры
Команды

Команды
ДИСПСК | Управление заданными пользовательскими системами координат
ЗНАКПСК | Управление видимостью и расположением знака ПСК
ПСК | Управление пользовательскими системами координат
Системные переменные
UCSVP | Определяет, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание пользовательской системы координат в 3D пространстве - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Задание пользовательской системы координат в 3D пространстве
Понятия
Процедуры
Команды

Существует несколько способов задания пользовательской системы координат. Положение координатной системы можно сохранять и восстанавливать.

Пользователь определяет пользовательскую систему координат (ПСК) с целью изменить местоположение исходной точки 0,0,0, местоположение и угол поворота плоскости XY и ориентацию плоскости XY или оси Z. Пользователь может расположить и сориентировать ПСК на любом месте в 3D пространстве и может определить, сохранить и заново вызвать такое количество сохраненных адресов ПСК, какое ему требуется.

Если на экране монитора располагается несколько видовых экранов, на каждом из них можно установить свою ПСК. Присваивая системной переменной UCSVP значение 1 (Вкл), можно сохранять положение ПСК для каждого видового экрана.

Задание ПСК

Задание новой ПСК может быть осуществлено следующими способами:

  • Задать новую исходную точку (одну), новую ось X (две точки) или новую плоскость XY (три точки).

  • Выровнять ПСК путем выбора грани на объекте 3D тела. Выбор может быть сделан на грани или на ребре тела.

  • Совместить новую РСК с существующим объектом. Исходная точка ПСК расположена в вершине, максимально приближенной к позиции, на которой был выбран объект.

  • Совместить новую ПСК с текущим направлением взгляда

  • Повернуть текущую ПСК вокруг любой из трех ее больших осей.

  • Переориентировать плоскость XY путем задания новой оси Z.

Стандартные ПСК

Существует возможность установки любой из стандартных координатных систем, Доступные варианты выбора указаны в изображениях на вкладке "Ортогональные ПСК" диалогового окна "(Именованные) ПСК".

Изменение текущего уровня

Командой УРОВЕНЬ задается значение Z по умолчанию для новых объектов, находящихся выше или ниже плоскости XY в текущей ПСК. Эти сведения хранятся в системной переменной ELEVATION.

Примечание Обычно рекомендуется оставлять уровень равным нулю и управлять положением плоскости построений (XY) с помощью команды ПСК.

Задание ПСК в пространстве листа

В пространстве листа новая ПСК может быть определена таким же образом, как и в пространстве модели; однако здесь разрешены только 2D операции с ПСК. Несмотря на возможность ввода 3D координат в пространство листа, не разрешается использовать такие команды 3D просмотра, как ПЛАН и ТЗРЕНИЯ.

Сохранение ПСК с присвоением имени и последующее восстановление

При интенсивном 3D моделировании полезно именовать и сохранять ПСК с различными точками начала и ориентацией. Определять, сохранять и восстанавливать различные ПСК можно неограниченное число раз.


Задание пользовательской системы координат в 3D пространстве - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание пользовательской системы координат в 3D пространстве
Понятия
Процедуры
Команды

Определение новой исходной точки ПСК в 3D

Определение новой ПСК с заданной осью Z

Определение новой ПСК с заданными осями X и Y

Для переноса плоскости XY

Для установки стандартной ПСК

Для восстановления местоположения и ориентации предыдущей ПСК


Определение новой исходной точки ПСК в 3D - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание пользовательской системы координат в 3D пространстве
Понятия
Процедуры
Команды

Определение новой исходной точки ПСК в 3D

  1. Выберите в меню "Сервис" » "Новая ПСК" » "Начало".
  2. Укажите точку, в которую нужно переместить начало координат.

    3. Исходная точка ПСК (0,0,0) заново определяется в указанной здесь точке.

Панель ПСК

Ввод команды: ПСК


Определение новой ПСК с заданной осью Z - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание пользовательской системы координат в 3D пространстве
Понятия
Процедуры
Команды

Определение новой ПСК с заданной осью Z

  1. Выберите в меню "Сервис" » "Новая ПСК" » "Zось"
  2. Укажите точку, в которую нужно переместить начало координат.

    3. Исходная точка ПСК (0,0,0) заново определяется в указанной здесь точке.

  3. Укажите точку, находящуюся на положительной оси Z.

Панель ПСК

Ввод команды: ПСК


Определение новой ПСК с заданными осями X и Y - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание пользовательской системы координат в 3D пространстве
Понятия
Процедуры
Команды

Определение новой ПСК с заданными осями X и Y

  1. Выберите в меню "Сервис" » "Новая ПСК" » "3 точки"
  2. Укажите точку, в которую нужно переместить начало координат.

    3. Исходная точка ПСК (0,0,0) заново определяется в указанной здесь точке.

  3. Укажите точку, находящуюся на положительной оси X.
  4. Укажите точку, находящуюся на положительной оси Y.

Панель ПСК

Ввод команды: ПСК


Для переноса плоскости XY - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание пользовательской системы координат в 3D пространстве
Понятия
Процедуры
Команды

Для переноса плоскости XY

  1. Выберите в меню "Сервис" » "Новая ПСК" » "3 точки"
  2. Укажите точку, куда нужно переместить начало координат новой ПСК (1).

    3. В крупном чертеже, например, имеет смысл устанавливать начало координат ПСК в той части, где предполагается выполнение построений.

  3. Укажите точку для задания горизонтальной ориентации новой ПСК (2). Эта точка будет определять положительное направление оси X новой ПСК.
  4. Укажите точку для задания вертикальной ориентации ПСК (3). Эта точка будет определять положительное направление оси Y новой ПСК.

    5. ПСК (вместе с сеткой) изменяет положение в соответствии с заданными параметрами.

Панель ПСК

Ввод команды: ПСК


Для установки стандартной ПСК - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание пользовательской системы координат в 3D пространстве
Понятия
Процедуры
Команды

Для установки стандартной ПСК

  1. Выберите в меню "Сервис" » "Ортогональные ПСК" » "Установленный".
  2. В диалоговом окне "ПСК" на вкладке "Ортогональные ПСК" выберите ПСК из списка.
  3. Нажмите кнопку "Установить".
  4. Нажмите "ОК".

    5. Устанавливается ПСК в соответствии с заданными параметрами.

Панель ПСК-2

Ввод команды: ДИСПСК


Для восстановления местоположения и ориентации предыдущей ПСК - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание пользовательской системы координат в 3D пространстве
Понятия
Процедуры
Команды

Для восстановления местоположения и ориентации предыдущей ПСК

  • В командной строке ввести пск. Затем ввести п (Предыдущая).

Восстанавливается предыдущая ПСК.

Панель ПСК

Ввод команды: ПСК


Задание пользовательской системы координат в 3D пространстве - Команды

Средства обеспечения точности
Средства обеспечения точности
Задание пользовательской системы координат в 3D пространстве
Понятия
Процедуры
Команды

Команды
ДИСПСК | Управление заданными пользовательскими системами координат
ПСК | Управление пользовательскими системами координат
УРОВЕНЬ | Задание уровня и трехмерной высоты для вновь создаваемых объектов
Системные переменные
ELEVATION | Сохраняет текущий уровень новых объектов относительно текущей ПСК
UCSVP | Определяет, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование динамической ПСК с моделями тел - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Использование динамической ПСК с моделями тел
Понятия
Процедуры
Команды

С помощью функции динамической ПСК можно на время автоматически выровнять XY-плоскость ПСК по плоскости в модели тела при создании объектов.

Во время выполнения команды рисования выравнивание ПСК обеспечивается не использованием команды ПСК, а перемещением пользовательского указателя на ребро грани. Когда выполнение команды завершается, ПСК возвращается на свое предыдущее место с сохранением прежней ориентации.

Показать: Использование динамической ПСК с моделями тел

Нажмите на стрелку "Просмотр" для запуска анимации.

Например, можно использовать динамическую ПСК с целью создания прямоугольника над расположенной под углом грани модели тела, как показано на рисунке.

На левом рисунке ПСК не выровнена по расположенной под углом грани. Вместо перемещения ПСК выполняется активизация динамической ПСК на строке состояния или нажатием F6.

Как показано на среднем рисунке, при перемещении указателя по всему ребру курсор изменяется для отображения направления осей динамической ПСК. Далее можно легко создавать объекты на расположенной под углом грани, как показано на правом рисунке.

Примечание Для отображения меток XYZ на курсоре нажмите правую кнопку мыши на кнопке ДПСК и нажмите на "Отобразить метки на перекрестьях".

Ось X динамической ПСК располагается вдоль ребра грани, и положительное направление оси X всегда указывает на правую половину экрана. Динамическая ПСК способна обнаружить только передние грани тела.

Ниже указаны типы команд, в которых можно использовать динамическую ПСК.

  • Простая геометрияЛиния, полилиния, прямоугольник, дуга, окружность
  • Текст.Текст, многострочный текст, таблица
  • Ссылки.Вставка, внешняя ссылка
  • Тела.Примитивные тела и ПОЛИТЕЛО
  • Редактирование.Поворот, зеркальное отражение, выравнивание
  • Прочее.ПСК, площадь, манипулирование ручками

Можно легко выровнять ПСК по плоскости в модели тела путем активизации функции динамической ПСК с последующим использованием команды ПСК для определения исходной точки в данной плоскости.

Если активны режимы "Сетка" и "Привязка", они на время выравниваются по динамической ПСК. Лимиты отображения сетки устанавливаются автоматически.

Можно на время отключить динамическую ПСК нажатием F6 или SHIFT+Я во время перемещения указателя по грани.

Примечание Динамическая ПСК доступна только при активной команде.


Замена ПСК динамическим способом - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование динамической ПСК с моделями тел
Понятия
Процедуры
Команды

Замена ПСК динамическим способом

  1. Вызовите команду, поддерживаемую динамической ПСК.
  2. Если требуется, заново активизируйте ПСК нажатием ДПСК на строке состояния.
  3. Переместите текущий указатель на ребро грани на модели тела.
  4. Завершите выполнение команды.


Использование динамической ПСК с моделями тел - Команды

Средства обеспечения точности
Средства обеспечения точности
Использование динамической ПСК с моделями тел
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
OSOPTIONS | Автоматически подавляет объектную привязку на объектах штриховки и геометрию с отрицательными значениями Z при использовании динамической ПСК
UCSDETECT | Управляет активность сбора данных динамической ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Назначение пользовательской системы координат видовому экрану - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Назначение пользовательской системы координат видовому экрану
Понятия
Процедуры
Команды

Чтобы облегчить редактирование объектов на различных видах, можно определить отличную от других ориентацию ПСК для каждого вида.

На видовые экраны можно выводить различные виды модели. Один из примеров возможных конфигураций - виды сверху, спереди, справа и в изометрии. Чтобы повысить удобство работы, для каждого видового экрана можно задать и сохранить отдельную ПСК. В этом случае при переключении между видовыми экранами не происходит потери информации о ПСК каждого из них.

Сохранением ПСК для каждого видового экрана управляет системная переменная UCSVP. На видовых экранах, где UCSVP равна 1, ПСК, использованная непосредственно перед переходом на другой видовой экран, запоминается; при возврате на данный видовой экран происходит ее восстановление. Если для видового экрана системная переменная UCSVP установлена равной 0, то ПСК этого видового экрана всегда совпадает с ПСК текущего активного видового экрана.

Например, можно задать три видовых экрана: с видами сверху, спереди и изометрическим. Если системная переменная UCSVP устанавливается равной 0 вна изометрическом видовом экране, можно использовать ПСК, соответствующую виду сверху, и на видовом экране вида сверху, и на изометрическом видовом экране. Когда видовой экран вида сверху становится текущим видовым экраном, то в ПСК изометрического видового экрана отражается ПСК видового экрана вида сверху. Аналогично, когда текущим становится видовой экран вида спереди, то ПСК изометрического видового экрана переключается для согласования с ПСК видового экрана вида спереди.

Ниже приведены иллюстрации к рассмотренному примеру. На первом чертеже текущим является левый верхний видовой экран (с видом сверху). На изометрическом видовом экране устанавливается ПСК, определенная на этом виде.

На следующем чертеже текущим является левый нижний видовой экран (с видом спереди). ПСК на изометрическом виде изменяется, и теперь соответствует системе координат вида спереди.

В предыдущих версиях AutoCAD установка ПСК была глобальной и действовала для всех видовых экранов как в пространстве модели, так и в пространстве листа. Если необходимо восстановить характеристики из предыдущих версий, можно присвоить переменной UCSVP значение 0 на всех активных видовых экранах.


Для применения текущей ПСК к другим видовым экранам - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Назначение пользовательской системы координат видовому экрану
Понятия
Процедуры
Команды

Для применения текущей ПСК к другим видовым экранам

  1. Убедитесь, что ПСК, которую нужно применить, является текущей.
  2. Выберите в меню "Сервис" » "Новая ПСК" » "Применить"
  3. Укажите видовой экран, к которому должна быть применена текущая ПСК, или введите все для применения ее параметров ко всем активным видовым экранам.

Ввод команды: ПСК


Назначение пользовательской системы координат видовому экрану - Команды

Средства обеспечения точности
Средства обеспечения точности
Назначение пользовательской системы координат видовому экрану
Понятия
Процедуры
Команды

Команды
ПСК | Управление пользовательскими системами координат
Системные переменные
UCSVP | Определяет, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Знак пользовательской системы координат - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Знак пользовательской системы координат
Понятия
Процедуры
Команды

Для облегчения работы с ПСК можно воспользоваться знаком пользовательской системы координат. Имеется несколько вариантов этого знака. Можно изменять его размеры, расположение и цвет.

Для обозначения местоположения и ориентации ПСК ее значок отображается либо в начале ПСК, либо в левом нижнем углу текущего видового экрана.

Для представления ПСК можно выбрать один из трех знаков.

Команда ЗНАКПСК используется для выбора между отображением 2D или 3D знака ПСК. Затененный знак ПСК отображается для затененного 3D вида. Для обозначения местоположения и ориентации ПСК можно отобразить значок ПСК в исходной точке ПСК с помощью команды ЗНАКПСК.

Если знак находится в точке начала координат текущей ПСК, он помечается крестиком (+). Если же знак расположен в левом нижнем углу видового экрана, крестик не ставится.

При наличии нескольких видовых экранов на каждом из них отображается свой знак ПСК.

Знак ПСК отображается по-разному, что облегчает визуальное представление ориентации плоскости видов чертежа. Некоторые из возможных вариантов представлены на чертеже.

Для переключения между двумерным и трехмерным знаками ПСК можно использовать команду ЗНАКПСК. Для трехмерного знака ПСК также можно изменять размер, цвет, тип стрелок осей и толщину линий.

Знак ПСК с изображением сломанного карандаша заменяет 2D знак ПСК, когда направление взгляда находится в плоскости, параллельной XY-плоскости ПСК. Знак с изображением сломанного карандаша указывает на то, что ребро плоскости XY почти перпендикулярно текущему направлению взгляда. В данном случае использование указывающего устройства для задания координат невозможно.

Обычно считается, что точки, выбираемые с помощью устройства указания, располагаются в плоскости XY. Если ПСК повернута таким образом, что Z-ось располагается в плоскости, параллельной плоскости взгляда—то есть, если XY-плоскость повернута ребром к наблюдателю—визуальное определение места нахождения точки может оказаться затруднительным.i В этом случае точки будут проецироваться на плоскость, параллельную плоскости вида и проходящую через начало координат. Например, если направление взгляда параллельно оси X, указанная на экране точка проецируется на плоскость YZ, содержащую начало ПСК.

Для определения плоскости проекции координат следует использовать режим 3D знака ПСК.


Знак пользовательской системы координат - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Знак пользовательской системы координат
Понятия
Процедуры
Команды

Для включения и отключения знака ПСК

Для установки знака ПСК в начало координат

Для настройки параметров знака ПСК


Для включения и отключения знака ПСК - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Знак пользовательской системы координат
Понятия
Процедуры
Команды

Для включения и отключения знака ПСК

  • Выберите в меню "Вид" » "Экран" » "Знак ПСК" » "Выбор Вкл".

    • Наличие пометки в этом пункте свидетельствует о том, что знак включен.

Ввод команды: ЗНАКПСК


Для установки знака ПСК в начало координат - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Знак пользовательской системы координат
Понятия
Процедуры
Команды

Для установки знака ПСК в начало координат

  • Выберите в меню "Вид" » "Экран" » "Знак ПСК" » "Начало".

    • Знак ПСК смещается в начало координат. Наличие пометки около пункта "Начало" свидетельствует о том, что знак находится в начале координат.

Ввод команды: ЗНАКПСК


Для настройки параметров знака ПСК - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Знак пользовательской системы координат
Понятия
Процедуры
Команды

Для настройки параметров знака ПСК

  1. Выберите в меню "Вид" » "Экран" » "Знак ПСК" » "Свойства".
  2. В диалоговом окне "Знак ПСК" настройте параметры.
  3. Нажать "ОК".

Ввод команды: ЗНАКПСК


Знак пользовательской системы координат - Команды

Средства обеспечения точности
Средства обеспечения точности
Знак пользовательской системы координат
Понятия
Процедуры
Команды

Команды
ЗНАКПСК | Управление видимостью и расположением знака ПСК
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование динамического ввода - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Функция динамического ввода обеспечивает командный интерфейс в области курсора, позволяющий удерживать фокус в области построения.

Когда параметр "Динамический ввод" включен, сведения, отображаемые в подсказках, рядом с курсором динамически обновляются по мере перемещения курсора. Когда команда активна, подсказки обеспечивают место для ввода, осуществляемого пользователем.

Если ввести значение в поле ввода и нажать клавишу TAB, в поле отображается значок блокировки, привязанный к введенному значению. После этого можно вводить значение для второго поля ввода. Иначе, если ввести значение и нажать ENTER, второе поле игнорируется и значение интерпретируется в качестве прямой записи расстояния.

Для выполнения команды или использования ручек необходимы действия, аналогичные действиям командной строки. Разница заключается в том, что внимание сосредоточено возле курсора.

Динамический ввод не является полной заменой окна команды. Можно скрыть окно команды, чтобы добавить для чертежа дополнительную область экрана, но оно может потребоваться для некоторых операций. При необходимости нажмите F2 для скрытия и отображения подсказок команд и сообщений об ошибках. Можно также разблокировать окно команды и использовать параметр "Автоматически убирать с экрана" для разворачивания окна.

Включение и отключение функции динамического ввода

Щелкните DYN в строке состояния, чтобы включить или отключить функцию динамического ввода. Чтобы временно ее отключить, нажмите клавишу F12. Функция динамического ввода содержит три компонента: ввод с помощью мыши, ввод размеров и динамические подсказки. Нажмите правой кнопкой мыши Dyn и выберите "Настройки", чтобы управлять тем, что отображается каждым компонентом, когда включена функция динамического ввода.

Ввод с помощью мыши

Когда ввод с помощью мыши включен и команда активна, положение курсоров в форме перекрестия отображается в виде координат в подсказке возле курсора. Значения координат можно вводить не в подсказке, а в командной строке.

Значением по умолчанию для второй и последующих точек являются относительные полярные координаты (относительная декартова координата для ПРЯМОУГ). Знак @ не требуется вводить. Если требуется использовать абсолютные координаты, используйте префикс решетка (#). Например, для перемещения объекта в исходную точку при запросе второй точки введите #0,0.

Воспользуйтесь настройками ввода с помощью мыши для изменения формата по умолчанию, используемого в координатах, и для управления отображением подсказок при вводе с помощью мыши.

Ввод размеров

Когда функция ввода размеров включена, в ответ на запросе второй точки подсказки отображают линейные и угловые значения. Значения в размерных подсказках изменяются по мере перемещения курсора. Для перехода к значению, которое нужно изменить, нажмите клавишу TAB. Ввод размеров возможен для команд ДУГА, КРУГ, ЭЛЛИПС, ОТРЕЗОК и ПЛИНИЯ.

В случае использования ручек для редактирования объекта, подсказки для ввода размеров могут отображать следующую информацию:

  • Исходная длина
  • Длина, которая обновляется при перемещении ручки
  • Изменение длины
  • Угол
  • Изменение угла при перемещении ручки
  • Радиус дуги

Воспользуйтесь настройками ввода размеров для отображения только необходимой информации.

При использовании ручек для растяжения объектов или при создании новых объектов во время ввода размеров отображаются только острые углы, то есть все углы, равные или меньше 180 градусов. Таким образом, угол 270 градусов отображается как угол, равный 90 градусам, независимо от установки системной переменной ANGDIR (установленной в диалоговом окне "Единицы чертежа"). При определении направления положительного угла углы, заданные при создании новых объектов, основываются на местоположении курсора.

Динамические подсказки

Когда функция динамических подсказок включена, запросы отображаются в подсказке возле курсора. Ответ можно вводить не в подсказке, а в командной строке. Нажмите клавишу СТРЕЛКА ВНИЗ для просмотра и выбора параметров. Нажмите клавишу СТРЕЛКА ВВЕРХ для отображения последних введенных команд.

Примечание Чтобы воспользоваться командой ВСТБУФЕР в динамической подсказке, прежде чем вставить запись, введите любую букву, а затем удалите ее клавишей Backspace. Иначе запись будет вставлена в чертеж как текст.


Использование динамического ввода - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Для ввода значений координат в подсказках динамического ввода

Для исправления ошибок ввода в подсказках динамического ввода

Для указания относительных или абсолютных координат в подсказках для ввода с помощью мыши

Для выбора параметров в динамической подсказке

Для изменения цвета, размера или прозрачности подсказок

Объединение информации из всех подсказок о построениях в одну подсказку.

Для включения или отключения динамического ввода

Для изменения настроек ввода с помощью мыши

Для изменения настроек ввода размеров

Для отображения запросов в подсказках


Для ввода значений координат в подсказках динамического ввода - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Для ввода значений координат в подсказках динамического ввода

  1. В строке состояния и убедитесь, что функция динамического ввода (кнопка Dyn) включена.
  2. Для ввода значений координат или выбора параметров используйте любой из следующих способов:
    • Чтобы ввести полярные координаты, введите расстояние от первой точки и нажмите клавишу TAB, затем введите значение угла и нажмите клавишу ENTER.
    • Чтобы ввести декартовы координаты, введите значение координаты оси X, запятую (,), затем введите значение координаты Y и нажмите клавишу ENTER.
    • Если после запроса следует значок стрелки вниз, нажимайте клавишу "СТРЕЛКА ВНИЗ", пока рядом с параметром не отобразится точка. Нажать ENTER.
    • Чтобы использовать последние координаты, нажмите клавишу СТРЕЛКА ВВЕРХ или нажмите правой кнопкой мыши. Чтобы использовать координаты из контекстного меню, нажмите "Последний ввод".

Примечание При вводе размеров после ввода значения в поле для ввода и нажатия клавиши TAB в поле отображается значок блокировки, а курсор ограничен введенным значением.


Для исправления ошибок ввода в подсказках динамического ввода - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Для исправления ошибок ввода в подсказках динамического ввода

  • Если в подсказке о динамическом вводе отображается красный контур ошибки, выбирается текущая запись. Замените выбранный текст подстановкой с клавиатуры. Для исправления введенной записи можно также использовать клавиши СТРЕЛКА ВПРАВО, СТРЕЛКА ВЛЕВО, ОБРАТНЫЙ ПРОБЕЛ и DELETE. После того, как исправление выполнено, для удаления красного контура и завершения построения координат нажмите клавишу TAB, введите запятую (,) или символ знака «меньше» (<).
  • Если в подсказке для ввода с помощью мыши нужно изменить введенные символы @, # или *, просто введите нужный символ. Необязательно пользоваться клавишей Backspace.


Для указания относительных или абсолютных координат в подсказках для ввода с помощью мыши - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Для указания относительных или абсолютных координат в подсказках для ввода с помощью мыши

  • Чтобы ввести абсолютные координаты, когда в подсказке отображаются относительные координаты, введите символ # для временного отключения системной переменной DYNPICOORDS.
  • Чтобы ввести относительные координаты, когда отображаются абсолютные координаты, введите символ @ для временного отключения системной переменной DYNPICOORDS.
  • Для ввода координат, заданных в мировой системе координат (МСК), введите *.

Примечание Во время ввода с помощью мыши для доступа к префиксам # и * можно использовать контекстное меню.


Для выбора параметров в динамической подсказке - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Для выбора параметров в динамической подсказке

  1. Вызовите команду.

    2. Подсказки возле курсоров в форме перекрестия отображают координаты положения курсора и подсказки.

  2. Если подсказка отображается, нажмите клавишу СТРЕЛКА ВНИЗ для отображения параметров.
  3. Нажмите клавишу СТРЕЛКА ВНИЗ или СТРЕЛКА ВВЕРХ, чтобы поместить точку рядом с нужным параметром. Нажать ENTER.

    4. Нажмите клавишу ESC, чтобы отменить последнее действие.

  4. Укажите точки и введите параметры для выполнения команды.


Для изменения цвета, размера или прозрачности подсказок - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Для изменения цвета, размера или прозрачности подсказок

  1. Щелкните правой кнопкой мыши Dyn в строке состояния. Выберите "Настройки".
  2. В диалоговом окне "Режимы рисования" на вкладке "Динамический ввод" щелкните "Внешний вид подсказок на чертеже".
  3. В диалоговом окне "Внешний вид подсказок" в разделе "Цвет" щелкните "Цвет модели" или "Цвет листа", чтобы отобразилось диалоговое окно Выбор цвета, в котором можно задать цвет для подсказок в выбранном пространстве.
  4. В разделе "Размер" переместите указатель шкалы вправо, чтобы увеличить подсказки, или влево, чтобы уменьшить их. Значение по умолчанию, 0, находится посередине.
  5. В разделе "Прозрачность" переместите указатель шкалы. Чем меньше значение настройки, тем прозрачнее подсказка. При значении, равном 100 единицам, подсказка становится непрозрачной.
  6. В разделе "Применить" выберите параметр:
    • Заменить параметры ОС для всех подсказок на чертеже. Настройки применяются ко всем подсказкам; при этом настройки в операционной системе отменяются.
    • Заменить параметры только для подсказок динамического ввода. Настройки применяются только к подсказкам на чертеже, используемым в динамическом вводе.
  7. Нажать "ОК".

    8. Ввод команды: DYNTOOLTIPS


Объединение информации из всех подсказок о построениях в одну подсказку. - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Объединение информации из всех подсказок о построениях в одну подсказку.

  • В командной строке введите tooltipmerge

Подсказки, содержащие информацию о построениях, объединяются в одну подсказку.


Для включения или отключения динамического ввода - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Для включения или отключения динамического ввода

  • В строке состояния щелкните Dyn или нажмите клавишу F12.

Для временного отключения динамического ввода нажмите и удерживайте клавишу F12 во время работы.

Примечание Клавиша F12 не включает функцию динамического ввода - она используется для временного отключения этого режима.


Для изменения настроек ввода с помощью мыши - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Для изменения настроек ввода с помощью мыши

  1. Щелкните правой кнопкой мыши Dyn в строке состояния. Выберите "Настройки".
  2. В диалоговом окне "Режимы рисования" на вкладке "Динамический ввод" в разделе "Ввод с помощью мыши" щелкните "Настройки".
  3. В диалоговом окне "Параметры ввода с помощью мыши" выберите формат полярных или декартовых координат в качестве настройки по умолчанию.
  4. Выберите формат относительных или абсолютных координат в качестве настройки по умолчанию.
  5. В разделе "Видимость" выберите один из следующих параметров:
    • Одновременно с вводом координатных данных. Когда ввод с помощью мыши включен, подсказки отображаются только в момент начала ввода координатных данных.
    • Когда команда содержит запрос для точки. Когда ввод с помощью мыши включен, подсказки отображаются, когда команда запрашивает точку.
    • Всегда—даже не в составе команды. Подсказки отображаются всегда, когда ввод с помощью мыши включен.
  6. Нажать "OK" для закрытия каждого диалогового окна.

    7. Ввод команды: РЕЖИМЧРТ


Для изменения настроек ввода размеров - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Для изменения настроек ввода размеров

  1. Щелкните правой кнопкой мыши Dyn в строке состояния. Выберите "Настройки".
  2. В диалоговом окне "Режимы рисования" на вкладке "Динамический ввод" в разделе "Ввод размеров" щелкните "Настройки".
  3. В диалоговом окне "Параметры ввода размеров" выберите формат полярных или декартовых координат в качестве настройки по умолчанию.
  4. В разделе "Видимость" выберите один из следующих параметров:
    • Показывать одновременно только 1 поле для ввода размеров. Когда для растягивания объекта используется редактирование с помощью ручек, отображается только подсказка ввода размеров для линейных значений.
    • Показывать одновременно 2 поля для ввода размеров. Когда для растягивания объекта используется редактирование с помощью ручек, отображаются подсказки ввода размеров для линейных и угловых значений.
    • Показывать одновременно следующие поля для ввода размеров. Когда для растягивания объекта используется редактирование с помощью ручек, отображаются выбранные подсказки ввода размеров. Установите один или несколько флажков.
  5. Нажать "OK" для закрытия каждого диалогового окна.

    6. Ввод команды: РЕЖИМЧРТ


Для отображения запросов в подсказках - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Для отображения запросов в подсказках

  1. Щелкните правой кнопкой мыши Dyn в строке состояния. Выберите "Настройки".
  2. В диалоговом окне "Режимы рисования" на вкладке "Динамический ввод" в разделе "Динамические подсказки" установите флажок "Показывать подсказку для ввода команды и вводимую команду рядом с перекрестьем".
  3. Нажать "ОК".

    4. Ввод команды: РЕЖИМЧРТ


Использование динамического ввода - Команды

Средства обеспечения точности
Средства обеспечения точности
Использование динамического ввода
Понятия
Процедуры
Команды

Команды
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
Системные переменные
DYNDIGRIP | Управляет отображением динамических размеров во время растягивания ручками
DYNDIVIS | Управляет отображением количества динамических размеров во время растягивания ручками
DYNMODE | Включает и отключает функции динамического ввода
DYNPICOORDS | Контролирует, используются ли для ввода с помощью мыши абсолютные или относительные координаты
DYNPIFORMAT | Контролирует, используется ли для ввода с помощью мыши формат полярных или декартовых координат
DYNPIVIS | Управляет отображением ввода с помощью мыши
DYNPROMPT | Управляет отображением подсказок динамического ввода
DYNTOOLTIPS | Управляет выбором подсказок, на которые влияют параметры внешнего вида подсказок
TEMPOVERRIDES | Включает и отключает клавиши временной отмены
TOOLTIPMERGE | Объединяет подсказки на чертеже в одну подсказку
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Объектная привязка - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Объектная привязка
Понятия
Процедуры
Команды

Вместо ввода значений координат пользователь имеет возможность задавать точки, привязывая курсор к характерным точками имеющихся объектов (к конечным точкам отрезков, центрам кругов и т.д.).

  • Использование объектной привязки
    Использование объектных привязок для указания точных положений на объектах. Например, включив объектную привязку, можно быстро построить отрезок от центра круга к середине сегмента полилинии.
  • Меню объектной привязки
    Контекстное меню объектной привязки позволяет быстро устанавливать необходимый режим объектной привязки.
  • Автопривязка
    Объектные привязки содержат визуальный ключ, именуемый Автопривязкой™ и помогающий пользователю более эффективно воспринимать и использовать объектные привязки. Автопривязка отображает маркер и всплывающую подсказку при подведении курсора к какой-либо точке объектной привязки.
  • Переопределение параметров объектной привязки
    Во время работы можно временно включить или отключить текущие режимы объектной привязки с помощью клавиши отмены. Клавиши временной отмены можно использовать для других режимов рисования, например, для режима "Орто" и полярного режима.


Объектная привязка - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Объектная привязка
Понятия
Процедуры
Команды

Для включения привязки к характерным точкам объектов

Для задания текущих режимов объектной привязки

Для включения и отключения текущих режимов объектной привязки в процессе работы

Для игнорирования объектов штриховки объектными привязками

Для вызова контекстного меню объектной привязки

Для изменения параметров автопривязки

Для временной отмены текущих настроек объектной привязки

Изменение времени реакции клавиатуры для кнопок временного переопределения


Объектная привязка - Команды

Создание и редактирование объектов
Средства обеспечения точности
Объектная привязка
Понятия
Процедуры
Команды
Команды
АДАПТАЦИЯ | Изменяет инструментальные палитры
АПЕРТУРА | Изменение размера прицела объектной привязки
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
ПРИВЯЗКА | Установка текущих режимов объектной привязки
Системные переменные
APBOX | Включает или отключает отображение прицела AutoSnap™
AUTOSNAP | Управление отображением маркера, всплывающей подсказки и магнита автопривязки
OSMODE | Определяет выполнение объектных привязок
OSNAPCOORD | Управляет приоритетом ввода координат с клавиатуры над текущими режимами привязки
OSNAPHATCH | Устар.
OSNAPZ | Управляет автоматической проекцией объектной привязки на плоскость, параллельную плоскости XY текущей ПСК, на текущем уровне
OSOPTIONS | Автоматически подавляет объектную привязку на объектах штриховки и геометрию с отрицательными значениями Z при использовании динамической ПСК
TEMPOVERRIDES | Включает и отключает клавиши временной отмены
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование объектной привязки - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Использование объектной привязки
Понятия
Процедуры
Команды

Использование объектных привязок для указания точных положений на объектах. Например, включив объектную привязку, можно быстро построить отрезок от центра круга к середине сегмента полилинии.

Объектную привязку можно включать во время любого запроса указания точек. По умолчанию при перемещении курсора над объектной привязкой на объекте отображаются маркер и подсказка. Данная функция, именуемая Автопривязкой™, обеспечивает визуальный ключ с указанием на те объектные привязки, которые действуют.

Подробнее о режимах объектной привязки см. описание команды ПРИВЯЗКА.

Задание объектной привязки

Для задания объектной привязки в запросе точки

  • Для вызова контекстного меню объектной привязки нажмите правую кнопку мыши при нажатой клавише SHIFT.
  • Нажмите кнопку объектной привязки на панели "Объектная привязка"
  • В командной строке введите имя режима объектной привязки

Когда объектная привязка задается в запросе точки, то она действует только для указания следующей точки.

Примечание Объектная привязка работает только при запросах на указание точек. При попытке использования объектной привязки в ответ на подсказку "Команда" возникает сообщение об ошибке.

Использование текущего режима объектной привязки

Если есть необходимость использовать один или несколько режимов объектной привязки более одного раза, то можно установить эти режимы в качестве текущих. Например, для того, чтобы соединить центры нескольких окружностей, можно установить режим "Центр" текущим режимом объектной привязки.

Пользователь может задать один или несколько текущих режимов объектной привязки на вкладке "Объектная привязка" в диалоговом окне "Режимы рисования", доступ к которому можно получить из меню "Сервис". Если включено несколько режимов объектной привязки, в выбранном положении может существовать более одной объектной привязки. До задания точки нажмите клавишу TAB для циклического просмотра возможностей.

Нажмите кнопку ПРИВЯЗКА в строке состояния или клавишу F3 для включения или выключения текущих объектных привязок.

Примечание Если необходимо, чтобы объекты штриховки игнорировались объектными привязками, установите системную переменную OSNAPHATCH равной 1.

Использование объектных привязок в 3D пространстве

По умолчанию Z-значение положения объектной привязки определяется положением объекта в пространстве. Однако если работа с объектными привязками ведется на плане здания или на виде сверху детали, удобнее будет воспользоваться постоянным Z-значением.

Если системная переменная OSNAPZ включена, все объектные привязки проецируются на плоскость XY текущей ПСК или, если для ELEV установлено не нулевое значение, - на плоскость, параллельную плоскости XY на заданном уровне.

Примечание При создании или изменении объектов необходимо знать, включена или выключена переменная OSNAPZ. Поскольку визуальные напоминания отсутствуют, могут быть получены неожиданные результаты.


Использование объектной привязки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование объектной привязки
Понятия
Процедуры
Команды

Для включения привязки к характерным точкам объектов

Для задания текущих режимов объектной привязки

Для включения и отключения текущих режимов объектной привязки в процессе работы

Для игнорирования объектов штриховки объектными привязками


Для включения привязки к характерным точкам объектов - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование объектной привязки
Понятия
Процедуры
Команды

Для включения привязки к характерным точкам объектов

  1. По запросу указания точки нажмите правую кнопку мыши в области чертежа при нажатой клавише SHIFT. Выберите объектную привязку, которой нужно воспользоваться.
  2. Переместите курсор в нужное положение объектной привязки.

    3. Если режим автопривязки включен, то при наведении курсора на характерную точку появляется маркер объектной привязки и соответствующая подсказка.

  3. Выбрать объект.

    4. Происходит выбор самой близкой к курсору точки привязки указанного объекта.


Для задания текущих режимов объектной привязки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование объектной привязки
Понятия
Процедуры
Команды

Для задания текущих режимов объектной привязки

  1. Выберите в меню "Сервис" » "Режимы черчения".
  2. На вкладке "Объектная привязка" диалогового окна "Режимы рисования" выберите необходимые режимы объектной привязки.
  3. Нажать "ОК".

Панель Объектная привязка

Ввод команды: ПРИВЯЗКА

Контекстное меню: Для вызова меню объектной привязки нажмите правую кнопку мыши при нажатой клавише SHIFT. Выберите "Режимы привязки".


Для включения и отключения текущих режимов объектной привязки в процессе работы - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование объектной привязки
Понятия
Процедуры
Команды

Для включения и отключения текущих режимов объектной привязки в процессе работы

  • В строке состояния щелкните "Привязка" или нажмите клавишу F3.

Если текущие режимы объектной привязки были заданы, происходит их включение или отключение.

Для временного включения и выключения текущих объектных привязок нажмите и удерживайте клавишу F3 во время работы.

Ввод команды: ПРИВЯЗКА


Для игнорирования объектов штриховки объектными привязками - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование объектной привязки
Понятия
Процедуры
Команды

Для игнорирования объектов штриховки объектными привязками

  1. По запросу команды введите osoptions
  2. Введите 1.


Использование объектной привязки - Команды

Средства обеспечения точности
Средства обеспечения точности
Использование объектной привязки
Понятия
Процедуры
Команды

Команды
АПЕРТУРА | Изменение размера прицела объектной привязки
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПРИВЯЗКА | Установка текущих режимов объектной привязки
Системные переменные
APBOX | Включает или отключает отображение прицела AutoSnap™
AUTOSNAP | Управление отображением маркера, всплывающей подсказки и магнита автопривязки
OSMODE | Определяет выполнение объектных привязок
OSNAPCOORD | Управляет приоритетом ввода координат с клавиатуры над текущими режимами привязки
OSNAPZ | Управляет автоматической проекцией объектной привязки на плоскость, параллельную плоскости XY текущей ПСК, на текущем уровне
OSOPTIONS | Автоматически подавляет объектную привязку на объектах штриховки и геометрию с отрицательными значениями Z при использовании динамической ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Меню объектной привязки - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Меню объектной привязки
Понятия
Процедуры
Команды

Контекстное меню объектной привязки позволяет быстро устанавливать необходимый режим объектной привязки.

Меню объектной привязки отображается на текущей позиции курсора, когда пользователь нажимает правую кнопку мыши (либо эквивалентную кнопку или другое устройство указания) при нажатой клавише SHIFT.

По умолчанию меню объектной привязки предлагает список опций объектной привязки и отслеживания. Если нужно изменить эти параметры, внесите изменения в файл адаптации. acad.cui является основным файлом адаптации, поставляемым вместе с продуктом.

См. также

См. раздел Создание раскрывающихся и контекстных меню в документе Руководстве по адаптации

Использование объектной привязки


Для вызова контекстного меню объектной привязки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Меню объектной привязки
Понятия
Процедуры
Команды

Для вызова контекстного меню объектной привязки

  1. Введите любую команду, которая требует указания точки. Например, введите отрезок
  2. По подсказке "От точки" нажмите правую кнопку мыши при нажатой клавише SHIFT.

    3. Появляется меню объектной привязки, где можно выбрать необходимый режим.


Меню объектной привязки - Команды

Средства обеспечения точности
Средства обеспечения точности
Меню объектной привязки
Понятия
Процедуры
Команды

Команды
ПРИВЯЗКА | Установка текущих режимов объектной привязки
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Автопривязка - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Автопривязка
Понятия
Процедуры
Команды

Объектные привязки содержат визуальный ключ, именуемый Автопривязкой™ и помогающий пользователю более эффективно воспринимать и использовать объектные привязки. Автопривязка отображает маркер и всплывающую подсказку при подведении курсора к какой-либо точке объектной привязки.

Элементы автопривязки

Средства автопривязки включают в себя следующие элементы:

  • Маркеры. Указывают на ближайшую к курсору точку привязки с помощью соответствующего символа. Форма маркера зависит от режима привязки.
  • Всплывающие подсказки автопривязки. Поясняют режим объектной привязки в точке привязки ниже позиции курсора.
  • Магнит. Автоматически перемещает курсор в точку привязки, если курсор находится около возможной точки привязки. если курсор находится около возможной точки привязки.
  • Прицел. Окружает перекрестье курсора и ограничивает область, в которой производится оценка объектных привязок. Показ прицела можно включать и отключать, а его размер - изменять.

По умолчанию включены следующие элементы автопривязки: маркеры, всплывающие подсказки и магнит. Настройки автопривязки можно изменять на вкладке "Построения" диалогового окна "Параметры".

Использование автопривязки для контроля и смены режима объектной привязки

Если задано несколько текущих объектных привязок, можно нажатием клавиши TAB перебирать все точки объектных привязок, доступные для определенного объекта.


Для изменения параметров автопривязки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Автопривязка
Понятия
Процедуры
Команды

Для изменения параметров автопривязки

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Параметры" на вкладке "Построения" установите нужные настройки:
    • Маркеры. Включение и отключение маркеров.
    • Магнит. Включение и отключение магнита.
    • Всплывающие подсказки автопривязки. Включение и отключение подсказок.
    • Прицел автопривязки. Включение и отключение отображения прицела в режиме объектной привязки. Если автопривязка отключена, то эта опция не действует.
    • Цвет маркера автопривязки. Изменение цвета маркера.
    • Размер маркера автопривязки. Настройка размера маркера.
  3. Нажать "ОК".

Панель Объектная привязка

Ввод команды: НАСТРОЙКА


Автопривязка - Команды

Средства обеспечения точности
Средства обеспечения точности
Автопривязка
Понятия
Процедуры
Команды

Команды
АПЕРТУРА | Изменение размера прицела объектной привязки
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПРИВЯЗКА | Установка текущих режимов объектной привязки
Системные переменные
APBOX | Включает или отключает отображение прицела AutoSnap™
AUTOSNAP | Управление отображением маркера, всплывающей подсказки и магнита автопривязки
OSMODE | Определяет выполнение объектных привязок
OSNAPHATCH | Устар.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Переопределение параметров объектной привязки - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Переопределение параметров объектной привязки
Понятия
Процедуры
Команды

Во время работы можно временно включить или отключить текущие режимы объектной привязки с помощью клавиши отмены. Клавиши временной отмены можно использовать для других режимов рисования, например, для режима "Орто" и полярного режима.

Например, если заданы текущие объектные привязки, но их необходимо отключить для одной точки, нажмите и удерживайте клавишу F3. Когда клавиша отмены будет освобождена, текущие режимы объектной привязки будут восстановлены.

Существуют также клавиши временной отмены для отдельных объектных привязок. Клавиши отмены задаются таким образом, чтобы можно было легко найти их на ощупь, не отрывая взгляда от чертежа.

Клавиши на следующем чертеже являются клавишами по умолчанию, однако при необходимости можно изменить назначение клавиш и добавить собственные.

Нажмите и удерживайте клавишу SHIFT и одну из клавиш временной отмены, изображенных на чертеже:
1 | Отмена объектной привязки: конечная точка | 5 | Отключение привязки и отслеживания
2 | Принудительный выбор объектной привязки | 6 | Отмена объектной привязки: по центру
3 | Включение/отключение режима отслеживания объектной привязки | 7 | Отмена объектной привязки: средняя точка
4 | Включение/отключение режима объектной привязки (ПРИВЯЗКА) |  |

Клавиши временной отмены можно использовать для других режимов рисования, заданных в диалоговом окне Режимы рисования.

См. также

Настройка сетки и шаговой привязки

Ортогональное рисование

Полярные отслеживание и привязка

Использование динамического ввода

См. раздел Задание клавиш быстрого вызова и временной замены в документе Руководстве по адаптации


Переопределение параметров объектной привязки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Переопределение параметров объектной привязки
Понятия
Процедуры
Команды

Для временной отмены текущих настроек объектной привязки

Изменение времени реакции клавиатуры для кнопок временного переопределения


Для временной отмены текущих настроек объектной привязки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Переопределение параметров объектной привязки
Понятия
Процедуры
Команды

Для временной отмены текущих настроек объектной привязки

  • Нажмите и удерживайте клавишу F3 во время работы.

    • Когда клавиша будет освобождена, текущие настройки объектной привязки будут восстановлены.


Изменение времени реакции клавиатуры для кнопок временного переопределения - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Переопределение параметров объектной привязки
Понятия
Процедуры
Команды

Изменение времени реакции клавиатуры для кнопок временного переопределения

  1. В панели управления Windows выберите опцию "Клавиатура".
  2. Во вкладке "Скорость" диалогового окна "Свойства клавиатуры" передвиньте ползунок "Частота повторения" для корректировки времени реакции клавиатуры. Затем нажать "OK".


Переопределение параметров объектной привязки - Команды

Средства обеспечения точности
Средства обеспечения точности
Переопределение параметров объектной привязки
Понятия
Процедуры
Команды

Команды
АДАПТАЦИЯ | Изменяет инструментальные палитры
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
ПРИВЯЗКА | Установка текущих режимов объектной привязки
Системные переменные
OSMODE | Определяет выполнение объектных привязок
TEMPOVERRIDES | Включает и отключает клавиши временной отмены
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Ограничение перемещения курсора - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Ограничение перемещения курсора
Понятия
Процедуры
Команды

Пользователю предоставляются различные средства для ограничения и блокирования перемещения курсора.

  • Настройка сетки и шаговой привязки
    Для повышения скорости и эффективности построения объектов можно включить прямоугольную сетку на экране и привязку к сетке. Шаг и ориентацию сетки можно изменять.
  • Ортогональное рисование
    Для точного построения объектов можно ограничить перемещение курсора горизонтальным и вертикальным направлениями.
  • Полярные отслеживание и привязка
    Полярное отслеживание ограничивает перемещение курсора направлением под заданным углом. Полярная привязка задает шаг перемещения курсора в заданном направлении.
  • Разовое задание угла отслеживания (Угол)
    Имеется возможность разового задания угла отслеживания, действующего до указания очередной точки.


Ограничение перемещения курсора - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ограничение перемещения курсора
Понятия
Процедуры
Команды

Для включения сетки и задания ее шага

Для включения режима шаговой привязки и задания шага

Установка границ сетки

Для временной отмены режима привязки

Поворот угла привязки и сетки и изменение базовой точки

Изменение отображения сетки в виде линий и точек

Изменение частоты главных линий сетки

Для включения и отключения режима "Орто"

Для включения и отключения полярного отслеживания

Для задания шага полярной привязки

Для построения объектов с помощью полярного отслеживания

Для построения объектов с помощью полярной привязки

Для задания углов полярного отслеживания


Ограничение перемещения курсора - Команды

Создание и редактирование объектов
Средства обеспечения точности
Ограничение перемещения курсора
Понятия
Процедуры
Команды
Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
ЛИМИТЫ | Установка и регулирование границ отображения сетки на текущей вкладке разметки листа или "Модель"
ОРТО | Ограничивает перемещение курсора в вертикальном или горизонтальном направлении
РЕЖИМРАСКР | Запускает команду ТЕКВИЗСТИЛЬ
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
СЕТКА | Отображение точечной сетки на текущем видовом экране, которая не выводится на печать
ШАГ | Ограничение перемещения курсора определенными интервалами
Системные переменные
ANGBASE | Задание для базового угла значения 0 в соответствии с текущей ПСК
ANGDIR | Задание направления для положительных углов.
AUTOSNAP | Управление отображением маркера, всплывающей подсказки и магнита автопривязки
GRIDDISPLAY | Управляет режимом работы дисплея и лимитами отображения сетки
GRIDMAJOR | Управляет частотой основных линий сетки по сравнению с второстепенными линиями сетки
GRIDMODE | Указывает, включена или отключена сетка
GRIDUNIT | Указывает размер ячейки сетки на текущем видовом экране по X и Y
LIMCHECK | Управляет созданием объектов за пределами лимитов чертежа
LIMMIN | Сохраняет левую нижнюю точку лимитов чертежа, выраженную в мировых координатах
ORTHOMODE | Управляет перемещением курсора в перпендикулярном направлении
POLARANG | Задает шаг для полярных углов
POLARDIST | Задает шаг привязки в случае, если для системной переменной SNAPTYPE установлено значение 1 (полярная привязка)
POLARMODE | Управляет полярным и объектным отслеживанием
SNAPMODE | Включает и отключает режим привязки
SNAPTYPE | Задает тип привязки для текущего видового экрана
SNAPUNIT | Задает интервал привязки для текущего видового экрана
TEMPOVERRIDES | Включает и отключает клавиши временной отмены
TRACKPATH | Управляет отображением линий выравнивания для полярного отслеживания и отслеживания объектной привязки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка сетки и шаговой привязки - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Настройка сетки и шаговой привязки
Понятия
Процедуры
Команды

Для повышения скорости и эффективности построения объектов можно включить прямоугольную сетку на экране и привязку к сетке. Шаг и ориентацию сетки можно изменять.

Сетка представляет собой прямоугольную комбинацию точек или отрезков, расположенных на площади в заданных пользователем границах сетки. Сетка заменяет листок бумаги, расчерченный в клетку, который подкладывают под чертеж для облегчения построений. Она помогает выравнивать объекты и оценивать расстояние между ними. На печать сетка не выводится.

Шаговая привязка позволяет ограничить передвижение курсора только узлами воображаемой решетки. При включенном режиме шаговой привязки движение курсора становится скачкообразным, он как бы "прилипает" к узлам решетки. Шаговая привязка обычно используется для безошибочного указания точек с помощью клавиатуры или устройства указания.

Режим сетки и режим привязки не зависят один от другого, но часто включаются одновременно.

Управление стилем экранного представления и площадью сетки

Сетку можно отображать в виде прямоугольной комбинации точек или прямоугольной комбинации линий. Сетка отображается в виде точек только в случае, если текущим стилем отображения является "2D Каркас"; иначе сетка отображается в виде линий. Сетка в виде линий отображается для всех стилей отображения при работе в 3D. Имеется несколько методов изменения текущего стиля отображения, включая вызов команды ТЕКВИЗСТИЛЬ.

По умолчанию, X- и Y-оси ПСК отображаются в цвете, отличном от цвета линий сетки. Для определения цвета можно использовать диалоговое окно ""Цвета окна чертежа". Данное диалоговое окно доступно через вкладку "Построения" в диалоговом окне "Настройка".

Площадь чертежа, покрываемая сеткой, определяется командой ЛИМИТЫ. Имеется опция переопределения лимитов таким образом, чтобы сетка покрывала всю плоскость XY пользовательской системы координат (ПСК). Для получения доступа к данной опции можно воспользоваться диалоговым окном "Режимы рисования" или использовать системную переменную GRIDDISPLAY.

Примечание Если используется динамическая ПСК, лимиты сетки устанавливаются автоматически по отношению к размеру выбранной грани тела и доступной площади чертежа.

Управление частотой больших линий сетки

Если сетка отображается не в виде точек, а в виде линий, то затемненные линии, именуемые главными линиями сетки, отображаются с определенными интервалами. Главные линии сетки особенно полезны для быстрого вычисления расстояний, измеряемых в десятичных единицах, футах или дюймах. Частоту расположения главных линий сетки можно задать в диалоговом окне "Режимы рисования" [image].

Для отключения отображения главных линий сетки следует установить частоту главных линий сетки равной 1.

Примечание Если сетка отображается в виде линий, лимиты сетки также отображаются в виде затемненных линий. Нельзя путать эти граничные линии с главными линиями сетки.

Примечание Если сетка представлена в виде линий и для SNAPANG установлено значение, отличное от нуля, сетка не отображается. SNAPANG не влияет на отображение сетки в виде точек.

Динамическое изменение сетки при зумировании

Если видимые размеры чертежа уменьшаются или увеличиваются зумированием, то интервал сетки автоматически корректируется для согласования с новым масштабом изображения. Это именуется адаптивным отображением сетки.

Например, при увеличении видимого размера чертежа плотность расположения отображаемых линий сетки автоматически уменьшается. Напротив, если видимый размер чертежа уменьшается, дополнительные линии сетки отображаются в той же пропорции, что и главные линии сетки.

Изменение шага сетки и привязки

В процессе работы режимы "Сетка" и "Шаг" можно включать/отключать, а также изменять шаг привязки и сетки. Режим привязки можно временно включить или отключить с помощью клавиши отмены.

Шаг привязки и шаг сетки могут не совпадать. Например, сетка, используемая исключительно для наглядности, может иметь достаточно большой шаг. При этом шаг привязки может быть более мелким, чтобы пользователь имел возможность указывать точки с большей точностью.

Изменение базы и угла привязки и сетки

Если требуется создание чертежа с определенным выравниванием или под определенным углом, можно изменить угол привязки и сетки путем поворота пользовательской системы координат (ПСК). При этом вид перекрестья и ориентация сетки также изменятся. Приведенный ниже пример иллюстрирует поворот ПСК на 30 градусов для согласования с углом анкерного кронштейна.

Точки привязки и сетки всегда совмещаются с исходной точкой ПСК. Если необходимо сдвинуть исходную точку сетки и шага сетки, следует переместить ПСК.

См. также

Задание изометрического стиля шаговой привязки и сетки

Переопределение параметров объектной привязки

Использование стиля отображения для модели


Настройка сетки и шаговой привязки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Настройка сетки и шаговой привязки
Понятия
Процедуры
Команды

Для включения сетки и задания ее шага

Для включения режима шаговой привязки и задания шага

Установка границ сетки

Для временной отмены режима привязки

Поворот угла привязки и сетки и изменение базовой точки

Изменение отображения сетки в виде линий и точек

Изменение частоты главных линий сетки


Для включения сетки и задания ее шага - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Настройка сетки и шаговой привязки
Понятия
Процедуры
Команды

Для включения сетки и задания ее шага

  1. Выберите в меню "Сервис" » "Режимы черчения".
  2. Во вкладке "Шаг и сетка" диалогового окна "Режимы рисования" выберите "Сетка Вкл" с целью отображения сетки.
  3. Убедитесь, что в группе "Тип привязки" включены опции "Шаговая привязка" и "Ортогональная привязка".
  4. В качестве X-шага сетки введите значение шага сетки по горизонтали в указанных единицах.
  5. Чтобы использовать это же значение для шага сетки по вертикали, нажмите ENTER. Иначе, введите новое значение для Y-шага сетки.
  6. Нажать "ОК".

Ввод команды: РЕЖИМЧРТ


Для включения режима шаговой привязки и задания шага - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Настройка сетки и шаговой привязки
Понятия
Процедуры
Команды

Для включения режима шаговой привязки и задания шага

  1. Выберите в меню "Сервис" » "Режимы черчения".
  2. На вкладке "Шаг и сетка" диалогового окна "Режимы рисования" выбрать "Шаг Вкл".
  3. Убедитесь, что в группе "Тип привязки" выбраны опции "Шаговая привязка" и "Ортогональная привязка".
  4. В качестве X-шага привязки введите значение шага привязки по горизонтали в указанных единицах.
  5. Чтобы использовать это же значение для шага привязки по вертикали, нажмите ENTER Иначе, введите новое значение расстояния в окно Y-шага привязки.
  6. Нажать "ОК".

Ввод команды: РЕЖИМЧРТ


Установка границ сетки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Настройка сетки и шаговой привязки
Понятия
Процедуры
Команды

Установка границ сетки

  1. Выберите в меню "Формат" » "Границы чертежа".
  2. По запросу команды введите значения координат для точки в нижнем левом углу границ сетки.
  3. Введите значения координат для точки в верхнем правом углу границ сетки.

Границы сетки устанавливаются равными площади, определяемой двумя точками.

Ввод команды:


Для временной отмены режима привязки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Настройка сетки и шаговой привязки
Понятия
Процедуры
Команды

Для временной отмены режима привязки

  • Нажмите и удерживайте клавишу F9 во время работы.

    • Когда клавиша будет освобождена, режим привязки будет восстановлен.


Поворот угла привязки и сетки и изменение базовой точки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Настройка сетки и шаговой привязки
Понятия
Процедуры
Команды

Поворот угла привязки и сетки и изменение базовой точки

  1. Выберите в меню "Сервис" » "Новая ПСК" » "Z"
  2. Введите угол поворота для ПСК.
  3. Выберите в меню "Сервис" » "Новая ПСК" » "Начало".
  4. Укажите новую исходную точку для ПСК.
  5. Нажмите "ОК".

Ввод команды: ПСК


Изменение отображения сетки в виде линий и точек - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Настройка сетки и шаговой привязки
Понятия
Процедуры
Команды

Изменение отображения сетки в виде линий и точек

  1. По запросу команды введите ТЕКВИЗСТИЛЬ.
  2. Выполните одно из следующих действий:
    • Для отображения сетки в виде точек укажите опцию "2D Каркас".
    • Для отображения сетки в виде линий укажите другую опцию.

Ввод команды: ТЕКВИЗСТИЛЬ


Изменение частоты главных линий сетки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Настройка сетки и шаговой привязки
Понятия
Процедуры
Команды

Изменение частоты главных линий сетки

  1. Если необходимо, введите по запросу команду ТЕКВИЗСТИЛЬ и укажите любой стиль отображения, кроме "2D Каркас".
  2. Выберите меню "Сервис" > "Режимы рисования".
  3. Во вкладке "Шаг и сетка" диалогового окна "Режимы рисования" укажите число для опции "Главная линия - каждая".
  4. Нажмите "ОК".

Ввод команды: ТЕКВИЗСТИЛЬ


Настройка сетки и шаговой привязки - Команды

Средства обеспечения точности
Средства обеспечения точности
Настройка сетки и шаговой привязки
Понятия
Процедуры
Команды

Команды
ЛИМИТЫ | Установка и регулирование границ отображения сетки на текущей вкладке разметки листа или "Модель"
РЕЖИМРАСКР | Запускает команду ТЕКВИЗСТИЛЬ
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
СЕТКА | Отображение точечной сетки на текущем видовом экране, которая не выводится на печать
ШАГ | Ограничение перемещения курсора определенными интервалами
Системные переменные
GRIDDISPLAY | Управляет режимом работы дисплея и лимитами отображения сетки
GRIDMAJOR | Управляет частотой основных линий сетки по сравнению с второстепенными линиями сетки
GRIDMODE | Указывает, включена или отключена сетка
GRIDUNIT | Указывает размер ячейки сетки на текущем видовом экране по X и Y
LIMCHECK | Управляет созданием объектов за пределами лимитов чертежа
LIMMIN | Сохраняет левую нижнюю точку лимитов чертежа, выраженную в мировых координатах
SNAPMODE | Включает и отключает режим привязки
SNAPTYPE | Задает тип привязки для текущего видового экрана
SNAPUNIT | Задает интервал привязки для текущего видового экрана
TEMPOVERRIDES | Включает и отключает клавиши временной отмены
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Ортогональное рисование - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Ортогональное рисование
Понятия
Процедуры
Команды

Для точного построения объектов можно ограничить перемещение курсора горизонтальным и вертикальным направлениями.

При создании объектов режим "Орто" ограничивает перемещение курсора горизонтальным или вертикальным направлением. По мере перемещения курсора, резиновая линия следует за горизонтальной или вертикальной осью, в зависимости от того, что ближе к курсору.

Ориентация текущей пользовательской системы координат (ПСК) определяет горизонтальное и вертикальное направления. На 3D видах режим "Орто" дополнительно ограничивает возможности перемещения курсора направлениями вверх и вниз. В этом случае в подсказке об угле отображается +Z или -Z.

Если включен режим "Орто", для создания ортогональных линий заданной длины или для перемещения объектов на заданные расстояния необходимо использовать прямую запись расстояния.

В любой момент режим "Орто" может быть отключен и включен вновь. Когда пользователь вводит координаты или указывает объектную привязку, "Орто" игнорируется. Для временного включения или отключения режима "Орто" нажмите и удерживайте клавишу временной отмены, SHIFT. Пока задействована клавиша временной отмены, метод "направление-расстояние" будет недоступен.

Подробнее о работе с направлениями, ориентированными под углом к горизонтальной или вертикальной оси, см. раздел Полярные отслеживание и привязка.

Если режим включен, то при определении горизонтального и вертикального направлений отдается предпочтение параметрам изометрической привязки над ПСК.

Примечание Режим ортогонального рисования не может использоваться совместно с режимом полярного отслеживания, поэтому при включении режима "Орто" полярное отслеживание автоматически отключается.

См. также

Переопределение параметров объектной привязки


Для включения и отключения режима "Орто" - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ортогональное рисование
Понятия
Процедуры
Команды

Для включения и отключения режима "Орто"

  • Нажмите кнопку "ОРТО" в строке состояния.

    • Для временного включения или отключения режима "Орто" нажмите и удерживайте клавишу SHIFT во время работы. Пока задействована клавиша временной отмены, метод "направление-расстояние" будет недоступен.

    Примечание При включении режима "Орто" автоматически отключается полярное отслеживание.

Ввод команды: ОРТО


Ортогональное рисование - Команды

Средства обеспечения точности
Средства обеспечения точности
Ортогональное рисование
Понятия
Процедуры
Команды

Команды
ОРТО | Ограничивает перемещение курсора в вертикальном или горизонтальном направлении
Системные переменные
ORTHOMODE | Управляет перемещением курсора в перпендикулярном направлении
TEMPOVERRIDES | Включает и отключает клавиши временной отмены
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Полярные отслеживание и привязка - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Полярные отслеживание и привязка
Понятия
Процедуры
Команды

Полярное отслеживание ограничивает перемещение курсора направлением под заданным углом. Полярная привязка задает шаг перемещения курсора в заданном направлении.

Полярное отслеживание облегчает выбор точек, лежащих на воображаемых линиях под одним из заданных полярных углов. На 3D видах полярное отслеживание дополнительно обеспечивает траекторию выравнивания в направлениях вверх и вниз. В этом случае в подсказке отображается для угла значение +Z или -Z.

Углы в полярных координатах соотносятся с ориентацией текущей пользовательской системы координат (ПСК) и с параметром для условного обозначения базового угла на чертеже. Базовое направление угла задается в диалоговом окне "Единицы чертежа".

Полярная привязка™ используется с целью привязки к указанным расстояниям вдоль траектории выравнивания. На следующей иллюстрации приводится пример последовательного построения двух отрезков длиной по 2 единицы каждый: сначала строится горизонтальный отрезок от точки 1 к точке 2, а затем под углом 45 градусов строится второй отрезок к точке 3. Если, например, шаг углов полярного отслеживания равен 45 градусам, линии отслеживания и всплывающие подсказки отображаются под углами, кратными 45 градусам. Текущая линия полярного отслеживания (а также всплывающая подсказка) исчезает, если она оказывается вне прицела курсора.

Линия полярного отслеживания и всплывающая подсказка появляются, если прямая, мысленно проведенная через предыдущую указанную точку и курсор, проходит под углом, близким к одному из полярных углов отслеживания. По умолчанию шаг полярных углов равен 90 градусам. Линию полярного отслеживания и информацию, содержащуюся во всплывающей подсказке, можно использовать при построении объектов. Для нахождения точки пересечения линии полярного отслеживания с другими объектами удобно пользоваться режимами объектной привязки "Пересечение" и "Кажущееся пересечение".

Примечание Режим ортогонального рисования не может использоваться совместно с режимом полярного отслеживания, При включении режима "Орто" полярное отслеживание автоматически отключается. Аналогичным образом полярная привязка (PolarSnap) и привязка к сетке не могут быть включены одновременно. При включении режима полярной привязки отключается режим шаговой привязки к сетке.

Задание углов полярного отслеживания

Полярное отслеживание может осуществляться под углами, кратными следующим стандартным значениям: 90, 45, 30, 22.5, 18, 15, 10 или 5 градусов. Кроме того, пользователь может определить другие значения углов. На следующей иллюстрации показаны некоторые из возможных линий полярного отслеживания при значении углового интервала 30 градусов.

Ориентация угла в 0 градусов зависит от угла, заданного в диалоговом окне "Единицы чертежа" (ЕДИНИЦЫ). Направление отсчета угла привязки (по часовой стрелке или против) также задается при настройке единиц измерения чертежа.

Режим полярного отслеживания можно временно включить или отключить с помощью клавиши отмены. Метод "направление-расстояние" будет недоступен, пока для полярного отслеживания задействована клавиша временной отмены.

Задание интервала полярной привязки

Полярная привязка задает шаг перемещения курсора в заданном направлении. Например, при задании интервала длиной 4 единицы курсор будет позиционироваться в заданном направлении на расстояниях 0, 4, 8, 12, 16 единиц и т.д. При перемещении курсора появляются всплывающие подсказки для ближайшей точки полярной привязки. Для возможности точного указания точек в заданном направлении и на заданном расстоянии следует включить как режим полярного отслеживания, так и режим полярной привязки. Режим всех привязок и отслеживания можно временно отключить с помощью клавиши отмены.

См. также

Переопределение параметров объектной привязки


Полярные отслеживание и привязка - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Полярные отслеживание и привязка
Понятия
Процедуры
Команды

Для включения и отключения полярного отслеживания

Для задания шага полярной привязки

Для построения объектов с помощью полярного отслеживания

Для построения объектов с помощью полярной привязки

Для задания углов полярного отслеживания


Для включения и отключения полярного отслеживания - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Полярные отслеживание и привязка
Понятия
Процедуры
Команды

Для включения и отключения полярного отслеживания

  • Нажмите F10 или нажмите на "Полярные" на строке состояния.

    • Для временного включения или отключения полярного отслеживания нажмите и удерживайте клавишу F10 во время работы.


Для задания шага полярной привязки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Полярные отслеживание и привязка
Понятия
Процедуры
Команды

Для задания шага полярной привязки

  1. Выберите в меню "Сервис" » "Режимы черчения".
  2. На вкладке "Шаг и сетка" диалогового окна "Режимы рисования" выбрать "Шаг Вкл".
  3. В группе "Тип привязки" выберите "Полярная привязка".
  4. В группе "Полярная привязка" ввести шаг полярной привязки.
  5. На вкладке №Отслеживание" установите флажок "Полярное отслеживание Вкл".
  6. Из списка "Шаг углов" выбрать нужное значение угла.

    7. Можно задать и любое другое значение угла. Для этого служат опция "Дополнительные углы" и кнопка "Новый".

  7. Нажать "ОК".

Ввод команды: РЕЖИМЧРТ


Для построения объектов с помощью полярного отслеживания - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Полярные отслеживание и привязка
Понятия
Процедуры
Команды

Для построения объектов с помощью полярного отслеживания

  1. Включите полярное отслеживание и вызовите команду рисования, например, ДУГА, КРУГ или ОТРЕЗОК.

    2. Полярное отслеживание можно также использовать при работе с командами редактирования, например, КОПИРОВАТЬ и ПЕРЕНЕСТИ.

  2. Переместить курсор, чтобы появилась пунктирная линия полярного отслеживания под одним из заданных углов. Указать точку на линии полярного отслеживания.

Ввод команды: РЕЖИМЧРТ


Для построения объектов с помощью полярной привязки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Полярные отслеживание и привязка
Понятия
Процедуры
Команды

Для построения объектов с помощью полярной привязки

  1. Включить полярные отслеживание и привязку.

    2. Убедиться, что на вкладке "Шаг и сетка" диалогового окна "Режимы рисования" включена опция "Полярная привязка".

  2. Вызовите команду рисования, например, ОТРЕЗОК.
  3. Переместить курсор так, чтобы появилась пунктирная линия полярного отслеживания, определяющая заданный угол и расстояние от исходной точки.
  4. Указать точку.

    5. Длина нового отрезка кратна заданному шагу полярной привязки.

Ввод команды: РЕЖИМЧРТ


Для задания углов полярного отслеживания - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Полярные отслеживание и привязка
Понятия
Процедуры
Команды

Для задания углов полярного отслеживания

  1. Выберите в меню "Сервис" » "Режимы черчения".
  2. На вкладке "Отслеживание" диалогового окна "Режимы рисования" установить флажок "Полярное отслеживание Вкл".
  3. Из списка "Шаг углов" выбрать угол полярной привязки.
  4. Для указания любого другого угла отметить опцию "Дополнительные углы". Щелкнуть "Создать". Введите значение угла в текстовом поле.
  5. В группе "Отсчет полярных углов" указать метод определения исходного направления, от которого отсчитываются углы (от нулевого направления ПСК или от направления, определяемого последним созданным объектом).
  6. Нажать "ОК".

Ввод команды: РЕЖИМЧРТ


Полярные отслеживание и привязка - Команды

Средства обеспечения точности
Средства обеспечения точности
Полярные отслеживание и привязка
Понятия
Процедуры
Команды

Команды
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
ШАГ | Ограничение перемещения курсора определенными интервалами
Системные переменные
ANGBASE | Задание для базового угла значения 0 в соответствии с текущей ПСК
ANGDIR | Задание направления для положительных углов.
AUTOSNAP | Управление отображением маркера, всплывающей подсказки и магнита автопривязки
POLARANG | Задает шаг для полярных углов
POLARDIST | Задает шаг привязки в случае, если для системной переменной SNAPTYPE установлено значение 1 (полярная привязка)
POLARMODE | Управляет полярным и объектным отслеживанием
SNAPTYPE | Задает тип привязки для текущего видового экрана
TEMPOVERRIDES | Включает и отключает клавиши временной отмены
TRACKPATH | Управляет отображением линий выравнивания для полярного отслеживания и отслеживания объектной привязки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Разовое задание угла отслеживания (Угол) - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Разовое задание угла отслеживания (Угол)
Понятия
Процедуры
Команды

Имеется возможность разового задания угла отслеживания, действующего до указания очередной точки.

Для разового задания угла отслеживания в ответ на запрос о выборе точки следует ввести в командной строке символ знака "меньше" (<) и нужное значение угла. Диалог в командной строке во время выполнения команды ОТРЕЗОК с использованием разового задания угла отслеживания выглядит следующим образом:

Команда: отрезок

Первая точка: Укажите точку начала отрезка

Следующая точка или [Отменить]: <30

Угол отслеживания: 30

Следующая точка или [Отменить]: Укажите точку

Заданный угол определяет направление перемещения курсора, игнорируя настройки шаговой привязки, ортогонального отслеживания и полярной привязки. Остаются действующими режим объектной привязки и метод задания координат.


Ограничение перемещения курсора

Создание и редактирование объектов
Средства обеспечения точности
Ограничение перемещения курсора
Понятия
Процедуры
Команды

Нет процедур.


Разовое задание угла отслеживания (Угол) - Команды

Средства обеспечения точности
Средства обеспечения точности
Разовое задание угла отслеживания (Угол)
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Комбинирование и смещение точек и координат - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Комбинирование и смещение точек и координат
Понятия
Процедуры
Команды

Чтобы задать новое положение точки, можно объединить координатные значения из нескольких точек или указать смещения от существующих объектов.

  • Комбинирование составляющих координат с помощью координатных фильтров
    Координатные фильтры используются для единовременного извлечения одного координатного значения из местоположений в существующих объектах.
  • Объектное отслеживание
    Создаваемые объекты можно размещать в определенной зависимости относительно других объектов с помощью линий отслеживания.
  • Отслеживание со смещением от опорных точек
    С помощью отслеживания со смещением можно получать новые точки путем вертикального и горизонтального смещения временных опорных точек.


Комбинирование и смещение точек и координат - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Комбинирование и смещение точек и координат
Понятия
Процедуры
Команды

Для задания 2D точки с использованием координатных фильтров

Для задания 3D точки с использованием координатных фильтров

Для включения и отключения объектного отслеживания

Для изменения параметров автоотслеживания

Для задания точки с помощью отслеживания


Комбинирование и смещение точек и координат - Команды

Создание и редактирование объектов
Средства обеспечения точности
Комбинирование и смещение точек и координат
Понятия
Процедуры
Команды
Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
Системные переменные
AUTOSNAP | Управление отображением маркера, всплывающей подсказки и магнита автопривязки
POLARMODE | Управляет полярным и объектным отслеживанием
TRACKPATH | Управляет отображением линий выравнивания для полярного отслеживания и отслеживания объектной привязки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Комбинирование составляющих координат с помощью координатных фильтров - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Комбинирование составляющих координат с помощью координатных фильтров
Понятия
Процедуры
Команды

Координатные фильтры используются для единовременного извлечения одного координатного значения из местоположений в существующих объектах.

Координатными фильтрами указывается положение новой координаты с помощью значения X из одного положения, значения Y - из второго положения, а для 3D координат - значения Z из третьего положения. В сочетании с объектной привязкой координатные фильтры можно использовать для получения значений координат из существующего объекта.

Как правило, координатные фильтры используются для указания центра прямоугольника или проекции 3D точки на плоскость XY ПСК.

Для указания фильтра в командной строке нужно ввести точку, за которой следует буква X, Y или Z. Следующий ввод ограничен только конкретным координатным значением.

Пример: Использование фильтров в 2D

Отверстие в крепежной пластине на следующем чертеже отцентрировано относительно прямоугольника путем извлечения координат X,Y середин горизонтального и вертикального ребер детали соответственно.

Диалог в командной строке выглядит так:

Команда: круг

Центр круга или [3Т/2Т/ККР (кас кас радиус)]:

сер

Выбрать горизонтальный отрезок нижнее ребро крепежной пластины

(требуется YZ): сер

Выбрать вертикальный отрезок левое ребро крепежной пластины

Диаметр/<Радиус> Задать радиус отверстия

Координатные фильтры действуют только в том случае, когда программа запрашивает точку. При попытке использования координатных фильтров в ответ на подсказку "Команда" программа выводит сообщение об ошибке.

Пример: Использование координатных фильтров в 3D

В данном примере показано использование координатного фильтра для создания объекта точки в центре 3D объекта. Для простоты восприятия невидимые линии подавлены. Координаты новой точки получаются в результате комбинирования значений составляющих координат X первой заданной точки, Y второй точки и Z третьей точки. точки.

Команда: точка

Точка: .x

сер

Выбрать объект (1)

(требуется YZ): .y

сер

Выбрать объект (2)

(требуется Z): сер

Выбрать объект (3)


Комбинирование составляющих координат с помощью координатных фильтров - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Комбинирование составляющих координат с помощью координатных фильтров
Понятия
Процедуры
Команды

Для задания 2D точки с использованием координатных фильтров

Для задания 3D точки с использованием координатных фильтров


Для задания 2D точки с использованием координатных фильтров - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Комбинирование составляющих координат с помощью координатных фильтров
Понятия
Процедуры
Команды

Для задания 2D точки с использованием координатных фильтров

  1. В ответ на запрос координат точки в командной строке указать координатный фильтр (.x или .y).

    2. Например, для задания значения координаты Xввести .x.

  2. Указать точку, из координат которой выделяется координатная составляющая.

    3. Например, в случае выбора фильтра .x в пункте 1, значение X выделяется из этой точки.

  3. Для получения остальных значений координат укажите другую точку.

    4. Положение новой точки объединяет координатные значения, извлеченные из точек, которые заданы в пункте 2 и 3.

Примечание При выполнении п.2 и п.3 вместо указания точек можно вводить числовые значения.


Для задания 3D точки с использованием координатных фильтров - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Комбинирование составляющих координат с помощью координатных фильтров
Понятия
Процедуры
Команды

Для задания 3D точки с использованием координатных фильтров

  1. В ответ на запрос координат точки в командной строке укажите координатный фильтр (.x, .y, .z, .xy, .xz или .yz).

    2. Например, для задания значения координаты Xввести .x.

  2. Указать точку, из координат которой выделяются значения.

    3. Например, в случае выбора фильтра .x в пункте 1, значение X выделяется из этой точки.

  3. В ответ на запрос остальных координат выполнить одно из действий:
    • Указать точку для получения остальных координатных значений.
    • Ввести другой координатный фильтр и вернуться к п.2.

    Например, в случае выбора фильтра .x в пункте 1, укажите вторую точку для одновременного выделения координат Y и Z либо введите .y или .z, чтобы отдельно указать значения Y и Z.

    Положение новой точки объединяет координатные значения, извлеченные из точек, которые заданы в пункте 2 и 3.

Примечание При выполнении п.2 и п.3 вместо указания точек можно вводить числовые значения.


Комбинирование составляющих координат с помощью координатных фильтров - Команды

Средства обеспечения точности
Средства обеспечения точности
Комбинирование составляющих координат с помощью координатных фильтров
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Объектное отслеживание - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Объектное отслеживание
Понятия
Процедуры
Команды

Создаваемые объекты можно размещать в определенной зависимости относительно других объектов с помощью линий отслеживания.

Автоотслеживание ™ помогает вычерчивать объекты под определенными углами или в определенных соотношениях с другими объектами. При включенных режимах автоотслеживания специальные временные линии отслеживания помогают выполнять точные построения. Автоотслеживание включает в себя два варианта отслеживания: полярное отслеживание и отслеживание объектной привязки.

Режимы автоотслеживания можно быстро включать и отключать нажатием кнопок "ОТС-ПОЛЯР" и "ОТС-ОБЪЕКТ" в строке состояния. Использование клавиш временной отмены для включения и отключения отслеживания объектной привязки или отключения всех режимов привязки и отслеживания. См. чертеж с изображением клавиатуры в разделе Переопределение параметров объектной привязки.

Объектное отслеживание расширяет и дополняет возможности объектной привязки. Для использования объектного отслеживания необходимо наличие включенных режимов объектной привязки.

Объектное отслеживание

Объектное отслеживание облегчает выбор точек, которые лежат на линиях отслеживания, проходящих через характерные точки объектов. Захваченная точка помечается маркером в виде маленького знака "плюс" (+). Одновременно может быть захвачено до семи точек чертежа. После захвата точки по мере передвижения курсора появляются вертикальные, горизонтальные или полярные линии отслеживания, проходящие через данную точку. Таким образом, можно, например, выбрать точку, лежащую на пересечении линий, проходящих через конечные точки или середины объектов.

На следующей иллюстрации приводится пример построения отрезка с использованием режима объектной привязки "Конточка". Сначала задается первая точка отрезка (1), затем курсор перемещается к имеющемуся отрезку для захвата его конечной точки (2), после чего курсор перемещается вдоль горизонтальной линии отслеживания для выбора конечной точки (3) нового отрезка.

Изменение параметров объектного отслеживания

По умолчанию разрешено только ортогональное отслеживание. При этом линии отслеживания проводятся через захваченную точку только под углами 0, 90, 180 и 270 градусов. Однако, при необходимости объектное отслеживание можно осуществлять вдоль всех текущих полярных углов отслеживания.

Для отслеживания объектной привязки, точки объекта запрашиваются автоматически. Однако можно установить такой режим, при котором захват точек происходит только по нажатию клавиши SHIFT.

Настройка отображения линий отслеживания

В функции автоотслеживания имеется возможность управления параметрами отображения линий отслеживания, а также способом захвата точек объектов для отслеживания объектных привязок. По умолчанию линии отслеживания являются бесконечными (продолжаются до границ области рисования). Однако можно установить такой режим, при котором длина линий отслеживания ограничивается текущим положением курсора.

Советы по использованию объектного отслеживания

Автоотслеживание (полярное и объектное) позволяет более простыми способами строить объекты, имеющие определенную геометрическую зависимость от других объектов. Ниже приводятся некоторые советы по использованию автоотслеживания при объектной привязке.

  • Для выбора точек, лежащих на перпендикулярах к концам или серединам объектов, объектное отслеживание следует использовать совместно с режимами привязки "Нормаль", "Конточка" и "Середина".
  • Для выбора точек, лежащих на касательной к конечной точке дуги, объектное отслеживание следует использовать совместно с режимами привязки "Касательная" и "Конточка".
  • Отслеживание можно осуществлять от так называемых временных точек отслеживания. Для задания такой точки в ответ на запрос команды выбрать точку, ввести то и указать нужную точку. Указанная точка помечается маленьким маркером в виде знака "плюс" (+). Далее, по мере перемещения курсора поочередно появляются линии отслеживания, проходящие через временную точку отслеживания. Для удаления временной точки нужно при перемещении задержать курсор на ее маркере (знаке "плюс").
  • Можно выбрать точку, находящуюся на заданном расстоянии от точки объектной привязки вдоль линии отслеживания. Для этого после появления линии отслеживания следует ввести в командной строке требуемое расстояние.

    • Примечание Метод "направление-расстояние" будет недоступен, пока для отслеживания объектной привязки задействована клавиша временной отмены.

  • Для изменения способа захвата точек используются параметры "Автоматически" и "Нажатием SHIFT" во вкладке "Построения" диалогового окна "Настройка". По умолчанию устанавливается автоматический способ. Для временного предотвращения захвата точки в областях чертежа с высокой плотностью объектов удерживайте нажатой клавишу SHIFT.


Объектное отслеживание - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Объектное отслеживание
Понятия
Процедуры
Команды

Для включения и отключения объектного отслеживания

Для изменения параметров автоотслеживания


Для включения и отключения объектного отслеживания - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Объектное отслеживание
Понятия
Процедуры
Команды

Для включения и отключения объектного отслеживания

  • Нажмите клавишу F11 или кнопку "ОТС-ОБЪЕКТ" в строке состояния.

    • Для временного включения и отключения отслеживания объектной привязки удерживайте нажатой клавишу F11 во время работы.


Для изменения параметров автоотслеживания - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Объектное отслеживание
Понятия
Процедуры
Команды

Для изменения параметров автоотслеживания

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Параметры" на вкладке "Построения" в разделе "Параметры автоотслеживания" установите или снимите флажки, связанные с настройкой отображения линий отслеживания:
    • Бесконечные линии полярного отслеживания. Отображение линий объектного отслеживания в виде бесконечных прямых. Если флажок сброшен, линия полярного отслеживания проводится от предыдущей указанной точки до курсора.
    • Бесконечные линии объектного отслеживания. Отображение линий объектного отслеживания в виде бесконечных прямых. Если флажок сброшен, линия объектного отслеживания проводится от точки привязки до курсора.
    • Всплывающие подсказки автоотслеживания. Управление выводом подсказок для автоотслеживания. Всплывающие подсказки дают информацию о типе объектной привязки (при объектном отслеживании), текущем угле отслеживания и расстоянии до предыдущей точки.
  3. В группе "Захват точек отслеживания" выбрать способ захвата характерных точек объектов для отслеживания:
    • Автоматически. Автоматический захват точек объекта. Если выбран данный способ, для предотвращения захвата характерной точки объекта можно удерживать нажатой клавишу SHIFT.
    • Нажатием SHIFT. Захват точек происходит только при нажатии клавиши SHIFT в момент, когда курсор находится над точкой объектной привязки.

Ввод команды: НАСТРОЙКА


Объектное отслеживание - Команды

Средства обеспечения точности
Средства обеспечения точности
Объектное отслеживание
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
Системные переменные
AUTOSNAP | Управление отображением маркера, всплывающей подсказки и магнита автопривязки
POLARMODE | Управляет полярным и объектным отслеживанием
TRACKPATH | Управляет отображением линий выравнивания для полярного отслеживания и отслеживания объектной привязки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Отслеживание со смещением от опорных точек - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Отслеживание со смещением от опорных точек
Понятия
Процедуры
Команды

С помощью отслеживания со смещением можно получать новые точки путем вертикального и горизонтального смещения временных опорных точек.

Метод отслеживания можно применять во время запроса точки. При использовании отслеживания с помощью устройства указания можно задавать новые точки путем вертикального и горизонтального смещения временных опорных точек. После включения режима отслеживания и установки базовой опорной точки последующая опорная точка располагается на горизонтальных или вертикальных линиях отслеживания, проведенных от этой точки. Направление смещения определяется резиновой линией. Его можно изменить путем перемещения курсора через опорную точку. Допустимое число временных точек отслеживания не ограничено. Как правило, отслеживание используется в сочетании с режимами объектной привязки или методом задания точек "направление-расстояние".

Например, отслеживание можно использовать для определения центра прямоугольника без построения вспомогательных линий. Для этого необходимо включить отслеживание и указать середину горизонтального отрезка. Затем вертикально переместить курсор до середины вертикального отрезка (2). Нажмите ENTER для принятия точки (3) в центре прямоугольника.


Для задания точки с помощью отслеживания - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Отслеживание со смещением от опорных точек
Понятия
Процедуры
Команды

Для задания точки с помощью отслеживания

  1. Вызовите команду (например, команду ОТРЕЗОК).
  2. Удерживая нажатой клавишу SHIFT, нажмите правую кнопку мыши в области чертежа. Выберите "Слежение".
  3. Указать точку.
  4. Переместить курсор вверх, вниз, влево или вправо до появления резиновой линии.

    5. Выбранным таким образом направлением задается направление отслеживания. Следует иметь в виду, что после перемещения курсора слева направо, если необходимо сменить направление перемещения вверх или вниз, нужно предварительно вернуть курсор на предыдущую заданную точку.

  5. Укажите вторую точку.
  6. Нажмите ENTER для завершения отслеживания.

    7. После этого начальная точка отрезка устанавливается в точке воображаемого пересечения вертикальной и горизонтальной линий отслеживания, проведенных через заданные точки. Расположение точки определяется направлением перемещения курсора после указания первой точки.

Ввод команды: Ключевое слово ОТСЛЕЖИВАНИЕ


Отслеживание со смещением от опорных точек - Команды

Средства обеспечения точности
Средства обеспечения точности
Отслеживание со смещением от опорных точек
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Задание расстояний - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Задание расстояний
Понятия
Процедуры
Команды

При указании точек можно вводить значения расстояний, смещений и интервалов.

  • Метод задания координат "направление-расстояние"
    Положение точки можно задавать путем перемещения курсора в требуемом направлении с последующим вводом точного значения расстояния.
  • Смещение от временных опорных точек
    Пользователь может устанавливать временную опорную точку в качестве базовой для смещения последующих точек.
  • Разметка и деление объектов
    Имеется возможность выполнения разметки вдоль объектов с равным интервалом.


Задание расстояний - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Задание расстояний
Понятия
Процедуры
Команды

Для построения отрезка методом "направление-расстояние"

Для смещения точки от временной опорной точки

Для разметки объекта с помощью точек

Для разметки объекта с помощью блоков

Для деления объекта точками на равные сегменты

Для деления объекта на равные сегменты с помощью блоков


Задание расстояний - Команды

Создание и редактирование объектов
Средства обеспечения точности
Задание расстояний
Понятия
Процедуры
Команды
Команды
БЛОК | Создание описания блока из выбранных объектов
ДИАЛТТОЧ | Задание стиля отображения и величины точечных объектов
ОТРЕЗОК | Построение отрезков
ПБЛОК | Запись объектов или блока в новый файл чертежа
ПОДЕЛИТЬ | Размещение по длине или периметру объекта на равном расстоянии точек или блоков
РАЗМЕТИТЬ | Размещение на объекте точек или блоков с равными интервалами
Системные переменные
PDMODE | Управляет отображением точечных объектов
PDSIZE | Устанавливает размер отображения точечных объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Метод задания координат "направление-расстояние" - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Метод задания координат "направление-расстояние"
Понятия
Процедуры
Команды

Положение точки можно задавать путем перемещения курсора в требуемом направлении с последующим вводом точного значения расстояния.

Длину отрезка или положение точки можно быстро задавать путем перемещения курсора в требуемом направлении с последующим вводом точного значения расстояния от первой заданной точки. Можно вводить вычисленные значения расстояния из калькулятора QuickCalc. Дополнительную информацию см. в разделе Использование калькулятора QuickCalc.

Методом "направление-расстояние" можно пользоваться при задании точек во всех командах, где требуется указание более одной точки. При включенном режиме "Орто" или полярном отслеживании этим способом очень удобно рисовать отрезки определенной длины в заданном направлении, а также перемещать или копировать объекты.

Примечание Метод "направление-расстояние" будет недоступен, пока для режима "Орто", отслеживания объектной привязки или полярного отслеживания задействованы клавиши временной отмены.

См. также

Полярные отслеживание и привязка

Разовое задание угла отслеживания (Угол)


Для построения отрезка методом "направление-расстояние" - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Метод задания координат "направление-расстояние"
Понятия
Процедуры
Команды

Для построения отрезка методом "направление-расстояние"

  1. Вызвать команду ОТРЕЗОК и указать первую точку.
  2. Перемещать устройство указания до тех пор, пока резиновая линия, соединяющая первую точку и перекрестье, не окажется повернутой под требуемым углом.
  3. Ввести значение расстояния в командной строке.

    4. На экране появляется отрезок, имеющий заданную длину и располагающийся в указанном направлении.


Метод задания координат "направление-расстояние" - Команды

Средства обеспечения точности
Средства обеспечения точности
Метод задания координат "направление-расстояние"
Понятия
Процедуры
Команды

Команды
ОТРЕЗОК | Построение отрезков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Смещение от временных опорных точек - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Смещение от временных опорных точек
Понятия
Процедуры
Команды

Пользователь может устанавливать временную опорную точку в качестве базовой для смещения последующих точек.

Режим "Смещение" позволяет устанавливать временную опорную точку в качестве базовой для смещения последующих точек. Режим "Смещение" не ограничивает направление перемещения курсора. Как правило, режим "Смещение" используется совместно с режимами объектной привязки.


Для смещения точки от временной опорной точки - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Смещение от временных опорных точек
Понятия
Процедуры
Команды

Для смещения точки от временной опорной точки

  1. На запрос указания точки ввести сме.
  2. Если нужно выполнить смещение от точки, расположенной на имеющемся объекте, указать режим объектной привязки. Затем выбрать объект.
  3. Ввести относительные координаты.

    4. Нажмите правую кнопку мыши при нажатой клавише SHIFT для вызова меню объектной привязки.

Панель Объектная привязка


Смещение от временных опорных точек - Команды

Средства обеспечения точности
Средства обеспечения точности
Смещение от временных опорных точек
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Разметка и деление объектов - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Разметка и деление объектов
Понятия
Процедуры
Команды

Имеется возможность выполнения разметки вдоль объектов с равным интервалом.

  • Команды разметки объектов
    Обзор команд для выполнения разметки вдоль объектов с равным интервалом.
  • Разметка объектов
    Пользователь может делать разметку вдоль выбранного объекта с заданным шагом.
  • Деление объектов на равные сегменты
    Выбранный объект можно разделить на заданное число равных сегментов.


Разметка и деление объектов - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Разметка и деление объектов
Понятия
Процедуры
Команды

Для разметки объекта с помощью точек

Для разметки объекта с помощью блоков

Для деления объекта точками на равные сегменты

Для деления объекта на равные сегменты с помощью блоков


Разметка и деление объектов - Команды

Создание и редактирование объектов
Средства обеспечения точности
Разметка и деление объектов
Понятия
Процедуры
Команды
Команды
БЛОК | Создание описания блока из выбранных объектов
ДИАЛТТОЧ | Задание стиля отображения и величины точечных объектов
ПБЛОК | Запись объектов или блока в новый файл чертежа
ПОДЕЛИТЬ | Размещение по длине или периметру объекта на равном расстоянии точек или блоков
РАЗМЕТИТЬ | Размещение на объекте точек или блоков с равными интервалами
Системные переменные
PDMODE | Управляет отображением точечных объектов
PDSIZE | Устанавливает размер отображения точечных объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Команды разметки объектов - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Команды разметки объектов
Понятия
Процедуры
Команды

Обзор команд для выполнения разметки вдоль объектов с равным интервалом.

Иногда возникает необходимость расставить точки или блоки вдоль объекта на определенных расстояниях друг от друга.

Пользователь может:

  • РАЗМЕТИТЬ если известны длины сегментов.
  • ПОДЕЛИТЬ если известно число равных по длине сегментов.

Размечать и делить можно отрезки, дуги, сплайны, окружности, эллипсы и полилинии. Обе команды производят разметку путем простановки либо объектов-точек, либо блоков.

Если разметка производится с помощью точек, то впоследствии, используя режим объектной привязки "Узел", можно располагать в этих точках (находящихся на одинаковом расстоянии друг от друга) другие объекты. Разметка с помощью блоков позволяет расставлять последовательности геометрических объектов или пользовательские маркеры. Имеется возможность задавать поворот блоков в точках вставки.

Вставляемые блоки должны быть определены в чертеже. Переменные атрибуты блоков при вставке игнорируются.

Точки или блоки, созданные с помощью команд РАЗМЕТИТЬ и ПОДЕЛИТЬ, помещаются в текущий набор объектов. Таким образом, если сразу после расстановки необходимо редактирование этих объектов, выбрать их можно с помощью опции "Текущий" команды ВЫБРАТЬ.

См. также

Создание и использование блоков (символов)


Разметка и деление объектов

Создание и редактирование объектов
Средства обеспечения точности
Разметка и деление объектов
Понятия
Процедуры
Команды

Нет процедур.


Команды разметки объектов - Команды

Средства обеспечения точности
Средства обеспечения точности
Команды разметки объектов
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
ДИАЛТТОЧ | Задание стиля отображения и величины точечных объектов
ПБЛОК | Запись объектов или блока в новый файл чертежа
ПОДЕЛИТЬ | Размещение по длине или периметру объекта на равном расстоянии точек или блоков
РАЗМЕТИТЬ | Размещение на объекте точек или блоков с равными интервалами
Системные переменные
PDMODE | Управляет отображением точечных объектов
PDSIZE | Устанавливает размер отображения точечных объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Разметка объектов - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Разметка объектов
Понятия
Процедуры
Команды

Пользователь может делать разметку вдоль выбранного объекта с заданным шагом.

Разметка объекта с заданным шагом производится командой РАЗМЕТИТЬ. В точках разметки могут проставляться либо объекты-точки, либо блоки. Последний сегмент размеченного объекта может оказаться короче заданного шага.

Выбор начальной точки для разметки и деления зависит от типа объекта. Для отрезков и разомкнутых полилиний начальная точка - конец объекта, ближайший к точке выбора. Для замкнутых полилиний начальная точка находится в начале полилинии. Для окружностей начальная точка располагается от центра под углом, равным текущему углу поворота шаговой привязки. Например, если угол поворота равен нулю, деление окружности идет в направлении против часовой стрелки начиная с точки окружности, радиус к которой ориентирован в восточном направлении.

Шаг разметки невозможно рассмотреть, если точки разметки отображаются как простые точки (по умолчанию). Стиль точек можно изменить несколькими способами. Для задания стиля через диалоговое окно можно воспользоваться командой ДИАЛТТОЧ или из меню "Формат" выбрать "Отображение точек". Вид точек разметки и деления можно также задать с помощью системной переменной PDMODE. Например, можно изменить значение таким образом, чтобы точки отображались в виде крестиков. Размером объектов-точек управляет системная переменная PDSIZE.


Разметка объектов - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Разметка объектов
Понятия
Процедуры
Команды

Для разметки объекта с помощью точек

Для разметки объекта с помощью блоков


Для разметки объекта с помощью точек - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Разметка объектов
Понятия
Процедуры
Команды

Для разметки объекта с помощью точек

  1. Выберите в меню "Рисование" » "Точка" » "Разметить".
  2. Выбрать отрезок, дугу, сплайн, окружность, эллипс или полилинию.
  3. Ввести значение шага разметки с клавиатуры или указанием двух точек чертежа.

    4. Точки размещаются на объекте с указанным шагом.

Ввод команды: РАЗМЕТИТЬ


Для разметки объекта с помощью блоков - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Разметка объектов
Понятия
Процедуры
Команды

Для разметки объекта с помощью блоков

  1. Если необходимо, создать предварительно блок.
  2. Выберите в меню "Рисование" » "Точка" » "Разметить".
  3. Выбрать отрезок, дугу, сплайн, окружность, эллипс или полилинию.
  4. Ввести значение шага разметки с клавиатуры или указанием двух точек чертежа.
  5. Ввести имя вставляемого блока.
  6. Ввести д для поворота блоков при вставке так, чтобы каждый блок ориентировался по касательной к размечаемому объекту. Ввести н для вставки блоков без поворота.
  7. Ввести значение шага разметки с клавиатуры или указанием двух точек чертежа.

    8. Блоки вставляются на объекте с указанным шагом.

Ввод команды: БЛОК, РАЗМЕТИТЬ


Разметка объектов - Команды

Средства обеспечения точности
Средства обеспечения точности
Разметка объектов
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
ДИАЛТТОЧ | Задание стиля отображения и величины точечных объектов
РАЗМЕТИТЬ | Размещение на объекте точек или блоков с равными интервалами
Системные переменные
PDMODE | Управляет отображением точечных объектов
PDSIZE | Устанавливает размер отображения точечных объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Деление объектов на равные сегменты - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Деление объектов на равные сегменты
Понятия
Процедуры
Команды

Выбранный объект можно разделить на заданное число равных сегментов.

Иногда возникает необходимость расставить точки или блоки вдоль объекта на определенных расстояниях друг от друга. Фактического деления объекта на отдельные части данной командой не производится. Определяется только местоположение делений, чтобы можно было использовать их как геометрические опорные точки.

Выбор начальной точки для разметки и деления зависит от типа объекта. Для отрезков и разомкнутых полилиний начальная точка - конец объекта, ближайший к точке выбора. Для замкнутых полилиний начальная точка находится в начале полилинии. Для окружностей начальная точка располагается от центра под углом, равным текущему углу поворота шаговой привязки. Например, если угол поворота равен нулю, деление окружности идет в направлении против часовой стрелки начиная с точки окружности, радиус к которой ориентирован в восточном направлении.

Сегменты невозможно рассмотреть, если точки деления отображаются как простые точки (по умолчанию). Стиль точек можно изменить несколькими способами. Для задания стиля через диалоговое окно можно воспользоваться командой ДИАЛТТОЧ или из меню "Формат" выбрать "Отображение точек". Вид точек разметки и деления можно также задать с помощью системной переменной PDMODE. Например, можно изменить значение таким образом, чтобы точки отображались в виде крестиков. Размером объектов-точек управляет системная переменная PDSIZE.


Деление объектов на равные сегменты - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Деление объектов на равные сегменты
Понятия
Процедуры
Команды

Для деления объекта точками на равные сегменты

Для деления объекта на равные сегменты с помощью блоков


Для деления объекта точками на равные сегменты - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Деление объектов на равные сегменты
Понятия
Процедуры
Команды

Для деления объекта точками на равные сегменты

  1. Выберите в меню "Рисование" » "Точка" » "Деление".
  2. Выбрать отрезок, дугу, сплайн, окружность, эллипс или полилинию.
  3. Ввести требуемое число сегментов.

    4. Точка помещается между каждым сегментом.

Ввод команды: ПОДЕЛИТЬ


Для деления объекта на равные сегменты с помощью блоков - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Деление объектов на равные сегменты
Понятия
Процедуры
Команды

Для деления объекта на равные сегменты с помощью блоков

  1. Если необходимо, создать предварительно блок.
  2. Выберите в меню "Рисование" » "Точка" » "Деление".
  3. Выбрать отрезок, дугу, сплайн, окружность, эллипс или полилинию.
  4. Ввести значение шага разметки с клавиатуры или указанием двух точек чертежа.
  5. Ввести имя вставляемого блока.
  6. Ввести д для поворота блоков при вставке так, чтобы каждый блок ориентировался по касательной к размечаемому объекту. Ввести н для вставки блоков без поворота.
  7. Ввести требуемое число сегментов.

Ввод команды: БЛОК, ПОДЕЛИТЬ


Деление объектов на равные сегменты - Команды

Средства обеспечения точности
Средства обеспечения точности
Деление объектов на равные сегменты
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
ДИАЛТТОЧ | Задание стиля отображения и величины точечных объектов
ПБЛОК | Запись объектов или блока в новый файл чертежа
ПОДЕЛИТЬ | Размещение по длине или периметру объекта на равном расстоянии точек или блоков
Системные переменные
PDMODE | Управляет отображением точечных объектов
PDSIZE | Устанавливает размер отображения точечных объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Получение геометрической информации от объектов - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Получение геометрической информации от объектов
Понятия
Процедуры
Команды

Пользователю предоставлен ряд команд для получения справочной информации об объектах чертежа и выполнения математических расчетов.

  • Вычисление расстояний, углов и определение координат
    Имеется возможность получения информации о взаимном расположении двух заданных точек: например, можно определить расстояние между ними или угол в плоскости XY.
  • Вычисление площадей
    Имеется возможность вычислить площадь и периметр области, ограниченной последовательностью точек или объектом определенного типа.


Получение геометрической информации от объектов - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Получение геометрической информации от объектов
Понятия
Процедуры
Команды

Для вычисления расстояния и угла

Для вычисления площади заданной области

Для вычисления площади объекта

Для суммирования площадей

Для вычитания площади из подсчитанной общей площади


Получение геометрической информации от объектов - Команды

Создание и редактирование объектов
Средства обеспечения точности
Получение геометрической информации от объектов
Понятия
Процедуры
Команды
Команды
БЫСТРКАЛЬК | Вызов калькулятора QuickCalc
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
КООРД | Определение координат точек
МАСС-ХАР | Вычисление массовых характеристик областей и тел
ПЛОЩАДЬ | Вычисление площадей и периметров объектов или заданных областей
СВОЙСТВА | Изменяет свойства объекта
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
Системные переменные
AREA | Сохранение значения последней области, вычисленного с помощью команды ПЛОЩАДЬ
DISTANCE | Сохраняет значение расстояния, вычисленное с помощью команды DIST
PERIMETER | Хранит последнее значение периметра, вычисленное с помощью команды ПЛОЩАДЬ или СПИСОК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вычисление расстояний, углов и определение координат - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Вычисление расстояний, углов и определение координат
Понятия
Процедуры
Команды

Имеется возможность получения информации о взаимном расположении двух заданных точек: например, можно определить расстояние между ними или угол в плоскости XY.

Пользователь имеет возможность получить следующую информацию о паре выбранных точек:

  • Расстояние между точками
  • Угол между точками в плоскости XY
  • Угол между воображаемым отрезком, проведенным через точки, и плоскостью XY
  • Разности координат точек по осям X, Y и Z

Получить координаты заданной точки можно с помощью команды КООРД.

См. также

Методы записи координат


Для вычисления расстояния и угла - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Вычисление расстояний, углов и определение координат
Понятия
Процедуры
Команды

Для вычисления расстояния и угла

  1. Выберите в меню "Сервис" » "Сведения" » "Расстояние".
  2. Указать первую и вторую точки, между которыми требуется определить расстояние.

    3. Отображается краткий отчет в командной строке.

Панель Сведения

Ввод команды: ДИСТ


Вычисление расстояний, углов и определение координат - Команды

Средства обеспечения точности
Средства обеспечения точности
Вычисление расстояний, углов и определение координат
Понятия
Процедуры
Команды

Команды
КООРД | Определение координат точек
Системные переменные
DISTANCE | Сохраняет значение расстояния, вычисленное с помощью команды DIST
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вычисление площадей - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Вычисление площадей
Понятия
Процедуры
Команды

Имеется возможность вычислить площадь и периметр области, ограниченной последовательностью точек или объектом определенного типа.

Существует возможность вычисления площади и периметра некоторых типов объектов, а также воображаемого многоугольника с вершинами в указанных пользователем точках.

Самый быстрый способ вычисления площади, ограничиваемой несколькими обхектами в 2D, состоит в использовании команды ГРАНИЦЫ. С помощью команды ГРАНИЦЫ можно выбрать точку в пределах площади с целью создания замкнутой полилинии или области. Далее можно использовать палитру "Свойства" или команду СПИСОК с целью получения площади и периметра полилинии или области.

Использование команды ПЛОЩАДЬ

С помощью команды ПЛОЩАДЬ можно задавать серии точек или выбирать объект. Если требуется найти общую площадь нескольких объектов, можно задать режим суммирования или вычитания последовательно вычисляемых площадей. Для выбора объектов в данном случае нельзя пользоваться рамкой выбора и секущей рамкой.

Вычисленные значения площади и периметра сохраняются в системных переменных AREA и PERIMETER.

Вычисление площади области, ограниченной точками

Можно вычислить площадь произвольной замкнутой области, определенной указанием набора двумерных или трехмерных точек. Все точки должны лежать в плоскости, параллельной плоскости XY текущей ПСК.

Вычисление площади, периметра или длины окружности объекта

Можно вычислить площадь, занимаемую кругом, эллипсом, полилинией, многоугольником или трехмерным телом, а также периметр объекта или длину его окружности. Набор выводимой информации зависит от типа выбранного объекта:

  • Круг. Площадь и длина окружности.
  • Эллипс, замкнутая полилиния, многоугольник, планарный замкнутый сплайн и область. Площадь и периметр. Для широкой полилинии вычисляется площадь, ограниченная ее осевой линией.
  • Разомкнутые объекты (разомкнутые сплайновые кривые, разомкнутые полилинии и т.п.). Площадь и длина. Площадь вычисляется в предположении, что начало и конец объекта соединены отрезком.
  • 3D тела AutoCAD. Общая площадь объекта.
Пример: Подсчет площадей в различных случаях

Сложение площадей

Можно производить измерение площади нескольких областей, как ограничиваемых точками, так и заключенных внутри объектов. Например, можно определить суммарную площадь комнат на плане этажа.

Вычитание площадей

Из подсчитанной суммарной площади можно производить вычитание площади одной или нескольких областей. В следующем примере вначале определяется полная площадь этажа, а затем из нее вычитается площадь, занимаемая комнатой.

Пример: Вычитание площади из суммарной площади

В следующем примере рассматривается определение площади металлической пластины, имеющей два больших отверстия; контур пластины образован замкнутой полилинией. Для определения площади пластины из площади, ограничиваемой полилинией, вычитается площадь, занимаемая отверстиями. После выполнения каждого шага вычислений отображаются значения площади и периметра или длины окружности каждого объекта и их суммарные значения.

Диалог в командной строке выглядит так:

Команда: площадь

Первая угловая точка или [Объект/Добавить/Вычесть]: д

Первая угловая точка или [Объект/Вычесть]: о

(Режим СЛОЖЕНИЕ) Выбрать объекты: Выберите полилинию (1)

Площадь = 0.34, Периметр = 2.71

Общая площадь = 0.34

(Режим СЛОЖЕНИЕ) Выбрать объекты: Нажмите ENTER

Первая угловая точка или [Объект/Вычесть]: о

Первая угловая точка или [Объект/Добавить]: о

(Режим ВЫЧИТАНИЕ) Выбрать объекты:Выберите нижнюю окружность (2)

Площадь = 0.02, Длина окружности = 0.46

Общая площадь = 0.32

(Режим ВЫЧИТАНИЕ) Выбрать объекты: Выберите верхнюю окружность (3)

Площадь = 0.02, Длина окружности = 0.46

Общая площадь = 0.30

(Режим ВЫЧИТАНИЕ) Выбрать окружность или полилинию: Нажмите ENTER

Первая угловая точка или [Объект/Добавить]: Нажмите ENTER

Площадь пластины можно также получить в палитре "Свойства" или (если предварительно преобразовать ее в область командой ОБЛАСТЬ и удалить из области отверстия) с помощью команды СПИСОК.

Калькулятор QuickCalc используется для преобразования единиц площади одной системы в единицы другой системы. Дополнительную информацию см. в разделе Использование калькулятора QuickCalc.

См. также

Построение и объединение областей

Коротко о свойствах объектов


Вычисление площадей - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Вычисление площадей
Понятия
Процедуры
Команды

Для вычисления площади заданной области

Для вычисления площади объекта

Для суммирования площадей

Для вычитания площади из подсчитанной общей площади


Для вычисления площади заданной области - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Вычисление площадей
Понятия
Процедуры
Команды

Для вычисления площади заданной области

  1. Выберите в меню "Сервис" » "Сведения" » "Площадь".
  2. Последовательно указать точки для задания области, площадь которой нужно измерить. Далее нажмите ENTER.

    3. Первая и последняя точка соединяются между собой для получения замкнутой области; отображаются значения площади и периметра, измеренные с учетом настроек, определяемых командой ЕДИНИЦЫ.

Панель Сведения

Ввод команды: ПЛОЩАДЬ


Для вычисления площади объекта - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Вычисление площадей
Понятия
Процедуры
Команды

Для вычисления площади объекта

  1. Выберите в меню "Сервис" » "Сведения" » "Площадь".
  2. Последовательно указать точки для задания области, площадь которой нужно измерить.
  3. Выбрать объект.

    4. Выводятся значения площади и периметра указанного объекта.

Панель Сведения

Ввод команды: ПЛОЩАДЬ


Для суммирования площадей - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Вычисление площадей
Понятия
Процедуры
Команды

Для суммирования площадей

  1. Выберите в меню "Сервис" » "Сведения" » "Площадь".
  2. Последовательно указать точки для задания области, площадь которой нужно измерить.
  3. Воспользоваться одним из следующих способов:
    • Укажите точки для определения области, в которой выполняется сложение, и нажмите ENTER
    • Ввести о (Объект) и выбрать объекты, ограничивающие составные части области.

      • Отображаются результаты измерений для каждой из заданных областей и текущее суммарное значение площади.

  4. Для завершения команды нажмите ENTER дважды.

Панель Сведения

Ввод команды: ПЛОЩАДЬ


Для вычитания площади из подсчитанной общей площади - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Вычисление площадей
Понятия
Процедуры
Команды

Для вычитания площади из подсчитанной общей площади

  1. После вывода информации об общей площади введите в (Вычесть).
  2. Воспользуйтесь одним из следующих способов:
    • Укажите точки для определения области, в которой выполняется вычитание, и нажмите ENTER.
    • Введите о (Объект) и выберите объекты, ограничивающие составные части области.

    При определении новых областей обновляется текущее суммарное значение.

  3. Нажмите ENTER для завершения команды.

Панель Сведения

Ввод команды: ПЛОЩАДЬ


Вычисление площадей - Команды

Средства обеспечения точности
Средства обеспечения точности
Вычисление площадей
Понятия
Процедуры
Команды

Команды
БЫСТРКАЛЬК | Вызов калькулятора QuickCalc
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
МАСС-ХАР | Вычисление массовых характеристик областей и тел
ПЛОЩАДЬ | Вычисление площадей и периметров объектов или заданных областей
СВОЙСТВА | Изменяет свойства объекта
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
Системные переменные
AREA | Сохранение значения последней области, вычисленного с помощью команды ПЛОЩАДЬ
PERIMETER | Хранит последнее значение периметра, вычисленное с помощью команды ПЛОЩАДЬ или СПИСОК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование калькулятора - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Использование калькулятора
Понятия
Процедуры
Команды

При работе с программой можно пользоваться функциями калькулятора. Можно использовать интерфейс калькулятора QuickCalc или калькулятор командной строки.

  • Использование калькулятора QuickCalc
    Используя калькулятор QuickCalc, интерфейс которого напоминает карманный калькулятор, можно выполнять математические, научные и геометрические вычисления, преобразовывать единицы измерения, управлять свойствами объектов и осуществлять оценку выражений.
  • Использование калькулятора командной строки
    При вводе выражения в калькуляторе командной строки можно быстро вычислять различные математические выражения и рассчитывать координаты точек.


Использование калькулятора - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование калькулятора
Понятия
Процедуры
Команды

Для очистки поля ввода

Для использования основных математических функций в калькуляторе QuickCalc

Для использования научных функций в калькуляторе QuickCalc

Для получения абсолютного значения числа с помощью QuickCalc

Для округления числа до ближайшего целого с помощью QuickCalc

Для отображения только целой части числа с помощью QuickCalc

Для сохранения значения в памяти QuickCalc

Для добавления текущего значения к значению, сохраненному в памяти QuickCalc

Для восстановления значения, сохраненного в памяти QuickCalc

Для очистки значения, сохраненного в памяти QuickCalc

Для использования калькулятора QuickCalc

Для использования калькулятора QuickCalc в рамках команды

Для использования калькулятора QuickCalc вместе с палитрой свойств

Для копирования/вставки значения в поле ввода QuickCalc

Для вставки значения из поля ввода QuickCalc в командную строку

Для очистки области журнала

Для повторного использования значения или выражения, сохраненного в области журнала калькулятора QuickCalc

Для изменения цвета шрифта значений или выражений в области журнала QuickCalc

Для копирования/вставки выражения в область журнала QuickCalc

Для добавления значения или выражения из области журнала калькулятора QuickCalc в поле ввода

Для изменения свойства в палитре свойств с помощью QuickCalc

Для получения значений координат X, Y, Z для точки с помощью QuickCalc

Для измерения расстояния между двумя точками с помощью QuickCalc

Для получения угла наклона отрезка, заданного двумя точками, с помощью QuickCalc

Для получения точки пересечения отрезков, заданной четырьмя точками, с помощью QuickCalc

Для преобразования единиц измерения с помощью QuickCalc

Для копирования результатов преобразования единиц в поле ввода калькулятора QuickCalc

Для преобразования радианов в градусы с помощью QuickCalc

Для преобразования градусов в радианы с помощью QuickCalc

Для использования стандартной переменной в выражении QuickCalc

Для создания новой переменной в QuickCalc

Для редактирования переменной в QuickCalc

Для удаления переменной в QuickCalc

Для создания новой глобальной константы в поле ввода калькулятора QuickCalc

Для обращения к глобальной константе из диалогового окна или обычного окна

Чтобы вычислять математические выражения в диалоговом окне


Использование калькулятора - Команды

Создание и редактирование объектов
Средства обеспечения точности
Использование калькулятора
Понятия
Процедуры
Команды
Команды
БКЗАКРЫТЬ | Закрытие калькулятора QuickCalc
БЫСТРКАЛЬК | Вызов калькулятора QuickCalc
КАЛЬК | Вычисление математических и геометрических выражений
Системные переменные
CALCINPUT | Управление вычислением математических выражений и глобальных констант в полях для ввода текстовых или числовых данных
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование калькулятора QuickCalc - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Использование калькулятора QuickCalc
Понятия
Процедуры
Команды

Используя калькулятор QuickCalc, интерфейс которого напоминает карманный калькулятор, можно выполнять математические, научные и геометрические вычисления, преобразовывать единицы измерения, управлять свойствами объектов и осуществлять оценку выражений.

  • Коротко о QuickCalc
  • Доступ к QuickCalc и сведения о его работе
    QuickCalc можно использовать так же, как калькулятор рабочего стола, или в рамках команды или палитры свойств.
  • Ввод, вычисление и получение выражений
    Введите выражения в QuickCalc, используя стандартные математические правила предшествования; просмотрите и извлеките расчеты из области журнала; ознакомьтесь с правилами использования единиц британской системы, относящихся к длине, площади и объему.
  • Преобразование единиц измерения
    В области преобразования единиц калькулятора QuickCalc можно получить эквивалентные значения для различных единиц измерения.
  • Создание и использование переменных калькулятора
    В области переменных QuickCalc хранятся переменные калькулятора, к которым можно обращаться в случае необходимости. Переменные калькулятора могут быть константами или функциями.


Использование калькулятора QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Использование калькулятора QuickCalc
Понятия
Процедуры
Команды

Для очистки поля ввода

Для использования основных математических функций в калькуляторе QuickCalc

Для использования научных функций в калькуляторе QuickCalc

Для получения абсолютного значения числа с помощью QuickCalc

Для округления числа до ближайшего целого с помощью QuickCalc

Для отображения только целой части числа с помощью QuickCalc

Для сохранения значения в памяти QuickCalc

Для добавления текущего значения к значению, сохраненному в памяти QuickCalc

Для восстановления значения, сохраненного в памяти QuickCalc

Для очистки значения, сохраненного в памяти QuickCalc

Для использования калькулятора QuickCalc

Для использования калькулятора QuickCalc в рамках команды

Для использования калькулятора QuickCalc вместе с палитрой свойств

Для копирования/вставки значения в поле ввода QuickCalc

Для вставки значения из поля ввода QuickCalc в командную строку

Для очистки области журнала

Для повторного использования значения или выражения, сохраненного в области журнала калькулятора QuickCalc

Для изменения цвета шрифта значений или выражений в области журнала QuickCalc

Для копирования/вставки выражения в область журнала QuickCalc

Для добавления значения или выражения из области журнала калькулятора QuickCalc в поле ввода

Для изменения свойства в палитре свойств с помощью QuickCalc

Для получения значений координат X, Y, Z для точки с помощью QuickCalc

Для измерения расстояния между двумя точками с помощью QuickCalc

Для получения угла наклона отрезка, заданного двумя точками, с помощью QuickCalc

Для получения точки пересечения отрезков, заданной четырьмя точками, с помощью QuickCalc

Для преобразования единиц измерения с помощью QuickCalc

Для копирования результатов преобразования единиц в поле ввода калькулятора QuickCalc

Для преобразования радианов в градусы с помощью QuickCalc

Для преобразования градусов в радианы с помощью QuickCalc

Для использования стандартной переменной в выражении QuickCalc

Для создания новой переменной в QuickCalc

Для редактирования переменной в QuickCalc

Для удаления переменной в QuickCalc

Для создания новой глобальной константы в поле ввода калькулятора QuickCalc

Для обращения к глобальной константе из диалогового окна или обычного окна

Чтобы вычислять математические выражения в диалоговом окне


Использование калькулятора QuickCalc - Команды

Создание и редактирование объектов
Средства обеспечения точности
Использование калькулятора QuickCalc
Понятия
Процедуры
Команды
Команды
БКЗАКРЫТЬ | Закрытие калькулятора QuickCalc
БЫСТРКАЛЬК | Вызов калькулятора QuickCalc
Системные переменные
CALCINPUT | Управление вычислением математических выражений и глобальных констант в полях для ввода текстовых или числовых данных
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о QuickCalc - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Калькулятор QuickCalc содержит основные функции, аналогичные тем, что существуют в стандартных математических калькуляторах. Кроме того, QuickCalc содержит функции, свойственные AutoCAD,например: геометрические функции, область преобразования единиц и область переменных.

В отличие от большинства калькуляторов, QuickCalc является построителем выражений. Для большей гибкости калькулятор не сразу выдает ответ после выбора функции. Вместо этого составляется выражение, которое можно легко редактировать. По завершении нажмите знак равенства (=) или нажмите клавишу ENTER. Позднее это выражение можно извлечь из области журнала, изменить, а затем выполнить перерасчет результатов.

Используя калькулятор QuickCalc, можно выполнять следующие действия.

  • Осуществление математических и тригонометрических расчетов
  • Обращение к ранее выполненным расчетам для переоценки, а также их просмотр
  • Использование калькулятора вместе с палитрой свойств для изменения свойств объектов
  • Преобразование единиц измерения
  • Осуществление геометрических расчетов, связанных с определенными объектами
  • Копирование и вставка значений и выражений с использованием палитры свойств или командной строки
  • Выполнение расчетов со смешанными числами (имеющими целые и дробные части), величинами в футах и дюймах
  • Определение, хранение и использование переменных калькулятора
  • Использование геометрических функций из команды КАЛЬК

Изменение размеров и внешнего вида QuickCalc

Нажмите кнопку "Больше/Меньше" на калькуляторе, и отобразятся только области ввода и журнала. Для открытия и закрытия областей можно пользоваться стрелками развертывания/свертывания. Кроме того, пользователь может изменять размеры, местоположение и внешний вид QuickCalc. Края граней, расположенных под большим углом, не сглаживаются. См. раздел Задание параметров интерфейса.


Коротко о QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Для очистки поля ввода

Для использования основных математических функций в калькуляторе QuickCalc

Для использования научных функций в калькуляторе QuickCalc

Для получения абсолютного значения числа с помощью QuickCalc

Для округления числа до ближайшего целого с помощью QuickCalc

Для отображения только целой части числа с помощью QuickCalc

Для сохранения значения в памяти QuickCalc

Для добавления текущего значения к значению, сохраненному в памяти QuickCalc

Для восстановления значения, сохраненного в памяти QuickCalc

Для очистки значения, сохраненного в памяти QuickCalc


Для очистки поля ввода - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Для очистки поля ввода

Выполнить одно из следующих действий:

  • На панели инструментов QuickCalc нажмите кнопку "Очистить".
  • На цифровой клавиатуре QuickCalc нажмите кнопку "Очистить".

    • Любое текущее значение или выражение в поле ввода будет удалено, и будет восстановлено значение 0.


Для использования основных математических функций в калькуляторе QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Для использования основных математических функций в калькуляторе QuickCalc

  1. На цифровой клавиатуре введите число.
  2. Нажмите кнопку оператора (+, -, *, /). Затем введите следующее число и т.д.
  3. Нажмите знак равенства (=).

    4. В поле ввода отобразятся результаты. Выражение и результат также отобразятся в области журнала.


Для использования научных функций в калькуляторе QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Для использования научных функций в калькуляторе QuickCalc

  1. На цифровой клавиатуре введите число.
  2. В области научных расчетов выберите функцию.
  3. На цифровой клавиатуре нажмите знак равенства (=).

    4. В поле ввода отобразятся результаты.


Для получения абсолютного значения числа с помощью QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Для получения абсолютного значения числа с помощью QuickCalc

  1. В момент отображения текущего значения в области научных расчетов нажмите кнопку abs.
  2. На цифровой клавиатуре нажмите знак равенства (=).

    3. В поле ввода отобразится абсолютное значение.


Для округления числа до ближайшего целого с помощью QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Для округления числа до ближайшего целого с помощью QuickCalc

  1. В момент отображения текущего значения в области научных расчетов нажмите кнопку rnd.
  2. На цифровой клавиатуре нажмите знак равенства (=).

    3. В поле ввода отобразится число, округленное до ближайшего целого.


Для отображения только целой части числа с помощью QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Для отображения только целой части числа с помощью QuickCalc

  1. В момент отображения текущего значения в области научных расчетов нажмите кнопку trunc.
  2. На цифровой клавиатуре нажмите знак равенства (=).

    3. В поле ввода отобразится целая часть числа без десятичных знаков.


Для сохранения значения в памяти QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Для сохранения значения в памяти QuickCalc

  • В момент отображения текущего значения щелкните MS.

    • Предыдущее значение перезаписывается, а новое значение сохраняется в памяти.


Для добавления текущего значения к значению, сохраненному в памяти QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Для добавления текущего значения к значению, сохраненному в памяти QuickCalc

  • В момент отображения текущего значения щелкните M+.

    • Отобразится сумма нового значения и значения, занесенного в память.


Для восстановления значения, сохраненного в памяти QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Для восстановления значения, сохраненного в памяти QuickCalc

  • В момент отображения текущего значения щелкните MR.

    • Отображаемое значение или выражение прибавляется, и выводится значение сохраненное в памяти.


Для очистки значения, сохраненного в памяти QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Для очистки значения, сохраненного в памяти QuickCalc

  • Щелкните MC.

    • Значение, сохраненное в памяти, будет очищено.


Коротко о QuickCalc - Команды

Средства обеспечения точности
Средства обеспечения точности
Коротко о QuickCalc
Понятия
Процедуры
Команды

Команды
БКЗАКРЫТЬ | Закрытие калькулятора QuickCalc
БЫСТРКАЛЬК | Вызов калькулятора QuickCalc
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Доступ к QuickCalc и сведения о его работе - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Доступ к QuickCalc и сведения о его работе
Понятия
Процедуры
Команды

В программе существует три способа работы с QuickCalc:

  • Непосредственно из меню "Сервис", панель инструментов "Стандартная", контекстное меню или командная строка
  • Просто во время выполнения команды из контекстного меню или командной строки
  • Просто из палитры свойств

Выбранный метод зависит от того, как используется QuickCalc.

Непосредственное использование QuickCalc

При непосредственной работе с QuickCalc можно выполнять расчеты и преобразования единиц, как при использовании настольного калькулятора. Для переноса результатов в другие части программы или во внешние программы можно использовать буфер обмена Windows (CTRL+C, CTRL+V). Расчеты, выполняемые непосредственно, не влияют на чертеж и ничего в нем не меняют.

Непосредственный доступ к QuickCalc можно получить следующими способами:

  • В меню "Сервис" выберите "Палитры" и затем "БЫСТРКАЛЬК".
  • На панели инструментов "Стандартная" нажмите кнопку "QuickCalc"
  • В редакторе чертежей (при отсутствии активных команд) нажмите правой кнопкой мыши, а затем выберите QuickCalc
  • Введите в командной строке quickcalc или qc, а затем нажмите ENTER.
Использование QuickCalc в рамках команды

Во время выполнения команды доступ к QuickCalc осуществляется следующими способами:

  • Щелкните правой кнопкой мыши для вызова контекстного меню. Выберите "QuickCalc".
  • Введите в командной строке 'quickcalc или 'qc.

Расчеты, переносимые в командную строку, влияют на чертеж. Например, если выполняется построение линии с помощью команды "ОТРЕЗОК" и выражение передается в командную строку из калькулятора, для следующей точки линии используются результаты, которые могут быть линейным или угловым значением. В калькуляторе QuickCalc нажмите кнопку "Применить", чтобы передать значение в чертеж исходя из данного выражения.

Примечание При открытом использовании QuickCalc для расчета значения, которое применяется при непосредственном вводе расстояния, оно передается в командную строку командой "Применить". Для использования значения определите направление с помощью курсоров в форме перекрестия и нажмите клавишу ENTER.

Открытое использование QuickCalc из палитры свойств

Когда необходимо изменить свойства и применить вычисленные выражения к объектам в чертеже, можно открыто обратиться к QuickCalc из палитры свойств. Используйте следующий способ:

  • Щелкните любое поле в палитре свойств, содержащее числовое значение. Затем нажмите кнопку "QuickCalc", которая появится в поле.
  • После расчета значения нажмите кнопку "Применить", чтобы перенести результат в палитру свойств.

Свойство объекта или чертежа изменяется, и в чертеже отображаются изменения.

Вычисление математических выражений в диалоговом окне

Можно также вводить и оценивать математические выражения в диалоговом окне с использованием следующего формата:=выражение<КОНЕЦ>

Примечание Чтобы вычислять выражения в диалоговом окне, необходимо убедиться, что для системной переменной CALCINPUT установлено значение 1.


Доступ к QuickCalc и сведения о его работе - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Доступ к QuickCalc и сведения о его работе
Понятия
Процедуры
Команды

Для использования калькулятора QuickCalc

Для использования калькулятора QuickCalc в рамках команды

Для использования калькулятора QuickCalc вместе с палитрой свойств


Для использования калькулятора QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Доступ к QuickCalc и сведения о его работе
Понятия
Процедуры
Команды

Для использования калькулятора QuickCalc

Выполнить одно из следующих действий:

  • Введите в командной строке quickcalc или qc.
  • Нажмите правой кнопкой в области рисования, чтобы отобразить контекстное меню. Выберите "QuickCalc".
  • В меню "Сервис" выберите "Палитры" » "БЫСТРКАЛЬК".
  • На панели инструментов "Стандартная" нажмите кнопку "QuickCalc".


Для использования калькулятора QuickCalc в рамках команды - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Доступ к QuickCalc и сведения о его работе
Понятия
Процедуры
Команды

Для использования калькулятора QuickCalc в рамках команды

Выполнить одно из следующих действий:

  • Введите в командной строке 'quickcalc или 'qc.
  • Нажмите правой кнопкой, чтобы отобразить контекстное меню. Выберите "QuickCalc".


Для использования калькулятора QuickCalc вместе с палитрой свойств - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Доступ к QuickCalc и сведения о его работе
Понятия
Процедуры
Команды

Для использования калькулятора QuickCalc вместе с палитрой свойств

  1. Откройте палитру свойств.
  2. Выберите один или несколько объектов.
  3. Щелкните поле с числовым свойством.
  4. Нажмите в поле кнопку "QuickCalc".


Доступ к QuickCalc и сведения о его работе - Команды

Средства обеспечения точности
Средства обеспечения точности
Доступ к QuickCalc и сведения о его работе
Понятия
Процедуры
Команды

Команды
БКЗАКРЫТЬ | Закрытие калькулятора QuickCalc
БЫСТРКАЛЬК | Вызов калькулятора QuickCalc
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Ввод, вычисление и получение выражений - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Введите выражения в QuickCalc, используя стандартные математические правила предшествования; просмотрите и извлеките расчеты из области журнала; ознакомьтесь с правилами использования единиц британской системы, относящихся к длине, площади и объему.

При вычислении выражений с помощью команды QuickCalc используется следующий стандартный порядок выполнения арифметических операций.

  • Вычисляются выражения в скобках, начиная со скобок максимальной вложенности
  • Выполняются операции в стандартной последовательности: вначале возведение в степень, затем умножение и деление, затем сложение и вычитание
  • Операции с равными приоритетами выполняются слева направо

Поле ввода калькулятора находится там, где осуществляется ввод и извлечение выражений. При использовании QuickCalc данные в поле ввода можно вводить двумя способами. Выражения можно вводить с помощью кнопок цифровой клавиатуры калькулятора QuickCalc; кроме того, можно использовать пользовательскую клавиатуру или ее цифровую клавиатуру. Для использования цифровой клавиатуры на пользовательской клавиатуре включите функцию NUMLOCK (индикатор светится).

Чтобы вычислить выражение, щелкните знак равенства (=) на цифровой клавиатуре QuickCalc или нажмите клавишу ENTER на пользовательской клавиатуре.

Сведения о синтаксисе выражений

Синтаксис для выражений QuickCalc и выражений калькулятора для командной строки идентичен. Например, чтобы выполнить операцию по вектору или по координатам 5,2,0, введите [5,2,0] в поле ввода.

Можно использовать функцию GETVAR для чтения значений системных переменных. Синтаксис:

getvar (имя_переменной)

Подробнее см. КАЛЬК.

Использование области журнала

В области журнала фиксируются текущие расчеты, наподобие бумажной ленты в физическом настольном калькуляторе. Область журнала можно использовать для просмотра предыдущих операций и передачи их обратно в поле ввода для повторных вычислений с различными параметрами.

Правила отображения и обработки единиц

В QuickCalc действуют следующие правила:

  • Результаты расчетов всегда выражаются в десятичном формате, если только расстояние не вводится в футах и дюймах.
  • Предполагается, что угловые значения, введенные в поле ввода, выражаются градусами независимо от настроек в диалоговом окне "Единицы чертежа". Чтобы указать радианы, грады или градусы, добавьте после углового значения параметры r, g или d.
  • Результаты расчетов углов всегда выражаются в градусах с максимальной для AutoCAD точностью.

Когда в качестве единиц чертежа используются архитектурные единицы, калькулятор отображает результаты вычислений величин в британских единицах в архитектурном формате и округляет их до указанного знака (LUPREC) при отображении на чертеже. Результаты для всех других расчетов отображаются в десятичном формате со всей точностью.

Футы, дюймы и дробные значения дюймов можно отделять с помощью тире, пробела, либо можно вообще ничего не использовать. Для ввода допустимых значений в формате футов/дюймов можно пользоваться любыми из указанных вариантов синтаксиса:

  • 5' или 60"
  • 5'-9" или 5' 9" или 5'9"
  • 5'-1/2" или 5' 1/2" или 5'1/2"
  • 5'-9-1/2" или 5' 9-1/2" или 5'9-1/2"
  • 5'-9 1/2" или 5' 9 1/2" или 5'9 1/2"

Ввод двойных кавычек (") для обозначения дюймов в линейных расчетах носит факультативных характер. Например, вместо того, чтобы вводить 5'9-1/2", можно ввести 5'9-1/2.

Предупреждение При использовании британских единиц QuickCalc интерпретирует минус или тире (-) не как операцию вычитания, а как разделитель единиц. Для обозначения вычитания вставляйте хотя бы один пробел до или после знака минуса. Например, чтобы вычесть 9" из 5', вводите 5' -9", а не 5'-9".

QuickCalc можно использовать для вычисления квадратных и кубических футов. Для ввода квадратных или кубических футов необходимо ввести единицы, используя следующие сокращения:

  • sq. ft. или sq ft
  • cu. ft. или cu ft


Ввод, вычисление и получение выражений - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для копирования/вставки значения в поле ввода QuickCalc

Для вставки значения из поля ввода QuickCalc в командную строку

Для очистки области журнала

Для повторного использования значения или выражения, сохраненного в области журнала калькулятора QuickCalc

Для изменения цвета шрифта значений или выражений в области журнала QuickCalc

Для копирования/вставки выражения в область журнала QuickCalc

Для добавления значения или выражения из области журнала калькулятора QuickCalc в поле ввода

Для изменения свойства в палитре свойств с помощью QuickCalc

Для получения значений координат X, Y, Z для точки с помощью QuickCalc

Для измерения расстояния между двумя точками с помощью QuickCalc

Для получения угла наклона отрезка, заданного двумя точками, с помощью QuickCalc

Для получения точки пересечения отрезков, заданной четырьмя точками, с помощью QuickCalc


Для копирования/вставки значения в поле ввода QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для копирования/вставки значения в поле ввода QuickCalc

  1. Щелкните правой кнопкой мыши значение в поле ввода. Выберите "Копировать".

    2. Текущая запись копируется в буфер обмена.

  2. Щелкните в новом месте, затем щелкните правой кнопкой мыши. Выберите "Вставить".

    3. Значение скопируется в новое место.


Для вставки значения из поля ввода QuickCalc в командную строку - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для вставки значения из поля ввода QuickCalc в командную строку

  • На панели инструментов QuickCalc нажмите кнопку "Вставить значение в командную строку".

    • Значение в поле ввода будет вставлено в командную строку.


Для очистки области журнала - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для очистки области журнала

  • На панели инструментов QuickCalc нажмите кнопку "Очистить журнал".

    • Контекстное меню: Щелкните правой кнопкой мыши в области журнала. Выберите "Очистить журнал".


Для повторного использования значения или выражения, сохраненного в области журнала калькулятора QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для повторного использования значения или выражения, сохраненного в области журнала калькулятора QuickCalc

  1. Нажмите кнопку C (если необходимо) для очистки поля ввода.
  2. В области журнала дважды щелкните значение или выражение. Значение или выражение отобразится в поле ввода.

    3. Примечание Курсор должен находиться на выбираемом значении или выражении.


Для изменения цвета шрифта значений или выражений в области журнала QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для изменения цвета шрифта значений или выражений в области журнала QuickCalc

  1. Щелкните правой кнопкой мыши в области журнала. Выберите "Цвет шрифта значения" или "Цвет шрифта выражения".
  2. В диалоговом окне "Цвет" щелкните "Основной цвет" или "Определить пользовательские цвета".

    3. При использовании параметра "Определить пользовательские цвета" можно выбрать пользовательский цвет и добавить его в "Пользовательские цвета".

  3. Нажать "ОК".

    4. Цвета, выбранные для значений и выражений, отобразятся в области журнала.

    Контекстное меню: Щелкните правой кнопкой мыши "Цвет шрифта выражения" или "Цвет шрифта значения". Выберите "Основной цвет" или "Определить пользовательские цвета".


Для копирования/вставки выражения в область журнала QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для копирования/вставки выражения в область журнала QuickCalc

  1. Щелкните правой кнопкой мыши выражение в области журнала. Выберите "Копировать".

    2. Текущая запись копируется в буфер обмена.

  2. Щелкните правой кнопкой мыши в новом месте. Выберите "Вставить".

    3. Выражение скопируется в новое место.


Для добавления значения или выражения из области журнала калькулятора QuickCalc в поле ввода - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для добавления значения или выражения из области журнала калькулятора QuickCalc в поле ввода

  • Дважды щелкните значение или выражение в области журнала.

    • Значение или выражение будет добавлено в поле ввода.

    Примечание Курсор должен находиться на выбираемом значении или выражении.

Контекстное меню: Щелкните правой кнопкой мыши "Добавить значение в область ввода" или "Добавить выражение в область ввода".


Для изменения свойства в палитре свойств с помощью QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для изменения свойства в палитре свойств с помощью QuickCalc

  1. Выбрать объект.

    2. Примечание Если QuickCalc отображается на рабочем столе во время работы с палитрой свойств, он на время скрывается, когда из палитры свойств пользователь обращается к модальному калькулятору.

  2. В разделе геометрии палитры свойств щелкните значение свойства.

    3. Справа от значения отобразится небольшой значок калькулятора.

    Примечание Изменить можно только те свойства, которые отображаются на белом фоне.

  3. Щелкните значок калькулятора.

    4. Откроется калькулятор QuickCalc, и в поле ввода отобразится текущее значение объекта.

  4. Выполните вычисления с отображаемым значением и щелкните кнопку знака равенства (=).

    5. В поле ввода отобразится новое значение.

  5. Нажмите кнопку "Применить".

    6. Примечание Кнопка "Применить" доступна только при определении свойств, которые можно редактировать, и к тому же, они должны относиться к числам.

    Калькулятор закроется, а новое значение отобразится в палитре свойств. Объект в чертеже изменится.


Для получения значений координат X, Y, Z для точки с помощью QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для получения значений координат X, Y, Z для точки с помощью QuickCalc

Примечание Кнопка "Получить координаты" на панели инструментов QuickCalc использует функцию cur.

  1. На панели инструментов QuickCalc нажмите кнопку "Получить координаты".

    2. QuickCalc временно закроется, и появится запрос для задания точки.

  2. В чертеже выберите точку.

    3. Откроется калькулятор QuickCalc, и в поле ввода отобразятся координатные значения точки.


Для измерения расстояния между двумя точками с помощью QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для измерения расстояния между двумя точками с помощью QuickCalc

Примечание Кнопка "Расстояние между двумя точками" на панели инструментов QuickCalc использует функцию dist(p1,p2).

  1. На панели инструментов QuickCalc нажмите кнопку "Расстояние между двумя точками".

    2. QuickCalc временно закроется, и появится запрос для задания двух точек.

  2. В чертеже выберите первую точку, затем - вторую.

    3. Откроется калькулятор QuickCalc, и в поле ввода отобразится значение расстояния между двумя точками.


Для получения угла наклона отрезка, заданного двумя точками, с помощью QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для получения угла наклона отрезка, заданного двумя точками, с помощью QuickCalc

Примечание Кнопка "Угол линии, определенной двумя точками" на панели инструментов QuickCalc использует функцию ang(p1,p2).

  1. На панели инструментов QuickCalc нажмите кнопку "Угол линии, определенной двумя точками".

    2. QuickCalc временно закроется, и в командной строке появится запрос для задания двух точек.

  2. Введите координатные значения первой точки, а затем - второй.

    3. Откроется калькулятор QuickCalc, и значение угла между двумя точками будет добавлено в конец любого значения или выражения, уже присутствующего в поле ввода.


Для получения точки пересечения отрезков, заданной четырьмя точками, с помощью QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Для получения точки пересечения отрезков, заданной четырьмя точками, с помощью QuickCalc

Примечание Кнопка "Пересечение двух линий, определенных четырьмя точками" калькулятора QuickCalc использует функцию ill(p1,p2,p3,p4).

  1. На панели инструментов QuickCalc нажмите кнопку "Пересечение двух линий, определенных четырьмя точками".

    2. QuickCalc временно закроется, и в командной строке появится запрос для задания четырех точек.

  2. Введите координатные значения первой точки первого отрезка, а затем - второй точки первого отрезка. Далее введите координатные значения первой точки второго отрезка, а затем - второй точки второго отрезка.

    3. Откроется калькулятор QuickCalc, и значение вычисленного выражения будет добавлено в конец любого значения или выражения, уже присутствующего в поле ввода.


Ввод, вычисление и получение выражений - Команды

Средства обеспечения точности
Средства обеспечения точности
Ввод, вычисление и получение выражений
Понятия
Процедуры
Команды

Команды
БКЗАКРЫТЬ | Закрытие калькулятора QuickCalc
БЫСТРКАЛЬК | Вызов калькулятора QuickCalc
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Преобразование единиц измерения - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Преобразование единиц измерения
Понятия
Процедуры
Команды

В области преобразования единиц калькулятора QuickCalc можно получить эквивалентные значения для различных единиц измерения.

Преобразование единиц возможно для величин, относящихся к длине, площади, объему и угловым значениям. В зависимости от выбранного типа можно выбрать список единиц, которые необходимо преобразовать, и список единиц, в которые они будут преобразованы.

В поле "Преобразуемое значение" автоматически отображается значение из поля ввода. Можно также ввести другое значение. Результаты преобразования единиц отображаются в поле "Преобразованное значение". Чтобы вставить этот результат в поле ввода, щелкните значок QuickCalc в поле "Преобразованное значение".

Примечание В поле "Преобразуемое значение" введите десятичные значения без единиц.


Преобразование единиц измерения - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Преобразование единиц измерения
Понятия
Процедуры
Команды

Для преобразования единиц измерения с помощью QuickCalc

Для копирования результатов преобразования единиц в поле ввода калькулятора QuickCalc

Для преобразования радианов в градусы с помощью QuickCalc

Для преобразования градусов в радианы с помощью QuickCalc


Для преобразования единиц измерения с помощью QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Преобразование единиц измерения
Понятия
Процедуры
Команды

Для преобразования единиц измерения с помощью QuickCalc

  1. В области преобразования единиц выберите категорию единиц в списке "Тип единиц".
  2. В списке "Преобразовать из" выберите тип единиц, который следует преобразовать.
  3. В списке "Преобразовать в" выберите тип единиц, в который будет выполнено преобразование.
  4. В поле "Преобразуемое значение" введите значение, которое необходимо преобразовать. Нажать ENTER.

    5. Преобразованное значение отобразится в поле "Преобразованное значение".


Для копирования результатов преобразования единиц в поле ввода калькулятора QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Преобразование единиц измерения
Понятия
Процедуры
Команды

Для копирования результатов преобразования единиц в поле ввода калькулятора QuickCalc

  • В заголовке области преобразования единиц нажмите кнопку "Возвратить значение преобразования в область ввода".

    • Преобразованное значение отобразится в поле ввода.


Для преобразования радианов в градусы с помощью QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Преобразование единиц измерения
Понятия
Процедуры
Команды

Для преобразования радианов в градусы с помощью QuickCalc

  1. На цифровой клавиатуре введите значение в радианах.
  2. В области научных расчетов нажмите кнопку r2d.
  3. На цифровой клавиатуре нажмите знак равенства (=).

    4. Преобразование отобразится в поле ввода.


Для преобразования градусов в радианы с помощью QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Преобразование единиц измерения
Понятия
Процедуры
Команды

Для преобразования градусов в радианы с помощью QuickCalc

  1. На цифровой клавиатуре введите значение в градусах.
  2. В области научных расчетов нажмите кнопку d2r.
  3. На цифровой клавиатуре нажмите знак равенства (=).

    4. Преобразование отобразится в поле ввода.


Преобразование единиц измерения - Команды

Средства обеспечения точности
Средства обеспечения точности
Преобразование единиц измерения
Понятия
Процедуры
Команды

Команды
БКЗАКРЫТЬ | Закрытие калькулятора QuickCalc
БЫСТРКАЛЬК | Вызов калькулятора QuickCalc
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и использование переменных калькулятора - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Создание и использование переменных калькулятора
Понятия
Процедуры
Команды

Область переменных можно использовать для определения, хранения и выбора переменных калькулятора. Переменные калькулятора могут быть константами (координаты/векторы, действительные числа и целые числа) или функциями. В области переменных можно выполнить следующее.

  • Щелкните переменную калькулятора для отображения в поле "Подробности" (в нижней части области переменных) такой информации, как значение, тип и описание.
  • Дважды щелкните переменную калькулятора, чтобы загрузить ее поле ввода QuickCalc.

Дополнительные операции можно выполнять с помощью контекстных меню в области переменных.

Создание новых переменных калькулятора

Новые переменные калькулятора можно создавать с помощью контекстных меню в области переменных. При определении новых переменных калькулятора в диалоговом окне "Описание переменной" применяются следующие правила:

  • Константы. Любое выражение, введенное в поле текстового ввода "Значение" или "Выражение", вычисляется до сохранения переменной калькулятора. Переменные калькулятора, определенные в виде констант, доступны “глобально. ” Можно обращаться к глобальным константам и использовать их в разных чертежах и различных сеансах работы.
  • Функции. Любое выражение, введенное в поле текстового ввода "Значение" или "Выражение", сохраняется как текст. Вычисление функций осуществляется при их использовании в поле ввода QuickCalc.
Создание глобальных констант

Для создания глобальных констант воспользуйтесь одним из следующих способов.

  • Введите выражение в поле ввода в следующем формате: $имя_переменной=значение. Например, чтобы определить золотое отношение как 8 знаков после запятой и принять его в качестве глобальной константы Phi, введите в поле ввода $Phi=1.61803399.
  • Нажмите кнопку "Новая переменная" в заголовке области переменных. В диалоговом окне "Описание переменных" щелкните "Константа" и заполните остальные поля.
  • Щелкните правой кнопкой мыши в области переменных. Выберите "Новая переменная".
Доступ к глобальным константам

Пользователь может обратиться к глобальным константам и передать их в поле ввода калькулятора QuickCalc следующим образом:

  • Дважды щелкните переменную в области переменных калькулятора QuickCalc.
  • Щелкните переменную в списке переменных калькулятора и нажмите кнопку "Вернуть переменную в область ввода".
  • Введите знак доллара ($), за которым следует имя переменной, и нажмите клавишу ENTER.

Для использования глобальной константы в поле ввода текстовых или числовых данных, расположенном в окне или диалоговом окне, пользуйтесь следующим синтаксисом: =$имя_переменной с последующим нажатием клавиши END. Например, для использования ранее упомянутой глобальной переменной Phi введите =$Phi и нажмите клавишу END.

Примечание В QuickCalc имена глобальных переменных, которые указываются в полях для ввода текстовых или числовых данных, можно использовать напрямую только для констант.

Использование функций в сокращенном виде

Некоторые типовые переменные калькулятора стали стандартными; они хранятся в категории функций сокращенного вида. Это геометрические выражения, объединяющие функции КАЛЬК с режимом привязки "Конточка". В приведенной ниже таблице описываются стандартные переменные, доступные в области переменных калькулятора.

Параметр | Сокращенная форма | Описание
dee | dist(end,end) | Расстояние между двумя конечными точками
ille | ill(end,end,end) | Пересечение двух линий, проведенных через четыре конечные точки
mee | (end+end)/2 | Середина отрезка, соединяющего две конечные точки
nee | nor(end,end) | Единичный вектор в плоскости XY, перпендикулярный двум конечным точкам
rad | rad | Радиус выбранной окружности, дуги или дуги полилинии
vee | vee(end,end) | Вектор от одной конечной точки к другой
vee1 | vec1(end,end) | Единичный вектор в направлении от одной конечной точки к другой

Можно легко создавать эти переменные калькулятора или создавать собственные. Дополнительную информацию см. в описании команды КАЛК.

Объединение переменных в категории

Систематизировать переменные калькулятора по нескольким категориям можно в области переменных. При этом формируется структура в виде одноярусного дерева. Категория функций сокращенного вида уже создана и содержит несколько функций.

Для создания, переименования или удаления категорий переменных пользуйтесь контекстным меню в области переменных.


Создание и использование переменных калькулятора - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Создание и использование переменных калькулятора
Понятия
Процедуры
Команды

Для использования стандартной переменной в выражении QuickCalc

Для создания новой переменной в QuickCalc

Для редактирования переменной в QuickCalc

Для удаления переменной в QuickCalc

Для создания новой глобальной константы в поле ввода калькулятора QuickCalc

Для обращения к глобальной константе из диалогового окна или обычного окна

Чтобы вычислять математические выражения в диалоговом окне


Для использования стандартной переменной в выражении QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Создание и использование переменных калькулятора
Понятия
Процедуры
Команды

Для использования стандартной переменной в выражении QuickCalc

  1. В области переменных щелкните переменную, которую нужно применить.
  2. В заголовке области переменных калькулятора QuickCalc нажмите кнопку "Вернуть переменную в область ввода".

    3. Переменная отобразится в поле ввода как часть выражения.


Для создания новой переменной в QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Создание и использование переменных калькулятора
Понятия
Процедуры
Команды

Для создания новой переменной в QuickCalc

  1. В заголовке области переменных калькулятора QuickCalc нажмите кнопку "Новая переменная".
  2. В диалоговом окне "Описание переменной" в разделе "Тип переменной" выберите "Константа" или "Функция".
  3. В диалоговом окне "Описание переменной" в разделе имен свойств переменной введите имя переменной. Имена переменных не должны содержать пробелы и специальные символы.

    4. Примечание При обращении к этой переменной из поля ввода необходимо помнить, что имя переменной должно начинаться со знака доллара ($). Этим она отличается от локальных переменных LISP.

  4. В разделе "Свойства переменной - группа" выберите "Создать".
  5. В диалоговом окне "Описание категории" в разделе "Свойства категории - имя" введите имя для новой категории.
  6. В разделе "Описание" введите описание для новой категории. Нажать "ОК".
  7. В диалоговом окне "Описание переменной" в разделе "Значение" или "Выражение" введите значение или выражение для новой переменной.
  8. В разделе "Описание" введите описание новой переменной. Нажать "ОК".

    9. Новая переменная теперь отобразится в области переменных.


Для редактирования переменной в QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Создание и использование переменных калькулятора
Понятия
Процедуры
Команды

Для редактирования переменной в QuickCalc

  1. В области переменных щелкните переменную, которую нужно отредактировать.
  2. В заголовке области переменных калькулятора QuickCalc нажмите кнопку "Изменить переменную".
  3. В диалоговом окне "Описание переменной" внесите изменения в переменную. Нажать "ОК".


Для удаления переменной в QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Создание и использование переменных калькулятора
Понятия
Процедуры
Команды

Для удаления переменной в QuickCalc

  1. В области переменных щелкните переменную, которую нужно удалить.
  2. В заголовке области переменных калькулятора QuickCalc нажмите кнопку "Удалить".


Для создания новой глобальной константы в поле ввода калькулятора QuickCalc - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Создание и использование переменных калькулятора
Понятия
Процедуры
Команды

Для создания новой глобальной константы в поле ввода калькулятора QuickCalc

  • В поле ввода QuickCalc введите данные, используя следующий синтаксис: $имя_переменной=значение.

    • Например, можно ввести $Phi=1.618

    Примечание Глобальные переменные не зависят от регистра.

    QuickCalc добавляет глобальные константы в список переменных в области переменных.


Для обращения к глобальной константе из диалогового окна или обычного окна - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Создание и использование переменных калькулятора
Понятия
Процедуры
Команды

Для обращения к глобальной константе из диалогового окна или обычного окна

  • В любом поле ввода текстовых или числовых данных введите выражение, используя следующий синтаксис: =$имя_переменной с последующим нажатием клавиши END.


Чтобы вычислять математические выражения в диалоговом окне - Процедуры

Создание и редактирование объектов
Средства обеспечения точности
Создание и использование переменных калькулятора
Понятия
Процедуры
Команды

Чтобы вычислять математические выражения в диалоговом окне

Примечание Чтобы вычислять математические выражения в диалоговом окне, для системной переменной CALCINPUT должно быть установлено значение 1.

  1. В области ввода числовых значений диалогового окна введите математическое выражение в следующем формате: =выражение (например, =5+3).
  2. Нажмите клавишу END на клавиатуре.

    3. Выражение вычисляется, а его значение отображается.

    Ввод команды: CALCINPUT


Создание и использование переменных калькулятора - Команды

Средства обеспечения точности
Средства обеспечения точности
Создание и использование переменных калькулятора
Понятия
Процедуры
Команды

Команды
БКЗАКРЫТЬ | Закрытие калькулятора QuickCalc
БЫСТРКАЛЬК | Вызов калькулятора QuickCalc
Системные переменные
CALCINPUT | Управление вычислением математических выражений и глобальных констант в полях для ввода текстовых или числовых данных
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование калькулятора командной строки - Понятия

Создание и редактирование объектов
Средства обеспечения точности
Использование калькулятора командной строки
Понятия
Процедуры
Команды

При вводе выражения в калькуляторе командной строки можно быстро вычислять различные математические выражения и рассчитывать координаты точек.

Для вычисления векторных выражений (объединяющие точки, векторы и числа) и выражений из действительных и целых чисел можно пользоваться командой КАЛЬК, которой запускается утилита 3D калькулятора. Калькулятор поддерживает выполнение стандартных математических операций. Кроме того, калькулятор содержит набор специализированных функций, предназначенных для работы с трехмерными точками, векторами и геометрическими объектами AutoCAD. Команда КАЛЬК обеспечивает:

  • Вычисление вектора между двумя точками, длины вектора, вектора нормали (перпендикуляра к плоскости XY) и точки на прямой
  • Вычисление расстояния, радиуса или угла
  • Задание точки указывающим устройством
  • Задание точки или пересечения, построенных в последний раз
  • Использование объектных привязок в качестве переменных в выражении
  • Преобразование точек из ПСК в МСК и обратно.
  • Выделение компонентов вектора по осям X, Y и Z
  • Поворот точки вокруг оси
Вычисление выражений

При вычислении выражений с помощью команды КАЛЬК используется стандартный порядок выполнения арифметических операций.

Арифметические операции в порядке убывания приоритета
Оператор | Операция
( ) | группирование выражений
^ | возведение в степень
*, / | умножение и деление
+, - | сложение и вычитание
Вычисление координат точек

Команду КАЛЬК можно использовать при любой необходимости вычисления числа или координат точки в рамках команды.

Например, выражение (mid+cen)/2 определяет точку, расположенную точно посредине между серединой отрезка и центром круга.

В следующем примере команда КАЛЬК используется как вспомогательное средство построений. С ее помощью определяется положение центра для новой окружности и задается величина ее радиуса, которая должна равняться одной пятой радиуса имеющейся окружности.

Диалог в командной строке выглядит так:

Команда: круг

Центр круга или [3Т/2Т/ККР (кас, кас, радиус)]: 'кальк

>> Выражение: (mid+cen)/2

>> Выберите объект для привязки MID: Выбрать отрезок в пазу (1)

>> Выберите объект для привязки CEN: Выбрать большую окружность (2)

Диаметр/<Радиус>: 'кальк

>> Выражение: 1/5*rad

>> Выберите круг, дугу или сегмент полилинии для функции RAD: Выбрать большую окружность (3)

Вычисление математических выражений в диалоговом окне

Можно также вводить и оценивать математические выражения в диалоговом окне с использованием следующего формата:=выражение<КОНЕЦ>

Примечание Чтобы вычислять выражения в диалоговом окне, необходимо убедиться, что для системной переменной CALCINPUT установлено значение 1.


Использование калькулятора

Создание и редактирование объектов
Средства обеспечения точности
Использование калькулятора
Понятия
Процедуры
Команды

Нет процедур.


Использование калькулятора командной строки - Команды

Средства обеспечения точности
Средства обеспечения точности
Использование калькулятора командной строки
Понятия
Процедуры
Команды

Команды
КАЛЬК | Вычисление математических и геометрических выражений
Системные переменные
CALCINPUT | Управление вычислением математических выражений и глобальных констант в полях для ввода текстовых или числовых данных
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение геометрических объектов - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Понятия
Процедуры
Команды

Все чертежи состоят из объектов. Как правило, при рисовании объектов точки задаются либо с помощью устройства указания, либо вводом значений координат в командной строке.

Имеется возможность создания различного рода графических объектов от простейших отрезков и кругов до сплайновых кривых и эллипсов. Как правило, при рисовании объектов точки задаются либо с помощью устройства указания, либо вводом значений координат в командной строке.

  • Построение линий
    Линия является базовым объектом AutoCAD и может представлять собой один сегмент или набор соединенных сегментов.
  • Построение криволинейных объектов
    К криволинейным объектам относятся дуги, круги, полилинии, кольца, эллипсы и сплайны.
  • Построение вспомогательных и опорных элементов
    Для выполнения точных построений используются такие временные объекты, как вспомогательные линии и опорные точки.
  • Построение и объединение областей
    Областями называются двумерные замкнутые объекты, которые имеют такие физические свойства, как центры масс. Имеющиеся области можно объединять в одну область и рассчитать ее площадь.
  • Создание облаков для пометок
    Облака для пометок представляют собой полилинии с дуговыми сегментами. Они используются для нанесения различных пояснительных надписей к элементам чертежа на стадии рассмотрения.


Построение геометрических объектов - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Понятия
Процедуры
Команды

Для построения отрезка

Для построения полилинии из линейных сегментов

Для построения полилинии из линейных и дуговых сегментов

Для создания широкой полилинии

Для создания полилинии контура

Для построения описанного многоугольника

Для построения многоугольника с заданной стороной

Для построения вписанного многоугольника

Для построения прямоугольника

Для построения мультилинии

Для создания стиля мультилиний

Для построения эскиза

Стирание эскизных линий

Для построения дуги по трем точкам

Для построения дуги по началу, центру и концу

Для продолжения дуги касательным отрезком

Для продолжения дуги касательной дугой

Для построения круга по центру и радиусу (или диаметру)

Для построения круга, касающегося двух объектов

Для построения полилинии из линейных сегментов

Для построения полилинии из линейных и дуговых сегментов

Для создания широкой полилинии

Для создания полилинии контура

Для построения кольца

Для построения изометрического круга

Для построения эллипса по конечным точкам одной оси и половине длины другой оси

Для построения эллиптической дуги по начальному и конечному углам

Преобразование сглаженных сплайнами полилиний в сплайны

Для построения сплайна путем задания определяющих точек

Для создания спирали

Для задания формы и размера точки

Для создания объекта-точки

Для построения прямой по двум точкам

Для построения луча

Для определения областей

Для создания областей с использованием контуров

Для построения составной области путем объединения

Для построения составной области путем вычитания

Для построения составной области путем пересечения

Создание облака для пометки с нуля

Для создания облака для пометки со стилем "Каллиграфия"

Для преобразования объекта в облако для пометок

Для изменения значений длин дуг по умолчанию для использования в облаках

Для изменения отдельных длин дуг или хорд, образующих облако


Построение геометрических объектов - Команды

Создание и редактирование объектов
Построение геометрических объектов
Понятия
Процедуры
Команды
Команды
3DПЛИНИЯ | Построение полилиний из линейных сегментов в 3D пространстве
ВЫЧИТАНИЕ | Объединение выбранных областей или тел посредством вычитания
ДИАЛТТОЧ | Задание стиля отображения и величины точечных объектов
ДУГА | Построение дуг
КОЛЬЦО | Построение закрашенных кругов и колец
КОНТУР | Создание области или полилинии из замкнутого контура
КРУГ | Построение окружностей
ЛУЧ | Построение линий, бесконечных в одном направлении
МАСС-ХАР | Вычисление массовых характеристик областей и тел
МЛИНИЯ | Создание нескольких параллельных отрезков
МЛСТИЛЬ | Создает, изменяет и управляет стилями мультилиний
МН-УГОЛ | Построение равносторонних многоугольников в виде замкнутых полилиний
НАСТРВИД | Задание точности аппроксимации объектов на текущем видовом экране
ОБЛАКО | Создание полилиний с дуговыми сегментами, используемых в качестве облаков для пометок
ОБЛАСТЬ | Преобразование объектов, ограничивающих некоторую площадь, в области
ОБЪЕДИНЕНИЕ | Объединение выбранных областей или тел посредством сложения
ОТРЕЗОК | Построение отрезков
ПЕРЕСЕЧЕНИЕ | Создает составные тела или области путем пересечения двух или более тел или областей и удаляет области снаружи пересечения.
ПЛИНИЯ | Построение двумерных полилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
ПРЯМАЯ | Построение бесконечных прямых
ПРЯМОУГ | Построение полилинии в виде прямоугольника
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
РЕДСПЛАЙН | Редактирование сплайнов или сглаженных сплайнами полилиний
СПИРАЛЬ | Создание 2D или 3D винтовой линии
СПЛАЙН | Создает гладкую кривую, проходящую вблизи (в пределах заданной погрешности) некоторого набора точек.
ТОЧКА | Создание объектов-точек
ЭЛЛИПС | Построение эллипсов и эллиптических дуг
ЭСКИЗ | Рисование коротких смежных сегментов от руки
Системные переменные
ANGDIR | Задание направления для положительных углов.
CIRCLERAD | Радиус круга по умолчанию. Нуль указывает на отсутствие значения по умолчанию
CMLSTYLE | Установка многострочного стиля, который управляет отображением многострочного текста
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
DIMSCALE | Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения
DONUTID | Устанавливает внутренний диаметр кольца по умолчанию
DONUTOD | Устанавливает внешний диаметр кольца по умолчанию
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
LASTANGLE | Сохраняет конечный угол последней введенной дуги в плоскости XY текущей ПСК в текущем пространстве
PDMODE | Управляет отображением точечных объектов
PDSIZE | Устанавливает размер отображения точечных объектов
PELLIPSE | Определяет тип эллипса, созданного с помощью команды ЭЛЛИПС
PLINEGEN | Управляет созданием типа линии вокруг вершин двухмерных полилиний
PLINETYPE | Указывает, используется ли оптимизированные двухмерные полилинии
PLINEWID | Хранит значение ширины полилинии по умолчанию
POLYSIDES | Задает число сторон по умолчанию для команды МН-УГОЛ
SKETCHINC | Устанавливает приращение для команды ЭСКИЗ
SKPOLY | Задает тип объектов (линии или полилинии), генерируемых командой ЭСКИЗ
WHIPARC | Управляет сглаживанием кругов и дуг на экране
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение линий - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение линий
Понятия
Процедуры
Команды

Линия является базовым объектом AutoCAD и может представлять собой один сегмент или набор соединенных сегментов.

  • Построение отрезков
    Отрезки могут быть одиночными или выглядеть как ломаная линия (несмотря на то, что сегменты соприкасаются в конечных точках, каждый из них представляет собой отдельный объект).
  • Построение полилиний
    Полилиния представляет собой связанную последовательность сегментов; все эти сегменты являются единым объектом. Полилинии могут состоять из линейных и дуговых сегментов, а также из любых их сочетаний.
  • Построение прямоугольников и многоугольников
    Можно быстро создавать прямоугольники и правильные многоугольники. Частным случаем равносторонних многоугольников являются равносторонние треугольники, квадраты, пятиугольники, шестиугольники и т.д.
  • Построение объектов мультилиний
    Мультилинии состоят из параллельных линий (от 1 до 16), называемых элементами.
  • Построение эскизов
    Эскизное рисование используется при построении линий неправильной формы и при оцифровке бумажных оригиналов с помощью дигитайзера.


Построение линий - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение линий
Понятия
Процедуры
Команды

Для построения отрезка

Для построения полилинии из линейных сегментов

Для построения полилинии из линейных и дуговых сегментов

Для создания широкой полилинии

Для создания полилинии контура

Для построения описанного многоугольника

Для построения многоугольника с заданной стороной

Для построения вписанного многоугольника

Для построения прямоугольника

Для построения мультилинии

Для создания стиля мультилиний

Для построения эскиза

Стирание эскизных линий


Построение линий - Команды

Создание и редактирование объектов
Построение геометрических объектов
Построение линий
Понятия
Процедуры
Команды
Команды
3DПЛИНИЯ | Построение полилиний из линейных сегментов в 3D пространстве
КОНТУР | Создание области или полилинии из замкнутого контура
ЛУЧ | Построение линий, бесконечных в одном направлении
МЛИНИЯ | Создание нескольких параллельных отрезков
МЛСТИЛЬ | Создает, изменяет и управляет стилями мультилиний
МН-УГОЛ | Построение равносторонних многоугольников в виде замкнутых полилиний
ОТРЕЗОК | Построение отрезков
ПЛИНИЯ | Построение двумерных полилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
ПРЯМАЯ | Построение бесконечных прямых
ПРЯМОУГ | Построение полилинии в виде прямоугольника
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
ЭСКИЗ | Рисование коротких смежных сегментов от руки
Системные переменные
CMLSTYLE | Установка многострочного стиля, который управляет отображением многострочного текста
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
PLINEGEN | Управляет созданием типа линии вокруг вершин двухмерных полилиний
PLINETYPE | Указывает, используется ли оптимизированные двухмерные полилинии
PLINEWID | Хранит значение ширины полилинии по умолчанию
POLYSIDES | Задает число сторон по умолчанию для команды МН-УГОЛ
SKETCHINC | Устанавливает приращение для команды ЭСКИЗ
SKPOLY | Задает тип объектов (линии или полилинии), генерируемых командой ЭСКИЗ
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение отрезков - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение отрезков
Понятия
Процедуры
Команды

Отрезки могут быть одиночными или выглядеть как ломаная линия (несмотря на то, что сегменты соприкасаются в конечных точках, каждый из них представляет собой отдельный объект).

Создание набора сегментов с типом линий CONTINUOUS осуществляется командой ЛИНИЯ.

Каждый линейный сегмент из набора сегментов может редактироваться отдельно. Последовательность сегментов может быть замкнутой, т.е. конец последнего сегмента может совпадать с началом первого.

Отрезкам можно назначать такие свойства, как цвет, тип и вес линий. Подробнее о свойствах см. раздел Свойства объектов.

Построение выполняется точным указанием конечных точек каждого отрезка. Пользователь может:

  • Вводить значения координат конечной точки с использованием либо абсолютных, либо относительных координат
  • Задать объектную привязку относительно имеющегося объекта. Например, в качестве одной конечной точки отрезка можно задать центр окружности
  • Использовать шаговую привязку

Также существуют и другие методы построения точных отрезков. Очень эффективным способом является создание подобного отрезка с его последующим удлинением или обрезкой до нужной длины.

Если необходимо, чтобы линейные сегменты были связаны между собой, как единый объект, следует использовать полилинии вместо отрезков.

См. также

Координаты и системы координат (ПСК)

Использование объектной привязки

Настройка сетки и шаговой привязки

Построение полилиний

Создание подобных объектов

Разрыв и соединение объектов


Для построения отрезка - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение отрезков
Понятия
Процедуры
Команды

Для построения отрезка

  1. Выберите в меню "Рисование" » "Отрезок".
  2. Укажите начальную точку.

    3. Положение точек задается либо щелчком устройства указания, либо набором координат на клавиатуре.

  3. Укажите конечную точку первого сегмента.

    4. Чтобы стереть последний сегмент, построенный в ходе выполнения команды ОТРЕЗОК, следует ввести о или выбрать "Отменить" на панели инструментов.

  4. Укажите конечные точки последующих сегментов.
  5. Нажмите ENTER, чтобы завершить построение, или з, чтобы замкнуть последовательность линейных сегментов.

    6. Чтобы провести новый отрезок из конечной точки последнего построенного отрезка, вызовите команду ОТРЕЗОК и нажмите ENTER в ответ на запрос "Начальная точка".

Панель "Рисование"

Ввод команды: ОТРЕЗОК


Построение отрезков - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение отрезков
Понятия
Процедуры
Команды

Команды
ЛУЧ | Построение линий, бесконечных в одном направлении
ОТРЕЗОК | Построение отрезков
ПРЯМАЯ | Построение бесконечных прямых
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение полилиний - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение полилиний
Понятия
Процедуры
Команды

Полилиния представляет собой связанную последовательность сегментов; все эти сегменты являются единым объектом. Полилинии могут состоять из линейных и дуговых сегментов, а также из любых их сочетаний.

Полилинии используются, если предполагается работа с набором сегментов как с целым. У полилиний можно изменять ширину и кривизну сегментов. Имеющиеся на чертеже полилинии можно отредактировать командой ПОЛРЕД, а также преобразовать в отдельные линейные и дуговые сегменты с помощью команды РАСЧЛЕНИТЬ. Пользователь может:

  • Преобразовывать сглаженные сплайнами полилинии в сплайны командой СПЛАЙН
  • Создавать многоугольники с помощью замкнутых полилиний
  • Создавать полилинии из контуров перекрывающихся объектов
Создание дуговых полилиний

Полилинии могут иметь дуговые сегменты. Каждый из таких сегментов строится из конечной точки предыдущего сегмента. Дуги описываются заданием угла, центра, направления или радиуса. Кроме того, дугу можно построить указанием второй и конечной точек.

Создание замкнутых полилиний

Имеется возможность построения замкнутой полилинии для создания многоугольника. Для замыкания полилинии нужно указать начальную точку последней построенной стороны объекта, ввести з (Замкнуть) и нажать ENTER.

Создание широких полилиний

Создаваемые полилинии могут иметь различную ширину, которая устанавливается опциями "Ширина" и "Полуширина". Для каждого сегмента можно задать свое значение ширины; кроме того, сегменты могут сужаться или расширяться, если значения ширины в начальной и конечной точках различны. Эти опции доступны после указания начальной точки при построении полилинии.

Опциями "Ширина" и "Полуширина" задается ширина следующего создаваемого сегмента полилинии. При указании значения 0 строится тонкий сегмент с нулевой шириной. Любые ненулевые положительные значения ширины приводят к созданию широких линий, которые отображаются закрашенными или в виде контуров, в зависимости от состояния режима закраски. Опцией "Полуширина" можно задавать расстояние от осевой линии широкой полилинии до ее края.

Конус

При использовании опции "Ширина" предоставляется возможность задания ширины сегмента как в начальной точке, так и в конечной. В этом случае ввод разных значений позволяет строить сужающиеся полилинии. Начальные и конечные точки широких сегментов полилинии располагаются на центральных осевых линиях сегментов. Места пересечений смежных широких сегментов полилинии обычно подрезаются. Однако, этого не происходит в случае некасательных дуговых сегментов, очень острых углов пересечения или при использовании прерывистого типа линий.

Создание полилиний из контуров перекрывающихся объектов

Из контура, полученного в результате взаимного перекрытия объектов и образующего замкнутую область, можно создать полилинию. Полилиния, построенная таким образом, является отдельным объектом и не связана с объектами, определяющими контур построения. С такой полилинией можно выполнять те же действия, что и с другими полилиниями.

При работе с большими и сложными чертежами процесс задания контуров можно упростить, сгруппировав контуры в наборы. Набор создается путем выбора объектов, которые должны определять окончательный контур.

См. также

Построение прямоугольников и многоугольников

Редактирование сложных объектов

Разрыв и соединение объектов

Работа с весами линий


Построение полилиний - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение полилиний
Понятия
Процедуры
Команды

Для построения полилинии из линейных сегментов

Для построения полилинии из линейных и дуговых сегментов

Для создания широкой полилинии

Для создания полилинии контура


Для построения полилинии из линейных сегментов - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение полилиний
Понятия
Процедуры
Команды

Для построения полилинии из линейных сегментов

  1. Выберите в меню "Рисование" » "Полилиния".
  2. Укажите начальную точку полилинии.
  3. Укажите конечную точку первого сегмента полилинии.
  4. Продолжать указание конечных точек для последующих сегментов.
  5. Для завершения построения нажмите ENTER или введите з, если нужно замкнуть полилинию.

    6. Чтобы провести новую полилинию из конечной точки последней построенной полилинии, нужно снова вызвать команду ПЛИНИЯ и нажать ENTER в ответ на запрос "Начальная точка".

Панель "Рисование"

Ввод команды: ПЛИНИЯ


Для построения полилинии из линейных и дуговых сегментов - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение полилиний
Понятия
Процедуры
Команды

Для построения полилинии из линейных и дуговых сегментов

  1. Выберите в меню "Рисование" » "Полилиния".
  2. Укажите начальную точку сегмента полилинии.
  3. Укажите конечную точку сегмента.
    • Для включения режима отрисовки дуг введите д (Дуга).
    • Для возврата в режим построения линейных сегментов введите л (Линейный).
  4. При необходимости построить последующие сегменты полилинии.
  5. Для завершения построения нажмите ENTER или введите з, если нужно замкнуть полилинию.

Панель "Рисование"

Ввод команды: ПЛИНИЯ


Для создания широкой полилинии - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение полилиний
Понятия
Процедуры
Команды

Для создания широкой полилинии

  1. Выберите в меню "Рисование" » "Полилиния".
  2. Укажите начальную точку линейного сегмента.
  3. Введите ш (Ширина).
  4. Введите значение ширины в начале линейного сегмента.
  5. Задайте ширину в конце сегмента одним из следующих методов:
    • Чтобы построить линейный сегмент с постоянной шириной, нажмите ENTER.
    • Для построения сужающегося или расширяющегося линейного сегмента введите другое значение ширины.
  6. Укажите конечную точку сегмента.
  7. Продолжайте указание конечных точек для последующих сегментов.
  8. Для завершения построения нажмите ENTER или введите з, если нужно замкнуть полилинию.

Панель "Рисование"

Ввод команды: ПЛИНИЯ


Для создания полилинии контура - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение полилиний
Понятия
Процедуры
Команды

Для создания полилинии контура

  1. Выберите в меню "Рисование" » "Контур".
  2. В списке "Тип объекта" диалогового окна "Создание контура" выберите "Полилиния".
  3. В группе "Набор контуров" выполние одно из следующих действий:
    • Для создания набора контуров с учетом всех объектов, видимых на текущем видовом экране, выберите опцию "Текущий видовой экран". Эту опцию не следует использовать при работе с большими и сложными чертежами.
    • Для ручного выбора объектов, которые должны учитываться при создании набора контуров, нажмите "Новый". Выберите объекты, определяющие контур. При использовании этого параметра автоматически включается параметр "Имеющийся набор".
  4. Нажмите кнопку "Указание точек".
  5. Укажите точки внутри каждой области, которые должны определять контур для построения полилинии.

    6. Задаваемая область должна быть замкнутой, то есть между объектами, определяющими эту область, не должно быть промежутков. Имеется возможность выбора нескольких областей. Чтобы включить внутренние замкнутые области в набор контуров, нужно щелкнуть "Обнаружение островков".

  6. Для создания контур-полилинии и завершения команды нажмите ENTER.

    7. Создается полилиния, повторяющая форму заданного контура. Объекты, участвующие в построении полилинии, могут стать невидимыми в результате перекрытия новой полилинией. Построенную полилинию контура можно перемещать, копировать и редактировать точно так же, как и другие полилинии.

Ввод команды: КОНТУР


Построение полилиний - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение полилиний
Понятия
Процедуры
Команды

Команды
3DПЛИНИЯ | Построение полилиний из линейных сегментов в 3D пространстве
КОНТУР | Создание области или полилинии из замкнутого контура
ПЛИНИЯ | Построение двумерных полилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
PLINEGEN | Управляет созданием типа линии вокруг вершин двухмерных полилиний
PLINETYPE | Указывает, используется ли оптимизированные двухмерные полилинии
PLINEWID | Хранит значение ширины полилинии по умолчанию
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение прямоугольников и многоугольников - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение прямоугольников и многоугольников
Понятия
Процедуры
Команды

Можно быстро создавать прямоугольники и правильные многоугольники. Частным случаем равносторонних многоугольников являются равносторонние треугольники, квадраты, пятиугольники, шестиугольники и т.д.

С помощью двух команд, ПРЯМОУГ и МН-УГОЛ, можно эффективно создавать прямоугольники и правильные многоугольники, такие как равносторонние треугольники, квадраты, пятиугольники, шестиугольники т.д. Если необходимо, с помощью команды РАСЧЛЕНИТЬ можно преобразовать получившийся полилинейный объект в отрезки.

Построение прямоугольников

С помощью команды ПРЯМОУГ можно создать замкнутые полилинии в форме прямоугольника. Можно задать длину, ширину, область и параметры вращения. Можно также выбирать тип углов прямоугольника—скругление, фаски или квадрат.

Построение правильных многоугольников

С помощью команды МН-УГОЛ можно создавать замкнутые полилинии с числом сторон равной длины от 3 до 1024. На следующих иллюстрациях представлены три метода создания многоугольников. В каждом случае задаются две точки.

См. также

Построение полилиний


Построение прямоугольников и многоугольников - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение прямоугольников и многоугольников
Понятия
Процедуры
Команды

Для построения описанного многоугольника

Для построения многоугольника с заданной стороной

Для построения вписанного многоугольника

Для построения прямоугольника


Для построения описанного многоугольника - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение прямоугольников и многоугольников
Понятия
Процедуры
Команды

Для построения описанного многоугольника

  1. Выберите в меню "Рисование" » "Многоугольник".
  2. В командной строке введите число сторон.
  3. Укажите центр многоугольника (1).
  4. Введите о (Описанный) для включения режима построения описанного многоугольника.
  5. Задайте радиус (2).

Панель "Рисование"

Ввод команды: МН-УГОЛ


Для построения многоугольника с заданной стороной - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение прямоугольников и многоугольников
Понятия
Процедуры
Команды

Для построения многоугольника с заданной стороной

  1. Выберите в меню "Рисование" » "Многоугольник".
  2. В командной строке введите число сторон.
  3. Введите к (Кромка).
  4. Укажите начальную точку одной стороны многоугольника.
  5. Укажите конечную точку этой же стороны.

Панель "Рисование"

Ввод команды: МН-УГОЛ


Для построения вписанного многоугольника - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение прямоугольников и многоугольников
Понятия
Процедуры
Команды

Для построения вписанного многоугольника

  1. Выберите в меню "Рисование" » "Многоугольник".
  2. В командной строке введите число сторон.
  3. Укажите центр многоугольника.
  4. Введите в (Вписанный) для входа в режим построения многоугольника, вписанного в круг с заданным центром.
  5. Задайте радиус.

Панель "Рисование"

Ввод команды: МН-УГОЛ


Для построения прямоугольника - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение прямоугольников и многоугольников
Понятия
Процедуры
Команды

Для построения прямоугольника

  1. Выберите в меню "Рисование" » "Прямоугольник".
  2. Укажите первый угол прямоугольника.
  3. Укажите второй угол прямоугольника.

Панель "Рисование"

Ввод команды: ПРЯМОУГ


Построение прямоугольников и многоугольников - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение прямоугольников и многоугольников
Понятия
Процедуры
Команды

Команды
КОНТУР | Создание области или полилинии из замкнутого контура
МН-УГОЛ | Построение равносторонних многоугольников в виде замкнутых полилиний
ПРЯМОУГ | Построение полилинии в виде прямоугольника
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
PLINEWID | Хранит значение ширины полилинии по умолчанию
POLYSIDES | Задает число сторон по умолчанию для команды МН-УГОЛ
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение объектов мультилиний - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение объектов мультилиний
Понятия
Процедуры
Команды

Мультилинии состоят из параллельных линий (от 1 до 16), называемых элементами.

При построении мультилинии можно использовать стиль СТАНДАРТ, в котором есть два элемента, или присвоить стиль, созданный ранее. Перед началом рисования можно задать режим расположения и масштаб мультилинии.

Тип расположения мультилинии определяет, с какой стороны от курсора будет нарисована мультилиния, или она будет расположена по центру.

Значение масштаба мультилинии определяет общую ширину мультилинии в текущих единицах. Масштаб мультилинии не связан с масштабом типа линий. Чтобы не допустить непропорционального изменения размеров точек и штрихов при изменении масштаба мультилинии, необходимо внести соответствующие изменения в масштаб типа линий.

Создание стилей мультилиний

Имеется возможность создавать именованные стили мультилиний, определяющие количество элементов и свойства каждого из них. Свойства мультилиний.

  • Общее число элементов и положение каждого элемента
  • Расстояние смещения от оси мультилинии для каждого элемента
  • Цвет и тип линии каждого элемента
  • Символы видимости отрезков, именуемые стыками, на каждой вершине
  • Используемый тип торцевых ограничителей
  • Цвет закраски фона мультилинии

В стиле мультилиний может быть описано до 16 элементов. Элементы с положительным смещением располагаются по одну сторону от оси мультилинии, элементы с отрицательным смещением - по другую сторону.

См. также

Редактирование мультилиний


Построение объектов мультилиний - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение объектов мультилиний
Понятия
Процедуры
Команды

Для построения мультилинии

Для создания стиля мультилиний


Для построения мультилинии - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение объектов мультилиний
Понятия
Процедуры
Команды

Для построения мультилинии

  1. Выберите в меню "Рисование" » "Мультилиния".
  2. Для выбора стиля введите с в командной строке.
  3. Введите ? для получения списка доступных стилей.
  4. Чтобы определить расположение мультилинии, нужно ввести р и выбрать один из следующих вариантов: верх, центр или низ.
  5. Для изменения масштаба мультилинии введите м и задать новый масштаб.

    6. Теперь можно переходить непосредственно к построению мультилинии.

  6. Укажите начальную точку.
  7. Укажите вторую точку.
  8. Задайте дополнительные точки или нажмите ENTER. Если указано три или более точек, то чтобы замкнуть мультилинию можно ввести з.

Ввод команды: МЛИНИЯ


Для создания стиля мультилиний - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение объектов мультилиний
Понятия
Процедуры
Команды

Для создания стиля мультилиний

  1. Выберите в меню "Формат" » "Стиль мультилиний".
  2. В диалоговом окне "Стиль мультилиний" выберите "Новый".
  3. В диалоговом окне "Создать новый стиль мультилинии" введите имя стиля мультилинии и выберите стиль для начала рисования. Нажмите кнопку "Продолжить".
  4. В диалоговом окне "Новый стиль мультилинии" выберите параметры стиля мультилинии. Можно также ввести описание.

    5. Пояснение не является обязательной характеристикой стиля мультилиний. Его длина не должна превышать 255 символов, включая пробелы.

  5. Нажать "ОК".
  6. В диалоговом окне "Стиль мультилинии", нажмите кнопку "Сохранить", чтобы сохранить стиль мультилинии в файл (по умолчанию имя файла acad.mln). В одном файле можно сохранять несколько стилей мультилиний.

    7. Перед созданием нового стиля мультилинии следует сохранить текущий стиль. В противном случае все изменения в текущем стиле будут потеряны.


Построение объектов мультилиний - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение объектов мультилиний
Понятия
Процедуры
Команды

Команды
МЛИНИЯ | Создание нескольких параллельных отрезков
МЛСТИЛЬ | Создает, изменяет и управляет стилями мультилиний
Системные переменные
CMLSTYLE | Установка многострочного стиля, который управляет отображением многострочного текста
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение эскизов - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение эскизов
Понятия
Процедуры
Команды

Эскизное рисование используется при построении линий неправильной формы и при оцифровке бумажных оригиналов с помощью дигитайзера.

Для рисования эскизов существует команда ЭСКИЗ. Эскизное рисование используется при построении линий неправильной формы и при оцифровке бумажных оригиналов с помощью дигитайзера.

Создание эскизов

При построении эскизов используйте устройство указания как перо. Нажмите кнопку, чтобы опустить перо и чертить на экране; нажмите кнопку еще раз, чтобы поднять перо и прекратить черчение. Эскизы состоят из множества прямолинейных сегментов. Каждый из сегментов может представлять собой либо отдельный объект, либо сегмент полилинии. Минимальная длина, или приращение, сегментов задается пользователем. При этом малая длина сегментов обеспечивает точность построений, но при этом значительно увеличивается размер файла чертежа. Поэтому данное средство следует применять только в случае крайней необходимости.

Перед построением эскиза следует убедиться, что системная переменная CELTYPE задает тип линии ПОСЛОЮ. Если используется тип линий, состоящий из точек или штрихов, а длина некоторых элементов образца (штрихов или промежутков) превышает величину приращения, то образец типа линий будет рисоваться не полностью.

Стирание эскизных линий

Стирание эскизных линий производится с помощью опции "Стереть" команды ЭСКИЗ. При этом стирается участок эскизной линии от выбранной точки до конца линии.

Сохраненные эскизные линии нельзя ни редактировать, ни стирать опцией "Стереть" команды ЭСКИЗ. По завершении эскизного рисования воспользуйтесь командой СТЕРЕТЬ.

Создание эскиза в режиме "Планшет"

Режим "Планшет" используется при работе с дигитайзером. Эскизное рисование в режиме "Планшет" используется, например, для копирования контуров карт с бумажного оригинала непосредственно на чертеж. Во время построения эскиза невозможно отключить режим "Планшет".

При включенном режиме "Планшет" можно настроить программу таким образом, что координаты чертежа на бумаге будут отображаться в программе в соответствии с Мировой системой координат. Таким образом устанавливается прямая связь между координатами перекрестья курсора на экране, координатами на планшете и координатами исходного чертежа. После того как соотнесение координат чертежа на бумаге настроено, может обнаружиться, что область, отображаемая на экране, не является требуемой областью. Во избежание этого перед входом в режим эскизного рисования нужно с помощью команды ПОКАЗАТЬ добиться показа на экране всей рабочей области.

Некоторые дигитайзеры не позволяют работать с меню при включенном режиме "Планшет". Подробнее см. документацию по используемому дигитайзеру.

Обеспечение точности эскизного рисования

Чтобы добиться достаточной точности рисования на медленном компьютере, следует устанавливать отрицательное значение приращения. Команда ЭСКИЗ использует это значение, как если бы оно было положительным, но при этом проверяет, чтобы расстояние между двумя последними полученными с устройства указания точками не превышало удвоенную величину приращения. Если расстояние превышает удвоенное приращение, выдается звуковой сигнал, означающий, что следует замедлить движение устройства указания; иначе точность рисования будет снижена. Например, если приращение равно -1, то расстояние между двумя последовательными точками не должно превышать 2 единиц. Использование данного метода не снижает скорость обхода контура при копировании.


Построение эскизов - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение эскизов
Понятия
Процедуры
Команды

Для построения эскиза

Стирание эскизных линий


Для построения эскиза - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение эскизов
Понятия
Процедуры
Команды

Для построения эскиза

  1. В командной строке введите эскиз.
  2. В ответ на запрос "Приращение:" введите минимальную длину линейного сегмента.
  3. Нажмите кнопку мыши, чтобы опустить “перо”.

    4. При перемещении устройства указания, программа рисует сегменты временных эскизных линий, указанной пользователем длины. Для команды ЭСКИЗ невозможно ввести координаты с клавиатуры. В ходе выполнения команды эскизные линии выделяются цветом.

  4. Для поднятия пера вновь нажмите кнопку мыши, чтобы поднять “перо”. После этого при перемещении курсора по экрану линия не строится. Нажмите кнопку мыши для задания новой начальной точки и продолжайте черчение.
  5. В любой момент можно ввести з, чтобы записать (сохранить) построенный эскиз в базу данных.

    6. Если перо опущено, то после записи можно продолжать черчение. Если перо поднято, для продолжения черчения требуется щелкнуть мышью. Новая линия строится из точки, в которой находится курсор.

  6. Для завершения эскиза и сохранения всех не сохраненных линий нажмите ENTER.


Стирание эскизных линий - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение эскизов
Понятия
Процедуры
Команды

Стирание эскизных линий

  1. Независимо от того, поднято перо или опущено, выполняя команду ЭСКИЗ, введите с (Стереть).

    2. Если перо было опущено, оно поднимается.

  2. Переместите курсор к конечной точке последней нарисованной линии; затем переместите его вдоль линии к точке, от которой необходимо стереть участок эскизной линии.
  3. Для возврата к обычной командной строке команды ЭСКИЗ введите п. Для отказа от стирания введите х.

    4. Для изменения текущего видового экрана в ходе эскизного рисования необходимо выполнение следующих условий: перо поднято, все эскизные линии сохранены, режим "Планшет" отключен.


Построение эскизов - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение эскизов
Понятия
Процедуры
Команды

Команды
ЭСКИЗ | Рисование коротких смежных сегментов от руки
Системные переменные
SKETCHINC | Устанавливает приращение для команды ЭСКИЗ
SKPOLY | Задает тип объектов (линии или полилинии), генерируемых командой ЭСКИЗ
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение криволинейных объектов - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение криволинейных объектов
Понятия
Процедуры
Команды

К криволинейным объектам относятся дуги, круги, полилинии, кольца, эллипсы и сплайны.

  • Построение дуг
    Дуги можно строить различными способами с использованием различных сочетаний таких параметров, как центральная, начальная и конечная точки, радиус, центральный угол, длина и направление хорды.
  • Построение кругов
    Для построения кругов используются различные сочетания таких параметров, как положение центра, радиус, диаметр, положение точек окружности и других объектов.
  • Построение дуг полилиний
    Полилиния представляет собой связанную последовательность сегментов; все эти сегменты являются единым объектом. Полилинии могут состоять из линейных и дуговых сегментов, а также из любых их сочетаний.
  • Построение колец
    Кольца представляют собой заполненные круги или замкнутые широкие полилинии круглой формы.
  • Построение эллипсов
    Построение эллипсов производится путем задания двух осей. Длинная ось эллипса называется его большой осью, короткая - малой осью.
  • Построение сплайнов
    Сплайн представляет собой гладкую кривую, проходящую через заданный набор точек или рядом с ними. Пользователь может задавать точность прохождения кривой через определяющие точки.
  • Построение спиралей
    Спираль представляет собой открытую 2D или 3D переходную кривую.


Построение криволинейных объектов - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение криволинейных объектов
Понятия
Процедуры
Команды

Для построения дуги по трем точкам

Для построения дуги по началу, центру и концу

Для продолжения дуги касательным отрезком

Для продолжения дуги касательной дугой

Для построения круга по центру и радиусу (или диаметру)

Для построения круга, касающегося двух объектов

Для построения полилинии из линейных сегментов

Для построения полилинии из линейных и дуговых сегментов

Для создания широкой полилинии

Для создания полилинии контура

Для построения кольца

Для построения изометрического круга

Для построения эллипса по конечным точкам одной оси и половине длины другой оси

Для построения эллиптической дуги по начальному и конечному углам

Преобразование сглаженных сплайнами полилиний в сплайны

Для построения сплайна путем задания определяющих точек

Для создания спирали


Построение криволинейных объектов - Команды

Создание и редактирование объектов
Построение геометрических объектов
Построение криволинейных объектов
Понятия
Процедуры
Команды
Команды
3DПЛИНИЯ | Построение полилиний из линейных сегментов в 3D пространстве
ДУГА | Построение дуг
КОЛЬЦО | Построение закрашенных кругов и колец
КОНТУР | Создание области или полилинии из замкнутого контура
КРУГ | Построение окружностей
НАСТРВИД | Задание точности аппроксимации объектов на текущем видовом экране
ОТРЕЗОК | Построение отрезков
ПЛИНИЯ | Построение двумерных полилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
РЕДСПЛАЙН | Редактирование сплайнов или сглаженных сплайнами полилиний
СПИРАЛЬ | Создание 2D или 3D винтовой линии
СПЛАЙН | Создает гладкую кривую, проходящую вблизи (в пределах заданной погрешности) некоторого набора точек.
ЭЛЛИПС | Построение эллипсов и эллиптических дуг
Системные переменные
ANGDIR | Задание направления для положительных углов.
CIRCLERAD | Радиус круга по умолчанию. Нуль указывает на отсутствие значения по умолчанию
DONUTID | Устанавливает внутренний диаметр кольца по умолчанию
DONUTOD | Устанавливает внешний диаметр кольца по умолчанию
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
LASTANGLE | Сохраняет конечный угол последней введенной дуги в плоскости XY текущей ПСК в текущем пространстве
PELLIPSE | Определяет тип эллипса, созданного с помощью команды ЭЛЛИПС
PLINEGEN | Управляет созданием типа линии вокруг вершин двухмерных полилиний
PLINETYPE | Указывает, используется ли оптимизированные двухмерные полилинии
PLINEWID | Хранит значение ширины полилинии по умолчанию
WHIPARC | Управляет сглаживанием кругов и дуг на экране
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение дуг - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение дуг
Понятия
Процедуры
Команды

Дуги можно строить различными способами. Обычно дуги создаются в направлении против хода часовой стрелки (кроме первого рассматриваемого ниже метода).

Построение дуг по трем точкам

Имеется возможность построения дуги путем задания трех точек. В следующем примере начальная точка дуги совпадает с конечной точкой отрезка. Вторая точка дуги привязана к средней окружности.

Построение дуги по началу, центру и концу

Если известны начальная, центральная и конечная точки, то построение дуги можно начать с указания как начальной, так и центральной точки. Центральная точка совпадает с центром окружности, частью которой является создаваемая дуга.

Построение дуги по началу, центру и углу

Если известны начальная точка, центр дуги и центральный угол, то можно воспользоваться опцией "Начало, центр, угол" или "Центр, начало, угол".

Положение конечной точки определяется центральным углом. Если же известны начало и конец, но неизвестен центр дуги, следует воспользоваться методом "Начало, конец, угол".

Построение дуги по началу, центру и длине хорды

Если известны начальная точка, центр дуги и длина хорды, то можно воспользоваться методом "Начало, центр, длина" или "Центр, начало, длина".

Длина хорды определяет центральный угол дуги.

Построение дуги по началу, концу и направлению/радиусу

Если известны начальная и конечная точки, то можно воспользоваться методом "Начало, конец, направление" или "Начало, конец, радиус".

На чертеже слева показана дуга, построенная путем указания начальной точки, конечной точки и радиуса. Радиус задается с клавиатуры или путем перемещения курсора в требуемом направлении с последующим вводом точного значения расстояния.

На чертеже справа изображена дуга, построенная с помощью устройства указания путем задания начальной и конечной точек и направления касательной. Если курсор перемещается вверх от начальной и конечной точек, то строится вогнутая дуга, как показано в данном случае. При перемещении курсора вниз строится выпуклая дуга.

Построение смежных дуг и отрезков

Сразу после завершения построения дуги можно приступить к созданию касательной к дуге в ее конечной точке, вызвав команду ОТРЕЗОК и нажав ENTER в ответ на запрос "Начальная точка". От пользователя в данном случае требуется только задать его длину.

Аналогично, после построения отрезка можно приступить к построению дуги, касательной к отрезку в его конечной точке, для чего нужно вызвать команду ДУГА и нажать ENTER в ответ на запрос "Начальная точка". От пользователя в данном случае требуется только задать конечную точку дуги.

Подобным образом можно строить последовательности дуг, соединенных между собой. Для этого из меню "Рисование" следует выбрать "Дуга", затем выбрать "Продолжить". В данном случае смежные дуги имеют общую касательную в точке соединения. Последующие касательные дуги можно строить с помощью пункта "Продолжить" контекстного меню.

См. также

Построение полилиний

Разрыв и соединение объектов


Построение дуг - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение дуг
Понятия
Процедуры
Команды

Для построения дуги по трем точкам

Для построения дуги по началу, центру и концу

Для продолжения дуги касательным отрезком

Для продолжения дуги касательной дугой


Для построения дуги по трем точкам - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение дуг
Понятия
Процедуры
Команды

Для построения дуги по трем точкам

  1. Выберите в меню "Рисование" » "Дуга" » "3 точки".
  2. Укажите начальную точку.
  3. Укажите промежуточную точку дуги.
  4. Укажите конечную точку.

Панель "Рисование"

Ввод команды: ДУГА


Для построения дуги по началу, центру и концу - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение дуг
Понятия
Процедуры
Команды

Для построения дуги по началу, центру и концу

  1. Выберите в меню "Рисование" » "Дуга" » "Начало, центр, конец".
  2. Укажите начальную точку.
  3. Укажите точку центра.
  4. Укажите конечную точку.

Панель "Рисование"

Ввод команды: ДУГА


Для продолжения дуги касательным отрезком - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение дуг
Понятия
Процедуры
Команды

Для продолжения дуги касательным отрезком

  1. Завершите построение дуги.
  2. Выберите в меню "Рисование" » "Отрезок".
  3. Нажмите ENTER на запрос указания первой точки.
  4. Ввести длину отрезка и нажмите ENTER.

Панель "Рисование"

Ввод команды: ОТРЕЗОК


Для продолжения дуги касательной дугой - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение дуг
Понятия
Процедуры
Команды

Для продолжения дуги касательной дугой

  1. Завершить построение дуги.
  2. Выберите в меню "Рисование" » "Дуга" » "Продолжить".
  3. Укажите конец касательной дуги.

Панель "Рисование"

Ввод команды: ДУГА


Построение дуг - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение дуг
Понятия
Процедуры
Команды

Команды
ДУГА | Построение дуг
НАСТРВИД | Задание точности аппроксимации объектов на текущем видовом экране
ОТРЕЗОК | Построение отрезков
Системные переменные
ANGDIR | Задание направления для положительных углов.
LASTANGLE | Сохраняет конечный угол последней введенной дуги в плоскости XY текущей ПСК в текущем пространстве
WHIPARC | Управляет сглаживанием кругов и дуг на экране
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение кругов - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение кругов
Понятия
Процедуры
Команды

Круги можно строить различными способами. По умолчанию построение производится по заданным центру и радиусу. Существуют также три дополнительных метода, которые показаны на чертеже.

Построение окружности, касающейся других объектов

Точка касания - это точка, в которой объект касается другого объекта, не пересекаясь с ним. Для построения окружности, касающейся других объектов, нужно указать точки касания на каждом из объектов и радиус окружности. На следующих чертежах построенная окружность показана жирной линией; точки касания - (1) и (2).

Для построения окружности, касательной в трех точках, нужно установить режим привязки "Касательная" командой ПРИВЯЗКА и построить окружность по трем точкам.

См. также

Использование объектной привязки

Построение изометрических кругов


Построение кругов - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение кругов
Понятия
Процедуры
Команды

Для построения круга по центру и радиусу (или диаметру)

Для построения круга, касающегося двух объектов


Для построения круга по центру и радиусу (или диаметру) - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение кругов
Понятия
Процедуры
Команды

Для построения круга по центру и радиусу (или диаметру)

  1. Выберите в меню "Рисование" » "Круг" » "Центр, радиус" (или "Центр, диаметр").
  2. Укажите точку центра.
  3. Задайте радиус или диаметр.

Панель "Рисование"

Ввод команды: КРУГ


Для построения круга, касающегося двух объектов - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение кругов
Понятия
Процедуры
Команды

Для построения круга, касающегося двух объектов

  1. Выберите в меню "Рисование" » "Круг" » "Кас, кас, радиус".

    2. Включается режим объектной привязки "Касательная".

  2. Выберите первый объект, которого касается окружность.
  3. Выберите второй объект, которого касается окружность.
  4. Задайте радиус круга.

Панель "Рисование"

Ввод команды: КРУГ


Построение кругов - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение кругов
Понятия
Процедуры
Команды

Команды
КРУГ | Построение окружностей
Системные переменные
CIRCLERAD | Радиус круга по умолчанию. Нуль указывает на отсутствие значения по умолчанию
WHIPARC | Управляет сглаживанием кругов и дуг на экране
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение дуг полилиний - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение дуг полилиний
Понятия
Процедуры
Команды

Полилиния представляет собой связанную последовательность сегментов; все эти сегменты являются единым объектом. Полилинии могут состоять из линейных и дуговых сегментов, а также из любых их сочетаний.

Полилинии используются, если предполагается работа с набором сегментов как с целым. У полилиний можно изменять ширину и кривизну сегментов (такие операции не возможны для простых отрезков). Имеющиеся на чертеже полилинии можно отредактировать командой ПОЛРЕД, а также преобразовать в отдельные линейные и дуговые сегменты с помощью команды РАСЧЛЕНИТЬ. Пользователь может:

  • Преобразовывать сглаженные сплайнами полилинии в сплайны командой СПЛАЙН
  • Создавать многоугольники с помощью замкнутых полилиний
  • Создавать полилинии из контуров перекрывающихся объектов
Создание дуговых полилиний

Полилинии могут иметь дуговые сегменты. Каждый из таких сегментов строится из конечной точки предыдущего сегмента. Дуги описываются заданием угла, центра, направления или радиуса. Кроме того, дугу можно построить указанием второй и конечной точек.

Создание замкнутых полилиний

Имеется возможность построения замкнутой полилинии для создания многоугольника. Для замыкания полилинии нужно выбрать начальную точку последней стороны объекта, ввести з (Замкнуть) и нажать ENTER.

Создание широких полилиний

Создаваемые полилинии могут иметь различную ширину, которая устанавливается опциями "Ширина" и "Полуширина". Для каждого сегмента можно задать свое значение ширины; кроме того, сегменты могут сужаться или расширяться, если значения ширины в начальной и конечной точках различны. Эти опции доступны после указания начальной точки при построении полилинии.

Опциями "Ширина" и "Полуширина" задается ширина следующего создаваемого сегмента полилинии. При указании значения 0 строится тонкий сегмент с нулевой шириной. Любые ненулевые положительные значения ширины приводят к созданию широких линий, которые отображаются закрашенными или в виде контуров, в зависимости от состояния режима закраски. Опцией "Полуширина" можно задавать расстояние от осевой линии широкой полилинии до ее края.

Конус

При использовании опции "Ширина" предоставляется возможность задания ширины сегмента как в начальной точке, так и в конечной. В этом случае ввод разных значений позволяет строить сужающиеся полилинии. Начальные и конечные точки широких сегментов полилинии располагаются на центральных осевых линиях сегментов. Места пересечений смежных широких сегментов полилинии обычно подрезаются. Однако этого не происходит в случае некасательных дуговых сегментов, очень острых углов пересечения или при использовании прерывистого типа линий.

Создание полилиний из контуров перекрывающихся объектов

Из контура, полученного в результате взаимного перекрытия объектов и образующего замкнутую область, можно создать полилинию. Полилиния, построенная таким образом, является отдельным объектом и не связана с объектами, определяющими контур построения. С такой полилинией можно выполнять те же действия, что и с другими полилиниями.

При работе с большими и сложными чертежами процесс задания контуров можно упростить, сгруппировав контуры в наборы. Набор создается путем выбора объектов, которые должны определять окончательный контур.

См. также

Редактирование сплайнов

Редактирование и объединение полилиний

Разрыв и соединение объектов

Работа с весами линий


Построение дуг полилиний - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение дуг полилиний
Понятия
Процедуры
Команды

Для построения полилинии из линейных сегментов

Для построения полилинии из линейных и дуговых сегментов

Для создания широкой полилинии

Для создания полилинии контура


Для построения полилинии из линейных сегментов - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение дуг полилиний
Понятия
Процедуры
Команды

Для построения полилинии из линейных сегментов

  1. Выберите в меню "Рисование" » "Полилиния".
  2. Укажите начальную точку полилинии.
  3. Укажите конечную точку первого сегмента полилинии.
  4. Продолжите указание конечных точек для последующих сегментов.
  5. Для завершения построения нажмите ENTER или введите з, если нужно замкнуть полилинию.

    6. Чтобы провести новую полилинию из конечной точки последней построенной полилинии, нужно снова вызвать команду ПЛИНИЯ и нажать ENTER в ответ на запрос "Начальная точка".

Панель "Рисование"

Ввод команды: ПЛИНИЯ


Для построения полилинии из линейных и дуговых сегментов - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение дуг полилиний
Понятия
Процедуры
Команды

Для построения полилинии из линейных и дуговых сегментов

  1. Выберите в меню "Рисование" » "Полилиния".
  2. Укажите начальную точку сегмента полилинии.
  3. Укажите конечную точку сегмента.
    • Для включения режима построения дуг введите д (Дуга).
    • Для возврата в режим построения линейных сегментов введите л (Линейный).
  4. При необходимости постройте последующие сегменты полилинии.
  5. Для завершения построения нажмите ENTER или введите з, если нужно замкнуть полилинию.

Панель "Рисование"

Ввод команды: ПЛИНИЯ


Для создания широкой полилинии - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение дуг полилиний
Понятия
Процедуры
Команды

Для создания широкой полилинии

  1. Выберите в меню "Рисование" » "Полилиния".
  2. Укажите начальную точку линейного сегмента.
  3. Введите ш (Ширина).
  4. Введите значение ширины в начале линейного сегмента.
  5. Задайте ширину в конце сегмента одним из следующих методов:
    • Чтобы построить линейный сегмент с постоянной шириной, нажмите ENTER.
    • Для построения сужающегося или расширяющегося линейного сегмента введите другое значение ширины.
  6. Укажите конечную точку сегмента.
  7. Продолжите указание конечных точек для последующих сегментов.
  8. Для завершения построения нажмите ENTERили введите з, если нужно замкнуть полилинию.

Панель "Рисование"

Ввод команды: ПЛИНИЯ


Для создания полилинии контура - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение дуг полилиний
Понятия
Процедуры
Команды

Для создания полилинии контура

  1. Выберите в меню "Рисование" » "Контур".
  2. В списке "Тип объекта" диалогового окна "Создание контура" выберите "Полилиния".
  3. В группе "Набор контуров" выполните одно из следующих действий:
    • Для создания набора контуров из всех объектов, видимых на текущем видовом экране, выберите из списка параметр "Текущий видовой экран". Эту опцию не следует использовать при работе с большими и сложными чертежами.
    • Чтобы вручную выборать объекты для создания набора контуров, нажмите "Новый". Выберите объекты, которые будут использоваться при создании контуров. При использовании этой опции автоматически включается опция "Имеющийся набор".
  4. Нажать кнопку "Указание точек".
  5. Укажите точки внутри каждой области, которые должны определять контур для построения полилинии.

    6. Задаваемая область должна быть замкнутой, то есть между объектами, определяющими эту область, не должно быть промежутков. Имеется возможность выбора нескольких областей.

  6. Для создания контур-полилинии и завершения команды нажмите ENTER.

    7. Создается полилиния, повторяющая форму заданного контура. Объекты, участвующие в построении полилинии, могут стать невидимыми в результате перекрытия новой полилинией. Построенную полилинию контура можно перемещать, копировать и редактировать точно так же, как и другие полилинии.

Ввод команды: КОНТУР


Построение дуг полилиний - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение дуг полилиний
Понятия
Процедуры
Команды

Команды
3DПЛИНИЯ | Построение полилиний из линейных сегментов в 3D пространстве
КОНТУР | Создание области или полилинии из замкнутого контура
НАСТРВИД | Задание точности аппроксимации объектов на текущем видовом экране
ПЛИНИЯ | Построение двумерных полилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
PLINEGEN | Управляет созданием типа линии вокруг вершин двухмерных полилиний
PLINETYPE | Указывает, используется ли оптимизированные двухмерные полилинии
PLINEWID | Хранит значение ширины полилинии по умолчанию
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение колец - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение колец
Понятия
Процедуры
Команды

Кольца представляют собой заполненные круги или замкнутые широкие полилинии круглой формы.

Для построения кольца необходимо задать его внутренний и внешний диаметры, а также центр. Вызванная команда позволяет построить любое количество колец, имеющих одинаковые диаметры, но разные центры. Если требуется построить закрашенный круг, следует задать нулевой внутренний диаметр кольца.


Для построения кольца - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение колец
Понятия
Процедуры
Команды

Для построения кольца

  1. Выберите в меню "Рисование" » "Кольцо".
  2. Задайте внутренний диаметр (1).
  3. Задайте наружный диаметр (2).
  4. Укажите центр кольца (3).
  5. Укажите центр следующего кольца или нажмите ENTER для завершения команды.


Построение колец - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение колец
Понятия
Процедуры
Команды

Команды
КОЛЬЦО | Построение закрашенных кругов и колец
Системные переменные
DONUTID | Устанавливает внутренний диаметр кольца по умолчанию
DONUTOD | Устанавливает внешний диаметр кольца по умолчанию
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение эллипсов - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение эллипсов
Понятия
Процедуры
Команды

Построение эллипсов производится путем задания двух осей. Длинная ось эллипса называется его большой осью, короткая - малой осью.

На следующем чертеже показаны два разных эллипса, построенные по конечным точкам одной оси и половине длины другой оси. Третья точка задает лишь половину длины второй оси, но не положение ее конечной точки.

При рисовании на плоскостях изометрии (имитация трехмерного рисования) окружности, рассматриваемые под углом к плоскости, представляются эллипсами. Перед рисованием нужно включить режим изометрии с помощью диалогового окна "Режимы рисования".

См. также

Построение изометрических кругов

Разрыв и соединение объектов


Построение эллипсов - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение эллипсов
Понятия
Процедуры
Команды

Для построения изометрического круга

Для построения эллипса по конечным точкам одной оси и половине длины другой оси

Для построения эллиптической дуги по начальному и конечному углам


Для построения изометрического круга - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение эллипсов
Понятия
Процедуры
Команды

Для построения изометрического круга

  1. Выберите в меню "Сервис" » "Режимы черчения".
  2. В диалоговом окне "Режимы рисования" на вкладке "Шаг и сетка", для параметра "Тип и стиль привязки" выберите "Изометрическая". Нажмите "ОК".
  3. Выберите в меню "Рисование" » "Эллипс" » "Ось, конец".
  4. Введите и (Изокруг).
  5. Укажите центр круга.
  6. Задайте радиус или диаметр круга.

Панель "Рисование"

Ввод команды: ЭЛЛИПС


Для построения эллипса по конечным точкам одной оси и половине длины другой оси - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение эллипсов
Понятия
Процедуры
Команды

Для построения эллипса по конечным точкам одной оси и половине длины другой оси

  1. Выберите в меню "Рисование" » "Эллипс" » "Ось, конец".
  2. Укажите начало первой оси (1).
  3. Укажите конец первой оси (2).
  4. Перетащив курсор на нужное расстояние, задать щелчком мыши половину длины второй оси (3).

Панель "Рисование"

Ввод команды: ЭЛЛИПС


Для построения эллиптической дуги по начальному и конечному углам - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение эллипсов
Понятия
Процедуры
Команды

Для построения эллиптической дуги по начальному и конечному углам

  1. Выберите в меню "Рисование" » "Эллипс" » "Дуга".
  2. Укажите конечные точки первой оси (1 и 2).
  3. Задайте половину длины второй оси (3).
  4. Задайте начальный угол (4).
  5. Задайте конечный угол (5).

    6. Эллиптическая дуга будет построена между начальной и конечной точками против часовой стрелки.

Панель "Рисование"

Ввод команды: ЭЛЛИПС


Построение эллипсов - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение эллипсов
Понятия
Процедуры
Команды

Команды
ЭЛЛИПС | Построение эллипсов и эллиптических дуг
Системные переменные
ANGDIR | Задание направления для положительных углов.
PELLIPSE | Определяет тип эллипса, созданного с помощью команды ЭЛЛИПС
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение сплайнов - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение сплайнов
Понятия
Процедуры
Команды

Сплайн представляет собой гладкую кривую, проходящую через заданный набор точек или рядом с ними. Пользователь может задавать точность прохождения кривой через определяющие точки.

Команда СПЛАЙН работает с частным случаем сплайнов неоднородными рациональными B-сплайновыми кривыми (NURBS). Применение NURBS обеспечивает достаточную гладкость кривых, проходящих через заданные управляющие точки.

Сплайны строятся путем задания координат определяющих точек. Сплайны могут быть замкнутыми; при этом совпадают как конечная и начальная точки, так и направления касательных в них.

Допуск задает максимально допустимое расстояние от реального сплайна до любой из определяющих точек. Чем меньше значение допуска, тем сплайн ближе к определяющим точкам. При нулевом допуске сплайн проходит через определяющие точки. При изменении допуска можно визуально контролировать результат для выбора оптимального значения.

Имеется два способа построения сплайнов:

  • Создание сплайнов с помощью опции "Сплайн" команды ПОЛРЕД, т.е. путем сглаживания имеющихся полилиний, созданных командой ПЛИНИЯ. Такие сглаженные сплайнами полилинии создаются с применением однородных узловых векторов и в дальнейшем могут использоваться в чертежах, созданных в более ранних версиях продукта.
  • Создание реальных сплайнов в виде NURBS-кривых с помощью команды СПЛАЙН. Чертеж, содержащий такие сплайны, занимает меньше места на диске и в оперативной памяти, чем Чертеж с полилиниями и фигурами подобных форм.

Сглаженные сплайнами полилинии можно легко преобразовать в реальные сплайны командой СПЛАЙН.

См. также

Редактирование сплайнов

Разрыв и соединение объектов


Построение сплайнов - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение сплайнов
Понятия
Процедуры
Команды

Преобразование сглаженных сплайнами полилиний в сплайны

Для построения сплайна путем задания определяющих точек


Преобразование сглаженных сплайнами полилиний в сплайны - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение сплайнов
Понятия
Процедуры
Команды

Преобразование сглаженных сплайнами полилиний в сплайны

  1. Выберите в меню "Рисование" » "Сплайн".
  2. Введите о (Объект).
  3. Выберите сглаженную сплайнами полилинию и нажмите ENTER.

    4. Выбранный объект преобразуется из полилинии в сплайн.


Для построения сплайна путем задания определяющих точек - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение сплайнов
Понятия
Процедуры
Команды

Для построения сплайна путем задания определяющих точек

  1. Выберите в меню "Рисование" » "Сплайн".
  2. Укажите начальную точку сплайна (1).
  3. Укажите определяющие точки сплайна (2-5); затем нажмите ENTER.
  4. Задайте направления касательных в начальной и конечной точках (6, 7).

На следующем чертеже показан сплайн с теми же определяющими точками, но с разными направлениями касательных в первой и последней точках.

Следующий сплайн построен по тем же определяющим точкам, но с большим допуском и другими направлениями касательных.

Панель "Рисование"

Ввод команды: СПЛАЙН


Построение сплайнов - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение сплайнов
Понятия
Процедуры
Команды

Команды
ПЛИНИЯ | Построение двумерных полилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
РЕДСПЛАЙН | Редактирование сплайнов или сглаженных сплайнами полилиний
СПЛАЙН | Создает гладкую кривую, проходящую вблизи (в пределах заданной погрешности) некоторого набора точек.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение спиралей - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение спиралей
Понятия
Процедуры
Команды

Спираль представляет собой открытую 2D или 3D переходную кривую.

Показать: Создать и изменить спираль

Для запуска анимации нажмите на стрелку "Просмотр". Подробней об изменении спиралей см. в разделе Изменение спиралей.

Спираль можно использовать в качестве траектории для команды СДВИГ. Например, при сдвиге круга вдоль траектории спирали может быть создана твердотельная модель пружины.

При создании спирали можно указать следующие параметры:

  • Радиус в основании
  • Радиус при вершине
  • Высота
  • Число витков
  • Высота витка
  • Направление вращения

Если для радиуса в основании и радиуса при вершине задать равные значения, будет создана цилиндрическая спираль. По умолчанию радиус при вершине и радиус в основании задаются равными. Значение 0 не может быть задано ни для радиуса при вершине, ни для радиуса в основании.

Если для радиуса в основании и радиуса при вершине задать разные значения, будет создана коническая спираль.

Если задать высоту витка равной 0, создается плоская двумерная спираль.

Примечание Спираль является сплайновой аппроксимацией реальной спирали. Значения длины могут быть не абсолютно точными. Однако при использовании спирали в качестве траектории развертки получаемые значения точны независимо от аппроксимации.

См. также

Изменение спиралей

Создание тела или поверхности посредством сдвига


Для создания спирали - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение спиралей
Понятия
Процедуры
Команды

Для создания спирали

  1. Выберите в меню "Рисование" » "Спираль".
  2. Укажите координаты центра основания спирали.
  3. Задайте радиус в основании.
  4. Укажите радиус при вершине или нажмите ENTER для ввода значения, равного радиусу в основании.
  5. Укажите высоту спирали.

Панель "Моделирование"

Ввод команды: СПИРАЛЬ

Пульт управления: Панель "3D построения" (нажмите на значке, чтобы развернуть), Спираль


Построение спиралей - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение спиралей
Понятия
Процедуры
Команды

Команды
СПИРАЛЬ | Создание 2D или 3D винтовой линии
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение вспомогательных и опорных элементов - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение вспомогательных и опорных элементов
Понятия
Процедуры
Команды

Для выполнения точных построений используются такие временные объекты, как вспомогательные линии и опорные точки.

  • Построение опорных точек
    Объекты-точки рекомендуется использовать в качестве геометрических опорных узлов для объектной привязки и относительных смещений.
  • Построение бесконечных линий (и лучей)
    Линии, бесконечные в обоих направлениях или только в одном направлении, называются соответственно прямыми и лучами. Бесконечные линии можно использовать в качестве вспомогательных при построении объектов.


Построение вспомогательных и опорных элементов - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение вспомогательных и опорных элементов
Понятия
Процедуры
Команды

Для задания формы и размера точки

Для создания объекта-точки

Для построения прямой по двум точкам

Для построения луча


Построение вспомогательных и опорных элементов - Команды

Создание и редактирование объектов
Построение геометрических объектов
Построение вспомогательных и опорных элементов
Понятия
Процедуры
Команды
Команды
ДИАЛТТОЧ | Задание стиля отображения и величины точечных объектов
ЛУЧ | Построение линий, бесконечных в одном направлении
ПРЯМАЯ | Построение бесконечных прямых
ТОЧКА | Создание объектов-точек
Системные переменные
PDMODE | Управляет отображением точечных объектов
PDSIZE | Устанавливает размер отображения точечных объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение опорных точек - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение опорных точек
Понятия
Процедуры
Команды

Объекты-точки рекомендуется использовать в качестве геометрических опорных узлов для объектной привязки и относительных смещений.

Форму символа-точки и его размер можно задать относительно размера экрана, либо в абсолютных единицах. При изменении формы символов точек:

  • Достигается желаемый результат отображения точек и возможность их идентификации среди узловых точек сетки
  • Изменяется вид отображаемых объектов-точек чертежа
  • Для вывода чертежа с измененной формой точек следует запустить команду РЕГЕН


Построение опорных точек - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение опорных точек
Понятия
Процедуры
Команды

Для задания формы и размера точки

Для создания объекта-точки


Для задания формы и размера точки - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение опорных точек
Понятия
Процедуры
Команды

Для задания формы и размера точки

  1. Выберите в меню "Формат" » "Отображение точек".
  2. В диалоговом окне "Отображение точек" выберите форму точки.
  3. В поле "Размер точки" задайте необходимый размер относительно размера экрана или в абсолютных единицах.
  4. Нажмите "ОК".

Ввод команды: ДИАЛТТОЧ


Для создания объекта-точки - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение опорных точек
Понятия
Процедуры
Команды

Для создания объекта-точки

  1. Выберите в меню "Рисование" » "Точка" » "Одиночная".
  2. Укажите положение точки.

    3. В дальнейшем к этой точке можно будет привязываться в режиме "Узел".

Панель "Рисование"

Ввод команды: ТОЧКА


Построение опорных точек - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение опорных точек
Понятия
Процедуры
Команды

Команды
ДИАЛТТОЧ | Задание стиля отображения и величины точечных объектов
ТОЧКА | Создание объектов-точек
Системные переменные
PDMODE | Управляет отображением точечных объектов
PDSIZE | Устанавливает размер отображения точечных объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение бесконечных линий (и лучей) - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение бесконечных линий (и лучей)
Понятия
Процедуры
Команды

Линии, бесконечные в обоих направлениях или только в одном направлении, называются соответственно прямыми и лучами. Бесконечные линии можно использовать в качестве вспомогательных при построении объектов.

Например, с помощью прямых можно найти центр треугольника, подготовить различные виды одного элемента или создать временные пересечения для объектной привязки.

Наличие бесконечных линий не изменяет границ чертежа. Следовательно, бесконечные линии не влияют на процесс зумирования и на видовые экраны, а также на результаты выполнения команд отображения в границах чертежа. Прямые и лучи можно перемещать, поворачивать и копировать таким же образом, как и любые другие объекты. Бесконечные линии часто строят на отдельном слое, который перед выводом на плоттер можно заморозить или отключить.

Построение прямых

Прямые можно строить в любом месте трехмерного пространства. Их направление может задаваться различными способами. По умолчанию применяется метод создания отрезка по двум точкам: пользователь должен указать две точки для определения ориентации. Первая (или базовая) точка является серединой прямой и определяется как точка привязки в режиме объектной привязки "Середина".

Прямые линии можно также строить и другими способами:

  • Горизонтали и вертикали. Построение прямых, проходящих через заданную точку и параллельных оси X или Y текущей ПСК.
  • Угол Построение прямой по углу наклона одним из двух методов. Можно либо выбрать базовую линию и задать угол между базовой линией и создаваемой прямой, либо (для построения прямой, лежащей под заданным углом к горизонтальной оси) задать угол и указать точку, через которую должна проходить прямая.
  • Биссектриса Построение прямой, делящей пополам какой-либо угол. Нужно указать вершину угла и его стороны.
  • ДИАЛТТОЧ Создание прямой, параллельной какой-либо линии, выбранной в качестве базовой, методом смещения. Нужно задать величину смещения, выбрать базовую линию, а затем указать, с какой стороны от базовой линии должна проходить прямая.
Лучи

Луч представляет собой линию в трехмерном пространстве, начинающуюся в заданной точке и уходящую в бесконечность. Таким образом, в отличие от прямых, лучи бесконечны только в одном направлении. Использование лучей вместо прямых помогает уменьшить загроможденность чертежа. Как и прямые, лучи игнорируются командами, с помощью которых осуществляется показ чертежа в его границах.


Построение бесконечных линий (и лучей) - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение бесконечных линий (и лучей)
Понятия
Процедуры
Команды

Для построения прямой по двум точкам

Для построения луча


Для построения прямой по двум точкам - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение бесконечных линий (и лучей)
Понятия
Процедуры
Команды

Для построения прямой по двум точкам

  1. Выберите в меню "Рисование" » "Прямая".
  2. Укажите базовую точку прямой.
  3. Укажите вторую точку, через которую должна проходить прямая.
  4. Если необходимо, можно сразу построить несколько прямых.

    5. Все последующие прямые начинаются в первой указанной точке.

  5. Нажмите ENTER для завершения команды.

Панель "Рисование"

Ввод команды: ПРЯМАЯ


Для построения луча - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение бесконечных линий (и лучей)
Понятия
Процедуры
Команды

Для построения луча

  1. Выберите в меню "Рисование" » "Луч".
  2. Выберите точку начала луча.
  3. Укажите вторую точку, через которую должен проходить луч.
  4. Если необходимо, можно сразу построить несколько лучей.

    5. Все последующие лучи начинаются в первой указанной точке.

  5. Нажмите ENTER для завершения команды.

Ввод команды: ЛУЧ


Построение бесконечных линий (и лучей) - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение бесконечных линий (и лучей)
Понятия
Процедуры
Команды

Команды
ЛУЧ | Построение линий, бесконечных в одном направлении
ПРЯМАЯ | Построение бесконечных прямых
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение и объединение областей - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Построение и объединение областей
Понятия
Процедуры
Команды

Областями называются двумерные замкнутые объекты, которые имеют такие физические свойства, как центры масс. Имеющиеся области можно объединять в одну область и рассчитать ее площадь.

Области представляют собой двумерные закрытые области, созданные объектами, образующими замкнутые контуры. Контуры могут состоять из отрезков, полилиний, окружностей, дуг, эллипсов, эллиптических дуг и сплайнов. Объекты контура должны быть представлены либо одним замкнутым объектом, либо замкнутой последовательностью объектов, соединяющихся в конечных точках.

Для областей можно:

  • Выполнять штрихование и закрашивание
  • Рассчитывать свойства, например, площадь с помощью команды МАСС-ХАР
  • Получать информацию, например, о расположении центра масс

Области могут быть созданы из нескольких контуров, а также из нескольких разомкнутых кривых, соединенных между собой и образующих контур. Нельзя формировать области с помощью открытых объектов, которые, пересекаясь, образуют замкнутый контур: например, пересекающиеся дуги или самопересекающиеся кривые.

Создавать области можно также с помощью команды КОНТУР.

Составные области строятся путем вычитания, объединения и пересечения имеющихся областей. После этого к ним можно применять штрихование и подсчитывать общую площадь.

Объединение объектов с помощью команды ОБЪЕДИНЕНИЕ

Объединение объектов с помощью команды ВЫЧИТАНИЕ

Объединение объектов с помощью команды ПЕРЕСЕЧЕНИЕ


Построение и объединение областей - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение и объединение областей
Понятия
Процедуры
Команды

Для определения областей

Для создания областей с использованием контуров

Для построения составной области путем объединения

Для построения составной области путем вычитания

Для построения составной области путем пересечения


Для определения областей - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение и объединение областей
Понятия
Процедуры
Команды

Для определения областей

  1. Выберите в меню "Рисование" » "Область".
  2. Выбрать объекты для преобразования в область.

    3. Каждый из этих объектов должен образовывать замкнутый контур, например круг или замкнутую полилинию.

  3. Нажмите ENTER.

    4. В командной строке выводится сообщение о том, сколько обнаружено контуров и сколько создано областей.

Ввод команды: ОБЛАСТЬ


Для создания областей с использованием контуров - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение и объединение областей
Понятия
Процедуры
Команды

Для создания областей с использованием контуров

  1. Выберите в меню "Рисование" » "Контур".
  2. В списке "Тип объекта" диалогового окна "Создание контура" выберите "Область".
  3. Нажмите кнопку "Указание точек".
  4. Укажите точку на чертеже внутри каждого замкнутого контура, из которого необходимо создать область, а затем нажмите ENTER.

    5. Эта точка интерпретируется как внутренния.

    Примечание Для ограничения числа объектов, участвующих в определении контура, можно создать новый набор контуров.

Ввод команды: КОНТУР


Для построения составной области путем объединения - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение и объединение областей
Понятия
Процедуры
Команды

Для построения составной области путем объединения

  1. Выберите в меню "Изменить" » "Редактирование тел" » "Объединение".
  2. Выберите первую область для объединения.
  3. Выберите следующую область.

    4. Выбор объединяемых областей можно выполнять в любой последовательности.

  4. Продолжите выбор областей или нажмите ENTER для завершения команды.

    5. Выбранные области объединяются в одну составную область.

Ввод команды: ОБЪЕДИНЕНИЕ


Для построения составной области путем вычитания - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение и объединение областей
Понятия
Процедуры
Команды

Для построения составной области путем вычитания

  1. Выберите в меню "Изменить" » "Редактирование тел" » "Вычитание".
  2. Выберите одну или несколько областей, из которых будет произведено вычитание и нажмите ENTER.
  3. Выберите вычитаемую область и нажмите ENTER.

    4. Будет выполнено вычитание площадей регионов.

Ввод команды: ВЫЧИТАНИЕ


Для построения составной области путем пересечения - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Построение и объединение областей
Понятия
Процедуры
Команды

Для построения составной области путем пересечения

  1. Выберите в меню "Изменить" » "Редактирование тел" » "Пересечение".
  2. Выберите первую область для пересечения.
  3. Выберите следующую область для пересечения.

    4. Порядок выбора исходных областей при построении пересечения не имеет значения.

  4. Продолжите выбор областей или нажмите ENTER для завершения команды.

    5. Строится новая область, полученная в результате пересечения выбранных областей.

Ввод команды: ПЕРЕСЕЧЕНИЕ


Построение и объединение областей - Команды

Построение геометрических объектов
Построение геометрических объектов
Построение и объединение областей
Понятия
Процедуры
Команды

Команды
ВЫЧИТАНИЕ | Объединение выбранных областей или тел посредством вычитания
КОНТУР | Создание области или полилинии из замкнутого контура
МАСС-ХАР | Вычисление массовых характеристик областей и тел
ОБЛАСТЬ | Преобразование объектов, ограничивающих некоторую площадь, в области
ОБЪЕДИНЕНИЕ | Объединение выбранных областей или тел посредством сложения
ПЕРЕСЕЧЕНИЕ | Создает составные тела или области путем пересечения двух или более тел или областей и удаляет области снаружи пересечения.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание облаков для пометок - Понятия

Создание и редактирование объектов
Построение геометрических объектов
Создание облаков для пометок
Понятия
Процедуры
Команды

Облака для пометок представляют собой полилинии с дуговыми сегментами. Они используются для нанесения различных пояснительных надписей к элементам чертежа на стадии рассмотрения.

Просмотр чертежей и процесс внесения электронных пометок можно сделать более удобным, если использовать возможность размещения на чертеже облаков, которые позволяют выделять пометки, вносимые в чертеж. С помощью команды ОБЛАКО можно создать полилинию из последовательно соединенных дуг для построения объекта в форме облака. Облака для пометок могут иметь 2 стиля дуг: "Обычный" и "Каллиграфия". Облако со стилем "Каллиграфия" выглядит так, как если бы оно было нарисовано от руки.

Облака для пометок можно создавать с нуля или же строить их путем преобразования таких объектов, как круги, эллипсы, полилинии и сплайны. Если DELOBJ = 1, то в ходе преобразования объекта в облако исходный объект подлежит удалению.

Пользователь может задавать минимальные и максимальные значения длин дуг облаков для пометок. При создании облака для пометок можно изменять размер дуг, выбирая точки дуговых сегментов. При помощи выбранных точек можно изменять нужные длины дуг и хорд, образующих облако для пометок.

Для согласования чертежей с различными масштабными коэффициентами команда REVCLOUD сохраняет последнюю использованную длину дуги в виде значения, кратного системной переменной DIMSCALE.

Прежде чем использовать REVCLOUD убедитесь, что площадь, подлежащая действию этой команды, не имеет скрытых областей. Команда REVCLOUD не поддерживает прозрачное панорамирование и масштабирование в режиме реального времени.


Создание облаков для пометок - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Создание облаков для пометок
Понятия
Процедуры
Команды

Создание облака для пометки с нуля

Для создания облака для пометки со стилем "Каллиграфия"

Для преобразования объекта в облако для пометок

Для изменения значений длин дуг по умолчанию для использования в облаках

Для изменения отдельных длин дуг или хорд, образующих облако


Создание облака для пометки с нуля - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Создание облаков для пометок
Понятия
Процедуры
Команды

Создание облака для пометки с нуля

  1. Выберите в меню "Рисование" » "Облако".
  2. Введите в командной строке новые значения минимальной и максимальной длины дуги или укажите начальную точку облака.

    3. По умолчанию минимальная и максимальная длины дуги равны 0.5 единицам. Максимальная длина дуги не может превышать минимальную более чем в три раза.

  3. Обведите перекрестьем курсора форму создаваемого облака. Длину дуг можно изменять, перемещая точки дуговых сегментов.
  4. Прервать построение облака для пометок можно в любой момент нажатием ENTER.

    5. Для замыкания контура облака нужно вернуть курсор в начальную точку.

Панель "Рисование"

Ввод команды: ОБЛАКО


Для создания облака для пометки со стилем "Каллиграфия" - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Создание облаков для пометок
Понятия
Процедуры
Команды

Для создания облака для пометки со стилем "Каллиграфия"

  1. Выберите в меню "Рисование" » "Облако".
  2. В командной строке введите стиль.
  3. В командной строке введите calligraphy.
  4. Нажмите ENTER для сохранения параметра "Каллиграфия" и переходите к работе с командой, или нажмите ESC для завершения команды.

Панель "Рисование"

Ввод команды: ОБЛАКО


Для преобразования объекта в облако для пометок - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Создание облаков для пометок
Понятия
Процедуры
Команды

Для преобразования объекта в облако для пометок

  1. Выберите в меню "Рисование" » "Облако".
  2. Укажите в командной строке новые значения минимальной и максимальной длины дуги или нажмите ENTER.

    3. По умолчанию минимальная и максимальная длины дуги равны 0.5 единицам. Максимальная длина дуги не может превышать минимальную более чем в три раза.

  3. Выбрать круг, эллипс, полилинию или сплайн, который требуется преобразовать в облако для пометок.

    4. Для обращения направления дуг введите в командной строке да и нажмите ENTER.

  4. Нажмите ENTER для преобразования выбранного объекта в облако.

Панель "Рисование"

Ввод команды: ОБЛАКО


Для изменения значений длин дуг по умолчанию для использования в облаках - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Создание облаков для пометок
Понятия
Процедуры
Команды

Для изменения значений длин дуг по умолчанию для использования в облаках

  1. Выберите в меню "Рисование" » "Облако".
  2. Введите в командной строке новую минимальную длину дуги и нажмите ENTER.
  3. Введите в командной строке новую максимальную длину дуги и нажмите ENTER.

    4. Максимальная длина дуги не может превышать минимальную более чем в три раза.

  4. Нажмите ENTER для продолжения работы с командой, или нажмите ESC для завершения команды.

Панель "Рисование"

Ввод команды: ОБЛАКО


Для изменения отдельных длин дуг или хорд, образующих облако - Процедуры

Создание и редактирование объектов
Построение геометрических объектов
Создание облаков для пометок
Понятия
Процедуры
Команды

Для изменения отдельных длин дуг или хорд, образующих облако

  1. Выберите облако для пометок, размер которого требуется изменить.
  2. Изменение длины дуг и хорд, составляющих облака для пометок, производится перемещением выделенных точек.


Создание облаков для пометок - Команды

Построение геометрических объектов
Построение геометрических объектов
Создание облаков для пометок
Понятия
Процедуры
Команды

Команды
ОБЛАКО | Создание полилиний с дуговыми сегментами, используемых в качестве облаков для пометок
Системные переменные
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
DIMSCALE | Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и использование блоков (символов) - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Понятия
Процедуры
Команды

Блоком называется совокупность связанных объектов чертежа, обрабатываемых как единый объект. Объединение объектов в блоки облегчает повторное использование их как внутри одного чертежа, так и в других чертежах.

  • Базовые понятия для блоков
    Блоки могут состоять из объектов, изначально находившихся на различных слоях и имевших различные свойства. Пользователь имеет возможность создавать блоки, применяя различные способы.
  • Создание и сохранение блоков
    Создание блока предполагает объединение объектов в группу под определенным именем. С блоком также можно связать дополнительные информационные записи (атрибуты).
  • Добавление функций динамического изменения в блоки
    При добавлении функций динамического изменения в определения блока добавляется гибкость и интеллектуальные возможности для геометрии. Блок уже не является фиксированной частью чертежа. Вхождение динамического блока можно изменять или манипулировать по мере работы с чертежом.
  • Цвета и типы линий объектов в блоках
    Объекты вставляемого блока могут сохранять свои исходные свойства, либо перенять свойства текущего слоя, на который они вставляются, или текущие значения свойств, установленные в чертеже.
  • Вложение блоков
    Блоки, которые содержатся внутри других вставленных в чертеж блоков, называются вложенными. Использование вложенных блоков позволяет упрощать описания сложных блоков.
  • Вставка блоков
    При вставке блока создается вхождение блока. Пользователь указывает точку вставки, масштабные коэффициенты и угол поворота.
  • Работа с динамическими блоками в чертежах
    Динамический блок обладает гибкостью и интеллектуальными возможностями. Динамический блок можно легко изменить на чертеже во время работы.
  • Атрибуты блоков
    Пользователь может связывать с блоками различные текстовые данные и в дальнейшем извлекать их для составления спецификаций, отчетов и т.д..
  • Редактирование блоков
    Имеется возможность редактирования описаний блоков и вхождений блоков уже после их вставки в чертеж.
  • Изменение цвета и типа линий в блоке
    Изменение цвета и типа линий объектов блока доступно лишь в том случае, если свойства объектов являются наследуемыми.
  • Расчленение блока
    Для того чтобы получить возможность редактировать отдельные объекты, входящие в блок, необходимо выполнить его расчленение на отдельные компоненты.
  • Удаление описаний блоков
    Для сокращения размера чертежа неиспользуемые описания блоков можно удалить.


Создание и использование блоков (символов) - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Понятия
Процедуры
Команды

Для создания описания блока в текущем чертеже

Для создания библиотеки компонентов

Для сохранения выбранных объектов в новом файле

Для редактирования текстового пояснения к блоку

Чтобы открыть существующее описание блока в редакторе блоков

Чтобы создать новое описание блока в редакторе блоков

Чтобы открыть блок на инструментальной палитре редакторе блоков

Чтобы открыть блок из окна Центра управления в редакторе блоков

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (но не динамический)

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок

Чтобы просмотреть свойства описания блока в редакторе блоков

Чтобы просмотреть свойства объектов в редакторе блоков

Чтобы закрыть редактор блоков

Чтобы запретить доступ к редактору блоков

Чтобы отобразить или скрыть окно "Палитры вариации блоков" в редакторе блоков

Чтобы создать копию набора параметров

Чтобы добавить операцию в набор параметров

Чтобы удалить операцию из параметра или набора параметров

Чтобы указать цвет отображения для параметров в редакторе блоков

Чтобы указать размер текста для параметров и операций в редакторе блоков

Чтобы указать шрифт для параметров в редакторе блоков

Чтобы указать цвет текста для операций в редакторе блоков

Чтобы указать отображаемый размер ручек в редакторе блоков

Чтобы указать отображаемый цвет ручек в редакторе блоков

Чтобы обновить текст или отображаемый размер ручки в указанных значениях в редакторе блоков

Чтобы указать, должны ли быть видны в редакторе блоков объекты, которые являются невидимыми для состояния видимости

Чтобы включить или отключить выделение зависимостей в редакторе блоков

Чтобы определить, должны ли отображаться метки наборов значений (засечки)

Чтобы создать динамический блок

Чтобы добавить в описание динамического блока параметр точки

Чтобы добавить в описание динамического блока линейный параметр

Чтобы добавить в описание динамического блока полярный параметр

Чтобы добавить в описание динамического блока параметр XY

Чтобы добавить в описание динамического блока параметр поворота

Чтобы добавить в описание динамического блока параметр выравнивания

Чтобы добавить в описание динамического блока параметр отражения

Чтобы добавить в описание динамического блока параметр видимости

Чтобы добавить в описание динамического блока параметр выбора

Чтобы добавить в описание динамического блока параметр базовой точки

Для добавления операции перемещения в описание динамических блоков

Для указания свойства "Тип расстояния" для операции перемещения, связанной с параметром XY

Для добавления операции масштабирования в описание динамических блоков

Для указания независимой базовой точки для операции масштабирования в описании динамических блоков

Для указания свойства "Тип масштаба" для операции масштабирования, связанной с параметром XY

Для добавления операции растягивания в описание блока

Для указания свойства "Тип расстояния" для операции растягивания, связанной с параметром XY

Для добавления операции полярного растягивания в описание блока

Для добавления операции поворота в описание блока

Для добавления операции отражения в описание блока

Чтобы добавить в описание блока операцию с массивом

Для добавления операции поиска в описание динамических блоков

Задание переопределения коэффициента расстояния для операции

Задание переопределения смещения угла для операции

Добавление набора параметров в описание динамического блока

Для указания количества специальных ручек, отображаемых для параметра в динамическом блоке

Чтобы переместить ручку в описании динамического блока

Чтобы восстановить для ручек в описании динамического блока положения по умолчанию

Чтобы включить или отключить циклический перебор для ручки настройки во вхождении динамического блока

Для изменения порядка перебора при вставке для специальных ручек в динамическом блоке

Для включения состояний видимости (добавить параметр видимости)

Для создания нового состояния видимости на основе текущего состояния

Для создания нового состояния видимости, в котором все объекты являются невидимыми.

Для создания нового состояния видимости, в котором все объекты являются видимыми

Чтобы сделать состояние видимости текущим

Для удаления состояния видимости

Для задания нового имени состоянию видимости

Чтобы сделать объекты видимыми в текущем состоянии видимости

Чтобы сделать объекты видимыми во всех состояниях видимости

Чтобы сделать объекты невидимыми в текущем состоянии видимости.

Чтобы сделать объекты невидимыми во всех состояниях видимости

Для отображения или скрытия невидимой геометрии для состояний видимости.

Для изменения порядка в списке состояний видимости для вхождения динамического блока

Для установки состояния видимости по умолчанию для вхождения динамического блока.

Для создания таблицы выбора для динамического блока

Для добавления свойств входа в таблицу выбора.

Для добавления свойств поиска в таблицу выбора.

Для добавления значений в таблицу выбора

Для включения обратного поиска

Чтобы сделать свойство поиска только для чтения

Для проверки на наличие ошибок в таблице выбора

Для открытия существующей таблицы выбора

Для указания ярлыка параметра

Для указания отображения настраиваемых свойств во вхождении динамического блока.

Для указания расчленения вхождения динамического блока

Для запрета неоднородного масштабирования во вхождении динамического блока.

Для указания набора значений для линейного или полярного параметра

Для указания набора значений для параметра XY

Для указания набора значений для параметра поворота

Для удаления значений из набора значений параметра

Для указания набора значений приращения для линейного, полярного параметра, параметра XY или поворота.

Для указания минимального и максимального значений для линейного, полярного параметра, параметра XY или поворота.

Для указания свойства "Цепочка операций" для линейного, полярного параметра, параметра точки, XY и поворота

Чтобы открыть существующее описание динамического блока в редакторе блоков

Удаление элемента из описания динамических блоков

Изменение набора объектов для операции в описании динамических блоков

Переопределение растяжения или набора рамок растяжения для операции полярного растяжения в описании динамических блоков

Исправление ошибки, обозначаемой желтым значком предупреждения в описании динамических блоков

Просмотр зависимостей внутри описания динамических блоков

Сохранение описания блоков в редакторе блоков

Сохранение копии текущего описания блоков в редакторе блоков под другим именем

Для задания цвета создаваемых объектов

Для задания типа линий вновь создаваемых объектов

Для вставки блока, описанного в текущем чертеже

Для вставки файла чертежа в качестве блока путем его перетаскивания

Для вставки блока с помощью Центра управления

Манипулирование динамическим блоком с помощью настраиваемых ручек

Манипулирование динамическим блоком с помощью настраиваемых свойств

Сброс вхождений блока в чертеже

Изменение цвета отображения настраиваемых ручек

Для создания описания атрибута

Для редактирования описания атрибута до его связывания с блоком

Изменение порядка описаний атрибутов

Извлечение атрибутов блоков в таблицу или файл

Для обновления таблицы извлечения атрибутов

Отключение уведомления об обновлении для таблиц извлечения атрибутов

Для создания файла шаблона вывода атрибутов

Для извлечения данных из атрибутов

Для обновления блока при изменении исходного файла

Для редактирования пояснения к блоку

Для редактирования атрибутов в описаниях блоков

Для включения и отключения применения изменений к существующим вхождениям блоков

Для нахождения одинаковых имен атрибутов блока

Для изменение порядка запросов на ввод значений атрибутов

Для удаления атрибута из описания блока и из всех вхождений блоков

Для обновления измененных атрибутов в существующих вхождениях блоков

Для обновления атрибутов во вхождениях, связанных с выбранным описанием блока

Для переноса объекта на другой слой

Для назначения цвета слою

Для назначения цвета объекту для использования вместо цвета слоя

Для назначения типа линий слою

Для назначения типа линий объекту для использования вместо типа линий слоя

Для изменения описания имеющегося блока

Для расчленения блока

Управление свойствами при расчленении объекта

Для удаления описания блока


Создание и использование блоков (символов) - Команды

Создание и редактирование объектов
Создание и использование блоков (символов)
Понятия
Процедуры
Команды
Команды
АТОПР | Создание описаний атрибутов
АТРЕД | Изменение данных в атрибутах
АТРЕДАКТ | Редактирование атрибутов во вхождениях блоков
АТРИЗВЛЕЧЬ | Экспорт информации атрибута блока в таблицу или внешний файл
АТРОБНОВИТЬ | Обновление всех экземпляров указанного блока с текущими атрибутами, заданными для блока
АТЭКР | Выполняет общий контроль видимости атрибутов блока в чертеже
АТЭКСП | Извлекает данные атрибута, т.е. связанный с блоком информационный текст, в файл
БАЗА | Задание базовой точки вставки для текущего чертежа
БЛОК | Создание описания блока из выбранных объектов
БЛОКНАБРУЧ | Создает, удаляет или выполняет сброс ручек, связанных с параметром
БЛОКПАЛВАР | Открытие окна "Палитры вариации блоков" в редакторе блоков.
БЛОКПАЛВАРЗАКР | Закрывает окно "Палитры вариации блоков" в редакторе блоков
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКПОКАЗАТЬ | Делает объекты видимыми в текущем или во всех состояниях видимости в описании динамического блока
БЛОКПОРАТР | Задание порядка атрибутов для блока
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТИНСТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКРЕДЗАКР | Закрывает редактор блоков
БЛОКСКРЫТЬ | Делает объекты невидимыми в текущем или во всех состояниях видимости в описании динамического блока
БЛОКСОСТВИД | Создает, устанавливает или удаляет состояние видимости в динамическом блоке
БЛОКСОХР | Сохраняет текущее описание блока
БЛОКСОХРКАК | Сохраняет копию текущего описания блока под новым именем
БЛОКТАБЛВЫБ | Отображает или создает таблицу выбора для описания динамического блока
БПОРЦИКЛ | Изменяет порядок циклического перебора ручек для вхождения динамического блока
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
ДИСПАТБЛК | Редактирование свойств атрибутов в описаниях блоков
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОЙ | Восстановление стертых объектов
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
ПБЛОК | Запись объектов или блока в новый файл чертежа
ПОДЕЛИТЬ | Размещение по длине или периметру объекта на равном расстоянии точек или блоков
РАЗМЕТИТЬ | Размещение на объекте точек или блоков с равными интервалами
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
РЕГЕН | Регенерация чертежа и перерисовка содержимого текущего видового экрана
СБРОСБЛОКА | Сбрасывает одно или несколько вхождений динамических блоков на значения описаний блоков по умолчанию.
СВОЙСТВА | Изменяет свойства объекта
СЛОЙ | Управление слоями и их свойствами
ТИПЛИН | Загрузка, установка и изменение типов линий
УРЛРАЗОРВАТЬ | Удаление гиперссылок в чертеже
УРЛСВЯЗАТЬ | Создает гиперссылки для объектов или областей чертежа
Цвет | Установка цвета для вновь создаваемых объектов
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
AFLAGS | Задание параметров для атрибутов
ATTDIA | Контроль команды ВСТАВИТЬ: используется ли диалоговое окно для указания значения атрибута.
ATTMODE | Управление отображением атрибутов
ATTREQ | Контроль использования командой ВСТАВИТЬ настроек по умолчанию для атрибутов в процессе вставки блоков.
BACTIONCOLOR | Установка цвета текста для операций, выполняемых в редакторе блоков
BDEPENDENCYHIGHLIGHT | Управление наличием выделенных взаимосвязей в зависимых объектах, когда параметр, действие или сетка выбраны в редакторе блоков
BGRIPOBJCOLOR | Задает цвет ручек в редакторе блоков
BGRIPOBJSIZE | Установка отображаемого размера настраиваемых ручек в редакторе блоков относительно экранной системы
BLOCKEDITLOCK | Запрет открытия редактора блоков и редактирование определений динамических блоков
BLOCKEDITOR | Отражает состояние редактора блока: открыт или не открыт
BPARAMETERCOLOR | Задает цвет параметров в редакторе блоков
BPARAMETERFONT | Задает шрифт, используемый для параметров и операций в редакторе блоков
BPARAMETERSIZE | Установка размера текста и функций параметра в редакторе блоков относительно экранной системы
BTMARKDISPLAY | Управляет отображением меток наборов значений для вхождений динамического блока
BVMODE | Управление способом отображения объектов, которые становятся невидимыми для текущего состояния видимости, в редакторе блока
GRIPDYNCOLOR | Управляет цветом специальных ручек для динамических блоков
INSNAME | Устанавливает имя блока по умолчанию для команды ВСТАВИТЬ
INSUNITS | Указывает значение в единицах чертежа для автоматического масштабирования блоков, изображений или вставленных или прикрепленных к чертежу внешних ссылок
INSUNITSDEFSOURCE | Устанавливает единицы измерения исходного содержимого, когда переменная INSUNITS имеет значение, равное 0
INSUNITSDEFTARGET | Устанавливает единицы измерения в целевом чертеже, когда переменная INSUNITS имеет значение, равное 0
MAXSORT | Устанавливает максимальное количество имен символов или имен файлов, которое можно отсортировать с помощью команд вывода списков
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Базовые понятия для блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Базовые понятия для блоков
Понятия
Процедуры
Команды

Пользователь имеет возможность создавать блоки, применяя различные способы.

  • Объединение объектов для создания описания блока в текущем чертеже.
  • С помощью редактора блоков можно добавлять функции динамического изменения в описание блока в текущем чертеже.
  • Создание файла чертежа с последующей его вставкой в качестве блока в другой чертеж.
  • Создание файла чертежа с несколькими описаниями логически родственных блоков для использования в качестве библиотеки компонентов.

Блоки могут состоять из объектов, изначально находившихся на различных слоях и имевших различные цвета, типы линий и веса линий. Хотя вставляемый блок всегда размещается на текущем слое, для каждого объекта, входящего в блок сохраняется информация об исходных слоях, цветах и типах линий. Пользователь может сохранять исходные свойства объектов блока или использовать настройки текущего слоя и текущие значения цвета, типа и веса линий.

Описание блока может также содержать элементы, которые добавляют функции динамического изменения для блока. Они добавляются с помощью редактора блоков. При добавлении функций динамического изменения в блок добавляется гибкость и интеллектуальные возможности для геометрии. После вставки в чертеж вхождения блока с функциями динамического изменения можно манипулировать геометрией вхождения блока с помощью настраиваемых ручек или настраиваемых свойств в зависимости от того, как был определен блок.

Неиспользуемые в чертеже описания блоков можно удалить командой ОЧИСТИТЬ.


Создание и использование блоков (символов)

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание и использование блоков (символов)
Понятия
Процедуры
Команды

Нет процедур.


Базовые понятия для блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Базовые понятия для блоков
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
ПБЛОК | Запись объектов или блока в новый файл чертежа
Системные переменные
MAXSORT | Устанавливает максимальное количество имен символов или имен файлов, которое можно отсортировать с помощью команд вывода списков
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и сохранение блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание и сохранение блоков
Понятия
Процедуры
Команды

Создание блока предполагает объединение объектов в группу под определенным именем. С блоком также можно связать дополнительные информационные записи (атрибуты).

  • Хранение и использование блоков
    В каждом файле чертежа имеется область данных, называемая таблицей описаний блоков. В ней содержатся все описания блоков. Именно отсюда извлекается информация для формирования вхождений блоков в чертеж.
  • Создание блоков в чертеже
    После того как создано описание блока, его вхождение можно многократно размещать на чертеже. Этот метод можно использовать для быстрого создания множества идентичных графических структур.
  • Создание библиотек компонентов
    Библиотека компонентов представляет собой файл чертежа, в котором хранится набор описаний блоков. Пользователь может использовать библиотеки компонентов, поставляемые Autodesk и другими разработчиками, а также создавать свои собственные библиотеки.
  • Сохранение блока в отдельном файле
    Имеется возможность создания файлов чертежей для использования их в качестве блоков.
  • Использование палитр инструментов для организации блоков
    С помощью инструментальной палитры можно упорядочивать блоки, хранящиеся в одном файле или в отдельных файлах чертежей.


Создание и сохранение блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание и сохранение блоков
Понятия
Процедуры
Команды

Для создания описания блока в текущем чертеже

Для создания библиотеки компонентов

Для сохранения выбранных объектов в новом файле

Для редактирования текстового пояснения к блоку


Создание и сохранение блоков - Команды

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание и сохранение блоков
Понятия
Процедуры
Команды
Команды
БАЗА | Задание базовой точки вставки для текущего чертежа
БЛОК | Создание описания блока из выбранных объектов
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
ОЙ | Восстановление стертых объектов
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
ПБЛОК | Запись объектов или блока в новый файл чертежа
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Хранение и использование блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Хранение и использование блоков
Понятия
Процедуры
Команды

В каждом файле чертежа имеется область данных, называемая таблицей описаний блоков. В ней содержатся все описания блоков. Именно отсюда извлекается информация для формирования вхождений блоков в чертеж. На следующих иллюстрациях схематично показаны структуры трех файлов чертежей. Каждый прямоугольник, разделенный на две части, представляет файл чертежа. Малая часть прямоугольника обозначает таблицу описаний блоков, большая часть - объекты чертежа.

При вставке блока в чертеже появляется так называемое вхождение блока. Данные не просто копируются из описания блока в область рисования, устанавливается связь между описанием и вхождением блока. Таким образом, при изменении описания блока все соответствующие вхождения автоматически обновляются.

Для сокращения размера чертежа неиспользуемые описания блоков можно удалить.


Создание и сохранение блоков

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание и сохранение блоков
Понятия
Процедуры
Команды

Нет процедур.


Хранение и использование блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Хранение и использование блоков
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание блоков в чертеже - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание блоков в чертеже
Понятия
Процедуры
Команды

После того как создано описание блока, его вхождение можно многократно размещать на чертеже. Этот метод можно использовать для быстрого создания множества идентичных графических структур.

Каждое описание блока включает в себя имя блока, один или несколько объектов, координаты базовой точки, используемой для вставки блока, а также атрибуты, хранящие произвольную дополнительную информацию.

Базовая точка определяет положение вхождения блока на чертеже при его вставке. Как правило, базовая точка указывается в нижнем левом углу объекта, входящего в блок. При вставке блока выдается запрос указания точки вставки. Вхождение блока размещается таким образом, чтобы базовая точка совпадала с указанной в ответ на запрос.

Описание блока, приведенное на рисунке, содержит имя PLUG_VALVE, четыре отрезка и базовую точку на месте пересечения двух диагональных отрезков. Описание изображенной на чертеже схемы приводится в разделе Базовые понятия для блоков.

На следующем чертеже показана типичная последовательность действий при создании описания блока внутри чертежа.

С помощью редактора блоков можно также создавать блоки, которые сохраняются внутри чертежа. Для получения более подробных сведений об использовании редактора блоков см. Использование редактора блоков.


Для создания описания блока в текущем чертеже - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание блоков в чертеже
Понятия
Процедуры
Команды

Для создания описания блока в текущем чертеже

  1. Создать объекты, предназначенные для формирования блока.
  2. Из меню "Рисование" выбрать "Блок" » "Создать".
  3. В диалоговом окне "Описание блока" ввести имя блока.
  4. В группе "Объекты" отметить опцию "Сделать блоком".

    5. Если необходимо, чтобы выбранные объекты после создания описания блока не удалялись, следует убедиться, что отключена опция "Удалить". В противном случае, выбранные объекты будут удалены из чертежа. При необходимости можно восстанавливать объекты с помощью команды ОЙ.

  5. Нажмите кнопку "Выбор объектов".
  6. Выберите с помощью устройства указания объекты для создания описания блока. Для завершения выбора объектов нажмите ENTER.
  7. В группе "Базовая точка" диалогового окна "Описание блока" задать координаты базовой точки вставки одним из способов:
    • Нажать кнопку "Указать" для выбора базовой точки с помощью устройства указания.
    • Ввести координаты X,Y,Z точки.
  8. В поле "Пояснение" ввести текстовое пояснение для облегчения идентификации блока. Данное описание отображается в окне Центра управления™ (ЦУВКЛ).
  9. Нажать "ОК".

    10. Описание блока сохраняется в текущем чертеже и может быть вставлено, как только это потребуется.

Панель Рисование

Ввод команды: БЛОК


Создание блоков в чертеже - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Создание блоков в чертеже
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание библиотек компонентов - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание библиотек компонентов
Понятия
Процедуры
Команды

Библиотека компонентов представляет собой файл чертежа, в котором хранится набор описаний блоков. Пользователь может использовать библиотеки компонентов, поставляемые Autodesk и другими разработчиками, а также создавать свои собственные библиотеки.

Набор родственных описаний блоков можно объединить и сохранить в виде одного файла чертежа. Файлы чертежей, созданные таким образом, называются библиотеками компонентов. Во время работы с чертежом пользователь может вставлять из библиотеки компонентов отдельные описания блоков. Файлы библиотек компонентов, кроме своего функционального предназначения, ничем не отличаются по структуре от других файлов чертежей.

При создании каждого описания блока в библиотеке компонентов с помощью команды БЛОК можно задать короткое пояснение к блоку, которое выводится в Центре управления.

При необходимости, в графическую область чертежа библиотеки компонентов можно вставить тексты, поясняющие каждый блок. Здесь, например, указывается имя блока, дата создания, дата внесения последних изменений и т.п. Это позволяет наглядно представлять себе содержание библиотеки.

Для просмотра и копирования отдельных описаний блоков из библиотеки компонентов и других имеющихся файлов чертежей в текущий чертеж можно использовать Центр управления. При копировании одноименного описания блока уже имеющийся в чертеже блок не удаляется.


Для создания библиотеки компонентов - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание библиотек компонентов
Понятия
Процедуры
Команды

Для создания библиотеки компонентов

  1. Создать новый чертеж.
  2. Создать описание блока.
  3. При необходимости, повторить пункт 2 для создания нескольких блоков.
  4. Сохранить чертеж с нужным именем.

    5. Эти блоки можно вставлять в любой чертеж с помощью Центра управления (команда ЦУВКЛ).

Панель Рисование

Ввод команды: БЛОК


Создание библиотек компонентов - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Создание библиотек компонентов
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение блока в отдельном файле - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Сохранение блока в отдельном файле
Понятия
Процедуры
Команды

Пользователь может создавать файлы чертежей для вставки их в другие чертежи в качестве блоков. Создавать отдельные файлы чертежей как источники описаний блоков и манипулировать ими достаточно легко. Библиотеки компонентов можно также сохранить в виде отдельных файлов чертежей и сгруппировать их по папкам.

Создание нового файла чертежа

Новый файл чертежа можно создать двумя способами:

  • Создать и сохранить готовый чертеж в файл с помощью команд СОХРАНИТЬ или СОХРАНИТЬКАК.
  • Создать и сохранить только выбранные объекты из текущего чертежа в новый файл с помощью команд ЭКСПОРТ или ПБЛОК.

При любом способе создается обычный файл чертежа, который можно вставлять в качестве блока в любой другой чертеж. Если требуется создание нескольких версий символа в виде отдельных файлов чертежей либо требуется создание файла чертежа без выхода из текущего чертежа, рекомендуется использовать команду ПБЛОК.

Изменение базовой точки чертежа, используемого как блок

По умолчанию AutoCAD определяет базовую точку чертежа, используемого как блок, в начале координат (0,0,0) МСК (Мировой системы координат). Точку вставки можно изменить, открыв исходный чертеж и задав с помощью команды БАЗА другую базовую точку вставки. При очередной вставке блока используется уже новая базовая точка.

Обновление чертежа

Изменение исходного чертежа блока не оказывает действия на текущий чертеж. Если необходимо, чтобы все изменения были видны на текущем чертеже, то вместо вставки блока следует выполнить вставку исходного чертежа в качестве внешней ссылки. Подробнее о внешних ссылках см. в разделе Внешние ссылки.

Использование объектов пространства листа в блоках

При вставке чертежа в качестве блока все объекты пространства листа, содержащиеся в нем, игнорируются. Чтобы иметь возможность вставлять в другие чертежи в виде блоков объекты листа, следует преобразовать эти объекты в отдельный блок или сохранить их в отдельном файле чертежа.


Сохранение блока в отдельном файле - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Сохранение блока в отдельном файле
Понятия
Процедуры
Команды

Для сохранения выбранных объектов в новом файле

Для редактирования текстового пояснения к блоку


Для сохранения выбранных объектов в новом файле - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Сохранение блока в отдельном файле
Понятия
Процедуры
Команды

Для сохранения выбранных объектов в новом файле

  1. Открыть имеющийся чертеж или создать новый.
  2. В командной строке ввести пблок.
  3. В диалоговом окне "Запись блока на диск" установить переключатель "Источник данных" в положение "Объекты".

    4. Если необходимо, чтобы выбранные объекты после создания нового чертежа не удалялись, отключить опцию "Удалить из чертежа". В противном случае, выбранные объекты будут удалены из чертежа. При необходимости можно восстанавливать объекты с помощью команды ОЙ.

  4. Нажать кнопку "Выбор объектов".
  5. Выбрать с помощью устройства указания объекты для создания нового чертежа. Для завершения выбора объектов нажмите ENTER.
  6. В группе "Базовая точка" задать базовую точку вставки создаваемого чертежа одним из способов:
    • Нажать кнопку "Указать" для выбора базовой точки с помощью устройства указания.
    • Ввести координаты X,Y,Z точки.
  7. В группе "Размещение" ввести имя и путь для нового файла чертежа.
  8. Нажать "ОК".

    9. Выбранные объекты сохраняются в новом файле чертежа.

Ввод команды: ПБЛОК


Для редактирования текстового пояснения к блоку - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Сохранение блока в отдельном файле
Понятия
Процедуры
Команды

Для редактирования текстового пояснения к блоку

  1. Из меню "Редакт" выберите "Объекты" » "Пояснение к блоку".
  2. В диалоговом окне "Описание блока" выбрать нужный блок.
  3. Ввести новое имя.
  4. В поле "Пояснение" ввести новое или изменить имеющееся текстовое пояснение для блока.
  5. Нажать "ОК".

Ввод команды: БЛОК


Сохранение блока в отдельном файле - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Сохранение блока в отдельном файле
Понятия
Процедуры
Команды

Команды
БАЗА | Задание базовой точки вставки для текущего чертежа
БЛОК | Создание описания блока из выбранных объектов
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
ОЙ | Восстановление стертых объектов
ПБЛОК | Запись объектов или блока в новый файл чертежа
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование палитр инструментов для организации блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование палитр инструментов для организации блоков
Понятия
Процедуры
Команды

С помощью инструментальной палитры можно упорядочивать блоки, хранящиеся в одном файле или в отдельных файлах чертежей.

После добавления инструмента блока в инструментальную палитру можно легко вставить вхождение блока в чертеж, перетащив его из инструментальной палитры в чертеж или щелкнув и разместив его на чертеже. Для получения сведений об использовании инструментальных палитр для организации и вставки блоков см. раздел Создание инструментов из объектов и работа с ними.


Использование палитр инструментов для организации блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Использование палитр инструментов для организации блоков
Понятия
Процедуры
Команды

Команды
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление функций динамического изменения в блоки - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Добавление функций динамического изменения в блоки
Понятия
Процедуры
Команды

При добавлении функций динамического изменения в определения блока добавляется гибкость и интеллектуальные возможности для геометрии. Блок уже не является фиксированной частью чертежа. Вхождение динамического блока можно изменять или манипулировать по мере работы с чертежом.

  • Быстрое начало работы по созданию динамических блоков
    Чтобы добавить функции динамического изменения в новые или существующие описания блоков, необходимо добавить параметры или операции с блоком в редакторе блоков.
  • Обзор динамических блоков
  • Использование редактора блоков
    С помощью редактора блоков можно добавлять в блоки функции динамического изменения. Редактор блоков содержит все необходимые инструменты для добавления в блоки интеллектуальных возможностей и достижения большей гибкости в работе.
  • Добавление в блоки динамических элементов
    Чтобы создать динамический блок, необходимо добавить в описание блока определенные элементы.
  • Сохранение блока в редакторе блоков
    По завершении добавления элементов в описание динамических блоков в редакторе блоков сохраните описание блоков.


Добавление функций динамического изменения в блоки - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Добавление функций динамического изменения в блоки
Понятия
Процедуры
Команды

Чтобы открыть существующее описание блока в редакторе блоков

Чтобы создать новое описание блока в редакторе блоков

Чтобы открыть блок на инструментальной палитре редакторе блоков

Чтобы открыть блок из окна Центра управления в редакторе блоков

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (но не динамический)

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок

Чтобы просмотреть свойства описания блока в редакторе блоков

Чтобы просмотреть свойства объектов в редакторе блоков

Чтобы закрыть редактор блоков

Чтобы запретить доступ к редактору блоков

Чтобы отобразить или скрыть окно "Палитры вариации блоков" в редакторе блоков

Чтобы создать копию набора параметров

Чтобы добавить операцию в набор параметров

Чтобы удалить операцию из параметра или набора параметров

Чтобы указать цвет отображения для параметров в редакторе блоков

Чтобы указать размер текста для параметров и операций в редакторе блоков

Чтобы указать шрифт для параметров в редакторе блоков

Чтобы указать цвет текста для операций в редакторе блоков

Чтобы указать отображаемый размер ручек в редакторе блоков

Чтобы указать отображаемый цвет ручек в редакторе блоков

Чтобы обновить текст или отображаемый размер ручки в указанных значениях в редакторе блоков

Чтобы указать, должны ли быть видны в редакторе блоков объекты, которые являются невидимыми для состояния видимости

Чтобы включить или отключить выделение зависимостей в редакторе блоков

Чтобы определить, должны ли отображаться метки наборов значений (засечки)

Чтобы создать динамический блок

Чтобы добавить в описание динамического блока параметр точки

Чтобы добавить в описание динамического блока линейный параметр

Чтобы добавить в описание динамического блока полярный параметр

Чтобы добавить в описание динамического блока параметр XY

Чтобы добавить в описание динамического блока параметр поворота

Чтобы добавить в описание динамического блока параметр выравнивания

Чтобы добавить в описание динамического блока параметр отражения

Чтобы добавить в описание динамического блока параметр видимости

Чтобы добавить в описание динамического блока параметр выбора

Чтобы добавить в описание динамического блока параметр базовой точки

Для добавления операции перемещения в описание динамических блоков

Для указания свойства "Тип расстояния" для операции перемещения, связанной с параметром XY

Для добавления операции масштабирования в описание динамических блоков

Для указания независимой базовой точки для операции масштабирования в описании динамических блоков

Для указания свойства "Тип масштаба" для операции масштабирования, связанной с параметром XY

Для добавления операции растягивания в описание блока

Для указания свойства "Тип расстояния" для операции растягивания, связанной с параметром XY

Для добавления операции полярного растягивания в описание блока

Для добавления операции поворота в описание блока

Для добавления операции отражения в описание блока

Чтобы добавить в описание блока операцию с массивом

Для добавления операции поиска в описание динамических блоков

Задание переопределения коэффициента расстояния для операции

Задание переопределения смещения угла для операции

Добавление набора параметров в описание динамического блока

Для указания количества специальных ручек, отображаемых для параметра в динамическом блоке

Чтобы переместить ручку в описании динамического блока

Чтобы восстановить для ручек в описании динамического блока положения по умолчанию

Чтобы включить или отключить циклический перебор для ручки настройки во вхождении динамического блока

Для изменения порядка перебора при вставке для специальных ручек в динамическом блоке

Для включения состояний видимости (добавить параметр видимости)

Для создания нового состояния видимости на основе текущего состояния

Для создания нового состояния видимости, в котором все объекты являются невидимыми.

Для создания нового состояния видимости, в котором все объекты являются видимыми

Чтобы сделать состояние видимости текущим

Для удаления состояния видимости

Для задания нового имени состоянию видимости

Чтобы сделать объекты видимыми в текущем состоянии видимости

Чтобы сделать объекты видимыми во всех состояниях видимости

Чтобы сделать объекты невидимыми в текущем состоянии видимости.

Чтобы сделать объекты невидимыми во всех состояниях видимости

Для отображения или скрытия невидимой геометрии для состояний видимости.

Для изменения порядка в списке состояний видимости для вхождения динамического блока

Для установки состояния видимости по умолчанию для вхождения динамического блока.

Для создания таблицы выбора для динамического блока

Для добавления свойств входа в таблицу выбора.

Для добавления свойств поиска в таблицу выбора.

Для добавления значений в таблицу выбора

Для включения обратного поиска

Чтобы сделать свойство поиска только для чтения

Для проверки на наличие ошибок в таблице выбора

Для открытия существующей таблицы выбора

Для указания ярлыка параметра

Для указания отображения настраиваемых свойств во вхождении динамического блока.

Для указания расчленения вхождения динамического блока

Для запрета неоднородного масштабирования во вхождении динамического блока.

Для указания набора значений для линейного или полярного параметра

Для указания набора значений для параметра XY

Для указания набора значений для параметра поворота

Для удаления значений из набора значений параметра

Для указания набора значений приращения для линейного, полярного параметра, параметра XY или поворота.

Для указания минимального и максимального значений для линейного, полярного параметра, параметра XY или поворота.

Для указания свойства "Цепочка операций" для линейного, полярного параметра, параметра точки, XY и поворота

Чтобы открыть существующее описание динамического блока в редакторе блоков

Удаление элемента из описания динамических блоков

Изменение набора объектов для операции в описании динамических блоков

Переопределение растяжения или набора рамок растяжения для операции полярного растяжения в описании динамических блоков

Исправление ошибки, обозначаемой желтым значком предупреждения в описании динамических блоков

Просмотр зависимостей внутри описания динамических блоков

Сохранение описания блоков в редакторе блоков

Сохранение копии текущего описания блоков в редакторе блоков под другим именем


Добавление функций динамического изменения в блоки - Команды

Создание и редактирование объектов
Создание и использование блоков (символов)
Добавление функций динамического изменения в блоки
Понятия
Процедуры
Команды
Команды
БЛОК | Создание описания блока из выбранных объектов
БЛОКНАБРУЧ | Создает, удаляет или выполняет сброс ручек, связанных с параметром
БЛОКПАЛВАР | Открытие окна "Палитры вариации блоков" в редакторе блоков.
БЛОКПАЛВАРЗАКР | Закрывает окно "Палитры вариации блоков" в редакторе блоков
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКПОКАЗАТЬ | Делает объекты видимыми в текущем или во всех состояниях видимости в описании динамического блока
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТИНСТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКРЕДЗАКР | Закрывает редактор блоков
БЛОКСКРЫТЬ | Делает объекты невидимыми в текущем или во всех состояниях видимости в описании динамического блока
БЛОКСОСТВИД | Создает, устанавливает или удаляет состояние видимости в динамическом блоке
БЛОКСОХР | Сохраняет текущее описание блока
БЛОКСОХРКАК | Сохраняет копию текущего описания блока под новым именем
БЛОКТАБЛВЫБ | Отображает или создает таблицу выбора для описания динамического блока
БПОРЦИКЛ | Изменяет порядок циклического перебора ручек для вхождения динамического блока
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
РЕГЕН | Регенерация чертежа и перерисовка содержимого текущего видового экрана
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
BACTIONCOLOR | Установка цвета текста для операций, выполняемых в редакторе блоков
BDEPENDENCYHIGHLIGHT | Управление наличием выделенных взаимосвязей в зависимых объектах, когда параметр, действие или сетка выбраны в редакторе блоков
BGRIPOBJCOLOR | Задает цвет ручек в редакторе блоков
BGRIPOBJSIZE | Установка отображаемого размера настраиваемых ручек в редакторе блоков относительно экранной системы
BLOCKEDITLOCK | Запрет открытия редактора блоков и редактирование определений динамических блоков
BLOCKEDITOR | Отражает состояние редактора блока: открыт или не открыт
BPARAMETERCOLOR | Задает цвет параметров в редакторе блоков
BPARAMETERFONT | Задает шрифт, используемый для параметров и операций в редакторе блоков
BPARAMETERSIZE | Установка размера текста и функций параметра в редакторе блоков относительно экранной системы
BVMODE | Управление способом отображения объектов, которые становятся невидимыми для текущего состояния видимости, в редакторе блока
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Быстрое начало работы по созданию динамических блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Быстрое начало работы по созданию динамических блоков
Понятия
Процедуры
Команды

Чтобы добавить функции динамического изменения в новые или существующие описания блоков, необходимо добавить параметры или операции с блоком в редакторе блоков. В следующем примере показан блок рабочего стола в редакторе блоков. В блоке содержится линейный параметр, отображаемый аналогично размеру и обозначаемый “Расстояние”, и указывается операция растягивания с отображением болта грозозащиты и метки “Растяжениеh”.

Чтобы сделать блок динамическим, необходимо добавить хотя бы один параметр. Затем добавляется операция, после чего она связывается с параметром. Типы добавляемых в описание блоков параметров и операций определяют, как будет работать вхождение блока в чертеже. Чтобы просмотреть, как параметры и операции добавляются в блок, см. Семинар по новым возможностям. Выберите "Справка" » "Новые возможности" » "Создание" » "Динамические блоки".

Подробнее о создании динамических блоков см.:

  • Обзор динамических блоков
  • Обзор элементов динамических блоков


Быстрое начало работы по созданию динамических блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Быстрое начало работы по созданию динамических блоков
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор динамических блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор динамических блоков
Понятия
Процедуры
Команды

Динамический блок обладает гибкостью и интеллектуальными возможностями. Вхождение динамического блока можно легко изменить на чертеже во время работы. Для изменения геометрии во вхождении динамического блока можно использовать настраиваемые ручки или настраиваемые свойства. Это позволяет изменять блок на месте, вместо того чтобы искать другой блок для вставки или уточнять описание существующего блока.

Например в случае вставки в чертеж вхождения блока может потребоваться изменить размер двери во время редактирования чертежа. Если блок является динамическим и в описании указано, что он имеет настраиваемый размер, то чтобы изменить размер двери, достаточно перетащить ручку настройки или указать другой размер в палитре "Свойства". Возможно, также потребуется изменить угол открытия двери. Дверной блок также может содержать ручку выравнивания, которая позволяет быстро выравнивать вхождение дверного блока с другой геометрией на чертеже.

Динамические блоки создаются с помощью редактора блоков. Редактор блоков - это специальная область, в которой добавляются элементы, образующие динамический блок. Блоки можно создавать с самого начала или добавлять функции динамического изменения в описание существующего блока. Можно также создавать геометрию точно так же, как и в области рисования.

Затем в блок добавляются параметры и операции, чтобы сделать его динамическим. При добавлении этих элементов в блок добавляется гибкость и интеллектуальные возможности для его геометрии.

  • Параметры определяют настраиваемые свойства для динамического блока путем указания положений, расстояний и углов для геометрии в блоке.
  • Операции определяют, как будет двигаться или изменяться геометрия вхождения динамического блока при манипулировании в чертеже. При добавлении в блок операций их необходимо связать с параметрами и, как правило, с геометрией.

При добавлении параметра в описание блока в блок автоматически добавляются ручки и свойства настройки. Они используются для манипулирования вхождением блока в чертеже.

Процесс создания динамических блоков

Чтобы создать динамические блоки необходимым результатом, рекомендуется точно выполнить следующие действия. Этот процесс позволяет эффективно создавать динамические блоки.

Шаг 1. Содержимое динамических блоков необходимо спланировать перед созданием

Прежде чем создавать динамический блок, следует представить, как он должен выглядеть и как он будет использоваться на чертеже. Определите, какие объекты внутри блока будут изменяться или перемещаться при манипулировании вхождением динамического блока. Более того, следует определить, как эти объекты будут изменяться. Например, можно создать динамический блок с изменяемыми размерами. Кроме того, при изменении размера вхождения блока может отображаться дополнительная геометрия. Эти факторы определяют тип параметров и операций, добавляемых в описание блока, а также совместную работу параметров, операций и геометрии.

Шаг 2. Нарисуйте геометрию

Геометрию для динамического блока можно нарисовать в области рисования или в редакторе блоков. Можно также воспользоваться существующей геометрией на чертеже или описанием существующего блока.

Примечание Если для изменения свойств отображения геометрии во вхождениях динамических блоков используются состояния видимости, то на этом этапе можно не включать всю геометрию. Подробнее о работе с состояниями видимости см. в разделе Создать "Состояния видимости".

Шаг 3. Определите, как элементы блока будут взаимодействовать друг с другом

Прежде чем добавлять параметры и операции в описание блока, необходимо выяснить их взаимосвязи друг с другом, а также с геометрией внутри блока. При добавлении операции в описание блока необходимо связать операцию с параметром и набором объектов геометрии. При этом создается зависимость. При добавлении во вхождение динамического блока нескольких параметров для правильной работы вхождения блока в чертеже необходимо настроить правильные зависимости.

Например, можно создать динамический блок, содержащий несколько объектов. С некоторыми объектами связано действие растягивания. Требуется, чтобы все объекты вращались вокруг одной и той же базовой точки. В этом случае после добавления всех других параметров и операций необходимо добавить операцию поворота. Если операция поворота связана не со всеми другими объектами (геометрия, параметры и операции) в описании блока, части вхождения блока могут не вращаться или манипулирование блоками может приводить к неожиданных результатам.

Шаг 4. Добавление параметров

Добавьте соответствующие параметры в описание динамического блока, следуя подсказкам в командной строке. Для получения более подробных сведений об использовании параметров см. раздел Использование параметров в динамических блоках.

Примечание С помощью вкладки "Наборы параметров" палитр создания блоков можно добавлять одновременно параметр и связанную с ним операцию. Для получения более подробных сведений об использовании набора параметров см. раздел Использование наборов параметров.

Шаг 5. Добавьте операции

Добавьте соответствующие операции в описание динамического блока. Следуйте подсказкам в командной строке, не забывая указывать связи операций с соответствующими параметрами и геометрией. Для получения более подробных сведений об использовании операций см. раздел Обзор операций в динамических блоках.

Шаг 6. Определите, как будет выполняться манипулирование вхождением динамического блока

Можно указать, как будет выполняться манипулирование вхождением динамического блока на чертеже. Для манипулирования вхождением динамического блока можно использовать ручки или свойства настройки. При создании описания динамического блока можно определить, какие ручки отображаются и как они изменяют вхождение динамического блока. Можно также указать, должны ли свойства настройки отображаться в палитре "Свойства", а также можно ли эти свойства изменять с помощью палитры или с помощью ручек настройки.

Шаг 7. Сохраните блок, а затем попробуйте его вставить в чертеж

Сохраните описание динамического блока и выйдите из редактора блоков. Вставьте динамический блок в чертеж и проверьте его работу.

См. также

Сохранение блока в редакторе блоков


Добавление функций динамического изменения в блоки

Создание и редактирование объектов
Создание и использование блоков (символов)
Добавление функций динамического изменения в блоки
Понятия
Процедуры
Команды

Нет процедур.


Обзор динамических блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Обзор динамических блоков
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование редактора блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование редактора блоков
Понятия
Процедуры
Команды

С помощью редактора блоков можно добавлять в блоки функции динамического изменения. Редактор блоков содержит все необходимые инструменты для добавления в блоки интеллектуальных возможностей и достижения большей гибкости в работе.

  • Обзор редактора блоков
  • Использование палитр вариации блоков
    Редактор блока содержит три палитры вариации блоков: "Параметры", "Операции" и "Наборы параметров".
  • Как объекты отображаются в редакторе блоков
    Параметры, операции и их взаимосвязи (зависимости) отображаются по-разному в редакторе блоков. Можно указать настройки для некоторых из этих элементов.


Использование редактора блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование редактора блоков
Понятия
Процедуры
Команды

Чтобы открыть существующее описание блока в редакторе блоков

Чтобы создать новое описание блока в редакторе блоков

Чтобы открыть блок на инструментальной палитре редакторе блоков

Чтобы открыть блок из окна Центра управления в редакторе блоков

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (но не динамический)

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок

Чтобы просмотреть свойства описания блока в редакторе блоков

Чтобы просмотреть свойства объектов в редакторе блоков

Чтобы закрыть редактор блоков

Чтобы запретить доступ к редактору блоков

Чтобы отобразить или скрыть окно "Палитры вариации блоков" в редакторе блоков

Чтобы создать копию набора параметров

Чтобы добавить операцию в набор параметров

Чтобы удалить операцию из параметра или набора параметров

Чтобы указать цвет отображения для параметров в редакторе блоков

Чтобы указать размер текста для параметров и операций в редакторе блоков

Чтобы указать шрифт для параметров в редакторе блоков

Чтобы указать цвет текста для операций в редакторе блоков

Чтобы указать отображаемый размер ручек в редакторе блоков

Чтобы указать отображаемый цвет ручек в редакторе блоков

Чтобы обновить текст или отображаемый размер ручки в указанных значениях в редакторе блоков

Чтобы указать, должны ли быть видны в редакторе блоков объекты, которые являются невидимыми для состояния видимости

Чтобы включить или отключить выделение зависимостей в редакторе блоков

Чтобы определить, должны ли отображаться метки наборов значений (засечки)


Использование редактора блоков - Команды

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование редактора блоков
Понятия
Процедуры
Команды
Команды
БЛОКПАЛВАР | Открытие окна "Палитры вариации блоков" в редакторе блоков.
БЛОКПАЛВАРЗАКР | Закрывает окно "Палитры вариации блоков" в редакторе блоков
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКРЕДЗАКР | Закрывает редактор блоков
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
РЕГЕН | Регенерация чертежа и перерисовка содержимого текущего видового экрана
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
BACTIONCOLOR | Установка цвета текста для операций, выполняемых в редакторе блоков
BDEPENDENCYHIGHLIGHT | Управление наличием выделенных взаимосвязей в зависимых объектах, когда параметр, действие или сетка выбраны в редакторе блоков
BGRIPOBJCOLOR | Задает цвет ручек в редакторе блоков
BGRIPOBJSIZE | Установка отображаемого размера настраиваемых ручек в редакторе блоков относительно экранной системы
BLOCKEDITLOCK | Запрет открытия редактора блоков и редактирование определений динамических блоков
BLOCKEDITOR | Отражает состояние редактора блока: открыт или не открыт
BPARAMETERCOLOR | Задает цвет параметров в редакторе блоков
BPARAMETERFONT | Задает шрифт, используемый для параметров и операций в редакторе блоков
BPARAMETERSIZE | Установка размера текста и функций параметра в редакторе блоков относительно экранной системы
BVMODE | Управление способом отображения объектов, которые становятся невидимыми для текущего состояния видимости, в редакторе блока
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор редактора блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Редактор блоков - это специальная область, в которой создаются описания блоков и добавляются возможности динамического изменения.

Редактор блоков содержит специальные палитры вариации. Эти палитры обеспечивают быстрый доступ к инструментам для разработки блоков.

Кроме палитр для создания блоков, в редакторе блоков имеется область рисования, в которой можно рисовать и изменять геометрию, как в основной области рисования программы. Можно указать цвет фона в области рисования редактора блоков.

Примечание В редакторе блоков можно использовать большинство команд. При вводе команды, которая недопустима в редакторе блоков, в командной строке отображается сообщение.

С помощью редактора блоков можно редактировать описания блоков, существующих в текущем чертеже, и добавлять в них функции динамического изменения. С помощью него также можно создавать новые описания блоков.

В редакторе блоков над областью рисования отображается специальная панель. На ней отображается имя редактируемого в настоящий момент описания блока, а также имеются инструменты для выполнения следующих операций.

  • Сохранение описания блока
  • Добавление параметра
  • Добавление операции
  • Задание атрибутов
  • Закрытие редактора блоков
  • Управление состоянием видимости

Чтобы просмотреть свойства любого параметра, ручки, операции или геометрического объекта, необходимо выбрать соответствующий элемент в редакторе блоков. Его свойства отобразятся в палитре свойств. При выборе объекта в редакторе блоков значения координат, отображаемые в палитре "Свойства", показывают пространство описания блока.

При работе в редакторе блоков должна отображается командная строка. В командной строке отображаются подсказки практически по всем аспектам создания динамических блоков.

ПСК в редакторе блоков

В области рисования в редакторе блоков отображается ПСК. Начальная точка значка UCS обозначает базовую точку блока. Чтобы изменить базовую точку для блока, можно переместить геометрию относительно исходной точки значка ПСК или добавить параметр базовой точки.

Команда ПСК не работает в редакторе блоков. В редакторе блоков можно открыть существующее описание 3D блока и назначить параметры для блока. Однако в параметрах будут игнорироваться все значения координат Z в пространстве блока. Поэтому вхождение бока нельзя изменять вдоль оси Z. Более того, при создании динамического блока, содержащего твердотельные объекты и добавлении в него таких операций, как перемещение, поворот и масштабирование, нельзя выполнять редактирование характеристик твердотельного объекта внутри вхождения динамического блока (например растяжение твердотельного объекта, перемещение отверстия в твердотельном объекте и т.д.).

См. также

Создание атрибутов


Обзор редактора блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Чтобы открыть существующее описание блока в редакторе блоков

Чтобы создать новое описание блока в редакторе блоков

Чтобы открыть блок на инструментальной палитре редакторе блоков

Чтобы открыть блок из окна Центра управления в редакторе блоков

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (но не динамический)

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок

Чтобы просмотреть свойства описания блока в редакторе блоков

Чтобы просмотреть свойства объектов в редакторе блоков

Чтобы закрыть редактор блоков

Чтобы запретить доступ к редактору блоков


Чтобы открыть существующее описание блока в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Чтобы открыть существующее описание блока в редакторе блоков

  1. Выберите меню "Сервис" » "Редактор блоков".
  2. В диалоговом окне "Редактирование описания блока" выполнить одно из следующих действий:
    • Выбрать описание блока из списка.
    • Выбрать <Текущий чертеж>, если чертеж является описанием блока, который требуется открыть.
  3. Нажать "ОК".

Панель Стандартная

Ввод команды: БЛОКРЕД

Контекстное меню: Щелкнуть выбранный блок правой кнопкой мыши. Выбрать "Редактор блоков".


Чтобы создать новое описание блока в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Чтобы создать новое описание блока в редакторе блоков

  1. Выберите меню "Сервис" » "Редактор блоков".
  2. В диалоговом окне "Редактирование описания блока" ввести имя для нового описания блоков.
  3. Нажать "ОК".
  4. В редакторе блоков щелкнуть "Сохранить описание блока".

    5. Примечание При этом описание блока будет сохранено, даже если в области рисования редактора блоков не было добавлено никаких объектов.

  5. Щелкнуть "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: БЛОКРЕД


Чтобы открыть блок на инструментальной палитре редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Чтобы открыть блок на инструментальной палитре редакторе блоков

  1. Если окно инструментальных палитр еще не открыто, выберите меню "Сервис" » "Палитры" » "Инструментальные палитры".
  2. Щелкнуть правой кнопкой мыши значок блока.
  3. Выбрать "Редактор блоков".

Примечание В инструментальной палитре блок может находиться в другом чертеже. Чертеж, содержащий описание блока, откроется в редакторе блоков.

Панель Стандартная

Ввод команды: ИНСТРПАЛВКЛ


Чтобы открыть блок из окна Центра управления в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Чтобы открыть блок из окна Центра управления в редакторе блоков

  1. Если окно "DesignCenter" ещё не открыто, выберите "Сервис" » "Палитры" » "DesignCenter".
  2. Щелкнуть правой кнопкой мыши значок блока.
  3. Выбрать "Редактор блоков".

Панель Стандартная

Ввод команды: ЦУВКЛ


Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (но не динамический) - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (но не динамический)

  1. Открыть файл чертежа, который был сохранен как блок.
  2. Выберите меню "Сервис" » "Редактор блоков".
  3. В диалоговом окне "Редактирование описания блока" выбрать <Текущий чертеж>.
  4. Нажать "ОК".

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок

  1. Открыть файл чертежа, который был сохранен как блок.

    2. Появится предупреждение, указывающее, что файл чертежа содержит элементы вариации.

  2. В диалоговом окне нажать "Да", чтобы открыть чертеж в редакторе блоков.

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Чтобы просмотреть свойства описания блока в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Чтобы просмотреть свойства описания блока в редакторе блоков

  1. Выберите меню "Сервис" » "Редактор блоков".
  2. В диалоговом окне "Редактирование описания блока" выполнить одно из следующих действий:
    • Выбрать описание блока из списка.
    • Выбрать <Текущий чертеж>, если чертеж является описанием блока, который требуется открыть.
  3. Нажать "ОК".
  4. Должно отобразиться окно "Палитра свойств". Если оно ещё не открыто, выберите "Сервис" » "Палитры" » "Свойства".
  5. В окне "Палитра свойств" в разделе "Блок" просмотреть свойства описания блока.

Панель Стандартная

Ввод команды: БЛОКРЕД


Чтобы просмотреть свойства объектов в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Чтобы просмотреть свойства объектов в редакторе блоков

  1. Выберите объект в редакторе блоков.
  2. Должно отобразиться окно "Палитра свойств". Если оно ещё не открыто, выберите "Сервис" » "Палитры" » "Свойства".
  3. В окне "Палитра свойств" просмотреть свойства выбранного объекта.

Панель Стандартная

Ввод команды: БЛОКРЕД

Контекстное меню: Щелкнуть правой кнопкой мыши на выбранном объекте. Нажать кнопку "Свойства".


Чтобы закрыть редактор блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Чтобы закрыть редактор блоков

  • В редакторе блоков щелкнуть "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКРЕДЗАКР


Чтобы запретить доступ к редактору блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Чтобы запретить доступ к редактору блоков

  1. В командной строке введите blockedtlock.
  2. Введите 1 и нажмите ENTER.


Обзор редактора блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Обзор редактора блоков
Понятия
Процедуры
Команды

Команды
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКРЕДЗАКР | Закрывает редактор блоков
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
BLOCKEDITLOCK | Запрет открытия редактора блоков и редактирование определений динамических блоков
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование палитр вариации блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование палитр вариации блоков
Понятия
Процедуры
Команды

Редактор блока содержит три палитры вариации блоков: "Параметры", "Операции" и "Наборы параметров".

Окно "Палитры вариации блоков" отображается только в редакторе блоков. С помощью этих палитр можно добавлять параметры и операции в описание динамического блока.

Создание инструментов для разработки блоков

Можно создавать собственные инструменты для разработки блоков. Чтоб сохранить инструменты по умолчанию в палитрах вариации блоков, необходимо создать новую палитру для собственных инструментов разработки блоков. Затем можно скопировать инструмент набора параметров из одной из существующих палитр и вставить копию в новую палитру. В диалоговом окне "Свойства инструмента" можно затем изменить свойства нового инструмента, включая следующие:

  • Описание инструмента
  • Тип параметра
  • Связанные операции
  • Важное свойство параметра, с которым связана операция (если таковая имеется)
  • Изображение инструментальной палитры

Из редактора блока нельзя перетаскивать параметры и операции в другие палитры.

См. также

Использование параметров в динамических блоках

Использование операций с динамическими блоками

Использование наборов параметров

Изменение свойств инструментов

Организация инструментальных палитр


Использование палитр вариации блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование палитр вариации блоков
Понятия
Процедуры
Команды

Чтобы отобразить или скрыть окно "Палитры вариации блоков" в редакторе блоков

Чтобы создать копию набора параметров

Чтобы добавить операцию в набор параметров

Чтобы удалить операцию из параметра или набора параметров


Чтобы отобразить или скрыть окно "Палитры вариации блоков" в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование палитр вариации блоков
Понятия
Процедуры
Команды

Чтобы отобразить или скрыть окно "Палитры вариации блоков" в редакторе блоков

  • В редакторе блоков на панели инструментов редактора блоков нажмите кнопку "Палитры вариации блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАЛВАР, БЛОКПАЛВАРЗАКР


Чтобы создать копию набора параметров - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование палитр вариации блоков
Понятия
Процедуры
Команды

Чтобы создать копию набора параметров

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Наборы параметров" щелкните правой кнопкой мыши набор параметров. Выберите "Копировать".
  2. Щелкните правой кнопкой мыши в любом месте на палитре, которую необходимо добавить набор параметров (но не на наборе параметров). Выберите "Вставить".


Чтобы добавить операцию в набор параметров - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование палитр вариации блоков
Понятия
Процедуры
Команды

Чтобы добавить операцию в набор параметров

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Наборы параметров" щелкните правой кнопкой мыши набор параметров. Нажать кнопку "Свойства".
  2. В диалоговом окне "Свойства инструмента" в разделе "Параметр" щелкните "Операции", а затем нажмите кнопку [...].
  3. В диалоговом окне "Добавление операций" в разделе "Добавляемый объект операции" выберите в списке операцию.
  4. Нажать "Добавить".
  5. (Необязательно) Повторить пункты 3 и 4, если нужно добавить дополнительные операции.
  6. Нажать "ОК".
  7. В диалоговом окне "Свойства инструмента" нажать "ОК".


Чтобы удалить операцию из параметра или набора параметров - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование палитр вариации блоков
Понятия
Процедуры
Команды

Чтобы удалить операцию из параметра или набора параметров

  1. В редакторе блоков в окне "Палитры вариации блоков" щелкните правой кнопкой мыши параметр или набор параметров. Нажать кнопку "Свойства".
  2. В диалоговом окне "Свойства инструмента" в разделе "Параметр" щелкните "Операции", а затем нажмите кнопку [...].
  3. В диалоговом окне "Добавление операций" в разделе "Список объектов операций" выберите в списке операцию.
  4. Нажать кнопку "Удалить".
  5. (Необязательно) Повторить пункты 3 и 4, если нужно удалить дополнительные операции.
  6. Нажать "ОК".
  7. В диалоговом окне "Свойства инструмента" нажать "ОК".


Использование палитр вариации блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Использование палитр вариации блоков
Понятия
Процедуры
Команды

Команды
БЛОКПАЛВАР | Открытие окна "Палитры вариации блоков" в редакторе блоков.
БЛОКПАЛВАРЗАКР | Закрывает окно "Палитры вариации блоков" в редакторе блоков
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
Системные переменные
BLOCKEDITOR | Отражает состояние редактора блока: открыт или не открыт
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Как объекты отображаются в редакторе блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Параметры, операции и их взаимосвязи (зависимости) отображаются по-разному в редакторе блоков. Можно указать настройки для некоторых из этих элементов.

Параметры

В редакторе блоков большинство параметров выглядят как размеры. Если создать набор значений (диапазон или список значений) для параметра, в местоположениях этих значений отображаются засечки.

Можно указать следующие настройки для параметров в редакторе блоков:

  • Цвет параметра
  • Текст параметра и размер стрелки
  • Шрифт параметра
  • Цвет ручки
  • Отображение меток наборов значений (засечек) для параметров

При использовании параметра видимости в описании динамического блока указывается, какие геометрические объекты являются невидимыми в заданном состоянии видимости. Можно указать отображается ли геометрия, которая делается невидимой для состояний видимости, в редакторе блоков. В следующем примере состояние видимости отображается в редакторе блоков. Геометрия, которая отображается серым цветом, является невидимой в этом состоянии видимости.

Операции

Для операции в редакторе блоков отображается имя и значок (вспышка молнии). В редакторе блоков для операций можно задать размер и цвет текста.

Ручки

Можно также задать размер ручки и цвет при отображении в редакторе блоков. Этот параметр не влияет на размер и цвет ручек во вхождении блока на чертеже.

Зависимости

При выборе в редакторе блоков параметра, ручки или операции, будут выделены все связанные объекты или зависимости. Этот процесс называется выделением зависимостей. Выделение зависимостей можно включать или отключать.

В следующем примере показано, как при выделении зависимостей создается эффект ореола для связанного параметра (Расстояние) и операции (Растянуть) при выборе в редакторе блоков ручки настройки.

В следующей таблице показано, какая выделяется зависимость при выборе элемента в редакторе блоков.

Выбранный объект в редакторе блоков | Объекты с выделенными взаимосвязями
Параметр | Связанные ручки и операции
Ручка | Связанный параметр или операции
Операция | Связанные параметры, ручки и набор объектов (геометрии)


Как объекты отображаются в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Чтобы указать цвет отображения для параметров в редакторе блоков

Чтобы указать размер текста для параметров и операций в редакторе блоков

Чтобы указать шрифт для параметров в редакторе блоков

Чтобы указать цвет текста для операций в редакторе блоков

Чтобы указать отображаемый размер ручек в редакторе блоков

Чтобы указать отображаемый цвет ручек в редакторе блоков

Чтобы обновить текст или отображаемый размер ручки в указанных значениях в редакторе блоков

Чтобы указать, должны ли быть видны в редакторе блоков объекты, которые являются невидимыми для состояния видимости

Чтобы включить или отключить выделение зависимостей в редакторе блоков

Чтобы определить, должны ли отображаться метки наборов значений (засечки)


Чтобы указать цвет отображения для параметров в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Чтобы указать цвет отображения для параметров в редакторе блоков

  1. В командной строке введите bparametercolor.
  2. Установить одно из возможных значений переменной:
    • ПОСЛОЮ
    • ПОБЛОКУ
    • Целое число в диапазоне от 1 до 255
    • Точное значение цвета задается тремя целыми числами в диапазоне от 1 до 255 в следующем формате: RGB:000,000,000.
  3. Нажать ENTER.


Чтобы указать размер текста для параметров и операций в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Чтобы указать размер текста для параметров и операций в редакторе блоков

  1. В командной строке введите bparametersize.
  2. Введите целое число от 1 до 255 (точек).
  3. Нажать ENTER.


Чтобы указать шрифт для параметров в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Чтобы указать шрифт для параметров в редакторе блоков

  1. В командной строке введите bparameterfont.
  2. Введите любой шрифт TrueType или SHX в системе.
  3. Нажать ENTER.


Чтобы указать цвет текста для операций в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Чтобы указать цвет текста для операций в редакторе блоков

  1. В командной строке введите bactioncolor.
  2. Установить одно из возможных значений переменной:
    • ПОСЛОЮ
    • ПОБЛОКУ
    • Целое число в диапазоне от 1 до 255.
    • Точное значение цвета задается тремя целыми числами в диапазоне от 1 до 255 в следующем формате: RGB:000,000,000.
  3. Нажать ENTER.


Чтобы указать отображаемый размер ручек в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Чтобы указать отображаемый размер ручек в редакторе блоков

  1. В командной строке введите bgripobjsize.
  2. Введите целое число от 1 до 255 (точек).
  3. Нажать ENTER.


Чтобы указать отображаемый цвет ручек в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Чтобы указать отображаемый цвет ручек в редакторе блоков

  1. В командной строке введите bgripobjcolor.
  2. Установить одно из возможных значений переменной:
    • ПОСЛОЮ
    • ПОБЛОКУ
    • Целое число в диапазоне от 1 до 255.
    • Точное значение цвета задается тремя целыми числами в диапазоне от 1 до 255 в следующем формате: RGB:000,000,000.
  3. Нажать ENTER.


Чтобы обновить текст или отображаемый размер ручки в указанных значениях в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Чтобы обновить текст или отображаемый размер ручки в указанных значениях в редакторе блоков

  • В редакторе блоков на панели инструментов редактора блоков щелкните "Обновление параметра и размер текста операции".

Примечание При увеличении или уменьшении в редакторе блоков, размер текста и ручки изменится пропорционально коэффициенту масштабирования. Однако можно обновить текст или отображаемый размер ручки в указанных значениях в редакторе блоков.

Ввод команды: РЕГЕН


Чтобы указать, должны ли быть видны в редакторе блоков объекты, которые являются невидимыми для состояния видимости - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Чтобы указать, должны ли быть видны в редакторе блоков объекты, которые являются невидимыми для состояния видимости

  1. В командной строке введите bvmode.
  2. Установить одно из возможных значений переменной:
    • 0 Указывает, что невидимые объекты не видны в редакторе блоков.
    • 1 Указывает, что невидимые объекты отображаются серым цветом в редакторе блоков.
  3. Нажать ENTER.

Панель инструментов редактора блоков


Чтобы включить или отключить выделение зависимостей в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Чтобы включить или отключить выделение зависимостей в редакторе блоков

  1. В командной строке введите bdependencyhighlight.
  2. Установить одно из возможных значений переменной:
    • 0 Выключает выделение зависимостей.
    • 1 Включает выделение зависимостей.
  3. Нажать ENTER.


Чтобы определить, должны ли отображаться метки наборов значений (засечки) - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Чтобы определить, должны ли отображаться метки наборов значений (засечки)

  1. В командной строке введите btmarkdisplay.
  2. Установить одно из возможных значений переменной:
    • 0 Указывает, что метки наборов значений не отображаются.
    • 1 Указывает, что метки наборов значений отображаются.
  3. Нажать ENTER.


Как объекты отображаются в редакторе блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Как объекты отображаются в редакторе блоков
Понятия
Процедуры
Команды

Команды
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
РЕГЕН | Регенерация чертежа и перерисовка содержимого текущего видового экрана
Системные переменные
BACTIONCOLOR | Установка цвета текста для операций, выполняемых в редакторе блоков
BDEPENDENCYHIGHLIGHT | Управление наличием выделенных взаимосвязей в зависимых объектах, когда параметр, действие или сетка выбраны в редакторе блоков
BGRIPOBJCOLOR | Задает цвет ручек в редакторе блоков
BGRIPOBJSIZE | Установка отображаемого размера настраиваемых ручек в редакторе блоков относительно экранной системы
BPARAMETERCOLOR | Задает цвет параметров в редакторе блоков
BPARAMETERFONT | Задает шрифт, используемый для параметров и операций в редакторе блоков
BPARAMETERSIZE | Установка размера текста и функций параметра в редакторе блоков относительно экранной системы
BVMODE | Управление способом отображения объектов, которые становятся невидимыми для текущего состояния видимости, в редакторе блока
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление в блоки динамических элементов - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Добавление в блоки динамических элементов
Понятия
Процедуры
Команды

Чтобы создать динамический блок, необходимо добавить в описание блока определенные элементы.

  • Обзор элементов динамических блоков
    Динамические элементы добавляются в описание блока в редакторе блоков. Кроме геометрии, динамический блок обычно содержит один или несколько параметров, а также одну или несколько операций.
  • Использование параметров в динамических блоках
    С помощью добавляемых в описание динамических блоков параметров определяются свойства настройки для блока, а также указываются положения, расстояния и углы для геометрии в блоке.
  • Использование операций с динамическими блоками
    Операции определяют способ перемещения или изменения геометрии динамического вхождения блока при выполнении операций с настраиваемыми свойствами вхождения блока в чертеже.
  • Использование наборов параметров
    Для добавления чаще всего парных параметров и операций в описание динамических блоков пользуйтесь вкладкой "Наборы параметров" окна "Палитры вариации блоков".
  • Указание ручек для динамических блоков
    При добавлении параметра в описание динамического блока, автоматически добавляются ручки настройки, связанные с ключевыми точками параметра.
  • Создать "Состояния видимости"
    Можно использовать состояния видимости, чтобы сделать геометрию видимой или невидимой в динамическом блоке. Один блок может иметь несколько состояний видимости.
  • Использовать таблицы выбора для назначения данных для динамических блоков
    Можно использовать таблицу выбора для определения и указания значений свойств для динамического блока.
  • Указание настраиваемых свойств для динамических блоков
    При создании динамического блока можно указать настраиваемые свойства для блока. Можно также указать, должны ли эти свойства отображаться в палитре "Свойства" при выборе вхождения блока на чертеже.
  • Изменение описаний динамических блоков
    Описания динамических блоков можно изменять в редакторе блоков.
  • Исправление ошибок в описаниях динамических блоков
    Желтый значок предупреждения отображается в редакторе блоков, если описание динамических блоков содержит ошибки или является неполным. Исправьте ошибки (или дополните блок), чтобы вхождение блока в чертеже работало правильно.


Добавление в блоки динамических элементов - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Добавление в блоки динамических элементов
Понятия
Процедуры
Команды

Чтобы создать динамический блок

Чтобы добавить в описание динамического блока параметр точки

Чтобы добавить в описание динамического блока линейный параметр

Чтобы добавить в описание динамического блока полярный параметр

Чтобы добавить в описание динамического блока параметр XY

Чтобы добавить в описание динамического блока параметр поворота

Чтобы добавить в описание динамического блока параметр выравнивания

Чтобы добавить в описание динамического блока параметр отражения

Чтобы добавить в описание динамического блока параметр видимости

Чтобы добавить в описание динамического блока параметр выбора

Чтобы добавить в описание динамического блока параметр базовой точки

Для добавления операции перемещения в описание динамических блоков

Для указания свойства "Тип расстояния" для операции перемещения, связанной с параметром XY

Для добавления операции масштабирования в описание динамических блоков

Для указания независимой базовой точки для операции масштабирования в описании динамических блоков

Для указания свойства "Тип масштаба" для операции масштабирования, связанной с параметром XY

Для добавления операции растягивания в описание блока

Для указания свойства "Тип расстояния" для операции растягивания, связанной с параметром XY

Для добавления операции полярного растягивания в описание блока

Для добавления операции поворота в описание блока

Для добавления операции отражения в описание блока

Чтобы добавить в описание блока операцию с массивом

Для добавления операции поиска в описание динамических блоков

Задание переопределения коэффициента расстояния для операции

Задание переопределения смещения угла для операции

Добавление набора параметров в описание динамического блока

Для указания количества специальных ручек, отображаемых для параметра в динамическом блоке

Чтобы переместить ручку в описании динамического блока

Чтобы восстановить для ручек в описании динамического блока положения по умолчанию

Чтобы включить или отключить циклический перебор для ручки настройки во вхождении динамического блока

Для изменения порядка перебора при вставке для специальных ручек в динамическом блоке

Для включения состояний видимости (добавить параметр видимости)

Для создания нового состояния видимости на основе текущего состояния

Для создания нового состояния видимости, в котором все объекты являются невидимыми.

Для создания нового состояния видимости, в котором все объекты являются видимыми

Чтобы сделать состояние видимости текущим

Для удаления состояния видимости

Для задания нового имени состоянию видимости

Чтобы сделать объекты видимыми в текущем состоянии видимости

Чтобы сделать объекты видимыми во всех состояниях видимости

Чтобы сделать объекты невидимыми в текущем состоянии видимости.

Чтобы сделать объекты невидимыми во всех состояниях видимости

Для отображения или скрытия невидимой геометрии для состояний видимости.

Для изменения порядка в списке состояний видимости для вхождения динамического блока

Для установки состояния видимости по умолчанию для вхождения динамического блока.

Для создания таблицы выбора для динамического блока

Для добавления свойств входа в таблицу выбора.

Для добавления свойств поиска в таблицу выбора.

Для добавления значений в таблицу выбора

Для включения обратного поиска

Чтобы сделать свойство поиска только для чтения

Для проверки на наличие ошибок в таблице выбора

Для открытия существующей таблицы выбора

Для указания ярлыка параметра

Для указания отображения настраиваемых свойств во вхождении динамического блока.

Для указания расчленения вхождения динамического блока

Для запрета неоднородного масштабирования во вхождении динамического блока.

Для указания набора значений для линейного или полярного параметра

Для указания набора значений для параметра XY

Для указания набора значений для параметра поворота

Для удаления значений из набора значений параметра

Для указания набора значений приращения для линейного, полярного параметра, параметра XY или поворота.

Для указания минимального и максимального значений для линейного, полярного параметра, параметра XY или поворота.

Для указания свойства "Цепочка операций" для линейного, полярного параметра, параметра точки, XY и поворота

Чтобы открыть существующее описание динамического блока в редакторе блоков

Удаление элемента из описания динамических блоков

Изменение набора объектов для операции в описании динамических блоков

Переопределение растяжения или набора рамок растяжения для операции полярного растяжения в описании динамических блоков

Исправление ошибки, обозначаемой желтым значком предупреждения в описании динамических блоков

Просмотр зависимостей внутри описания динамических блоков


Добавление в блоки динамических элементов - Команды

Создание и редактирование объектов
Создание и использование блоков (символов)
Добавление в блоки динамических элементов
Понятия
Процедуры
Команды
Команды
БЛОКНАБРУЧ | Создает, удаляет или выполняет сброс ручек, связанных с параметром
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКПОКАЗАТЬ | Делает объекты видимыми в текущем или во всех состояниях видимости в описании динамического блока
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТИНСТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКСКРЫТЬ | Делает объекты невидимыми в текущем или во всех состояниях видимости в описании динамического блока
БЛОКСОСТВИД | Создает, устанавливает или удаляет состояние видимости в динамическом блоке
БЛОКТАБЛВЫБ | Отображает или создает таблицу выбора для описания динамического блока
БПОРЦИКЛ | Изменяет порядок циклического перебора ручек для вхождения динамического блока
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
BVMODE | Управление способом отображения объектов, которые становятся невидимыми для текущего состояния видимости, в редакторе блока
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор элементов динамических блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор элементов динамических блоков
Понятия
Процедуры
Команды

Динамические элементы добавляются в описание блока в редакторе блоков. Кроме геометрии, динамический блок обычно содержит один или несколько параметров, а также одну или несколько операций.

  • Параметры. Определяют настраиваемые свойства для динамического блока путем указания положений, расстояний и углов для геометрии в блоке.
  • Операции. Определяют, как будет двигаться или изменяться геометрия вхождения динамического блока при манипулировании в чертеже. При добавлении в описание динамического блока операций их необходимо связать с параметрами. Кроме того, указывается набор объектов геометрии, которые участвуют в этой операции.

Примечание Параметры и операции отображаются только в редакторе блоков. При вставке в чертеж вхождения динамического блока параметры и операции, содержащиеся в описании динамического блока, не отображаются.

При добавлении параметра в описание динамического блока в ключевые точки параметра добавляются ручки. Ключевые точки - это части параметра, которые используются для манипулирования вхождением блока. Например, линейный параметр имеет ключевые точки в своей базовой и конечной точках. Расстоянием параметра можно манипулировать из любой ключевой точки.

Тип параметра, добавляемого в динамический блок, определяет тип добавляемых ручек. Каждый тип параметра поддерживает только определенные типы операций. В следующей таблице приведены взаимосвязи между параметрами, ручками и операциями.

Тип параметра | Тип ручки |  | Операции, которые можно связать с параметром
Точка |  | Стандартный | Переместить, Растянуть
Линейный |  | Линейный | Переместить, Масштаб, Растянуть, Массив
Полярная |  | Стандартный | Переместить, Масштаб, Растянуть, Полярное растяжение, Массив,
XY |  | Стандартный | Переместить, Масштаб, Растянуть, Массив
Поворот |  | Поворот | Поворот
Отразить |  | Отразить | Отразить
Выравнивание |  | Выравнивание | Нет (операция подразумевается и содержится внутри параметра).
Видимость |  | Поискать | Нет (операция подразумевается и определяется состояниями видимости).
Поискать |  | Поискать | Поискать
Базовая точка |  | Стандартный | Нет


Чтобы создать динамический блок - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор элементов динамических блоков
Понятия
Процедуры
Команды

Чтобы создать динамический блок

  1. Выберите меню "Сервис" » "Редактор блоков".
  2. В диалоговом окне "Редактирование описания блока" выполнить одно из следующих действий:
    • Выбрать описание блока из списка.
    • Выбрать <Текущий чертеж>, если необходимо сохранить чертеж как динамический блок.
    • В разделе "Блок для создания или изменения" ввести имя для описания нового блока.
  3. Нажать "ОК".
  4. В редакторе блоков добавить или изменить геометрию.
  5. Выполнить одно из следующих действий:
    • Добавить один или несколько наборов параметров с вкладки "Наборы параметров" окна "Палитры вариации блоков", следуя подсказкам в командной строке. Дважды щелкните желтый значок предупреждения (или используйте команду БЛОКРЕАКТНАБОР) и следуйте подсказкам в командной строке, чтобы связать операцию с набором объектов геометрии.
    • Добавить один или несколько параметров с вкладки "Параметры" окна "Палитры вариации блоков", следуя подсказкам в командной строке. Добавить одну или несколько операций с вкладки "Операции", следуя подсказкам в командной строке.
  6. На панели инструментов редактора блоков щелкнуть "Сохранить описание блока".
  7. Щелкнуть "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: БЛОКРЕД

Контекстное меню: Щелкнуть правой кнопкой мыши блока. Выбрать "Редактор блоков".


Обзор элементов динамических блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Обзор элементов динамических блоков
Понятия
Процедуры
Команды

Команды
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование параметров в динамических блоках - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Параметры в описание динамического блока добавляются в редакторе блоков. В редакторе блоков параметры отображаются похожими на размеры. Параметры определяют свойства настройки блока. Параметры также определяют положения, расстояния и углы для геометрии во вхождения блока. При добавлении параметра в описание динамического блока параметры определяют одно или несколько настраиваемых свойств для блока.

Например, при добавлении в описание динамического блока параметра поворота этот параметр определяет свойство Угол для вхождения блока. Поэтому если на чертеже имеется блок стула и требуется возможность поворота положения блока во время редактирования, то этот параметр определяет ось, вокруг которой можно поворачивать блок.

В случае добавления параметра точки в описание динамического блока, этот параметр определяет два свойства настройки для вхождения блока: Положение X и Положение Y (относительно базовой точки вхождения блока).

Описание динамического блока должно содержать хотя бы один параметр. При добавлении параметра в описание динамического блока автоматически добавляются ручки, связанные с ключевыми точками параметра. Затем в описание блока необходимо добавить операцию и связать операцию с параметром.

На чертеже для манипулирования вхождением блока можно использовать ручку или свойство настройки в палитре свойств. При манипулировании вхождением блока на чертеже путем перемещения ручки или изменения значения настраиваемого свойства в палитре свойств изменяется значение параметра, определяющего это свойство настройки в блоке. При изменении значения параметра производится операция, связанная с этим параметром, которая изменяет геометрию (или свойство) вхождения динамического блока.

Параметры также определяют значения ограничений, влияющих на поведение вхождения динамического блока на чертеже. Некоторые параметры имеют фиксированный набор значений, минимальные и максимальные значения или значения приращения. Например, линейный параметр, используемый в блоке окна, может иметь следующий фиксированный набор значений: 10, 20, 30 и 40. При вставке в чертеж вхождения бока можно изменять окно, используя только одно из этих значений. Добавление набора значений для параметра позволяет ограничить манипулирование вхождением блока в чертеже. Для получения более подробных сведений о наборе значений параметров см. раздел Указание наборов значений для динамических блоков.

Параметры точки, поворота, XY, а также линейные и полярные параметры имеют свойство под названием "Цепочка операций". Для получения более подробных сведений о возможности использования цепочки операций для параметра см. раздел Разрешение цепочки операций для динамических блоков.

Значения параметров также можно извлекать с помощью Мастера извлечения атрибутов или с помощью файла шаблона извлечения атрибутов.

В следующей таблице приведен список и описания типов параметров, которые можно добавлять в описания динамических блоков, а также типы операций, которые можно связывать с каждым параметром.

Тип параметра | Описание | Поддерживаемые операции
Точка | Определяет координаты X и Y на чертеже. В редакторе блоков выглядят похоже на ординатный размер. | Переместить, Растянуть
Линейный | Показывает расстояние между двумя точками привязки. Ограничивает перемещение с помощью ручки по заданному углу. В редакторе блоков выглядят похоже на выровненный размер. | Переместить, Масштаб, Растянуть, Массив
Полярная | Отображает расстояние между двумя точками привязки и отображает значение угла. Для изменения значений расстояния и угла можно использовать как ручки, так и палитру свойств. В редакторе блоков выглядят похоже на выровненный размер. | Переместить, Масштаб, Растянуть, Полярное растяжение, Массив,
XY | Показывает расстояния X и Y от базовой точки параметра. В редакторе блоков отображается в виде пары размеров (горизонтального и вертикального). | Переместить, Масштаб, Растянуть, Массив
Поворот | Определяет угол. В редакторе блоков отображается в виде окружности. | Поворот
Отразить | Отражает объекты. В редакторе блоков отображается в виде линии отражения. Объекты могут отражаться относительно этой линии отражения. Отображает значение, которое показывает, отражено или еще нет вхождение блока. | Отразить
Выравнивание | Определяет координаты X и Y и угол. Параметр выравнивания всегда относится ко всему блоку и не требует наличия связанной с ним операции. Параметр выравнивания позволяет вхождению блока автоматически вращаться вокруг точки для выравнивания с другим объектом на чертеже. Параметр выравнивания влияет на свойство поворота вхождения блока. В редакторе блоков выглядит как линия выравнивания. | Нет (операция подразумевается и содержится внутри параметра).
Видимость | Управляет видимостью объектов в блоке. Параметр видимости всегда относится ко всему блоку и не требует наличия связанной с ним операции. На чертеже можно щелкнуть ручку, чтобы отобразить список имеющихся состояний видимости для вхождения блока. В редакторе блоков отображается в виде текста со связанной ручкой. | Нет (операция подразумевается и определяется состояниями видимости).
Поискать | Определяет свойство настройки, которое можно указать, или набор для вычисления значения из списка или таблицы, задаваемых пользователем. Его можно связать с одной ручкой выбора. Во вхождении блока можно щелкнуть ручку, чтобы отобразить список имеющихся значений. В редакторе блоков отображается в виде текста со связанной ручкой. | Поискать
Базовая точка | Определяет базовую точку для вхождения динамического блока относительно геометрии в блоке. Его невозможно связать с любыми операциями, но можно включить в набор объектов операции. В редакторе блоков отображается в виде окружности с перекрестиями. | Нет

См. также

Указание наборов значений для динамических блоков

Обзор настраиваемых свойств для динамических блоков

Извлечение данных из атрибутов

Извлечение данных из атрибутов (метод низкого уровня)


Использование параметров в динамических блоках - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Чтобы добавить в описание динамического блока параметр точки

Чтобы добавить в описание динамического блока линейный параметр

Чтобы добавить в описание динамического блока полярный параметр

Чтобы добавить в описание динамического блока параметр XY

Чтобы добавить в описание динамического блока параметр поворота

Чтобы добавить в описание динамического блока параметр выравнивания

Чтобы добавить в описание динамического блока параметр отражения

Чтобы добавить в описание динамического блока параметр видимости

Чтобы добавить в описание динамического блока параметр выбора

Чтобы добавить в описание динамического блока параметр базовой точки


Чтобы добавить в описание динамического блока параметр точки - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Чтобы добавить в описание динамического блока параметр точки

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр точки".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее.
    • Имя
    • Подпись
    • Описание
    • Цепочка операций
    • Свойства, отображаемые для вхождения блока

    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в описание блока.

  3. Выполните одно из следующих действий для указания расположения параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  4. Выполните одно из следующих действий для указания расположения ярлыка параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      • Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  5. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам для связи операции с параметром и набором объектов геометрии.
  6. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  7. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока линейный параметр - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Чтобы добавить в описание динамического блока линейный параметр

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Линейный параметр".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее.
    • Имя
    • Подпись
    • Описание
    • Набор значений
    • Цепочка операций
    • Свойства, отображаемые для вхождения блока

    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в описание блока.

  3. Выполните одно из следующих действий для указания базовой точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  4. Выполните одно из следующих действий для указания конечной точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  5. Выполните одно из следующих действий для указания расположения ярлыка параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      • Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  6. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам для связи операции с параметром и набором объектов геометрии.
  7. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  8. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока полярный параметр - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Чтобы добавить в описание динамического блока полярный параметр

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Полярный параметр".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее.
    • Имя
    • Подпись
    • Описание
    • Набор значений
    • Цепочка операций
    • Свойства, отображаемые для вхождения блока

    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в описание блока.

  3. Выполните одно из следующих действий для указания базовой точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  4. Выполните одно из следующих действий для указания конечной точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  5. Выполните одно из следующих действий для указания расположения ярлыка параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      • Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  6. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам для связи операции с параметром и набором объектов геометрии.
  7. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  8. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр XY - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Чтобы добавить в описание динамического блока параметр XY

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр XY".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее.
    • Имя
    • Подпись
    • Описание
    • Набор значений
    • Цепочка операций
    • Свойства, отображаемые для вхождения блока

    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в описание блока.

  3. Выполните одно из следующих действий для указания базовой точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  4. Выполните одно из следующих действий для указания конечной точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      • Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  5. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам для связи операции с параметром и набором объектов геометрии.
  6. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  7. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр поворота - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Чтобы добавить в описание динамического блока параметр поворота

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр поворота".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее.
    • Имя
    • Подпись
    • Описание
    • Набор значений
    • Цепочка операций
    • Свойства, отображаемые для вхождения блока

    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в описание блока.

  3. Выполните одно из следующих действий для указания базовой точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  4. Выполните одно из следующих действий для указания радиуса для параметра:
    • Используйте указывающее устройство.
    • Введите значение.
  5. Укажите базовый угол для параметра.

    6. Угол, отображаемый в палитре свойств и при выборе вхождения блока на чертеже, измеряется относительно базового угла, заданного в описании блока.

  6. Выполните одно из следующих действий для указания угла поворота по умолчанию для параметра:
    • Используйте указывающее устройство.
    • Введите значение угла.
  7. Выполните одно из следующих действий для указания расположения ярлыка параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      • Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  8. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам для связи операции с параметром и набором объектов геометрии.
  9. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  10. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр выравнивания - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Чтобы добавить в описание динамического блока параметр выравнивания

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр выравнивания".
  2. Следуйте подсказкам в командной строке, чтобы указать имя параметра.
  3. Выполните одно из следующих действий для указания базовой точки параметра выравнивания:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

    Эта базовая точка является местоположением по умолчанию для ручки параметра выравнивания.

  4. (Дополнительно) Введите в командной строке тип и следуйте подсказкам, чтобы указать, является ли тип параметра нормальным или касательным.
  5. Выполните одно из следующих действий для указания направления выравнивания:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  6. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  7. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр отражения - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Чтобы добавить в описание динамического блока параметр отражения

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр отражения".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее.
    • Имя
    • Подпись
    • Описание
    • Свойства, отображаемые для вхождения блока

    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в описание блока.

  3. Выполните одно из следующих действий для указания первой точки линии отражения для параметра отражения:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

    Эта первая точка линии отражения является местоположением по умолчанию для ручки параметра отражения.

  4. Выполните одно из следующих действий для указания второй точки линии отражения для параметра отражения:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  5. Выполните одно из следующих действий для указания расположения ярлыка параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      • Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  6. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам для связи операции с параметром и набором объектов геометрии.
  7. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  8. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр видимости - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Чтобы добавить в описание динамического блока параметр видимости

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр видимости".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее.
    • Имя
    • Подпись
    • Описание
    • Свойства, отображаемые для вхождения блока

    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в описание блока.

  3. Выполните одно из следующих действий для указания расположения параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

    Это расположение для ручки параметра видимости во вхождении блока.

  4. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  5. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр выбора - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Чтобы добавить в описание динамического блока параметр выбора

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр выбора".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее.
    • Имя
    • Подпись
    • Описание
    • Свойства, отображаемые для вхождения блока

    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в описание блока.

  3. Выполните одно из следующих действий для указания расположения параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      • Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  4. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам, чтобы связать с параметром операцию поиска. При этом отобразится диалоговое окно "Таблица выбора свойств", значения в котором можно ввести либо сейчас, либо позднее.
  5. Нажать "ОК".
  6. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  7. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр базовой точки - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Чтобы добавить в описание динамического блока параметр базовой точки

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр базовой точки".
  2. Выполните одно из следующих действий для указания расположения параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  3. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  4. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАРАМ


Использование параметров в динамических блоках - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Использование параметров в динамических блоках
Понятия
Процедуры
Команды

Команды
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование операций с динамическими блоками - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операций с динамическими блоками
Понятия
Процедуры
Команды

Операции определяют способ перемещения или изменения геометрии динамического вхождения блока при выполнении операций с настраиваемыми свойствами вхождения блока в чертеже.

  • Обзор операций в динамических блоках
  • Использование операций перемещения в динамическом блоке
    Во вхождении динамического блока операция перемещения приводит к тем же результатам, что и команда ПЕРЕНЕСТИ.
  • Использование операций масштабирования в динамическом блоке
    Во вхождении динамического блока операция масштабирования приводит к тем же результатам, что и команда МАСШТАБ.
  • Используйте операцию растягивания в динамическом блоке
    Во вхождении динамического блока операция растягивания приводит к перемещению и растягиванию объектов.
  • Используйте операцию полярного растягивания в динамическом блоке
    Во вхождении динамического блока операция полярного растягивания вращает, перемещает и растягивает объекты на указанный угол и расстояние.
  • Используйте операцию поворота в динамическом блоке
    Во вхождении динамического блока действие операции поворота подобно действию команды ПОВЕРНУТЬ.
  • Используйте операцию отражения в динамическом блоке
    Операция отражения позволяет выполнять отражение вхождения динамического блока относительно указанной оси, которая называется линией отражения.
  • Используйте операцию с массивом в динамическом блоке
    Во вхождении динамического блока операция с массивом приводит к копированию и созданию массива связанной геометрии.
  • Использование операции поиска в динамическом блоке
    При добавлении операции поиска в описание динамического блока и связывании ее с параметром выбора создается таблица выбора. Можно использовать таблицу выбора для назначения свойств настройки и значений динамического блока.
  • Использование переопределения для коэффициента расстояния и смещения угла
    В некоторых операциях используются свойства переопределения коэффициента расстояния и смещения угла. Эти свойства позволяют задать коэффициент, на который увеличивается или уменьшается значение параметра при его изменении во вхождении динамического блока.


Использование операций с динамическими блоками - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операций с динамическими блоками
Понятия
Процедуры
Команды

Для добавления операции перемещения в описание динамических блоков

Для указания свойства "Тип расстояния" для операции перемещения, связанной с параметром XY

Для добавления операции масштабирования в описание динамических блоков

Для указания независимой базовой точки для операции масштабирования в описании динамических блоков

Для указания свойства "Тип масштаба" для операции масштабирования, связанной с параметром XY

Для добавления операции растягивания в описание блока

Для указания свойства "Тип расстояния" для операции растягивания, связанной с параметром XY

Для добавления операции полярного растягивания в описание блока

Для добавления операции поворота в описание блока

Для добавления операции отражения в описание блока

Чтобы добавить в описание блока операцию с массивом

Для добавления операции поиска в описание динамических блоков

Задание переопределения коэффициента расстояния для операции

Задание переопределения смещения угла для операции


Использование операций с динамическими блоками - Команды

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операций с динамическими блоками
Понятия
Процедуры
Команды
Команды
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКТАБЛВЫБ | Отображает или создает таблицу выбора для описания динамического блока
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор операций в динамических блоках - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор операций в динамических блоках
Понятия
Процедуры
Команды

Операции определяют способ перемещения или изменения геометрии динамического вхождения блока при выполнении операций с настраиваемыми свойствами вхождения блока в чертеже. Динамический блок содержит по меньшей мере одну операцию.

Как правило, при добавление в описание динамического блока операции ее необходимо связать с параметром, ключевой точкой на параметре и геометрией. Ключевая точка - это точка на параметре, запускающая связанную с ней операцию при редактировании. Связанная с операцией геометрия называется набором объектов.

В следующем примере описание динамического блока содержит геометрию, представляющую стол, линейный параметр с одной ручкой, заданной для его конечной точки, и операцию растягивания, связанную с конечной точкой параметра и геометрией для правой стороны стола. Конечная точка параметра является ключевой точкой. Геометрия с правой стороны стола является набором объектов.

Если требуется изменить вхождение блока на чертеже, достаточно переместить ручку, и стол растянется.

В динамическом блоке можно использовать следующие типы операций:

  • Перенести
  • Масштаб
  • Растянуть
  • Полярное растяжение
  • Поворот
  • Отразить
  • Массив
  • Поискать

Для одного параметра и геометрии можно назначить несколько операций. Однако не следует назначать две или более операций одного типа для одной ключевой точки на параметре, если обе операции воздействуют на одну и ту же геометрию. Это может привести к неожиданному поведению вхождения блока.

Операции и типы параметров

Каждый тип операции можно связать с определенными параметрами. В следующей таблице показаны параметры, с которыми можно связать операции каждого типа.

Тип операции | Параметр
Перенести | Точка, линейный, полярный, XY
Масштаб | Линейный, полярный, XY
Растянуть | Точка, линейный, полярный, XY
Полярное растяжение | Полярная
Поворот | Поворот
Отразить | Отразить
Массив | Линейный, полярный, XY
Поискать | Поискать


Обзор операций в динамических блоках - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Обзор операций в динамических блоках
Понятия
Процедуры
Команды

Команды
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование операций перемещения в динамическом блоке - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операций перемещения в динамическом блоке
Понятия
Процедуры
Команды

Действие операции перемещения подобно действию команды ПЕРЕНЕСТИ. Во вхождении динамического блока операция перемещения приводит к перемещению объектов на заданные расстояние и угол.

В описании динамического блока операцию перемещения можно связать с любым из следующих параметров:

  • Точка
  • Линейный
  • Полярная
  • XY

После связи операции перемещения с параметром, операция связывается с набором объектов геометрии.

Во вхождении динамического блока, если с помощью ручки или палитры свойств изменяется значение параметра, связанного с операцией перемещения, это может повлиять на ключевую точку в параметре, связанную с операцией перемещения. При воздействии на ключевую точку геометрия в наборе операции перемещения будет перемещаться.

Например, пусть имеется динамический блок, представляющий стул. Блок содержит параметр точки и операцию перемещения, связанную с этим параметром. Набор объектов операции перемещения содержит всю геометрию в блоке (стуле). При манипулировании вхождением динамического объекта с помощью ручки, связанной с параметром точки (или свойств "Положение X" или "Положение Y" в палитре свойств), изменяется значение параметра точки. В результате этого изменения значения стул перемещается.

В следующем примере перемещение вхождения блока стула путем перетаскивания ручки параметра точки отображается новым положением этой ручки в палитре свойств.

Задание свойства "Тип расстояния" для операции перемещения

Если операция перемещения связана с праметром XY, то она имеет свойство переопределения Тип расстояния. Это свойство определяет, является ли примененное расстояние для перемещения значением X, значением Y или значениями координат X и Y от базовой точки параметра.

Например, в описании динамических блоков в качестве типа расстояния задается расстояние X для операции перемещения. Это означает, что блок может перемещаться только по оси X. Поэтому в случае перемещения блока по оси Y блок не перемещается.

См. также

Использование переопределения для коэффициента расстояния и смещения угла


Использование операций перемещения в динамическом блоке - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операций перемещения в динамическом блоке
Понятия
Процедуры
Команды

Для добавления операции перемещения в описание динамических блоков

Для указания свойства "Тип расстояния" для операции перемещения, связанной с параметром XY


Для добавления операции перемещения в описание динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операций перемещения в динамическом блоке
Понятия
Процедуры
Команды

Для добавления операции перемещения в описание динамических блоков

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция перемещения".
  2. В области рисования редактора блоков выберите параметр, который необходимо связать с операцией. (С операцией перемещения можно связать следующие типы параметров: точка, линейный, полярный и XY.)
  3. Выберите объекты (набор), чтобы связать с этой операцией.
  4. Нажать ENTER.
  5. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать коэффициент расстояния и угловое смещение.
  6. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

    Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.

  7. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  8. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКРЕАКТ


Для указания свойства "Тип расстояния" для операции перемещения, связанной с параметром XY - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операций перемещения в динамическом блоке
Понятия
Процедуры
Команды

Для указания свойства "Тип расстояния" для операции перемещения, связанной с параметром XY

  1. В редакторе блоков выберите операцию перемещения.
  2. На палитре "Свойства" в области "Переопределения" в поле "Тип расстояния" в списке выберите параметр.


Использование операций перемещения в динамическом блоке - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Использование операций перемещения в динамическом блоке
Понятия
Процедуры
Команды

Команды
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование операций масштабирования в динамическом блоке - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операций масштабирования в динамическом блоке
Понятия
Процедуры
Команды

Действие операции масштабирования подобно действию команды МАСШТАБ. Во вхождении динамического блока операция масштабирования приводит к масштабированию набора объектов блока при изменении параметра путем перемещения ручек или с использованием палитры свойств.

В описании динамического блока операция масштабирования связана со всем параметром, а не с ключевой точкой на параметре. Операцию масштабирования можно связать с любым из следующих параметров:

  • Линейный
  • Полярная
  • XY

После связи операции масштабирования с параметром, операция связывается с набором объектов геометрии.

Указание типа базовой точки для операции масштабирования

Операция масштабирования содержит свойство Тип базы. С помощью этого свойства можно указать тип базовой точки для масштабного коэффициента: зависимый или независимый.

Если тип базы зависимый, то объекты в наборе масштабируются относительно базовой точки параметра, с которой связана операция масштабирования. В следующем примере операция масштабирования связана с параметром XY. Операция масштабирования имеет зависимый тип базы. Базовая точка параметра XY расположена в левом нижнем углу прямоугольника. При использовании ручки настройки для масштабирования блока, его масштаб изменяется относительно левого нижнего угла прямоугольника.

Если тип базы независимый (показан в редакторе блоков как маркер X), то базовая точка задается независимо от параметра, с которым связана операция масштабирования. Объекты в наборе будут масштабироваться относительно базовой этой указанной независимой базовой точки. В следующем примере операция масштабирования связана с параметром XY. Операция масштабирования имеет независимый тип базы. Независимая базовая точка расположена в центре окружности. При использовании ручки настройки для масштабирования блока, его масштаб изменяется относительно центра окружности.

Укажите свойство "Тип масштаба" для операции масштабирования

Если операция масштабирования связана с параметром XY, то операция масштабирования имеет свойство переопределения Тип масштаба. Это свойство определяет, является ли использованный коэффициент масштаба расстоянием X, расстоянием Y или расстоянием значений координат X и Y от базовой точки параметра.

Например, в описании динамических блоков в качестве типа масштаба задается расстояние X для операции масштабирования. Если на чертеже выполняется редактирование вхождения блока путем перетаскивания ручки в параметре XY только вдоль оси Y, то масштаб связанной геометрии не изменяется.


Использование операций масштабирования в динамическом блоке - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операций масштабирования в динамическом блоке
Понятия
Процедуры
Команды

Для добавления операции масштабирования в описание динамических блоков

Для указания независимой базовой точки для операции масштабирования в описании динамических блоков

Для указания свойства "Тип масштаба" для операции масштабирования, связанной с параметром XY


Для добавления операции масштабирования в описание динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операций масштабирования в динамическом блоке
Понятия
Процедуры
Команды

Для добавления операции масштабирования в описание динамических блоков

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция масштабирования".
  2. В области рисования редактора блоков выберите параметр, который необходимо связать с операцией. (С операцией масштабирования можно связать следующие типы параметров: линейный, полярный и XY.)
  3. Выберите геометрию (набор), чтобы связать с этой операцией.
  4. Нажать ENTER.
  5. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать тип базовой точки.
  6. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

    Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.

  7. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  8. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКРЕАКТ


Для указания независимой базовой точки для операции масштабирования в описании динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операций масштабирования в динамическом блоке
Понятия
Процедуры
Команды

Для указания независимой базовой точки для операции масштабирования в описании динамических блоков

  1. Выберите операцию масштабирования в редакторе блоков.
  2. На палитре "Свойства" в области "Переопределения" в поле "Тип базы" в раскрывающемся списке выберите значение "Независимый".


Для указания свойства "Тип масштаба" для операции масштабирования, связанной с параметром XY - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операций масштабирования в динамическом блоке
Понятия
Процедуры
Команды

Для указания свойства "Тип масштаба" для операции масштабирования, связанной с параметром XY

  1. В редакторе блоков выберите операцию масштабирования, связанную с параметром XY.
  2. На палитре "Свойства" в области "Переопределения" в поле "Тип масштаба" в раскрывающемся списке выберите параметр.

    3. В зависимости от применяемого переопределения операции масштабирования для этого блока ограничена осью X, осью Y или обеими осями.


Использование операций масштабирования в динамическом блоке - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Использование операций масштабирования в динамическом блоке
Понятия
Процедуры
Команды

Команды
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Используйте операцию растягивания в динамическом блоке - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Используйте операцию растягивания в динамическом блоке
Понятия
Процедуры
Команды

Во вхождении динамического блока операция растягивания приводит к перемещению и растягиванию объектов на заданное расстояние в указанном месте.

В описании динамического блока операцию растягивания можно связать с любым из следующих параметров:

  • Точка
  • Линейный
  • Полярная
  • XY

После связывания операции растягивания с параметром можно указать рамку растягивания для этой операции. Затем выберите объекты для набора операции растяжения. Рамка растягивания определяет способ редактирования объектов внутри рамки или пересекаемых рамкой во вхождении блока. Это поведение напоминает выбор секущей рамкой с помощью команды РАСТЯНУТЬ.

  • Объекты, полностью входящие в рамку, перемещаются.
  • Объекты, пересекаемые рамкой, растягиваются.
  • Объекты, находящиеся внутри рамки или пересекаемые ей, но не входящие в набор объектов, не растягиваются и не перемещаются.
  • Объекты за пределами рамки, входящие в набор, перемещаются.

В следующем примере рамка растягивания указана пунктирной линией, а набор объектов выделен с помощью эффекта ореола. Несмотря на то, что верхняя окружность заключена в рамку растяжения, она не входит в набор объектов, поэтому не будет перемещаться. Нижняя окружность полностью входит в рамку растягивания и в набор объектов, поэтому она будет перемещаться. Прямоугольник пересекается рамкой растягивания и входит в набор объектов, поэтому он будет растягиваться.

Во вхождении динамического блока, если с помощью ручки или палитры свойств изменяется значение параметра, связанного с операцией растягивания, это может повлиять на ключевую точку в параметре, связанную с операцией растягивания. При воздействии на ключевую точку геометрия в наборе операции растяжения будет перемещаться.

Задание свойства "Тип расстояния" для операции растягивания

Если операция растягивания связана с параметром XY, то она имеет свойство переопределения Тип расстояния. Это свойство определяет, является ли примененное расстояние для перемещения значением X, значением Y или значениями координат X и Y от базовой точки параметра.

Например, в описании динамических блоков в качестве типа расстояния задается расстояние X для операции растягивания. На чертеже, если выполняется попытка изменить вхождение блока путем перетаскивания ключевой точки только вдоль оси Y, то связанная геометрия не перемещается, так как добавлено переопределение типа расстояния, которое позволяет только перемещение по оси X.

См. также

Использование переопределения для коэффициента расстояния и смещения угла


Используйте операцию растягивания в динамическом блоке - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Используйте операцию растягивания в динамическом блоке
Понятия
Процедуры
Команды

Для добавления операции растягивания в описание блока

Для указания свойства "Тип расстояния" для операции растягивания, связанной с параметром XY


Для добавления операции растягивания в описание блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Используйте операцию растягивания в динамическом блоке
Понятия
Процедуры
Команды

Для добавления операции растягивания в описание блока

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция растягивания".
  2. В области рисования редактора блоков выберите параметр, который необходимо связать с операцией. (С операцией перемещения можно связать следующие типы параметров: точка, линейный, полярный и XY.)

    3. Если выполняется связка операции растягивания с параметром точки, перейдите к шагу 4.

  3. Выполните одно из следующих действий для выбора точки параметра для связывания с операцией:
    • Используйте указывающее устройство.
    • Следуйте подсказкам в командной строке.
  4. Выполните одно из следующих действий, чтобы задать первый угол рамки растягивания:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  5. Выполните одно из следующих действий, чтобы задать противоположный угол рамки растягивания:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  6. Выберите объекты для набора операции.
  7. Нажать ENTER.
  8. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать коэффициент расстояния и угловое смещение.
  9. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      • Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.

  10. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  11. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКРЕАКТ


Для указания свойства "Тип расстояния" для операции растягивания, связанной с параметром XY - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Используйте операцию растягивания в динамическом блоке
Понятия
Процедуры
Команды

Для указания свойства "Тип расстояния" для операции растягивания, связанной с параметром XY

  1. В редакторе блоков выберите операцию растягивания, связанную с параметром XY.
  2. На палитре "Свойства" в области "Переопределения" в поле "Тип расстояния" в раскрывающемся списке выберите параметр.

В зависимости от применяемого переопределения операция растягивания для этого блока ограничена осью X, осью Y или обеими осями.


Используйте операцию растягивания в динамическом блоке - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Используйте операцию растягивания в динамическом блоке
Понятия
Процедуры
Команды

Команды
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Используйте операцию полярного растягивания в динамическом блоке - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Используйте операцию полярного растягивания в динамическом блоке
Понятия
Процедуры
Команды

Во вхождении блока операция полярного растягивания поворачивает, перемещает и растягивает объекты на указанный угол и расстояние, если ключевая точка в связанном полярном параметре изменяется с помощью ручки или палитры свойств.

В описании динамического блока операцию полярного растягивания можно связать только с полярным параметром: Базовая точка для части растяжения операции - это точка параметра, а не ключевая точка.

После связывания операции полярного растягивания с полярным параметром можно указать рамку растягивания для этой операции. Затем выбираются объекты для растяжения и объекты для вращения.

  • Объекты, полностью входящие в рамку, перемещаются.
  • Объекты, пересекаемые рамкой, растягиваются.
  • Объекты в наборе объектов операции, указанные только для вращения, не растягиваются.
  • Объекты, полностью входящие в рамку, перемещаются линейно после поворота.
  • Объекты, пересекаемые рамкой, растягиваются линейно после поворота.
  • Объекты, находящиеся внутри рамки или пересекаемые ей, но не входящие в набор объектов, не растягиваются и не поворачиваются.
  • Объекты за пределами рамки, входящие в набор, перемещаются.

В следующем примере рамка растягивания указана пунктирной линией, а набор объектов выделен с помощью эффекта ореола. Несмотря на то, что верхняя окружность заключена в рамку растяжения, она не входит в набор объектов, поэтому не будет перемещаться. Нижняя окружность полностью входит в рамку растягивания и в набор объектов растяжения, поэтому она будет перемещаться. Прямоугольник пересекается рамкой растягивания и входит в набор объектов, поэтому он будет растягиваться. Квадрат полностью входит в рамку растяжения и в набор объектов поворота, но не в набор объектов растягивания, он будет только вращаться.

Во вхождении динамического блока, если с помощью ручки или палитры свойств изменяется значение параметра, связанного с операцией полярного растягивания, это может повлиять на ключевую точку в параметре, связанную с операцией полярного растяжения. При воздействии на ключевую точку геометрия в наборе операции полярного растяжения будет перемещаться или вращаться в зависимости от способа определения блока.

Примечание Если требуется, чтобы вращались только объекты во вхождении блока, не включайте никакие объекты в рамку растяжения.

См. также

Использование переопределения для коэффициента расстояния и смещения угла


Для добавления операции полярного растягивания в описание блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Используйте операцию полярного растягивания в динамическом блоке
Понятия
Процедуры
Команды

Для добавления операции полярного растягивания в описание блока

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция растягивания".
  2. В области рисования редактора блоков выберите полярный параметр для связывания с операцией. (Операцию полярного растягивания можно связать только с полярным параметром.)
  3. Выполните одно из следующих действий для выбора точки параметра для связывания с операцией:
    • Используйте указывающее устройство.
    • Следуйте подсказкам в командной строке.
  4. Выполните одно из следующих действий, чтобы задать первый угол рамки растягивания:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  5. Выполните одно из следующих действий, чтобы задать противоположный угол рамки растягивания:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  6. Выберите объекты для растяжения или перемещения.
  7. Нажать ENTER.
  8. Выберите объекты для поворота.

    9. (Выбранные в шагах 6 и 8 объекты входят в набор операции полярного растяжения.)

  9. Нажать ENTER.
  10. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать расстояние и смещение.
  11. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

    Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.

  12. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  13. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКРЕАКТ


Используйте операцию полярного растягивания в динамическом блоке - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Используйте операцию полярного растягивания в динамическом блоке
Понятия
Процедуры
Команды

Команды
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Используйте операцию поворота в динамическом блоке - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Используйте операцию поворота в динамическом блоке
Понятия
Процедуры
Команды

Действие операции поворота подобно действию команды ПОВЕРНУТЬ. Во вхождении динамического блока операция поворота приводит к повороту связанных объектов при редактировании связанного параметра с помощью ручки или палитры свойств.

В описании динамического блока операцию поворота можно связать только с параметром поворота: Операция поворота связана с целым параметром, а не с ключевой точкой параметра.

После связи операции поворота с параметром поворота, операция связывается с набором объектов геометрии.

Укажите тип базовой точки для операции поворота

Операция поворота содержит свойство Тип базы. С помощью этого свойства можно указать, является ли базовая точка поворота базовой точки параметра или независимой базовой точкой, которая указывается в описании блока.

По умолчанию тип базы зависимый. Это означает, что блок вращается вокруг связанной базовой точки параметра поворота. В следующем примере блок стула содержит параметр поворота и связанную операцию поворота. Операция поворота имеет зависимый типы базы. Базовая точка параметра - это центр стула. Поэтому стул вращается вокруг центральной точки.

При выборе независимого типа базы можно указать базовую точку для операции поворота, которая отличается от базовой точки связанного параметра поворота. Эта независимая базовая точка показана в редакторе блоков как маркер X. Местоположение независимой базовой точки можно изменять путем ее перетаскивания или изменения значений "База X" и "База Y" в разделе "Переопределения" палитры свойств.

В следующем примере блок стула содержит параметр поворота и связанную операцию поворота. Операция поворота имеет независимый типы базы. Независимая базовая точка расположена в левом нижнем углу стула. Поэтому стул вращается вокруг левого нижнего угла.

В следующем примере каждый из трех прямоугольников во вхождении динамического блока вращается вокруг независимой базовой точки, расположенной в левом нижнем углу каждого четырехугольника. Для этого задается один параметр поворота. Затем добавляются три операции поворота. Каждая операция поворота связана с параметром поворота. Каждая операция поворота затем связывается с отдельным объектом и для него назначается отдельная независимая базовая точка.

Такие результаты можно получить, используя для каждой операции поворота зависимые базовые точки, каждая из которых имеет отдельное смещение базы. Однако, если требуется переместить прямоугольники независимо друг от друга (например с помощью полярного параметра или параметра XY и операции перемещения) во вхождении блока, необходимо использовать независимые базовые точки для операций поворота, так как в противном случае объекты будут вращаться неправильно.


Для добавления операции поворота в описание блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Используйте операцию поворота в динамическом блоке
Понятия
Процедуры
Команды

Для добавления операции поворота в описание блока

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операцию поворота".
  2. В области рисования редактора блоков выберите параметр поворота для связывания с операцией. (Операцию поворота можно связать только с параметром поворота.)
  3. Выберите объекты (набор), чтобы связать с этой операцией.
  4. Нажать ENTER.
  5. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать тип базовой точки.
  6. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      • Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.

  7. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  8. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКРЕАКТ


Используйте операцию поворота в динамическом блоке - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Используйте операцию поворота в динамическом блоке
Понятия
Процедуры
Команды

Команды
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Используйте операцию отражения в динамическом блоке - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Используйте операцию отражения в динамическом блоке
Понятия
Процедуры
Команды

С помощью операции отражения можно выполнять отражение вхождения динамического блока относительно указанной оси, которая называется линией отражения.

Во вхождении динамического блока операция отражения приводит к отражению связанного набора объектов вокруг оси, которая называется линией отражения, при редактировании связанного параметра с помощью ручки или палитры свойств.

В описании динамического блока операцию отражения можно связать только с параметром отражения: Операция отражения связана с целым параметром, а не с ключевой точкой параметра. После связи операции отражения с параметром отражения, операция связывается с набором объектов геометрии. Только отдельные объекты будут отражаться относительно линии отражения.

Например, на следующем чертеже полилиния между двумя окружностями на включена в набора операции отражения При отражении вхождения блока полилиния не отражается с остальной геометрией.


Для добавления операции отражения в описание блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Используйте операцию отражения в динамическом блоке
Понятия
Процедуры
Команды

Для добавления операции отражения в описание блока

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция отражения".
  2. В области рисования редактора блоков выберите параметр, который необходимо связать с операцией. (Операцию отражения можно связать только с параметром отражения.)
  3. Выберите объекты (набор), чтобы связать с этой операцией.
  4. Нажать ENTER.
  5. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      • Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.

  6. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  7. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКРЕАКТ


Используйте операцию отражения в динамическом блоке - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Используйте операцию отражения в динамическом блоке
Понятия
Процедуры
Команды

Команды
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Используйте операцию с массивом в динамическом блоке - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Используйте операцию с массивом в динамическом блоке
Понятия
Процедуры
Команды

Во вхождении динамического блока операция с массивом приводит к копированию и созданию массивов в прямоугольном массиве при редактировании связанного параметра с помощью ручки или палитры свойств.

В описании динамического блока операцию с массивом можно связать с любым из следующих параметров:

  • Линейный
  • Полярная
  • XY

После связи операцию с массивом с параметром отражения, операция связывается с набором объектов геометрии.

Укажите ряды и столбцы для операции с массивом

При связывании операции с массивом с линейным или полярным параметром указывается расстояние между столбцами для элементов массива. Расстояние между столбцами определяет расстояние между элементами массива. При изменении параметра во вхождении блока расстояние параметра (от базовой до второй точки) делится на расстояние между столбцами для определения числа столбцов (числа объектов).

Например, можно связать операцию с массивом с линейным параметром. Задано значение 2 расстояния между столбцами, которое имеет операция с массивом. При изменении линейного параметра во вхождении динамического блока для расстояния 10, число столбцов для вхождения блока равно 5.

При связывании операции с массивом с параметром XY также указывается расстояние между строками.

Включение параметров в набор объектов операции с массивом

Если включить параметр в набор объектов операции с массивом, это не повлияет на работу вхождения блока. Параметр не копируется вместе с другими объектами в наборе объектов. Дополнительные ручки не отображаются во вхождении блока.

В следующем примере блок места парковки можно занести в массив, чтобы в нем могло быть любое количество мест. Вертикальную строку можно повернуть. Обратите внимание, что после занесения блока в массив он по-прежнему содержит только одну ручку поворота.

Однако при изменении ручки для параметра, включенного в набор объектов операции с массивом, выполняется связанная с параметром операция для всех вхождений объектов. То же самое происходит, если параметр не включен в набор объектов операции с массивом.

Использование операции поворота и операции с массивом в одном динамическом блоке

Динамический блок может содержать операцию с массивом и операцию поворота, воздействующие на один и тот же набор объектов. Порядок, в котором вхождение блока заносится в массив и поворачивается, влияет на отображение блока.

Если сначала повернуть блок, в затем занести его в массив, то все экземпляры элементов массива будут отдельно повернуты вокруг собственной базовой точки.

Если сначала занести блок в массив, а затем повернуть его, то все экземпляры элементов массива будут повернуты вокруг одной базовой точки.


Чтобы добавить в описание блока операцию с массивом - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Используйте операцию с массивом в динамическом блоке
Понятия
Процедуры
Команды

Чтобы добавить в описание блока операцию с массивом

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция с массивом".
  2. В области рисования редактора блоков выберите параметр, который необходимо связать с операцией. (С операцией с массивом можно связать линейные, полярные параметры и параметры XY.)
  3. Выберите объекты (набор), чтобы связать с этой операцией.
  4. Нажать ENTER.
  5. При связывании операции с массивом с параметром XY выполните одно из следующих действий:
    • Расстояние между строками.
    • Укажите ячейку единицы, введя через запятую два значения или выбрав две противоположные точки прямоугольника в обрасти чертежа, а затем перейдите к шагу 7.
  6. Введите значение расстояния между столбцами.
  7. В случае назначения операции с массивом для параметра XY введите расстояние между строками.
  8. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      • Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.

  9. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  10. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКРЕАКТ


Используйте операцию с массивом в динамическом блоке - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Используйте операцию с массивом в динамическом блоке
Понятия
Процедуры
Команды

Команды
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование операции поиска в динамическом блоке - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операции поиска в динамическом блоке
Понятия
Процедуры
Команды

При добавлении операции поиска в описание динамического блока и связывании ее с параметром выбора создается таблица выбора. Можно использовать таблицу выбора для назначения свойств настройки и значений динамического блока.

Для получения сведений о добавлении таблиц выбора в динамические блоки, см. раздел Использовать таблицы выбора для назначения данных для динамических блоков.


Для добавления операции поиска в описание динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование операции поиска в динамическом блоке
Понятия
Процедуры
Команды

Для добавления операции поиска в описание динамических блоков

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция поиска".
  2. В области рисования редактора блоков выберите один или несколько параметров выбора, которые необходимо связать с операцией. (Операцию поиска можно связать только с параметрами выбора.)
  3. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      • Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.

  4. В диалоговом окне "Таблица выбора свойств", если необходимо, заполните таблицу.
  5. Нажать "ОК".
  6. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  7. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКРЕАКТ


Использование операции поиска в динамическом блоке - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Использование операции поиска в динамическом блоке
Понятия
Процедуры
Команды

Команды
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКТАБЛВЫБ | Отображает или создает таблицу выбора для описания динамического блока
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование переопределения для коэффициента расстояния и смещения угла - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование переопределения для коэффициента расстояния и смещения угла
Понятия
Процедуры
Команды

В некоторых операциях используются свойства переопределения коэффициента расстояния и смещения угла. Эти свойства позволяют задать коэффициент, на который увеличивается или уменьшается значение параметра при его изменении во вхождении динамического блока.

Действие переопределяет свойства операций. Однако они не оказывают влияния на вхождение блока, пока оно не будет обработано в чертеже. Существует два типа переопределения операций: коэффициент расстояния и смещение угла.

  • Коэффициент расстояния. Свойство коэффициента расстояния используется для изменения значения параметра на заданный коэффициент. Например, если для свойства коэффициента расстояния установить значение 2, чтобы выполнить операцию растягивания, соответствующая геометрия во вхождении блока будет увеличена, а расстояние движения ручки будет удвоено.
  • Смещение угла. Свойство смещения угла используется для увеличения или уменьшения угла изменяемого значения параметра на заданную величину. Например, если для свойства смещения угла в операцию перемещения установить значение 90, вхождение блока переместится на 90 градусов от значения угла перемещения ручки.

Эти свойства переопределения операций можно задавать, следуя подсказкам в командной строке, при добавлении операции в описание динамического блока. Можно также указать эти свойства в палитре свойств при выборе операции в редакторе блоков.

В следующей таблице представлены возможные свойства переопределения для каждого типа операции.

Тип операции | Возможные свойства переопределения
Перенести | Коэффициент расстояния, смещение угла
Масштаб | Нет
Растянуть | Коэффициент расстояния, смещение угла
Полярное растяжение | Коэффициент расстояния, смещение угла
Поворот | Нет
Отразить | Нет
Массив | Нет
Поискать | Нет


Использование переопределения для коэффициента расстояния и смещения угла - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование переопределения для коэффициента расстояния и смещения угла
Понятия
Процедуры
Команды

Задание переопределения коэффициента расстояния для операции

Задание переопределения смещения угла для операции


Задание переопределения коэффициента расстояния для операции - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование переопределения для коэффициента расстояния и смещения угла
Понятия
Процедуры
Команды

Задание переопределения коэффициента расстояния для операции

  1. В редакторе блоков выберите операцию перемещения, растягивания, полярного растягивания или операции с масивом.
  2. На палитре "Свойства" в области "Переопределения" в поле "Коэффициент расстояния" введите значение.
  3. Нажать ENTER.


Задание переопределения смещения угла для операции - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование переопределения для коэффициента расстояния и смещения угла
Понятия
Процедуры
Команды

Задание переопределения смещения угла для операции

  1. В редакторе блоков выберите операцию перемещения, растягивания, полярного растягивания.
  2. На палитре "Свойства" в области "Переопределения" в поле "Смещение угла" введите значение.
  3. Нажать ENTER.


Использование переопределения для коэффициента расстояния и смещения угла - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Использование переопределения для коэффициента расстояния и смещения угла
Понятия
Процедуры
Команды

Команды
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование наборов параметров - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование наборов параметров
Понятия
Процедуры
Команды

Для добавления чаще всего парных параметров и операций в описание динамических блоков пользуйтесь вкладкой "Наборы параметров" окна "Палитры вариации блоков".

Набор параметров добавляется в блок таким же образом, как и параметр. Операция, внесенная в набор параметров, автоматически добавляется в описание блока и связывается с добавленным параметром. Затем необходимо связать набор объектов (геометрию) с каждым действием.

При первом добавлении набора параметров в описание динамического блока, рядом с каждой операцией будет отображаться желтый значок предупреждения. Это указывает на то, что необходимо связать набор объектов с каждой операцией. Дважды щелкните желтый значок предупреждения (или используйте команду БЛОКРЕАКТНАБОР) и следуйте подсказкам в командной строке, чтобы связать операцию с набором объектов.

Примечание Когда пользователь вставляет набор параметров выбора и дважды щелкает желтый значок предупреждения, отображается диалоговое окно "Таблица выбора свойств". Операции поиска связываются с данными, добавляемыми в эту таблицу, а не с набором объектов.

В приведенной ниже таблице перечислены наборы параметров, предложенные на вкладке "Наборы параметров" окна "Палитры вариации блоков".

Набор параметров | Описание
Перемещение точки | Добавляет параметр точки с одной ручкой и связанную с ним операцию перемещения в описание динамического блока.
Линейное перемещение | Добавляет линейный параметр с одной ручкой и связанную с ним операцию перемещения в описание динамического блока.
Линейное растяжение | Добавляет линейный параметр с одной ручкой и связанную с ним операцию растягивания в описание динамического блока.
Линейный массив | Добавляет линейный параметр с одной ручкой и связанную с ним операцию с массивом в описание динамического блока.
Пара линейных перемещений | Добавляет линейный параметр с двумя ручками и операцию перемещения, связанную с каждой ручкой, в описание динамического блока.
Пара линейных растяжений | Добавляет линейный параметр с двумя ручками и операцию растягивания, связанную с каждой ручкой, в описание динамического блока.
Полярное перемещение | Добавляет полярный параметр с одной ручкой и связанную с ним операцию перемещения в описание динамического блока.
Полярное растяжение | Добавляет полярный параметр с одной ручкой и связанную с ним операцию растягивания в описание динамического блока.
Круговой массив | Добавляет полярный параметр с одной ручкой и связанную с ним операцию с массивом в описание динамического блока.
Пара полярных перемещений | Добавляет полярный параметр с двумя ручками и операцию перемещения, связанную с каждой ручкой, в описание динамического блока.
Пара полярных растяжений | Добавляет полярный параметр с двумя ручками и операцию растягивания, связанную с каждой ручкой, в описание динамического блока.
Перемещение XY | Добавляет параметр XY с одной ручкой и связанную с ним операцию перемещения в описание динамического блока.
Пара перемещений XY | Добавляет параметр XY с двумя ручками и операцию перемещения, связанную с каждой ручкой, в описание динамического блока.
Набор рамок перемещения XY | Добавляет параметр XY с четырьмя ручками и операцию перемещения, связанную с каждой ручкой, в описание динамического блока.
Набор рамок растяжения XY | Добавляет параметр XY с четырьмя ручками и операцию растягивания, связанную с каждой ручкой, в описание динамического блока.
Набор рамок массива XY | Добавляет параметр XY с четырьмя ручками и операцию с массивом, связанную с каждой ручкой, в описание динамического блока.
Поворот | Добавляет параметр поворота с одной ручкой и связанную с ним операцию поворота в описание динамического блока.
Отразить | Добавляет параметр отражения с одной ручкой и связанную с ним операцию отражения в описание динамического блока.
Видимость | Добавляет параметр видимости с одной ручкой. Параметр видимости не требует никаких операций.
Поискать | Добавляет параметр выбора с одной ручкой и операцию поиска в описание динамического блока.

См. также

Использование палитр вариации блоков


Добавление набора параметров в описание динамического блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использование наборов параметров
Понятия
Процедуры
Команды

Добавление набора параметров в описание динамического блока

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Наборы параметров" щелкните набор параметров.
  2. Следуйте подсказкам в командной строке.
  3. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  4. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".


Использование наборов параметров - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Использование наборов параметров
Понятия
Процедуры
Команды

Команды
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Указание ручек для динамических блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание ручек для динамических блоков
Понятия
Процедуры
Команды

При добавлении параметра в описание динамического блока, автоматически добавляются ручки настройки, связанные с ключевыми точками параметра. В чертеже эти ручки настройки можно использовать для выполнения операций с геометрией вхождения динамического блока.

Все параметры (кроме параметра выравнивания, который всегда отображает одну ручку) содержат свойство Число ручек. При выборе параметра в редакторе блоков свойство "Число ручек" отображается в палитре свойств. Это свойство позволяет задавать (в стандартном списке) число ручек, которые требуется отобразить для параметра.

Если задать 0 ручек для параметра, вхождение динамического блока можно по-прежнему редактировать с помощью палитры свойств (если блок определен этим способом).

Если описание динамического блока содержит состояния видимости или таблицу выбора, можно описать блок таким образом, чтобы отображалась только ручка выбора. Если щелкнуть эту ручку во вхождении блока, отобразится раскрывающийся список. При выборе элемента из этого списка отображение вхождения блока может измениться.

Ручки добавляются автоматически в ключевых точках в параметре. Положение ручки можно изменить, то есть ее можно поместить в любом месте блока относительно связанной с ней ключевой точки в параметре. При изменении положения ручки она остается связанной с ключевой точкой, соотнесенной с ней. Независимо от того, где отображается ручка во вхождении блока, она по-прежнему будет манипулировать связанной с ней ключевой точкой. В случае перемещения или изменения ключевой точки параметра, положение ручки относительно ключевой точки будет сохранено. Поскольку ручки используются для манипулирования вхождением динамического блока в чертеже, необходимо убедиться, что каждая ручка размещена в логическом местоположении. Если ручка не размещена в логическом местоположении, существует вероятность непредвиденного поведения.

И линейные, и полярные параметры могут отображать две, одну или ни одной ручки. Если пользователь указывает, что линейный или полярный параметр отображается с одной ручкой, она отображается в конечной точке параметра. Если планируется, что будет отображаться только одна ручка, следует назначать операции только для конечной точки любого из этих параметров. Иначе невозможно будет манипулировать вхождением (запускать операции), потому что ручка не будет отображаться для ключевой точки, связанной с операцией.

Если пользователь изменяет положение ручки для динамического блока, он может использовать команду БЛОКНАБРУЧ, чтобы восстановить ручки в местоположениях по умолчанию.

Тип параметра, добавляемого в описание динамического блока, определяет тип ручек, добавляемых в блок. Эти ручки предоставляют визуальные ключи в отношении способа манипулирования вхождением блока в чертеже. В следующей таблице приведены типы ручек, используемых в динамических блоках, их внешний вид и параметры, с которыми они связаны.

Тип ручки | Манипулирование ручкой в чертеже | Связанные параметры
Стандартный | В пределах плоскости в любом направлении | База, Точка, Линейный, Полярный и XY
Линейный | Назад и вперед в определенном направлении или вдоль оси | Линейный
Поворот | Вокруг оси | Поворот
Отразить | Щелкните для отражения вхождения динамического блока | Отразить
Выравнивание | В пределах плоскости в любом направлении; при перемещении над объектом вхождение блока выравнивается по объекту | Выравнивание
Поискать | Щелкните для отображения списка элементов | Видимость, поиск
Указать циклическую вставку для ручек в динамических блоках

Ручки в динамических блоках имеют свойство Циклический перебор. Если для этого свойства задано значение "Да", то ручка становится доступной точкой вставки для вхождения динамического блока. Для включения или отключения циклического перебора ручек в динамических блоках, а также задания порядка их циклического перебора можно использовать команду БПОРЦИКЛ. При вставке вхождения динамического блока в чертеж можно использовать клавишу CTRL для циклического перемещения по имеющимся ручкам с целью выбора, какая ручка будет точкой вставки для блока.


Указание ручек для динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание ручек для динамических блоков
Понятия
Процедуры
Команды

Для указания количества специальных ручек, отображаемых для параметра в динамическом блоке

Чтобы переместить ручку в описании динамического блока

Чтобы восстановить для ручек в описании динамического блока положения по умолчанию

Чтобы включить или отключить циклический перебор для ручки настройки во вхождении динамического блока

Для изменения порядка перебора при вставке для специальных ручек в динамическом блоке


Для указания количества специальных ручек, отображаемых для параметра в динамическом блоке - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание ручек для динамических блоков
Понятия
Процедуры
Команды

Для указания количества специальных ручек, отображаемых для параметра в динамическом блоке

  1. В редакторе блоков выберите параметр.
  2. На палитре свойств в разделе "Разное" щелкните "Число ручек", а затем выберите число ручек, которое должно отображаться для параметра.
  3. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  4. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Ввод команды: БЛОКНАБРУЧ

Контекстное меню: В редакторе блоков выберите параметр. Нажмите в области рисования правой кнопкой мыши. Выберите "Отображение ручки" » любое значение.


Чтобы переместить ручку в описании динамического блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание ручек для динамических блоков
Понятия
Процедуры
Команды

Чтобы переместить ручку в описании динамического блока

  1. В редакторе блоков выберите ручку настройки (не стандартную ручку, связанную с ключевой точкой параметра).
  2. Выполните одно из следующих действий для перемещения ручки:
    • Перетащите ручку в другое место в пространстве блока.
    • В палитре свойств в разделе "Геометрия" введите значения для свойств "База X" и "База Y". (Эти значения указываются относительно базовой точки параметра.)
  3. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  4. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".


Чтобы восстановить для ручек в описании динамического блока положения по умолчанию - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание ручек для динамических блоков
Понятия
Процедуры
Команды

Чтобы восстановить для ручек в описании динамического блока положения по умолчанию

  1. В редакторе блоков в командной строке введите блокнабруч.
  2. Выберите ручку, для которой требуется восстановить положения ручек по умолчанию.
  3. В строке состояния введите переставить и нажмите ENTER.
  4. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  5. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Контекстное меню: В редакторе блоков выберите параметр. Нажмите в области рисования правой кнопкой мыши. Выберите "Отображение ручки" » "Положение сброса".


Чтобы включить или отключить циклический перебор для ручки настройки во вхождении динамического блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание ручек для динамических блоков
Понятия
Процедуры
Команды

Чтобы включить или отключить циклический перебор для ручки настройки во вхождении динамического блока

  1. В редакторе блоков в командной строке введите бпорцикл.
  2. В диалоговом окне "Порядок перебора при вставке" выберите из списка ручку и нажмите "Циклический перебор", чтобы включить или отключить циклический перебор для ручки. (Пометка в столбце "Циклический перебор" означает, что циклический перебор включен для ручки.)
  3. Нажать "ОК".
  4. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  5. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Контекстное меню: В редакторе блоков выберите динамическую ручку. Нажмите в области рисования правой кнопкой мыши. Выбрать "Циклическая вставка".


Для изменения порядка перебора при вставке для специальных ручек в динамическом блоке - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание ручек для динамических блоков
Понятия
Процедуры
Команды

Для изменения порядка перебора при вставке для специальных ручек в динамическом блоке

  1. В редакторе блоков в командной строке введите бпорцикл.
  2. В диалоговом окне "Порядок перебора при вставке" выберите из списка ручку и нажмите "Вверх" или "Вниз". (Пометка в столбце "Циклическая вставка" означает, что циклическая вставка включена для ручки.)
  3. Повторять шаг 2 пока не изменится порядок циклической вставки ручки.
  4. Нажать "ОК".
  5. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".


Указание ручек для динамических блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Указание ручек для динамических блоков
Понятия
Процедуры
Команды

Команды
БЛОКНАБРУЧ | Создает, удаляет или выполняет сброс ручек, связанных с параметром
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БПОРЦИКЛ | Изменяет порядок циклического перебора ручек для вхождения динамического блока
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создать "Состояния видимости" - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Можно использовать состояния видимости, чтобы сделать геометрию видимой или невидимой в динамическом блоке. Один блок может иметь несколько состояний видимости.

с помощью состояний видимости можно быстро создать блок, который будет иметь разные графические представления. Можно легко изменить вхождение блока, который имеет разные состояния видимости, для вставки в чертеж.

Например, имеется четыре следующих обозначения сварки.

С помощью состояний видимости можно объединить эти обозначения сварки в один динамический блок. В следующем примере отображена геометрия для четырех обозначений сварки, объединенных в одно описание динамического блока в редакторе блоков.

После объединения геометрии в редакторе блоков, можно добавить параметр видимости. Можно добавить только один параметр видимости к описанию динамического блока. Не связывайте какие-либо действия с параметром видимости.

Затем можно создать и назвать другое состояние видимости для каждого обозначения сварки (например, WLD1, WLD2, WLD3 и WLD4). Для каждого состояния можно сделать определенную геометрию видимой или невидимой. В следующем примере состояние видимости WLD1 отображается в редакторе блоков. Геометрия, которая отображается серым цветом, является невидимой в состоянии видимости WLD1.

Параметр видимости включает ручку выбора. Эта ручка всегда отображается во вхождении блока, который содержит состояния видимости. При нажатии этой ручки во вхождении блока отображается раскрывающийся список всех состояний видимости во вхождении блока. При выборе одного состояния из списка геометрия, которая является видимой для этого состояния, отобразится на чертеже.

На правой стороне панели инструментов редактора блоков отобразится имя текущего состояния видимости. Все блоки имеют хотя бы одно состояние видимости. Нельзя удалить текущее состояние. В этой области панели инструментов находится несколько инструментов для работы с состояниями видимости.

Во время работы с состояниями видимости можно увидеть геометрию, которая является невидимой для данного состояния. Можно использовать кнопку режима видимости (BVMODE) для отображения или скрытия геометрии (серым цветом), которая является невидимой. Если для системной переменной BVMODE установлено значение 1, то геометрия, являющаяся невидимой при заданном состоянии видимости, отображается тусклым цветом.


Создать "Состояния видимости" - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Для включения состояний видимости (добавить параметр видимости)

Для создания нового состояния видимости на основе текущего состояния

Для создания нового состояния видимости, в котором все объекты являются невидимыми.

Для создания нового состояния видимости, в котором все объекты являются видимыми

Чтобы сделать состояние видимости текущим

Для удаления состояния видимости

Для задания нового имени состоянию видимости

Чтобы сделать объекты видимыми в текущем состоянии видимости

Чтобы сделать объекты видимыми во всех состояниях видимости

Чтобы сделать объекты невидимыми в текущем состоянии видимости.

Чтобы сделать объекты невидимыми во всех состояниях видимости

Для отображения или скрытия невидимой геометрии для состояний видимости.

Для изменения порядка в списке состояний видимости для вхождения динамического блока

Для установки состояния видимости по умолчанию для вхождения динамического блока.


Для включения состояний видимости (добавить параметр видимости) - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Для включения состояний видимости (добавить параметр видимости)

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр видимости".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее.
    • Имя
    • Подпись
    • Описание
    • Свойства, отображаемые для вхождения блока

    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в описание блока.

  3. Выполните одно из следующих действий для указания расположения параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

    Это расположение по умолчанию для ручки параметра видимости.

  4. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  5. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАРАМ


Для создания нового состояния видимости на основе текущего состояния - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Для создания нового состояния видимости на основе текущего состояния

  1. На панели инструментов редактора блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" щелкните "Новый".
  3. В диалоговом окне "Новое состояние видимости" введите имя для нового состояния видимости.
  4. Выберите "Оставить видимость существующих объектов неизменной".
  5. Нажать "ОК".

Видимость существующих объектов неизменна в новом состоянии.

Панель инструментов редактора блоков

Ввод команды: БЛОКСОСТВИД


Для создания нового состояния видимости, в котором все объекты являются невидимыми. - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Для создания нового состояния видимости, в котором все объекты являются невидимыми.

  1. На панели инструментов редактора блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" щелкните "Новый".
  3. В диалоговом окне "Новое состояние видимости" введите имя для нового состояния видимости.
  4. Выбрать "Скрыть все существующие объекты".
  5. Нажать "ОК".

Панель инструментов редактора блоков

Ввод команды: БЛОКСОСТВИД


Для создания нового состояния видимости, в котором все объекты являются видимыми - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Для создания нового состояния видимости, в котором все объекты являются видимыми

  1. На панели инструментов редактора блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" щелкните "Новый".
  3. В диалоговом окне "Новое состояние видимости" введите имя для нового состояния видимости.
  4. Выбрать "Отобразить все существующие объекты".
  5. Нажать "ОК".

Панель инструментов редактора блоков

Ввод команды: БЛОКСОСТВИД


Чтобы сделать состояние видимости текущим - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Чтобы сделать состояние видимости текущим

  1. На панели инструментов редактора блоков щелкните "Управление состояниями видимости".
  2. Выберите состояние видимости, которое необходимо установить как текущее состояние.

Панель инструментов редактора блоков

Ввод команды: БЛОКСОСТВИД

Контекстное меню: В диалоговом окне "Состояния видимости" щелкните правой кнопкой мыши состояние видимости в списке. Нажать кнопку "Установить".


Для удаления состояния видимости - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Для удаления состояния видимости

  1. На панели инструментов редактора блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" выберите в списке состояние видимости.
  3. Нажать кнопку "Удалить".
  4. Нажать "ОК".

Панель инструментов редактора блоков

Ввод команды: БЛОКСОСТВИД

Контекстное меню: В диалоговом окне "Состояния видимости" щелкните правой кнопкой мыши состояние видимости в списке. Выберите "Удалить состояние".


Для задания нового имени состоянию видимости - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Для задания нового имени состоянию видимости

  1. В редакторе блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" выберите в списке состояние видимости.
  3. Выбрать "Переименовать".
  4. Введите новое имя для состояния видимости.
  5. Нажать "ОК".

Панель инструментов редактора блоков

Ввод команды: БЛОКСОСТВИД

Контекстное меню: Щелкните правой кнопкой мыши состояние видимости в списке. Щелкните "Переименовать состояние".


Чтобы сделать объекты видимыми в текущем состоянии видимости - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Чтобы сделать объекты видимыми в текущем состоянии видимости

  1. На панели инструментов редактора блоков щелкните "Сделать видимым".
  2. В области рисования выберите объекты, чтобы сделать их видимыми в текущем состоянии видимости.
  3. Нажать ENTER.
  4. В командной строке введите текущий.
  5. Нажать ENTER.

Панель инструментов редактора блоков

Ввод команды: БЛОКПОКАЗАТЬ

Контекстное меню: В области рисования редактора блоков выберите один или несколько объектов. Нажмите в области рисования правой кнопкой мыши. Выберите "Видимость объекта" » "Показать для текущего состояния".


Чтобы сделать объекты видимыми во всех состояниях видимости - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Чтобы сделать объекты видимыми во всех состояниях видимости

  1. В области рисования редактора блоков выберите объекты, которые необходимо сделать видимыми во всех состояниях видимости.
  2. Нажмите в области рисования правой кнопкой мыши.
  3. Выберите "Видимость объекта" » "Показать для всех состояний".

Ввод команды: БЛОКПОКАЗАТЬ


Чтобы сделать объекты невидимыми в текущем состоянии видимости. - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Чтобы сделать объекты невидимыми в текущем состоянии видимости.

  1. На панели инструментов редактора блоков щелкните "Сделать невидимым".
  2. В области рисования выберите объекты, которые необходимо сделать невидимыми в текущем состоянии видимости.
  3. Нажать ENTER.
  4. В командной строке введите текущий.
  5. Нажать ENTER.

Панель инструментов редактора блоков

Ввод команды: БЛОКСКРЫТЬ

Контекстное меню: В области рисования редактора блоков выберите один или несколько объектов. Нажмите в области рисования правой кнопкой мыши. Выберите "Видимость объекта" » "Скрыть для текущего состояния".


Чтобы сделать объекты невидимыми во всех состояниях видимости - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Чтобы сделать объекты невидимыми во всех состояниях видимости

  1. В области рисования выберите объекты, которые необходимо сделать невидимыми во всех состояниях видимости.
  2. Нажмите в области рисования правой кнопкой мыши.
  3. Выберите "Видимость объекта" » "Скрыть для всех состояний".

Ввод команды: БЛОКСКРЫТЬ


Для отображения или скрытия невидимой геометрии для состояний видимости. - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Для отображения или скрытия невидимой геометрии для состояний видимости.

  • На панели инструментов редактора блоков щелкните "Режим видимости".

Панель инструментов редактора блоков

Ввод команды: BVMODE


Для изменения порядка в списке состояний видимости для вхождения динамического блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Для изменения порядка в списке состояний видимости для вхождения динамического блока

  1. На панели инструментов редактора блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" выберите в списке состояние видимости.
  3. Щелкните "Вверх" или "Вниз", чтобы изменить порядок.
  4. Повторяйте шаги 2 и 3, пока не выберите правильный порядок в списке состояний видимости.
  5. Нажать "ОК".

Панель инструментов редактора блоков

Ввод команды: БЛОКСОСТВИД


Для установки состояния видимости по умолчанию для вхождения динамического блока. - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Для установки состояния видимости по умолчанию для вхождения динамического блока.

  1. В редакторе блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" выберите в списке состояние видимости.
  3. Нажимайте "Вверх" пока выбранное состояние видимости не появится в верхней части списка.
  4. Нажать "ОК".

Панель инструментов редактора блоков

Ввод команды: БЛОКСОСТВИД


Создать "Состояния видимости" - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Создать "Состояния видимости"
Понятия
Процедуры
Команды

Команды
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКПОКАЗАТЬ | Делает объекты видимыми в текущем или во всех состояниях видимости в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКСКРЫТЬ | Делает объекты невидимыми в текущем или во всех состояниях видимости в описании динамического блока
БЛОКСОСТВИД | Создает, устанавливает или удаляет состояние видимости в динамическом блоке
Системные переменные
BVMODE | Управление способом отображения объектов, которые становятся невидимыми для текущего состояния видимости, в редакторе блока
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использовать таблицы выбора для назначения данных для динамических блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Использовать таблицы выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Можно использовать таблицу выбора для определения и указания значений свойств для динамического блока.

  • Обзор использования таблиц выбора для назначения данных для динамических блоков
    Можно использовать таблицу выбора для определения и указания значений свойств для динамического блока. При работе с вхождением блока на чертеже значения свойств ассоциируются с изменениями вхождения блока.
  • Указание значений для таблиц выбора
    Когда указываются значения в таблицы выбора, применяются некоторые специальные правила.


Использовать таблицы выбора для назначения данных для динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Использовать таблицы выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Для создания таблицы выбора для динамического блока

Для добавления свойств входа в таблицу выбора.

Для добавления свойств поиска в таблицу выбора.

Для добавления значений в таблицу выбора

Для включения обратного поиска

Чтобы сделать свойство поиска только для чтения

Для проверки на наличие ошибок в таблице выбора

Для открытия существующей таблицы выбора


Использовать таблицы выбора для назначения данных для динамических блоков - Команды

Создание и редактирование объектов
Создание и использование блоков (символов)
Использовать таблицы выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды
Команды
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКТАБЛВЫБ | Отображает или создает таблицу выбора для описания динамического блока
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор использования таблиц выбора для назначения данных для динамических блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Можно использовать таблицу выбора для определения и указания значений свойств для динамического блока. С помощью таблиц выбора можно быстро связать значения параметра для вхождения динамического блока с другими указанными данными (например, номером детали или модели). Данные из вхождений блока на чертеже можно вывести так же, как данные атрибутов блока.

После завершения таблица выбора назначает для вхождения динамического блока значения свойств на основе того, как блоком манипулируют на чертеже. И наоборот, можно изменить способ отображения вхождения блока на чертеже, изменив значение свойства таблицы поиска для вхождения блока с помощью ручки выбора или палитры свойств.

На следующем чертеже отображено вхождение динамического блока для крепления освещения. Для этого блока в области "Настройка" палитры "Свойства" отображается свойство размера. Это свойство определяется в таблице выбора для блока.

Если изменить размер крепления освещения на чертеже (с помощью специальных ручек), также изменится свойство размера в палитре "Свойства".

Можно также использовать ручку выбора для изменения отображения вхождения блока. Если выбрать размер из списка, который отображается при нажатии на ручку, изменится геометрия блока и новый размер отобразится в палитре "Свойства" в списке "Настройка".

Создание таблицы выбора

После того, как нарисована геометрия и добавлены необходимые для работы динамического блока параметры и действия, можно добавить таблицу поиска к описанию блока.

Пустая таблица выбора создается, когда добавляется параметр выбора в описание динамического блока, а затем добавляется операция поиска и связывается с параметром выбора. Таблица выбора отображается в диалоговом окне таблицы выбора.

Добавление свойств и значений в таблицу выбора.

Таблица выбора свойств состоит из свойств входа и поиска. Каждое свойство входа и поиска представлено с помощью столбца в таблице.

  • Свойства входа.Параметры, отличные от параметров поиска (например, линейный параметр под именем “Ширина”). В группе "Свойства входа" можно создать столбец для каждого параметра в описании блока, кроме параметров поиска, выравнивания и параметра базовой точки.
  • Свойства поиска. Параметры выбора. Один параметр выбора добавляется к описанию динамического блока для каждого столбца свойства поиска, который необходимо добавить к таблице выбора. Метка параметра выбора используется в качестве имени свойства.

После добавления свойств (столбцов) в таблицу, добавьте значения в ячейки каждого столбца. Щелкните ячейку и введите значение. Убедитесь, что выполняются следующие правила в разделе Указание значений для таблиц выбора.

Если определен набор значений для свойства (параметра) входа в таблице, отобразится раскрывающийся список доступных значений при нажатии ячейки в данном столбце.

Следующая таблица выбора используется для отображенного ранее блока крепления освещения. Линейные параметры под обозначениями “Высота” и “Ширина”, добавлены в качестве свойств ввода. Параметр “Размер” добавлен в качества свойства поиска. Значения параметров "Высота" и "Ширина" заимствованы из наборов значений, определенных для каждого из этих параметров. Значения параметра "Размер" вводятся вручную.

Когда значения параметров вхождения динамического блока соответствуют ряду значений свойств входа, значения соответствующего свойства поиска присваиваются этому вхождению блока. Эти параметры и значения поиска отображаются в палитре "Свойства" в списке "Настройка".

Например, при изменении значения высоты вхождения блока крепления освещения на 250 сантиметров и значения ширины на 500 сантиметров свойство "Размер" в области "Настройка" палитры "Свойства" будет иметь значение 0,25 м x 0,50 м.

В таблице выбора в нижней части свойств входа находится ряд с ярлыком <Несоответствующий>. Если значения параметра во вхождении блока не соответствуют ряду значений свойства входа, определенных в таблице поиска блока, значение свойства поиска, которое соответствует ряду <Несоответствующий> назначается вхождению блока. Значением по умолчанию является Настройка, но можно указать другое значение, изменив его в таблице.

Включение обратного поиска

Можно также указать свойство поиска для обратного поиска. Это добавит ручку выбора к вхождению динамического блока. При нажатии этой ручки отображается раскрывающийся список значений поиска для этого свойства поиска (столбец в таблице). При выборе значения из этого списка соответствующие значения свойства входа присваиваются этому вхождению блока. В зависимости от того, как был определен блок, это обычно приводит к изменению геометрии вхождения блока.

Для включения обратного поиска для свойства поиска каждый ряд в таблице выбора должен быть уникальным. После добавления свойств и значений в таблицу можно проверить ее на наличие ошибок и пустых ячеек, нажав кнопку проверки в диалоговом окне "Таблица выбора свойств". Можно также использовать параметры контекстного меню для вставки, удаления и изменения порядка рядов.

Примечание Если оставить ячейку в столбце свойств поиска пустой и если у нее будет связанное свойство входа в том же ряду, свойство поиска не позволит выполнить обратный поиск.

См. также

Извлечение данных из атрибутов

Извлечение данных из атрибутов (метод низкого уровня)


Обзор использования таблиц выбора для назначения данных для динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Для создания таблицы выбора для динамического блока

Для добавления свойств входа в таблицу выбора.

Для добавления свойств поиска в таблицу выбора.

Для добавления значений в таблицу выбора

Для включения обратного поиска

Чтобы сделать свойство поиска только для чтения

Для проверки на наличие ошибок в таблице выбора

Для открытия существующей таблицы выбора


Для создания таблицы выбора для динамического блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Для создания таблицы выбора для динамического блока

  1. В редакторе блоков добавьте один или несколько параметров выбора к описанию динамического блока, выполнив шаги в разделе Чтобы добавить в описание динамического блока параметр выбора.
  2. В редакторе блоков добавьте операцию поиска к описанию динамического блока, выполнив следующие шаги в разделе Для добавления операции поиска в описание динамических блоков .

    3. Отобразится диалоговое окно "Таблица выбора свойств".

  3. Используйте одну из следующих процедур для настройки таблицы выбора для динамического блока.
    • Для добавления свойств входа в таблицу выбора.
    • Для добавления свойств поиска в таблицу выбора.
    • Для включения обратного поиска
  4. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  5. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель инструментов редактора блоков

Ввод команды: БЛОКПАРАМ


Для добавления свойств входа в таблицу выбора. - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Для добавления свойств входа в таблицу выбора.

  1. В редакторе блоков дважды щелкните опеарцию поиска в описании динамического блока.
  2. В диалоговом окне "Таблица выбора свойств" щелкните "Добавить свойства".
  3. В нижнем левом углу диалогового окна "Добавление свойств параметров" щелкните "Добавить свойства входа".
  4. В списке "Свойства параметров" выберите свойства параметров, которые необходимо добавить в таблицу выбора. Для выбора нескольких свойств следует удерживать нажатой клавишу CTRL.
  5. Нажать "ОК".

Ввод команды: БЛОКТАБЛВЫБ


Для добавления свойств поиска в таблицу выбора. - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Для добавления свойств поиска в таблицу выбора.

  1. В редакторе блоков дважды щелкните операцию поиска в описании динамического блока.
  2. В диалоговом окне "Таблица выбора свойств" щелкните "Добавить свойства".
  3. В нижнем левом углу диалогового окна "Добавление свойств параметров" щелкните "Добавить свойства поиска".
  4. В списке "Свойства параметров" выберите свойства параметров выбора, которые необходимо добавить в таблицу выбора. Для выбора нескольких свойств следует удерживать нажатой клавишу CTRL.
  5. Нажать "ОК".

Ввод команды: БЛОКТАБЛВЫБ


Для добавления значений в таблицу выбора - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Для добавления значений в таблицу выбора

  1. В редакторе блоков дважды щелкните операцию поиска в описании динамического блока.
  2. В диалоговом окне "Таблица выбора свойств" щелкните пустую ячейку и выполните одно из следующих действий:
    • Выбрать значение из раскрывающегося списка. (Раскрывающийся список отображается, только если для параметра определен набор значений.)
    • Ввести значение.
  3. Повторить шаг 2, как требуется для заполнения таблицы.
  4. Нажать "ОК".

Ввод команды: БЛОКТАБЛВЫБ


Для включения обратного поиска - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Для включения обратного поиска

  1. В редакторе блоков дважды щелкните операцию поиска в описании динамического блока.
  2. В нижней части столбца "Свойство поиска" диалогового окна "Таблица выбора свойств" щелкните "Только чтение" и выберите "Разрешить обратный просмотр" из списка.

    3. Примечание Можно также выбрать "Разрешить обратный просмотр", если данные введены в столбец.

  3. Нажать "ОК".

Ввод команды: БЛОКТАБЛВЫБ


Чтобы сделать свойство поиска только для чтения - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Чтобы сделать свойство поиска только для чтения

  1. В редакторе блоков дважды щелкните операцию поиска в описании динамического блока.
  2. В нижней части столбца "Свойство поиска" диалогового окна "Таблица выбора свойств" щелкните "Разрешить обратный просмотр" и выберите "Только чтение" из списка.
  3. Нажать "ОК".

Ввод команды: БЛОКТАБЛВЫБ


Для проверки на наличие ошибок в таблице выбора - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Для проверки на наличие ошибок в таблице выбора

  • В диалоговом окне "Таблица выбора свойств" нажмите кнопку "Проверить".


Для открытия существующей таблицы выбора - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Для открытия существующей таблицы выбора

  • В редакторе блоков дважды щелкните операцию поиска.

Ввод команды: БЛОКТАБЛВЫБ


Обзор использования таблиц выбора для назначения данных для динамических блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Команды
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКТАБЛВЫБ | Отображает или создает таблицу выбора для описания динамического блока
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Указание значений для таблиц выбора - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание значений для таблиц выбора
Понятия
Процедуры
Команды

Когда указываются значения в таблицы выбора, применяются следующие правила:

  • Использовать запятую при разделении значений.
  • Можно указать любое число уникальных значений, разделенное запятой. Например: 5,6,7 5.5,6.25
  • Для указания диапазона используйте квадратные скобки [ ], чтобы обозначить, что диапазон включает значения, разделенные запятой, или используйте круглые скобки ( ), чтобы обозначить, что в диапазон не входят значения, разделенные запятой.
  • Для непрерывного диапазона используйте пару значений, разделенных запятой и включенных в квадратные или круглые скобки. Например: [3,10] указывает любое значение между 3 и 10,включая 3 и 10; (3,10) указывает любое значение между 3 и 10, не включая 3 и 10.
  • Для неограниченного вторым значением диапазона используйте одно значение с запятой, включенное в квадратные или круглые скобки. Например: [,5] указывает значение меньше или равное 5; (5,) указывает значение больше 5.
  • Используйте не более, чем 256 символов в ячейке таблицы.
  • Можно использовать архитектурный и технический синтаксис для единицы (например, 15'1/4").
  • Если ввести значение в неверном формате, произойдет возврат последнего значения при переходе к другой ячейке в таблице.

Таблицы выбора поддерживают следующее:

  • Все свойства числовых параметров (например, параметры расстояния и углов для точки, линейные, полярные параметры, параметры XY и поворота)
  • Свойства параметра текстовой строки (например, значения параметров отражения и видимости)


Использовать таблицы выбора для назначения данных для динамических блоков

Создание и редактирование объектов
Создание и использование блоков (символов)
Использовать таблицы выбора для назначения данных для динамических блоков
Понятия
Процедуры
Команды

Нет процедур.


Указание значений для таблиц выбора - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Указание значений для таблиц выбора
Понятия
Процедуры
Команды

Команды
БЛОКТАБЛВЫБ | Отображает или создает таблицу выбора для описания динамического блока
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Указание настраиваемых свойств для динамических блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание настраиваемых свойств для динамических блоков
Понятия
Процедуры
Команды

При создании динамического блока можно указать настраиваемые свойства для блока. Можно также указать, должны ли эти свойства отображаться в палитре "Свойства" при выборе вхождения блока на чертеже.

  • Обзор настраиваемых свойств для динамических блоков
    В редакторе блоков можно указать свойства для параметра в описании динамического блока. Некоторые из этих свойств могут быть отображены как настраиваемые свойства для вхождения динамического блока, когда он находится на чертеже.
  • Указание наборов значений для динамических блоков
    Можно указать определенный набор значений для линейных, полярных параметров, а также параметров XY и поворота.
  • Разрешение цепочки операций для динамических блоков
    Параметры точки, поворота, XY, а также линейные и полярные параметры имеют свойство под названием "Цепочка операций". Это свойство влияет на параметра, если параметр является частью набора операций.


Указание настраиваемых свойств для динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание настраиваемых свойств для динамических блоков
Понятия
Процедуры
Команды

Для указания ярлыка параметра

Для указания отображения настраиваемых свойств во вхождении динамического блока.

Для указания расчленения вхождения динамического блока

Для запрета неоднородного масштабирования во вхождении динамического блока.

Для указания набора значений для линейного или полярного параметра

Для указания набора значений для параметра XY

Для указания набора значений для параметра поворота

Для удаления значений из набора значений параметра

Для указания набора значений приращения для линейного, полярного параметра, параметра XY или поворота.

Для указания минимального и максимального значений для линейного, полярного параметра, параметра XY или поворота.

Для указания свойства "Цепочка операций" для линейного, полярного параметра, параметра точки, XY и поворота


Указание настраиваемых свойств для динамических блоков - Команды

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание настраиваемых свойств для динамических блоков
Понятия
Процедуры
Команды
Команды
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор настраиваемых свойств для динамических блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор настраиваемых свойств для динамических блоков
Понятия
Процедуры
Команды

В редакторе блоков можно указать свойства для параметра в описании динамического блока. Некоторые из этих свойств можно отобразить как настраиваемые свойства для вхождения динамического блока, когда он находится на чертеже. Эти свойства отображаются в палитре "Свойства" в списке "Настройка".

В редакторе блоков можно указать ярлыки параметров. При выборе на чертеже вхождения динамического блока эти свойства отображаются в списке "Настройка" в палитре "Свойства". Рекомендуется указать уникальные ярлыки параметров в блоке.

В зависимости от параметров, используемых в описании динамического блока, другие свойства параметров могут быть перечислены в группе "Настройка" в палитре "Свойства" при выборе вхождения динамического блока на чертеже. Например, полярный параметр имеет свойство угла, которое отображается в палитре "Свойства". В зависимости от того, как динамический блок определен, эти свойства могут отображать такие значения, как размер, угол и положение для вхождения выбранного блока.

Можно указать, должны ли эти настраиваемые свойства отображаться для вхождения блока при выборе его на чертеже. Эти свойства можно извлечь с помощью Мастера извлечения атрибутов.

Можно также использовать палитру "Свойства" для указания свойств геометрии (таких, как цвет, тип линии и вес линии) параметра. Эти свойства перечисляются в палитре "Свойства" в списке "Геометрия" при выборе параметра в редакторе блоков.

Другие свойства параметра, например, свойства "Набор значений" и "Цепочка операций", определяют, как вхождение блока будет работать на чертеже.

В редакторе блоков также указывается, можно ли блок расчленить, и может ли он быть со сложным масштабом.

См. также

Указание наборов значений для динамических блоков

Разрешение цепочки операций для динамических блоков

Указание ручек для динамических блоков

Извлечение данных из атрибутов


Обзор настраиваемых свойств для динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор настраиваемых свойств для динамических блоков
Понятия
Процедуры
Команды

Для указания ярлыка параметра

Для указания отображения настраиваемых свойств во вхождении динамического блока.

Для указания расчленения вхождения динамического блока

Для запрета неоднородного масштабирования во вхождении динамического блока.


Для указания ярлыка параметра - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор настраиваемых свойств для динамических блоков
Понятия
Процедуры
Команды

Для указания ярлыка параметра

  1. В редакторе блоков выберите меню "Сервис" » "Свойства" для отображения палитры "Свойства".
  2. В редакторе блоков выберите параметр.
  3. В палитре "Свойства" группы "Ярлыки свойств" щелкните ярлык <имя параметра>.
  4. Введите ярлык для параметра.
  5. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: ОКНОСВ

Контекстное меню: Щелкнуть правой кнопкой мыши на выбранном объекте. Щелкнуть "Переименовать ярлык". Введите новое имя для параметра и нажмите ENTER.


Для указания отображения настраиваемых свойств во вхождении динамического блока. - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор настраиваемых свойств для динамических блоков
Понятия
Процедуры
Команды

Для указания отображения настраиваемых свойств во вхождении динамического блока.

  1. В редакторе блоков выберите меню "Сервис" » "Свойства" для отображения палитры "Свойства".
  2. В редакторе блоков выберите параметр.
  3. В палитре "Свойства" в списке "Разное" щелкните "Показать свойства".
  4. В раскрывающемся списке выполните одно из следующих действий.
    • Выбрать "Да" для отображения настраиваемых свойств для вхождения блока.
    • Выбрать "Нет", чтобы настраиваемые свойства не отображались для вхождения блока.
  5. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: ОКНОСВ


Для указания расчленения вхождения динамического блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор настраиваемых свойств для динамических блоков
Понятия
Процедуры
Команды

Для указания расчленения вхождения динамического блока

  1. Использовать одну из следующих процедур для открытия описания блока в редакторе блоков.
    • Чтобы открыть существующее описание блока в редакторе блоков
    • Чтобы открыть блок из окна Центра управления в редакторе блоков
  2. Убедитесь, что в редакторе блоков ничего не выбрано.
  3. В палитре "Свойства" в списке "Блок" щелкните "Разрешить расчленение".
  4. В раскрывающемся списке выберите "Да" или "Нет".
  5. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: БЛОКРЕД


Для запрета неоднородного масштабирования во вхождении динамического блока. - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Обзор настраиваемых свойств для динамических блоков
Понятия
Процедуры
Команды

Для запрета неоднородного масштабирования во вхождении динамического блока.

  1. Использовать одну из следующих процедур для открытия описания блока в редакторе блоков.
    • Чтобы открыть существующее описание блока в редакторе блоков
    • Чтобы открыть блок из окна Центра управления в редакторе блоков
  2. Убедитесь, что в редакторе блоков ничего не выбрано.
  3. В палитре "Свойства" в списке "Блок" щелкните "Одинаковый масштаб".
  4. В раскрывающемся списке выберите "Да".
  5. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: БЛОКРЕД


Обзор настраиваемых свойств для динамических блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Обзор настраиваемых свойств для динамических блоков
Понятия
Процедуры
Команды

Команды
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Указание наборов значений для динамических блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание наборов значений для динамических блоков
Понятия
Процедуры
Команды

Можно также указать определенный набор значений для линейных, полярных параметров, а также параметров XY и поворота.

Набор значений - это диапазон или список значений, указанных для параметра. Эти значения могут быть отображены для вхождения блока как раскрывающийся список рядом с ярлыком параметра в списке "Настройка" в палитре "Свойства". Когда определяется набор значений для параметра, параметр ограничивается до этих значений при манипулировании вхождением блока на чертеже. Например, если определить линейный параметр в блоке, который задает рамку с набором значений 20, 40 и 60, рамку можно растянуть только до 20, 40 или 60 единиц.

При создании списка значений для параметра значение параметра, существующее в описании, автоматически добавляется в набор значений. Это значение является значением по умолчанию для вхождения блока при вставке его в чертеж.

Если изменить во вхождении блока значение параметра на значение, отличное от указанного в списке, будет выбрано ближайшее допустимое значение параметра. Например, определить набор значений линейного параметра, как 2, 4 и 6. Если изменить значение параметра во вхождении блока на 10, в результате будет выбрано 6, поскольку это ближайшее допустимое значение.

Если указать набор значений для параметра в динамическом блоке, отобразятся засечки при редактировании с помощью ручки вхождения блока на чертеже. Засечки означают расположения допустимых значений параметра.

Примечание Если переопределить значения в наборе значений после добавления свойств параметров в таблицу поиска, обязательно обновите таблицу поиска для соответствия новым значениям в наборе значений.


Указание наборов значений для динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание наборов значений для динамических блоков
Понятия
Процедуры
Команды

Для указания набора значений для линейного или полярного параметра

Для указания набора значений для параметра XY

Для указания набора значений для параметра поворота

Для удаления значений из набора значений параметра

Для указания набора значений приращения для линейного, полярного параметра, параметра XY или поворота.

Для указания минимального и максимального значений для линейного, полярного параметра, параметра XY или поворота.


Для указания набора значений для линейного или полярного параметра - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание наборов значений для динамических блоков
Понятия
Процедуры
Команды

Для указания набора значений для линейного или полярного параметра

  1. В редакторе блоков выберите меню "Сервис" » "Свойства" для отображения палитры "Свойства".
  2. В редакторе блоков выберите линейный или полярный параметр.
  3. В палитре "Свойства" в списке " Набор значений" щелкните "Тип расстояния".
  4. В раскрывающемся списке выберите "Список".
  5. В палитре "Свойства" в списке " Набор значений" щелкните "Список значений расстояния".
  6. Нажмите кнопку [...].
  7. В диалоговом окне "Добавление значения расстояния" в списке "Расстояния для добавления" введите одно или несколько значений, разделенных запятой.
  8. Нажать "Добавить".
  9. Нажать "ОК".
  10. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  11. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: ОКНОСВ


Для указания набора значений для параметра XY - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание наборов значений для динамических блоков
Понятия
Процедуры
Команды

Для указания набора значений для параметра XY

  1. В редакторе блоков выберите меню "Сервис" » "Свойства" для отображения палитры "Свойства".
  2. В редакторе блоков выберите параметр XY.
  3. В палитре "Свойства" в списке " Набор значений" щелкните "Горизонтальный тип" или "Вертикальный тип".
  4. В раскрывающемся списке выберите "Список".
  5. В палитре "Свойства" в списке " Набор значений" щелкните "Список значений по горизонтали" или "Список значений по вертикали".
  6. Нажмите кнопку [...].
  7. В диалоговом окне "Добавление значения расстояния" в списке "Расстояния для добавления" введите одно или несколько значений, разделенных запятой.
  8. Нажать "Добавить".
  9. Нажать "ОК".
  10. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  11. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: ОКНОСВ


Для указания набора значений для параметра поворота - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание наборов значений для динамических блоков
Понятия
Процедуры
Команды

Для указания набора значений для параметра поворота

  1. В редакторе блоков выберите меню "Сервис" » "Свойства" для отображения палитры "Свойства".
  2. В редакторе блоков выберите параметр поворота.
  3. В палитре "Свойства" в списке " Набор значений" щелкните "Тип угла".
  4. В раскрывающемся списке выберите "Список".
  5. В палитре "Свойства" в списке " Набор значений" щелкните "Список значений угла".
  6. Нажмите кнопку [...].
  7. В диалоговом окне "Добавление значения угла" в списке "Угол для добавления" введите одно или несколько значений, разделенных запятой.
  8. Нажать "Добавить".
  9. Нажать "ОК".
  10. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  11. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: ОКНОСВ


Для удаления значений из набора значений параметра - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание наборов значений для динамических блоков
Понятия
Процедуры
Команды

Для удаления значений из набора значений параметра

  1. В редакторе блоков выберите меню "Сервис" » "Свойства" для отображения палитры "Свойства".
  2. В редакторе блоков выберите линейный, полярный параметр, параметр XY или поворота.
  3. В палитре "Свойства" в списке "Набор значений" щелкните один из следующих списков.
    • Список значений расстояния
    • Список значений угла
    • Список значений по горизонтали
    • Список значений по вертикали
  4. Нажмите кнопку [...].
  5. В диалоговом окне "Добавление значения расстояния" или "Добавление значения угла" выберите значение списка для удаления.
  6. Нажать кнопку "Удалить".
  7. Нажать "ОК".
  8. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  9. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: ОКНОСВ


Для указания набора значений приращения для линейного, полярного параметра, параметра XY или поворота. - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание наборов значений для динамических блоков
Понятия
Процедуры
Команды

Для указания набора значений приращения для линейного, полярного параметра, параметра XY или поворота.

  1. В редакторе блоков выберите меню "Сервис" » "Свойства" для отображения палитры "Свойства".
  2. В редакторе блоков выберите линейный, полярный параметр, параметр XY или поворота.
  3. В палитре "Свойства" в списке " Набор значений" щелкните "Тип расстояния", "Тип угла", "Горизонтальный тип" или "Вертикальный тип".
  4. В раскрывающемся списке выберите "Приращение".
  5. В палитре "Свойства" в списке " Набор значений" щелкните "Приращение расстояния", "Приращение угла", "Приращение по горизонтали" или "Приращение по вертикали", а затем введите значение приращения для параметра.
  6. Щелкните "Минимальное расстояние", "Минимальный угол", "Минимальное по горизонтали" или "Минимальное по вертикали", а затем введите минимальное значение для параметра.
  7. Щелкните "Максимальное расстояние", "Максимальный угол", "Максимальное по горизонтали" или "Максимальное по вертикали", а затем введите максимальное значение для параметра.
  8. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  9. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: ОКНОСВ


Для указания минимального и максимального значений для линейного, полярного параметра, параметра XY или поворота. - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Указание наборов значений для динамических блоков
Понятия
Процедуры
Команды

Для указания минимального и максимального значений для линейного, полярного параметра, параметра XY или поворота.

  1. В редакторе блоков выберите меню "Сервис" » "Свойства" для отображения палитры "Свойства".
  2. В редакторе блоков выберите линейный, полярный параметр, параметр XY или поворота.
  3. В палитре "Свойства" в списке " Набор значений" щелкните "Минимальное расстояние", "Минимальный угол", "Минимальное по горизонтали" или "Минимальное по вертикали", а затем введите минимальное значение для параметра.
  4. Щелкните "Максимальное расстояние", "Максимальный угол", "Максимальное по горизонтали" или "Максимальное по вертикали", а затем введите максимальное значение для параметра.
  5. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: ОКНОСВ


Указание наборов значений для динамических блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Указание наборов значений для динамических блоков
Понятия
Процедуры
Команды

Команды
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Разрешение цепочки операций для динамических блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Разрешение цепочки операций для динамических блоков
Понятия
Процедуры
Команды

Параметры точки, поворота, XY, а также линейные и полярные параметры имеют свойство под названием Цепочка операций. Это свойство влияет на параметра, если параметр является частью набора операций.

Например, можно включить параметр точки в набор действия растягивания, который связан с линейным параметром. Если линейный параметр редактируется во вхождении блока, его связанная операция растягивания приводит к изменению в наборе. Так как параметр точки включен в набор, параметр точки редактируется с помощью изменения линейного параметра.

В следующем примере отображено описание блока в редакторе блоков. Параметр точки (с ярлыком "Положение") входит в набор операции растяжения.

Если у свойства "Цепочка операций" для параметра точки установлено значение "Да", изменение линейного параметра приведет к перемещению, связанному с параметром точки, как если бы параметр точки во вхождении блока был отредактирован с помощью ручки или настраиваемого свойства.

Если для свойства "Цепочка операций" установлено значение "Нет", перемещение, связанное с параметром точки, не будет выполнено при изменении линейного параметра. Поэтому круг не перемещается.


Для указания свойства "Цепочка операций" для линейного, полярного параметра, параметра точки, XY и поворота - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Разрешение цепочки операций для динамических блоков
Понятия
Процедуры
Команды

Для указания свойства "Цепочка операций" для линейного, полярного параметра, параметра точки, XY и поворота

  1. В редакторе блоков выберите меню "Сервис" » "Свойства" для отображения палитры "Свойства".
  2. В редакторе блоков выберите линейный, полярный параметр, параметр точки, XY или поворота.
  3. В палитре "Свойства" в списке "Разное" щелкните "Цепочка операций".
  4. В раскрывающемся списке выберите "Да" или "Нет".
  5. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: ОКНОСВ


Разрешение цепочки операций для динамических блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Разрешение цепочки операций для динамических блоков
Понятия
Процедуры
Команды

Команды
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение описаний динамических блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение описаний динамических блоков
Понятия
Процедуры
Команды

После описания динамического блока его можно изменить в редакторе блоков. В редакторе блоков можно удалять, добавлять, и изменять следующие элементы:

  • Параметры (см. раздел Использование параметров в динамических блоках)
  • Операции (см. раздел Использование параметров в динамических блоках Использование операций с динамическими блоками )
  • Геометрия
  • Состояния видимости (см. раздел Создать "Состояния видимости")
  • Таблицы выбора (см. раздел Использовать таблицы выбора для назначения данных для динамических блоков)
  • Ручки (см. раздел Указание ручек для динамических блоков)
  • Свойства (см. раздел Обзор настраиваемых свойств для динамических блоков)

Можно также воспользоваться командой БЛОКРЕАКТНАБОР для изменения набора объектов операции. Если удален параметр, связанный с операцией, и требуется переназначить эту операцию для другого параметра, используйте команду БЛОКРЕАКТСВЯЗЬ.

После изменения описания динамического блока в редакторе блоков необходимо сохранить изменения (см. раздел Сохранение блока в редакторе блоков).

Предупреждение Если переопределить динамический блок в AutoCAD 2005 или более ранних версиях, блок потеряет свои возможности динамического изменения.


Изменение описаний динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение описаний динамических блоков
Понятия
Процедуры
Команды

Чтобы открыть существующее описание динамического блока в редакторе блоков

Удаление элемента из описания динамических блоков

Изменение набора объектов для операции в описании динамических блоков

Переопределение растяжения или набора рамок растяжения для операции полярного растяжения в описании динамических блоков


Чтобы открыть существующее описание динамического блока в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение описаний динамических блоков
Понятия
Процедуры
Команды

Чтобы открыть существующее описание динамического блока в редакторе блоков

  1. Откройте файл чертежа, содержащий описание динамического блока, или откройте файл чертежа, который был сохранен как блок.
  2. Выполните действия, приведенные в разделе Чтобы открыть существующее описание блока в редакторе блоков .

Панель Стандартная

Ввод команды: ОТКРЫТЬ

Контекстное меню: Щелкните выбранный блок правой кнопкой мыши. Выберите "Редактор блоков".


Удаление элемента из описания динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение описаний динамических блоков
Понятия
Процедуры
Команды

Удаление элемента из описания динамических блоков

  1. Выберите в редакторе блоков элемент, который требуется удалить из описания динамических блоков.
  2. Нажмите клавишу DELETE.


Изменение набора объектов для операции в описании динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение описаний динамических блоков
Понятия
Процедуры
Команды

Изменение набора объектов для операции в описании динамических блоков

  1. Выберите действие в редакторе блоков.
  2. В командной строке введите блокреактнабор и нажмите ENTER.
  3. Следуйте подсказкам в командной строке.
  4. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  5. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".


Переопределение растяжения или набора рамок растяжения для операции полярного растяжения в описании динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение описаний динамических блоков
Понятия
Процедуры
Команды

Переопределение растяжения или набора рамок растяжения для операции полярного растяжения в описании динамических блоков

  1. В редакторе блоков дважды щелкните операцию растягивания или полярного растягивания.
  2. Следуйте подсказкам в командной строке, чтобы определить новую рамку растяжения и добавить объекты в набор объектов для операции или удалить их оттуда.
  3. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  4. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Ввод команды: БЛОКРЕАКТНАБОР


Изменение описаний динамических блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Изменение описаний динамических блоков
Понятия
Процедуры
Команды

Команды
БЛОКНАБРУЧ | Создает, удаляет или выполняет сброс ручек, связанных с параметром
БЛОКПАРАМ | Добавляет в описание динамического блока параметр с ручками
БЛОКРЕАКТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТИНСТ | Добавляет операцию в описание динамических блоков
БЛОКРЕАКТНАБОР | Указывает набор объектов, связанных с операцией в описании динамического блока
БЛОКРЕАКТСВЯЗЬ | Связывает операцию с параметром в описании динамического блока
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКСОСТВИД | Создает, устанавливает или удаляет состояние видимости в динамическом блоке
БЛОКТАБЛВЫБ | Отображает или создает таблицу выбора для описания динамического блока
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Исправление ошибок в описаниях динамических блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Исправление ошибок в описаниях динамических блоков
Понятия
Процедуры
Команды

Желтый значок предупреждения отображается в редакторе блоков, если описание динамических блоков содержит ошибки или является неполным. Исправьте ошибки (или дополните блок), чтобы вхождение блока в чертеже работало правильно.

Желтый значок предупреждения указывает на то, что описание блока определено неправильно или является неполным. Например, желтый значок будет отображаться при наличии параметра, не связанного с операцией. При наличии параметра, не связанного с операцией или набором объектов, также отображается желтый значок.

Чтобы исправить эти ошибки, щелкните дважды желтый значок предупреждения и следуйте подсказкам в командной строке.

После создания описания динамических блоков в редакторе блоков сохраните его, а затем проверьте правильность работы вхождения блока в чертеже. Если вхождение блока работает не так, как требуется, откройте описание в редакторе блоков и щелкните дважды типы использованных параметров и операций, а также их зависимости и свойства.


Исправление ошибок в описаниях динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Исправление ошибок в описаниях динамических блоков
Понятия
Процедуры
Команды

Исправление ошибки, обозначаемой желтым значком предупреждения в описании динамических блоков

Просмотр зависимостей внутри описания динамических блоков


Исправление ошибки, обозначаемой желтым значком предупреждения в описании динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Исправление ошибок в описаниях динамических блоков
Понятия
Процедуры
Команды

Исправление ошибки, обозначаемой желтым значком предупреждения в описании динамических блоков

  1. Дважды щелкните желтый значок предупреждения в редакторе блоков.
  2. Следуйте подсказкам в командной строке, чтобы исправить ошибки в описании динамических блоков.
  3. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  4. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".


Просмотр зависимостей внутри описания динамических блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Исправление ошибок в описаниях динамических блоков
Понятия
Процедуры
Команды

Просмотр зависимостей внутри описания динамических блоков

  1. Выберите параметр или действие в редакторе блоков.

    2. При выборе параметра связанное с ним действие выделяется.

    При выборе действия параметр и набор объектов геометрии, связанные с ним, подсвечиваются.

  2. По окончании просмотра зависимостей нажмите ESC.
  3. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".


Исправление ошибок в описаниях динамических блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Исправление ошибок в описаниях динамических блоков
Понятия
Процедуры
Команды

Команды
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение блока в редакторе блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Сохранение блока в редакторе блоков
Понятия
Процедуры
Команды

По завершении добавления элементов в описание динамических блоков в редакторе блоков сохраните описание блоков.

Чтобы сохранить описание блоков в редакторе блоков, нажмите кнопку "Сохранить описание блока" на панели инструментов редактора блоков или введите блоксохр в командной строке. Затем следует сохранить чертеж и убедиться, что описание блоков в чертеже сохранено.

При сохранении описания блоков в редакторе блоков текущие значения геометрии и параметров в блоке устанавливаются как значения по умолчанию для вхождения блока. При создании динамического блока, где используются состояния видимости, в верхней части списка диалогового окна "Управление состоянием видимости" отображается состояние видимости по умолчанию для вхождения блока.

После сохранения описания блоков можно закрыть редактор блоков и проверить блок в чертеже.

Примечание Если выбрать "Файл" » "Сохранить" во время работы в редакторе блоков, будет сохранен чертеж, но не описание блоков. Во время работы в редакторе блоков описание блоков нужно сохранять отдельно.


Сохранение блока в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Сохранение блока в редакторе блоков
Понятия
Процедуры
Команды

Сохранение описания блоков в редакторе блоков

Сохранение копии текущего описания блоков в редакторе блоков под другим именем


Сохранение описания блоков в редакторе блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Сохранение блока в редакторе блоков
Понятия
Процедуры
Команды

Сохранение описания блоков в редакторе блоков

  1. На панели инструментов редактора блоков щелкните "Сохранить описание блока".
  2. Выберите "Файл" » "Сохранить", чтобы сохранить описание блоков в чертеже.
  3. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: БЛОКСОХР


Сохранение копии текущего описания блоков в редакторе блоков под другим именем - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Сохранение блока в редакторе блоков
Понятия
Процедуры
Команды

Сохранение копии текущего описания блоков в редакторе блоков под другим именем

  1. На панели инструментов редактора блоков щелкните "Сохранить описание блока как".
  2. В диалоговом окне "Сохранение блока как" введите имя для нового описания блоков.
  3. Нажать "ОК".
  4. Выберите "Файл" » "Сохранить", чтобы сохранить описание блоков в чертеже.
  5. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".

Панель Стандартная

Ввод команды: БЛОКСОХРКАК


Сохранение блока в редакторе блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Сохранение блока в редакторе блоков
Понятия
Процедуры
Команды

Команды
БЛОКРЕД | Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков
БЛОКРЕДЗАКР | Закрывает редактор блоков
БЛОКСОХР | Сохраняет текущее описание блока
БЛОКСОХРКАК | Сохраняет копию текущего описания блока под новым именем
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Цвета и типы линий объектов в блоках - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Цвета и типы линий объектов в блоках
Понятия
Процедуры
Команды

Объекты вставляемого блока могут сохранять свои исходные свойства, либо перенять свойства текущего слоя, на который они вставляются, или текущие значения свойств, установленные в чертеже.

Как правило, цвет, тип и вес линий объектов блока сохраняют свои исходные значения, независимо от текущих свойств, заданных в чертеже. Однако имеется возможность присвоения текущих свойств чертежа объектам создаваемого блока. В этом случае происходит наследование значений свойств.

Пользователь может выбрать один из трех режимов поведения свойств объектов (цвета, типа линий и веса линий) при вставке блока.

  • Объекты блока сохраняют свои исходные свойства. Свойства объектов блока не меняются, независимо от заданных текущих значений свойств.

    • В этом случае рекомендуется отдельно устанавливать свойства цвета, типа линии и веса линии для каждого объекта в описании блоков: при создании этих объектов нельзя использовать настройки цвета, типа линии и веса линии ПО БЛОКУ или ПОСЛОЮ .

  • Объекты блока наследуют цвет, тип линий и вес линий, установленные для текущего слоя.

    • В данном случае перед созданием объектов, включаемых в описание блока, следует перейти на слой 0 и установить текущее значение ПОСЛОЮ для текущего цвета, типа линий и веса линий.

  • Объекты блока наследуют текущие значения цвета, типа линий и веса линий. Если текущие свойства в чертеже не заданы явным образом, то наследуются свойства текущего слоя.

    • В данном случае перед созданием объектов, включаемых в описание блока, следует установить текущее значение ПОБЛОКУ для цвета или типа линия.

Если требуется, чтобы с помощью объектов в блоке | создавались объекты на этих слоях | создавались объекты с этими свойствами
сохраняли исходные свойства | на любых, но не 0 | с любыми, но не ПОБЛОКУ и ПОСЛОЮ
наследовали свойства текущего слоя | 0 | ПОСЛОЮ
наследовали в первую очередь текущие свойства, переопределяющие свойства слоя | на любых | ПОБЛОКУ

Наследуемые свойства могут также использоваться и во вложенных блоках.


Цвета и типы линий объектов в блоках - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Цвета и типы линий объектов в блоках
Понятия
Процедуры
Команды

Для задания цвета создаваемых объектов

Для задания типа линий вновь создаваемых объектов


Для задания цвета создаваемых объектов - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Цвета и типы линий объектов в блоках
Понятия
Процедуры
Команды

Для задания цвета создаваемых объектов

  1. На панели "Свойства" щелкнуть на управляющем списке "Цвета".
  2. Щелкнуть на нужном цвете для его использования при создании новых объектов или щелкнуть на пункте "Выбор цвета" для вызова одноименного диалогового окна, где выполнить одно из действий:
    • На вкладке "Номер цвета" выбрать цвет или ввести номер по ИЦА (1-255) либо имя в поле "Цвет". Нажать "ОК".
    • На вкладке "Вся палитра" выбрать цветовую модель "HSL" и задать значения "H (оттенок)", "S (насыщенность)" и "L (яркость)". Затем нажать "OK".
    • На вкладке "Альбомы цветов" выбрать необходимый альбом, выбрать требуемый цвет. Нажать "ОК".
    • Выберите ПОСЛОЮ для создания новых объектов чертежа в цвете, назначенном текущему слою.
    • Выберите ПОБЛОКУ для создания новых объектов чертежа в текущем цвете в течение всего времени, пока они объединены в блок. При вставке блока объектам присваивается текущий цвет, заданный в чертеже.
  3. Нажать "ОК".

    4. Установленный текущий цвет отображается в управляющем списке "Цвета".

Ввод команды: ЦВЕТ


Для задания типа линий вновь создаваемых объектов - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Цвета и типы линий объектов в блоках
Понятия
Процедуры
Команды

Для задания типа линий вновь создаваемых объектов

  1. Из меню "Формат" выбрать "Типы линий".
  2. При необходимости загрузки дополнительных типов линий нажать "Загрузить", выбрать один или несколько типов линий и нажать "OK".

    3. Для выделения нескольких типов линий используется клавиша CTRL; для выделения диапазона типов линий - клавиша SHIFT.

  3. В окне Диспетчера типов линий выполнить одно из следующих действий:
    • Выделить тип линий и нажать кнопку "Текущий" для назначения выбранного типа линий всем вновь создаваемым объектам.
    • Выберите значение ПОСЛОЮ для построения новых объектов с текущим типом линий слоя.
    • Выберите значение ПОБЛОКУ для построения новых объектов с типом линий текущего слоя, пока они не объединены в блок. При вставке блока в чертеж объектам в блоке присваивается текущая настройка типа линии.
  4. Нажать "ОК".

    5. Установленный текущий тип линий отображается в управляющем списке "Типы линий". Для установки текущим уже загруженного типа линий нужно раскрыть управляющий список "Типы линий" и выбрать нужный тип линий.

Ввод команды: ТИПЛИН


Цвета и типы линий объектов в блоках - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Цвета и типы линий объектов в блоках
Понятия
Процедуры
Команды

Команды
СЛОЙ | Управление слоями и их свойствами
ТИПЛИН | Загрузка, установка и изменение типов линий
Цвет | Установка цвета для вновь создаваемых объектов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вложение блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Вложение блоков
Понятия
Процедуры
Команды

Блоки, которые содержатся внутри других вставленных в чертеж блоков, называются вложенными. Использование вложенных блоков позволяет упрощать описания сложных блоков.

С помощью вложенных блоков можно построить один блок из нескольких компонентов. Например, можно вставить в чертеж изображение механического узла, в который входят кожух, кронштейн и крепежные элементы; где каждый крепежный элемент состоит из болта, шайбы и гайки. Единственное ограничение при использовании вложенных блоков - запрет ссылок из блока на сам этот блок.


Вложение блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Вложение блоков
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вставка блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Вставка блоков
Понятия
Процедуры
Команды

Для каждого направления X, Y и Z задаются свои значения масштабного коэффициента. Во время вставки блока создается так называемое вхождение блока - объект, который связан с описанием блока, хранящимся в текущем чертеже. Оранжевый значок вспышки молнии, отображаемый в правом нижнем углу окна предварительного просмотра блока, обозначает, что блок динамический.

Если вставить блок, где используются единицы чертежа, отличные от указанных для текущего чертежа, масштаб блока изменится автоматически в соответствии с коэффициентом отношения двух единиц.

При вставке вхождения блока, включающего в себя редактируемые пользовательские свойства или атрибуты, можно изменять значения этих пользовательских свойств и атрибутов в палитре "Свойства" во время вставки блока. Пользовательские свойства и атрибуты блока становятся редактируемыми в палитре "Свойства" после определяния блока одним из указанных ниже способов.

  • В диалоговом окне Вставка после нажатия OK.
  • При использовании командной строки ВСТАВИТЬ после ввода имени блока.
  • При нажатии на инструмент работы с блоком в инструментальной палитре.
Вставка файла чертежа в качестве блока

При вставке в чертеж другого чертежа его данные копируются в таблицу блоков текущего чертежа в качестве описания блока. Последующие вхождения используют созданное описание, но для них задаются свои точки вставки, масштабные коэффициенты и углы поворота, как это показано на следующем чертеже.

В целевом чертеже (том, в который выполняется вставка) внешние ссылки и растровые изображения, содержащиеся во вставляемом чертеже, могут отображаться некорректно. Этого можно избежать, предварительно вставив такие внешние ссылки и изображения в целевой чертеж.

Вставка блоков из инструментальных палитр

Можно вставлять блоки из инструментальных палитр перетаскиванием инструмента работы с блоком в чертеж либо нажатием на инструмент работы с блоком и последующим обозначением точки вставки.

Можно установить режим вывода на командную строку запроса угла поворота (начиная с нуля) при нажатии кнопки мыши и размещении блока В этом режиме угол поворота, заданный в диалоговом окне "Свойства инструмента", игнорируется при создании объекта в чертеже. Запрос не выводится при перетаскивании блока или внешней ссылки или при вводе опции поворот в командной строке при вставке объекта.

Блоки, которые пользователь перетаскивает мышью из палитры в область рисования, можно масштабировать и поворачивать после того, как они станут объектами чертежа. При перетаскивании блоков можно использовать объектную привязку; шаговая привязка при этом подавляется.

При перетаскивании блока из инструментальной палитры в чертеж он автоматически масштабируется в соответствии с соотношением заданных единиц блока и единиц текущего чертежа. Например, если для измерения единиц данного чертежа используются метры, а для измерения единиц блока сантиметры, коэффициент пересчета составляет 1 к 100. Соответственно, при перетаскивании блока в чертеж его размеры меняются в пропорции 1:100.

Примечание В диалоговом окне "Настройка" на вкладке "Пользовательские" находятся раскрывающиеся списки "Единицы исходного чертежа" и "Единицы целевого чертежа". Выбранные в них единицы используются в том случае, когда единицы вставки не заданы в исходном блоке или целевом чертеже.

Вставка блоков из библиотек компонентов

В текущий чертеж можно вставлять один или несколько блоков из других файлов чертежей. Этот метод используется при вставке из библиотек компонентов. Библиотека компонентов содержит описания блоков для сходных компонентов. Такие описания блоков для удобства хранятся в одном файле чертежа.

Вставка блоков с помощью Центра управления AutoCAD

Вставка блоков из текущего и других чертежей выполняется с помощью Центра управления. Быстрое копирование блоков осуществляется простым перетаскиванием имен блоков. Двойным щелчком мыши на имени нужного блока можно задать положение, угол поворота и масштабные коэффициенты блока.

Вставка блоков в чертеж невозможна в процессе выполнения другой команды. Кроме того, за один раз можно вставить только один блок.

Вставка блоков с заданным интервалом

Имеется возможность вставки блоков с заданным интервалом вдоль выбранного геометрического объекта.

  • Для вставки блоков с заданным интервалом используется команда РАЗМЕТИТЬ.
  • Для вставки блоков с равными интервалами используется команда ПОДЕЛИТЬ.

См. также

Сохранение блока в отдельном файле

Базовые понятия для блоков

Создание библиотек компонентов

Работа с динамическими блоками в чертежах

Добавление содержимого с помощью центра управления DesignCenter

Создание инструментов из объектов и работа с ними


Вставка блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Вставка блоков
Понятия
Процедуры
Команды

Для вставки блока, описанного в текущем чертеже

Для вставки файла чертежа в качестве блока путем его перетаскивания

Для вставки блока с помощью Центра управления


Для вставки блока, описанного в текущем чертеже - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Вставка блоков
Понятия
Процедуры
Команды

Для вставки блока, описанного в текущем чертеже

  1. Из меню "Вставка" выбрать "Блок".
  2. В диалоговом окне "Вставка блока" выбрать имя блока из списка.
  3. Если необходимо задать точку вставки, масштабные коэффициенты и угол поворота непосредственно при вставке, установить опцию "Указать на экране" для каждого параметра. В противном случае, ввести значения в группах опций "Точка вставки", "Масштаб" и "Угол поворота".
  4. Если вместо целого блока необходимо вставить его отдельные объекты, то установить флажок "Расчленить".
  5. Нажать "ОК".

Панель Вставка

Ввод команды: ВСТАВИТЬ


Для вставки файла чертежа в качестве блока путем его перетаскивания - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Вставка блоков
Понятия
Процедуры
Команды

Для вставки файла чертежа в качестве блока путем его перетаскивания

  1. Перетащить значок файла чертежа в графическую область из Проводника Windows или любого другого окна с содержимым какой-либо папки.

    2. При отпускании кнопки мыши выдается запрос о точке вставки блока.

  2. Задать точку вставки, масштаб и угол поворота.


Для вставки блока с помощью Центра управления - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Вставка блоков
Понятия
Процедуры
Команды

Для вставки блока с помощью Центра управления

  1. Из меню "Сервис" выбрать "Центр управления".

    2. Появляется окно Центра управления.

  2. Выполнить одно из следующих действий для получения списка элементов, которые нужно вставить:
    • На панели окна Центра управления нажать кнопку "Область структуры". Нажать на обозначении папки, содержащей чертеж, который нужно вставить.
    • Нажать на значке нужного файла чертежа в области структуры.
  3. Выполнить одно из следующих действий для выполнения вставки:
    • Перетащить значок файла чертежа или блока в графическую область текущего чертежа. Этот метод удобен для быстрого выполнения вставки; точное положение и угол поворота блока определяется позже.
    • Дважды нажать на значке файла чертежа или блока, который нужно вставить в текущий чертеж. В этом случае значения координат точки вставки, масштаба и угла поворота задаются непосредственно перед вставкой блока. Этот метод можно использовать для обновления вхождений блоков в текущем чертеже из исходного файла.

Панель Стандартная

Ввод команды: ЦУВКЛ


Вставка блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Вставка блоков
Понятия
Процедуры
Команды

Команды
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
ПОДЕЛИТЬ | Размещение по длине или периметру объекта на равном расстоянии точек или блоков
РАЗМЕТИТЬ | Размещение на объекте точек или блоков с равными интервалами
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
ATTDIA | Контроль команды ВСТАВИТЬ: используется ли диалоговое окно для указания значения атрибута.
INSNAME | Устанавливает имя блока по умолчанию для команды ВСТАВИТЬ
INSUNITS | Указывает значение в единицах чертежа для автоматического масштабирования блоков, изображений или вставленных или прикрепленных к чертежу внешних ссылок
INSUNITSDEFSOURCE | Устанавливает единицы измерения исходного содержимого, когда переменная INSUNITS имеет значение, равное 0
INSUNITSDEFTARGET | Устанавливает единицы измерения в целевом чертеже, когда переменная INSUNITS имеет значение, равное 0
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с динамическими блоками в чертежах - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Работа с динамическими блоками в чертежах
Понятия
Процедуры
Команды

Динамический блок обладает гибкостью и интеллектуальными возможностями. Вхождение динамического блока можно легко изменить на чертеже во время работы. Для изменения геометрии можно использовать настраиваемые ручки или настраиваемые свойства. Это позволяет изменять вхождение блока на месте, вместо того чтобы искать другой блок для вставки или уточнять описание существующего блока.

Например в случае вставки в чертеж вхождения блока может потребоваться изменить размер двери во время редактирования чертежа. Если блок является динамическим и в описании указано, что он имеет настраиваемый размер, то, чтобы изменить размер двери, достаточно перетащить ручку настройки или указать другой размер в палитре "Свойства". Возможно, также потребуется изменить угол открытия двери. Дверной блок также может содержать ручку выравнивания, которая позволяет быстро выравнивать вхождение дверного блока с другой геометрией на чертеже.

В динамическом блоке могут присутствовать настраиваемые ручки или настраиваемые свойства. Возможно, в зависимости от того, как был определен блок, им можно будет управлять с помощью настраиваемых ручек или настраиваемых свойств. По умолчанию цвет настраиваемых ручек для динамического блока отличается от цвета стандартных. Цвет отображения настраиваемых ручек можно изменять с помощью системной переменной GRIPDYNCOLOR. В следующей таблице приведены различные типы настраиваемых ручек, которые можно включать в динамические блоки.

Тип ручки | Манипулирование ручкой в чертеже
Стандартный | В пределах плоскости в любом направлении
Линейный | Назад и вперед в определенном направлении или вдоль оси
Поворот | Вокруг оси
Отразить | При нажатии отражается вхождение динамического блока
Выравнивание | В пределах плоскости в любом направлении; при перемещении над объектом вхождение блока выравнивается по объекту
Поискать | При нажатии отображается список элементов

По завершении манипулирования динамическим блоком в чертеже его можно сбросить. При сбросе вхождения блока сам блок изменяется в соответствии со значением по умолчанию, указанным в описании блоков. Если масштаб вхождения динамического блока изменяется неравномерно или вхождение расчленяется, оно теряет свои динамические свойства. Блок можно сбросить, восстановив значения по умолчанию, что снова сделает его динамическим.

Некоторые динамические блоки определены таким образом, что геометрию внутри блока можно изменять только до определенных размеров, указанных в описаниях блоков. Если для редактирования вхождения блока используется ручка, в точках расположения допустимых значений для вхождения блока отображаются засечки. Если изменить значение свойства блока на значение, отличное от указанного в описании, будет выбрано ближайшее допустимое значение параметра. Например, согласно описанию длина блока имеет значение 2, 4 и 6. Если изменить это значение расстояния на 10, в результате будет выбрано 6, поскольку это ближайшее допустимое значение.


Работа с динамическими блоками в чертежах - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Работа с динамическими блоками в чертежах
Понятия
Процедуры
Команды

Манипулирование динамическим блоком с помощью настраиваемых ручек

Манипулирование динамическим блоком с помощью настраиваемых свойств

Сброс вхождений блока в чертеже

Изменение цвета отображения настраиваемых ручек


Манипулирование динамическим блоком с помощью настраиваемых ручек - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Работа с динамическими блоками в чертежах
Понятия
Процедуры
Команды

Манипулирование динамическим блоком с помощью настраиваемых ручек

  1. Выберите вхождение динамического блока в чертеже.
  2. Растяните или измените блок с помощью ручек.


Манипулирование динамическим блоком с помощью настраиваемых свойств - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Работа с динамическими блоками в чертежах
Понятия
Процедуры
Команды

Манипулирование динамическим блоком с помощью настраиваемых свойств

  1. Выберите вхождение динамического блока в чертеже.
  2. Измените соответствующие значения в палитре "Свойства" в разделе "Настройка".


Сброс вхождений блока в чертеже - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Работа с динамическими блоками в чертежах
Понятия
Процедуры
Команды

Сброс вхождений блока в чертеже

  1. Выберите вхождение динамического блока в чертеже.
  2. Нажмите в области рисования правой кнопкой мыши. Выберите "Сброс блока".

    3. Примечание Чтобы одновременно сбросить несколько вхождений блока, воспользуйтесь командой СБРОСБЛОКА.

Ввод команды: СБРОСБЛОКА


Изменение цвета отображения настраиваемых ручек - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Работа с динамическими блоками в чертежах
Понятия
Процедуры
Команды

Изменение цвета отображения настраиваемых ручек

  1. Введите в командной строке gripdyncolor.
  2. Введите целое число от 1 до 255 (цвет ACI).
  3. Нажать ENTER.


Работа с динамическими блоками в чертежах - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Работа с динамическими блоками в чертежах
Понятия
Процедуры
Команды

Команды
АТРОБНОВИТЬ | Обновление всех экземпляров указанного блока с текущими атрибутами, заданными для блока
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
СБРОСБЛОКА | Сбрасывает одно или несколько вхождений динамических блоков на значения описаний блоков по умолчанию.
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
BTMARKDISPLAY | Управляет отображением меток наборов значений для вхождений динамического блока
GRIPDYNCOLOR | Управляет цветом специальных ручек для динамических блоков
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Атрибуты блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Атрибуты блоков
Понятия
Процедуры
Команды

Пользователь может связывать с блоками различные текстовые данные и в дальнейшем извлекать их для составления спецификаций, отчетов и т.д..

  • Коротко об атрибутах блоков
  • Создание атрибутов
    Для создания атрибута нужно вначале создать его описание, куда заносятся характеристики атрибута.
  • Извлечение данных из атрибутов
    Если с блоком связаны атрибуты, позднее можно запросить один или несколько чертежей для этих данных атрибутов блока и сохранить их в таблице или внешнем файле.
  • Извлечение данных из атрибутов (метод низкого уровня)
    Файлы шаблонов вывода атрибутов предназначены для извлечения данных из атрибутов из чертежа в отдельный текстовый файл, который впоследствии может быть передан в какую-либо систему управления базами данных.


Атрибуты блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Атрибуты блоков
Понятия
Процедуры
Команды

Для создания описания атрибута

Для редактирования описания атрибута до его связывания с блоком

Изменение порядка описаний атрибутов

Извлечение атрибутов блоков в таблицу или файл

Для обновления таблицы извлечения атрибутов

Отключение уведомления об обновлении для таблиц извлечения атрибутов

Для создания файла шаблона вывода атрибутов

Для извлечения данных из атрибутов


Атрибуты блоков - Команды

Создание и редактирование объектов
Создание и использование блоков (символов)
Атрибуты блоков
Понятия
Процедуры
Команды
Команды
АТОПР | Создание описаний атрибутов
АТРЕД | Изменение данных в атрибутах
АТРИЗВЛЕЧЬ | Экспорт информации атрибута блока в таблицу или внешний файл
АТЭКР | Выполняет общий контроль видимости атрибутов блока в чертеже
АТЭКСП | Извлекает данные атрибута, т.е. связанный с блоком информационный текст, в файл
БЛОКПОРАТР | Задание порядка атрибутов для блока
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
СВОЙСТВА | Изменяет свойства объекта
УРЛРАЗОРВАТЬ | Удаление гиперссылок в чертеже
УРЛСВЯЗАТЬ | Создает гиперссылки для объектов или областей чертежа
Системные переменные
AFLAGS | Задание параметров для атрибутов
ATTDIA | Контроль команды ВСТАВИТЬ: используется ли диалоговое окно для указания значения атрибута.
ATTMODE | Управление отображением атрибутов
ATTREQ | Контроль использования командой ВСТАВИТЬ настроек по умолчанию для атрибутов в процессе вставки блоков.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко об атрибутах блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Коротко об атрибутах блоков
Понятия
Процедуры
Команды

Атрибут представляет собой текстовый объект для связывания с блоком каких-либо данных. В атрибутах могут храниться номера деталей, стоимость, комментарии, фамилии владельцев и т.п. Имя атрибута можно сравнить с названием столбца в таблице базы данных. На чертеже схематично показано применение атрибутов и блоков.

Информацию, хранящуюся в атрибутах чертежа, можно экспортировать из чертежа с последующим использованием в электронных таблицах или базах данных для генерации различных спецификаций. С каждым блоком может быть связано несколько атрибутов, имеющих различные имена.

В процессе вставки блока с несколькими атрибутами последовательно предлагается ввести значение каждого из них. Кроме того, можно задать постоянные атрибуты, значения которых одинаковы для каждого вхождения блока. Запрос на их ввод при вставке блока не выдается.

Атрибуты могут быть скрытыми. Скрытый атрибут не отображается на экране и не выводится на печать. Тем не менее, информация атрибута хранится в файле чертежа и может быть записана в файл извлечения для использования в программе базы данных.

См. также

Изменение атрибутов блока


Атрибуты блоков

Создание и редактирование объектов
Создание и использование блоков (символов)
Атрибуты блоков
Понятия
Процедуры
Команды

Нет процедур.


Коротко об атрибутах блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Коротко об атрибутах блоков
Понятия
Процедуры
Команды

Команды
АТОПР | Создание описаний атрибутов
АТРЕД | Изменение данных в атрибутах
АТЭКР | Выполняет общий контроль видимости атрибутов блока в чертеже
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
AFLAGS | Задание параметров для атрибутов
ATTDIA | Контроль команды ВСТАВИТЬ: используется ли диалоговое окно для указания значения атрибута.
ATTMODE | Управление отображением атрибутов
ATTREQ | Контроль использования командой ВСТАВИТЬ настроек по умолчанию для атрибутов в процессе вставки блоков.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание атрибутов - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание атрибутов
Понятия
Процедуры
Команды

Для создания атрибута нужно вначале создать его описание, куда заносятся характеристики атрибута. Под характеристиками понимаются имя атрибута, текст выдаваемой подсказки, значение по умолчанию, форматирование текста, расположение атрибута и его необязательные режимы (скрытый, постоянный, контролируемый, установленный).

Созданный атрибут включается в набор объектов при создании описания блока. При очередной вставке блока выдаются запросы с заданными в описаниях атрибутов подсказками для ввода значений. Таким образом, при каждой вставке одного блока можно указывать различные значения атрибутов.

В один блок можно включить несколько атрибутов. Например, можно определить атрибуты с метками "Тип", "Изготовитель", “Модель,” и “Цена” и далее включить их в блок с именем СТУЛ.

Если данные из атрибутов планируется использовать для создания каких-либо спецификаций или отчетов, то следует запоминать имена атрибутов. Они понадобятся позже при создании файла шаблона атрибутов.

Устранение ошибок в описаниях атрибутов

Если в описании атрибута обнаружены ошибки, то их можно исправить в окне "Свойства" или командой ДИАЛРЕД перед тем, как связывать атрибут с блоком. Изменять можно имя атрибута, текст запроса и значение по умолчанию.

Связывание атрибутов с блоками

Связывание атрибутов с блоком производится при его создании или переопределении. Атрибуты следует выбрать вместе с другими объектами, включаемыми в блок.

Для связывания атрибутов с блоком нужно вначале создать их описания, а затем выбрать их в ответ на запрос выбора объектов для блока. Порядок выбора атрибутов задает порядок следования запросов на ввод их значений при вставке блока.

Обычно запросы выдаются в том же порядке, в каком выбирались атрибуты при формировании блока. Однако если атрибуты в ходе формирования блока были выбраны с помощью рамки или секущей рамки, запросы выдаются в порядке, обратном порядку создания атрибутов. Воспользуйтесь диспетчером атрибутов блоков, чтобы изменить порядок запросов данных атрибутов при вставке вхождения блока.

Чтобы изменить порядок запросов данных атрибутов при вставке вхождения блока во время работы с редактором блоков, можно также использовать диалоговое окно "Порядок атрибутов". Эта операция доступна, только если в редакторе блоков открыто описание блоков.

Использование атрибутов без связывания с блоками

Имеется возможность создания отдельных атрибутов, не связанных с блоками. Если чертеж, где имеются такие атрибуты, сохранить, то при выполнении вставки этого чертежа в другой чертеж выдаются запросы на ввод значений атрибутов.


Создание атрибутов - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание атрибутов
Понятия
Процедуры
Команды

Для создания описания атрибута

Для редактирования описания атрибута до его связывания с блоком

Изменение порядка описаний атрибутов


Для создания описания атрибута - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание атрибутов
Понятия
Процедуры
Команды

Для создания описания атрибута

  1. В меню "Рисование" нажмите "Блок" » "Задание атрибутов...".
  2. В диалоговом окне "Описание атрибута" указать точку вставки атрибута, задать его имя, подсказку, режимы и параметры текста.
  3. Нажать "ОК".

    4. Созданный атрибут включается в набор объектов при создании описания блока. При очередной вставке блока, имеющего атрибуты, выдается запрос с заданным в описании атрибута текстом. Значения атрибута для разных вхождений блока могут различаться.

Ввод команды: АТОПР


Для редактирования описания атрибута до его связывания с блоком - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание атрибутов
Понятия
Процедуры
Команды

Для редактирования описания атрибута до его связывания с блоком

  1. В меню "Редакт" выберите "Объект" » "Текст".
  2. Выбрать атрибут для редактирования.
  3. В диалоговом окне "Редактирование описания атрибута" указать имя атрибута, подсказку и значение по умолчанию. Затем нажать "OK".

Ввод команды: ДИАЛРЕД


Изменение порядка описаний атрибутов - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Создание атрибутов
Понятия
Процедуры
Команды

Изменение порядка описаний атрибутов

  1. Выберите атрибут блока в редакторе блоков.
  2. Щелкните в области рисования редактора блоков правой кнопкой мыши.
  3. Выберите "Порядок атрибутов".
  4. Выберите описание атрибута в диалоговом окне "Порядок атрибутов".
  5. Щелкните "Вверх" или "Вниз", чтобы изменить порядок описаний атрибутов.
  6. Повторяйте шаги 2 и 3, пока не выберете правильный порядок в списке описаний атрибутов.
  7. Нажать "ОК".

Ввод команды: БЛОКРЕД» БЛОКПОРАТР


Создание атрибутов - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Создание атрибутов
Понятия
Процедуры
Команды

Команды
АТОПР | Создание описаний атрибутов
АТЭКР | Выполняет общий контроль видимости атрибутов блока в чертеже
БЛОКПОРАТР | Задание порядка атрибутов для блока
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
СВОЙСТВА | Изменяет свойства объекта
УРЛРАЗОРВАТЬ | Удаление гиперссылок в чертеже
УРЛСВЯЗАТЬ | Создает гиперссылки для объектов или областей чертежа
Системные переменные
AFLAGS | Задание параметров для атрибутов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Извлечение данных из атрибутов - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Извлечение данных из атрибутов
Понятия
Процедуры
Команды

Если с блоком связаны атрибуты, позднее можно запросить один или несколько чертежей для этих данных атрибутов блока и сохранить их в таблице или внешнем файле.

Извлечение данных атрибутов - это удобный способ создания спецификаций и отчетов о материалах непосредственно из данных чертежей. Например, можно создать чертеж, где каждый блок представляет определенное производственное оборудование. Если с каждым блоком связаны атрибуты, в которых указана модель и производитель оборудования, можно создать отчет о стоимости оборудования.

Процесс выбора чертежей, экземпляров блоков и атрибутов организован с помощью Мастера извлечения атрибутов. С помощью Мастера можно также создать файл срасширением BLK, который будет содержать все настройки для дальнейшего использования.

Вывод в таблицу

Если извлечь данные атрибутов в таблицу, таблица будет вставлена в текущий чертеж и текущее пространство (пространство модели или пространство листа) на текущем слое.

При обновлении таблицы данные атрибутов извлекаются повторно, а строки данных в таблице заменяются. Если в таблицу была добавлена строка названия, одна или несколько строк заголовков или строка сводки, во время обновления они не заменяются.

Примечание Чтобы контекстные меню в области чертежа, которые требуются для редактирования и обновления таблиц, стали доступны, установите флажок "Контекстные меню в области рисования" в диалоговом окне "Параметры" на вкладке "Пользовательские".

Вывод в файл

Для сохранения данных во внешний файл доступны следующие форматы файлов: с разделением запятыми (CSV), с разделением табуляциями (TXT), Microsoft Excel (XLS) и Microsoft Access (MDB).

Если точка (.), запятая (,) или решетка (#) записываются в файл Excel или Access, они заменяются знаками Unicode.


Извлечение данных из атрибутов - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Извлечение данных из атрибутов
Понятия
Процедуры
Команды

Извлечение атрибутов блоков в таблицу или файл

Для обновления таблицы извлечения атрибутов

Отключение уведомления об обновлении для таблиц извлечения атрибутов


Извлечение атрибутов блоков в таблицу или файл - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Извлечение данных из атрибутов
Понятия
Процедуры
Команды

Извлечение атрибутов блоков в таблицу или файл

  • Выберите меню "Сервис" » "Извлечение атрибутов".

    • Открывается диалоговое окно Мастера извлечения атрибутов. Мастер предоставляет пошаговые инструкции для извлечения информации из атрибутов блока в текущем чертеже или других чертежах. Информация используется для создания таблицы в текущем чертеже или сохраняется во внешний файл.

    В разделе Мастер извлечения атрибутов описываются параметры в мастере.

Панель Редактирование-2

Ввод команды: АТРИЗВЛЕЧЬ


Для обновления таблицы извлечения атрибутов - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Извлечение данных из атрибутов
Понятия
Процедуры
Команды

Для обновления таблицы извлечения атрибутов

  • Если в строке состояния отображается уведомление “Необходимо обновить таблицу извлечения атрибутов“, нажмите на "Обновить данные таблицы".


Отключение уведомления об обновлении для таблиц извлечения атрибутов - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Извлечение данных из атрибутов
Понятия
Процедуры
Команды

Отключение уведомления об обновлении для таблиц извлечения атрибутов

  1. Чтобы отключить уведомление для всех таблиц в чертеже, в которых оно включено, нажмите правой кнопкой мыши значок уведомления в строке состояния. Снимите флажок "Включить уведомления для данных таблицы отсутствия синхронизации".
  2. Чтобы отключить уведомление для выбранной таблицы, щелкните правой кнопкой мыши. Выберите параметр "Отключить уведомления для этой таблицы".

При использовании Мастера извлечения атрибутов возможность обновления включена по умолчанию на странице "Стили таблиц".


Извлечение данных из атрибутов - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Извлечение данных из атрибутов
Понятия
Процедуры
Команды

Команды
АТРИЗВЛЕЧЬ | Экспорт информации атрибута блока в таблицу или внешний файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Извлечение данных из атрибутов (метод низкого уровня) - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Извлечение данных из атрибутов (метод низкого уровня)
Понятия
Процедуры
Команды

Имеется возможность извлечения данных из атрибутов из чертежа в отдельный текстовый файл, который впоследствии может быть передан в какую-либо систему управления базами данных. Это позволяет легко создавать различные спецификации и отчеты, опираясь на данные, содержащиеся в базах данных внутри чертежей. Извлечение информации, хранящейся в атрибутах, никак не влияет на чертеж.

Для создания спецификации или отчета

  • Создать и отредактировать описание атрибута.
  • Ввести значения атрибутов в процессе выполнения вставки блоков.
  • Создать файл шаблона и затем извлечь данные из атрибутов в текстовый файл.

Для извлечения данных из атрибутов вначале создается файл шаблона атрибутов с помощью любого текстового редактора, затем с помощью AutoCAD формируется файл вывода атрибутов, который, наконец, можно передать в систему управления базами данных. Если данные атрибутов необходимо выводить в DXF-файл графического обмена, то создание шаблона не требуется.

Примечание Необходимо убедиться в том, что имена файла вывода атрибутов и файла шаблона атрибутов не совпадают.

Создание файла шаблона вывода атрибутов

Перед тем как извлекать данные из атрибутов, вначале необходимо создать текстовый (ASCII) файл шаблона, описывающий структуру формируемого файла, куда должны выводится данные. В файле шаблона содержится информация об именах выводимых атрибутов, типах данных, длине полей и количестве знаков представления числовых значений.

Поля файла шаблона описывают информацию, извлекаемую из вхождений блоков чертежа. Каждая строка в шаблоне соответствует одному полю в файле вывода; она задает имя поля, его ширину (в символах) и точность представления. Каждая запись в файле вывода включает в себя заданные поля именно в том порядке, в каком они перечислены в шаблоне.

В следующем файле шаблона перечислено 15 возможных полей. N означает числовой тип, C символьный тип, www общая длина поля в виде трехзначного числа, ddd число выводимых знаков после десятичной точки в виде трехзначного числа.

BL:NAMECwww000 (Имя блока)

BL:LEVELNwww000 (Уровень вложенности блокаl)

BL:X Nwwwddd(Координата X точки вставки)

BL:Y Nwwwddd(Координата Y)

BL:Z Nwwwddd(Координата Z)

BL:NUMBERNwww000 (Счетчик блоков; один и тот же для блоков, вставленных по МВСТАВИТЬ)

BL:HANDLECwww000 (Метка блоков; одна и та же для блоков, вставленных по МВСТАВИТЬ)

BL:LAYERCwww000 (Имя слоя вставки блока)

BL:ORIENT Nwwwddd(Угол поворота блока)

BL:XSCALE Nwwwddd(Масштаб по X)

BL:YSCALE Nwwwddd(Масштаб по Y)

BL:ZSCALE Nwwwddd(Масштаб по Z)

BL:XEXTRUDE Nwwwddd(Составляющая X вектора выдавливания)

BL:YEXTRUDE Nwwwddd(Составляющая Y вектора выдавливания)

BL:ZEXTRUDE Nwwwddd(Составляющая Z вектора выдавливания)

numericNwwwddd (Числовой атрибут)

characterCwww000 (Символьный атрибут)

Шаблон может включать в себя все или некоторые из полей типа BL:xxxxxxx, перечисленных выше. Включенные в шаблон имена атрибутов задают, данные каких атрибутов (и, следовательно, каких блоков) включаются в файл вывода. Значения заданных в шаблоне, но не содержащихся в блоке атрибутов, заменяются пробелами (для символьных) или нулями (для числовых).

Пояснения о назначении стандартных полей приведены здесь исключительно в качестве комментария; включаться в шаблон они не должны.

В шаблоне вывода атрибутов задаются сведения об атрибутах; например, о наименовании детали, номере модели, стоимости и поставщике, как показано на чертеже блока с атрибутами и в таблице.

Поле | Символьные (C) или числовые (N) данные | Максимальная длина поля | Число десятичных знаков
Тип | C | 040 | 000
Изготовитель | C | 006 | 000
Модель | C | 015 | 000
Цена | N | 006 | 002

Число создаваемых файлов шаблонов не ограничивается. Каждая запись в файле шаблона описывает одно поле, сохраняемое в файле вывода атрибутов.

При создании файла шаблона вывода атрибутов рекомендуется придерживаться следующих правил:

  • Между именем атрибута и описанием формата выводимого значения должен стоять символ пробела. Для ввода пробела следует использовать не символ табуляции, а планку пробела.
  • Каждую строку файла, включая последнюю, необходимо заканчивать нажатием ENTER.
  • Файл шаблона должен содержать хотя бы одно поле с именем атрибута, и каждое из полей может упоминаться в шаблоне не более одного раза.

Ниже приведен пример простого файла шаблона для извлечения информации из атрибутов.

BL:NAME C008000 (Имя блока, 8 символов)

BL:X N007001 (Координата X, в формате nnnnnn.d)

BL:Y N007001 (Координата Y, в формате nnnnnn.d)

SUPPLIER C016000 (Фирма-изготовитель, 16 символов)

MODEL C009000 (Номер модели, 9 символов)

PRICE N009002 (Стоимость единицы, в формате nnnnnnnn.dd)

Примечание В общую длину числового поля входит и десятичная точка. Например, для вывода числа 249.95 требуется хотя бы 6 позиций; формат записи может выглядеть как N006002. Для описания символьных полей не нужно указывать три последние цифры, как для числовых полей.

Создание файла вывода атрибутов

После создания файла шаблона пользователь может извлечь данные из атрибутов, сохранив их в файле вывода в одном из форматов:

  • Формат файла с разделителями-запятыми (CDF)
  • Формат файла с разделителями-пробелами (SDF)
  • Формат файла обмена графическими данными (DXF)

Файл формата CDF содержит по одной записи для каждого вхождения блока в чертеж. Поля записи разделяются запятыми, а символьные поля заключаются в апострофы. Некоторые системы управления базами данных могут непосредственно воспринимать данный формат.

Файл формата SDF также содержит по одной записи для каждого вхождения блока в чертеж. Поля каждой записи имеют фиксированную длину и не требуют ни разделителей, ни ограничителей символьных полей. Операция dBASE III Copy . . . SDF также формирует файлы в формате SDI. Операция Append From ... SDF позволяет читать файлы в формате dBASE IV, которые легко обрабатываются пользовательскими программами, написанными на языке FORTRAN.

При выводе в формате DXF образуется подмножество файла обмена чертежами, содержащее только вхождения блоков, атрибуты и символы конца последовательности. В данном случае файл шаблона вывода атрибутов не требуется. Выходные файлы отличаются от стандартных DXF-файлов своим расширением (.dxx ).

Использование файла вывода атрибутов

Файл вывода атрибутов содержит список значений и других сведений всех атрибутов, вывод которых описан в шаблоне.

Если при выводе с помощью шаблона применяется формат CDF, то файл вывода может иметь следующий вид:

'DESK', 120.0, 49.5, 'ACME INDUST.', '51-793W', 379.95

'CHAIR', 122.0, 47.0, 'ACME INDUST.', '34-902A', 199.95

'DESK', -77.2, 40.0, 'TOP DRAWER INC.', 'X-52-44',249.95

По умолчанию, символьные поля заключаются в апострофы. Разделителем по умолчанию является запятая. Для переопределения этих настроек можно использовать две следующие записи в шаблоне:

C:QUOTE c(Ограничитель символьной строки)

C:DELIM c(Разделитель полей)

Символ, следующий сразу (без пробела) за именем поля C:QUOTE или C:DELIM определяет соответственно ограничитель символьных строк или разделитель полей. Например, для того чтобы символьные строки заключались в кавычки, необходимо вписать в шаблон следующую строку:

C:QUOTE "

Ограничителем символьных строк не может быть символ, встречающийся в символьных значениях полей. Аналогично, разделителем полей не может быть символ, встречающийся в числовых значениях полей.

Если при выводе с помощью шаблона применяется формат SDF, то файл вывода может иметь следующий вид:

(NAME) | (X) | (Y) | (SUPPLIER) | (МОДЕЛЬ) | (PRICE)
DESK | 120.0 | 49.5 | ACME INDUST. | 51-793W | 379.95
CHAIR | 122.0 | 47.0 | ACME INDUST. | 34-902A | 199.95
DESK | -77.2 | 40.0 | TOP DRAWER INC. | X-52-44 | 249.95

Порядок вывода полей соответствует порядку описания полей в файле шаблона. Файлы, полученные после вывода атрибутов, могут использоваться в других приложениях, включая электронные таблицы. Данные из этих файлов могут в дальнейшем сортироваться и обрабатываться. О порядке работы с данными других приложений см. документацию по используемому приложению обработки электронных таблиц. Если полученный файл открыть в Блокноте или каком-либо другом текстовом редакторе Windows, то данные из файла можно вставить в чертеж в виде текста с помощью буфера обмена.

Вложенные блоки

Строка BL:LEVEL шаблона определяет уровень вложенности блока. Блок, вставленный в чертеж, имеет уровень вложенности 1. Вхождение блока, являющегося частью первого блока, имеет уровень вложенности 2 и т.д.

Во вложенном вхождении блока координаты, масштабные коэффициенты, вектор выдавливания и угол поворота отражают реальные значения вложенного блока в Мировой системе координат.

В некоторых случаях, вложенные вхождения блоков невозможно корректно представить, оперируя только двумя масштабными коэффициентами и углом поворота. К таким случаям можно отнести вхождение блока, повернутое в трехмерном пространстве. В этой ситуации, масштабные коэффициенты и угол поворота в записях файла вывода отображаются значением 0.

Обработка ошибок

Если заданная длина поля недостаточна для представления значения атрибута, то конец значения отсекается, затем появляется следующее сообщение:

** Переполнение в поле записи <номер_записи>

Подобная ошибка может произойти, например, если в шаблоне для поля BL:NAME указана длина поля 8, а в чертеже содержится имя длиной 10 символов.


Извлечение данных из атрибутов (метод низкого уровня) - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Извлечение данных из атрибутов (метод низкого уровня)
Понятия
Процедуры
Команды

Для создания файла шаблона вывода атрибутов

Для извлечения данных из атрибутов


Для создания файла шаблона вывода атрибутов - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Извлечение данных из атрибутов (метод низкого уровня)
Понятия
Процедуры
Команды

Для создания файла шаблона вывода атрибутов

  1. Открыть программу "Блокнот".

    2. Можно также воспользоваться любым другим текстовым редактором, работающим с текстами в формате ASCII.

  2. Ввести данные шаблона. Подробнее о формате шаблона см. в разделе Извлечение данных из атрибутов (метод низкого уровня).
  3. Сохранить файл с расширением .txt.

    4. Для извлечения данных конкретного атрибута подставить его имя вместо элементов "числовой" или "символьный" приведенной выше таблицы.

Предупреждение При создании файла шаблона не следует использовать символы табуляции. При использовании для выравнивания символов табуляции выходной файл не создается. Для выравнивания столбцов следует использовать обычные пробелы, нажимая плаанку пробела. При использовании символов табуляции текст может располагаться неравномерно.


Для извлечения данных из атрибутов - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Извлечение данных из атрибутов (метод низкого уровня)
Понятия
Процедуры
Команды

Для извлечения данных из атрибутов

  1. В командной строке ввести атэксп.
  2. В диалоговом окне "Извлечение атрибутов" выберите нужный формат файла: CDF, SDF или DXF.
  3. Нажать кнопку "Выбрать объекты" и указать объекты, данные из атрибутов которых нужно извлечь.

    4. На чертеже можно выбрать один или несколько блоков.

  4. Ввести имя файла шаблона или нажать кнопку "Файл шаблона" и выбрать нужный файл.
  5. Ввести имя файла вывода или нажать кнопку "Файл вывода" и выбрать нужный файл.
  6. Нажать "ОК".

Ввод команды: АТЭКСП


Извлечение данных из атрибутов (метод низкого уровня) - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Извлечение данных из атрибутов (метод низкого уровня)
Понятия
Процедуры
Команды

Команды
АТРИЗВЛЕЧЬ | Экспорт информации атрибута блока в таблицу или внешний файл
АТЭКСП | Извлекает данные атрибута, т.е. связанный с блоком информационный текст, в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Редактирование блоков
Понятия
Процедуры
Команды

Имеется возможность редактирования описаний блоков и вхождений блоков уже после их вставки в чертеж.

  • Редактирование описаний блоков
    Изменения описаний блоков в текущем чертеже оказывают действие как на уже созданные в чертеже вхождения блоков, так и на создаваемые в дальнейшем.
  • Изменение атрибутов блока
    Имеется возможность редактирования значений и других свойств атрибутов, уже связанных с вставленными в чертеж блоками.


Редактирование блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Редактирование блоков
Понятия
Процедуры
Команды

Для обновления блока при изменении исходного файла

Для редактирования пояснения к блоку

Для редактирования атрибутов в описаниях блоков

Для включения и отключения применения изменений к существующим вхождениям блоков

Для нахождения одинаковых имен атрибутов блока

Для изменение порядка запросов на ввод значений атрибутов

Для удаления атрибута из описания блока и из всех вхождений блоков

Для обновления измененных атрибутов в существующих вхождениях блоков

Для обновления атрибутов во вхождениях, связанных с выбранным описанием блока


Редактирование блоков - Команды

Создание и редактирование объектов
Создание и использование блоков (символов)
Редактирование блоков
Понятия
Процедуры
Команды
Команды
АТРЕДАКТ | Редактирование атрибутов во вхождениях блоков
АТРОБНОВИТЬ | Обновление всех экземпляров указанного блока с текущими атрибутами, заданными для блока
БЛОК | Создание описания блока из выбранных объектов
ДИСПАТБЛК | Редактирование свойств атрибутов в описаниях блоков
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование описаний блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Редактирование описаний блоков
Понятия
Процедуры
Команды

Пользователь может переопределять описания блоков в текущем чертеже. Изменения описаний блоков в текущем чертеже оказывают действие как на уже созданные в чертеже вхождения блоков, так и на создаваемые в дальнейшем, а также на любые связанные с блоками атрибуты.

Существует два способа редактирования описания блока:

  • Изменение описания блока в текущем чертеже.
  • Изменение описания блока в исходном файле и его повторная вставка в текущий чертеж.

Выбор метода зависит от того, необходимо ли внести изменения только в текущий чертеж или нужно изменить также исходный файл блока.

Изменение описания блока в текущем чертеже.

Для изменения описания блока следует выполнить все действия по созданию нового блока, но вводимое имя должно совпадать с именем редактируемого описания блока. При переопределении все имеющиеся вхождения блока в чертеже немедленно обновляются.

Чтобы облегчить задачу, можно выполнить вставку блока с его расчленением, а затем полученные таким образом объекты использовать для создания нового описания блока.

Обновление блока при изменении исходного файла

Изменение исходного чертежа блока не оказывает немедленного действия на текущий чертеж, куда вставлен этот блок. Для обновления блока в текущем чертеже, вставленного из исходного файла, следует воспользоваться командой ВСТАВИТЬ.

Обновление блока при изменении библиотеки компонентов

Центр управления™ не вызывает перезапись имеющегося описания блока на чертеже описанием блока, вставляемым из другого чертежа. Для обновления описания блока из библиотеки можно использовать команду ПБЛОК, которая создает отдельный файл блока из библиотеки компонентов. Затем используется команда ВСТАВИТЬ для перезаписи описания блока на чертеже, где используется блок.

Примечание При использовании команды ВСТАВИТЬ пояснения к блокам сбрасываются. Текстовые пояснения к блокам, выводимые в диалоговом окне "Описание блока", можно копировать между описаниями блоков через буфер обмена.

Редактирование пояснений для блоков

Для изменения пояснений к блокам, отображаемых в Центре управления, следует использовать команду БЛОК. Кроме того, в диалоговом окне "Описание блока" можно также добавлять пояснения к имеющимся блокам.

Переопределение атрибутов блоков

Связывание атрибутов с блоком производится при его создании или переопределении. Необходимые атрибуты включаются в блок во время выбора объектов для блока. Переопределение атрибутов в описании блока оказывает следующие действия на уже созданные вхождения блоков:

  • Постоянные атрибуты, имеющие фиксированные значения (константы), теряются или заменяются новыми атрибутами.
  • Переменные атрибуты остаются без изменений, даже если в новом описании блока совсем нет атрибутов.
  • Новые атрибуты в имеющихся вхождениях блоков не появляются.

См. также

Атрибуты блоков

Изменение описаний динамических блоков


Редактирование описаний блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Редактирование описаний блоков
Понятия
Процедуры
Команды

Для обновления блока при изменении исходного файла

Для редактирования пояснения к блоку


Для обновления блока при изменении исходного файла - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Редактирование описаний блоков
Понятия
Процедуры
Команды

Для обновления блока при изменении исходного файла

  1. Из меню "Сервис" выбрать "Центр управления".
  2. Из списка папок выбрать папку, содержащую исходный файл чертежа.
  3. Нажать правой кнопкой мыши на файле чертежа.
  4. Выбрать "Вставить как блок" из контекстного меню.
  5. В диалоговом окне "Вставка блока" нажать "ОК".
  6. Нажать "Да" в диалоговом окне для перезаписи описания блока.
  7. Нажать ESC для выхода из команды.


Для редактирования пояснения к блоку - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Редактирование описаний блоков
Понятия
Процедуры
Команды

Для редактирования пояснения к блоку

  1. Из меню "Редакт" выберите "Объекты" » "Пояснение к блоку".
  2. В диалоговом окне "Описание блока" выбрать блок, пояснение к которому необходимо отредактировать.
  3. В поле "Пояснение" ввести новое или изменить имеющееся пояснение для блока.
  4. Нажать "ОК".
  5. Появляется сообщение с запросом подтверждения на переопределение блока. Нажать "Да".

Ввод команды: БЛОК


Редактирование описаний блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Редактирование описаний блоков
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение атрибутов блока - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение атрибутов блока
Понятия
Процедуры
Команды

Имеется возможность редактирования значений и других свойств атрибутов, уже связанных с вставленными в чертеж блоками.

Изменение атрибутов описаний блоков выполняется с помощью Диспетчера атрибутов блоков. Например, в нем можно редактировать:

  • Свойства, определяющие порядок присваивания значений атрибутам и отвечающие за вывод или подавление отображения значений в графической области
  • Свойства, управляющие отображением текста атрибутов на чертеже
  • Свойства, определяющие слой, цвет, вес и тип линий для вывода атрибутов

По умолчанию изменение атрибутов оказывает действие на все имеющиеся вхождения блоков в текущем чертеже.

Изменение свойств атрибутов существующих вхождений блоков не влияет на значения, связанные с этими блоками. Например, если атрибут блока имеет имя "Стоимость" со значением 19,99, то после изменения имени атрибута на "Стоимость единицы" значение останется прежним.

Обновление атрибутов с одинаковыми именами может привести к непредсказуемым результатам. Для выявления одинаковых имен и их изменения можно воспользоваться Диспетчером атрибутов блоков.

Для обновления вхождений блоков в графической области после изменения их постоянных атрибутов и атрибутов вложенных блоков используется команда РЕГЕН.

Изменение порядка запросов на ввод значений атрибутов

Во время создания описания блока порядок выбора атрибутов задает порядок следования запросов на ввод их значений при вставке блока. Изменить этот порядок можно с помощью Диспетчера атрибутов блоков.

Удаление атрибутов блока

В текущем чертеже пользователь может удалять атрибуты из описаний блоков, а также из всех существующих вхождений блоков. Атрибуты, удаленные из вхождений блоков, не исчезают в области рисования до регенерации чертежа пользователем с помощью команды РЕГЕН.

Нельзя таким способом удалить все атрибуты из блока; хотя бы один атрибут в блоке должен остаться. Если необходимо удалить все атрибуты, следует переопределить блок.

Обновление вхождений блоков

После внесения изменений в описания блоков пользователь может обновлять вхождения блоков в текущем чертеже. При редактировании свойств атрибутов в описаниях блоков с помощью Диспетчера атрибутов блоков автоматического обновления в чертеже существующих вхождений блоков не происходит. После завершения внесения изменений пользователь может применить изменения ко всем блокам текущего чертежа.

Можно также использовать ATTSYNC для обновления свойств атрибутов во вхождениях блоков с целью согласования с их пояснениями к блокам либо для обновления экземпляра блока после переопределения атрибута блока с помощью команды БЛОК, -БЛОК или БЛОКРЕД.

Обновление свойств атрибутов во вхождениях блоков не оказывает никакого влияния на значения этих атрибутов.

Редактирование атрибутов во вхождениях блоков

Можно выбрать атрибут во вхождении блока и использовать палитру "Свойства" с целью изменения их свойств либо можно использовать Дополнительный редактор атрибутов с целью изменения всех атрибутов в выбранном вхождении блока.

См. также

Создание атрибутов

Редактирование описаний блоков


Изменение атрибутов блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение атрибутов блока
Понятия
Процедуры
Команды

Для редактирования атрибутов в описаниях блоков

Для включения и отключения применения изменений к существующим вхождениям блоков

Для нахождения одинаковых имен атрибутов блока

Для изменение порядка запросов на ввод значений атрибутов

Для удаления атрибута из описания блока и из всех вхождений блоков

Для обновления измененных атрибутов в существующих вхождениях блоков

Для обновления атрибутов во вхождениях, связанных с выбранным описанием блока


Для редактирования атрибутов в описаниях блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение атрибутов блока
Понятия
Процедуры
Команды

Для редактирования атрибутов в описаниях блоков

  1. Из меню "Редакт" выбрать "Объекты" » "Атрибуты" » "Диспетчер атрибутов блоков".
  2. В Диспетчере атрибутов блоков выбрать блок из списка или нажать "Выбрать блок" для указания блока в графической области.
  3. В списке атрибутов дважды щелкнуть мышью на имени редактируемого атрибута или, выделив его, нажать "Редактировать".
  4. В диалоговом окне "Редактирование атрибута" внести все необходимые изменения и нажать "OK".

Панель Редактирование-2

Ввод команды: ДИСПАТБЛК


Для включения и отключения применения изменений к существующим вхождениям блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение атрибутов блока
Понятия
Процедуры
Команды

Для включения и отключения применения изменений к существующим вхождениям блоков

  1. Из меню "Редакт" выбрать "Объекты" » "Атрибуты" » "Диспетчер атрибутов блоков".
  2. В Диспетчере атрибутов блоков нажать "Параметры".
  3. В диалоговом окне "Параметры" выполнить одно из действий:
    • Для применения внесенных изменений к существующим вхождениям блоков установите флажок "Применять к имеющимся вхождениям".
    • Для применения внесенных изменений только к новым вхождениям блоков снимите флажок "Применять к имеющимся вхождениям".
  4. Нажать "ОК".

Панель Редактирование-2

Ввод команды: ДИСПАТБЛК


Для нахождения одинаковых имен атрибутов блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение атрибутов блока
Понятия
Процедуры
Команды

Для нахождения одинаковых имен атрибутов блока

  1. Из меню "Редакт" выбрать "Объекты" » "Атрибуты" » "Диспетчер атрибутов блоков".
  2. В Диспетчере атрибутов блоков нажать "Параметры".
  3. В диалоговом окне "Параметры" установить опцию "Выделять повторные имена".
  4. Нажать "ОК".

Панель Редактирование-2

Ввод команды: ДИСПАТБЛК


Для изменение порядка запросов на ввод значений атрибутов - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение атрибутов блока
Понятия
Процедуры
Команды

Для изменение порядка запросов на ввод значений атрибутов

  1. Из меню "Редакт" выбрать "Объекты" » "Атрибуты" » "Диспетчер атрибутов блоков".
  2. В Диспетчере атрибутов блоков выбрать блок из списка или нажать "Выбрать блок" для указания блока в графической области.

    3. Для выбранного блока выводится список атрибутов в порядке выполнения запросов на ввод их значений.

  3. Для изменения положения атрибута в списке выделить его и нажать кнопку "Вверх" для перемещения вверх по списку или кнопку "Вниз" для перемещения вниз.

    4. Примечание Для постоянных атрибутов (Режим=C), определяющих константы, эти кнопки недоступны.

Панель Редактирование-2

Ввод команды: ДИСПАТБЛК


Для удаления атрибута из описания блока и из всех вхождений блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение атрибутов блока
Понятия
Процедуры
Команды

Для удаления атрибута из описания блока и из всех вхождений блоков

  1. Из меню "Редакт" выбрать "Объекты" » "Атрибуты" » "Диспетчер атрибутов блоков".
  2. В Диспетчере атрибутов блоков выбрать блок из списка или нажать "Выбрать блок" для указания блока в графической области.
  3. (Не обязательно) Если атрибуты не нужно удалять из существующих экземпляров блока, щелкните "Настройки" и в диалоговом окне настроек снимите флажок "Применять к имеющимся вхождениям".
  4. В Диспетчере атрибутов блоков выделить атрибут в списке и нажать "Удалить".

    5. Атрибуты, удаленные из имеющихся экземпляров блоков, не исчезают в графической области до регенерации чертежа пользователем с помощью команды РЕГЕН.

Панель Редактирование-2

Ввод команды: ДИСПАТБЛК


Для обновления измененных атрибутов в существующих вхождениях блоков - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение атрибутов блока
Понятия
Процедуры
Команды

Для обновления измененных атрибутов в существующих вхождениях блоков

  1. Из меню "Редакт" выбрать "Объекты" » "Атрибуты" » "Диспетчер атрибутов блоков".
  2. В Диспетчере атрибутов блоков выбрать блок из списка или нажать "Выбрать блок" для указания блока в графической области.
  3. Нажать "Обновить" для обновления измененных атрибутов во всех вхождениях, связанных с выбранным блоком.

Панель Редактирование-2

Ввод команды: ДИСПАТБЛК


Для обновления атрибутов во вхождениях, связанных с выбранным описанием блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение атрибутов блока
Понятия
Процедуры
Команды

Для обновления атрибутов во вхождениях, связанных с выбранным описанием блока

  1. На панели "Редактирование-2" нажать кнопку "Обновить атрибуты".
  2. Выполнить одно из действий:
    • Ввести имя, затем ввести имя блока, вхождения которого следует обновить.
    • Ввести ? для получения списка блоков, затем введите имя и имя блока.
    • Нажмите ENTER и затем укажите блок в области чертежа с помощью указывающего устройства.

    При вводе имени несуществующего блока или при выборе блока, не имеющего атрибутов, появляется сообщение об ошибке.

Панель Редактирование-2

Ввод команды: АТРОБНОВИТЬ

Другой способ

  1. Из меню "Редакт" выбрать "Объекты" » "Атрибуты" » "Один".
  2. В графической области выбрать блок для редактирования.
  3. В Редакторе атрибутов блоков выбрать атрибут для редактирования. Пользователь может изменить значение атрибута или перейти на другую вкладку для редактирования других свойств атрибута.
  4. Внести необходимые изменения и затем выполнить одно из следующих действий:
    • Нажать "Применить" для сохранения изменений. Редактор атрибутов блоков остается открытым.

      • При нажатии кнопки "Отмена" для выхода из Редактора атрибутов блоков все изменения, сохраненные нажатием кнопки "Применить", остаются в силе.

    • Нажать "OK" для сохранения изменений и выхода из Редактора атрибутов блоков.
    • Нажать "Выбрать блок" для редактирования атрибутов другого блока. Если выполненные изменения для текущего блока не были сохранены, то перед началом выбора нового блока выдается запрос на сохранение.

Панель Редактирование-2

Ввод команды: АТРЕДАКТ


Изменение атрибутов блока - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Изменение атрибутов блока
Понятия
Процедуры
Команды

Команды
АТРЕДАКТ | Редактирование атрибутов во вхождениях блоков
АТРОБНОВИТЬ | Обновление всех экземпляров указанного блока с текущими атрибутами, заданными для блока
ДИСПАТБЛК | Редактирование свойств атрибутов в описаниях блоков
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение цвета и типа линий в блоке - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение цвета и типа линий в блоке
Понятия
Процедуры
Команды

Изменение цвета и типа линий объектов блока доступно лишь в том случае, если свойства объектов являются наследуемыми.

Блок, содержащий объекты с наследуемыми свойствами, передает цвет и тип линий слоя, куда он вставляется, своим объектам. Если создание объектов блока выполняется с выполнением определенных условий, то пользователь может устанавливать в чертеже текущие цвет и тип линий, переопределяя тем самым свойства, наследуемые объектами блока.

Если объекты блока созданы с явно заданными свойствами, то единственный способ изменить их свойства это переопределение блока.

См. также

Цвета и типы линий объектов в блоках


Изменение цвета и типа линий в блоке - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение цвета и типа линий в блоке
Понятия
Процедуры
Команды

Для переноса объекта на другой слой

Для назначения цвета слою

Для назначения цвета объекту для использования вместо цвета слоя

Для назначения типа линий слою

Для назначения типа линий объекту для использования вместо типа линий слоя

Для изменения описания имеющегося блока


Для переноса объекта на другой слой - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение цвета и типа линий в блоке
Понятия
Процедуры
Команды

Для переноса объекта на другой слой

  1. Выбрать объекты, которые необходимо перенести на другой слой.
  2. На панели "Слои" щелкнуть на управляющем списке "Слой".
  3. Выбрать слой, на который требуется перенести объекты.

Ввод команды: СЛОЙ


Для назначения цвета слою - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение цвета и типа линий в блоке
Понятия
Процедуры
Команды

Для назначения цвета слою

  1. На панели "Слои" выбрать "Диспетчер свойств слоев".
  2. В окне Диспетчера свойств слоев щелкнуть на цвете, который нужно изменить.
  3. В диалоговом окне "Выбор цвета" выполнить одно из следующих действий:
    • На вкладке "Номер цвета" выбрать цвет и нажать "OK".
    • На вкладке "Номер цвета" ввести в поле "Цвет" порядковый номер (1-255). Затем нажать "OK".
    • На вкладке "Вся палитра" выбрать цветовую модель "HSL" и задать значения "H (оттенок)", "S (насыщенность)" и "L (яркость)". Затем нажать "OK".
    • На вкладке "Альбомы цветов" выбрать необходимый альбом, выбрать требуемый цвет. Нажать "ОК".
  4. Нажать "ОК".

Панель Слои

Ввод команды: СЛОЙ


Для назначения цвета объекту для использования вместо цвета слоя - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение цвета и типа линий в блоке
Понятия
Процедуры
Команды

Для назначения цвета объекту для использования вместо цвета слоя

  1. На панели "Стандартная" нажать кнопку "Свойства".
  2. Выбрать объекты, цвета которых необходимо изменить.
  3. В панели "Свойства" выбрать свойство "Цвет".

    4. Справа от поля располагается кнопка со стрелкой.

  4. Щелкнуть на этой кнопке для раскрытия списка и выбрать необходимый цвет.

Панель Стандартная

Ввод команды: ОКНОСВ


Для назначения типа линий слою - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение цвета и типа линий в блоке
Понятия
Процедуры
Команды

Для назначения типа линий слою

  1. На панели "Слои" выбрать "Диспетчер свойств слоев".
  2. В окне "Диспетчер свойств слоев" нажать "Загрузить" и выбрать один или несколько типов линий для их загрузки. Затем нажать "OK".

    3. Для выделения нескольких типов линий используется клавиша CTRL; для выделения диапазона типов линий - клавиша SHIFT.

  3. Выделить слой из списка и нажать "Вкл подробности" для получения доступа к дополнительным опциям диалогового окна.
  4. Выбрать тип линий из списка "Тип линий".
  5. Нажать кнопку "OK".

    6. Диспетчер свойств слоев, где осуществляется выбор слоя, можно вызывать из меню "Формат".

Панель Слои

Ввод команды: СЛОЙ


Для назначения типа линий объекту для использования вместо типа линий слоя - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение цвета и типа линий в блоке
Понятия
Процедуры
Команды

Для назначения типа линий объекту для использования вместо типа линий слоя

  1. Выбрать объекты, типы линий которых необходимо изменить.
  2. Щелкнуть на управляющем списке "Типы линий" панели "Свойства".
  3. Выбрать тип линий для назначения объектам.

Ввод команды: ТИПЛИН


Для изменения описания имеющегося блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Изменение цвета и типа линий в блоке
Понятия
Процедуры
Команды

Для изменения описания имеющегося блока

  1. Выбрать редактируемый блок.
  2. Щелкнуть правой кнопкой мыши на блоке и выбрать "Свойства" из контекстного меню.
  3. В окне "Свойства" выделить и изменить значения X и Y координат базовой точки, масштабных коэффициентов, угла поворота и других параметров.

Ввод команды: ОКНОСВ


Изменение цвета и типа линий в блоке - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Изменение цвета и типа линий в блоке
Понятия
Процедуры
Команды

Команды
СВОЙСТВА | Изменяет свойства объекта
СЛОЙ | Управление слоями и их свойствами
ТИПЛИН | Загрузка, установка и изменение типов линий
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Расчленение блока - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Расчленение блока
Понятия
Процедуры
Команды

Для того чтобы получить возможность редактировать отдельные объекты, входящие в блок, необходимо выполнить его расчленение на отдельные компоненты. После этого пользователь может:

  • Создать описание нового блока
  • Переопределить описание имеющегося блока
  • Сохранить объекты в разрозненном виде для различных целей

Имеется возможность автоматического расчленения блоков на месте создаваемых вхождений блоков путем включения опции "Расчленить" диалогового окна "Вставка блока".


Расчленение блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Расчленение блока
Понятия
Процедуры
Команды

Для расчленения блока

Управление свойствами при расчленении объекта


Для расчленения блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Расчленение блока
Понятия
Процедуры
Команды

Для расчленения блока

  1. Из меню "Редакт" выбрать "Расчленить".
  2. Выберите блок для расчленения и нажмите ENTER.

    3. Блок на месте вхождения расчленяется на отдельные объекты; однако описание блока сохраняется для возможности выполнения вставки в дальнейшем.

Панель Редактирование

Ввод команды: РАСЧЛЕНИТЬ


Управление свойствами при расчленении объекта - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Расчленение блока
Понятия
Процедуры
Команды

Управление свойствами при расчленении объекта

  1. Введите расчленить
  2. Выбрать объекты для расчленения.
  3. Если выбрано более одного объекта, введите и с целью управления свойствами для индивидуальных объектов либо введите г с целью управления свойствами для всех выбранных объектов.
  4. Введите опцию для свойства, которое необходимо изменить.

    5. Свойство применяется к составному объекту, и заново выводится подсказка.

  5. Введите другую опцию или введите р для расчленения выбранных объектов.

    6. Выбранные объекты расчленяются, и указанные свойства применяются к компонентным объектам.


Расчленение блока - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Расчленение блока
Понятия
Процедуры
Команды

Команды
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Удаление описаний блоков - Понятия

Создание и редактирование объектов
Создание и использование блоков (символов)
Удаление описаний блоков
Понятия
Процедуры
Команды

Для сокращения размера чертежа неиспользуемые описания блоков можно удалить. Для сокращения размера чертежа неиспользуемые описания блоков можно удалить. Пользователь может удалять из чертежа вхождения блоков, однако при этом описание блока сохраняется в таблице описаний блоков чертежа.

Перед удалением описания блока необходимо предварительно удалить все связанные с ним вхождения блоков.

См. также

Базовые понятия для блоков


Для удаления описания блока - Процедуры

Создание и редактирование объектов
Создание и использование блоков (символов)
Удаление описаний блоков
Понятия
Процедуры
Команды

Для удаления описания блока

  1. Из меню "Файл" выберите "Утилиты построения" » "Очистить".

    2. Появляется диалоговое окно "Очистка чертежа", отображающее дерево именованных объектов, которые можно удалить.

  2. Для удаления неиспользуемых описаний блоков следует воспользоваться одним из следующих способов:
    • Для очистки чертежа от описаний всех неиспользуемых блоков выбрать "Блоки". Для включения вложенных блоков в список отметить опцию "Удаление вложенных элементов".
    • Для удаления описаний только некоторых неиспользуемых блоков дважды щелкнуть на элементе "Блоки" для раскрытия списка блоков. Выбрать блоки для удаления.

    Если нужные элементы отсутствуют в списке, включить опцию "Просмотреть элементы, которые нельзя удалить".

  3. Удаление каждого элемента из списка требуется подтвердить. Для подавления запросов перед каждым удалением можно предварительно отключить опцию "Удаление элементов с подтверждением".
  4. Нажать "Удалить".

    5. В ответ на запрос перед каждым удалением следует нажимать "Да", "Нет" или "Да для всех" для удаления сразу всех выбранных элементов.

  5. Выбрать другие элементы для удаления или нажать "Закрыть".

Ввод команды: ОЧИСТИТЬ


Удаление описаний блоков - Команды

Создание и использование блоков (символов)
Создание и использование блоков (символов)
Удаление описаний блоков
Понятия
Процедуры
Команды

Команды
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Методы редактирования - Понятия

Создание и редактирование объектов
Методы редактирования
Понятия
Процедуры
Команды

В данной главе описывается, как выбирать объекты, просматривать и редактировать их свойства, а также выполнять различные действия по редактированию объектов.

  • Выбор объектов
    Для выбора редактируемых объектов предусмотрен широкий набор различных средств и опций.
  • Исправление ошибок
    Имеется возможность отмены действия последней или нескольких последних команд.
  • Стирание объектов
    Удаление объектов из чертежа можно выполнять различными способами.
  • Использование буфера обмена Windows
    При необходимости, объекты из чертежа можно скопировать или вырезать в буфер обмена, а затем вставить эти объекты в файл, открытый в другом приложении.
  • Редактирование объектов
    Объекты можно редактировать, изменяя их размеры, форму и расположение.
  • Редактирование сложных объектов
    Для таких сложных объектов, как блоки, размеры, штриховки и полилинии, предусмотрены дополнительные операции редактирования.

См. также

Работа со сторонними объектами и заместителями


Методы редактирования - Процедуры

Создание и редактирование объектов
Методы редактирования
Понятия
Процедуры
Команды

Выбор одного объекта

Изменение размера прицела курсора

Для циклического перебора объектов

Исключение объектов из набора

Для получения списка опций при запросе выбора объектов

Для выбора объектов в области неправильной формы

Для выбора объектов, входящих в область неправильной формы или пересекающих ее границы

Для выбора объектов линией выбора

Для исключения нескольких объектов из набора

Для блокирования и разблокирования слоя

Блокирование/разблокирование слоя путем выбора объекта на слое

Для формирования набора объектов с помощью функции быстрого выбора

Для исключения объектов из набора

Для добавления объектов в имеющийся набор

Для сохранения фильтра под заданным именем

Для использования именованного фильтра

Для изменения размера прицела

Для задания параметров выбора объектов

Для включения или отключения просмотра выбранных объектов

Для изменения вида просмотра выбранных объектов

Для исключения объектов из просмотра выбранных

Для изменения вида выбранной области

Для создания группы

Определение возможности индивидуального выбора объектов, входящих в группу

Определение возможности выбора конкретной группы

Для удаления именованной группы

Для переупорядочения элементов группы

Для отмены последнего действия

Для отмены нескольких действий

Для повторного выполнения отмененного действия

Для повторного выполнения нескольких отмененных действий

Для стирания объекта

Для восстановления последнего стертого объекта

Для вырезания объектов в буфер обмена

Для удаления маркеров

Для очистки чертежа от неиспользуемых типов линий

Для вырезания объектов в буфер обмена

Для копирования объектов в буфер обмена

Для вставки объектов из буфера обмена

Для преобразования вставленной информации в формат файла чертежа

Для перемещения объекта по двум точкам

Для перемещения объекта на заданную величину смещения

Перемещение объекта из пространства модели в пространство листа (и наоборот)

Перемещение объектов с помощью растягивания

Для поворота объекта

Поворот объекта на заданный абсолютный угол

Для поворота 3D объекта вокруг оси

Выравнивание двух объектов в 2D представлении

Выравнивание двух объектов в 3D представлении

Для копирования объектов с помощью двух точек

Для создания прямоугольного массива

Для создания кругового массива

Для создания прямоугольного массива 3D объектов

Для создания кругового массива 3D объектов

Для построения подобного объекта путем задания смещения

Для построения подобного объекта, проходящего через точку

Для зеркального отображения объектов

Для зеркального отображения 3D объектов

Для удлинения объекта

Для обрезки объекта

Для удлинения объектов в 3D каркасных моделях

Для обрезки в 3D пространстве с проецированием на плоскость текущего вида

Для обрезки объектов в 3D каркасных моделях

Для растягивания объекта

Для масштабирования объекта с заданным масштабным коэффициентом

Для масштабирования объекта по длине опорного отрезка

Для изменения длины отрезка перетаскиванием

Задание радиуса сопряжения

Для сопряжения двух отрезков

Построение сопряжения без обрезки

Для построения сопряжений вдоль всей полилинии

Для сопряжения нескольких объектов

Для построения фаски по двум линейным размерам

Для соединения фаской двух непараллельных отрезков

Для построения фаски по линейному и угловому размерам

Для построения фаски без обрезки объектов

Для снятия фасок вдоль всей полилинии

Для соединения фаской нескольких объектов

Для разрывания объекта

Для соединения объектов

Для включения ручек

Для установки цвета ручек под курсором

Для задания предельного количества выбранных объектов для показа ручек

Для отображения подсказок к ручкам в пользовательских объектах, поддерживающих подсказки к ручкам

Для отмены выделения ручками

Для растягивания объекта с помощью ручек

Для растягивания с помощью нескольких ручек

Для перемещения объекта с помощью ручек

Для поворота объекта с помощью ручек

Для масштабирования объектов с помощью ручек

Для зеркального отображения объектов с помощью ручек

Для многократного копирования в любом режиме ручек

Для задания шага смещения при многократном копировании

Для задания шага поворота при многократном копировании

Для зеркального отображения объектов с помощью ручек и с сохранением оригиналов

Для включения и отключения ручек в блоках

Для расчленения объекта

Для редактирования полилинии

Объединение полилиний, линий и дуг в одну полилинию

Удаление вершины в полилинии

Для сужения ширины отдельных сегментов

Для редактирования сплайна

Для удаления вершины мультилинии

Для задания закрытого крестообразного типа пересечения

Редактирование стиля мультилинии


Методы редактирования - Команды

Создание и редактирование объектов
Методы редактирования
Понятия
Процедуры
Команды
Команды
3DALIGN | Выравнивание объектов относительно других объектов в 2D и 3D
3DЗЕРКАЛО | Создание зеркальной копии объектов относительно заданной плоскости
3DМАССИВ | Построение трехмерных массивов
БВЫБОР | Быстрое создание набора объектов на основе заданных критериев фильтрации
ВБУФЕР | Занесение объектов в буфер обмена с удалением их из чертежа
ВСЕОСВЕЖ | Перерисовка содержимого всех видовых экранов
ВСТБЛОК | Вставка скопированных ранее объектов в виде блока
ВСТБУФЕР | Вставка содержимого буфера обмена
ВСТИСХОД | Вставка скопированного блока в новый чертеж с координатами, которые он имел в исходном чертеже
ВСТСПЕЦ | Вставка данных из буфера обмена Windows с возможностью управления их форматом
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
ВЫРОВНЯТЬ | Выравнивание объектов относительно других объектов в 2D и 3D
ГРУППА | Создание именованных наборов объектов (групп) и управление ими
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
ИМПОРТМТФ | Импорт метафайла Windows
КБУФЕР | Копирует объекты или текст из командной строки в буфер обмена
КОПИРОВАТЬ | Копирует объекты на заданное расстояние в указанном направлении
МАССИВ | Создание массивов объектов
МАСШТАБ | Пропорциональное увеличение/уменьшение размеров выбранных объектов в направлениях,и
МЛРЕД | Редактирует пересечения мультилиний, разрывы и вершины
МЛСТИЛЬ | Создает, изменяет и управляет стилями мультилиний
МПОВТОРИТЬ | Отмена действия нескольких команд ОТМЕНИТЬ или О
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
ОБРЕЗАТЬ | Обрезка объекта по режущей кромке, заданной другими объектами
ОЙ | Восстановление стертых объектов
ОПЦИИМТФ | Задание опций для команды ИМПОРТМТФ
ОСВЕЖИТЬ | Перерисовка содержимого текущего видового экрана
ОТМЕНИТЬ | Отмена действия команд
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПОВЕРНУТЬ | Поворачивает объект вокруг базовой точки.
ПОВЕРНУТЬ3D | Поворот объектов вокруг оси в 3D пространстве
ПОВТОРИТЬ | Отменяет действие последней команды ОТМЕНИТЬ или О
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
ПСК | Управление пользовательскими системами координат
РАЗОРВАТЬ | Разрыв выбранного объекта между двумя точками
РАСТЯНУТЬ | Перенос или растягивание объектов
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
РЕГЕН | Регенерация чертежа и перерисовка содержимого текущего видового экрана
РЕДСПЛАЙН | Редактирование сплайнов или сглаженных сплайнами полилиний
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
СВОЙСТВА | Изменяет свойства объекта
СЛОЙ | Управление слоями и их свойствами
СЛОЙБЛК | Блокирует слои выбранных объектов
СЛОЙРАЗБЛ | Разблокирует слой выбранного объекта
СМЕНАПРОСТР | Переносит объекты из пространства модели в пространство листа и наоборот
СОЕДИНИТЬ | Соединяет объекты для формирования одного целого объекта
СОПРЯЖЕНИЕ | Скругление углов и сопряжение объектов
СПИРАЛЬ | Создание 2D или 3D винтовой линии
СТЕРЕТЬ | Удаление объектов из чертежа
УВЕЛИЧИТЬ | Изменение длин объектов и центральных углов дуг
УДЛИНИТЬ | Удлинение объектов до пересечения с другими объектами
ФАСКА | Построение фасок в местах пересечения объектов
ФИЛЬТР | Создает список свойств, которыми должен обладать объект, чтобы быть выбранным
ЭКСПОРТМТФ | Сохранение объектов в метафайл Windows (WMF)
Системные переменные
ANGBASE | Задание для базового угла значения 0 в соответствии с текущей ПСК
ANGDIR | Задание направления для положительных углов.
CHAMFERA | Устанавливает первое расстояние фаски, когда значение CHAMMODE задано равным 0
CHAMFERB | Устанавливает второе расстояние фаски, когда значение CHAMMODE задано равным 0
CHAMFERC | Устанавливает длину фаски, когда значение CHAMMODE задано равным 1
CHAMFERD | Устанавливает угол фаски, когда значение CHAMMODE задано равным 1
CHAMMODE | Установка метода ввода для команды ФАСКА
CROSSINGAREACOLOR | Управление цветом области выбора в процессе выбора секущей рамки
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
DRAGMODE | Управляет отображением объектов при перетаскивании
EDGEMODE | Управляет режимом определения режущих и граничных кромок для команд ОБРЕЗАТЬ и УДЛИНИТЬ.
EXPLMODE | Управляет обработкой блоков с разными масштабами вставки в команде РАСЧЛЕНИТЬ
FILLETRAD | Сохраняет значение текущего радиуса сопряжения
GRIPBLOCK | Управляет ручками внутри блоков
GRIPCOLOR | Управляет цветом невыбранных ручек
GRIPHOT | Управляет цветом выбранных ручек
GRIPHOVER | Управляет цветом заполнения невыбранной ручки, когда курсор останавливается над ней
GRIPOBJLIMIT | Подавляет ручки, если исходный набор содержит больше объектов, чем задано
GRIPS | Управляет использованием набора ручек при растягивании, перемещении, повороте, масштабировании и зеркальном отображении объектов
GRIPSIZE | Устанавливает размер квадрата, изображающего ручку (в пикселах)
GRIPTIPS | Управляет подсказками для ручки при наведении курсора на ручку пользовательского объекта, поддерживающего подсказки к ручкам
HIGHLIGHT | Управляет подсветкой объектов; не влияет на объекты, имеющие ручки
LEGACYCTRLPICK | Задает клавиши циклического повторения выбора и определяет действия при нажатии клавиши CTRL и левой кнопки мыши
MIRRTEXT | Управляет отображением текста с помощью команды ЗЕРКАЛО
OFFSETDIST | Устанавливает расстояние смещения по умолчанию
OFFSETGAPTYPE | Управляет зазорами между сегментами, возникающими при смещении замкнутых полилиний
OLEHIDE | Управляет отображением и выводом на печать объектов OLE
PEDITACCEPT | Подавляет отображение подсказки "Выбранный объект не является полилинией" команды ПОЛРЕД
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
PICKBOX | Устанавливает размер прицела выбора объектов (в пикселах)
PICKDRAG | Управляет методом создания рамки выбора
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
PREVIEWEFFECT | Указывает визуальный эффект, используемый для предварительного просмотра набора объектов
PREVIEWFILTER | Исключает указанные типы объектов из области предварительного выбора
PROJMODE | Устанавливает текущий режим проецирования для операций обрезки и удлинения
SELECTIONAREA | Управляет отображением эффектов для областей выбора
SELECTIONAREAOPACITY | Управляет прозрачностью области выбора в процессе выбора рамки и секущей рамки
SELECTIONPREVIEW | Управляет отображением предварительного просмотра выбора
SPLFRAME | Управляет отображением сплайнов и сглаженных сплайнами полилиний
SPLINESEGS | Задает количество сегментов линии, генерируемых для каждой сглаженной сплайном полилинии, созданной с помощью параметра "Сплайн" команды ПОЛРЕД
SPLINETYPE | Задает тип кривой, создаваемой с помощью параметра "Сплайн" команды ПОЛРЕД
SURFTYPE | Управляет типом поверхности сглаживания, которая используется командой ПОЛРЕД (параметр "Сплайн")
SURFU | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности
SURFV | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности.
TRIMMODE | Управляет обрезкой выбранных кромок для фасок и сопряжений
UCSDETECT | Управляет активность сбора данных динамической ПСК
UNDOCTL | Указывает состояние параметров "Авто", "Управление" и "Группа" команды ОТМЕНИТЬ
UNDOMARKS | Сохраняет количество меток, заданных в команде ОТМЕНИТЬ (параметр "Метка") для управления отменой
WINDOWAREACOLOR | Управляет цветом прозрачной области выбора в процессе выбора рамки
WMFBKGND | Управляет отображением фона при вставке объектов в формат метафайлов Windows (WMF)
WMFFOREGND | Управляет назначением цвета переднего плана при вставке объектов в формат метафайла Windows (WMF)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Выбор объектов
Понятия
Процедуры
Команды

Для выбора редактируемых объектов предусмотрен широкий набор различных средств и опций.

  • Выбор отдельных объектов
    В ответ на запрос "Выберите объекты" можно произвести выбор одного или нескольких отдельных объектов.
  • Выбор нескольких объектов
    В ответ на запрос "Выберите объекты" можно одновременно выбрать сразу несколько объектов.
  • Блокирование выбора объектов
    Блокирование слоев позволяет защищать расположенные на них объекты от операций выбора и редактирования.
  • Фильтрация наборов объектов
    Имеется возможность отбора объектов, заносимых в набор, по каким-либо свойствам или по типам.
  • Настройка параметров выбора объектов
    Можно управлять несколькими аспектами выбора объектов путем задания режима выбора сначала команды или объектов, размера курсора и отображения выбранных объектов.
  • Группы
    Группой называется именованный и сохраненный набор объектов. Пользователь может выбирать и редактировать как сразу всю группу, так и ее отдельные объекты. Группы удобны для согласованного управления несколькими графическими объектами.


Выбор объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор объектов
Понятия
Процедуры
Команды

Выбор одного объекта

Изменение размера прицела курсора

Для циклического перебора объектов

Исключение объектов из набора

Для получения списка опций при запросе выбора объектов

Для выбора объектов в области неправильной формы

Для выбора объектов, входящих в область неправильной формы или пересекающих ее границы

Для выбора объектов линией выбора

Для исключения нескольких объектов из набора

Для блокирования и разблокирования слоя

Блокирование/разблокирование слоя путем выбора объекта на слое

Для формирования набора объектов с помощью функции быстрого выбора

Для исключения объектов из набора

Для добавления объектов в имеющийся набор

Для сохранения фильтра под заданным именем

Для использования именованного фильтра

Для изменения размера прицела

Для задания параметров выбора объектов

Для включения или отключения просмотра выбранных объектов

Для изменения вида просмотра выбранных объектов

Для исключения объектов из просмотра выбранных

Для изменения вида выбранной области

Для создания группы

Определение возможности индивидуального выбора объектов, входящих в группу

Определение возможности выбора конкретной группы

Для удаления именованной группы

Для переупорядочения элементов группы


Выбор объектов - Команды

Создание и редактирование объектов
Методы редактирования
Выбор объектов
Понятия
Процедуры
Команды
Команды
БВЫБОР | Быстрое создание набора объектов на основе заданных критериев фильтрации
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
ГРУППА | Создание именованных наборов объектов (групп) и управление ими
СВОЙСТВА | Изменяет свойства объекта
СЛОЙ | Управление слоями и их свойствами
СЛОЙБЛК | Блокирует слои выбранных объектов
СЛОЙРАЗБЛ | Разблокирует слой выбранного объекта
ФИЛЬТР | Создает список свойств, которыми должен обладать объект, чтобы быть выбранным
Системные переменные
CROSSINGAREACOLOR | Управление цветом области выбора в процессе выбора секущей рамки
DRAGMODE | Управляет отображением объектов при перетаскивании
HIGHLIGHT | Управляет подсветкой объектов; не влияет на объекты, имеющие ручки
LEGACYCTRLPICK | Задает клавиши циклического повторения выбора и определяет действия при нажатии клавиши CTRL и левой кнопки мыши
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
PICKBOX | Устанавливает размер прицела выбора объектов (в пикселах)
PICKDRAG | Управляет методом создания рамки выбора
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
PREVIEWEFFECT | Указывает визуальный эффект, используемый для предварительного просмотра набора объектов
PREVIEWFILTER | Исключает указанные типы объектов из области предварительного выбора
SELECTIONAREA | Управляет отображением эффектов для областей выбора
SELECTIONAREAOPACITY | Управляет прозрачностью области выбора в процессе выбора рамки и секущей рамки
SELECTIONPREVIEW | Управляет отображением предварительного просмотра выбора
WINDOWAREACOLOR | Управляет цветом прозрачной области выбора в процессе выбора рамки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор отдельных объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Выбор отдельных объектов
Понятия
Процедуры
Команды

В ответ на запрос "Выберите объекты" можно произвести выбор одного или нескольких отдельных объектов.

Использование прицела

Если прицел находится в положении для выбора объекта, объект выделяется цветом. Для выбора объекта нажмите кнопку мыши.

Размер прицела можно регулировать на вкладке "Выбор" диалогового окна "Настройка".

Выбор одного из близкорасположенных объектов

Выбор одного из объектов, лежащих близко друг к другу или перекрывающих друг друга, представляет определенную трудность. На примере показаны два отрезка и окружность, которые находятся в прицеле.

Если включен предварительный просмотр набора объектов, можно просматривать объекты по очереди, удерживая нажатой клавишу SHIFT и нажимая клавишу ПРОБЕЛ. Когда нужный объект будет подсвечен, для его выбора нажмите на нем кнопку мыши.

Если предварительный просмотр набора объектов отключен, нажмите и удерживайте SHIFT + ПРОБЕЛ, а затем нажимайте кнопку мыши для переключения между объектами до тех пор пока не будет выбран нужный. Для выхода из режима циклического переключения нажмите ESC.

Исключение объектов из набора

Исключите объекты из текущего набора, удерживая нажатой клавишу SHIFT и повторно выбирая исключаемые объекты.

См. также

Выбор и редактирование 3D подобъектов

Манипулирование составными телами


Выбор отдельных объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор отдельных объектов
Понятия
Процедуры
Команды

Выбор одного объекта

Изменение размера прицела курсора

Для циклического перебора объектов

Исключение объектов из набора


Выбор одного объекта - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор отдельных объектов
Понятия
Процедуры
Команды

Выбор одного объекта

  1. В ответ на запрос "Выберите объекты" какой-либо команды переместите прицел, чтобы объект, который необходимо выбрать, был выделен.
  2. Наведя курсор на объекте, нажмите кнопку мыши.

    3. Выбранный объект выделяется.

  3. По окончании выбора объектов нажмите ENTER.

    4. Примечание Если значение системной переменной PICKFIRST равно 1 (предварительный выбор), объекты можно выбрать до ввода команды.


Изменение размера прицела курсора - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор отдельных объектов
Понятия
Процедуры
Команды

Изменение размера прицела курсора

  1. Выберите в меню "Сервис" » "Настройка".
  2. В группе "Размер прицела" вкладки "Выбор" задайте необходимый размер прицела с помощью регулятора.
  3. Нажмите "ОК".

Ввод команды: РЕЖИМЧРТ


Для циклического перебора объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор отдельных объектов
Понятия
Процедуры
Команды

Для циклического перебора объектов

  1. При отображении запроса "Выберите объекты", нажмите и удерживайте клавиши SHIFT+ПРОБЕЛ. Нажмите кнопкой мыши как можно ближе к нужному объекту.
  2. Последовательно нажимайте кнопку мыши до тех пор, пока нужный объект не будет подсвечен.
  3. Для выбора объекта нажмите ENTER.

Примечание Если включен предварительный просмотр набора объектов, можно просматривать объекты по очереди, удерживая нажатой клавишу SHIFT и нажимая клавишу ПРОБЕЛ. Когда нужный объект будет подсвечен, для его выбора нажмите на нем кнопку мыши.


Исключение объектов из набора - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор отдельных объектов
Понятия
Процедуры
Команды

Исключение объектов из набора

  • Нажмите и удерживайте нажатой клавишу SHIFT. Выберите объекты, которые необходимо исключить из набора.


Выбор отдельных объектов - Команды

Методы редактирования
Методы редактирования
Выбор отдельных объектов
Понятия
Процедуры
Команды

Команды
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
HIGHLIGHT | Управляет подсветкой объектов; не влияет на объекты, имеющие ручки
LEGACYCTRLPICK | Задает клавиши циклического повторения выбора и определяет действия при нажатии клавиши CTRL и левой кнопки мыши
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
PICKBOX | Устанавливает размер прицела выбора объектов (в пикселах)
PICKDRAG | Управляет методом создания рамки выбора
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор нескольких объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Выбор нескольких объектов
Понятия
Процедуры
Команды

В ответ на запрос "Выберите объекты" можно одновременно выбрать сразу несколько объектов.

Укажите прямоугольную область выбора

Укажите противоположные углы для определения прямоугольной области. Цвет фона в области изменится, и фон станет прозрачным. Направление, в котором перемещается курсор из начальной точки в противоположный угол, определяет выбор объектов.

  • Выбор рамкой. Перетащите курсор слева направо, чтобы выбрать только объекты, которые полностью заключены в прямоугольную область.
  • Пересечение секущей рамкой. Перетащите курсор слева направо, чтобы выбрать объекты, которые заключены или пересечены рамкой.

При выборе рамкой выбираемые объекты должны полностью находиться в прямоугольной области. Однако, если объект построен прерывистой линией (пунктиром) и виден в видовом экране лишь частично, а все видимые векторы типа линии включены в окно выбора, то будет выбран объект целиком.

Выбор области неправильной формы

Укажите точки для определения области неправильной формы. Многоугольная рамка используется для выбора объектов, полностью расположенные в пределах области выбора. Для выбора объектов, расположенных в области выбора полностью или пересекаемых ей, используется секущая рамка многоугольника.

Линии выбора

Используйте линии выбора на сложном чертеже. Линия выбора похожа на полилинию, и предназначена только для выбора объектов, через которые она проходит. На чертеже показана линия выбора, с помощью которой выбираются несколько элементов на печатной плате.

Использование других опций выбора

Все доступные опции при выполнении операции выбора можно посмотреть, введя ? в ответ на запрос «Выберите объекты». Подробнее об опциях выбора см. описание команды ВЫБРАТЬ.

Исключение нескольких объектов из набора

В ответ на запрос "Выберите объекты" можно ввести и (Исключить), а затем одним из доступных средств выделить объекты для исключения их из набора. Для возврата из режима исключения и продолжения пополнения набора выбираемых объектов следует ввести д (Добавить).

Объекты можно также исключать из текущего набора, удерживая нажатой клавишу SHIFT и повторно выбирая исключаемые объекты по отдельности, или удерживая нажатой клавишу SHIFT и перетаскивая рамку выбора или секущую рамку. В текущий набор можно добавлять и удалять объекты без ограничений.


Выбор нескольких объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор нескольких объектов
Понятия
Процедуры
Команды

Для получения списка опций при запросе выбора объектов

Для выбора объектов в области неправильной формы

Для выбора объектов, входящих в область неправильной формы или пересекающих ее границы

Для выбора объектов линией выбора

Для исключения нескольких объектов из набора


Для получения списка опций при запросе выбора объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор нескольких объектов
Понятия
Процедуры
Команды

Для получения списка опций при запросе выбора объектов

  • Введите ? в ответ на запрос "Выберите объекты".


Для выбора объектов в области неправильной формы - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор нескольких объектов
Понятия
Процедуры
Команды

Для выбора объектов в области неправильной формы

  1. В ответ на запрос "Выберите объекты" введите рм (РМн-угол).
  2. Укажите точки, которые определяют область, полностью охватывающую объекты для выбора.
  3. Нажмите ENTER для замыкания многоугольной рамки выбора и завершения выбора.


Для выбора объектов, входящих в область неправильной формы или пересекающих ее границы - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор нескольких объектов
Понятия
Процедуры
Команды

Для выбора объектов, входящих в область неправильной формы или пересекающих ее границы

  1. В ответ на запрос "Выберите объекты" введите см (СМн-угол).
  2. Укажите точки, которые определяют область, охватывающую или пересекающую объекты для выбора.
  3. Нажмите ENTER для замыкания многоугольной рамки выбора и завершения выбора.


Для выбора объектов линией выбора - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор нескольких объектов
Понятия
Процедуры
Команды

Для выбора объектов линией выбора

  1. В ответ на запрос "Выберите объекты" введите л (Линия).
  2. Укажите точки, которые определяют линию выбора, проходящую через выбираемые объекты.
  3. Для завершения выбора нажмите ENTER.


Для исключения нескольких объектов из набора - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор нескольких объектов
Понятия
Процедуры
Команды

Для исключения нескольких объектов из набора

  1. В ответ на запрос "Выберите объекты" после выбора объектов введите и (Исключить).
  2. Введите любую опцию выбора, например, мн-секрамка (Секущая рамка многоугольника) или л (Линия) и выберите объекты, подлежащие удалению из набора объектов.

    3. Для возврата к операции добавления объектов введите д (Добавить).


Выбор нескольких объектов - Команды

Методы редактирования
Методы редактирования
Выбор нескольких объектов
Понятия
Процедуры
Команды

Команды
БВЫБОР | Быстрое создание набора объектов на основе заданных критериев фильтрации
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
HIGHLIGHT | Управляет подсветкой объектов; не влияет на объекты, имеющие ручки
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
PICKBOX | Устанавливает размер прицела выбора объектов (в пикселах)
PICKDRAG | Управляет методом создания рамки выбора
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
PREVIEWEFFECT | Указывает визуальный эффект, используемый для предварительного просмотра набора объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Блокирование выбора объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Блокирование выбора объектов
Понятия
Процедуры
Команды

Блокирование слоев позволяет защищать расположенные на них объекты от операций выбора и редактирования.

Как правило, на блокированных слоях невозможно выполнять редактирование объектов. Другие же операции остаются доступными и на блокированных слоях. Например, блокированный слой можно сделать текущим и разместить на нем новый объект. Кроме того, остаются доступными команды получения различных сведений (например, СПИСОК), режимы объектной привязки для указания характерных точек объектов на блокированных слоях и операция смены порядка прорисовки объектов.


Блокирование выбора объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Блокирование выбора объектов
Понятия
Процедуры
Команды

Для блокирования и разблокирования слоя

Блокирование/разблокирование слоя путем выбора объекта на слое


Для блокирования и разблокирования слоя - Процедуры

Создание и редактирование объектов
Методы редактирования
Блокирование выбора объектов
Понятия
Процедуры
Команды

Для блокирования и разблокирования слоя

  1. На панели "Слои" выберите "Диспетчер свойств слоев".
  2. В "Диспетчере свойств слоев" нажмите мышью на значке блокирования (с изображением замка) для тех слоев, которые нужно заблокировать или разблокировать.
  3. Нажмите "ОК".

    4. Закрытый замок, изображенный на значке, означает блокированный слой. На таком слое недоступны операции выбора объектов.

Панель "Слои"

Ввод команды: СЛОЙ


Блокирование/разблокирование слоя путем выбора объекта на слое - Процедуры

Создание и редактирование объектов
Методы редактирования
Блокирование выбора объектов
Понятия
Процедуры
Команды

Блокирование/разблокирование слоя путем выбора объекта на слое

  1. Перейдите на вкладку "Модель".
  2. Выполните одно из следующих действий:
    • Выберите в меню "Формат" » "Инструменты слоя" » "Блокировать слой".
    • Выберите в меню "Формат" » "Инструменты слоя" » "Разбокировать слой".
  3. Выберите объект на слое, который требуется блокировать или разблокировать.

Панель "Слои 2"

Ввод команды: СЛОЙБЛК, СЛОЙРАЗБЛ


Блокирование выбора объектов - Команды

Методы редактирования
Методы редактирования
Блокирование выбора объектов
Понятия
Процедуры
Команды

Команды
СЛОЙ | Управление слоями и их свойствами
СЛОЙБЛК | Блокирует слои выбранных объектов
СЛОЙРАЗБЛ | Разблокирует слой выбранного объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Фильтрация наборов объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Фильтрация наборов объектов
Понятия
Процедуры
Команды

Имеется возможность отбора объектов, заносимых в набор, по каким-либо свойствам или по типам.

Имеется возможность отбора объектов, заносимых в набор выбора, по каким-либо характеристикам (цвет, тип объекта и т.п.) с помощью диалоговых окон "Быстрый выбор" (БВЫБОР) и "Фильтры выбора объектов" (ФИЛЬТР). Например, можно выбрать на чертеже только окружности красного цвета или, наоборот, выбрать все объекты, кроме окружностей красного цвета.

Функция "Быстрый выбор" позволяет быстро сформировать набор объектов по заданному критерию отбора. Если для добавления классификации функций в объект использовались Autodesk или программы других разработчиков, пользователь может выбирать объекты по свойству, упомянутому в классификации. В диалоговом окне "Фильтры выбора объектов" задаются и сохраняются для дальнейшего применения различные фильтры выбора.

При работе с функциями "Быстрый выбор" или "Фильтры выбора объектов" и фильтрации по цвету, типу линий или весу линий, сначала проверьте, задаются ли эти свойства ПОСЛОЮ для всех объектов чертежа. Например, объект может быть красным, потому что имеет цвет ПОСЛОЮ, а слою присвоен красный цвет.

См. также

Настройка параметров выбора объектов

Работа со слоями


Фильтрация наборов объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Фильтрация наборов объектов
Понятия
Процедуры
Команды

Для формирования набора объектов с помощью функции быстрого выбора

Для исключения объектов из набора

Для добавления объектов в имеющийся набор

Для сохранения фильтра под заданным именем

Для использования именованного фильтра


Для формирования набора объектов с помощью функции быстрого выбора - Процедуры

Создание и редактирование объектов
Методы редактирования
Фильтрация наборов объектов
Понятия
Процедуры
Команды

Для формирования набора объектов с помощью функции быстрого выбора

В следующем примере для выбора на чертеже всех объектов красного цвета используется функция "Быстрый выбор".

  1. Выберите в меню "Сервис" » "Быстрый выбор".
  2. В диалоговом окне "Быстрый выбор" из списка "Применить" выберите "Ко всему чертежу".
  3. В списке "Тип объектов" выберите "Несколько".
  4. В списке "Свойства" выберите "Цвет".
  5. В списке "Оператор" выберите "Равно".
  6. В списке "Значение" выберите "Красный".
  7. В группе "Отобранные объекты" выберите "Включить в новый набор".
  8. Нажмите "ОК".

    9. На чертеже выбираются все объекты красного цвета, и диалоговое окно "Быстрый выбор" закрывается. Если слой имеет красный цвет, то объекты красного цвета, унаследовавшие его ПОСЛОЮ, не включаются в набор объектов.

Примечание Если для добавления классификации функций в объект использовались приложения подобные Autodesk Map, и если в наличии имеется фал классификации (XML), пользователь может выбирать объекты по свойству, упомянутому в классификации. Так, можно выбрать классификацию в поле "Тип объекта" и его свойства в поле "Свойства".

Ввод команды: БВЫБОР


Для исключения объектов из набора - Процедуры

Создание и редактирование объектов
Методы редактирования
Фильтрация наборов объектов
Понятия
Процедуры
Команды

Для исключения объектов из набора

Опция "Исключить из нового набора" позволяет исключать объекты из текущего набора. В следующем примере из имеющегося набора исключаются все круги с радиусом больше 1.

  1. После выбора нескольких объектов выберите меню "Сервис" » "Быстрый выбор".
  2. В диалоговом окне "Быстрый выбор" из списка "Применить" выберите "Текущий набор".
  3. В списке "Тип объектов" выберите "Круг".
  4. В списке "Свойства" выберите "Радиус".
  5. В списке "Оператор" выберите "Больше".
  6. В поле "Значение" введите 1.
  7. В группе "Отобранные объекты" выберите "Исключить из нового набора".
  8. Нажмите "ОК".

    9. Все окружности с радиусом превышающим 1 исключаются из набора.

Ввод команды: БВЫБОР


Для добавления объектов в имеющийся набор - Процедуры

Создание и редактирование объектов
Методы редактирования
Фильтрация наборов объектов
Понятия
Процедуры
Команды

Для добавления объектов в имеющийся набор

Функцией "Быстрый выбор" можно воспользоваться для добавления объектов в имеющийся набор. В следующем примере к текущему набору объектов добавляются все объекты чертежа, содержащие гиперссылки, которые начинаются на bld1_.

  1. Выберите в меню "Сервис" » "Быстрый выбор".
  2. В диалоговом окне "Быстрый выбор" установить флажок "Добавить в текущий набор".
  3. В списке "Тип объектов" выберите "Несколько".
  4. В списке "Свойства" выберите "Гиперссылка".
  5. В списке "Оператор" выберите "* Поиск с глобальными символами".
  6. В поле "Значение" введите bld1_*.
  7. В группе "Отобранные объекты" выберите "Включить в новый набор".
  8. Нажмите "ОК".

Ввод команды: БВЫБОР


Для сохранения фильтра под заданным именем - Процедуры

Создание и редактирование объектов
Методы редактирования
Фильтрация наборов объектов
Понятия
Процедуры
Команды

Для сохранения фильтра под заданным именем

  1. В командной строке введите фильтр.
  2. В диалоговом окне "Фильтры выбора объектов" из раскрывающегося списка "Выбор фильтра" выберите один из фильтров, например, Отрезок.
  3. Нажмите "Добавить в список".
  4. В поле справа от кнопки "Сохранить как" введите имя, например, "Фильтр отрезков".
  5. Нажмите "Сохранить как".
  6. Нажмите кнопку "Применить".

    7. Применяется фильтр, после чего можно выбрать на чертеже только отрезки. При выборе объектов с помощью рамки фильтр применяется ко всем попадающим в нее объектам.

Ввод команды: ФИЛЬТР


Для использования именованного фильтра - Процедуры

Создание и редактирование объектов
Методы редактирования
Фильтрация наборов объектов
Понятия
Процедуры
Команды

Для использования именованного фильтра

  1. В ответ на запрос "Выберите объекты" введите 'фильтр. (Ввод апострофа делает команду прозрачной)
  2. В диалоговом окне "Фильтры выбора объектов" из раскрывающегося списка "Выбор фильтра" выберите нужный фильтр. Нажмите кнопку "Применить".
  3. Выберите объекты секущей рамкой.

    4. В набор включаются объекты, выбранные секущей рамкой и отвечающие условиям фильтра.


Фильтрация наборов объектов - Команды

Методы редактирования
Методы редактирования
Фильтрация наборов объектов
Понятия
Процедуры
Команды

Команды
БВЫБОР | Быстрое создание набора объектов на основе заданных критериев фильтрации
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
СВОЙСТВА | Изменяет свойства объекта
ФИЛЬТР | Создает список свойств, которыми должен обладать объект, чтобы быть выбранным
Системные переменные
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
PICKBOX | Устанавливает размер прицела выбора объектов (в пикселах)
PICKDRAG | Управляет методом создания рамки выбора
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка параметров выбора объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Настройка параметров выбора объектов
Понятия
Процедуры
Команды

Можно управлять несколькими аспектами выбора объектов путем задания режима выбора сначала команды или объектов, размера курсора и отображения выбранных объектов.

Для команд, в которых используется запрос "Выберите объекты", можно выполнить следующее:

  • Вначале ввести команду, затем произвести выбор объектов
  • Вначале выбрать объекты, затем вызвать команду

Пользователь может также выбирать

  • Просматривать ли объекты, которые необходимо выбрать, во время выбора
  • Выделяются ли цветом ли выбранные объекты
  • Как определяются области выбора и создаются наборы объектов
Если начинать с выбора команды

После использования команды редактирования, отобразится запрос "Выберите объекты", и прицел заменит курсоры в форме перекрестия. На запрос "Выберите объекты" отреагируйте одним из следующих способов:

  • Выберите одновременно сразу все нужные объекты.
  • Нажмите кнопку мыши на пустой области. Перетащите курсор для выбора прямоугольной области.
  • Введите опцию выбора. Введите ? для отображения всех параметров выбора.
  • Комбинируйте различные методы выбора. Например, для выбора большинства объектов в области рисования выберите все объекты, а затем исключите ненужные объекты.
  • Введите 'фильтр для использования именованного фильтра выбора. Символ апострофа указывает на прозрачное выполнение команды.
Если начинать с выбора объектов

Можно использовать один из двух методов для выбора объектов до вызова команды.

  • Запустите команду ВЫБРАТЬ и введите ? для получения списка всех опций выбора. Все выбираемые объекты включаются в текущий набор. При выполнении последующей команды в ответ на запрос "Выберите объекты" введите т для использования набора предварительно выбранных объектов.
  • Если режим предварительного выбора включен, выберите объекты в подсказке команды перед вызовом таких команд, как ПЕРЕНЕСТИ, КОПИРОВАТЬ или СТЕРЕТЬ. В данном случае выбор может осуществляться только с помощью мыши (щелчками на каждом объекте), или путем автоматического выбора.
  • Введите бвыбор для использования фильтра выбора. Затем при выполнении последующей команды в ответ на запрос "Выберите объекты" введите т.
Выделение объектов для выбора

Объекты выделяются при перемещении прицела над ними, обеспечивая просмотр объектов, которые будут выбраны, если их нажать кнопкой мыши.

После того как указана область для выбора нескольких объектов, фон области становится прозрачным.

Эти эффекты просмотра выбранных объектов включены по умолчанию. Их можно выключить или изменить вид просмотра выбранных объектов (диалоговое окно "Настройка", вкладка "Выбор"). Если для системной переменной PICKBOX установлено значение 0, просмотр выбранных объектов недоступен.

Управление отображением выбранных объектов

По умолчанию выбранные объекты отображаются с прерывистыми линиями. Можно увеличить производительность программы, установив для системной переменной HIGHLIGHT значение 0. Однако эта возможность используется редко и только при работе с большими чертежами.

Задание параметров выбора объектов по умолчанию

С помощью параметров на вкладке "Выбор" диалогового окна "Настройка" можно контролировать методы выбора объектов по умолчанию.

  • Для просмотра выбранных объектов используйте эффекты просмотра выбранных объектов и эффекты выбранной области.
  • Выберите объекты до ввода команды (предварительный выбор) или после вводв команды. (PICKFIRST)
  • Нажмите клавишу SHIFT для добавления объектов в набор для выбора. (PICKADD)
  • Перетащите курсор при нажатой кнопке мыши, для создания рамки выбора. Либо укажите курсором 2 места, для определения углов рамки выбора. (команда PICKDRAG)
  • Задайте режим выбора рамкой или секущей рамкой автоматически при указании точки вне объектов. Или введите c или w для указания режима выбора секущей рамкой. (PICKAUTO)
  • Измените размер прицела. (PICKBOX)
  • Выберите все объекты в группе при выборе одного объекта в этой группе.
  • Включите контур в набор объектов при выборе штриховки.


Настройка параметров выбора объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Настройка параметров выбора объектов
Понятия
Процедуры
Команды

Для изменения размера прицела

Для задания параметров выбора объектов

Для включения или отключения просмотра выбранных объектов

Для изменения вида просмотра выбранных объектов

Для исключения объектов из просмотра выбранных

Для изменения вида выбранной области


Для изменения размера прицела - Процедуры

Создание и редактирование объектов
Методы редактирования
Настройка параметров выбора объектов
Понятия
Процедуры
Команды

Для изменения размера прицела

  1. Выберите в меню "Сервис" » "Настройка" » вкладка "Выбор".
  2. В группе "Размер прицела" задайте необходимый размер прицела с помощью скользящей шкалы.
  3. Нажмите "ОК".

Ввод команды: НАСТРОЙКА


Для задания параметров выбора объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Настройка параметров выбора объектов
Понятия
Процедуры
Команды

Для задания параметров выбора объектов

  1. Выберите в меню "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка", на вкладке "Выбор", измените области просмотра выбора и режимов выбора, а также размер прицела.
  3. Нажмите "ОК".

Ввод команды: НАСТРОЙКА


Для включения или отключения просмотра выбранных объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Настройка параметров выбора объектов
Понятия
Процедуры
Команды

Для включения или отключения просмотра выбранных объектов

  1. Выберите в меню "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка", на вкладке "Выбор", включите или отключите параметр следующим образом.
    • Выберите параметр "Когда активна команда" для отображения флажка.
    • Выберите параметр "Если нет активных команд" для отображения флажка.
    • Выберите оба параметра для включения режима просмотра выбранных объектов каждый раз, когда это возможно.
    • Отключите оба параметра для полного выключения режима просмотра выбранных объектов.

    Ввод команды: SELECTIONPREVIEW


Для изменения вида просмотра выбранных объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Настройка параметров выбора объектов
Понятия
Процедуры
Команды

Для изменения вида просмотра выбранных объектов

  1. Выберите в меню "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка", на вкладке "Выбор", выберите "Параметры визуальных эффектов".
  3. В диалоговом окне "Параметры визуальных эффектов" выберите один из следующих параметров.
    • Пунктир. Отображает прерывистые линии.
    • Придать толщину. Отображает утолщенные линии.
    • Оба. Отображает прерывистые и утолщенные линии.
  4. Для выхода из каждого диалогового окна необходимо нажимать кнопку "ОК".


Для исключения объектов из просмотра выбранных - Процедуры

Создание и редактирование объектов
Методы редактирования
Настройка параметров выбора объектов
Понятия
Процедуры
Команды

Для исключения объектов из просмотра выбранных

  1. Выберите в меню "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка", на вкладке "Выбор", выберите "Параметры визуальных эффектов".
  3. В диалоговом окне "Параметры визуальных эффектов" выберите "Дополнительные опции".
  4. В диалоговом окне "Дополнительные опции просмотра" выберите любой из следующих параметров для исключения объектов из просмотра выбранных.
    • Исключить объекты на заблокированных слоях
    • Внешние ссылки
    • Таблицы
    • Группы
    • Многострочные тексты
    • штриховки
  5. Для выхода из каждого диалогового окна необходимо нажимать кнопку "ОК".


Для изменения вида выбранной области - Процедуры

Создание и редактирование объектов
Методы редактирования
Настройка параметров выбора объектов
Понятия
Процедуры
Команды

Для изменения вида выбранной области

  1. Выберите в меню "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка", на вкладке "Выбор", выберите "Параметры визуальных эффектов".
  3. В диалоговом окне "Параметры визуальных эффектов" измените один из следующих параметров.
    • Указать область. Выберите для отображения эффектов для областей.
    • Цвет рамки выбора. Выберите один из цветов, или воспользуйтесь элементом "Выбор цвета" для вызова диалогового окна "Выбор цвета". (системная переменная WINDOWAREACOLOR)
    • Цвет секущей рамки выбора. Выберите один из стандартных цветов, или воспользуйтесь элементом "Выбор цвета" для вызова диалогового окна выбора цвета. (системная переменная CROSSINGAREACOLOR)
    • Затенение выбранной области. Использовать указатель для установки прозрачности для областей выбора. Чем меньше значение настройки, тем прозрачнее область. При значении, равном 100 единицам, область становится непрозрачной. (системная переменная SELECTIONAREAOPACITY)
  4. Для выхода из каждого диалогового окна необходимо нажимать кнопку "ОК".


Настройка параметров выбора объектов - Команды

Методы редактирования
Методы редактирования
Настройка параметров выбора объектов
Понятия
Процедуры
Команды

Команды
БВЫБОР | Быстрое создание набора объектов на основе заданных критериев фильтрации
СВОЙСТВА | Изменяет свойства объекта
ФИЛЬТР | Создает список свойств, которыми должен обладать объект, чтобы быть выбранным
Системные переменные
CROSSINGAREACOLOR | Управление цветом области выбора в процессе выбора секущей рамки
DRAGMODE | Управляет отображением объектов при перетаскивании
HIGHLIGHT | Управляет подсветкой объектов; не влияет на объекты, имеющие ручки
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
PICKBOX | Устанавливает размер прицела выбора объектов (в пикселах)
PICKDRAG | Управляет методом создания рамки выбора
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
PREVIEWEFFECT | Указывает визуальный эффект, используемый для предварительного просмотра набора объектов
PREVIEWFILTER | Исключает указанные типы объектов из области предварительного выбора
SELECTIONAREA | Управляет отображением эффектов для областей выбора
SELECTIONAREAOPACITY | Управляет прозрачностью области выбора в процессе выбора рамки и секущей рамки
SELECTIONPREVIEW | Управляет отображением предварительного просмотра выбора
WINDOWAREACOLOR | Управляет цветом прозрачной области выбора в процессе выбора рамки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Группы - Понятия

Создание и редактирование объектов
Методы редактирования
Группы
Понятия
Процедуры
Команды

Группой называется именованный и сохраненный набор объектов. Пользователь может выбирать и редактировать как сразу всю группу, так и ее отдельные объекты. Группы удобны для согласованного управления несколькими графическими объектами.

  • Коротко о группах
  • Создание групп
    При создании группы выбираются объекты, задается ее имя и описание.
  • Выбор объектов в группах
    Существует несколько способов выбора групп объектов, включая выбор группы по имени или выбор указанием одного из элементов группы.
  • Редактирование групп
    Можно изменять группы несколькими способами, включая изменение их состава, изменение их свойств, корректировку имен и пояснений к группам и удаление их из чертежа.

См. также

Создание и использование блоков (символов)


Группы - Процедуры

Создание и редактирование объектов
Методы редактирования
Группы
Понятия
Процедуры
Команды

Для создания группы

Определение возможности индивидуального выбора объектов, входящих в группу

Определение возможности выбора конкретной группы

Для удаления именованной группы

Для переупорядочения элементов группы


Группы - Команды

Создание и редактирование объектов
Методы редактирования
Группы
Понятия
Процедуры
Команды
Команды
ГРУППА | Создание именованных наборов объектов (групп) и управление ими
Системные переменные
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о группах - Понятия

Создание и редактирование объектов
Методы редактирования
Коротко о группах
Понятия
Процедуры
Команды

Группой называется именованный и сохраненный набор объектов. Пользователь может выбирать и редактировать как сразу всю группу, так и ее отдельные объекты. Группы удобны для согласованного управления несколькими графическими объектами. Можно создавать их быстро, назначая им имена по умолчанию.

Группы полезны при связывании 3D тел в случаях, когда не требуется их объединение с помощью булевой операции.

Имеется возможность в любой момент добавлять в группу или исключить из нее элементы.

В некоторой степени группы напоминают блоки, которые также объединяют объекты с присвоением имени, но несколько иным способом. Например, группы можно сохранять для использования в следующих сеансах работы. Различие - в том, что пользователь может редактировать отдельные объекты в группе, тогда как при работе с блоками для этого необходимо сначала расчленить блок на отдельные элементы. В отличие от блоков, группы нельзя использовать в других чертежах.


Группы

Создание и редактирование объектов
Методы редактирования
Группы
Понятия
Процедуры
Команды

Нет процедур, относящихся к этому разделу.


Коротко о группах - Команды

Методы редактирования
Методы редактирования
Коротко о группах
Понятия
Процедуры
Команды

Команды
ГРУППА | Создание именованных наборов объектов (групп) и управление ими
Системные переменные
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание групп - Понятия

Создание и редактирование объектов
Методы редактирования
Создание групп
Понятия
Процедуры
Команды

При создании группы выбираются объекты, задается ее имя и описание.

При создании группы задается ее имя и описание. При копировании группы новой копии по умолчанию присваивается имя Ax; новая группа считается неименованной. Неименованные группы не выводятся в списке диалогового окна "Группы объектов", если не установлена опция "Включая неименованные".

При выборе хотя бы одного элемента выбираемой группы, все ее элементы включаются в новую группу.

Объект может входить одновременно в несколько групп, а группа может входить в другие группы. Для восстановления конфигураций исходных групп можно выполнить разгруппирование вложенных групп.

При использовании чертежа в качестве внешней ссылки или вставляемого блока именованные группы внутри этого чертежа становятся недоступны. Однако пользователь может внедрить и затем расчленить внешнюю ссылку или блок, после чего группы становятся доступными как неименованные.

Примечание Следует избегать создания больших групп, содержащих сотни и тысячи объектов. Большие группы значительно снижают производительность этой программы.


Создание групп - Процедуры

Создание и редактирование объектов
Методы редактирования
Создание групп
Понятия
Процедуры
Команды

Для создания группы


Для создания группы - Процедуры

Создание и редактирование объектов
Методы редактирования
Создание групп
Понятия
Процедуры
Команды

Для создания группы

  1. В командной строке введите группа.
  2. В группе "Идентификация группы" диалогового окна "Группы объектов" введите имя группы и пояснение к ней.
  3. Нажмите кнопку "Новая".

    4. Диалоговое окно временно закрывается.

  4. Выберите объекты и нажмите ENTER.
  5. Нажмите "ОК".

Ввод команды: ГРУППА


Создание групп - Команды

Методы редактирования
Методы редактирования
Создание групп
Понятия
Процедуры
Команды

Команды
ГРУППА | Создание именованных наборов объектов (групп) и управление ими
Системные переменные
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор объектов в группах - Понятия

Создание и редактирование объектов
Методы редактирования
Выбор объектов в группах
Понятия
Процедуры
Команды

Существует несколько способов выбора групп объектов, включая выбор группы по имени или выбор указанием одного из элементов группы.

Группу можно выбрать, введя ее имя в ответ на запрос "Выберите объекты". Если системная переменная PICKSTYLE имеет значение 1 или 3, при выборе любого элемента выбираемой группы выбираются также все входящие в нее элементы, отвечающие заданному критерию. Для включения и отключения режима выбора групп можно использовать комбинацию клавиш CTRL+H или SHIFT+CTRL+A.

Все элементы выбираемой группы выбираются также при циклическом переборе объектов; например, при выборе объекта, полностью покрытого другим. При выборе объекта, принадлежащего нескольким группам, выбираются все элементы всех групп, в которые он входит. Для редактирования с помощью ручек группа выбирается в ответ на подсказку "Команда:" с помощью устройства указания.


Выбор объектов в группах - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор объектов в группах
Понятия
Процедуры
Команды

Определение возможности индивидуального выбора объектов, входящих в группу

Определение возможности выбора конкретной группы


Определение возможности индивидуального выбора объектов, входящих в группу - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор объектов в группах
Понятия
Процедуры
Команды

Определение возможности индивидуального выбора объектов, входящих в группу

Выполните одно из следующих действий:

  • В командной строке введите pickstyle Введите 1 для включения режима выбора группы. Объекты, входящие в группу, можно выбирать не по отдельности, а только в виде группы.
  • В командной строке введите pickstyle Введите 0 для отключения режима выбора группы. Объекты, входящие в группу, можно выбирать только по отдельности, но не в виде группы.
  • В любое время можно включать и отключать режим выбора групп с помощью комбинаций клавиш CTRL+H или SHIFT+CTRL+A.


Определение возможности выбора конкретной группы - Процедуры

Создание и редактирование объектов
Методы редактирования
Выбор объектов в группах
Понятия
Процедуры
Команды

Определение возможности выбора конкретной группы

  1. В командной строке введите group
  2. Во вкладке "Имя группы" в диалоговом окне "Группа объектов" выберите группу, для которой необходимо изменить возможность выбора.
  3. Во вкладке "Изменить группу" выберите опцию "Выбираемая".

    4. При этом изменяется возможность выбора объектов, входящих в группу, в виде группы, что определяется системной переменной PICKSTYLE. Если возможность выбора выключена, входящие в группу объекты выбираются только в виде индивидуальных объектов. В списке "Выбираемые" вверху диалогового окна "Группа объектов" отображается текущее состояние для каждой группы.

  4. Нажмите "ОК".


Выбор объектов в группах - Команды

Методы редактирования
Методы редактирования
Выбор объектов в группах
Понятия
Процедуры
Команды

Команды
ГРУППА | Создание именованных наборов объектов (групп) и управление ими
Системные переменные
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование групп - Понятия

Создание и редактирование объектов
Методы редактирования
Редактирование групп
Понятия
Процедуры
Команды

Можно изменять группы несколькими способами, включая изменение их состава, изменение их свойств, корректировку имен и пояснений к группам и удаление их из чертежа.

Редактирование объекта в качестве группы

Если включен режим выбора групп, то группы можно перемещать, копировать, поворачивать и редактировать точно так же, как индивидуальные объекты. Для редактирования отдельного объекта в группе необходимо выключить режим выбора групп или воспользоваться ручками на объекте. Дополнительную информацию см. в разделе Выбор объектов в группах.

В некоторых случаях полезно управлять очередностью, в которой выбираются объекты, принадлежащие одной и той же группе. Например, пользовательская программа, определяющая траектории перемещения инструмента для числового управления, может зависеть от ряда смежных объектов в указанной очередности.

Переупорядочение элементов может быть выполнено двумя способами: либо изменить порядковые позиции отдельных элементов (как по одному, так и для нескольких), либо изменить порядок следования всех элементов. Нумерация объектов группы начинается с 0, а не с 1.

Изменение имени, пояснения и состава элементов группы

С помощью диалогового окна "Группа объектов" можно в любое время задавать объекты для добавления в группу или удаления из группы. Можно также изменять имя группы или описание группы. Если при удалении из чертежа или исключении объекта группа остается пустой, ее описание сохраняется без описания составных элементов.

Примечание Расчленение такого объекта, как экземпляр блока или штриховка, принадлежащего группе, не вызывает автоматического добавления получаемых составных элементов в какую-либо группу.

Удаление групп

Для удаления описания группы можно использовать опцию "расчленить" в диалоговом окне "Группа объектов". Данная операция отличается от операции расчленения блока, штриховки или размера. Объекты, принадлежащие расчлененной группе, остаются в чертеже.

В результате группа распадается, но составные элементы группы более никак не изменяются.


Редактирование групп - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование групп
Понятия
Процедуры
Команды

Для удаления именованной группы

Для переупорядочения элементов группы


Для удаления именованной группы - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование групп
Понятия
Процедуры
Команды

Для удаления именованной группы

  1. В командной строке введите группа.
  2. В диалоговом окне "Группы объектов" выберите имя группы из списка.
  3. В группе опций "Изменение группы" выберите "Расчленить".
  4. Нажмите "ОК".

    5. Группа удаляется.

Ввод команды: ГРУППА


Для переупорядочения элементов группы - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование групп
Понятия
Процедуры
Команды

Для переупорядочения элементов группы

  1. В командной строке введите группа.
  2. В группе опций "Изменение группы" диалогового окна "Группы объектов" нажмите кнопку "Переупорядочить".
  3. В списке "Имя группы" диалогового окна "Порядок объектов в группе" выберите группу для переупорядочения.
  4. Для просмотра текущего порядка группы нажмите кнопку "Подсветить".
  5. С помощью кнопок "Предыдущий" и "Следующий" диалогового окна "Группа объектов" просмотреть порядок объектов в группе. Нажмите кнопку "ОК", если завершен просмотр порядка объектов.
  6. В поле "Взять из позиции" диалогового окна "Порядок объектов в группе" введите порядковый номер объекта.
  7. В поле "Переместить в позицию" введите номер новой позиции.
  8. В поле "Количество объектов" введите количество объектов, порядок которых меняется. Нажмите кнопку "Переупорядочить".
  9. Нажмите "OK" для закрытия каждого диалогового окна.

Ввод команды: ГРУППА


Редактирование групп - Команды

Методы редактирования
Методы редактирования
Редактирование групп
Понятия
Процедуры
Команды

Команды
ГРУППА | Создание именованных наборов объектов (групп) и управление ими
Системные переменные
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Исправление ошибок - Понятия

Создание и редактирование объектов
Методы редактирования
Исправление ошибок
Понятия
Процедуры
Команды

Имеется возможность отмены действия последней или нескольких последних команд.

Отмена одного действия

Самой простой способ отмены одного последнего действия заключается в использовании кнопки "Отменить" на панели "Стандартная" или команды О. Многие команды имеют собственную опцию О (отменить), что позволяет исправлять ошибки без выхода из команды. Например, при создании отрезков или полилиний можно ввести о для отмены последнего построенного сегмента.

Примечание По умолчанию для системной переменной UNDOCTLустановлено значение для объединения команд смежного панорамирования и масштабирования в одну операцию при отмене и повторе.

Отмена группы действий

Опция "Метка" команды ОТМЕНИТЬ служит для запоминания состояния чертежа в ходе работы. С помощью опции "Обратно" команды ОТМЕНИТЬ можно отменить все действия, имевшие место после отмеченного действия. Используя используя опции "Начало" и "Конец" команды ОТМЕНИТЬ, сразу отменять действие целой группы команд.

Группу последних действий можно также отменить с помощью списка "Отмена" на панели "Стандартная".

Повторное выполнение отмененного действия

С помощью опции ПОВТОРИТЬ можно отменить отдельную операцию отмены или команду ОТМЕНИТЬ, имевшие место сразу после отмененного действия.

Группу последних действий можно также повторить с помощью списка "Повторить" на панели "Стандартная".

Стирание объектов

Любой построенный объект можно стереть. Если объект стерт случайно, его можно восстановить командой ОТМЕНИТЬ или ОЙ.

Дополнительную информацию см. в разделе Стирание объектов.

Прерывание команды

Выполнение команды можно прервать с помощью клавиши ESC. Для изменения клавиши прерывания следует сбросить флажок "Клавиши быстрого вызова по стандарту Windows" на вкладке "Пользовательские" диалогового окна "Настройка".


Исправление ошибок - Процедуры

Создание и редактирование объектов
Методы редактирования
Исправление ошибок
Понятия
Процедуры
Команды

Для отмены последнего действия

Для отмены нескольких действий

Для повторного выполнения отмененного действия

Для повторного выполнения нескольких отмененных действий


Для отмены последнего действия - Процедуры

Создание и редактирование объектов
Методы редактирования
Исправление ошибок
Понятия
Процедуры
Команды

Для отмены последнего действия

  • Выберите в меню "Правка" » "Отменить".

Панель "Стандартная"

Ввод команды: О


Для отмены нескольких действий - Процедуры

Создание и редактирование объектов
Методы редактирования
Исправление ошибок
Понятия
Процедуры
Команды

Для отмены нескольких действий

  1. На панели "Стандартная" нажать на стрелку кнопки "Отменить" для раскрытия списка действий.

    2. Выводится список действий, которые можно отменить, начиная с последнего действия.

  2. Выделите отменяемые действия перетаскивая мышь.
  3. Нажмите кнопкой мыши для отмены выбранных действий.

Панель "Стандартная"

Ввод команды: ОТМЕНИТЬ


Для повторного выполнения отмененного действия - Процедуры

Создание и редактирование объектов
Методы редактирования
Исправление ошибок
Понятия
Процедуры
Команды

Для повторного выполнения отмененного действия

  • Выберите в меню "Правка" » "Повторить".

Команда ПОВТОРИТЬ используется для повтора последнего действия, отмененного командой ОТМЕНИТЬ. Команду ПОВТОРИТЬ нельзя использовать для повторного выполнения другой команды.

Панель "Стандартная"

Ввод команды: ПОВТОРИТЬ


Для повторного выполнения нескольких отмененных действий - Процедуры

Создание и редактирование объектов
Методы редактирования
Исправление ошибок
Понятия
Процедуры
Команды

Для повторного выполнения нескольких отмененных действий

  1. На панели "Стандартная" нажмите на стрелку кнопки "Повторить" для раскрытия списка действий.

    2. Выводится список отмененных действий, которые можно повторно выполнить, начиная с последнего действия.

  2. Выделите повторно выполняемые действия.
  3. Нажмите кнопкой мыши для повторного выполнения выбранных действий.

Панель "Стандартная"

Ввод команды: МПОВТОРИТЬ


Исправление ошибок - Команды

Методы редактирования
Методы редактирования
Исправление ошибок
Понятия
Процедуры
Команды

Команды
МПОВТОРИТЬ | Отмена действия нескольких команд ОТМЕНИТЬ или О
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОЙ | Восстановление стертых объектов
ОТМЕНИТЬ | Отмена действия команд
ПОВТОРИТЬ | Отменяет действие последней команды ОТМЕНИТЬ или О
СТЕРЕТЬ | Удаление объектов из чертежа
Системные переменные
UNDOCTL | Указывает состояние параметров "Авто", "Управление" и "Группа" команды ОТМЕНИТЬ
UNDOMARKS | Сохраняет количество меток, заданных в команде ОТМЕНИТЬ (параметр "Метка") для управления отменой
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Стирание объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Стирание объектов
Понятия
Процедуры
Команды

Удаление объектов из чертежа можно выполнять различными способами.

  • Удаление с помощью команды УДАЛИТЬ.
  • Выберите объекты, а затем вырежьте их в буфер обмена с помощью комбинации клавиш CTRL+X.
  • Выберите объекты и нажмите УДАЛИТЬ.

Случайно стертые объекты можно восстановить командой ОТМЕНИТЬ. Команда ОЙ восстанавливает все объекты, удаленные последним выполнением одной из команд СТЕРЕТЬ, БЛОК или ПБЛОК

Очистка дисплея

Можно удалить маркеры и пикселы помех, которые могут остаться после некоторых операций редактирования, из области отображения.

  • Для удаления маркеров используйте команду ПЕРЕРИСОВЫВАТЬ.
  • Для удаления пиксел помех используйте команду РЕГЕН.
Удаление неиспользуемых описаний и стилей

Для удаления неиспользуемых именованных объектов, описаний блоков, размерных стилей, слоев, типов линий и текстовых стилей используется команда ОЧИСТИТЬ.

См. также

Исправление ошибок


Стирание объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Стирание объектов
Понятия
Процедуры
Команды

Для стирания объекта

Для восстановления последнего стертого объекта

Для вырезания объектов в буфер обмена

Для удаления маркеров

Для очистки чертежа от неиспользуемых типов линий


Для стирания объекта - Процедуры

Создание и редактирование объектов
Методы редактирования
Стирание объектов
Понятия
Процедуры
Команды

Для стирания объекта

  1. Выберите в меню "Изменить" » "Удалить".
  2. В ответ на подсказку "Выберите объекты" укажите объекты любым способом или задать одну из следующих опций:
    • Введите п (Последний) для стирания последнего созданного объекта.
    • Введите т (Текущий) для стирания объектов из текущего набора.
    • Введите все для стирания всех объектов чертежа.
    • Введите ? для получения информации обо всех методах выбора.
  3. Нажмите ENTER для завершения команды.

Панель "Редактирование"

Ввод команды: СТЕРЕТЬ


Для восстановления последнего стертого объекта - Процедуры

Создание и редактирование объектов
Методы редактирования
Стирание объектов
Понятия
Процедуры
Команды

Для восстановления последнего стертого объекта

  • В командной строке введите ой.

Восстанавливаются объекты, стертые последним выполнением одной из команд СТЕРЕТЬ, БЛОК или ПБЛОК.

Ввод команды: ОЙ


Для вырезания объектов в буфер обмена - Процедуры

Создание и редактирование объектов
Методы редактирования
Стирание объектов
Понятия
Процедуры
Команды

Для вырезания объектов в буфер обмена

  1. Выберите объекты для вырезания в буфер.
  2. Выберите в меню "Правка" » "Вырезать". Можно также нажать комбинацию клавиш CTRL+X.

    3. После этого объекты становятся доступны для вставки в других приложениях Windows.

Ввод команды: ВБУФЕР


Для удаления маркеров - Процедуры

Создание и редактирование объектов
Методы редактирования
Стирание объектов
Понятия
Процедуры
Команды

Для удаления маркеров

  • Выберите в меню "Вид" » "Освежить".

Ввод команды: ОСВЕЖИТЬ


Для очистки чертежа от неиспользуемых типов линий - Процедуры

Создание и редактирование объектов
Методы редактирования
Стирание объектов
Понятия
Процедуры
Команды

Для очистки чертежа от неиспользуемых типов линий

  1. Выберите в меню "Файл" » "Утилиты" » "Очистить".

    2. Появляется диалоговое окно "Очистка чертежа", отображающее дерево объектов, которые можно удалить.

  2. Для удаления неиспользуемых типов линий воспользоваться одним из способов:
    • Для очистки чертежа от всех неиспользуемых типов линий выберите "Типы линий".
    • Для очистки чертежа от определенных типов линий дважды нажмите на пункте "Типы линий" для раскрытия списка следующего уровня. Затем выделить типы линий для удаления.

    Если нужные элементы отсутствуют в списке, включить опцию "Просмотреть элементы, которые нельзя удалить".

  3. Удаление каждого элемента из списка требуется подтвердить. Для подавления запросов перед каждым удалением можно предварительно отключить опцию "Удаление элементов с подтверждением".
  4. Нажмите "Удалить".

    5. В ответ на запрос перед каждым удалением следует нажимать "Да", "Нет" или "Да для всех" для удаления сразу всех выбранных элементов.

  5. Нажмите кнопку "Закрыть".

Ввод команды: ОЧИСТИТЬ


Стирание объектов - Команды

Методы редактирования
Методы редактирования
Стирание объектов
Понятия
Процедуры
Команды

Команды
ВБУФЕР | Занесение объектов в буфер обмена с удалением их из чертежа
ВСЕОСВЕЖ | Перерисовка содержимого всех видовых экранов
ОЙ | Восстановление стертых объектов
ОСВЕЖИТЬ | Перерисовка содержимого текущего видового экрана
ОТМЕНИТЬ | Отмена действия команд
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
РЕГЕН | Регенерация чертежа и перерисовка содержимого текущего видового экрана
СТЕРЕТЬ | Удаление объектов из чертежа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование буфера обмена Windows - Понятия

Создание и редактирование объектов
Методы редактирования
Использование буфера обмена Windows
Понятия
Процедуры
Команды

При необходимости, объекты из чертежа можно скопировать или вырезать в буфер обмена, а затем вставить эти объекты в файл, открытый в другом приложении.

Вырезание объектов

В процессе вырезания выбранные объекты удаляются из чертежа и размещаются в буфере обмена. Эти объекты можно использовать для вставки в другие документы Microsoft® Windows®

Копирование объектов

Для копирования чертежа или его части в другое приложение можно использовать буфер обмена. Объекты копируются в векторном формате для сохранения высокого разрешения в других приложениях. Буфер обмена хранит эти объекты в формате метафайла Windows (WMF). Данные из буфера обмена могут внедряться в документы других приложений. При дальнейшем редактировании исходного объекта его вставленная копия в других приложениях не изменяется.

Вставка объектов

В различных приложениях для сохранения информации в буфере обмена используются различные внутренние форматы. При копировании объектов в буфер обмена информация сохраняется во всех доступных форматах. При вставке в чертеж содержимого буфера обмена используется формат, обеспечивающий наиболее полную информацию. Однако эту установку можно переопределить и задать явное преобразование информации о вставляемом объекте в формат AutoCAD.

Предпочтительно использовать при копировании объектов формат AutoCAD, так как он является самым удобным для редактирования созданных в AutoCAD объектов. Данный формат позволяет сохранить всю необходимую информацию об объекте, включая ссылки на блоки и трехмерные характеристики.

Формат метафайла Windows обеспечивает хранение графики в векторном представлении; таким образом, файлы могут масштабироваться и выводится на печать без потери качества. Данный формат рекомендуется использовать для вставки объектов в поддерживающие WMF-файлы приложения Windows. Вставляемые в AutoCAD метафайлы обладают большим разрешением, чем растровые изображения, но обрабатывать их сложнее, чем объекты AutoCAD. Растровые изображения, состоящие из описаний расположения пикселов, обычно используются в приложениях иллюстративной графики.

Цвет объекта не изменяется при копировании в буфер обмена. Если объект, имеющий белый цвет, вставляется в приложение с белым фоном рабочей области, то такой объект будет невидимым. Изменяя значения системных переменных WMFBKGND и WMFFOREGND, можно включать или отключать прозрачность фона и линий для формата метафайла объектов, помещенных в буфер обмена и вставленных в другие приложения.

Для вставки связанного или внедренного объекта из других приложений через буфер обмена в чертеж используется команда ВСТСПЕЦ. При этом, если данные буфера обмена можно преобразовать в формат AutoCAD, то объекты вставляются в виде вхождений блоков. Для редактирования вставленных таким образом блоков следует расчленить их в местах вхождений на отдельные объекты. Во время преобразования графики, хранимой в буфере обмена, из формата метафайла Windows в формат AutoCAD может произойти некоторая потеря точности масштабирования. Для избежания этого недостатка объекты из буфера обмена следует сохранять в виде блока в отдельном чертеже (ПБЛОК), а затем вставлять их в AutoCAD с помощью команды ВСТАВИТЬ.


Использование буфера обмена Windows - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование буфера обмена Windows
Понятия
Процедуры
Команды

Для вырезания объектов в буфер обмена

Для копирования объектов в буфер обмена

Для вставки объектов из буфера обмена

Для преобразования вставленной информации в формат файла чертежа


Для вырезания объектов в буфер обмена - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование буфера обмена Windows
Понятия
Процедуры
Команды

Для вырезания объектов в буфер обмена

  1. Выберите объекты для вырезания в буфер.
  2. Выберите в меню "Правка" » "Вырезать". Можно также нажать комбинацию клавиш CTRL+X.

    3. После этого объекты становятся доступны для вставки в другие приложения Windows.

Ввод команды: ВБУФЕР


Для копирования объектов в буфер обмена - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование буфера обмена Windows
Понятия
Процедуры
Команды

Для копирования объектов в буфер обмена

  1. Выберите объекты для копирования в буфер.
  2. Выберите в меню "Правка" » "Копировать". Можно также нажать комбинацию клавиш CTRL+C.

Ввод команды: КБУФЕР


Для вставки объектов из буфера обмена - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование буфера обмена Windows
Понятия
Процедуры
Команды

Для вставки объектов из буфера обмена

  • Выберите в меню "Правка" » "Вставить". Можно также нажать комбинацию клавиш CTRL+V.

    • Объекты, находящиеся в буфере обмена, вставляются в чертеж.

Ввод команды: ВСТБУФЕР


Для преобразования вставленной информации в формат файла чертежа - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование буфера обмена Windows
Понятия
Процедуры
Команды

Для преобразования вставленной информации в формат файла чертежа

  1. Выберите в меню "Правка" » "Специальная вставка".
  2. В диалоговом окне "Специальная вставка" выберите "Вставить".
  3. В списке форматов выберите "Растровое изображение".
  4. Нажмите "ОК".

Ввод команды: ВСТСПЕЦ


Использование буфера обмена Windows - Команды

Методы редактирования
Методы редактирования
Использование буфера обмена Windows
Понятия
Процедуры
Команды

Команды
ВБУФЕР | Занесение объектов в буфер обмена с удалением их из чертежа
ВСТБЛОК | Вставка скопированных ранее объектов в виде блока
ВСТБУФЕР | Вставка содержимого буфера обмена
ВСТИСХОД | Вставка скопированного блока в новый чертеж с координатами, которые он имел в исходном чертеже
ВСТСПЕЦ | Вставка данных из буфера обмена Windows с возможностью управления их форматом
ИМПОРТМТФ | Импорт метафайла Windows
КБУФЕР | Копирует объекты или текст из командной строки в буфер обмена
ОПЦИИМТФ | Задание опций для команды ИМПОРТМТФ
ЭКСПОРТМТФ | Сохранение объектов в метафайл Windows (WMF)
Системные переменные
OLEHIDE | Управляет отображением и выводом на печать объектов OLE
WMFBKGND | Управляет отображением фона при вставке объектов в формат метафайлов Windows (WMF)
WMFFOREGND | Управляет назначением цвета переднего плана при вставке объектов в формат метафайла Windows (WMF)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Редактирование объектов
Понятия
Процедуры
Команды

Объекты можно редактировать, изменяя их размеры, форму и расположение.

  • Выберите метод для редактирования объектов
  • Перемещение или поворот объектов
    Можно переместить объекты в другое место или изменить ориентацию объектов, повернув их в заданном направлении или переместив к другим объектам.
  • Копирование, зеркальное отображение и создание подобных объектов
    Существует возможность создания копий объектов: либо точных, либо с закономерными изменениями.
  • Изменение размеров и формы объектов
    Имеется несколько способов регулировки размеров существующих объектов относительно других объектов, как с соблюдением симметрии, так и без соблюдения симметрии.
  • Сопряжение, Фаска, Разорвать или Объединить объекты
    Объекты чертежа можно соединять, сопрягая их в углах или строя фаски (скошенные линии). Кроме того, в объектах можно создавать или удалять разрывы.
  • Редактирование с помощью ручек
    Ручки имеют вид квадратных меток и находятся в характерных точках выбранных объектов. Перетаскивая эти ручки, можно быстро и наглядно редактировать объекты.

См. также

Работа со сторонними объектами и заместителями

Редактирование размеров


Редактирование объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование объектов
Понятия
Процедуры
Команды

Для перемещения объекта по двум точкам

Для перемещения объекта на заданную величину смещения

Перемещение объекта из пространства модели в пространство листа (и наоборот)

Перемещение объектов с помощью растягивания

Для поворота объекта

Поворот объекта на заданный абсолютный угол

Для поворота 3D объекта вокруг оси

Выравнивание двух объектов в 2D представлении

Выравнивание двух объектов в 3D представлении

Для копирования объектов с помощью двух точек

Для создания прямоугольного массива

Для создания кругового массива

Для создания прямоугольного массива 3D объектов

Для создания кругового массива 3D объектов

Для построения подобного объекта путем задания смещения

Для построения подобного объекта, проходящего через точку

Для зеркального отображения объектов

Для зеркального отображения 3D объектов

Для удлинения объекта

Для обрезки объекта

Для удлинения объектов в 3D каркасных моделях

Для обрезки в 3D пространстве с проецированием на плоскость текущего вида

Для обрезки объектов в 3D каркасных моделях

Для растягивания объекта

Для масштабирования объекта с заданным масштабным коэффициентом

Для масштабирования объекта по длине опорного отрезка

Для изменения длины отрезка перетаскиванием

Задание радиуса сопряжения

Для сопряжения двух отрезков

Построение сопряжения без обрезки

Для построения сопряжений вдоль всей полилинии

Для сопряжения нескольких объектов

Для построения фаски по двум линейным размерам

Для соединения фаской двух непараллельных отрезков

Для построения фаски по линейному и угловому размерам

Для построения фаски без обрезки объектов

Для снятия фасок вдоль всей полилинии

Для соединения фаской нескольких объектов

Для разрывания объекта

Для соединения объектов

Для включения ручек

Для установки цвета ручек под курсором

Для задания предельного количества выбранных объектов для показа ручек

Для отображения подсказок к ручкам в пользовательских объектах, поддерживающих подсказки к ручкам

Для отмены выделения ручками

Для растягивания объекта с помощью ручек

Для растягивания с помощью нескольких ручек

Для перемещения объекта с помощью ручек

Для поворота объекта с помощью ручек

Для масштабирования объектов с помощью ручек

Для зеркального отображения объектов с помощью ручек

Для многократного копирования в любом режиме ручек

Для задания шага смещения при многократном копировании

Для задания шага поворота при многократном копировании

Для зеркального отображения объектов с помощью ручек и с сохранением оригиналов

Для включения и отключения ручек в блоках


Редактирование объектов - Команды

Создание и редактирование объектов
Методы редактирования
Редактирование объектов
Понятия
Процедуры
Команды
Команды
3DALIGN | Выравнивание объектов относительно других объектов в 2D и 3D
3DЗЕРКАЛО | Создание зеркальной копии объектов относительно заданной плоскости
3DМАССИВ | Построение трехмерных массивов
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
ВЫРОВНЯТЬ | Выравнивание объектов относительно других объектов в 2D и 3D
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
КОПИРОВАТЬ | Копирует объекты на заданное расстояние в указанном направлении
МАССИВ | Создание массивов объектов
МАСШТАБ | Пропорциональное увеличение/уменьшение размеров выбранных объектов в направлениях,и
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
ОБРЕЗАТЬ | Обрезка объекта по режущей кромке, заданной другими объектами
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПОВЕРНУТЬ | Поворачивает объект вокруг базовой точки.
ПОВЕРНУТЬ3D | Поворот объектов вокруг оси в 3D пространстве
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
ПСК | Управление пользовательскими системами координат
РАЗОРВАТЬ | Разрыв выбранного объекта между двумя точками
РАСТЯНУТЬ | Перенос или растягивание объектов
РЕДСПЛАЙН | Редактирование сплайнов или сглаженных сплайнами полилиний
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
СВОЙСТВА | Изменяет свойства объекта
СМЕНАПРОСТР | Переносит объекты из пространства модели в пространство листа и наоборот
СОЕДИНИТЬ | Соединяет объекты для формирования одного целого объекта
СОПРЯЖЕНИЕ | Скругление углов и сопряжение объектов
УВЕЛИЧИТЬ | Изменение длин объектов и центральных углов дуг
УДЛИНИТЬ | Удлинение объектов до пересечения с другими объектами
ФАСКА | Построение фасок в местах пересечения объектов
Системные переменные
ANGBASE | Задание для базового угла значения 0 в соответствии с текущей ПСК
ANGDIR | Задание направления для положительных углов.
CHAMFERA | Устанавливает первое расстояние фаски, когда значение CHAMMODE задано равным 0
CHAMFERB | Устанавливает второе расстояние фаски, когда значение CHAMMODE задано равным 0
CHAMFERC | Устанавливает длину фаски, когда значение CHAMMODE задано равным 1
CHAMFERD | Устанавливает угол фаски, когда значение CHAMMODE задано равным 1
CHAMMODE | Установка метода ввода для команды ФАСКА
DRAGMODE | Управляет отображением объектов при перетаскивании
EDGEMODE | Управляет режимом определения режущих и граничных кромок для команд ОБРЕЗАТЬ и УДЛИНИТЬ.
FILLETRAD | Сохраняет значение текущего радиуса сопряжения
GRIPBLOCK | Управляет ручками внутри блоков
GRIPCOLOR | Управляет цветом невыбранных ручек
GRIPHOT | Управляет цветом выбранных ручек
GRIPHOVER | Управляет цветом заполнения невыбранной ручки, когда курсор останавливается над ней
GRIPOBJLIMIT | Подавляет ручки, если исходный набор содержит больше объектов, чем задано
GRIPS | Управляет использованием набора ручек при растягивании, перемещении, повороте, масштабировании и зеркальном отображении объектов
GRIPSIZE | Устанавливает размер квадрата, изображающего ручку (в пикселах)
GRIPTIPS | Управляет подсказками для ручки при наведении курсора на ручку пользовательского объекта, поддерживающего подсказки к ручкам
MIRRTEXT | Управляет отображением текста с помощью команды ЗЕРКАЛО
OFFSETDIST | Устанавливает расстояние смещения по умолчанию
OFFSETGAPTYPE | Управляет зазорами между сегментами, возникающими при смещении замкнутых полилиний
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
PROJMODE | Устанавливает текущий режим проецирования для операций обрезки и удлинения
TRIMMODE | Управляет обрезкой выбранных кромок для фасок и сопряжений
UCSDETECT | Управляет активность сбора данных динамической ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выберите метод для редактирования объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Выберите метод для редактирования объектов
Понятия
Процедуры
Команды

Объекты можно редактировать, изменяя их размеры, форму и расположение. Пользователь может:

  • Вначале вызвать команду, а затем выберите объекты для редактирования.
  • Сначала выбрать объекты, а затем вызвать команду для их редактирования.
  • Для выбора контекстного меню выбрать объект и нажать правую кнопку мыши.
  • Дважды нажать объект для открытия палитры "Свойства" или, в некоторых случаях, диалогового окна или окна редактора, соответствующего типу объекта. (Путем редактирования файла НПИ и загрузки его в программу пользователь может назначить выполнение действия по двойному нажатию кнопки мыши для каждого типа объекта)

См. также

Редактирование текста

Выбор объектов

Редактирование размеров

Отображение и редактирование свойств объектов

Работа со сторонними объектами и заместителями

См. раздел Создание операции при двукратном нажатии в документе Руководство по адаптации


Выберите метод для редактирования объектов - Команды

Методы редактирования
Методы редактирования
Выберите метод для редактирования объектов
Понятия
Процедуры
Команды

Команды
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
СВОЙСТВА | Изменяет свойства объекта
Системные переменные
DRAGMODE | Управляет отображением объектов при перетаскивании
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Перемещение или поворот объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Перемещение или поворот объектов
Понятия
Процедуры
Команды

Можно переместить объекты в другое место или изменить ориентацию объектов, повернув их в заданном направлении или переместив к другим объектам.

  • Перемещение объектов
    Можно переместить объекты, расположив их на определенном расстоянии и в определенном направлении от исходных объектов.
  • Поворот объектов
    Объекты можно поворачивать на чертеже вокруг заданной базовой точки.
  • Выравнивание объектов
    Имеется возможность так переместить и повернуть объект, чтобы выровнять его с другим объектом.


Перемещение или поворот объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Перемещение или поворот объектов
Понятия
Процедуры
Команды

Для перемещения объекта по двум точкам

Для перемещения объекта на заданную величину смещения

Перемещение объекта из пространства модели в пространство листа (и наоборот)

Перемещение объектов с помощью растягивания

Для поворота объекта

Поворот объекта на заданный абсолютный угол

Для поворота 3D объекта вокруг оси

Выравнивание двух объектов в 2D представлении

Выравнивание двух объектов в 3D представлении


Перемещение или поворот объектов - Команды

Создание и редактирование объектов
Методы редактирования
Перемещение или поворот объектов
Понятия
Процедуры
Команды
Команды
3DALIGN | Выравнивание объектов относительно других объектов в 2D и 3D
ВЫРОВНЯТЬ | Выравнивание объектов относительно других объектов в 2D и 3D
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПОВЕРНУТЬ | Поворачивает объект вокруг базовой точки.
ПОВЕРНУТЬ3D | Поворот объектов вокруг оси в 3D пространстве
РАСТЯНУТЬ | Перенос или растягивание объектов
СВОЙСТВА | Изменяет свойства объекта
СМЕНАПРОСТР | Переносит объекты из пространства модели в пространство листа и наоборот
Системные переменные
UCSDETECT | Управляет активность сбора данных динамической ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Перемещение объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Перемещение объектов
Понятия
Процедуры
Команды

Можно переместить объекты, расположив их на определенном расстоянии и в определенном направлении от исходных объектов.

Используйте координаты, шаговую привязку, объектные привязки и другие инструменты для перемещения объектов с точностью.

Указание расстояния с помощью двух точек

Переместите объект, используя расстояние и направление, указанное базовой точкой, за которой следует вторая точка. В следующем примере производится перемещение блока, представляющего окно. Нажмите "Переместить" в меню "Правка", выберите объект для перемещения (1). Укажите базовую точку для перемещения (2), за которой следует вторая точка (3). Объект перемещается на расстояние и в направлении от точки 2 к точке 3.

Указание расстояния с помощью относительных координат

Объект можно переместить путем указания относительного расстояния, для задания которого нужно ввести значения координат первой точки и нажать ENTER для второй. Значения координат определяют не положение базовой точки, а величину смещения объекта.

Примечание Не следует вводить знак @ для указания относительных координат, так как здесь уже предполагается ввод именно относительных координат.

В режимах полярного отслеживания и "Орто" объекты можно копировать путем ввода расстояния перемещения. Дополнительную информацию см. в разделе Метод задания координат "направление-расстояние"

Использование операции "Растянуть-Переместить"

Для перемещения объектов, расположенных полностью внутри рамки выбора, можно использовать команду РАСТЯНУТЬ. Включите режим "Орто" или полярного отслеживания для перемещения объектов в заданном направлении.

Например: движение двери по направлению к стене. Дверь на чертеже находится полностью в секущей рамке, а линии стены лишь частично размещены в области секущей рамки.

В результате необходимо захватить рамкой весь объект для перемещения.

Использование альтернативных методов

Для быстрого перемещения и копирования объектов можно использовать ручки. См. раздел Редактирование с помощью ручек.

Можно также выбирать объекты и перетаскивать их на новое место; для создания копии нажмите CTRL. Таким способом можно перетаскивать объекты между открытыми чертежами и приложениями. При попытке перетаскивания с помощью правой кнопки мыши открывается контекстное меню. Это меню содержит опции "Перенести сюда", "Копировать сюда", "Вставить как блок" и "Отмена". См. раздел Внедрение OLE-объектов в чертежи.


Перемещение объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Перемещение объектов
Понятия
Процедуры
Команды

Для перемещения объекта по двум точкам

Для перемещения объекта на заданную величину смещения

Перемещение объекта из пространства модели в пространство листа (и наоборот)

Перемещение объектов с помощью растягивания


Для перемещения объекта по двум точкам - Процедуры

Создание и редактирование объектов
Методы редактирования
Перемещение объектов
Понятия
Процедуры
Команды

Для перемещения объекта по двум точкам

  1. Выберите в меню "Изменить" » "Переместить".
  2. Выберите объекты для перемещения.
  3. Укажите базовую точку перемещения.
  4. Укажите вторую точку.

    5. Выбранные объекты перемещаются в направлении и на расстояние, определяемые двумя заданными точками.

Панель "Редактирование"

Ввод команды: ПЕРЕНЕСТИ


Для перемещения объекта на заданную величину смещения - Процедуры

Создание и редактирование объектов
Методы редактирования
Перемещение объектов
Понятия
Процедуры
Команды

Для перемещения объекта на заданную величину смещения

  1. Выберите в меню "Изменить" » "Переместить".
  2. Выберите перемещаемый объект.
  3. Введите значения относительных координат смещения в декартовой, полярной, цилиндрической или сферической системе координат. Не следует вводить знак @, так как уже предполагается ввод относительных координат.
  4. На запрос второй точки нажмите ENTER.

    5. Значения координат определяют не положение базовой точки, а величину смещения объекта. Выбранные объекты перемещаются на заданную величину смещения.

Панель "Редактирование"

Ввод команды: ПЕРЕНЕСТИ


Перемещение объекта из пространства модели в пространство листа (и наоборот) - Процедуры

Создание и редактирование объектов
Методы редактирования
Перемещение объектов
Понятия
Процедуры
Команды

Перемещение объекта из пространства модели в пространство листа (и наоборот)

  1. Перейдите на вкладку "Лист".
  2. Выберите в меню "Изменить" » "Смена пространства".
  3. Выберите один или несколько объектов для перемещения.
  4. Нажмите ENTER.

    5. Объект перемещается в выбранное пространство и в соответствии с этим пространстовом изменяет свой масштаб.

Панель "Редактирование"

Ввод команды: СМЕНАПРОСТР


Перемещение объектов с помощью растягивания - Процедуры

Создание и редактирование объектов
Методы редактирования
Перемещение объектов
Понятия
Процедуры
Команды

Перемещение объектов с помощью растягивания

  1. Выберите в меню "Изменить" » "Растянуть".
  2. Выберите объекты секущей рамкой.

    3. Секущая рамка должна захватывать по крайней мере одну вершину или определяющую точку объекта. Выбор секущей рамкой осуществляется путем щелчка и перетаскивания мыши справа налево, после чего необходимо снова нажать кнопку мыши.

  3. Выполните одно из следующих действий:
    • Укажите базовую точку и вторую точку для перемещения.
    • Введите значения относительных координат смещения в декартовой, полярной, цилиндрической или сферической системе координат. Не следует вводить знак @, так как уже предполагается ввод относительных координат. На запрос второй точки смещения нажмите ENTER.

    Объекты, у которых хотя бы одна вершина или определяющая точка расположена внутри секущей рамки, растягиваются. Объекты, полностью охваченные секущей рамкой, перемещаются без растягивания.

Панель "Редактирование"

Ввод команды: РАСТЯНУТЬ


Перемещение объектов - Команды

Методы редактирования
Методы редактирования
Перемещение объектов
Понятия
Процедуры
Команды

Команды
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
РАСТЯНУТЬ | Перенос или растягивание объектов
СВОЙСТВА | Изменяет свойства объекта
СМЕНАПРОСТР | Переносит объекты из пространства модели в пространство листа и наоборот
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Поворот объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Поворот объектов
Понятия
Процедуры
Команды

Объекты можно поворачивать на чертеже вокруг заданной базовой точки.

Для определения угла поворота вводится значение угла, перетаскивается с помощью курсора или указывается опорный угол для выравнивания с абсолютным углом.

Поворот объекта на заданный угол

Введите значение угла поворота в диапазоне от 0 до 360 градусов. Значения также могут вводиться в радианах, градах и топографических единицах. Направление отсчета углов (по часовой стрелке или против нее) определяется установкой "Выбор направления" в диалоговом окне "Единицы измерения".

Поворот объекта с помощью перетаскивания

Протащите объект возле базовой точки и укажите вторую точку. Используйте режимы "Орто", полярного отслеживания или объектной привязки для большей точности.

Например, можно повернуть план дома путем выбора объектов (1), указания базовой точки (2) и угла поворота, перемещая к другой точке (3).

Поворот объекта на заданный абсолютный угол

С помощью параметра "Ссылка" можно поверните объект для выравнивания с абсолютным углом.

Например, поверните деталь на чертеже, чтобы диагональная кромка повернулась на 90 градусов, выберите объекты для поворота (1, 2), укажите базовую точку (3) и введите параметр "Ссылка". Для опорного угла укажите две конечные точки диагональной линии (4, 5). Для нового угла введите значение 90.

Поворот объектов в трехмерном пространстве

Для поворота 3D объектов может использоваться команда ПОВЕРНУТЬ или ПОВЕРНУТЬ3D.

  • С помощью команды ПОВЕРНУТЬ можно повернуть объекты вокруг указанной базовой точки. Ось вращения проходит через базовую точку и параллельна оси Z текущей ПСК.
  • С помощью ПОВЕРНУТЬ3D можно задавать ось вращения с использованием двух точек; либо объекта; оси X, Y или Z либо направления Z текущего вида.

См. также

Поворот видов на видовых экранах листа


Поворот объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Поворот объектов
Понятия
Процедуры
Команды

Для поворота объекта

Поворот объекта на заданный абсолютный угол

Для поворота 3D объекта вокруг оси


Для поворота объекта - Процедуры

Создание и редактирование объектов
Методы редактирования
Поворот объектов
Понятия
Процедуры
Команды

Для поворота объекта

  1. Выберите в меню "Изменить" » "Повернуть".
  2. Выберите поворачиваемый объект.
  3. Укажите базовую точку поворота.
  4. Выполните одно из следующих действий:
    • Введите значение угла поворота.
    • Перетащите объект возле базовой точки и укажите местоположение точки, к которой нужно повернуть объект.
    • Введите c для создания копии выбранных объектов.
    • Введите r для поворота выбранных объектов не на указанный опорный угол, а на абсолютный угол.

Панель "Редактирование"

Ввод команды: ПОВЕРНУТЬ


Поворот объекта на заданный абсолютный угол - Процедуры

Создание и редактирование объектов
Методы редактирования
Поворот объектов
Понятия
Процедуры
Команды

Поворот объекта на заданный абсолютный угол

  1. Выберите в меню "Изменить" » "Повернуть".
  2. Выберите поворачиваемые объекты.
  3. Укажите базовую точку поворота.
  4. Выполните одно из следующих действий:
  5. Введите значение опорного угла или указать два местоположения точек.

    6. С помощью этого можно определить воображаемую линию, которую будет повернута на новый угол.

  6. Введите новый угол или указать точку.

    7. Значение, которое было введено для нового угла, является значением абсолютного угла. Если же указать точку, то опорный угол будет повернут к этой точке.

Панель "Редактирование"

Ввод команды: ПОВЕРНУТЬ


Для поворота 3D объекта вокруг оси - Процедуры

Создание и редактирование объектов
Методы редактирования
Поворот объектов
Понятия
Процедуры
Команды

Для поворота 3D объекта вокруг оси

  1. Выберите в меню "Редакт" » "3D операции" » "3D поворот".
  2. Выберите поворачиваемый объект (1).
  3. Укажите начальную и конечную точки оси вращения (2, 3).

    4. Положительным направлением оси считается направление от начальной точки к конечной; поворот подчиняется правилу правой руки (см. раздел Понятие о пользовательской системе координат в 3D).

  4. Задать угол поворота.

Ввод команды: ПОВЕРНУТЬ3D


Поворот объектов - Команды

Методы редактирования
Методы редактирования
Поворот объектов
Понятия
Процедуры
Команды

Команды
ПОВЕРНУТЬ | Поворачивает объект вокруг базовой точки.
ПОВЕРНУТЬ3D | Поворот объектов вокруг оси в 3D пространстве
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выравнивание объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Выравнивание объектов
Понятия
Процедуры
Команды

Имеется возможность так переместить и повернуть объект, чтобы выровнять его с другим объектом.

В приведенном ниже примере две пары точек используются для выравнивания трубопровода в 2D представлении с использованием команды ВЫРОВНЯТЬ. Использование объектных привязок конечных точек позволяет выровнять трубы с высокой точностью.

В 3D представлении команда 3-ВЫРОВНЯТЬ используется для обозначения до трех точек с целью определения исходной плоскости м далее до трех точек с целью определения конечной плоскости.

  • Первая исходная точка на объекте, именуемая базовой точкой, всегда переносится в первую конечную точку.
  • Указание второй исходной или конечной точки приводит к повороту выбранных объектов.
  • Третья точка, определяемая для исходной или конечной плоскости, приводит к дополнительному повороту выбранных объектов.

При работе с 3D моделями тел рекомендуется включать динамическую ПСК для ускорения выбора конечной плоскости.


Выравнивание объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Выравнивание объектов
Понятия
Процедуры
Команды

Выравнивание двух объектов в 2D представлении

Выравнивание двух объектов в 3D представлении


Выравнивание двух объектов в 2D представлении - Процедуры

Создание и редактирование объектов
Методы редактирования
Выравнивание объектов
Понятия
Процедуры
Команды

Выравнивание двух объектов в 2D представлении

  1. Выберите в меню "Изменить" » "3D операции" » "Выровнять".
  2. Выберите объекты для выравнивания.
  3. Укажите исходную точку и далее соответствующую конечную точку. Для поворота объекта укажите вторую исходную точку и далее вторую конечную точку.
  4. Нажмите ENTER для завершения команды.

    5. Выбранные объекты перемещаются из исходной точки в конечную, а а вторая и третья точки, если таковые заданы, определяют поворот и наклон выбранных объектов.

Ввод команды: ВЫРОВНЯТЬ


Выравнивание двух объектов в 3D представлении - Процедуры

Создание и редактирование объектов
Методы редактирования
Выравнивание объектов
Понятия
Процедуры
Команды

Выравнивание двух объектов в 3D представлении

  1. Выберите в меню "Редакт" » "3D операции" » "3D выравнивание".
  2. Выберите объекты для выравнивания.
  3. Укажите одну, две или три исходных точки, а затем соответствующие им первую, вторую и третью конечные точки. Первая точка именуется базовой точкой.

    4. Объекты перемещаются из исходной точки в конечную, а а вторая и третья точки, если таковые заданы, определяют поворот и наклон выбранных объектов.

Ввод команды: 3DALIGN


Выравнивание объектов - Команды

Методы редактирования
Методы редактирования
Выравнивание объектов
Понятия
Процедуры
Команды

Команды
3DALIGN | Выравнивание объектов относительно других объектов в 2D и 3D
ВЫРОВНЯТЬ | Выравнивание объектов относительно других объектов в 2D и 3D
Системные переменные
UCSDETECT | Управляет активность сбора данных динамической ПСК
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Копирование, зеркальное отображение и создание подобных объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Копирование, зеркальное отображение и создание подобных объектов
Понятия
Процедуры
Команды

Существует возможность создания копий объектов: либо точных, либо с закономерными изменениями.

  • Копирование объектов
    Можно создать копии объектов на указанном расстоянии и в указанном направлении от оригиналов.
  • Размножение объектов массивом
    Объекты можно копировать, упорядоченно располагая копии по окружности (круговой массив) или в узлах прямоугольного массива.
  • Создание подобных объектов
    Сместите объект для создания нового объекта, подобного имеющемуся и расположенному на заданном расстоянии от него.
  • Зеркальное отображение объектов
    Зеркальное отображение позволяет создавать зеркальные копии объектов относительно заданной оси.


Копирование, зеркальное отображение и создание подобных объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Копирование, зеркальное отображение и создание подобных объектов
Понятия
Процедуры
Команды

Для копирования объектов с помощью двух точек

Для создания прямоугольного массива

Для создания кругового массива

Для создания прямоугольного массива 3D объектов

Для создания кругового массива 3D объектов

Для построения подобного объекта путем задания смещения

Для построения подобного объекта, проходящего через точку

Для зеркального отображения объектов

Для зеркального отображения 3D объектов


Копирование, зеркальное отображение и создание подобных объектов - Команды

Создание и редактирование объектов
Методы редактирования
Копирование, зеркальное отображение и создание подобных объектов
Понятия
Процедуры
Команды
Команды
3DЗЕРКАЛО | Создание зеркальной копии объектов относительно заданной плоскости
3DМАССИВ | Построение трехмерных массивов
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
КОПИРОВАТЬ | Копирует объекты на заданное расстояние в указанном направлении
МАССИВ | Создание массивов объектов
ПСК | Управление пользовательскими системами координат
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
Системные переменные
ANGBASE | Задание для базового угла значения 0 в соответствии с текущей ПСК
ANGDIR | Задание направления для положительных углов.
MIRRTEXT | Управляет отображением текста с помощью команды ЗЕРКАЛО
OFFSETDIST | Устанавливает расстояние смещения по умолчанию
OFFSETGAPTYPE | Управляет зазорами между сегментами, возникающими при смещении замкнутых полилиний
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Копирование объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Копирование объектов
Понятия
Процедуры
Команды

Можно создать копии объектов на указанном расстоянии и в указанном направлении от оригиналов.

Использовать координаты, шаговую привязку, объектные привязки и другие инструменты для копирования объектов с точностью.

Указание расстояния с помощью двух точек

Копировать объект, используя расстояние и направление, указанное базовой точкой, за которой следует вторая точка. В следующем примере производится копирование блока, представляющего электронный компонент. Нажмите "Переместить" в меню "Правка" и выберите исходный объект для копирования. Укажите базовую точку для перемещения (1), за которой следует вторая точка (2). Объект копируется на расстояние и в направлении от точки 1 к точке 2.

Указание расстояния с помощью относительных координат

Объект можно скопировать методом относительного расстояния, для чего нужно ввести значения координат для первой точки и нажать ENTER для ввода второй. Значения координат определяют не положение базовой точки, а величину смещения объекта.

Примечание Не следует вводить знак @ для указания относительных координат, так как здесь уже предполагается ввод именно относительных координат.

В режимах полярного отслеживания и "Орто" объекты можно копировать путем ввода расстояния перемещения. Дополнительную информацию см. в разделе Метод задания координат "направление-расстояние".

Создание нескольких копий

Для удобства повторять команду КОПИРОВАТЬ. Для завершения команды нажмите ENTER.

Использование альтернативных методов

Для быстрого перемещения и копирования объектов можно использовать ручки. См. раздел Редактирование с помощью ручек.

Можно также выбирать объекты и перетаскивать их на новое место; для создания копии нажмите CTRL. Таким способом можно перетаскивать объекты между открытыми чертежами и приложениями. При попытке перетаскивания с помощью правой кнопки мыши открывается контекстное меню. Это меню содержит опции "Перенести сюда", "Копировать сюда", "Вставить как блок" и "Отмена". См. раздел Внедрение OLE-объектов в чертежи.


Для копирования объектов с помощью двух точек - Процедуры

Создание и редактирование объектов
Методы редактирования
Копирование объектов
Понятия
Процедуры
Команды

Для копирования объектов с помощью двух точек

  1. Выберите в меню "Изменить" » "Копировать".
  2. Выберите копируемые объекты.
  3. Укажите базовую точку.
  4. Укажите вторую точку. Нажмите ENTER.

Панель "Редактирование"

Ввод команды: КОПИРОВАТЬ


Копирование объектов - Команды

Методы редактирования
Методы редактирования
Копирование объектов
Понятия
Процедуры
Команды

Команды
КОПИРОВАТЬ | Копирует объекты на заданное расстояние в указанном направлении
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Размножение объектов массивом - Понятия

Создание и редактирование объектов
Методы редактирования
Размножение объектов массивом
Понятия
Процедуры
Команды

Объекты можно копировать, упорядоченно располагая копии по окружности (круговой массив) или в узлах прямоугольного массива.

Для прямоугольных массивов задается количество рядов и столбцов, а также расстояние между ними. Для круговых массивов задается количество копий объекта и режим их поворота. Размножение массивом является более быстрым методом для создания нескольких копий объекта с заданным интервалом, чем выполнение обычного копирования.

Создание прямоугольных массивов

Прямоугольный массив создан вдоль базовой линии, определяемой текущим углом поворота шаговой привязки. Этот угол по умолчанию равен нулю, так что ряды и столбцы прямоугольного массива взаимно перпендикулярны и располагаются вдоль осей X и Y. Направление нулевого угла, принятое по умолчанию, можно изменить командой ЕДИНИЦЫ.

Создание круговых массивов

Направление создания кругового массива (по часовой стрелке или против нее) определяется знаком (положительный или отрицательный) угла заполнения массива.

При генерации массива радиус определяется расстоянием от центра массива до опорной или базовой точки на последнем выбранном объекте. Для создания массива может использоваться текущая опорная точка, обычной совпадающая с точкой привязки, или новая указанная базовая точка, которая в дальнейшем используется в качестве опорной точки.

Размножение 3D объектов массивом

С помощью команды 3DМАССИВ можно создать прямоугольный или полярный массив объектов в трехмерном пространстве. Дополнительно к заданию числа рядов (в направлении X) и числа столбцов (в направлении Y) здесь необходимо указать и число этажей массива (в направлении Z).

Ограничение размера массивов

Если для массива указать большое число рядов и столбцов, для создания копий может потребоваться много времени. По умолчанию число элементов массива, создаваемого по одной команде, ограничивается значением порядка 100000. Это предельное значение определяется в реестре при помощи переменной MaxArray.

Пользователь может изменить этот предел путем настройки системной переменной MaxArray с помощью команды (setenv “MaxArray” “n”) где n является числом от 100 до 10000000 (десять миллионов).

Примечание При изменении значения MaxArray необходимо соблюдать регистр символов в имени этой переменной.


Размножение объектов массивом - Процедуры

Создание и редактирование объектов
Методы редактирования
Размножение объектов массивом
Понятия
Процедуры
Команды

Для создания прямоугольного массива

Для создания кругового массива

Для создания прямоугольного массива 3D объектов

Для создания кругового массива 3D объектов


Для создания прямоугольного массива - Процедуры

Создание и редактирование объектов
Методы редактирования
Размножение объектов массивом
Понятия
Процедуры
Команды

Для создания прямоугольного массива

  1. Выберите в меню "Изменить" » "Массив".
  2. В диалоговом окне "Массив" выберите "Прямоугольный массив".
  3. Нажмите кнопку "Выбор объектов".

    4. Закрытие диалогового окна "Массив". Запрос на выбор объектов.

  4. Выберите объекты для сведения в массив и нажмите ENTER.
  5. В полях "Рядов" и "Столбцов" введите число рядов и столбцов.
  6. Задать горизонтальное и вертикальное расстояния между объектами одним из следующих способов:
    • В полях "Между рядами" и "Между столбцами" введите значения расстояний между рядами и столбцами. Знак числа (плюс или минус) указывает на направление построения массива.
    • Нажмите кнопку "Указать оба расстояния" и указать с помощью устройства указания два противоположных угла ячейки массива. Ячейка определяет вертикальное и горизонтальное расстояния между рядами и столбцами.
    • Нажмите кнопку "Указать расстояние между рядами" для задания вертикального расстояния с помощью устройства указания и кнопку "Указать расстояние между столбцами" для задания горизонтального расстояния.

    В окне образца выводится результат действий.

  7. Для изменения угла поворота массива введите новое значение угла в поле "Угол поворота".
  8. Направление нулевого угла, принятого по умолчанию, можно изменить командой ЕДИНИЦЫ.
  9. Нажмите кнопку "ОК" для создания массива.

Панель "Редактирование"

Ввод команды: МАССИВ


Для создания кругового массива - Процедуры

Создание и редактирование объектов
Методы редактирования
Размножение объектов массивом
Понятия
Процедуры
Команды

Для создания кругового массива

  1. Выберите в меню "Изменить" » "Массив".
  2. В диалоговом окне "Массив" выберите "Круговой массив".
  3. Для задания точки центра кругового массива выполнить одно из действий:
    • Введите значения координат X и Y, определяющие положение центра кругового массива.
    • Нажмите кнопку "Указать центр массива". Диалоговое окно "Массив" временно закрывается, и предлагается выбрать объекты. С помощью устройства указания задать точку центра кругового массива.
  4. Нажмите кнопку "Выбор объектов".

    5. Диалоговое окно "Массив" временно закрывается, и предлагается выбрать объекты.

  5. Выберите размножаемые объекты.
  6. В списке "Способ построения" выберите один из предлагаемых способов:
    • Число элементов и угол заполнения
    • Число элементов и угол между элементами
    • Угол заполнения и угол между элементами
  7. Введите число элементов, включая исходный объект, если установлена соответствующая опция.
  8. Воспользуйтесь одним из следующих способов:
    • Введите значения угла заполнения и угла между элементами, если таковые известны. В поле "Угол заполнения" указывается угол заполнения массива. В поле "Угол между элементами" задается угловое расстояние между парой соседних элементов.
    • Нажмите кнопку "Указать угол заполнения" или "Указать угол между элементами". Используйте указывающее устройство, чтобы указать угол заполнения и угол между элементами.

    В окне образца выводится результат действий.

  9. При необходимости настройте дополнительные опции:
    • Для поворота элементов в массиве установите флажок "Поворачивать элементы массива". В окне образца выводится результат действий.
    • Чтобы указать базовую точку осей X,Y, выберите "Подробнее", отключите параметр "Как установлено в объекте" и введите значения в окна X и Y, или нажмите кнопку "Указать базовую точку" и используйте указывающее устройство для указания точки.
  10. Нажмите кнопку "ОК" для создания массива.

Панель "Редактирование"

Ввод команды: МАССИВ


Для создания прямоугольного массива 3D объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Размножение объектов массивом
Понятия
Процедуры
Команды

Для создания прямоугольного массива 3D объектов

  1. Выберите в меню "Редакт" » "3D операции" » "3D массив".
  2. Выберите размножаемый объект (1).
  3. Задать опцию "Прямоугольный".
  4. Введите число рядов.
  5. Введите число столбцов.
  6. Введите число этажей.
  7. Задать расстояние между рядами.
  8. Задать расстояние между столбцами.
  9. Задать расстояние между этажами.

Ввод команды: 3DМАССИВ


Для создания кругового массива 3D объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Размножение объектов массивом
Понятия
Процедуры
Команды

Для создания кругового массива 3D объектов

  1. Выберите в меню "Редакт" » "3D операции" » "3D массив".
  2. Выберите размножаемый объект (1).
  3. Задать опцию "Круговой".
  4. Задать число элементов массива.
  5. Задать угол заполнения.
  6. Нажмите ENTER для поворота объектров в ходе объединения в массив или введите n для сохранения их ориентации.
  7. Укажите начальную и конечную точки оси вращения (2, 3).

Ввод команды: 3DМАССИВ


Размножение объектов массивом - Команды

Методы редактирования
Методы редактирования
Размножение объектов массивом
Понятия
Процедуры
Команды

Команды
3DМАССИВ | Построение трехмерных массивов
ЕДИНИЦЫ | Задание форматов и точности представления линейных и угловых единиц
МАССИВ | Создание массивов объектов
ПСК | Управление пользовательскими системами координат
РЕЖИМЧРТ | Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода
Системные переменные
ANGBASE | Задание для базового угла значения 0 в соответствии с текущей ПСК
ANGDIR | Задание направления для положительных углов.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание подобных объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Создание подобных объектов
Понятия
Процедуры
Команды

С помощью команды СМЕСТИТЬ можно создать новый объект, подобный выбранному объекту. Подобные круги или дуги имеют диаметр, больший или меньший радиуса исходного, в зависимости от того, как задано смещение.

Создание подобных объектов с последующей обрезкой или удлинением концов является эффективным методом построений.

Можно строить следующие подобные объекты:

  • Отрезки
  • Дуги
  • Круги
  • Эллипсы и эллиптические дуги (в результате образуются сплайны овальных форм)
  • Двумерные полилинии
  • Прямые и лучи
  • Сплайны
Особые случаи перемещения полилиний и сплайнов

Обрезка двумерных полилиний и сплайнов происходит автоматически, если расстояние смещения превышает значение, допустимое для размещения создаваемого подобного объекта.

Закрытые 2D полилинии, которые смещаются для создания более крупных полилиний, приводят к зазорам между сегментами. Системная переменная OFFSETGAPTYPE контролирует закрытие зазоров.


Создание подобных объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Создание подобных объектов
Понятия
Процедуры
Команды

Для построения подобного объекта путем задания смещения

Для построения подобного объекта, проходящего через точку


Для построения подобного объекта путем задания смещения - Процедуры

Создание и редактирование объектов
Методы редактирования
Создание подобных объектов
Понятия
Процедуры
Команды

Для построения подобного объекта путем задания смещения

  1. Выберите в меню "Изменить" » "Смещение".
  2. Задать расстояние смещения.

    3. Смещение задается с помощью устройства указания или вводом с клавиатуры.

  3. Выберите исходный объект.
  4. Укажите сторону смещения.
  5. Выберите для смещения следующий объект или нажмите ENTER для завершения команды.

Панель "Редактирование"

Ввод команды: ПОДОБИЕ


Для построения подобного объекта, проходящего через точку - Процедуры

Создание и редактирование объектов
Методы редактирования
Создание подобных объектов
Понятия
Процедуры
Команды

Для построения подобного объекта, проходящего через точку

  1. Выберите в меню "Изменить" » "Смещение".
  2. Задайте расстояние смещения.
  3. Выберите исходный объект.
  4. Укажите точку, через которую должен проходить новый объект.
  5. Выберите для смещения следующий объект или нажмите ENTER для завершения команды.

Панель "Редактирование"

Ввод команды: ПОДОБИЕ


Создание подобных объектов - Команды

Методы редактирования
Методы редактирования
Создание подобных объектов
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
OFFSETDIST | Устанавливает расстояние смещения по умолчанию
OFFSETGAPTYPE | Управляет зазорами между сегментами, возникающими при смещении замкнутых полилиний
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Зеркальное отображение объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Зеркальное отображение объектов
Понятия
Процедуры
Команды

Зеркальное отображение позволяет создавать зеркальные копии объектов относительно заданной оси.

Функция зеркального отражения помогает быстро создавать симметричные объекты, так как достаточно построение лишь половины объекта с последующим зеркальным отражением вместо построения целого объекта.

Зеркальное отображение объектов производится относительно оси отражения. Ось отражения задается двумя точками. Можно выбрать удаление или сохранение исходных объектов.

Согласно настройкам по умолчанию при зеркальном отражении тексты, атрибуты и описания атрибутов в зеркальном изображении не обращаются справа налево и не переворачиваются вверх ногами. Выравнивание и отступ текста остаются такими же, как до операции зеркального отражения. Если обращение текста справа налево все-таки необходимо, задайте значение 1 для системной переменной MIRRTEXT.

Переменная MIRRTEXT влияет на текст, который создан с помощью команд ТЕКСТ, }АТОПР или МТЕКСТ, а также на описания атрибутов и переменные атрибуты. При зеркальном отражении блока текст и постоянные атрибуты, являющиеся частью вставленного блока, обращаются независимо от состояния параметра MIRRTEXT.

Зеркальное отображение в трехмерном пространстве

С помощью команды 3DЗЕРКАЛО, можно зеркально отразить объекты относительно указанной плоскости отражения. Плоскость отражения может представлять собой:

  • Плоскость построения 2D объекта
  • Плоскость, параллельная одной из плоскостей координат (XY, YZ или XZ) текущей ПСК и проходящая через заданную точку
  • Плоскость определяется тремя указанными точками (2, 3 и 4)


Зеркальное отображение объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Зеркальное отображение объектов
Понятия
Процедуры
Команды

Для зеркального отображения объектов

Для зеркального отображения 3D объектов


Для зеркального отображения объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Зеркальное отображение объектов
Понятия
Процедуры
Команды

Для зеркального отображения объектов

  1. Выберите в меню "Изменить" » "Зеркало".
  2. Выберите отображаемые объекты.
  3. Укажите первую точку оси отражения.
  4. Укажите вторую точку.
  5. Нажмите ENTER для сохранения исходных объектов или введите y для их удаления.

Панель "Редактирование"

Ввод команды: ЗЕРКАЛО


Для зеркального отображения 3D объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Зеркальное отображение объектов
Понятия
Процедуры
Команды

Для зеркального отображения 3D объектов

  1. Выберите в меню "Редакт" » "3D операции" » "3D зеркало".
  2. Выберите отображаемый объект.
  3. Укажите три точки, определяющие плоскость отражения.
  4. Нажмите ENTER для сохранения исходных объектов или введите y для их удаления.

Ввод команды: 3DЗЕРКАЛО


Зеркальное отображение объектов - Команды

Методы редактирования
Методы редактирования
Зеркальное отображение объектов
Понятия
Процедуры
Команды

Команды
3DЗЕРКАЛО | Создание зеркальной копии объектов относительно заданной плоскости
Системные переменные
MIRRTEXT | Управляет отображением текста с помощью команды ЗЕРКАЛО
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение размеров и формы объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Изменение размеров и формы объектов
Понятия
Процедуры
Команды

Имеется несколько способов регулировки размеров существующих объектов относительно других объектов, как с соблюдением симметрии, так и без соблюдения симметрии.

  • Обрезка и удлинение объектов
    Объекты можно обрезать или удлинять так, чтобы они заканчивались точно на граничных кромках, определяемых другими объектами.
  • Изменение размеров и форм объектов
    Объекты можно изменять, увеличивая или уменьшая их размеры как в одном направлении, так и с сохранением пропорций.


Изменение размеров и формы объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Изменение размеров и формы объектов
Понятия
Процедуры
Команды

Для удлинения объекта

Для обрезки объекта

Для удлинения объектов в 3D каркасных моделях

Для обрезки в 3D пространстве с проецированием на плоскость текущего вида

Для обрезки объектов в 3D каркасных моделях

Для растягивания объекта

Для масштабирования объекта с заданным масштабным коэффициентом

Для масштабирования объекта по длине опорного отрезка

Для изменения длины отрезка перетаскиванием


Изменение размеров и формы объектов - Команды

Создание и редактирование объектов
Методы редактирования
Изменение размеров и формы объектов
Понятия
Процедуры
Команды
Команды
МАСШТАБ | Пропорциональное увеличение/уменьшение размеров выбранных объектов в направлениях,и
ОБРЕЗАТЬ | Обрезка объекта по режущей кромке, заданной другими объектами
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
РАЗОРВАТЬ | Разрыв выбранного объекта между двумя точками
РАСТЯНУТЬ | Перенос или растягивание объектов
РЕДСПЛАЙН | Редактирование сплайнов или сглаженных сплайнами полилиний
СВОЙСТВА | Изменяет свойства объекта
СОЕДИНИТЬ | Соединяет объекты для формирования одного целого объекта
УВЕЛИЧИТЬ | Изменение длин объектов и центральных углов дуг
УДЛИНИТЬ | Удлинение объектов до пересечения с другими объектами
Системные переменные
EDGEMODE | Управляет режимом определения режущих и граничных кромок для команд ОБРЕЗАТЬ и УДЛИНИТЬ.
PROJMODE | Устанавливает текущий режим проецирования для операций обрезки и удлинения
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обрезка и удлинение объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Обрезка и удлинение объектов
Понятия
Процедуры
Команды

Объекты можно обрезать или удлинять так, чтобы они заканчивались точно на граничных кромках, определяемых другими объектами.

Таким образом, вначале можно создать такой объект, как отрезок, а затем изменить его длину, точно ограниченную с разных сторон другими объектами.

Объекты, выбираемые для определения граничных или режущих кромок, не обязательно должны пересекаться с обрезаемыми объектами. В операции могут участвовать и продолжения кромок, т.е. объекты удлиняются/обрезаются в точках воображаемых пересечений с кромками.

Если контур не задан, то нажатие клавиши ENTER на запрос "Выберите объект" превращает все отображаемые объекты в потенциальные контуры.

Примечание Для выбора режущих или граничных кромок, в которые входят блоки, можно использовать только параметры "Одиночный", "Секущая рамка", "Линия" и "Выбрать все".

Обрезка объектов

Имеется возможность обрезки объекта точно по режущей кромке, задаваемой одним или несколькими объектами.

Например, можно производить обрезку ненужных участков линий в месте пересечения двух стен.

Один и тот же объект может быть одновременно и режущей кромкой, и обрезаемым объектом. Например, на чертеже осветительного прибора окружность является режущей кромкой для прямых линий, и в то же время обрезается сама.

При обрезке составных объектов следует внимательно относиться к способам выбора режущих кромок и обрезаемых объектов. В следующем примере режущие кромки выбираются секущей рамкой.

В следующем примере обрезаемые объекты выбираются с помощью линии выбора.

Имеется возможность обрезать объекты до их ближайших пересечений с другими объектами. Вместо указания режущей кромки следует просто нажать ENTER. Далее, после выбора обрезаемых объектов, ближайшие отображаемые объекты выступают в качестве режущих кромок. В следующем примере производится обрезка ненужных участков линий в месте пересечения стен.

Имеется возможность обрезать объекты до их ближайших пересечений с другими объектами. Удерживая клавишу SHIFT нажатой, выберите объекты для удлинения.

Удлинение объектов

Удлинение и обрезка объектов схожи по технике выполнения. Имеется возможность удлинить объекты так, чтобы они заканчивались точно на граничных кромках, определенных другими объектами. В следующем примере отрезки удлиняются до пересечения с окружностью.

Пользователь может обрезать объекты не выходя из команды УДЛИНИТЬ. Удерживайте нажатой клавишу SHIFT и выберите объекты для обрезки.

Обрезка и удлинение широких полилиний

Обрезка 2D широких полилиний и удлинение центровых линий. Торцы широких полилиний всегда перпендикулярны осевым линиям. Если кромка направлена не под прямым углом, часть обрезанной полилинии выступает за кромку

При обрезке или удлинении сужающегося сегмента 2D полилинии ширина удлиненной конечной точки корректируется для сохранения степени сужения для новой конечной точки. Если в результате конечная ширина становится отрицательной, то она приравнивается к нулю.

Обрезка и удлинение сглаженных сплайнами полилиний

Обрезка сглаженных сплайнами полилиний стирает информацию о сглаженных сплайнами полилиниях и превращает сглаженные сплайнами сегменты в обычные сегменты полилиний.

При удлинении полилинии, сглаженной сплайном, добавляется новая вершина.

Обрезка и удлинение в трехмерном пространстве

Любой 3D объект можно обрезать или удлинить до другого объекта, независимо от того, лежат ли они в одной плоскости с режущими или граничными кромками. Для выбора одной из трех проекций для обрезки или удлинения в командах ОБРЕЗАТЬ и УДЛИНИТЬ используйте параметры "Проект" и "Кромка":

  • Плоскость XY текущей ПСК
  • Плоскость текущего вида
  • Реальное 3D пространство, которое не является проекцией

См. также

Разрыв и соединение объектов


Обрезка и удлинение объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Обрезка и удлинение объектов
Понятия
Процедуры
Команды

Для удлинения объекта

Для обрезки объекта

Для удлинения объектов в 3D каркасных моделях

Для обрезки в 3D пространстве с проецированием на плоскость текущего вида

Для обрезки объектов в 3D каркасных моделях


Для удлинения объекта - Процедуры

Создание и редактирование объектов
Методы редактирования
Обрезка и удлинение объектов
Понятия
Процедуры
Команды

Для удлинения объекта

  1. Выберите в меню "Изменить" » "Удлинить".
  2. Выберите объекты, определяющие граничные кромки.

    3. Для выбора всех отображаемых объектов в качестве потенциальных граничных кромок нажмите ENTER, не выбирая объектов.

  3. Выберите удлиняемые объекты.

Панель "Редактирование"

Ввод команды: УДЛИНИТЬ


Для обрезки объекта - Процедуры

Создание и редактирование объектов
Методы редактирования
Обрезка и удлинение объектов
Понятия
Процедуры
Команды

Для обрезки объекта

  1. Выберите в меню "Изменить" » "Обрезать".
  2. Выберите объекты, определяющие режущие кромки.

    3. Для выбора всех отображаемых объектов в качестве потенциальных режущих кромок нажмите ENTER без указания объектов.

  3. Выберите обрезаемые объекты.

Панель "Редактирование"

Ввод команды: ОБРЕЗКА


Для удлинения объектов в 3D каркасных моделях - Процедуры

Создание и редактирование объектов
Методы редактирования
Обрезка и удлинение объектов
Понятия
Процедуры
Команды

Для удлинения объектов в 3D каркасных моделях

  1. Выберите в меню "Изменить" » "Удлинить".
  2. Выберите граничную кромку для удлинения (1).
  3. Введите к (Кромка).
  4. Введите с (С продолжением).
  5. Введите п (Проекция).
  6. Введите п (ПСК).
  7. Выберите удлиняемый объект (2).

Ввод команды: УДЛИНИТЬ


Для обрезки в 3D пространстве с проецированием на плоскость текущего вида - Процедуры

Создание и редактирование объектов
Методы редактирования
Обрезка и удлинение объектов
Понятия
Процедуры
Команды

Для обрезки в 3D пространстве с проецированием на плоскость текущего вида

  1. Выберите в меню "Изменить" » "Обрезать".
  2. Выберите режущую кромку (1).
  3. Введите п (Проекция).
  4. Введите в (Вид).
  5. Выберите обрезаемый объект (2).

Ввод команды: ОБРЕЗКА


Для обрезки объектов в 3D каркасных моделях - Процедуры

Создание и редактирование объектов
Методы редактирования
Обрезка и удлинение объектов
Понятия
Процедуры
Команды

Для обрезки объектов в 3D каркасных моделях

  1. Выберите в меню "Изменить" » "Обрезать".
  2. Выберите режущие кромки (1, 2).
  3. Введите п (Проекция).
  4. Введите н (Нет).
  5. Выберите обрезаемый объект (3, 4).

Ввод команды: ОБРЕЗКА


Обрезка и удлинение объектов - Команды

Методы редактирования
Методы редактирования
Обрезка и удлинение объектов
Понятия
Процедуры
Команды

Команды
ОБРЕЗАТЬ | Обрезка объекта по режущей кромке, заданной другими объектами
РАЗОРВАТЬ | Разрыв выбранного объекта между двумя точками
СВОЙСТВА | Изменяет свойства объекта
СОЕДИНИТЬ | Соединяет объекты для формирования одного целого объекта
УВЕЛИЧИТЬ | Изменение длин объектов и центральных углов дуг
УДЛИНИТЬ | Удлинение объектов до пересечения с другими объектами
Системные переменные
EDGEMODE | Управляет режимом определения режущих и граничных кромок для команд ОБРЕЗАТЬ и УДЛИНИТЬ.
PROJMODE | Устанавливает текущий режим проецирования для операций обрезки и удлинения
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение размеров и форм объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Изменение размеров и форм объектов
Понятия
Процедуры
Команды

Объекты можно изменять, увеличивая или уменьшая их размеры как в одном направлении, так и с сохранением пропорций.

Кроме того, некоторые объекты можно растягивать, перемещая их конечные точки, вершины или определяющие точки.

Изменение длин объектов

С помощью команды УВЕЛИЧИТЬ можно изменить внутренний угол дуг и длину следующих объектов.

  • Отрезки
  • Дуги
  • Разомкнутые полилинии
  • Эллиптические дуги
  • Разомкнутые сплайны.

В зависимости от ситуации операция изменения длины работает либо подобно удлинению, либо подобно обрезке. Пользователь может:

  • Динамическое перетаскивание конечной точки объекта
  • Укажите новую длину или угол в процентах к общей длине или углу
  • Укажите приращение длины или угла, откладываемого от конечной точки
  • Укажите полную абсолютную длину объекта или внутреннего угла
Растягивание объектов

С помощью команды РАСТЯНУТЬ переместите конечные точки объектов, которые пересекают рамку выбора или расположены внутри нее.

  • Объекты, которые частично находятся в секущей рамке, растягиваются.
  • Объекты, которые полностью включены в секущую рамку, или выделены отдельно, перемещаются, а не растягиваются.

Для растягивания объекта нужно указать базовую точку и точку перемещения.

Для точного растягивания использовать объектную привязку, привязку к ручкам и ввод относительных координат.

Масштабирование объектов с помощью масштабного коэффициента

С помощью команды МАСШТАБ можно увеличивать или уменьшать объект. Для масштабирования объекта нужно указать базовую точку и масштабный коэффициент. Можно также указать длину для использования в качестве масштабного коэффициента на основе текущих единиц чертежа.

Если масштабный коэффициент больше единицы, объект увеличивается, Значения в пределах от 0 до 1 уменьшают объект.

При масштабировании производится изменение размеров выбранного объекта во всех измерениях. Если масштабный коэффициент больше единицы, объект увеличивается, если меньше единицы уменьшается.

Масштабирование объектов с помощью опорного отрезка

Масштабирование можно также выполнять по длине опорного отрезка. При масштабировании с помощью опорного отрезка используется имеющееся расстояние как основа для нового размера. При этом задается длина опорного отрезка в текущем масштабе и его новая длина. Пусть например, одна из сторон объекта имеет 4.8 единицы в длину. Необходимо таким образом масштабировать объект, чтобы она увеличилась до 7.5 единиц. Длина 4.8 является опорной.

Масштабирование по опорной длине можно применять ко всему чертежу. Это может понадобиться, например, если были неверно заданы единицы чертежа. Для этого нужно выбрать в чертеже все объекты. Затем, задав опцию "Опорный отрезок", выберите две точки и укажите новое расстояние между ними. Все объекты чертежа масштабируются соответственно.

См. также

Разрыв и соединение объектов


Изменение размеров и форм объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Изменение размеров и форм объектов
Понятия
Процедуры
Команды

Для растягивания объекта

Для масштабирования объекта с заданным масштабным коэффициентом

Для масштабирования объекта по длине опорного отрезка

Для изменения длины отрезка перетаскиванием


Для растягивания объекта - Процедуры

Создание и редактирование объектов
Методы редактирования
Изменение размеров и форм объектов
Понятия
Процедуры
Команды

Для растягивания объекта

  1. Выберите в меню "Изменить" » "Растянуть".
  2. Выберите объект секущей рамкой.

    3. Секущая рамка должна захватывать по крайней мере одну вершину или определяющую точку объекта.

  3. Выполнить одно из следующих действий:
    • Введите значения относительных координат смещения в декартовой, полярной, цилиндрической или сферической системе координат. Не следует вводить знак @, так как уже предполагается ввод относительных координат. Нажмите ENTER на запрос второй точки перемещения.
    • Укажите базовую точку для растягивания указать вторую точку для определения расстояния и направления.

    Объекты, у которых хотя бы одна вершина или конечная точка расположена внутри секущей рамки, растягиваются. Объекты, полностью охваченные секущей рамкой или выбранные отдельно, перемещаются без растягивания.

Панель "Редактирование"

Ввод команды: РАСТЯНУТЬ


Для масштабирования объекта с заданным масштабным коэффициентом - Процедуры

Создание и редактирование объектов
Методы редактирования
Изменение размеров и форм объектов
Понятия
Процедуры
Команды

Для масштабирования объекта с заданным масштабным коэффициентом

  1. Выберите в меню "Изменить" » "Масштаб".
  2. Выберите объект для масштабирования.
  3. Укажите базовую точку.
  4. Введите значение масштабного коэффициента или перетащить объект и нажать кнопку мыши для задания нового масштаба.

Панель "Редактирование"

Ввод команды: МАСШТАБ


Для масштабирования объекта по длине опорного отрезка - Процедуры

Создание и редактирование объектов
Методы редактирования
Изменение размеров и форм объектов
Понятия
Процедуры
Команды

Для масштабирования объекта по длине опорного отрезка

  1. Выберите в меню "Изменить" » "Масштаб".
  2. Выберите объект для масштабирования.
  3. Укажите базовую точку.
  4. Выполнить одно из следующих действий:
  5. Укажите первую и вторую опорные точки или введите значение длины опорного отрезка.

Панель "Редактирование"

Ввод команды: МАСШТАБ


Для изменения длины отрезка перетаскиванием - Процедуры

Создание и редактирование объектов
Методы редактирования
Изменение размеров и форм объектов
Понятия
Процедуры
Команды

Для изменения длины отрезка перетаскиванием

  1. Выберите в меню "Изменить" » "Увеличить".
  2. Введите ди для вызова режима динамического перетаскивания.
  3. Выберите объект, длина которого изменяется.
  4. Задать перетаскиванием новое положение ближайшей к точке указания конечной точки.

    5. Выбранный объект увеличивается или уменьшается, сохраняя положение и ориентацию.

Ввод команды: УВЕЛИЧИТЬ


Изменение размеров и форм объектов - Команды

Методы редактирования
Методы редактирования
Изменение размеров и форм объектов
Понятия
Процедуры
Команды

Команды
МАСШТАБ | Пропорциональное увеличение/уменьшение размеров выбранных объектов в направлениях,и
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
РАСТЯНУТЬ | Перенос или растягивание объектов
РЕДСПЛАЙН | Редактирование сплайнов или сглаженных сплайнами полилиний
СВОЙСТВА | Изменяет свойства объекта
СОЕДИНИТЬ | Соединяет объекты для формирования одного целого объекта
УВЕЛИЧИТЬ | Изменение длин объектов и центральных углов дуг
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сопряжение, Фаска, Разорвать или Объединить объекты - Понятия

Создание и редактирование объектов
Методы редактирования
Сопряжение, Фаска, Разорвать или Объединить объекты
Понятия
Процедуры
Команды

Объекты чертежа можно соединять, сопрягая их в углах или строя фаски (скошенные линии). Кроме того, в объектах можно создавать или удалять разрывы.

  • Построение сопряжений
    С помощью сопряжения можно соединить два объекта, используя дугу, касательную к объектам, и которая имеет определенный радиус.
  • Снятие фасок
    Фаска соединяет два объекта для их пересечения в плоском или скошенном углу.
  • Разрыв и соединение объектов
    Можно разорвать и объединить два объекта с зазором или нет. Можно также создать один объект, объединив несколько.


Сопряжение, Фаска, Разорвать или Объединить объекты - Процедуры

Создание и редактирование объектов
Методы редактирования
Сопряжение, Фаска, Разорвать или Объединить объекты
Понятия
Процедуры
Команды

Задание радиуса сопряжения

Для сопряжения двух отрезков

Построение сопряжения без обрезки

Для построения сопряжений вдоль всей полилинии

Для сопряжения нескольких объектов

Для построения фаски по двум линейным размерам

Для соединения фаской двух непараллельных отрезков

Для построения фаски по линейному и угловому размерам

Для построения фаски без обрезки объектов

Для снятия фасок вдоль всей полилинии

Для соединения фаской нескольких объектов

Для разрывания объекта

Для соединения объектов


Сопряжение, Фаска, Разорвать или Объединить объекты - Команды

Создание и редактирование объектов
Методы редактирования
Сопряжение, Фаска, Разорвать или Объединить объекты
Понятия
Процедуры
Команды
Команды
РАЗОРВАТЬ | Разрыв выбранного объекта между двумя точками
СОЕДИНИТЬ | Соединяет объекты для формирования одного целого объекта
СОПРЯЖЕНИЕ | Скругление углов и сопряжение объектов
ФАСКА | Построение фасок в местах пересечения объектов
Системные переменные
CHAMFERA | Устанавливает первое расстояние фаски, когда значение CHAMMODE задано равным 0
CHAMFERB | Устанавливает второе расстояние фаски, когда значение CHAMMODE задано равным 0
CHAMFERC | Устанавливает длину фаски, когда значение CHAMMODE задано равным 1
CHAMFERD | Устанавливает угол фаски, когда значение CHAMMODE задано равным 1
CHAMMODE | Установка метода ввода для команды ФАСКА
FILLETRAD | Сохраняет значение текущего радиуса сопряжения
TRIMMODE | Управляет обрезкой выбранных кромок для фасок и сопряжений
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение сопряжений - Понятия

Создание и редактирование объектов
Методы редактирования
Построение сопряжений
Понятия
Процедуры
Команды

С помощью сопряжения можно соединить два объекта, используя дугу, касательную к объектам, и которая имеет определенный радиус.

Внутренний угол называется сопряжением, а внешний угол - округлением; можно создать оба угла с помощью команды СОПРЯЖЕНИЕ.

Сопрягать можно следующие объекты:

  • Дуги
  • Круги
  • Эллипсы и эллиптические дуги
  • Отрезки
  • Полилинии
  • Лучи
  • Сплайны
  • Прямые
  • 3D тела

Cкруглить все углы полилинии можно с помощью команды СОПРЯЖЕНИЕ.

Примечание Сопряжение границ штриховки, которое состоит из отрезков, ведет к потере ассоциативности. Если же граница штриховки задана полилинией, ассоциативность сохраняется.

Если оба соединяемых объекта лежат на одном слое, дуга сопряжения также проводится на том же слое. В противном случае, она строится на текущем слое. Слой определяет другие свойства объекта, включая цвет и тип линий.

С помощью опции "Несколько" можно осуществить сопряжение нескольких объектов, не выходя из команды.

Задание радиуса сопряжения

Радиусом сопряжения называется радиус дуги, соединяющей сопрягаемые объекты. Изменение радиуса действует только на выполняемые после этого сопряжения, оставляя неизменными существующие. Если радиус задать равным 0, то сопрягаемые объекты просто обрезаются или удлиняются до точки пересечения без построения дуги сопряжения.

При выборе объектов для замены значения текущего радиуса сопряжения на 0 можно удерживать нажатой клавишу SHIFT.

Обрезка и удлинение сопрягаемых объектов

Опцией "С обрезкой" можно выбрать режим сопряжения, при котором объекты либо обрезаются/удлиняются до точки пересечения с сопрягающей дугой, либо остаются без изменений.

Задание точек сопряжения

Возможных сопряжений может существовать несколько, и программа делает их выбор на основании положения точек указания. Сравните на чертежах расположения наборов объектов и полученных сопряжений.

Сопряжение отрезков с полилиниями

Для сопряжения линий с полилиниями каждая линия или ее продолжение должно пересечь один из линейных сегментов полилинии. Если включен режим "С обрезкой", сопряженные объекты и дуга сопряжения объединяются, образуя новую полилинию.

Сопряжение вдоль всей полилинии

Можно построить или отменить построение сопряжений вдоль всей полилинии.

При ненулевом радиусе сопряжения команда СОПРЯЖЕНИЕ проводит сопрягающие дуги у каждой из вершин, образованных пересечением линейных сегментов, если эти сегменты имеют достаточную для радиуса сопряжения длину.

Если два сходящихся линейных сегмента полилинии разделены дугой, команда СОПРЯЖЕНИЕ заменяет эту дугу сопрягающей дугой.

Если радиус сопряжения равен 0, то сопрягающие дуги не проводятся. Если при этом два линейных сегмента полилинии разделены одним дуговым сегментом, команда СОПРЯЖЕНИЕ удаляет дугу и удлиняет линейные сегменты до их пересечения.

Сопряжение параллельных линий

Имеется возможность сопряжения параллельных отрезков, прямых и лучей. Текущий радиус сопряжения временно регулируется для создания дуги, касательной к обоим объектам, и размещенной в плоскости, общей для обоих объектов.

Первый из выбранных объектов должен быть отрезком или лучом, а второй - отрезком, прямой или лучом. Сопрягающая дуга проводится, как показано на чертеже.

Объекты сопряжения с ненулевой высотой в 3D пространстве

В AutoCAD можно сопрягать любые объекты, расположенные в одной плоскости и имеющие направления выдавливания, не параллельные оси Z текущей ПСК. Команда СОПРЯЖЕНИЕ определяет направление выдавливания для сопрягающей дуги в 3D пространстве близкое к направлению оси Z текущей ПСК.


Построение сопряжений - Процедуры

Создание и редактирование объектов
Методы редактирования
Построение сопряжений
Понятия
Процедуры
Команды

Задание радиуса сопряжения

Для сопряжения двух отрезков

Построение сопряжения без обрезки

Для построения сопряжений вдоль всей полилинии

Для сопряжения нескольких объектов


Задание радиуса сопряжения - Процедуры

Создание и редактирование объектов
Методы редактирования
Построение сопряжений
Понятия
Процедуры
Команды

Задание радиуса сопряжения

  1. Выберите в меню "Изменить" » "Сопряжение".
  2. Введите д (раДиус).
  3. Введите радиус сопряжения.
  4. Выберите объекты для сопряжения.

Панель "Редактирование"

Ввод команды: СОПРЯЖЕНИЕ


Для сопряжения двух отрезков - Процедуры

Создание и редактирование объектов
Методы редактирования
Построение сопряжений
Понятия
Процедуры
Команды

Для сопряжения двух отрезков

  1. Выберите в меню "Изменить" » "Сопряжение".
  2. Выберите первый отрезок.
  3. Выберите второй отрезок.

Панель "Редактирование"

Ввод команды: СОПРЯЖЕНИЕ


Построение сопряжения без обрезки - Процедуры

Создание и редактирование объектов
Методы редактирования
Построение сопряжений
Понятия
Процедуры
Команды

Построение сопряжения без обрезки

  1. Выберите в меню "Изменить" » "Сопряжение".
  2. Если необходимо, введите t (Обрезать). Введитеб (Без обрезки).
  3. Выберите объекты для сопряжения.

Панель "Редактирование"

Ввод команды: СОПРЯЖЕНИЕ


Для построения сопряжений вдоль всей полилинии - Процедуры

Создание и редактирование объектов
Методы редактирования
Построение сопряжений
Понятия
Процедуры
Команды

Для построения сопряжений вдоль всей полилинии

  1. Выберите в меню "Изменить" » "Сопряжение".
  2. Введите д (раДиус).
  3. Выберите полилинию.

Панель "Редактирование"

Ввод команды: СОПРЯЖЕНИЕ


Для сопряжения нескольких объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Построение сопряжений
Понятия
Процедуры
Команды

Для сопряжения нескольких объектов

  1. Выберите в меню "Изменить" » "Сопряжение".
  2. Укажите базовую точку.

    3. В командной строке отображается стандартное приглашение команды.

  3. Выберите первую линию или задать параметр и завершить выполнение команд запросов для этого параметра. Выберите первый отрезок.
  4. Выберите второй отрезок.

    5. В командной строке вновь отображается стандартное приглашение команды.

  5. Выберите первый отрезок для построения следующего сопряжения, либо нажмите ENTER или ESC для завершения команды.

Панель "Редактирование"

Ввод команды: СОПРЯЖЕНИЕ


Построение сопряжений - Команды

Методы редактирования
Методы редактирования
Построение сопряжений
Понятия
Процедуры
Команды

Команды
СОПРЯЖЕНИЕ | Скругление углов и сопряжение объектов
Системные переменные
FILLETRAD | Сохраняет значение текущего радиуса сопряжения
TRIMMODE | Управляет обрезкой выбранных кромок для фасок и сопряжений
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Снятие фасок - Понятия

Создание и редактирование объектов
Методы редактирования
Снятие фасок
Понятия
Процедуры
Команды

Фаска соединяет два объекта с помощью изогнутой линии. Обычно таким образом создаются скошенные углы.

Можно снять фаску

  • Отрезки
  • Полилинии
  • Лучи
  • Прямые
  • 3D тела

Команду ФАСКА можно использовать для скашивания углов полилинии с помощью одной команды.

Примечание Снятие фаски с границ штриховки, которая состоит из отрезков, ведет к потере ассоциативности. Если же граница штриховки задана полилинией, ассоциативность сохраняется.

Если оба соединяемых объекта лежат на одном слое, линия фаски также проводится на том же слое. В противном случае, она строится на текущем слое. Слой определяет другие свойства объекта, включая цвет и тип линий.

С помощью опции "Несколько" можно соединить фаской нескольких объектов, не выходя из команды.

Задание фасок двумя линейными размерами

Длиной фаски называется расстояние между точкой реального или воображаемого пересечения объектов и точкой, до которой удлиняется или обрезается объект при снятии фаски. Если обе длины фаски равны 0, то объекты обрезаются или удлиняются до точки их пересечения, а линия фаски не строится. Можно удерживать нажатой клавишу SHIFT при выборе объектов для замены значения текущих расстояний фаски на 0.

Приводится пример задания длины первой фаски 0,5, а второй фаски 0,25. После указания длин фасок выбираются два отрезка.

Обрезка и удлинение соединяемых фаской объектов

По умолчанию соединяемые фаской объекты обрезаются. Обрезку можно отменить с помощью опции "Обрезка".

Построение фаски по линейному и угловому размерам

Для построения фаски можно задать точку пересечения фаски с первым выбранным объектом и угла, образуемого линией фаски с этим объектом.

В следующем примере два отрезка соединяются фаской. Фаска начинается на первом отрезке на расстоянии 1.5 единицы от точки пересечения отрезков и образует с ним угол 30 градусов.

Построение фасок для полилиний и их сегментов

Для снятия фасок можно выбирать сегменты одной полилинии. Они должны быть либо смежными, либо разделенными одним дуговым сегментом. Если между заданными сегментами имеется дуговой сегмент, как это показано на чертеже, то этот дуговой сегмент удаляется и заменяется линией фаски.

Снятие фасок вдоль всей полилинии

Имеется возможность снять фаски вдоль всей полилинии, то есть построить их в каждом пересечении ее сегментов. При этом рекомендуется задавать одинаковые значения для обеих длин фаски.

В следующем примере оба линейных размера каждой фаски равны между собой.

При снятии фасок вдоль всей полилинии, обрабатываются только те сегменты, длины которых превосходят длину фаски. На следующем чертеже изображена полилиния, некоторые из сегментов которой оказались слишком малы для снятия фасок.


Снятие фасок - Процедуры

Создание и редактирование объектов
Методы редактирования
Снятие фасок
Понятия
Процедуры
Команды

Для построения фаски по двум линейным размерам

Для соединения фаской двух непараллельных отрезков

Для построения фаски по линейному и угловому размерам

Для построения фаски без обрезки объектов

Для снятия фасок вдоль всей полилинии

Для соединения фаской нескольких объектов


Для построения фаски по двум линейным размерам - Процедуры

Создание и редактирование объектов
Методы редактирования
Снятие фасок
Понятия
Процедуры
Команды

Для построения фаски по двум линейным размерам

  1. Выберите в меню "Изменить" » "Фаска".
  2. Введите д (Длина).
  3. Задать первую длину фаски.
  4. Задать вторую длину фаски.
  5. Выберите соединяемые фаской отрезки.

Панель "Редактирование"

Ввод команды: ФАСКА


Для соединения фаской двух непараллельных отрезков - Процедуры

Создание и редактирование объектов
Методы редактирования
Снятие фасок
Понятия
Процедуры
Команды

Для соединения фаской двух непараллельных отрезков

  1. Выберите в меню "Изменить" » "Фаска".
  2. Выберите первый отрезок.
  3. Выберите второй отрезок.

Панель "Редактирование"

Ввод команды: ФАСКА


Для построения фаски по линейному и угловому размерам - Процедуры

Создание и редактирование объектов
Методы редактирования
Снятие фасок
Понятия
Процедуры
Команды

Для построения фаски по линейному и угловому размерам

  1. Выберите в меню "Изменить" » "Фаска".
  2. Выберите первый отрезок.
  3. Введите длину фаски от угла соединения вдоль первого отрезка.
  4. Введите угол фаски.
  5. Выберите первый отрезок. Затем выберите второй отрезок.

Панель "Редактирование"

Ввод команды: ФАСКА


Для построения фаски без обрезки объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Снятие фасок
Понятия
Процедуры
Команды

Для построения фаски без обрезки объектов

  1. Выберите в меню "Изменить" » "Фаска".
  2. Введите t (Управление обрезкой).
  3. Введите n (Без обрезки)
  4. Выберите соединяемые объекты.

Панель "Редактирование"

Ввод команды: ФАСКА


Для снятия фасок вдоль всей полилинии - Процедуры

Создание и редактирование объектов
Методы редактирования
Снятие фасок
Понятия
Процедуры
Команды

Для снятия фасок вдоль всей полилинии

  1. Выберите в меню "Изменить" » "Фаска".
  2. Введите п (Полилиния).
  3. Выберите полилинию.

    4. Вдоль всей полилинии происходит снятие фасок установленным текущим способом и с размерами, заданными по умолчанию.

Панель "Редактирование"

Ввод команды: ФАСКА


Для соединения фаской нескольких объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Снятие фасок
Понятия
Процедуры
Команды

Для соединения фаской нескольких объектов

  1. Выберите в меню "Изменить" » "Фаска".
  2. Введите m (Несколько).

    3. В командной строке отображается стандартное приглашение команды.

  3. Выберите первый объект, или сначала задать необходимые опции, а затем выберите первый объект.
  4. Выберите второй отрезок.

    5. В командной строке вновь отображается стандартное приглашение команды.

  5. Выберите первый отрезок для построения следующей фаски, либо нажмите ENTER или ESC для завершения команды.

Панель "Редактирование"

Ввод команды: ФАСКА


Снятие фасок - Команды

Методы редактирования
Методы редактирования
Снятие фасок
Понятия
Процедуры
Команды

Команды
ФАСКА | Построение фасок в местах пересечения объектов
Системные переменные
CHAMFERA | Устанавливает первое расстояние фаски, когда значение CHAMMODE задано равным 0
CHAMFERB | Устанавливает второе расстояние фаски, когда значение CHAMMODE задано равным 0
CHAMFERC | Устанавливает длину фаски, когда значение CHAMMODE задано равным 1
CHAMFERD | Устанавливает угол фаски, когда значение CHAMMODE задано равным 1
CHAMMODE | Установка метода ввода для команды ФАСКА
TRIMMODE | Управляет обрезкой выбранных кромок для фасок и сопряжений
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Разрыв и соединение объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Разрыв и соединение объектов
Понятия
Процедуры
Команды

Можно разорвать и объединить два объекта с зазором или нет. Можно также создать один объект, объединив несколько.

Разрыв объектов

Используйте команду РАЗОРВАТЬ, чтобы создать зазор в объекте для образования двух объектов с зазором. Команда РАЗОРВАТЬ часто используется для создания пространства для вставки блока или текста.

Для разрыва объекта без создания зазора указать обе точки разрыва в одном местоположении. Это можно сделать быстро, если ввести @0,0 на запрос второй точки.

Можно создать разрывы в большинстве геометрических тел кроме

  • Блоки
  • Размеры
  • Мультилинии
  • Области
Соединение объектов

Используйте команду СОЕДИНИТЬ для объединения похожих объектов в один. Можно также создать замкнутые круги и эллипсы из дуг и эллиптических дуг. Можно соединять объекты

  • Дуги
  • Эллиптические дуги
  • Отрезки
  • Полилинии
  • Сплайны

Объект, к которому необходимо присоединить подобные объекты, называется исходным объектом. Объекты, которые необходимо присоединить, должны находиться в одной плоскости. Дополнительные ограничения для каждого типа объектов описаны в команде СОЕДИНИТЬ.

Примечание При объединении двух или более дуг (или эллиптических дуг) их объединение начинается с исходной эллиптической дуги в направлении против часовой стрелки.

См. также

Редактирование и объединение полилиний

Редактирование сложных объектов


Разрыв и соединение объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Разрыв и соединение объектов
Понятия
Процедуры
Команды

Для разрывания объекта

Для соединения объектов


Для разрывания объекта - Процедуры

Создание и редактирование объектов
Методы редактирования
Разрыв и соединение объектов
Понятия
Процедуры
Команды

Для разрывания объекта

  1. Выберите в меню "Изменить" » "Разорвать".
  2. Выберите разрываемый объект.

    3. По умолчанию точка указания объекта считается первой точкой разрыва. Чтобы выбрать в качестве первой точки разрыва другую точку, следует ввести п(Первая) и указать новую точку.

  3. Укажите вторую точку разрыва.

    4. Для разрыва объекта без создания зазора введите @0,0 для указания предыдущей точки.

Панель "Редактирование"

Ввод команды: РАЗОРВАТЬ


Для соединения объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Разрыв и соединение объектов
Понятия
Процедуры
Команды

Для соединения объектов

  1. Выберите в меню "Изменить" » "Соединить".
  2. Выберите исходный объект, к которому необходимо присоединить объекты.
  3. Выберите один или несколько объектов для присоединения к исходному объекту.

    4. Доступные объекты включают арки, эллиптические арки, линии, полилинии и сплайны. Дополнительные ограничения для каждого типа объектов описаны в команде СОЕДИНИТЬ.

Панель "Редактирование"

Ввод команды: СОЕДИНИТЬ


Разрыв и соединение объектов - Команды

Методы редактирования
Методы редактирования
Разрыв и соединение объектов
Понятия
Процедуры
Команды

Команды
РАЗОРВАТЬ | Разрыв выбранного объекта между двумя точками
СОЕДИНИТЬ | Соединяет объекты для формирования одного целого объекта
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование с помощью ручек - Понятия

Создание и редактирование объектов
Методы редактирования
Редактирование с помощью ручек
Понятия
Процедуры
Команды

Ручки имеют вид квадратных меток и находятся в характерных точках выбранных объектов. Перетаскивая эти ручки, можно быстро и наглядно редактировать объекты.

  • Использование режимов ручек
    Перетаскиванием ручек можно выполнять растягивание, перемещение, поворот, масштабирование и зеркальное отображение объектов. Выбранная операция редактирования называется режимом ручек.
  • Многократное копирование с помощью ручек
    С помощью ручек, кроме операций редактирования, можно также выполнять многократное копирование объектов.
  • Управление ручками в блоках
    По желанию пользователя вставленный блок может иметь как одну ручку, так и набор ручек.


Редактирование с помощью ручек - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование с помощью ручек
Понятия
Процедуры
Команды

Для включения ручек

Для установки цвета ручек под курсором

Для задания предельного количества выбранных объектов для показа ручек

Для отображения подсказок к ручкам в пользовательских объектах, поддерживающих подсказки к ручкам

Для отмены выделения ручками

Для растягивания объекта с помощью ручек

Для растягивания с помощью нескольких ручек

Для перемещения объекта с помощью ручек

Для поворота объекта с помощью ручек

Для масштабирования объектов с помощью ручек

Для зеркального отображения объектов с помощью ручек

Для многократного копирования в любом режиме ручек

Для задания шага смещения при многократном копировании

Для задания шага поворота при многократном копировании

Для зеркального отображения объектов с помощью ручек и с сохранением оригиналов

Для включения и отключения ручек в блоках


Редактирование с помощью ручек - Команды

Создание и редактирование объектов
Методы редактирования
Редактирование с помощью ручек
Понятия
Процедуры
Команды
Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
GRIPBLOCK | Управляет ручками внутри блоков
GRIPCOLOR | Управляет цветом невыбранных ручек
GRIPHOT | Управляет цветом выбранных ручек
GRIPHOVER | Управляет цветом заполнения невыбранной ручки, когда курсор останавливается над ней
GRIPOBJLIMIT | Подавляет ручки, если исходный набор содержит больше объектов, чем задано
GRIPS | Управляет использованием набора ручек при растягивании, перемещении, повороте, масштабировании и зеркальном отображении объектов
GRIPSIZE | Устанавливает размер квадрата, изображающего ручку (в пикселах)
GRIPTIPS | Управляет подсказками для ручки при наведении курсора на ручку пользовательского объекта, поддерживающего подсказки к ручкам
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование режимов ручек - Понятия

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Перетаскиванием ручек можно выполнять растягивание, перемещение, поворот, масштабирование и зеркальное отображение объектов. Выбранная операция редактирования называется режимом ручек.

Ручки имеют вид квадратных меток и находятся в характерных точках выбранных объектов. Перетаскивая их, можно выполнять растягивание, перемещение, поворот, масштабирование и зеркальное отображение объектов.

В режиме включенных ручек выбор объектов производится до ввода команды, после чего пользователь может манипулировать объектом с помощью устройства указания.

Для использования режима ручки выберите ручку (базовую ручку) с целью действий в базовой точке для операций. (Выбранная ручка называется также"горячей"). После этого выбирается один из режимов ручек. Циклическое переключение этих режимов производится последовательным нажатием клавиш ENTER или ПРОБЕЛ. Нужный режим можно включить с помощью комбинации быстрого вызова или из контекстного меню.

В качестве базовых точкек для операции можно использовать несколько ручек. Когда выбрано несколько ручек (что носит также название "выбор нескольких наиболее часто используемых ручек"), форма объекта между выбранными ручками остается неизменной. Чтобы выбрать несколько ручек, удерживайте SHIFT нажатой и выберите дополнительные ручки.

Для ручек, расположенных на кругах и эллипсах, расстояния отмеряются от точки центра, а не от выбранной ручки. Например, для того чтобы растянуть круг, можно выбрать ручку, а затем ввести новое значение радиуса в командной строке. Новое значение радиуса отмеряется от центра круга, а не от выбранной ручки. Если выбрать ручку, расположенную в центре круга, то круг можно перемещать.

Растягивание двумерного объекта, расположенного на плоскости, отличной от текущей ПСК, происходит именно в плоскости, где он был создан.

Отображение ручек на выбранных объектах является настраиваемым. Режим подавления ручек в случае, если исходный набор содержит больше объектов, чем задано, устанавливается системной переменной GRIPOBJLIMIT. При добавлении объектов к исходному набору ограничение не действует. Например, если значение переменной GRIPOBJLIMIT равно 20, то пользователь может выбрать 15 объектов, затем добавить в исходный набор 25 объектов, и на всех объектах будут отображаться ручки.

Растягивание с помощью ручек

Объект можно растянуть перетаскиванием его ручек. Но если перетаскивать ручки, расположенные на текстовых объектах, в точках вхождений блоков, на серединах отрезков, в центрах кругов и на объектах-точках, то вместо растягивания происходит перемещение всего объекта. Таким образом, ручки позволяют легко перемещать вхождения блоков и изменять размеры объектов.

Перемещение с помощью ручек

С помощью ручек можно перемещать объекты. При задании направления и расстояния указанием точки выбранные объекты, выделенные подсветкой, перемещаются на новое место.

Поворот с помощью ручек

Выбранные объекты можно поворачивать вокруг базовой точки путем указания точки и перетаскивания ручки. Кроме того, можно ввести значение угла. Этим способом можно поворачивать и вхождения блоков.

Масштабирование с помощью ручек

Выбранные объекты можно масштабировать относительно базовой точки. Для увеличения объекта следует перетаскивать курсор от базовой ручки, а для уменьшения - к базовой ручке. Можно также ввести значение относительного масштабного коэффициента.

Зеркальное отображение с помощью ручек

Выбранные объекты можно зеркально отображать относительно временной оси отражения. Для задания вертикальной или горизонтальной оси отражения можно воспользоваться режимом "Орто".

См. также

Использование динамического ввода

Работа с динамическими блоками в чертежах


Использование режимов ручек - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Для включения ручек

Для установки цвета ручек под курсором

Для задания предельного количества выбранных объектов для показа ручек

Для отображения подсказок к ручкам в пользовательских объектах, поддерживающих подсказки к ручкам

Для отмены выделения ручками

Для растягивания объекта с помощью ручек

Для растягивания с помощью нескольких ручек

Для перемещения объекта с помощью ручек

Для поворота объекта с помощью ручек

Для масштабирования объектов с помощью ручек

Для зеркального отображения объектов с помощью ручек


Для включения ручек - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Для включения ручек

  1. В меню "Сервис" выберите "Настройка".
  2. На вкладке "Выбор" диалогового окна "Настройка" установите флажок "Включить ручки".
  3. Нажмите "ОК".

Ввод команды: НАСТРОЙКА


Для установки цвета ручек под курсором - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Для установки цвета ручек под курсором

  1. Выберите в меню "Сервис" » "Настройка".
  2. На вкладке "Выбор" диалогового окна "Настройка" нажать на стрелку рядом с полем "Цвет ручки под курсором".
  3. Выберите один из стандартных цветов, или воспользоваться элементом "Выбор цвета" для вызова диалогового окна выбора цвета.


Для задания предельного количества выбранных объектов для показа ручек - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Для задания предельного количества выбранных объектов для показа ручек

  1. Выберите в меню "Сервис" » "Настройка".
  2. На вкладке "Выбор" диалогового окна "Настройка" введите требуемое значение в поле "Предельное количество выбранных объектов для показа ручек". Максимальное возможное значение составляет 32767.

    3. При добавлении объектов к исходному набору ограничение не действует.


Для отображения подсказок к ручкам в пользовательских объектах, поддерживающих подсказки к ручкам - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Для отображения подсказок к ручкам в пользовательских объектах, поддерживающих подсказки к ручкам

  1. Выберите в меню "Сервис" » "Настройка".
  2. На вкладке "Выбор" диалогового окна "Настройка" выберите "Подсказки к ручкам".


Для отмены выделения ручками - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Для отмены выделения ручками

  • Нажмите ESC.


Для растягивания объекта с помощью ручек - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Для растягивания объекта с помощью ручек

  1. Выберите объект для растягивания.
  2. Выберите базовую ручку на объекте.

    3. Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Переместите устройство указания и нажмите кнопку мыши.

    4. Выбранный объект растягивается с учетом нового положения ручки.

Примечание Для копирования выбранного объекта во время выполнения операции растяжения нажмите и удерживайте клавишу CTRL.


Для растягивания с помощью нескольких ручек - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Для растягивания с помощью нескольких ручек

  1. Выберите несколько объектов для растягивания.
  2. Удерживая нажатой клавишу SHIFT, выберите несколько ручек; выбранные ручки выделяются цветом.
  3. Отпустите клавишу SHIFT и нажатием кнопки мыши выберите ручку для использования в качестве базовой.

    4. Включается режим "Растягивание", выбранный по умолчанию.

  4. Переместить устройство указания и нажмите кнопку мыши.

    5. Выбранные ручки перемещаются одновременно. Заданные объекты растягиваются.


Для перемещения объекта с помощью ручек - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Для перемещения объекта с помощью ручек

  1. Выберите объекты для перемещения.
  2. Выберите базовую ручку на объекте.

    3. Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Перемещение".

    4. Нужный режим можно также выбрать из контекстного меню.

  4. Переместить устройство указания и нажать кнопку мыши.

    5. Выбранные объекты перемещаются, следуя за ручкой.

Примечание Для копирования выбранного объекта во время выполнения операции перемещения нажмите и удерживайте клавишу CTRL.


Для поворота объекта с помощью ручек - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Для поворота объекта с помощью ручек

  1. Выберите поворачиваемые объекты.
  2. Выберите базовую ручку на объекте с помощью нажатия кнопки мыши.

    3. Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Поворот".

    4. Нужный режим можно также выбрать из контекстного меню.

  4. Переместить устройство указания и нажмите кнопку мыши.

    5. Выбранные объекты поворачиваются вокруг базовой ручки.

Примечание Для копирования выбранного объекта во время выполнения операции поворота нажмите и удерживайте клавишу CTRL.


Для масштабирования объектов с помощью ручек - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Для масштабирования объектов с помощью ручек

  1. Выберите объекты для масштабирования.
  2. Выберите базовую ручку на объекте.

    3. Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Масштаб".

    4. Нужный режим можно также выбрать из контекстного меню.

  4. Введите значение масштабного коэффициента или перетащите объект и нажмите кнопку мыши для задания нового масштаба.

Примечание Для копирования выбранного объекта во время выполнения операции масштабирования нажмите и удерживайте клавишу CTRL.


Для зеркального отображения объектов с помощью ручек - Процедуры

Создание и редактирование объектов
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Для зеркального отображения объектов с помощью ручек

  1. Выберите отображаемые объекты.
  2. Выберите мышью базовую ручку на объекте.

    3. Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Зеркало".

    4. Нужный режим можно также выбрать из контекстного меню.

  4. Укажите вторую точку для определения оси отражения.

    5. Для зеркального отображения объектов иногда удобно использовать режим "Орто".


Использование режимов ручек - Команды

Методы редактирования
Методы редактирования
Использование режимов ручек
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
GRIPBLOCK | Управляет ручками внутри блоков
GRIPCOLOR | Управляет цветом невыбранных ручек
GRIPHOT | Управляет цветом выбранных ручек
GRIPHOVER | Управляет цветом заполнения невыбранной ручки, когда курсор останавливается над ней
GRIPOBJLIMIT | Подавляет ручки, если исходный набор содержит больше объектов, чем задано
GRIPS | Управляет использованием набора ручек при растягивании, перемещении, повороте, масштабировании и зеркальном отображении объектов
GRIPSIZE | Устанавливает размер квадрата, изображающего ручку (в пикселах)
GRIPTIPS | Управляет подсказками для ручки при наведении курсора на ручку пользовательского объекта, поддерживающего подсказки к ручкам
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Многократное копирование с помощью ручек - Понятия

Создание и редактирование объектов
Методы редактирования
Многократное копирование с помощью ручек
Понятия
Процедуры
Команды

С помощью ручек, кроме операций редактирования, можно также выполнять многократное копирование объектов.

Так, например, используя опцию "Копировать", можно поворачивать выбранные объекты, создавая их копии в каждой указываемом положении.

Кроме того, режим многократного копирования активизируется нажатием клавиши CTRL в процессе указания первого нового положения для объекта. Так в режиме "Растянуть" функция многократного копирования растягивает объект, например, отрезок, и копирует его в любую точку графической области, указанную пользователем. Множественное копирование будет продолжаться, пока не выключить ручки.

Задание шага смещения и шага поворота

Многократное копирование можно производить, размещая копии с заданным шагом смещения. Этот шаг определяется расстоянием между объектом и его следующей копией. В следующем примере размещаются источники освещения. Первая копия осветительного прибора создается со смещением в две единицы. Все последующие копии также размещаются на расстоянии в две единицы от предыдущих.

Если при выборе нескольких точек копирования с помощью указывающего устройства удерживать нажатой клавишу CTRL, графический курсор будет привязан к точке смещения, созданной на основе двух последних выбранных точек. В приведенной ниже иллюстрации координаты середины отрезка 1 - 8,5. На основе этой серединной точки отрезок 2 был скопирован с помощью клавиши CTRL и режима ручек "Растянуть"; координаты середины этого отрезка - 9,5. Третий отрезок будет привязан к точке смещения, созданной на основе значений координат 10,5.

При повороте объекта вокруг базовой ручки можно также размещать копии с заданным угловым интервалом. Шаг поворота определяется углом между объектом и его следующей копией, создаваемой в режиме ручек "Поворот". Для использования шага поворота нажмите и удерживайте клавишу CTRL.


Многократное копирование с помощью ручек - Процедуры

Создание и редактирование объектов
Методы редактирования
Многократное копирование с помощью ручек
Понятия
Процедуры
Команды

Для многократного копирования в любом режиме ручек

Для задания шага смещения при многократном копировании

Для задания шага поворота при многократном копировании

Для зеркального отображения объектов с помощью ручек и с сохранением оригиналов


Для многократного копирования в любом режиме ручек - Процедуры

Создание и редактирование объектов
Методы редактирования
Многократное копирование с помощью ручек
Понятия
Процедуры
Команды

Для многократного копирования в любом режиме ручек

  1. Выберите копируемые объекты.
  2. Выберите базовую ручку на объекте.

    3. Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите требуемый режим.

    4. Нужный режим можно также выбрать из контекстного меню.

  4. Введите к (Копировать) или нажмите и удерживайте клавишу CTRL при растягивании, перемещении, повороте или масштабировании.

    5. Копирование будет продолжаться, пока не выключены ручки.

  5. Введите или укажите дополнительные параметры для выполнения операции в текущем режиме ручек.
  6. Выключите ручки нажатием клавиши ENTER, ПРОБЕЛ или ESC.


Для задания шага смещения при многократном копировании - Процедуры

Создание и редактирование объектов
Методы редактирования
Многократное копирование с помощью ручек
Понятия
Процедуры
Команды

Для задания шага смещения при многократном копировании

  1. Выберите копируемые объекты.
  2. Выберите базовую ручку на объекте.

    3. Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Перемещение".

    4. Нужный режим можно также выбрать из контекстного меню.

  4. Введите к (Копировать).
  5. Переместите курсор и нажмите кнопку мыши.

    6. Шаг смещения определяется расстоянием между выбранной ручкой и точкой, указанной для копирования.

  6. Удерживая в нажатой клавишу CTRL, разместите дополнительные копии, для чего укажите дополнительные положения.

    7. Копии объектов размещаются с равным интервалом, определяемым при последнем копировании.

  7. Выключите ручки нажатием клавиши ENTER, ПРОБЕЛ или ESC.


Для задания шага поворота при многократном копировании - Процедуры

Создание и редактирование объектов
Методы редактирования
Многократное копирование с помощью ручек
Понятия
Процедуры
Команды

Для задания шага поворота при многократном копировании

  1. Выберите поворачиваемые объекты.
  2. Выберите базовую ручку на объекте.

    3. Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Поворот".

    4. Нужный режим можно также выбрать из контекстного меню.

  4. Введите к (Копировать).
  5. Переместите устройство указания и нажмите кнопку мыши.

    6. Шаг поворота определяется углом между выбранной ручкой и точкой, указанной для копирования.

  6. Удерживая в нажатом состоянии клавишу CTRL, укажите следующие положения для копирования объектов.

    7. Копии объектов создаются путем поворота предыдущей копии на угол, определяемый при повороте первой копии.

  7. Выключите ручки нажатием клавиши ENTER, ПРОБЕЛ или ESC.


Для зеркального отображения объектов с помощью ручек и с сохранением оригиналов - Процедуры

Создание и редактирование объектов
Методы редактирования
Многократное копирование с помощью ручек
Понятия
Процедуры
Команды

Для зеркального отображения объектов с помощью ручек и с сохранением оригиналов

  1. Выберите отображаемые объекты.
  2. Выберите базовую ручку на объекте.

    3. Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Зеркало".

    4. Нужный режим можно также выбрать из контекстного меню.

  4. Нажмите и удерживайте клавишу CTRL(или введите к (Копировать)), чтобы запомнить исходное изображение и указать вторую точку оси отражения.

    5. Для зеркального отображения объектов иногда удобно использовать режим "Орто".

  5. Выключите ручки нажатием клавиши ENTER, ПРОБЕЛ или ESC.


Многократное копирование с помощью ручек - Команды

Методы редактирования
Методы редактирования
Многократное копирование с помощью ручек
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
GRIPBLOCK | Управляет ручками внутри блоков
GRIPCOLOR | Управляет цветом невыбранных ручек
GRIPHOT | Управляет цветом выбранных ручек
GRIPS | Управляет использованием набора ручек при растягивании, перемещении, повороте, масштабировании и зеркальном отображении объектов
GRIPSIZE | Устанавливает размер квадрата, изображающего ручку (в пикселах)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление ручками в блоках - Понятия

Создание и редактирование объектов
Методы редактирования
Управление ручками в блоках
Понятия
Процедуры
Команды

По желанию пользователя вставленный блок может иметь как одну ручку, так и набор ручек.

По желанию пользователя вставленный блок может иметь как одну ручку в точке вставки, так и набор ручек для каждого отдельного объекта внутри блока.

См. также

Указание ручек для динамических блоков


Для включения и отключения ручек в блоках - Процедуры

Создание и редактирование объектов
Методы редактирования
Управление ручками в блоках
Понятия
Процедуры
Команды

Для включения и отключения ручек в блоках

  1. Выберите в меню "Сервис" » "Настройка".
  2. На вкладке "Выбор" диалогового окна "Настройка" установите или сбросьте флажок "Ручки внутри блоков".
  3. Нажмите "ОК".

Ввод команды: НАСТРОЙКА


Управление ручками в блоках - Команды

Методы редактирования
Методы редактирования
Управление ручками в блоках
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
GRIPBLOCK | Управляет ручками внутри блоков
GRIPCOLOR | Управляет цветом невыбранных ручек
GRIPHOT | Управляет цветом выбранных ручек
GRIPS | Управляет использованием набора ручек при растягивании, перемещении, повороте, масштабировании и зеркальном отображении объектов
GRIPSIZE | Устанавливает размер квадрата, изображающего ручку (в пикселах)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование сложных объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Редактирование сложных объектов
Понятия
Процедуры
Команды

Для таких сложных объектов, как блоки, размеры, штриховки и полилинии, предусмотрены дополнительные операции редактирования.

  • Расчленение составных объектов
    Составные объекты, такие как полилинии, размеры, штриховки и вхождения блоков, можно расчленять на отдельные составляющие элементы.
  • Редактирование и объединение полилиний
    Для изменения формы полилиний, кроме общих операций редактирования, предусмотрены также дополнительные операции. Кроме того, можно объединять отдельные полилинии в одну.
  • Редактирование сплайнов
    Для изменения форм сплайнов, кроме общих операций редактирования, предусмотрены также дополнительные опции.
  • Изменение спиралей
    Для изменения зформы и размера спирали можно использовать как ручки, так и палитру "Свойства".
  • Редактирование мультилиний
    Многострочные объекты состоят из параллельных линий (от 1 до 16), называемых элементами. Для изменения мультилиний можно использовать обычные команды редактирования, команду редактирования мультилинии и стили мультилинии.

См. также

Создание 3D моделей

Редактирование блоков

Редактирование штриховки и заливки

Редактирование текста

Редактирование размеров

Обновление полей

Создание и редактирование таблиц

Редактирование растровых изображений и их контуров


Редактирование сложных объектов - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование сложных объектов
Понятия
Процедуры
Команды

Для расчленения объекта

Для редактирования полилинии

Объединение полилиний, линий и дуг в одну полилинию

Удаление вершины в полилинии

Для сужения ширины отдельных сегментов

Для редактирования сплайна

Для удаления вершины мультилинии

Для задания закрытого крестообразного типа пересечения

Редактирование стиля мультилинии


Редактирование сложных объектов - Команды

Создание и редактирование объектов
Методы редактирования
Редактирование сложных объектов
Понятия
Процедуры
Команды
Команды
МЛРЕД | Редактирует пересечения мультилиний, разрывы и вершины
МЛСТИЛЬ | Создает, изменяет и управляет стилями мультилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
РЕДСПЛАЙН | Редактирование сплайнов или сглаженных сплайнами полилиний
СОЕДИНИТЬ | Соединяет объекты для формирования одного целого объекта
СПИРАЛЬ | Создание 2D или 3D винтовой линии
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
EXPLMODE | Управляет обработкой блоков с разными масштабами вставки в команде РАСЧЛЕНИТЬ
PEDITACCEPT | Подавляет отображение подсказки "Выбранный объект не является полилинией" команды ПОЛРЕД
SPLFRAME | Управляет отображением сплайнов и сглаженных сплайнами полилиний
SPLINESEGS | Задает количество сегментов линии, генерируемых для каждой сглаженной сплайном полилинии, созданной с помощью параметра "Сплайн" команды ПОЛРЕД
SPLINETYPE | Задает тип кривой, создаваемой с помощью параметра "Сплайн" команды ПОЛРЕД
SURFTYPE | Управляет типом поверхности сглаживания, которая используется командой ПОЛРЕД (параметр "Сплайн")
SURFU | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности
SURFV | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Расчленение составных объектов - Понятия

Создание и редактирование объектов
Методы редактирования
Расчленение составных объектов
Понятия
Процедуры
Команды

Составные объекты, такие как полилинии, размеры, штриховки и вхождения блоков, можно расчленять на отдельные составляющие элементы. Например, расчленение полилинии приводит к ее разрыванию на простые отрезки и дуги. Вхождения блоков и ассоциативные размеры после расчленения преобразуются в наборы простых объектов.

Расчленение размеров и штриховок

При расчленении размеров и штриховок теряется ассоциативная связь между элементами, что приводит к образованию набора простых объектов, таких как отрезки, тексты, точки и 2D фигуры. Для автоматического расчленения размеров во время их создания задайте для системной переменной DIMASSOC значение 0.

Расчленение полилиний

При расчленении полилинии теряется информацию о ее ширине. Результирующие отрезки и дуги располагаются вдоль ее осевой линии. Для расчленения полилиний, содержавшихся в расчлененном блоке, требуется отдельная операция. Ширина кольца после его расчленения также становится нулевой.

Расчленение блоков

При расчленении из блоков удаляются атрибуты, однако при этом исходные описания атрибутов сохраняются. Цвета и типы линий отдельных объектов, образующихся на месте вхождений блоков, могут измениться.

Расчленение внешних ссылок

Внешними ссылками называются файлы чертежей, вставленные в другие чертежи и сохраняющие связь со своим исходным описанием. Внешние ссылки и унаследованные из них блоки расчленить нельзя.


Для расчленения объекта - Процедуры

Создание и редактирование объектов
Методы редактирования
Расчленение составных объектов
Понятия
Процедуры
Команды

Для расчленения объекта

  1. Выберите в меню "Изменить" » "Расчленить".
  2. Выберите объекты для расчленения.

    3. Для многих объектов результат расчленения визуально не заметен.

Панель "Редактирование"

Ввод команды: РАСЧЛЕНИТЬ


Расчленение составных объектов - Команды

Методы редактирования
Методы редактирования
Расчленение составных объектов
Понятия
Процедуры
Команды

Команды
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
EXPLMODE | Управляет обработкой блоков с разными масштабами вставки в команде РАСЧЛЕНИТЬ
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование и объединение полилиний - Понятия

Создание и редактирование объектов
Методы редактирования
Редактирование и объединение полилиний
Понятия
Процедуры
Команды

Для изменения формы полилиний, кроме общих операций редактирования, предусмотрены также дополнительные операции. Кроме того, можно объединять отдельные полилинии в одну.

Редактирование полилиний заключается в их замыкании и размыкании, а также в перемещении, добавлении и удалении отдельных вершин. Имеется возможность выпрямления полилинии между двумя вершинами, настройки типа линии так, что до и после каждой вершины рисуются штрихи. Можно задать единую ширину для всей полилинии или управлять шириной для каждого сегмента. Полилинии можно также линейно аппроксимировать в сплайновые кривые.

Сегменты объединяемых полилиний

К разомкнутой полилинии можно присоединить отрезок, дугу или другую полилинию, если их конечные точки совпадают. Если конечные точки не совпадают, но расстояние между ними не превышает некоторого критического значения, то объединение выполняется с помощью обрезки, удлинения или создания нового сегмента.

Свойства объединенных полилиний

Полилиния, полученная в результате объединения нескольких объектов с различными свойствами, наследует свойства первого выбранного объекта. Если две линии примыкают к полилинии в форме буквы Y, выбирается одна из линий и она присоединяется к полилинии. Данное объединение также приводит к тому, что программа неявно отменяет сглаживание как исходной полилинии, так и присоединяемой. После присоединения полученную полилинию можно сгладить снова.

Дополнительные опции редактирования полилиний

Для редактирования полилиний, кроме общих операций редактирования, применяемых ко многим объектам, предусмотрены также дополнительные опции редактирования и объединения, реализуемые командой ПОЛРЕД.

  • "Замкнуть". Создание замыкающего сегмента полилинии, соединяющего его последний сегмент с первым. Полилиния считается открытой, пока ее не замкнуть с помощью параметра "Замкнуть".
  • "Соединить". Добавление линий, дуг или полилиний к концу открытой полилинии и отмена сглаживания для полилиний, сглаженных дугой. Конец добавляемого объекта должен точно совпадать с одной из конечных точек полилинии.
  • "Ширина". Задание новой единой ширины для всей полилинии. Можно воспользоваться также подопцией "Ширина" опции "Вершина" для изменения начальной и конечной ширины отдельных сегментов.

  • "Вершина". Первая вершина полилинии на экране помечается крестиком (X) на экране. Если для этой вершины задана касательная, то ее направление указывается стрелкой.
  • "Сгладить". Вычисление гладкой кривой, сглаживающей вершины полилинии дугами. Кривая проходит через все вершины полилинии, удовлетворяя при этом значениям касательных, заданных для этих вершин.
  • "Сплайн". Использование вершин выбранной полилинии в качестве управляющих точек или контура сглаженной сплайном полилинии. Кривая проходит через первую и последнюю управляющие точки, если исходная полилиния не была замкнута.

  • "Убрать сглаживание". Удаление всех дополнительных вершин с помощью сглаженной дугой или сплайном полилинии и выпрямление всех сегментов полилинии.
  • "Типлин". Задание способа генерации типа линий в вершинах полилинии. При включенном параметре генерация заданного типа линий начинается со штриха и заканчивается штрихом в каждой вершине.

См. также

Обрезка и удлинение объектов

Разрыв и соединение объектов


Редактирование и объединение полилиний - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование и объединение полилиний
Понятия
Процедуры
Команды

Для редактирования полилинии

Объединение полилиний, линий и дуг в одну полилинию

Удаление вершины в полилинии

Для сужения ширины отдельных сегментов


Для редактирования полилинии - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование и объединение полилиний
Понятия
Процедуры
Команды

Для редактирования полилинии

  1. Выберите в меню "Изменить" » "Объект" » "Полилиния".
  2. Выберите полилинию для редактирования.

    3. Если выбранный объект является линией или дугой, отобразится следующий запрос.

    Выбранный объект - не полилиния.

    Сделать его полилинией? <Y>: Введите y или n, или нажмите ENTER

    При ответе д такой объект преобразуется в двумерную полилинию, состоящую из одного сегмента. Полученную полилинию можно отредактировать. Этой операцией можно пользоваться для объединения отрезков и дуг в полилинию. Если значение системной переменной PEDITACCEPT равно 1, то такой запрос не выдается, и выбранный объект автоматически преобразуется в полилинию.

  3. Задать любые из приведенных опций редактирования:
    • Введите з (Замкнуть) для замыкания разомкнутой полилинии.
    • Введите д (Добавить) для объединения смежных отрезков, дуг или полилиний.
    • Введите ш (Ширина) для задания новой единой ширины для всей полилинии.
    • Введите в (Вершина) для редактирования вершин.
    • Введите сг (СГладить) для сглаживания полилинии дугами, проходящими через все вершины.
    • Введите сп (СПлайн) для сплайновой аппроксимации полилинии.
    • Введите у (Убрать сглаживание) для удаления всех дополнительных вершин, вставленных при выполнении операций "Сгладить" и "Сплайн", и выпрямление всех сегментов полилинии.
    • Введите т (Типлин) для включения или отключения непрерывной генерации образца типа линий.
    • Введите о (Отменить), чтобы вернуть действия к началу ПОЛРЕД.
  4. Введите x (Выход) для завершения опции команды. Для выхода из команды ПОЛРЕД нажмите ENTER.

Панель "Редактирование-2"

Ввод команды: ПОЛРЕД


Объединение полилиний, линий и дуг в одну полилинию - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование и объединение полилиний
Понятия
Процедуры
Команды

Объединение полилиний, линий и дуг в одну полилинию

  1. Выберите в меню "Изменить" » "Объект" » "Полилиния".
  2. Выберите полилинию, линию или дугу для редактирования. Если выбрана линия или дуга, нажмите ENTER для преобразования выбранной линии или дуги в полилинию.
  3. Введите с (Соединить).
  4. Выберите одну или несколько полилиний, линий или дуг, располагаемых из конца в конец.

    5. Все выбранные полилинии, линии или дуги теперь соединяются в единую полилинию.

  5. Нажмите ENTER для завершения команды.

Панель "Редактирование-2"

Ввод команды: ПОЛРЕД


Удаление вершины в полилинии - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование и объединение полилиний
Понятия
Процедуры
Команды

Удаление вершины в полилинии

  1. Выберите в меню "Редакт" » "Объект" » "Полилиния".
  2. Выберите полилинию.
  3. Введите р (редактировать вершину).

    4. Первая вершина помечается символом X. Используйте опцию "Далее" для перемещения X на вершину, предшествующую той, которую нужно удалить.

  4. Введите с (спрямить)
  5. Используйте опцию "Далее" для перемещения X на вершину, следующую непосредственно за той, которую нужно удалить
  6. Введите и (Идти дальше).

    7. Вершина на полилинии удаляется. Вершины с каждой из сторон от удаленной вершины соадиняются между собой прямолинейным отрезком полилинии.

  7. Введите х (выХод) для завершения работы с вершинами.
  8. Нажмите ENTER для завершения команды.

Панель "Редактирование-2"

Ввод команды: ПОЛРЕД


Для сужения ширины отдельных сегментов - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование и объединение полилиний
Понятия
Процедуры
Команды

Для сужения ширины отдельных сегментов

  1. Выберите в меню "Изменить" » "Объект" » "Полилиния".
  2. Выберите полилинию для редактирования.
  3. Введите в (Вершина).

    4. Первая вершина помечается крестиком (X). Переместите соответствующую вершину с помощью опций "Следующая" или "Предыдущая".

  4. Введите ш (Ширина).
  5. Введите начальную и конечную ширину, затем нажмите ENTER для перехода к следующей вершине. Повторить пункты 4 и 5 для каждого сегмента.
  6. Введите о (Отменить), чтобы вернуть действия к началу ПОЛРЕД.
  7. Введите х (выХод) для завершения работы с вершинами.
  8. Нажмите ENTER для завершения команды.

Панель "Редактирование-2"

Ввод команды: ПОЛРЕД


Редактирование и объединение полилиний - Команды

Методы редактирования
Методы редактирования
Редактирование и объединение полилиний
Понятия
Процедуры
Команды

Команды
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
СОЕДИНИТЬ | Соединяет объекты для формирования одного целого объекта
Системные переменные
PEDITACCEPT | Подавляет отображение подсказки "Выбранный объект не является полилинией" команды ПОЛРЕД
SPLFRAME | Управляет отображением сплайнов и сглаженных сплайнами полилиний
SPLINESEGS | Задает количество сегментов линии, генерируемых для каждой сглаженной сплайном полилинии, созданной с помощью параметра "Сплайн" команды ПОЛРЕД
SPLINETYPE | Задает тип кривой, создаваемой с помощью параметра "Сплайн" команды ПОЛРЕД
SURFTYPE | Управляет типом поверхности сглаживания, которая используется командой ПОЛРЕД (параметр "Сплайн")
SURFU | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности
SURFV | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование сплайнов - Понятия

Создание и редактирование объектов
Методы редактирования
Редактирование сплайнов
Понятия
Процедуры
Команды

Для изменения форм сплайнов, кроме общих операций редактирования, предусмотрены также дополнительные опции.

Для редактирования сплайнов, кроме общих операций редактирования, применяемых ко многим объектам, предусмотрены также дополнительные опции, реализуемые командой РЕДСПЛАЙН:

  • Определяющие. Редактирование определяющих сплайн данных, включая значения допусков.
  • "Замкнуть". Замыкание разомкнутого сплайна со сглаживанием в точке соединения.
  • Перенести. Изменение положения определяющей точки.
  • "Уточнить". Изменение формы сплайна добавлением управляющих точек и изменением их весовых коэффициентов, а также повышением порядка сплайна.
  • "Обратно". Изменение направление сплайна на противоположное.

Кроме того, разрешается изменение допуска сплайна. Допуск задает максимально допустимое расстояние от реального сплайна до любой из определяющих точек. Чем меньше значение допуска, тем сплайн ближе к определяющим точкам.

Редактирование сплайнов с помощью ручек

Если системная переменная GRIPS имеет значение 1, то ручки размещаются на определяющих точках выбранного сплайна. С их помощью можно изменять форму и положение сплайна.

Выполнение некоторых операций приводит к удалению определяющих точек. В этих случаях ручки располагаются в управляющих точках сплайна. К таким операциям относятся обрезка сплайна, перемещение контрольных точек и удаление определяющих данных. Если включена управляющая ломаная сплайна (системная переменная SPLFRAME равна 1), то ручки отображаются как на управляющих точках, так и на определяющих точках, если они имеются.

Имеется возможность удалять определяющие точки сплайна, добавлять их для повышения точности и изменять форму сплайна путем перемещения определяющих точек. Сплайны можно замыкать и размыкать, а также изменять направления касательных в начальной и конечной точках. Можно менять местами начало и конец сплайна. Кроме того, разрешается изменение допуска сплайна. Допуск задает максимально допустимое расстояние от реального сплайна до любой из определяющих точек. Чем меньше значение допуска, тем сплайн ближе к определяющим точкам.

Исправление формы сплайна

Повысить точность сплайна можно, увеличив количество управляющих точек в какой-либо из его частей, или изменив весовые коэффициенты некоторых из управляющих точек. Повышение весового коэффициента управляющей точки заставляет сплайн проходить ближе к ней. Еще один способ увеличения точности сплайна - повышение его порядка. Порядком сплайна называется число, на единицу большее степени полинома, описывающего сплайн. Например, кубический сплайн имеет порядок 4. Чем выше порядок сплайна, ткм больше у него управляющих точек.

Рассмотрим следующий случай. Пусть построенный сплайн представляет на чертеже географическую горизонталь. Ручки включены, и для увеличения точности требуется переместить четвертую определяющую точку. При выборе сплайна в управляющих точках появляются ручки. Если сплайн создан путем задания совокупности определяющих точек и положения этих точек не удалены из определения опцией "Очистить" команды РЕДСПЛАЙН, при выборе опции "Определяющие" ручки появляются в определяющих, а не в управляющих, точках выбранного сплайна.

См. также

Разрыв и соединение объектов


Для редактирования сплайна - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование сплайнов
Понятия
Процедуры
Команды

Для редактирования сплайна

  1. Выберите в меню "Изменить" » "Сплайн".
  2. Выберите сплайн для редактирования.
  3. Выполните одно или несколько действий из перечисленных:
    • Введите о (Определяющие) для редактирования определяющих сплайн данных.
    • Введите з (Замкнуть) для замыкания разомкнутого сплайна и сглаживания кривой в точке соединения.
    • Введите п (Перенести) для переноса определяющей точки в новое положение.
    • Введите и (Исправить) для изменения формы сплайна путем добавления управляющих точек и изменения их весовых коэффициентов, а также повышением порядка сплайна.
    • Введите об (ОБратно) для изменения направления сплайна на противоположное.
    • Введите от (ОТменить) для отмены последней операции редактирования.
  4. Введите х (выХод) для завершения команды.

Панель "Редактирование-2"

Ввод команды: РЕДСПЛАЙН


Редактирование сплайнов - Команды

Методы редактирования
Методы редактирования
Редактирование сплайнов
Понятия
Процедуры
Команды

Команды
РЕДСПЛАЙН | Редактирование сплайнов или сглаженных сплайнами полилиний
СОЕДИНИТЬ | Соединяет объекты для формирования одного целого объекта
Системные переменные
SPLFRAME | Управляет отображением сплайнов и сглаженных сплайнами полилиний
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение спиралей - Понятия

Создание и редактирование объектов
Методы редактирования
Изменение спиралей
Понятия
Процедуры
Команды

Для изменения зформы и размера спирали можно использовать как ручки, так и палитру "Свойства".

Показать: Создать и изменить спираль

Для запуска анимации нажмите на стрелку "Показать". Более подробную информацию о создании спиралей см. в разделе Построение спиралей.

Ручки можно использовать для изменения следующих параметров спирали:

  • Начальная точка
  • Радиус в основании
  • Радиус при вершине
  • Высота
  • Расположения

Если для изменения радиуса спирали в основании используется ручка, то радиус при вершине автоматически изменяется с соблюдением заданной пропорции. Для изменения радиуса в основания независимо от радиуса при вершине используется палитра "Свойства".

С помощью палитры "Свойства" можно изменять и другие свойства спирали, например:

  • Число витков (Витки)
  • Высота витка
  • Направление кручения - по часовой стрелке (ПОЧС) или против часовой стрелки (ПРЧС).

С помощью свойства "Наложение зависимости" можно задать зависимости для таких свойств спирали как "Высота", "Число витков" и "Высота витка". "Наложение зависимости" влияет на изменение таких свойств спирали как "Высота", "Число витков" и "Высота витка" при изменении их в панели "Свойства" или с помощью ручек для редактирования. Приведенная ниже таблица показывает изменения спирали в зависимости от того, на какое свойство налагается зависимость.

Свойство, на которое наложена зависимость | Свойство, подлежащее изменению | Изменяемые свойства спирали
 |  | Высота | Витки | Высота витка
Высота | Высота | Изменяется | Не изменяется | Изменяется
 | Витки | Не изменяется | Изменяется | Изменяется
 | Высота витка | Не изменяется | Изменяется | Изменяется
Витки | Высота | Изменяется | Не изменяется | Изменяется
 | Витки | Не изменяется | Изменяется | Изменяется
 | Высота витка | Изменяется | Не изменяется | Изменяется
Высота витка | Высота | Изменяется | Изменяется | Не изменяется
 | Витки | Изменяется | Изменяется | Не изменяется
 | Высота витка | Не изменяется | Изменяется | Изменяется

См. также

Построение спиралей


Редактирование сложных объектов

Создание и редактирование объектов
Методы редактирования
Редактирование сложных объектов
Понятия
Процедуры
Команды

Нет процедур, относящихся к этому разделу.


Изменение спиралей - Команды

Методы редактирования
Методы редактирования
Изменение спиралей
Понятия
Процедуры
Команды

Команды
СПИРАЛЬ | Создание 2D или 3D винтовой линии
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование мультилиний - Понятия

Создание и редактирование объектов
Методы редактирования
Редактирование мультилиний
Понятия
Процедуры
Команды

Многострочные объекты состоят из параллельных линий (от 1 до 16), называемых элементами. Для изменения мультилиний можно использовать обычные команды редактирования, команду редактирования мультилинии и стили мультилинии.

Специальные функции редактирования мультилинии доступны с помощью команды МЛРЕД, включая следующие.

  • Добавление или удаление вершины
  • Контролирование видимости стыков угла
  • Контролирование стиля пересечения с другими мультилиниями
  • Создание или удаление разрывов в многострочном объекте
Добавление и удаление вершин мультилиний

Имеется возможность добавления к мультилинии новой вершины или удаления имеющейся.

Редактирование пересечений мультилиний

Имеется возможность отредактировать способ пересечения мультилиний. Пересечения могут быть крестообразными или T-образными; крестообразные или T-образные подразделяется на закрытые, открытые и сплошные пересечения.

Редактирование стилей мультилиний

Можно использовать команду МЛСТИЛЬ для редактирования стилей мультилиний, т.е. изменить свойства элементов, а также вид торцов и цвет закрашивания для последующих мультилиний.

Стили мультилиний определяют количество элементов в мультилинии, цвет, тип линий, толщину линии и смещение каждого элемента от исходного положения. Кроме того, допускается изменение вида соединяющих отрезков, торцевых ограничителей и фона заполнения.

Стили мультилиний имеют следующие ограничения.

  • Редактирование свойств элементов и мультилиний невозможно для стиля СТАНДАРТ и стилей, используемых в чертеже.
  • Редактировать стиль мультилинии необходимо до того, как он будет использован для создания мультилинии в текущем чертеже.

Примечание Если не сохранить созданный с помощью команды МЛСТИЛЬ стиль мультилинии, то выбор другого стиля или переход к созданию нового приведет к потере всех свойств команды МЛСТИЛЬ Поэтому после определения свойств стиля мультилинии рекомендуется сразу сохранить его в MLN-файле.

Использование команд редактирования для мультилиний

Можно использовать большинство обычных команд редактирования для мультилиний кроме

  • РАЗОРВАТЬ
  • ФАСКА
  • СОПРЯЖЕНИЕ
  • УВЕЛИЧИТЬ
  • ПОДОБИЕ

Для выполнения этих операций сначала использовать команду РАСЧЛЕНИТЬ для перемещения многострочного объекта с объектом отдельной линии.

Примечание При обрезке или удлинении многострочного объекта форму конца мультилинии определяет только первый объект контура. Сложный контур не может находиться на конечной точки мультилинии.

См. также

Построение объектов мультилиний


Редактирование мультилиний - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование мультилиний
Понятия
Процедуры
Команды

Для удаления вершины мультилинии

Для задания закрытого крестообразного типа пересечения

Редактирование стиля мультилинии


Для удаления вершины мультилинии - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование мультилиний
Понятия
Процедуры
Команды

Для удаления вершины мультилинии

  1. Выберите в меню "Изменить" » "Объект" » "Мультилиния".
  2. В диалоговом окне "Редактирование мультилинии" выберите пиктограмму "Удалить вершину".
  3. Укажите на чертеже вершину для удаления. Нажмите ENTER.

Ввод команды: МЛРЕД


Для задания закрытого крестообразного типа пересечения - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование мультилиний
Понятия
Процедуры
Команды

Для задания закрытого крестообразного типа пересечения

  1. Выберите в меню "Изменить" » "Объект" » "Мультилиния".
  2. В диалоговом окне "Редактирование мультилинии" выберите пиктограмму "Закрытый крест".
  3. Выберите верхнюю мультилинию.
  4. Выберите нижнюю мультилинию.

    5. Тип пересечения изменяется. После этого можно либо продолжить выбор пересечений мультилиний, либо завершить команду нажатием ENTER . Для повторного вызова диалогового окна "Редактирование мультилинии" нужно вновь нажать ENTER.


Редактирование стиля мультилинии - Процедуры

Создание и редактирование объектов
Методы редактирования
Редактирование мультилиний
Понятия
Процедуры
Команды

Редактирование стиля мультилинии

  1. Выберите в меню "Формат" » "Стиль мультилиний".
  2. В диалоговом окне "Стили мультилиний" выберите имя стиля из списка. Нажмите кнопку "Изменить".
  3. Выберите "Свойства элементов".
  4. В диалоговом окне "Редактирование стилей мультилиний" изменить необходимые параметры.
  5. Нажмите "ОК".
  6. В диалоговом окне "Стили мультилиний" нажать кнопку "Сохранить" для сохранения сделанных изменений в MLN-файле.
  7. Нажмите "ОК".

Ввод команды: МЛСТИЛЬ


Редактирование мультилиний - Команды

Методы редактирования
Методы редактирования
Редактирование мультилиний
Понятия
Процедуры
Команды

Команды
МЛРЕД | Редактирует пересечения мультилиний, разрывы и вершины
МЛСТИЛЬ | Создает, изменяет и управляет стилями мультилиний
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с 3D моделями

Создание 3D моделей
Возможно создание 3D тел и поверхностей с самого начала или на основе имеющихся объектов. В дальнейшем эти тела и поверхность можно комбинировать для получения моделей тел. 3D объекты могут быть также представлены моделированными поверхностями (с 3D высотой), в виде каркасной модели или в виде сетчатой модели поверхности.

Изменение 3D тел и поверхностей
После создания модели тела можно вручную изменять форму его отображения, вручную управляя телами и поверхностями множеством способов, включая нажатие и перетаскивание ручек, использование блоков захвата и изменение свойств объектов с помощью палитры свойств.

Построение сечений и 2D чертежей из 3D моделей
Предусмотрена возможность построения поперечного сечения 3D тела с помощью пересечения плоскости и твердотельных объектов для создания области. Можно также использовать режущую плоскость, называемую объект-сечение, которая позволяет рассматривать в режиме реального времени виды поперечных сечений в 3D модели. Виды сечений можно зафиксировать в качестве плоскостных представлений.


Работа с 3D моделями - Понятия

Работа с 3D моделями
Работа с 3D моделями
Работа с 3D моделями
Понятия
Процедуры
Команды

Возможно создание 3D тел и поверхностей с самого начала или на основе имеющихся объектов. Далее эти тела и поверхность можно комбинировать для получения моделей тел. 3D объекты могут быть также представлены моделированными поверхностями (3D высотой), в виде каркасной модели или в виде сетчатой модели поверхности.

После создания модели тела можно изменять форму его отображения, вручную управляя телами и поверхностями множеством способов, включая редактирование с помощью ручек и изменение свойств объектов с помощью палитры свойств.

Имеется возможность построения поперечного сечения 3D тел. В результате может быть получен двумерный объект, отображающий форму сечения. Возможно также использование режущей плоскости, позволяющей просматривать виды поперечных сечений в 3D модели в реальном времени.


Работа с 3D моделями - Процедуры

Работа с 3D моделями
Работа с 3D моделями
Работа с 3D моделями
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Работа с 3D моделями - Команды

Работа с 3D моделями
Работа с 3D моделями
Работа с 3D моделями
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Создание 3D моделей - Понятия

Работа с 3D моделями
Создание 3D моделей
Понятия
Процедуры
Команды

Возможно создание 3D тел и поверхностей с самого начала или на основе имеющихся объектов. В дальнейшем эти тела и поверхность можно комбинировать для получения моделей тел. 3D объекты могут быть также представлены моделированными поверхностями (с 3D высотой), в виде каркасной модели или в виде сетчатой модели поверхности.

  • Обзор 3D моделирования
  • Создание 3D тел и поверхностей
    Возможно создание 3D тел и поверхностей с самого начала или на основе имеющихся объектов.
  • Проверка взаимодействий в твердотельной модели
    Команда ВЗАИМОД позволяет проверить взаимодействия (областей пересечения или перекрытия 3D тел) внутри твердотельной модели путем сравнения двух наборов объектов или попарного сравнения всех тел.
  • Создание сетей
    Имеется возможность создания многоугольных сетчатых форм. Так как грани сети являются плоскими, представление криволинейных поверхностей производится путем их аппроксимации.
  • Создание каркасных моделей
    Каркасная модель представляет собой скелетное описание 3D объекта, состоящее из отрезков и кривых.
  • Задание трехмерной высоты объектов
    Задание высоты объектов позволяет моделировать объем.


Создание 3D моделей - Процедуры

Работа с 3D моделями
Создание 3D моделей
Понятия
Процедуры
Команды

Создание ящика

Создание клина

Для построения конуса с круговым основанием

Для построения конуса с эллиптическим основанием

Создание усеченного конуса

Создание конуса с высотой и ориентацией, задаваемыми конечной точкой оси

Создание цилиндра с круговым основанием

Создание цилиндра с эллиптическим основанием

Создание цилиндра с высотой и ориентацией, задаваемыми конечной точкой оси

Создание шаров

Создание шара, определяемого тремя точками

Создание пирамиды

Создание усеченной пирамиды

Создание тора

Вычерчивание политела

Создание политела на основе существующего объекта

Выдавливание объекта

Выдавливание объекта вдоль траектории

Создание тела или поверхности посредством сдвига объекта вдоль траектории

Создание тела или поверхности по сечениям с использованием набора поперечных сечений

Вращение объектов вокруг оси

Преобразование одного или нескольких объектов в поверхности

Создание плоской поверхности на основе существующего объекта

Создание плоской поверхности посредством задания углов поверхности

Преобразование объектов, имеющих высоту, в тела выдавливания

Преобразование одной или нескольких поверхностей в тела

Объединение тел

Вычитание тел друг из друга

Создание тела путем пересечения двух или нескольких тел

Разрезание тел

Разрезание тел с помощью плоского объекта

Разрезание тел с помощью поверхности

Проверка взаимодействий в твердотельной модели

Изменение отображения объектов взаимодействия

Для построения сети из четырехугольных ячеек

Создание сети соединения

Создание сети сдвига

Создание сети вращения

Для построения сети в виде участка поверхности Кунса, заданной кромками

Построение перпендикуляра из 3D точки к плоскости XY

Создание каркасной геометрии посредством извлечения ребер

Для задания 3D высоты вновь создаваемых объектов

Для изменения 3D высоты существующих объектов


Создание 3D моделей - Команды

Работа с 3D моделями
Создание 3D моделей
Понятия
Процедуры
Команды
Команды
3D | Создание трехмерных объектов в виде полигональных сетей распространенных геометрических форм, которые можно скрыть, раскрасить или тонировать
3DГРАНЬ | Создает трех- или четырехстороннюю поверхность в любом месте 3D пространства
3DСЕТЬ | Построение полигональных сетей произвольной формы
ВЗАИМОД | Подсвечивает накладывающиеся друг на друга 3D тела
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
ВРАЩАТЬ | Создается 3D тело или поверхность вращением 2D объектов вокруг оси.
ВЫДАВИТЬ | Создание 3D тела или поверхности путем выдавливания объекта или плоской грани в заданном направлении и на заданное расстояние.
ВЫЧИТАНИЕ | Объединение выбранных областей или тел посредством вычитания
ИЗВЛРЕБРА | Создание геометрии каркаса посредством извлечения ребер из 3D тела или поверхности
КЛИН | Построение трехмерного пятигранного тела с наклонной гранью, приближающейся к оси X.
КОНУС | Создает 3D тело с основанием в форме окружности или эллипса, симметрично суживающихся к точке, или к плоской грани в форме окружности или эллипса
ОБЪЕДИНЕНИЕ | Объединение выбранных областей или тел посредством сложения
П-ВРАЩ | Создается сеть вращения вокруг выбранной оси.
ПГРАНЬ | Создание трехмерной многогранной сети по вершинам.
ПЕРЕСЕЧЕНИЕ | Создает составные тела или области путем пересечения двух или более тел или областей и удаляет области снаружи пересечения.
ПИРАМИДА | Создается 3D тело пирамиды
П-КРОМКА | Построение трехмерных полигональных сетей
ПЛОСКПОВ | Создается плоская поверхность
ПОЛИТЕЛО | Создается 3D политело
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
ПОСЕЧЕНИЯМ | Создает 3D тела или поверхности путем сечений двумя или более кривыми.
ПРЕОБРВПВРХ | Преобразует объекты в поверхности
ПРЕОБРВТЕЛО | Преобразует полилинии и окружности, для которых задана высота, в 3D тела.
П-СДВИГ | Создание сети сдвига на основе определяющей кривой и вектора направления
ПСК | Управление пользовательскими системами координат
П-СОЕД | Создается сеть соединений между двумя кривыми
РАЗРЕЗ | Разрезание тел плоскостью или поверхностью
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
СДВИГ | Создание 3D тела или поверхности посредством сдвига 2D кривой вдоль траектории
ТОЛЩИНА | Создание 3D тела посредством утолщения поверхности
ТОР | Создание 3D тела в форме тора
УРОВЕНЬ | Задание уровня и трехмерной высоты для вновь создаваемых объектов
ЦИЛИНДР | Создает трехстороннее 3D тело с окружностью или эллипсом в основании и на верхней грани
ШАР | Создание 3D тела - шара
ЯЩИК | Создает 3D твердотельный параллелепипед (ящик)
Системные переменные
BACKZ | Сохранение смещения задней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа).
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
DRAGVS | Устанавливает визуальный стиль при создании 3D твердотельных примитивов и выдавленных тел и поверхностей.
FACETRATIO | Управляет плотностью сетевого представления цилиндрических и конических тел
FACETRES | Регулирует гладкость раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями
FRONTZ | Сохраняет смещение передней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа)
INTERFERECOLOR | Устанавливает цвет объектов взаимодействия
INTERFEREOBJVS | Устанавливает стиль отображения объектов взаимодействия
INTERFEREVPVS | Задает стиль отображения видового экрана во время проверки пространственных взаимодействий
ISOLINES | Указывает количество линий контура для изображения поверхностей объектов
LOFTANG1 | Устанавливает черновой угол сквозь первое поперечное сечение в операции сечения
LOFTANG2 | Устанавливает черновой угол сквозь последнее поперечное сечение в операции сечения
LOFTMAG1 | Устанавливает величину чернового угла сквозь первое поперечное сечение в операции сечения
LOFTMAG2 | Устанавливает величину чернового угла сквозь последнее поперечное сечение в операции сечения
LOFTNORMALS | Управляет нормалями развернутого объекта в точках их прохода сквозь поперечные сечения
LOFTPARAM | Управляет очертанием развернутых тел и поверхностей
PFACEVMAX | Устанавливает максимальное число вершин на одну грань
PSOLHEIGHT | Управляет значением высоты по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО
PSOLWIDTH | Управляет значением ширины по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО
SURFTAB1 | Задает число интервалов, генерируемых командами П-СОЕД и П-СДВИГ
SURFTAB2 | Задает плотность сети в направлении N для команд П-ВРАЩ и П-КРОМКА
SURFTYPE | Управляет типом поверхности сглаживания, которая используется командой ПОЛРЕД (параметр "Сплайн")
SURFU | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности
SURFV | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности.
VIEWMODE | Сохраняет режим "Вид" для текущего видового экрана
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор 3D моделирования - Понятия

Работа с 3D моделями
Создание 3D моделей
Обзор 3D моделирования
Понятия
Процедуры
Команды

Применяя 3D моделирование при работе над проектом, можно создавать модели тел, каркасные и сетчатые модели. Использование 3D моделирования дает несколько преимуществ. Имеется возможность:

  • Рассматривать модели из любой точки.
  • Использовать автоматическую генерацию основных и дополнительных 2D видов.
  • Создавать сечения и 2D чертежи.
  • Подавлять скрытые линии и добиваться реалистичного тонирования.
  • Проверять взаимодействия.
  • Добавлять источники света.
  • Создавать реалистичное тонирование.
  • Перемещаться по модели.
  • Использовать модель для создания анимации.
  • Выполнять инженерный анализ.
  • Извлекать характеристики, необходимые для производства.
Моделирование тела

При моделировании твердых тел в качестве строительных блоков для модели используются тела и поверхности.

Твердотельный объект, или тело, представляет собой изображение объекта, хранящее, помимо всего прочего, информацию о своих объемных свойствах. Следовательно, тела наиболее полно из всех типов 3D моделей отражают моделируемые объекты. Кроме того, тела, несмотря на их кажущуюся сложность, легче строить и редактировать, чем каркасные модели и сети.

См. также

3D координаты

Задание плоскостей видов чертежа в 3D (ПСК)

Использование динамической ПСК с моделями тел


Создание 3D моделей

Работа с 3D моделями
Создание 3D моделей
Создание 3D моделей
Понятия
Процедуры
Команды

Нет процедур.


Обзор 3D моделирования - Команды

Создание 3D моделей
Создание 3D моделей
Обзор 3D моделирования
Понятия
Процедуры
Команды

Команды
ВРАЩАТЬ | Создается 3D тело или поверхность вращением 2D объектов вокруг оси.
ВЫДАВИТЬ | Создание 3D тела или поверхности путем выдавливания объекта или плоской грани в заданном направлении и на заданное расстояние.
КЛИН | Построение трехмерного пятигранного тела с наклонной гранью, приближающейся к оси X.
КОНУС | Создает 3D тело с основанием в форме окружности или эллипса, симметрично суживающихся к точке, или к плоской грани в форме окружности или эллипса
ПИРАМИДА | Создается 3D тело пирамиды
ПОЛИТЕЛО | Создается 3D политело
ПОСЕЧЕНИЯМ | Создает 3D тела или поверхности путем сечений двумя или более кривыми.
СДВИГ | Создание 3D тела или поверхности посредством сдвига 2D кривой вдоль траектории
ТОР | Создание 3D тела в форме тора
ЦИЛИНДР | Создает трехстороннее 3D тело с окружностью или эллипсом в основании и на верхней грани
ШАР | Создание 3D тела - шара
ЯЩИК | Создает 3D твердотельный параллелепипед (ящик)
Системные переменные
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
PSOLHEIGHT | Управляет значением высоты по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО
PSOLWIDTH | Управляет значением ширины по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание 3D тел и поверхностей - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание 3D тел и поверхностей
Понятия
Процедуры
Команды

Возможно создание 3D тел и поверхностей с самого начала или на основе имеющихся объектов.

  • Обзор создания 3D тел и поверхностей
  • Создание 3D твердотельных примитивов
    Предусмотрена возможность создания базовых твердотельных форм в виде ящика, конуса, цилиндра, шара, тора, клина и пирамиды. Эти формы называют твердотельными примитивами.
  • Создание политела
    Политело вычерчивается точно так же, как и полилиния. По умолчанию у политела всегда прямоугольные контуры. Предусмотрено задание высоты и ширины политела. Для построения в модели стен служит команда ПОЛИТЕЛО.
  • Создание тел и поверхностей на основе отрезков и кривых
    Тела и поверхности можно строить на основе существующих отрезков и кривых. Эти объекты можно использовать для определения как контура, так и траектории для тела или поверхности.
  • Создание тел и поверхностей на основе объектов
    Поверхности можно создавать на основе существующих в чертеже объектов.
  • Создание тел на основе поверхностей
    3D тело можно построить на основе поверхности любого типа путем ее утолщения.
  • Создание составных тел
    Составные тела создаются из двух и более индивидуальных тел с использованием любой из следующих команд: ОБЪЕДИНЕНИЕ,, ВЫЧИТАНИЕ и ПЕРЕСЕЧЕНИЕ (Для создания составных тел используются также команды СОПРЯЖЕНИЕ и ФАСКА).
  • Создание тел путем разрезания
    Новые тела могут быть получены разрезанием существующих тел. Существует ряд способов определения режущей плоскости, включая задание точек или выбор поверхности или плоского объекта.


Создание 3D тел и поверхностей - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание 3D тел и поверхностей
Понятия
Процедуры
Команды

Создание ящика

Создание клина

Для построения конуса с круговым основанием

Для построения конуса с эллиптическим основанием

Создание усеченного конуса

Создание конуса с высотой и ориентацией, задаваемыми конечной точкой оси

Создание цилиндра с круговым основанием

Создание цилиндра с эллиптическим основанием

Создание цилиндра с высотой и ориентацией, задаваемыми конечной точкой оси

Создание шаров

Создание шара, определяемого тремя точками

Создание пирамиды

Создание усеченной пирамиды

Создание тора

Вычерчивание политела

Создание политела на основе существующего объекта

Выдавливание объекта

Выдавливание объекта вдоль траектории

Создание тела или поверхности посредством сдвига объекта вдоль траектории

Создание тела или поверхности по сечениям с использованием набора поперечных сечений

Вращение объектов вокруг оси

Преобразование одного или нескольких объектов в поверхности

Создание плоской поверхности на основе существующего объекта

Создание плоской поверхности посредством задания углов поверхности

Преобразование объектов, имеющих высоту, в тела выдавливания

Преобразование одной или нескольких поверхностей в тела

Объединение тел

Вычитание тел друг из друга

Создание тела путем пересечения двух или нескольких тел

Разрезание тел

Разрезание тел с помощью плоского объекта

Разрезание тел с помощью поверхности


Создание 3D тел и поверхностей - Команды

Работа с 3D моделями
Создание 3D моделей
Создание 3D тел и поверхностей
Понятия
Процедуры
Команды
Команды
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
ВРАЩАТЬ | Создается 3D тело или поверхность вращением 2D объектов вокруг оси.
ВЫДАВИТЬ | Создание 3D тела или поверхности путем выдавливания объекта или плоской грани в заданном направлении и на заданное расстояние.
ВЫЧИТАНИЕ | Объединение выбранных областей или тел посредством вычитания
КЛИН | Построение трехмерного пятигранного тела с наклонной гранью, приближающейся к оси X.
КОНУС | Создает 3D тело с основанием в форме окружности или эллипса, симметрично суживающихся к точке, или к плоской грани в форме окружности или эллипса
ОБЪЕДИНЕНИЕ | Объединение выбранных областей или тел посредством сложения
ПЕРЕСЕЧЕНИЕ | Создает составные тела или области путем пересечения двух или более тел или областей и удаляет области снаружи пересечения.
ПИРАМИДА | Создается 3D тело пирамиды
ПЛОСКПОВ | Создается плоская поверхность
ПОЛИТЕЛО | Создается 3D политело
ПОСЕЧЕНИЯМ | Создает 3D тела или поверхности путем сечений двумя или более кривыми.
ПРЕОБРВПВРХ | Преобразует объекты в поверхности
ПРЕОБРВТЕЛО | Преобразует полилинии и окружности, для которых задана высота, в 3D тела.
РАЗРЕЗ | Разрезание тел плоскостью или поверхностью
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
СДВИГ | Создание 3D тела или поверхности посредством сдвига 2D кривой вдоль траектории
ТОЛЩИНА | Создание 3D тела посредством утолщения поверхности
ТОР | Создание 3D тела в форме тора
ЦИЛИНДР | Создает трехстороннее 3D тело с окружностью или эллипсом в основании и на верхней грани
ШАР | Создание 3D тела - шара
ЯЩИК | Создает 3D твердотельный параллелепипед (ящик)
Системные переменные
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
DRAGVS | Устанавливает визуальный стиль при создании 3D твердотельных примитивов и выдавленных тел и поверхностей.
FACETRES | Регулирует гладкость раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями
ISOLINES | Указывает количество линий контура для изображения поверхностей объектов
LOFTANG1 | Устанавливает черновой угол сквозь первое поперечное сечение в операции сечения
LOFTANG2 | Устанавливает черновой угол сквозь последнее поперечное сечение в операции сечения
LOFTMAG1 | Устанавливает величину чернового угла сквозь первое поперечное сечение в операции сечения
LOFTMAG2 | Устанавливает величину чернового угла сквозь последнее поперечное сечение в операции сечения
LOFTNORMALS | Управляет нормалями развернутого объекта в точках их прохода сквозь поперечные сечения
LOFTPARAM | Управляет очертанием развернутых тел и поверхностей
PSOLHEIGHT | Управляет значением высоты по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО
PSOLWIDTH | Управляет значением ширины по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО
SURFU | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности
SURFV | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор создания 3D тел и поверхностей - Понятия

Работа с 3D моделями
Создание 3D моделей
Обзор создания 3D тел и поверхностей
Понятия
Процедуры
Команды

Предусмотрена возможность создания базовых 3D форм (твердотельных примитивов): ящиков, конусов, цилиндров, шаров, клиньев, пирамид и торов (колец). Из этих форм путем их объединения, вычитания и пересечения строятся более сложные пространственные тела.

Можно также создавать 3D тела и поверхности на основе существующих объектов с помощью любого из следующих методов:

  • Выдавливание объектов.
  • Сдвиг объектов вдоль траектории.
  • Вращение объектов вокруг оси.
  • Сечение с помощью набора кривых.
  • Разрезание тела.
  • Преобразование плоских объектов, имеющих толщину, в тела и поверхности

Тела и поверхности отображаются в таком визуальном стиле, который применим для соответствующего видового экрана.

Для тел предусмотрена возможность анализировать свойства, присущие массе (объем, момент инерции, центр масс и т.п.). Данные о теле могут экспортироваться в такие приложения, как системы числового программного управления (ЧПУ) или анализа методом конечных элементов (МКЭ). Посредством расчленения тела его можно разделить на области, элементарные тела, поверхности и каркасные объекты.

Плотность линий кривизны, используемых для визуализации криволинейных элементов модели, определяется системной переменной ISOLINES. Системная переменная FACETRES задает степень сглаживания тонированных объектов с подавленными скрытыми линиями.

По умолчанию в 3D телах журнале регистрируются исходные профили 3D тел. Этот журнал позволяет видеть исходные формы, из которых получены составные тела. Дополнительные сведения о параметрах журнала для тел и поверхностей см. в разделе Отображение исходных форм составных тел.


Создание 3D тел и поверхностей

Работа с 3D моделями
Создание 3D моделей
Создание 3D тел и поверхностей
Понятия
Процедуры
Команды

Нет процедур.


Обзор создания 3D тел и поверхностей - Команды

Создание 3D моделей
Создание 3D моделей
Обзор создания 3D тел и поверхностей
Понятия
Процедуры
Команды

Команды
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
ВРАЩАТЬ | Создается 3D тело или поверхность вращением 2D объектов вокруг оси.
ВЫДАВИТЬ | Создание 3D тела или поверхности путем выдавливания объекта или плоской грани в заданном направлении и на заданное расстояние.
ВЫЧИТАНИЕ | Объединение выбранных областей или тел посредством вычитания
КЛИН | Построение трехмерного пятигранного тела с наклонной гранью, приближающейся к оси X.
КОНУС | Создает 3D тело с основанием в форме окружности или эллипса, симметрично суживающихся к точке, или к плоской грани в форме окружности или эллипса
ОБЪЕДИНЕНИЕ | Объединение выбранных областей или тел посредством сложения
ПЕРЕСЕЧЕНИЕ | Создает составные тела или области путем пересечения двух или более тел или областей и удаляет области снаружи пересечения.
ПИРАМИДА | Создается 3D тело пирамиды
ПОСЕЧЕНИЯМ | Создает 3D тела или поверхности путем сечений двумя или более кривыми.
ПРЕОБРВПВРХ | Преобразует объекты в поверхности
ПРЕОБРВТЕЛО | Преобразует полилинии и окружности, для которых задана высота, в 3D тела.
РАЗРЕЗ | Разрезание тел плоскостью или поверхностью
СДВИГ | Создание 3D тела или поверхности посредством сдвига 2D кривой вдоль траектории
ТОР | Создание 3D тела в форме тора
ЦИЛИНДР | Создает трехстороннее 3D тело с окружностью или эллипсом в основании и на верхней грани
ЯЩИК | Создает 3D твердотельный параллелепипед (ящик)
Системные переменные
FACETRES | Регулирует гладкость раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями
ISOLINES | Указывает количество линий контура для изображения поверхностей объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание 3D твердотельных примитивов - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание 3D твердотельных примитивов
Понятия
Процедуры
Команды

Предусмотрена возможность создания базовых твердотельных форм в виде ящика, конуса, цилиндра, шара, тора, клина и пирамиды. Эти формы называют твердотельными примитивами.

  • Создание ящиков
    Имеется возможность построить ящик. Основание ящика всегда вычерчивается параллельно плоскости XY текущей ПСК (плоскость построений).
  • Создание клиньев
    Имеется возможность построить клин.
  • Создание конусов
    Можно построить конус с круговым или эллиптическим основанием, суживающимся в точку. Также можно построить усеченный конус, который суживается в круговую или эллиптическую грань, параллельную основанию конуса.
  • Создание цилиндров
    Можно построить цилиндр с круговым или эллиптическим основанием.
  • Создание шаров
    Имеется возможность построить шар.
  • Создание пирамиды
    Имеется возможность построить пирамиду. Для пирамиды можно определить от 3 до 32 сторон.
  • Создание торов
    Для построения тела в виде кольца, напоминающего по форме камеру автомобильной шины, служит команда ТОР.


Создание 3D твердотельных примитивов - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание 3D твердотельных примитивов
Понятия
Процедуры
Команды

Создание ящика

Создание клина

Для построения конуса с круговым основанием

Для построения конуса с эллиптическим основанием

Создание усеченного конуса

Создание конуса с высотой и ориентацией, задаваемыми конечной точкой оси

Создание цилиндра с круговым основанием

Создание цилиндра с эллиптическим основанием

Создание цилиндра с высотой и ориентацией, задаваемыми конечной точкой оси

Создание шаров

Создание шара, определяемого тремя точками

Создание пирамиды

Создание усеченной пирамиды

Создание тора


Создание 3D твердотельных примитивов - Команды

Работа с 3D моделями
Создание 3D моделей
Создание 3D твердотельных примитивов
Понятия
Процедуры
Команды
Команды
КЛИН | Построение трехмерного пятигранного тела с наклонной гранью, приближающейся к оси X.
КОНУС | Создает 3D тело с основанием в форме окружности или эллипса, симметрично суживающихся к точке, или к плоской грани в форме окружности или эллипса
ПИРАМИДА | Создается 3D тело пирамиды
ТОР | Создание 3D тела в форме тора
ЦИЛИНДР | Создает трехстороннее 3D тело с окружностью или эллипсом в основании и на верхней грани
ШАР | Создание 3D тела - шара
ЯЩИК | Создает 3D твердотельный параллелепипед (ящик)
Системные переменные
DRAGVS | Устанавливает визуальный стиль при создании 3D твердотельных примитивов и выдавленных тел и поверхностей.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание ящиков - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание ящиков
Понятия
Процедуры
Команды

Имеется возможность построить ящик. Основание ящика всегда вычерчивается параллельно плоскости XY текущей ПСК (плоскость построений).

Для создания ящика с ребрами одинаковой длины можно воспользоваться параметром "Куб" команды ЯЩИК.

Если при построении ящика используется параметр "Куб" или "Длина", то при задании длины можно задать также угол поворота ящика в плоскости XY.

С помощью параметра "Центральная точка" можно построить ящик, задав конкретную центральную точку.


Создание ящика - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание ящиков
Понятия
Процедуры
Команды

Создание ящика

  1. Выберите меню "Рисование" » "Моделирование" » "Ящик".
  2. Укажите первый угол основания.
  3. Укажите противоположный угол основания.
  4. Задайте высоту.

Панель "Моделирование"

Ввод команды: ЯЩИК

Пульт управления: Панель "3D построения", "Ящик"


Создание ящиков - Команды

Создание 3D моделей
Создание 3D моделей
Создание ящиков
Понятия
Процедуры
Команды

Команды
ЯЩИК | Создает 3D твердотельный параллелепипед (ящик)
Системные переменные
DRAGVS | Устанавливает визуальный стиль при создании 3D твердотельных примитивов и выдавленных тел и поверхностей.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание клиньев - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание клиньев
Понятия
Процедуры
Команды

Имеется возможность построить клин.

Основание клина вычерчивается параллельно плоскости XY текущей ПСК, а наклонная грань располагается напротив первого указанного угла основания. Высота клина параллельна оси Z.

Параметр "Куб" команды КЛИН служит для построения клина с ребрами одинаковой длины.

Если при построении клина используется параметр "Куб" или "Длина", то при задании длины можно задать также угол поворота клина в плоскости XY.

С помощью параметра "Центральная точка" можно построить клин, задав конкретную центральную точку.


Создание клина - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание клиньев
Понятия
Процедуры
Команды

Создание клина

  1. Выберите меню "Рисование" » "Моделирование" » "Клин".
  2. Укажите первый угол основания.
  3. Укажите противоположный угол основания.
  4. Задайте высоту клина.

Панель "Моделирование"

Ввод команды: КЛИН

Пульт управления: Панель "3D построения", "Клин"


Создание клиньев - Команды

Создание 3D моделей
Создание 3D моделей
Создание клиньев
Понятия
Процедуры
Команды

Команды
КЛИН | Построение трехмерного пятигранного тела с наклонной гранью, приближающейся к оси X.
Системные переменные
DRAGVS | Устанавливает визуальный стиль при создании 3D твердотельных примитивов и выдавленных тел и поверхностей.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание конусов - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание конусов
Понятия
Процедуры
Команды

Можно построить конус с круговым или эллиптическим основанием, суживающимся в точку. Также можно построить усеченный конус, который суживается в круговую или эллиптическую грань, параллельную основанию конуса.

Показать: "Создание и изменение конуса"

Для запуска анимации нажмите стрелку "Просмотр". Дополнительные сведения об изменении конусов и других твердотельных примитивов см. в Манипулирование отдельными телами и поверхностями.

По умолчанию основание конуса располагается в плоскости XY текущей ПСК. Высота конуса параллельна оси Z.

Параметр "Конечная точка оси" команды КОНУС служит для определения высоты и ориентации конуса. Конечной точкой является вершина конуса или центр верхней грани, если используется параметр "Верхний радиус". Конечная точка оси может быть расположена в любом месте 3D пространства

Параметр "3Т" (три точки) команды КОНУС позволяет определить основание конуса, задавая три точки, расположенные в любом месте 3D пространства.

Параметр "Верхний радиус" команды КОНУС служит для построения усеченного конуса, суживающегося в эллиптическую или плоскую грань.

Для построения конического тела, определение сторон которого требует задания конкретного угла, начертите 2D круг, а затем с помощью команды ВЫДАВИТЬ и параметра "Угол конуса" задайте суживание к кругу, расположенному под углом к оси Z. Однако, этот метод обеспечивает построение выдавленного тела, а не подлинного примитива твердотельного конуса.


Создание конусов - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание конусов
Понятия
Процедуры
Команды

Для построения конуса с круговым основанием

Для построения конуса с эллиптическим основанием

Создание усеченного конуса

Создание конуса с высотой и ориентацией, задаваемыми конечной точкой оси


Для построения конуса с круговым основанием - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание конусов
Понятия
Процедуры
Команды

Для построения конуса с круговым основанием

  1. Выберите меню "Рисование" » "Моделирование" » "Конус".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. Задайте высоту конуса.

Панель "Моделирование"

Ввод команды: КОНУС

Пульт управления: Панель "3D построения", "Конус"


Для построения конуса с эллиптическим основанием - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание конусов
Понятия
Процедуры
Команды

Для построения конуса с эллиптическим основанием

  1. Выберите меню "Рисование" » "Моделирование" » "Конус".
  2. Введите э (эллиптический).
  3. Задайте конечную точку для первой оси. Это начальная точка первой оси.
  4. Задайте другую конечную точку первой оси. Это конечная точка первой оси.
  5. Задайте конечную точку (длину и угол поворота) второй оси.
  6. Задайте высоту конуса.

Панель "Моделирование"

Ввод команды: КОНУС

Пульт управления: Панель "3D построения", "Конус"


Создание усеченного конуса - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание конусов
Понятия
Процедуры
Команды

Создание усеченного конуса

  1. Выберите меню "Рисование" » "Моделирование" » "Конус".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. Введите в (верхний радиус).
  5. Задайте верхний радиус.
  6. Задайте высоту конуса.

Панель "Моделирование"

Ввод команды: КОНУС

Пульт управления: Панель "3D построения", "Конус"


Создание конуса с высотой и ориентацией, задаваемыми конечной точкой оси - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание конусов
Понятия
Процедуры
Команды

Создание конуса с высотой и ориентацией, задаваемыми конечной точкой оси

  1. Выберите меню "Рисование" » "Моделирование" » "Конус".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. В командной строке введите д.
  5. Задайте конечную точку оси конуса.

    6. Эта конечная точка может располагаться в любом месте 3D пространства.

Панель "Моделирование"

Ввод команды: КОНУС

Пульт управления: Панель "3D построения", "Конус"


Создание конусов - Команды

Создание 3D моделей
Создание 3D моделей
Создание конусов
Понятия
Процедуры
Команды

Команды
КОНУС | Создает 3D тело с основанием в форме окружности или эллипса, симметрично суживающихся к точке, или к плоской грани в форме окружности или эллипса
Системные переменные
DRAGVS | Устанавливает визуальный стиль при создании 3D твердотельных примитивов и выдавленных тел и поверхностей.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание цилиндров - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание цилиндров
Понятия
Процедуры
Команды

Можно построить цилиндр с круговым или эллиптическим основанием.

Для определения высоты и ориентации конуса служит параметр "Конечная точка оси" команды ЦИЛИНДР. Эта конечная точка является центральной точкой верхней грани цилиндра. Конечная точка оси может быть расположена в любом месте 3D пространства.

Параметр "3Т" (три точки) команды ЦИЛИНДР позволяет определить основание цилиндра, задавая три точки, расположенные в любом месте 3D пространства.

Если необходимо построить цилиндрическую форму со специальными деталями, например с пазами вдоль сторон, следует создать двухмерные контуры ее основания с помощью команды ПЛИНИЯ и воспользоваться командой ВЫДАВИТЬ для задания ее высоты вдоль оси Z. Однако этот метод обеспечивает построение выдавленного тела, а не подлинного примитива твердотельного цилиндра.


Создание цилиндров - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание цилиндров
Понятия
Процедуры
Команды

Создание цилиндра с круговым основанием

Создание цилиндра с эллиптическим основанием

Создание цилиндра с высотой и ориентацией, задаваемыми конечной точкой оси


Создание цилиндра с круговым основанием - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание цилиндров
Понятия
Процедуры
Команды

Создание цилиндра с круговым основанием

  1. Выберите меню "Рисование" » "Моделирование" » "Цилиндр".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. Задайте высоту цилиндра.

Панель "Моделирование"

Ввод команды: ЦИЛИНДР

Пульт управления: Панель "3D построения", "Цилиндр"


Создание цилиндра с эллиптическим основанием - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание цилиндров
Понятия
Процедуры
Команды

Создание цилиндра с эллиптическим основанием

  1. Выберите меню "Рисование" » "Моделирование" » "Цилиндр".
  2. Введите э (эллиптический).
  3. Задайте конечную точку для первой оси. Это начальная точка первой оси.
  4. Задайте другую конечную точку первой оси. Это конечная точка первой оси.
  5. Задайте конечную точку (длину и угол поворота) второй оси.
  6. Задайте высоту цилиндра.

Панель "Моделирование"

Ввод команды: ЦИЛИНДР

Пульт управления: Панель "3D построения", "Цилиндр"


Создание цилиндра с высотой и ориентацией, задаваемыми конечной точкой оси - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание цилиндров
Понятия
Процедуры
Команды

Создание цилиндра с высотой и ориентацией, задаваемыми конечной точкой оси

  1. Выберите меню "Рисование" » "Моделирование" » "Цилиндр".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. В командной строке введите д.
  5. Задайте конечную точку оси цилиндра.

    6. Эта конечная точка может располагаться в любом месте 3D пространства.

Панель "Моделирование"

Ввод команды: ЦИЛИНДР

Пульт управления: Панель "3D построения", "Цилиндр"


Создание цилиндров - Команды

Создание 3D моделей
Создание 3D моделей
Создание цилиндров
Понятия
Процедуры
Команды

Команды
ЦИЛИНДР | Создает трехстороннее 3D тело с окружностью или эллипсом в основании и на верхней грани
Системные переменные
DRAGVS | Устанавливает визуальный стиль при создании 3D твердотельных примитивов и выдавленных тел и поверхностей.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание шаров - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание шаров
Понятия
Процедуры
Команды

Имеется возможность построить шар.

При задании центральной точки шар размещается так, чтобы его центральная ось была параллельна оси Z текущей пользовательской системы координат (ПСК).

Для определения шара можно также использовать любой из следующих параметров команды SPHERE:

  • 3Т (три точки). Окружность шара определяется заданием трех точек, расположенных в произвольном месте 3D пространства. Три заданные точки определяют также плоскость окружности шара.
  • 2Т (две точки). Окружность шара определяется заданием двух точек, расположенных в произвольном месте 3D пространства. Плоскость окружности шара определяется координатой Z первой точки.
  • ККР (касательная, касательная, радиус). Шар определяется заданием радиуса, являющегося касательной для двух объектов. Указанные точки касания проецируются на текущую ПСК.


Создание шаров - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание шаров
Понятия
Процедуры
Команды

Создание шаров

Создание шара, определяемого тремя точками


Создание шаров - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание шаров
Понятия
Процедуры
Команды

Создание шаров

  1. Выберите меню "Рисование" » "Моделирование" » "Шар".
  2. Укажите центр шара.
  3. Задайте радиус или диаметр шара.

Панель "Моделирование"

Ввод команды: ШАР

Пульт управления: Панель "3D построения", "Шар"


Создание шара, определяемого тремя точками - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание шаров
Понятия
Процедуры
Команды

Создание шара, определяемого тремя точками

  1. Выберите меню "Рисование" » "Моделирование" » "Шар".
  2. Введите 3т.
  3. Укажите первую точку.
  4. Укажите вторую точку.
  5. Укажите третью точку.

Панель "Моделирование"

Ввод команды: ШАР

Пульт управления: Панель "3D построения", "Шар"


Создание шаров - Команды

Создание 3D моделей
Создание 3D моделей
Создание шаров
Понятия
Процедуры
Команды

Команды
ШАР | Создание 3D тела - шара
Системные переменные
DRAGVS | Устанавливает визуальный стиль при создании 3D твердотельных примитивов и выдавленных тел и поверхностей.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание пирамиды - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание пирамиды
Понятия
Процедуры
Команды

Имеется возможность построить пирамиду. Для пирамиды можно определить от 3 до 32 сторон.

Для задания расположения конечной точки оси пирамиды служит параметр "Конечная точка оси" команды ПИРАМИДА. Эта конечная точка является верхней точкой пирамиды или центром верхней грани, если используется параметр "Верхний радиус". Возможно расположение конечной точки оси в любом месте 3D пространства. Конечная точка оси определяет длину пирамиды и ее положение в пространстве.

Параметр "Верхний радиус" служит для построения усеченной пирамиды, суживающейся к плоской грани, имеющей такое же число сторон, как и основание.


Создание пирамиды - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание пирамиды
Понятия
Процедуры
Команды

Создание пирамиды

Создание усеченной пирамиды


Создание пирамиды - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание пирамиды
Понятия
Процедуры
Команды

Создание пирамиды

  1. Выберите меню "Рисование" » "Моделирование" » "Пирамида".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. Задайте высоту пирамиды.

Панель "Моделирование"

Ввод команды: ПИРАМИДА

Пульт управления: Панель "3D построения", "Пирамида"


Создание усеченной пирамиды - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание пирамиды
Понятия
Процедуры
Команды

Создание усеченной пирамиды

  1. Выберите меню "Рисование" » "Моделирование" » "Пирамида".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. Введите в (верхний радиус).
  5. Задайте верхний радиус.
  6. Задайте высоту пирамиды.

Панель "Моделирование"

Ввод команды: ПИРАМИДА

Пульт управления: Панель "3D построения", "Пирамида"


Создание пирамиды - Команды

Создание 3D моделей
Создание 3D моделей
Создание пирамиды
Понятия
Процедуры
Команды

Команды
ПИРАМИДА | Создается 3D тело пирамиды
Системные переменные
DRAGVS | Устанавливает визуальный стиль при создании 3D твердотельных примитивов и выдавленных тел и поверхностей.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание торов - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание торов
Понятия
Процедуры
Команды

Для построения тела в виде кольца, напоминающего по форме камеру автомобильной шины, служит команда ТОР.

Тор определяется двумя значениями радиусов. Одно значение задает радиус внутреннего прохода, а второе значение определяет расстояние от центра тора до центра внутреннего прохода.

Параметр "3Т" (три точки) команды ТОР служит для определения окружности тора посредством задания трех точек, расположенных в произвольном месте 3D пространства.

Тор вычерчивается параллельно плоскости XY текущей ПСК, рассекаемый ею пополам (это не обязательно выполняется при использовании параметра "3Т" [Три точки] команды ТОР).

Допускается построение самопересекающихся торов, т.е. торов, не имеющих центрального отверстия. Для этого нужно задавать радиус полости большим, чем радиус тора.


Создание тора - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание торов
Понятия
Процедуры
Команды

Создание тора

  1. Выберите меню "Рисование" » "Моделирование" » "Тор".
  2. Укажите центр тора.
  3. Задайте радиус или диаметр тора.
  4. Задайте радиус или диаметр полости тора.

Панель "Моделирование"

Ввод команды: ТОР

Пульт управления: Панель "3D построения", "Тор"


Создание торов - Команды

Создание 3D моделей
Создание 3D моделей
Создание торов
Понятия
Процедуры
Команды

Команды
ТОР | Создание 3D тела в форме тора
Системные переменные
DRAGVS | Устанавливает визуальный стиль при создании 3D твердотельных примитивов и выдавленных тел и поверхностей.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание политела - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание политела
Понятия
Процедуры
Команды

Политело вычерчивается точно так же, как и полилиния. По умолчанию у политела всегда прямоугольные контуры. Предусмотрено задание высоты и ширины политела. Для построения в модели стен служит команда ПОЛИТЕЛО.

С помощью команды ПОЛИТЕЛО можно построить политело на основе существующего отрезка, 2D полилинии, дуги или круга.

Показать: "Создание политела на основе полилинии"

Для запуска анимации нажмите стрелку "Просмотр".

Политело может содержать криволинейные сегменты, но контуры всегда являются прямоугольными по умолчанию.

При вычерчивании политела можно воспользоваться параметром "Дуга" для добавления в политело дуговых сегментов. Для замыкания тела между первой и последней указанными точками служит параметр "Замкнуть".

Системная переменная PSOLWIDTH задает ширину политела по умолчанию. Системная переменная PSOLHEIGHT задает высоту политела по умолчанию.

При построении политела на основе существующего объекта системная переменная DELOBJ определяет, должна ли траектория удаляться автоматически после построения политела, или должен выдаваться запрос на удаление объекта.

Политела представляют собой тела деформации (тела, вычерчиваемые посредством использования заданного контура вдоль указанной траектории) и на палитре "Свойства" отображаются как тела деформации.


Создание политела - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание политела
Понятия
Процедуры
Команды

Вычерчивание политела

Создание политела на основе существующего объекта


Вычерчивание политела - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание политела
Понятия
Процедуры
Команды

Вычерчивание политела

  1. Выберите меню "Рисование" » "Моделирование" » "Политело".
  2. Укажите начальную точку.
  3. Укажите следующую точку.
  4. Повторите шаг 3 для завершения построения требуемого тела.
  5. Нажмите клавишу ENTER.

Панель "Моделирование"

Ввод команды: ПОЛИТЕЛО

Пульт управления: Панель "3D построения", "Политело"


Создание политела на основе существующего объекта - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание политела
Понятия
Процедуры
Команды

Создание политела на основе существующего объекта

  1. Выберите меню "Рисование" » "Моделирование" » "Политело".
  2. Введите о, затем нажмите клавишу ENTER.
  3. Выберите отрезок, 2D полилинию, дугу или круг.

    4. После завершения построения тела исходный объект может быть удален или сохранен в зависимости от значения системной переменной DELOBJ.

Панель "Моделирование"

Ввод команды: ПОЛИТЕЛО

Пульт управления: Панель "3D построения", "Политело"


Создание политела - Команды

Создание 3D моделей
Создание 3D моделей
Создание политела
Понятия
Процедуры
Команды

Команды
ПОЛИТЕЛО | Создается 3D политело
Системные переменные
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
PSOLHEIGHT | Управляет значением высоты по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО
PSOLWIDTH | Управляет значением ширины по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание тел и поверхностей на основе отрезков и кривых - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание тел и поверхностей на основе отрезков и кривых
Понятия
Процедуры
Команды

Тела и поверхности можно строить на основе существующих отрезков и кривых. Эти объекты можно использовать для определения как контура, так и траектории для тела или поверхности.

  • Выдавливание объектов
    Тела и поверхности можно получать посредством выдавливания выбранных объектов. Для построения тела или поверхности на основе контура пересечения объекта служит команда ВЫДАВИТЬ.
  • Создание тела или поверхности посредством сдвига
    С помощью команды СДВИГ выполняется построение нового тела или поверхности посредством сдвига разомкнутой или замкнутой плоской кривой (контура) вдоль разомкнутой или замкнутой 2D или 3D траектории.
  • Создание тела или поверхности с помощью сечений
    С помощью команды ПОСЕЧЕНИЯМ выполняется построение 3D тела или поверхности посредством сечения (рисования тела или поверхности) с использованием двух или более кривых поперечного сечения.
  • Создание тела или поверхности с помощью вращения
    Команда ВРАЩАТЬ позволяет построить тело или поверхность с помощью вращения вокруг оси разомкнутых или замкнутых объектов. Вращаемые объекты определяют контур тела или поверхности.


Создание тел и поверхностей на основе отрезков и кривых - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тел и поверхностей на основе отрезков и кривых
Понятия
Процедуры
Команды

Выдавливание объекта

Выдавливание объекта вдоль траектории

Создание тела или поверхности посредством сдвига объекта вдоль траектории

Создание тела или поверхности по сечениям с использованием набора поперечных сечений

Вращение объектов вокруг оси


Создание тел и поверхностей на основе отрезков и кривых - Команды

Работа с 3D моделями
Создание 3D моделей
Создание тел и поверхностей на основе отрезков и кривых
Понятия
Процедуры
Команды
Команды
ВРАЩАТЬ | Создается 3D тело или поверхность вращением 2D объектов вокруг оси.
ВЫДАВИТЬ | Создание 3D тела или поверхности путем выдавливания объекта или плоской грани в заданном направлении и на заданное расстояние.
ПОСЕЧЕНИЯМ | Создает 3D тела или поверхности путем сечений двумя или более кривыми.
СДВИГ | Создание 3D тела или поверхности посредством сдвига 2D кривой вдоль траектории
Системные переменные
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
LOFTANG1 | Устанавливает черновой угол сквозь первое поперечное сечение в операции сечения
LOFTANG2 | Устанавливает черновой угол сквозь последнее поперечное сечение в операции сечения
LOFTMAG1 | Устанавливает величину чернового угла сквозь первое поперечное сечение в операции сечения
LOFTMAG2 | Устанавливает величину чернового угла сквозь последнее поперечное сечение в операции сечения
LOFTNORMALS | Управляет нормалями развернутого объекта в точках их прохода сквозь поперечные сечения
LOFTPARAM | Управляет очертанием развернутых тел и поверхностей
SURFU | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности
SURFV | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выдавливание объектов - Понятия

Работа с 3D моделями
Создание 3D моделей
Выдавливание объектов
Понятия
Процедуры
Команды

Тела и поверхности можно получать посредством выдавливания выбранных объектов. Для построения тела или поверхности на основе контура пересечения объекта служит команда ВЫДАВИТЬ.

Если осуществляется выдавливание замкнутого объекта, получается тело. Если осуществляется выдавливание незамкнутого объекта, получается поверхность.

Операцию выдавливания можно применить к следующим объектам и подобъектам:

  • отрезки
  • дуги
  • эллиптические дуги
  • двумерные полилинии
  • двумерные сплайны
  • круги
  • эллипсы
  • 3D грани
  • 2D фигуры
  • полосы
  • области
  • плоские поверхности
  • плоские грани на телах

Примечание Для выбора граней на телах нужно нажать и удерживать клавишу CTRL, а затем выбрать одну или несколько граней.

Невозможно получить операцией выдавливания следующие объекты.

  • Полилинии, имеющие пересекающиеся или самопересекающиеся сегменты
  • Объекты, заключенные в блок

Если заданная полилиния имеет ширину, эта ширина игнорируется, и полилиния выдавливается из центра своей траектории. Если выбранный объект имеет толщину, эта толщина игнорируется.

Для построения тела на основе контура с использованием отрезков или дуг служит параметр "Соединить" команды ПОЛРЕД, чтобы преобразовать их в единый объект полилинии. Перед использованием команды ВЫДАВИТЬ можно также преобразовать объекты в область.

При выдавливании объектов задаются любые из следующих параметров:

  • траектория
  • угол конуса
  • направление
задание траектории для тела выдавливания

Параметр "Траектор" служит для задания объекта в виде траектории для выдавливания. Для построения тела или поверхности контур выбранного объекта выдавливается вдоль выбранной траектории. Наилучшие результаты достигаются, если траектория лежит на или внутри границы выдавливаемого объекта.

Операция выдавливания отличается от операции сдвига. При выдавливании контура вдоль траектории, если она уже не пересекает контур, траектория перемещается к контуру. Затем контур сдвигается вдоль траектории.

Примечание Применение траектории в сочетании с командой СДВИГ обеспечивает большую степень контроля и достижение лучших результатов.

Тело выдавливания начинается в плоскости исходного контура и заканчивается в плоскости, перпендикулярной траектории в ее конечной точке.

Траекториями могут быть следующие объекты:

  • отрезки
  • круги
  • дуги
  • эллипсы
  • эллиптические дуги
  • двумерные полилинии
  • трехмерные полилинии
  • двумерные сплайны
  • трехмерные сплайны
  • грани тел
  • грани поверхностей
  • спирали
Задание угла конуса для тела выдавливания

Конусное выдавливание часто применяется при рисовании объектов с наклонными сторонами; например, литейных форм. Не рекомендуется задавать большие углы сужения. Если угол слишком большой, образующие конуса могут сойтись в одну точку до того, как будет достигнута требуемая глубина выдавливания.

Задание направления для тела выдавливания

Параметр "Направление" позволяет задать длину и направление выдавливания посредством указания двух точек.


Выдавливание объектов - Процедуры

Работа с 3D моделями
Создание 3D моделей
Выдавливание объектов
Понятия
Процедуры
Команды

Выдавливание объекта

Выдавливание объекта вдоль траектории


Выдавливание объекта - Процедуры

Работа с 3D моделями
Создание 3D моделей
Выдавливание объектов
Понятия
Процедуры
Команды

Выдавливание объекта

  1. Выберите меню "Рисование" » "Моделирование" » "Выдавить".
  2. Выберите объекты для выдавливания, затем нажмите клавишу ENTER.
  3. Задайте высоту.

    4. По завершении выдавливания исходные объекты удаляются или сохраняются, в зависимости от значения системной переменной DELOBJ.

Панель "Моделирование"

Ввод команды: ВЫДАВИТЬ

Пульт управления: Панель "3D построения", "Выдавить"


Выдавливание объекта вдоль траектории - Процедуры

Работа с 3D моделями
Создание 3D моделей
Выдавливание объектов
Понятия
Процедуры
Команды

Выдавливание объекта вдоль траектории

  1. Выберите меню "Рисование" » "Моделирование" » "Выдавить".
  2. Выберите объекты для выдавливания.
  3. Введите т (траектория), затем нажмите клавишу ENTER.
  4. Выберите объект для использования в качестве траектории.

    5. По завершении выдавливания исходные объекты удаляются или сохраняются, в зависимости от значения системной переменной DELOBJ.

Панель "Моделирование"

Ввод команды: ВЫДАВИТЬ

Пульт управления: Панель "3D построения", "Выдавить"


Выдавливание объектов - Команды

Создание 3D моделей
Создание 3D моделей
Выдавливание объектов
Понятия
Процедуры
Команды

Команды
ВЫДАВИТЬ | Создание 3D тела или поверхности путем выдавливания объекта или плоской грани в заданном направлении и на заданное расстояние.
Системные переменные
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
SURFU | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности
SURFV | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание тела или поверхности посредством сдвига - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание тела или поверхности посредством сдвига
Понятия
Процедуры
Команды

С помощью команды СДВИГ выполняется построение нового тела или поверхности посредством сдвига разомкнутой или замкнутой плоской кривой (контура) вдоль разомкнутой или замкнутой 2D или 3D траектории.

Командой СДВИГ вычерчивается тело или поверхность, имеющая форму с указанным контуром (объект сдвига) на протяжении указанной траектории. Команду СДВИГ можно использовать сразу для нескольких объектов при условии, что все они находятся в одной плоскости.

При сдвиге вдоль траектории замкнутой кривой получается тело.

Показать: "Сдвиг круга вдоль 3D траектории"

Для запуска анимации нажмите стрелку "Просмотр". Дополнительные сведения о построении и изменении спиралей см. в разделах Построение спиралей и Изменение спиралей.

При сдвиге вдоль траектории разомкнутой кривой получается поверхность.

Операция сдвига отличается от операции выдавливания. При выполнении сдвига контура вдоль траектории контур перемещается и устанавливается перпендикулярным к траектории. Затем контур сдвигается вдоль траектории.

Для выполнения сдвига контура, например замкнутой полилинии, вдоль спирали переместите или поверните контур на месте и отключите режим "Выравнивание" в команде СДВИГ. Если при моделировании возникает ошибка, следите за тем, чтобы результирующий объект не пересекал сам себя.

Во время выполнения сдвига объектов их можно закручивать или масштабировать. Также можно использовать палитру "Свойства" для задания следующих свойств контура после его сдвига.

  • Вращение профиля
  • Масштабирование вдоль траектории
  • Закручивание вдоль траектории
  • Крен (естественное вращение)

Примечание Изменение этих свойств на палитре "Свойства" невозможно, если режим "Выравнивание" был отключен при выполнении сдвига контура или если изменение приводит к ошибке моделирования, например самопересечению тела. Предупреждающее сообщение не отображается.

Можно сдвигать несколько объектов одновременно, но все они должны лежать в одной и той же плоскости.

При построении тела или поверхности сдвига можно использовать следующие объекты и траектории:

объекты для сдвига (контуры) | объекты, используемые в качестве траектории сдвига
отрезок | отрезок
дуга | дуга
эллиптическая дуга | эллиптическая дуга
2D полилиния | 2D полилиния
2D сплайн | 2D сплайн
круг | круг
эллипс | эллипс
3D грань | 3D сплайн
2D фигура | 3D полилиния
полоса | спираль
область | кромки тела или поверхности
плоская поверхность |
плоские грани тела |

Примечание Для выбора граней на телах нужно нажать и удерживать клавишу CTRL, а затем выбрать одну или несколько граней.

Системная переменная DELOBJ определяет, должны ли контур и траектория удаляться автоматически после построения тела или поверхности, или должен выдаваться запрос на удаление контура и траектории.

См. также

Построение спиралей


Создание тела или поверхности посредством сдвига объекта вдоль траектории - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тела или поверхности посредством сдвига
Понятия
Процедуры
Команды

Создание тела или поверхности посредством сдвига объекта вдоль траектории

  1. Выберите меню "Рисование" » "Моделирование" » "Сдвиг".
  2. Выберите объекты для сдвига.
  3. Нажмите клавишу ENTER.
  4. Выберите траекторию сдвига.

    5. По завершении сдвига исходные объекты удаляются или сохраняются, в зависимости от значения системной переменной DELOBJ.

Панель "Моделирование"

Ввод команды: СДВИГ

Пульт управления: Панель "3D построения", "Сдвиг"


Создание тела или поверхности посредством сдвига - Команды

Создание 3D моделей
Создание 3D моделей
Создание тела или поверхности посредством сдвига
Понятия
Процедуры
Команды

Команды
СДВИГ | Создание 3D тела или поверхности посредством сдвига 2D кривой вдоль траектории
Системные переменные
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
SURFU | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности
SURFV | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание тела или поверхности с помощью сечений - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание тела или поверхности с помощью сечений
Понятия
Процедуры
Команды

С помощью команды ПОСЕЧЕНИЯМ выполняется построение 3D тела или поверхности посредством сечения (рисования тела или поверхности) с использованием двух или более кривых поперечного сечения.

Поперечные сечения определяют контур (форму) результирующего тела или поверхности. Поперечные сечения (как правило, кривые или отрезки) могут быть разомкнутыми (например дуга) или замкнутыми (например круг). Командой ПОСЕЧЕНИЯМ выполняется построение тела или поверхности между поперечными сечениями. При использовании команды ПОСЕЧЕНИЯМ необходимо задать не менее двух поперечных сечений.

Если при построении используется набор замкнутых кривых поперечных сечений, получается тело.

Показать: "Создание тела по набору поперечных сечений"

Для запуска анимации нажмите стрелку "Просмотр".

Если при построении используется набор разомкнутых кривых поперечных сечений, получается поверхность.

Примечание Все кривые, используемые при построении по сечениям, должны быть либо разомкнутыми, либо замкнутыми. Не допускается использование набора кривых, содержащего одновременно разомкнутые и замкнутые кривые.

Для операции построения по сечениям можно задать траекторию. Задание траектории обеспечивает более высокую степень контроля формы тела или поверхности, построение которых выполняется по сечениям. Рекомендуется выбирать криволинейную траекторию, начинающуюся на плоскости первого поперечного сечения и заканчивающуюся на плоскости последнего поперечного сечения.

Кроме этого, при построении по сечениям можно задать направляющие. Использование направляющих обеспечивает другой способ контроля формы тела или поверхности, построение которых выполняется по сечениям. Направляющие позволяют контролировать соответствие точек на соответствующих поперечных сечениях для предотвращения нежелательных эффектов, например складок на результирующем теле или поверхности.

Все направляющие должны удовлетворять следующим критериям:

  • Пересекать все поперечные сечения.
  • Начинаться на первом поперечном сечении.
  • Заканчиваться на последнем поперченном сечении.

Для построения поверхности или тела по сечениям можно выбрать любое число направляющих.

Если при построении поверхности или тела по сечениям используются только поперечные сечения, контролировать форму поверхности или тела можно также с помощью параметров диалогового окна "Настройки сечений".

В следующей таблице приведены объекты, которые можно использовать при построении тела или поверхности по сечениям.

Объекты, используемые в качестве поперечных сечений | Объекты, используемые в качестве траектории для построения по сечениям | Объекты, используемые в качестве направляющих
Отрезок | Отрезок | Отрезок
Дуга | Дуга | Дуга
Эллиптическая дуга | Эллиптическая дуга | Эллиптическая дуга
2D полилиния | Сплайн | 2D сплайн
2D сплайн | Спираль | 3D сплайн
Круг | Круг | 2D полилиния
Эллипс | Эллипс | 3D полилиния
Точки (только первого и последнего поперечного сечения) | 2D полилиния |
 | 3D полилиния |

Системная переменная DELOBJ определяет, должны ли поперечные сечения, траектории и направляющие удаляться автоматически после построения тела или поверхности, или должен выдаваться запрос на удаление контуров и траектории.


Создание тела или поверхности по сечениям с использованием набора поперечных сечений - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тела или поверхности с помощью сечений
Понятия
Процедуры
Команды

Создание тела или поверхности по сечениям с использованием набора поперечных сечений

  1. Выберите меню "Рисование" » "Моделирование" » "По сечениям".
  2. Выберите поперечные сечения в том порядке, в котором тело или поверхность должны через них проходить.
  3. Нажмите клавишу ENTER.
  4. Выполните одно из следующих действий:
    • Нажмите клавишу ENTER или введите с, чтобы использовать только поперечные сечения.

      • Открывается диалоговое окно "Настройки сечений". Для контроля формы тела или поверхности воспользуйтесь параметрами этого диалогового окна. Задайте требуемые значения параметров и нажмите кнопку "Предварительный просмотр" для предварительного просмотра поверхности или тела.

      По завершении нажмите кнопку OK.

    • Введите н для выбора направляющих. Выберите направляющие, затем нажмите клавишу ENTER.
    • Введите т для выбора траектории. Выберите траекторию, затем нажмите клавишу ENTER.

    По завершении построения по сечениям исходные объекты могут быть удалены или сохранены, в зависимости от значения системной переменной DELOBJ.

Панель "Моделирование"

Ввод команды: ПОСЕЧЕНИЯМ

Пульт управления: Панель "3D построения", "По сечениям"


Создание тела или поверхности с помощью сечений - Команды

Создание 3D моделей
Создание 3D моделей
Создание тела или поверхности с помощью сечений
Понятия
Процедуры
Команды

Команды
ПОСЕЧЕНИЯМ | Создает 3D тела или поверхности путем сечений двумя или более кривыми.
Системные переменные
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
LOFTANG1 | Устанавливает черновой угол сквозь первое поперечное сечение в операции сечения
LOFTANG2 | Устанавливает черновой угол сквозь последнее поперечное сечение в операции сечения
LOFTMAG1 | Устанавливает величину чернового угла сквозь первое поперечное сечение в операции сечения
LOFTMAG2 | Устанавливает величину чернового угла сквозь последнее поперечное сечение в операции сечения
LOFTNORMALS | Управляет нормалями развернутого объекта в точках их прохода сквозь поперечные сечения
LOFTPARAM | Управляет очертанием развернутых тел и поверхностей
SURFU | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности
SURFV | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание тела или поверхности с помощью вращения - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание тела или поверхности с помощью вращения
Понятия
Процедуры
Команды

Команда ВРАЩАТЬ позволяет построить тело или поверхность с помощью вращения вокруг оси разомкнутых или замкнутых объектов. Вращаемые объекты определяют контур тела или поверхности.

При вращении замкнутого объекта получается тело. При вращении разомкнутого объекта получается поверхность.

Допускается одновременное вращение нескольких объектов.

При вращении объектов любую из следующих осей можно задать в качестве оси, вокруг которой должны вращаться объекты.

  • Ось, определяемая двумя точками, указанными пользователем
  • X - ось
  • Y - ось
  • Z - ось
  • Ось, определяемая объектом (параметр "Объект")

Применяя команду ВРАЩАТЬ, можно использовать следующие объекты:

вращаемые объекты | объекты, используемые в качестве оси вращения
отрезок | отрезок
дуга | линейный сегмент полилинии
эллиптическая дуга | линейная кромка поверхности
2D полилиния | линейная кромка тела
2D сплайн |
круг |
эллипс |
3D грани |
2D фигура |
полоса |
область |
плоская поверхность |
плоская грань тела |

Примечание Для выбора граней на телах нужно нажать и удерживать клавишу CTRL, а затем выбрать одну или несколько граней.

Если выполняется построение тела с использованием контура, состоящего из отрезков и дуг, соответствующих полилинии, то перед вызовом команды ВРАЩАТЬ их нужно преобразовать в единый объект полилинии с помощью параметра "Соединить" команды ПОЛРЕД. Если эти объекты не преобразовать в единую полилинию, при их вращении получается поверхность.

Команду ВРАЩАТЬ нельзя применять к объектам, входящим в блок или полилиниям, имеющим пересекающиеся или самопересекающиеся сегменты.


Вращение объектов вокруг оси - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тела или поверхности с помощью вращения
Понятия
Процедуры
Команды

Вращение объектов вокруг оси

  1. Выберите меню "Рисование" » "Моделирование" » "Вращать".
  2. Выберите объекты для вращения.
  3. Укажите начальную и конечную точку оси вращения.

    4. Точки нужно указывать так, чтобы вращаемый объект находился по одну сторону оси. Положительным направлением оси считается направление от первой точки ко второй.

  4. Задайте угол поворота.

Панель "Моделирование"

Ввод команды: ВРАЩАТЬ

Пульт управления: Панель "3D построения", "Вращать"


Создание тела или поверхности с помощью вращения - Команды

Создание 3D моделей
Создание 3D моделей
Создание тела или поверхности с помощью вращения
Понятия
Процедуры
Команды

Команды
ВРАЩАТЬ | Создается 3D тело или поверхность вращением 2D объектов вокруг оси.
Системные переменные
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
SURFU | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности
SURFV | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание тел и поверхностей на основе объектов - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание тел и поверхностей на основе объектов
Понятия
Процедуры
Команды

Поверхности можно создавать на основе существующих в чертеже объектов.

Команда ПРЕОБРВПВРХ позволяет преобразовывать в поверхности любой из следующих объектов:

  • 2D фигуры
  • области
  • фигуры
  • разомкнутые полилинии с нулевой шириной, имеющие высоту
  • отрезки, имеющие высоту
  • дуги, имеющие высоту
  • плоские 3D грани

С помощью команды РАСЧЛЕНИТЬ можно строить поверхности на основе 3D тел с искривленными гранями, например, на основе цилиндра.

Команда ПЛОСКПОВ используется для построения плоской поверхности. Воспользуйтесь одним из следующих методов:

  • Выберите один или несколько объектов, образующих одну или несколько замкнутых областей.
  • Укажите противоположные углы прямоугольника.

При задании углов поверхности она строится параллельно плоскости построений.

Команда ПРЕОБРВТЕЛО применяется для преобразования следующих объектов в 3D тела выдавливания:

  • широкие полилинии постоянной ширины, имеющие высоту
  • замкнутые полилинии нулевой ширины, имеющие высоту
  • круги, имеющие высоту

Примечание Нельзя использовать команду ПРЕОБРВТЕЛО для полилиний, содержащих вертикальные линии с нулевой шириной, или содержащих сегменты разной ширины.

Системная переменная DELOBJ определяет, должны ли выбранные пользователем объекты удаляться автоматически после построения поверхности, или должен выдаваться запрос на удаление объектов.


Создание тел и поверхностей на основе объектов - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тел и поверхностей на основе объектов
Понятия
Процедуры
Команды

Преобразование одного или нескольких объектов в поверхности

Создание плоской поверхности на основе существующего объекта

Создание плоской поверхности посредством задания углов поверхности

Преобразование объектов, имеющих высоту, в тела выдавливания


Преобразование одного или нескольких объектов в поверхности - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тел и поверхностей на основе объектов
Понятия
Процедуры
Команды

Преобразование одного или нескольких объектов в поверхности

  1. Выберите меню "Редактирование" » "3D операции" » "Преобразовать в поверхность".
  2. Выберите объекты для преобразования.
  3. Нажмите клавишу ENTER.

Ввод команды: ПРЕОБРВПВРХ

Пульт управления: Панель "3D построения" (нажмите кнопку мыши на значке, чтобы расширить панель), "Преобразовать в поверхность"


Создание плоской поверхности на основе существующего объекта - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тел и поверхностей на основе объектов
Понятия
Процедуры
Команды

Создание плоской поверхности на основе существующего объекта

  1. Выберите меню "Рисование" » "Моделирование" » "Плоская поверхность".
  2. Введите o.
  3. Выберите объект.
  4. Нажмите клавишу ENTER.

Панель "Моделирование"

Ввод команды: ПЛОСКПОВ

Пульт управления: Панель "3D построения", "Плоская поверхность"


Создание плоской поверхности посредством задания углов поверхности - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тел и поверхностей на основе объектов
Понятия
Процедуры
Команды

Создание плоской поверхности посредством задания углов поверхности

  1. Выберите меню "Рисование" » "Моделирование" » "Плоская поверхность".
  2. Укажите первый угол поверхности.
  3. Укажите второй угол поверхности.

Панель "Моделирование"

Ввод команды: ПЛОСКПОВ

Пульт управления: Панель "3D построения", "Плоская поверхность"


Преобразование объектов, имеющих высоту, в тела выдавливания - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тел и поверхностей на основе объектов
Понятия
Процедуры
Команды

Преобразование объектов, имеющих высоту, в тела выдавливания

  1. Выберите меню "Редактирование" » "3D операции" » "Преобразовать в тело".
  2. Выберите один или несколько из следующих типов объектов, имеющих высоту.
    • полилинии постоянной ширины
    • замкнутые полилинии нулевой ширины
    • круги
  3. Нажмите клавишу ENTER.

Ввод команды: ПРЕОБРВТЕЛО

Пульт управления: Панель "3D построения" (нажмите кнопку мыши на значке, чтобы расширить панель), "Преобразовать в тело"


Создание тел и поверхностей на основе объектов - Команды

Создание 3D моделей
Создание 3D моделей
Создание тел и поверхностей на основе объектов
Понятия
Процедуры
Команды

Команды
ПЛОСКПОВ | Создается плоская поверхность
ПРЕОБРВПВРХ | Преобразует объекты в поверхности
ПРЕОБРВТЕЛО | Преобразует полилинии и окружности, для которых задана высота, в 3D тела.
Системные переменные
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание тел на основе поверхностей - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание тел на основе поверхностей
Понятия
Процедуры
Команды

3D тело можно построить на основе поверхности любого типа путем ее утолщения.

Для преобразования поверхностей в тела служит команда ТОЛЩИНА.

Системная переменная DELOBJопределяет, удаляется ли выбранный пользователем объект автоматически после создания поверхности либо пользователю выводится запрос на удаление объекта.


Преобразование одной или нескольких поверхностей в тела - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тел на основе поверхностей
Понятия
Процедуры
Команды

Преобразование одной или нескольких поверхностей в тела

  1. Выберите меню "Редактирование" » "3D операции" » "Толщина".
  2. Выберите поверхности для утолщения.
  3. Нажмите клавишу ENTER.
  4. Задайте толщину для тела.
  5. Нажмите клавишу ENTER.

Ввод команды: ТОЛЩИНА

Пульт управления: Панель "3D построения", "Утолщение поверхности"


Создание тел на основе поверхностей - Команды

Создание 3D моделей
Создание 3D моделей
Создание тел на основе поверхностей
Понятия
Процедуры
Команды

Команды
ТОЛЩИНА | Создание 3D тела посредством утолщения поверхности
Системные переменные
DELOBJ | Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание составных тел - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание составных тел
Понятия
Процедуры
Команды

Составные тела создаются из двух и более индивидуальных тел с использованием любой из следующих команд: ОБЪЕДИНЕНИЕ,, ВЫЧИТАНИЕ и ПЕРЕСЕЧЕНИЕ (Для создания составных тел используются также команды СОПРЯЖЕНИЕ и ФАСКА).

По умолчанию для 3D тел в журнале регистрируются исходные профили 3D тел. Этот журнал позволяет видеть исходные формы, из которых получены составные тела. Дополнительные сведения о параметрах журнала для тел и поверхностей см. в разделе Отображение исходных форм составных тел.

С помощью команды ОБЪЕДИНЕНИЕ можно получить сложный объект, занимающий суммарный объем всех его составляющих.

С помощью команды ВЫЧИТАНИЕ из набора тел удаляются те части объема, которые принадлежат другому набору тел. Например, команду ВЫЧИТАНИЕ можно использовать для получения отверстий в механических деталях путем вычитания цилиндров из объектов.

С помощью команды ПЕРЕСЕЧЕНИЕ можно построить сложное тело, занимающее объем, являющийся общим для нескольких пересекающихся тел. Выполнение команды ПЕРЕСЕЧЕНИЕ приводит к удалению непересекающихся частей и построению сложного тела, состоящего из общего объема.


Создание составных тел - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание составных тел
Понятия
Процедуры
Команды

Объединение тел

Вычитание тел друг из друга

Создание тела путем пересечения двух или нескольких тел


Объединение тел - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание составных тел
Понятия
Процедуры
Команды

Объединение тел

  1. Выберите меню "Редактирование" » "Редактирование тела" » "Объединение".
  2. Выберите объединяемые объекты.
  3. Нажмите клавишу ENTER.

Панель "Редактирование тела"

Ввод команды: ОБЪЕДИНЕНИЕ

Пульт управления: Панель "3D построения", "Объединение"


Вычитание тел друг из друга - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание составных тел
Понятия
Процедуры
Команды

Вычитание тел друг из друга

  1. Выберите меню "Редактирование" » "Редактирование тела" » "Вычитание".
  2. Выберите объекты, из которых производится вычитание.
  3. Нажмите клавишу ENTER.
  4. Выберите объекты, которые вычитаются.
  5. Нажмите клавишу ENTER.

Панель "Редактирование тела"

Ввод команды: ВЫЧИТАНИЕ

Пульт управления: Панель "3D построения", "Вычитание"


Создание тела путем пересечения двух или нескольких тел - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание составных тел
Понятия
Процедуры
Команды

Создание тела путем пересечения двух или нескольких тел

  1. Выберите меню "Редактирование" » "Редактирование тела" » "Пересечение".
  2. Выберите пересекаемые объекты.
  3. Нажмите клавишу ENTER.

Панель "Редактирование тела"

Ввод команды: ПЕРЕСЕЧЕНИЕ

Пульт управления: Панель "3D построения", "Пересечение"


Создание составных тел - Команды

Создание 3D моделей
Создание 3D моделей
Создание составных тел
Понятия
Процедуры
Команды

Команды
ОБЪЕДИНЕНИЕ | Объединение выбранных областей или тел посредством сложения
ПЕРЕСЕЧЕНИЕ | Создает составные тела или области путем пересечения двух или более тел или областей и удаляет области снаружи пересечения.
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание тел путем разрезания - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание тел путем разрезания
Понятия
Процедуры
Команды

Новые тела могут быть получены разрезанием существующих тел. Существует ряд способов определения режущей плоскости, включая задание точек или выбор поверхности или плоского объекта.

Применяя команду РАЗРЕЗ для разрезания тела, можно сохранить одну или обе половины разрезанного тела. Разрезанные тела не несут в себе информации об исходных формах, из которых они получены. Разрезанные тела наследуют свойства слоя и цвета исходных тел.

По умолчанию используется метод разрезания, при котором задаются две точки, определяющие режущую плоскость, перпендикулярную к текущей ПСК, после чего выбирается сохраняемая сторона. Режущую плоскость можно определить также, задав три точки, используя поверхность, другой объект, текущий вид, ось Z или плоскость XY, YZ или ZX.

В качестве режущей плоскости можно использовать следующие объекты:

  • поверхности
  • круги
  • эллипсы
  • круговые или эллиптические дуги
  • двумерные сплайны
  • сегменты 2D полилиний

См. также

Создание 3D моделей


Создание тел путем разрезания - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тел путем разрезания
Понятия
Процедуры
Команды

Разрезание тел

Разрезание тел с помощью плоского объекта

Разрезание тел с помощью поверхности


Разрезание тел - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тел путем разрезания
Понятия
Процедуры
Команды

Разрезание тел

  1. Выберите меню "Редактирование" » "3D операции" » "Разрез".
  2. Выберите объекты для разрезания.
  3. Нажмите клавишу ENTER.
  4. Укажите две точки для определения режущей плоскости.
  5. Укажите, какая сторона сохраняется, или введите б для сохранения обеих сторон.

Ввод команды: РАЗРЕЗ

Пульт управления: Панель "3D построения" (нажмите значок, чтобы развернуть), "Разрез"


Разрезание тел с помощью плоского объекта - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тел путем разрезания
Понятия
Процедуры
Команды

Разрезание тел с помощью плоского объекта

  1. Выберите меню "Рисование" » "3D операции" » "Разрез".
  2. Выберите объекты для разрезания.
  3. Нажмите клавишу ENTER.
  4. В командной строке введите о.
  5. Нажмите клавишу ENTER.
  6. Выберите круг, эллипс, дугу, 2D сплайн или 2D полилинию для использования в качестве режущей плоскости.
  7. Укажите, какая сторона сохраняется, или введите б для сохранения обеих сторон.

Ввод команды: РАЗРЕЗ

Пульт управления: Панель "3D построения" (нажмите значок, чтобы развернуть), "Разрез"


Разрезание тел с помощью поверхности - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание тел путем разрезания
Понятия
Процедуры
Команды

Разрезание тел с помощью поверхности

  1. Выберите меню "Рисование" » "3D операции" » "Разрез".
  2. Выберите объекты для разрезания.
  3. Нажмите клавишу ENTER.
  4. В командной строке введите р.
  5. Нажмите клавишу ENTER.
  6. Выберите поверхность для использования в качестве режущей плоскости.
  7. Укажите, какая сторона сохраняется, или введите б для сохранения обеих сторон.

Ввод команды: РАЗРЕЗ

Пульт управления: Панель "3D построения" (нажмите значок, чтобы развернуть), "Разрез"


Создание тел путем разрезания - Команды

Создание 3D моделей
Создание 3D моделей
Создание тел путем разрезания
Понятия
Процедуры
Команды

Команды
РАЗРЕЗ | Разрезание тел плоскостью или поверхностью
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Проверка взаимодействий в твердотельной модели - Понятия

Работа с 3D моделями
Создание 3D моделей
Проверка взаимодействий в твердотельной модели
Понятия
Процедуры
Команды

Команда ВЗАИМОД позволяет проверить взаимодействия (областей пересечения или перекрытия 3D тел) внутри твердотельной модели путем сравнения двух наборов объектов или попарного сравнения всех тел.

Команду ВЗАИМОД можно применять также к блокам, содержащим 3D тела, и к телам, вложенным в блоки.

При использовании команды ВЗАИМОД создаются временные тела и выделяются области пересечения тел.

Если задан один набор выбора (один набор объектов), команда ВЗАИМОД определяет области пересечения всех пар тел. Если задано два набора выбора (два набора объектов), команда ВЗАИМОД определяет области пересечения тел из первого набора с телами из второго.

Запустив проверку взаимодействий, можно в диалоговом окне "Проверка взаимодействий" циклически переключаться между объектами взаимодействий и выполнять их масштабирование. Предусмотрена возможность задания удаления при закрытии диалогового окна временных объектов взаимодействий, построенных во время проверки взаимодействий.

Отображение объектов взаимодействий настраивается с помощью параметров диалогового окна "Параметры взаимодействий".


Проверка взаимодействий в твердотельной модели - Процедуры

Работа с 3D моделями
Создание 3D моделей
Проверка взаимодействий в твердотельной модели
Понятия
Процедуры
Команды

Проверка взаимодействий в твердотельной модели

Изменение отображения объектов взаимодействия


Проверка взаимодействий в твердотельной модели - Процедуры

Работа с 3D моделями
Создание 3D моделей
Проверка взаимодействий в твердотельной модели
Понятия
Процедуры
Команды

Проверка взаимодействий в твердотельной модели

  1. Выберите меню "Редактирование" » "3D операции" » "Проверка взаимодействий".
  2. Выберите в модели первый набор объектов.
  3. Нажмите клавишу ENTER.
  4. Выберите в модели второй набор объектов.
  5. Нажмите клавишу ENTER.

    6. Отображается диалоговое окно "Проверка взаимодействий".

  6. (Дополнительно) В диалоговом окне "Проверка взаимодействий" для циклического переключения между объектами взаимодействия нажимайте кнопки "Следующий" и "Предыдущий".
  7. (Дополнительно) Чтобы объекты взаимодействия не удалялись при закрытии диалогового окна "Проверка взаимодействий", отмените выбор режима "При закрытии удалить созданные объекты взаимодействий".
  8. Нажмите кнопку "Закрыть".

    9. Объекты взаимодействия удаляются, если выбран режим "При закрытии удалить объекты взаимодействий".

Ввод команды: ВЗАИМОД

Пульт управления: Панель "3D построения" (нажмите левую кнопку мыши на значке, чтобы развернуть), "Проверка взаимодействий"


Изменение отображения объектов взаимодействия - Процедуры

Работа с 3D моделями
Создание 3D моделей
Проверка взаимодействий в твердотельной модели
Понятия
Процедуры
Команды

Изменение отображения объектов взаимодействия

  1. Выберите меню "Редактирование" » "3D операции" » "Проверка взаимодействий".
  2. Введите р.
  3. Нажмите клавишу ENTER.
  4. В диалоговом окне "Параметры взаимодействий" измените значение любого параметра.
  5. Нажмите "ОК".

Ввод команды: ВЗАИМОД

Пульт управления: Панель "3D построения" (нажмите левую кнопку мыши на значке, чтобы развернуть), "Проверка взаимодействий"


Проверка взаимодействий в твердотельной модели - Команды

Создание 3D моделей
Создание 3D моделей
Проверка взаимодействий в твердотельной модели
Понятия
Процедуры
Команды

Команды
ВЗАИМОД | Подсвечивает накладывающиеся друг на друга 3D тела
Системные переменные
INTERFERECOLOR | Устанавливает цвет объектов взаимодействия
INTERFEREOBJVS | Устанавливает стиль отображения объектов взаимодействия
INTERFEREVPVS | Задает стиль отображения видового экрана во время проверки пространственных взаимодействий
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание сетей - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание сетей
Понятия
Процедуры
Команды

Имеется возможность создания многоугольных сетчатых форм. Так как грани сети являются плоскими, представление криволинейных поверхностей производится путем их аппроксимации.

Моделирование объектов с помощью сетей применяется в случаях, когда можно игнорировать их физические свойства, такие как масса, объем, центр масс, момент инерции и т.п. (они сохраняются только в твердотельных моделях), но желательно иметь возможность подавления скрытых линий, раскрашивания и тонирования (эти средства неприменимы к каркасным моделям).

Сети применяются также для создания геометрии с необычными образцами сетей, например, 3D топологическая модель горной местности.

Способ отображения сети (каркасная или раскрашенная) определяется визуальным стилем (команда ВИЗСТИЛИ).

Предусмотрено создание нескольких типов сетей.

  • 3D грань. 3DГРАНЬ предназначена для построения плоской сети с тремя или четырьмя сторонами.
  • Сеть соединения. Команда П-СОЕД предназначена для построения многоугольной сети в виде линейчатой поверхности между двумя отрезками или кривыми.
  • Сеть сдвига. С помощью команды П-СДВИГ создается многоугольная сеть, представляющая собой поверхность сдвига, полученную при выдавливании отрезка или кривой (именуемой криволинейной траекторией) в определенном направлении и на определенное расстояние (именуемое направляющим вектором).
  • Сеть вращения. С помощью команды П-ВРАЩ создается многоугольная сеть, аппроксимирующая поверхность вращения путем вращения криволинейной траектории вокруг выбранной оси. Определяющие кривые могут представлять собой отрезки, круги, дуги, эллипсы, эллиптические дуги, полилинии, сплайны, замкнутые полилинии, многоугольники, замкнутые сплайны или кольца.
  • Сеть, определенная кромкойКомандаП-КРОМКА строит многоугольную сеть, аппроксимирующую участок поверхности Кунса по четырем смыкающимся кромкам. Поверхность Кунса - это бикубическая поверхность, натянутая на четыре смыкающиеся кромки (пространственные кривые).
  • Стандартная 3D сеть. С помощью команды 3D создаются трехмерные сетевые объекты распространенных геометрических форм, включая параллелепипеды, конусы, сферы, торы, клинья и пирамиды.
  • Общие сети. 3DСЕТЬ и ПГРАНЬ позволяют создавать трехмерные сетевые объекты любой формы.
Построение сети

Плотность сети регулирует количество ячеек и задается матрицей с вершинами M и N, подобно сетке, состоящей из рядов и столбцов. Для сети значения M и N определяют соответственно ряд и столбец каждой вершины.

Сети могут быть разомкнутыми и замкнутыми. Сеть будет открыта в заданном направлении, если начальная и конечная кромки сети не соприкасаются, как показано на следующих иллюстрациях.

Существует несколько способов построения сетей.

Создание сети соединения

Сеть, соединяющую два отрезка или кривые, строится с помощью команды П-СОЕД. Для определения кромок сети соединения можно использовать два различных объекта: отрезки, точки, дуги, круги, эллипсы, эллиптические дуги, 2D или 3D полилинии, а также сплайны. Оба объекта, используемые в качестве “границ” сети соединения, должны быть либо разомкнуты, либо замкнуты. Если один из объектов - точка, то второй может быть как разомкнутым, так и замкнутым.

При выполнении команды П-СОЕД для замкнутых кривых можно задавать две произвольные точки. В случае разомкнутых кривых построение сети соединения определяется выбором местоположения заданных точек на кривых.

Создание сети сдвига

Сеть, представляющая общую поверхность сдвига, задаваемую криволинейной траекторией и направляющим вектором, строится командой П-СДВИГ. Криволинейная траектория может представлять собой отрезок, дугу, круг, эллипс, эллиптическую дугу, 2D или 3D полилинию, а также сплайн. Осью вращения может быть отрезок или разомкнутая полилиния (как 2D, так и 3D). Сеть, построенная командой П-СДВИГ, представляет собой набор параллельных многоугольников, идущих вдоль указанной траектории. Как показано на следующих иллюстрациях, исходный объект и направляющий вектор должны существовать на чертеже к моменту вызова команды.

Создание сети вращения

Для построения сети вращения путем вращения контура объекта вокруг оси используется команда П-ВРАЩ. Команда П-ВРАЩ полезна для построения сетей с осевой симметрией.

Контур называется криволинейной траекторией, которая может представлять собой любую комбинацию отрезков, кругов, дуг, эллипсов, эллиптических дуг, полилиний, сплайнов, замкнутых полилиний, многоугольников, замкнутых сплайнов или колец.

Создание сети, определенной кромкой

Сеть в виде участка поверхности Кунса, определяемая четырьмя кромками, строится командой П-КРОМКА. Кромки могут представлять собой дуги, отрезки, полилинии, сплайны или эллиптические дуги; они должны попарно смыкаться в конечных точках. Участок поверхности Кунса это бикубическая (т.е. обладающая кубической кривизной как в направлении M, так и в направлении N) поверхность, натянутая на четыре пространственные кривые.

Создание стандартной трехмерной сети

С помощью команды 3D можно создавать следующие 3D фигуры: ящики, конусы, чаши, купола, сети, пирамиды, сферы, торы (кольца) и клинья.

Для лучшего рассмотрения объектов, создаваемых с помощью команды 3D, следует задать направление просмотра, используя команды 3DОРБИТА, ДВИД и ТЗРЕНИЯ.

На приведенных ниже иллюстрациях цифрами обозначены последовательности точек, задаваемых для построения сети.

Создание сети из четырехугольных ячеек

Команда 3DСЕТЬ позволяет строить полигональные сети, разомкнутые как в направлении M, так и в направлении N (по аналогии с осями X и Y плоскости XY). Замкнуть сеть можно с помощью команды ПОЛРЕД. Для построения несимметричных сетей используется команда 3DСЕТЬ. В большинстве случаев команда 3DСЕТЬ применяется в комбинации с командными (пакетными) файлами AutoCAD или LISP-программами, передающими в нее координаты вершин сети.

Следующий пример иллюстрирует создание сети путем ввода пользователем координат всех ее вершин.

Пример:

Команда: 3dсеть

Размер сети в направлении M: 4

Размер сети в направлении N: 3

Вершина (0, 0): 10,1, 3

Вершина (0, 1): 10, 5, 5

Вершина (0, 2): 10,10, 3

Вершина (1, 0): 15,1, 0

Вершина (1, 1): 15, 5, 0

Вершина (1, 2): 15,10, 0

Вершина (2, 0): 20,1, 0

Вершина (2, 1): 20, 5, -1

Вершина (2, 2): 20,10 ,0

Вершина (3, 0): 25,1, 0

Вершина (3, 1): 25, 5, 0

Вершина (3, 2): 25,10, 0

Создание многогранной сети

Многогранные сети строятся командой ПГРАНЬ. Команда ПГРАНЬ чаще всего используется приложениями, а не напрямую пользователем.

Создание многогранной сети производится аналогично сети из четырехугольных ячеек. Вначале вводятся все вершины сети. Затем производится описание граней путем ввода номеров вершин, образующих каждую грань. В ходе построения сети можно изменять видимость кромок граней, а также устанавливать слои и цвета для их рисования.

Для того чтобы сделать кромку невидимой, перед номером вершины при описании грани ставится знак минус. Например, если нужно сделать невидимой кромку между точками 5 и 7 сети, следует ввести:

грань 3, вершина 3: -7

На следующем чертеже грань 1 определяется вершинами 1, 5, 6 и 2; грань 2 - вершинами 1, 4, 3 и 2; грань 3 - вершинами 1, 4, 7 и 5; грань 4 - вершинами 3, 4, 7 и 8.

Изображение на чертеже невидимых кромок граней определяется системной переменной ПСПЛАЙН. Если ее значение не равно нулю, невидимые кромки становится видимыми и доступны для редактирования. Если же переменная равна нулю, невидимые кромки не отображаются.


Создание сетей - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание сетей
Понятия
Процедуры
Команды

Для построения сети из четырехугольных ячеек

Создание сети соединения

Создание сети сдвига

Создание сети вращения

Для построения сети в виде участка поверхности Кунса, заданной кромками


Для построения сети из четырехугольных ячеек - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание сетей
Понятия
Процедуры
Команды

Для построения сети из четырехугольных ячеек

  1. Выберите меню "Рисование" » "Моделирование" » "Сети" » "3D сеть".
  2. Задайте величину M с помощью целого числа от 2 до 256.
  3. Задайте величину N с помощью целого числа от 2 до 256.
  4. Введите в ответ на подсказки координаты вершин сети. После задания последней вершины построение сети завершается.

Ввод команды: 3DСЕТЬ


Создание сети соединения - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание сетей
Понятия
Процедуры
Команды

Создание сети соединения

  1. Выберите меню "Рисование" » "Моделирование" » "Сети" » "Сеть соединения".
  2. Выберите первую определяющую кривую. Затем выберите вторую кривую.
  3. Если необходимо, сотрите исходную кривую.

Ввод команды: П-СОЕД


Создание сети сдвига - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание сетей
Понятия
Процедуры
Команды

Создание сети сдвига

  1. Выберите меню "Рисование" » "Моделирование" » "Сети" » "Сеть сдвига".
  2. Укажите криволинейную траекторию.
  3. Укажите направляющий вектор.
  4. Если необходимо, сотрите исходные объекты.

Ввод команды: П-СДВИГ


Создание сети вращения - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание сетей
Понятия
Процедуры
Команды

Создание сети вращения

  1. Выберите меню "Рисование" » "Моделирование" » "Сети" » "Сеть вращения".
  2. Укажите криволинейную траекторию.

    3. Криволинейная траектория, задающая направление N для сети, может быть отрезком, дугой, кругом, эллипсом, эллиптической дугой, 2D полилинией, 3D полилинией или сплайном. При выборе круга, замкнутого эллипса или замкнутой полилинии сеть будет замкнута в направленииN.

  3. Укажите ось вращения.

    4. Осью вращения может быть отрезок или разомкнутая полилиния (как 2D, так и 3D). Если указана полилиния, ось проводится между ее начальной и конечной точками; Все промежуточные вершины игнорируются. Ось вращения задает направление M сети.

  4. Задайте начальный угол. Затем задайте центральный угол.

    5. Если начальный угол не равен нулю, сеть будет построена со смещением от криволинейной траектории на величину этого угла. Центральный угол задает угол поворота кривой вокруг оси вращения.

  5. Если необходимо, сотрите исходные объекты.

Ввод команды: П-ВРАЩ


Для построения сети в виде участка поверхности Кунса, заданной кромками - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание сетей
Понятия
Процедуры
Команды

Для построения сети в виде участка поверхности Кунса, заданной кромками

  1. Выберите меню "Рисование" » "Моделирование" » "Сети" » "Сеть по кромке".
  2. Выберите в любом порядке четыре кромки.

    3. Первая из выбранных кромок определяет направление M сети.

Ввод команды: П-КРОМКА


Создание сетей - Команды

Создание 3D моделей
Создание 3D моделей
Создание сетей
Понятия
Процедуры
Команды

Команды
3D | Создание трехмерных объектов в виде полигональных сетей распространенных геометрических форм, которые можно скрыть, раскрасить или тонировать
3DГРАНЬ | Создает трех- или четырехстороннюю поверхность в любом месте 3D пространства
3DСЕТЬ | Построение полигональных сетей произвольной формы
П-ВРАЩ | Создается сеть вращения вокруг выбранной оси.
ПГРАНЬ | Создание трехмерной многогранной сети по вершинам.
П-КРОМКА | Построение трехмерных полигональных сетей
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
П-СДВИГ | Создание сети сдвига на основе определяющей кривой и вектора направления
П-СОЕД | Создается сеть соединений между двумя кривыми
Системные переменные
FACETRATIO | Управляет плотностью сетевого представления цилиндрических и конических тел
PFACEVMAX | Устанавливает максимальное число вершин на одну грань
SURFTAB1 | Задает число интервалов, генерируемых командами П-СОЕД и П-СДВИГ
SURFTAB2 | Задает плотность сети в направлении N для команд П-ВРАЩ и П-КРОМКА
SURFTYPE | Управляет типом поверхности сглаживания, которая используется командой ПОЛРЕД (параметр "Сплайн")
SURFU | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности
SURFV | Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание каркасных моделей - Понятия

Работа с 3D моделями
Создание 3D моделей
Создание каркасных моделей
Понятия
Процедуры
Команды

Каркасная модель представляет собой скелетное описание 3D объекта, состоящее из отрезков и кривых.

Использование каркасных моделей позволяет:

  • Рассматривать модели из любой точки.
  • Автоматически генерировать ортогональные и дополнительные виды.
  • Легко генерировать расчлененные и перспективные виды.
  • Рассматривать взаимное расположение элементов в пространстве, оценивать кратчайшие расстояния между вершинами и ребрами и т.д.
  • Сократить число необходимых исходных элементов модели.

Каркасные модели состоят только из точек, отрезков и кривых, описывающих кромки объекта. Поскольку каждый из составляющих такую модель объектов должен рисоваться и размещаться независимо от других, затраты времени на моделирование часто бывают крайне велики.

Для создания каркасной геометрии на основе областей и 3D тел и поверхностей используется команда ИЗВЛРЕБРА. Команда ИЗВЛРЕБРА извлекает все ребра на выбранных объектах или подобъектах.

Советы по работе с каркасными моделями

Создание каркасных 3D моделей является более трудоемким процессом, чем построение их двумерных проекций. В связи с этим рекомендуется следовать следующим инструкциям, позволяющим повысить эффективность работы:

  • Спланировать послойную структуру создаваемой модели таким образом, чтобы можно было упрощать выводимую модель отключением тех или иных слоев. Использовать цвета для идентификации объектов на различных видах.
  • Использовать вспомогательные элементы для оценки формы модели.
  • Использовать несколько видов, особенно изометрические, для визуализации модели и упрощения выбора объектов.
  • Изучить управление ПСК в 3D пространстве. Плоскость XY текущей ПСК является плоскостью построений, которая задает ориентацию плоских объектов, таких как круги и дуги. ПСК также определяет плоскость для выполнения операций обрезки, удлинения, смещения и поворота объектов.
  • Использовать режимы объектной и шаговой привязки для обеспечения точности построения модели.
  • Использовать координатные фильтры для построения перпендикуляров и указания точек в трехмерном пространстве на основе координат точек имеющихся объектов.
Способы построения каркасных моделей

Имеется возможность создавать каркасные модели путем размещения плоских 2D объектов в любом месте 3D пространства. Для этого предлагаются следующие способы:

  • Ввод значений 3D точек. Ввод значений 3D точек (с координатами X, Y и Z) в ходе построения объекта.
  • Задание плоскости построений по умолчанию (т.е. плоскости XY ПСК) для рисования объекта.
  • Перемещение или копирование созданного 2D объекта для задания его пространственной ориентации.

Каркасное моделирование требует определенных навыков, приобретаемых в процессе практической работы. Для освоения каркасного моделирования лучше начинать с построения простых моделей с последующим переходом на более сложные.


Создание каркасных моделей - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание каркасных моделей
Понятия
Процедуры
Команды

Построение перпендикуляра из 3D точки к плоскости XY

Создание каркасной геометрии посредством извлечения ребер


Построение перпендикуляра из 3D точки к плоскости XY - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание каркасных моделей
Понятия
Процедуры
Команды

Построение перпендикуляра из 3D точки к плоскости XY

  1. Выберите в меню "Рисование" » "Отрезок".
  2. Используйте объектную привязку для указания точки на объекте, расположенном вне плоскости XY ПСК.

    3. Указанная точка определяет первую точку для построения отрезка.

  3. Введите .xy, затем введите @ на запрос командной строки.

    4. Этим действием извлекаются координатные значения X и Y первой точки.

  4. Введите 0 для указания оставшегося значения Z.

    5. С помощью координатного фильтра значения X и Y, извлеченные из координат первой точки, объединяются с указанным значением Z (0).

  5. Нажмите ENTER для завершения команды.


Создание каркасной геометрии посредством извлечения ребер - Процедуры

Работа с 3D моделями
Создание 3D моделей
Создание каркасных моделей
Понятия
Процедуры
Команды

Создание каркасной геометрии посредством извлечения ребер

  1. Выберите меню "Редактирование" » "3D операции" » "Извлечь ребра".
  2. Выберите любую комбинацию из следующих объектов:
    • тела
    • поверхности
    • области
    • ребра (на 3D телах или поверхностях)
    • грани (на 3D телах или поверхностях)
  3. Нажмите клавишу ENTER.

Ввод команды: ИЗВЛРЕБРА


Создание каркасных моделей - Команды

Создание 3D моделей
Создание 3D моделей
Создание каркасных моделей
Понятия
Процедуры
Команды

Команды
ИЗВЛРЕБРА | Создание геометрии каркаса посредством извлечения ребер из 3D тела или поверхности
ПСК | Управление пользовательскими системами координат
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание трехмерной высоты объектов - Понятия

Работа с 3D моделями
Создание 3D моделей
Задание трехмерной высоты объектов
Понятия
Процедуры
Команды

Задание высоты объектов позволяет моделировать объем.

3D высотой объекта называется расстояние, на которое объект выдавлен выше или ниже своего уровня. Положительная высота означает выдавливание вверх (в положительном направлении оси Z), отрицательная выдавливание вниз (в отрицательном направлении оси Z), нулевая -рисование без выдавливания. Нулевая (0) высота означает отсутствие высоты объекта 3D. Направление Z определяет ориентацию создаваемого объекта относительно ПСК. Объекты, обладающие ненулевой высотой, можно раскрашивать. Они могут также скрывать другие объекты, расположенные позади.

Заданием высоты можно изменять внешний вид таких объектов, как:

  • 2D фигуры
  • дуги
  • круги
  • отрезки
  • полилинии (включая сглаженные сплайнами полилинии, прямоугольники, многоугольники, контуры и кольца)
  • текст (только однострочный текстовый объект, созданный с использованием шрифта SHX)
  • полосы
  • точки

Попытки изменения высоты других объектов не дают никакого эффекта.

Имеется возможность установить значение высоты для вновь создаваемых объектов с помощью системной переменной THICKNESS. Высоту уже имеющихся объектов можно изменять в палитре свойств. Задание трехмерной высоты относится к объекту как целому: различные его точки не могут иметь различные высоты.

Для наглядного просмотра объектов, обладающих ненулевой высотой, может понадобиться изменение положения точки зрения на 3D виде.

См. также

Создание тел и поверхностей на основе объектов


Задание трехмерной высоты объектов - Процедуры

Работа с 3D моделями
Создание 3D моделей
Задание трехмерной высоты объектов
Понятия
Процедуры
Команды

Для задания 3D высоты вновь создаваемых объектов

Для изменения 3D высоты существующих объектов


Для задания 3D высоты вновь создаваемых объектов - Процедуры

Работа с 3D моделями
Создание 3D моделей
Задание трехмерной высоты объектов
Понятия
Процедуры
Команды

Для задания 3D высоты вновь создаваемых объектов

  1. Выберите в меню "Формат" » "Высота".
  2. В командной строке введите значение высоты.

    3. Новые объекты создаются с заданной 3D высотой.

Ввод команды: ВЫСОТА


Для изменения 3D высоты существующих объектов - Процедуры

Работа с 3D моделями
Создание 3D моделей
Задание трехмерной высоты объектов
Понятия
Процедуры
Команды

Для изменения 3D высоты существующих объектов

  1. Выберите объекты, 3D высоту которых необходимо изменить.
  2. Нажмите правую кнопку мыши на одном из объектов. Выберите "Свойства".
  3. На палитре "Свойства" выберите "Высота" и задайте новое значение высоты.

    4. Выбранные объекты отображаются с заданной 3D высотой.

Панель "Стандартная"

Ввод команды: ОКОНСВ


Задание трехмерной высоты объектов - Команды

Создание 3D моделей
Создание 3D моделей
Задание трехмерной высоты объектов
Понятия
Процедуры
Команды

Команды
УРОВЕНЬ | Задание уровня и трехмерной высоты для вновь создаваемых объектов
Системные переменные
BACKZ | Сохранение смещения задней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа).
FRONTZ | Сохраняет смещение передней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа)
VIEWMODE | Сохраняет режим "Вид" для текущего видового экрана
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение 3D тел и поверхностей - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Понятия
Процедуры
Команды

После создания модели тела можно вручную изменять форму его отображения, вручную управляя телами и поверхностями множеством способов, включая нажатие и перетаскивание ручек, использование блоков захвата и изменение свойств объектов с помощью палитры свойств.

  • Манипулирование 3D телами и поверхностями
    Для изменения форм и размеров тел и поверхностей можно использовать ручки или палитру "Свойства". Возможности манипулирования телом или поверхностью определяются типом тела или поверхности и способом их создания.
  • Выбор и редактирование 3D подобъектов
    Имеется возможность выбора и редактирования подобъектов (граней, кромок и вершин) на телах. Можно выбирать и редактировать эти подобъекты по отдельности или создавать набор подобъектов одного или нескольких типов и редактировать набор.
  • Сжатие или вытягивание ограниченных областей
    Для сжатия или вытягивания ограниченных областей можно нажать CTRL + ALT и, удерживая их нажатыми, указать на область. Область должна быть ограничена копланарными линиями или кромками.
  • Использование инструментов ручек для редактирования объектов
    Инструменты ручки можно использовать для перемещения и вращения объектов и подобъектов в 3D виде. Инструменты ручки отображаются при выборе объектов и подобъектов в 3D проекции с применением 3D визуального стиля или при использовании команд 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ.
  • Добавление ребер и граней к телам
    Внешний вид граней 3D тел можно изменять путем их клеймения различными объектами, пересекающими грани. При клеймении объект объединяется с гранью, создавая ребро.
  • Разделение 3D тел
    3D тела могут быть разделены на исходные компонентные 3D тела.
  • Создание оболочек из 3D тел
    Можно создать оболочку (тонкостенную оболочку заданной толщины) из 3D тела.
  • Упрощение и проверка корректности 3D тел
    С помощью команды РЕДТЕЛ имеется возможность автоматического удаления избыточных граней, ребер и вершин 3D тел, а также выполнения проверки на корректность тела.


Изменение 3D тел и поверхностей - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Понятия
Процедуры
Команды

Перемещение оси вращения для тела (поверхности), построенного методом вращения

Изменение контура тела (поверхности), построенного методом сечений, с помощью палитры свойств

Для отображения исходных тел, образующих составное тело

Для удаления журнала тела

Для выбора ведения журнала исходных форм в составном теле

Для выбора индивидуального тела, являющегося частью составного тела

Для выбора одной или нескольких граней, кромок или вершин на теле

Для создания набора 3D объектов и подобъектов

Для удаления подобъекта из набора подобъектов

Для выбора кромки, грани или вершины на исходной форме составного тела

Для циклического прохождения по подобъектам и выбора перекрывающихся подобъектов

Для копирования грани тела

Для удаления грани тела

Для изменения цвета грани тела

Для сопряжения граней тела

Снятие фаски на 3D теле

Для редактирования сопряжения или фаски на 3D теле

Для изменения цвета ребра тела

Для копирования ребра тела

Для редактирования вершины на 3D объекте

Для удаления вершины на 3D объекте

Для сжатия или вытягивания ограниченной области

Определение начального местоположения по умолчанию для инструментов ручки

Для перемещения инструмента ручки

Изменение типа инструмента ручки при переносе или повороте объектов

Для перемещения объектов в 3D пространстве вдоль указанной оси

Для перемещения объектов в 3D пространстве с ограничением по указанной плоскости.

Для вращения объектов в 3D пространстве вдоль указанной оси

Для клеймения тела

Для разделения составного 3D тела на отдельные части

Для создания оболочки

Для упрощения тела

Для проверки целостности тела


Изменение 3D тел и поверхностей - Команды

Работа с 3D моделями
Изменение 3D тел и поверхностей
Понятия
Процедуры
Команды
Команды
3DПЕРЕНЕСТИ | Отображает инструмент ручки перемещения в 3D виде и перемещает объекты на указанное расстояние в заданном направлении
3DПОВЕРНУТЬ | На 3D виде отображает ручку поворота и вращает объекты вокруг базовой точки
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
КРОМКА | Изменение видимости кромок трехмерных граней
МАСШТАБ | Пропорциональное увеличение/уменьшение размеров выбранных объектов в направлениях,и
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПОВЕРНУТЬ | Поворачивает объект вокруг базовой точки.
РЕДТЕЛ | Редактирование граней и ребер 3D тел
СОПРЯЖЕНИЕ | Скругление углов и сопряжение объектов
ФАСКА | Построение фасок в местах пересечения объектов
Системные переменные
GTAUTO | Управляет автоматическим отображением инструментов ручки при выборе объектов перед запуском команды в видовом экране, которому задан 3D стиль отображения
GTDEFAULT | Управляет автоматическим выполнением команд 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ при выполнении команд ПЕРЕНЕСТИ и ПОВЕРНУТЬ (соответственно) в 3D виде
GTLOCATION | Управляет первоначальным расположением инструментов ручки, если выбор объектов производится до выполнения команд 3DПЕРЕНЕСТИ или 3DПОВЕРНУТЬ
IMPLIEDFACE | Управляет обнаружением предполагаемых граней
LEGACYCTRLPICK | Задает клавиши циклического повторения выбора и определяет действия при нажатии клавиши CTRL и левой кнопки мыши
SHOWHIST | Управляет свойством "Показать журнал" для тел на чертеже
SOLIDCHECK | Включает и отключает проверку тела для текущего сеанса
SOLIDHIST | Управляет установкой значения по умолчанию для свойства Журнала для новых и существующих объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Манипулирование 3D телами и поверхностями - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Манипулирование 3D телами и поверхностями
Понятия
Процедуры
Команды

Для изменения форм и размеров тел и поверхностей можно использовать ручки или палитру "Свойства". Возможности манипулирования телом или поверхностью определяются типом тела или поверхности и способом их создания.

  • Манипулирование отдельными телами и поверхностями
    Для изменения размера и формы определенных отдельных тел и поверхностей можно использовать ручки или палитру "Свойства".
  • Работа с составными телами
    Составные тела создаются из двух и более индивидуальных тел с использованием любой из следующих команд: ОБЪЕДИНЕНИЕ,, ВЫЧИТАНИЕ и ПЕРЕСЕЧЕНИЕ (Для создания составных тел используются также команды СОПРЯЖЕНИЕ и ФАСКА.) Можно манипулировать исходными индивидуальными телами, образующими составное тело, или телом в полной компоновке.


Манипулирование 3D телами и поверхностями - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Манипулирование 3D телами и поверхностями
Понятия
Процедуры
Команды

Перемещение оси вращения для тела (поверхности), построенного методом вращения

Изменение контура тела (поверхности), построенного методом сечений, с помощью палитры свойств

Для отображения исходных тел, образующих составное тело

Для удаления журнала тела

Для выбора ведения журнала исходных форм в составном теле

Для выбора индивидуального тела, являющегося частью составного тела


Манипулирование 3D телами и поверхностями - Команды

Работа с 3D моделями
Изменение 3D тел и поверхностей
Манипулирование 3D телами и поверхностями
Понятия
Процедуры
Команды
Команды
Нет. |
Системные переменные
LEGACYCTRLPICK | Задает клавиши циклического повторения выбора и определяет действия при нажатии клавиши CTRL и левой кнопки мыши
SHOWHIST | Управляет свойством "Показать журнал" для тел на чертеже
SOLIDHIST | Управляет установкой значения по умолчанию для свойства Журнала для новых и существующих объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Манипулирование отдельными телами и поверхностями - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Манипулирование отдельными телами и поверхностями
Понятия
Процедуры
Команды

Для изменения размера и формы определенных отдельных тел и поверхностей можно использовать ручки или палитру "Свойства".

Возможности манипулирования телом или поверхностью, предоставляемые ручками или палитрой свойств, зависят от типа тела или поверхности.

Элементарные тела (ящик, клин, пирамида, шар, цилиндр, конус и тор)

Использование ручек или палитры свойств позволяет изменять очертания и размер элементарных тел с сохранением их исходной базовой формы. Например, можно изменить радиус основания и высоту конуса, но сохранить форму конуса.

Показать: "Построение и изменение конуса"

Для запуска анимации нажмите стрелку "Просмотр". Подробнее о создании конусов см. Создание конусов.

Другой пример: можно изменить пирамиду, преобразуя четырехстороннюю пирамиду, сводимую в точку, в восьмистороннюю пирамиду, усекаемую до плоской поверхности, с сохранением пирамидальной формы.

Выдавливаемые тела и поверхности

Для создания выдавливаемых тел и поверхностей используется команда ВЫДАВИТЬ. При выборе выдавливаемых тел и поверхностей отображаются ручки на их профилях. Профиль является исходной формой, используемой для создания выдавливаемого тела или поверхности и определяющей внешний вид объекта. Можно использовать эти ручки для управления профилем тела или поверхности с целью изменения формы всего тела или поверхности.

Если выполнено выдавливание по траектории, отображается траектория, которой можно управлять с помощью ручек. Если траектория не использовалась, вверху выдавленного тела или поверхности отображается ручка высоты, позволяющая изменять высоту объекта.

Политела

Можно использовать ручки для изменения формы и размера полител, включая профиль политела. Ручки можно перемещать в плоскости XY тела. Политело всегда имеет угловой профиль (по умолчанию прямоугольный).

Развернутые тела и поверхности

Для развернутых тел и поверхностей ручки отображаются на развернутом профиле, а также на траектории развертывания. Эти ручки можно использовать для изменения тела или поверхности.

Перетаскивание по профилю ручки, выбранной нажатием левой кнопки мыши, позволяет вносить изменения только в плоскости кривой профиля.

Тела и поверхности, полученные по сечениям

В зависимости от того, каким способом получены тела и поверхности по сечениям, для тела или поверхности отображаются ручки на указанных ниже объектах, определяющих линиях или кривых.

  • Поперечное сечение
  • Траектория

Можно перетаскивать выбираемые мышью ручки по любой из определяющих линий или кривых с целью изменения тела или поверхности. Если полученное методом сечений тело или поверхность содержит траекторию, разрешается редактировать только часть траектории, находящуюся между первым и последним поперечными сечениями.

Можно также использовать область "Геометрия" палитры "Свойства" для изменения контура тела (поверхности), построенного методом сечений, на его поперечных сечениях. Когда выбирается тело (поверхность), полученное методом сечений, в области "Геометрия" палитры "Свойства" отображаются параметры, которые были заданы в диалоговом окне "Настройки сечений" при создании тела (поверхности).

Для изменения тел или поверхностей, построенных методом сечений с использованием направляющих, использование ручек не предусмотрено.

Тела и поверхности, созданные методом вращения

Для тел и поверхностей, созданных методом вращения, отображаются ручки на профиле вращения в начале тела (поверхности), построенного методом вращения. Можно использовать эти ручки для изменения профиля тела или поверхности.

Ручка отображается также в конечной точке оси вращения. Можно переместить ось вращения, выбирая ручку и указывая другое местоположение оси.

См. также

Создание 3D тел и поверхностей


Манипулирование отдельными телами и поверхностями - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Манипулирование отдельными телами и поверхностями
Понятия
Процедуры
Команды

Перемещение оси вращения для тела (поверхности), построенного методом вращения

Изменение контура тела (поверхности), построенного методом сечений, с помощью палитры свойств


Перемещение оси вращения для тела (поверхности), построенного методом вращения - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Манипулирование отдельными телами и поверхностями
Понятия
Процедуры
Команды

Перемещение оси вращения для тела (поверхности), построенного методом вращения

  1. На четреже выберите тело (поверхность), созданное методом вращения.
  2. Выберите ручку на оси вращения.
  3. Нажмите левую кнопку мыши и переместите ось вращения.


Изменение контура тела (поверхности), построенного методом сечений, с помощью палитры свойств - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Манипулирование отдельными телами и поверхностями
Понятия
Процедуры
Команды

Изменение контура тела (поверхности), построенного методом сечений, с помощью палитры свойств

  1. На чертеже выбрать тело (поверхность), полученное методом сечений с использованием поперечных сечений.
  2. Если палитра "Свойства" не отображается, нажатием левой кнопки мыши выберите в меню "Сервис" » "Палитра" » "Свойства".
  3. В области "Геометрия" палитры "Свойства" измените настройку "Нормали к поверхности", выбрав одно из указанных ниже значений.
    • Линованная Указывается, что тело (поверхность) является линейчатым между поперечными сечениями и имеет острые кромки на поперечных сечениях.
    • СглаженнаяУказывается, что между поперечными сечениями расположено гладкое тело (поверхность), имеющее острые кромки на поперечных сечениях. Касательное направление на поперечных сечениях определяется примыкающими поперечными сечениями.
    • Первая нормальУказывается, что нормаль к поверхности является нормалью к первому поперечному сечению.
    • Последняя нормаль Указывается, что нормаль к поверхности является нормалью к последнему поперечному сечению.
    • Концы нормалиУказывается, что нормаль к поверхности является нормалью и к первому, и к последнему поперечному сечению.
    • Все нормали Указывается, что нормаль к поверхности является нормалью ко всем поперечным сечениям.
    • Использование конусных ограниченийОпределяется угол наклона первого и последнего поперечных сечений тела (поверхности), построенного по сечениям. Значения угла наклона определяются следующими системными переменными: LOFTANG1, LOFTANG2, LOFTMAG1 и LOFTMAG2.


Манипулирование отдельными телами и поверхностями - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Манипулирование отдельными телами и поверхностями
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Работа с составными телами - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Работа с составными телами
Понятия
Процедуры
Команды

Составные тела создаются из двух и более индивидуальных тел с использованием любой из следующих команд: ОБЪЕДИНЕНИЕ,, ВЫЧИТАНИЕ и ПЕРЕСЕЧЕНИЕ (Для создания составных тел используются также команды СОПРЯЖЕНИЕ и ФАСКА.) Можно манипулировать исходными индивидуальными телами, образующими составное тело, или телом в полной компоновке.

  • Отображение исходных форм составных тел
    По умолчанию в журнале 3D тел регистрируются исходные профили 3D тел. Этот журнал позволяет видеть исходные формы, из которых получены составные тела.
  • Манипулирование составными телами
    Возможно манипулирование составным телом в полной компоновке или исходными формами, образующими составное тело.

См. также

Редактирование ребер на 3D телах


Работа с составными телами - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Работа с составными телами
Понятия
Процедуры
Команды

Для отображения исходных тел, образующих составное тело

Для удаления журнала тела

Для выбора ведения журнала исходных форм в составном теле

Для выбора индивидуального тела, являющегося частью составного тела


Работа с составными телами - Команды

Работа с 3D моделями
Изменение 3D тел и поверхностей
Работа с составными телами
Понятия
Процедуры
Команды
Команды
Нет. |
Системные переменные
LEGACYCTRLPICK | Задает клавиши циклического повторения выбора и определяет действия при нажатии клавиши CTRL и левой кнопки мыши
SHOWHIST | Управляет свойством "Показать журнал" для тел на чертеже
SOLIDHIST | Управляет установкой значения по умолчанию для свойства Журнала для новых и существующих объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Отображение исходных форм составных тел - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Отображение исходных форм составных тел
Понятия
Процедуры
Команды

По умолчанию в журнале 3D тел регистрируются исходные профили 3D тел. Этот журнал позволяет видеть исходные формы, из которых получены составные тела.

При выборе значения "Да" для опции "Показать протокол" составного тела отображаются (бледными линиями) каркасы исходных форм индивидуальных тел, образующих составное тело.

Отображение журнала составного тела полезно при модификации составных тел. Ручки отображаются на исходных формах, из которых создается составное тело. Подробнее об использовании ручек для манипулирования составными телами см. Манипулирование составными телами

Для переопределения настройки свойства "Показать протокол" в палитре "Свойства" можно использовать системную переменную SHOWHIST.

Ведение журнала регистрации исходных компонентов составного тела возможно при условии, что для свойства "Журнал" исходных индивидуальных тел установлено значение "Запись". "Запись" является значением данного свойства по умолчанию, но может быть изменено в секции "Журнал тел" палитры "Свойства" или с помощью системной переменной SOLIDHIST.

Для удаления журнала составного тела, можно выбрать тело и заменить значение его свойства "Журнал" на "Нет". Для удаления журнала из индивидуального или составного тела можно использовать также команду ГРПРЕД. При удалении журнала тела утрачивается возможность выбора и изменения исходных компонентов тела. После этого можно заново установить значение "Запись" для настройки журнала тела, перезапуская ведение журнала "с нуля".

Удаление журнала составного тела может быть полезным при создании очень сложных составных тел. Например, может понадобиться создание сложных составных тел, служащих основой для дополнительных составных тел. Журнал можно удалить сразу после создания базовой формы. Далее можно вернуть свойству "Журнал" значение "Запись" с тем, чтобы можно было в дальнейшем редактировать формы дополнительных объектов, добавляемых в составное тело.


Отображение исходных форм составных тел - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Отображение исходных форм составных тел
Понятия
Процедуры
Команды

Для отображения исходных тел, образующих составное тело

Для удаления журнала тела

Для выбора ведения журнала исходных форм в составном теле


Для отображения исходных тел, образующих составное тело - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Отображение исходных форм составных тел
Понятия
Процедуры
Команды

Для отображения исходных тел, образующих составное тело

  1. Если палитра "Свойства" не отображается, нажатием левой кнопки мыши выберите в меню "Сервис" » "Палитра" » "Свойства".
  2. На чертеже выберите 3D составное тело.
  3. Выберите "Да" для опции "Показать протокол" в секции "Журнал тел" палитры "Свойства".


Для удаления журнала тела - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Отображение исходных форм составных тел
Понятия
Процедуры
Команды

Для удаления журнала тела

  1. Если палитра "Свойства" не отображается, нажатием левой кнопки мыши выберите меню "Сервис" » "Палитра" » "Свойства".
  2. На чертеже выберите 3D тело.
  3. Выберите "Нет" для опции "Журнал" в секции "Журнал тел" палитры "Свойства".

Ввод команды: ГРПРЕД


Для выбора ведения журнала исходных форм в составном теле - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Отображение исходных форм составных тел
Понятия
Процедуры
Команды

Для выбора ведения журнала исходных форм в составном теле

  1. Если палитра "Свойства" не отображается, нажатием левой кнопки мыши выберите меню "Сервис" » "Палитра" » "Свойства".
  2. Выберите тело на чертеже.
  3. Выберите "Запись" для опции "Журнал" в секции "Журнал тел" палитры "Свойства".


Отображение исходных форм составных тел - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Отображение исходных форм составных тел
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
SHOWHIST | Управляет свойством "Показать журнал" для тел на чертеже
SOLIDHIST | Управляет установкой значения по умолчанию для свойства Журнала для новых и существующих объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Манипулирование составными телами - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Манипулирование составными телами
Понятия
Процедуры
Команды

Возможно манипулирование составным телом в полной компоновке или исходными формами, образующими составное тело.

Можно выбрать составное тело на чертеже и перемещать, масштабировать или вращать тело с использованием ручек или инструментов ручек.

Можно также выбирать исходные индивидуальные формы составного тела, удерживая в нажатом состоянии клавишу CTRL. Если исходная форма тела не является элементарным телом, отображаются ручки, позволяющие изменять профиль и размер элементарной формы внутри составного тела.

Если в выбранной индивидуальной форме отсутствует журнал, можно перемещать, поворачивать, масштабировать или удалять форму.

Составное тело может быть образовано другими составными телами. Можно выбирать исходные индивидуальные формы составных тел, образующих составное тело, удерживая в нажатом состоянии клавишу CTRL в процессе выбора форм левой кнопкой мыши.

Размер и форму составных тел можно изменять также, выбирая мышью и перетаскивая ручки на индивидуальных гранях, кромках и вершинах. Подробнее см. Выбор и редактирование 3D подобъектов.

См. также

Использование режимов ручек

Многократное копирование с помощью ручек

Использование инструментов ручек для редактирования объектов


Для выбора индивидуального тела, являющегося частью составного тела - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Манипулирование составными телами
Понятия
Процедуры
Команды

Для выбора индивидуального тела, являющегося частью составного тела

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Нажмите левую кнопку мыши на индивидуальном теле, являющемся частью составного тела.
  3. Повторяйте этот шаг, пока не будут выбраны все требуемые формы.


Манипулирование составными телами - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Манипулирование составными телами
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
LEGACYCTRLPICK | Задает клавиши циклического повторения выбора и определяет действия при нажатии клавиши CTRL и левой кнопки мыши
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор и редактирование 3D подобъектов - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Выбор и редактирование 3D подобъектов
Понятия
Процедуры
Команды

Имеется возможность выбора и редактирования подобъектов (граней, кромок и вершин) на телах. Можно выбирать и редактировать эти подобъекты по отдельности или создавать набор подобъектов одного или нескольких типов и редактировать набор.

  • Выбор 3D подобъектов
    Для выбора подобъектов (граней, кромок и вершин) на телах необходимо нажать и удерживать нажатой клавишу CTRL и далее выбирать эти подобъекты.
  • Перемещение, поворот и масштабирование подобъектов
    Перемещение, поворот и масштабирование отдельных подобъектов на 3D телах выполняется выбором и перетаскиванием ручки подобъекта, используя инструменты ручки (3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ) или посредством команд ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ.
  • Редактирование граней на 3D телах
    Возможен выбор граней на 3D теле для их перемещения, вращения или масштабирования. Можно также удалять, копировать, окрашивать грани и добавлять к ним материалы.
  • Редактирование ребер на 3D телах
    Имеется возможность выбора и редактирования ребер на 3D теле.
  • Редактирование вершин на 3D телах
    Имеется возможность выбора и редактирования вершин на 3D телах. Выбор левой кнопкой мыши и перетаскивание вершины приводит к "растягиванию" 3D объекта.


Выбор и редактирование 3D подобъектов - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Выбор и редактирование 3D подобъектов
Понятия
Процедуры
Команды

Для выбора одной или нескольких граней, кромок или вершин на теле

Для создания набора 3D объектов и подобъектов

Для удаления подобъекта из набора подобъектов

Для выбора кромки, грани или вершины на исходной форме составного тела

Для циклического прохождения по подобъектам и выбора перекрывающихся подобъектов

Для копирования грани тела

Для удаления грани тела

Для изменения цвета грани тела

Для сопряжения граней тела

Снятие фаски на 3D теле

Для редактирования сопряжения или фаски на 3D теле

Для изменения цвета ребра тела

Для копирования ребра тела

Для редактирования вершины на 3D объекте

Для удаления вершины на 3D объекте


Выбор и редактирование 3D подобъектов - Команды

Работа с 3D моделями
Изменение 3D тел и поверхностей
Выбор и редактирование 3D подобъектов
Понятия
Процедуры
Команды
Команды
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
КРОМКА | Изменение видимости кромок трехмерных граней
МАСШТАБ | Пропорциональное увеличение/уменьшение размеров выбранных объектов в направлениях,и
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПОВЕРНУТЬ | Поворачивает объект вокруг базовой точки.
РЕДТЕЛ | Редактирование граней и ребер 3D тел
СОПРЯЖЕНИЕ | Скругление углов и сопряжение объектов
ФАСКА | Построение фасок в местах пересечения объектов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор 3D подобъектов - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Выбор 3D подобъектов
Понятия
Процедуры
Команды

Для выбора подобъектов (граней, кромок и вершин) на телах необходимо нажать и удерживать нажатой клавишу CTRL и далее выбирать эти подобъекты.

Подобъектом является любая составная часть тела: грань, кромка или вершина. Возможен также вызов исходных индивидуальных форм, образующих составные подобъекты тел. Эти исходные формы являются составными частями тел и выбираются таким же образом (при нажатой клавише CTRL), как грани, кромки и вершины.

На всех выбранных гранях, кромках и вершинах по отдельности отображаются ручки различных типов.

Можно выбрать один подобъект либо создать набор из двух и более подобъектов в любом количестве тел. В этот набор разрешается включать подобъекты двух и более типов. Можно также использовать CTRL с целью выбора подобъектов по подсказкам выбора из команд ПЕРЕНЕСТИ, ПОВЕРНУТЬ, МАСШТАБ и СТЕРЕТЬ.

Кроме того, можно нажимать и удерживать нажатой клавишу CTRL для выбора граней, кромок и вершин на составных телах. Однако, если для свойства "Журнал" составного тела задано значение "Запись", первое пользовательское "указание" может привести к выбору исходного тела, включенного в составное тело. Продолжая удерживать нажатой клавишу CTRL, можно новыми указаниями выбирать грань, кромку или вершину на данной исходной форме.

Возможно также создание набора, состоящего из любого числа тел, поверхностей и подобъектов.

Если подобъекты перекрываются между собой, и включена опция предварительного просмотра набора, можно циклически проходить по объектам; с этой целью выберите (прокруткой) подобъект на верхней позиции для его подсветки, нажмите и удерживайте нажатой клавишу CTRL и последовательно нажимайте клавишу ПРОБЕЛ. Когда подсвечивается нужный объект, выберите его нажатием левой кнопки мыши.

Если опция предварительного просмотра набора выключена и указатель выбора (миниатюрный прямоугольник, заменяющий перекрестье при выборе объектов) указывает на два и более подобъекта, можно циклически проходить по подобъектам, пока не будет выбран нужный подобъект; для этого следует нажимать клавишу ПРОБЕЛ при нажатой клавише CTRL и нажимать левую кнопку мыши на нужном подобъекте.

Например, когда выбираются грани в 3D телах, первой обнаруживается грань лицевой стороны на переднем плане. Грань задней стороны, расположенную позади грани лицевой стороны, можно выбрать нажатием клавиши ПРОБЕЛ (при нажатой клавише CTRL).


Выбор 3D подобъектов - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Выбор 3D подобъектов
Понятия
Процедуры
Команды

Для выбора одной или нескольких граней, кромок или вершин на теле

Для создания набора 3D объектов и подобъектов

Для удаления подобъекта из набора подобъектов

Для выбора кромки, грани или вершины на исходной форме составного тела

Для циклического прохождения по подобъектам и выбора перекрывающихся подобъектов


Для выбора одной или нескольких граней, кромок или вершин на теле - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Выбор 3D подобъектов
Понятия
Процедуры
Команды

Для выбора одной или нескольких граней, кромок или вершин на теле

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Выберите грань, кромку или вершину.
  3. Повторяйте шаг 2, пока не будут выбраны требуемые подобъекты.

    4. Ввод команды: ВЫБРАТЬ (опция подобъекта)


Для создания набора 3D объектов и подобъектов - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Выбор 3D подобъектов
Понятия
Процедуры
Команды

Для создания набора 3D объектов и подобъектов

  1. Выберите требуемые тела и поверхности.
  2. Нажмите и удерживайте нажатой клавишу CTRL.
  3. Выберите грань, кромку или вершину.
  4. Повторяйте шаги 1 - 3, пока не будут выбраны требуемые подобъекты.

Ввод команды: ВЫБРАТЬ


Для удаления подобъекта из набора подобъектов - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Выбор 3D подобъектов
Понятия
Процедуры
Команды

Для удаления подобъекта из набора подобъектов

  1. Нажмите и удерживайте нажатыми клавиши CTRL + SHIFT.
  2. Нажатием левой кнопки мыши выберите грань, кромку или вершину.


Для выбора кромки, грани или вершины на исходной форме составного тела - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Выбор 3D подобъектов
Понятия
Процедуры
Команды

Для выбора кромки, грани или вершины на исходной форме составного тела

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Выберите исходную форму, на которой необходимо выбрать грань, кромку или вершину.
  3. При нажатой клавише CTRL нажмите левую кнопку мыши на грани, кромке или вершине.

    4. Может потребоваться повтор данного шага для выбора требуемой грани, кромки или вершины.

Ввод команды: ВЫБРАТЬ (опция подобъекта)


Для циклического прохождения по подобъектам и выбора перекрывающихся подобъектов - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Выбор 3D подобъектов
Понятия
Процедуры
Команды

Для циклического прохождения по подобъектам и выбора перекрывающихся подобъектов

  1. Нажмите и удерживайте нажатыми CTRL + ПРОБЕЛ.
  2. Нажмите левую кнопку мыши как можно ближе к требуемому подобъекту.
  3. Последовательно нажимайте кнопку, пока не произойдет подсветка нужного объекта.
  4. Нажмите ENTER для выбора подобъекта.


Выбор 3D подобъектов - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Выбор 3D подобъектов
Понятия
Процедуры
Команды

Команды
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
РЕДТЕЛ | Редактирование граней и ребер 3D тел
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Перемещение, поворот и масштабирование подобъектов - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Перемещение, поворот и масштабирование подобъектов
Понятия
Процедуры
Команды

Перемещение, поворот и масштабирование отдельных подобъектов на 3D телах выполняется выбором и перетаскиванием ручки подобъекта, используя инструменты ручки (3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ) или посредством команд ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ.

Показать: "Перенос граней и ребер на 3D теле"

Для запуска анимации нажмите стрелку "Просмотр".

При переносе, повороте или масштабировании подобъекта претерпеваемые им изменения не нарушают целостности 3D тела. Например, при переносе ребра (красного цвета на иллюстрации), смежные с ребром грани остаются смежными с этим ребром.

В некоторых случаях при изменении тела возможно получение нескольких результатов. При переносе, повороте или масштабировании подобъектов можно во время перетаскивания нажать клавишу CTRL для циклического перебора режимов изменения. Ниже на иллюстрации показаны варианты изменений для переноса грани (красного цвета).

Дополнительные сведения о вариантах изменений см. в разделе:

  • Перемещение, вращение и масштабирование граней на 3D телах
  • Редактирование ребер на 3D телах
  • Редактирование вершин на 3D телах
"Перенос, поворот и масштабирование подобъектов на составных телах"

Если для свойства "Журнал" составного тела задано значение "Запись", можно выбирать и переносить, поворачивать и масштабировать грани, ребра и вершины только на отдельно взятых примитивных телах, образующих составные тела.

Если для свойства "Журнал" составного тела задано значение "Нет", можно выбирать и переносить, поворачивать и масштабировать грани, ребра и вершины только всего составного тела (но не отдельно взятых примитивов, образующих составные тела).

Правила и ограничения на выполнение переноса, поворота, масштабирования подобъектов

Допускаются только те операции переноса, поворота и масштабирования подобъектов, которые не нарушают целостности 3D тела. При выполнении переноса, поворота и масштабирования подобъектов действуют следующие правила:

  • Если для изменения подобъектов используются ручки, они не отображаются на подобъектах, которые нельзя переносить, поворачивать или масштабировать.
  • В большинстве случаев можно выполнять перенос, поворот и масштабирование как плоских, так и неплоских граней.
  • Можно изменять только ребро, являющееся прямым отрезком и имеющее не менее одной плоской смежной грани. Выполняется регулировка плоскостей смежных плоских граней, обеспечивающая сохранение в них изменяемого ребра.
  • Не допускается выполнение переноса, поворота или масштабирования ребре (или их вершин), запечатленных внутри грани.
  • Возможно изменение только вершины, имеющей не менее одной плоской смежной грани. Выполняется регулировка плоскостей смежных плоских граней, обеспечивающая сохранение в них изменяемой вершины.
  • При перетаскивании подобъекта конечный результат может отличаться от предварительного изображения, отображаемого во время изменения. Это определяется тем, что выполняется регулировка способа изменения тела для сохранения его топологии. В некоторых случаях изменение может оказаться невозможным из-за слишком серьезного изменения топологии тела.
  • Как правило, операция завершается неудачей, если изменения приводят к удлинению поверхностей сплайнов.
  • Не допускается выполнение переноса, поворота или масштабирования ребер или вершин, принадлежащих более чем двум граням. Аналогично, если некоторые ребра или вершины, принадлежащие более чем двум граням, находятся рядом с изменяемыми гранями, ребрами или вершинами, операция может оказаться невозможной.


Выбор и редактирование 3D подобъектов

Работа с 3D моделями
Изменение 3D тел и поверхностей
Выбор и редактирование 3D подобъектов
Понятия
Процедуры
Команды

Нет процедур.


Перемещение, поворот и масштабирование подобъектов - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Перемещение, поворот и масштабирование подобъектов
Понятия
Процедуры
Команды

Команды
МАСШТАБ | Пропорциональное увеличение/уменьшение размеров выбранных объектов в направлениях,и
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПОВЕРНУТЬ | Поворачивает объект вокруг базовой точки.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование граней на 3D телах - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование граней на 3D телах
Понятия
Процедуры
Команды

Возможен выбор граней на 3D теле для их перемещения, вращения или масштабирования. Можно также удалять, копировать, окрашивать грани и добавлять к ним материалы.

  • Перемещение, вращение и масштабирование граней на 3D телах
    Разрешается выбирать и редактировать грани на 3D телах. Для изменения граней применяются ручки, захватные блоки или такие команды, как ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ.
  • Копирование, удаление и окрашивание граней на 3D телах
    Можно использовать РЕДТЕЛ для копирования или удаления граней объекта 3D тела. Палитра "Свойства" позволяет изменять цвет граней на объектах 3D тел.


Редактирование граней на 3D телах - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование граней на 3D телах
Понятия
Процедуры
Команды

Для копирования грани тела

Для удаления грани тела

Для изменения цвета грани тела


Редактирование граней на 3D телах - Команды

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование граней на 3D телах
Понятия
Процедуры
Команды
Команды
МАСШТАБ | Пропорциональное увеличение/уменьшение размеров выбранных объектов в направлениях,и
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПОВЕРНУТЬ | Поворачивает объект вокруг базовой точки.
РЕДТЕЛ | Редактирование граней и ребер 3D тел
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Перемещение, вращение и масштабирование граней на 3D телах - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Перемещение, вращение и масштабирование граней на 3D телах
Понятия
Процедуры
Команды

Разрешается выбирать и редактировать грани на 3D телах. Для изменения граней применяются ручки, захватные блоки или такие команды, как ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ.

Команды ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ можно использовать для редактирования граней точно так же, как для любого другого объекта. Нажмите и удерживайте нажатой клавишу CTRL при выборе грани на теле.

Когда перемещается, поворачивается или масштабируется грань на 3D элементарном теле, удаляется журнал элементарного тела. Тело не является более истинно элементарным телом и не доступно для манипулирования в качестве такого тела (с помощью ручек и палитры "Свойства").

Режимы изменения граней

Для циклического перебора режимов изменения нажмите клавишу CTRL при перетаскивании грани.

При выполнении переноса, поворота или масштабирования грани без использования клавиши CTRL грань изменяется вместе со своими ребрами, сохраняя свою форму и ребра, но при этом возможно изменение плоскостей плоских граней, смежных с изменяемой.

При выполнении переноса, поворота или масштабирования грани, сопровождаемых однократным нажатием и отпусканием клавиши CTRL во время перетаскивания, грань изменяется отдельно от своих ребер. При этом сохраняются поверхности смежных граней, но возможно изменение формы (границы) изменяемой грани.

При выполнении переноса, поворота или масштабирования грани, сопровождаемых двукратным нажатием и отпусканием клавиши CTRL во время перетаскивания, грань изменяется вместе со своими ребрами (так же, как без нажатия клавиши CTRL). Однако, при необходимости, для плоских граней, смежных с изменяемой, выполняется триангуляция (разделение на две или более плоские треугольные грани).

Если клавиша CTRL нажимается и отпускается в третий раз, возвращается первый режим изменения, как если бы клавиша CTRL не нажималась.

См. также

Перемещение, поворот и масштабирование подобъектов

Использование инструментов ручек для редактирования объектов

Применение материалов к объектам и поверхностям

Перемещение или поворот объектов

Изменение размеров и форм объектов


Перемещение, вращение и масштабирование граней на 3D телах - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Перемещение, вращение и масштабирование граней на 3D телах
Понятия
Процедуры
Команды

Команды
МАСШТАБ | Пропорциональное увеличение/уменьшение размеров выбранных объектов в направлениях,и
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПОВЕРНУТЬ | Поворачивает объект вокруг базовой точки.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Копирование, удаление и окрашивание граней на 3D телах - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Копирование, удаление и окрашивание граней на 3D телах
Понятия
Процедуры
Команды

Можно использовать РЕДТЕЛ для копирования или удаления граней объекта 3D тела. Палитра "Свойства" позволяет изменять цвет граней на объектах 3D тел.

Копирование и удаление граней

Если для копирования граней на объекте 3D тела используется команда РЕДТЕЛ, выбранные грани копируются в качестве областей или тел. Если указать две точки, то первая будет использоваться как базовая точка и одна копия будет размещена относительно базовой точки. Если указать одну точку и затем нажать клавишу ENTER, исходная точка выбора используется как базовая точка, а следующая точка используется как точка смещения.

Грань, окружаемую копланарными гранями, можно удалять либо путем выбора грани и ее удаления, либо с помощью команды СТЕРЕТЬ. Для удаления граней можно использовать также команду РЕДТЕЛ.

Изменение цвета граней

Цвет грани на 3D теле можно изменять, выбирая грань и далее изменяя свойство "Цвет" в палитре "Свойства".


Копирование, удаление и окрашивание граней на 3D телах - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Копирование, удаление и окрашивание граней на 3D телах
Понятия
Процедуры
Команды

Для копирования грани тела

Для удаления грани тела

Для изменения цвета грани тела


Для копирования грани тела - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Копирование, удаление и окрашивание граней на 3D телах
Понятия
Процедуры
Команды

Для копирования грани тела

  1. Выберите в меню "Редактирование" » "Редактирование тела" » "Копировать грани".
  2. Выберите грань для копирования (1).
  3. Выберите дополнительные грани или нажмите ENTER для выполнения операции копирования.
  4. Укажите базовую точку для копирования (2).
  5. Укажите вторую точку перемещения (3).
  6. Нажмите ENTER для выполнения команды.

Примечание Для выдавливания скопированной грани следует использовать команду ВЫДАВИТЬ.

Ввод команды: РЕДТЕЛ


Для удаления грани тела - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Копирование, удаление и окрашивание граней на 3D телах
Понятия
Процедуры
Команды

Для удаления грани тела

  1. Выберите в меню "Редактирование" » "Редактирование тела" » "Удалить грани".
  2. Выберите грань для удаления (1).
  3. Выберите дополнительные грани или нажмите ENTER для удаления.
  4. Нажмите ENTER для выполнения команды.

Панель "Редактирование тела"

Ввод команды: РЕДТЕЛ


Для изменения цвета грани тела - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Копирование, удаление и окрашивание граней на 3D телах
Понятия
Процедуры
Команды

Для изменения цвета грани тела

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Нажмите левую кнопку мыши на грани 3D тела.
  3. Если палитра "Свойства" не отображается, нажатием левой кнопки мыши следует выбрать меню "Сервис" » "Палитра" » "Свойства".
  4. В палитре "Свойства" нажмите на "Цвет" на вкладке "Общие".

    5. Справа от поля располагается кнопка со стрелкой.

  5. Нажмите на кнопку и выберите цвет из списка или воспользуйтесь пунктом "Выбор цвета" для вызова диалогового окна "Выбор цвета". В этом случае выполните одно из следующих действий:
    • На вкладке "Номер цвета" выберите цвет или введите в поле "Цвет" его имя или числовое значение в системе ИЦА (от 1 до 255).
    • На вкладке "Вся палитра" выберите цветовую модель "HSL" в списке "Цветовая модель" и введите значение цвета в поле "Цвет" или задайте значения "H (оттенок)", "S (насыщенность)" и "L (яркость)". Нажмите "OK".
    • На вкладке "Вся палитра" выберите цветовую модель RGB в списке "Цветовая модель". Задайте цвет путем введения его номера в поле "Цвет" или введением значений в полях "Красный", "Зеленый" и "Синий".
    • На вкладке "Альбомы цветов" выберите необходимый альбом, выберите требуемый цвет (с помощью стрелок вверх или вниз). Нажмите "OK".

    Ввод команды: ОКОНСВ


Копирование, удаление и окрашивание граней на 3D телах - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Копирование, удаление и окрашивание граней на 3D телах
Понятия
Процедуры
Команды

Команды
РЕДТЕЛ | Редактирование граней и ребер 3D тел
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование ребер на 3D телах - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование ребер на 3D телах
Понятия
Процедуры
Команды

Имеется возможность выбора и редактирования ребер на 3D теле.

Перемещение, поворот и масштабирование ребер

Ребра на 3D телах изменяются с помощью ручек, захватных блоков и с использованием таких команд, как ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ.

Команды ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ можно использовать для редактирования ребер на 3D телах, точно так же как для любого другого объекта. Нажмите и удерживайте нажатой клавишу CTRL при выборе ребра на теле.

Ребра на областях можно выбирать, но при этом не отображаются ручки. Этими ребрами можно также управлять с помощью команд ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ.

Кроме того, можно удалять ребра, которые полностью разделяют две копланарные грани, либо путем выбора и удаления грани, либо с помощью команды СТЕРЕТЬ.

Когда перемещается, поворачивается или масштабируется ребро на 3D элементарном теле, удаляется журнал этого элементарного тела. Тело не является более элементарным и не доступно для манипулирования в качестве такого тела (с помощью ручек и палитры "Свойства").

Режимы изменения ребер

Для циклического перебора режимов изменения нажмите клавишу CTRL при перетаскивании ребра.

При выполнении переноса, поворота или масштабирования без нажатия клавиши CTRL ребро изменяется вместе со своим вершинами, сохраняя длину ребра, но при этом возможно изменение плоскостей плоских граней, смежных с вершинами ребер.

При выполнении переноса, поворота или масштабирования ребра, сопровождаемых однократным нажатием и отпусканием клавиши CTRL во время перетаскивания, ребро изменяется отдельно от своих вершин. При этом сохраняются поверхности смежных граней, но возможно изменение длины изменяемого ребра.

При выполнении переноса, поворота или масштабирования ребра, сопровождаемых двукратным нажатием и отпусканием клавиши CTRL во время перетаскивания, ребро изменяется вместе со своими вершинами (так же, как без нажатия клавиши CTRL). Однако, для плоских граней, смежных с вершинами изменяемого ребра, выполняется триангуляция (разделение на две или более плоские треугольные грани), если они становятся неплоскими.

Если клавиша CTRL нажимается и отпускается в третий раз, возвращается первый режим изменения, как если бы клавиша CTRL не нажималась.

Сопряжение граней и снятие фасок у 3D тел

С помощью команды СОПРЯЖЕНИЕ можно добавлять к выбранным 3D телам плавные переходы и сопряжения. Методом по умолчанию можно задать радиус сопряжения и далее выбрать ребра для сопряжения. Существуют и другие способы, в которых для каждой сопрягаемой грани задается свой радиус сопряжения или сопрягается последовательность ребер, переходящих одно в другое по касательной. Аналогично, снятие фасок на пересечениях смежных граней 3D тел осуществляется командой ФАСКА.

После выполнения команды СОПРЯЖЕНИЕ или ФАСКА для тела можно выбрать сопряжение или фаску и отредактировать свойства сопряжения или фаски в палитре "Свойства".

При применении сопряжения или фаски к ребру тела удаляется журнал тела.

Изменение цвета ребер

Для изменения цвета ребра на 3D объекте можно выбрать ребро и изменить свойство "Цвет" в палитре "Свойства".

Копирование ребер

Имеется возможность индивидуального копирования ребер 3D тел. В результате копирования образуются отрезки, дуги, круги, эллипсы и сплайны. Если указать две точки, первая будет использоваться как базовая точка и одна копия будет размещена относительно базовой точки. Если указать одну точку и затем нажать клавишу ENTER, исходная точка выбора используется как базовая точка, а следующая точка используется как точка смещения.

См. также

Перемещение, поворот и масштабирование подобъектов

Использование инструментов ручек для редактирования объектов

Редактирование объектов

Перемещение или поворот объектов

Изменение размеров и форм объектов


Редактирование ребер на 3D телах - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование ребер на 3D телах
Понятия
Процедуры
Команды

Для сопряжения граней тела

Снятие фаски на 3D теле

Для редактирования сопряжения или фаски на 3D теле

Для изменения цвета ребра тела

Для копирования ребра тела


Для сопряжения граней тела - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование ребер на 3D телах
Понятия
Процедуры
Команды

Для сопряжения граней тела

  1. Выберите "Редактирование" » "Сопряжение".
  2. Выберите ребро тела для сопряжения.
  3. Задайте радиус сопряжения.
  4. Продолжите выбор ребер или нажмите ENTER для перехода к построению сопряжения.

Ввод команды: СОПРЯЖЕНИЕ


Снятие фаски на 3D теле - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование ребер на 3D телах
Понятия
Процедуры
Команды

Снятие фаски на 3D теле

  1. Выберите "Редактирование" » "Фаска"
  2. Выберите ребро базовой грани для фаски (1).

    3. Выделяется одна из двух поверхностей, смежных с выбранным ребром.

  3. Для перехода к следующей грани введите с (сменить); для подтверждения работы с текущей выделенной гранью нажать ENTER.
  4. Задайте длину фаски для базовой грани.

    5. Длина фаски для базовой грани измеряется от выбранного ребра до точки на базовой грани. Длина фаски для смежной грани измеряется от выбранного ребра до точки на смежной грани.

  5. Задайте длину фаски для смежной грани.

    6. Опция "Контур" выбирает для снятия фаски все ребра базовой грани; опция "Выберите ребро" позволяет выбрать ребра вручную.

  6. Укажите ребра для снятия фасок (2).

Ввод команды: ФАСКА


Для редактирования сопряжения или фаски на 3D теле - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование ребер на 3D телах
Понятия
Процедуры
Команды

Для редактирования сопряжения или фаски на 3D теле

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Выберите сопряжение или фаску на 3D теле.
  3. Если палитра "Свойства" не отображается, следует нажатием левой кнопки мыши выбрать меню "Сервис" » "Палитра" » "Свойства".
  4. В палитре "Свойства" измените свойства сопряжения или фаски.

Ввод команды: ОКОНСВ


Для изменения цвета ребра тела - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование ребер на 3D телах
Понятия
Процедуры
Команды

Для изменения цвета ребра тела

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Нажмите левую кнопку мыши на ребре 3D тела.
  3. Если палитра "Свойства" не отображается, нажатием левой кнопки мыши выберите в меню "Сервис" » "Палитра" » "Свойства".
  4. В палитре "Свойства" выберите опцию "Цвет" на вкладке "Общие".

    5. Справа от поля располагается кнопка со стрелкой.

  5. Нажмите на кнопку и выберите цвет из списка или воспользуйтесь пунктом "Выбор цвета" для вызова диалогового окна "Выбор цвета". В этом случае выполните одно из следующих действий:
    • На вкладке "Номер цвета" выберите цвет или введите в поле "Цвет" его имя или числовое значение в системе ИЦА (от 1 до 255).
    • На вкладке "Вся палитра" выберите цветовую модель "HSL" в списке "Цветовая модель" и введите значение цвета в поле "Цвет" или задайте значения "H (оттенок)", "S (насыщенность)" и "L (яркость)". Нажмите "OK".
    • На вкладке "Вся палитра" выберите цветовую модель RGB в списке "Цветовая модель". Задайте цвет путем введения его номера в поле "Цвет" или введением значений в полях "Красный", "Зеленый" и "Синий".
    • На вкладке "Альбомы цветов" выберите альбом цветов в окне "Альбом цветов", выберите цвет нажатием на цветовую полоску при перемещении по альбому цветов (с помощью стрелок вверх или вниз). Нажмите "OK".

    Ввод команды: ОКОНСВ


Для копирования ребра тела - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование ребер на 3D телах
Понятия
Процедуры
Команды

Для копирования ребра тела

  1. Выберите в меню "Редактирование" » "Редактирование тела" » "Копировать ребра".
  2. Выберите ребро для копирования (1).
  3. Выберите дополнительные ребра или нажмите ENTER.
  4. Укажите базовую точку перемещения (2).
  5. Укажите вторую точку перемещения (3).
  6. Нажмите ENTER для выполнения команды.

Панель "Редактирование тела"

Ввод команды: РЕДТЕЛ


Редактирование ребер на 3D телах - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Редактирование ребер на 3D телах
Понятия
Процедуры
Команды

Команды
КРОМКА | Изменение видимости кромок трехмерных граней
МАСШТАБ | Пропорциональное увеличение/уменьшение размеров выбранных объектов в направлениях,и
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПОВЕРНУТЬ | Поворачивает объект вокруг базовой точки.
РЕДТЕЛ | Редактирование граней и ребер 3D тел
СОПРЯЖЕНИЕ | Скругление углов и сопряжение объектов
ФАСКА | Построение фасок в местах пересечения объектов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование вершин на 3D телах - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование вершин на 3D телах
Понятия
Процедуры
Команды

Имеется возможность выбора и редактирования вершин на 3D телах. Выбор левой кнопкой мыши и перетаскивание вершины приводит к "растягиванию" 3D объекта.

Можно также отредактировать всю форму 3D тела путем изменения одной или нескольких вершин с помощью ручек, инструментов ручек или с помощью команд ПЕРЕНЕСТИ, ПОВЕРНУТЬ или МАСШТАБ. При масштабировании вершин следует масштабировать две или большее количество вершин и следить за изменениями в теле.

Когда выполняется перемещение, поворот или масштабирование одной или нескольких вершин в 3D элементарном теле, удаляется журнал этого элементарного тела. Тело не является более истинно элементарным и не доступно для манипулирования в качестве такого тела (с помощью ручек и палитры "Свойства").

Можно также удалять вершины, соединяющие два ребра, являющихся параллельными и коллинеарными и не совмещенными по расположению с какими-либо другими ребрами.

Режимы изменения вершины

Для циклического перебора вариантов изменения нажмите клавишу CTRL при перетаскивании вершины.

При выполнении переноса, поворота или масштабирования вершины без нажатия клавиши CTRL для некоторых плоских граней может быть проведена триангуляция (разделение на две или более плоские треугольные грани).

При выполнении переноса, поворота или масштабирования вершины, сопровождаемых однократным нажатием и отпусканием клавиши CTRL может производиться регулировка некоторых смежных плоских граней.

Если клавиша CTRL нажимается и отпускается во второй раз, возвращается первый режим изменения, как если бы клавиша CTRL не нажималась.

См. также

Перемещение, поворот и масштабирование подобъектов

Использование инструментов ручек для редактирования объектов

Редактирование объектов


Редактирование вершин на 3D телах - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование вершин на 3D телах
Понятия
Процедуры
Команды

Для редактирования вершины на 3D объекте

Для удаления вершины на 3D объекте


Для редактирования вершины на 3D объекте - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование вершин на 3D телах
Понятия
Процедуры
Команды

Для редактирования вершины на 3D объекте

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Нажмите левую кнопку мыши на вершине 3D объекта.
  3. Отпустите CTRL.
  4. Нажмите левую кнопку мыши на вершине и перетащите вершину в требуемое место.


Для удаления вершины на 3D объекте - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Редактирование вершин на 3D телах
Понятия
Процедуры
Команды

Для удаления вершины на 3D объекте

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Нажмите левую кнопку мыши на вершине 3D объекта, где соединяются два ребра, являющихся параллельными и коллинеарными и не совмещенными по расположению с какими-либо другими ребрами.
  3. Отпустите CTRL.
  4. Нажмите DELETE.


Редактирование вершин на 3D телах - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Редактирование вершин на 3D телах
Понятия
Процедуры
Команды

Команды
МАСШТАБ | Пропорциональное увеличение/уменьшение размеров выбранных объектов в направлениях,и
ПЕРЕНЕСТИ | Перемещает объекты на заданное расстояние в указанном направлении
ПОВЕРНУТЬ | Поворачивает объект вокруг базовой точки.
РЕДТЕЛ | Редактирование граней и ребер 3D тел
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сжатие или вытягивание ограниченных областей - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Сжатие или вытягивание ограниченных областей
Понятия
Процедуры
Команды

Для сжатия или вытягивания ограниченных областей можно нажать CTRL + ALT и, удерживая их нажатыми, указать на область. Область должна быть ограничена копланарными линиями или кромками.

Можно сжимать или вытягивать ограниченные области, определяемые объектами указанных ниже типов.

  • Любая область, которую можно штриховать путем выборки точек (с нулевым допуском замкнутости).
  • Области, ограничиваемые пересечением копланарной, линейной геометрии, включая ребра и геометрию в блоках
  • Замкнутые полилинии, области, 3D грани и 2D тела, состоящие из копланарных вершин
  • Области, создаваемые геометрией (включая ребра на гранях), вычерчиваемой копланарно любой грани 3D тела
Показать: "Сжатие ограниченной области"

Для запуска анимации нажмите на стрелку "Просмотр".

Сжимая или вытягивая ограниченную область, нельзя ее сужать. Однако можно выбирать ребра ограниченной области после ее сжатия или вытягивания и манипулировать ребрами для получения такого же эффекта.

Системная переменная IMPLIEDFACE позволяет указывать, допускается ли обнаружение ограниченной области и ее сжатие или вытягивание.

Примечание Если выдавливается существующая грань на 3D теле, создается новый выдавливаемый объект.


Для сжатия или вытягивания ограниченной области - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Сжатие или вытягивание ограниченных областей
Понятия
Процедуры
Команды

Для сжатия или вытягивания ограниченной области

  1. Нажмите и удерживайте нажатыми CTRL + ALT.
  2. Нажмите левую кнопку мыши в любой области, ограничиваемой копланарными линиями или ребрами.
  3. Перетаскиванием мыши сожмите или вытяните ограниченную область.
  4. Укажите высоту нажатием левой кнопки мыши или введите численное значение высоты.

Панель "Моделирование"

Ввод команды: вытягивание

Пульт управления: Панель "3D Создать", "Вытягивание"


Сжатие или вытягивание ограниченных областей - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Сжатие или вытягивание ограниченных областей
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
IMPLIEDFACE | Управляет обнаружением предполагаемых граней
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование инструментов ручек для редактирования объектов - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Использование инструментов ручек для редактирования объектов
Понятия
Процедуры
Команды

Инструменты ручки можно использовать для перемещения и вращения объектов и подобъектов в 3D виде. Инструменты ручки отображаются при выборе объектов и подобъектов в 3D проекции с применением 3D визуального стиля или при использовании команд 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ.

  • Понятие об инструментах ручки
    Инструменты ручек представляют собой значки, используемые в 3D проекции для того, чтобы простым способом ограничивать перемещение или вращение выбранного набора объектов до оси или плоскости.
  • Использование инструмента ручки перемещения для редактирования объектов
    Инструмент ручки перемещения позволяет перемещать выбранный набор объектов без ограничений или с ограничением позицией оси или плоскости.
  • Использование захватного блока вращения для редактирования объекта
    Инструмент ручки вращения позволяет вращать объекты и подобъекты без ограничений или с ограничением позицией оси.


Использование инструментов ручек для редактирования объектов - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Использование инструментов ручек для редактирования объектов
Понятия
Процедуры
Команды

Определение начального местоположения по умолчанию для инструментов ручки

Для перемещения инструмента ручки

Изменение типа инструмента ручки при переносе или повороте объектов

Для перемещения объектов в 3D пространстве вдоль указанной оси

Для перемещения объектов в 3D пространстве с ограничением по указанной плоскости.

Для вращения объектов в 3D пространстве вдоль указанной оси


Использование инструментов ручек для редактирования объектов - Команды

Работа с 3D моделями
Изменение 3D тел и поверхностей
Использование инструментов ручек для редактирования объектов
Понятия
Процедуры
Команды
Команды
3DПЕРЕНЕСТИ | Отображает инструмент ручки перемещения в 3D виде и перемещает объекты на указанное расстояние в заданном направлении
3DПОВЕРНУТЬ | На 3D виде отображает ручку поворота и вращает объекты вокруг базовой точки
Системные переменные
GTAUTO | Управляет автоматическим отображением инструментов ручки при выборе объектов перед запуском команды в видовом экране, которому задан 3D стиль отображения
GTDEFAULT | Управляет автоматическим выполнением команд 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ при выполнении команд ПЕРЕНЕСТИ и ПОВЕРНУТЬ (соответственно) в 3D виде
GTLOCATION | Управляет первоначальным расположением инструментов ручки, если выбор объектов производится до выполнения команд 3DПЕРЕНЕСТИ или 3DПОВЕРНУТЬ
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Понятие об инструментах ручки - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Понятие об инструментах ручки
Понятия
Процедуры
Команды

Инструменты ручек представляют собой значки, используемые в 3D проекции для того, чтобы простым способом ограничивать перемещение или вращение выбранного набора объектов до оси или плоскости.

Имеются инструменты ручек двух типов: ручки перемещения и ручки вращения.

Инструменты ручек отображаются путем вызова команд 3DПЕРЕНЕСТИ или 3DПОВЕРНУТЬ или нажатием на кнопки "3D Перенести" и "3D Повернуть" на инструментальной панели.

Инструменты ручек могут располагаться в любых местах 3D пространства. Данное местоположение (обозначаемое центральным прямоугольником [или базовой ручкой] инструмента ручки) определяет базовую точку для перемещения или вращения. Это равносильно временному изменению расположения в координатах ПСК во время перемещения или вращения выбранных объектов. Далее используются линии (ручки осей) инструмента ручки для ограничения перемещения или вращения позицией оси или плоскости.

Если сначала выбираются объекты, а затем нажимается кнопка мыши на рукоятке осей, и начинается перемещение выбранных объектов, для перехода к инструменту ручки поворота можно нажать клавишу ПРОБЕЛ. Повторное нажатие клавиши ПРОБЕЛ осуществляет возврат к инструменту ручки переноса. При таком способе изменения инструмента ручек перемещение ограничено выбранными осями.

Если запустить команду 3DПЕРЕНЕСТИ или 3DПОВЕРНУТЬ перед выбором объектов, инструмент ручки присоединяется к курсору после создания набора объектов пользователем. Далее можно нажатием левой кнопки мыши поместить инструмент ручки в любое место 3D пространства. Для перемещения инструмента ручки можно нажать кнопку мыши на центральном прямоугольнике (базовой ручке) и далее нажатием кнопки указать новое расположение.

Инструменты ручки отображаются только в 3D проекции, к которой применен 3D визуальный стиль. Если применен визуальный стиль 2D каркаса, то команды 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ автоматически заменяют этот стиль визуальным стилем 3D каркаса.

Если вначале выбираются объекты и далее вызывается команда 3DПЕРЕНЕСТИ или 3DПОВЕРНУТЬ для отображения инструмента ручки, то по умолчанию отображается инструмент ручки перемещения, который помещается в то же место, что и в ПСК, и выравнивается по этому месту. Можно использовать системную переменную GTLOCATION с целью определения начального расположения по умолчанию для инструмента ручки.

Системная переменная GTAUTO используется для определения того, происходит ли автоматическое отображение инструментов ручки при выборе объектов перед запуском команды в 3D проекции, к которой применен 3D визуальный стиль.

Системная переменная GTDEFAULT определяет, вызываются ли команды 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ автоматически при запуске команд ПЕРЕНЕСТИ и ПОВЕРНУТЬ (соответственно) в 3D проекции. По умолчанию, команды 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ не вызываются автоматически при запуске команд ПЕРЕНЕСТИ и ПОВЕРНУТЬ (соответственно) в 3D проекции


Понятие об инструментах ручки - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Понятие об инструментах ручки
Понятия
Процедуры
Команды

Определение начального местоположения по умолчанию для инструментов ручки

Для перемещения инструмента ручки

Изменение типа инструмента ручки при переносе или повороте объектов


Определение начального местоположения по умолчанию для инструментов ручки - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Понятие об инструментах ручки
Понятия
Процедуры
Команды

Определение начального местоположения по умолчанию для инструментов ручки

  1. В командной строке введите gtlocation.
  2. Выполните одно из следующих действий:
    • Введите 0 для определения местоположения, совпадающего с местоположением в ПСК.
    • Введите 1 для выбора в качестве места расположения позицию последнего выбранного объекта или подобъекта.
  3. Нажмите ENTER.


Для перемещения инструмента ручки - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Понятие об инструментах ручки
Понятия
Процедуры
Команды

Для перемещения инструмента ручки

  1. Нажмите кнопку мыши на центральном прямоугольнике (базовой ручке) инструмента ручки.
  2. Нажатием левой кнопки мыши обозначьте новое местоположение.


Изменение типа инструмента ручки при переносе или повороте объектов - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Понятие об инструментах ручки
Понятия
Процедуры
Команды

Изменение типа инструмента ручки при переносе или повороте объектов

  1. На инструментальной панели (панели управления "3D построения") выберите "3D перенос" или "3D поворот".
  2. Выберите объекты и подобъекты для переноса или поворота.

    3. Нажмите и удерживайте нажатой кнопку CTRL для выбора подобъектов (граней, ребер и вершин). Отпустите CTRL для выбора объектов.

  3. По окончании выбора объектов нажмите ENTER.

    4. Инструмент ручки переноса или поворота отображается в соединении с курсором.

  4. Нажатием кнопки мыши выберите местоположение инструмента ручки, обозначая базовую точку для перемещения.
  5. Удерживайте курсор на рукоятке оси на инструменте ручки, пока рукоятка оси не станет желтой и не появится вектор, затем нажмите левую кнопку мыши на рукоятке оси.
  6. Нажмите клавишу ПРОБЕЛ.

    7. Повторное нажатие клавиши ПРОБЕЛ осуществляет возврат к другому инструменту ручки. При таком способе изменения инструмента ручки перемещение ограничено выбранными осями.

Панель инструментов "Моделирование"

Ввод команды: 3DПЕРЕНЕСТИ или 3DПОВЕРНУТЬ


Понятие об инструментах ручки - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Понятие об инструментах ручки
Понятия
Процедуры
Команды

Команды
3DПЕРЕНЕСТИ | Отображает инструмент ручки перемещения в 3D виде и перемещает объекты на указанное расстояние в заданном направлении
3DПОВЕРНУТЬ | На 3D виде отображает ручку поворота и вращает объекты вокруг базовой точки
Системные переменные
GTAUTO | Управляет автоматическим отображением инструментов ручки при выборе объектов перед запуском команды в видовом экране, которому задан 3D стиль отображения
GTDEFAULT | Управляет автоматическим выполнением команд 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ при выполнении команд ПЕРЕНЕСТИ и ПОВЕРНУТЬ (соответственно) в 3D виде
GTLOCATION | Управляет первоначальным расположением инструментов ручки, если выбор объектов производится до выполнения команд 3DПЕРЕНЕСТИ или 3DПОВЕРНУТЬ
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование инструмента ручки перемещения для редактирования объектов - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Использование инструмента ручки перемещения для редактирования объектов
Понятия
Процедуры
Команды

Инструмент ручки перемещения позволяет перемещать выбранный набор объектов без ограничений или с ограничением позицией оси или плоскости.

После выбора объектов и подобъектов, которые необходимо переместить, следует поместить инструмент ручки в любое место в 3D пространстве. Данное местоположение (обозначаемое центральным прямоугольником [или базовой ручкой] инструмента ручки) определяет базовую точку для перемещения и на время изменяет позицию в координатах ПСК в процессе перемещения выбранных объектов.

Далее следует свободно перемещать объекты путем перетаскивания инструмента ручки к наружной стороне или обозначить ось или плоскость, которой ограничивается перемещение.

Примечание По умолчанию, при создании набора объектов в 3D проекции, к которой применен 3D визуальный стиль перед вызовом команды, автоматически отображается инструмент ручки перемещения. Можно отменить автоматическое отображение инструмента ручки перемещения, установив системную переменную GTAUTO равной 0.

Ограничение перемещения позицией оси

Можно использовать инструмент ручки перемещения для ограничения перемещения позицией оси. Следует удерживать курсор на ручке оси на инструменте ручки, пока отображаемый вектор не совпадет по расположению с осью, и далее нажать левую кнопку мыши на рукоятке оси.

При последующем перетаскивании курсора выбранные объекты и подобъекты перемещаются только вдоль указанной оси. Можно нажать левую кнопку мыши или ввести значение для обозначения расстояния смещения от базовой точки.

Ограничение перемещения позицией плоскости

Можно использовать инструмент ручки перемещения для ограничения перемещения позицией плоскости. Следует удерживать курсор на точке, в которой сходятся две линии, отходящие от рукояток оси (эти линии определяют плоскость), пока линии не станут желтыми, а затем нажать левую кнопку мыши на данной точке.

При последующем перетаскивании курсора выбранные объекты и подобъекты перемещаются только вдоль указанной плоскости. Можно нажать левую кнопку мыши или ввести значение для обозначения расстояния смещения от базовой точки.


Использование инструмента ручки перемещения для редактирования объектов - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Использование инструмента ручки перемещения для редактирования объектов
Понятия
Процедуры
Команды

Для перемещения объектов в 3D пространстве вдоль указанной оси

Для перемещения объектов в 3D пространстве с ограничением по указанной плоскости.


Для перемещения объектов в 3D пространстве вдоль указанной оси - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Использование инструмента ручки перемещения для редактирования объектов
Понятия
Процедуры
Команды

Для перемещения объектов в 3D пространстве вдоль указанной оси

  1. На инструментальной панели (панели управления 3D построения) нажмите на "3D перемещение"
  2. Выберите объекты и подобъекты, которые необходимо переместить.

    3. Нажмите и удерживайте нажатой кнопку CTRL для выбора подобъектов (граней, ребер и вершин). Отпустите CTRL для выбора объектов.

  3. По окончании выбора объектов нажмите ENTER.

    4. Инструмент ручки перемещения отображается в соединении с курсором.

  4. Нажатием левой кнопки мыши выберите местоположение захватного блока, обозначая базовую точку для перемещения.
  5. Удерживать курсор на ручке оси на захватном блоке, пока рукоятка оси не станет желтой и не появится вектор, а затем нажмите левую кнопку мыши на рукоятке оси.

  6. Введите значение или нажмите левую кнопку мыши для обозначения расстояния перемещения.

Панель "Моделирование"

Ввод команды: 3DПЕРЕНЕСТИ


Для перемещения объектов в 3D пространстве с ограничением по указанной плоскости. - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Использование инструмента ручки перемещения для редактирования объектов
Понятия
Процедуры
Команды

Для перемещения объектов в 3D пространстве с ограничением по указанной плоскости.

  1. На инструментальной панели (панели управления 3D построения) нажмите "3D перемещение"
  2. Выбрать объекты и подобъекты, которые необходимо переместить.

    3. Нажмите и удерживайте нажатой кнопку CTRL для выбора подобъектов (граней, ребер и вершин). Отпустите CTRL с целью выбора объектов.

  3. По окончании выбора объектов нажмите ENTER.

    4. Инструмент ручки перемещения отображается в соединении с курсором.

  4. Нажатием левой кнопки мыши выберите местоположение инструмента ручки, обозначая базовую точку для перемещения.
  5. Удерживать курсор на точке, в которой сходятся две линии, отходящие от рукояток оси (эти линии определяют плоскость), пока линии не станут желтыми, а затем нажмите левую кнопку мыши.

  6. Введите значение или нажмите левую кнопку мыши для обозначения расстояния перемещения.

Панель "Моделирование"

Ввод команды: 3DПЕРЕНЕСТИ


Использование инструмента ручки перемещения для редактирования объектов - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Использование инструмента ручки перемещения для редактирования объектов
Понятия
Процедуры
Команды

Команды
3DПЕРЕНЕСТИ | Отображает инструмент ручки перемещения в 3D виде и перемещает объекты на указанное расстояние в заданном направлении
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование захватного блока вращения для редактирования объекта - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Использование захватного блока вращения для редактирования объекта
Понятия
Процедуры
Команды

Инструмент ручки вращения позволяет вращать объекты и подобъекты без ограничений или с ограничением позицией оси.

После выбора объектов и подобъектов, которые необходимо вращать, следует поместить инструмент ручки в любое место в 3D пространстве. Данное местоположение (обозначаемое центральным прямоугольником [или базовой ручкой] инструмента ручки) определяет базовую точку для перемещения и на время изменяет позицию в координатах ПСК в процессе поворота выбранных объектов.

Далее можно вращать объекты без ограничений, перетаскивая инструмент ручки к наружной стороне, либо указывать ось, которой ограничивается поворот.

Ограничение угла поворота позицией оси

Можно использовать инструмент ручки вращения для ограничения угла поворота позицией оси. Следует удерживать курсор на одной из рукояток осей инструмента ручки, пока линия не станет желтой и не появится желтый вектор, совпадающий по расположению с осью. Далее нажмите левую кнопку мыши на осевой линии.

При последующем перетаскивании курсора выбранные объекты и подобъекты поворачиваются относительно базовой точки вдоль указанной оси. Можно ввести значение или нажать левую кнопку мыши для обозначения угла поворота.


Для вращения объектов в 3D пространстве вдоль указанной оси - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Использование захватного блока вращения для редактирования объекта
Понятия
Процедуры
Команды

Для вращения объектов в 3D пространстве вдоль указанной оси

  1. На инструментальной панели (панели управления 3D построения) нажмите на "3D вращение"
  2. Выберите объекты и подобъекты, которые необходимо вращать.

    3. Нажмите и удерживайте нажатой кнопку CTRL для выбора подобъектов (граней, ребер и вершин). Отпустите CTRL для выбора объектов.

  3. По окончании выбора объектов нажмите ENTER.

    4. Инструмент ручки вращения отображается в соединении с курсором.

  4. Нажатием левой кнопки мыши выберите местоположение инструмента ручки вращения, обозначая базовую точку для перемещения.
  5. Удерживайте курсор на рукоятке оси на инструменте ручки, пока рукоятка оси не станет желтой и не появится вектор, а затем нажмите левую кнопку мыши.

  6. Введите значение или нажмите левую кнопку мыши для обозначения угла вращения.

Панель "Моделирование"

Ввод команды: 3DПОВЕРНУТЬ


Использование захватного блока вращения для редактирования объекта - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Использование захватного блока вращения для редактирования объекта
Понятия
Процедуры
Команды

Команды
3DПОВЕРНУТЬ | На 3D виде отображает ручку поворота и вращает объекты вокруг базовой точки
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление ребер и граней к телам - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Добавление ребер и граней к телам
Понятия
Процедуры
Команды

Внешний вид граней 3D тел можно изменять путем их клеймения различными объектами, пересекающими грани. При клеймении объект объединяется с гранью, создавая ребро.

Показать: "Добавление ребра, разделение грани на две"

Для запуска анимации нажмите на стрелку "Показать".

С помощью команды КЛЕЙМО AutoCAD позволяет создавать на 3D телах новые грани путем их клеймения дугами, кругами, отрезками, 2D и 3D полилиниями, эллипсами, сплайнами, областями и другими телами. Например, для пересекаемого кругом 3D тела можно выполнить клеймение кривой пересечения. Использованные для клеймения тел объекты можно удалить из чертежа или оставить в нем. Для того, чтобы клеймение могло быть успешно выполнено, необходимо наличие пересечения клеймящего объекта и грани (граней) выбранного тела.

В некоторых случаях невозможно выполнение переноса, поворота или масштабирования следующих объектов, и клейменые ребра и грани могут быть утрачены, если выполняется перенос, поворот или масштабирование следующих подобъектов:

  • граней, содержащих клейменые ребра или грани
  • ребер или вершин со смежными гранями, содержащими клейменые ребра или грани

Примечание При клеймении ребра на грани тела возможен перенос ребер клейменой грани только вместе с плоскостью этой грани.


Для клеймения тела - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Добавление ребер и граней к телам
Понятия
Процедуры
Команды

Для клеймения тела

  1. Выберите в меню "Редактирование" » "Редактирование тела" » "Клеймить ребра".
  2. Выберите 3D тело (1).
  3. Выберите клеймящий объект (2).
  4. Нажмите ENTER для сохранения исходных объектов или введите у для их удаления.
  5. Выберите дополнительные объекты для клеймения или нажмите ENTER.
  6. Нажмите ENTER для выполнения команды.

Панель "Редактирование тела"

Ввод команды: КЛЕЙМО

Пульт управления: Панель 3D построения, "Клеймо"


Добавление ребер и граней к телам - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Добавление ребер и граней к телам
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Разделение 3D тел - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Разделение 3D тел
Понятия
Процедуры
Команды

3D тела могут быть разделены на исходные компонентные 3D тела.

Составные тела могут быть разделены (расчленены) на составляющие. Данная операция применима только к составным 3D телам, части которых не обладают общим объемом. Тела, полученные в результате разделения 3D тела, наследуют слой и цвет исходного объекта. Все 3D тела с уровнями вложений разделяются на составляющие самого низкого уровня вложения.


Для разделения составного 3D тела на отдельные части - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Разделение 3D тел
Понятия
Процедуры
Команды

Для разделения составного 3D тела на отдельные части

  1. Выберите в меню "Редактирование" » "Редактирование тела" » "Разделить".
  2. Выберите 3D тело.
  3. Нажмите ENTER для выполнения команды.

Панель "Редактирование тела"

Ввод команды: РЕДТЕЛ


Разделение 3D тел - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Разделение 3D тел
Понятия
Процедуры
Команды

Команды
РЕДТЕЛ | Редактирование граней и ребер 3D тел
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание оболочек из 3D тел - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Создание оболочек из 3D тел
Понятия
Процедуры
Команды

Можно создать оболочку (тонкостенную оболочку заданной толщины) из 3D тела.

Новые грани создаются путем смещения существующих граней в ту или иную сторону от исходных позиций. Грани, переходящие друг в друга по касательной, считаются при создании оболочки единой гранью.


Для создания оболочки - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Создание оболочек из 3D тел
Понятия
Процедуры
Команды

Для создания оболочки

  1. Выберите в меню "Редактирование" » "Редактирование тела" » "Оболочка".
  2. Выберите 3D тело.
  3. Выберите грань, исключаемую из оболочки (1).
  4. Выберите дополнительные исключаемые грани или нажмите ENTER.
  5. Задайте толщину стенок оболочки.

    6. При положительном значении толщины новые грани оболочки создаются с положительной стороны от исходных; при отрицательном значении - с отрицательной стороны.

  6. Нажмите ENTER для выполнения команды.

Панель "Редактирование тела"

Ввод команды: РЕДТЕЛ


Создание оболочек из 3D тел - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Создание оболочек из 3D тел
Понятия
Процедуры
Команды

Команды
РЕДТЕЛ | Редактирование граней и ребер 3D тел
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Упрощение и проверка корректности 3D тел - Понятия

Работа с 3D моделями
Изменение 3D тел и поверхностей
Упрощение и проверка корректности 3D тел
Понятия
Процедуры
Команды

С помощью команды РЕДТЕЛ имеется возможность автоматического удаления избыточных граней, ребер и вершин 3D тел, а также выполнения проверки на корректность тела.

Можно удалять ребра или вершины, если они находятся на одной и той же поверхности или имеют одно и то же определение вершины на любой стороне ребра или вершины. Тело, грани или кромки на теле отмечаются, а смежные грани, которые находятся на той же поверхности, объединяются. Удаляются все избыточные ребра в 3D теле, которые получены в результате клеймения или не используются.

Имеется возможность проверки, является ли используемое 3D тело корректным 3D телом. Если 3D тело корректно, можно редактировать объект, не вызывая сообщения об ошибках. Если 3D тело некорректно, редактирование объекта не допускается.


Упрощение и проверка корректности 3D тел - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Упрощение и проверка корректности 3D тел
Понятия
Процедуры
Команды

Для упрощения тела

Для проверки целостности тела


Для упрощения тела - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Упрощение и проверка корректности 3D тел
Понятия
Процедуры
Команды

Для упрощения тела

  1. Выберите в меню "Редактирование" » "Редактирование тела" » "Упростить".
  2. Выберите 3D тело (1).
  3. Нажмите ENTER для выполнения команды.

Панель "Редактирование тела"

Ввод команды: РЕДТЕЛ


Для проверки целостности тела - Процедуры

Работа с 3D моделями
Изменение 3D тел и поверхностей
Упрощение и проверка корректности 3D тел
Понятия
Процедуры
Команды

Для проверки целостности тела

  1. Выберите в меню "Редактирование" » "Редактирование тела" » "Проверить".
  2. Выберите 3D тело.
  3. Нажмите ENTER для выполнения команды.

Панель "Редактирование тела"

Ввод команды: РЕДТЕЛ


Упрощение и проверка корректности 3D тел - Команды

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Упрощение и проверка корректности 3D тел
Понятия
Процедуры
Команды

Команды
РЕДТЕЛ | Редактирование граней и ребер 3D тел
Системные переменные
SOLIDCHECK | Включает и отключает проверку тела для текущего сеанса
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение сечений и 2D чертежей из 3D моделей - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Понятия
Процедуры
Команды

Предусмотрена возможность построения поперечного сечения 3D тела с помощью пересечения плоскости и твердотельных объектов для создания области. Можно также использовать режущую плоскость, называемую объект-сечение, которая позволяет рассматривать в режиме реального времени виды поперечных сечений в 3D модели. Виды сечений можно зафиксировать в качестве плоскостных представлений.

  • Сечение 3D тел
    Имеется возможность построения поперечного сечения 3D тела. Результатом является двумерный объект, имеющий форму соответствующего сечения. Предусмотрена также возможность использования режущей плоскости, называемой объект-сечение, которая позволяет увидеть в режиме реального времени профиль разреза пересечённых тел.
  • Работа с объектами-сечениями
    Можно строить виды сечений из 3D моделей, определяемые тем, в каком месте прозрачная режущая плоскость, называемая объект-сечение, пересекает модель. Если на объекте-сечении активна функция псевдоразреза, можно увидеть внутренние детали модели при неподвижной режущей плоскости или при её перемещении через 3D модель. Применение псевдоразреза позволяет динамически изменять профиль среза пересекаемого тела.
  • Применение псевдоразреза
    Если для объекта-сечения включена функция псевдоразреза, в пространстве модели можно динамически строить сечения 3D модели. При перемещении объекта-сечения через 3D модель его прозрачный указатель секущей плоскости разрезает тело, поверхность или область в режиме реального времени.
  • Создание 2D и 3D сечений
    Предусмотрена возможность создания представления области поперечного сечения в виде 2D или 3D блока в месте пересечения 3D модели объектом-сечением.
  • Создание плоского вида
    Командой ПЛОСКСНИМОК создаётся плоский вид всех 3D тел и областей текущего вида.


Построение сечений и 2D чертежей из 3D моделей - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Понятия
Процедуры
Команды

Построение поперечного сечения тела

Создание объекта-сечения с помощью выбора грани

Создание объекта-сечения с использованием двух точек

Создание объекта-сечения с использованием сегментов с изломами

Создание объекта-сечения на предварительно заданной ортогональной плоскости

Изменение режима объекта-сечения с помощью ручки "Меню"

Переименование объекта-сечения

Изменение режима объекта-сечения с использованием палитры свойств

Изменение прозрачности и цвета указателя секущей плоскости

Изменение высоты указателя секущей плоскости

Связывание объекта-сечения с видом или камерой

Сохранение инструмента объекта-сечения в качестве инструмента инструментальной панели

Добавление изломов секущей плоскости

Включение и отключение функции псевдоразреза

Отображение геометрии срезов

Создание 2D или 3D сечения

Создание плоского 2D вида 3D модели


Построение сечений и 2D чертежей из 3D моделей - Команды

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Понятия
Процедуры
Команды
Команды
3DДВФ | Создает 3D DWF-файл пользовательской трехмерной модели и отображает ее в программе просмотра DWF
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
ИЗЛОМРАЗРЕЗ | Добавление сегмента с изломом к объекту-сечению
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПЛОСКСНИМОК | Создание 2D представления всех 3D объектов в текущем виде
ПСЕВДОРАЗРЕЗ | Включение режима псевдоразреза для выбранного объекта-сечения.
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
СЕЧЕНИЕ | Создание области на основе пересечения плоскости и тел
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Т-ПРОФИЛЬ | Создает профили трехмерных тел в пространстве листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сечение 3D тел - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Сечение 3D тел
Понятия
Процедуры
Команды

Имеется возможность построения поперечного сечения 3D тела. Результатом является двумерный объект, имеющий форму соответствующего сечения. Предусмотрена также возможность использования режущей плоскости, называемой объект-сечение, которая позволяет увидеть в режиме реального времени профиль разреза пересечённых тел.

Команда СЕЧЕНИЕ позволяет построить поперечное сечение тела. Для определения плоскости поперечного сечения задаются три точки. Плоскость поперечного сечения можно определить также с помощью другого объекта, текущего вида, оси Z или плоскости XY, YZ или ZX. Плоскость поперечного сечения размещается на текущем слое.

Команда СЕКПЛОСКОСТЬ позволяет построить объект-сечение, который выступает в качестве режущей плоскости для тел, поверхностей или областей (двумерных областей, построенные на основе замкнутых контуров). Если включить функцию псевдоразреза, то при перемещении объекта-сечения через 3D модель в пространстве модели внутренние детали отображаются в режиме реального времени.

Для построения объекта-сечения нужно переместить курсор на любую грань 3D модели и нажать кнопку мыши для автоматического размещения объекта-сечения. Можно также указать точки для построения прямой режущей плоскости или указать несколько точек для построения плоскости, содержащей сегменты с изломами. Другой метод заключается в создании ортогонального вида, например, вида спереди, сверху или сзади.


Построение поперечного сечения тела - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Сечение 3D тел
Понятия
Процедуры
Команды

Построение поперечного сечения тела

  1. Выберите в меню "Рисование" » "Моделирование"», "Сечение".
  2. Выберите объект для построения поперечного сечения.
  3. Задайте три точки для определения плоскости поперечного сечения.

Ввод команды: СЕЧЕНИЕ

Примечание Для того чтобы заштриховать полученное сечение, необходимо вначале совместить ПСК с плоскостью поперечного сечения.


Сечение 3D тел - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Сечение 3D тел
Понятия
Процедуры
Команды

Команды
СЕЧЕНИЕ | Создание области на основе пересечения плоскости и тел
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с объектами-сечениями - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Работа с объектами-сечениями
Понятия
Процедуры
Команды

Можно строить виды сечений из 3D моделей, определяемые тем, в каком месте прозрачная режущая плоскость, называемая объект-сечение, пересекает модель. Если на объекте-сечении активна функция псевдоразреза, можно увидеть внутренние детали модели при неподвижной режущей плоскости или при её перемещении через 3D модель. Применение псевдоразреза позволяет динамически изменять профиль среза пересекаемого тела.

  • Обзор объектов-сечений
  • Построение объектов-сечений
    Объекты-сечения создаются с помощью команды СЕКПЛОСКОСТЬ.
  • Задание режимов объекта-сечения
    Объекты-сечения имеют три режима: "Секущая плоскость", "Контур сечения" и "Объем сечения". В зависимости от выбранного режима режущая плоскость представляется в виде 2D плоскости, 2D прямоугольника или 3D ящика. Ручки позволяют регулировать длину, ширину и высоту режущей области.
  • Применение ручек объекта-сечения
    При выборе объекта-сечения отображаются различные типы ручек, выполняющих разные функции. Существуют следующие ручки:
  • Открытие контекстного меню "Объект-сечение"
    Выбрав объект-сечение, можно получить доступ к следующим элементам управления в контекстном меню, нажав правой кнопкой мыши на секущей линии.
  • Изменить свойства объекта-сечения
    Объекты-сечения, точно так же, как и другие объекты AutoCAD, имеют свойства. Свойства хранятся в секущей линии и могут быть открыты в палитре свойств. Например, можно изменить имя объекта-сечения, слой и тип линий, а также цвет и прозрачность указателя секущей плоскости (прозрачная режущая плоскость объекта-сечения).
  • Связать объекты-сечения с видами и камерами
    Связывание объектов-сечений с именованными видами и камерами выполняется в диалоговом окне "Диспетчер видов".
  • Публикация объектов-сечений
    Предусмотрена возможность управления видимостью объектов-сечений во время их тонирования, печати или просмотра в программе Autodesk DWF Viewer.
  • Сохранение объекта-сечения в качестве инструмента инструментальной палитры
    Аналогично другим объектам, из конкретных объектов-сечений можно создавать инструменты, доступные из инструментальной палитры.
  • Добавление изломов секущей плоскости
    Построение секущей линии с несколькими сегментами (изломами) осуществляется в режиме "Вычерчивание сечения" команды СЕКПЛОСКОСТЬ. Другой способ добавления излома к существующему объекту-сечению заключается в использовании пункта "Добавить излом секущей плоскости" контекстного меню.


Работа с объектами-сечениями - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Работа с объектами-сечениями
Понятия
Процедуры
Команды

Создание объекта-сечения с помощью выбора грани

Создание объекта-сечения с использованием двух точек

Создание объекта-сечения с использованием сегментов с изломами

Создание объекта-сечения на предварительно заданной ортогональной плоскости

Изменение режима объекта-сечения с помощью ручки "Меню"

Переименование объекта-сечения

Изменение режима объекта-сечения с использованием палитры свойств

Изменение прозрачности и цвета указателя секущей плоскости

Изменение высоты указателя секущей плоскости

Связывание объекта-сечения с видом или камерой

Сохранение инструмента объекта-сечения в качестве инструмента инструментальной панели

Добавление изломов секущей плоскости


Работа с объектами-сечениями - Команды

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Работа с объектами-сечениями
Понятия
Процедуры
Команды
Команды
3DДВФ | Создает 3D DWF-файл пользовательской трехмерной модели и отображает ее в программе просмотра DWF
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
ИЗЛОМРАЗРЕЗ | Добавление сегмента с изломом к объекту-сечению
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор объектов-сечений - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Обзор объектов-сечений
Понятия
Процедуры
Команды

С помощью команды СЕКПЛОСКОСТЬ можно построить один или несколько объектов-сечений и разместить их в объёме 3D модели. Активизирование функции псевдоразреза на объекте-сечении позволяет видеть динамические разрезы в 3D модели при перемещении через неё объекта-сечения, не изменяя при этом сами 3D объекты.

Объекты-сечения снабжены прозрачным указателем секущей плоскости, который действует как режущая плоскость. В силу прозрачности он является удобным визуальным инструментом, поскольку позволяет видеть геометрию с любой стороны режущей плоскости. Эту плоскость можно легко размещать и перемещать в любое место в пределах 3D модели, состоящей из 3D тел, поверхностей или областей (двумерных областей, построенных на основе замкнутых контуров).

Секущая плоскость включает секущую линию, в которой хранятся свойства объекта-сечения. Можно иметь несколько объектов-сечений, каждый из которых имеет индивидуальные свойства. Например, на одном объекте-сечении может отображаться штриховка в том месте, где пересекается 3D модель, в то время как на другом объекте-сечении может отображаться иной тип линий для обозначения границы пересечённой области.

Каждый объект-сечение может быть сохранён в качестве инструмента инструментальной палитры, что позволяет обеспечить к нему быстрый доступ без необходимости перенастройки свойств при очередном создании нового объекта-сечения.

Секущая плоскость может быть прямой линией или линией, имеющей несколько сегментов или имеющей сегменты с изломами. Например, секущая линия, содержащая излом, даёт возможность построить из цилиндра клин в форме куска пирога.

Объект-сечение с сегментом с изломом

После получения необходимого вида сечения можно выполнить генерацию точного 2D или 3D блока из 3D модели. Эти блоки можно анализировать или проверять на соблюдение зазоров и условий взаимодействия. Кроме этого, на них можно наносить размеры или использовать их в качестве каркасных или тонированных представлений в документации и презентационных чертежах.


Работа с объектами-сечениями

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Работа с объектами-сечениями
Понятия
Процедуры
Команды

Нет процедур.


Обзор объектов-сечений - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Обзор объектов-сечений
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Построение объектов-сечений - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Построение объектов-сечений
Понятия
Процедуры
Команды

Объекты-сечения создаются с помощью команды СЕКПЛОСКОСТЬ.

Используемый по умолчанию способ заключается в перемещении курсора на грань 3D модели и размещении объекта-сечения последующим нажатием кнопки мыши. Объект-сечение автоматически выравнивается относительно плоскости выбранной грани.

Объект-сечение можно построить, выбрав две точки для создания прямой секущей линии.

На анимации показано построение объекта-сечения посредством задания двух точек. После построения и включения функции псевдоразреза объект-сечение перемещается в разные области модели; при этом построение сечений выполняется в режиме реального времени.

Показать: "Получение сечения 3D модели с помощью объекта-сечения (при включённой функции псевдоразреза)"

Для запуска анимации нажмите на стрелку "Показать".

Если требуется секущая линия, содержащая сегменты с изломами, в режиме "Вычерчивание сечения" можно указать несколько точек внутри 3D модели.

В режиме "Ортогональный" можно быстро построить объект-сечение, выровненный относительно предварительно выбранной ортогональной плоскости. Перед построением объекта-сечения оцениваются все 3D объекты чертежа и вычисляется воображаемая 3D граница, окружающая их. Затем объект-сечение располагается таким образом, чтобы он проходил через центр 3D контура и был ориентирован в сторону выбранной ортогональной плоскости.


Построение объектов-сечений - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Построение объектов-сечений
Понятия
Процедуры
Команды

Создание объекта-сечения с помощью выбора грани

Создание объекта-сечения с использованием двух точек

Создание объекта-сечения с использованием сегментов с изломами

Создание объекта-сечения на предварительно заданной ортогональной плоскости


Создание объекта-сечения с помощью выбора грани - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Построение объектов-сечений
Понятия
Процедуры
Команды

Создание объекта-сечения с помощью выбора грани

  1. Выберите в меню "Рисование" » "Моделирование" » "Секущая плоскость".
  2. Нажмите кнопку мыши для выбора грани на модели.

    3. На плоскости выбранной грани создаётся объект-сечение.

  3. Нажмите на секущей линии для отображения её ручек.
  4. Выберите ручку для перемещения секущей плоскости через 3D объект.

    5. Построенный объект-сечение имеет состояние "Секущая плоскость". Функция псевдоразреза включена.


Создание объекта-сечения с использованием двух точек - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Построение объектов-сечений
Понятия
Процедуры
Команды

Создание объекта-сечения с использованием двух точек

  1. Выберите в меню "Рисование" » "Моделирование" » "Секущая плоскость".
  2. Укажите первую точку объекта-сечения.
  3. Укажите конечную точку.

Объект-сечение строится между этими двумя точками. Функция псевдоразреза отключена.


Создание объекта-сечения с использованием сегментов с изломами - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Построение объектов-сечений
Понятия
Процедуры
Команды

Создание объекта-сечения с использованием сегментов с изломами

  1. Выберите в меню "Рисование" » "Моделирование" » "Секущая плоскость".
  2. Введите d ("Вычерчивание сечения").
  3. Укажите начальную точку объекта-сечения.
  4. Укажите вторую точку для построения первого сегмента с изломом.

    5. От этой точки невозможно построить пересекающиеся сегменты.

  5. Продолжайте задание конечных точек сегментов, затем нажмите клавишу ENTER.
  6. Задайте точку в направлении секущего разреза.

Создаётся объект-сечение с несколькими сегментами, имеющими состояние "Контур сечения". Функция псевдоразреза отключёна.


Создание объекта-сечения на предварительно заданной ортогональной плоскости - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Построение объектов-сечений
Понятия
Процедуры
Команды

Создание объекта-сечения на предварительно заданной ортогональной плоскости

  1. Выберите в меню "Рисование" » "Моделирование" » "Секущая плоскость".
  2. Введите o (ортогонально).
  3. Выберите вариант выравнивания.

Создаётся объект-сечение, находящийся в центре воображаемого 3D контура, охватывающего все 3D объекты чертежа. Он размещается на выбранной ортогональной плоскости. Функция псевдоразреза включёна.


Построение объектов-сечений - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Построение объектов-сечений
Понятия
Процедуры
Команды

Команды
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание режимов объекта-сечения - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Задание режимов объекта-сечения
Понятия
Процедуры
Команды

Объекты-сечения имеют три режима: "Секущая плоскость", "Контур сечения" и "Объем сечения". В зависимости от выбранного режима режущая плоскость представляется в виде 2D плоскости, 2D прямоугольника или 3D ящика. Ручки позволяют регулировать длину, ширину и высоту режущей области.

  • Секущая плоскость.Отображение секущей линии и прозрачного указателя секущей плоскости. Режущая плоскость расширяется неограниченно во всех направлениях.
  • Контур сечения. 2D прямоугольник представляет XY границы режущей плоскости. Режущая плоскость уходит в бесконечность вдоль оси Z.
  • Объем сечения. 3D параллелепипед (ящик) представляет границы режущей плоскости во всех направлениях.


Изменение режима объекта-сечения с помощью ручки "Меню" - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Задание режимов объекта-сечения
Понятия
Процедуры
Команды

Изменение режима объекта-сечения с помощью ручки "Меню"

  1. Выберите объект-сечение для отображения его ручек.
  2. Выберите ручку "Меню".
  3. В меню режимов сечения выберите нужный режим.

Режим объекта-сечения на видовом экране меняется на выбранный.


Задание режимов объекта-сечения - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Задание режимов объекта-сечения
Понятия
Процедуры
Команды

Команды
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Применение ручек объекта-сечения - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Применение ручек объекта-сечения
Понятия
Процедуры
Команды

При выборе объекта-сечения отображаются различные типы ручек, выполняющих разные функции. Существуют следующие ручки:

  • Базовая ручка. Выполняет функцию ручки базовой точки объекта-сечения для перемещения, масштабирования и поворота объекта-сечения. Она всегда находится рядом с ручкой "Меню".
  • Ручка "Меню". Отображает меню режимов объекта-сечения.
  • Ручка "Направление". Показывает направление, относительно которого строятся 2D сечения и в котором просматриваются псевдоразрезы. Для изменения направления секущей плоскости на противоположное нажмите кнопку мыши на ручке "Направление".
  • Ручка "Стрелка". Перемещает сегменты секущей линии в перпендикулярном им направлении. Во время перемещения сегментов их длина изменяется, но угол между смежными сегментами сохраняется.
  • Ручка "Вторая". Вращает объект-сечение вокруг базовой ручки.
  • Ручки концов сегмента. Действуют аналогично ручкам полилинии, но не могут быть перемещены так, чтобы сегменты пересекались. Ручки концов сегментов отображаются в конечных точках сегментов с изломами.

    • Примечание Невозможно выбрать несколько ручек объекта-сечения одновременно.


Применение ручек объекта-сечения - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Применение ручек объекта-сечения
Понятия
Процедуры
Команды

Команды
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Открытие контекстного меню "Объект-сечение" - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Открытие контекстного меню "Объект-сечение"
Понятия
Процедуры
Команды

Выбрав объект-сечение, можно получить доступ к следующим элементам управления в контекстном меню, нажав правой кнопкой мыши на секущей линии.

  • Активизировать функцию псевдоразреза. Включает и отключает функцию псевдоразреза для выбранного объекта-сечения.
  • Показать геометрию срезов. Отображает геометрическую структуру, полученную вырезанием с использованием параметров отображения, установленными в диалоговом окне "Параметры сечения". Эта опция доступна при включенной функции псевдоразреза.
  • Параметры псевдоразрезов. Отображает диалоговое окно "Параметры сечения".
  • Создание 2D/3D сечения. Отображает диалоговое окно "Создание сечения/уровня".
  • Добавить излом секущей плоскости. Добавляет новый сегмент, излом, к секущей линии.


Открытие контекстного меню "Объект-сечение" - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Открытие контекстного меню "Объект-сечение"
Понятия
Процедуры
Команды

Команды
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменить свойства объекта-сечения - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Изменить свойства объекта-сечения
Понятия
Процедуры
Команды

Объекты-сечения, точно так же, как и другие объекты AutoCAD, имеют свойства. Свойства хранятся в секущей линии и могут быть открыты в палитре свойств. Например, можно изменить имя объекта-сечения, слой и тип линий, а также цвет и прозрачность указателя секущей плоскости (прозрачная режущая плоскость объекта-сечения).


Изменить свойства объекта-сечения - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Изменить свойства объекта-сечения
Понятия
Процедуры
Команды

Переименование объекта-сечения

Изменение режима объекта-сечения с использованием палитры свойств

Изменение прозрачности и цвета указателя секущей плоскости

Изменение высоты указателя секущей плоскости


Переименование объекта-сечения - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Изменить свойства объекта-сечения
Понятия
Процедуры
Команды

Переименование объекта-сечения

  1. Нажмите правой кнопкой мыши на объекте-сечении. Нажмите кнопку "Свойства".
  2. В группе "Объект-сечение" введите новое имя в поле "Имя".


Изменение режима объекта-сечения с использованием палитры свойств - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Изменить свойства объекта-сечения
Понятия
Процедуры
Команды

Изменение режима объекта-сечения с использованием палитры свойств

  1. Нажмите правой кнопкой мыши на объекте-сечении. Нажмите кнопку "Свойства".
  2. В группе "Объект-сечение" измените значение в поле "Тип".

Режим объекта-сечения на видовом экране меняется на выбранный.


Изменение прозрачности и цвета указателя секущей плоскости - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Изменить свойства объекта-сечения
Понятия
Процедуры
Команды

Изменение прозрачности и цвета указателя секущей плоскости

  1. Нажмите правой кнопкой мыши на объекте-сечении. Нажмите кнопку "Свойства".
  2. В группе "Объект-сечение" введите для параметра "Прозрачность плоскости" значение из интервала 1 - 100. При значении "1" указатель секущей плоскости становится непрозрачным.
  3. Выберите цвет плоскости (параметр "Цвет плоскости").

    4. На видовом экране обновляется указатель секущей плоскости.


Изменение высоты указателя секущей плоскости - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Изменить свойства объекта-сечения
Понятия
Процедуры
Команды

Изменение высоты указателя секущей плоскости

  1. Нажмите правой кнопкой мыши на объекте-сечении. Нажмите кнопку "Свойства".
  2. В группе "Геометрия" измените значение параметра "Верхняя плоскость". Изменяется расстояние от секущей линии до верхней кромки секущей плоскости.
  3. Измените значение параметра "Нижняя плоскость". Это приводит к изменению расстояния от секущей линии до нижней кромки секущей плоскости.

    4. На видовом экране обновляется указатель секущей плоскости.


Изменить свойства объекта-сечения - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Изменить свойства объекта-сечения
Понятия
Процедуры
Команды

Команды
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Связать объекты-сечения с видами и камерами - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Связать объекты-сечения с видами и камерами
Понятия
Процедуры
Команды

Связывание объектов-сечений с именованными видами и камерами выполняется в диалоговом окне "Диспетчер видов".

Когда становятся активными именованный вид или камера, связанные с объектом-сечением, для этого объекта-сечения включается функция псевдоразреза. В случае 3D модели, имеющей несколько объектов-сечений, удобно связать конкретный объект-сечение с видом или камерой. Впоследствии можно быстро восстановить сохранённый вид сечения или камеру, что автоматически активизирует функцию псевдоразреза для связанного объекта-сечения.

Например, имеются два объекта-сечения, разрезающих 3D модель в разных направлениях. Объект-сечение A разрезает модель по ширине; объект-сечение B разрезает модель по длине. Требуется увидеть секущий разрез, перпендикулярный направлению взгляда. Связав каждый объект-сечение с видом или камерой, можно быстро переключиться между двумя видами и увидеть нужное поперечное сечение.


Связывание объекта-сечения с видом или камерой - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Связать объекты-сечения с видами и камерами
Понятия
Процедуры
Команды

Связывание объекта-сечения с видом или камерой

  1. Выберите меню "Вид" » "Именованные виды".
  2. На левой панели диалогового окна "Диспетчер видов" в поле "Виды моделей" выберите именованный вид или камеру.
  3. В разделе "Общие" в раскрывающемся списке "Псевдоразрез" выберите объект-сечение по имени.
  4. Нажмите "ОК".

    5. Объект-сечение связан с именованным видом или камерой. Когда именованный вид или камера восстанавливается, включается функция псевдоразреза для связанного объекта-сечения.


Связать объекты-сечения с видами и камерами - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Связать объекты-сечения с видами и камерами
Понятия
Процедуры
Команды

Команды
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Публикация объектов-сечений - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Публикация объектов-сечений
Понятия
Процедуры
Команды

Предусмотрена возможность управления видимостью объектов-сечений во время их тонирования, печати или просмотра в программе Autodesk DWF Viewer.

Тонирование объектов-сечений

При включённой функции псевдоразреза все линии на объекте-сечении тонируются как 2D линии. Указатель секущей плоскости тонируется как прозрачный материал. Управление степенью его прозрачности осуществляется на палитре свойств объекта-сечения.

Печать объектов-сечений

Если для объекта-сечения установлен режим "Контур сечения" или "Объём сечения", отображаемые линии не печатаются. Указатель секущей плоскости изображается при печати так, как если бы он ему был назначен прозрачный материал, но не с той точностью воспроизведения, как при тонировании. Если при выводе на печать не требуется изображать секущую линию, поместите объект-сечение на отключённый слой.

Просмотр объектов-сечений в программе Autodesk DWF Viewer

Если на объекте-сечении активна функция псевдоразреза, 3D модель отображается в DWF Viewer с максимально возможной точностью. Геометрическая структура, скрытая при создании псевдоразреза, скрывается также при ее отображении в программе DWF Viewer. Параметры отображения, связанные с псевдоразрезами, отображаются в этой программе так же, как на чертеже. Например, пунктирные линии и образцы штриховок, связанные с областью пересечения 3D модели, выглядят такими же в DWF Viewer.

Объект-сечение в DWF Viewer невидим.


Публикация объектов-сечений - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Публикация объектов-сечений
Понятия
Процедуры
Команды

Команды
3DДВФ | Создает 3D DWF-файл пользовательской трехмерной модели и отображает ее в программе просмотра DWF
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение объекта-сечения в качестве инструмента инструментальной палитры - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Сохранение объекта-сечения в качестве инструмента инструментальной палитры
Понятия
Процедуры
Команды

Аналогично другим объектам, из конкретных объектов-сечений можно создавать инструменты, доступные из инструментальной палитры.

Можно иметь несколько объектов-сечений, имеющих свои собственные наборы свойств. Сохранив каждый объект-сечение в качестве инструмента, можно быстро создавать объекты-сечения без необходимости каждый раз менять их параметры.


Сохранение инструмента объекта-сечения в качестве инструмента инструментальной панели - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Сохранение объекта-сечения в качестве инструмента инструментальной палитры
Понятия
Процедуры
Команды

Сохранение инструмента объекта-сечения в качестве инструмента инструментальной панели

  1. На объекте-сечении выберите секущую линию.
  2. Перетащите объект-сечение на инструментальную панель и, не отпуская кнопку мыши, переведите курсор на то место инструментальной панели, в которое нужно поместить инструмент.

    3. Черная линия на палитре указывает возможное расположение инструмента.

  3. Отпустите кнопку мыши.

    4. Объект-сечение сохраняется в качестве инструмента инструментальной панели.


Сохранение объекта-сечения в качестве инструмента инструментальной палитры - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Сохранение объекта-сечения в качестве инструмента инструментальной палитры
Понятия
Процедуры
Команды

Команды
ИНСТРПАЛВКЛ | Открытие окна инструментальных палитр
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление изломов секущей плоскости - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Добавление изломов секущей плоскости
Понятия
Процедуры
Команды

Построение секущей линии с несколькими сегментами (изломами) осуществляется в режиме "Вычерчивание сечения" команды СЕКПЛОСКОСТЬ. Другой способ добавления излома к существующему объекту-сечению заключается в использовании пункта "Добавить излом секущей плоскости" контекстного меню.

Показать: "Добавление излома к объекту-сечению"

Для запуска анимации нажмите на стрелку "Показать".

Объект-сечение, построенный с помощью сегмента с изломом

При добавлении излома к существующему объекту-сечению создаётся сегмент, перпендикулярный выбранному сегменту, в направлении, определяемом ручкой "Направление". К боковым или задним линиям объекта-сечения добавить изломы невозможно. При добавлении изломов к сечению параметр "Ближайшая привязка" временно включается.

После добавления изломов можно улучшить сегменты с изломами, используя ручки объекта-сечения .


Добавление изломов секущей плоскости - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Добавление изломов секущей плоскости
Понятия
Процедуры
Команды

Добавление изломов секущей плоскости

  1. На объекте-сечении выберите секущую линию.
  2. Нажмите на секущей линии правую кнопку мыши . Выберите "Добавить излом секущей плоскости".
  3. Переведите курсор на секущую линию.
  4. Выберите точку на секущей линии, в которую нужно поместить излом, перпендикулярный выбранному сегменту.

    5. Для построения других изломов повторите эти действия.

Примечание В программе не допускается введение изломов, которые приводят к самопересечению или замыканию линии. Если это происходит, точка ввода игнорируется, и в командной строке выводится сообщение об ошибке.


Добавление изломов секущей плоскости - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Добавление изломов секущей плоскости
Понятия
Процедуры
Команды

Команды
ИЗЛОМРАЗРЕЗ | Добавление сегмента с изломом к объекту-сечению
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Применение псевдоразреза - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Применение псевдоразреза
Понятия
Процедуры
Команды

Если для объекта-сечения включена функция псевдоразреза, в пространстве модели можно динамически строить сечения 3D модели. При перемещении объекта-сечения через 3D модель его прозрачный указатель секущей плоскости разрезает тело, поверхность или область в режиме реального времени.

  • Принцип работы функции псевдоразреза
    Функция псевдоразреза представляет собой аналитический инструмент, позволяющий видеть геометрию среза в 3D теле, поверхности или области в том месте, где объект-сечение пересекает 3D геометрическую структуру.


Применение псевдоразреза - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Применение псевдоразреза
Понятия
Процедуры
Команды

Включение и отключение функции псевдоразреза

Отображение геометрии срезов


Применение псевдоразреза - Команды

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Применение псевдоразреза
Понятия
Процедуры
Команды
Команды
ПСЕВДОРАЗРЕЗ | Включение режима псевдоразреза для выбранного объекта-сечения.
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Принцип работы функции псевдоразреза - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Принцип работы функции псевдоразреза
Понятия
Процедуры
Команды

Функция псевдоразреза представляет собой аналитический инструмент, позволяющий видеть геометрию среза в 3D теле, поверхности или области в том месте, где объект-сечение пересекает 3D геометрическую структуру.

Можно также применять функцию псевдоразреза для анализа модели, перемещая объект-сечение назад и вперёд. Например, плавно передвигая объект-сечение через двигатель в сборе, можно визуализировать его внутренние компоненты.

Перед началом работы с псевдоразрезом необходимо разобраться с некоторыми ключевыми свойствами этой функции.

  • Использование функции псевдоразреза возможно только для 3D объектов и областей в пространстве модели.
  • Функция псевдоразреза включается или отключается в зависимости от режима, используемого при создании объекта-сечения. Например, выбор грани создаёт объект-сечение с включённой функцией псевдоразреза; в режиме "Вычерчивание сечения" создаётся объект-сечение с отключённой функцией псевдоразреза. После того как объект-сечение создан, функцию псевдоразреза любого объекта-сечения можно включить или отключить вручную.
  • В чертеже можно иметь несколько объектов-сечений; однако функция псевдоразреза может быть активна только для одного из них. Например, в модели имеется два объекта-сечения: Сечение A и Сечение B. Если функция псевдоразреза Сечения A включена и выполняется активизирование функции псевдоразреза для Сечения B, функция псевдоразреза для Сечения A автоматически отключается.
  • Отключение слоя объекта-сечения не приводит к отключению функции псевдоразреза, но при замораживании слоя функция отключается.
  • При включенной функции псевдоразреза можно с помощью ручек плавно передвигать сегменты объекта-сечения и наблюдать результирующий эффект в 3D модели.


Принцип работы функции псевдоразреза - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Принцип работы функции псевдоразреза
Понятия
Процедуры
Команды

Включение и отключение функции псевдоразреза

Отображение геометрии срезов


Включение и отключение функции псевдоразреза - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Принцип работы функции псевдоразреза
Понятия
Процедуры
Команды

Включение и отключение функции псевдоразреза

  1. Выберите объект-сечение.
  2. Нажмите на секущей линии правую кнопку мыши
  3. Для включения функции выберите пункт "Активизировать формирование псевдоразрезов". Если функция включена, нажмите, чтобы отключить ее.


Отображение геометрии срезов - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Принцип работы функции псевдоразреза
Понятия
Процедуры
Команды

Отображение геометрии срезов

  1. Выберите объект-сечение.
  2. Нажмите на секущей линии правую кнопку мыши Для включения функции выберите пункт "Показать геометрию срезов.

    3. Геометрия срезов отображается в соответствии с настройками "Линия переднего плана" в диалоговом окне "Параметры сечения".


Принцип работы функции псевдоразреза - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Принцип работы функции псевдоразреза
Понятия
Процедуры
Команды

Команды
ПСЕВДОРАЗРЕЗ | Включение режима псевдоразреза для выбранного объекта-сечения.
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание 2D и 3D сечений - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Создание 2D и 3D сечений
Понятия
Процедуры
Команды

Предусмотрена возможность создания представления области поперечного сечения в виде 2D или 3D блока в месте пересечения 3D модели объектом-сечением.

Тип создаваемого блока задаётся в диалоговом окне "Создание сечения/уровня". Если в проекте требуется построение 2D чертежей уровней или 2D поперечных сечений, в режиме "2D сечение / уровень" создаётся точное представление блока, готовое для нанесения размеров. Если создаётся презентация и требуется опубликовать или тонировать срез 3D модели, используется режим "3D сечение".

При создании сечений нужно учитывать некоторые дополнительные обстоятельства.

  • Как 2D, так и 3D сечения могут быть вставлены в чертёж в виде неименованного блока или сохранены во внешнем файле в виде "пблока". Созданные сечения строятся в виде блоков, которые можно переименовывать и редактировать командой БЛОКРЕД.
  • Перед вставкой блоков в чертёж их можно поворачивать и изменять их масштаб. Предусмотрено также изменение базовой точки вставки.
  • Для создания сечений могут использоваться 3D объекты, вставленные в чертёж в виде внешних ссылок и блоков.
  • 2D сечения строятся с помощью 2D отрезков, дуг, окружностей, эллипсов, сплайнов и образцов штриховки.
  • 3D сечения строятся с помощью 3D тел и поверхностей, но для контуров профилей и образцов штриховки используются 2D отрезки.
  • Управление свойствами отображения блоков 2D сечений/уровней и блоков 3D сечений осуществляется в диалоговом окне "Параметры сечения".


Создание 2D или 3D сечения - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Создание 2D и 3D сечений
Понятия
Процедуры
Команды

Создание 2D или 3D сечения

  1. Выберите объект-сечение. Нажмите на секущей линии правую кнопку мыши и выберите пункт "Создание 2D/3D сечения".
  2. В диалоговом окне "Создание сечения/уровня" выберите "2D сечение/уровень" или "3D сечение".
  3. Выберите "Включить все объекты".
  4. В группе "Назначение" выберите "Вставить в виде нового блока".
  5. Нажмите кнопку "Создать".
  6. Укажите на экране точку вставки.

    7. Вставляется неименованный блок, состоящий из 2D или 3D геометрической структуры.


Создание 2D и 3D сечений - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Создание 2D и 3D сечений
Понятия
Процедуры
Команды

Команды
СЕКПЛОСКОСТЬ | Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание плоского вида - Понятия

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Создание плоского вида
Понятия
Процедуры
Команды

Командой ПЛОСКСНИМОК создаётся плоский вид всех 3D тел и областей текущего вида.

Полученный вид представляет собой блок, являющийся плоскостным представлением 3D модели, спроектированным на плоскость XY. Эта процедура аналогична получению "снимка" всей 3D модели с помощью камеры и последующего устранения эффекта объёмности на фотографии. После вставки блока его можно изменять, поскольку плоский вид состоит из 2D геометрических объектов. Эта функция особенно удобна для создания технических иллюстраций.

Перед применением команды ПЛОСКСНИМОК не обязательно задавать какой-то определённый вид. Можно настроить чертёж в ортогональном или параллельном виде.

Плоский вид создается со следующими параметрами:

  • Вид включает все 3D объекты на видовом экране пространства модели. Объекты, которые не следует помещать в вид, необходимо расположить на отключённых или замороженных слоях.
  • Плоские виды создаются в виде блоков, которые можно переименовывать и редактировать с помощью команды БЛОКРЕД.
  • Создаваемый блок определяется настройками отображения для линий переднего плана и скрытых линий, выполняемыми в диалоговом окне "Плоский снимок".
  • Скрытые линии фиксируются и отображаются в блоке с помощью настроек отображения для параметра "Линии заднего плана" в диалоговом окне "Плоский снимок".
  • 3D объекты, рассечённые объектом-сечением, помещаются в вид целиком. Командой ПЛОСКСНИМОК эти объекты помещаются в вид так, как если бы они не были рассечены.

Примечание Для построения профилей изображений 3D тел в пространстве листа применяется команда Т-ПРОФИЛЬ.


Создание плоского 2D вида 3D модели - Процедуры

Работа с 3D моделями
Построение сечений и 2D чертежей из 3D моделей
Создание плоского вида
Понятия
Процедуры
Команды

Создание плоского 2D вида 3D модели

  1. Настройте вид 3D модели.
  2. В командной строке введите плоскснимок.
  3. В диалоговом окне "Плоский снимок" в группе "Назначение" выберите один из параметров.
  4. Измените цвет и тип для фоновых и погашенных линий.
  5. Нажмите кнопку "Создать".
  6. Укажите на экране точку вставки для размещения блока. При необходимости отрегулируйте положение базовой точки, масштаб и угол поворота.

    7. Создаётся блок, состоящий из 2D геометрической структуры, который проецируется на плоскость XY текущей ПСК.


Создание плоского вида - Команды

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Создание плоского вида
Понятия
Процедуры
Команды

Команды
ПЛОСКСНИМОК | Создание 2D представления всех 3D объектов в текущем виде
Т-ПРОФИЛЬ | Создает профили трехмерных тел в пространстве листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Штриховка, пояснения, таблицы и размеры

Штриховка, закрашивание и маскировка
Штриховку можно использовать для закрашивания области выбранным образцом или цветом. Для того чтобы оставить свободное место на области, можно создать маскирующий объект.

Надписи и метки
Имеется возможность выполнения и редактирования различных типов текстовых надписей, включая надписи на выносках. Большинство параметров текста управляется с помощью текстовых стилей.

Таблицы
Таблица представляет собой прямоугольную структуру ячеек, в которых содержатся текстовые объекты или блоки.

Размеры и допуски
Имеется множество команд, предназначенных для нанесения и форматирования размеров на чертеже. Для быстрого форматирования размеров и обеспечения их соответствия государственным стандартам и стандартам предприятия используйте размерные стили.


Штриховка, пояснения, таблицы и размеры - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, пояснения, таблицы и размеры
Штриховка, пояснения, таблицы и размеры
Понятия
Процедуры
Команды

В процессе работы можно закрашивать области путем нанесения штриховки заданного образца или сплошной закраски определенного цвета.

Имеется возможность выполнения и редактирования различных типов текстовых надписей, включая надписи на выносках. Большинствоv параметров текста можно управлять с помощью текстовых стилей.

Таблица представляет собой прямоугольную структуру ячеек, в которых содержатся текстовые объекты или блоки.

Имеется множество команд, предназначенных для нанесения и форматирования размеров на чертеже. Размерные стили используются для запоминания пользовательских настроек форматирования размеров и поддержания стандартов нанесения размеров.


Штриховка, пояснения, таблицы и размеры - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, пояснения, таблицы и размеры
Штриховка, пояснения, таблицы и размеры
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Штриховка, пояснения, таблицы и размеры - Команды

Штриховка, пояснения, таблицы и размеры
Штриховка, пояснения, таблицы и размеры
Штриховка, пояснения, таблицы и размеры
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Штриховка, закрашивание и маскировка - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Понятия
Процедуры
Команды

Штриховку можно использовать для закрашивания области выбранным образцом или цветом. Для того чтобы оставить свободное место на области, можно создать маскирующий объект.

  • Коротко об образцах штриховки и закрашивании
  • Определение контуров штриховки
    Нанесение штриховки или заливки выполняется путем выбора объекта или определения контура с последующим указанием внутренней точки.
  • Выбор образцов штриховки и сплошной заливки
    Можно использовать стандартные образцы штриховки или сплошной заливки, а также определять собственные.
  • Редактирование штриховки и заливки
    Имеется возможность редактирования образцов и контуров штриховки (и сплошной закраски).
  • Создание пустых маскирующих областей
    Маскирующие объекты закрывают объекты чертежа с целью резервирования места для пояснений или скрытия каких-либо деталей.

См. также

Коротко об описании образцов штриховки в документе Руководство по адаптации

Редактирование сложных объектов


Штриховка, закрашивание и маскировка - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Понятия
Процедуры
Команды

Перетаскивание образцов штриховки в чертеж

Штрихование областей

Штрихование выбранных объектов

Исключение островков в области штриховки

Задание набора контуров в сложном чертеже

Задание контура штриховки по точкам

Нанесение сплошной заливки

Построение 2D фигуры

Создание широкой полилинии

Построение кольца

Нанесение одноцветной градиентной заливки

Нанесение двухцветной градиентной заливки

Редактирование градиентной заливки

Использование стандартного образца штриховки

Формирование штриховки из линий

Изменение угла наклона штриховки

Задание ограничения числа объектов, создаваемых штриховкой

Редактирование градиентной заливки

Маскировка объектов чертежа пустыми областями

Включение/отключение видимости контуров маскирующих объектов


Штриховка, закрашивание и маскировка - Команды

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Понятия
Процедуры
Команды
Команды
КОЛЬЦО | Построение закрашенных кругов и колец
КОНТУР | Создание области или полилинии из замкнутого контура
КОПИРОВАТЬСВ | Копирование свойств выбранного объекта в другие объекты
МАСКИРОВКА | Скрытие существующих объектов чертежа посредством наложения на них объектов цвета фона
ПЛИНИЯ | Построение двумерных полилиний
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
ПСК | Управление пользовательскими системами координат
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
ФИГУРА | Создание закрашенных многоугольников
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPANG | Указывает угол поворота образца штриховки
HPASSOC | Управляет ассоциативностью образцов штриховки и градиентных заливок
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
HPDOUBLE | Указывает режим штрихования крест-накрест для созданных пользователем штриховок
HPDRAWORDER | Управляет порядком прорисовки штриховки или заливки
HPGAPTOL | Рассматривает набор объектов, окружающих почти замкнутую область, как замкнутый контур штриховки
HPINHERIT | Определяет исходную точку полученной штриховки с помощью параметра "Копирование свойств" команд ШТРИХОВКА и РЕДШТРИХ
HPNAME | Устанавливает имя образца штриховки по умолчанию длиной до 34 символов (без пробелов)
HPOBJWARNING | Устанавливает количество объектов контура штриховки, которые можно выбрать до отображения предупреждения
HPORIGIN | Устанавливает исходную точку штриховки для новых объектов штриховки относительно текущей системы координат пользователя
HPORIGINMODE | Определяет исходную точку штриховки с помощью команды ШТРИХОВКА
HPSCALE | Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым
HPSEPARATE | Определяет количество создаваемых заштрихованных объектов (один или несколько) с помощью команды ШТРИХОВКА, если выделено несколько замкнутых контуров
HPSPACE | Указывает расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть ненулевым
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко об образцах штриховки и закрашивании - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Коротко об образцах штриховки и закрашивании
Понятия
Процедуры
Команды

Можно заштриховать область с помощью стандартных образцов, определить простой образец штриховки из текущего типа линии или создать более сложные образцы. Тип образца, заполняющий область сплошным цветом, называется сплошным.

Градиентная заливка может состоять из оттенков одного цвета или представлять собой плавный переход из одного цвета в другой. Градиентные заливки можно использовать для украшения чертежей, создавая эффект отражающегося от объекта света.

Определение контуров штриховки

Можно выбрать один из способов определения контуров штриховки:

  • Указать точку на области, замкнутой объектами.
  • Выбрать объекты, окружающие область.
  • Из инструментальной палитры или DesignCenter перетащите образец штриховки на замкнутую область.

Все объекты, полностью или частично попадающие в область штриховки и не являющиеся ее контуром, игнорируются и не влияют на процесс штрихования.

Команда ШТРИХОВКА выполняет штриховку вокруг таких объектов, как текст, атрибут или объект со сплошной закраской, а также, если объект выбран как часть набора контуров.

Примечание Если необходимо заштриховать область с незамкнутым контуром, можно так настроить системную переменную HPGAPTOL, что зазоры не будет учитываться, и контур будет считаться замкнутым. Системная переменная HPGAPTOL используется только для разрывов между отрезками и дугами, которые пересеклись бы при их удлинении.

Для уменьшения размера файла область со штриховкой определяется в базе данных чертежа как единый графической объект.

Нанесение штриховки и сплошной заливки

Для нанесения штриховки можно использовать несколько методов.

  • Команда ШТРИХОВКА содержит большое число параметров.
  • Штриховки можно перетаскивать из инструментальной палитры. Наиболее простой и быстрый способ штрихования обеспечивают инструментальные палитры.

    • В открытом окне "Инструментальные палитры" можно нажать правой кнопкой мыши на выбранном образце штриховки и вызвать диалоговое окно "Свойства инструмента" из контекстного меню. В этом диалоговом окне содержится несколько параметров образца штриховки, которые также доступны при вызове команды ШТРИХОВКА. Например, можно задать масштаб и интервал между линиями штриховки.

  • Можно также использовать DesignCenter.
Управление исходной точкой штриховки

По умолчанию образцы штриховки всегда “соединяются” друг с другом. Тем не менее, иногда может потребоваться перенести начальную точку штриховки (ее называют исходная точка). Например, при создании образца кирпичной кладки, возможно, потребуется начать с целого кирпича в левом нижнем углу штрихуемой области. В этом случае нужно воспользоваться параметрами "Исходная точка штриховки" диалогового окна "Штриховка и градиент".

Положение и вид образца штриховки зависит от системных переменных HPORIGIN, HPORIGINMODE и HPINHERIT, связанных с расположением и ориентацией пользовательской системы координат.

Выбор образца штриховки

Программа поставляется со сплошной закраской и более чем 50 стандартными образцами штриховки, которые можно использовать для различения компонентов объектов или представления материалов объектов. В состав программы также входят 14 образцов штриховки, соответствующих стандартам ISO (Международная организация по стандартизации). Для штриховки по стандарту ISO можно задать толщину пера, которая определяет вес линий образца.

На вкладке "Штриховка" диалогового окна "Штриховка и градиент" в области "Тип и массив" отображаются названия всех образцов штриховки, указанных в текстовом файле acad.pat. Можно добавлять в диалоговое окно новые образцы штриховки, указывая их описания в файле acad.pat.

Нанесение ассоциативной штриховки

Обновление ассоциативной штриховки происходит при изменениях контура. Штриховка, нанесенная с помощью команды ШТРИХОВКА, является ассоциативной по умолчанию. Данная настройка хранится в системной переменной HPASSOC. Штриховки, созданные путем перетаскивания образца штриховки из инструментальной палитры или из DesignCenter™, используют значение системной переменной HPASSOC. Можно в любой момент отменить ассоциативность штриховки или воспользоваться командой ШТРИХОВКА для создания неассоциативной штриховки. Если для системной переменной HPGAPTOL задано значение 0 (значение по умолчанию), ассоциативность устраняется автоматически, если при внесении правки создается разомкнутый контур.

Можно использовать команду ШТРИХОВКА для нанесения неассоциативной штриховки, не зависящей от контура.

Назначение штриховке порядка прорисовки

Штриховке можно назначить порядок прорисовки таким образом, чтобы она помещалась за или перед контуром на заднем или на переднем плане.

При нанесении штриховки она по умолчанию помещается за контуром. Это облегчает просмотр и выбор контура штриховки. Порядок прорисовки для штриховки можно изменить таким образом, чтобы она помещалась перед контуром на заднем или на переднем плане. Этот параметр хранится в системной переменной HPDRAWORDER. Штриховки, созданные путем перетаскивания образца штриховки из инструментальной палитры или из DesignCenter™, используют значение системной переменной HPDRAWORDER.

Ограничение плотности образца штриховки

При нанесении слишком плотной штриховки программа может отменить выполнение операции и отобразить сообщение о том, что масштаб штриховки или длина пунктира слишком малы. Можно изменить максимальное количество линий штриховки путем задания переменной системного реестра MaxHatch в командной строке, введя (setenv “MaxHatch” “n”), где n - число от 100 до 10000000 (десяти миллионов). Значение по умолчанию для MaxHatch составляет 10000.

Примечание При изменении значения переменной реестра MaxHatch необходимо учитывать положение регистра символов имени этой переменной.

Редактирование контуров штриховки

Поскольку комбинации штрихуемых областей крайне разнообразны, при редактировании объектов, определяющих штриховку, могут проявиться различные побочные эффекты. Если нанесение штриховки не дало ожидаемого результата, то можно отменить действие или удалить штриховку, а затем повторить попытку с другими параметрами.

Создание пользовательских образцов штриховки

Можно также создать собственный образец штриховки с помощью текущего типа линий и параметра "Пользовательская штриховка" диалогового окна "Штриховка и градиент". Можно также создать более сложные образцы.

См. также

Редактирование штриховки и заливки

Коротко об описании образцов штриховки в документе Руководство по адаптации


Коротко об образцах штриховки и закрашивании - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Коротко об образцах штриховки и закрашивании
Понятия
Процедуры
Команды

Перетаскивание образцов штриховки в чертеж

Штрихование областей

Штрихование выбранных объектов


Перетаскивание образцов штриховки в чертеж - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Коротко об образцах штриховки и закрашивании
Понятия
Процедуры
Команды

Перетаскивание образцов штриховки в чертеж

  1. Нажмите "Сервис" » "Палитры" » "DesignCenter".

    2. Примечание Действия, описанные ниже, позволяют перетаскивать образцы штриховок из DesignCenter непосредственно в чертеж. Образцы штриховок можно также перетаскивать с инструментальной палитры.

  2. Перейдите на вкладку "Папки" и нажмите кнопку "Поиск".
  3. В диалоговом окне "Поиск" необходимо проделать следующее:
    • В выпадающем списке "Что искать" выбрать "Файлы образцов штриховки".
    • В списке "Где искать" выбрать диск, на котором установлена программа.
    • Установить флажок "Просматривать вложенные папки".
    • На вкладке "Файлы образцов штриховки" в поле "Искать имя" ввести * (звездочку).
  4. Нажать кнопку "Найти".

    5. Файл образца штриховки по умолчанию - acad.pat или acadiso.pat. Результатом поиска может быть этот же файл, найденный по другому пути.

    Примечание Для быстрого доступа к PAT-файлу можно занести его в папку "Избранное". Ярлык РАТ-файла отображается в папке "Избранное" на вкладке "Папки" в центре управления DesignCenter.

  5. Произведите двойное нажатие на имени найденного файла, чтобы добавить образцы штриховок в окно "DesignCenter".
  6. (Не обязательно) Укажите образец правой кнопкой мыши для вызова контекстного меню со следующими командами:
    • ШТРИХОВКА. Вызов диалогового окна "Штриховка и градиент".
    • Копировать. Копирование образца штриховки в буфер обмена.
    • Создать инструментальную палитру. Создание инструментальной палитры, содержащей выбранный образец штриховки.
  7. Перетащите с помощью устройства указания образец штриховки на замкнутый объект чертежа или на инструментальную палитру.

    8. Примечание Если масштаб образца штриховки слишком велик или мал, то выдается сообщение об ошибке. Можно настроить масштаб любого образца штриховки в диалоговом окне "Штриховка и градиент", отображающемся при двойном нажатии кнопки мыши на образце.

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Штрихование областей - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Коротко об образцах штриховки и закрашивании
Понятия
Процедуры
Команды

Штрихование областей

  1. Выберите "Рисование" » "Штриховка".
  2. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора".
  3. На чертеже укажите точку внутри каждой области, которую требуется заштриховать, и нажмите ENTER.

    4. Указанные точки интерпретируются как внутренние.

  4. Следует убедиться, что в диалоговом окне "Штриховка и градиент" на вкладке "Штриховка" выбран необходимый образец. Для выбора другого образца штриховки воспользуйтесь списком "Образец".

    5. Для просмотра выбранного образца в наглядной форме нажмите кнопку [...] рядом со списком образцов. Нажмите "ОК" для завершения просмотра.

  5. При необходимости выполнить настройки в диалоговом окне "Штриховка и градиент".

    6. Новые контуры штриховки можно определить, нажав кнопку "Добавить контуры" или "Удалить контуры".

  6. В выпадающем списке "Порядок прорисовки" выберите одну из опций.

    7. Порядок прорисовки для штриховки можно изменить таким образом, чтобы она помещалась за или перед контуром на заднем или на переднем плане.

  7. Нажмите "ОК".

Панель "Рисование"

Ввод команды: ШТРИХОВКА


Штрихование выбранных объектов - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Коротко об образцах штриховки и закрашивании
Понятия
Процедуры
Команды

Штрихование выбранных объектов

  1. Выберите "Рисование" » "Штриховка".
  2. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора".
  3. Выберите объекты, которые необходимо заштриховать.

    4. При этом не обязательно, чтобы объекты образовывали замкнутый контур. Можно также указать любые островки, которые должны остаться незаштрихованными. Также можно задать системной переменной HPGAPTOL такое значение, которое позволит считать набор объектов, составляющих не полностью замкнутую область, замкнутым контуром штриховки.

  4. В выпадающем списке "Порядок прорисовки" выберите одну из опций.

    5. Порядок следования для штриховки можно изменить таким образом, чтобы она помещалась за или перед контуром на заднем или на переднем плане.

  5. Нажать "ОК".

Панель "Рисование"

Ввод команды: ШТРИХОВКА


Коротко об образцах штриховки и закрашивании - Команды

Штриховка, закрашивание и маскировка
Штриховка, закрашивание и маскировка
Коротко об образцах штриховки и закрашивании
Понятия
Процедуры
Команды

Команды
КОЛЬЦО | Построение закрашенных кругов и колец
КОНТУР | Создание области или полилинии из замкнутого контура
КОПИРОВАТЬСВ | Копирование свойств выбранного объекта в другие объекты
ПЛИНИЯ | Построение двумерных полилиний
ПСК | Управление пользовательскими системами координат
ФИГУРА | Создание закрашенных многоугольников
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPANG | Указывает угол поворота образца штриховки
HPASSOC | Управляет ассоциативностью образцов штриховки и градиентных заливок
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
HPDOUBLE | Указывает режим штрихования крест-накрест для созданных пользователем штриховок
HPDRAWORDER | Управляет порядком прорисовки штриховки или заливки
HPGAPTOL | Рассматривает набор объектов, окружающих почти замкнутую область, как замкнутый контур штриховки
HPINHERIT | Определяет исходную точку полученной штриховки с помощью параметра "Копирование свойств" команд ШТРИХОВКА и РЕДШТРИХ
HPNAME | Устанавливает имя образца штриховки по умолчанию длиной до 34 символов (без пробелов)
HPOBJWARNING | Устанавливает количество объектов контура штриховки, которые можно выбрать до отображения предупреждения
HPORIGIN | Устанавливает исходную точку штриховки для новых объектов штриховки относительно текущей системы координат пользователя
HPORIGINMODE | Определяет исходную точку штриховки с помощью команды ШТРИХОВКА
HPSCALE | Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым
HPSEPARATE | Определяет количество создаваемых заштрихованных объектов (один или несколько) с помощью команды ШТРИХОВКА, если выделено несколько замкнутых контуров
HPSPACE | Указывает расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть ненулевым
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Определение контуров штриховки - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Определение контуров штриховки
Понятия
Процедуры
Команды

Нанесение штриховки или заливки выполняется путем выбора объекта или определения контура с последующим указанием внутренней точки.

  • Коротко о контурах штриховки
  • Штрихование островков
    Имеется возможность задания способа штрихования замкнутых областей внутри контуров штриховки, называемых островками.
  • Определение контуров штриховки в сложных чертежах
    В целях сокращения времени на выполнение действий для штрихования небольшой области сложного чертежа можно задавать набор объектов чертежа, определяющих контуры штриховки.
  • Нанесение штриховки указанием точек
    Можно наносить штриховку, не имеющую контура.


Определение контуров штриховки - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Определение контуров штриховки
Понятия
Процедуры
Команды

Исключение островков в области штриховки

Задание набора контуров в сложном чертеже

Задание контура штриховки по точкам


Определение контуров штриховки - Команды

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Определение контуров штриховки
Понятия
Процедуры
Команды
Команды
КОНТУР | Создание области или полилинии из замкнутого контура
Системные переменные
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
HPGAPTOL | Рассматривает набор объектов, окружающих почти замкнутую область, как замкнутый контур штриховки
HPOBJWARNING | Устанавливает количество объектов контура штриховки, которые можно выбрать до отображения предупреждения
HPSEPARATE | Определяет количество создаваемых заштрихованных объектов (один или несколько) с помощью команды ШТРИХОВКА, если выделено несколько замкнутых контуров
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о контурах штриховки - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Коротко о контурах штриховки
Понятия
Процедуры
Команды

Штриховка замкнутой области или контура выполняется с помощью команды ШТРИХОВКА. По умолчанию с помощью команды ШТРИХОВКА создаются ассоциативные штриховки, обновляемые при каждом изменении контура.

Нанесение штриховки выполняется путем выбора объекта или определения контура с последующим указанием внутренней точки. Контур может представлять комбинацию объектов, таких как отрезки, дуги, круги и полилинии, которые образуют замкнутую область.

Замкнутые области внутри области штрихования рассматриваются как островки. Их можно заштриховать или оставить незаштрихованными в зависимости от значения параметра "Островки" в диалоговом окне "Штриховка и градиент".

Для штрихования небольшой области сложного чертежа можно задать произвольный набор контуров.

Штрихование объектов возможно только в том случае, если они расположены параллельно плоскости XY текущей ПСК.

Примечание Если требуется заштриховать область, которая замкнута не полностью, можно задать допуск замкнутости (системная переменная HPGAPTOL). Зазоры между объектами, величина которых не превышает заданного максимального значения, игнорируются, а контур образованный такими объектами считается замкнутым.


Определение контуров штриховки

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Определение контуров штриховки
Понятия
Процедуры
Команды

Нет процедур.


Коротко о контурах штриховки - Команды

Штриховка, закрашивание и маскировка
Штриховка, закрашивание и маскировка
Коротко о контурах штриховки
Понятия
Процедуры
Команды

Команды
КОНТУР | Создание области или полилинии из замкнутого контура
Системные переменные
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
HPGAPTOL | Рассматривает набор объектов, окружающих почти замкнутую область, как замкнутый контур штриховки
HPOBJWARNING | Устанавливает количество объектов контура штриховки, которые можно выбрать до отображения предупреждения
HPSEPARATE | Определяет количество создаваемых заштрихованных объектов (один или несколько) с помощью команды ШТРИХОВКА, если выделено несколько замкнутых контуров
PICKSTYLE | Управляет выбором групп и ассоциативной штриховки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Штрихование островков - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Штрихование островков
Понятия
Процедуры
Команды

Имеется возможность задания способа штрихования замкнутых областей внутри контура штриховки, называемых островками, путем выбора одного из трех стилей штриховки: "Нормальный", "Внешний" и "Игнорирующий". Предварительный просмотр этих стилей штриховки можно выполнить в области "Дополнительно" диалогового окна "Штриховка и градиент".

При использовании стиля "Нормальный" (по умолчанию) штриховка наносится начиная от внешнего контура по направлению вовнутрь. Если обнаружено внутреннее пересечение, штрихование прекращается, а на следующем пересечении возобновляется.

Таким образом, штриховка наносится на области, отделенные от внешней области нечетным числом замкнутых контуров, как это показано ниже на чертеже. При этом области, отделенные четным числом контуров, не штрихуются.

При использовании стиля "Внешний" штриховка наносится только от внешнего контура до первого обнаруженного пересечения, за которым область остается незаштрихованной.

Стиль "Игнорирующий" служит для нанесения штриховки на всю область, ограниченную внешним контуром, вне зависимости от наличия внутренних контуров.

В области штриховки можно исключать из рассмотрения любые островки.

См. также

Редактирование штриховки и заливки


Исключение островков в области штриховки - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Штрихование островков
Понятия
Процедуры
Команды

Исключение островков в области штриховки

  1. Выберите "Рисование" » "Штриховка".
  2. После добавления одного или нескольких контуров в диалоговом окне "Штриховка и градиент" нажмите кнопку "Удалить контуры".
  3. Выберите контуры, которые необходимо удалить, и нажмите ENTER.
  4. В диалоговом окне "Штриховка и градиент" нажмите "ОК" для нанесения штриховки.

Панель "Рисование"

Ввод команды: ШТРИХОВКА


Штрихование островков - Команды

Штриховка, закрашивание и маскировка
Штриховка, закрашивание и маскировка
Штрихование островков
Понятия
Процедуры
Команды

Команды
КОНТУР | Создание области или полилинии из замкнутого контура
Системные переменные
HPOBJWARNING | Устанавливает количество объектов контура штриховки, которые можно выбрать до отображения предупреждения
HPSEPARATE | Определяет количество создаваемых заштрихованных объектов (один или несколько) с помощью команды ШТРИХОВКА, если выделено несколько замкнутых контуров
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Определение контуров штриховки в сложных чертежах - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Определение контуров штриховки в сложных чертежах
Понятия
Процедуры
Команды

В целях сокращения времени на выполнение действий для штрихования небольшой области сложного чертежа можно задавать набор объектов чертежа, определяющих контуры штриховки.

По умолчанию команда ШТРИХОВКА определяет контур, анализируя все замкнутые объекты чертежа. Для сложных чертежей подобный поиск контура среди всех объектов, полностью или частично отображаемых на экране, может отнимать достаточно много времени. В таких случаях для штрихования небольшой области сложного чертежа можно явно задать объекты, определяющие так называемый набор контуров. Команда ШТРИХОВКА не анализирует объекты, не входящие в набор контуров.

Для наглядности область, на которую необходимо нанести штриховку, можно предварительно увеличить.

Параметр "Просмотр набора" диалогового окна "Штриховка и градиент" используется для выделения объектов чертежа, определяющих контур.


Задание набора контуров в сложном чертеже - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Определение контуров штриховки в сложных чертежах
Понятия
Процедуры
Команды

Задание набора контуров в сложном чертеже

  1. Выберите "Рисование" » "Штриховка".
  2. В диалоговом окне "Штриховка и градиент" в области "Дополнительно" в списке "Набор контуров" выберите "Создать".
  3. На запрос "Выберите объекты" укажите два противоположных угла для задания области, содержащей объекты, определяющие набор контуров, и нажмите ENTER.

    4. При выборе секущей рамкой путем перетаскивания курсора справа налево выбираются все объекты, полностью или частично входящие в заданную область.

  4. В диалоговом окне "Штриховка и градиент" выберите "Добавить контур". При необходимости введите у, чтобы выбрать опцию "Указать внутреннюю точку".
  5. Укажите внутреннюю точку.
  6. Нажмите "ОК" для нанесения штриховки.

Панель "Рисование"

Ввод команды: ШТРИХОВКА


Определение контуров штриховки в сложных чертежах - Команды

Штриховка, закрашивание и маскировка
Штриховка, закрашивание и маскировка
Определение контуров штриховки в сложных чертежах
Понятия
Процедуры
Команды

Команды
КОНТУР | Создание области или полилинии из замкнутого контура
Системные переменные
HPOBJWARNING | Устанавливает количество объектов контура штриховки, которые можно выбрать до отображения предупреждения
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение штриховки указанием точек - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Нанесение штриховки указанием точек
Понятия
Процедуры
Команды

Существует несколько способов нанесения штриховки, не имеющей контура.

  • Штриховку можно нанести с помощью команды ШТРИХОВКА, а затем стереть все или некоторые объекты контура.
  • Штриховку можно нанести с помощью команды ШТРИХОВКА, убедившись, что объекты контура не находятся на том же слое, что и штриховка. Затем нужно отключить или заморозить слой, на котором находятся объекты контура. Это единственный способ, поддерживающий ассоциативность штриховки.
  • Можно обрезать существующую штриховку объектами, созданными в качестве контура обрезки. После обрезки штриховки необходимо стереть эти объекты.
  • Контур штриховки можно определить по заданным точкам с помощью параметра рисования команды -ШТРИХОВКА.

Например, может понадобиться показать, что значительная область чертежа заполняется образцом путем заполнения всего лишь маленькой части этой области, как это показано на следующем рисунке.

Имеется возможность сохранения контура после нанесения штриховки; здесь контур не сохранен.


Задание контура штриховки по точкам - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Нанесение штриховки указанием точек
Понятия
Процедуры
Команды

Задание контура штриховки по точкам

  1. В командной строке ввести -штриховка.
  2. Введите имя нужного образца штриховки. Например, введите earth для выбора образца EARTH.
  3. Задайте масштаб образца и угол его поворота.
  4. Введите ш, чтобы выбрать опцию "Рисование".
  5. Указать точки, определяющие контур. Введите з, чтобы замкнуть контур полилинии, и нажмите ENTER.
  6. Введите н для удаления контура после нанесения штриховки или д для его сохранения.

Ввод команды: -ШТРИХОВКА


Нанесение штриховки указанием точек - Команды

Штриховка, закрашивание и маскировка
Штриховка, закрашивание и маскировка
Нанесение штриховки указанием точек
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Выбор образцов штриховки и сплошной заливки - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Выбор образцов штриховки и сплошной заливки
Понятия
Процедуры
Команды

Можно использовать стандартные образцы штриховки или сплошной заливки, а также определять собственные.

  • Построение заполненных фигур
    Построение заполненных фигур может выполняться несколькими способами.
  • Создание областей с градиентной заливкой
    Градиентная заливка - это разновидность сплошной заливки с эффектом плавного перехода одного цвета в другой. Градиентная заливка позволяет создавать эффект объемности фигур в двумерных чертежах.
  • Стандартные образцы штриховки
    В продукт входит более 50 образцов штриховки, удовлетворяющих промышленным стандартам, которые можно использовать в своей работе. Помимо образцов, поставляемых с продуктом, можно использовать также образцы из внешних библиотек.
  • Создание пользовательских образцов штриховки
    Можно сформировать простейший образец штриховки на основе текущего типа линий.


Выбор образцов штриховки и сплошной заливки - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Выбор образцов штриховки и сплошной заливки
Понятия
Процедуры
Команды

Нанесение сплошной заливки

Построение 2D фигуры

Создание широкой полилинии

Построение кольца

Нанесение одноцветной градиентной заливки

Нанесение двухцветной градиентной заливки

Редактирование градиентной заливки

Использование стандартного образца штриховки

Формирование штриховки из линий


Выбор образцов штриховки и сплошной заливки - Команды

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Выбор образцов штриховки и сплошной заливки
Понятия
Процедуры
Команды
Команды
КОЛЬЦО | Построение закрашенных кругов и колец
ПЛИНИЯ | Построение двумерных полилиний
ФИГУРА | Создание закрашенных многоугольников
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPANG | Указывает угол поворота образца штриховки
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
HPDOUBLE | Указывает режим штрихования крест-накрест для созданных пользователем штриховок
HPNAME | Устанавливает имя образца штриховки по умолчанию длиной до 34 символов (без пробелов)
HPSCALE | Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым
HPSPACE | Указывает расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть ненулевым
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение заполненных фигур - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Построение заполненных фигур
Понятия
Процедуры
Команды

Закрашенные области можно создать с помощью:

  • Штриховки с образцами сплошной штриховки (ШТРИХОВКА)
  • двумерных фигур (ФИГУРА)
  • широких полилиний и колец (ПЛИНИЯ, КОЛЬЦО)

См. также

Коротко об образцах штриховки и закрашивании

Редактирование штриховки и заливки

Построение полилиний

Построение колец


Построение заполненных фигур - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Построение заполненных фигур
Понятия
Процедуры
Команды

Нанесение сплошной заливки

Построение 2D фигуры

Создание широкой полилинии

Построение кольца


Нанесение сплошной заливки - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Построение заполненных фигур
Понятия
Процедуры
Команды

Нанесение сплошной заливки

  1. Выберите "Рисование" » "Штриховка".
  2. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора".
  3. Укажите точки внутри областей, которые необходимо заштриховать.

    4. Указанные точки интерпретируются как внутренние.

  4. Нажмите ENTER.
  5. В диалоговом окне "Штриховка и градиент" на вкладке "Штриховка" в списке "Тип" выберите "Стандартный".
  6. Нажмите кнопку [...] рядом со списком образцов.
  7. В диалоговом окне "Палитра образцов штриховки" на вкладке "Другие стандартные" выберите "Сплошная". Нажмите "ОК".
  8. Для просмотра образца штриховки нажмите "Просмотр".
  9. По завершении просмотра образца штриховки нажмите правую кнопку мыши или клавишу ENTER для нанесения штриховки или нажмите любую клавишу или кнопку для возврата к диалоговому окну "Штриховка и градиент".
  10. При необходимости выполните настройки в диалоговом окне "Штриховка и градиент". (Новые контуры штриховки можно определить, нажав кнопку "Добавить контуры" или "Удалить контуры".)
  11. Нажмите "ОК".

Панель "Рисование"

Ввод команды: ШТРИХОВКА


Построение 2D фигуры - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Построение заполненных фигур
Понятия
Процедуры
Команды

Построение 2D фигуры

  1. В командной строке введите фигура.
  2. Укажите первую точку.
  3. Укажите вторую точку, переводя курсор слева направо.
  4. Продолжите указание следующих точек. Для окончания определения объекта нажмите ENTER.

    5. При создании четырехугольной фигуры порядок указания вершин влияет на форму фигуры. Это показано на следующих чертежах.

    Следует учитывать, что для создания четырехугольника верхняя и нижняя стороны должны определяться в одном направлении. При задании следующих пар вершин необходимо придерживаться установленного порядка указания для получения ожидаемого результата.

Ввод команды: ФИГУРА


Создание широкой полилинии - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Построение заполненных фигур
Понятия
Процедуры
Команды

Создание широкой полилинии

  1. Выберите "Рисование" » "Полилиния".
  2. Укажите начальную точку линейного сегмента.
  3. Введите ш (Ширина).
  4. Введите значение ширины в начале линейного сегмента.
  5. Задайте ширину в конце сегмента одним из следующих методов:
    • Для создания линейного сегмента с постоянной шириной нажмите клавишу ENTER.
    • Для построения сужающегося или расширяющегося линейного сегмента введите другое значение ширины.
  6. Укажите конечную точку сегмента.
  7. Продолжайте указание конечных точек для последующих сегментов.
  8. Нажмите ENTER для завершения команды или с для замыкания полилинии.

Панель "Рисование"

Ввод команды: ПЛИНИЯ


Построение кольца - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Построение заполненных фигур
Понятия
Процедуры
Команды

Построение кольца

  1. Выберите "Рисование" » "Кольцо".
  2. Задайте внутренний диаметр (1).
  3. Задайте наружный диаметр (2).
  4. Укажите центр кольца (3).
  5. Укажите центральную точку для другого кольца или нажмите клавишу ENTER для завершения команды.

Ввод команды: КОЛЬЦО


Построение заполненных фигур - Команды

Штриховка, закрашивание и маскировка
Штриховка, закрашивание и маскировка
Построение заполненных фигур
Понятия
Процедуры
Команды

Команды
КОЛЬЦО | Построение закрашенных кругов и колец
ПЛИНИЯ | Построение двумерных полилиний
ФИГУРА | Создание закрашенных многоугольников
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание областей с градиентной заливкой - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Создание областей с градиентной заливкой
Понятия
Процедуры
Команды

Градиентная заливка - это разновидность сплошной заливки с эффектом плавного перехода одного цвета в другой. Градиентная заливка позволяет создавать эффект объемности фигур в двумерных чертежах.

Одноцветная градиентная заливка может содержать плавный переход цвета от более светлого к более темному, от более темного к более светлому или сочетание таких переходов. Необходимо выбрать предлагаемый образец заливки и задать угол. Двухцветная градиентная заливка состоит из переходов от светлых к темным оттенкам, а также от одного цвета к другому.

Градиентная заливка наносится так же, как и сплошная. Она может иметь ассоциативную связь с контурами областей. Ассоциативная заливка автоматически обновляется при изменении контура.

Цвета градиентной заливки не зависят от стилей печати.

Для редактирования градиентной заливки необходимо нажать на ней дважды кнопку мыши.


Создание областей с градиентной заливкой - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Создание областей с градиентной заливкой
Понятия
Процедуры
Команды

Нанесение одноцветной градиентной заливки

Нанесение двухцветной градиентной заливки

Редактирование градиентной заливки


Нанесение одноцветной градиентной заливки - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Создание областей с градиентной заливкой
Понятия
Процедуры
Команды

Нанесение одноцветной градиентной заливки

  1. Выберите "Рисование" » "Штриховка".
  2. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора" или "Добавить: объекты выбора".
  3. Задайте внутреннюю точку или выберите объект, затем нажмите клавишу ENTER.
  4. В диалоговом окне "Штриховка и градиент" на вкладке "Градиент" выберите "Один цвет".
  5. Если необходимо изменить цвет, нажмите кнопку [...] рядом с цветом.
  6. В диалоговом окне "Выбор цвета" с помощью указателя "Темнее/светлее" настройте цвет.
    • Перемещение указателя вправо создает эффект перехода от более темного цвета к более светлому.
    • Перемещение указателя влево создает эффект перехода от более светлого цвета к более темному.
  7. Выберите образец заливки и произведите следующие настройки:
    • Для создания симметричной заливки установите флажок "По центру"; если нужно переместить “яркий участок” вверх и влево, снимите этот флажок.
    • Задайте угол для “подсвеченного” участка.
  8. Кнопка "Просмотр" позволяет контролировать результат. Для возврата к диалоговому окну и выполнения настроек нажмите клавишу ENTER.
  9. После того, как требуемый эффект достигнут, в диалоговом окне "Штриховка и градиент" нажмите "ОК" для создания градиентной заливки.

Панель "Рисование"

Ввод команды: ШТРИХОВКА


Нанесение двухцветной градиентной заливки - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Создание областей с градиентной заливкой
Понятия
Процедуры
Команды

Нанесение двухцветной градиентной заливки

  1. Выберите "Рисование" » "Штриховка".
  2. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора" или "Добавить: объекты выбора".
  3. Задайте внутреннюю точку или выберите объект, затем нажмите клавишу ENTER.
  4. В диалоговом окне "Штриховка и градиент" на вкладке "Градиент" выберите "Два цвета".

    5. Двухцветная заливка создает эффект плавного перехода одного цвета в другой.

  5. Выбрать цвета можно в диалоговом окне "Выбор цвета", которое вызывается нажатием кнопки [...].
  6. Выберите образец заливки и произведите следующие настройки:
    • Для создания симметричной заливки поднимите флажок "По центру"; если нужно переместить “яркий участок” вверх и влево, снимите этот флажок.
    • Задайте угол для “подсвеченного” участка.
  7. Кнопка "Просмотр" позволяет контролировать результат. Для возврата к диалоговому окну и выполнения настроек нажмите клавишу ENTER.
  8. После того, как требуемый эффект достигнут, в диалоговом окне "Штриховка и градиент" нажмите "ОК" для создания градиентной заливки.

Панель "Рисование"

Ввод команды: ШТРИХОВКА


Редактирование градиентной заливки - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Создание областей с градиентной заливкой
Понятия
Процедуры
Команды

Редактирование градиентной заливки

  • Для редактирования градиентной заливки необходимо дважды нажать кнопку мыши на ней.


Создание областей с градиентной заливкой - Команды

Штриховка, закрашивание и маскировка
Штриховка, закрашивание и маскировка
Создание областей с градиентной заливкой
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Стандартные образцы штриховки - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Стандартные образцы штриховки
Понятия
Процедуры
Команды

Программа поставляется со сплошной закраской и более чем 50 стандартными образцами штриховки, служащими для обозначения материалов объектов, например земля, кирпич или глина.

В AutoCAD имеется 14 образцов штриховки, удовлетворяющих стандартам ISO (Международной организации по стандартизации). Для штриховки по стандарту ISO можно задать толщину пера, которая определяет вес линий образца.

Помимо образцов, поставляемых с программой, можно использовать образцы из внешних библиотек. Список таких образцов и их изображения можно просматривать в диалоговом окне "Палитра образцов штриховки".


Использование стандартного образца штриховки - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Стандартные образцы штриховки
Понятия
Процедуры
Команды

Использование стандартного образца штриховки

  1. Выберите "Рисование" » "Штриховка".
  2. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора" или "Добавить: объекты выбора".
  3. Указать внутреннюю точку или объект.
  4. В диалоговом окне "Штриховка и градиент" на вкладке "Штриховка" в списке "Тип" выберите "Стандартный".
  5. Из списка "Образец" выберите нужный образец.
  6. Нажмите "ОК".

Панель "Рисование"

Ввод команды: ШТРИХОВКА


Стандартные образцы штриховки - Команды

Штриховка, закрашивание и маскировка
Штриховка, закрашивание и маскировка
Стандартные образцы штриховки
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
HPANG | Указывает угол поворота образца штриховки
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
HPDOUBLE | Указывает режим штрихования крест-накрест для созданных пользователем штриховок
HPNAME | Устанавливает имя образца штриховки по умолчанию длиной до 34 символов (без пробелов)
HPSCALE | Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание пользовательских образцов штриховки - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Создание пользовательских образцов штриховки
Понятия
Процедуры
Команды

Можно использовать стандартные образцы штриховки или сформировать простейший образец штриховки на основе текущего типа линий. Образец определяется углом поворота и интервалом между линиями штриховки.


Формирование штриховки из линий - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Создание пользовательских образцов штриховки
Понятия
Процедуры
Команды

Формирование штриховки из линий

  1. Задайте текущий тип линий, используемый для образца штриховки пользователя.
  2. Выберите "Рисование" » "Штриховка".
  3. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора" или "Добавить: объекты выбора".
  4. Укажите внутреннюю точку или объект.
  5. В диалоговом окне "Штриховка и градиент" на вкладке "Штриховка" в списке "Тип" выберите "Пользовательская".
  6. Задать угол поворота и интервал между линиями в образце штриховки.
  7. Для нанесения штриховки с линиями, расположенными крест-накрест, включите опцию "Двусторонняя".
  8. Нажмите "ОК".

Панель "Рисование"

Ввод команды: ШТРИХОВКА


Создание пользовательских образцов штриховки - Команды

Штриховка, закрашивание и маскировка
Штриховка, закрашивание и маскировка
Создание пользовательских образцов штриховки
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
HPANG | Указывает угол поворота образца штриховки
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
HPDOUBLE | Указывает режим штрихования крест-накрест для созданных пользователем штриховок
HPNAME | Устанавливает имя образца штриховки по умолчанию длиной до 34 символов (без пробелов)
HPSCALE | Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым
HPSPACE | Указывает расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть ненулевым
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование штриховки и заливки - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Редактирование штриховки и заливки
Понятия
Процедуры
Команды

Имеется возможность редактирования образцов и контуров штриховки (и сплошной закраски). Кроме того, можно редактировать закрашенные элементы чертежа; при этом способ редактирования зависит от их типа. Закрашенными могут выглядеть сплошные заливки, двумерные фигуры, широкие полилинии и кольца. Также можно изменить порядок следования для штриховки.

Управление плотностью образца штриховки

При нанесении штриховки может образовываться очень большое число отрезков и объектов-точек. Хотя штриховка хранится как единый объект, все же каждый его отрезок и точка занимает место на диске и требует определенного времени на обработку. При использовании относительно малого масштабного коэффициента во время штрихования области могут создаваться миллионы отрезков и объектов-точек, отнимающих длительное время на прорисовку и поглощающих практически все доступные ресурсы. Этой проблемы можно избежать, ограничив число объектов, создаваемых однократным выполнением команды ШТРИХОВКА. Если предполагаемое число объектов, необходимое для определенной штриховки (учитывая длину контура, образец и масштаб), превышает ограничение, команда ШТРИХОВКА выдает сообщение о том, что масштаб штриховки или длина пунктира слишком малы, и штрихование отменяется. В таком случае необходимо изменить параметры штрихования; например, поменять масштабный коэффициент.

Максимальное допустимое число объектов, создаваемых штрихованием, задается в записи MaxHatch системного реестра. По умолчанию количество объектов ограничивается числом 10000. Можно изменить данное предельное значение путем задания переменной системного реестра MaxHatch в командной строке, введя (setenv “MaxHatch” “n”), где n - число от 100 до 10000000 (десяти миллионов).

Изменение свойств имеющейся штриховки

Можно изменять такие свойства имеющейся штриховки, как массив, масштаб и угол. Можно использовать:

  • диалоговое окно "Редактирование штриховки" (рекомендуется)
  • палитру свойств

Можно копировать свойства одной штриховки в другую штриховку. Используя кнопку "Копирование свойств" диалогового окна "Редактирование штриховки", можно копировать все свойства, включая исходную точку штриховки, из одной штриховки в другую. Для копирования общих свойств и свойств штриховки (кроме исходной точки штриховки) из одной штриховки в другую используется диалоговое окно "Копировать свойства".

Для разделения штриховки на исходные объекты можно использовать команду РАСЧЛЕНИТЬ.

Редактирование контура штриховки

Имеется возможность редактировать контуры штриховки, как и другие объекты. Для этого можно использовать ручки, позволяющие растягивать, перемещать, поворачивать, масштабировать и зеркально отображать заштрихованные области и их контуры. Ассоциативная штриховка при редактировании замкнутого контура автоматически обновляется. Если в результате редактирования контур стал разомкнутым, то штриховка перестает быть ассоциативной и, следовательно, больше не зависит от формы контура. Ассоциативность штриховки может быть потеряна также в том случае, если во время редактирования контура оказался недоступен файл образца штриховки. Также при обрезке штриховки, если файл образца штриховки (PAT-файл) недоступен, штриховка не отображается.

Ассоциативность штриховки зависит от поднятия флажка "Ассоциативная" в диалоговых окнах "Штриховка и градиент" (ШТРИХОВКА) и "Редактирование штриховки" (РЕДШТР). Неассоциативные штриховки при изменении контуров не обновляются.

Ассоциативность штриховки в любой момент можно отменить, но после этого ассоциативность существующей штриховки восстановить будет уже нельзя. Необходимо повторно создать штриховку для восстановления ассоциативности или создать новый контур и ассоциировать его со штриховкой.

Для создания контура вокруг неассоциативной штриховки или штриховки, созданной с помощью указания точек, используйте параметр "Восстановить контур" диалогового окна "Штриховка и градиент". С помощью этого параметра можно также задать ассоциативность нового контура со штриховкой.

Редактирование закрашенных элементов

Закрашенными элементами могут быть:

  • сплошные штриховки-заливки
  • двумерные фигуры
  • градиентные заливки
  • широкие полилинии и кольца

Эти закрашенные объекты редактируются так же, как и другие штриховки, 2D фигуры, широкие полилинии и кольца. Кроме команды ОКОНСВ, можно использовать команду РЕДШТРИХ для работы с закрашенными штриховками и градиентными заливками, ручки для редактирования 2D фигур, а также команду ПОЛРЕД для широких полилиний и колец.

Изменение порядка следования для штриховки

Во время редактирования штриховки можно изменить ее порядок прорисовки таким образом, чтобы она отображалась за контуром, перед контуром, на заднем или на переднем плане.


Редактирование штриховки и заливки - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Редактирование штриховки и заливки
Понятия
Процедуры
Команды

Изменение угла наклона штриховки

Задание ограничения числа объектов, создаваемых штриховкой

Редактирование градиентной заливки


Изменение угла наклона штриховки - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Редактирование штриховки и заливки
Понятия
Процедуры
Команды

Изменение угла наклона штриховки

  1. Выберите образец штриховки.
  2. Укажите штриховку правой кнопкой мыши. Выберите "Свойства".
  3. На палитре свойств введите новое значение в поле "Угол".

Панель "Стандартная"

Ввод команды: ОКОНСВ


Задание ограничения числа объектов, создаваемых штриховкой - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Редактирование штриховки и заливки
Понятия
Процедуры
Команды

Задание ограничения числа объектов, создаваемых штриховкой

  • В командной строке введите (setenv “MaxHatch” “n”)

где n - число от 100 до 10000000 (десяти миллионов). Чем больше значение, тем плотнее наносимая штриховка.

Примечание При вводе имени переменной MaxHatch необходимо соблюдать регистр символов.


Редактирование градиентной заливки - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Редактирование штриховки и заливки
Понятия
Процедуры
Команды

Редактирование градиентной заливки

  1. Дважды нажмите кнопку мыши на градиентной заливке, которую требуется отредактировать.
  2. Введите необходимые изменения на вкладке "Градиент" диалогового окна "Редактирование штриховки".
  3. Кнопка "Просмотр" позволяет контролировать результат. Для возврата к диалоговому окну и выполнения настроек нажмите клавишу ENTER.
  4. После того, как требуемый эффект достигнут, в диалоговом окне "Штриховка и градиент" нажмите "ОК" для создания градиентной заливки.


Редактирование штриховки и заливки - Команды

Штриховка, закрашивание и маскировка
Штриховка, закрашивание и маскировка
Редактирование штриховки и заливки
Понятия
Процедуры
Команды

Команды
КОПИРОВАТЬСВ | Копирование свойств выбранного объекта в другие объекты
ПОЛРЕД | Редактирование полилиний и трехмерных полигональных сетей
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPANG | Указывает угол поворота образца штриховки
HPASSOC | Управляет ассоциативностью образцов штриховки и градиентных заливок
HPDOUBLE | Указывает режим штрихования крест-накрест для созданных пользователем штриховок
HPINHERIT | Определяет исходную точку полученной штриховки с помощью параметра "Копирование свойств" команд ШТРИХОВКА и РЕДШТРИХ
HPNAME | Устанавливает имя образца штриховки по умолчанию длиной до 34 символов (без пробелов)
HPORIGIN | Устанавливает исходную точку штриховки для новых объектов штриховки относительно текущей системы координат пользователя
HPORIGINMODE | Определяет исходную точку штриховки с помощью команды ШТРИХОВКА
HPSCALE | Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым
HPSPACE | Указывает расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть ненулевым
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание пустых маскирующих областей - Понятия

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Создание пустых маскирующих областей
Понятия
Процедуры
Команды

Маскирующие объекты - это многоугольники фонового цвета, которыми можно закрывать объекты чертежа. Область ограничивается контурами, видимость которых можно включать при редактировании и отключать при печати.

Маскирующие объекты создаются указанием точек многоугольника; они также могут быть получены преобразованием замкнутых полилиний.

Необходимые условия и ограничения

Полилиния, преобразуемая в маскирующий объект, должна быть замкнутой, иметь нулевую ширину и состоять только из линейных сегментов.

Маскирующие объекты можно создавать в пространстве листа для скрытия объектов в пространстве модели; однако для гарантии правильной печати маскирующего объекта должен быть снят флажок опции "Объекты листа последними" вкладки "Параметры печати" диалогового окна "Печать".

Поскольку маскирующие объекты похожи на растровые изображения, они имеют аналогичные требования к печати. Необходимо устройство печати, поддерживающее растровую графику, управляемое драйвером ADI 4.3 или драйвером системного принтера.

См. также

Управление отображением перекрывающихся объектов


Создание пустых маскирующих областей - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Создание пустых маскирующих областей
Понятия
Процедуры
Команды

Маскировка объектов чертежа пустыми областями

Включение/отключение видимости контуров маскирующих объектов


Маскировка объектов чертежа пустыми областями - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Создание пустых маскирующих областей
Понятия
Процедуры
Команды

Маскировка объектов чертежа пустыми областями

  1. Выберите "Рисование" » "Маскировка".
  2. Укажите точки в последовательности, определяющей контур, в пределах которого необходимо скрыть объекты.
  3. Для завершения нажмите ENTER.

Ввод команды: МАСКИРОВКА


Включение/отключение видимости контуров маскирующих объектов - Процедуры

Штриховка, пояснения, таблицы и размеры
Штриховка, закрашивание и маскировка
Создание пустых маскирующих областей
Понятия
Процедуры
Команды

Включение/отключение видимости контуров маскирующих объектов

  1. Выберите "Рисование" » "Маскировка".
  2. В командной строке введите р (рамка).
  3. Введите вкл или откл и нажмите ENTER.

Ввод команды: МАСКИРОВКА


Создание пустых маскирующих областей - Команды

Штриховка, закрашивание и маскировка
Штриховка, закрашивание и маскировка
Создание пустых маскирующих областей
Понятия
Процедуры
Команды

Команды
МАСКИРОВКА | Скрытие существующих объектов чертежа посредством наложения на них объектов цвета фона
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Надписи и метки - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Понятия
Процедуры
Команды

Имеется возможность выполнения и редактирования различных типов текстовых надписей, включая надписи на выносках. Большинство параметров текста управляется с помощью текстовых стилей.

  • Коротко о надписях и метках
  • Нанесение текста
    Нанесение текста может выполняться различными способами, в зависимости от поставленных целей.
  • Использование полей в тексте
    Поле представляет собой обновляемый текст, предназначенный для отображения данных, которые могут поменяться в ходе редактирования чертежа. При обновлении поля отображается его последнее значение.
  • Работа с текстовыми стилями
    При выполнении надписей на чертеже применяется текущий текстовый стиль, который определяет шрифт, высоту и угол наклона символов, ориентацию надписи, а также другие параметры текста.
  • Редактирование текста
    Имеется возможность редактирования и форматирования текста в надписях с изменением таких свойств, как масштаб и выравнивание.
  • Проверка орфографии
    Имеется возможность проверки орфографии во всех текстах чертежа. При этом пользователь может указывать и настраивать используемый словарь.
  • Работа с внешними текстовыми редакторами
    Редактором по умолчанию является редактор, используемый в месте редактирования, но можно использовать любой другой текстовый редактор, сохраняющий файлы в формате ASCII.


Надписи и метки - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Понятия
Процедуры
Команды

Создание однострочного текста

Задание текстового стиля при создании однострочного текста

Задание режима выравнивания однострочного текста

Создание многострочного текста

Вставка специальных символов в многострочный текст

Задание объекту многострочного текста непрозрачной или цветной маски заднего плана

Изменение в редакторе многострочного текста настройки сглаживания шрифтов Windows для улучшения видимости текста

Изменение режима выравнивания многострочного текста

Форматирование символов многострочного текста

Форматирование многострочного текста как списка

Отмена форматирования в многострочном тексте

Создание буквенного или нумерованного списка в многострочном тексте при вводе

Создание маркированного списка в многострочном тексте при вводе

Перемещение элемента списка многострочного текста на один уровень вниз

Разделение существующего списка

Преобразование списков, расположенных в многострочном тексте, в обычный текст

Создание абзацев с отступом

Изменение межстрочного интервала многострочного текстового объекта

Создание дробного текста

Изменение свойств дробного текста

Отключение состояния дробности текста

Построение выноски с прямой линией

Построение сплайновой выноски из двух сегментов с текстовой надписью

Построение нескольких выносок, ведущих к одной пояснительной надписи

Создание выноски с помощью редактора, используемого в месте редактирования

Импорт текстовых файлов

Вставка текстового файла перетаскиванием

Вставка поля в текст

Вставка поля в таблицу

Использование поля для отображения свойства объекта

Вставка поля заменителя подшивки

Форматирование значения поля

Редактирование поля

Ручное обновление поля

Обновление вручную нескольких полей

Автоматическое обновление полей

Добавление в текст поля гиперссылки

Установка текущего текстового стиля

Назначение шрифта текстовому стилю

Назначение SHX-шрифта азиатского языка текстовому стилю

Определение файла соответствия шрифтов

Задание альтернативного шрифта по умолчанию

Задание высоты в текстовом стиле

Задание угла наклона символов в текстовом стиле

Задание вертикальной ориентации в текстовом стиле

Редактирование однострочного текста

Изменение свойств однострочного текста

Изменение многострочного текста

Поиск фрагмента текста на чертеже

Замена текста

Изменение ширины многострочного текстового объекта

Редактирование пояснительной надписи

Проверка орфографии

Смена текущего основного или вспомогательного словаря во время проверки орфографии

Создание или редактирование вспомогательных словарей во время проверки орфографии

Указание внешнего текстового редактора

Создание многострочной надписи во внешнем редакторе


Надписи и метки - Команды

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Понятия
Процедуры
Команды
Команды
БВЫНОСКА | Построение простой выноски и надписи для нее
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ВЫРТЕКСТ | Изменение точки выравнивания для выбранных текстовых объектов без изменения их положения
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
ЕДПРОСТ | Преобразование расстояний между единицами пространства модели и пространства листа
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
МАСШТЕКСТ | Увеличение/уменьшение размеров текстовых объектов без изменения их расположения
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
МТРЕД | Редактирует многострочный текст
НАЙТИ | Поиск, замена , выбор и показ текста на чертеже
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОБНПОЛЕ | Позволяет обновлять поля в выбранных объектах чертежа вручную
ОРФО | Орфографическая проверка надписей в чертеже
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
ПОЛЕ | Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения
РЗМСТИЛЬ | Создание и модификация размерных стилей
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
ТАБЛИЦА | Создание пустой таблицы объектов в чертеже
ТАБЛСТИЛЬ | Создание нового стиля таблиц
ТЕКСТ | Создание однострочных текстовых объектов
ЭКСПОРТТАБЛ | Экспорт данных таблицы в файл формата CSV
Системные переменные
CENTERMT | Управление растягиванием центрированного по горизонтали многострочного текста с помощью ручек
CTABLESTYLE | Установка имени текущего стиля таблицы.
DCTCUST | Отображает путь и имя файла текущего настраиваемого орфографического словаря.
DCTMAIN | Отображает имя файла текущего основного орфографического словаря.
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
DIMASZ | Управление величинами стрелок размерных линий и линий выноски
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMLDRBLK | Задает тип стрелки для выносок
DIMSCALE | Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
DTEXTED | Задает интерфейс пользователя, выводимый на экран для редактирования однострочного текста.
FIELDDISPLAY | Управляет отображением полей на сером фоне
FIELDEVAL | Управляет обновлением полей
FONTALT | Указывает альтернативный шрифт, используемый в случае, если не найден указанный шрифт
FONTMAP | Указывает файл, описывающий подстановку шрифтов
MIRRTEXT | Управляет отображением текста с помощью команды ЗЕРКАЛО
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
MTEXTFIXED | Устанавливает размер экрана и положение многострочного текста
MTJIGSTRING | Определяет содержимое образца текста, отображаемого в месте курсора при запуске команды МТЕКСТ
QTEXTMODE | Управляет отображением текста
TEXTEVAL | Управляет методом обработки текстовых строк, вводимых с помощью команды ТЕКСТ (с использованием AutoLISP) или -ТЕКСТ
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
TEXTSIZE | Устанавливает высоту по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля
TEXTSTYLE | Задает имя текущего текстового стиля
TSPACEFAC | Управляет отношением межстрочного интервала к высоте многострочного текста
TSTACKALIGN | Управляет выравниванием дробного текста по вертикали
TSTACKSIZE | Управляет процентом дробной высоты многострочного текста относительно текущей высоты выбранного текста
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о надписях и метках - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о надписях и метках
Понятия
Процедуры
Команды

Текст можно создать различными способами. Более короткие фрагменты выполняются с помощью однострочного текста. Для длинных надписей с форматированием используется многострочный текст (также называемый мтекст). Многострочные текстовые надписи могут применяться и в выносках.

Несмотря на то, что при нанесении надписей применяется текущий текстовый стиль, который определяет шрифт и параметры текста, существует несколько способов настройки внешнего вида текста. Существуют инструменты для масштабирования и выравнивания текста, поиска и замены текста, а также для проверки на наличие орфографических ошибок.

Текстовые надписи, используемые в размерах и допусках, выполняются с помощью команд, предназначенных для нанесения размеров.

См. также

Отображение полилиний, штриховок, градиентных заливок, весов линий и текста

Управление отображением перекрывающихся объектов


Надписи и метки

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Надписи и метки
Понятия
Процедуры
Команды

Нет процедур.


Коротко о надписях и метках - Команды

Надписи и метки
Надписи и метки
Коротко о надписях и метках
Понятия
Процедуры
Команды

Команды
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
ОРФО | Орфографическая проверка надписей в чертеже
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
ТЕКСТ | Создание однострочных текстовых объектов
Системные переменные
DIMASZ | Управление величинами стрелок размерных линий и линий выноски
DIMLDRBLK | Задает тип стрелки для выносок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение текста - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Нанесение текста
Понятия
Процедуры
Команды

Нанесение текста может выполняться различными способами, в зависимости от поставленных целей.

  • Коротко о создании надписей и выносок
  • Создание однострочного текста
    Можно создавать одну или несколько строк текста, каждая из которых является отдельным объектом. Строки можно по отдельности перемещать, форматировать или редактировать иным образом.
  • Создание многострочного текста
    Многострочный текст ("мтекст") состоит из одного или нескольких абзацев, которые при манипуляциях ведут себя как единый объект.
  • Нанесение текстов на выноски
    Имеется возможность выполнения надписей с одной или несколькими линиями-выносками.
  • Импорт текстовых файлов
    В чертеж можно вставлять текст из файлов форматов TXT и RTF, импортируя сам текст или перетаскивая значок файла из Проводника Windows.

См. также

Использование полей в тексте


Нанесение текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Нанесение текста
Понятия
Процедуры
Команды

Создание однострочного текста

Задание текстового стиля при создании однострочного текста

Задание режима выравнивания однострочного текста

Создание многострочного текста

Вставка специальных символов в многострочный текст

Задание объекту многострочного текста непрозрачной или цветной маски заднего плана

Изменение в редакторе многострочного текста настройки сглаживания шрифтов Windows для улучшения видимости текста

Изменение режима выравнивания многострочного текста

Форматирование символов многострочного текста

Форматирование многострочного текста как списка

Отмена форматирования в многострочном тексте

Создание буквенного или нумерованного списка в многострочном тексте при вводе

Создание маркированного списка в многострочном тексте при вводе

Перемещение элемента списка многострочного текста на один уровень вниз

Разделение существующего списка

Преобразование списков, расположенных в многострочном тексте, в обычный текст

Создание абзацев с отступом

Изменение межстрочного интервала многострочного текстового объекта

Создание дробного текста

Изменение свойств дробного текста

Отключение состояния дробности текста

Построение выноски с прямой линией

Построение сплайновой выноски из двух сегментов с текстовой надписью

Построение нескольких выносок, ведущих к одной пояснительной надписи

Создание выноски с помощью редактора, используемого в месте редактирования

Импорт текстовых файлов

Вставка текстового файла перетаскиванием


Нанесение текста - Команды

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Нанесение текста
Понятия
Процедуры
Команды
Команды
БВЫНОСКА | Построение простой выноски и надписи для нее
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОРФО | Орфографическая проверка надписей в чертеже
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
РЗМСТИЛЬ | Создание и модификация размерных стилей
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
ТЕКСТ | Создание однострочных текстовых объектов
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
DIMASZ | Управление величинами стрелок размерных линий и линий выноски
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMLDRBLK | Задает тип стрелки для выносок
DIMSCALE | Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
FONTALT | Указывает альтернативный шрифт, используемый в случае, если не найден указанный шрифт
FONTMAP | Указывает файл, описывающий подстановку шрифтов
MIRRTEXT | Управляет отображением текста с помощью команды ЗЕРКАЛО
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
MTEXTFIXED | Устанавливает размер экрана и положение многострочного текста
MTJIGSTRING | Определяет содержимое образца текста, отображаемого в месте курсора при запуске команды МТЕКСТ
QTEXTMODE | Управляет отображением текста
TEXTEVAL | Управляет методом обработки текстовых строк, вводимых с помощью команды ТЕКСТ (с использованием AutoLISP) или -ТЕКСТ
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
TEXTSIZE | Устанавливает высоту по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля
TEXTSTYLE | Задает имя текущего текстового стиля
TSPACEFAC | Управляет отношением межстрочного интервала к высоте многострочного текста
TSTACKALIGN | Управляет выравниванием дробного текста по вертикали
TSTACKSIZE | Управляет процентом дробной высоты многострочного текста относительно текущей высоты выбранного текста
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о создании надписей и выносок - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о создании надписей и выносок
Понятия
Процедуры
Команды

Наносимые на чертеж текстовые надписи несут различную информацию. Надписи могут представлять собой сложные спецификации, элементы основной надписи, заголовки; кроме того, надписи могут даже быть полноправными элементами самого чертежа.

Однострочный текст

Короткие надписи, не требующие применения различных шрифтов, выполняются в виде однострочного текста. Такие надписи наиболее удобны для нанесения меток.

Многострочные тексты

Для создания длинных и сложных надписей используется многострочный текст или текст, содержащий абзацы. Многострочный текст состоит из текстовых строк или абзацев, вписанных в указанную пользователем ширину; его длина при этом не определена.

В отличие от однострочного текста, все строки многострочного текста представляют собой единый объект. Многострочный текст можно перемещать, поворачивать, стирать, копировать, зеркально отображать и масштабировать.

Возможности форматирования многострочного текста намного шире, чем однострочного. Например, в многострочных надписях можно задавать режим подчеркивания отдельных слов и фраз, назначать для них свой шрифт, цвет и высоту символов.

Выноски

Выноской называется отрезок или сплайн, на одном конце которого размещается стрелка, а на другом пояснительная надпись в виде многострочного текста. Объект выноски связан с многострочным текстом таким образом, что при перемещении, повороте или масштабировании текста происходит соответствующее изменение линии выноски. Точно так же выноска связывается с любым объектом, к которому прикреплена ее стрелка, если используются ассоциативные размеры и включена объектная привязка для позиционирования стрелок выносок.

Текст, содержащийся в чертеже, можно копировать и связывать с объектом выноски.

Примечание Не следует путать выноски с линиями-выносками, которые автоматически генерируются как части размерных линий.


Нанесение текста

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Нанесение текста
Понятия
Процедуры
Команды

Нет процедур.


Коротко о создании надписей и выносок - Команды

Надписи и метки
Надписи и метки
Коротко о создании надписей и выносок
Понятия
Процедуры
Команды

Команды
БВЫНОСКА | Построение простой выноски и надписи для нее
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
ТЕКСТ | Создание однострочных текстовых объектов
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
DIMASZ | Управление величинами стрелок размерных линий и линий выноски
DIMLDRBLK | Задает тип стрелки для выносок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание однострочного текста - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание однострочного текста
Понятия
Процедуры
Команды

Команда однострочного текста (ТЕКСТ) позволяет создать одну или несколько строк текста. Каждая строка заканчивается при нажатии клавиши ENTER. Каждая строка является отдельным объектом, который можно перемещать, форматировать или редактировать иным образом.

При создании однострочного текста устанавливаются стиль текста и выравнивание. Текущие настройки вида текстового объекта определяются текстовым стилем. Выравнивание задает расположение текстовой строки относительно точки вставки. Для введения текста по месту используется команда ТЕКСТ, тогда как ввод слова -текст в командной строке позволяет ввести текст в командную строку.

В однострочный текст можно вставить поле. Полем называется текст, используемый для отображения данных, которые могут изменяться. При обновлении поля отображается его последнее значение.

Одни и те же текстовые стили могут применяться как для однострочных текстов, так и для многострочных. Назначение стиля при создании текста выполняется с помощью опции "Стиль" с последующим вводом имени нужного стиля. Для выполнения надписей с неоднородным форматированием вместо однострочного текста следует использовать многострочный.

Можно также задать режим вписывания текста между указанными точками. При этом текст растягивается или сжимается в зависимости от расстояния между ними.

Системная переменная DTEXTED определяет пользовательский интерфейс, отображаемый для редактирования однострочного текста.

Режимы выравнивания однострочного текста

При создании текста можно задать режимы его выравнивания. Варианты выравнивания текста иллюстрируются на следующем чертеже. По умолчанию используется режим выравнивания "Влево". Поэтому для нанесения надписи, выровненной влево от точки вставки, в командной строке дополнительно задавать ничего не требуется.

См. также

Использование полей в тексте


Создание однострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание однострочного текста
Понятия
Процедуры
Команды

Создание однострочного текста

Задание текстового стиля при создании однострочного текста

Задание режима выравнивания однострочного текста


Создание однострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание однострочного текста
Понятия
Процедуры
Команды

Создание однострочного текста

  1. Нажмите "Рисование" » "Текст" » "Однострочный".
  2. Укажите точку вставки первого символа. При нажатии клавиши ENTER программа поместит новый текст непосредственно под текстовым объектом, созданным последним (если таковой имеется).
  3. Задайте высоту текста. Запрос высоты появляется в том случае, если текущий текстовый стиль имеет нулевую высоту.

    4. Точка вставки текста и курсор соединяются резиновой линией. Чтобы задать высоту текста по резиновой линии, требуется нажать кнопку мыши.

  4. Задайте угол поворота текста.

    5. Угол можно задать путем ввода числового значения или с помощью устройства указания.

  5. Введите строку текста. В конце строки нажмите ENTER. Если необходимо, введите следующие строки.

    6. Примечание Текст, который может оказаться трудночитаемым (если он очень мелкий, очень крупный или повёрнут), отображается в удобном для чтения масштабе и в горизонтальном положении, чтобы его было удобно читать и редактировать.

    Если указать другую точку вставки, курсор перемещается к указанной позиции, после чего можно продолжать ввод текста. После каждого нажатия ENTER или указания точки создается новый текстовый объект.

  6. Для завершения команды нажмите ENTER на пустой строке.

Ввод команды: ТЕКСТ


Задание текстового стиля при создании однострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание однострочного текста
Понятия
Процедуры
Команды

Задание текстового стиля при создании однострочного текста

  1. Нажмите "Рисование" » "Текст" » "Однострочный".
  2. Введите с (стиль).
  3. В ответ на запрос "Имя стиля" введите имя имеющегося текстового стиля.

    4. Для получения списка текстовых стилей можно ввести ?, после чего следует дважды нажать ENTER.

  4. Продолжите создание текста.

Ввод команды: ТЕКСТ


Задание режима выравнивания однострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание однострочного текста
Понятия
Процедуры
Команды

Задание режима выравнивания однострочного текста

  1. Нажмите "Рисование" » "Текст" » "Однострочный".
  2. Ввести с (Стиль).
  3. Задайте режим выравнивания. Например, введите вв для выравнивания текста вверх и влево.
  4. Продолжите нанесение текста.

Ввод команды: ТЕКСТ


Создание однострочного текста - Команды

Надписи и метки
Надписи и метки
Создание однострочного текста
Понятия
Процедуры
Команды

Команды
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
ТЕКСТ | Создание однострочных текстовых объектов
Системные переменные
FONTALT | Указывает альтернативный шрифт, используемый в случае, если не найден указанный шрифт
FONTMAP | Указывает файл, описывающий подстановку шрифтов
MIRRTEXT | Управляет отображением текста с помощью команды ЗЕРКАЛО
QTEXTMODE | Управляет отображением текста
TEXTEVAL | Управляет методом обработки текстовых строк, вводимых с помощью команды ТЕКСТ (с использованием AutoLISP) или -ТЕКСТ
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
TEXTSIZE | Устанавливает высоту по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля
TEXTSTYLE | Задает имя текущего текстового стиля
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание многострочного текста - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание многострочного текста
Понятия
Процедуры
Команды

Многострочный текст ("мтекст") состоит из одного или нескольких абзацев, которые при манипуляциях ведут себя как единый объект.

  • Коротко о многострочном тексте
  • Выравнивание многострочного текста
    Режим выравнивания управляет размещением многострочного текста относительно его точки вставки, а также направлением его распространения.
  • Форматирование символов многострочного текста
    Для многострочного текста можно применять неоднородное форматирование, переопределяя заданный текстовый стиль.
  • Создание списков в многострочном тексте
    Можно создавать маркированные списки, буквенные или нумерованные списки или простые планы в многострочном тексте.
  • Задание отступов и табуляции в многострочном тексте
    Можно устанавливать отступ абзацев в объектах многострочного текста (мтекст). Линейка в верхней части редактора, используемого в месте редактирования, отображает позиции табуляции и отступа текущего абзаца.
  • Задание межстрочного интервала многострочного текста
    Межстрочный интервал определяет расстояние между базовыми линиями двух соседних строк текста. Значение межстрочного интервала устанавливается сразу для всего многострочного текстового объекта, а не только для выделенных строк.
  • Создание дробей в многострочном тексте
    Текст, отображающий дробные значения измерений или допусков, может быть отформатирован в разных стандартах.


Создание многострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание многострочного текста
Понятия
Процедуры
Команды

Создание многострочного текста

Вставка специальных символов в многострочный текст

Задание объекту многострочного текста непрозрачной или цветной маски заднего плана

Изменение в редакторе многострочного текста настройки сглаживания шрифтов Windows для улучшения видимости текста

Изменение режима выравнивания многострочного текста

Форматирование символов многострочного текста

Форматирование многострочного текста как списка

Отмена форматирования в многострочном тексте

Создание буквенного или нумерованного списка в многострочном тексте при вводе

Создание маркированного списка в многострочном тексте при вводе

Перемещение элемента списка многострочного текста на один уровень вниз

Разделение существующего списка

Преобразование списков, расположенных в многострочном тексте, в обычный текст

Создание абзацев с отступом

Изменение межстрочного интервала многострочного текстового объекта

Создание дробного текста

Изменение свойств дробного текста

Отключение состояния дробности текста


Создание многострочного текста - Команды

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание многострочного текста
Понятия
Процедуры
Команды
Команды
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
Системные переменные
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
MTEXTFIXED | Устанавливает размер экрана и положение многострочного текста
MTJIGSTRING | Определяет содержимое образца текста, отображаемого в месте курсора при запуске команды МТЕКСТ
QTEXTMODE | Управляет отображением текста
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
TEXTSIZE | Устанавливает высоту по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля
TEXTSTYLE | Задает имя текущего текстового стиля
TSPACEFAC | Управляет отношением межстрочного интервала к высоте многострочного текста
TSTACKALIGN | Управляет выравниванием дробного текста по вертикали
TSTACKSIZE | Управляет процентом дробной высоты многострочного текста относительно текущей высоты выбранного текста
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о многострочном тексте - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о многострочном тексте
Понятия
Процедуры
Команды

Один и более абзацев многострочного текста (мтекст) можно ввести в текстовом редакторе, используемом в месте редактирования, в альтернативном текстовом редакторе или в командной строке. Можно также вставлять текст из файлов формата TXT и RTF.

Прежде чем набрать или импортировать текст, необходимо задать рамкой ширину абзацев многострочного текста. В отличие от ширины, длина текста не определяется рамкой, а зависит только от размера текстовых данных объекта. С помощью ручек многострочные текстовые объекты можно перемещать и поворачивать.

Текстовый редактор, используемый в месте редактирования, представляет собой окно с линейкой в верхней части и панелью форматирования текста. Окно редактора является прозрачным, что позволяет контролировать расположение набираемого текста относительно других объектов. Чтобы отключить прозрачность во время работы, установите флажок "Непрозрачный фон" в меню "Настройка". Можно также включить для многострочного текста непрозрачную маску заднего плана и задать ее цвет.

Для настройки внешнего вида многострочного текста можно устанавливать символы табуляции и делать отступы в тексте.

В многострочном текст можно использовать поля. Полем называется текст, используемый для отображения данных, которые могут изменяться. При обновлении поля отображается его последнее значение.

Текстовый стиль

Большинство параметров текста обуславливаются текстовым стилем. К числу таких параметров относятся шрифт, цвет, режим выравнивания и интервал. Имеется возможность использования текущего текстового стиля, а также выбора и загрузки нового. По умолчанию применяется текстовый стиль СТАНДАРТ.

Для отдельных фрагментов текста можно задавать различные текстовые стили, изменяя начертание и шрифт. Можно также включать фрагменты с использованием дробного текста, например значения допусков. Кроме того, при использовании шрифтов TrueType можно вставлять специальные символы, в том числе символы из набора Unicode.

Примечание Не все текстовые шрифты TrueType и SHX поддерживают символы из набора Unicode.

Свойства текста

На палитре "Свойства" можно просматривать и изменять свойства объектов многострочного текста, в том числе свойства, присущие только тексту.

  • Режим выравнивания определяет положение текста относительно границ окна и задает направление текста при его вводе.
  • Опции межстрочного интервала определяют расстояние между базовыми линиями двух соседних строк многострочного текстового объекта.
  • Настройка ширины задает ширину рамки текста, т.е. определяет место переноса текста на новую строку.
  • Маска заднего плана делает невидимыми объекты, расположенные за текстом.


Коротко о многострочном тексте - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о многострочном тексте
Понятия
Процедуры
Команды

Создание многострочного текста

Вставка специальных символов в многострочный текст

Задание объекту многострочного текста непрозрачной или цветной маски заднего плана

Изменение в редакторе многострочного текста настройки сглаживания шрифтов Windows для улучшения видимости текста


Создание многострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о многострочном тексте
Понятия
Процедуры
Команды

Создание многострочного текста

  1. Нажмите "Рисование" » "Текст" » "Многострочный".
  2. Задайте рамкой ширину области многострочного текста.

    3. Отобразится текстовый редактор, используемый в месте редактирования.

  3. Для задания отступа первой строки абзаца на горизонтальной линейке переместите маркер "Первая строка" в положение, с которого должен начинаться текст. Для задания отступа остальных строк абзаца на горизонтальной линейке переместите маркер "Абзац".
  4. Для задания позиций табуляции нажмите кнопку мыши в нужных местах на горизонтальной линейке.
  5. Для задания текстового стиля, отличного от установленного по умолчанию, раскройте список "Стиль" на панели редактора и выберите требуемый стиль.
  6. Введите текст.

    7. Примечание Текст, который может оказаться трудночитаемым (если он очень мелкий, очень крупный или повёрнут), отображается в удобном для чтения масштабе и в горизонтальном положении, чтобы его было удобно читать и редактировать.

  7. Для переопределения настроек текущего текстового стиля выделите текст одним из следующих способов:
    • Для выделения фрагмента текста нажмите левую кнопку мыши и, не отпуская ее, проведите курсор над нужными символами.
    • Для выделения слова дважды нажмите на нем кнопку мыши.
    • Для выделения абзаца трижды нажмите на нем кнопку мыши.
  8. С помощью панели инструментов измените формат следующим образом:
    • Для изменения шрифта выберите нужное значение из списка "Шрифт".
    • Для изменения высоты символов введите новое значение в поле "Высота текста".
    • Для изменения начертания символов на полужирное или курсивное (только для шрифтов TrueType) или создания подчеркнутого или надчеркнутого текста нажмите соответствующую кнопку на панели инструментов. Для SHX-шрифтов полужирное и курсивное начертания не поддерживаются.
    • Для изменения цвета символов выберите нужное значение из списка "Цвет". Если необходимый цвет отсутствует в списке, следует воспользоваться пунктом "Выбор цвета".
  9. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку в области чертежа вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Вставка специальных символов в многострочный текст - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о многострочном тексте
Понятия
Процедуры
Команды

Вставка специальных символов в многострочный текст

  1. Дважды нажмите кнопку мыши на многострочном тексте, чтобы открыть текстовый редактор, используемый в месте редактирования.
  2. На развернутой панели нажмите "Символ".
  3. Выберите нужный символ из подменю или выберите пункт "Прочие" для вызова диалогового окна "Таблица символов".

    4. Для вызова диалогового окна "Таблица символов" необходимо, чтобы была установлена программа charmap.exe. Сведения о добавке программ к своей системе - см. в справке по Microsoft® Windows®.

  4. В диалоговом окне "Таблица символов" выберите шрифт.
  5. Выделите символ и выполните одно из следующих действий:
    • Для вставки одиночного символа необходимо перетащить выбранный символ в редактор.
    • Для вставки нескольких символов необходимо для каждого символа нажать кнопку "Выбрать" для добавления его в поле "Копируемые символы". После выбора всех необходимых символов нажмите кнопку "Копировать". Нажмите правую кнопку мыши в редакторе. Выберите "Вставить".
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку в области чертежа вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Задание объекту многострочного текста непрозрачной или цветной маски заднего плана - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о многострочном тексте
Понятия
Процедуры
Команды

Задание объекту многострочного текста непрозрачной или цветной маски заднего плана

  1. Дважды нажмите кнопку мыши на многострочном тексте, чтобы открыть текстовый редактор, используемый в месте редактирования.
  2. Нажмите правую кнопку мыши в редакторе. Выберите "Маска заднего плана".
  3. В диалоговом окне "Маска заднего плана" выберите "Использовать маску".
  4. Введите значение для коэффициента смещения границ.

    5. Значение привязывается к высоте текста. Коэффициент, равный 1,0, означает, что размер непрозрачного фона точно соответствует размеру объекта многострочного текста. Коэффициент 1,5 (по умолчанию) означает, что маска выступает за пределы текста на половину его высоты.

  5. В группе "Цвет закрашивания" выполните одно из следующих действий:
    • Выберите параметр "Использовать цвет фона чертежа".
    • Выберите цвет фона или нажмите "Выбор цвета" для открытия диалогового окна "Выбор цвета".
  6. Нажмите "OK" для возврата в редактор.
  7. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

    После выхода из редактора используется непрозрачный фон.

Панель "Рисование"

Ввод команды: МТЕКСТ


Изменение в редакторе многострочного текста настройки сглаживания шрифтов Windows для улучшения видимости текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о многострочном тексте
Понятия
Процедуры
Команды

Изменение в редакторе многострочного текста настройки сглаживания шрифтов Windows для улучшения видимости текста

  1. Нажмите правую кнопку мыши на рабочем столе Windows. Выберите "Свойства".
  2. В диалоговом окне "Свойства: Экран" выберите вкладку "Оформление".
  3. Выберите "Эффекты".
  4. В диалоговом окне "Эффекты" выберите "Применять следующий метод сглаживания экранных шрифтов" для отмены этого режима.
  5. Нажмите "ОК" для выхода из диалогового окна "Эффекты".
  6. Нажмите "ОК" для выхода из диалогового окна "Свойства: Экран".


Коротко о многострочном тексте - Команды

Надписи и метки
Надписи и метки
Коротко о многострочном тексте
Понятия
Процедуры
Команды

Команды
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
Системные переменные
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
MTEXTFIXED | Устанавливает размер экрана и положение многострочного текста
MTJIGSTRING | Определяет содержимое образца текста, отображаемого в месте курсора при запуске команды МТЕКСТ
QTEXTMODE | Управляет отображением текста
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
TEXTSIZE | Устанавливает высоту по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля
TEXTSTYLE | Задает имя текущего текстового стиля
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выравнивание многострочного текста - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Выравнивание многострочного текста
Понятия
Процедуры
Команды

Режим выравнивания управляет размещением многострочного текста относительно его точки вставки, а также направлением его распространения. Выравнивание текста производится относительно левой и правой границ текстовой рамки. Текст может распространяться от середины, верхней или нижней границы абзаца.

Существуют девять вариантов настроек выравнивания многострочного текста.

Если длина отдельного слова текста больше ширины абзаца, то слово не переносится, а выходит за границы абзаца.


Изменение режима выравнивания многострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Выравнивание многострочного текста
Понятия
Процедуры
Команды

Изменение режима выравнивания многострочного текста

  1. Нажмите "Сервис" » "Свойства".
  2. Выберите объект многострочного текста.
  3. На палитре свойств выберите один из режимов выравнивания.
  4. Нажмите кнопку мыши за пределами палитры свойств.

Ввод команды: ОКОНСВ


Выравнивание многострочного текста - Команды

Надписи и метки
Надписи и метки
Выравнивание многострочного текста
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Форматирование символов многострочного текста - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Форматирование символов многострочного текста
Понятия
Процедуры
Команды

Для многострочного текста можно применять неоднородное форматирование, переопределяя заданный текстовый стиль. Форматирование воздействует только на выбранный текст; текущий текстовый стиль не меняется.

Можно задавать шрифт и размер текста, а также изменять начертание (полужирное, курсивное, подчеркнутое, надчеркнутое) и цвет. Также можно задавать угол наклона, изменять межсимвольный интервал и расширять или сужать символы. Параметр "Отменить форматирование" в меню параметров меняет значения атрибутов символов выделенного фрагмента на значения текущего стиля текста, а также меняет цвет текста на цвет объекта многострочного текста.

Высота прописных букв в тексте определяется заданной высотой символов. Подробнее о расчете высоты см. описание команды МТЕКСТ.

См. также

Работа с внешними текстовыми редакторами


Форматирование символов многострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Форматирование символов многострочного текста
Понятия
Процедуры
Команды

Форматирование символов многострочного текста

  1. Дважды нажмите кнопку мыши на многострочном тексте, чтобы открыть текстовый редактор, используемый в месте редактирования.
  2. Выделите текст одним из следующих способов:
    • Для выделения фрагмента текста нажмите левую кнопку мыши и, не отпуская ее, провести курсор над нужными символами.
    • Для выделения слова нажмите на нем дважды кнопку мыши.
    • Для выделения абзаца нажмите кнопку мыши трижды.
  3. С помощью панели инструментов измените формат следующим образом:
    • Для изменения шрифта выберите нужное значение из списка "Шрифт".
    • Для изменения высоты символов введите новое значение в поле "Высота текста".
    • Для изменения начертания символов на полужирное или курсивное (только для шрифтов TrueType) или создания подчеркнутого или надчеркнутого текста нажмите соответствующую кнопку на панели инструментов. Для SHX-шрифтов полужирное и курсивное начертания не поддерживаются.
    • Для изменения цвета символов выберите нужное значение из списка "Цвет". Нажмите кнопку "Прочие" для отображения диалогового окна "Выбор цвета".
    • Для задания угла наклона текста введите значение от -85 до 85. Положительное значение угла соответствует наклону символов вправо, отрицательное - наклону влево.
    • Для изменения интервала между знаками в выделенном фрагменте введите новое значение.
    • Для изменения ширины символов в выделенном фрагменте введите новое значение.
  4. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Форматирование символов многострочного текста - Команды

Надписи и метки
Надписи и метки
Форматирование символов многострочного текста
Понятия
Процедуры
Команды

Команды
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
Системные переменные
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание списков в многострочном тексте - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание списков в многострочном тексте
Понятия
Процедуры
Команды

Строки многострочного текста можно форматировать так же, как и список. При добавлении или удалении элемента или при перемещении элемента вверх или вниз на один уровень нумерация в списке изменяется автоматически. Имеется возможность удаления и возвращения форматирования списка тем же способом, что используется в большинстве текстовых редакторов.

Использование автоматического форматирования списков

По умолчанию формат списка применяется ко всем текстам, похожим на список. Списком считается текст, одновременно отвечающий следующим критериям:

  • строка начинается с одной или нескольких букв или цифр или символа;
  • за буквой или цифрой следует знак препинания;
  • пробел после знака препинания создается нажатием клавиши TAB;
  • текст, следующий за пробелом, заканчивается нажатием клавиш ЕNTER или SHIFT+ENTER.

Примечание Если не требуется применять форматирование списка ко всем фрагментам текста, удовлетворяющим этим критериям, нужно снять флажок "Разрешить маркеры и списки". (Нажмите правую кнопку мыши в текстовом редакторе, используемом в месте редактирования, выберите "Маркеры и списки" и снимите флажок "Разрешить маркеры и списки".) Если не установлен флажок "Разрешить маркеры и списки", создавать новые форматированные списки в объекте многострочного текста нельзя.

Для создания списка можно воспользоваться одним из следующих способов:

  • Применить форматирование списка к новому тексту или выделенному фрагменту текста.
  • Воспользоваться автоматическим режимом списка (включен по умолчанию) и ввести элементы списка.
  • Если опция "Автоматический список" отключена, то для преобразования текста в список необходимо ввести элементы списка, затем закрыть редактор и вновь открыть его.
Применение форматирования списка

При использовании форматирования списка можно задавать маркеры, буквы верхнего или нижнего регистра или цифры. Для выбираемого типа списка используются параметры по умолчанию. После букв и цифр ставится точка. Во вложенных списках используются двойные маркеры, буквы или цифры. Смещение элементов вправо (отступ) производится по позициям табуляции, установленных на линейке редактора, используемого в месте редактирования.

Использование автоматического списка для ввода списка

Когда включен режима автоматического списка, список можно создавать при вводе текста. Можно использовать буквы, цифры или символы. Например, можно ввести 421., нажать клавишу TAB и ввести какой-нибудь текст. При нажатии клавиши ENTER следующая строка начнется c 422, точки и табуляции.

Ниже приведены символы, которые можно использовать в качестве знаков препинания после цифры или буквы при вводе элементов списка. Эти символы нельзя использовать в качестве маркеров.

Символ | Описание
. | Точка
: | Двоеточие
) | Закрывающая круглая скобка
> | Закрывающая угловая скобка
] | Закрывающая квадратная скобка
} | Закрывающая фигурная скобка
Вставка списка из другого документа

При копировании вложенных маркированных списков (список в списке) из программы Microsoft Word и вставке списка в многострочный текст маркеры, отображаемые пустыми кружками, не могут форматироваться, как другие маркеры в тексте. Это связано с тем, что в программе Word буква o используется вместо маркера для вложенных маркированных текстов. Можно отменить форматирование во вложенном списке и повторно применить его для замены маркеров двойными маркерами.


Создание списков в многострочном тексте - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание списков в многострочном тексте
Понятия
Процедуры
Команды

Форматирование многострочного текста как списка

Отмена форматирования в многострочном тексте

Создание буквенного или нумерованного списка в многострочном тексте при вводе

Создание маркированного списка в многострочном тексте при вводе

Перемещение элемента списка многострочного текста на один уровень вниз

Разделение существующего списка

Преобразование списков, расположенных в многострочном тексте, в обычный текст


Форматирование многострочного текста как списка - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание списков в многострочном тексте
Понятия
Процедуры
Команды

Форматирование многострочного текста как списка

  1. Нажмите "Рисование" » "Текст" » "Многострочный".
  2. Задать рамкой ширину области многострочного текста.
  3. Для развертывания панели "Формат текста" нажмите кнопку "Параметры" » "Показать параметры".
  4. При преобразовании многострочного текста в список выберите абзацы.

    5. Примечание Форматирование списка возможно только тогда, когда флажок "Разрешить маркеры и списки" установлен (значение по умолчанию).

  5. На развернутой панели нажмите кнопку "Нумерация", "Маркеры" или "Буквы верхнего регистра".
    • Нумерация. Использует цифры с точками для элементов в списке.
    • Маркеры. Использует маркер или другой символ для элементов в списке.
    • Прописные буквы. Использует прописные буквы с точками для элементов в списке. Если в списке больше элементов, чем букв в алфавите, для продолжения последовательности используются две буквы. Для использования букв нижнего регистра нажмите правую кнопку мыши в редакторе. Выберите "Маркеры и списки" » "Буквенный" » "Нижний регистр".
  6. Если создаются новые элементы списка, следует ввести текст.
  7. Чтобы завершить список, нажмите клавишу ENTER для перехода на новую строку. Нажмите кнопку, которая была нажата раньше для создания списка.
  8. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна Редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Отмена форматирования в многострочном тексте - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание списков в многострочном тексте
Понятия
Процедуры
Команды

Отмена форматирования в многострочном тексте

  1. Дважды нажмите кнопку мыши на многострочном тексте, чтобы открыть текстовый редактор, используемый в месте редактирования.
  2. Выберите элементы списка.
  3. Для развертывания панели "Формат текста" нажмите кнопку "Параметры" » "Показать параметры".
  4. На развернутой панели нажмите активную кнопку списка: "Нумерация", "Маркеры" или "Буквы верхнего регистра" - для ее отключения.

    5. Примечание Если в списке используются буквы нижнего регистра, нажмите кнопку "Буквы нижнего регистра" для преобразования регистра букв списка в верхний. Затем нажмите кнопку "Буквы верхнего регистра" для ее отключения.

  5. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Создание буквенного или нумерованного списка в многострочном тексте при вводе - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание списков в многострочном тексте
Понятия
Процедуры
Команды

Создание буквенного или нумерованного списка в многострочном тексте при вводе

  1. Нажмите "Рисование" » "Текст" » "Многострочный".
  2. Задайте рамкой ширину области многострочного текста.
  3. Для развертывания панели "Формат текста" нажмите кнопку "Параметры" » "Показать параметры".
  4. Выберите "Маркеры и списки". Удостоверьтесь, что установлены флажки "Разрешить автоматический список" и "Разрешить маркеры и списки".
  5. Введите букву или цифру и точку (или другой знак препинания).

    6. В качестве знаков препинания после букв или цифр можно использовать следующие символы: точку (.), двоеточие (:), закрывающую круглую скобку ()), закрывающую угловую скобку (>), закрывающую квадратную скобку (]) и закрывающую фигурную скобку (}).

  6. Нажмите TAB.
  7. Введите текст элемента списка. Нажмите клавишу ENTER для перехода к следующему элементу или использовать сочетание клавиш SHIFT+ENTER для добавления абзаца перед следующим элементом.

    8. Элементу автоматически присваивается следующая буква или цифра.

  8. Дважды нажмите клавишу ENTER для завершения списка.
  9. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Создание маркированного списка в многострочном тексте при вводе - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание списков в многострочном тексте
Понятия
Процедуры
Команды

Создание маркированного списка в многострочном тексте при вводе

  1. Нажмите "Рисование" » "Текст" » "Многострочный".
  2. Задайте рамкой ширину области многострочного текста.
  3. Для развертывания панели "Формат текста" нажмите кнопку "Параметры" » "Показать параметры".
  4. Выберите "Маркеры и списки". Удостоверьтесь, что установлены флажки "Разрешить автоматический список" и "Разрешить маркеры и списки".
  5. В начале текстовой строки введите \U+2022 (строка Unicode для маркера) или выберите символ маркера или другой символ.

    6. В качестве маркеров не могут быть использованы следующие символы: точка (.), двоеточие (:), закрывающая круглая скобка ()), закрывающая угловая скобка (>), закрывающая квадратная скобка (]) и закрывающая фигурная скобка (}).

  6. Нажмите TAB.
  7. Введите текст элемента списка. Нажмите клавишу ENTER для перехода к следующему элементу или используйте сочетание клавиш SHIFT+ENTER для добавления абзаца перед следующим элементом.

    8. Символ маркера автоматически добавляется к следующему элементу.

  8. Дважды нажмите клавишу ENTER для завершения списка.
  9. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Перемещение элемента списка многострочного текста на один уровень вниз - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание списков в многострочном тексте
Понятия
Процедуры
Команды

Перемещение элемента списка многострочного текста на один уровень вниз

  1. Дважды нажмите кнопку мыши на многострочном тексте, чтобы открыть текстовый редактор, используемый в месте редактирования.
  2. Поместите курсор в начале элемента списка и нажмите клавишу TAB.

    3. Элемент перемещается на один уровень вниз и начинает вложенный список.

  3. Нажмите клавишу ENTER для расположения следующего элемента на том же уровне или используйте сочетание клавиш SHIFT + TAB для перемещения элемента на один уровень вверх.
  4. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Разделение существующего списка - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание списков в многострочном тексте
Понятия
Процедуры
Команды

Разделение существующего списка

  1. Дважды нажмите кнопку мыши на многострочном тексте, чтобы открыть текстовый редактор, используемый в месте редактирования.
  2. Выберите последовательность элементов или поместите курсор в начало элемента, где необходимо создать новый список.
  3. Нажмите правую кнопку мыши в редакторе. Выберите "Маркеры и списки" » "Начать заново".

    4. Выбранные элементы перенумеровываются, создавая отдельную последовательность. Если выбрать элементы в середине списка, то невыбранные элементы, расположенные ниже выбранных, также станут частью нового списка.

  4. Для продолжения исходного списка после нового, выберите первый элемент, следующий за новым списком.
  5. Нажмите правую кнопку мыши в редакторе. Выберите "Маркеры и списки" » "Продолжить".

    6. Выбранный и следующие за ним элементы перенумеровываются, продолжая исходный список.

  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Преобразование списков, расположенных в многострочном тексте, в обычный текст - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание списков в многострочном тексте
Понятия
Процедуры
Команды

Преобразование списков, расположенных в многострочном тексте, в обычный текст

  1. Дважды нажмите кнопку мыши на многострочном тексте, чтобы открыть текстовый редактор, используемый в месте редактирования.
  2. Нажмите правую кнопку мыши в редакторе. Выберите "Маркеры и списки". Снимите флажок опции "Разрешить маркеры и списки".

    3. В неформатированных списках сохраняются маркеры, цифры и буквы нумерации. При добавлении элемента в такой список цифровая или буквенная последовательность не изменяется.


Создание списков в многострочном тексте - Команды

Надписи и метки
Надписи и метки
Создание списков в многострочном тексте
Понятия
Процедуры
Команды

Команды
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
Системные переменные
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание отступов и табуляции в многострочном тексте - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Задание отступов и табуляции в многострочном тексте
Понятия
Процедуры
Команды

Можно устанавливать отступ абзацев в объектах многострочного текста (мтекст). Линейка в верхней части редактора, используемого в месте редактирования, отображает позиции табуляции и отступа текущего абзаца.

Отступы и позиции табуляции, установленные до набора текста, относятся ко всему многострочному тексту. Чтобы задать различные отступы и позиции табуляции для разных абзацев, необходимо выбрать один или несколько абзацев, а затем установить необходимые отступы и табуляцию.

Маркеры на линейке показывают отступ от левой границы рамки текста. Верхний маркер служит для задания отступа первой строки, а нижний - остальных строк абзаца.

Длинные деления на линейке отмечают стандартные позиции табуляции. Если задать на линейке устройством указания пользовательские позиции табуляции, на ней появится небольшой L-образный маркер в каждой из таких позиций. Для удаления маркера табуляции следует перетащить его в нулевую позицию линейки.


Создание абзацев с отступом - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Задание отступов и табуляции в многострочном тексте
Понятия
Процедуры
Команды

Создание абзацев с отступом

  1. Дважды нажмите кнопку мыши на многострочном тексте, чтобы открыть текстовый редактор, используемый в месте редактирования.
  2. Выделите абзацы, которые необходимо сместить.
  3. Переместить верхний маркер отступа на линейке туда, где должна начинаться первая строка абзаца.

    4. Примечание На линейке отображаются отступы и позиции табуляции для выделенного абзаца или для абзаца, где установлен курсор. Стандартные позиции табуляции отмечаются длинными делениями линейки. Для задания дополнительных маркеров табуляции нужно задать выбранную позицию горизонтальной линейки устройством указания.

  4. Переместить нижний маркер отступа туда, где должны начинаться остальные строки абзаца.

    5. Таким образом смещаются элементы абзацев длиной более одной строки.

  5. Для изменения величины отступа следует выделить необходимый абзац, установить на линейке позиции табуляции, если они требуются, и переместить маркеры отступов.
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Задание отступов и табуляции в многострочном тексте - Команды

Надписи и метки
Надписи и метки
Задание отступов и табуляции в многострочном тексте
Понятия
Процедуры
Команды

Команды
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
Системные переменные
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание межстрочного интервала многострочного текста - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Задание межстрочного интервала многострочного текста
Понятия
Процедуры
Команды

Межстрочный интервал определяет расстояние между базовыми линиями двух соседних строк текста. Значение межстрочного интервала устанавливается сразу для всего многострочного текстового объекта, а не только для выделенных строк.

Интервал между строками может иметь какое-либо фиксированное численное значение или устанавливаться кратным одинарному интервалу. Одинарный межстрочный интервал равен 1,66 высоты символов.

Используемая по умолчанию опция "Минимум" обеспечивает автоматический подбор межстрочного интервала для тех строк, которые содержат символы разной высоты. Способ задания межстрочного интервала "Точно" удобно использовать при создании таблиц.

Чтобы интервал между строками различных многострочных текстовых объектов имел одинаковое значение, для всех объектов следует использовать опцию "Точно" и одно и то же значение интервала.

Примечание При использовании опции "Точно" для текстов с неоднородной высотой символов наиболее высокие из них могут накладываться на символы соседних строк.


Изменение межстрочного интервала многострочного текстового объекта - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Задание межстрочного интервала многострочного текста
Понятия
Процедуры
Команды

Изменение межстрочного интервала многострочного текстового объекта

  1. Нажмите "Сервис" » "Свойства".

    2. Отображается палитра свойств.

  2. Выберите многострочный текстовый объект, который нужно изменить.
  3. В поле "Стиль межстр. интервала" выберите одну из опций:
    • Минимум. Автоматический подбор интервала на основе размера самого высокого символа строки. Чем выше символы строки, тем больше интервал до соседних строк. Данная опция используется по умолчанию.
    • Точно. Использование одинакового интервала между всеми строками многострочного текстового объекта, независимо от параметров форматирования отдельных фрагментов, например, шрифта и высоты символов.
  4. Измените межстрочный интервал, введя новое значение для любой из следующих опций. Две опции межстрочного интервала предоставляют различные способы задания параметров:
    • Межстрочный интервал. Установка межстрочного интервала, кратного одинарному интервалу. Одинарный межстрочный интервал равен 1,66 высоты символов.
    • Интервал между линиями. Установка межстрочного интервала по абсолютному значению в единицах чертежа. Абсолютные значения можно задавать в интервале от 0,0833 до 1,3333.

Примечание После выхода из палитры свойств другие параметры межстрочных интервалов примут значения, соответствующие введенной пользователем величине.

Панель "Стандартная"

Ввод команды: ОКОНСВ


Задание межстрочного интервала многострочного текста - Команды

Надписи и метки
Надписи и метки
Задание межстрочного интервала многострочного текста
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
TSPACEFAC | Управляет отношением межстрочного интервала к высоте многострочного текста
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание дробей в многострочном тексте - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание дробей в многострочном тексте
Понятия
Процедуры
Команды

Текст, отображающий дробные значения измерений или допусков, может быть отформатирован в разных стандартах.

Дробные тексты представляют собой фрагменты текста одной строки, расположенные на разных уровнях относительно базовой линии строки. С помощью дробных текстов на чертежах записываются такие элементы, как натуральные дроби, предельные отклонения размеров и т.д. Для указания места разбиения дробного текста зарезервированы специальные символы.

  • Косая черта (/): создание текста в виде обыкновенной дроби, числитель и знаменатель которой располагаются друг над другом и разделяются горизонтальной чертой.
  • Решетка (#): создание текста в виде обыкновенной дроби, числитель и знаменатель которой располагаются по диагонали и разделяются косой чертой.
  • Крышка (^): создание дробного текста для пределов, элементы которого располагаются один над другим без разделительной черты.

Можно включить средство автоформатирования дробных текстов, которое преобразует числа, разделенные символами косой черты, решетки или крышки, по мере их ввода. Например, если после 1#3 ввести какой-либо нецифровой символ или пробел, автоматически открывается диалоговое окно "Автоформат дробного текста". В нем пользователь может изменить параметры форматирования дробного текста.

Средство автоформатирования преобразует числа в дробный текст только в том случае, если между цифрами и символом-разделителем (косой чертой, решеткой или крышкой) нет пробелов. Для группировки нецифровых символов или текста с пробелами необходимо выделить текст и нажать кнопку "Дробный" на панели форматирования текста.

См. также

Работа с внешними текстовыми редакторами


Создание дробей в многострочном тексте - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание дробей в многострочном тексте
Понятия
Процедуры
Команды

Создание дробного текста

Изменение свойств дробного текста

Отключение состояния дробности текста


Создание дробного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание дробей в многострочном тексте
Понятия
Процедуры
Команды

Создание дробного текста

  1. Нажмите "Рисование" » "Текст" » "Многострочный".
  2. Задайте рамкой ширину области многострочного текста.
  3. В редакторе, используемом в месте редактирования, задайте стиль текста и настройте требуемые параметры многострочного текста.
  4. Введите текст, который необходимо преобразовать в дробный, отделив фрагменты друг от друга одним из следующих символов-разделителей:
    • Косая черта (/): создание текста в виде обыкновенной дроби, числитель и знаменатель которой располагаются друг над другом и разделяются горизонтальной чертой.
    • Решетка (#): создание текста в виде обыкновенной дроби, числитель и знаменатель которой располагаются по диагонали и разделяются косой чертой.
    • Крышка (^): создание дробного текста для пределов, элементы которого располагаются один над другим без разделительной черты.

    Если после цифр, разделенных упомянутыми выше символами, ввести какой-либо нецифровой символ или пробел, автоматически открывается диалоговое окно "Автоформат дробного текста".

  5. В этом окне можно разрешить автоматическое преобразование чисел в дроби, а также включить автоматическое удаление ведущих пробелов. Кроме того, для чисел, разделенных косой чертой, здесь можно выбрать формат дроби (с горизонтальной или косой разделяющей чертой). Если автоформатирование дробного текста не требуется, нажмите кнопку "Отмена".
  6. Выделите текст, который нужно преобразовать в дробный, и нажмите кнопку "Дробный" на панели инструментов.
  7. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Изменение свойств дробного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание дробей в многострочном тексте
Понятия
Процедуры
Команды

Изменение свойств дробного текста

  1. Дважды нажмите кнопку мыши для выделения многострочного текста, который нужно изменить.
  2. В редакторе, используемом в месте редактирования, выделите дробный текст.
  3. Нажмите правую кнопку мыши в редакторе. Нажмите кнопку "Свойства".
  4. В диалоговом окне "Свойства дробного текста" измените параметры форматирования.
  5. Для задания параметров автоматического форматирования нажмите "Автоформат".
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Отключение состояния дробности текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Создание дробей в многострочном тексте
Понятия
Процедуры
Команды

Отключение состояния дробности текста

  1. Дважды нажмите кнопку мыши на многострочном, который нужно изменить.
  2. В редакторе, используемом в месте редактирования, выделите дробный текст.
  3. Нажмите кнопку "Дробный" на панели форматирования текста.
  4. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Создание дробей в многострочном тексте - Команды

Надписи и метки
Надписи и метки
Создание дробей в многострочном тексте
Понятия
Процедуры
Команды

Команды
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
Системные переменные
TSTACKALIGN | Управляет выравниванием дробного текста по вертикали
TSTACKSIZE | Управляет процентом дробной высоты многострочного текста относительно текущей высоты выбранного текста
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение текстов на выноски - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Нанесение текстов на выноски
Понятия
Процедуры
Команды

Имеется возможность выполнения надписей с одной или несколькими линиями-выносками.

  • Коротко о нанесении надписей на выноски
  • Построение линии-выноски
    Выноска, как правило, состоит из стрелки, линии или кривой и многострочного текстового объекта.
  • Нанесение пояснительной надписи в выноске
    Текст пояснительной надписи для выноски можно вводить либо в командной строке, либо в редакторе, используемом в месте редактирования.


Нанесение текстов на выноски - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Нанесение текстов на выноски
Понятия
Процедуры
Команды

Построение выноски с прямой линией

Построение сплайновой выноски из двух сегментов с текстовой надписью

Построение нескольких выносок, ведущих к одной пояснительной надписи

Создание выноски с помощью редактора, используемого в месте редактирования


Нанесение текстов на выноски - Команды

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Нанесение текстов на выноски
Понятия
Процедуры
Команды
Команды
БВЫНОСКА | Построение простой выноски и надписи для нее
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОРФО | Орфографическая проверка надписей в чертеже
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
РЗМСТИЛЬ | Создание и модификация размерных стилей
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
ТЕКСТ | Создание однострочных текстовых объектов
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
DIMASZ | Управление величинами стрелок размерных линий и линий выноски
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMLDRBLK | Задает тип стрелки для выносок
DIMSCALE | Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
FONTALT | Указывает альтернативный шрифт, используемый в случае, если не найден указанный шрифт
FONTMAP | Указывает файл, описывающий подстановку шрифтов
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
QTEXTMODE | Управляет отображением текста
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о нанесении надписей на выноски - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о нанесении надписей на выноски
Понятия
Процедуры
Команды

Выноской называется отрезок или сплайн, на одном конце которого размещается стрелка, а на другом пояснительная надпись в виде многострочного текста. Иногда между выноской и текстом или рамкой допуска формы и расположения ставится короткий горизонтальный отрезок - так называемая полка.

Объект выноски связан с многострочным текстом таким образом, что при перемещении, повороте или масштабировании текста происходит соответствующее изменение линии выноски.

Выноска связывается с любым объектом, к которому прикреплена ее стрелка, если используются ассоциативные размеры и включена объектная привязка для позиционирования стрелок выносок. При изменении положения объекта стрелка следует за ним, растягивая, таким образом, выносную линию.

Текст, содержащийся в чертеже, можно копировать и связывать с объектом выноски.

См. также

Изменение текста с выноской


Нанесение текстов на выноски

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Нанесение текстов на выноски
Понятия
Процедуры
Команды

Нет процедур.


Коротко о нанесении надписей на выноски - Команды

Надписи и метки
Надписи и метки
Коротко о нанесении надписей на выноски
Понятия
Процедуры
Команды

Команды
БВЫНОСКА | Построение простой выноски и надписи для нее
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMLDRBLK | Задает тип стрелки для выносок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение линии-выноски - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Построение линии-выноски
Понятия
Процедуры
Команды

Выноска, как правило, состоит из стрелки, линии или кривой и многострочного текстового объекта.

Пользователь может построить выноску из любой точки или объекта чертежа, управляя ее внешним видом. Выноски могут иметь вид ломаных линий или гладких сплайновых кривых. Цвет выносок определяется текущим цветом размерных линий. Масштаб выносок задается соответствующим свойством текущего размерного стиля. Этим же стилем определяется тип и размер стрелки, если она присутствует.

Команда ВЫНОСКА создает сложные линии выноски, которые могут состоять из нескольких (более двух) линейных сегментов. РЗМДИАМЕТР и РЗМРАДИУС используются для создания простых автоматических выносок, состоящих из двух линейных сегментов, для кругов и дуг.

Ассоциирование выносок с объектами

При использовании ассоциированных размеров (переменная DIMASSOC) в режиме объектной привязки стрелка выноски связывается с объектом, на который она указывает. При изменении положения объекта стрелка также перемещается вместе с ним, а линия-выноска растягивается так, чтобы многострочный текст пояснительной надписи оставался на своем месте.


Построение линии-выноски - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Построение линии-выноски
Понятия
Процедуры
Команды

Построение выноски с прямой линией

Построение сплайновой выноски из двух сегментов с текстовой надписью

Построение нескольких выносок, ведущих к одной пояснительной надписи


Построение выноски с прямой линией - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Построение линии-выноски
Понятия
Процедуры
Команды

Построение выноски с прямой линией

  1. Нажмите "Размеры" » "Выноска".
  2. Нажмите ENTER для вызова диалогового окна "Параметры выноски" и выполните следующие действия:
    • На вкладке "Выноска и стрелка" выберите "Прямая". В группе "Количество точек" выберите "Не ограничено".
    • На вкладке "Пояснение" выберите "МТекст".
    • Нажмите "ОК".
  3. Укажите начальную и последующие точки линии-выноски.
  4. Нажмите ENTER для завершения указания точек излома линии выноски.
  5. Укажите ширину текста.
  6. Введите строку текста. Если необходимо, нажмите ENTER для перехода на следующую строку текста.
  7. Для завершения команды нажмите ENTER дважды.

    8. После выполнения команды БВЫНОСКА около конечной точки линии создается многострочный текстовый объект.

Панель "Размеры"

Ввод команды: БВЫНОСКА


Построение сплайновой выноски из двух сегментов с текстовой надписью - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Построение линии-выноски
Понятия
Процедуры
Команды

Построение сплайновой выноски из двух сегментов с текстовой надписью

  1. Нажмите "Размеры" » "Выноска".
  2. Нажмите ENTER для вызова диалогового окна "Параметры выноски" и выполнить следующие действия:
    • На вкладке "Пояснение" выберите "МТекст".
    • На вкладке "Выноска и стрелка" выберите "Сплайновая". В группе "Количество точек" в поле "Максимум" введите 3. При необходимости опустите флажок опции "Не ограничено".
  3. Нажмите "ОК".
  4. Укажите первую, вторую и третью (не обязательную) точки линии-выноски.
  5. Задайте ширину текста.
  6. Введите первую строку текста. Для ввода следующей строки нажмите ENTER один раз.
  7. Для завершения команды нажмите ENTER дважды.

Панель "Размеры"

Ввод команды: БВЫНОСКА


Построение нескольких выносок, ведущих к одной пояснительной надписи - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Построение линии-выноски
Понятия
Процедуры
Команды

Построение нескольких выносок, ведущих к одной пояснительной надписи

  1. Выберите выноску, а затем выберите ручку стрелки выноски.
  2. В командной строке введите с (copy - копировать).
  3. Укажите конечные точки для нескольких выносок и нажмите ENTER.
  4. Для перемещения конца новой выноски к полке уберите все ручки нажатием ESC, выберите новую выноску, затем выберите ручку выноски и переместите ее к полке.

Панель "Размеры"

Ввод команды: БВЫНОСКА


Построение линии-выноски - Команды

Надписи и метки
Надписи и метки
Построение линии-выноски
Понятия
Процедуры
Команды

Команды
БВЫНОСКА | Построение простой выноски и надписи для нее
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
DIMASZ | Управление величинами стрелок размерных линий и линий выноски
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMLDRBLK | Задает тип стрелки для выносок
DIMSCALE | Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение пояснительной надписи в выноске - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Нанесение пояснительной надписи в выноске
Понятия
Процедуры
Команды

Пояснительные надписи для выносок можно создавать двумя способами. Можно вводить текст в командной строке или создавать целые абзацы в редакторе, используемом в месте редактирования. Для многострочного текста можно применять неоднородное форматирование. Для выноски можно скопировать уже имеющийся в чертеже текст.

Надпись автоматически размещается на заданном расстоянии от конца выноски. Это расстояние устанавливается в Диспетчере размерных стилей на вкладке "Текст" в группе опций "Выравнивание текста". Рамки допусков формы и расположения также автоматически проставляются на конце выноски. Элементы выноски, образуя единый блок, вставляются в указанной позиции с применением заданного масштаба и угла поворота.

Для вертикального выравнивания надписи относительно выноски используется опция "По вертикали" в группе "Выравнивание текста" на вкладке "Текст" Диспетчера размерных стилей. На следующей иллюстрации показан режим вертикального выравнивания "Над линией".

Если системной переменной DIMGAP присвоить отрицательное значение, то вокруг надписи выводится рамка. Поля между рамкой и текстом определяются абсолютным значением переменной DIMGAP.


Создание выноски с помощью редактора, используемого в месте редактирования - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Нанесение пояснительной надписи в выноске
Понятия
Процедуры
Команды

Создание выноски с помощью редактора, используемого в месте редактирования

  1. Нажмите "Размеры" » "Выноска".
  2. Укажите начальную и последующие точки выноски.
  3. Нажмите ENTER для завершения определения точек линии выноски.
  4. Укажите ширину текста.
  5. В ответ на запрос "Первая строка текста пояснения" нажмите ENTER.
  6. Введите и отформатируйте текст в Редакторе, используемом в месте редактирования.
  7. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

    Пояснительная надпись наносится с отступом от конца выноски, заданным в Диспетчере размерных стилей (команда РЗМСТИЛЬ).

Панель "Размеры"

Ввод команды: БВЫНОСКА


Нанесение пояснительной надписи в выноске - Команды

Надписи и метки
Надписи и метки
Нанесение пояснительной надписи в выноске
Понятия
Процедуры
Команды

Команды
БВЫНОСКА | Построение простой выноски и надписи для нее
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОРФО | Орфографическая проверка надписей в чертеже
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
РЗМСТИЛЬ | Создание и модификация размерных стилей
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
ТЕКСТ | Создание однострочных текстовых объектов
Системные переменные
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
FONTALT | Указывает альтернативный шрифт, используемый в случае, если не найден указанный шрифт
FONTMAP | Указывает файл, описывающий подстановку шрифтов
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
QTEXTMODE | Управляет отображением текста
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Импорт текстовых файлов - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Импорт текстовых файлов
Понятия
Процедуры
Команды

Имеется возможность вставки текста в чертеж из файлов формата TXT и RTF, созданных в текстовых редакторах, путем импорта или перетаскивания значка файла из окна Проводника Windows.

Импорт TXT- и RTF-файлов дает определенную гибкость. Например, в текстовом файле можно хранить стандартные примечания к чертежам. Импортированный текст становится многострочным текстовым объектом, который можно отредактировать и переформатировать. При импорте обычного TXT-файла применяется текущий текстовый стиль. При импорте RTF-файла применяются параметры текущего текстового стиля, однако исходные шрифты и элементы форматирования импортируемого текста сохраняются. Импортируемые файлы ограничены размером 32 Кб и должны иметь расширение .txt или .rtf.

При перетаскивании текстового файла в чертеж ширина текстовой рамки определяется символами конца строки или перехода на новую строку исходного документа. Текст перетаскиваемого RTF-файла вставляется в качестве OLE-объекта.

При вставке текста, созданного в другом приложении, из буфера обмена создается OLE-объект. Если текст импортируется из другого файла с помощью буфера обмена, текст вставляется как вхождение блока с сохранением исходного стиля.

См. также

Импорт OLE-объектов


Импорт текстовых файлов - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Импорт текстовых файлов
Понятия
Процедуры
Команды

Импорт текстовых файлов

Вставка текстового файла перетаскиванием


Импорт текстовых файлов - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Импорт текстовых файлов
Понятия
Процедуры
Команды

Импорт текстовых файлов

  1. Нажмите "Рисование" » "Текст" » "Многострочный".
  2. Задайте рамкой ширину области многострочного текста.
  3. Нажмите правую кнопку мыши в редакторе. Выберите "Импортировать текст".

    4. Размер импортируемых файлов ограничен 32 Кб.

  4. В диалоговом окне "Выбор файла" дважды нажмите на имени импортируемого файла или выделите файл. Нажмите кнопку "Открыть".

    5. Текст вставляется в текущей позиции курсора.

  5. Отредактируйте текст, если это необходимо.
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

Панель "Рисование"

Ввод команды: МТЕКСТ


Вставка текстового файла перетаскиванием - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Импорт текстовых файлов
Понятия
Процедуры
Команды

Вставка текстового файла перетаскиванием

  1. Откройте Проводник Windows в неполноэкранном режиме.
  2. Перейдите в папку, содержащую требуемый TXT- или RTF-файл.
  3. Перетащите значок текстового файла формата TXT или RTF в чертеж. TXT-файлы вставляются как многострочные текстовые объекты с применением текущего текстового стиля. RTF-файлы вставляются как OLE-объекты.


Импорт текстовых файлов - Команды

Надписи и метки
Надписи и метки
Импорт текстовых файлов
Понятия
Процедуры
Команды

Команды
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование полей в тексте - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Использование полей в тексте
Понятия
Процедуры
Команды

Поле представляет собой обновляемый текст, предназначенный для отображения данных, которые могут поменяться в ходе редактирования чертежа. При обновлении поля отображается его последнее значение.

  • Вставка полей
    Поле представляет собой текст, содержащий правила отображения данных, которые могут поменяться в ходе редактирования чертежа.
  • Обновление полей
    При обновлении поля отображается его последнее значение. Пользователь может обновить поля по одному или обновить все поля в одном или нескольких выбранных текстовых объектах.
  • Использование гиперссылок в полях
    В тексте можно использовать поля гиперссылок.


Использование полей в тексте - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Использование полей в тексте
Понятия
Процедуры
Команды

Вставка поля в текст

Вставка поля в таблицу

Использование поля для отображения свойства объекта

Вставка поля заменителя подшивки

Форматирование значения поля

Редактирование поля

Ручное обновление поля

Обновление вручную нескольких полей

Автоматическое обновление полей

Добавление в текст поля гиперссылки


Использование полей в тексте - Команды

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Использование полей в тексте
Понятия
Процедуры
Команды
Команды
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАЙТИ | Поиск, замена , выбор и показ текста на чертеже
ОБНПОЛЕ | Позволяет обновлять поля в выбранных объектах чертежа вручную
ОРФО | Орфографическая проверка надписей в чертеже
ПОЛЕ | Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
ТАБЛИЦА | Создание пустой таблицы объектов в чертеже
ТАБЛСТИЛЬ | Создание нового стиля таблиц
ЭКСПОРТТАБЛ | Экспорт данных таблицы в файл формата CSV
Системные переменные
CTABLESTYLE | Установка имени текущего стиля таблицы.
FIELDDISPLAY | Управляет отображением полей на сером фоне
FIELDEVAL | Управляет обновлением полей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вставка полей - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Вставка полей
Понятия
Процедуры
Команды

Поле представляет собой текст, содержащий правила отображения данных, которые могут поменяться в ходе редактирования чертежа.

При обновлении поля отображаются самые новые данные. Например, значением поля "ИмяФайла" является имя файла. Если имя файла изменяется, то при обновлении данного поля отобразится новое имя файла.

Поля могут быть вставлены в текст любого типа (за исключением допусков), включая текст в ячейках таблицы, в атрибутах и описаниях атрибутов. В ходе выполнения любой текстовой команды в контекстном меню появляется опция "Вставить поле".

Некоторые поля подшивок могут быть вставлены как заменители. Например, пользователь может вставить поле "НомерИНазваниеЛиста" в качестве заменителя. Позднее, после добавления листа в подшивку, поле заменителя будет отображать правильный номер и название листа.

Поля местозаменителя блока можно использовать в описаниях атрибутов блока во время работы в Редактор блоков.

Поле, для которого нет значений, будет отображать черточки (---). Например, поле "Автор", устанавливаемое в диалоговом окне "Свойства чертежа", может быть оставлено пустым. Неверное поле будет отображать знаки решеток (####). Например, поле "НазваниеТекущегоЛиста", допустимое только для пространства листа, будет отображать знаки решетки, если его расположить в пространстве модели.

Изменение внешнего вида поля

Текст поля использует тот же текстовый стиль, что и текстовый объект, в который он вставлен. По умолчанию поля отображают информацию на светло-сером фоне, который не выводится на печать (системная переменная FIELDDISPLAY).

Настройки форматирования в диалоговом окне "Поле" позволяют контролировать вид отображаемого текста. Набор настроек зависит от типа поля. Например, формат полей дат включает опции по отображению дня недели и времени, а формат полей именованных объектов включает опции выделения заглавными буквами.

Редактирование поля

Поле является частью тестового объекта и не может редактироваться в текстовом редакторе. Самый простой способ редактирования поля состоит в следующем. Нужно дважды нажать кнопку мыши на текстовом объекте, содержащем поле, затем, для отображения диалогового окна "Поле", нужно дважды нажать кнопку мыши на поле. Эти операции можно выполнять также в контекстных меню.

Если необходимо, чтобы поле больше не обновлялось, то пользователь может сохранить значение, которое отображается в настоящий момент, преобразовав поле в текст.

Выражение поля, содержащее знаки переключения кода и код поля, показывается в диалоговом окне "Поле", но не может быть изменено.


Вставка полей - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Вставка полей
Понятия
Процедуры
Команды

Вставка поля в текст

Вставка поля в таблицу

Использование поля для отображения свойства объекта

Вставка поля заменителя подшивки

Форматирование значения поля

Редактирование поля


Вставка поля в текст - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Вставка полей
Понятия
Процедуры
Команды

Вставка поля в текст

  1. Укажите текст, дважды нажав кнопку мыши для отображения соответствующего диалогового окна редактирования текста.
  2. Поместите курсор в то место, где должен располагаться текст поля, и нажмите правую кнопку мыши. Выберите "Вставить поле".

    3. Для вызова этой команды с клавиатуры используйте сочетание клавиш CTRL+ F.

  3. В диалоговом окне "Поле" в группе "Категории полей" выберите "Все" или категорию поля.

    4. Поля в выбранной категории будут отображены в списке "Имена полей".

  4. В списке "Имена полей" выберите поле.

    5. Текущее значение большинства полей будет отображено в затененной текстовой области справа от группы "Категории полей". Текущее значение поля даты отображается в списке "Варианты".

  5. Выберите формат и задать остальные настройки.

    6. Например, когда выбрано поле "ИменованныйОбъект", пользователь задает тип (например, слой или текстовые стили) и имя (например "0" для слоя или "STANDARD" для текстового стиля).

    В поле "Формула для поля" задается выражение, лежащее в основе поля. Формулу для поля нельзя изменить. Она только дает представление о том, как сформированы поля.

  6. Нажмите "ОК" для вставки поля.

    7. Поле отобразит свое текущее значение в тексте после выходе из диалогового окна "Поле".


Вставка поля в таблицу - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Вставка полей
Понятия
Процедуры
Команды

Вставка поля в таблицу

  1. Дважды нажмите кнопку мыши на выбранной ячейке таблицы для редактирования.
  2. Поместите курсор в то место, где должен располагаться текст поля, и нажмите правую кнопку мыши. Выберите "Вставить поле".
  3. В диалоговом окне "Поле" выберите опцию "Все" или выделить категорию.
  4. В списке "Имена полей" выберите поле.

    5. Текущее значение поля будет отображено в затененной текстовой области справа от группы "Категории полей".

  5. Выберите формат и любую другую опцию.
  6. Нажмите "ОК" для вставки поля.

    7. Поле отобразит свое текущее значение при переходе к следующей ячейке.


Использование поля для отображения свойства объекта - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Вставка полей
Понятия
Процедуры
Команды

Использование поля для отображения свойства объекта

  1. Дважды нажмите кнопку мыши на тексте для вызова соответствующего диалогового окна редактирования текста.
  2. Поместите курсор в то место, где должен располагаться текст поля, и нажмите правую кнопку мыши. Выберите "Вставить поле".
  3. В диалоговом окне "Поле" в группе "Категории полей" выберите "Все".
  4. В списке "Имена полей" выберите "Объект".
  5. В группе "Тип объекта" нажмите кнопку "Выберите объект" и выберите объект на чертеже.
  6. В диалоговом окне "Поле" в группе "Свойства" выберите свойство, значение которого необходимо отобразить в тексте.

    7. Например, поле может отображать радиус выбранного круга.

  7. Выберите формат текста.
  8. Нажмите "ОК".

    9. В тексте отобразится текущее значение свойства данного объекта.


Вставка поля заменителя подшивки - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Вставка полей
Понятия
Процедуры
Команды

Вставка поля заменителя подшивки

  1. В меню "Рисование" нажмите "Блок" » "Задание атрибутов...".
  2. В диалоговом окне "Описание атрибута", в группе "Режим" выберите "Стандартный". Задайте параметры текста.
  3. В поле "Имя" в группе "Атрибут" введите имя поля.
  4. Нажмите кнопку "Вставить поле", расположенную справа от поля "Значение".
  5. В диалоговом окне "Поле" в группе "Категории полей" выберите "Подшивка".
  6. В списке "Имена полей" выберите "ПодшЗаменитель".
  7. В группе "Тип заменителя" выберите необходимый тип поля.

    8. В блоке "Временное значение" будет показано поле заменителя.

  8. В группе "Формат" для поля-заменителя выберите стиль "Верхний регистр".

    9. При обновлении поля этот же стиль будет использоваться для значения поля.

  9. (Не обязательно) Установите флажок "С гиперссылками", если необходимо, чтобы поле служило гиперссылкой.

    10. Примечание Опция "С гиперссылками" недоступна для поля "МасштабВЭкрана".

  10. Нажмите "OK", чтобы выйти из диалогового окна "Поле".

    11. Поле заменителя отображает свое имя после закрытия диалогового окна "Поле", например "НомерЛиста". Когда блок будет вставлен из контекстного меню вкладки "Список видов" в Диспетчере подшивок, поле отобразит значение, связанное с листом, в который оно было вставлено, например номер этого листа.

  11. Нажмите "OK" в диалоговом окне "Описание атрибута". Определите место около созданного объекта для вставки текста поля, которое будет использоваться Диспетчером подшивок как блок-идентификатор или блок метки.
  12. Создайте блок, в который наряду с геометрией для блока входит новый атрибут.


Форматирование значения поля - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Вставка полей
Понятия
Процедуры
Команды

Форматирование значения поля

  1. Дважды нажмите кнопку мыши на тексте для вызова соответствующего диалогового окна редактирования текста.
  2. Дважды нажмите на поле, которое необходимо отформатировать.

    3. Открывается диалоговое окно "Поле". Если форматирование этого поля возможно, отображается кнопка "Формат поля".

  3. Нажмите "Формат поля".

    4. В диалоговом окне "Дополнительные параметры формата" отображается текущее значение поля. Когда параметр выбран, результат отображается в области "Предварительный просмотр".

  4. Введите коэффициент преобразования, который необходимо использовать для текущего значения.

    5. Например, для преобразования дюймов в миллиметры введите 0.03937.

  5. Введите текст, который необходимо поместить до или после значения, указанного в поле.

    6. Например, введите мм для миллиметров.

  6. Выберите десятичный разделитель. Выберите "Ничего" или "Запятая" для тысяч.
  7. Выберите параметр для подавления нулей.
    • Ведущие: подавление ведущих нулей в десятичных значениях. Например, 0,5000 записывается как ,5000.
    • Замыкающие: подавление замыкающих нулей в десятичных значениях. Например, 12,5000 представляется как 12,5, а 30,0000 - как 30.
    • 0 футов: подавление вывода значения футов в поле формата футы-дюймы, если расстояние меньше одного фута. Например, 0'-6 1/2" представляется как 6 1/2".
    • 0 дюймов: подавление вывода значения дюймов в поле формата футы-дюймы, если расстояние равно целому числу футов. Например, 1'-0" представляется как 1'.
  8. Нажмите "ОК".

    9. В диалоговом окне "Поле" значение поля отображается в области "Предварительный просмотр" в формате, определенном пользователем.

  9. Нажмите "ОК".


Редактирование поля - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Вставка полей
Понятия
Процедуры
Команды

Редактирование поля

  1. Дважды нажмите кнопку мыши на тексте для вызова соответствующего диалогового окна редактирования текста.
  2. Дважды нажмите кнопку мыши на поле, которое нужно отредактировать.

    3. Открывается диалоговое окно "Поле".

  3. Внести необходимые изменения.
  4. Нажмите "OK", чтобы выйти из диалогового окна "Поле".
  5. Выйдите из текстового редактора.


Вставка полей - Команды

Надписи и метки
Надписи и метки
Вставка полей
Понятия
Процедуры
Команды

Команды
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАЙТИ | Поиск, замена , выбор и показ текста на чертеже
ОБНПОЛЕ | Позволяет обновлять поля в выбранных объектах чертежа вручную
ОРФО | Орфографическая проверка надписей в чертеже
ПОЛЕ | Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
ТАБЛИЦА | Создание пустой таблицы объектов в чертеже
ТАБЛСТИЛЬ | Создание нового стиля таблиц
ЭКСПОРТТАБЛ | Экспорт данных таблицы в файл формата CSV
Системные переменные
CTABLESTYLE | Установка имени текущего стиля таблицы.
FIELDDISPLAY | Управляет отображением полей на сером фоне
FIELDEVAL | Управляет обновлением полей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обновление полей - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Обновление полей
Понятия
Процедуры
Команды

Пользователь может также установить автоматическое обновление полей при открытии, сохранении, печати, регенерации чертежа или его отправки с помощью команды ФОРМКОМПЛЕКТ.

Настройки в Вкладка "Пользовательские" (диалоговое окно "Настройка") определяют режим обновления полей: автоматический или по запросу (системная переменная FIELDEVAL). Поле "Дата", вне зависимости от значения переменной FIELDEVAL, автоматически не обновляется.

Примечание При присвоении системной переменной DEMANDLOAD значения 2, невозможно будет обновить поля до тех пор, пока не будут использованы команды ПОЛЕ или ОБНПОЛЕ.

Контекстно-зависимые поля в блоках и внешних ссылках

Некоторые поля являются контекстно-зависимыми; т.е. их значение зависит от пространства или вкладки-листа, на котором они расположены. Например, поскольку каждая разметка листа может иметь различные параметры листа, то значение, отображаемое полем "ОриентацияЛиста", может различаться на различных разметках листа одного и того же чертежа.

Список контекстно-зависимых полей
ТекЛистПольз | НазваниеТекущегоЛиста
ПояснениеТекЛист | ИмяУстройства
НомерТекущегоЛиста | ФорматЛиста
НомерИНазваниеЛиста | ДатаВывода
ТекущаяПодшивка | ОриентацияЛиста
ТекПодшПольз | МасштабПечати
ПояснениеТекПодш | ИмяНабораПараметров
ТекущаяГруппаЛистов | ТаблицаСтилейПечати

Для совместимости с предыдущими версиями контекстно-зависимые поля в блоках и внешних ссылках не обновляются при вставке их в чертеж; вместо этого поля отображают последнее кэшированное значение. Поэтому, если необходимо использовать контекстно-зависимое поле внутри блока, например блока основной надписи, то надо вставить поле как атрибут. Например, блок основной надписи может использовать поле "НомерТекущегоЛиста" как атрибут. Тогда при вставке основной надписи в чертеж поле отобразит номер листа, на который была произведена вставка.

Большинство полей не являются контекстно-зависимыми и обновляются в блоках и внешних ссылках. Поля во внешних ссылках обновляются на основе файла, в который они вставлены, а не исходного файла. Эти поля не следует использовать в атрибутах. Например, поле, отображающее номер конкретного листа в подшивке и обновляющееся при изменении данного номера, является свойством подшивки. При создании поля пользователь выделяет имя поля "Подшивка", выбирает подшивку и лист в области структуры, а затем выбирает свойство "НомерЛиста" в качестве значения поля. Это поле будет отображать номер данного листа, даже если данное поле поместить в блок и вставить в другой чертеж. Если лист удалить из подшивки, то он уже не будет иметь номер, а поле станет недействительным и будет отображать знаки решетки.

Некоторые поля подшивок могут быть вставлены как заменители. Например, при создании собственных блоков-идентификаторов и блоков марок, пользователь может вставить поле "НомерЛиста" в качестве заменителя. Позже, когда блок будет вставлен из контекстного меню вкладки "Список видов" в Диспетчере подшивок, поле отобразит номер листа чертежа.

Совместимость с AutoCAD LT и предыдущими версиями AutoCAD

При открытии чертежа с полями в AutoCAD 2004 или более ранней версии, поля не обновляются; они отображают последнее показанное перед открытием в этих программах значение поля. Если поля не были изменены, то они обновляются как обычно при открытии чертежа в системе, поддерживающей поля.

AutoCAD LT не поддерживает поля. При открытии чертежа с полями в AutoCAD LT поля вычисляются на основе значения системной переменной FIELDEVAL в чертеже, при этом сама системная переменная FIELDEVAL недоступна.

См. также

Работа с чертежами AutoCAD в AutoCAD LT


Обновление полей - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Обновление полей
Понятия
Процедуры
Команды

Ручное обновление поля

Обновление вручную нескольких полей

Автоматическое обновление полей


Ручное обновление поля - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Обновление полей
Понятия
Процедуры
Команды

Ручное обновление поля

  1. Дважды нажмите кнопку мыши на тексте.
  2. Выберите поле, которое необходимо обновить, и нажмите правую кнопку мыши. Выберите "Обновить поле".


Обновление вручную нескольких полей - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Обновление полей
Понятия
Процедуры
Команды

Обновление вручную нескольких полей

  1. Введите в командной строке обнполе.
  2. В ответ на подсказку "Выберите объекты" выберите объекты, содержащие поля, которые требуется обновить, и нажмите ENTER.

    3. Все поля в выделенных объектах обновятся.


Автоматическое обновление полей - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Обновление полей
Понятия
Процедуры
Команды

Автоматическое обновление полей

  1. В командной строке введите fieldeval.
  2. Введите код, являющийся суммой любых из следующих значений:
    • 0: не обновляются
    • 1: обновляются при открытии
    • 2: обновляются при сохранении
    • 4: обновляются при печати
    • 8: обновляются при вызове команды ФОРМКОМПЛЕКТ
    • 16: обновляются при регенерации

    Например, для обновления полей только при открытии, сохранении или печати файла необходимо ввести 7.


Обновление полей - Команды

Надписи и метки
Надписи и метки
Обновление полей
Понятия
Процедуры
Команды

Команды
ОБНПОЛЕ | Позволяет обновлять поля в выбранных объектах чертежа вручную
ПОЛЕ | Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения
Системные переменные
FIELDDISPLAY | Управляет отображением полей на сером фоне
FIELDEVAL | Управляет обновлением полей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование гиперссылок в полях - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Использование гиперссылок в полях
Понятия
Процедуры
Команды

Текстовые гиперссылки работают таким же образом, что и гиперссылки, связанные с объектами. При наведении курсора на текст отображается курсор гиперссылки, а также соответствующая подсказка. Для перехода по гиперссылке надо, нажав клавишу CTRL, указать гиперссылку.

Примечание Поле гиперссылки использует абсолютный путь к файлу; команда ГИПЕРССЫЛКА может создать гиперссылку с относительным путем.

Полям, указывающим на названия и номера листов и видов, при создании могут быть назначены гиперссылки. При изменении этих элементов или перемещении в Диспетчере подшивок, гиперссылки, связанные с ними, также изменяются, указывая на новое положение.

При публикации в формат многолистового DWF-файла гиперссылки в полях преобразуются из связей с DWG-файлами в связи с DWF-файлами.


Добавление в текст поля гиперссылки - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Использование гиперссылок в полях
Понятия
Процедуры
Команды

Добавление в текст поля гиперссылки

  1. Нажмите "Рисование" » "Текст" » "Многострочный".
  2. Расположите курсор в месте, где должен отображаться текст с гиперссылкой.
  3. Нажмите правую кнопку мыши в редакторе. Выберите "Вставить поле".
  4. В диалоговом окне "Поле" в группе "Категории полей" выберите "Связи".
  5. В группе "Имена полей" выберите "Гиперссылка" и укажите гиперссылку.
  6. В диалоговом окне "Вставка гиперссылки" для задания расположения можно использовать один из следующих способов:
    • В поле "Ввод имени файла или Web-страницы" ввести имя файла (вместе с путем), на который должен производиться переход.
    • В группе "Что искать:" нажать на кнопки "Файл", "Web-страница" или "Позиция". Выбрать местоположение, для которого необходимо создать гиперссылку. Нажать "Открыть" или "OK".
  7. (Не обязательно) В поле "Отображаемый текст" выделить текст, предлагаемый по умолчанию, и ввести текст ссылки, который должен отображаться в многострочном текстовом объекте.
  8. Нажать "OK" для закрытия каждого диалогового окна.
  9. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

    Гиперссылка будет отображаться в многострочном текстовом объекте вместе с текстом, который был введен пользователем. Для перехода по гиперссылке указать ее, удерживая нажатой клавишу CTRL.

Панель "Рисование"

Ввод команды: МТЕКСТ


Использование гиперссылок в полях - Команды

Надписи и метки
Надписи и метки
Использование гиперссылок в полях
Понятия
Процедуры
Команды

Команды
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАЙТИ | Поиск, замена , выбор и показ текста на чертеже
ОБНПОЛЕ | Позволяет обновлять поля в выбранных объектах чертежа вручную
ОРФО | Орфографическая проверка надписей в чертеже
ПОЛЕ | Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
ТАБЛИЦА | Создание пустой таблицы объектов в чертеже
ТАБЛСТИЛЬ | Создание нового стиля таблиц
ЭКСПОРТТАБЛ | Экспорт данных таблицы в файл формата CSV
Системные переменные
CTABLESTYLE | Установка имени текущего стиля таблицы.
FIELDDISPLAY | Управляет отображением полей на сером фоне
FIELDEVAL | Управляет обновлением полей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с текстовыми стилями - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Работа с текстовыми стилями
Понятия
Процедуры
Команды

При выполнении надписей на чертеже применяется текущий текстовый стиль, который определяет шрифт, высоту и угол наклона символов, ориентацию надписи, а также другие параметры текста.

  • Коротко о текстовых стилях
  • Назначение шрифтов
    При создании описания текстового стиля пользователь задает для него шрифт. При этом выбор того или иного шрифта зависит от типа вводимого текста.
  • Задание высоты символов
    Высота символов задается в единицах чертежа.
  • Задание угла наклона символов
    Угол наклона определяет наклон символов надписи вправо или влево.
  • Задание горизонтальной или вертикальной ориентации текста
    Выполняемые надписи могут быть ориентированы как горизонтально, так и вертикально. Но вертикальную ориентацию можно использовать только для шрифтов, поддерживающих оба типа ориентации.


Работа с текстовыми стилями - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Работа с текстовыми стилями
Понятия
Процедуры
Команды

Установка текущего текстового стиля

Назначение шрифта текстовому стилю

Назначение SHX-шрифта азиатского языка текстовому стилю

Определение файла соответствия шрифтов

Задание альтернативного шрифта по умолчанию

Задание высоты в текстовом стиле

Задание угла наклона символов в текстовом стиле

Задание вертикальной ориентации в текстовом стиле


Работа с текстовыми стилями - Команды

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Работа с текстовыми стилями
Понятия
Процедуры
Команды
Команды
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
Системные переменные
FONTALT | Указывает альтернативный шрифт, используемый в случае, если не найден указанный шрифт
FONTMAP | Указывает файл, описывающий подстановку шрифтов
QTEXTMODE | Управляет отображением текста
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
TEXTSIZE | Устанавливает высоту по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля
TEXTSTYLE | Задает имя текущего текстового стиля
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о текстовых стилях - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о текстовых стилях
Понятия
Процедуры
Команды

У каждого фрагмента текста на чертеже свой текстовый стиль. При вводе текста применяется текущий текстовый стиль, который определяет шрифт, размер и угол наклона символов, ориентацию, а также другие параметры текста. При необходимости выполнить надпись определенным текстовым стилем его следует сделать текущим. Ниже приведен пример таблицы со значениями параметров текстового стиля СТАНДАРТ.

Параметры текстового стиля
Параметр | По умолчанию | Описание
Имя стиля | СТАНДАРТ | Имя может содержать до 255 символов
Имя шрифта | txt.shx | Имя файла шрифта, задающего начертание литер
Большой шрифт | Нет | Имя файла, используемого для задания наборов символов, не входящих в формат ASCII (японский алфавит и т.п.)
Высота | 0 | Высота символов
Коэффициент сжатия | 1 | Коэффициент растяжения или сжатия символов
Угол наклона | 0 | Величина наклона символов
Справа налево | Нет | Написание текста справа налево
Перевернутый | Нет | Написание текста в перевернутом виде
Вертикальный | Нет | Вертикальное или горизонтальное расположение текста

Значения параметров текущего текстового стиля отображаются в запросах командной строки. Имеется возможность использования и редактирования текущего текстового стиля, а также создания или загрузки нового. Созданный стиль может быть впоследствии модифицирован, переименован или удален.

Создание и редактирование текстовых стилей

Все текстовые стили, кроме заранее определенного стиля СТАНДАРТ, пользователю необходимо создавать самому.

Длина имен стилей ограничена 255 символами. В именах можно использовать буквы и цифры, а также некоторые специальные знаки: знак доллара ($), подчеркивание (_) и дефис (-). Если пользователь не присваивает имена стилям, то им автоматически присваиваются имена "Стильn", где n - любое целое число, начиная с 1.

Имеется возможность изменять параметры существующих текстовых стилей с помощью диалогового окна "Текстовые стили". Можно также выполнять обновление существующего текста для измененного текстового стиля.

Влияние некоторых параметров стиля на многострочный и однострочный тексты различно. Например, параметры "Перевернутый" и "Справа налево" не оказывают никакого действия на многострочные текстовые объекты. А параметры "Коэффициент сжатия" и "Угол наклона", наоборот, бесполезны для однострочного текста.

После переименования существующего текстового стиля во всех текстовых объектах, использующих его, имя стиля обновляется.

Неиспользуемые текстовые стили можно удалять командой ОЧИСТИТЬ или удалением их имен из списка в диалоговом окне "Текстовые стили". Текстовый стиль СТАНДАРТ удалить нельзя.

Изменение текстового стиля

Изменение параметров текстового стиля для многострочного текстового объекта приводит к обновлению всего объекта. При этом некоторые ранее заданные элементы форматирования отдельных фрагментов текста могут быть потеряны. В следующей таблице приводятся элементы форматирования текстовых фрагментов и указана возможность их сохранения при обновлении объекта после изменения текстового стиля.

Элемент форматирования | Сохраняется?
Полужирный | Нет
Цвет | Да
Шрифт | Нет
Высота | Нет
Курсив | Нет
Дроби | Да
Подчеркивание | Да


Установка текущего текстового стиля - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о текстовых стилях
Понятия
Процедуры
Команды

Установка текущего текстового стиля

  • Выберите стиль из выпадающего списка на панели инструментов "Стили".

Ввод команды: СТИЛЬ


Коротко о текстовых стилях - Команды

Надписи и метки
Надписи и метки
Коротко о текстовых стилях
Понятия
Процедуры
Команды

Команды
ОЧИСТИТЬ | Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
Системные переменные
FONTALT | Указывает альтернативный шрифт, используемый в случае, если не найден указанный шрифт
FONTMAP | Указывает файл, описывающий подстановку шрифтов
TEXTSIZE | Устанавливает высоту по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля
TEXTSTYLE | Задает имя текущего текстового стиля
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Назначение шрифтов - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Назначение шрифтов
Понятия
Процедуры
Команды

При создании описания текстового стиля пользователь задает для него шрифт. При этом выбор того или иного шрифта зависит от типа вводимого текста.

  • Коротко о назначении шрифтов
  • Использование шрифтов TrueType
    Результат отображения шрифтов TrueType на чертеже зависит от различных факторов.
  • Использование шрифтов текста для работ в рамках международного сотрудничества
    Некоторые факторы влияют на выбор, ввод и представление на чертеже текста на разных языках.
  • Подстановка шрифтов
    Если используемый на чертеже шрифт недоступен, он автоматически подменяется другим шрифтом.


Назначение шрифтов - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Назначение шрифтов
Понятия
Процедуры
Команды

Назначение шрифта текстовому стилю

Назначение SHX-шрифта азиатского языка текстовому стилю

Определение файла соответствия шрифтов

Задание альтернативного шрифта по умолчанию


Назначение шрифтов - Команды

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Назначение шрифтов
Понятия
Процедуры
Команды
Команды
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
Системные переменные
FONTALT | Указывает альтернативный шрифт, используемый в случае, если не найден указанный шрифт
FONTMAP | Указывает файл, описывающий подстановку шрифтов
QTEXTMODE | Управляет отображением текста
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о назначении шрифтов - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о назначении шрифтов
Понятия
Процедуры
Команды

Шрифты определяют внешний вид всех символов, входящих в символьный набор. Возможно использование как собственных SHX-шрифтов, так и шрифтов TrueType.

Один и тот же шрифт может использоваться в нескольких текстовых стилях. Если стандарты (государственные, отраслевые и т.д.) требуют выполнения надписей только определенным шрифтом, можно создать набор стилей, базирующихся на нужном шрифте. На следующей иллюстрации показано использование одного шрифта в нескольких стилях, которые отличаются друг от друга углом наклона символов.

Назначение шрифта текстовому стилю выполняется путем выбора файла шрифта из списка диалогового окна "Текстовые стили".


Назначение шрифтов

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Назначение шрифтов
Понятия
Процедуры
Команды

Нет процедур.


Коротко о назначении шрифтов - Команды

Надписи и метки
Надписи и метки
Коротко о назначении шрифтов
Понятия
Процедуры
Команды

Команды
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
Системные переменные
FONTALT | Указывает альтернативный шрифт, используемый в случае, если не найден указанный шрифт
FONTMAP | Указывает файл, описывающий подстановку шрифтов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование шрифтов TrueType - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Использование шрифтов TrueType
Понятия
Процедуры
Команды

Результат отображения шрифтов TrueType на чертеже зависит от различных факторов.

Символы надписей, выполненные шрифтами TrueType, на чертеже всегда выглядят заполненными; однако при вычерчивании на плоттере их внешний вид определяется состоянием системной переменной TEXTFILL. По умолчанию TEXTFILL равна 1; это значит, что символы выводятся на печать заполненными.

Редактор, используемый в месте редактирования, способен отображать только шрифты, распознаваемые Microsoft Windows. Так как SHX-шрифты не распознаются системой Windows, в редакторе, используемом в месте редактирования, при выборе SHX-шрифта или любого другого шрифта, отличного от TrueType, применяется шрифт, эквивалентный TrueType.

См. также

Задание высоты символов


Назначение шрифта текстовому стилю - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Использование шрифтов TrueType
Понятия
Процедуры
Команды

Назначение шрифта текстовому стилю

  1. Нажмите "Формат" » "Текстовые стили".
  2. В группе "Имя стиля" диалогового окна "Текстовые стили" нажмите кнопку "Новый".
  3. В диалоговом окне "Новый текстовый стиль" введите имя нового текстового стиля. Нажмите "OK".
  4. В группе "Шрифт" выберите из списка один из TrueType-шрифтов. Слева от названий TrueType-шрифтов отображаются значки в виде буквы "Т".
  5. Чтобы увидеть результат применения эффектов к различным символам, можно ввести текст в текстовое поле группы "Образец", расположенное слева от кнопки "Просмотр". Нажмите кнопку "Просмотр".
  6. Чтобы обновить текст на чертеже, нажмите кнопку "Применить".
  7. Нажмите кнопку "Закрыть".

Панель "Стили"

Ввод команды: СТИЛЬ


Использование шрифтов TrueType - Команды

Надписи и метки
Надписи и метки
Использование шрифтов TrueType
Понятия
Процедуры
Команды

Команды
КТЕКСТ | Управление отображением и выводом на плоттер текста и атрибутов
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
Системные переменные
QTEXTMODE | Управляет отображением текста
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование шрифтов текста для работ в рамках международного сотрудничества - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Использование шрифтов текста для работ в рамках международного сотрудничества
Понятия
Процедуры
Команды

Некоторые факторы влияют на выбор, ввод и представление на чертеже текста на разных языках.

Программа поддерживает стандарт кодирования символов Unicode. SHX-шрифт, закодированный с использованием шрифта стандарта Unicode, может содержать намного больше символов, чем описанный в системе пользователя; поэтому для использования символа, не доступного непосредственно с клавиатуры, можно ввести последовательность \U+nnnn, где nnnn представляет собой шестнадцатеричное значение Unicode для символа.

Начиная с версии AutoCAD 2007, все контурные SHX-шрифты кодируются с учетом стандарта Unicode, за исключением "Больших шрифтов". При выборе шрифта для международных работ можно воспользоваться или шрифтом TrueType, или "Большим шрифтом".

SHX-файлы азиатских "больших шрифтов"

Азиатские алфавиты содержат тысячи символов, не относящихся к стандарту ASCII. Для поддержки такого текста программа позволяет работать с особым типом файлов описания форм, называемых файлами большого шрифта. При этом текстовому стилю можно одновременно назначать обычный и большой шрифт.

Большие шрифты азиатских языков, входящие в продукт
Наименование файла шрифта | Описание
@extfont2.shx | Японский вертикальный шрифт (некоторые символы повернуты для корректного использования в вертикальном тексте)
bigfont.shx | Японский шрифт, подгруппа символов
chineset.shx | Традиционный китайский шрифт
extfont.shx | Расширенный японский шрифт, уровень 1
extfont2.shx | Расширенный японский шрифт, уровень 2
gbcbig.shx | Упрощенный китайский шрифт
whgdtxt.shx | Корейский шрифт
whgtxt.shx | Корейский шрифт
whtgtxt.shx | Корейский шрифт
whtmtxt.shx | Корейский шрифт

При вводе имен шрифтов в командной строке в ответ на запрос команды -СТИЛЬ предполагается, что первым вводится имя обычного шрифта, а вторым (через запятую) - имя большого шрифта. Если вводится только одно имя, предполагается, что это имя обычного шрифта, и любой связанный с ним большой шрифт удаляется из стиля. Вставляя запятые перед именами файлов шрифтов или после них, можно переназначить только один из шрифтов, не изменяя другой, как показано в следующей таблице.

Задание обычных и больших шрифтов из командной строки
Что вводится... | Что устанавливается...
[имя шрифта],[имя большого шрифта] | И обычный, и большой шрифты
[имя шрифта], | Только обычный шрифт (большой не изменяется)
,[имя большого шрифта] | Только большой шрифт (обычный не изменяется)
[имя шрифта] | Только обычный шрифт (большой отменяется, если был задан)
ENTER (пустой ввод) | Изменений нет

Примечание Длинные имена файлов, содержащие запятые, не принимаются в качестве имен файлов шрифтов. Запятая воспринимается как разделитель между именами файлов SHX-шрифта и большого шрифта.

См. также

Подстановка шрифтов


Назначение SHX-шрифта азиатского языка текстовому стилю - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Использование шрифтов текста для работ в рамках международного сотрудничества
Понятия
Процедуры
Команды

Назначение SHX-шрифта азиатского языка текстовому стилю

  1. Нажмите "Формат" » "Текстовые стили".
  2. В диалоговом окне "Текстовый стиль" в группе "Имя стиля" нажмите кнопку "Новый".
  3. В диалоговом окне "Новый текстовый стиль" введите имя нового текстового стиля. Нажмите "OK".
  4. Выберите имя файла шрифта SHX из списка "Имя шрифта", затем установите флажок "Использовать большой шрифт" для использования большого шрифта азиатского языка.

    5. После выбора опции "Использовать большой шрифт" список "Начертание" заменяется на "Большой шрифт". При этом в списках отображаются только SHX-шрифты.

  5. Чтобы увидеть результат применения эффектов к различным символам, можно ввести текст в текстовое поле группы "Образец", расположенное слева от кнопки "Просмотр". Нажмите кнопку "Просмотр".
  6. Чтобы обновить текст на чертеже, нажмите кнопку "Применить".
  7. Нажмите кнопку "Закрыть".

Панель "Стили"

Ввод команды: СТИЛЬ


Использование шрифтов текста для работ в рамках международного сотрудничества - Команды

Надписи и метки
Надписи и метки
Использование шрифтов текста для работ в рамках международного сотрудничества
Понятия
Процедуры
Команды

Команды
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Подстановка шрифтов - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Подстановка шрифтов
Понятия
Процедуры
Команды

Программа заменяет отсутствующий в системе шрифт другим шрифтом.

Задание альтернативного шрифта

Если используемый на чертеже шрифт отсутствует в системе, то он автоматически заменяется альтернативным шрифтом, заданным пользователем. По умолчанию используется файл шрифта simplex.shx. Если необходимо задать другой шрифт, требуется ввести имя файла альтернативного шрифта в системную переменную FONTALT. Если используется текстовый стиль, содержащий большой шрифт, можно привести его в соответствие с другим шрифтом с помощью системной переменной FONTALT. По умолчанию системная переменная использует пару файлов шрифтов txt.shx, bigfont.shx. Дополнительную информацию см. в разделе Использование шрифтов текста для работ в рамках международного сотрудничества.

В прежних версиях имелась возможность отображения на чертежах шрифтов PostScript®. Так как в более поздних версиях шрифты PostScript не отображаются, в программе Autodesk используются шрифты, эквивалентные TrueType. Таблица соответствия шрифтов PostScript шрифтам, эквивалентным TrueType, хранится в файле соответствия шрифтов, поставляемом с программой.

Отображение шрифтов-заместителей

Шрифты сторонних разработчиков или пользовательские SHX-шрифты, не имеющие TrueType-эквивалентов, заменяются одним из нескольких шрифтов TrueType, называемых шрифтами-заместителями. В Редакторе, используемом в месте редактирования, шрифты-заместители отличаются по внешнему виду от замещаемых шрифтов для отображения того, что они служат заместителями шрифтов чертежа.

Пользовательские SHX-шрифты не отображаются в списке шрифтов на панели "Форматирование текста". Чтобы иметь возможность использовать такие шрифты, необходимо вначале создать текстовый стиль с нужным шрифтом, а затем применить его к фрагменту текста.

Использование файлов соответствия шрифтов

Иногда возникает необходимость использования в чертеже ограниченного набора шрифтов, или преобразования заданных в чертеже шрифтов в другие. В этом случае следует с помощью любого текстового редактора создать таблицу соответствия шрифтов.

Таблицы соответствия удобно использовать для подгонки чертежей под шрифтовые стандарты различных фирм, а также для ускорения вычерчивания рабочих вариантов чертежей. Например, при передаче чертежей консультантам в таблице соответствия шрифтов необходимо определить, какой шрифт следует применить при отображении текстового объекта, созданного с использованием другого шрифта. В ходе черновой работы надписи можно наносить с применением быстро обрабатываемых SHX-шрифтов, а для получения окончательного чертежа заменить их на более сложные шрифты, создав таблицу, ставящую в соответствие каждому из SHX-шрифтов его эквивалент.

Таблица соответствия шрифтов представляет собой текстовый ASCII-файл с расширением .fmp, в каждой строке которого записываются исходный и подставляемый вместо него шрифты. Каждая строка файла - это запись об одном соответствии шрифтов. Запись состоит из базового имени файла шрифта (без пути к его папке), точки с запятой (;) и имени файла шрифта, используемого для подмены. Имя файла, используемого для замены, содержит расширение файла, например .ttf.

Например, для замены файлом шрифта TrueType times.ttf файла шрифта romanc.shx в таблице соответствия необходимо сделать следующую запись:

romanc.shx;times.ttf

Программа поставляется со стандартным файлом соответствия шрифтов. Его можно редактировать с помощью любого текстового редактора, поддерживающего формат ASCII. Для использования другой таблицы соответствия шрифтов ее имя можно задать в диалоговом окне "Настройка" или с помощью системной переменной FONTMAP. В следующей таблице приводятся правила замены шрифтов, применяемые, если файл шрифта не может быть обнаружен при открытии чертежа.

Подстановка шрифтов
Расширения файлов | В первую очередь | Во вторую очередь | В третью очередь | В четвертую очередь
.ttf | Шрифт, заданный в FONTMAP | Шрифт, заданный в текстовом стиле | Подобный шрифт из имеющихся в Windows |
.shx | Шрифт, заданный в FONTMAP | Шрифт, заданный в текстовом стиле | Шрифт, заданный в FONTALT | Запрос нового шрифта
.pfb | Шрифт, заданный в FONTMAP | Шрифт, заданный в FONTALT | Запрос нового шрифта |


Подстановка шрифтов - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Подстановка шрифтов
Понятия
Процедуры
Команды

Определение файла соответствия шрифтов

Задание альтернативного шрифта по умолчанию


Определение файла соответствия шрифтов - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Подстановка шрифтов
Понятия
Процедуры
Команды

Определение файла соответствия шрифтов

  1. Нажмите "Сервис" » "Настройки".
  2. На вкладке "Файлы" в списке дважды нажмите кнопку мыши на элементе "Имена файлов текстового редактора, словаря и шрифтов".
  3. Дважды нажмите на "Файле соответствия шрифтов".

    4. Файл acad.fmp определен по умолчанию.

  4. Для использования другой таблицы соответствия шрифтов нужно дважды нажать на линии со стрелкой и выбрать файл таблицы в диалоговом окне "Выбор файла". Выберите файл и нажмите кнопку "Открыть". Нажмите "ОК".
  5. Введите в командной строке реген для обновления надписей чертежа согласно установленной таблице соответствия шрифтов.

Ввод команды: НАСТРОЙКА


Задание альтернативного шрифта по умолчанию - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Подстановка шрифтов
Понятия
Процедуры
Команды

Задание альтернативного шрифта по умолчанию

  1. В командной строке введите fontalt.
  2. Введите имя файла шрифта, который должен использоваться как альтернативный.


Подстановка шрифтов - Команды

Надписи и метки
Надписи и метки
Подстановка шрифтов
Понятия
Процедуры
Команды

Команды
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
FONTALT | Указывает альтернативный шрифт, используемый в случае, если не найден указанный шрифт
FONTMAP | Указывает файл, описывающий подстановку шрифтов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание высоты символов - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Задание высоты символов
Понятия
Процедуры
Команды

Высота символов задается в единицах чертежа. Численное значение высоты определяет размер прописных букв всех шрифтов, кроме шрифтов TrueType.

Если в описании стиля задана фиксированная высота текста, то при создании однострочных надписей запрос "Высота" не выводится. Когда в текстовом стиле задана высота, равная 0, каждый раз при создании однострочных надписей выводится запрос высоты. Задание высоты, равной 0, позволяет создавать новые тексты различной высоты.

Шрифты TrueType

Высота шрифтов TrueType определяется суммой высоты прописной буквы и высоты верхней добавочной зоны, предназначенной для диакритических знаков (штрихи, галочки и т.п.), которые располагаются над некоторыми буквами в ряде европейских языков. Конкретные значения этих двух составляющих высоты не стандартизованы: они определяются разработчиком шрифта при его создании и, как следствие, меняются от шрифта к шрифту.

Кроме высоты прописной буквы и высоты верхней добавочной зоны, определяющей высоту текста, заданную пользователем, для шрифтов TrueType существует нижняя добавочная зона для таких символов, как y, j, p, g и q.

При изменении высоты символов многострочного тексте в редакторе происходит изменение всех размеров текстового объекта, в том числе его ширины.


Задание высоты в текстовом стиле - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Задание высоты символов
Понятия
Процедуры
Команды

Задание высоты в текстовом стиле

  1. Нажмите "Формат" » "Текстовые стили".
  2. В диалоговом окне "Текстовые стили" выберите текстовый стиль из списка "Имя стиля".
  3. В поле "Высота" группы "Шрифт" введите значение высоты (в единицах чертежа).
  4. Для обновления надписей, использующих данный текстовый стиль, нажмите кнопку "Применить".
  5. Нажмите кнопку "Закрыть".

Панель "Стили"

Ввод команды: СТИЛЬ


Задание высоты символов - Команды

Надписи и метки
Надписи и метки
Задание высоты символов
Понятия
Процедуры
Команды

Команды
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
Системные переменные
TEXTSIZE | Устанавливает высоту по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля
TEXTSTYLE | Задает имя текущего текстового стиля
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание угла наклона символов - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Задание угла наклона символов
Понятия
Процедуры
Команды

Угол наклона определяет наклон символов надписи вправо или влево. Значение угла наклона отсчитывается относительно перпендикуляра, проведенного к основанию строки.

Значение угла наклона может лежать в диапазоне от -85 до 85 градусов. Положительное значение угла соответствует наклону символов вправо, отрицательное - наклону влево.


Задание угла наклона символов в текстовом стиле - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Задание угла наклона символов
Понятия
Процедуры
Команды

Задание угла наклона символов в текстовом стиле

  1. Нажмите "Формат" » "Текстовые стили".
  2. В диалоговом окне "Текстовые стили" выберите текстовый стиль из списка "Имя стиля".
  3. В поле "Угол наклона" группы "Эффекты" введите значение угла между -85 и 85.

    4. Положительное значение угла соответствует наклону символов вправо, отрицательное - наклону влево.

  4. Для обновления надписей, использующих данный текстовый стиль, нажмите кнопку "Применить".
  5. Нажмите кнопку "Закрыть".

Панель "Стили"

Ввод команды: СТИЛЬ


Задание угла наклона символов - Команды

Надписи и метки
Надписи и метки
Задание угла наклона символов
Понятия
Процедуры
Команды

Команды
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание горизонтальной или вертикальной ориентации текста - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Задание горизонтальной или вертикальной ориентации текста
Понятия
Процедуры
Команды

Надписи можно располагать вертикально или горизонтально. Но вертикальную ориентацию можно использовать только для шрифтов, поддерживающих оба типа ориентации. Строки текста вертикальной ориентации могут располагаться одна рядом с другой. При последовательном нанесении однострочных надписей с вертикальной ориентацией каждая следующая надпись располагается правее предыдущей. Стандартное значение угла поворота для вертикальных текстов равно 270 градусам.

Примечание Для шрифтов и символов TrueType вертикальная ориентация не поддерживается.


Задание вертикальной ориентации в текстовом стиле - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Задание горизонтальной или вертикальной ориентации текста
Понятия
Процедуры
Команды

Задание вертикальной ориентации в текстовом стиле

  1. Нажмите "Формат" » "Текстовые стили".
  2. В диалоговом окне "Текстовые стили" выберите текстовый стиль из списка "Имя стиля".
  3. В группе "Эффекты" выберите "Вертикальная ориентация".
  4. Для обновления надписей, использующих данный текстовый стиль, нажмите кнопку "Применить".
  5. Нажмите кнопку "Закрыть".

Панель "Стили"

Ввод команды: СТИЛЬ


Задание горизонтальной или вертикальной ориентации текста - Команды

Надписи и метки
Надписи и метки
Задание горизонтальной или вертикальной ориентации текста
Понятия
Процедуры
Команды

Команды
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование текста - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Редактирование текста
Понятия
Процедуры
Команды

Имеется возможность редактирования и форматирования текста в надписях с изменением таких свойств, как масштаб и выравнивание.

  • Коротко о редактировании текста
  • Изменение однострочного текста
    Однострочный текст редактируют с помощью команд ДИАЛРЕД, ОКОНСВ и ручек.
  • Изменение многострочного текста
    Положение и содержимое многострочных текстовых объектов можно изменить с помощью палитры свойств, редактора, используемого в тексте редактирования, и ручек. Текст можно легко найти и заменить с помощью команды НАЙТИ.
  • Изменение текста с выноской
    Имеется возможность редактирования как пояснительной надписи для выноски, так и геометрических элементов самого объекта выноски.
  • Изменение масштаба и режима выравнивания текста
    В распоряжении пользователя имеются команды, позволяющие изменять масштаб и точки вставки текстовых объектов и атрибутов, не меняя при этом положения объектов.


Редактирование текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Редактирование текста
Понятия
Процедуры
Команды

Редактирование однострочного текста

Изменение свойств однострочного текста

Изменение многострочного текста

Поиск фрагмента текста на чертеже

Замена текста

Изменение ширины многострочного текстового объекта

Редактирование пояснительной надписи


Редактирование текста - Команды

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Редактирование текста
Понятия
Процедуры
Команды
Команды
БВЫНОСКА | Построение простой выноски и надписи для нее
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ВЫРТЕКСТ | Изменение точки выравнивания для выбранных текстовых объектов без изменения их положения
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
ЕДПРОСТ | Преобразование расстояний между единицами пространства модели и пространства листа
МАСШТЕКСТ | Увеличение/уменьшение размеров текстовых объектов без изменения их расположения
МТРЕД | Редактирует многострочный текст
НАЙТИ | Поиск, замена , выбор и показ текста на чертеже
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
ТЕКСТ | Создание однострочных текстовых объектов
Системные переменные
CENTERMT | Управление растягиванием центрированного по горизонтали многострочного текста с помощью ручек
DTEXTED | Задает интерфейс пользователя, выводимый на экран для редактирования однострочного текста.
MIRRTEXT | Управляет отображением текста с помощью команды ЗЕРКАЛО
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о редактировании текста - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о редактировании текста
Понятия
Процедуры
Команды

Текст, созданный с помощью команд ТЕКСТ, МТЕКСТ, ВЫНОСКА или БВЫНОСКА, можно редактировать, как любой другой объект. Их можно перемещать, поворачивать, стирать и копировать. Свойства текстовых объектов можно изменять на палитре свойств.

Для текстового объекта возможно не только редактирование его содержимого, но и создание зеркального отображения текста. Системная переменная MIRRTEXT управляет тем, происходит ли зеркальное отображение текста при симметричном отображении объектов на чертеже. Процедура редактирования текстов при различных способах его создания может несколько отличаться.


Редактирование текста

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Редактирование текста
Понятия
Процедуры
Команды

Нет процедур.


Коротко о редактировании текста - Команды

Надписи и метки
Надписи и метки
Коротко о редактировании текста
Понятия
Процедуры
Команды

Команды
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
НАЙТИ | Поиск, замена , выбор и показ текста на чертеже
Системные переменные
MIRRTEXT | Управляет отображением текста с помощью команды ЗЕРКАЛО
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение однострочного текста - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение однострочного текста
Понятия
Процедуры
Команды

Однострочный текст редактируют с помощью команд ДИАЛРЕД и ОКОНСВ. Команда ДИАЛРЕД используется при необходимости изменить только сам текст, но не формат или свойства текстового объекта. Команда ОКОНСВ позволяет изменить содержимое, стиль текста, его расположение, ориентацию, размер, выравнивание и другие характеристики.

Перемещение, масштабирование и поворот текстовых объектов можно также осуществлять с помощью ручек. У текстового объекта ручки находятся в левом нижнем углу базовой линии и в точке вставки.

Действие команд редактирования зависит от того, какая из ручек выбрана.


Изменение однострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение однострочного текста
Понятия
Процедуры
Команды

Редактирование однострочного текста

Изменение свойств однострочного текста


Редактирование однострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение однострочного текста
Понятия
Процедуры
Команды

Редактирование однострочного текста

  1. Нажмите "Редактирование" » "Объект" » "Текст" » "Изменить".
  2. Выберите однострочный текстовый объект.
  3. В редакторе, используемом в месте редактирования, введите новый текст.
  4. Нажмите ENTER.
  5. Выберите другой текстовый объект, требующий правки, или нажмите ENTER для завершения команды.

Ввод команды: ДИАЛРЕД


Изменение свойств однострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение однострочного текста
Понятия
Процедуры
Команды

Изменение свойств однострочного текста

  1. Выберите однострочный текстовый объект.
  2. Нажмите правую кнопку мыши на выбранном объекте. Нажмите кнопку "Свойства".
  3. На палитре свойств измените (если необходимо) значение любого из свойств, включая и сам текст надписи.

Панель "Стандартная"

Ввод команды: ОКОНСВ


Изменение однострочного текста - Команды

Надписи и метки
Надписи и метки
Изменение однострочного текста
Понятия
Процедуры
Команды

Команды
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
ТЕКСТ | Создание однострочных текстовых объектов
Системные переменные
DTEXTED | Задает интерфейс пользователя, выводимый на экран для редактирования однострочного текста.
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение многострочного текста - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение многострочного текста
Понятия
Процедуры
Команды

Положение и содержимое многострочных текстовых объектов можно изменить с помощью палитры свойств, редактора, используемого в тексте редактирования, и ручек. Текст можно легко найти и заменить с помощью команды НАЙТИ.

После создания многострочного текста пользователь может на палитре свойств изменять его следующие свойства:

  • текстовый стиль
  • выравнивание
  • ширина
  • поворот
  • межстрочный интервал

Кроме того, с помощью редактора, используемого в месте редактирования, можно изменять форматирование текста, например начертание жирным шрифтом и подчеркивание, а также изменять ширину многострочного текстового объекта.

Изменение положения текста

Для изменения положения и ширины многострочного текста можно использовать ручки. Ручки располагаются в вершинах текстовой рамки и, в некоторых случаях, в точке вставки текста.

Для перемещения многострочного текста можно воспользоваться палитрой свойств, где можно также редактировать содержимое надписей и изменять их свойства.

При использовании для создания многострочного текста таких команд, как РЗМЛИНЕЙНЫЙ или ВЫНОСКА, не требуется указания рамки текста, и создаваемый объект имеет всего одну ручку в точке вставки.

Поиск и замена текста

Для поиска и замены текста можно использовать команду НАЙТИ. Заменяется только содержание текста; форматирование символов и свойства текста не изменяются.

Команда НАЙТИ позволяет использовать при поиске символы-шаблоны.

Символ | Пояснение
# (Решетка) | Соответствует любой одиночной цифре
@ (Коммерческое "при") | Соответствует любой одиночной букве
. (Точка) | Соответствует любому символу, кроме букв и цифр
* (Звездочка) | Соответствует любой последовательности символов. Может использоваться в любой позиции строки
? (Знак вопроса) | Соответствует любому одиночному символу; например, ?BC соответствует ABC, 3BC и т.п.
~ (Тильда) | Соответствует всем строкам, кроме отвечающих следующему после тильды шаблону; например, ~*AB* соответствует всем строкам, не содержащим последовательности AB
[ ] | Соответствует любому из символов в скобках; например, [AB]C соответствует AC и BC
[~] | Соответствует любому из символов, кроме заключенных в скобки; например, [~AB]C соответствует XC, но не соответствует BC
[-] | Задает диапазон для одиночного символа; например, [A-G]C соответствует AC, BC и так далее до GC, но не соответствует HC
' (Апостроф) | Следующий за ним специальный символ трактуется как обычный; например, '~AB соответствует ~AB

Для поиска файлов чертежей, содержащих определенное слово или фразу, используйте средство поиска в системе Microsoft® Windows®. С помощью средства поиска можно искать любую текстовую информацию, кроме текста в таблицах и полях, а также внешних ссылок в файлах чертежей.

См. также

Работа с текстовыми стилями

Отображение полилиний, штриховок, градиентных заливок, весов линий и текста


Изменение многострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение многострочного текста
Понятия
Процедуры
Команды

Изменение многострочного текста

Поиск фрагмента текста на чертеже

Замена текста

Изменение ширины многострочного текстового объекта


Изменение многострочного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение многострочного текста
Понятия
Процедуры
Команды

Изменение многострочного текста

  1. Выберите многострочный текстовый объект.
  2. Нажмите правую кнопку мыши на выбранном объекте. Нажмите кнопку "Свойства".
  3. На палитре свойств измените (если необходимо) значение любого из свойств, включая и сам текст надписи.

Панель "Стандартная"

Ввод команды: ОКОНСВ


Поиск фрагмента текста на чертеже - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение многострочного текста
Понятия
Процедуры
Команды

Поиск фрагмента текста на чертеже

  1. Нажмите "Правка" » "Найти...".
  2. В поле "Строка для поиска" введите искомый фрагмент текста.
  3. В группе "Область поиска" выберите "Весь чертеж" или нажмите кнопку "Выберите объекты" для выбора одного или более текстовых объектов.
  4. Нажмите кнопку "Параметры" для выбора типа текстовых элементов, обрабатываемых при поиске, а также для задания того, следует ли выполнять поиск с учетом регистра и следует ли искать только целые слова, а не части слов.
  5. Нажмите "Найти".

    6. В области "Контекст" будет отображена часть строки, содержащей найденный фрагмент, причем сам фрагмент будет выделен подсветкой.

  6. Для показа найденного фрагмента на чертеже нажмите кнопку "Зумировать".
  7. Нажмите кнопку "Закрыть".

Ввод команды: НАЙТИ


Замена текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение многострочного текста
Понятия
Процедуры
Команды

Замена текста

  1. Нажмите "Правка" » "Найти...".
  2. В поле "Строка для поиска" введите искомый фрагмент текста.
  3. В группе "Область поиска" выберите "Весь чертеж" или нажмите кнопку "Выберите объекты" для выбора одного или более текстовых объектов.
  4. Нажмите кнопку "Параметры" для выбора типа текстовых элементов, обрабатываемых при поиске, а также для задания того, следует ли выполнять поиск с учетом регистра и следует ли искать только целые слова, а не части слов.
  5. В поле "Заменить на" введите текст, которым необходимо заменить найденный при поиске фрагмент текста.
  6. Нажмите "Найти".

    7. В области "Контекст" будет отображена часть строки, содержащей найденный фрагмент, причем сам фрагмент будет выделен подсветкой.

  7. Воспользуйтесь одним из следующих способов:
    • Нажать кнопку "Заменить" для замены только текущего найденного фрагмента.
    • Нажать кнопку "Заменить все" для поиска и замены сразу всех искомых фрагментов текста.

    В нижней части диалогового окна отображается информация о числе произведенных замен.

  8. Нажать кнопку "Закрыть".

Ввод команды: НАЙТИ


Изменение ширины многострочного текстового объекта - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение многострочного текста
Понятия
Процедуры
Команды

Изменение ширины многострочного текстового объекта

  1. Двойным нажатием выделите многострочный текстовый объект.
  2. В редакторе, используемом в месте редактирования, выполните одно из действий, описанных ниже:
    • Подвести курсор к правому краю линейки так, чтобы он принял вид двойной стрелки. Удерживая нажатой кнопку устройства указания, перетащить край линейки на необходимое расстояние. При перетаскивании значение ширины отображается в виде всплывающей подсказки. Отпустить кнопку, установив новую ширину.
    • Нажать правую кнопку мыши на нижней кромке линейки. Выбрать "Установить ширину МТекста". Ввести значение ширины в открывшемся диалоговом окне.
  3. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.


Изменение многострочного текста - Команды

Надписи и метки
Надписи и метки
Изменение многострочного текста
Понятия
Процедуры
Команды

Команды
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
МТРЕД | Редактирует многострочный текст
НАЙТИ | Поиск, замена , выбор и показ текста на чертеже
СТИЛЬ | Создание и изменение текстовых стилей, а также задание текущего текстового стиля
Системные переменные
CENTERMT | Управление растягиванием центрированного по горизонтали многострочного текста с помощью ручек
MIRRTEXT | Управляет отображением текста с помощью команды ЗЕРКАЛО
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
TEXTFILL | Управляет заливкой шрифтов TrueType во время печати или тонирования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение текста с выноской - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение текста с выноской
Понятия
Процедуры
Команды

Имеется возможность редактирования как пояснительной надписи для выноски, так и геометрических элементов самого объекта выноски.

Изменение размеров выноски выполняется путем ее растягивания и масштабирования. При растягивании изменяется отступ пояснительной надписи от конечной точки выноски. При масштабировании изменяется только сам объект выноски, то есть пояснительная надпись не масштабируется и не изменяет своего положения относительно конечной точки масштабируемой выноски. Выноски можно использовать в качестве кромок при обрезке и удлинении, однако сами они не могут быть ни обрезаны, ни удлинены.


Редактирование пояснительной надписи - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение текста с выноской
Понятия
Процедуры
Команды

Редактирование пояснительной надписи

  1. Дважды нажмите кнопку мыши на тексте, который надо изменить.

    2. Редактор, используемый в месте редактирования, отображается как для однострочного, так и для многострочного текста. Панель "Форматирование текста" не доступна для однострочного текста.

  2. Отредактируйте текст.

    3. Также можно выделить текст и нажать правую кнопку мыши. Выберите "Свойства". Отредактируйте текст на палитре свойств.

    Любые изменения положения пояснения приводят к перемещению конечной точки выноски. Например, поворот надписи влечет за собой поворот полки выноски (если она имеется).

Ввод команды: ДИАЛРЕД


Изменение текста с выноской - Команды

Надписи и метки
Надписи и метки
Изменение текста с выноской
Понятия
Процедуры
Команды

Команды
БВЫНОСКА | Построение простой выноски и надписи для нее
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
НАЙТИ | Поиск, замена , выбор и показ текста на чертеже
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение масштаба и режима выравнивания текста - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Изменение масштаба и режима выравнивания текста
Понятия
Процедуры
Команды

Имеется возможность изменения масштаба и точек вставки текстовых объектов, атрибутов и их описаний, не меняя при этом положения объектов.

Изменение масштаба многострочного текстового объекта

В чертеже могут содержаться сотни текстовых объектов, и отдельное масштабирование каждого из них может оказаться утомительным. Для масштабирования одного или сразу нескольких объектов, таких как атрибуты, однострочные и многострочные тексты, можно использовать команду МАСШТЕКСТ. При этом имеется возможность задавать относительный масштабный коэффициент или абсолютную высоту символов. Можно также масштабировать выбранный текст по заданной высоте символов уже имеющегося текста. Все текстовые объекты масштабируются с общим коэффициентом и сохраняют свои текущие положения.

Преобразование высоты символов при переходе между пространствами листа и модели

Команда ЕДПРОСТ конвертирует единицы размеров в пространстве модели в единицы размеров в пространстве листа и обратно. Ее прозрачный вызов в ходе выполнения других команд позволяет указывать расстояния в единицах другого пространства. Например, можно создать текстовый объект в пространстве модели с высотой символов другого текста, созданного в пространстве листа. В этом случае диалог в пространстве модели может выглядеть так:

Команда: текст

Начальная точка текста или [Выравнивание/Стиль]: 1,3

Высота <0,375>: 'едпрост

>>Расстояние в пространстве листа <1,000>: 3/8

Возобновляется команда ТЕКСТ.

Задайте высоту <0.375>: 1,173

После выполнения команды создается текстовый объект в пространстве модели с высотой символов 1,173; при переходе на лист высота равна 3/8.

Подробнее о прозрачных командах см. раздел Ввод команд в командной строке.

Изменение выравнивания текстовых объектов с сохранением их положения

Переопределение точки вставки текста без перемещения последнего выполняется с помощью команды ВЫРТЕКСТ. Например, в таблице или графике могут быть верно проставлены надписи, однако для дальнейшей работы необходимо их выровнять вправо.


Изменение масштаба и режима выравнивания текста - Команды

Надписи и метки
Надписи и метки
Изменение масштаба и режима выравнивания текста
Понятия
Процедуры
Команды

Команды
ВЫРТЕКСТ | Изменение точки выравнивания для выбранных текстовых объектов без изменения их положения
ЕДПРОСТ | Преобразование расстояний между единицами пространства модели и пространства листа
МАСШТЕКСТ | Увеличение/уменьшение размеров текстовых объектов без изменения их расположения
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Проверка орфографии - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Проверка орфографии
Понятия
Процедуры
Команды

Имеется возможность проверки орфографии во всех текстах чертежа, включая

  • однострочный текст
  • многострочный текст
  • тексты в значениях атрибутов
  • тексты во вхождениях блоков и связанных с ними описаниях блоков
  • тексты во вложенных блоках

Проверка орфографии осуществляется только в выбранных объектах. Для проверки всех объектов пространств модели и листа следует использовать опцию "Все" при выборе объектов. Проверка не выполняется в описаниях блоков невыбранных вхождений, а также в размерных текстах.

Смена словарей

Программа содержит несколько основных словарей, доступных на разных языках. Основные словари представляют собой перечни правильно написанных слов.

В ходе орфографической проверки слова надписей на чертеже сравниваются со словами, хранящимися в текущем основном словаре. Все добавляемые пользователем слова заносятся в текущий на данный момент вспомогательный словарь. Например, можно занести в словарь имена собственные, которые в дальнейшем не будут определяться как написанные с ошибкой.

Для проверки правописания текстов, выполненных на другом языке, необходимо сменить основной словарь. Кроме этого, можно вести одновременно несколько вспомогательных словарей, переключаясь с одного на другой по мере надобности.

Смена словаря может выполняться в диалоговом окне или с помощью системных переменных DCTMAIN и DCTCUST. Имена файлов словарей приводятся в описании системной переменной DCTMAIN.

Создание и редактирование вспомогательных словарей

Вспомогательный словарь представляет собой список слов, не вошедших в главный словарь. Файлы вспомогательных словарей имеют расширение .cus. Для добавления и удаления слов, а также для объединения словарей можно использовать любой текстовый редактор, поддерживающий формат ASCII. Если слову предшествует тильда (~), оно всегда отмечается как неправильное.

Создавать и редактировать словари можно непосредственно в программе.


Проверка орфографии - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Проверка орфографии
Понятия
Процедуры
Команды

Проверка орфографии

Смена текущего основного или вспомогательного словаря во время проверки орфографии

Создание или редактирование вспомогательных словарей во время проверки орфографии


Проверка орфографии - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Проверка орфографии
Понятия
Процедуры
Команды

Проверка орфографии

  1. Нажмите "Сервис" » "Орфография".
  2. Выберите текстовые объекты для проверки или введите все для проверки орфографии всех текстовых объектов.
  3. Если слова с ошибками не обнаружены, отображается соответствующее сообщение. Если программа обнаружила слово с ошибкой, то оно выводится в диалоговом окне "Проверка орфографии".
  4. Выполните одно из следующих действий:
    • Для исправления слова выберите один из вариантов, предлагаемых в списке "Варианты", или введите слово в поле "Варианты". Нажмите кнопку "Изменить" или "Изменить все".
    • Для пропуска слова (без изменения) нажмите кнопку "Пропустить" или "Пропустить все".
    • Для пропуска слова (без изменения) и добавления его во вспомогательный словарь нажмите кнопку "Добавить". (Эта опция не доступна, пока не выбран вспомогательный словарь.)
  5. Повторите пункт 4 для каждого обнаруженного слова с ошибкой. Для выхода нажмите "OK" или "Отмена".

Ввод команды: ОРФО


Смена текущего основного или вспомогательного словаря во время проверки орфографии - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Проверка орфографии
Понятия
Процедуры
Команды

Смена текущего основного или вспомогательного словаря во время проверки орфографии

  1. Нажмите "Сервис" » "Орфография".
  2. Выберите текст, который необходимо проверить, и нажмите ENTER.
  3. В диалоговом окне "Проверка орфографии" нажмите кнопку "Сменить словари".
  4. Выполните одно из следующих действий:
    • Для смены основного словаря выберите нужный из раскрывающегося списка "Основной словарь".
    • Для смены вспомогательного словаря выберите или введите его имя в поле "Вспомогательный словарь".
    • Чтобы выбрать словарь из списка, нажмите кнопку "Обзор".
  5. Нажмите "Принять".

Ввод команды: ОРФО


Создание или редактирование вспомогательных словарей во время проверки орфографии - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Проверка орфографии
Понятия
Процедуры
Команды

Создание или редактирование вспомогательных словарей во время проверки орфографии

  1. Нажмите "Сервис" » "Орфография".
  2. Выберите текст, который необходимо проверить, и нажмите ENTER.
  3. В диалоговом окне "Проверка орфографии" нажмите кнопку "Сменить словари".
  4. В диалоговом окне "Смена словарей" в группе "Вспомогательный словарь" выберите необходимый для редактирования словарь одним из следующих способов:
    • Ввести имя существующего словаря, включая расширение .cus.
    • Для выбора из списка папок нажать кнопку "Обзор".
    • Для создания нового словаря ввести его имя. Указать расширение файла .cus.
  5. Для пополнения словаря ввести слово в поле "Ведение вспомогательного словаря". Нажать "Добавить".
  6. Для удаления слова из словаря выделить его в списке. Нажать кнопку "Удалить".
  7. Нажать "ОК".

Ввод команды: ОРФО


Проверка орфографии - Команды

Надписи и метки
Надписи и метки
Проверка орфографии
Понятия
Процедуры
Команды

Команды
ОРФО | Орфографическая проверка надписей в чертеже
Системные переменные
DCTCUST | Отображает путь и имя файла текущего настраиваемого орфографического словаря.
DCTMAIN | Отображает имя файла текущего основного орфографического словаря.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с внешними текстовыми редакторами - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Работа с внешними текстовыми редакторами
Понятия
Процедуры
Команды

Редактором по умолчанию является редактор, используемый в месте редактирования, но можно использовать любой другой текстовый редактор, сохраняющий файлы в формате ASCII.

  • Коротко о работе с внешними текстовыми редакторами
  • Форматирование многострочного текста во внешнем редакторе
    Для форматирования отдельных символов и слов надписи во внешнем редакторе в текст можно включать управляющие коды.


Работа с внешними текстовыми редакторами - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Работа с внешними текстовыми редакторами
Понятия
Процедуры
Команды

Указание внешнего текстового редактора

Создание многострочной надписи во внешнем редакторе


Работа с внешними текстовыми редакторами - Команды

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Работа с внешними текстовыми редакторами
Понятия
Процедуры
Команды
Команды
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о работе с внешними текстовыми редакторами - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Коротко о работе с внешними текстовыми редакторами
Понятия
Процедуры
Команды

Редактором по умолчанию является редактор, используемый в месте редактирования, но можно выберите любой внешний текстовый редактор, определив его с помощью системной переменной MTEXTED. Выбранный редактор должен работать с текстовыми файлами в формате ASCII. Это может быть, например, Блокнот Microsoft.

При использовании внешнего текстового редактора для работы с многострочным текстом перед вводом текста необходимо задать общие параметры текста из командной строки. Затем открывается текстовый редактор для ввода текста. После закрытия текстового редактора текст размещается в соответствии с заданной шириной абзаца.

Если используется внешний редактор, то пользователь должен ввести специальные коды для применения форматирования.

Набор этих кодов не зависит от выбора внешнего редактора. Во избежание потери информации о форматировании текста для его изменения рекомендуется использовать тот же редактор, который использовался при создании текста.


Работа с внешними текстовыми редакторами

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Работа с внешними текстовыми редакторами
Понятия
Процедуры
Команды

Нет процедур.


Коротко о работе с внешними текстовыми редакторами - Команды

Надписи и метки
Надписи и метки
Коротко о работе с внешними текстовыми редакторами
Понятия
Процедуры
Команды

Команды
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Форматирование многострочного текста во внешнем редакторе - Понятия

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Форматирование многострочного текста во внешнем редакторе
Понятия
Процедуры
Команды

Для форматирования отдельных символов и слов надписи во внешнем редакторе в текст можно включать управляющие коды. С помощью управляющих кодов можно получать подчеркнутые, надчеркнутые и дробные надписи. Также имеется возможность задавать цвет, шрифт и размер символов. Кроме того, допускается изменение расстояния между символами текста и увеличение их ширины. Перечень управляющих кодов приводится в следующей таблице.

Управляющие коды для многострочных текстов
Код | Назначение | Ввести следующее … | Чтобы получить следующее …
\0...\o | Включение и отключение надчеркивания | Autodesk \OAutoCAD\o |
\L...\l | Включение и отключение надчеркивания подчеркивания | Autodesk \OAutoCAD\o |
\~ | Вставка неразрывного пробела | Autodesk AutoCAD\~LT |
\\ | Вставка обратной косой черты | Autodesk \\AutoCAD |
\{...\} | Вставка открывающей и закрывающей фигурных скобок | Autodesk \{AutoCAD\} |
\Cзначение; | Переход к определенному цвету | Autodesk \C2;AutoCAD |
\ имя файла; | Переход к определенному файлу шрифта | Autodesk \Ftimes; AutoCAD |
\Hзначение; | Переход к высоте, определенной в единицах чертежа | Autodesk \H2;AutoCAD |
\HзначениеX; | Умножение текущей высоты символов на коэффициент (буква Х латинская) | Autodesk \H3x;AutoCAD |
\S...^...; | Построение дробного текста с разбиением по символу /, # или ^ | 1.000\S+0.010^-0.000; |
\Tзначение; | Изменение расстояния между символами с коэффициентом от 0,75 до 4 | \T2;Autodesk |
\Qугол; | Изменение угла наклона символов | \Q20;Autodesk |
\Wзначение; | Изменение коэффициента растяжения символов | \W2;Autodesk |
\A | Установка режима выравнивания; допустимые значения: 0, 1, 2 (вниз, по центру, вверх) | \A1;1\S1/2 |
\P | Символ конца абзаца | Autodesk\PAutoCAD |

Допускается вложенность фигурных скобок до восьми уровней.

Управляющие коды могут также использоваться в размерных текстах (в частности для обозначения допусков). См. описание команды МТЕКСТ.

Пример: форматирование текста во внешнем текстовом редакторе

Данный пример описывает, как был создан текст со следующей иллюстрации.

Каждая приведенная ниже строка вводилась во внешнем текстовом редакторе:

{{\H1.5x; Большой текст} \A2; над текстом\A1;/\A0; за текстом}\P
{\A0;Базовый: 1 \S1/2;}\P
{\A1;По центру: 1 \S1/2;}\P
{\A2;Верхняя линия: 1 \S1/2;}\P
{Допуски: \A1;1.000\H.75x;\S+0.010^-0.000;}\P
{Архитектурный: 9-{\H.666x;\A2;11\A1;/\A0;16}\A2;"}\P


Форматирование многострочного текста во внешнем редакторе - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Форматирование многострочного текста во внешнем редакторе
Понятия
Процедуры
Команды

Указание внешнего текстового редактора

Создание многострочной надписи во внешнем редакторе


Указание внешнего текстового редактора - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Форматирование многострочного текста во внешнем редакторе
Понятия
Процедуры
Команды

Указание внешнего текстового редактора

  1. В командной строке введите mtexted.
  2. Выполните одно из следующих действий:
    • Ввести путь и имя исполняемого файла текстового редактора, поддерживающего текстовые файлы в формате ASCII, для его использования при создании и редактировании многострочного текста.
    • Ввести внутренний для назначения встроенного текстового редактора.


Создание многострочной надписи во внешнем редакторе - Процедуры

Штриховка, пояснения, таблицы и размеры
Надписи и метки
Форматирование многострочного текста во внешнем редакторе
Понятия
Процедуры
Команды

Создание многострочной надписи во внешнем редакторе

  1. Для определения текстового редактора на запрос "Команда" введите mtexted. Затем введите путь и имя используемого редактора.
  2. Нажмите "Рисование" » "Текст" » "Многострочный".
  3. Укажите первый угол текстовой рамки.
  4. Укажите противоположный угол текстовой рамки.
  5. В текстовом редакторе введите текст. Для завершения абзаца и перехода на новую строку следует вводить \P (эта латинская буква обязательно должна быть заглавной).
  6. По окончании ввода текста сохраните его в файле и выйдите из текстового редактора.

Панель "Рисование"

Ввод команды: МТЕКСТ


Форматирование многострочного текста во внешнем редакторе - Команды

Надписи и метки
Надписи и метки
Форматирование многострочного текста во внешнем редакторе
Понятия
Процедуры
Команды

Команды
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Таблицы - Понятия

Штриховка, пояснения, таблицы и размеры
Таблицы
Понятия
Процедуры
Команды

Таблица представляет собой прямоугольную структуру ячеек, в которых содержатся текстовые объекты или блоки.

  • Создание и редактирование таблиц
    Данные в таблице организованы по строкам и столбцам. Сначала создают пустую таблицу, а затем заполняют ее ячейки необходимой информацией.
  • Работа со стилями таблиц
    Вид таблицы определяется заданным для нее стилем. Можно использовать стиль таблиц СТАНДАРТ, предлагаемый по умолчанию, или создать свои собственные стили таблиц.
  • Добавление в таблицы текста и блоков
    Ячейка таблицы может содержать в качестве данных текстовые записи или блоки.
  • Использование формул в ячейках таблицы
    В ячейках таблицы могут содержаться формулы, использующие для расчетов величины, содержащиеся в других ячейках таблицы.


Таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Понятия
Процедуры
Команды

Создание таблицы

Изменение ячеек в таблице с помощью ручек

Изменение ячеек в таблице с помощью ручек

Изменение таблицы с помощью палитры свойств

Изменение ширины столбца или высоты строки в таблице

Добавление столбцов или строк в таблицу

Объединение ячеек в таблице

Удаление столбцов или строк из таблицы

Экспорт таблицы

Определение или изменение стиля таблиц

Применение к таблице нового стиля

Изменение стиля таблиц, применяемого к новым таблицам

Определение типа данных и форматирования для строки таблицы

Определение типа данных и форматирования для выбранных ячеек таблицы

Ввод текста в таблицу

Изменение свойств ячеек в таблице

Копирование свойств ячейки в другие ячейки

Изменение веса линий или цвета границ ячеек таблицы

Редактирование текста в ячейке таблицы

Вставка блока в ячейку таблицы

Вставка поля в ячейку таблицы

Суммирование значений в диапазоне ячеек таблицы

Получение среднего значения в диапазоне ячеек таблицы

Подсчет ячеек в столбце или строке таблицы

Использование в формуле ячейки из другой таблицы

Ввод формулы в ячейку таблицы вручную

Отключение отображения букв столбцов и номеров строк

Изменение цвета фона букв столбцов и номеров строк таблиц

Вставка поля формулы в ячейку таблицы


Таблицы - Команды

Штриховка, пояснения, таблицы и размеры
Таблицы
Понятия
Процедуры
Команды
Команды
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
КОПИРОВАТЬЯЧСВ | Копирует свойства выбранной ячейки таблицы в другие ячейки
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАЙТИ | Поиск, замена , выбор и показ текста на чертеже
ОБНПОЛЕ | Позволяет обновлять поля в выбранных объектах чертежа вручную
ОРФО | Орфографическая проверка надписей в чертеже
ПОЛЕ | Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
ТАБЛИЦА | Создание пустой таблицы объектов в чертеже
ТАБЛРЕД | Редактирование текста в ячейках таблиц
ТАБЛСТИЛЬ | Создание нового стиля таблиц
ЭКСПОРТТАБЛ | Экспорт данных таблицы в файл формата CSV
Системные переменные
CTABLESTYLE | Установка имени текущего стиля таблицы.
FIELDDISPLAY | Управляет отображением полей на сером фоне
FIELDEVAL | Управляет обновлением полей
TABLEINDICATOR | Управляет отображением номеров рядов и букв столбцов при открытии текстового редактора, используемого в месте редактирования, для изменения ячейки таблицы
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и редактирование таблиц - Понятия

Штриховка, пояснения, таблицы и размеры
Таблицы
Создание и редактирование таблиц
Понятия
Процедуры
Команды

Данные в таблице организованы по строкам и столбцам. Сначала создают пустую таблицу, а затем заполняют ее ячейки необходимой информацией.

После создания таблицы пользователь может указать с помощью мыши любую линию сетки таблицы для ее выделения и изменения с помощью ручек или палитры свойств.

При изменении высоты или ширины таблицы строки и столбцы меняются пропорционально. При изменении ширины столбца таблица соответственно расширяется или сужается. Для сохранения ширины таблицы необходимо удерживать нажатой клавишу CTRL, пользуясь ручкой столбца.

Изменение ячейки таблицы

Для выделения ячейки укажите точку внутри нее. На середине каждой границы ячейки появляется ручка. Для выделения другой ячейки необходимо указать точку внутри нужной ячейки. С помощью ручек можно изменить ширину и высоту ячейки и, соответственно, ширину и высоту ее столбца и строки.

Для выделения нескольких ячеек следует выбрать первую из ячеек, а затем, удерживая кнопку мыши в нажатом состоянии, указать все остальные ячейки. Если, нажав клавишу SHIFT, последовательно указать точки внутри двух ячеек, то вместе с указанными ячейками будут выбраны также все ячейки, расположенные между ними.

Для вставки или удаления столбцов и строк, комбинирования смежных ячеек и т.д. можно воспользоваться опциями контекстного меню, для вызова которого следует выделить ячейку и нажать правую кнопку мыши. При наличии выделенных ячеек можно использовать сочетание клавиш CTRL+Y для повтора последнего действия, включая изменения, сделанные в палитре свойств.

Добавление таблицы в инструментальную палитру

При добавлении таблицы в инструментальную палитру, свойства таблицы (например ее стиль и число строк и столбцов) и переопределения свойств ячеек (например для выравнивания и веса линий границ) сохраняются в описании инструмента. При этом содержимое таблицы и форматирование символов игнорируются.

См. также

Добавление в таблицы текста и блоков


Создание и редактирование таблиц - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Создание и редактирование таблиц
Понятия
Процедуры
Команды

Создание таблицы

Изменение ячеек в таблице с помощью ручек

Изменение ячеек в таблице с помощью ручек

Изменение таблицы с помощью палитры свойств

Изменение ширины столбца или высоты строки в таблице

Добавление столбцов или строк в таблицу

Объединение ячеек в таблице

Удаление столбцов или строк из таблицы

Экспорт таблицы


Создание таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Создание и редактирование таблиц
Понятия
Процедуры
Команды

Создание таблицы

  1. Нажмите "Рисование" » "Таблица".
  2. В диалоговом окне "Вставка таблицы" выберите стиль таблицы из списка или нажмите кнопку [...] для создания нового стиля таблицы.
  3. Выберите способ вставки:
    • Задайте точку вставки.
    • Задайте занимаемую область.
  4. Задайте число и ширину столбцов.

    5. При вставке с указанием области можно задайте либо число, либо ширину столбцов, но не оба эти параметра одновременно.

  5. Задайте число и высоту строк.

    6. При вставке с указанием области число строк определяется размером указанной области и высотой строк.

  6. Нажмите "ОК".


Изменение ячеек в таблице с помощью ручек - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Создание и редактирование таблиц
Понятия
Процедуры
Команды

Изменение ячеек в таблице с помощью ручек

  1. Выберите устройством указания линию сетки таблицы.
  2. Воспользуйтесь одной из следующих ручек:
    • Верхняя левая ручка. Перемещение таблицы.
    • Верхняя правая ручка. Изменение ширины таблицы с пропорциональным изменением ширины всех столбцов.
    • Нижняя левая ручка. Изменение высоты таблицы с пропорциональным изменением высоты всех строк.
    • Нижняя правая ручка. Изменение высоты и ширины таблицы с пропорциональным изменением высоты и ширины строк и столбцов соответственно.
    • Ручка столбца (над верхней строчкой столбца). Изменение ширины столбца, расположенного слева от ручки, и расширение или сужение таблицы в соответствии с этим изменением.
    • Клавиша CTRL + ручка столбца Расширение или сужение соседних столбцов без изменения ширины таблицы.

    Минимальное значение ширины столбца ограничено шириной одного символа. Минимальная высота строки пустой таблицы определяется суммарным значением высоты текста и вертикального отступа границ ячейки.

  3. Нажмите ESC для отмены выделения.


Изменение ячеек в таблице с помощью ручек - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Создание и редактирование таблиц
Понятия
Процедуры
Команды

Изменение ячеек в таблице с помощью ручек

  1. Выделите для изменения одну или несколько ячеек в таблице любым из следующих способов:
    • Укажите точку внутри ячейки.
    • Нажав клавишу SHIFT, выберите другую ячейку для выделения вместе с указанными ячейками всех ячеек, находящихся между ними.
    • Укажите выбранную ячейку и, удерживая нажатой кнопку мыши, укажите остальные выбираемые ячейки, а затем отпустить кнопку.
  2. Для изменения высоты строки выделенной ячейки необходимо перетащить верхнюю или нижнюю ручку.

    3. Если выделено несколько ячеек, то высота каждой строки изменится одинаково.

  3. Для изменения ширины столбца выделенной ячейки необходимо перетащить левую или правую ручку.

    4. Если выделено более одной ячейки, то ширина каждого столбца изменится одинаково.

  4. Для объединения выделенных ячеек нужно нажать правую кнопку мыши. Выберите "Объединить ячейки".

    5. Выделив несколько строк или столбцов, можно объединять ячейки по строкам или по столбцам.

  5. Нажмите ESC для отмены выделения.


Изменение таблицы с помощью палитры свойств - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Создание и редактирование таблиц
Понятия
Процедуры
Команды

Изменение таблицы с помощью палитры свойств

  1. Выберите устройством указания линию сетки таблицы.
  2. Нажмите "Сервис" » "Свойства".
  3. В палитре свойств укажите значение, которое требуется изменить, и введите или выберите новое значение.

    4. Свойство изменится в выделенной таблице.

  4. Выведите курсор из палитры свойств и нажмите ESC для отмены выделения.


Изменение ширины столбца или высоты строки в таблице - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Создание и редактирование таблиц
Понятия
Процедуры
Команды

Изменение ширины столбца или высоты строки в таблице

  1. Укажите точку внутри ячейки таблицы в столбце или строчке, которую требуется изменить.

    2. Нажав клавишу SHIFT, выберите другую ячейку для выделения вместе с указанными ячейками всех ячеек, находящихся между ними.

  2. Нажмите "Сервис" » "Свойства".
  3. В палитре свойств в группе "Ячейка" выберите значение ширины или высоты ячейки и введите новое значение.
  4. Нажмите ESC для отмены выделения.


Добавление столбцов или строк в таблицу - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Создание и редактирование таблиц
Понятия
Процедуры
Команды

Добавление столбцов или строк в таблицу

  1. Укажите точку внутри ячейки таблицы там, где необходимо добавить столбец или строчку.

    2. Можно выбрать одновременно несколько ячеек для добавления нескольких строк или столбцов.

  2. Нажмите правую кнопку мыши и воспользуйтесь одной из следующих опций:
    • "Вставить столбцы" » "Справа" Вставка столбца справа от выделенной ячейки.
    • "Вставить столбцы" » "Слева" Вставка столбца слева от выделенной ячейки.
    • "Вставить строки" » "Выше" Вставка строки сверху от выделенной ячейки.
    • "Вставить строки" » "Ниже" Вставка строки снизу от выделенной ячейки.
  3. Нажмите ESC для отмены выделения.


Объединение ячеек в таблице - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Создание и редактирование таблиц
Понятия
Процедуры
Команды

Объединение ячеек в таблице

  1. Выделите объединяемые ячейки в таблице любым из следующих способов:
    • Выделите ячейку и, нажав клавишу SHIFT, выберите другую ячейку для выделения этих двух ячеек и всех ячеек, находящихся между ними.
    • Укажите выбранную ячейку и, удерживая нажатой кнопку мыши, укажите остальные выбираемые ячейки, а затем отпустить кнопку.

    Полученная в результате объединенная ячейка должна иметь прямоугольную форму.

  2. Нажмите правую кнопку мыши. Выберите "Объединить ячейки". Создать несколько объединенных ячеек можно каким-либо из следующих способов:
    • По строкам: объединение ячеек горизонтально, с удалением вертикальных линий сетки; горизонтальные линии сетки остаются нетронутыми.
    • По столбцам: объединение ячеек вертикально, с удалением горизонтальных линий сетки; вертикальные линии сетки остаются нетронутыми.
  3. Введите текст в новую объединенную ячейку или нажмите ESC для отмены выделения.


Удаление столбцов или строк из таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Создание и редактирование таблиц
Понятия
Процедуры
Команды

Удаление столбцов или строк из таблицы

  1. Выберите ячейку, расположенную в столбце или строке, которую требуется удалить.

    2. Нажав клавишу SHIFT, выберите другую ячейку для выделения вместе с указанными ячейками всех ячеек, находящихся между ними.

  2. Нажмите правую кнопку мыши и воспользуйтесь одной из следующих опций:
    • Удалить столбцы. Удаление указанных пользователем столбцов.
    • Удалить строки. Удаление указанных пользователем строк.
  3. Нажмите ESC для отмены выделения.


Экспорт таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Создание и редактирование таблиц
Понятия
Процедуры
Команды

Экспорт таблицы

  1. В командной строке введите экспорттабл.
  2. Выберите таблицу, которую необходимо экспортировать.

    3. Появляется стандартное диалоговое окно выбора файлов.

  3. Введите имя файла и укажите его расположение.

    4. Таблица данных экспортируется в файл формата CSV (с разделением запятыми). Все форматирование таблицы и текста теряется.

Ввод команды: С выделенной таблицей нажмите правую кнопку мыши. Выберите пункт "Экспорт".


Создание и редактирование таблиц - Команды

Таблицы
Таблицы
Создание и редактирование таблиц
Понятия
Процедуры
Команды

Команды
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАЙТИ | Поиск, замена , выбор и показ текста на чертеже
ОБНПОЛЕ | Позволяет обновлять поля в выбранных объектах чертежа вручную
ОРФО | Орфографическая проверка надписей в чертеже
ПОЛЕ | Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
ТАБЛИЦА | Создание пустой таблицы объектов в чертеже
ТАБЛРЕД | Редактирование текста в ячейках таблиц
ТАБЛСТИЛЬ | Создание нового стиля таблиц
ЭКСПОРТТАБЛ | Экспорт данных таблицы в файл формата CSV
Системные переменные
CTABLESTYLE | Установка имени текущего стиля таблицы.
FIELDDISPLAY | Управляет отображением полей на сером фоне
FIELDEVAL | Управляет обновлением полей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа со стилями таблиц - Понятия

Штриховка, пояснения, таблицы и размеры
Таблицы
Работа со стилями таблиц
Понятия
Процедуры
Команды

Вид таблицы определяется заданным для нее стилем. Можно использовать стиль таблиц СТАНДАРТ, предлагаемый по умолчанию, или создать свои собственные стили таблиц.

Стиль таблиц может задать форматирование заголовка, заголовков столбцов и строк данных. В стиле СТАНДАРТ, например, первая строка является строкой заголовка, в которой все ячейки объединены в одну, а текст выровнен по центру. Вторая строка предназначена для заголовков столбцов, а все остальные строки - это строки данных.

Стиль может предусматривать свое выравнивание, формат текста и вид линий сетки для каждого типа строк. Например, в стиле таблицы можно задать использование более крупного шрифта для строки заголовка, выравнивание по центру заголовков столбцов и выравнивание по левому краю текста строк данных.

Данные в таблице могут располагаться сверху вниз или снизу вверх. Число столбцов и строк практически не ограничено.

Свойства границы в стиле таблиц задают внешний вид линий сетки, делящей таблицу на ячейки. Границы строки заголовка таблицы, строки заголовков столбцов и строк данных могут иметь различные вес линий и цвет и могут отображаться или не отображаться. Изменения параметров границы в диалоговом окне "Стили таблиц" незамедлительно отображаются в области предварительного просмотра.

Вид текста в ячейках таблицы определяется текстовым стилем, заданным в текущем стиле таблиц. Можно применить любой текстовый стиль из имеющихся в чертеже или создать новый. С помощью DesignCenter можно также копировать стили таблиц из других чертежей.

Можно определить данные и форматирование для общего заголовка, заголовков столбцов и строк данных. Также имеется возможность переназначить данные и форматирование для определенных ячеек. Например, можно установить отображение текста прописными буквами для всех строк заголовков столбцов, а затем установить отображение строчными буквами в отдельной ячейке таблицы. Тип данных, отображаемых в строке, и форматирование данного типа данных управляются параметрами форматирования, выбранными в диалоговом окне "Формат ячеек таблиц".

См. также

Работа с текстовыми стилями


Работа со стилями таблиц - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Работа со стилями таблиц
Понятия
Процедуры
Команды

Определение или изменение стиля таблиц

Применение к таблице нового стиля

Изменение стиля таблиц, применяемого к новым таблицам

Определение типа данных и форматирования для строки таблицы

Определение типа данных и форматирования для выбранных ячеек таблицы


Определение или изменение стиля таблиц - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Работа со стилями таблиц
Понятия
Процедуры
Команды

Определение или изменение стиля таблиц

  1. Нажмите "Формат" » "Стили таблиц".
  2. В диалоговом окне "Стили таблиц" нажмите "Создать".
  3. В диалоговом окне "Создание нового стиля таблиц" введите имя для нового стиля таблиц, выберите в поле "На основе" стиль, параметры которого будут использоваться новым стилем по умолчанию, и нажмите "Далее".
  4. В диалоговом окне "Новый стиль таблиц" задайте следующие параметры таблицы:
    • Общие. Задайте направление построения таблицы, выбрав "Вниз" или "Вверх". При выборе опции "Вверх" таблица будет строиться снизу вверх, а заголовок таблицы и заголовки столбцов будут располагаться внизу таблицы.
    • Отступ в ячейках. Введите значение для вертикального и горизонтального отступа между границей ячейки и содержимым ячейки. По умолчанию отступ по вертикали составляет одну треть высоты текста в строках данных. Максимальный отступ равен высоте текста в строках данных.
  5. Для настройки внешнего вида ячеек данных, ячеек заголовков столбцов или ячейки заголовка таблицы следует перейти на соответствующую вкладку.
  6. Если необходимо включить в таблицу строку заголовка таблицы или строку заголовков столбцов, то на вкладке "Заголовок" или "Заголовки столбцов" надо установить или сбросить флажки следующих опций:
    • Заголовок таблицы. Если флажок установлен, то первая строка таблицы состоит из одной ячейки, параметры которой задаются пользователем на вкладке "Заголовок".
    • Заголовки столбцов. Если флажок установлен, то в таблицу включается строка заголовков столбцов, параметры которой задаются пользователем на вкладке "Заголовки столбцов".

    Если выбраны обе опции, то первые две строки таблицы будут представлять собой строку заголовка таблицы и строку заголовков столбцов.

  7. На каждой из этих вкладок задаются следующие настройки отображения ячеек:
    • Текстовый стиль. Выберите текстовый стиль или нажмите кнопку [...] для вызова диалогового окна "Текстовые стили" и создания нового текстового стиля.
    • Высота текста. Введите значение высоты текста. Эта опция доступна, только если выбранный текстовый стиль имеет значение 0 для высоты текста. (Используемый по умолчанию текстовый стиль СТАНДАРТ имеет значение 0 для высоты текста.) Если в выбранном текстовом стиле задана фиксированная высота текста, то данная опция недоступна.
    • Цвет текста. Выберите один из стандартных цветов или нажмите кнопку "Выбор цвета" для отображения диалогового окна "Выбор цвета".
    • Цвет фона. Выберите "Нет" или цвет фона или нажмите кнопку "Выбор цвета" для отображения диалогового окна "Выбор цвета".
    • Выравнивание. Задание выравнивания для содержимого ячейки. Понятие "Центр" относится к выравниванию по горизонтали; понятие "Середина" относится к выравниванию по вертикали.
    • Формат Задайте тип данных и форматирование для строк данных, заголовков столбцов и заголовка таблицы. Нажмите кнопку [...] для вывода на экран диалогового окна "Формат ячеек таблицы", в котором можно определить дополнительные параметры форматирования.
  8. Для задания свойств линий границ можно использовать следующие настройки:
    • Кнопки обрамления. Позволяют задать вес линий и цвет для всех границ ячейки, только для внешних границ, только для внутренних границ (не доступны на вкладке "Заголовок"), только для нижней границы или установить режим отображения таблицы без границ. Область предварительного просмотра в диалоговом окне будет обновляться и показывать результат.
    • Вес линий границ. Введите вес линий, который будет использован для отображаемых границ. При использовании больших значений весов линий может понадобиться изменить отступы в ячейках таким образом, чтобы внутри них был виден текст.
    • Цвет линий границ. Выберите цвет, который будет использован для отображаемых границ, или нажмите кнопку "Выбор цвета" для открытия диалогового окна "Выбор цвета".
  9. Перейдите на другую вкладку для продолжения описания стиля таблиц или нажмите "ОК" для выхода из диалогового окна.


Применение к таблице нового стиля - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Работа со стилями таблиц
Понятия
Процедуры
Команды

Применение к таблице нового стиля

  1. Выберите таблицу, указав линию ее сетки.
  2. Нажмите "Сервис" » "Свойства".
  3. На палитре свойств в группе "Таблица" укажите значение параметра "Стиль таблицы" и выберите стиль таблицы.

    4. Новый стиль таблиц будет применен к таблице.

    Примечание Если предыдущий стиль таблиц имел строку заголовка, а новый нет, то текст заголовка будет помещен в первую ячейку таблицы, а другие ячейки в первой строке останутся пустыми.

  4. Дважды нажмите ESC для отмены выделения.


Изменение стиля таблиц, применяемого к новым таблицам - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Работа со стилями таблиц
Понятия
Процедуры
Команды

Изменение стиля таблиц, применяемого к новым таблицам

  1. Нажмите "Формат" » "Стили таблиц".
  2. В диалоговом окне "Стили таблиц" выберите стиль таблицы. Выберите "Установить".
  3. Нажмите кнопку "Закрыть".

    4. Текущий стиль таблиц будет применяться к вновь создаваемым таблицам.


Определение типа данных и форматирования для строки таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Работа со стилями таблиц
Понятия
Процедуры
Команды

Определение типа данных и форматирования для строки таблицы

  1. Нажмите "Формат" » "Стили таблиц".
  2. В диалоговом окне "Стили таблиц" выполнить одну из следующих операций:
    • Нажмите "Создать". В диалоговом окне "Создание нового стиля таблиц" введите имя нового стиля таблиц. В поле "На основе" выберите стиль таблиц, из которого будут взяты значения параметров по умолчанию для нового стиля таблиц. Нажмите кнопку "Продолжить".
    • Нажмите кнопку "Изменить".
  3. В диалоговом окне "Новый стиль таблиц" или "Изменение стиля таблиц" перейдите на вкладку "Данные", "Заголовки столбцов" или "Заголовок".
  4. В группе "Свойства ячеек" нажмите кнопку [...] справа от параметра "Формат".
  5. В диалоговом окне "Формат ячеек таблицы" установите тип, формат данных и другие параметры для выбранной строки таблицы.
  6. Нажмите "ОК".


Определение типа данных и форматирования для выбранных ячеек таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Работа со стилями таблиц
Понятия
Процедуры
Команды

Определение типа данных и форматирования для выбранных ячеек таблицы

  1. В таблице укажите ячейки, для которых требуется переопределить тип данных и форматирование.
  2. Нажмите правую кнопку мыши и в контекстном меню выберите "Формат".
  3. В диалоговом окне "Формат ячеек таблицы" установите тип, формат данных и другие параметры для выбранных ячеек таблицы.
  4. Введите данные в выбранные ячейки таблицы. Выбранный тип и формат данных будут определять их представление.
  5. Нажмите "ОК".


Работа со стилями таблиц - Команды

Таблицы
Таблицы
Работа со стилями таблиц
Понятия
Процедуры
Команды

Команды
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАЙТИ | Поиск, замена , выбор и показ текста на чертеже
ОБНПОЛЕ | Позволяет обновлять поля в выбранных объектах чертежа вручную
ОРФО | Орфографическая проверка надписей в чертеже
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
ТАБЛИЦА | Создание пустой таблицы объектов в чертеже
ТАБЛСТИЛЬ | Создание нового стиля таблиц
ЭКСПОРТТАБЛ | Экспорт данных таблицы в файл формата CSV
Системные переменные
CTABLESTYLE | Установка имени текущего стиля таблицы.
FIELDDISPLAY | Управляет отображением полей на сером фоне
FIELDEVAL | Управляет обновлением полей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление в таблицы текста и блоков - Понятия

Штриховка, пояснения, таблицы и размеры
Таблицы
Добавление в таблицы текста и блоков
Понятия
Процедуры
Команды

Ячейка таблицы может содержать в качестве данных текстовые записи или блоки.

При создании таблицы первая ячейка выделяется, отображается панель "Формат текста", после чего можно начать ввод текста. Высота строки ячейки увеличивается с увеличением количества строк текста. Для перехода к следующей ячейке необходимо нажать клавишу TAB или использовать клавиши со стрелками для перехода влево, вправо, вверх или вниз.

При вставке блока в ячейку таблицы либо блок автоматически меняет свои размеры под размер ячейки, либо ячейка изменяет свои размеры под размер блока.

Внутри ячейки клавиши со стрелками перемещают курсор. Для форматирования текста, импорта текста или осуществления других операций с текстом в ячейке можно воспользоваться кнопками панели инструментов или контекстным меню.

См. также

Использование полей в тексте

Создание многострочного текста


Добавление в таблицы текста и блоков - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Добавление в таблицы текста и блоков
Понятия
Процедуры
Команды

Ввод текста в таблицу

Изменение свойств ячеек в таблице

Копирование свойств ячейки в другие ячейки

Изменение веса линий или цвета границ ячеек таблицы

Редактирование текста в ячейке таблицы

Вставка блока в ячейку таблицы

Вставка поля в ячейку таблицы


Ввод текста в таблицу - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Добавление в таблицы текста и блоков
Понятия
Процедуры
Команды

Ввод текста в таблицу

  1. Укажите точку внутри ячейки таблицы и введите текст.

    2. Открывается панель "Формат текста".

  2. Для перемещения курсора по тексту внутри ячейки используются клавиши со стрелками.
  3. Для перехода на новую строку в ячейке следует нажать комбинацию клавиш ALT+ ENTER.
  4. Для переопределения текстового стиля, описанного в стиле таблицы, необходимо нажать стрелку рядом со списком "Текстовые стили" на панели инструментов и выбрать новый текстовый стиль.

    5. Выбранный текстовый стиль применяется к тексту, уже имеющемуся в ячейке, и любому новому тексту, который будет введен в эту ячейку впоследствии.

  5. Для переопределения настроек форматирования текущего текстового стиля необходимо сначала выделить текст одним из следующих способов:
    • Для выделения произвольного фрагмента текста нажмите левую кнопку мыши и, не отпуская ее, выберите курсором требуемый сегмент текста.
    • Для выделения слова нажмите на нем дважды кнопку мыши.
    • Для выделения текста ячейки целиком нажмите кнопку мыши на ячейке трижды. (можно также нажать правую кнопку мыши и выбрать пункт "Выбрать все").
  6. С помощью панели инструментов измените формат следующим образом:
    • Для изменения шрифта выберите нужное значение из списка "Шрифт".
    • Для изменения высоты символов введите новое значение в поле "Высота текста".
    • Для изменения начертания символов на полужирное или курсивное (только для шрифтов TrueType) или создания подчеркнутого или надчеркнутого текста нажмите соответствующую кнопку на панели инструментов. Для SHX-шрифтов полужирное и курсивное начертания не поддерживаются.
    • Для изменения цвета символов выберите нужное значение из списка "Цвет". Нажмите кнопку "Прочие" для отображения диалогового окна "Выбор цвета".
  7. Для перемещения между ячейками можно использовать клавиатуру:
    • Нажмите TAB для перемещения в следующую ячейку. Для добавления новой строчки можно нажать TAB, находясь в последней ячейке.
    • Нажмите SHIFT+TAB для перехода к предыдущей ячейке.
    • Если курсор находится в начале или конце текста ячейки, то использование клавиш со стрелками приведет к переходу в соседние ячейки. Можно также использовать сочетание клавиши CTRL и клавиши со стрелкой.
    • Если текст в ячейке выделен цветом, то нажатие клавиши со стрелкой приведет к снятию выделения и переходу курсора в начало или конец текста ячейки.
    • Для перехода вниз на одну ячейку можно нажать ENTER.
  8. Для сохранения сделанных изменений и выхода нажмите "OK" на панели инструментов или сочетание клавиш CTRL+ ENTER.


Изменение свойств ячеек в таблице - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Добавление в таблицы текста и блоков
Понятия
Процедуры
Команды

Изменение свойств ячеек в таблице

  1. Укажите ячейку таблицы, которую следует изменить.

    2. Нажав клавишу SHIFT, выберите другую ячейку для выделения вместе с указанными ячейками всех ячеек, находящихся между ними.

  2. Воспользуйтесь одним из следующих способов:
    • Для изменения одного или большего количества свойств в палитре свойств укажите значение, которое требуется изменить, и введите или выберите новое значение.
    • Для восстановления свойств по умолчанию нажмите правую кнопку мыши. Выберите "Снять переопределения свойств".


Копирование свойств ячейки в другие ячейки - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Добавление в таблицы текста и блоков
Понятия
Процедуры
Команды

Копирование свойств ячейки в другие ячейки

  1. Укажите ячейку таблицы, свойства которой надо скопировать.
  2. (Не обязательно) Для просмотра текущих свойств выбранной ячейки таблицы можно воспользоваться сочетанием клавиш CTRL+1, чтобы открыть палитру свойств.

    3. Будут скопированы все свойства ячейки за исключением типа ячейки: текстовая или блоковая.

  3. Нажмите правую кнопку мыши. Выберите "Формат по образцу".

    4. Курсор изменится на кисть.

  4. Для копирования свойств в другую ячейку таблицы чертежа необходимо указать точку внутри этой ячейки.
  5. Нажмите правую кнопку мыши или нажмите клавишу ESC для прекращения копирования свойств.


Изменение веса линий или цвета границ ячеек таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Добавление в таблицы текста и блоков
Понятия
Процедуры
Команды

Изменение веса линий или цвета границ ячеек таблицы

  1. Укажите ячейку таблицы, которую надо изменить.

    2. Нажав клавишу SHIFT, выберите другую ячейку для выделения вместе с указанными ячейками всех ячеек, находящихся между ними.

  2. Нажмите правую кнопку мыши. Выберите "Границы ячеек".
  3. В диалоговом окне "Свойства границ ячеек" выберите вес линий и цвет.

    4. Для соответствия свойств границ параметрам стиля таблиц, который был применен к таблице, используйте значение "ПОБЛОКУ".

  4. Нажмите одну из кнопок типа границы для определения границ, которые надо изменить, или выделите границы в области предварительного просмотра.
  5. Нажмите "ОК".
  6. Выведите курсор из палитры свойств и нажмите ESC для отмены выделения или выберите другую ячейку.


Редактирование текста в ячейке таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Добавление в таблицы текста и блоков
Понятия
Процедуры
Команды

Редактирование текста в ячейке таблицы

  1. Дважды нажмите кнопку мыши внутри ячейки, текст которой требуется отредактировать, и выберите опцию "Редактировать ячейку" из контекстного меню.
  2. Для внесения изменений можно воспользоваться панелью "Формат текста" или контекстным меню.
  3. Для сохранения сделанных изменений и выхода нажмите "OK" на панели инструментов, воспользуйтесь сочетанием клавиш CTRL+ENTER или укажите точку вне ячейки.
  4. Для снятия выделения таблицы нажмите клавишу ESC.


Вставка блока в ячейку таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Добавление в таблицы текста и блоков
Понятия
Процедуры
Команды

Вставка блока в ячейку таблицы

  1. Выберите ячейку таблицы, а затем нажмите правую кнопку мыши. Выберите "Вставить блок".
  2. В диалоговом окне "Вставка блока в ячейку таблицы" выберите блок из списка блоков чертежа или нажмите кнопку "Обзор", чтобы найти блок в другом чертеже.
  3. Задайте следующие свойства для блока:
    • Способ выравнивания Задание параметров выравнивания для блока в ячейке таблицы. Вертикальное выравнивание блока может осуществляться по центру, по верхнему и нижнему краям ячейки. Горизонтальное выравнивание блока может осуществляться по центру, по правому и левому краям ячейки.
    • Масштаб Масштаб для вставки блока. Введите значение масштаба или выберите опцию "Вписать" для автоматического подбора масштаба по величине ячейки.
    • Угол поворота блока Угол поворота блока.
  4. Нажмите "ОК".

    5. Если блок имеет атрибуты, открывается диалоговое окно "Редактирование атрибутов".


Вставка поля в ячейку таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Добавление в таблицы текста и блоков
Понятия
Процедуры
Команды

Вставка поля в ячейку таблицы

  1. Дважды нажмите кнопку мыши внутри ячейки таблицы.
  2. Нажмите правую кнопку мыши. Выберите "Вставить поле" или используйте сочетание клавиш CTRL+F.
  3. В диалоговом окне "Поле" выберите категорию в списке "Категории полей" для отображения имен полей в данной категории.
  4. Выберите поле.
  5. Выберите формат или задайте другие настройки, доступные для данного поля.
  6. Нажмите "ОК".


Добавление в таблицы текста и блоков - Команды

Таблицы
Таблицы
Добавление в таблицы текста и блоков
Понятия
Процедуры
Команды

Команды
ВСТАВИТЬ | Вставка именованного блока или другого чертежа в текущий чертеж
КОПИРОВАТЬЯЧСВ | Копирует свойства выбранной ячейки таблицы в другие ячейки
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
НАЙТИ | Поиск, замена , выбор и показ текста на чертеже
ОБНПОЛЕ | Позволяет обновлять поля в выбранных объектах чертежа вручную
ОРФО | Орфографическая проверка надписей в чертеже
ПОЛЕ | Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
ТАБЛИЦА | Создание пустой таблицы объектов в чертеже
ТАБЛРЕД | Редактирование текста в ячейках таблиц
ТАБЛСТИЛЬ | Создание нового стиля таблиц
ЭКСПОРТТАБЛ | Экспорт данных таблицы в файл формата CSV
Системные переменные
CTABLESTYLE | Установка имени текущего стиля таблицы.
FIELDDISPLAY | Управляет отображением полей на сером фоне
FIELDEVAL | Управляет обновлением полей
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование формул в ячейках таблицы - Понятия

Штриховка, пояснения, таблицы и размеры
Таблицы
Использование формул в ячейках таблицы
Понятия
Процедуры
Команды

В ячейках таблицы могут содержаться формулы, использующие для расчетов величины, содержащиеся в других ячейках таблицы. После выделения ячейки в таблице можно вставлять формулы с помощью контекстного меню. Можно также открыть текстовый редактор, используемый в месте редактирования, и ввести формулу в ячейку таблицы вручную.

Вставка формулы

В формулах ячейки обозначаются с помощью буквы столбца и номера строки. Например, ячейка в левом верхнем углу имеет обозначение A1. При объединении нескольких ячеек в одну ей присваивается обозначение левой верхней ячейки. Диапазон ячеек определяется с помощью первой и последней ячеек, разделенных двоеточием. Например, в диапазон A5:C10 включены ячейки строк 5-10 и столбцов A, B и C.

Формула должна начинаться со знака равенства (=). В формулах, использующихся для суммирования, определения средних значений и подсчета пустые ячейки и ячейки, не содержащие цифрового значения, игнорируются. Другие формулы выдают ошибку (#), если какая-либо ячейка арифметического выражения пуста или содержит нецифровые данные.

Для выбора ячейки из другой таблицы в том же чертеже используется параметр "Ячейка". После выбора ячейки откроется текстовый Редактор, используемый в месте редактирования, с помощью которого можно введите оставшуюся часть формулы.

Копирование формулы

При копировании формулы в другую ячейку таблицы диапазон изменяется для отображения нового местоположения. Например, при перемещении формулы из ячейки A10, используемой для суммирования значений в ячейках A1-A9, в ячейку B10 диапазон ячеек изменяется, и формула используется для суммирования значений в ячейках B1-B9.

Если при копировании и вставке формулы адрес ячейки изменять не требуется, добавьте значок доллара ($) в часть адреса, указывающую на строку или на столбец. Например, при вводе $A10 значение столбца останется прежним, а значение строки изменится. При вводе $A$10 значения столбца и строки останутся прежними.

Настройка отображения букв столбцов и номеров строк

По умолчанию буквы столбца и номера строк отображаются в текстовом редакторе, используемом в месте редактирования, при выборе ячейки для редактирования. Используйте системную переменную TABLEINDICATOR для включения и отключения отображения. Для установки нового цвета фона нужно выделить таблицу, нажать правую кнопку мыши и в контекстном меню выбрать "Цвет индикатора таблицы". Цвет, размер, стиль текста и цвет строки указаны в настройках заголовков столбцов в текущем стиле таблицы.

См. также

Использование полей в тексте


Использование формул в ячейках таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Использование формул в ячейках таблицы
Понятия
Процедуры
Команды

Суммирование значений в диапазоне ячеек таблицы

Получение среднего значения в диапазоне ячеек таблицы

Подсчет ячеек в столбце или строке таблицы

Использование в формуле ячейки из другой таблицы

Ввод формулы в ячейку таблицы вручную

Отключение отображения букв столбцов и номеров строк

Изменение цвета фона букв столбцов и номеров строк таблиц

Вставка поля формулы в ячейку таблицы


Суммирование значений в диапазоне ячеек таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Использование формул в ячейках таблицы
Понятия
Процедуры
Команды

Суммирование значений в диапазоне ячеек таблицы

  1. Выберите ячейку таблицы, в которую необходимо вставить формулу.
  2. Нажмите правую кнопку мыши. Выберите "Вставка формулы" » "Сумма".

    3. В командной строке выдается следующий запрос:

    Выберите первый угол диапазона ячеек таблицы.

  3. Укажите точку внутри первой ячейки в диапазоне.

    4. В командной строке выдается следующий запрос:

    Выберите второй угол диапазона ячеек таблицы.

  4. Укажите точку внутри последней ячейки в диапазоне.

    5. Откроется текстовый редактор, используемый в месте редактирования, и отобразится формула в ячейке.

  5. При необходимости отредактируйте формулу.
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажмите "ОК" на панели "Форматирование текста".
    • Укажите точку на чертеже вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

    В ячейке отобразится сумма значений всего диапазона ячеек. Пустые ячейки и ячейки, не содержащие цифрового значения, игнорируются.


Получение среднего значения в диапазоне ячеек таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Использование формул в ячейках таблицы
Понятия
Процедуры
Команды

Получение среднего значения в диапазоне ячеек таблицы

  1. Выберите ячейку таблицы, в которую необходимо вставить формулу.
  2. Нажмите правую кнопку мыши. Выберите "Вставка формулы" » "Среднее".

    3. В командной строке выдается следующий запрос:

    Выберите первый угол диапазона ячеек таблицы.

  3. Укажите точку внутри первой ячейки в диапазоне.

    4. В командной строке выдается следующий запрос:

    Выберите второй угол диапазона ячеек таблицы.

  4. Укажите точку внутри последней ячейки в диапазоне.

    5. Откроется текстовый редактор, используемый в месте редактирования, и отобразится формула в ячейке.

  5. При необходимости отредактируйте формулу.
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажмите "ОК" на панели "Форматирование текста".
    • Укажите точку на чертеже вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

    В ячейке отобразится среднее значение для всего диапазона ячеек. Пустые ячейки и ячейки, не содержащие цифрового значения, игнорируются.


Подсчет ячеек в столбце или строке таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Использование формул в ячейках таблицы
Понятия
Процедуры
Команды

Подсчет ячеек в столбце или строке таблицы

  1. Выберите ячейку таблицы, в которую необходимо вставить формулу.
  2. Нажмите правую кнопку мыши. Выберите "Вставка формулы" » "Кол-во".

    3. В командной строке выдается следующий запрос:

    Выберите первый угол диапазона ячеек таблицы.

  3. Укажите точку внутри первой ячейки в диапазоне.

    4. В командной строке выдается следующий запрос:

    Выберите второй угол диапазона ячеек таблицы.

  4. Укажите точку внутри последней ячейки в диапазоне.

    5. Откроется текстовый редактор, используемый в месте редактирования, и отобразится формула в ячейке.

  5. При необходимости отредактируйте формулу.
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажмите "ОК" на панели "Форматирование текста".
    • Укажите точку на чертеже вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

    В ячейке отобразится общее число ячеек в диапазоне.


Использование в формуле ячейки из другой таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Использование формул в ячейках таблицы
Понятия
Процедуры
Команды

Использование в формуле ячейки из другой таблицы

  1. Выберите ячейку таблицы, в которую необходимо вставить формулу.
  2. Нажмите правую кнопку мыши. Выберите "Вставка формулы" » "Ячейка".

    3. В командной строке выдается следующий запрос:

    Выберите ячейку таблицы:

  3. Укажите точку внутри ячейки из другой таблицы.

    4. Откроется текстовый редактор, используемый в месте редактирования, и отобразится адрес ячейки.

  4. Введите оставшуюся часть формулы.
  5. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажмите "ОК" на панели "Форматирование текста".
    • Укажите точку на чертеже вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

    В ячейке отобразится результат вычисления.


Ввод формулы в ячейку таблицы вручную - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Использование формул в ячейках таблицы
Понятия
Процедуры
Команды

Ввод формулы в ячейку таблицы вручную

  1. Дважды нажмите кнопку мыши внутри ячейки таблицы.

    2. Откроется текстовый редактор, используемый в месте редактирования.

  2. Введите формулу (функцию или арифметическое выражение), как показано в следующих примерах.
    • =sum(a1:a25,b1). Суммирует значения в 25 строках столбца A и в первой строке столбца B.
    • =average(a100:d100). Вычисляет среднее значение в первых 4 столбцах строки 100.
    • =count(a1:m500). Отображает общее число ячеек в столбцах A-M строк 1-100.
    • =(a6+d6)/e1. Суммирует значения в A6 и D6, а затем делит результат на значение в E1.

      • Для задания диапазона ячеек используется двоеточие, а для отдельных ячеек - запятая. Формула должна начинаться со знака равенства (=) и может содержать любой из следующих знаков: знак плюс (+), знак минус (-), знак умножения (*), знак деления (/), знак возведения в степень (^) и скобки ().

  3. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажмите "ОК" на панели "Форматирование текста".
    • Укажите точку на чертеже вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

    В ячейке отобразится результат вычисления.


Отключение отображения букв столбцов и номеров строк - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Использование формул в ячейках таблицы
Понятия
Процедуры
Команды

Отключение отображения букв столбцов и номеров строк

  1. В командной строке введите tableindicator.
  2. В ответ на запрос "Введите новое значение" введите 0.

Если для параметра TABLEINDICATOR установлено значение 1, при выборе ячейки буквы столбца и номера строк отображаются в редакторе, используемом в месте редактирования.


Изменение цвета фона букв столбцов и номеров строк таблиц - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Использование формул в ячейках таблицы
Понятия
Процедуры
Команды

Изменение цвета фона букв столбцов и номеров строк таблиц

  1. Укажите линию сетки, чтобы выберите таблицу.
  2. Нажмите правую кнопку мыши. Выберите "Цвет индикатора таблицы".
  3. В диалоговом окне "Выбор цвета" выберите цвет.
  4. Нажмите "ОК".

    5. Цвет, размер, стиль текста и цвет строки указаны в настройках заголовков столбцов в текущем стиле таблицы.


Вставка поля формулы в ячейку таблицы - Процедуры

Штриховка, пояснения, таблицы и размеры
Таблицы
Использование формул в ячейках таблицы
Понятия
Процедуры
Команды

Вставка поля формулы в ячейку таблицы

  1. Дважды нажмите кнопку мыши внутри ячейки таблицы.
  2. Нажмите правую кнопку мыши в текстовом редакторе, используемом в месте редактирования. Выберите "Вставить поле".
  3. В диалоговом окне "Поле" в списке "Категории полей" выберите "Объекты".
  4. В списке "Имена полей" выберите "Формула".
  5. Для ввода формулы можно использовать любой из следующих способов один или несколько раз:
    • Нажмите "Среднее", "Сумма" или "Кол-во". Диалоговое окно "Поле" временно закроется. Для указания диапазона укажите точку внутри первой и последней ячейки. Результат добавляется в формулу.
    • Нажмите "Ячейка". Диалоговое окно "Поле" временно закроется. Выберите ячейку в таблице на чертеже. Адрес ячейки добавится в формулу.
  6. (Не обязательно) Выберите формат и десятичный разделитель.
  7. Нажмите "ОК".
  8. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажмите "ОК" на панели "Форматирование текста".
    • Укажите точку на чертеже вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

    В ячейке отобразится результат вычисления.


Использование формул в ячейках таблицы - Команды

Таблицы
Таблицы
Использование формул в ячейках таблицы
Понятия
Процедуры
Команды

Команды
МТЕКСТ | Создает абзацы текста как единый объект многострочного текста
ОБНПОЛЕ | Позволяет обновлять поля в выбранных объектах чертежа вручную
ПОЛЕ | Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения
ТАБЛИЦА | Создание пустой таблицы объектов в чертеже
ТАБЛСТИЛЬ | Создание нового стиля таблиц
ЭКСПОРТТАБЛ | Экспорт данных таблицы в файл формата CSV
Системные переменные
CTABLESTYLE | Установка имени текущего стиля таблицы.
FIELDDISPLAY | Управляет отображением полей на сером фоне
FIELDEVAL | Управляет обновлением полей
TABLEINDICATOR | Управляет отображением номеров рядов и букв столбцов при открытии текстового редактора, используемого в месте редактирования, для изменения ячейки таблицы
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Размеры и допуски - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Понятия
Процедуры
Команды

Имеется множество команд, предназначенных для нанесения и форматирования размеров на чертеже. Для быстрого форматирования размеров и обеспечения их соответствия государственным стандартам и стандартам предприятия используйте размерные стили.

  • Основные понятия
    Имеется возможность проставления различных типов размеров, которые можно форматировать путем задания размерных стилей или редактирования отдельных размерных объектов.
  • Размерные стили
    Изменяя определенные параметры, можно управлять внешним видом размеров. При этом использование размерных стилей позволяет быстро форматировать размеры, обеспечивая их соответствие государственным стандартам и стандартам предприятия.
  • Задание масштаба размеров
    Имеется возможность задания масштаба для вывода размерных элементов. Устанавливаемый масштаб зависит от используемого способа компоновки и печати чертежа.
  • Нанесение размеров
    Имеется возможность нанесения всех стандартных типов размеров.
  • Редактирование размеров
    Редактирование нанесенных размеров может осуществляться либо отдельно для каждого размерного объекта, либо глобально путем изменения размерных стилей.
  • Нанесение допусков формы и расположения
    Имеется возможность нанесения допусков формы и расположения, выражающих отклонения формы, контура, ориентации и расположения элементов чертежа.


Размеры и допуски - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Понятия
Процедуры
Команды

Создание размера

Включение-отключение ассоциативности размеров по умолчанию

Выбор текущего размерного стиля

Получение списка всех параметров текущего размерного стиля

Получение списка параметров имеющегося размерного стиля

Получение списка размерных стилей в текущем чертеже

Сравнение размерных стилей

Форматирование размерных линий

Форматирование выносных линий

Выбор стрелок

Изменение направления стрелки

Использование стрелок собственной разработки

Размещение текста между выносными линиями

Принудительное размещение размерной линии между выносными линиями и выбора режима размещения

Размещение текста вдоль размерной линии

Размещение текста у второй выносной линии

Размещение размерного текста вручную

Размещение текста над размерной линией

Управление текстовым стилем в размерах

Добавление и форматирование основных единиц

Добавление и форматирование альтернативных единиц

Округление размерных значений

Подавление нулей в размерных значениях

Задание способа нанесения двусторонних допусков

Выравнивание допусков и подавление нулей в значениях допусков

Задание глобального масштаба размеров

Задание масштаба размеров пространства модели на листах

Задание масштаба размеров, создаваемых в пространстве листа

Нанесение горизонтального или вертикального размера

Нанесение параллельного размера

Нанесение линейных размеров от общей базы

Нанесение линейной размерной цепи

Нанесение повернутого размера

Изменение наклона выносных линий

Нанесение диаметра

Нанесение радиуса

Создание размера радиуса с изломом

Автоматическое создание центровых линий с помощью радиальных размеров

Создание центровых линий или маркеров центра для дуги или круга

Нанесение углового размера

Нанесение ординатного размера

Создание размера длины дуги

Назначение текущего размерного стиля уже нанесенным размерам

Восстановление размерного стиля

Переопределение размерного стиля

Назначение переопределений размерного стиля

Поворот размерного текста

Возврат размерного текста в исходное положение

Редактирование размерного текста

Перемещение текста вдоль размерной линии влево

Задание расстояния между размерными линиями в размерах от общей базы и размерных цепях

Изменение отступа выносных линий от объекта

Ассоциативное прикрепление размеров к объектам

Разрыв ассоциативной связи размеров с объектами

Нанесение допуска формы и расположения

Нанесение допуска формы и расположения с выноской


Размеры и допуски - Команды

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Понятия
Процедуры
Команды
Команды
БЛОК | Создание описания блока из выбранных объектов
БРАЗМЕР | Быстрое нанесение размера
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
ДОПУСК | Нанесение допусков формы и расположения
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПБЛОК | Запись объектов или блока в новый файл чертежа
РАСТЯНУТЬ | Перенос или растягивание объектов
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
РЗМБАЗОВЫЙ | Нанесение новых линейных, угловых или ординатных размеров от базовой линии предыдущего или выбранного размера
РЗМДИАМЕТР | Нанесение диаметров кругов и дуг
РЗМДУГА | Создает размер длины дуги
РЗМДУГА | Создает размер длины дуги
РЗМИЗЛОМ | Создание ломаных линий размеров радиуса
РЗМИЗЛОМ | Создание ломаных линий размеров радиуса
РЗМЛИНЕЙНЫЙ | Нанесение линейных размеров
РЗМОРДИНАТА | Нанесение ординатных размеров
РЗМОТКРЕПИТЬ | Отмена ассоциативности выбранных размеров
РЗМПАРАЛ | Нанесение параллельных линейных размеров
РЗМПОДАВИТЬ | Переопределение установок размерных переменных
РЗМПРИКРЕПИТЬ | Ассоциирование выбранных размеров с геометрическими объектами
РЗМРАДИУС | Нанесение радиусов кругов и дуг
РЗМРЕГЕН | Обновление расположения всех ассоциативных размеров
РЗМРЕД | Редактирование размерного текста и выносных линий на объектах для нанесения размеров
РЗМРЕДТЕКСТ | Перемещение и поворот размерных текстов
РЗМСТИЛЬ | Создание и модификация размерных стилей
РЗМУГЛОВОЙ | Нанесение угловых размеров
РЗМЦЕНТР | Нанесение маркеров центра или центровых линий для кругов и дуг
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
Системные переменные
DIMADEC | Управление отображением числа точных знаков в угловых размерах.
DIMALT | Управление альтернативными единицами в размерах.
DIMALTD | Управление количеством десятичных знаков в альтернативных единицах.
DIMALTF | Управление множителем для альтернативных единиц.
DIMALTTD | Установка числа знаков после запятой в значениях допуска для альтернативных размерных единиц
DIMALTTZ | Управление подавлением нулей в значениях допуска.
DIMALTU | Установка формата альтернативных единиц измерения для всех вторичных размерных стилей за исключением угловых.
DIMALTZ | Управление подавлением нулей в альтернативных размерных единицах.
DIMAPOST | Указывает префикс или суффикс текста (или и то, и другое) для альтернативных размерных единиц для всех типов размеров, кроме угловых
DIMARCSYM | Управляет отображением символа дуги в размере длины дуги
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
DIMASZ | Управление величинами стрелок размерных линий и линий выноски
DIMATFIT | Определение размещения размерного текста и стрелок, если и для текста, и для стрелок недостаточно места в выносных линиях
DIMAUNIT | Установка формата единиц измерения для угловых размеров.
DIMAZIN | Подавление нулевых значений для всех угловых размеров.
DIMBLK | Установка блока стрелок, отображаемого на концах размерных линий или линий выноски.
DIMBLK1 | Установка стрелки на первом конце размерной линии (при включенной переменной DIMSAH).
DIMBLK2 | Установка стрелки на втором конце размерной линии (при включенной переменной DIMSAH).
DIMCEN | Управление рисованием маркеров центра и центровых линий кругов и дуг с помощью команд РЗМЦЕНТР, РЗМДИАМЕТР и РЗМРАДИУС.
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
DIMCLRE | Задает цвет для размерных выносных линий.
DIMCLRT | Цвет, которым рисуется размерный текст. Для цвета можно выбрать любой допустимый номер цвета
DIMDEC | Установка числа десятичных знаков, отображаемых для основных единиц размера
DIMDLE | Установка значения расстояния, на которое размерная линия выступает за выносную линию, когда наклонные засечки рисуются вместо стрелок
DIMDLI | Управление расстоянием между размерными линиями в базовых размерах
DIMDSEP | Задает символ десятичного разделителя, используемый при создании размеров с десятичным форматом единиц измерения.
DIMEXE | Задает величину, на которую выносная линия должна выступать за размерную линию
DIMEXO | Задает величину смещения выносных линий относительно исходных точек
DIMFRAC | Установка формата дроби, если для переменной DIMLUNIT установлено значение 4 (архитектурные) или 5 (дробные)
DIMFXL | Устанавливает общую длину выносных линий от размерной линии до исходной точки размера
DIMFXLON | Управляет установкой фиксированной длины выносных линий
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMJOGANG | Определяет угол поперечного сегмента размерной линии в ломаной линии размера радиуса
DIMJUST | Управление положением размерного текста по горизонтали
DIMLFAC | Установка масштабного коэффициента для значений линейных размеров.
DIMLIM | Создание ограничений размеров в качестве текста по умолчанию
DIMLTEX1 | Устанавливает тип первой выносной линии
DIMLTEX2 | Устанавливает тип второй выносной линии
DIMLTYPE | Устанавливает тип размерной линии
DIMLUNIT | Установка единиц для всех типов размеров, кроме угловых.
DIMLWD | Задание веса для размерных линий.
DIMLWE | Задание веса для выносных линий
DIMPOST | Указание префикса или суффикса текста (или и того, и другого) для размерных единиц
DIMRND | Округление всех размерных расстояний в соответствии с указанным значением
DIMSAH | Управление отображением блоков стрелок размерных линий.
DIMSCALE | Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения
DIMSD1 | Управление подавлением первой размерной линии
DIMSD2 | Управление подавлением второй размерной линии
DIMSE1 | Подавление отображения первой выносной линии
DIMSE2 | Подавление отображения второй выносной линии
DIMSOXD | Подавляет отображение стрелок при отсутствии достаточного пространства между выносными линиями
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
DIMTDEC | Устанавливает количество десятичных знаков для значений допусков в основных единицах
DIMTFAC | Указывает масштабный коэффициент для высоты текста дробных частей размеров и допусков относительно высоты размерного текста, заданной в переменной DIMTXT
DIMTFILL | Управляет фоном размерного текста
DIMTFILLCLR | Устанавливает цвет фона текста в размерах
DIMTIH | Управляет ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями
DIMTIX | Отображает текст между размерными линиями
DIMTM | Устанавливает минимальное (или нижнее) предельное отклонение для размерного текста при включенной переменной DIMTOL или DIMLIM
DIMTMOVE | Устанавливает правила перемещения размерного текста
DIMTOFL | Управляет построением размерной линии между выносными линиями, даже если текст размещается вне линий
DIMTOH | Управляет ориентацией размерного текста за выносными линиями
DIMTOL | Добавление предельных отклонений в конец размерного текста.
DIMTP | Устанавливает максимальное (или верхнее) предельное отклонение для размерного текста при включенной переменной DIMTOL или DIMLIM.
DIMTSZ | Указывает размер засечки, которая наносится вместо стрелки в линейных размерах, радиусах и диаметрах
DIMTVP | Определяет вертикальное положение размерного текста над или под размерной линией
DIMTXSTY | Указывает текстовый стиль для размера
DIMTXT | Указывает высоту размерного текста, если в текстовом стиле не задана фиксированная высота
DIMTZIN | Управляет подавлением нулей в допусках
DIMUPT | Управляет параметрами при пользовательском расположении текста
DIMZIN | Управляет подавлением нулей в основных единицах измерения
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Основные понятия - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Основные понятия
Понятия
Процедуры
Команды

Имеется возможность проставления различных типов размеров, которые можно форматировать путем задания размерных стилей или редактирования отдельных размерных объектов.

  • Коротко о нанесении размеров
  • Размерные элементы
    Здесь перечисляются элементы, составляющие размеры, и даются их краткие описания.
  • Ассоциативные размеры
    Размеры могут быть ассоциативными, неассоциативными и расчлененными. Ассоциативные размеры настраиваются в соответствии с изменениями объектов, к которым они относятся.


Основные понятия - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Основные понятия
Понятия
Процедуры
Команды

Создание размера

Включение-отключение ассоциативности размеров по умолчанию


Основные понятия - Команды

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Основные понятия
Понятия
Процедуры
Команды
Команды
БРАЗМЕР | Быстрое нанесение размера
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
РЗМДИАМЕТР | Нанесение диаметров кругов и дуг
РЗМДУГА | Создает размер длины дуги
РЗМИЗЛОМ | Создание ломаных линий размеров радиуса
РЗМЛИНЕЙНЫЙ | Нанесение линейных размеров
РЗМОРДИНАТА | Нанесение ординатных размеров
РЗМОТКРЕПИТЬ | Отмена ассоциативности выбранных размеров
РЗМПРИКРЕПИТЬ | Ассоциирование выбранных размеров с геометрическими объектами
РЗМРАДИУС | Нанесение радиусов кругов и дуг
РЗМРЕГЕН | Обновление расположения всех ассоциативных размеров
РЗМРЕД | Редактирование размерного текста и выносных линий на объектах для нанесения размеров
РЗМРЕДТЕКСТ | Перемещение и поворот размерных текстов
РЗМСТИЛЬ | Создание и модификация размерных стилей
РЗМУГЛОВОЙ | Нанесение угловых размеров
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о нанесении размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Коротко о нанесении размеров
Понятия
Процедуры
Команды

Нанесение размеров является важным этапом в разработке конструкторской документации.

Размеры можно создавать для разных типов объектов, которые могут быть ориентированы разным образом. Существуют следующие основные типы нанесения размеров.

  • Линейный
  • Радиальный (радиус и диаметр)
  • Угловой
  • Ординатный
  • Длина дуги

Линейные размеры могут быть горизонтальными, вертикальными, параллельными, повернутыми, базовыми или в виде цепей. Некоторые примеры приведены на чертеже.

Примечание Для упрощения организации чертежа и изменения масштаба размера рекомендуется создавать размеры на листах, а не в пространстве модели.


Создание размера - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Коротко о нанесении размеров
Понятия
Процедуры
Команды

Создание размера

  1. Создайте слой, предназначенный для размеров, и сделайте его текущим.
  2. В левом нижнем углу окна приложения выберите вкладку разметки листа.
  3. Нажмите меню "Размеры" и выберите команду нанесения размера.
  4. Отвечайте на запросы команды.

Ввод команды: РЗМЛИНЕЙНЫЙ, РЗМРАДИУС, РЗМУГЛОВОЙ


Коротко о нанесении размеров - Команды

Размеры и допуски
Размеры и допуски
Коротко о нанесении размеров
Понятия
Процедуры
Команды

Команды
БРАЗМЕР | Быстрое нанесение размера
РЗМДИАМЕТР | Нанесение диаметров кругов и дуг
РЗМДУГА | Создает размер длины дуги
РЗМИЗЛОМ | Создание ломаных линий размеров радиуса
РЗМЛИНЕЙНЫЙ | Нанесение линейных размеров
РЗМОРДИНАТА | Нанесение ординатных размеров
РЗМПРИКРЕПИТЬ | Ассоциирование выбранных размеров с геометрическими объектами
РЗМРАДИУС | Нанесение радиусов кругов и дуг
РЗМРЕД | Редактирование размерного текста и выносных линий на объектах для нанесения размеров
РЗМРЕДТЕКСТ | Перемещение и поворот размерных текстов
РЗМСТИЛЬ | Создание и модификация размерных стилей
РЗМУГЛОВОЙ | Нанесение угловых размеров
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Размерные элементы - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размерные элементы
Понятия
Процедуры
Команды

Здесь перечисляются элементы, составляющие размеры, и даются их краткие описания.

Размеры содержат в себе следующие элементы: размерный текст, размерные линии, выносные линии и стрелки.

Размерный текст указывает величину размера. Размерный текст может включать в себя различные специальные обозначения в виде префиксов и суффиксов, а также допуски.

Размерные линии графически показывают величину размера и его ориентацию на чертеже. В случае углового размера размерная линия представляет собой дугу.

Стрелки ограничивают размерную линию и изображаются на ее концах. Можно задавать размеры и форму стрелок, а также использовать другие обозначения, такие как засечки и точки.

Выносные линии проводятся от объекта к размерной линии.

Маркер центра имеет вид крестика для обозначения центра круга или дуги.

Центровые линии исходят из маркера центра и имеют разрывы в точке центра.


Основные понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Основные понятия
Понятия
Процедуры
Команды

Нет процедур.


Размерные элементы - Команды

Размеры и допуски
Размеры и допуски
Размерные элементы
Понятия
Процедуры
Команды

Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Ассоциативные размеры - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Ассоциативные размеры
Понятия
Процедуры
Команды

Размеры могут быть ассоциативными, неассоциативными и расчлененными. Ассоциативные размеры настраиваются в соответствии с изменениями объектов, к которым они относятся.

Ассоциативность размеров заключается в их связи с геометрическими объектами с нанесенными размерами. Существует три типа ассоциативности между объектами и размерами.

  • Ассоциативные размеры. Автоматически изменяют свое положение, ориентацию и значения величин при редактировании ассоциированных с ними геометрических объектов. Размеры в пространстве листа могут ассоциироваться с объектами в пространстве модели. Для системной переменной DIMASSOC установлено значение 2.
  • Неассоциативные размеры. Выделяются и редактируются вместе с измеряемыми геометрическими объектами. Изменение объектов не оказывает никакого действия на неассоциативные размеры. Системная переменная DIMASSOC равна 1.
  • Расчлененные размеры. Содержат не единые размерные объекты, а наборы отдельных объектов. Для системной переменной DIMASSOC установлено значение 0.

Определить наличие ассоциативной связи размера с объектом можно, выбрав размер и выполнив одно из следующих действий:

  • Посмотреть свойства размера на палитре свойств.
  • Воспользоваться командой СПИСОК для получения значений свойств размера.

Можно также с помощью диалогового окна "Быстрый выбор" выполнить выбор ассоциативных или неассоциативных размеров с применением соответствующего фильтра. Размер считается ассоциативным, даже если с объектом с нанесенными размерами ассоциирован только один его конец. Для отображения ассоциативных или неассоциативных элементов размера можно воспользоваться командой РЗМПРИКРЕПИТЬ.

Особые случаи и ограничения

После панорамирования или зумирования с помощью кнопки-колесика мыши, открытия чертежа, отредактированного и сохраненного в более ранних версиях программы, а также после открытия чертежа с отредактированными внешними ссылками следует использовать команду РЗМРЕГЕН для обновления ассоциативных размеров.

Ассоциативные размеры могут использоваться для многих объектов, однако они неприменимы для следующих типов объектов:

  • штриховки
  • мультилинии
  • двумерные фигуры
  • объекты с ненулевой трехмерной высотой

При выборе объектов для нанесения ассоциативных размеров следует следить, чтобы в набор не входили перекрывающиеся объекты, которые не поддерживают ассоциативные размеры, например, 2D фигура.

Ассоциативность не сохраняется между размером и вхождением блока после того, как блок переопределен.

Ассоциативность не сохраняется между размером и 3D телом после того, как 3D тело изменяется.

Размеры, нанесенные с помощью команды БРАЗМЕР, не являются ассоциативными, но могут быть преобразованы в ассоциативные в индивидуальном порядке командой РЗМПРИКРЕПИТЬ.

Примечание В версиях, предшествующих AutoCAD 2002, ассоциативность размеров определялась системной переменной DIMASO; описания ассоциативных и неассоциативных размеров различались. Теперь же ассоциативность устанавливается системной переменной DIMASSOC.

Подробнее о работе с ассоциативными размерами предыдущих версий см. раздел Сохранение чертежей в форматах прежних версий.

См. также

Изменение ассоциативности размеров


Включение-отключение ассоциативности размеров по умолчанию - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Ассоциативные размеры
Понятия
Процедуры
Команды

Включение-отключение ассоциативности размеров по умолчанию

  1. Нажмите "Сервис" » "Настройки".
  2. В диалоговом окне "Параметры" на вкладке "Пользовательские" в разделе "Ассоциативные размеры" установите или снимите флажок "Делать новые размеры ассоциативными".
  3. Выполните хотя бы одно из предлагаемых действий:
    • Нажмите кнопку "Применить" для сохранения текущих настроек в системном реестре.
    • Нажмите кнопку "OK" для сохранения текущих настроек в системном реестре и закрытия диалогового окна "Параметры".

Все новые размеры создаются с учетом заданных настроек. В отличие от большинства параметров, опция ассоциативности размеров сохраняется в самом чертеже.

Ввод команды: НАСТРОЙКА


Ассоциативные размеры - Команды

Размеры и допуски
Размеры и допуски
Ассоциативные размеры
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
РЗМОТКРЕПИТЬ | Отмена ассоциативности выбранных размеров
РЗМПРИКРЕПИТЬ | Ассоциирование выбранных размеров с геометрическими объектами
РЗМРЕГЕН | Обновление расположения всех ассоциативных размеров
СПИСОК | Получение информации о выбранных объектах из базы данных чертежа
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Размерные стили - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размерные стили
Понятия
Процедуры
Команды

Изменяя определенные параметры, можно управлять внешним видом размеров. При этом использование размерных стилей позволяет быстро форматировать размеры, обеспечивая их соответствие государственным стандартам и стандартам предприятия.

  • Коротко о размерных стилях
  • Сравнение размерных стилей и переменных
    Имеется возможность просмотра всех свойств размерного стиля. Размерные стили, описанные в чертежах, вставленных как внешние ссылки, обрабатываются отдельно от размерных стилей текущего чертежа.
  • Редактирование размерных стилей
    Имеется возможность управления отображением размерных линий, выносных линий, стрелок и маркеров центра.
  • Управление размерным текстом
    Имеется возможность управления размещением размерного текста, стрелок и линий выносок относительно размерных и выносных линий.
  • Форматирование размерных значений
    Для отображения значений размерных чисел можно задавать различные параметры форматирования. Также имеется возможность управления представлением расстояния между числами.


Размерные стили - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размерные стили
Понятия
Процедуры
Команды

Выбор текущего размерного стиля

Получение списка всех параметров текущего размерного стиля

Получение списка параметров имеющегося размерного стиля

Получение списка размерных стилей в текущем чертеже

Сравнение размерных стилей

Форматирование размерных линий

Форматирование выносных линий

Выбор стрелок

Изменение направления стрелки

Использование стрелок собственной разработки

Размещение текста между выносными линиями

Принудительное размещение размерной линии между выносными линиями и выбора режима размещения

Размещение текста вдоль размерной линии

Размещение текста у второй выносной линии

Размещение размерного текста вручную

Размещение текста над размерной линией

Управление текстовым стилем в размерах

Добавление и форматирование основных единиц

Добавление и форматирование альтернативных единиц

Округление размерных значений

Подавление нулей в размерных значениях

Задание способа нанесения двусторонних допусков

Выравнивание допусков и подавление нулей в значениях допусков


Размерные стили - Команды

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размерные стили
Понятия
Процедуры
Команды
Команды
БЛОК | Создание описания блока из выбранных объектов
ПБЛОК | Запись объектов или блока в новый файл чертежа
РЗМРЕДТЕКСТ | Перемещение и поворот размерных текстов
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMALT | Управление альтернативными единицами в размерах.
DIMALTD | Управление количеством десятичных знаков в альтернативных единицах.
DIMALTF | Управление множителем для альтернативных единиц.
DIMALTTD | Установка числа знаков после запятой в значениях допуска для альтернативных размерных единиц
DIMALTTZ | Управление подавлением нулей в значениях допуска.
DIMALTU | Установка формата альтернативных единиц измерения для всех вторичных размерных стилей за исключением угловых.
DIMALTZ | Управление подавлением нулей в альтернативных размерных единицах.
DIMAPOST | Указывает префикс или суффикс текста (или и то, и другое) для альтернативных размерных единиц для всех типов размеров, кроме угловых
DIMASZ | Управление величинами стрелок размерных линий и линий выноски
DIMATFIT | Определение размещения размерного текста и стрелок, если и для текста, и для стрелок недостаточно места в выносных линиях
DIMAUNIT | Установка формата единиц измерения для угловых размеров.
DIMAZIN | Подавление нулевых значений для всех угловых размеров.
DIMBLK | Установка блока стрелок, отображаемого на концах размерных линий или линий выноски.
DIMBLK1 | Установка стрелки на первом конце размерной линии (при включенной переменной DIMSAH).
DIMBLK2 | Установка стрелки на втором конце размерной линии (при включенной переменной DIMSAH).
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
DIMCLRE | Задает цвет для размерных выносных линий.
DIMCLRT | Цвет, которым рисуется размерный текст. Для цвета можно выбрать любой допустимый номер цвета
DIMDEC | Установка числа десятичных знаков, отображаемых для основных единиц размера
DIMDLE | Установка значения расстояния, на которое размерная линия выступает за выносную линию, когда наклонные засечки рисуются вместо стрелок
DIMDLI | Управление расстоянием между размерными линиями в базовых размерах
DIMEXE | Задает величину, на которую выносная линия должна выступать за размерную линию
DIMEXO | Задает величину смещения выносных линий относительно исходных точек
DIMFRAC | Установка формата дроби, если для переменной DIMLUNIT установлено значение 4 (архитектурные) или 5 (дробные)
DIMFXL | Устанавливает общую длину выносных линий от размерной линии до исходной точки размера
DIMFXLON | Управляет установкой фиксированной длины выносных линий
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMJUST | Управление положением размерного текста по горизонтали
DIMLFAC | Установка масштабного коэффициента для значений линейных размеров.
DIMLIM | Создание ограничений размеров в качестве текста по умолчанию
DIMLTEX1 | Устанавливает тип первой выносной линии
DIMLTEX2 | Устанавливает тип второй выносной линии
DIMLTYPE | Устанавливает тип размерной линии
DIMLUNIT | Установка единиц для всех типов размеров, кроме угловых.
DIMLWD | Задание веса для размерных линий.
DIMLWE | Задание веса для выносных линий
DIMPOST | Указание префикса или суффикса текста (или и того, и другого) для размерных единиц
DIMRND | Округление всех размерных расстояний в соответствии с указанным значением
DIMSAH | Управление отображением блоков стрелок размерных линий.
DIMSD1 | Управление подавлением первой размерной линии
DIMSD2 | Управление подавлением второй размерной линии
DIMSE1 | Подавление отображения первой выносной линии
DIMSE2 | Подавление отображения второй выносной линии
DIMSOXD | Подавляет отображение стрелок при отсутствии достаточного пространства между выносными линиями
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
DIMTDEC | Устанавливает количество десятичных знаков для значений допусков в основных единицах
DIMTFAC | Указывает масштабный коэффициент для высоты текста дробных частей размеров и допусков относительно высоты размерного текста, заданной в переменной DIMTXT
DIMTFILL | Управляет фоном размерного текста
DIMTFILLCLR | Устанавливает цвет фона текста в размерах
DIMTIH | Управляет ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями
DIMTIX | Отображает текст между размерными линиями
DIMTM | Устанавливает минимальное (или нижнее) предельное отклонение для размерного текста при включенной переменной DIMTOL или DIMLIM
DIMTOFL | Управляет построением размерной линии между выносными линиями, даже если текст размещается вне линий
DIMTOH | Управляет ориентацией размерного текста за выносными линиями
DIMTOL | Добавление предельных отклонений в конец размерного текста.
DIMTP | Устанавливает максимальное (или верхнее) предельное отклонение для размерного текста при включенной переменной DIMTOL или DIMLIM.
DIMTSZ | Указывает размер засечки, которая наносится вместо стрелки в линейных размерах, радиусах и диаметрах
DIMTVP | Определяет вертикальное положение размерного текста над или под размерной линией
DIMTXSTY | Указывает текстовый стиль для размера
DIMTXT | Указывает высоту размерного текста, если в текстовом стиле не задана фиксированная высота
DIMTZIN | Управляет подавлением нулей в допусках
DIMUPT | Управляет параметрами при пользовательском расположении текста
DIMZIN | Управляет подавлением нулей в основных единицах измерения
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о размерных стилях - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Коротко о размерных стилях
Понятия
Процедуры
Команды

Размерный стиль - это именованный набор размерных параметров, управляющих внешним видом размеров, например стилем стрелок, расположением текста и двусторонними допусками. Использование размерных стилей позволяет быстро форматировать размеры, обеспечивая их соответствие государственным стандартам и стандартам предприятия.

  • При нанесении размера используются параметры текущего размерного стиля
  • При изменении параметров размерного стиля все размеры на чертеже, использующие этот стиль, обновляются автоматически
  • Можно создать размерные подстили для указанных типов размеров, которые отличаются от текущего размерного стиля
  • При необходимости размерный стиль можно на время переопределить.


Выбор текущего размерного стиля - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Коротко о размерных стилях
Понятия
Процедуры
Команды

Выбор текущего размерного стиля

  • Выберите стиль из выпадающего списка "Управление размерными стилями" на панели "Стили".

Ввод команды: РЗМСТИЛЬ


Коротко о размерных стилях - Команды

Размеры и допуски
Размеры и допуски
Коротко о размерных стилях
Понятия
Процедуры
Команды

Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сравнение размерных стилей и переменных - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Сравнение размерных стилей и переменных
Понятия
Процедуры
Команды

Имеется возможность просмотра всех свойств размерного стиля. Размерные стили, описанные в чертежах, вставленных как внешние ссылки, обрабатываются отдельно от размерных стилей текущего чертежа.

Существует возможность получить список размерных стилей чертежа. Можно также просмотреть список значений всех размерных системных переменных или только тех переменных, которые определяются размерным стилем.

При просмотре текущего состояния всех размерных системных переменных отображается список значений с учетом переопределений, применяемых для текущего размерного стиля. Кроме того, имеется возможность получения списка различий параметров между указанным именованным и текущим размерными стилями.

Размерные стили из внешних ссылок

Программа одинаково отображает имена размерных стилей из внешних ссылок и имена других внешне зависимых именованных объектов. В списке стилей Диспетчера размерных стилей каждое имя файла чертежа, вставленного как внешняя ссылка, выводится в виде Xref:имя чертежа, под которым перечисляются имена описанных в нем размерных стилей. Например, если в файле чертежа baseplat.dwg содержится размерный стиль FRACTIONAL-1 и baseplat.dwg прикрепляется как внешняя ссылка к новому чертежу, то в списке стилей Диспетчера размерных стилей отображается размерный стиль внешней ссылки в виде Xref:baseplat.dwg и FRACTIONAL-1 (под именем чертежа).

Стили из внешних ссылок доступны для просмотра, но их нельзя редактировать и задавать текущими. Их можно использовать в качестве шаблонов для создания новых размерных стилей в текущем чертеже.


Сравнение размерных стилей и переменных - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Сравнение размерных стилей и переменных
Понятия
Процедуры
Команды

Получение списка всех параметров текущего размерного стиля

Получение списка параметров имеющегося размерного стиля

Получение списка размерных стилей в текущем чертеже

Сравнение размерных стилей


Получение списка всех параметров текущего размерного стиля - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Сравнение размерных стилей и переменных
Понятия
Процедуры
Команды

Получение списка всех параметров текущего размерного стиля

  1. Нажмите "Размеры" » "Размерные стили".
  2. В списке "Стили" Диспетчера размерных стилей выберите стиль.
  3. Нажмите кнопку "Сравнить".

    4. В списке перечислены размерные системные переменные с текущими параметрами и кратким описанием. Переопределения свойств текущего размерного стиля также отображаются в списке.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Получение списка параметров имеющегося размерного стиля - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Сравнение размерных стилей и переменных
Понятия
Процедуры
Команды

Получение списка параметров имеющегося размерного стиля

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей введите имя нужного стиля или выберите размер, стиль которого нужно просмотреть.
  3. Нажмите кнопку "Сравнить".

    4. В списке перечислены используемые переменные с заданными значениями и кратким описанием. Переопределения свойств выбранного размерного стиля не отображаются в списке.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Получение списка размерных стилей в текущем чертеже - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Сравнение размерных стилей и переменных
Понятия
Процедуры
Команды

Получение списка размерных стилей в текущем чертеже

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей в разделе "Вывести в список" выберите "Все стили" или "Задействованные стили".

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Сравнение размерных стилей - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Сравнение размерных стилей и переменных
Понятия
Процедуры
Команды

Сравнение размерных стилей

  1. Нажмите "Размеры" » "Размерные стили".
  2. В списке "Стили" Диспетчера размерных стилей выберите стиль, который необходимо сравнить.
  3. Нажмите кнопку "Сравнить".

    4. Размерный стиль сравнивается с текущим размерным стилем.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Сравнение размерных стилей и переменных - Команды

Размеры и допуски
Размеры и допуски
Сравнение размерных стилей и переменных
Понятия
Процедуры
Команды

Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование размерных стилей - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размерных стилей
Понятия
Процедуры
Команды

Имеется возможность управления отображением размерных линий, выносных линий, стрелок и маркеров центра.

  • Управление размерными линиями
    Можно изменять свойства размерных линий, включая цвет, толщину и интервал.
  • Управление выносными линиями
    Можно изменять свойства выносных линий, включая цвет, толщину, превышение и длину смещения.
  • Управление стрелками на концах размерных линий
    Символами стрелок у размеров и выносок можно управлять, в том числе их типом, размером и видимостью.
  • Пользовательские стрелки
    Пользователь имеет возможность создавать собственные стрелки.


Редактирование размерных стилей - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размерных стилей
Понятия
Процедуры
Команды

Форматирование размерных линий

Форматирование выносных линий

Выбор стрелок

Изменение направления стрелки

Использование стрелок собственной разработки


Редактирование размерных стилей - Команды

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размерных стилей
Понятия
Процедуры
Команды
Команды
БЛОК | Создание описания блока из выбранных объектов
ПБЛОК | Запись объектов или блока в новый файл чертежа
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMASZ | Управление величинами стрелок размерных линий и линий выноски
DIMBLK | Установка блока стрелок, отображаемого на концах размерных линий или линий выноски.
DIMBLK1 | Установка стрелки на первом конце размерной линии (при включенной переменной DIMSAH).
DIMBLK2 | Установка стрелки на втором конце размерной линии (при включенной переменной DIMSAH).
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
DIMCLRE | Задает цвет для размерных выносных линий.
DIMDLE | Установка значения расстояния, на которое размерная линия выступает за выносную линию, когда наклонные засечки рисуются вместо стрелок
DIMDLI | Управление расстоянием между размерными линиями в базовых размерах
DIMEXE | Задает величину, на которую выносная линия должна выступать за размерную линию
DIMEXO | Задает величину смещения выносных линий относительно исходных точек
DIMFXL | Устанавливает общую длину выносных линий от размерной линии до исходной точки размера
DIMFXLON | Управляет установкой фиксированной длины выносных линий
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMLTEX1 | Устанавливает тип первой выносной линии
DIMLTEX2 | Устанавливает тип второй выносной линии
DIMLTYPE | Устанавливает тип размерной линии
DIMLWD | Задание веса для размерных линий.
DIMLWE | Задание веса для выносных линий
DIMSAH | Управление отображением блоков стрелок размерных линий.
DIMSD1 | Управление подавлением первой размерной линии
DIMSD2 | Управление подавлением второй размерной линии
DIMSE1 | Подавление отображения первой выносной линии
DIMSE2 | Подавление отображения второй выносной линии
DIMSOXD | Подавляет отображение стрелок при отсутствии достаточного пространства между выносными линиями
DIMTOFL | Управляет построением размерной линии между выносными линиями, даже если текст размещается вне линий
DIMTSZ | Указывает размер засечки, которая наносится вместо стрелки в линейных размерах, радиусах и диаметрах
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление размерными линиями - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Управление размерными линиями
Понятия
Процедуры
Команды

Можно изменять свойства размерных линий, включая цвет, толщину и интервал.

Имеется возможность изменения различных свойств размерных линий. Существует возможность:

  • Указывать цвет и толщину линии для визуального эффекта и печати.
  • Отключать отображение размерной линии или, если она разделена текстом, одну или обе ее половины.

  • Задавать интервал между соседними размерными линиями в базовых размерах.

  • Указывать расстояние, на которое размерная линия выходит за выносные линии, для окончаний размерных линий на строительных чертежах (с наклонными засечками).


Форматирование размерных линий - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Управление размерными линиями
Понятия
Процедуры
Команды

Форматирование размерных линий

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Линии" измените параметры в разделе "Размерные линии".
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Управление размерными линиями - Команды

Размеры и допуски
Размеры и допуски
Управление размерными линиями
Понятия
Процедуры
Команды

Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
DIMDLE | Установка значения расстояния, на которое размерная линия выступает за выносную линию, когда наклонные засечки рисуются вместо стрелок
DIMDLI | Управление расстоянием между размерными линиями в базовых размерах
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMLTYPE | Устанавливает тип размерной линии
DIMLWD | Задание веса для размерных линий.
DIMSD1 | Управление подавлением первой размерной линии
DIMSD2 | Управление подавлением второй размерной линии
DIMSOXD | Подавляет отображение стрелок при отсутствии достаточного пространства между выносными линиями
DIMTOFL | Управляет построением размерной линии между выносными линиями, даже если текст размещается вне линий
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление выносными линиями - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Управление выносными линиями
Понятия
Процедуры
Команды

Можно изменять свойства выносных линий, включая цвет, толщину, превышение и длину смещения.

Можно изменять различные свойства выносных линий. Существует возможность:

  • Указывать цвет и толщину линии для визуального эффекта и печати.
  • Отключать отображение одной или обеих выносных линий ("подавлять"), если они не используются или при недостатке места.

  • Указывать расстояние, на которое выносные линии выходят за размерную (удлинение).

  • Указывать отступ исходной точки удлинения, расстояние между исходной точкой выносной линии и ее началом.

  • Указывать фиксированную длину выносных линий - расстояние от размерной линии до исходной точки выносной линии.

  • Указывать тип прерывистой линии, обычно используемый для центровых линий.

  • Изменять угол выносных линий выбранного размера, делая их наклонными.

Выносные линии фиксированной длины

С помощью Диспетчера размерных стилей на вкладке "Линии" можно указать размерный стиль, устанавливающий полную длину выносных линий от размерной линии до исходной точки размера.

Расстояние отступа выносной линии от исходной точки никогда не будет меньше значения, указанного системной переменной DIMEXO.

См. также

Нанесение размеров с наклонными выносными линиями


Форматирование выносных линий - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Управление выносными линиями
Понятия
Процедуры
Команды

Форматирование выносных линий

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Линии" в разделе "Выносные линии" измените необходимые параметры.
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Управление выносными линиями - Команды

Размеры и допуски
Размеры и допуски
Управление выносными линиями
Понятия
Процедуры
Команды

Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMCLRE | Задает цвет для размерных выносных линий.
DIMDLE | Установка значения расстояния, на которое размерная линия выступает за выносную линию, когда наклонные засечки рисуются вместо стрелок
DIMEXE | Задает величину, на которую выносная линия должна выступать за размерную линию
DIMEXO | Задает величину смещения выносных линий относительно исходных точек
DIMFXL | Устанавливает общую длину выносных линий от размерной линии до исходной точки размера
DIMFXLON | Управляет установкой фиксированной длины выносных линий
DIMLTEX1 | Устанавливает тип первой выносной линии
DIMLTEX2 | Устанавливает тип второй выносной линии
DIMLWE | Задание веса для выносных линий
DIMSE1 | Подавление отображения первой выносной линии
DIMSE2 | Подавление отображения второй выносной линии
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление стрелками на концах размерных линий - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Управление стрелками на концах размерных линий
Понятия
Процедуры
Команды

Символами стрелок у размеров и выносок можно управлять, в том числе их типом, размером и видимостью.

Можно выбрать стандартные типы стрелок или создать собственные. Дополнительные возможности:

  • Подавление отображения стрелок или использование только одной стрелки.
  • Использование различного типа стрелок на каждом конце размерной линии.
  • Управление размером стрелок.
  • Изменение направления стрелки с помощью контекстного меню размера.

Примечание Отраженные стрелки сохраняют свой внешний вид, начиная с версии AutoCAD 2002. Тем не менее, при редактировании чертежа с отраженными стрелками в более ранних версиях, чем AutoCAD 2006, направления стрелок будут возвращены к исходным.

См. также

Пользовательские стрелки


Управление стрелками на концах размерных линий - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Управление стрелками на концах размерных линий
Понятия
Процедуры
Команды

Выбор стрелок

Изменение направления стрелки


Выбор стрелок - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Управление стрелками на концах размерных линий
Понятия
Процедуры
Команды

Выбор стрелок

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Символы и стрелки" в разделе "Стрелки" выберите тип стрелки на первом конце размерной линии.

    4. Тип второй стрелки автоматически устанавливается таким же.

  4. Для установки другого типа стрелки на втором конце размерной линии выберите необходимый тип во втором списке.
  5. Введите величину размерных стрелок в поле "Величина".
  6. Нажмите "ОК".
  7. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Изменение направления стрелки - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Управление стрелками на концах размерных линий
Понятия
Процедуры
Команды

Изменение направления стрелки

  1. В командной строке выберите один объект размера рядом со стрелкой, направление которой необходимо изменить.
  2. Нажмите правую кнопку мыши. Выберите "Перевернуть стрелку".


Управление стрелками на концах размерных линий - Команды

Размеры и допуски
Размеры и допуски
Управление стрелками на концах размерных линий
Понятия
Процедуры
Команды

Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
DIMDLE | Установка значения расстояния, на которое размерная линия выступает за выносную линию, когда наклонные засечки рисуются вместо стрелок
DIMSD1 | Управление подавлением первой размерной линии
DIMSD2 | Управление подавлением второй размерной линии
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Пользовательские стрелки - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Пользовательские стрелки
Понятия
Процедуры
Команды

Пользователь имеет возможность создавать собственные стрелки.

Стрелки сохраняются как описания блоков. Для создания своих стрелок необходимо описать блок и присвоить ему имя. Подробнее о создании блоков см. раздел Создание блоков в чертеже.

Окончательная величина стрелок зависит от глобального масштабного коэффициента размеров для чертежа. При нанесении размера происходит вставка блока в типовое место расположения стрелок. Для масштабных коэффициентов X и Y объекта задаётся значение глобальный масштабный коэффициентразмерной стрелки . Размерная линия обрезается с соблюдением зазоров размерного текста, определяемых умножением заданной величины зазора и глобального масштабного коэффициента. Чтобы обрезать размерную линию, крайний правый блок вставляется с нулевым углом поворота для горизонтального размера. Крайний левый блок поворачивается на 180 градусов вокруг точки вставки.

При использовании масштабирования пространства листа вычисление масштабного коэффициента происходит перед применением к значению размера стрелки.


Использование стрелок собственной разработки - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Пользовательские стрелки
Понятия
Процедуры
Команды

Использование стрелок собственной разработки

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. В Диспетчере размерных стилей на вкладке "Символы и стрелки" в разделе "Стрелки" в списке первой стрелки выберите "Пользовательская".
  4. В диалоговом окне "Выбор блока пользовательской стрелки" введите имя блока. Нажмите "ОК".
  5. Для установки второй пользовательской стрелки, отличающейся от первой, повторите действия пунктов 3 и 4, выбрав "Пользовательская" и в списке второй стрелки (не обязательно) .
  6. Нажмите "ОК".
  7. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Пользовательские стрелки - Команды

Размеры и допуски
Размеры и допуски
Пользовательские стрелки
Понятия
Процедуры
Команды

Команды
БЛОК | Создание описания блока из выбранных объектов
ПБЛОК | Запись объектов или блока в новый файл чертежа
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMASZ | Управление величинами стрелок размерных линий и линий выноски
DIMBLK | Установка блока стрелок, отображаемого на концах размерных линий или линий выноски.
DIMBLK1 | Установка стрелки на первом конце размерной линии (при включенной переменной DIMSAH).
DIMBLK2 | Установка стрелки на втором конце размерной линии (при включенной переменной DIMSAH).
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
DIMDLE | Установка значения расстояния, на которое размерная линия выступает за выносную линию, когда наклонные засечки рисуются вместо стрелок
DIMSAH | Управление отображением блоков стрелок размерных линий.
DIMTSZ | Указывает размер засечки, которая наносится вместо стрелки в линейных размерах, радиусах и диаметрах
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление размерным текстом - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Управление размерным текстом
Понятия
Процедуры
Команды

Имеется возможность управления размещением размерного текста, стрелок и линий выносок относительно размерных и выносных линий.

  • Размещение размерного текста между выносными линиями
    Как правило, размерный текст и стрелки располагаются между выносными линиями. Однако, в случае нехватки места, можно изменять расположение этих размерных элементов.
  • Размещение размерного текста
    Имеется возможность вручную указывать положение размерного текста, а также задавать его выравнивание и ориентацию.
  • Внешний вид размерного текста
    Размерный текст может содержать различные префиксы и суффиксы, а также другие определенные пользователем текстовые элементы. Можно также задать текстовый стиль и изменить параметры форматирования размерного текста.


Управление размерным текстом - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Управление размерным текстом
Понятия
Процедуры
Команды

Размещение текста между выносными линиями

Принудительное размещение размерной линии между выносными линиями и выбора режима размещения

Размещение текста вдоль размерной линии

Размещение текста у второй выносной линии

Размещение размерного текста вручную

Размещение текста над размерной линией

Управление текстовым стилем в размерах


Управление размерным текстом - Команды

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Управление размерным текстом
Понятия
Процедуры
Команды
Команды
РЗМРЕДТЕКСТ | Перемещение и поворот размерных текстов
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMATFIT | Определение размещения размерного текста и стрелок, если и для текста, и для стрелок недостаточно места в выносных линиях
DIMCLRT | Цвет, которым рисуется размерный текст. Для цвета можно выбрать любой допустимый номер цвета
DIMFRAC | Установка формата дроби, если для переменной DIMLUNIT установлено значение 4 (архитектурные) или 5 (дробные)
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMJUST | Управление положением размерного текста по горизонтали
DIMLWD | Задание веса для размерных линий.
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
DIMTFAC | Указывает масштабный коэффициент для высоты текста дробных частей размеров и допусков относительно высоты размерного текста, заданной в переменной DIMTXT
DIMTFILL | Управляет фоном размерного текста
DIMTFILLCLR | Устанавливает цвет фона текста в размерах
DIMTIH | Управляет ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями
DIMTIX | Отображает текст между размерными линиями
DIMTOFL | Управляет построением размерной линии между выносными линиями, даже если текст размещается вне линий
DIMTOH | Управляет ориентацией размерного текста за выносными линиями
DIMTVP | Определяет вертикальное положение размерного текста над или под размерной линией
DIMTXSTY | Указывает текстовый стиль для размера
DIMTXT | Указывает высоту размерного текста, если в текстовом стиле не задана фиксированная высота
DIMUPT | Управляет параметрами при пользовательском расположении текста
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Размещение размерного текста между выносными линиями - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размещение размерного текста между выносными линиями
Понятия
Процедуры
Команды

Как правило, размерный текст и стрелки располагаются между выносными линиями. Однако, в случае нехватки места, можно изменять расположение этих размерных элементов.

На результат размещения текста и стрелок между выносными линиями влияют различные факторы, в том числе расстояние между выносными линиями и величина стрелок. Обычно выбирается оптимальное расположение объектов, обеспечивающее наличие свободного места. Если есть возможность, текст и стрелки размещаются между выносными линиями, независимо от установленных опций размещения.

При создании новых размеров можно вручную задавать положение размерного текста путем ввода координат с клавиатуры или указанием точки с помощью устройства указания. В противном случае программа вычислит наилучшее расположение текста. Режимы автоматического размещения размерного текста и стрелок задаются на вкладке "Размещение" диалогового окна работы с размерными стилями. Например, можно установить такой режим, чтобы текст и стрелки размещались одинаковым способом. В этом случае, если между выносными линиями недостаточно места хотя бы для одного из элементов, то и размерный текст, и стрелки наносятся вне выносных линий. И наоборот, можно задать опции таким образом, чтобы между выносными линиями размещались либо стрелки, либо текст при наличии достаточного места для размещения хотя бы одного их этих элементов.

На следующих иллюстрациях показано определение программой оптимального расположения для стрелок и текста.

Если между выносными линиями недостаточно места для размещения текста, то имеется возможность автоматического создания выноски. Такой способ наиболее предпочтителен в тех случаях, когда при размещении вне выносных линий текст наезжает на другие элементы, например, при построении размерной цепи. Сторона, где должен располагаться текст относительно выноски, определяется режимом горизонтального выравнивания, заданного на вкладке "Текст" диалогового окна работы с размерными стилями. Положение размерного текста и стрелок можно сохранить между выносными линиями, изменяя их величину.

Даже если стрелки наносятся вне выносных линий, можно провести размерную линию между выносными. Пример такого принудительного размещения размерной линии показан на следующем чертеже.

Размещение текста на диаметре

Можно наносить несколько разных размеров диаметров в зависимости от размещения текста, режима горизонтального выравнивания, задаваемого на вкладке "Текст", и параметра "Размерная линия между выносными", устанавливаемого на вкладке "Размещение".


Размещение размерного текста между выносными линиями - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размещение размерного текста между выносными линиями
Понятия
Процедуры
Команды

Размещение текста между выносными линиями

Принудительное размещение размерной линии между выносными линиями и выбора режима размещения


Размещение текста между выносными линиями - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размещение размерного текста между выносными линиями
Понятия
Процедуры
Команды

Размещение текста между выносными линиями

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Размещение" диалогового окна "Изменение размерного стиля" в группе "Опции размещения" задайте нужный режим.
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

    6. Если имеется достаточно места, текст размещается между выносными линиями.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Принудительное размещение размерной линии между выносными линиями и выбора режима размещения - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размещение размерного текста между выносными линиями
Понятия
Процедуры
Команды

Принудительное размещение размерной линии между выносными линиями и выбора режима размещения

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Размещение" диалогового окна "Изменение размерного стиля" в группе "Подгонка элементов" установите флажок "Размерная линия между выносными".
  4. В группе "Опции размещения" установите нужный режим.
  5. Нажмите "ОК".
  6. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Размещение размерного текста между выносными линиями - Команды

Размеры и допуски
Размеры и допуски
Размещение размерного текста между выносными линиями
Понятия
Процедуры
Команды

Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMATFIT | Определение размещения размерного текста и стрелок, если и для текста, и для стрелок недостаточно места в выносных линиях
DIMJUST | Управление положением размерного текста по горизонтали
DIMLWD | Задание веса для размерных линий.
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
DIMTIH | Управляет ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями
DIMTIX | Отображает текст между размерными линиями
DIMTOFL | Управляет построением размерной линии между выносными линиями, даже если текст размещается вне линий
DIMTOH | Управляет ориентацией размерного текста за выносными линиями
DIMTVP | Определяет вертикальное положение размерного текста над или под размерной линией
DIMUPT | Управляет параметрами при пользовательском расположении текста
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Размещение размерного текста - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размещение размерного текста
Понятия
Процедуры
Команды

Имеется возможность вручную указывать положение размерного текста, а также задавать его выравнивание и ориентацию.

В программе доступно несколько параметров для выравнивания, соответствующих международным стандартам. Также можно выбирать местоположение текста.

Многие параметры размещения взаимозависимы. В Диспетчере размерных стилей выводится пример изображения, обновляемый каждый раз при смене параметров для показа результата размещения размерного текста.

Параллельный размерный текст

Независимо от того, размещается ли размерный текст между выносными линиями или снаружи, имеется возможность задания ориентации текста как вдоль размерной линии, так и в горизонтальном направлении. На следующих чертежах показаны оба этих режима.

По умолчанию установлена горизонтальная ориентация размерного текста даже для вертикальных размеров.

Положение размерного текста по горизонтали

Положение текста вдоль размерной линии по отношению к выносным линиям называют размещением текста. Для произвольного размещения текста при нанесении размера следует включить опцию "Размещение текста вручную" на вкладке "Размещение" диалогового окна работы с размерными стилями. Для автоматического размещения текста в центре размерной линии или у одной из выносных линий используются опции размещения, устанавливающие нужный режим.

Первая и вторая выносные линии определяются последовательностью указания начальных точек выносных линий во время построения размера. Для угловых размеров вторая выносная линия повернута в направлении против часовой стрелки от первой. На следующем чертеже цифрой 1 обозначена первая начальная точка выносных линий, цифрой 2 - вторая.

При размещении текста создаваемого размера вручную имеется возможность указания положения текста в любом месте вдоль размерной линии, между выносными линиями или снаружи. Этот режим позволяет наиболее оптимально размещать текст при наличии очень ограниченного места. Однако при использовании горизонтальной ориентации размерного текста достигается большая аккуратность нанесения последовательности размеров.

Положение размерного текста по вертикали

Положение текста по отношению к размерной линии называют вертикальными размещением текста. Текст может размещаться над или под размерной линией, а также в центре размерной линии. В соответствии со стандартами ANSI, размерный текст обычно размещается в центре, разрывая размерную линию. Стандарты ISO предусматривают расположение размерного текста над размерной линией или за пределами объекта на который наносятся размеры. На следующих чертежах показаны примеры допустимого по стандартам ISO нанесения размерного текста.

На размерный текст влияют и другие параметры, например "Ориентация текста". Так, если установлена горизонтальная ориентация, то текст, размещаемый между выносными линиями в центре размерной линии, ориентируется горизонтально, как показано на левом чертеже выше. Здесь ориентация текста сохраняется горизонтальной даже в том случае, когда размерная линия не расположена горизонтально.


Размещение размерного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размещение размерного текста
Понятия
Процедуры
Команды

Размещение текста вдоль размерной линии

Размещение текста у второй выносной линии

Размещение размерного текста вручную

Размещение текста над размерной линией


Размещение текста вдоль размерной линии - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размещение размерного текста
Понятия
Процедуры
Команды

Размещение текста вдоль размерной линии

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Текст" диалогового окна "Изменение размерного стиля" в группе "Ориентация текста" установить опцию "Вдоль размерной линии".
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Размещение текста у второй выносной линии - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размещение размерного текста
Понятия
Процедуры
Команды

Размещение текста у второй выносной линии

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Текст" диалогового окна "Изменение размерного стиля" в группе "Выравнивание текста" из списка "По горизонтали" выберите опцию "У 2-й выносной".

    4. Изменение параметров вызывает обновление образца изображения.

  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Размещение размерного текста вручную - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размещение размерного текста
Понятия
Процедуры
Команды

Размещение размерного текста вручную

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Размещение" диалогового окна "Изменение размерного стиля" в группе "Подгонка элементов" включите опцию "Размещение текста вручную".
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

    6. При создании размера можно перемещать текст вдоль размерной линии. Для задания положения размерной линии и текста можно воспользоваться устройством указания или ввести координаты с клавиатуры.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Размещение текста над размерной линией - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Размещение размерного текста
Понятия
Процедуры
Команды

Размещение текста над размерной линией

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Текст" диалогового окна "Изменение размерного стиля" в группе "Выравнивание текста" из списка "По вертикали" выберите опцию "Над линией".

    4. Изменение параметров вызывает обновление образца изображения.

  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Размещение размерного текста - Команды

Размеры и допуски
Размеры и допуски
Размещение размерного текста
Понятия
Процедуры
Команды

Команды
РЗМРЕДТЕКСТ | Перемещение и поворот размерных текстов
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMJUST | Управление положением размерного текста по горизонтали
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
DIMTIH | Управляет ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями
DIMTOH | Управляет ориентацией размерного текста за выносными линиями
DIMTVP | Определяет вертикальное положение размерного текста над или под размерной линией
DIMUPT | Управляет параметрами при пользовательском расположении текста
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Внешний вид размерного текста - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Внешний вид размерного текста
Понятия
Процедуры
Команды

Размерный текст может содержать различные префиксы и суффиксы, а также другие определенные пользователем текстовые элементы. Можно также задать текстовый стиль и изменить параметры форматирования размерного текста.

Программа позволяет работать с разнообразными текстовыми элементами, определяемыми пользователем, префиксами и суффиксами, поддерживаемыми размерным стилем, а также сгенерированными значениями размеров. Например, можно добавить символ диаметра в качестве префикса измерения или сокращение (например, мм) для единицы измерения в качестве суффикса. Описывать таким образом можно любой размерный текст, применяя любые доступные префиксы и суффиксы, основные и альтернативные единицы, а также обозначение двустороннего допуска. Допуски формы и расположения определяются независимо.

Размерный текст представляет из себя однострочный текст, который можно создайте и отформатировать с помощью текстового редактора.

Управление текстовым стилем в размерах

Внешний вид размерного текста зависит от текстового стиля, заданного с помощью Диспетчера размерных стилей на вкладке "Текст". В процессе создания размерного стиля можно выбрать текстовый стиль и задать цвет текста и высоту символов независимо от настроек текущего текстового стиля чертежа. Кроме того, можно указать величину зазора между базовой линией текста и окружающей рамкой.

Для размеров используются те же текстовые стили, что и для текстовых объектов чертежа.

Дополнительную информацию см. в разделе Работа с текстовыми стилями.

Пользовательский размерный текст

Кроме стандартных префиксов и суффиксов для основных и альтернативных единиц, пользователь может наносить свои тексты при создании размеров. С помощью префиксов, суффиксов и пользовательских текстов формируются однострочные тексты, к которым можно добавлять допуски, а также редактировать и форматировать с помощью текстового редактора.

Для размещения пользовательского текста над размерной линией и под ней используется символ разделителя \X. Текст, предшествующий этому символу, располагается над размерной линией и выравнивается вдоль нее. Текст, следующий за разделителем \X, располагается под размерной линией и ориентирован вдоль нее. Зазор между текстом и размерной линией определяется значением, вводимым в поле "Отступ от размерной линии" на вкладке "Текст".

Пример: пользовательский размерный текст

В данном примере величина размера в основных единицах измерения равна 5,08, а в альтернативных единицах - 2,00. У размера в основных единицах имеется суффикс H7/h6, а размер в альтернативных единицах содержит суффикс, обозначающий дюймы.

При создании размера в ответ на запрос вводится следующая строка, описывающая формат размерного текста:

<> H7/h6\XСм. примечание 26\P[ ]

Угловые скобки представляют значение величины в основных единицах, квадратные скобки значение в альтернативных единицах. Разделителем \X строка разбивается на две части; первая часть размещается над размерной линией, вторая под размерной линией. Обозначение \P указывает на конец абзаца.

В результате размерный текст имеет следующий вид:


Управление текстовым стилем в размерах - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Внешний вид размерного текста
Понятия
Процедуры
Команды

Управление текстовым стилем в размерах

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Текст" диалогового окна "Изменение размерного стиля" в группе "Свойства текста" выберите текстовый стиль.
  4. Если в текстовом стиле не задана фиксированная высота, то укажите высоту символов размерного текста в поле "Высота текста".
  5. На вкладке "Допуски" в поле "Масштаб высоты" введите значение высоты текста для отклонений.
  6. В поле "Отступ от размерной линии" (на вкладке "Текст") введите величину зазора, окружающего текст при его расположении в разрыве размерной линии.
  7. В списке "Цвет текста" выберите цвет.
  8. Нажмите кнопку "ОК".
  9. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Внешний вид размерного текста - Команды

Размеры и допуски
Размеры и допуски
Внешний вид размерного текста
Понятия
Процедуры
Команды

Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMCLRT | Цвет, которым рисуется размерный текст. Для цвета можно выбрать любой допустимый номер цвета
DIMFRAC | Установка формата дроби, если для переменной DIMLUNIT установлено значение 4 (архитектурные) или 5 (дробные)
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMTFAC | Указывает масштабный коэффициент для высоты текста дробных частей размеров и допусков относительно высоты размерного текста, заданной в переменной DIMTXT
DIMTFILL | Управляет фоном размерного текста
DIMTFILLCLR | Устанавливает цвет фона текста в размерах
DIMTXSTY | Указывает текстовый стиль для размера
DIMTXT | Указывает высоту размерного текста, если в текстовом стиле не задана фиксированная высота
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Форматирование размерных значений - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Форматирование размерных значений
Понятия
Процедуры
Команды

Для отображения значений размерных чисел можно задавать различные параметры форматирования. Также имеется возможность управления представлением расстояния между числами.

  • Форматирование размерных единиц
    Числовые значения измеряемых величин могут наноситься на размерах как в одной системе измерений, так и в двух. В любом случае, существует возможность задавать формат отображаемых значений.
  • Округление размерных величин
    Все значения размерных чисел, включая двусторонние допуски, можно округлять.
  • Подавление нулей в размерных значениях
    Отображение ведущих и замыкающих нулей в числовых значениях размерного текста можно подавлять.
  • Нанесение двусторонних допусков
    Допуски показывают пределы, в которых может колебаться размер. Можно управлять отображением двусторонних допусков, стили которых можно выбирать.


Форматирование размерных значений - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Форматирование размерных значений
Понятия
Процедуры
Команды

Добавление и форматирование основных единиц

Добавление и форматирование альтернативных единиц

Округление размерных значений

Подавление нулей в размерных значениях

Задание способа нанесения двусторонних допусков

Выравнивание допусков и подавление нулей в значениях допусков


Форматирование размерных значений - Команды

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Форматирование размерных значений
Понятия
Процедуры
Команды
Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMALT | Управление альтернативными единицами в размерах.
DIMALTD | Управление количеством десятичных знаков в альтернативных единицах.
DIMALTF | Управление множителем для альтернативных единиц.
DIMALTTD | Установка числа знаков после запятой в значениях допуска для альтернативных размерных единиц
DIMALTTZ | Управление подавлением нулей в значениях допуска.
DIMALTU | Установка формата альтернативных единиц измерения для всех вторичных размерных стилей за исключением угловых.
DIMALTZ | Управление подавлением нулей в альтернативных размерных единицах.
DIMAPOST | Указывает префикс или суффикс текста (или и то, и другое) для альтернативных размерных единиц для всех типов размеров, кроме угловых
DIMAUNIT | Установка формата единиц измерения для угловых размеров.
DIMAZIN | Подавление нулевых значений для всех угловых размеров.
DIMDEC | Установка числа десятичных знаков, отображаемых для основных единиц размера
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMLFAC | Установка масштабного коэффициента для значений линейных размеров.
DIMLIM | Создание ограничений размеров в качестве текста по умолчанию
DIMLUNIT | Установка единиц для всех типов размеров, кроме угловых.
DIMPOST | Указание префикса или суффикса текста (или и того, и другого) для размерных единиц
DIMRND | Округление всех размерных расстояний в соответствии с указанным значением
DIMTDEC | Устанавливает количество десятичных знаков для значений допусков в основных единицах
DIMTFAC | Указывает масштабный коэффициент для высоты текста дробных частей размеров и допусков относительно высоты размерного текста, заданной в переменной DIMTXT
DIMTM | Устанавливает минимальное (или нижнее) предельное отклонение для размерного текста при включенной переменной DIMTOL или DIMLIM
DIMTOL | Добавление предельных отклонений в конец размерного текста.
DIMTP | Устанавливает максимальное (или верхнее) предельное отклонение для размерного текста при включенной переменной DIMTOL или DIMLIM.
DIMTZIN | Управляет подавлением нулей в допусках
DIMZIN | Управляет подавлением нулей в основных единицах измерения
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Форматирование размерных единиц - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Форматирование размерных единиц
Понятия
Процедуры
Команды

Числовые значения измеряемых величин могут наноситься на размерах как в одной системе измерений, так и в двух. В любом случае, существует возможность задавать формат отображаемых значений.

Параметры настройки основных единиц позволяют управлять выводом размерных значений. Можно форматировать размерные единицы, а также задавать такие свойства, как точность представления числовых значений и вид десятичного разделителя. Например, можно задать в качестве префикса обозначение диаметра, как показано на чертеже. Любой заданный префикс заменяет префиксы, обычно используемые для размеров диаметра и радиуса (символ Юникод 2205 и R, соответственно).

Все эти параметры задаются на вкладке "Основные единицы" Диспетчера размерных стилей.

Форматирование альтернативных единиц

Пользователь может наносить размеры с указанием величин сразу в двух системах единиц. Обычно такая возможность используется для проставления значений размеров в метрических единицах, если чертеж выполнен в британских единицах, и наоборот. Величина размера в альтернативных единицах наносится в квадратных скобках [ ] в размерном тексте. Альтернативные единицы не могут использоваться при нанесении угловых размеров.

Если включен режим альтернативных единиц, то выводимые значения в альтернативных единицах получаются путем умножения значений в основных единицах на заданный коэффициент пересчета. Этот коэффициент представляет число альтернативных единиц в одной текущей размерной единице. По умолчанию для основных британских единиц принимается коэффициент 25,4, используемый для пересчета дюймов в миллиметры. По умолчанию для основных метрических единиц коэффициент составляет примерно 0,0394, что равно количеству дюймов в миллиметре. Количество десятичных знаков устанавливается параметром точности альтернативных единиц.

Например, если основными являются британские единицы, для коэффициента пересчета задано значение 25,4, а для точности - 0,00, то размеры могут иметь такой вид:


Форматирование размерных единиц - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Форматирование размерных единиц
Понятия
Процедуры
Команды

Добавление и форматирование основных единиц

Добавление и форматирование альтернативных единиц


Добавление и форматирование основных единиц - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Форматирование размерных единиц
Понятия
Процедуры
Команды

Добавление и форматирование основных единиц

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Основные единицы" диалогового окна "Изменение размерного стиля" в группах "Линейные размеры" и "Угловые размеры" задайте параметры форматирования и точность основных единиц.
  4. В группе "Линейные размеры" введите префикс и суффикс для размеров.
  5. Нажмите "ОК".
  6. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Добавление и форматирование альтернативных единиц - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Форматирование размерных единиц
Понятия
Процедуры
Команды

Добавление и форматирование альтернативных единиц

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Альт. единицы" диалогового окна "Изменение размерного стиля" установить флажок "Разрешить альтернативные единицы".
  4. В группе "Альтернативные единицы":
    • Выберите формат единиц из списка.
    • Задайте точность значений для альтернативных единиц.
    • Введите любые префикс и суффикс для нанесения размеров. Здесь можно использовать символ пробела для задания интервала между префиксом или суффиксом и размерным значением.
  5. Нажмите "ОК".
  6. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Форматирование размерных единиц - Команды

Размеры и допуски
Размеры и допуски
Форматирование размерных единиц
Понятия
Процедуры
Команды

Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMALT | Управление альтернативными единицами в размерах.
DIMALTD | Управление количеством десятичных знаков в альтернативных единицах.
DIMALTF | Управление множителем для альтернативных единиц.
DIMALTTD | Установка числа знаков после запятой в значениях допуска для альтернативных размерных единиц
DIMALTU | Установка формата альтернативных единиц измерения для всех вторичных размерных стилей за исключением угловых.
DIMALTZ | Управление подавлением нулей в альтернативных размерных единицах.
DIMAPOST | Указывает префикс или суффикс текста (или и то, и другое) для альтернативных размерных единиц для всех типов размеров, кроме угловых
DIMAUNIT | Установка формата единиц измерения для угловых размеров.
DIMDEC | Установка числа десятичных знаков, отображаемых для основных единиц размера
DIMLFAC | Установка масштабного коэффициента для значений линейных размеров.
DIMLUNIT | Установка единиц для всех типов размеров, кроме угловых.
DIMPOST | Указание префикса или суффикса текста (или и того, и другого) для размерных единиц
DIMTDEC | Устанавливает количество десятичных знаков для значений допусков в основных единицах
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Округление размерных величин - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Округление размерных величин
Понятия
Процедуры
Команды

Все значения размерных чисел, включая двусторонние допуски, можно округлять.

Все значения размерных чисел, кроме угловых размеров, можно округлить. Например, если задать точность 0,25, все измеренные расстояния будут округлены до ближайшего кратного 0,25. Число десятичных знаков в дробной части зависит от точности, заданной для основных и альтернативных единиц, а также для двусторонних допусков.


Округление размерных значений - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Округление размерных величин
Понятия
Процедуры
Команды

Округление размерных значений

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Основные единицы" диалогового окна "Изменение размерного стиля" в группе "Линейные размеры" введите значения в поле "Округление".
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Округление размерных величин - Команды

Размеры и допуски
Размеры и допуски
Округление размерных величин
Понятия
Процедуры
Команды

Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMRND | Округление всех размерных расстояний в соответствии с указанным значением
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Подавление нулей в размерных значениях - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Подавление нулей в размерных значениях
Понятия
Процедуры
Команды

Отображение ведущих и замыкающих нулей в числовых значениях размерного текста можно подавлять.

Если включить подавление ведущих нулей, то значение 0,500 выводится как ,500. При подавлении замыкающих нулей 0,500 записывается как 0,5. При подавлении и тех и других нулей 0,5000 записывается как ,5, а 0,0000 как 0.

В следующей таблице представлены результаты подавления нулей в архитектурных единицах. Флажок подавления нулей не распространяется на значения в дюймах, выраженные с помощью дробей. Например, значение 4'-3/4" записывается как 4'-0 3/4".

Подавление нулей для футов и дюймов
Флажок | Воздействие | Примеры
Флажки не установлены | Нулевые значения записываются и для футов, и для дюймов. | 0'-0 1/2" | 0'-6" | 1'-0" | 1'-0 3/4"
Установлен флажок "0 дюймов" | Нулевые значения подавляются для дюймов (записываются только для футов) | 0'-0 1/2" | 0'-6" | 1' | 1'-0 3/4"
Установлен флажок "0 футов" | Нулевые значения подавляются для футов (записываются только для дюймов) | 1/2" | 6" | 1'-0" | 1'-0 3/4"
Установлены флажки "0 футов" и "0 дюймов" | Нулевые значения подавляются и для футов, и для дюймов. | 1/2" | 6" | 1' | 1'-0 3/4"


Подавление нулей в размерных значениях - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Подавление нулей в размерных значениях
Понятия
Процедуры
Команды

Подавление нулей в размерных значениях

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Основные единицы" или "Альт. единицы" диалогового окна "Изменение размерного стиля" в группах "Подавление нулей" установить любые из следующих опций:
    • Ведущие. Подавление ведущих нулей в десятичных значениях.
    • Замыкающие. Подавление хвостовых нулей в десятичных значениях.
    • 0 футов. Подавление отображения значения "0 футов" в размере формата футы-дюймы.
    • 0 дюймов. Подавление отображения значения "0 дюймов" в размере формата футы-дюймы.
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Подавление нулей в размерных значениях - Команды

Размеры и допуски
Размеры и допуски
Подавление нулей в размерных значениях
Понятия
Процедуры
Команды

Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMALTTZ | Управление подавлением нулей в значениях допуска.
DIMALTZ | Управление подавлением нулей в альтернативных размерных единицах.
DIMAZIN | Подавление нулевых значений для всех угловых размеров.
DIMTZIN | Управляет подавлением нулей в допусках
DIMZIN | Управляет подавлением нулей в основных единицах измерения
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение двусторонних допусков - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение двусторонних допусков
Понятия
Процедуры
Команды

Допуски показывают пределы, в которых может колебаться размер. Можно управлять отображением двусторонних допусков, стили которых можно выбирать.

Допуски показывают пределы, в которых может колебаться размер. Применение допусков в производстве позволяет задавать степень точности, которая должна соблюдаться при изготовлении для элементов детали, таких как точка, отрезок, ось или поверхность.

Допуски могут быть элементами размеров. Для этого их следует включить в размерный текст. Такие размерные допуски показывают максимальные и минимальные допустимые значения размерных величин. Кроме того, имеется возможность использования допусков формы и расположения, выражающих отклонения формы, контура, ориентации и взаимного расположения.

Для описания двусторонних допусков могут задаваться теоретически точные размеры. Такие размеры называются номинальными. Текст номинального размера заключается в рамку.

К размерным значениям можно добавить указание верхнего и нижнего отклонений. Если значения допусков отклонений одинаковы, они отображаются со знаком ± и называются симметричными. В противном случае, значение верхнего отклонения (со знаком плюс) выводится над значением нижнего отклонения (со знаком минус).

Если допуски применяются в качестве ограничений, программа использует значения "плюс" и "минус", указанные пользователем, для вычисления максимального и минимального значения. Эти значения отображаются в качестве размерного текста. Наибольшее предельное значение выводится над наименьшим.

Форматирование двусторонних допусков

Имеется возможность задавать положение значений допусков по вертикали относительно основного размерного текста. При этом допуски могут выравниваться по верхней или нижней границе размерного текста, а также по середине.

Кроме того, можно включать подавление нулей в значениях допусков точно так же, как для размерных значений в основных и альтернативных единицах. Например, при подавлении ведущих нулей 0,5 записывается как ,5, а при подавлении замыкающих нулей 0,5000 - как 0,5.

См. также

Нанесение допусков формы и расположения


Нанесение двусторонних допусков - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение двусторонних допусков
Понятия
Процедуры
Команды

Задание способа нанесения двусторонних допусков

Выравнивание допусков и подавление нулей в значениях допусков


Задание способа нанесения двусторонних допусков - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение двусторонних допусков
Понятия
Процедуры
Команды

Задание способа нанесения двусторонних допусков

  1. Нажмите "Формат" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Допуски" диалогового окна "Изменение размерного стиля" в группе "Формат допусков" выберите нужный способ из списка "Способ" и выполнить одно из действий:
    • При выборе способа "Предельные размеры" введите значения верхнего и нижнего отклонений в полях "Максимальное значение" и "Минимальное значение" соответственно.
    • При выборе способа "Симметрично" введите только одно значение отклонения в поле "Максимальное значение". Указание минимального значения не требуется.
    • При выборе способа "Номинальный" введите значение в поле "Отступ от размерной линии" на вкладке "Текст" для задания зазора между размерным текстом и окружающей его рамкой.
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Выравнивание допусков и подавление нулей в значениях допусков - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение двусторонних допусков
Понятия
Процедуры
Команды

Выравнивание допусков и подавление нулей в значениях допусков

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Допуски" диалогового окна "Изменение размерного стиля" в группе "Формат допусков" выберите режим из списка "Выравнивание".
  4. Для подавления ведущих нулей размеров в основных и альтернативных единицах в группе "Подавление нулей" следует установить флажок "Ведущие". Для подавления замыкающих нулей следует установить флажок "Замыкающие".
  5. Нажмите "ОК".
  6. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Нанесение двусторонних допусков - Команды

Размеры и допуски
Размеры и допуски
Нанесение двусторонних допусков
Понятия
Процедуры
Команды

Команды
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMALTTD | Установка числа знаков после запятой в значениях допуска для альтернативных размерных единиц
DIMALTTZ | Управление подавлением нулей в значениях допуска.
DIMGAP | Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом
DIMLIM | Создание ограничений размеров в качестве текста по умолчанию
DIMTDEC | Устанавливает количество десятичных знаков для значений допусков в основных единицах
DIMTFAC | Указывает масштабный коэффициент для высоты текста дробных частей размеров и допусков относительно высоты размерного текста, заданной в переменной DIMTXT
DIMTM | Устанавливает минимальное (или нижнее) предельное отклонение для размерного текста при включенной переменной DIMTOL или DIMLIM
DIMTOL | Добавление предельных отклонений в конец размерного текста.
DIMTP | Устанавливает максимальное (или верхнее) предельное отклонение для размерного текста при включенной переменной DIMTOL или DIMLIM.
DIMTZIN | Управляет подавлением нулей в допусках
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание масштаба размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Задание масштаба размеров
Понятия
Процедуры
Команды

Имеется возможность задания масштаба для вывода размерных элементов. Устанавливаемый масштаб зависит от используемого способа компоновки и печати чертежа.

Масштаб размеров влияет на степень увеличения размерных элементов чертежа. При этом изменяются такие характеристики, как высота символов текста, величина стрелок и зазоров между выносными линиями и точками объектов с нанесенными размерами. При создании размерных стилей следует указывать реальные величины, используемые при выводе чертежа на печать. Глобальный масштаб размеров не применяется для значений длин, включая допуски, координат и углов.

Задание масштаба размеров зависит от способа компоновки чертежа на листе. Существует три способа построения размеров:

  • Нанесение размеров в пространстве модели для печати в пространстве модели. Стандартный способ, используемый при работе с одним видом чертежа. Для корректного масштабирования размеров при выводе на печать системной переменной DIMSCALE следует присвоить значение, обратное установленному масштабу печати. Например, если масштаб печати равен 1/4, то переменная DIMSCALE должна иметь значение 4.
  • Нанесение размеров в пространстве модели для печати в пространстве листа. Это наиболее предпочтительный способ для сложных чертежей со множеством видов, созданных в версиях более ранних, чем AutoCAD 2002. Используйте этот способ при необходимости ссылаться на размеры в чертеже с помощью других чертежей (внешние ссылки) или при нанесении изометрических размеров в трехмерных изометрических видах. Для того чтобы отключить вывод размеров одного видового экрана листа на других, необходимо создайте отдельный слой размеров для каждого видового экрана листа, замораживаемый на всех остальных видовых экранах. Для автоматического масштабирования размеров при отображении в пространстве листа нужно присвоить системной переменной DIMSCALE значение 0.
  • Нанесение размеров в пространстве листа. Самый простой способ. Для построения размеров в пространстве листа выбираются объекты пространства модели или включается объектная привязка для позиционирования в точках объектов модели. По умолчанию устанавливается ассоциативная связь между размерами пространства листа и объектами модели. Дополнительное масштабирование для размеров, нанесенных в пространстве листа, не требуется. Для переменных DIMLFAC и DIMSCALE не требуется изменять значения по умолчанию (1,0000).

Примечание При нанесении размера объектов пространства модели в пространстве листа с помощью ассоциативных размеров размерные величины для масштаба отображения каждого видового экрана настраиваются автоматически. Эта настройка объединяется с текущим параметром для DIMLFAC и отображается с помощью команды СПИСОК как переопределение размерного стиля. Для неассоциативных размеров необходимо установить DIMLFAC вручную.

См. также

Рисование, масштабирование и пояснения в пространстве модели

Масштабирование видов на видовых экранах листа


Задание масштаба размеров - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Задание масштаба размеров
Понятия
Процедуры
Команды

Задание глобального масштаба размеров

Задание масштаба размеров пространства модели на листах

Задание масштаба размеров, создаваемых в пространстве листа


Задание глобального масштаба размеров - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Задание масштаба размеров
Понятия
Процедуры
Команды

Задание глобального масштаба размеров

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Размещение" диалогового окна "Изменение размерного стиля" в группе "Масштаб размерных элементов" введите значение глобального масштабного коэффициента.
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Задание масштаба размеров пространства модели на листах - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Задание масштаба размеров
Понятия
Процедуры
Команды

Задание масштаба размеров пространства модели на листах

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. На вкладке "Размещение" диалогового окна "Изменение размерного стиля" в группе "Масштаб размерных элементов" установите флажок "Масштаб размеров по листу".
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Задание масштаба размеров, создаваемых в пространстве листа - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Задание масштаба размеров
Понятия
Процедуры
Команды

Задание масштаба размеров, создаваемых в пространстве листа

  1. Выберите вкладку разметки листа, чтобы переключиться на пространство листа.
  2. Для нанесения размеров в пространстве листа с корректными размерными значениями пространства модели включить объектную привязку для позиционирования в точках модели из пространства листа или непосредственно указывать объекты, на которые наносятся размеры.

    3. Значение системной переменной DIMLFAC можно изменить в случае необходимости преобразования линейных размерных величин между британской и метрической системой единиц.


Задание масштаба размеров - Команды

Размеры и допуски
Размеры и допуски
Задание масштаба размеров
Понятия
Процедуры
Команды

Команды
РЗМРЕГЕН | Обновление расположения всех ассоциативных размеров
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
DIMLFAC | Установка масштабного коэффициента для значений линейных размеров.
DIMSCALE | Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение размеров
Понятия
Процедуры
Команды

Имеется возможность нанесения всех стандартных типов размеров.

  • Нанесение линейных размеров
    Имеется возможность наносить линейные размеры с горизонтальным, вертикальным или параллельным направлением размерных линий. Линейные размеры могут располагаться в несколько уровней или составлять размерные цепи.
  • Нанесение радиальных размеров
    Радиальные размеры иллюстрируют значения радиусов и диаметров дуг или кругов; для этих объектов существует также возможность нанесения маркеров центра и центровых линий.
  • Нанесение угловых размеров
    Угловые размеры наносятся для обозначения углов между двумя отрезками или тремя точками.
  • Нанесение ординатных размеров
    Ординатные размеры указывают перпендикулярное расстояние от исходной точки (база) до измеряемого элемента, например отверстия в детали.
  • Создание размеров длины дуги
    Размеры длины дуги указывают расстояние вдоль дуги или дугового сегмента полилинии.


Нанесение размеров - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение размеров
Понятия
Процедуры
Команды

Нанесение горизонтального или вертикального размера

Нанесение параллельного размера

Нанесение линейных размеров от общей базы

Нанесение линейной размерной цепи

Нанесение повернутого размера

Изменение наклона выносных линий

Нанесение диаметра

Нанесение радиуса

Создание размера радиуса с изломом

Автоматическое создание центровых линий с помощью радиальных размеров

Создание центровых линий или маркеров центра для дуги или круга

Нанесение углового размера

Нанесение ординатного размера

Создание размера длины дуги


Нанесение размеров - Команды

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение размеров
Понятия
Процедуры
Команды
Команды
БРАЗМЕР | Быстрое нанесение размера
РЗМБАЗОВЫЙ | Нанесение новых линейных, угловых или ординатных размеров от базовой линии предыдущего или выбранного размера
РЗМДИАМЕТР | Нанесение диаметров кругов и дуг
РЗМДУГА | Создает размер длины дуги
РЗМИЗЛОМ | Создание ломаных линий размеров радиуса
РЗМЛИНЕЙНЫЙ | Нанесение линейных размеров
РЗМОРДИНАТА | Нанесение ординатных размеров
РЗМПАРАЛ | Нанесение параллельных линейных размеров
РЗМРАДИУС | Нанесение радиусов кругов и дуг
РЗМРЕД | Редактирование размерного текста и выносных линий на объектах для нанесения размеров
РЗМСТИЛЬ | Создание и модификация размерных стилей
РЗМУГЛОВОЙ | Нанесение угловых размеров
РЗМЦЕНТР | Нанесение маркеров центра или центровых линий для кругов и дуг
Системные переменные
DIMADEC | Управление отображением числа точных знаков в угловых размерах.
DIMARCSYM | Управляет отображением символа дуги в размере длины дуги
DIMATFIT | Определение размещения размерного текста и стрелок, если и для текста, и для стрелок недостаточно места в выносных линиях
DIMAUNIT | Установка формата единиц измерения для угловых размеров.
DIMCEN | Управление рисованием маркеров центра и центровых линий кругов и дуг с помощью команд РЗМЦЕНТР, РЗМДИАМЕТР и РЗМРАДИУС.
DIMDEC | Установка числа десятичных знаков, отображаемых для основных единиц размера
DIMDLI | Управление расстоянием между размерными линиями в базовых размерах
DIMEXO | Задает величину смещения выносных линий относительно исходных точек
DIMJOGANG | Определяет угол поперечного сегмента размерной линии в ломаной линии размера радиуса
DIMJUST | Управление положением размерного текста по горизонтали
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
DIMTIH | Управляет ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями
DIMTMOVE | Устанавливает правила перемещения размерного текста
DIMTOFL | Управляет построением размерной линии между выносными линиями, даже если текст размещается вне линий
DIMTOH | Управляет ориентацией размерного текста за выносными линиями
DIMUPT | Управляет параметрами при пользовательском расположении текста
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение линейных размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение линейных размеров
Понятия
Процедуры
Команды

Имеется возможность наносить линейные размеры с горизонтальным, вертикальным или параллельным направлением размерных линий. Линейные размеры могут располагаться в несколько уровней или составлять размерные цепи.

  • Коротко о нанесении линейных размеров
  • Нанесение горизонтальных и вертикальных размеров
    Имеется возможность нанесения размеров, описывающих горизонтальные или вертикальные величины координат и линейных характеристик объектов.
  • Нанесение параллельных размеров
    Имеется возможность нанесения размера с размерной линией, проходящей параллельно прямой, проходящей через заданные точки образмериваемого объекта.
  • Нанесение размеров от общей базы и размерных цепей
    Размеры от общей базы - это последовательность размеров, отложенных от одной базовой линии. У размерных цепей начало каждого размера совпадает с концом предыдущего, т.е. каждый последующий размер имеет общую выносную линию с предыдущим.
  • Нанесение повернутых размеров
    В повернутом размере размерная линия проходит под заданным углом поворота относительно начальной точки выносной линии.
  • Нанесение размеров с наклонными выносными линиями
    Имеется возможность нанесения размеров, выносные линии которых не располагаются перпендикулярно размерным.


Нанесение линейных размеров - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение линейных размеров
Понятия
Процедуры
Команды

Нанесение горизонтального или вертикального размера

Нанесение параллельного размера

Нанесение линейных размеров от общей базы

Нанесение линейной размерной цепи

Нанесение повернутого размера

Изменение наклона выносных линий


Нанесение линейных размеров - Команды

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение линейных размеров
Понятия
Процедуры
Команды
Команды
БРАЗМЕР | Быстрое нанесение размера
РЗМБАЗОВЫЙ | Нанесение новых линейных, угловых или ординатных размеров от базовой линии предыдущего или выбранного размера
РЗМЛИНЕЙНЫЙ | Нанесение линейных размеров
РЗМПАРАЛ | Нанесение параллельных линейных размеров
РЗМРЕД | Редактирование размерного текста и выносных линий на объектах для нанесения размеров
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMDLI | Управление расстоянием между размерными линиями в базовых размерах
DIMEXO | Задает величину смещения выносных линий относительно исходных точек
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о нанесении линейных размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Коротко о нанесении линейных размеров
Понятия
Процедуры
Команды

Линейные размеры могут иметь горизонтальное, вертикальное или параллельное направление. Размерная линия параллельного размера ориентирована так же, как и отрезок (воображаемый или реальный), соединяющий размерные точки. Последовательности линейных размеров могут представлять собой размеры от общей базы или размерные цепи.

На следующих чертежах задаются начальные точки выносных линий в позициях 1 и 2. Положение размерной линии определяется указанием точки 3.

При нанесении линейного размера можно редактировать размерный текст, а также задавать углы направлений текста и размерной линии.


Нанесение линейных размеров

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение линейных размеров
Понятия
Процедуры
Команды

Нет процедур.


Коротко о нанесении линейных размеров - Команды

Размеры и допуски
Размеры и допуски
Коротко о нанесении линейных размеров
Понятия
Процедуры
Команды

Команды
БРАЗМЕР | Быстрое нанесение размера
РЗМБАЗОВЫЙ | Нанесение новых линейных, угловых или ординатных размеров от базовой линии предыдущего или выбранного размера
РЗМЛИНЕЙНЫЙ | Нанесение линейных размеров
РЗМПАРАЛ | Нанесение параллельных линейных размеров
РЗМРЕД | Редактирование размерного текста и выносных линий на объектах для нанесения размеров
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMDLI | Управление расстоянием между размерными линиями в базовых размерах
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение горизонтальных и вертикальных размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение горизонтальных и вертикальных размеров
Понятия
Процедуры
Команды

Имеется возможность нанесения размеров, описывающих горизонтальные или вертикальные величины координат и линейных характеристик объектов.

Программа автоматически наносит горизонтальный или вертикальный размер в соответствии с исходными точками выносных линий, указанными пользователем, или местом выбора объекта. Тем не менее, можно заменить этот размер при нанесении, указав его положение (горизонтальное или вертикальное). На следующем примере чертежа по умолчанию создается горизонтальный размер, который меняется пользователем на вертикальный.


Нанесение горизонтального или вертикального размера - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение горизонтальных и вертикальных размеров
Понятия
Процедуры
Команды

Нанесение горизонтального или вертикального размера

  1. Нажмите "Размеры" » "Линейный".
  2. Нажмите клавишу ENTER для выбора объекта для нанесения размеров или укажите начальные точки первой и второй выносных линий.
  3. Перед указанием расположения размерной линии можно переопределить направление размера, отредактировать размерный текст, а также задать углы направлений текста и выносной линии.
    • Для поворота выносных линий введите п (Повернутый). Затем введите угол поворота размерной линии.
    • Для редактирования размерного текста введите м (МТекст). В текстовом редакторе, используемом в месте редактирования, измените текст. Нажмите "ОК".

      • Редактирование текста в скобках (<>) приводит к изменению или удалению размерной величины, вычисленной программой. Для добавления текстовых элементов до и после размерного числа следует введите текст до и после угловых скобок соответственно.

    • Для поворота текста введите у (Угол). Затем введите угол поворота размерного текста.
  4. Укажите положение размерной линии.

Панель "Размеры"

Ввод команды: РЗМЛИНЕЙНЫЙ


Нанесение горизонтальных и вертикальных размеров - Команды

Размеры и допуски
Размеры и допуски
Нанесение горизонтальных и вертикальных размеров
Понятия
Процедуры
Команды

Команды
РЗМЛИНЕЙНЫЙ | Нанесение линейных размеров
Системные переменные
DIMEXO | Задает величину смещения выносных линий относительно исходных точек
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение параллельных размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение параллельных размеров
Понятия
Процедуры
Команды

Имеется возможность нанесения размера с размерной линией, проходящей параллельно прямой, проходящей через заданные точки образмериваемого объекта.

Размерная линия в параллельных размерах расположена параллельно прямой, проходящей через размерные точки. Примеры параллельных размеров приведены на следующих двух чертежах. Выбирается объект (1) и указывается положение параллельного размера (2). Выносные линии наносятся автоматически.


Нанесение параллельного размера - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение параллельных размеров
Понятия
Процедуры
Команды

Нанесение параллельного размера

  1. Нажмите "Размеры" » "Параллельный".
  2. Нажмите клавишу ENTER для выбора объекта для нанесения размеров или укажите начальные точки первой и второй выносных линий.
  3. Перед указанием расположения размерной линии можно отредактировать размерный текст и изменить угол его наклона. Редактирование текста в скобках (<>) приводит к изменению или удалению размерной величины, вычисленной программой. Для добавления текстовых элементов до и после размерного числа следует введите текст до и после угловых скобок соответственно.
    • Для редактирования многострочного размерного текста введите м (МТекст). В текстовом редакторе, используемом в месте редактирования, изменить текст. Нажмите "ОК".
    • Для редактирования однострочного размерного текста введите т (Текст). Отредактируйте текст в командной строке и нажмите ENTER .
    • Для поворота текста введите у (Угол). Затем введите угол поворота размерного текста.
  4. Укажите положение размерной линии.

Панель "Размеры"

Ввод команды: РЗМПАРАЛ


Нанесение параллельных размеров - Команды

Размеры и допуски
Размеры и допуски
Нанесение параллельных размеров
Понятия
Процедуры
Команды

Команды
РЗМПАРАЛ | Нанесение параллельных линейных размеров
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMEXO | Задает величину смещения выносных линий относительно исходных точек
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение размеров от общей базы и размерных цепей - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение размеров от общей базы и размерных цепей
Понятия
Процедуры
Команды

Размеры от общей базы - это последовательность размеров, отложенных от одной базовой линии. У размерных цепей начало каждого размера совпадает с концом предыдущего, т.е. каждый последующий размер имеет общую выносную линию с предыдущим. Для нанесения размеров от общей базы или размерной цепи для изделия должен быть проставлен хотя бы один линейный, ординатный или угловой размер. Величина каждого следующего размера из последовательности размеров от общей базы увеличивается по сравнению с величиной предыдущего размера.

Если не укажите начальную размерную точку, то базовая линия или первая выносная линия размерной цепи располагаются на месте второй выносной линии последнего нанесенного размера.


Нанесение размеров от общей базы и размерных цепей - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение размеров от общей базы и размерных цепей
Понятия
Процедуры
Команды

Нанесение линейных размеров от общей базы

Нанесение линейной размерной цепи


Нанесение линейных размеров от общей базы - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение размеров от общей базы и размерных цепей
Понятия
Процедуры
Команды

Нанесение линейных размеров от общей базы

  1. Нажмите "Размеры" » "От общей базы".

    2. По умолчанию первая выносная линия нового размера определяется начальной точкой последнего линейного размера. Появится запрос второй размерной линии.

  2. Воспользоваться объектной привязкой для указания начальной точки второй выносной линии или нажмите ENTER для выбора другого размера в качестве базового.

    3. Программа автоматически размещает вторую размерную линию на расстоянии, указанном с помощью параметра "Шаг в базовых размерах" на вкладке "Линии" Диспетчера размерных стилей.

  3. Воспользоваться объектной привязкой для указания начальной точки следующей выносной линии.
  4. При необходимости провести указание начальных точек последующих выносных линий.
  5. Для завершения команды нажмите ENTER дважды.

Панель "Размеры"

Ввод команды: РЗМБАЗОВЫЙ


Нанесение линейной размерной цепи - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение размеров от общей базы и размерных цепей
Понятия
Процедуры
Команды

Нанесение линейной размерной цепи

  1. Нажмите "Размеры" » "Продолжить".

    2. Программа использует исходную точку второй выносной линии существующего размера в качестве исходной точки первой выносной линии.

  2. Воспользоваться объектной привязкой для указания начальных точек последующих выносных линий.
  3. Для завершения команды нажмите ENTER дважды.

Панель "Размеры"

Ввод команды: РЗМЦЕПЬ


Нанесение размеров от общей базы и размерных цепей - Команды

Размеры и допуски
Размеры и допуски
Нанесение размеров от общей базы и размерных цепей
Понятия
Процедуры
Команды

Команды
РЗМБАЗОВЫЙ | Нанесение новых линейных, угловых или ординатных размеров от базовой линии предыдущего или выбранного размера
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMDLI | Управление расстоянием между размерными линиями в базовых размерах
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение повернутых размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение повернутых размеров
Понятия
Процедуры
Команды

В повернутом размере размерная линия проходит под заданным углом поворота относительно начальной точки выносной линии. На следующем чертеже показан пример повернутого размера. Здесь угол поворота размерной линии равен углу расположения щели, на которую наносятся размеры.


Нанесение повернутого размера - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение повернутых размеров
Понятия
Процедуры
Команды

Нанесение повернутого размера

  1. Нажмите "Размеры" » "Линейный".
  2. Нажмите клавишу ENTER для выбора объекта для нанесения размеров или укажите начальные точки первой и второй выносных линий.
  3. Для поворота размерной линии введите п (Повернутый). Затем введите угол поворота размерной линии.
  4. Укажите положение размерной линии.

Панель "Размеры"

Ввод команды: РЗМЛИНЕЙНЫЙ


Нанесение повернутых размеров - Команды

Размеры и допуски
Размеры и допуски
Нанесение повернутых размеров
Понятия
Процедуры
Команды

Команды
РЗМЛИНЕЙНЫЙ | Нанесение линейных размеров
РЗМПАРАЛ | Нанесение параллельных линейных размеров
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение размеров с наклонными выносными линиями - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение размеров с наклонными выносными линиями
Понятия
Процедуры
Команды

Имеется возможность нанесения размеров, выносные линии которых не располагаются перпендикулярно размерным.

Выносные линии строятся перпендикулярно размерной линии. Однако в случае, если выносные линии ухудшают удобочитаемость других элементов чертежа, угол их наклона можно изменить уже после создания размера.

Применение наклона к существующему размеру не действует на размеры, строящиеся после этого.


Изменение наклона выносных линий - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение размеров с наклонными выносными линиями
Понятия
Процедуры
Команды

Изменение наклона выносных линий

  1. Нажмите "Размеры" » "Наклонить".
  2. Выберите размер.
  3. Введите значение угла наклона или укажите две точки.

Панель "Размеры"

Ввод команды: РЗМРЕД


Нанесение размеров с наклонными выносными линиями - Команды

Размеры и допуски
Размеры и допуски
Нанесение размеров с наклонными выносными линиями
Понятия
Процедуры
Команды

Команды
РЗМРЕД | Редактирование размерного текста и выносных линий на объектах для нанесения размеров
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение радиальных размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение радиальных размеров
Понятия
Процедуры
Команды

Радиальные размеры иллюстрируют значения радиусов и диаметров дуг или кругов; для этих объектов существует также возможность нанесения маркеров центра и центровых линий.

Существует два типа радиальных размеров.

  • РЗМРАДИУС используется для измерения радиуса дуги или круга и отображает размерный текст, перед которым стоит буква R.
  • РЗМДИАМЕТР используется для измерения диаметра дуги или круга и отображает размерный текст, перед которым стоит символ диаметра.

Если угол наклона радиальной размерной линии больше 15 градусов (от горизонтальной плоскости), для размерного текста, расположенного по горизонтали, создается полка выноски, также называемая ломаной линией или площадкой, рядом с размерным текстом.

Управление центровыми линиями и метками центра

В зависимости от настроек размерного стиля, маркер центра и центровые линии для размеров радиуса и диаметра создаются автоматически. Они создаются только в том случае, если размерная линия расположена за пределами круги или дуги. Центровые линии и маркеры центра можно создавать напрямую с помощью команды РЗМЦЕНТР.

Размером и видимостью центровых линий и маркеров центра можно управлять в диалоговом окне "Изменение размерного стиля" на вкладке "Символы и стрелки" в разделе "Маркеры центра". Доступ к этим настройкам можно также получить с помощью системной переменной DIMCEN.

Размер центровой линии равен длине сегмента центровой линии, выходящего за пределы круга или дуги. Это также и размер промежутка между маркером центра и началом центровой линии.

Размер маркера центра равен расстоянию от центра круга или дуги до конца маркера центра.

Создание размеров радиуса с изломом

С помощью команды РЗМИЗЛОМ можно создавать размеры радиусов с изломом, также называемые “укороченными размерами радиуса”, в том случае, если центр дуги или круга располагается за пределами листа и его истинное положение не может быть показано. Исходную точку размера можно задайте в более удобном месте, называемом переопределением положения центра.

Углом ломаной линии по умолчанию можно управлять в диалоговом окне "Изменение размерного стиля" на вкладке "Символы и стрелки" в разделе "Ломаная размера радиуса".

После создания размера радиуса с изломом его, а также положение центра можно изменять следующим образом:

  • С помощью ручек для перемещения элементов.
  • Изменяя положение элементов с помощью палитры свойств.
  • С помощью команды РАСТЯНУТЬ.

Примечание Размеры радиуса с изломом можно просматривать без возможности редактирования в версиях, предшествующих AutoCAD. 2006. Кроме того, значительное редактирование связанных объектов может привести к непредсказуемым результатам для размера радиуса с изломом.

См. также

Размещение размерного текста между выносными линиями


Нанесение радиальных размеров - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение радиальных размеров
Понятия
Процедуры
Команды

Нанесение диаметра

Нанесение радиуса

Создание размера радиуса с изломом

Автоматическое создание центровых линий с помощью радиальных размеров

Создание центровых линий или маркеров центра для дуги или круга


Нанесение диаметра - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение радиальных размеров
Понятия
Процедуры
Команды

Нанесение диаметра

  1. Нажмите "Размеры" » "Диаметр".
  2. Выберите дугу или круг для нанесения размеров.
  3. Введите необходимые опции:
    • Для редактирования размерного текста введите т (Текст) или м (МТекст). Редактирование текста в скобках (<>) приводит к изменению или удалению размерной величины. Для добавления текстовых элементов до и после размерного числа следует введите текст до и после угловых скобок соответственно.
    • Для задания угла нанесения размерного текста введите у (Угол).
  4. Укажите положение линии выноски.

Панель "Размеры"

Ввод команды: РЗМДИАМЕТР


Нанесение радиуса - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение радиальных размеров
Понятия
Процедуры
Команды

Нанесение радиуса

  1. Нажмите "Размеры" » "Радиус".
  2. Выберите дугу, круг или дуговой сегмент полилинии.
  3. Введите необходимые опции:
    • Для редактирования размерного текста введите т (Текст) или м (МTекст). Редактирование текста в скобках (<>) приводит к изменению или удалению размерной величины. Для добавления текстовых элементов до и после размерного числа следует введите текст до и после угловых скобок соответственно.
    • Для задания угла нанесения размерного текста введите у (Угол).
  4. Укажите положение линии выноски.

Панель "Размеры"

Ввод команды: РЗМРАДИУС


Создание размера радиуса с изломом - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение радиальных размеров
Понятия
Процедуры
Команды

Создание размера радиуса с изломом

  1. Нажмите "Размеры" » "С изломом".
  2. Выберите дугу, круг или дуговой сегмент полилинии.
  3. Укажите исходную точку размера (переопределение положения центра).
  4. Укажите точку угла размерной линии и положение размерного текста.
  5. Укажите другую точку для расположения излома размерной линии.

Панель "Размеры"

Ввод команды: РЗМИЗЛОМ


Автоматическое создание центровых линий с помощью радиальных размеров - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение радиальных размеров
Понятия
Процедуры
Команды

Автоматическое создание центровых линий с помощью радиальных размеров

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Линии" в разделе "Маркеры центра" в списке "Тип" выберите "Линия". Изменение параметров вызывает обновление образца изображения.
  4. В поле "Размер" введите значение величины центровых линий.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Создание центровых линий или маркеров центра для дуги или круга - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение радиальных размеров
Понятия
Процедуры
Команды

Создание центровых линий или маркеров центра для дуги или круга

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Линии" в разделе "Маркеры центра" в списке "Тип" выберите "Линия". Изменение параметров вызывает обновление образца изображения.
  4. В поле "Размер" введите значение величины центровых линий.
  5. Нажмите "Размеры" » "Метка центра".
  6. Выберите дугу или круг.

Панель "Размеры"

Ввод команды: РЗМЦЕНТР


Нанесение радиальных размеров - Команды

Размеры и допуски
Размеры и допуски
Нанесение радиальных размеров
Понятия
Процедуры
Команды

Команды
БРАЗМЕР | Быстрое нанесение размера
РЗМДИАМЕТР | Нанесение диаметров кругов и дуг
РЗМИЗЛОМ | Создание ломаных линий размеров радиуса
РЗМРАДИУС | Нанесение радиусов кругов и дуг
РЗМЦЕНТР | Нанесение маркеров центра или центровых линий для кругов и дуг
Системные переменные
DIMATFIT | Определение размещения размерного текста и стрелок, если и для текста, и для стрелок недостаточно места в выносных линиях
DIMCEN | Управление рисованием маркеров центра и центровых линий кругов и дуг с помощью команд РЗМЦЕНТР, РЗМДИАМЕТР и РЗМРАДИУС.
DIMJOGANG | Определяет угол поперечного сегмента размерной линии в ломаной линии размера радиуса
DIMJUST | Управление положением размерного текста по горизонтали
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
DIMTIH | Управляет ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями
DIMTMOVE | Устанавливает правила перемещения размерного текста
DIMTOFL | Управляет построением размерной линии между выносными линиями, даже если текст размещается вне линий
DIMTOH | Управляет ориентацией размерного текста за выносными линиями
DIMUPT | Управляет параметрами при пользовательском расположении текста
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение угловых размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение угловых размеров
Понятия
Процедуры
Команды

Угловые размеры наносятся для обозначения углов между двумя отрезками или тремя точками. Для выбора измеряемого угла между двумя радиусами круга необходимо выбрать круг и указать конечные точки, определяющие угол с вершиной в центре круга. Для нанесения размеров на другие выбранные объекты следует указать положение размера. Кроме того, угловой размер можно нанести заданием вершины угла и образующих конечных точек. При создании размера перед указанием положения размерной линии можно отредактировать размерный текст и задать его ориентацию.

Примечание Имеется возможность наносить размеры от общей базы и размерные цепи угловых размеров относительно уже существующих угловых размеров. Размеры от общей базы и цепи угловых размеров наносятся только в пределах 180 градусов. Это ограничение можно преодолеть, если с помощью ручек увеличить выносную линию размерной цепи или размера от общей базы.

Размерные линии

Если угол образован двумя непараллельными прямыми, размерная дуга стягивает угол между ними. Если дуга размерной линии не пересекается с одной или обеими измеряемыми линиями, программа проводит одну или две выносные линии для пересечения с дугой размерной линии. Стягиваемый угол всегда меньше 180 градусов.

Образмеривание кругов и дуг

Если для задания угла используется дуга, круг или три точки, программа проводит дугу размерной линии между выносными линиями. Выносные линии проходят из конечных точек, определяющих угол, до пересечений с размерной дугой.

Заданное положение размерной дуги определяет квадрант угла, на который наносятся размеры.


Нанесение углового размера - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение угловых размеров
Понятия
Процедуры
Команды

Нанесение углового размера

  1. Нажмите "Размеры" » "Угловой".
  2. Воспользуйтесь одним из следующих способов:
    • Для нанесения размеров на круг, выберите круг, указав первую конечную точку угла. Затем укажите вторую конечную точку.
    • Для нанесения размеров на любой другой объект укажите первый отрезок, определяющий сторону измеряемого угла. Затем укажите второй отрезок.
  3. Введите необходимые опции:
    • Для редактирования размерного текста введите т (Текст) или м (МТекст). Редактирование текста в скобках (<>) приводит к изменению или удалению вычисленной размерной величины. Для добавления текстовых элементов до и после размерного числа следует ввести текст до и после угловых скобок соответственно.
    • Для задания угла нанесения размерного текста введите у (Угол).
  4. Укажите положение размерной дуги.

Панель "Размеры"

Ввод команды: РЗМУГЛОВОЙ


Нанесение угловых размеров - Команды

Размеры и допуски
Размеры и допуски
Нанесение угловых размеров
Понятия
Процедуры
Команды

Команды
РЗМБАЗОВЫЙ | Нанесение новых линейных, угловых или ординатных размеров от базовой линии предыдущего или выбранного размера
РЗМУГЛОВОЙ | Нанесение угловых размеров
Системные переменные
DIMADEC | Управление отображением числа точных знаков в угловых размерах.
DIMAUNIT | Установка формата единиц измерения для угловых размеров.
DIMDEC | Установка числа десятичных знаков, отображаемых для основных единиц размера
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение ординатных размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение ординатных размеров
Понятия
Процедуры
Команды

Ординатные размеры указывают перпендикулярное расстояние от исходной точки (база) до измеряемого элемента, например отверстия в детали. Вычисление значений этих размеров относительно базы позволяет избежать возможных ошибок в размерах, связанных с накоплением погрешностей.

Ординатные размеры состоят из значения координаты X или Y и выноски. X - ординатные размеры - указывают расстояние элемента от базы по оси X. Y - ординатные размеры - указывают расстояние элемента от базы по оси Y. При указании точки программа автоматически определяет, является она ординатным размером по оси X или Y. Такой способ нанесения ординатных размеров называется автоматическим. Если расстояние больше для значения Y, то размер измеряется по значению X. В противном случае измеряется значение по оси Y.

В программе используется абсолютное значение координаты текущей ПСК для определения ординатного значения. Обычно перед построением ординатных размеров исходную точку ПСК совмещают с базовой точкой.

Размерный текст располагается вдоль выноски, независимо от ориентации текста, определяемой текущим размерным стилем. Вместо текущего текста можно проставить любой другой текст.


Нанесение ординатного размера - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение ординатных размеров
Понятия
Процедуры
Команды

Нанесение ординатного размера

  1. Нажмите "Размеры" » "Ординатный".
  2. Если необходимо построить прямые выноски, то включите режим "Орто".
  3. В ответ на запрос "Укажите положение элемента" укажите точку.
  4. Введите x (Xзначение) или y (Yзначение).

    5. Данный пункт можно пропустить, если необходимо соединить конец выноски с вертикалью для обозначения координаты X базы или с горизонталью для обозначения координаты Y.

  5. Укажите конечную точку выноски.

Панель "Размеры"

Ввод команды: РЗМОРДИНАТА


Нанесение ординатных размеров - Команды

Размеры и допуски
Размеры и допуски
Нанесение ординатных размеров
Понятия
Процедуры
Команды

Команды
БРАЗМЕР | Быстрое нанесение размера
РЗМОРДИНАТА | Нанесение ординатных размеров
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание размеров длины дуги - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Создание размеров длины дуги
Понятия
Процедуры
Команды

Размеры длины дуги указывают расстояние вдоль дуги или дугового сегмента полилинии.

Типичные применения размеров длины дуги включают измерение расстояния перемещения вокруг шаблона и указание длины кабеля. Чтобы отличать эти размеры от линейных и угловых, для размеров длины дуги по умолчанию отображается символ дуги.

Символ дуги, также называемый "шляпка" или "крышка", отображается над или перед размерным текстом. Стиль размещения можно задайте с помощью Диспетчера размерных стилей. Его можно изменить на вкладке "Символы и стрелки" диалогового окна "Новый размерный стиль" или "Изменение размерного стиля".

Выносные линии размера длины дуги могут быть ортогональными или радиальными.

Примечание Ортогональные выносные линии отображаются только в случае, если прилежащий угол дуги меньше 90 градусов.


Создание размера длины дуги - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Создание размеров длины дуги
Понятия
Процедуры
Команды

Создание размера длины дуги

  1. Нажмите "Размеры" » " Длина дуги".
  2. Выберите дугу или дуговой сегмент полилинии.
  3. Укажите положение размерной линии.

Панель "Размеры"

Ввод команды: РЗМДУГА


Создание размеров длины дуги - Команды

Размеры и допуски
Размеры и допуски
Создание размеров длины дуги
Понятия
Процедуры
Команды

Команды
РЗМДУГА | Создает размер длины дуги
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMARCSYM | Управляет отображением символа дуги в размере длины дуги
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размеров
Понятия
Процедуры
Команды

Редактирование нанесенных размеров может осуществляться либо отдельно для каждого размерного объекта, либо глобально путем изменения размерных стилей.

  • Назначение нового размерного стиля для уже нанесенного размера
    Редактирование нанесенных размеров может выполняться путем назначения другого размерного стиля. Отредактировав размерный стиль, можно обновить или оставить без изменений уже нанесенные размеры, связанные с этим стилем.
  • Переопределение размерных стилей
    С помощью переопределений размерного стиля можно временно изменять значения размерных переменных без редактирования текущего размерного стиля.
  • Редактирование размерного текста
    Размерный текст в нанесенном размере можно отредактировать или заменить на новый, а также изменить его положение и угол поворота.
  • Редактирование геометрии размеров
    Редактирование с помощью ручек - наиболее быстрый и удобный способ изменения расположения размерных элементов. Способ редактирования размеров зависит от наличия ассоциативной связи между размерами и объектами.
  • Изменение ассоциативности размеров
    В некоторых случаях может понадобиться изменить ассоциативность размеров. Например, размеры, нанесенные на чертеже с помощью предыдущих версий программы, можно сделать ассоциативными.


Редактирование размеров - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размеров
Понятия
Процедуры
Команды

Назначение текущего размерного стиля уже нанесенным размерам

Восстановление размерного стиля

Переопределение размерного стиля

Назначение переопределений размерного стиля

Поворот размерного текста

Возврат размерного текста в исходное положение

Редактирование размерного текста

Перемещение текста вдоль размерной линии влево

Задание расстояния между размерными линиями в размерах от общей базы и размерных цепях

Изменение отступа выносных линий от объекта

Ассоциативное прикрепление размеров к объектам

Разрыв ассоциативной связи размеров с объектами


Редактирование размеров - Команды

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размеров
Понятия
Процедуры
Команды
Команды
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
РАСТЯНУТЬ | Перенос или растягивание объектов
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
РЗМОТКРЕПИТЬ | Отмена ассоциативности выбранных размеров
РЗМПОДАВИТЬ | Переопределение установок размерных переменных
РЗМПРИКРЕПИТЬ | Ассоциирование выбранных размеров с геометрическими объектами
РЗМРЕГЕН | Обновление расположения всех ассоциативных размеров
РЗМРЕД | Редактирование размерного текста и выносных линий на объектах для нанесения размеров
РЗМРЕДТЕКСТ | Перемещение и поворот размерных текстов
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
DIMCLRT | Цвет, которым рисуется размерный текст. Для цвета можно выбрать любой допустимый номер цвета
DIMDSEP | Задает символ десятичного разделителя, используемый при создании размеров с десятичным форматом единиц измерения.
DIMJUST | Управление положением размерного текста по горизонтали
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
DIMTIH | Управляет ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями
DIMTMOVE | Устанавливает правила перемещения размерного текста
DIMTOH | Управляет ориентацией размерного текста за выносными линиями
DIMTVP | Определяет вертикальное положение размерного текста над или под размерной линией
DIMUPT | Управляет параметрами при пользовательском расположении текста
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Назначение нового размерного стиля для уже нанесенного размера - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Назначение нового размерного стиля для уже нанесенного размера
Понятия
Процедуры
Команды

Редактирование нанесенных размеров может выполняться путем назначения другого размерного стиля. Отредактировав размерный стиль, можно обновить или оставить без изменений уже нанесенные размеры, связанные с этим стилем.

Для создаваемого размера используется текущий размерный стиль. Размер сохраняет все настройки, заданные связанным с ним размерным стилем, до назначения нового размерного стиля или установки переопределений стиля.

Редактирование нанесенных размеров может выполняться путем назначения другого размерного стиля. Отредактировав размерный стиль, можно обновить или оставить без изменений уже нанесенные размеры, связанные с этим стилем.

Для выбранных размеров можно восстановить имеющийся размерный стиль или назначить текущий размерный стиль, включая все переопределения.


Назначение нового размерного стиля для уже нанесенного размера - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Назначение нового размерного стиля для уже нанесенного размера
Понятия
Процедуры
Команды

Назначение текущего размерного стиля уже нанесенным размерам

Восстановление размерного стиля


Назначение текущего размерного стиля уже нанесенным размерам - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Назначение нового размерного стиля для уже нанесенного размера
Понятия
Процедуры
Команды

Назначение текущего размерного стиля уже нанесенным размерам

  1. Нажмите "Размеры" » " Обновить".
  2. Выберите размеры для их обновления с параметрами текущего размерного стиля.
  3. Нажмите ENTER.

Панель "Размеры"

Ввод команды: РЗМСТИЛЬ


Восстановление размерного стиля - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Назначение нового размерного стиля для уже нанесенного размера
Понятия
Процедуры
Команды

Восстановление размерного стиля

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите размерный стиль, который необходимо восстановить. Нажмите кнопку "Установить".
  3. Нажмите кнопку "Закрыть".

Панель "Размеры"

Ввод команды: РЗМСТИЛЬ

Другой способ

  • Выберите стиль из выпадающего списка "Управление размерными стилями" на панели "Стили".


Назначение нового размерного стиля для уже нанесенного размера - Команды

Размеры и допуски
Размеры и допуски
Назначение нового размерного стиля для уже нанесенного размера
Понятия
Процедуры
Команды

Команды
РЗМПОДАВИТЬ | Переопределение установок размерных переменных
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Переопределение размерных стилей - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Переопределение размерных стилей
Понятия
Процедуры
Команды

С помощью переопределений размерного стиля можно временно изменять значения размерных переменных без редактирования текущего размерного стиля.

Переопределения размерного стиля позволяют изменять отдельные параметры текущего размерного стиля. При этом происходит изменение значений размерных переменных без редактирования текущего размерного стиля.

Переопределения могут затрагивать параметры размерного стиля как для отдельных размеров, так и для всего текущего размерного стиля.

  • Переопределения в отдельных размерах используются для улучшения читаемости чертежа, когда, например, необходимо подавить нанесение выносных линий, отредактировать размерный текст или изменить положение стрелок, чтобы расположенные рядом размеры не перекрывали друг друга. При этом новые размерные стили не создаются.
  • Можно также переопределить параметры в текущем размерном стиле. Переопределения учитываются при создании новых размеров до тех пор, пока пользователь не сохранит их в новом стиле или не установит текущим другой стиль. Например, при выборе параметра "Переопределить" в Диспетчере размерных стилей и изменении цвета выносных линий на вкладке "Линии" текущий размерный стиль не изменится. Новое значение цвета сохраняется в системной переменной DIMCLRE. Таким образом, вновь создаваемые размеры строятся с выносными линиями нового цвета. Переопределения можно сохранить как новый размерный стиль.

Настройки некоторых свойств размеров общеприняты для всего чертежа и размерного стиля, поэтому они заданы в размерном стиле постоянно. Другие параметры, наоборот, используются индивидуально для каждого размера, поэтому их удобнее задавать с помощью переопределений. Например, в чертежах обычно применяется один простой вид стрелок, следовательно вид стрелки лучше задайте и сохранить в размерном стиле. Подавление выносных линий, наоборот, используется лишь в отдельных случаях и этот режим лучше задавать с помощью переопределения размерного стиля.

Существует несколько способов переопределения параметров размерных стилей. Параметры можно изменять либо в диалоговых окнах, либо путем присвоения новых значений системным переменным из командной строки. Можно отменить переопределения и восстановить исходные параметры. Установленные переопределения применяются при создании всех последующих размеров до момента отмены переопределений или смены текущего размерного стиля.

Пример: задание переопределений размерного стиля из командной строки

Переопределение текущего размерного стиля во время построения размера выполняется путем ввода имени любой размерной переменной в ответ на любой запрос. В этом примере изменяется цвет размерной линии. Изменение цвета продолжает действовать при создании последующих размеров до момента отмены переопределения или смены текущего размерного стиля.

Команда: рзмлинейный

Укажите первую исходную точку выносной линии или <выберите объект>: dimclrd

Введите новое значение для размерной переменной <поблоку>: 5

Укажите первую исходную точку выносной линии <выберите объект>: Укажите первую исходную точку выносной линии или выберите измеряемый объект


Переопределение размерных стилей - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Переопределение размерных стилей
Понятия
Процедуры
Команды

Переопределение размерного стиля

Назначение переопределений размерного стиля


Переопределение размерного стиля - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Переопределение размерных стилей
Понятия
Процедуры
Команды

Переопределение размерного стиля

  1. Нажмите "Размеры" » "Размерные стили".
  2. В окне "Диспетчер размерных стилей" выберите переопределяемый размерный стиль. Нажмите "Переопределить".
  3. В диалоговом окне "Переопределение текущего стиля" изменить размерный стиль, выбрав соответствующую вкладку.
  4. Нажмите "OK" для возврата в Диспетчер размерных стилей.

    5. Установленные переопределения включаются в список размерных стилей под именем переопределенного стиля.

  5. Нажмите кнопку "Закрыть".

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Назначение переопределений размерного стиля - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Переопределение размерных стилей
Понятия
Процедуры
Команды

Назначение переопределений размерного стиля

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей нажмите кнопку "Переопределить".
  3. В диалоговом окне "Переопределение текущего стиля" введите переопределения стиля. Нажмите "ОК".

    4. В диалоговом окне "Диспетчер размерных стилей" под именем размерного стиля отображается <переопределения стиля>. Переопределения не препятствуют внесению изменений в стили, их можно также сравнивать с другими стилями, удалять или переименовывать.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Переопределение размерных стилей - Команды

Размеры и допуски
Размеры и допуски
Переопределение размерных стилей
Понятия
Процедуры
Команды

Команды
РЗМПОДАВИТЬ | Переопределение установок размерных переменных
РЗМСТИЛЬ | Создание и модификация размерных стилей
Системные переменные
DIMCLRD | Указание цветов для размерных линий, стрелок и размерных линий выноски.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование размерного текста - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размерного текста
Понятия
Процедуры
Команды

Размерный текст в нанесенном размере можно отредактировать или заменить на новый, а также изменить угол его поворота. Кроме того, текст можно передвинуть или, наоборот, вернуть в исходное положение, определяемое текущим размерным стилем. На следующей иллюстрации исходное положение текста задано над размерной линией в центре.

Поворот и редактирование размерного текста выполняется перед окончательным нанесением размера. Например, для поворота следует введите значения угла. Перемещение размерного текста осуществляется путем выбора уже нанесенного размера.

Размерный текст можно переместить вдоль размерной линии вправо, влево или к центру, а также разместить вне выносных линий или между ними. Наиболее быстрый и простой способ перемещения достигается использованием ручек. При перемещении текста вверх и вниз изменяются выносные линии и положение размерной линии; режим вертикального выравнивания текста относительно размерной линии сохраняется. На следующем чертеже показан результат перемещения текста вниз и вправо. Положение текста по вертикали относительно размерной линии сохраняется.

См. также

Управление размерным текстом


Редактирование размерного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размерного текста
Понятия
Процедуры
Команды

Поворот размерного текста

Возврат размерного текста в исходное положение

Редактирование размерного текста

Перемещение текста вдоль размерной линии влево

Задание расстояния между размерными линиями в размерах от общей базы и размерных цепях

Изменение отступа выносных линий от объекта


Поворот размерного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размерного текста
Понятия
Процедуры
Команды

Поворот размерного текста

  1. Нажмите "Размеры" » "Размерный текст" » "Угол".
  2. Выберите размер для редактирования.
  3. Введите новое значение угла поворота текста.

Панель "Размеры"

Ввод команды: РЗМРЕДТЕКСТ


Возврат размерного текста в исходное положение - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размерного текста
Понятия
Процедуры
Команды

Возврат размерного текста в исходное положение

  1. Нажмите "Размеры" » "Размерный текст" » "Вернуть".
  2. Выберите размерный текст для возврата в исходное положение.

Панель "Размеры"

Ввод команды: РЗМРЕДТЕКСТ


Редактирование размерного текста - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размерного текста
Понятия
Процедуры
Команды

Редактирование размерного текста

  1. Нажмите "Редактирование" » "Объект" » "Текст" » "Изменить".
  2. Выберите размерный текст для редактирования.
  3. В текстовом редакторе, используемом в месте редактирования, введите новый размерный текст. Нажмите "ОК".

Панель "Текст"

Ввод команды: ДИАЛРЕД


Перемещение текста вдоль размерной линии влево - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размерного текста
Понятия
Процедуры
Команды

Перемещение текста вдоль размерной линии влево

  1. Нажмите "Размеры" » "Размерный текст" » "Влево".
  2. Выберите размер.

    3. Размерный текст выравнивается влево вдоль размерной линии между выносными линиями. Для выравнивания текста по центру или вправо следует воспользоваться опциями "Центр" или "Вправо".

Панель "Размеры"

Ввод команды: РЗМРЕДТЕКСТ


Задание расстояния между размерными линиями в размерах от общей базы и размерных цепях - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размерного текста
Понятия
Процедуры
Команды

Задание расстояния между размерными линиями в размерах от общей базы и размерных цепях

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Линии" в разделе "Размерные линии" в поле "Шаг в базовых размерах" введите значение расстояния смещения между размерными линиями для базовой линии и размерными цепями.
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Изменение отступа выносных линий от объекта - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размерного текста
Понятия
Процедуры
Команды

Изменение отступа выносных линий от объекта

  1. Нажмите "Размеры" » "Размерные стили".
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Изменить".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Линии" в разделе "Выносные линии" введите новое значение для параметра "Отступ от объекта".
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

Панель "Размеры" или "Стили"

Ввод команды: РЗМСТИЛЬ


Редактирование размерного текста - Команды

Размеры и допуски
Размеры и допуски
Редактирование размерного текста
Понятия
Процедуры
Команды

Команды
ДИАЛРЕД | Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения
РЗМРЕД | Редактирование размерного текста и выносных линий на объектах для нанесения размеров
РЗМРЕДТЕКСТ | Перемещение и поворот размерных текстов
Системные переменные
DIMCLRT | Цвет, которым рисуется размерный текст. Для цвета можно выбрать любой допустимый номер цвета
DIMDSEP | Задает символ десятичного разделителя, используемый при создании размеров с десятичным форматом единиц измерения.
DIMJUST | Управление положением размерного текста по горизонтали
DIMTAD | Управление расположением текста по вертикали относительно размерной линии
DIMTIH | Управляет ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями
DIMTMOVE | Устанавливает правила перемещения размерного текста
DIMTOH | Управляет ориентацией размерного текста за выносными линиями
DIMTVP | Определяет вертикальное положение размерного текста над или под размерной линией
DIMUPT | Управляет параметрами при пользовательском расположении текста
MTEXTED | Определяет приложение для редактирования многострочных текстовых объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование геометрии размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование геометрии размеров
Понятия
Процедуры
Команды

Редактирование с помощью ручек - наиболее быстрый и удобный способ изменения расположения размерных элементов. Способ редактирования размеров зависит от наличия ассоциативной связи между размерами и объектами.

Изменять размеры можно с помощью команд редактирования и ручек. Редактирование с помощью ручек - наиболее быстрый и удобный способ редактирования размеров. Способ редактирования размеров зависит от наличия ассоциативной связи между размерами и объектами.

Редактирование ассоциативных размеров

При использовании многих команд редактирования ассоциативный размер сохраняет связь с объектом с нанесенными размерами, если для выполнения одной команды выбирается сразу и размер, и связанный с ним объект. Так, например, после перемещения, копирования или размножения массивом объекта и связанного с ним размера одной командой ассоциативная связь между ними сохраняется.

Ассоциативная связь размеров теряется в следующих случаях:

  • Если удалить связанный с размером объект.
  • Если связанный с размером объект обработать логической операцией, такой как, например, UNION (ОБЪЕДИНЕНИЕ) или SUBTRACT (ВЫЧИТАНИЕ).
  • Если с помощью ручек растянуть размер вдоль размерной линии.
  • Если ассоциативная связь с объектом установлена в режиме объектной привязки "Кажущееся пересечение", и в результате перемещения объекта воображаемое пересечение исчезает.

В других случаях ассоциативная связь может частично сохраняться. Например, при создании ассоциативного размера для конечных точек двух объектов с последующим стиранием одного из этих объектов ассоциативная связь сохраняется с оставшимся объектом. Потерявший ассоциативную связь конец линейного размера в дальнейшем может быть ассоциирован с другим объектом с помощью команды РЗМПРИКРЕПИТЬ.

Примечание В случае потери ассоциативности размера в командной строке выводится предупреждающее сообщение.

Редактирование неассоциативных размеров

В случае неассоциативных размеров для обновления размеров при редактировании объектов с нанесенными размерами необходимо включать в набор точки, определяющие размер. Эти точки задают расположение размера. Так, например, для растягивания размера необходимо включить в набор соответствующую определяющую точку при выборе редактируемого объекта. Это можно легко сделать, включив ручки и выбрав редактируемый объект таким образом, чтобы нужные ручки стали выделенными.

На следующих чертежах показаны определяющие точки разных типов размеров. Точка середины размерного текста является определяющей для любого типа размера.

Если вершина угла не отображается, определяющие точки располагаются на концах линий, образующих угол. В примере с двухлинейным углом определяющая точка расположена в центре измеряемой дуги.

Примечание Определяющие точки наносятся на специальном слое DEFPOINTS; объекты, расположенные на этом слое, никогда не выводятся на плоттер.

Редактирование расчлененных размеров

Расчлененные размеры можно редактировать как и любые другие объекты, поскольку они состоят из отдельных объектов: линий, двухмерных фигур и текста. Иногда размер требуется расчленить, когда, например, нужно разорвать размерную или выносную линию. Расчлененный размер нельзя объединить обратно в единый размерный объект.

См. также

Редактирование размерных стилей


Редактирование размеров

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Редактирование размеров
Понятия
Процедуры
Команды

Нет процедур.


Редактирование геометрии размеров - Команды

Размеры и допуски
Размеры и допуски
Редактирование геометрии размеров
Понятия
Процедуры
Команды

Команды
РАСТЯНУТЬ | Перенос или растягивание объектов
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
РЗМОТКРЕПИТЬ | Отмена ассоциативности выбранных размеров
РЗМПРИКРЕПИТЬ | Ассоциирование выбранных размеров с геометрическими объектами
РЗМРЕД | Редактирование размерного текста и выносных линий на объектах для нанесения размеров
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение ассоциативности размеров - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Изменение ассоциативности размеров
Понятия
Процедуры
Команды

В некоторых случаях может понадобиться изменить ассоциативность размеров. Например, размеры, нанесенные на чертеже с помощью предыдущих версий программы, можно сделать ассоциативными.

Изменение ассоциативности размеров может потребоваться в следующих случаях:

  • После внесения значительных изменений в чертежи.
  • При частичной утрате размерами ассоциативных связей.
  • После загрузки чертежей, созданных в прежних версиях программы.
  • Удалите ассоциативность размеров на чертежах, которые будут использоваться в более ранних версиях, чем AutoCAD 2002, если наличие объектов заместителей не требуется.
Ассоциативное связывание размеров с различными объектами

С помощью команды РЗМПРИКРЕПИТЬ пользователь может выбрать один или несколько размеров и пройти через исходные точки выносной линии каждого размера. Для каждой исходной точки выносной линии можно задать новую точку прикрепления на геометрическом объекте. Точки прикрепления определяют места связи выносных линий с объектами.

Примечание В процессе создания или редактирования ассоциативных размеров важно тщательно указывать точки прикрепления, для того чтобы сохранялась возможность дальнейшего редактирования объектов совместно с прикрепленными к ним размерами.

При использовании команды РЗМПРИКРЕПИТЬ появляется маркер, показывающий наличие или отсутствие ассоциативной связи для исходной точки каждой последовательной выносной линии размера. Маркер в виде крестика в квадрате обозначает наличие ассоциативной связи начальной точки с точкой объекта, маркер в виде крестика без квадрата - отсутствие связи. Для указания новой связи для исходной точки выносной линии необходимо воспользоваться объектной привязкой или нажать ENTER для перехода к исходной точке следующей выносной линии.

Примечание Маркер исчезает при панорамировании или зумировании с помощью мыши.

Преобразование неассоциативных размеров в ассоциативные

Все неассоциативные размеры чертежа можно быстро и просто преобразовать в ассоциативные. С помощью команды БВЫБОР выбираются все неассоциативные размеры, а затем командой РЗМПРИКРЕПИТЬ задаются ассоциативные связи с точками объектов путем перебора всех выбранных размеров.

Преобразование ассоциативных размеров в неассоциативные

Все ассоциативные размеры чертежа можно быстро и просто преобразовать в неассоциативные. С помощью команды БВЫБОР выбираются все ассоциативные размеры, затем командой РЗМОТКРЕПИТЬ выбранные размеры преобразовываются в неассоциативные.

См. также

Ассоциативные размеры

Сохранение чертежей в форматах прежних версий


Изменение ассоциативности размеров - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Изменение ассоциативности размеров
Понятия
Процедуры
Команды

Ассоциативное прикрепление размеров к объектам

Разрыв ассоциативной связи размеров с объектами


Ассоциативное прикрепление размеров к объектам - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Изменение ассоциативности размеров
Понятия
Процедуры
Команды

Ассоциативное прикрепление размеров к объектам

  1. Нажмите "Размеры" » "Прикрепить размеры".
  2. Выберите один или несколько размеров для ассоциативного прикрепления.
  3. Выполнить одно из следующих действий:
    • Укажите новое положение начальной точки выносной линии.
    • Введите с и выберите геометрический объект для ассоциативного связывания с размером.
    • Нажмите ENTER для пропуска начальной точки текущей выносной линии и перехода к следующей.
    • Нажмите ESC для завершения команды с сохранением уже установленной ассоциативности размеров.
  4. Повторить предыдущий пункт нужное число раз.

Ввод команды: РЗМПРИКРЕПИТЬ


Разрыв ассоциативной связи размеров с объектами - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Изменение ассоциативности размеров
Понятия
Процедуры
Команды

Разрыв ассоциативной связи размеров с объектами

  1. В командной строке введите РЗМОТКРЕПИТЬ.
  2. Выделите размеры, для которых требуется удалить ассоциативную связь, и нажмите ENTER.


Изменение ассоциативности размеров - Команды

Размеры и допуски
Размеры и допуски
Изменение ассоциативности размеров
Понятия
Процедуры
Команды

Команды
РАСЧЛЕНИТЬ | Разбиение составного объекта на составляющие его объекты
РЗМОТКРЕПИТЬ | Отмена ассоциативности выбранных размеров
РЗМПРИКРЕПИТЬ | Ассоциирование выбранных размеров с геометрическими объектами
РЗМРЕГЕН | Обновление расположения всех ассоциативных размеров
Системные переменные
DIMASSOC | Управляет ассоциативностью размерных объектов и расчленением размеров.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нанесение допусков формы и расположения - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение допусков формы и расположения
Понятия
Процедуры
Команды

Имеется возможность нанесения допусков формы и расположения, выражающих отклонения формы, контура, ориентации и расположения элементов чертежа.

  • Коротко о допусках формы и расположения
  • Зависимые допуски
    Зависимые допуски связаны с элементами, размеры которых могут варьироваться.
  • Комплект базовых плоскостей
    За величиной допуска в рамке допуска формы и расположения можно проставить до трех необязательных обозначений баз с символами-модификаторами.
  • Выступающие поля допуска расположения
    Дополнительно к позиционным допускам для их уточнения можно задавать выступающие поля допуска.
  • Составные допуски
    В составных допусках указываются два допуска для одной геометрической характеристики элемента, либо для элементов с различными требованиями к базам.


Нанесение допусков формы и расположения - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение допусков формы и расположения
Понятия
Процедуры
Команды

Нанесение допуска формы и расположения

Нанесение допуска формы и расположения с выноской


Нанесение допусков формы и расположения - Команды

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение допусков формы и расположения
Понятия
Процедуры
Команды
Команды
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ДОПУСК | Нанесение допусков формы и расположения
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о допусках формы и расположения - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Коротко о допусках формы и расположения
Понятия
Процедуры
Команды

Допуски формы и расположения иллюстрируют отклонения формы, контура, ориентации и расположения элементов чертежа. Такие допуски проставляются в прямоугольных рамках. В каждой рамке содержится исчерпывающая информация по допускам для соответствующего размера. Допуски формы и расположения могут строиться как с выносками, так и без них, в зависимости от используемой команды для нанесения допусков (ДОПУСК или ВЫНОСКА).

Рамка допуска формы и расположения состоит, по меньшей мере, из двух частей. В первой находится графический символ, обозначающий вид допуска (формы, расположения, сечения, биения и т.п.). Допуски формы подразделяются на допуски прямолинейности, плоскостности, округлости, цилиндричности и профиля продольного сечения. На чертеже обозначен позиционный допуск.

Редактирование рамок допусков формы и расположения осуществляется многими командами редактирования, а также с помощью ручек. Кроме того, для их указания можно использовать режимы объектной привязки. Также их можно редактировать с помощью ручек.

Примечание В отличие от размеров и выносок, допуски формы и расположения не могут ассоциативно прикрепляться к геометрическим объектам.


Коротко о допусках формы и расположения - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Коротко о допусках формы и расположения
Понятия
Процедуры
Команды

Нанесение допуска формы и расположения

Нанесение допуска формы и расположения с выноской


Нанесение допуска формы и расположения - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Коротко о допусках формы и расположения
Понятия
Процедуры
Команды

Нанесение допуска формы и расположения

  1. Нажмите "Размеры" » "Допуск".
  2. В диалоговом окне "Допуски формы и расположения" нажмите на первой ячейке группы "Симв" и выберите обозначение вида допуска.
  3. В группе "Допуск 1" нажмите на крайней слева ячейке для нанесения диаметра.
  4. В текстовом поле введите значение для первого допуска.
  5. Если необходимо добавить символ зависимого допуска, нажмите на крайней справа ячейке, затем в диалоговом окне "Зависимый допуск" нажмите на нужном символе зависимого допуска.
  6. Если необходимо, таким же образом проставьте второй допуск.
  7. Нанесите буквенные обозначения баз в полях соответствующих групп.
  8. Для каждой базы нажмите на соответствующей ячейке справа для вставки символа-модификатора.
  9. В поле "Высота" введите значение высоты.
  10. Нажмите на ячейке "Выступающее поле допуска" для вставки символа.
  11. В поле "Идентификатор базы" добавьте значение базы.
  12. Нажмите "ОК".
  13. Укажите на чертеже положение рамки допуска.

Панель "Размеры"

Ввод команды: ДОПУСК


Нанесение допуска формы и расположения с выноской - Процедуры

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Коротко о допусках формы и расположения
Понятия
Процедуры
Команды

Нанесение допуска формы и расположения с выноской

  1. В командной строке введите выноска.
  2. Укажите начальную точку выноски.
  3. Укажите вторую точку выноски.
  4. Дважды нажмите ENTER для вывода запросов на ввод обозначений.
  5. Введите д (Допуск) для нанесения рамки допуска формы и расположения.

    6. Рамка допуска формы и расположения наносится у конечной точки выноски.

Ввод команды: ВЫНОСКА


Коротко о допусках формы и расположения - Команды

Размеры и допуски
Размеры и допуски
Коротко о допусках формы и расположения
Понятия
Процедуры
Команды

Команды
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ДОПУСК | Нанесение допусков формы и расположения
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Зависимые допуски - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Зависимые допуски
Понятия
Процедуры
Команды

Зависимые допуски связаны с элементами, размеры которых могут варьироваться.

Во второй части допуска формы и расположения помещается числовое значение допуска. Перед значением может быть проставлено обозначение диаметра, а после значения - один из символов зависимого допуска.

Зависимые допуски связаны с элементами, размеры которых могут варьироваться.

  • При максимально допустимом припуске (символ "М", также известный как "МДП") элемент содержит максимальное количество материала, указанное значением допуска.
  • При МДП отверстие имеет минимальный диаметр, тогда как вал - максимальный.
  • При минимально допустимом припуске (символ "L") элемент содержит минимальное количество материала, указанное значением допуска.
  • В этом случае отверстие имеет максимальный диаметр, а вал - минимальный.
  • Произвольным зависимым допуском (символ "S") считается тот, при котором в детали может содержаться любое в допустимых пределах количество материала.


Нанесение допусков формы и расположения

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Нанесение допусков формы и расположения
Понятия
Процедуры
Команды

Нет процедур.


Зависимые допуски - Команды

Размеры и допуски
Размеры и допуски
Зависимые допуски
Понятия
Процедуры
Команды

Команды
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ДОПУСК | Нанесение допусков формы и расположения
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Комплект базовых плоскостей - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Комплект базовых плоскостей
Понятия
Процедуры
Команды

За величиной допуска в рамке допуска формы и расположения можно проставить до трех необязательных обозначений баз с символами-модификаторами. Базой называется теоретически точный элемент детали (точка, ось или плоскость), относительно которой производятся измерения и контроль размеров. Обычно в роли баз выступают две или три взаимно перпендикулярные плоскости. В совокупности они называются комплектом базовых плоскостей.

На следующем чертеже изображен комплект базовых плоскостей, используемый для контроля размеров детали.


Комплект базовых плоскостей - Команды

Размеры и допуски
Размеры и допуски
Комплект базовых плоскостей
Понятия
Процедуры
Команды

Команды
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ДОПУСК | Нанесение допусков формы и расположения
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выступающие поля допуска расположения - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Выступающие поля допуска расположения
Понятия
Процедуры
Команды

Дополнительно к позиционным допускам для их уточнения можно задавать выступающие поля допуска. Они могут, например, определять допуск перпендикулярности для детали, вставляемой или вворачиваемой в отверстие другой.

Перед символом выступающего поля допуска ( [image]) ставится значение высоты, обозначающее минимальное выступающее поле допуска. Высота и сам символ проставляются в рамке, расположенной под рамкой допуска формы и расположения, как показано на следующем чертеже.


Выступающие поля допуска расположения - Команды

Размеры и допуски
Размеры и допуски
Выступающие поля допуска расположения
Понятия
Процедуры
Команды

Команды
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ДОПУСК | Нанесение допусков формы и расположения
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Составные допуски - Понятия

Штриховка, пояснения, таблицы и размеры
Размеры и допуски
Составные допуски
Понятия
Процедуры
Команды

В составных допусках указываются два допуска для одной геометрической характеристики элемента, либо для элементов с различными требованиями к базам. Первый допуск относится к системе элементов, второй - к каждому элементу в отдельности. При этом второй допуск является более строгим, чем первый.

На чертеже пересечение базовых плоскостей A и B образует базовую ось, от которой определяется положение системы.

На следующем чертеже составной допуск относится и к диаметру системы отверстий, и диаметру каждого отверстия в отдельности.

При нанесении составного допуска вначале создается первая строка рамки допусков формы и расположения, а затем указывается тот же самый символ вида допуска для второй строки. Часть геометрического символа расширяется по обеим линиям. После этого вычерчивается вторая строка рамки.


Составные допуски - Команды

Размеры и допуски
Размеры и допуски
Составные допуски
Понятия
Процедуры
Команды

Команды
ВЫНОСКА | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
ДОПУСК | Нанесение допусков формы и расположения
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Печать и публикация чертежей

Подготовка чертежей к печати и публикации
При подготовке чертежа к печати или публикации ему назначается ряд параметров, сохраняемых в файле чертежа в виде набора для каждого листа. Настройка может осуществляться либо путем редактирования отдельных параметров, либо применением к листу какого-либо из ранее сохраненных наборов.

Вывод чертежей на печать
Понятие "печать чертежа" для подготовленных в AutoCAD чертежей объединяет в себе процессы получения вычерченных бумажных копий или электронных чертежей, которые могут использоваться в других приложениях. В обоих случаях необходимо настроить параметры печати.

Публикация чертежей
Имеется возможность без труда опубликовать всю подшивку из Диспетчера подшивок как комплект чертежей на бумаге или как единый, содержащий много листов файл формата Design Web Format™ (DWF™).


Печать и публикация чертежей - Понятия

Печать и публикация чертежей
Печать и публикация чертежей
Печать и публикация чертежей
Понятия
Процедуры
Команды

При подготовке чертежа к печати или публикации ему назначается ряд параметров листа. Эти параметры сохраняются в файле чертежа для листа. После создания листа можно редактировать настройки параметров листа либо применять к листу другие параметры листа.

Готовый чертеж можно распечатать на листе бумаги или вывести в файл для использования в других приложениях. В обоих случаях перед выводом необходимо настроить параметры печати.

Публикацией называется процесс вывода набора чертежей на бумагу или в DWF-файл (Design Web Format). Опубликованный набор чертежей является электронным эквивалентом набора печатных чертежей, созданным на основе чертежей AutoCAD.


Печать и публикация чертежей - Процедуры

Печать и публикация чертежей
Печать и публикация чертежей
Печать и публикация чертежей
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Печать и публикация чертежей - Команды

Печать и публикация чертежей
Печать и публикация чертежей
Печать и публикация чертежей
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Подготовка чертежей к печати и публикации - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Понятия
Процедуры
Команды

При подготовке чертежа к печати или публикации ему назначается ряд параметров, сохраняемых в файле чертежа в виде набора для каждого листа. Настройка может осуществляться либо путем редактирования отдельных параметров, либо применением к листу какого-либо из ранее сохраненных наборов.

  • Основные сведения о подготовке чертежей к печати и публикации
    Подготовка чертежа к печати или публикации требует задания многих параметров и опций, определяющих внешний вид чертежа. Эти параметры могут быть сохранены как набор параметров листа.
  • Задание настроек параметров листа
    Параметры листа связаны с листами и хранятся в файле чертежа. Настройки, заданные в параметрах листа, определяют вид и формат листа, как он будет напечатан или опубликован.
  • Задание параметров листа с помощью Мастера компоновки листа
    Новую разметку листа можно создать с помощью Мастера компоновки листа.
  • Импорт настроек PCP или PC2 в компоновку листа
    Можно импортировать в текущую разметку листа параметры листа и печати, содержащиеся в файлах PCP или PC2.
  • Создание и использование наборов параметров листов
    Настройки устройства печати и другие параметры листа можно сохранить в наборе параметров листов. Созданный таким образом набор параметров листа можно впоследствии изменить или импортировать в другие чертежи.
  • Использование наборов параметров листов в подшивках
    Наборы параметров листов можно использовать для задания одних и тех же опций вывода для всех листов подшивки.


Подготовка чертежей к печати и публикации - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Понятия
Процедуры
Команды

Изменение настроек разметки в параметрах листа

Применение именованного набора параметров разметки одного листа к другой разметке листа

Выбор принтера или плоттера для разметки листа

Изменение конфигурации принтера или плоттера, определенного в параметрах листа

Задание формата бумаги для разметки листа

Запуск редактора параметров плоттера

Создание пользовательского формата листа бумаги с нуля

Создание нового пользовательского формата листа бумаги на основе имеющегося формата

Редактирование нестандартного формата листа

Удаление нестандартного формата листа

Изменение стандартного формата листа бумаги

Задание области печати

Задание смещения печати для разметки листа

Задание масштаба печати

Подбор масштаба в зависимости от формата листа при печати

Масштабирование весов линий

Выбор таблицы стилей печати для разметки листа

Создание новой таблицы стилей печати для разметки листа

Изменение таблицы стилей печати для разметки листа

Просмотр содержимого листа с учетом таблицы стилей печати

Задание параметров печати видовых экранов с раскрашиванием

Установка опций печати для листа

Задание ориентации вывода чертежа

Создание разметки листа с помощью Мастера

Импорт параметров из PCP или PC2 в текущую разметку листа

Создание новых наборов параметров листов

Применение набора параметров листов к какой-либо разметке листа

Изменение набора параметров листов

Импорт набора параметров листов из другого чертежа

Удаление набора параметров листов

Переименование набора параметров листов

Применение набора параметров к листу подшивки, созданному с нуля

Применение набора параметров листов в качестве переопределения при публикации листов


Подготовка чертежей к печати и публикации - Команды

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Понятия
Процедуры
Команды
Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
ИМПОРТПЛ | Импорт набора параметров листа из другого файла чертежа во вновь создаваемый лист
МАСТЕРЛИСТ | Создание нового листа, задание параметров листа и печати
МАСТЕРПЕЧ | Вызов Мастера для импорта параметров печати из PCP- и PC2-файлов настройки для вкладки "Модель" или текущего листа
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПОДШИВКА | Вызов диспетчера подшивок
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
СПИСМАСШТРЕД | Управление списком доступных значений масштаба для видовых экранов, листа и печати
Системные переменные
PLOTOFFSET | Управляет способом отсчета смещения чертежа относительно печатаемой области или кромок листа бумаги
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Основные сведения о подготовке чертежей к печати и публикации - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Основные сведения о подготовке чертежей к печати и публикации
Понятия
Процедуры
Команды

Подготовка чертежа к печати или публикации требует задания многих параметров и опций, определяющих внешний вид чертежа. Эти параметры могут быть сохранены как набор параметров листа.

Один и тот же набор параметров листов можно назначить нескольким листам с помощью Диспетчера наборов параметров листов. Можно также импортировать набор параметров листов из другого чертежа и применить его к листам в текущем чертеже.

Наборы параметров листов используются в тех случаях, когда необходимо задать одни и те же настройки вывода на печать для нескольких листов.


Основные сведения о подготовке чертежей к печати и публикации - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Основные сведения о подготовке чертежей к печати и публикации
Понятия
Процедуры
Команды

Команды
ИМПОРТПЛ | Импорт набора параметров листа из другого файла чертежа во вновь создаваемый лист
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание настроек параметров листа - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание настроек параметров листа
Понятия
Процедуры
Команды

Параметры листа связаны с листами и хранятся в файле чертежа. Настройки, заданные в параметрах листа, определяют вид и формат листа, как он будет напечатан или опубликован.

  • Обзор настроек параметров листа
    Параметры листа - это набор устройств печати и других настроек, определяющих вид и формат листа, как он будет напечатан или опубликован. Эти параметры можно изменять и применять к другим листам.
  • Выбор принтера или плоттера для листа
    При создании разметки листа необходимо в диалоговом окне "Параметры листа" выбрать принтер или плоттер для его вывода на печать.
  • Задание формата бумаги для разметки листа
    Формат бумаги можно выбрать из стандартного списка. Также можно задать пользовательский нестандартный формат с помощью редактора параметров плоттера.
  • Установка печатаемой области в разметке листа
    Можно указать печатаемую область, т.е. пространственную часть чертежа, которая должна быть выведена на печать.
  • Регулировка смещения от начала для разметки листа
    Печатаемая область листа чертежа определяется выбранным устройством вывода на печать и обозначается на листе штриховой линией. При смене устройства вывода на печать область печати может измениться.
  • Задание масштаба печати
    При выводе чертежа на печать можно либо задать точный масштаб, либо воспользоваться режимом вписывания чертежа в заданный формат листа бумаги.
  • Задание масштаба весов линий
    Веса линий на выводимых листах можно пропорционально масштабировать в соответствии с масштабом печати.
  • Выбор таблицы стилей печати для разметки листа
    Таблица стилей печати содержит набор стилей печати, назначенных разметке листа или модели.
  • Задание параметров печати для видовых экранов с раскрашиванием
    Ряд настроек, сохраняющихся в параметрах листа, позволяет задавать параметры вывода на печать видовых экранов, содержащих раскрашенные тела.
  • Задание ориентации чертежа
    Переключатель ориентации чертежа имеет два положения: "Альбомная" и "Книжная".


Задание настроек параметров листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание настроек параметров листа
Понятия
Процедуры
Команды

Изменение настроек разметки в параметрах листа

Применение именованного набора параметров разметки одного листа к другой разметке листа

Выбор принтера или плоттера для разметки листа

Изменение конфигурации принтера или плоттера, определенного в параметрах листа

Задание формата бумаги для разметки листа

Запуск редактора параметров плоттера

Создание пользовательского формата листа бумаги с нуля

Создание нового пользовательского формата листа бумаги на основе имеющегося формата

Редактирование нестандартного формата листа

Удаление нестандартного формата листа

Изменение стандартного формата листа бумаги

Задание области печати

Задание смещения печати для разметки листа

Задание масштаба печати

Подбор масштаба в зависимости от формата листа при печати

Масштабирование весов линий

Выбор таблицы стилей печати для разметки листа

Создание новой таблицы стилей печати для разметки листа

Изменение таблицы стилей печати для разметки листа

Просмотр содержимого листа с учетом таблицы стилей печати

Задание параметров печати видовых экранов с раскрашиванием

Установка опций печати для листа

Задание ориентации вывода чертежа


Задание настроек параметров листа - Команды

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание настроек параметров листа
Понятия
Процедуры
Команды
Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
СПИСМАСШТРЕД | Управление списком доступных значений масштаба для видовых экранов, листа и печати
Системные переменные
PLOTOFFSET | Управляет способом отсчета смещения чертежа относительно печатаемой области или кромок листа бумаги
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор настроек параметров листа - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Обзор настроек параметров листа
Понятия
Процедуры
Команды

Параметры листа - это набор устройств печати и других настроек, определяющих вид и формат листа, как он будет напечатан или опубликован. Эти параметры можно изменять и применять к другим листам.

После того как чертеж полностью построен на вкладке "Модель", пользователь может cформировать компоновку листа для вывода чертежа на печать. При первом открытии вкладки разметки на листе отображается один видовой экран. Пунктирная линия обозначает печатаемую область листа для текущих настроек формата и печатающего устройства.

Подготавливая разметку листа, пользователь задает настройки параметров листа и настройки устройства печати для вывода. Пользовательские настройки параметров листа сохраняются в файле чертежа вместе с листом. Пользователь может изменить настройки параметров листа в любое время.

По умолчанию каждая инициализированная разметка листа имеет свои параметры. Разметка листа инициализируется, если в параметрах листа определяется любое, отличное от 0 x 0, значение его размера. Имеется возможность применить набор параметров листа, сохраненный для одной разметки листа, к другой. При этом создается новый набор параметров листа, имеющий те же настройки, что и исходный набор.

Для того чтобы каждый раз при начале работы с новой разметкой листа открывался Диспетчер наборов параметров листа, следует установить флажок "Диспетчер параметров для новых разметок листов" на вкладке "Экран" диалогового окна "Настройка". Если не нужно, чтобы при каждой новой разметке листа автоматически создавался видовой экран, следует опустить там же флажок "Создавать видовые экраны при новой разметке листа".


Обзор настроек параметров листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Обзор настроек параметров листа
Понятия
Процедуры
Команды

Изменение настроек разметки в параметрах листа

Применение именованного набора параметров разметки одного листа к другой разметке листа


Изменение настроек разметки в параметрах листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Обзор настроек параметров листа
Понятия
Процедуры
Команды

Изменение настроек разметки в параметрах листа

  1. Выберите вкладку разметки листа, параметры которого необходимо изменить.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" измените нужные настройки. Нажмите "OK".
  6. В Диспетчере наборов параметров листов нажмите "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Применение именованного набора параметров разметки одного листа к другой разметке листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Обзор настроек параметров листа
Понятия
Процедуры
Команды

Применение именованного набора параметров разметки одного листа к другой разметке листа

  1. Выберите вкладку разметки листа, к которой необходимо применить настройки параметров другой разметки.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите именованный набор параметров разметки листа, который надо применить к данной разметке.
  4. Нажмите кнопку "Установить как текущее".
  5. Нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Обзор настроек параметров листа - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Обзор настроек параметров листа
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор принтера или плоттера для листа - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Выбор принтера или плоттера для листа
Понятия
Процедуры
Команды

При создании разметки листа необходимо в диалоговом окне "Параметры листа" выбрать принтер или плоттер для его вывода на печать. После выбора устройства можно просматривать сведения об имени и местоположении устройства, а также изменять параметры его настройки.

От того, какой принтер или плоттер был выбран пользователем в диалоговом окне "Параметры листа", зависит печатаемая область листа. Она обозначается на разметке листа штриховой линией. При изменении размера бумаги или устройства печати может измениться область печати чертежа.

См. также

Выбор принтера или плоттера

Настройка параметров устройства и документа в PC3-файле в документе Руководство по периферийным устройствам


Выбор принтера или плоттера для листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Выбор принтера или плоттера для листа
Понятия
Процедуры
Команды

Выбор принтера или плоттера для разметки листа

Изменение конфигурации принтера или плоттера, определенного в параметрах листа


Выбор принтера или плоттера для разметки листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Выбор принтера или плоттера для листа
Понятия
Процедуры
Команды

Выбор принтера или плоттера для разметки листа

  1. Выберите вкладку разметки листа, для которой необходимо определить принтер или плоттер.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в списке "Принтер/Плоттер" выберите принтер или плоттер. Нажмите "OK".
  6. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на ярлыке вкладки разметки листа и выберите из контекстного меню "Диспетчер наборов параметров листов".


Изменение конфигурации принтера или плоттера, определенного в параметрах листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Выбор принтера или плоттера для листа
Понятия
Процедуры
Команды

Изменение конфигурации принтера или плоттера, определенного в параметрах листа

  1. Выберите вкладку разметки листа, для которой необходимо определить принтер или плоттер.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Принтер/Плоттер" нажмите "Свойства".
  6. В редакторе параметров плоттера измените требуемые настройки. Нажмите "OK".
  7. В диалоговом окне "Параметры листа" нажмите "ОК".
  8. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Выбор принтера или плоттера для листа - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Выбор принтера или плоттера для листа
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание формата бумаги для разметки листа - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание формата бумаги для разметки листа
Понятия
Процедуры
Команды

Формат бумаги можно выбрать из стандартного списка. Перечень присутствующих в списке форматов определяется установкой текущего для данной разметки листа плоттера. Если плоттер сконфигурирован на вывод в растровом формате, размеры изображения задаются в пикселах. Используя редактор настроек плоттера, можно добавить свои форматы бумаги и сохранить их в файле конфигурации плоттера (PC3).

При выводе на системный принтер формат по умолчанию берется из Панели управления Windows. Именно этот формат первоначально предлагается в диалоговом окне "Параметры листа" при создании новой разметки листа. Если изменяется формат, новое значение запоминается вместе с разметкой листа; оно имеет приоритет перед форматом, хранящимся в файле конфигурации плоттера (PC3).

См. также

Настройка параметров устройства и документа в PC3-файле в документе Руководство по периферийным устройствам


Задание формата бумаги для разметки листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание формата бумаги для разметки листа
Понятия
Процедуры
Команды

Задание формата бумаги для разметки листа

Запуск редактора параметров плоттера

Создание пользовательского формата листа бумаги с нуля

Создание нового пользовательского формата листа бумаги на основе имеющегося формата

Редактирование нестандартного формата листа

Удаление нестандартного формата листа

Изменение стандартного формата листа бумаги


Задание формата бумаги для разметки листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание формата бумаги для разметки листа
Понятия
Процедуры
Команды

Задание формата бумаги для разметки листа

  1. Выберите вкладку разметки листа, размер бумаги для которого необходимо задать.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в списке "Формат листа" выберите формат бумаги для печати. Нажмите "OK".
  6. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Запуск редактора параметров плоттера - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание формата бумаги для разметки листа
Понятия
Процедуры
Команды

Запуск редактора параметров плоттера

  1. Выберите "Файл" » "Диспетчер плоттеров...".
  2. В Диспетчере плоттеров дважды нажмите кнопку мыши на значке PC3-файла, в котором нужно изменить конфигурацию плоттера.

    3. Открывается редактор параметров плоттера.

Ввод команды: ДИСППЕЧ


Создание пользовательского формата листа бумаги с нуля - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание формата бумаги для разметки листа
Понятия
Процедуры
Команды

Создание пользовательского формата листа бумаги с нуля

  1. Нажмите "Файл" » "Диспетчер плоттеров...".
  2. В Диспетчере плоттеров дважды нажмите на значке PC3-файла, в котором нужно изменить конфигурацию плоттера.
  3. В редакторе параметров плоттеров на вкладке "Параметры устройства и документа" дважды нажмите на "Нестандартных форматах и калибровке" для отображения параметров калибровки и формата листа бумаги для печати.
  4. Выберите "Нестандартные форматы бумаги".
  5. В группе "Нестандартные форматы бумаги" нажмите "Добавить".
  6. В Мастере пользовательских форматов бумаги на странице "Начало" выберите "Начать заново". Нажмите "Далее".
  7. На страничке "Медиа-границы" в списке "Единицы" выберите "Миллиметры" или "Дюймы".

    8. Если печатается растровое изображение (например BMP- или TIFF-файл), не имеющее определенных размеров, формат задается только в пикселах.

  8. В списках "Ширина" и "Длина" укажите размеры листа. Нажмите "Далее".

    9. Примечание Для каждого плоттера существует ограничение на область вывода, в пределах которой может перемещаться контейнер с перьями. При задании формата, размеры которого больше предлагаемых Мастером, следует убедиться, что имеющийся плоттер может выводить чертежи в указанных размерах.

  9. На страничке "Область печати" в полях "Верх", "Низ", "Слева" и "Справа" задайте размеры полей области печати. Нажмите "Далее".
  10. На страничке "Имя формата" введите имя для идентификации данного нестандартного формата. Нажмите "Далее".
  11. На страничке "Имя файла" введите имя для PMP-файла.
  12. На конечной странице выберите источник подави бумаги - листовая или рулонная.
  13. Нажмите кнопку "Тестовая печать" для проверки созданного нестандартного формата.

    14. Напечатаются перекрестье, определяющее формат листа, и прямоугольник, определяющий область печати. Если какие-либо стороны рамки отсутствуют, следует увеличить область печати.

  14. Нажмите "Готово" для выхода из Мастера.

Ввод команды: ДИСППЕЧ


Создание нового пользовательского формата листа бумаги на основе имеющегося формата - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание формата бумаги для разметки листа
Понятия
Процедуры
Команды

Создание нового пользовательского формата листа бумаги на основе имеющегося формата

  1. Нажмите "Файл" » "Диспетчер плоттеров...".
  2. В Диспетчере плоттеров дважды нажмите кнопку мыши на значке PC3-файла, в котором нужно изменить конфигурацию плоттера.
  3. В Редакторе параметров плоттеров на вкладке "Параметры устройства и документа" дважды нажмите на "Нестандартных форматах и калибровке" для отображения настроек калибровки и формата бумаги.
  4. Выберите "Нестандартные форматы бумаги".
  5. В группе "Нестандартные форматы бумаги" нажмите "Добавить".
  6. В Мастере пользовательских форматов листа бумаги на странице "Начало" выберите "По существующему формату".
  7. В списке имеющихся стандартных форматов выберите формат, на основе которого будет создан новый.
  8. Дальнейшие действия, выполняемые в Мастере пользовательских форматов листа, описаны в разделе Создание пользовательского формата листа бумаги с нуля .

    9. Созданный таким образом формат считается нестандартным.

  9. Нажмите "Готово" для выхода из Мастера.

Ввод команды: ДИСППЕЧ


Редактирование нестандартного формата листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание формата бумаги для разметки листа
Понятия
Процедуры
Команды

Редактирование нестандартного формата листа

  1. Нажмите "Файл" » "Диспетчер плоттеров...".
  2. В Диспетчере плоттеров дважды нажмите кнопку мыши на значке PC3-файла, в котором нужно изменить конфигурацию плоттера.
  3. В Редакторе параметров плоттеров на вкладке "Параметры устройства и документа" дважды нажмите на "Нестандартных форматах и калибровке" для отображения настроек калибровки и формата листа.
  4. Выберите "Нестандартные форматы бумаги".
  5. В списке группы опций "Нестандартные форматы бумаги" выберите требуемый формат. Нажмите кнопку "Правка".
  6. В окне Мастера пользовательских форматов листа изменить размер листа или области печати, имя формата или источник носителя.
  7. Нажмите "Готово" для выхода из Мастера.

Ввод команды: ДИСППЕЧ


Удаление нестандартного формата листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание формата бумаги для разметки листа
Понятия
Процедуры
Команды

Удаление нестандартного формата листа

  1. Нажмите "Файл" » "Диспетчер плоттеров...".
  2. В Диспетчере плоттеров произвести двойное нажатие значка PC3-файла, в котором нужно изменить конфигурацию плоттера.
  3. В Редакторе параметров плоттеров на вкладке "Параметры устройства и документа" дважды нажмите элемент "Нестандартные форматы и калибровка" для отображения настроек калибровки и формата листа.
  4. Нажмите "Нестандартные форматы бумаги".
  5. В списке группы опций "Нестандартные форматы бумаги" выберите требуемый формат.
  6. Нажмите кнопку "Удалить".

Ввод команды: ДИСППЕЧ


Изменение стандартного формата листа бумаги - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание формата бумаги для разметки листа
Понятия
Процедуры
Команды

Изменение стандартного формата листа бумаги

  1. Нажмите "Файл" » "Диспетчер плоттеров...".
  2. В Диспетчере плоттеров дважды нажмите на значке PC3-файла, в котором нужно изменить конфигурацию плоттера.
  3. В редакторе параметров плоттеров на вкладке "Параметры устройства и документа" дважды нажмите на "Нестандартных форматах и калибровке" для отображения настроек калибровки и формата листов бумаги.
  4. Выберите "Изменение стандартных форматов бумаги".
  5. В списке группы "Изменение стандартных форматов бумаги" выберите формат для его изменения. Нажмите кнопку "Редактирование".
  6. В Мастере пользовательских форматов листа измените область печати. Нажмите "Готово" для выхода из Мастера.

Ввод команды: ДИСППЕЧ


Задание формата бумаги для разметки листа - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Задание формата бумаги для разметки листа
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Установка печатаемой области в разметке листа - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Установка печатаемой области в разметке листа
Понятия
Процедуры
Команды

Готовя модель или лист к печати, можно указать печатаемую область, т.е. пространственную часть чертежа, которая должна быть выведена на печать. При создании новой разметки листа в качестве печатаемой области используется настройка по умолчанию "Разметка листа". Это значит, что печатаются все объекты, попадающие в область печати выбранного формата листа.

Для печати всех объектов, отображаемых в графической области окна, используется настройка печатаемой области "Экран". Для печати всех видимых объектов чертежа применяется настройка печатаемой области "Границы". Настройка печатаемой области "Вид" позволяет печатать сохраненный ранее вид. Для печати объектов в пределах указанной области используется настройка печатаемой области "Рамка".

См. также

Задание области печати


Задание области печати - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Установка печатаемой области в разметке листа
Понятия
Процедуры
Команды

Задание области печати

  1. Выберите вкладку разметки листа, для которой необходимо задать область печати и параметры отображения.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Область печати" выберите одну из следующих опций:
    • Разметка листа. Печать всех объектов, находящихся в печатаемой области листа. Опция доступна только для вкладок разметок листа.
    • Лимиты. Печать в пределах границ сетки. Опция доступна только для вкладок модели.
    • Границы. Печать всех объектов на чертеже.
    • Экран. Печать всех объектов, отображаемых в пределах области рисования.
    • Вид. Печать сохраненного вида. Вид выбирается из предлагаемого списка именованных видов.
    • Рамка. Печать объектов в пределах задаваемой пользователем области. Выберите опцию "Рамка" и в ответ на запрос укажите нужную область. Кнопкой "Рамка" можно воспользоваться также для того, чтобы изменить заданную область.
  6. Нажмите "ОК".
  7. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Установка печатаемой области в разметке листа - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Установка печатаемой области в разметке листа
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Регулировка смещения от начала для разметки листа - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Регулировка смещения от начала для разметки листа
Понятия
Процедуры
Команды

Печатаемая область листа чертежа определяется выбранным устройством вывода на печать и обозначается на листе штриховой линией. При смене устройства вывода на печать область печати может измениться.

Смещение печати задается от нижнего левого угла печатаемой области или края листа бумаги в зависимости от настройки параметра "Отсчет смещения чертежа" в диалоговом окне "Настройка" на вкладке "Печать/Публикация". Выбранный вариант смещения приводится в круглых скобках после названия группы опций "Смещение от начала" в диалоговом окне "Печать".

Смещение можно задать, введя положительные или отрицательные значения в поля "X" и "Y". Однако это может привести к усечению чертежа при печати.

Если на печать выводится не все содержимое разметки листа, то можно воспользоваться опцией центрирования чертежа на листе бумаги.


Задание смещения печати для разметки листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Регулировка смещения от начала для разметки листа
Понятия
Процедуры
Команды

Задание смещения печати для разметки листа

  1. Выберите вкладку разметки листа, для которой необходимо настроить смещение чертежа.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в списке "Смещение от начала" введите значение в единицах для X или Y или для обеих координат. Нажмите "OK".
  6. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Регулировка смещения от начала для разметки листа - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Регулировка смещения от начала для разметки листа
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
Системные переменные
PLOTOFFSET | Управляет способом отсчета смещения чертежа относительно печатаемой области или кромок листа бумаги
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание масштаба печати - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание масштаба печати
Понятия
Процедуры
Команды

При выводе чертежа на печать можно либо задать точный масштаб, либо воспользоваться режимом вписывания чертежа в заданный формат листа бумаги.

Обычно чертежи печатают в масштабе 1:1. Чтобы задать другой масштаб печати чертежа, установите его в диалоговом окне "Параметры листа" или "Печать" В указанных диалоговых окнах масштаб можно ввести или выбрать из списка.

Примечание Можно изменить список масштабов с помощью команды СПИСМАСШТРЕД.

Для черновых вариантов чертежей точность задания масштаба не столь важна. Здесь лучше воспользоваться опцией "Вписать" для вывода чертежа в наибольшем из возможных для данного формата масштабе.

См. также

Масштабирование видов на видовых экранах листа

Рисование, масштабирование и пояснения в пространстве модели


Задание масштаба печати - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание масштаба печати
Понятия
Процедуры
Команды

Задание масштаба печати

Подбор масштаба в зависимости от формата листа при печати


Задание масштаба печати - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание масштаба печати
Понятия
Процедуры
Команды

Задание масштаба печати

  1. Выберите вкладку разметки листа, для которой необходимо установить масштаб.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Масштаб печати" выберите масштаб из списка масштабов.

    6. Для листа масштаб по умолчанию равен 1:1. Для установки пользовательского (нестандартного) масштаба печати следует ввести значения, задающие отношение реальных единиц готового чертежа к условным единицам чертежа. Тип единиц измерения определяется размером листа, но его можно изменить, выбрав из списка.

  6. Нажмите "ОК".
  7. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Параметры листа".


Подбор масштаба в зависимости от формата листа при печати - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание масштаба печати
Понятия
Процедуры
Команды

Подбор масштаба в зависимости от формата листа при печати

  1. Выберите вкладку разметки листа, которую необходимо вписать в лист данного формата.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Масштаб печати" выберите опцию "Вписать".

    6. Примечание Если выбрана опция области печати "Разметка листа", то опция "Вписать" становится недоступной.

  6. Нажмите "ОК".
  7. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Задание масштаба печати - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Задание масштаба печати
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
СПИСМАСШТРЕД | Управление списком доступных значений масштаба для видовых экранов, листа и печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание масштаба весов линий - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание масштаба весов линий
Понятия
Процедуры
Команды

Веса линий на выводимых листах можно пропорционально масштабировать в соответствии с масштабом печати.

Веса линий, как правило, обозначают ширину линий печатаемых объектов и печатаются независимо от масштаба печати. Наиболее часто масштаб печати бывает равен 1:1, при этом никаких дополнительных действий с весом линий производить не требуется. Однако один и тот же лист можно напечатать в масштабе 1:1 на бумаге формата A3, а также в масштабе 1:2 на бумаге формата A4. При этом на каждом из полученных чертежей может понадобиться сохранить пропорции толщины линий.

См. также

Работа с весами линий


Масштабирование весов линий - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание масштаба весов линий
Понятия
Процедуры
Команды

Масштабирование весов линий

  1. Выберите вкладку разметки листа, для которой необходимо изменить веса линий.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Масштаб печати" установите флажок "Масштабировать веса линий".

    6. Веса линий в текущем листе будут отмасштабированы в соответствии с указанным масштабом печати. При работе на вкладке "Модель" данная опция недоступна.

  6. Нажмите "ОК".
  7. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Задание масштаба весов линий - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Задание масштаба весов линий
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор таблицы стилей печати для разметки листа - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Выбор таблицы стилей печати для разметки листа
Понятия
Процедуры
Команды

Таблица стилей печати содержит набор стилей печати, назначенных разметке листа или модели. Стиль печати, наряду с типом линии или цветом, является свойством объекта. Стили печати могут назначаться отдельным объектам и слоям. Стиль печати задает свойства объекта при выводе на печать.

Можно создать новую таблицу стилей печати для сохранения параметров листа или отредактировать уже существующую таблицу стилей печати.

Если установить флажок "Показать стили печати" в группе опций "Таблица стилей печати", объекты на выбранном листе будут отображаться с учетом назначенных им свойств стилей печати.

См. также

Управление стилем печати объектов


Выбор таблицы стилей печати для разметки листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Выбор таблицы стилей печати для разметки листа
Понятия
Процедуры
Команды

Выбор таблицы стилей печати для разметки листа

Создание новой таблицы стилей печати для разметки листа

Изменение таблицы стилей печати для разметки листа

Просмотр содержимого листа с учетом таблицы стилей печати


Выбор таблицы стилей печати для разметки листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Выбор таблицы стилей печати для разметки листа
Понятия
Процедуры
Команды

Выбор таблицы стилей печати для разметки листа

  1. Выберите вкладку разметки листа, для которой необходимо выбрать таблицу стилей печати.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе опций "Таблица стилей печати" выберите необходимую таблицу.
  6. Нажмите "ОК".
  7. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Создание новой таблицы стилей печати для разметки листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Выбор таблицы стилей печати для разметки листа
Понятия
Процедуры
Команды

Создание новой таблицы стилей печати для разметки листа

  1. Выберите вкладку разметки листа, для которой необходимо создать новую таблицу стилей печати.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Таблица стилей печати" выберите из списка "Новая".
  6. Следуйте инструкциям появившегося мастера (Мастера создания таблиц цветозависимых стилей печати или Мастера создания таблиц именованных стилей печати).
  7. В диалоговом окне "Параметры листа" нажмите "ОК".
  8. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Изменение таблицы стилей печати для разметки листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Выбор таблицы стилей печати для разметки листа
Понятия
Процедуры
Команды

Изменение таблицы стилей печати для разметки листа

  1. Выберите вкладку разметки листа, для которой необходимо изменить таблицу стилей печати.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Таблица стилей печати" выберите из списка таблицу стилей печати, которую надо отредактировать.
  6. Нажмите кнопку "Правка".
  7. В редакторе таблиц стилей печати внесите требуемые изменения. Нажмите кнопку "Принять & Закрыть".
  8. В диалоговом окне "Параметры листа" нажмите "ОК".
  9. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Просмотр содержимого листа с учетом таблицы стилей печати - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Выбор таблицы стилей печати для разметки листа
Понятия
Процедуры
Команды

Просмотр содержимого листа с учетом таблицы стилей печати

  1. Выберите вкладку разметки листа, для которой необходимо отобразить стили печати.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Таблицы стилей печати" выберите опцию "Отобразить таблицу стилей печати".
  6. Нажмите "ОК".
  7. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Выбор таблицы стилей печати для разметки листа - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Выбор таблицы стилей печати для разметки листа
Понятия
Процедуры
Команды

Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание параметров печати для видовых экранов с раскрашиванием - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание параметров печати для видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Ряд настроек позволяет задавать параметры вывода на печать видовых экранов, содержащих раскрашенные тела. Настройки печати видовых экранов, содержащих раскрашенные объекты, обеспечивают большую гибкость представления трехмерных объектов. Печать чертежа производится на основании выбранного режима обращения с раскрашенными видовыми экранами и установленного разрешения печатающего устройства.

Настройки печати ВЭкранов с раскрашиванием

Возможные варианты печати раскрашенных видовых экранов таковы: "Обычный", "Каркас", "Скрытие линий" и "Тонирование".

Опции печати раскрашенных видовых экранов применимы ко всем объектам на видовых экранах и в пространстве модели. При использовании средства печати раскрашенных и тонированных видовых экранов таблицы стилей печати в параметрах листов не активизируются. Если используется опция "Тонирование", то двухмерные каркасные объекты, такие как линии, дуги и текст, не печатаются.

Примечание Распечатывать раскрашенные видовые экраны можно только на устройствах с растровой графикой. Большинство современных плоттеров и принтеров поддерживают растровую графику.

Опции печати

Для листов можно задать также следующие опции, определяющие то, как объекты будут печататься.

  • Учитывать веса линий. Задает печать с учетом весов линий, назначенных объектам и слоям.
  • Учитывать стили печати. Задает печать чертежа с применением стилей печати. При выборе этой опции печать выполняется с учетом весов линий. Если эта опция отключена, то печать выполняется с учетом свойств объектов без переопределения этих свойств с помощью стилей печати.
  • Объекты листа последними. Задает последовательность печати таким образом, чтобы в первую очередь выполнялась печать объектов пространства модели и только затем - пространства листа.
  • Скрывать объекты листа Определяет, применима ли операция скрытия к объектам видового экрана пространства листа. Доступно только для вкладки разметки листа. Опция воздействует на линии только в момент печати и просмотра перед печатью.

См. также

Настройка печати видовых экранов с раскрашиванием

Задание параметров печати объектов


Задание параметров печати для видовых экранов с раскрашиванием - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание параметров печати для видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Задание параметров печати видовых экранов с раскрашиванием

Установка опций печати для листа


Задание параметров печати видовых экранов с раскрашиванием - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание параметров печати для видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Задание параметров печати видовых экранов с раскрашиванием

  1. Выберите вкладку разметки листа, для которой необходимо установить параметры печати раскрашенных видовых экранов.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "ВЭкраны с раскрашиванием" выберите требуемые настройки.
  6. Нажмите "ОК".
  7. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Установка опций печати для листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание параметров печати для видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Установка опций печати для листа

  1. Выберите вкладку разметки листа, для которого необходимо установить параметры печати.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Опции печати" выберите требуемые настройки.
  6. Нажмите "ОК".
  7. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Задание параметров печати для видовых экранов с раскрашиванием - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Задание параметров печати для видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание ориентации чертежа - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание ориентации чертежа
Понятия
Процедуры
Команды

Переключатель ориентации чертежа имеет два положения: "Альбомная" и "Книжная". При альбомной ориентации горизонтально располагается длинная сторона листа, а при книжной - короткая. Смена ориентации создает эффект поворота листа бумаги, подложенного под чертеж, на 90 градусов.

При любой ориентации, переключив флажок "Перевернуть", можно выполнить разворот выводимого чертежа на 180 градусов.

Хотя ориентацию чертежа можно задать в обоих диалоговых окнах, управляющих выводом на печать ("Параметры листа" и "Печать"), с листом сохраняются только установки, сделанные в диалоговом окне "Параметры листа". В диалоговом окне "Печать" можно переопределить параметры отдельного листа, но новые значения параметров при этом не сохраняются. Для сохранения настроек, которые были применены в диалоговом окне "Печать", необходимо в этом диалоговом окне нажать на кнопку "Применить к листу".

При смене ориентации чертежа точка его начала остается в левом нижнем углу области чертежа.


Задание ориентации вывода чертежа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание ориентации чертежа
Понятия
Процедуры
Команды

Задание ориентации вывода чертежа

  1. Выберите вкладку разметки листа, для которой необходимо задать ориентацию чертежа.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Ориентация чертежа" необходимо осуществить одно из следующих действий:
    • Если чертеж должен располагаться горизонтально, выберите "Альбомная".
    • Если чертеж должен располагаться вертикально, выберите "Книжная".
    • Для разворота чертежа на 180 градусов оставьте значение ориентации прежним ("Книжная" или "Альбомная") и переключите состояние флажка "Перевернуть".
  6. Нажмите "ОК".
  7. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Задание ориентации чертежа - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Задание ориентации чертежа
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание параметров листа с помощью Мастера компоновки листа - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание параметров листа с помощью Мастера компоновки листа
Понятия
Процедуры
Команды

Новую разметку листа можно создать с помощью Мастера компоновки листа. При использовании Мастера процесс создания разметки листа разбивается на несколько этапов, при прохождении которых пользователь задает следующие параметры:

  • имя новой разметки листа
  • принтер, назначаемый разметке листа
  • формат бумаги, используемый для разметки листа
  • ориентация чертежа на листе бумаги
  • основная надпись
  • параметры видового экрана
  • расположение видового экрана в разметке листа

Заданные в окне Мастера параметры можно в дальнейшем отредактировать. Для этого следует перейти на вкладку разметки листа и выберите из меню "Файл" пункт "Диспетчер наборов параметров листа", а затем нажмите в открывшемся Диспетчере кнопку "Редактирование" .


Создание разметки листа с помощью Мастера - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Задание параметров листа с помощью Мастера компоновки листа
Понятия
Процедуры
Команды

Создание разметки листа с помощью Мастера

  1. Нажмите "Вставка" » "Разметка" » "Мастер компоновки листа".
  2. На каждой странице Мастера создания разметки листа задать соответствующие настройки для новой разметки листа.

    3. После завершения работы Мастера вновь созданная разметка листа станет текущей.

Ввод команды: МАСТЕРЛИСТ


Задание параметров листа с помощью Мастера компоновки листа - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Задание параметров листа с помощью Мастера компоновки листа
Понятия
Процедуры
Команды

Команды
МАСТЕРЛИСТ | Создание нового листа, задание параметров листа и печати
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Импорт настроек PCP или PC2 в компоновку листа - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Импорт настроек PCP или PC2 в компоновку листа
Понятия
Процедуры
Команды

При работе с чертежами, созданными в AutoCAD Release 14 или более ранних версиях, можно импортировать параметры листа и печати, содержащиеся в файлах PCP или PC2, и применить их к текущей разметке листа. В файлах PCP или PC2 хранятся следующие настройки

  • печатаемая область
  • угол поворота
  • формат листа
  • масштаб печати
  • точка начала чертежа
  • смещение от начала

Кроме того, файл PC2 содержит сведения о разрешении, модифицированные при калибровке плоттера. Из PCP- и PC2-файлов с помощью Мастера создания таблиц стилей печати можно импортировать информацию о присвоениях перьев и сохранить ее в таблице стилей печати.

Для импорта информации об устройстве печати и назначениях перьев можно воспользоваться Мастером импорта параметров печати из PCP или PC2. Любые из импортированных настроек можно изменить в диалоговом окне "Параметры листа".


Импорт параметров из PCP или PC2 в текущую разметку листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Импорт настроек PCP или PC2 в компоновку листа
Понятия
Процедуры
Команды

Импорт параметров из PCP или PC2 в текущую разметку листа

  1. В командной строке введите мастерпеч.
  2. В Мастере импорта параметров печати из PCP или PC2 выберите файл PCP или PC2 для импорта настроек в текущий лист.


Импорт настроек PCP или PC2 в компоновку листа - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Импорт настроек PCP или PC2 в компоновку листа
Понятия
Процедуры
Команды

Команды
МАСТЕРПЕЧ | Вызов Мастера для импорта параметров печати из PCP- и PC2-файлов настройки для вкладки "Модель" или текущего листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и использование наборов параметров листов - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Создание и использование наборов параметров листов
Понятия
Процедуры
Команды

Настройки устройства печати и другие параметры листа можно сохранить в наборе параметров листов. Созданный таким образом набор параметров листа можно впоследствии изменить или импортировать в другие чертежи.

Пользователь может создать набор параметров листов и применить его к другим разметкам листов в данном чертеже. Набор параметров листов сохраняется в файле чертежа. Он может быть импортирован в другие файлы чертежей и применен к другим разметкам листов. Можно также изменить настройки набора параметров листов. Измененные параметры могут быть применены только к текущей разметке листа или ко всем листам в текущем чертеже, использующим данный набор параметров листов.

Наборы параметров листа используются в тех случаях, когда необходимо распечатать один и тот же лист различными способами или задать одни и те же настройки вывода на печать для нескольких разметок листов.

Пользователь может применить другой набор параметров листов к этой же разметке листа, чтобы получить несколько иной результат при печати. Например, можно создать наборы параметров листа, описанные в следующей таблице.

Набор параметров листа | Описание
В натур. вел. | Печать в масштабе 1:1, на формате A3
Масштаб 1:2 | Печать в масштабе 1:2, на формате A4
Черновое | Вывод с черновым качеством
Окончат. вариант | Высококачественная печать
Вписать в размеры листа | Вписать в размеры листа, лист формата А5

Печать или публикация листа всегда осуществляется с применением настроек, заданных в назначенном данной разметке листа наборе параметров.


Создание и использование наборов параметров листов - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Создание и использование наборов параметров листов
Понятия
Процедуры
Команды

Создание новых наборов параметров листов

Применение набора параметров листов к какой-либо разметке листа

Изменение набора параметров листов

Импорт набора параметров листов из другого чертежа

Удаление набора параметров листов

Переименование набора параметров листов


Создание новых наборов параметров листов - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Создание и использование наборов параметров листов
Понятия
Процедуры
Команды

Создание новых наборов параметров листов

  1. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  2. В Диспетчере наборов параметров листов в группе опций "Параметры листа" нажмите кнопку "Создать".
  3. В диалоговом окне "Создание набора параметров листа" ввести имя для нового набора параметров листа.
  4. В группе "На основе" выберите из списка параметры листа. Настройки выбранного в качестве основы набора параметров листа, будут отображены в диалоговом окне "Параметры листа" после нажатия кнопки "ОК".
  5. Нажмите "ОК".
  6. В диалоговом окне "Параметры листа" измените нужные настройки. Нажмите "OK".

    7. Новые настройки листа будут отображены в списке "Параметры листа" в Диспетчере наборов параметров листов.

  7. Для применения новых настроек листа к текущей разметке листа необходимо в Диспетчере наборов параметров листов нажать "Установить текущим".
  8. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Применение набора параметров листов к какой-либо разметке листа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Создание и использование наборов параметров листов
Понятия
Процедуры
Команды

Применение набора параметров листов к какой-либо разметке листа

  1. Выберите вкладку разметки листа, к которой надо применить набор параметров листа.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов в группе "Параметры листа" выберите набор параметров листов из списка.

    4. Примечание Неименованные наборы параметров листа обозначаются в Диспетчере наборов параметров листов звездочками вокруг имени соответствующего листа. Неименованный набор параметров листа менее функционален по сравнению с именованным набором параметров. Например, неименованный набор параметров можно присвоить какому-либо иному листу. Однако если затем изменить настройки этого неименованного набора параметров листов, то эти изменения не будут применены к листу, которому данный неименованный набор параметров был назначен.

  4. Нажмите кнопку "Установить".
  5. Нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Изменение набора параметров листов - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Создание и использование наборов параметров листов
Понятия
Процедуры
Команды

Изменение набора параметров листов

  1. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  2. В Диспетчере наборов параметров листов в группе "Параметры листа" выберите набор параметров листов из списка.

    3. Примечание Неименованные наборы параметров листа обозначаются в Диспетчере наборов параметров листов звездочками вокруг имени соответствующего листа. Неименованный набор параметров листа менее функционален по сравнению с именованным набором параметров. Например, неименованный набор параметров можно присвоить какой-либо иной разметке листа. Однако если затем изменить настройки этого неименованного набора параметров листов, то эти изменения не будут применены к разметке листа, которой данный неименованный набор параметров был назначен.

  3. Нажмите кнопку "Редактирование".
  4. В диалоговом окне "Параметры листа" внесите необходимые изменения. Нажмите "OK".
  5. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Импорт набора параметров листов из другого чертежа - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Создание и использование наборов параметров листов
Понятия
Процедуры
Команды

Импорт набора параметров листов из другого чертежа

  1. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  2. В Диспетчере наборов параметров листов нажмите кнопку "Импорт".
  3. В диалоговом окне "Загрузка набора параметров листа из файла" выберите файл чертежа, из которого необходимо импортировать один или более наборов параметров листа. Нажмите "Импорт".
  4. В диалоговом окне "Импорт наборов параметров листов" выберите один или несколько наборов параметров листов для импорта. Нажмите "OK".

    5. Если набор параметров листов с таким же именем уже существует в данном чертеже, то можно принять настройки из импортируемого набора параметров листа или отменить операцию.

    Импортированные наборы параметров листа появляются в списке Диспетчера наборов параметров листов.

    Примечание Можно импортировать параметры одновременно и для вкладок разметок листов и для пространства модели. Однако импортированный набор параметров листа для пространства модели включается в список Диспетчера наборов параметров листов только в том случае, если вкладка модели являлась текущей при открытии Диспетчера. Аналогично, импортированный набор параметров вкладки разметки листа включается в список Диспетчера наборов параметров листов только в том случае, если вкладка листа являлась текущей при открытии Диспетчера.

  5. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Удаление набора параметров листов - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Создание и использование наборов параметров листов
Понятия
Процедуры
Команды

Удаление набора параметров листов

  1. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  2. В Диспетчере наборов параметров листов в группе "Параметры листов" нажмите правую кнопку мыши на наборе параметров листов, который требуется удалить. Выберите "Удалить".

    3. Примечание Неименованные наборы параметров листа обозначаются в Диспетчере наборов параметров листов звездочками вокруг имени соответствующей разметки листа. Неименованный набор параметров листа менее функционален по сравнению с именованным набором параметров. Например, неименованный набор параметров можно присвоить какому-либо иной разметки листа. Однако если затем изменить настройки этого неименованного набора параметров листов, то эти изменения не будут применены к разметке листа, которой данный неименованный набор параметров был назначен.

  3. Нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Переименование набора параметров листов - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Создание и использование наборов параметров листов
Понятия
Процедуры
Команды

Переименование набора параметров листов

  1. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  2. В Диспетчере наборов параметров листов в группе опций "Параметры листов" нажмите правую кнопку мыши на наборе параметров листов, который требуется переименовать. Выберите "Переименовать".

    3. Примечание Неименованные наборы параметров листа обозначаются в Диспетчере наборов параметров листов звездочками вокруг имени соответствующей разметки листа. Неименованный набор параметров листа менее функционален по сравнению с именованным набором параметров. Например, неименованный набор параметров можно присвоить какому-либо иному листу. Однако если затем изменить настройки этого неименованного набора параметров листов, то эти изменения не будут применены к листу, которому данный неименованный набор параметров был назначен.

  3. Введите новое имя для набора параметров листов.
  4. Нажмите кнопку "Закрыть".

Панель "Листы"

Ввод команды: ПАРАМЛИСТ

Контекстное меню: Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Создание и использование наборов параметров листов - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Создание и использование наборов параметров листов
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование наборов параметров листов в подшивках - Понятия

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Использование наборов параметров листов в подшивках
Понятия
Процедуры
Команды

Наборы параметров листов можно использовать для задания одних и тех же опций вывода для всех листов подшивки.

Пользователь может с помощью Диспетчера подшивок создать разметку листа с нуля, а затем применить к ней набор параметров листа.

В ходе публикации можно также разово применить наборы параметров листов, которые хранятся в файле переопределения параметров листа подшивки (DWT), к одному листу или ко всей подшивке.

См. также

Создание и использование наборов параметров листов


Использование наборов параметров листов в подшивках - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Использование наборов параметров листов в подшивках
Понятия
Процедуры
Команды

Применение набора параметров к листу подшивки, созданному с нуля

Применение набора параметров листов в качестве переопределения при публикации листов


Применение набора параметров к листу подшивки, созданному с нуля - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Использование наборов параметров листов в подшивках
Понятия
Процедуры
Команды

Применение набора параметров к листу подшивки, созданному с нуля

  1. Нажмите "Файл" » "Открыть подшивку".
  2. В диалоговом окне "Открытие подшивки" выберите подшивку. Нажмите кнопку "Открыть".
  3. В Диспетчере подшивок нажмите правую кнопку мыши в области "Листы". Выберите "Создать лист".
  4. В диалоговом окне "Новый лист" введите номер и заголовок листа. Нажмите "OK".
  5. В Диспетчере подшивок в области "Листы" дважды нажмите кнопку мыши на новом листе.
  6. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  7. В диспетчере наборов параметров листов в группе "Параметры листа" выберите набор параметров листов. Выберите "Установить текущим".

    8. Именованные наборы параметров листов не обрамляются звездочками.

  8. Нажмите кнопку "Закрыть".

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Применение набора параметров листов в качестве переопределения при публикации листов - Процедуры

Печать и публикация чертежей
Подготовка чертежей к печати и публикации
Использование наборов параметров листов в подшивках
Понятия
Процедуры
Команды

Применение набора параметров листов в качестве переопределения при публикации листов

  1. Нажмите "Файл" » "Открыть подшивку".
  2. В диалоговом окне "Открытие подшивки" выберите подшивку. Нажмите кнопку "Открыть".
  3. В Диспетчере подшивок в области "Листы" выберите подшивку, подгруппу или лист для публикации.
  4. В верхней части Диспетчера подшивок нажмите кнопку "Опубликовать".
  5. В контекстном меню наведите курсор на пункт "Опубликовать без учета параметров листа".
  6. В подменю выберите именованный набор параметров листов, который необходимо использовать.

Панель "Стандартная"

Ввод команды: ПОДШИВКА


Использование наборов параметров листов в подшивках - Команды

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Использование наборов параметров листов в подшивках
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПОДШИВКА | Вызов диспетчера подшивок
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вывод чертежей на печать - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Понятия
Процедуры
Команды

Понятие "печать чертежа" для подготовленных в AutoCAD чертежей объединяет в себе процессы получения вычерченных бумажных копий или электронных чертежей, которые могут использоваться в других приложениях. В обоих случаях необходимо настроить параметры печати.

  • Коротко о процессе печати
    Для вывода на печать одного листа или части чертежа используется диалоговое окно "Печать".
  • Основные сведения о процессе печати
    Знание терминов и понятий, касающихся процесса печати, поможет сделать первый шаг в работе с программой.
  • Использование набора параметров листа для задания режимов печати
    Существует возможность настроить процесс печати на основании установок из набора параметров листа.
  • Выбор принтера или плоттера
    Перед печатью чертежа необходимо выбрать принтер или плоттер. Выбранное устройство определяет, какая часть чертежа входит в печатаемую область.
  • Задание области печати
    Для печати чертежа необходимо задать печатаемую область. В диалоговом окне "Печать" можно выбрать любой из следующих вариантов:
  • Задание формата бумаги
    Формат листа при выводе чертежа на печать задается в диалоговом окне "Печать".
  • Расположение чертежа на бумаге
    Для задания расположения чертежа на бумаге существует несколько методов. Можно задать область печати, смещение чертежа на бумаге и ориентацию чертежа.
  • Управление стилем печати объектов
    Имеется возможность управления печатью объектов с помощью параметров масштаба печати, стилей печати, таблиц стилей печати и путем изменения свойств слоев объектов.
  • Предварительный просмотр
    Прежде чем выводить чертеж на печать, рекомендуется выполнять предварительный просмотр чертежа. Это позволит сократить затраты времени и расходных материалов, необходимых для выполнения печати.
  • Печать в файлы различных форматов
    Имеется возможность экспорта или(посредством процедур печати) чертежей в файлы различных форматов, включая форматы DWF, DXF, PDF и WMF (метафайлы Windows). Вывод чертежей в файлы можно выполнять с помощью специальных драйверов печати.


Вывод чертежей на печать - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Понятия
Процедуры
Команды

Печать чертежа

Включение/отключение фоновой печати

Проверка состояния текущего вывода на печать, выполняемого в фоновом режиме

Частичная или полная отмена печати, выполняемой в фоновом режиме

Просмотр подробных сведений о выполненных процедурах печати

Печать чертежа с настройками, заданными в наборе параметров листа

Сохранение настроек печати в новом именованном наборе параметров

Сохранение параметров печати вместе с листом

Выбор принтера или плоттера

Выбор печатаемой области

Выбор формата для текущей процедуры печати

Задание формата, принятого для листа по умолчанию

Задание формата бумаги, принятого по умолчанию для плоттера

Создание и изменение нестандартного формата листа для несистемного принтера

Печать с использованием масштаба в реальных координатах

Печать с использованием нестандартного масштаба

Вписывание чертежа в лист бумаги

Изменение способа печати раскрашенных видовых экранов

Изменение способа печати раскрашенных объектов пространства модели

Настройка уровня разрешения при печати видовых экранов с раскрашиванием

Настройка параметров печати раскрашенных объектов со вкладки "Модель"

Настройка параметров печати видовых экранов с раскрашиванием со вкладок разметок листов

Подавление скрытых линий при печати со вкладки "Модель"

Подавление скрытых линий при печати вкладки разметки листа

Печать с учетом весов линий

Отключение использования стилей печати

Изменение последовательности печати объектов

Скрытие объектов пространства листа при печати со вкладки разметки листа

Задание типа таблицы стилей печати для новых чертежей

Переход к использованию именованных стилей печати

Переход к использованию цветозависимых стилей печати

Преобразование таблицы цветозависимых стилей печати в таблицу именованных стилей печати

Подключения таблицы стилей печати к разметке листа

Просмотр разметки листа с учетом таблицы стилей печати

Создание таблицы стилей печати

Переименование таблицы стилей печати

Изменение пояснения к таблице стилей печати

Редактирование стилей в таблице стилей печати

Изменение стиля печати объекта

Изменение стиля печати для слоя

Задание текущего стиля печати

Создание именованного стиля печати

Копирование именованного стиля печати

Изменение пояснения к стилю печати

Переименование именованного стиля печати

Удаление именованного стиля печати

Удаление таблицы соответствия цветов

Изменение параметров стиля печати

Задание цвета в стиле печати

Назначение интенсивности

Включение/отключение размывания

Включение/отключение преобразования цветов в оттенки серого

Задание номера виртуального пера

Задание веса линий в стиле печати

Задание типа линий в стиле печати

Масштабирование типов линий и образцов закрашивания, не относящихся к стандарту ISO

Задание стиля окончаний или соединений линий

Задание стиля закрашивания

Предварительный просмотр

Печать в файлы DWF

Создание файла DXB

Создание файла растрового формата

Печать файла PDF

Печать файла PDF в альбомной ориентации

Печать в файл PostScript

Создание файла вывода на печать


Вывод чертежей на печать - Команды

Печать и публикация чертежей
Вывод чертежей на печать
Понятия
Процедуры
Команды
Команды
ВЕСЛИН | Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий
ГРАФНАСТР | Обеспечивает конфигурационные установки системы 3D-графики
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
МАСТЕРПЕЧ | Вызов Мастера для импорта параметров печати из PCP- и PC2-файлов настройки для вкладки "Модель" или текущего листа
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПАН | Перемещение изображения на текущем видовом экране
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПОДРОБНОСТИПП | Отображает информацию о выполненных заданиях печати и публикации
ПОКАЗАТЬ | Увеличение или уменьшение видимого размера объектов на текущем видовом экране
ПРЕДВАР | Предварительный просмотр на экране выводимого на печать листа
ПРЕОБРСПЕЧ | Настройка чертежа на использование именованных или цветозависимых стилей печати
ПРЕОБРТСП | Преобразование таблиц цветозависимых стилей печати (СТВ) в таблицы именованных стилей печати (STB)
ПСТИЛЬ | Задание текущего стиля печати для новых объектов или назначение стиля печати выбранным объектам
РЕЖИМРАСКР | Запускает команду ТЕКВИЗСТИЛЬ
СЛОЙ | Управление слоями и их свойствами
СПИСМАСШТРЕД | Управление списком доступных значений масштаба для видовых экранов, листа и печати
ШТЕМПЕЛЬ | Нанесение штемпеля в определенном углу каждого чертежа и запись соответствующей информации в файл журнала
ЭКСПОРТБМП | Сохранение выбранных объектов в файле аппаратно-независимого растрового формата (BMP)
ЭКСПОРТДЖ | Сохраняет выбранные объекты в файл в формате JPEG
ЭКСПОРТПНГ | Сохраняет выбранные объекты в файл в формате Portable Network Graphics
ЭКСПОРТТИФ | Сохранение выбранных объектов в файл формата TIFF
Системные переменные
BACKGROUNDPLOT | Управление включением/отключением режима фонового вывода для операций печати и публикации
CPLOTSTYLE | Управление текущим стилем печати для новых объектов.
DEFLPLSTYLE | Указывает стиль печати по умолчанию для слоя 0
DEFPLSTYLE | Указывает стиль печати по умолчанию для новых объектов.
PAPERUPDATE | Управление выводом диалогового окна предупреждения при попытке вывести на печать лист, формат которого не совпадает с форматом, заданным по умолчанию в файле параметров плоттера
PLOTROTMODE | Управляет ориентацией чертежа
PSTYLEMODE | Указывает режим стиля печати текущего чертежа - цветозависимый или именованный
PSTYLEPOLICY | Управляет ассоциативностью свойства цвета объекта с его стилем печати
RASTERDPI | Управляет размером листа и масштабом печати при переключении с устройств вывода размерных файловых форматов на устройства вывода безразмерных файловых форматов и наоборот
RASTERPREVIEW | Управляет сохранением вместе с чертежом образцов для просмотра в формате BMP
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о процессе печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Коротко о процессе печати
Понятия
Процедуры
Команды

Для вывода на печать одного листа или части чертежа используется диалоговое окно "Печать".

В диалоговом окне "Печать" можно задать именованный набор параметров печати, а также определить устройство вывода на печать.

Для печати более одного чертежа следует использовать окно "Публикация".

См. также

Коротко о публикации


Коротко о процессе печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Коротко о процессе печати
Понятия
Процедуры
Команды

Команды
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Основные сведения о процессе печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Основные сведения о процессе печати
Понятия
Процедуры
Команды

Знание терминов и понятий, касающихся процесса печати, поможет сделать первый шаг в работе с программой.

Диспетчер плоттеров

Диспетчер плоттеров представляет из себя окно со списком PC3-файлов параметров плоттера для всех установленных принтеров, в том числе и тех, которые не являются системными. Файлы параметров плоттера могут быть созданы и для системных принтеров Windows®, если требуется использовать свойства по умолчанию, отличающиеся от принятых в Windows. К параметрам плоттера относятся сведения о порте подключения, качестве растровой и векторной графики, допустимых форматах листа, а также дополнительные свойства (свои для каждого типа устройства).

Диспетчер плоттеров предоставляет базовое средство для создания новых файлов параметров плоттеров - Мастер установки плоттеров. Этот Мастер запрашивает у пользователя необходимую информацию о плоттере в процессе установки.

Разметки листов

Разметка листа является изображением распечатанной страницы. Имеется возможность создавать столько вариантов разметок, сколько потребуется. Каждый вариант разметки листа хранится на своей вкладке разметки листа, и ему может быть назначен свой набор параметров листа.

В процессе создания разметки листа выполняется размещение таких выводящихся только при печати листа элементов, как основная надпись и примечания. Объекты чертежа, создаваемые в пространстве модели, размещаются на вкладке "Модель". Для их просмотра в пространстве листа необходимо создавать видовые экраны разметки листа.

Наборы параметров листа

При создании листа необходимо указывать устройство печати и такие параметры, как формат и ориентация печати. Эти настройки сохраняются в наборе параметров листа. Эти параметры можно задавать для пространства листа и модели с помощью Диспетчера наборов параметров листов. Наборы параметров листа можно именовать и сохранять в целях дальнейшего их использования для других разметок листов.

Если в диалоговом окне "Параметры листа" заданы не все параметры, то их можно указать непосредственно перед началом печати. Кроме того, можно переназначить параметры листа во время печати. Новые параметры листа могут быть либо использованы только во время текущего процесса печати, либо сохранены для последующих сеансов.

Стили печати

Использование стилей печати позволяет изменять внешний вид объектов и слоев при их выводе на печатающее устройство, регулируя такие свойства, как вес линий, цвет и стиль закрашивания. Стили печати группируются в таблицы стилей печати. Диспетчер стилей печати - это окно, в котором отображаются все доступные стили печати.

Существует два типа стилей печати: цветозависимые и именованные. В таблице, которая назначена чертежу, должны присутствовать только стили какого-либо одного вида. Стили печати в таблице могут быть преобразованы из одного типа в другой. Можно также менять используемый в чертеже тип стилей печати.

При использовании цветозависимых стилей печати на печать объектов влияет их цвет. Файлы таблиц таких стилей имеют расширение .ctb. Назначение цветозависимых стилей печати непосредственно объектам не разрешено. Это означает, что для изменения внешнего вида выводимого на печать объекта нужно присвоить ему другой цвет на чертеже. Например, для печати группы объектов чертежа одним методом им всем присваивается красный цвет.

Именованные стили печати могут быть назначены непосредственно объектам и слоям. Файлы таблиц таких стилей печати имеют расширение .stb. Использование именованных стилей позволяет печатать каждый объект с различными характеристиками, независимо от цвета самих объектов.

Штемпель для чертежа

Штемпель - это фрагмент текста, размещаемый на чертеже при печати. Расположение штемпеля задается в диалоговом окне "Штемпель". Если эта опция активна, то при выводе чертежа на печать на него ставится штемпель—с именем чертежа, именем разметки листа, датой, временем и т.д.—. Информацию со штемпеля можно запомнить в файле журнала (одновременно выводя или не выводя ее на печать).

Примечание Файл чертежа или файл шаблона чертежа, созданный в учебной версии, всегда выводится на печать со следующим штемпелем: "СОЗДАНО УЧЕБНОЙ ВЕРСИЕЙ ПРОДУКТА AUTODESK" Если в чертеже используются блоки или внешние ссылки, созданные в учебной версии продукта, то при выводе на печать появляется аналогичный штемпель.

См. также

Создание многовидовых чертежей (в пространстве листа)

Для получения справки по дополнительным свойствам в документе Руководство по периферийным устройствам


Основные сведения о процессе печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Основные сведения о процессе печати
Понятия
Процедуры
Команды

Печать чертежа

Включение/отключение фоновой печати

Проверка состояния текущего вывода на печать, выполняемого в фоновом режиме

Частичная или полная отмена печати, выполняемой в фоновом режиме

Просмотр подробных сведений о выполненных процедурах печати


Печать чертежа - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Основные сведения о процессе печати
Понятия
Процедуры
Команды

Печать чертежа

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Принтер/Плоттер" выберите из списка имя печатающего устройства.
  3. В группе "Формат" выберите из списка формат бумаги для печати.
  4. (Не обязательно) Задайте число печатаемых экземпляров в поле "Число экземпляров".
  5. В группе "Печатаемая область" укажите фрагмент чертежа, выводимый на печать.
  6. В группе "Масштаб печати" из раскрывающегося списка "Масштаб" выберите необходимый масштаб.
  7. Нажмите кнопку "Развернуть окно" для настройки дополнительных параметров печати.
  8. (Не обязательно) В группе "Таблица стилей печати" выберите таблицу стилей печати из списка.
  9. (Не обязательно) Настройте параметры в группах "ВЭкраны с раскрашиванием" и "Опции печати".

    10. Примечание Штемпель в чертеже не сохраняется и используется только во время распечатки чертежа.

  10. В группе "Ориентация чертежа" задайте ориентацию.
  11. Нажмите "ОК".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ

Контекстное меню: Нажмите правую кнопку мыши на ярлыке вкладки "Модель" или разметки листа и выберите "Печать".

Для печати из командной строки (без использования диалогового окна) введите -ПЕЧАТЬ.


Включение/отключение фоновой печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Основные сведения о процессе печати
Понятия
Процедуры
Команды

Включение/отключение фоновой печати

  1. Нажмите "Сервис" » "Настройки".
  2. В диалоговом окне "Настройка" на вкладке "Печать/Публикация" установите или снимите флажок "Поддержка фонового вывода: печать" в группе "Параметры фоновой обработки".
  3. Нажмите "ОК".

    4. Примечание При фоновой печати можно сразу же возобновить работу с чертежом. При фоновой печати документа в строке состояния появляется значок печатающего устройства, с помощью которого можно узнать о состоянии процесса печати. Подробности о завершенных заданиях можно просмотреть непосредственно из текущего сеанса программы.

Ввод команды: НАСТРОЙКА


Проверка состояния текущего вывода на печать, выполняемого в фоновом режиме - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Основные сведения о процессе печати
Понятия
Процедуры
Команды

Проверка состояния текущего вывода на печать, выполняемого в фоновом режиме

  • Подведите курсор к значку плоттера в строке состояния. Во всплывающей подсказке отображается состояние процесса печати.

Строка состояния


Частичная или полная отмена печати, выполняемой в фоновом режиме - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Основные сведения о процессе печати
Понятия
Процедуры
Команды

Частичная или полная отмена печати, выполняемой в фоновом режиме

  • Нажмите правую кнопку мыши на значке печатающего устройства. Выберите "Отмена задания для листа" <имя листа> или "Прервать все задание".

Строка состояния


Просмотр подробных сведений о выполненных процедурах печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Основные сведения о процессе печати
Понятия
Процедуры
Команды

Просмотр подробных сведений о выполненных процедурах печати

  1. Выполните одно из следующих действий:
    • Нажмите "Файл" » "Подробности о печати/публикации".
    • Нажмите кнопку мыши на значке печатающего устройства в строке состояния.
  2. В диалоговом окне "Подробности о печати/публикации" выводятся подробные сведения о процессе печати.

Ввод команды: ПОДРОБНОСТИПП

Контекстное меню: Нажмите правую кнопку мыши на значке печатающего устройства. Выберите "Подробности о печати/публикации".


Основные сведения о процессе печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Основные сведения о процессе печати
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
МАСТЕРПЕЧ | Вызов Мастера для импорта параметров печати из PCP- и PC2-файлов настройки для вкладки "Модель" или текущего листа
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПОДРОБНОСТИПП | Отображает информацию о выполненных заданиях печати и публикации
ШТЕМПЕЛЬ | Нанесение штемпеля в определенном углу каждого чертежа и запись соответствующей информации в файл журнала
Системные переменные
BACKGROUNDPLOT | Управление включением/отключением режима фонового вывода для операций печати и публикации
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование набора параметров листа для задания режимов печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Использование набора параметров листа для задания режимов печати
Понятия
Процедуры
Команды

Существует возможность настроить процесс печати на основании установок из набора параметров листа. При выборе какого-либо из именованных наборов параметров листа в диалоговом окне "Печать" поля окна заполняются параметрами из этого набора. С этими настройками можно либо сразу производить печать, либо изменить некоторые параметры перед отправкой чертежа на печать.

Любые настройки, установленные в диалоговом окне "Печать", могут быть сохранены как новый именованный набор параметров, если нажать кнопку "Добавить" рядом со списком имеющихся наборов.

Настройки параметров, заданные любым способом (как вручную, так с помощью набора параметров), могут быть применены и для последующей печати.


Использование набора параметров листа для задания режимов печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Использование набора параметров листа для задания режимов печати
Понятия
Процедуры
Команды

Печать чертежа с настройками, заданными в наборе параметров листа

Сохранение настроек печати в новом именованном наборе параметров

Сохранение параметров печати вместе с листом


Печать чертежа с настройками, заданными в наборе параметров листа - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Использование набора параметров листа для задания режимов печати
Понятия
Процедуры
Команды

Печать чертежа с настройками, заданными в наборе параметров листа

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в списке "Набор параметров листа" выберите набор параметров.
  3. (Не обязательно) Измените отдельные настройки в диалоговом окне "Печать".
  4. Сохраните настройки, нажав кнопку "Применить к листу".
  5. Нажмите "OK".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Сохранение настроек печати в новом именованном наборе параметров - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Использование набора параметров листа для задания режимов печати
Понятия
Процедуры
Команды

Сохранение настроек печати в новом именованном наборе параметров

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" измените параметры.
  3. Рядом со списком наборов параметров листов нажмите кнопку "Добавить".
  4. В диалоговом окне "Добавление набора параметров листа" введите имя нового набора параметров. Нажмите "OK".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Сохранение параметров печати вместе с листом - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Использование набора параметров листа для задания режимов печати
Понятия
Процедуры
Команды

Сохранение параметров печати вместе с листом

  1. Находясь на вкладке разметки листа, нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" выберите имеющийся набор параметров листа или настройте параметры вручную.
  3. Нажмите "Применить к разметке листа".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Использование набора параметров листа для задания режимов печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Использование набора параметров листа для задания режимов печати
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор принтера или плоттера - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Выбор принтера или плоттера
Понятия
Процедуры
Команды

После выбора устройства печати на нем можно напечатать чертеж, используя настройки печати по умолчанию.


Выбор принтера или плоттера - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Выбор принтера или плоттера
Понятия
Процедуры
Команды

Выбор принтера или плоттера

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Принтер/Плоттер" выберите из списка имя плоттера.

    3. Если текущий формат листа не поддерживается выбранным устройством печати, выдается сообщение о том, что будет использован формат листа по умолчанию. Нажмите "ОК" в этом окне сообщения.

  3. После выбора плоттера задайте формат листа или сразу нажмите "OK".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Выбор принтера или плоттера - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Выбор принтера или плоттера
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание области печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Задание области печати
Понятия
Процедуры
Команды

Для печати чертежа необходимо задать печатаемую область. В диалоговом окне "Печать" можно выбрать любой из следующих вариантов:

  • Разметка листа или Лимиты. Печатаются все объекты в пределах области печати. Началом чертежа служит точка листа с координатами 0,0. При печати со вкладки "Модель" печатается вся область рисования, определенная границами сетки. Если вид на текущем видовом экране отличен от вида в плане, опция работает аналогично опции "Границы".
  • Границы. Печать той части чертежа, которая в данный момент содержит объекты. Печатаются все объекты текущего пространства. Чертеж может быть регенерирован для пересчета границ перед печатью.
  • Экран. Печатается текущий видовой экран (для вкладки "Модель") или текущий вид пространства листа на вкладке разметки листа.
  • Вид. Вывод вида, предварительно описанного и сохраненного командой ВИД. Имя вида выбирается из списка. Если в чертеже нет именованных видов, опция недоступна.
  • Рамка. Печатается выделенный фрагмент чертежа. Нажав кнопку "Рамка", можно либо указать два противоположных угла, определяющих область печати, либо ввести их координаты.


Выбор печатаемой области - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание области печати
Понятия
Процедуры
Команды

Выбор печатаемой области

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать", в группе "Печатаемая область", укажите, какой фрагмент чертежа должен выводиться на печать.
  3. Внесите необходимые изменения в параметры. Нажмите "ОК" для печати чертежа.

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Задание области печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Задание области печати
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание формата бумаги - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Задание формата бумаги
Понятия
Процедуры
Команды

Формат листа при выводе чертежа на печать задается в диалоговом окне "Печать".

При печати по разметке листа используются параметры, установленные в диалоговом окне "Параметры листа". Если печать производится со вкладки "Модель", формат должен указать пользователь. Формат листа бумаги при выводе чертежа на печать задается в диалоговом окне "Печать". Набор доступных форматов зависит от принтера или плоттера, выбранного в этом же диалоговом окне или в окне "Параметры листа". В списке доступных устройств печати выводятся все имена системных принтеров Windows, а также несистемных устройств печати, для которых установлены драйверы.

Для вновь создаваемых разметок листов можно установить принятый по умолчанию формат бумаги с помощью PC3-файла, назначенного выбранному устройству печати. При выводе на системный принтер Windows данным методом можно пользоваться для указания другого формата страницы по умолчанию в Windows и в этой программе.

Примечание Если системная переменная PAPERUPDATE равна 0, выполняется проверка, поддерживает ли печатающее устройство заданный формат листа бумаги, и выводится предупреждение в случае несоответствия. Если переменная равна 1, при печати автоматически используется формат бумаги по умолчанию.

Нестандартный формат бумаги

С помощью редактора параметров печатающего устройства можно задавать нестандартные форматы бумаги для несистемных плоттеров, дополняя тем самым список доступных форматов в диалоговых окнах "Печать" и "Параметры листа". Как правило, для системных принтеров Windows добавление нестандартных форматов невозможно, и наборы допустимых форматов и печатаемых областей определяются производителями. Однако существует возможность изменения печатаемых областей для форматов бумаги, назначенных системному принтеру Windows.


Задание формата бумаги - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание формата бумаги
Понятия
Процедуры
Команды

Выбор формата для текущей процедуры печати

Задание формата, принятого для листа по умолчанию

Задание формата бумаги, принятого по умолчанию для плоттера

Создание и изменение нестандартного формата листа для несистемного принтера


Выбор формата для текущей процедуры печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание формата бумаги
Понятия
Процедуры
Команды

Выбор формата для текущей процедуры печати

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Принтер/Плоттер" выберите из списка имя плоттера.
  3. В группе "Формат" выберите формат бумаги из раскрывающегося списка.

    4. Набор доступных форматов зависит от выбранного устройства печати.

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Задание формата, принятого для листа по умолчанию - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание формата бумаги
Понятия
Процедуры
Команды

Задание формата, принятого для листа по умолчанию

  1. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  2. В Диспетчере наборов параметров листов в группе "Параметры листа" должна быть выбрана та разметка листа, для которой назначается формат. Если это не так, выберите разметку листа. Нажмите кнопку "Изменить".
  3. В диалоговом окне "Параметры листа" в списке "Формат листа бумаги" выберите формат. Нажмите "OK".

    4. Доступные форматы бумаги в списке зависят от типа плоттера.

  4. Нажмите кнопку "Закрыть" в Диспетчере наборов параметров листов.

    5. Новые параметры вступают в силу, изменяя вид разметки листа.

Панель "Листы"

Ввод команды: ПАРАМЛИСТ


Задание формата бумаги, принятого по умолчанию для плоттера - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание формата бумаги
Понятия
Процедуры
Команды

Задание формата бумаги, принятого по умолчанию для плоттера

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Принтер/Плоттер" выберите из списка имя плоттера.
  3. Нажмите кнопку "Свойства".

    4. Открывается редактор параметров плоттера.

  4. Установить формат бумаги по умолчанию одним из следующих способов:
    • Для несистемного устройства печати в группе "Носитель" области структуры выберите "Подача и размеры".
    • Для системного принтера в области структуры выберите "Дополнительные свойства". Затем в группе параметров "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
  5. Укажите необходимый формат бумаги.
  6. Нажмите "OK" для закрытия каждого диалогового окна.

    7. Примечание Набор доступных форматов бумаги зависит от выбранного устройства печати. Различные производители устройств предлагают свои диалоговые окна, вызываемые из редактора параметров устройства печати, для управления форматом бумаги.

Панель "Листы"

Ввод команды: ПАРАМЛИСТ


Создание и изменение нестандартного формата листа для несистемного принтера - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание формата бумаги
Понятия
Процедуры
Команды

Создание и изменение нестандартного формата листа для несистемного принтера

  1. Нажмите "Файл" » "Диспетчер плоттеров...".
  2. В Диспетчере плоттеров дважды нажмите кнопку мыши на ярлыке PC3-файла, в котором нужно изменить конфигурацию.
  3. В Редакторе параметров плоттеров на вкладке "Параметры устройства и документа" в группе "Нестандартные форматы и калибровка" области структуры выберите "Нестандартные форматы листа бумаги".
  4. Установите формат бумаги одним из следующих способов:
    • Для добавления нестандартного формата листа бумаги нажмите "Добавить" и следуйте указаниям Мастера пользовательских форматов бумаги. С помощью Мастера определяются формат бумаги, печатаемая область и имя для нового формата.
    • Для редактирования существующего формата бумаги в группе "Нестандартные форматы листа" укажите формат листа бумаги и нажмите "Правка". Появляется окно Мастера пользовательских форматов бумаги. Введите необходимые изменения в параметры формата листа бумаги.
  5. Нажмите "ОК".

    6. После выбора соответствующего PC3-файла новый или измененный формат бумаги становится доступным в диалоговых окнах "Печать" и "Параметры листа".

    Примечание После создания нестандартного формата бумаги для несистемного устройства печати происходит добавление PMP-файла параметров печати к PC3-файлу конфигурации плоттера. PMP-файл содержит пользовательские параметры калибровки плоттера и формата бумаги. По умолчанию PMP-файлы размещаются в папке Drv.

Ввод команды: ДИСППЕЧ


Задание формата бумаги - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Задание формата бумаги
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
PAPERUPDATE | Управление выводом диалогового окна предупреждения при попытке вывести на печать лист, формат которого не совпадает с форматом, заданным по умолчанию в файле параметров плоттера
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Расположение чертежа на бумаге - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Расположение чертежа на бумаге
Понятия
Процедуры
Команды

Для задания расположения чертежа на бумаге существует несколько методов. Можно задать область печати, смещение чертежа на бумаге и ориентацию чертежа.

  • Задание печатаемой области
    Область чертежа, предназначенная для вывода на печать, выделяется пунктирной рамкой на вкладке разметки листа. Печатаемая область определяется установленным плоттером и выбранным форматом бумаги.
  • Задание расположения при печати
    Печатаемая область листа чертежа определяется выбранным устройством вывода на печать и обозначается на разметке листа пунктирной линией. Расположение при печати может изменяться в зависимости от области печати и размера бумаги.
  • Ориентация листа и ориентация изображения
    Имеется возможность выбора из двух типов ориентации чертежа: альбомная или книжная.


Расположение чертежа на бумаге - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Расположение чертежа на бумаге
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Расположение чертежа на бумаге - Команды

Печать и публикация чертежей
Вывод чертежей на печать
Расположение чертежа на бумаге
Понятия
Процедуры
Команды
Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
PLOTROTMODE | Управляет ориентацией чертежа
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание печатаемой области - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Задание печатаемой области
Понятия
Процедуры
Команды

Область чертежа, предназначенная для вывода на печать, выделяется пунктирной рамкой на вкладке разметки листа. Печатаемая область определяется установленным плоттером и выбранным форматом бумаги.

Предупреждение Если плоттер работает в одном из режимов экономии бумаги (вложение или печать области, содержащей чернила), возможно несоблюдение плоттером установленной печатаемой области и параметров смещения чертежа.

Если результат печати не соответствует установленной печатаемой области для выбранного формата бумага, то настройку печатаемой области можно выполнить в редакторе параметров плоттера на вкладке "Параметры устройства и документа" в разделе структуры "Изменение стандартных форматов листа".

Примечание Эти опции не служат для задания отступов при выводе на печать. Для указания расположения чертежа на листе бумаги следует пользоваться опциями группы "Смещение от начала" диалогового окна "Печать".


Расположение чертежа на бумаге

Печать и публикация чертежей
Вывод чертежей на печать
Расположение чертежа на бумаге
Понятия
Процедуры
Команды

Нет процедур.


Задание печатаемой области - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Задание печатаемой области
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание расположения при печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Задание расположения при печати
Понятия
Процедуры
Команды

Печатаемая область листа чертежа определяется выбранным устройством вывода на печать и обозначается на разметке листа пунктирной линией. При выборе другого печатающего устройства область печати может измениться.

Настройка параметра "Смещение от начала" диалогового окна "Печать" определяет смещение области печати относительно левого нижнего угла печатаемой области или границы бумаги, в зависимости от положения переключателя "Отсчет смещения чертежа" на вкладке "Печать/Публикация" диалогового окна "Настройка". Выбранный вариант смещения приводится в круглых скобках после названия группы опций "Смещение от начала" в диалоговом окне "Печать".

Чертеж может быть смещен на положительную или отрицательную величину по осям X и Y. Однако это может привести к усечению чертежа при печати. Если выводимый фрагмент (границы, экран, вид или рамка) не укладывается полностью в печатаемую область, существует возможность центрировать изображение, выбрав опцию "Центрировать".


Задание расположения при печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Задание расположения при печати
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Ориентация листа и ориентация изображения - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Ориентация листа и ориентация изображения
Понятия
Процедуры
Команды

Имеется возможность выбора из двух типов ориентации чертежа: альбомная (длинный край располагается горизонтально) или книжная (длинный край располагается вертикально). Тип ориентации выбирается с учетом заданного формата бумаги. Кроме того, при выводе на печать чертеж можно переворачивать.


Ориентация листа и ориентация изображения - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Ориентация листа и ориентация изображения
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
PLOTROTMODE | Управляет ориентацией чертежа
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление стилем печати объектов - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Управление стилем печати объектов
Понятия
Процедуры
Команды

Имеется возможность управления печатью объектов с помощью параметров масштаба печати, стилей печати, таблиц стилей печати и путем изменения свойств слоев объектов.

  • Задание масштаба печати
    Для вывода чертежа на печать можно выбрать из списка один из предлагаемых масштабов печати в реальных координатах или указать свой масштаб. Кроме этого, можно установить масштаб "Вписать"; в этом случае масштаб будет подобран таким образом, что выводимый на печать чертеж окажется вписанным в выбранный формат листа.
  • Настройка печати видовых экранов с раскрашиванием
    Существует возможность выбора опций для печати раскрашенных и тонированных видовых экранов. Видовой экран можно вывести на печать в обычном состоянии, в каркасном представлении, без невидимых линий или тонированным.
  • Задание параметров печати объектов
    Диалоговые окна "Печать" и "Параметры листа" позволяют настраивать параметры, влияющие на печать объектов.
  • Использование стилей печати
    Имеется возможность управления печатью объектов с помощью стилей печати.
  • Таблицы цветозависимых стилей печати
    Использование цветозависимых стилей печати обеспечивает вывод объектов с учетом заданных для этих объектов цветов.
  • Таблицы именованных стилей печати
    В таблице именованных стилей печати можно создавать, удалять и редактировать стили. В такой таблице может быть создано любое число стилей.
  • Редактирование стилей печати
    В стили печати можно вносить изменения с помощью редактора таблиц стилей печати. Все модификации стиля отражаются на объектах, использующих этот стиль.


Управление стилем печати объектов - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Управление стилем печати объектов
Понятия
Процедуры
Команды

Печать с использованием масштаба в реальных координатах

Печать с использованием нестандартного масштаба

Вписывание чертежа в лист бумаги

Изменение способа печати раскрашенных видовых экранов

Изменение способа печати раскрашенных объектов пространства модели

Настройка уровня разрешения при печати видовых экранов с раскрашиванием

Настройка параметров печати раскрашенных объектов со вкладки "Модель"

Настройка параметров печати видовых экранов с раскрашиванием со вкладок разметок листов

Подавление скрытых линий при печати со вкладки "Модель"

Подавление скрытых линий при печати вкладки разметки листа

Печать с учетом весов линий

Отключение использования стилей печати

Изменение последовательности печати объектов

Скрытие объектов пространства листа при печати со вкладки разметки листа

Задание типа таблицы стилей печати для новых чертежей

Переход к использованию именованных стилей печати

Переход к использованию цветозависимых стилей печати

Преобразование таблицы цветозависимых стилей печати в таблицу именованных стилей печати

Подключения таблицы стилей печати к разметке листа

Просмотр разметки листа с учетом таблицы стилей печати

Создание таблицы стилей печати

Переименование таблицы стилей печати

Изменение пояснения к таблице стилей печати

Редактирование стилей в таблице стилей печати

Изменение стиля печати объекта

Изменение стиля печати для слоя

Задание текущего стиля печати

Создание именованного стиля печати

Копирование именованного стиля печати

Изменение пояснения к стилю печати

Переименование именованного стиля печати

Удаление именованного стиля печати

Удаление таблицы соответствия цветов

Изменение параметров стиля печати

Задание цвета в стиле печати

Назначение интенсивности

Включение/отключение размывания

Включение/отключение преобразования цветов в оттенки серого

Задание номера виртуального пера

Задание веса линий в стиле печати

Задание типа линий в стиле печати

Масштабирование типов линий и образцов закрашивания, не относящихся к стандарту ISO

Задание стиля окончаний или соединений линий

Задание стиля закрашивания


Управление стилем печати объектов - Команды

Печать и публикация чертежей
Вывод чертежей на печать
Управление стилем печати объектов
Понятия
Процедуры
Команды
Команды
ВЕСЛИН | Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий
ГРАФНАСТР | Обеспечивает конфигурационные установки системы 3D-графики
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПРЕОБРСПЕЧ | Настройка чертежа на использование именованных или цветозависимых стилей печати
ПРЕОБРТСП | Преобразование таблиц цветозависимых стилей печати (СТВ) в таблицы именованных стилей печати (STB)
ПСТИЛЬ | Задание текущего стиля печати для новых объектов или назначение стиля печати выбранным объектам
РЕЖИМРАСКР | Запускает команду ТЕКВИЗСТИЛЬ
СЛОЙ | Управление слоями и их свойствами
СПИСМАСШТРЕД | Управление списком доступных значений масштаба для видовых экранов, листа и печати
ШТЕМПЕЛЬ | Нанесение штемпеля в определенном углу каждого чертежа и запись соответствующей информации в файл журнала
Системные переменные
CPLOTSTYLE | Управление текущим стилем печати для новых объектов.
DEFLPLSTYLE | Указывает стиль печати по умолчанию для слоя 0
DEFPLSTYLE | Указывает стиль печати по умолчанию для новых объектов.
PSTYLEMODE | Указывает режим стиля печати текущего чертежа - цветозависимый или именованный
PSTYLEPOLICY | Управляет ассоциативностью свойства цвета объекта с его стилем печати
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание масштаба печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Задание масштаба печати
Понятия
Процедуры
Команды

Для вывода чертежа на печать можно выбрать из списка один из предлагаемых масштабов печати в реальных координатах или указать свой масштаб. Кроме этого, можно установить масштаб "Вписать"; в этом случае масштаб будет подобран таким образом, что выводимый на печать чертеж окажется вписанным в выбранный формат листа.

При рисовании объекты обычно изображаются в натуральную величину. Пользователь сам решает, с какой единицей реального мира (дюйм, миллиметр, метр и т.д.) сопоставить единицу чертежа. Например, если размеры реальных объектов удобно выражать в миллиметрах, то одна единица чертежа соответствует одному миллиметру. В дальнейшем при печати чертежа можно либо задать точный масштаб, либо воспользоваться режимом вписывания чертежа в заданный формат листа бумаги.

В большинстве случаев печать чертежей выполняется с точным масштабом. Метод задания масштаба печати зависит от выбора между вкладками разметки и модели при печати:

  • При выборе вкладки "Модель" задание масштаба печати выполняется в диалоговом окне "Печать". Этот масштаб определяет отношение единицы длины на напечатанном чертеже к единице реального мира, использованной при построении чертежа.
  • При выборе одной из вкладок разметки листа используются два масштаба. Первый из них задается для всего листа чертежа установленного формата и обычно определяется отношением 1:1. Второй масштаб применяется к самой модели, изображаемой на видовых экранах листа. Он определяет для каждого видового экрана как отношение размеров формата листа к размерам модели на видовом экране.

Примечание Можно изменить список масштабов, отображающихся во всех списках видов и масштабов печати, с помощью команды СПИСМАСШТРЕД.

Задание нестандартных масштабов

Во время печати можно выбирать единицы измерения (дюймы или миллиметры). Так, например, выбрав опцию "мм" (миллиметры) и указав в числовом поле значение 1, а в поле "Единицы чертежа" значение 10, можно тем самым установить масштаб, при котором каждые 10 миллиметров чертежа при выводе на печать будут преобразовываться в 1 миллиметр.

На рисунке показан результат печати лампы в трех различных масштабах.

Вписывание чертежа в лист бумаги

Для черновых вариантов чертежей точность задания масштаба не столь важна. Здесь лучше воспользоваться опцией "Вписать" для печати чертежа в наибольшем из возможных для данного формата масштабе. Ширина или высота чертежа соответствует ширине или высоте листа.

Опция масштабирования "Вписать" используется автоматически при печати вида в перспективе из пространства модели, даже если был выбран другой масштаб.

При выборе параметра "Вписать" происходит также изменение размеров текстовых объектов для отражения отношения форматов печатаемых объектов к формату объектов чертежа. Этот масштаб обновляется при каждом изменении формата бумаги, устройства печати, начала чертежа, ориентации или размеров печатаемой области в диалоговом окне "Печать".

Примечание Опция не доступна, если для области печати задан параметр "Разметка листа".


Задание масштаба печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание масштаба печати
Понятия
Процедуры
Команды

Печать с использованием масштаба в реальных координатах

Печать с использованием нестандартного масштаба

Вписывание чертежа в лист бумаги


Печать с использованием масштаба в реальных координатах - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание масштаба печати
Понятия
Процедуры
Команды

Печать с использованием масштаба в реальных координатах

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Масштаб печати" выберите масштаб из раскрывающегося списка.
  3. Нажмите "ОК" для вывода чертежа на печать.

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Печать с использованием нестандартного масштаба - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание масштаба печати
Понятия
Процедуры
Команды

Печать с использованием нестандартного масштаба

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Масштаб печати" введите пользовательский масштаб. Масштаб задается двумя значениями, определяющими отношение единиц измерения. Первое значение задает число единиц измерения на чертеже, а второе - соответствующее число единиц чертежа. Тип единиц измерения определяется размером листа, но его можно изменить, выбрав из списка.

    3. При вводе значений пользовательского масштаба автоматически происходит выбор опции "Пользовательский" из раскрывающего списка "Масштаб"; при этом параметры пользовательского масштаба могут совпадать с установками уже выбранного из списка масштаба. Пользовательский масштаб определяется отношением между единицами печати и чертежа; например, соотношения 1:12 и 2:24 приводят к выводу на печать в одном и том же масштабе.

  3. Нажмите "ОК" для вывода чертежа на печать.

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Вписывание чертежа в лист бумаги - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание масштаба печати
Понятия
Процедуры
Команды

Вписывание чертежа в лист бумаги

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Масштаб печати" выберите опцию "Вписать".

    3. Полученный масштаб будет вычислен автоматически. В соответствующем поле отображается отношение размеров печатаемых объектов к размерам объектов чертежа.

  3. Нажмите "ОК" для вывода чертежа на печать.

Примечание Опция не доступна, если для области печати задан параметр "Разметка листа".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Задание масштаба печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Задание масштаба печати
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
СПИСМАСШТРЕД | Управление списком доступных значений масштаба для видовых экранов, листа и печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка печати видовых экранов с раскрашиванием - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Настройка печати видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Существует возможность выбора опций для печати раскрашенных и тонированных видовых экранов. Видовой экран можно вывести на печать в обычном состоянии, в каркасном представлении, без невидимых линий или тонированным.

Для этого необходимо определить, как должны печататься раскрашенные области, и сохранить настройку опций в чертеже. Разрешение при печати выбирается в зависимости от плоттера и сохраняется для чертежа.

  • Коротко о процессе печати тонированных видовых экранов.
    Настройки печати видовых экранов, содержащих раскрашенные объекты, обеспечивают большую гибкость представления трехмерных объектов. Печать чертежа производится на основании выбранного режима обращения с раскрашенными видовыми экранами и установленного разрешения печатающего устройства.
  • Настройка режима печати видовых экранов с раскрашиванием
    При печати чертежей, содержащих раскрашенные 3D тела, возможен контроль качества печати.
  • Настройка уровня разрешения при печати видовых экранов с раскрашиванием
    Этот параметр управляет скоростью и качеством печати раскрашенных видовых экранов.


Настройка печати видовых экранов с раскрашиванием - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Настройка печати видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Изменение способа печати раскрашенных видовых экранов

Изменение способа печати раскрашенных объектов пространства модели

Настройка уровня разрешения при печати видовых экранов с раскрашиванием


Настройка печати видовых экранов с раскрашиванием - Команды

Печать и публикация чертежей
Вывод чертежей на печать
Настройка печати видовых экранов с раскрашиванием
Понятия
Процедуры
Команды
Команды
ГРАФНАСТР | Обеспечивает конфигурационные установки системы 3D-графики
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
РЕЖИМРАСКР | Запускает команду ТЕКВИЗСТИЛЬ
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о процессе печати тонированных видовых экранов. - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Коротко о процессе печати тонированных видовых экранов.
Понятия
Процедуры
Команды

Настройки печати видовых экранов, содержащих раскрашенные объекты, обеспечивают большую гибкость представления трехмерных объектов. Печать чертежа производится на основании выбранного режима обращения с раскрашенными видовыми экранами и установленного разрешения печатающего устройства.

С помощью режимов печати с раскрашиванием можно задать печать набора раскрашенных объектов в том виде, как они отображаются, либо в каркасном виде, в режиме с использованием подавления линий, визуальном стиле, или с тонированием. Раскрашенные и тонированные видовые экраны можно предварительно просматривать, печатать, печатать в файл и публиковать.

Презентационные изображения часто формируются путем печати содержимого раскрашенных видовых экранов либо в обычном виде, либо с изменением параметров.

Опции печати раскрашенных видовых экранов применимы ко всем объектам на видовых экранах и в пространстве модели. При использовании средства печати раскрашенных и тонированных видовых экранов таблицы стилей печати в параметрах листов не активизируются. Если используется опция "Тонирование", то двумерные каркасные объекты, такие как линии, дуги и текст, не печатаются.

Примечание Распечатывать раскрашенные видовые экраны можно только на устройствах с растровой графикой. Большинство современных плоттеров и принтеров поддерживают растровую графику.


Настройка печати видовых экранов с раскрашиванием

Печать и публикация чертежей
Вывод чертежей на печать
Настройка печати видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Нет процедур.


Коротко о процессе печати тонированных видовых экранов. - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Коротко о процессе печати тонированных видовых экранов.
Понятия
Процедуры
Команды

Команды
ГРАФНАСТР | Обеспечивает конфигурационные установки системы 3D-графики
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
РЕЖИМРАСКР | Запускает команду ТЕКВИЗСТИЛЬ
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка режима печати видовых экранов с раскрашиванием - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Настройка режима печати видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

При печати чертежей, содержащих раскрашенные 3D тела, возможен контроль качества печати.

Существует возможность выбора одного из следующих параметров:

  • Обычный. Печатает чертеж в том виде, в каком он отображен на экране, т. е. с сохранением всего имеющегося раскрашивания.
  • Каркас. Отображает линии и кривые для показа контуров объектов.
  • Скрытие линий. Запрещает печать объектов, находящихся за другими объектами.
  • Визуальные стили.Проект печатается так, как он отображается в выбранном визуальном стиле.
  • Тонирование. Выполнение тонирования объектов перед их печатью на основе параметров тонирования, заданных перед запуском печати или на основе выбранного набора параметров тонирования.

Параметры для чертежа могут быть выбраны в пространстве модели или на листе. В пространстве модели параметры печати доступны на палитре свойств и в диалоговом окне "Печать". Для разметки листа (после выбора видового экрана) доступ к параметрам печати возможет через контекстное меню или палитру свойств.

Также существует возможность сохранить настройки в самом чертеже.

Примечание При использовании параметра "Тонирование" перед печатью необходимо указать настройки тонирования. Если опция "Тонирование" выбрана для очень сложного чертежа, то, возможно, выведенной на печать окажется только рамка видового экрана.


Настройка режима печати видовых экранов с раскрашиванием - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Настройка режима печати видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Изменение способа печати раскрашенных видовых экранов

Изменение способа печати раскрашенных объектов пространства модели


Изменение способа печати раскрашенных видовых экранов - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Настройка режима печати видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Изменение способа печати раскрашенных видовых экранов

  1. Перейдите на вкладку разметки листа.
  2. Дважды нажмите кнопку мыши на контуре видового экрана, который нужно отредактировать.
  3. На палитре свойств в группе "Разное" выберите "Визуализация при печати" и назначьте нужный режим.

Контекстное меню: Выберите видовой экран и нажмите правую кнопку мыши в области построения чертежа. Выберите один из параметров подменю "Способ вывода".


Изменение способа печати раскрашенных объектов пространства модели - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Настройка режима печати видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Изменение способа печати раскрашенных объектов пространства модели

  1. На вкладке "Модель" отмените выбор всех объектов.
  2. Нажмите "Файл" » "Печать".
  3. В диалоговом окне "Печать" выберите нужный способ вывода в группе "ВЭкраны с раскрашиванием".

Ввод команды: ПЕЧАТЬ


Настройка режима печати видовых экранов с раскрашиванием - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Настройка режима печати видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Команды
ГРАФНАСТР | Обеспечивает конфигурационные установки системы 3D-графики
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
РЕЖИМРАСКР | Запускает команду ТЕКВИЗСТИЛЬ
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка уровня разрешения при печати видовых экранов с раскрашиванием - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Настройка уровня разрешения при печати видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Этот параметр управляет скоростью и качеством печати раскрашенных видовых экранов.

После выбора устройства печати можно установить уровень качества вывода на печать. Уровень качества определяет количество точек на дюйм (dpi). Количество точек на дюйм, соответствующее уровню качества, зависит от выбранного плоттера.

Максимально возможное количество точек на дюйм также зависит от выбранного плоттера. Если качеству печати присвоено значение "Пользовательское", можно установить значение в диапазоне от 100 т/дюйм до максимально допустимого значения.

Чем выше уровень качества печати, тем больше оперативной памяти компьютера требуется для вывода на печать. Следовательно время, затрачиваемое на печать чертежа, возрастает. Для оптимальной работы большинства устройств печати достаточно назначить уровень качества в диапазоне от 300 до 600 т/дюйм.


Настройка уровня разрешения при печати видовых экранов с раскрашиванием - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Настройка уровня разрешения при печати видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Настройка уровня разрешения при печати видовых экранов с раскрашиванием

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать", в группе "ВЭкраны с раскрашиванием", выберите в раскрывающемся списке "Качество" соответствующее значение.

    3. Для явного задания уровня качества печати выберите из списка "Качество" значение "Пользовательское" и введите число в поле "Т/дюйм".

  3. Нажмите "ОК".

Ввод команды: ПЕЧАТЬ


Настройка уровня разрешения при печати видовых экранов с раскрашиванием - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Настройка уровня разрешения при печати видовых экранов с раскрашиванием
Понятия
Процедуры
Команды

Команды
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание параметров печати объектов - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Задание параметров печати объектов
Понятия
Процедуры
Команды

Диалоговые окна "Печать" и "Параметры листа" позволяют настраивать параметры, влияющие на печать объектов.

  • ВЭкраны с раскрашиванием. Задает параметры печати раскрашенных видовых экранов: "Обычный", "Каркас" или "Скрытие линий". Опция воздействует на линии только в момент печати и просмотра перед печатью.
  • Учитывать веса линий. Задает печать с учетом толщин линий, назначенных объектам и слоям.
  • Учитывать стили печати. Задает печать чертежа с применением стилей печати. При выборе этой опции печать выполняется с учетом весов линий. Если эта опция отключена, то печать выполняется с учетом свойств объектов без переопределения этих свойств с помощью стилей печати.

    • Примечание Стили печати недоступны для объектов, к которым применён модификатор мерцания ребра (ВИЗСТИЛИ).

  • Печатать пространство листа последним. Задает последовательность печати таким образом, чтобы в первую очередь выполнялась печать объектов пространства модели и только затем - пространства листа.
  • Скрывать объекты листа Определяет, применима ли операция скрытия к объектам видового экрана пространства листа. Доступно только для вкладок разметки листов. Опция обеспечивает изображение только для просмотра перед печатью, но не в разметке листа.
  • Печатать штемпель. Распечатывает штемпель в определенном углу каждого чертежа и записывает соответствующую информацию в файл журнала. Настройки штемпеля задаются в диалоговом окне "Штемпель чертежа", предназначенном для задания информации, включаемой в штемпель, например имени чертежа, даты/времени, масштаба и т.п. Для вызова этого окна следует в диалоговом окне "Печать" выбрать опцию "Печатать штемпель", а затем нажать кнопку "Параметры штемпеля".
  • Сохранить изменения в разметке листа. После нажатия кнопки "OK" сохраняет в разметке листа все изменения параметров, произведенные в диалоговом окне "Печать".


Задание параметров печати объектов - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание параметров печати объектов
Понятия
Процедуры
Команды

Настройка параметров печати раскрашенных объектов со вкладки "Модель"

Настройка параметров печати видовых экранов с раскрашиванием со вкладок разметок листов

Подавление скрытых линий при печати со вкладки "Модель"

Подавление скрытых линий при печати вкладки разметки листа

Печать с учетом весов линий

Отключение использования стилей печати

Изменение последовательности печати объектов

Скрытие объектов пространства листа при печати со вкладки разметки листа


Настройка параметров печати раскрашенных объектов со вкладки "Модель" - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание параметров печати объектов
Понятия
Процедуры
Команды

Настройка параметров печати раскрашенных объектов со вкладки "Модель"

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "ВЭкраны с раскрашиванием" в раскрывающемся списке "Способ вывода" выберите соответствующий параметр.

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Настройка параметров печати видовых экранов с раскрашиванием со вкладок разметок листов - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание параметров печати объектов
Понятия
Процедуры
Команды

Настройка параметров печати видовых экранов с раскрашиванием со вкладок разметок листов

  1. Выберите видовой экран разметки листа.
  2. Дважды нажав кнопку мыши на границе видового экрана, откройте палитру свойств.
  3. В палитре свойств выберите "Визуализация при печати".
  4. В раскрывающемся списке "Визуализация при печати" выберите соответствующий параметр.

Панель "Стандартная"

Ввод команды: ОКОНСВ

Контекстное меню: Выберите видовой экран, нажмите правую кнопку мыши в области чертежа и выберите "Визуализация при печати".


Подавление скрытых линий при печати со вкладки "Модель" - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание параметров печати объектов
Понятия
Процедуры
Команды

Подавление скрытых линий при печати со вкладки "Модель"

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "ВЭкраны с раскрашиванием" в раскрывающемся списке "Способ вывода" выберите "Скрытие линий".
  3. Нажмите "ОК" для вывода чертежа на печать.

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Подавление скрытых линий при печати вкладки разметки листа - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание параметров печати объектов
Понятия
Процедуры
Команды

Подавление скрытых линий при печати вкладки разметки листа

  1. Выберите видовой экран разметки листа.
  2. Дважды нажав кнопку мыши на границе видового экрана, откройте палитру свойств.
  3. В палитре свойств выберите "Визуализация при печати".
  4. В раскрывающемся списке "Визуализация при печати" выберите "Скрытие линий".
  5. Нажмите "ОК" для вывода чертежа на печать.

Панель "Стандартная"

Ввод команды: ОКОНСВ

Контекстное меню: Выберите видовой экран и нажмите правую кнопку мыши в области построения чертежа. Выберите "Визуализация при печати".


Печать с учетом весов линий - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание параметров печати объектов
Понятия
Процедуры
Команды

Печать с учетом весов линий

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Опции печати" установить флажок "Учитывать веса линий".

    3. Эта опция доступна для изменения только в том случае, если сброшен флажок "Учитывать стили печати".

  3. Нажмите "ОК" для вывода чертежа на печать.

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Отключение использования стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание параметров печати объектов
Понятия
Процедуры
Команды

Отключение использования стилей печати

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Опции печати" снимите флажок "Учитывать стили печати".
  3. Нажмите "ОК" для вывода чертежа на печать.

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Изменение последовательности печати объектов - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание параметров печати объектов
Понятия
Процедуры
Команды

Изменение последовательности печати объектов

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Опции печати" установите флажок "Объекты листа последними". Снимите флажок для вывода на печать объектов листа первыми.
  3. Нажмите "ОК" для вывода чертежа на печать.

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Скрытие объектов пространства листа при печати со вкладки разметки листа - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание параметров печати объектов
Понятия
Процедуры
Команды

Скрытие объектов пространства листа при печати со вкладки разметки листа

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Опции печати" установить флажок "Скрывать объекты листа".
  3. Нажмите "ОК" для вывода чертежа на печать.

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Задание параметров печати объектов - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Задание параметров печати объектов
Понятия
Процедуры
Команды

Команды
ВЕСЛИН | Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ШТЕМПЕЛЬ | Нанесение штемпеля в определенном углу каждого чертежа и запись соответствующей информации в файл журнала
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование стилей печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Использование стилей печати
Понятия
Процедуры
Команды

Имеется возможность управления печатью объектов с помощью стилей печати.

  • Коротко о стилях печати
    Стиль печати задает свойства объекта при выводе на печать.
  • Выбор типа таблиц стилей печати
    Таблица стилей печати содержит набор стилей печати, назначенных листу или модели. Существует два типа таблиц стилей печати: таблицы цветозависимых стилей печати и таблицы именованных стилей печати.
  • Смена типов таблиц стилей печати
    При работе с чертежом имеется возможность выбора, использовать таблицу цветозависимых стилей печати или именованных стилей печати.
  • Подключение таблиц стилей печати к листам
    Возможность подключения различных таблиц стилей печати к каждому листу чертежа позволяет управлять печатью объектов.
  • Управление таблицами стилей печати
    С помощью Диспетчера стилей печати можно добавлять, удалять, переименовывать, копировать и редактировать таблицы стилей печати.


Использование стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Использование стилей печати
Понятия
Процедуры
Команды

Задание типа таблицы стилей печати для новых чертежей

Переход к использованию именованных стилей печати

Переход к использованию цветозависимых стилей печати

Преобразование таблицы цветозависимых стилей печати в таблицу именованных стилей печати

Подключения таблицы стилей печати к разметке листа

Просмотр разметки листа с учетом таблицы стилей печати

Создание таблицы стилей печати

Переименование таблицы стилей печати

Изменение пояснения к таблице стилей печати

Редактирование стилей в таблице стилей печати


Использование стилей печати - Команды

Печать и публикация чертежей
Вывод чертежей на печать
Использование стилей печати
Понятия
Процедуры
Команды
Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПРЕОБРСПЕЧ | Настройка чертежа на использование именованных или цветозависимых стилей печати
ПРЕОБРТСП | Преобразование таблиц цветозависимых стилей печати (СТВ) в таблицы именованных стилей печати (STB)
Системные переменные
CPLOTSTYLE | Управление текущим стилем печати для новых объектов.
DEFLPLSTYLE | Указывает стиль печати по умолчанию для слоя 0
DEFPLSTYLE | Указывает стиль печати по умолчанию для новых объектов.
PSTYLEMODE | Указывает режим стиля печати текущего чертежа - цветозависимый или именованный
PSTYLEPOLICY | Управляет ассоциативностью свойства цвета объекта с его стилем печати
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о стилях печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Коротко о стилях печати
Понятия
Процедуры
Команды

Стиль печати наряду с типом линии или цветом является свойством объекта. Стили печати могут назначаться отдельным объектам и слоям. Стиль печати управляет следующими свойствами объекта при выводе его на печать:

  • цвет
  • размывание
  • оттенки серого
  • номер пера
  • виртуальное перо
  • интенсивность
  • тип линий
  • вес линий
  • стиль окончаний линий
  • стиль соединений линий
  • стиль закрашивания

Использование стилей печати позволяет при необходимости переопределять установленные свойства объектов, что придает работе с объектами большую гибкость.

Стили печати могут быть сохранены группами в виде таблиц. Таблицы стилей печати бывают двух видов: цветозависимые (CTB) или именованные (STB). Цветозависимые стили печати базируются на цветах объектов. Именованные стили печати могут назначаться объектам независимо от их цветов.

Примечание Стили печати недоступны для объектов, к которым применён модификатор мерцания ребра (ВИЗСТИЛИ).


Использование стилей печати

Печать и публикация чертежей
Вывод чертежей на печать
Использование стилей печати
Понятия
Процедуры
Команды

Нет процедур.


Коротко о стилях печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Коротко о стилях печати
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПРЕОБРСПЕЧ | Настройка чертежа на использование именованных или цветозависимых стилей печати
ПРЕОБРТСП | Преобразование таблиц цветозависимых стилей печати (СТВ) в таблицы именованных стилей печати (STB)
Системные переменные
CPLOTSTYLE | Управление текущим стилем печати для новых объектов.
DEFLPLSTYLE | Указывает стиль печати по умолчанию для слоя 0
DEFPLSTYLE | Указывает стиль печати по умолчанию для новых объектов.
PSTYLEMODE | Указывает режим стиля печати текущего чертежа - цветозависимый или именованный
PSTYLEPOLICY | Управляет ассоциативностью свойства цвета объекта с его стилем печати
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор типа таблиц стилей печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Выбор типа таблиц стилей печати
Понятия
Процедуры
Команды

Таблица стилей печати содержит набор стилей печати, назначенных листу или модели. Существует два типа таблиц стилей печати: таблицы цветозависимых стилей печати и таблицы именованных стилей печати.

Таблицы цветозависимых стилей печати (CTB) позволяют использовать цвет для определения таких характеристик, как вес линий. Каждый объект, вычерченный, например, красным цветом, будет напечатан с одними и теми же параметрами. Стили печати в такой таблице можно редактировать, но их добавление в таблицу и удаление из таблицы цветозависимых стилей печати невозможны. В таблице цветозависимых стилей печати имеется 256 стилей, по одному на каждый цвет.

Таблицы именованных стилей печати (STB) содержат пользовательские стили печати. При использовании такой таблицы печать объектов, имеющих один и тот же цвет, может выполняться с различными характеристиками, на основании назначенных каждому объекту стилей печати. Таблица именованных стилей печати может содержать любое количество стилей. Именованные стили печати могут назначаться объектам или слоям, как любые другие свойства.


Задание типа таблицы стилей печати для новых чертежей - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Выбор типа таблиц стилей печати
Понятия
Процедуры
Команды

Задание типа таблицы стилей печати для новых чертежей

  1. Нажмите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" на вкладке "Печать/Публикация" нажмите кнопку "Таблицы стилей печати".
  3. В диалоговом окне "Параметры таблиц стилей печати" установите переключатель в положение "Цветозависимые стили печати" или "Именованные стили печати".
  4. (Не обязательно) Выберите таблицу из списка "Таблица стилей печати по умолчанию".
  5. (Не обязательно) Если установить переключатель в положение "Именованные стили печати", то выбранные стили будут применяться к слою 0 и к новым объектам.
  6. Нажмите "ОК".

    7. Примечание Установка типов таблиц стилей печати для новых чертежей никак не влияет на уже существующие чертежи.

Ввод команды: НАСТРОЙКА


Выбор типа таблиц стилей печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Выбор типа таблиц стилей печати
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Смена типов таблиц стилей печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Смена типов таблиц стилей печати
Понятия
Процедуры
Команды

При работе с чертежом имеется возможность выбора, использовать таблицу цветозависимых стилей печати или именованных стилей печати.

Для определения того, какую таблицу стилей печати, цветозависимых или именованных, следует использовать на чертеже, можно вызвать команду ПРЕОБРСПЕЧ.

При переходе с использования таблицы цветозависимых стилей печати к использованию таблицы именованных стилей печати все цветозависимые стили печати, назначенные листам, удаляются, и вместо них назначаются именованные стили печати. Если необходимо использовать стили, определяемые в таблицах цветозависимых стилей печати, после применения к чертежу таблицы именованных стилей, требуется предварительное преобразование таблицы цветозависимых стилей печати в таблицу именованных стилей печати.

При переходе с таблиц именованных стилей печати к таблицам цветозависимых стилей печати теряются имена стилей печати, назначенных объектам чертежа.

Кроме смены типа таблицы стилей печати, можно воспользоваться командой ПРЕОБРТСП для преобразования таблиц цветозависимых стилей печати в таблицы именованных стилей. Преобразовать таблицу именованных стилей печати в таблицу цветозависимых стилей невозможно.


Смена типов таблиц стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Смена типов таблиц стилей печати
Понятия
Процедуры
Команды

Переход к использованию именованных стилей печати

Переход к использованию цветозависимых стилей печати

Преобразование таблицы цветозависимых стилей печати в таблицу именованных стилей печати


Переход к использованию именованных стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Смена типов таблиц стилей печати
Понятия
Процедуры
Команды

Переход к использованию именованных стилей печати

  1. В командной строке введите преобрспеч.
  2. Нажмите "ОК" в окне сообщения для подтверждения.
  3. В диалоговом окне "Выбор файла" выберите файл таблицы именованных стилей печати для его подключения к модели и листам, использующих общую таблицу.
  4. Нажмите "Открыть".

    5. Появится окно подтверждения преобразования чертежа.

    Примечание Если в диалоговом окне флажок "Показать стили печати" был уже установлен, то в командной строке следует ввести реген для отображения чертежа с учетом подключенных стилей печати.


Переход к использованию цветозависимых стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Смена типов таблиц стилей печати
Понятия
Процедуры
Команды

Переход к использованию цветозависимых стилей печати

  1. В командной строке введите преобрспеч.
  2. Нажмите "ОК".

    3. Появится окно подтверждения преобразования чертежа.


Преобразование таблицы цветозависимых стилей печати в таблицу именованных стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Смена типов таблиц стилей печати
Понятия
Процедуры
Команды

Преобразование таблицы цветозависимых стилей печати в таблицу именованных стилей печати

  1. В командной строке ввести преобртсп.
  2. В диалоговом окне "Выбор файла" выберите файл таблицы стилей печати для преобразования и нажмите "Открыть". По умолчанию, таблицы стилей печати сохраняются в папке Plot Styles.
  3. Введите имя новой таблицы стилей печати. Нажмите кнопку "Сохранить".
  4. Нажмите "ОК" в окне сообщения для подтверждения.

Примечание Переименование стилей печати таблицы с помощью редактора таблиц стилей печати следует выполнять перед тем, как подключать эту таблицу к чертежу.

Ввод команды: ПРЕОБРТСП


Смена типов таблиц стилей печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Смена типов таблиц стилей печати
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПРЕОБРСПЕЧ | Настройка чертежа на использование именованных или цветозависимых стилей печати
ПРЕОБРТСП | Преобразование таблиц цветозависимых стилей печати (СТВ) в таблицы именованных стилей печати (STB)
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Подключение таблиц стилей печати к листам - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Подключение таблиц стилей печати к листам
Понятия
Процедуры
Команды

Возможность подключения различных таблиц стилей печати к каждому листу чертежа позволяет управлять печатью объектов пространств модели и листа. Для печати чертежа без учета свойств стилей печати следует из списка таблиц стилей печати выбрать "Нет".

Если используются таблицы именованных стилей печати, то стиль печати присваивается каждому объекту чертежа напрямую или через назначение слою с этим объектом.

Для просмотра результата применения таблицы стилей печати к листу необходимо в диалоговом окне "Параметры листа" в группе "Таблица стилей печати" установить флажок "Показать стили печати".

Примечание Если вставить в текущий чертеж внешнюю ссылку, то таблица стилей печати этой внешней ссылки также добавляется в чертеж. Для внесения изменений в процесс обработки объектов с помощью стилей печати служит редактор таблиц стилей печати.


Подключение таблиц стилей печати к листам - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Подключение таблиц стилей печати к листам
Понятия
Процедуры
Команды

Подключения таблицы стилей печати к разметке листа

Просмотр разметки листа с учетом таблицы стилей печати


Подключения таблицы стилей печати к разметке листа - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Подключение таблиц стилей печати к листам
Понятия
Процедуры
Команды

Подключения таблицы стилей печати к разметке листа

  1. Перейдите на вкладку модели или разметки листа, которой должна быть назначена таблица.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов нажмите "Редактирование".
  4. В группе "Таблица стилей печати" выберите таблицу стилей печати из списка.
  5. В диалоговом окне "Вопрос" нажмите "Да" или "Нет", чтобы указать, применять ли сделанный выбор к текущей вкладке или ко всем разметкам листов.

    6. Эта опция доступна только на вкладке "Модель".

  6. Для просмотра результата применения таблицы стилей печати к разметке листа поднимите флажок "Показать стили печати".

    7. Эта опция доступна только на вкладках разметок листов.

  7. Нажмите "ОК".
  8. Нажмите кнопку "Закрыть" в Диспетчере наборов параметров листов.

Примечание Если в диалоговом окне флажок "Показать стили печати" был уже установлен, то в командной строке следует ввести реген для отображения чертежа с учетом подключенных стилей печати.

Панель "Листы"

Ввод команды: ПАРАМЛИСТ


Просмотр разметки листа с учетом таблицы стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Подключение таблиц стилей печати к листам
Понятия
Процедуры
Команды

Просмотр разметки листа с учетом таблицы стилей печати

  1. Перейдите на вкладку разметки листа, на которой нужно оценить результат применения таблицы стилей печати.
  2. Нажмите "Файл" » "Диспетчер наборов параметров листов".
  3. В Диспетчере наборов параметров листов нажмите "Редактирование".
  4. В группе "Таблица стилей печати" установить флажок "Показать стили печати".
  5. Нажмите "ОК".
  6. Нажмите кнопку "Закрыть" в Диспетчере наборов параметров листов.

    7. Результат применения таблицы стилей печати отображается на разметке листа.

Панель "Листы"

Ввод команды: ПАРАМЛИСТ


Подключение таблиц стилей печати к листам - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Подключение таблиц стилей печати к листам
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление таблицами стилей печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Управление таблицами стилей печати
Понятия
Процедуры
Команды

С помощью Диспетчера стилей печати можно добавлять, удалять, переименовывать, копировать и редактировать таблицы стилей печати.

По умолчанию таблицы цветозависимых (CTB-файлы) и именованных (STB-файлы) стилей печати хранятся в папке Plot Styles. С файлами из этой папки Диспетчер стилей печати работает по умолчанию.

С помощью Диспетчера стилей печати можно добавлять, удалять, переименовывать, копировать и редактировать таблицы стилей печати. В Диспетчере стилей печати отобразятся все доступные таблицы стилей печати.


Управление таблицами стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Управление таблицами стилей печати
Понятия
Процедуры
Команды

Создание таблицы стилей печати

Переименование таблицы стилей печати

Изменение пояснения к таблице стилей печати

Редактирование стилей в таблице стилей печати


Создание таблицы стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Управление таблицами стилей печати
Понятия
Процедуры
Команды

Создание таблицы стилей печати

  1. Нажмите "Сервис" » "Мастера" » "Добавление таблиц стилей печати...".
  2. Прочтите первую страницу. Нажмите "Далее".
  3. На странице "Начало" можно использовать файл конфигурации (CFG) или файл конфигурации плоттера (PCP или PC2) для импорта параметров перьев и создания таблицы стилей на основе уже существующей таблицы стилей или с самого начала. Если для создания выберите уже существующую таблицу стилей печати, то для новой таблицы устанавливается тот же тип. Нажмите "Далее".
  4. На странице "Выбор типа таблицы" установите переключатель в положение "Таблица цветозависимых стилей печати" или "Таблица именованных стилей печати".
  5. Если создание выполняется с импортированием параметров перьев из PCP- или PC2-файла, а также на основе CFG-файла или существующей таблицы стилей печати, то на странице "Поиск файла" выберите файл. Если для создания используется CFG-файл, то может потребоваться выбор конфигурации плоттера для импорта. Нажмите "Далее".
  6. На странице "Имя файла" введите имя новой таблицы стилей печати. Нажмите "Далее".
  7. На странице "Окончание" можно нажать кнопку "Редактор таблиц стилей печати" для редактирования новой таблицы. Можно указать, что новая таблица стилей печати будет использоваться всеми чертежами.
  8. Нажмите "Готово".

    9. Новая таблица стилей печати становится доступна в диалоговых окнах "Печать" и "Параметры листа" для применения ко всем чертежам, использующим таблицы цветозависимых стилей печати.


Переименование таблицы стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Управление таблицами стилей печати
Понятия
Процедуры
Команды

Переименование таблицы стилей печати

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Нажмите правую кнопку мыши на стиле печати, который необходимо переименовать. Выберите "Переименовать".
  3. Введите новое имя файла. Расширение нового имени файла следует оставить без изменений (.ctb или .stb). По завершении процедуры нажмите ENTER.

    4. Переименованная таблица стилей печати становится доступна в диалоговых окнах "Печать" и "Параметры листа" для применения ко всем чертежам, использующим данный тип таблиц стилей печати.

Ввод команды: ДИСПСТИЛЬ


Изменение пояснения к таблице стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Управление таблицами стилей печати
Понятия
Процедуры
Команды

Изменение пояснения к таблице стилей печати

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке файла таблицы стилей печати, пояснение к которой требуется изменить.
  3. На вкладке "Общие" редактора таблиц стилей печати введите новое пояснение к таблице.
  4. Нажмите кнопку "Принять".

Ввод команды: ДИСПСТИЛЬ


Редактирование стилей в таблице стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Управление таблицами стилей печати
Понятия
Процедуры
Команды

Редактирование стилей в таблице стилей печати

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати в списке "Стили" выберите стиль печати и внесите изменения в его параметры.
  4. Нажмите кнопку "Принять".

Ввод команды: ДИСПСТИЛЬ


Управление таблицами стилей печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Управление таблицами стилей печати
Понятия
Процедуры
Команды

Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Таблицы цветозависимых стилей печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Таблицы цветозависимых стилей печати
Понятия
Процедуры
Команды

Если в чертеже используется таблица цветозависимых стилей печати, назначение стиля печати отдельно каждому объекту или слою невозможно. Для настройки цветов следует использовать цветовые свойства объектов или слоев.

Таблицы цветозависимых стилей печати можно назначать листам. При этом допустимо использование нескольких стандартных таблиц цветозависимых стилей, а также редактирование и создание своих таблиц.

По умолчанию файлы таблиц цветозависимых стилей печати имеют расширение .ctb и хранятся в папке Plot Styles.

Стандартные таблицы цветозависимых стилей печати

В папке Plot Styles, которая называется также Диспетчером стилей печати, установлено несколько таблиц цветонезависимых стилей печати.

Таблица | Описание
acad.ctb | Таблица стилей печати, используемая по умолчанию
fillPatterns.ctb | Устанавливает первые 9 цветов для использования в первых 9 образцах закрашивания, а остальные цвета - для закрашиваний, задаваемых в объектах
grayscale.ctb | Преобразовывает все цвета в оттенки серого при печати
monochrome.ctb | Печатает все цвета черным
Нет | Обозначает отсутствие назначения какой-либо таблицы стилей печати
screening 100%.ctb | Использует 100% краски для вывода всех цветов
screening 75%.ctb | Использует 75% краски для вывода всех цветов
screening 50%.ctb | Использует 50% краски для вывода всех цветов
screening 25%.ctb | Использует 25% краски для вывода всех цветов

Примечание Назначение листу таблицы цветозависимых стилей печати возможно лишь в том случае, если в параметрах чертежа установлена возможность использования таблиц цветозависимых стилей.

См. также

Подключение таблиц стилей печати к листам


Управление стилем печати объектов

Печать и публикация чертежей
Вывод чертежей на печать
Управление стилем печати объектов
Понятия
Процедуры
Команды

Нет процедур.


Таблицы цветозависимых стилей печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Таблицы цветозависимых стилей печати
Понятия
Процедуры
Команды

Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Таблицы именованных стилей печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Таблицы именованных стилей печати
Понятия
Процедуры
Команды

В таблице именованных стилей печати можно создавать, удалять и редактировать стили. В такой таблице может быть создано любое число стилей.

  • Именованные стили печати
    Именованные стили печати, так же как тип линий и цвет, можно назначать объектам и слоям.
  • Управление именованными стилями печати
    Для добавления, удаления, переименования и копирования именованных стилей печати в таблице стилей предназначен редактор таблиц стилей печати.
  • Стандартные таблицы именованных стилей печати
    Помимо таблицы стилей по умолчанию имеется дополнительная таблица именованных стилей, которую можно использовать. Все файлы таблиц именованных стилей печати имеют расширение .stb.
  • Удаление таблиц соответствия цветов
    Таблицы стилей печати, из которых удалена информация о соответствии цветов, не годятся для назначения стилей печати объектам старых чертежей.


Таблицы именованных стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Таблицы именованных стилей печати
Понятия
Процедуры
Команды

Изменение стиля печати объекта

Изменение стиля печати для слоя

Задание текущего стиля печати

Создание именованного стиля печати

Копирование именованного стиля печати

Изменение пояснения к стилю печати

Переименование именованного стиля печати

Удаление именованного стиля печати

Удаление таблицы соответствия цветов


Таблицы именованных стилей печати - Команды

Печать и публикация чертежей
Вывод чертежей на печать
Таблицы именованных стилей печати
Понятия
Процедуры
Команды
Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
ПСТИЛЬ | Задание текущего стиля печати для новых объектов или назначение стиля печати выбранным объектам
СЛОЙ | Управление слоями и их свойствами
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Именованные стили печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Именованные стили печати
Понятия
Процедуры
Команды

Именованные стили печати, так же как тип линий и цвет, можно назначать объектам и слоям.

Если для свойства "Стиль печати" объекта установлено значение ПОСЛОЮ, то данный объект использует характеристики стиля печати, назначенные для его слоя.

Изменение стиля печати для объекта можно выполнять с помощью палитры свойств, для слоя - с помощью Диспетчера свойств слоев.

Так как каждому листу может быть назначена своя таблица именованных стилей печати, в которой может содержаться произвольное число стилей, то возможны такие ситуации, когда для объекта или слоя назначается стиль печати, который не определен в таблицах, подключенных к другим листам чертежа. В этом случае, если стиль печати отсутствует в диалоговом окне "Выбор стиля печати", используются свойства печати объекта по умолчанию. Например, пусть имеются таблицы Style1 со стилями печати A и B и Style2 со стилями печати B и C. Тогда на листе с подключенной таблицей Style1 все объекты, которым назначен стиль печати C, будут выведены в список объектов с необнаруженными стилями печати. Эти объекты вычерчиваются с учетом параметров, установленных по умолчанию.


Именованные стили печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Именованные стили печати
Понятия
Процедуры
Команды

Изменение стиля печати объекта

Изменение стиля печати для слоя

Задание текущего стиля печати


Изменение стиля печати объекта - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Именованные стили печати
Понятия
Процедуры
Команды

Изменение стиля печати объекта

Устанавливать стиль печати для каждого объекта можно лишь в том случае, если в чертеже используются таблицы именованных стилей печати. Если же в чертеже используются таблицы цветозависимых стилей, то управление отображением объектов возможно лишь через их свойства, определяющие цвет.

  1. Выберите объекты, для которых необходимо изменить стиль печати.
  2. Нажмите правую кнопку мыши в области чертежа. Выберите "Свойства".
  3. В палитре свойств выберите стиль печати из списка доступных стилей. Нажмите для этого кнопку мыши на второй ячейке строки "Стиль печати".

    4. Раскрывается список стилей, используемых объектами и входящих в таблицу стилей, подключенную к текущему листу.

  4. Если требуется задать иной стиль печати, не входящий в этот список, выберите "Прочие". В диалоговом окне "Выбор стиля печати" можно подключить другую таблицу стилей печати и выбрать необходимый стиль из этой таблицы.
  5. Для редактирования текущей таблицы стилей нажмите "Редактор".
  6. По завершении нажмите кнопку "OK".

    7. Все изменения, выполненные на палитре свойств, сразу же вступают в силу. Смена таблицы стилей печати для текущего листа сказывается на объектах модели и пространства листа.

Панель "Стандартная"

Ввод команды: ОКОНСВ


Изменение стиля печати для слоя - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Именованные стили печати
Понятия
Процедуры
Команды

Изменение стиля печати для слоя

  1. Нажмите "Формат" » "Слои".
  2. В Диспетчере свойств слоев выберите слой, для которого требуется изменить стиль печати.
  3. Нажмите кнопку мыши на имени текущего стиля в столбце "Стиль печати". Выберите назначаемый стиль печати.
  4. Для выбора стиля печати из другой таблицы стилей выберите нужную таблицу для активизации из списка "Активная таблица стилей печати".

    5. Состав списка доступных стилей печати меняется в соответствии с выбранной таблицей.

  5. Для редактирования таблицы стилей нажмите "Редактор". Внесите необходимые изменения. Нажмите кнопку "Принять & Закрыть".
  6. Нажмите "ОК".

    7. Устанавливать стиль печати для каждого слоя можно лишь в том случае, если в чертеже используются таблицы именованных стилей печати. Если же в чертеже используются таблицы цветозависимых стилей, то управление отображением слоя возможно лишь через свойства его объектов, определяющие цвет.

    Примечание Для того, чтобы объект наследовал стиль печати от слоя, следует установить для стиля печати объекта значение ПОСЛОЮ.

Панель "Слои"

Ввод команды: СЛОЙ


Задание текущего стиля печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Именованные стили печати
Понятия
Процедуры
Команды

Задание текущего стиля печати

  1. Нажмите "Формат" » "Стили печати".
  2. В диалоговом окне "Текущий стиль печати" выберите стиль из списка.

    3. В списке выводятся стили печати, доступные в текущей таблице стилей.

  3. Для выбора стиля печати из другой таблицы стилей выберите нужную таблицу для активизации из списка "Активная таблица стилей печати".

    4. Состав списка доступных стилей печати меняется в соответствии с выбранной таблицей.

  4. Для редактирования таблицы стилей нажмите "Редактор". Внесите необходимые изменения. Нажмите кнопку "Принять & Закрыть".
  5. Нажмите "ОК".

    6. Текущий стиль печати автоматически назначается новым создаваемым объектам чертежа.

    Задание текущего стиля возможно лишь в том случае, если в чертеже используются таблицы именованных стилей печати. Если же в чертеже используются таблицы цветозависимых стилей, то управление отображением объектов и слоев возможно лишь через свойства объектов, определяющие цвет.

    Примечание Для того, чтобы объект унаследовал текущий стиль печати от текущего слоя, следует установить для текущего стиля печати объекта значение ПОСЛОЮ.

Ввод команды: ПСТИЛЬ


Именованные стили печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Именованные стили печати
Понятия
Процедуры
Команды

Команды
ПСТИЛЬ | Задание текущего стиля печати для новых объектов или назначение стиля печати выбранным объектам
СЛОЙ | Управление слоями и их свойствами
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление именованными стилями печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Управление именованными стилями печати
Понятия
Процедуры
Команды

Для добавления, удаления, переименования и копирования именованных стилей печати в таблице стилей предназначен редактор таблиц стилей печати.

Редактор используется также для настройки параметров как именованных стилей, так и цветозависимых стилей печати.

Примечание Стиль печати NORMAL нельзя ни модифицировать, ни удалить. Кроме того, если для таблицы именованных стилей печати уже присвоены цвета, то добавление, удаление, копирование или переименование стилей в такой таблице невозможно. Таблица соответствия цветов связывает каждый стиль печати с цветом ACI.

См. также

Редактирование стилей печати


Управление именованными стилями печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Управление именованными стилями печати
Понятия
Процедуры
Команды

Создание именованного стиля печати

Копирование именованного стиля печати

Изменение пояснения к стилю печати

Переименование именованного стиля печати

Удаление именованного стиля печати


Создание именованного стиля печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Управление именованными стилями печати
Понятия
Процедуры
Команды

Создание именованного стиля печати

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке STB-файла таблицы стилей, в которую нужно добавить стиль печати.
  3. (Не обязательно) Если нужно задать расположение нового стиля в списке, то на вкладке "Карточка" указать стиль печати, который должен предшествовать новому стилю в списке.
  4. На вкладке "Карточка" или "Таблица" нажмите "Добавить стиль".
  5. В диалоговом окне "Добавление стиля печати" введите имя стиля печати.
  6. Нажмите кнопку "Принять & Закрыть".

    7. Примечание Стиль печати NORMAL нельзя ни модифицировать, ни удалить.

Ввод команды: ДИСПСТИЛЬ


Копирование именованного стиля печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Управление именованными стилями печати
Понятия
Процедуры
Команды

Копирование именованного стиля печати

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке STB-файла, который нужно отредактировать.
  3. На вкладке "Карточка" редактора таблиц стилей печати нажмите правую кнопку мыши на стиле печати, который необходимо скопировать. Выберите "Копировать".
  4. Нажмите правую кнопку мыши на стиле печати. Выберите "Вставить". Если нужно задать расположение нового стиля в списке, то нажмите правую кнопку мыши на имени стиля, который должен предшествовать новому стилю в списке.
  5. В диалоговом окне "Добавление стиля печати" введите имя стиля печати.
  6. Нажмите кнопку "Принять & Закрыть".

Примечание Если таблице стилей печати назначена таблица соответствия цветов, то копирование стилей этой таблицы невозможно. Нельзя также выполнять копирование и в таблицах цветозависимых стилей.

Ввод команды: ДИСПСТИЛЬ


Изменение пояснения к стилю печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Управление именованными стилями печати
Понятия
Процедуры
Команды

Изменение пояснения к стилю печати

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке файла таблицы, пояснения к стилям которой требуется изменить.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль печати, пояснение к которому необходимо изменить.
  4. В поле "Пояснение" введите необходимый текст.

    5. Можно выбрать несколько стилей печати и ввести для них пояснения или настроить их параметры.

  5. Нажмите кнопку "Принять & Закрыть".

Примечание Стиль печати NORMAL нельзя ни модифицировать, ни удалить.

Ввод команды: ДИСПСТИЛЬ


Переименование именованного стиля печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Управление именованными стилями печати
Понятия
Процедуры
Команды

Переименование именованного стиля печати

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке STB-файла, в котором необходимо переименовать стиль печати.
  3. На вкладке "Карточка" редактора таблиц стилей печати нажмите правую кнопку мыши на стиле печати, который необходимо переименовать. Выберите "Переименовать".
  4. Введите новое имя для выбранного стиля печати.
  5. Нажмите кнопку "Принять & Закрыть".

Примечание Стиль печати NORMAL переименовать нельзя. Нельзя также переименовывать цветозависимые стили печати.

Ввод команды: ДИСПСТИЛЬ


Удаление именованного стиля печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Управление именованными стилями печати
Понятия
Процедуры
Команды

Удаление именованного стиля печати

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке STB-файла, который нужно отредактировать.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль для его удаления из списка.
  4. Выберите "Удалить стиль".
  5. Нажмите кнопку "Принять & Закрыть".

Примечание Стиль печати NORMAL нельзя ни модифицировать, ни удалить. Если таблице стилей печати назначена таблица соответствия цветов, то удаление стилей из этой таблицы невозможно. Нельзя также удалять цветозависимые стили печати.

Ввод команды: ДИСПСТИЛЬ


Управление именованными стилями печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Управление именованными стилями печати
Понятия
Процедуры
Команды

Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
ПСТИЛЬ | Задание текущего стиля печати для новых объектов или назначение стиля печати выбранным объектам
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Стандартные таблицы именованных стилей печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Стандартные таблицы именованных стилей печати
Понятия
Процедуры
Команды

Помимо таблицы стилей по умолчанию имеется дополнительная таблица именованных стилей, которую можно использовать. Все файлы таблиц именованных стилей печати имеют расширение .stb.

  • acad.stb: Таблица стилей печати, используемая по умолчанию
  • Monochrome.stb: печатает все цвета черным
  • "Нет": ни одна таблица стилей печати не назначена

Примечание Таблицы именованных стилей доступны лишь в том случае, когда для чертежа установлено использование таблиц именованных стилей.

См. также

Подключение таблиц стилей печати к листам


Таблицы именованных стилей печати

Печать и публикация чертежей
Вывод чертежей на печать
Таблицы именованных стилей печати
Понятия
Процедуры
Команды

Нет процедур.


Стандартные таблицы именованных стилей печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Стандартные таблицы именованных стилей печати
Понятия
Процедуры
Команды

Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
ПСТИЛЬ | Задание текущего стиля печати для новых объектов или назначение стиля печати выбранным объектам
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Удаление таблиц соответствия цветов - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Удаление таблиц соответствия цветов
Понятия
Процедуры
Команды

Таблицы стилей печати, из которых удалена информация о соответствии цветов, не годятся для назначения стилей печати объектам старых чертежей.

У таблиц именованных стилей печати, созданных на основе файлов, CFG, PCP или PC2, имеются таблицы соответствия цветов, созданные с присвоением перьев из прежних версий. Для таких таблиц, помимо этого, имеются таблицы соответствия цветов. Таблицы соответствия цветов используются для связывания стилей печати с цветами (а через них - с объектами чертежа) при открытии чертежей, созданных в версиях программы, предшествующих AutoCAD 2000. Это позволяет выводить чертежи, построенные и предназначенные для вывода в прежних версиях.

Пока существует таблица соответствия цветов, добавление, удаление и переименование стилей печати в таблице невозможно.

Таблицы стилей печати, из которых удалена информация о соответствии цветов, не годятся для назначения стилей печати объектам старых чертежей. Тем не менее, остается возможность их использования во вновь создаваемых чертежах.

Предупреждение После удаления таблицы соответствия цветов автоматическое назначение стилей печати для объектов при первом открытии чертежей, созданных в более ранних версиях программы, невозможно.


Удаление таблицы соответствия цветов - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Удаление таблиц соответствия цветов
Понятия
Процедуры
Команды

Удаление таблицы соответствия цветов

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Общие" редактора таблиц стилей печати нажмите "Удалить цветовую таблицу AutoCAD Release 14".
  4. Прочтите предупреждающее сообщение. Нажмите "Да" для удаления таблицы соответствия цветов или "Нет" для отмены удаления.
  5. Нажмите кнопку "Принять & Закрыть".

Ввод команды: ДИСПСТИЛЬ


Удаление таблиц соответствия цветов - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Удаление таблиц соответствия цветов
Понятия
Процедуры
Команды

Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование стилей печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Редактирование стилей печати
Понятия
Процедуры
Команды

В стили печати можно вносить изменения с помощью редактора таблиц стилей печати. Все модификации стиля отражаются на объектах, использующих этот стиль.

  • Коротко о параметрах стилей печати
    Редактор таблиц стилей печати можно вызвать двойным нажатием кнопки мыши на ярлыке CTB- или STB-файла в Диспетчере стилей печати. В окне редактора таблиц стилей печати отображаются параметры всех стилей, входящих в выбранную таблицу.
  • Цвет, интенсивность, оттенки серого и размывание
    С помощью стиля печати можно задавать свойства, определяющие цвет, интенсивность, режимы размывания и преобразования в оттенки серого.
  • Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
    Присвоения перьев, используемые плоттером, могут изменяться в зависимости от того, является ли устройство печати перьевым плоттером или каким-то другим типом устройства, например, лазерным принтером.
  • Задание веса и типа линий
    Вес и тип линий могут определяться в свойствах объекта или в стиле печати при выводе на печать. Во время печати параметры веса и типа линий, заданные в стиле печати, переопределяют аналогичные свойства объекта.
  • Задание стилей окончаний и соединений линий
    Стили окончаний и соединений линий можно задавать в свойствах объекта или переопределять с помощью стиля печати.
  • Задание стиля закрашивания
    Для печати широких полилиний, колец, раскрашенных объектов и тел предлагаются различные стили закрашивания.


Редактирование стилей печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Редактирование стилей печати
Понятия
Процедуры
Команды

Изменение параметров стиля печати

Задание цвета в стиле печати

Назначение интенсивности

Включение/отключение размывания

Включение/отключение преобразования цветов в оттенки серого

Задание номера виртуального пера

Задание веса линий в стиле печати

Задание типа линий в стиле печати

Масштабирование типов линий и образцов закрашивания, не относящихся к стандарту ISO

Задание стиля окончаний или соединений линий

Задание стиля закрашивания


Редактирование стилей печати - Команды

Печать и публикация чертежей
Вывод чертежей на печать
Редактирование стилей печати
Понятия
Процедуры
Команды
Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о параметрах стилей печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Коротко о параметрах стилей печати
Понятия
Процедуры
Команды

Редактор таблиц стилей печати можно вызвать двойным нажатием кнопки мыши на ярлыке CTB- или STB-файла в Диспетчере стилей печати. В окне редактора таблиц стилей печати отображаются параметры всех стилей, входящих в выбранную таблицу.

Вкладка "Общие" предоставляет базовые сведения о таблице стилей. Вкладки "Таблица" и "Карточка" обеспечивают два способа доступа к свойствам стилей печати. Как правило, если количество стилей печати невелико, удобнее пользоваться вкладкой "Таблица". Если же в таблице определено много стилей печати, более предпочтительной становится вкладка "Карточка".

В таблице именованных стилей стиль NORMAL содержит свойства объекта, принятые по умолчанию (без применения стиля печати). Стиль NORMAL изменить или удалить невозможно.


Изменение параметров стиля печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Коротко о параметрах стилей печати
Понятия
Процедуры
Команды

Изменение параметров стиля печати

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати из списка "Стили" выберите стиль печати для редактирования.
  4. В группе "Свойства" нажмите стрелку рядом с тем свойством, значение которого необходимо изменить. Выберите параметр из списка.
  5. Если необходимо, повторите операцию редактирования для других свойств.
  6. Нажмите кнопку "Принять & Закрыть".

Ввод команды: ДИСПСТИЛЬ


Коротко о параметрах стилей печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Коротко о параметрах стилей печати
Понятия
Процедуры
Команды

Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Цвет, интенсивность, оттенки серого и размывание - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Цвет, интенсивность, оттенки серого и размывание
Понятия
Процедуры
Команды

С помощью стиля печати можно задавать свойства, определяющие цвет, интенсивность, режимы размывания и преобразования в оттенки серого.

Задание цвета в стиле печати

По умолчанию в стиле печати установлено значение цвета "Взять из объекта". Это значение позволяет сохранять цвет объекта, установленный в свойствах слоя или самого объекта. Если задать цвет явно, при печати объекты будут перекрашены в этот цвет. Можно выбрать один из 255 цветов ACI, из всей палитры цветов или воспользоваться альбомами цветов. Для использования всей палитры цветов плоттер должен быть настроен для работы в режиме True Color.

Примечание При использовании таблицы стилей печати, созданной в AutoCAD 2000 или более поздней версии, цвета из полной палитры заменяются наиболее близкими цветами из палитры текущей версии.

Задание интенсивности вывода

Можно выбрать значение интенсивности цвета, которое определяет количество краски, попадающее на бумагу при печати. Допустимый диапазон значений - от 0 до 100. Значение 0 соответствует выводу белым цветом, а значение 100 - полной интенсивности. Параметр интенсивности работает только на плоттерах, работающих с цветом или оттенками серого. Для использования этого параметра необходимо также включить режим размывания.

Включение размывания

Размывание используется в плоттерах для имитации составных цветов путем пространственного комбинирования точек, имеющих стандартные цвета (т.е. цвета чернил картриджей). Если плоттер не поддерживает размывание, параметр игнорируется.

Иногда отключение размывания позволяет избежать преобразования тонких векторов в псевдоштриховые линии, а также делает более наглядными цвета тусклых оттенков. Если размывание отключено, устанавливается соответствие цвета с ближайшим стандартным; это ограничивает цветовую гамму чертежа. Размывание при печати возможно независимо от того, как задан цвет в стиле печати (цвет объекта или явное присвоение).

Примечание Включение размывания может приводить к визуальному слиянию близко расположенных элементов.

Печатать с оттенками серого

Если выбран параметр "Печатать с оттенками серого", цвета объекта преобразуются в оттенки серого, если плоттер поддерживает печать с оттенками серого. Светлые цвета, такие как желтый, печатаются светлыми оттенками серого, а темные цвета - темными оттенками серого. Если параметр "Печатать с оттенками серого" отключен, для печати цветов объекта используются значения RGB. Преобразование в оттенки серого при печати возможно независимо от того, как задан цвет в стиле печати (цвет объекта или явное присвоение).


Цвет, интенсивность, оттенки серого и размывание - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Цвет, интенсивность, оттенки серого и размывание
Понятия
Процедуры
Команды

Задание цвета в стиле печати

Назначение интенсивности

Включение/отключение размывания

Включение/отключение преобразования цветов в оттенки серого


Задание цвета в стиле печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Цвет, интенсивность, оттенки серого и размывание
Понятия
Процедуры
Команды

Задание цвета в стиле печати

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Нажмите правую кнопку мыши на файле CTB или STB и выберите в контекстном меню "Открыть".
  3. На вкладке "Таблица" редактора таблиц стилей печати выберите поле "Цвет" стиля печати, в который требуется внести изменения.
  4. Из выпадающего списка цветов выберите нужный цвет или опцию "Выбор цвета", открывающую одноименное диалоговое окно, и выполните одну из следующих операций:
    • На вкладке "Номер цвета" выберите цвет или ввести в поле "Цвет" его имя или числовое значение в системе ACI (от 1 до 255). Нажмите "ОК".
    • На вкладке "Вся палитра" в поле "Цветовая модель" укажите цвет (введите его значение в поле "Цвет" или введите значения оттенка, насыщенности и яркости в соответствующие поля). Нажмите "OK".
    • На вкладке "Альбомы цветов" выберите цвет в группе "Альбом цветов" (воспользуйтесь стрелками перемещения вверх и вниз и выберите цветовую метку). Нажмите "ОК".

Ввод команды: ДИСПСТИЛЬ


Назначение интенсивности - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Цвет, интенсивность, оттенки серого и размывание
Понятия
Процедуры
Команды

Назначение интенсивности

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" Редактора таблиц стилей печати выберите стиль для редактирования.
  4. В поле параметра "Интенсивность" укажите значение от 1 до 100.
  5. По завершении нажмите кнопку "Принять & Закрыть".

    6. Редактор таблиц стилей печати позволяет одновременно изменять параметры для нескольких стилей.

    Примечание Как правило, при использовании параметра интенсивности цвет каждого стиля устанавливают в черный. Таким образом, значение интенсивности задает насыщенность черного цвета.

Ввод команды: ДИСПСТИЛЬ


Включение/отключение размывания - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Цвет, интенсивность, оттенки серого и размывание
Понятия
Процедуры
Команды

Включение/отключение размывания

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль и нажмите кнопку мыши на поле параметра "Разрешить размывание".
  4. Выберите значение "Вкл" или "Откл".
  5. По завершении нажмите кнопку "Принять & Закрыть".

    6. Редактор таблиц стилей печати позволяет одновременно изменять параметры для нескольких стилей.

Ввод команды: ДИСПСТИЛЬ


Включение/отключение преобразования цветов в оттенки серого - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Цвет, интенсивность, оттенки серого и размывание
Понятия
Процедуры
Команды

Включение/отключение преобразования цветов в оттенки серого

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль и нажмите кнопку мыши на поле параметра "Печатать с оттенками серого".
  4. Выберите значение "Вкл" или "Откл".
  5. По завершении нажмите кнопку "Принять & Закрыть".

    6. Редактор таблиц стилей печати позволяет одновременно изменять параметры для нескольких стилей.

Ввод команды: ДИСПСТИЛЬ


Цвет, интенсивность, оттенки серого и размывание - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Цвет, интенсивность, оттенки серого и размывание
Понятия
Процедуры
Команды

Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Назначение номеров перьев и виртуальных перьев в таблицах стилей печати - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
Понятия
Процедуры
Команды

Присвоения перьев, используемые плоттером, могут изменяться в зависимости от того, является ли устройство печати перьевым плоттером или каким-то другим типом устройства, например, лазерным принтером.

Задание перьев для стилей печати

Для задания перьев, используемых каждым стилем печати, служит параметр "Номер назначенного пера" в стиле печати. Физические перья плоттера задаются в PC3-файле конфигурации плоттера. При использовании перьевого плоттера необходимо указать значения цветов, скоростей и толщин всех перьев в разделе "Параметры физических перьев" редактора параметров плоттера.

Рассмотрим пример. Пусть в редакторе параметров плоттера задано, что перо номер 1 чертит черным цветом и обладает толщиной 0,25 мм, а перо номер 2 имеет красный цвет и толщину 0,5 мм. В Редакторе таблиц стилей печати можно назначить перу №1 стиль печати под названием "Водопроводные трубы", а перу №2 - стиль печати "Канализационные трубы".

Номер назначаемого пера в поле "Номер назначенного пера" может указываться в диапазоне от 1 до 32. По умолчанию используется значение 1. Изменение номера пера невозможно в том случае, если для цвета в стиле печати установлено значение "Взять из объекта", а также при редактировании стиля печати в таблице цветозависимых стилей печати.

Если занести в поле значение 0, программа изменяет его на "Авто". Сведения, указанные в поле "Параметры физических перьев" редактора параметров плоттера, используются для выбора пера, ближайшего по цвету к печатаемому объекту.

Эмуляция перьев для неперьевых плоттеров

Многие неперьевые плоттеры способны работать в режиме эмуляции перьевых, оперируя понятием виртуального пера. Эмуляция перьев для таких устройств выполняется программно или при помощи панели управления плоттера.

Если установлен режим программного управления перьями устройства, то параметры веса и типа линий, интенсивности, стилей окончаний и соединений линий, а также стиля закрашивания, задаваемые в таблице стилей печати, отражаются на работе плоттера, переопределяя установки панели устройства печати.

Если программное управление отключено (как правило, используется аппаратное управление), то программно можно задавать только номера виртуальных перьев без установки цвета, весов и типов линий, стилей окончаний, соединений и закрашивания. В программе аппаратное управления (виртуальное перо) включается вместо программного (нормального) управления после выбора параметра "255 виртуальных перьев" в области "Глубина цветности" параметра "Векторная графика" на вкладке "Устройство и документ" редактора параметров плоттера. Выбор любой другой глубины цветности включает программное управление.

В редакторе таблиц стилей печати значение параметра "Номер виртуального пера" может устанавливаться в диапазоне от 1 до 255. Введите 0 или Авто для указания на то, что назначение виртуальных перьев необходимо производить с использованием ACI.

При создании таблицы стилей печати необходимо иметь в виду, что таблица может использоваться различными плоттерами, и для разных плоттеров и режимов печати могут выбираться разные части одной таблицы стилей.

  • Если используется перьевой плоттер с пользовательскими установками перьев, то номера виртуальных перьев и назначения цветов игнорируются.
  • Если используется перьевой плоттер с автоматическим назначением перьев, то выбор перьев осуществляется с учетом цвета и веса линий. В этом случае номера виртуальных перьев также игнорируются.
  • Если используется растровый плоттер в растровом режиме, то игнорируются номера как физических, так и виртуальных перьев.
  • Если используется растровый плоттер в режиме работы с виртуальными перьями, то игнорируются все параметры перьев, кроме назначенных номеров виртуальных перьев.

Примечание Если для работы с созданными файлами печати используется другое приложение и пользователь изменяет атрибуты перьев, печать без применения виртуальных перьев приводит к отсутствию прямой связи номеров перьев в файле печати с цветами объекта в программе. Это затрудняет использование дополнительных атрибутов перьев.


Задание номера виртуального пера - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
Понятия
Процедуры
Команды

Задание номера виртуального пера

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль печати, который необходимо изменить, и нажмите поле "Номер виртуального пера".
  4. В поле "Номер виртуального пера" ввести число от 1 до 255, или же 0 или Авто для автоматического назначения цвета ACI печатаемого объекта для виртуального пера.
  5. По завершении нажмите кнопку "Принять & Закрыть".

    6. Редактор таблиц стилей печати позволяет одновременно изменять параметры для нескольких стилей.

Ввод команды: ДИСПСТИЛЬ


Назначение номеров перьев и виртуальных перьев в таблицах стилей печати - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
Понятия
Процедуры
Команды

Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание веса и типа линий - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Задание веса и типа линий
Понятия
Процедуры
Команды

Вес и тип линий могут определяться в свойствах объекта или в стиле печати при выводе на печать. Во время печати параметры веса и типа линий, заданные в стиле печати, переопределяют аналогичные свойства объекта.

Задание и отображение весов линий

При выборе свойства "Вес линий" в редакторе таблиц стилей печати отображается образец толщины линии и его цифровое значение. По умолчанию в стиле печати установлено значение веса линии "Взять из объекта". Если нужного веса линий нет в списке, его можно получить модификацией одного из существующих.

Для просмотра листа с результатами применения весов линий необходимо в диалоговом окне "Параметры листа" в группе "Таблица стилей печати" установите флажок "Показать стили печати".

Задание типов линий

При выборе свойства "Тип линий" в редакторе таблиц стилей печати отображается список с описаниями и образцами всех доступных типов линий. По умолчанию в стиле печати установлено значение типа линии "Взять из объекта".

Независимо от того, как задан тип линии в стиле печати (тип линии объекта или явное присвоение), пользователь может включать параметр "Подстройка масштаба". Этот параметр регулирует масштаб типа линий так, чтобы в каждом объекте укладывалось целое число элементарных образцов. Если он отключен, элементарные образцы могут обрываться в линиях на середине. Параметр необходимо отключать, если приоритет имеет соблюдение точного масштаба. Включение параметра означает, что масштабы типов линий будут разными, но за счет этого будет достигнута корректность отображения объектов, выполненных штриховыми и пунктирными линиями.

Пользователь может применить глобальный масштабный коэффициент к типам линий и образцам закрашивания, не относящимся к стандарту ISO.

См. также

Работа с типами линий

Работа с весами линий


Задание веса и типа линий - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание веса и типа линий
Понятия
Процедуры
Команды

Задание веса линий в стиле печати

Задание типа линий в стиле печати

Масштабирование типов линий и образцов закрашивания, не относящихся к стандарту ISO


Задание веса линий в стиле печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание веса и типа линий
Понятия
Процедуры
Команды

Задание веса линий в стиле печати

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль для редактирования.
  4. Раскройте список параметра "Вес линий" и выберите необходимое значение. Чтобы указать необходимость использования веса линий объекта, следует выбрать параметр "Взять из объекта".
  5. Нажмите кнопку "Принять & Закрыть".

    6. Редактор таблиц стилей печати позволяет одновременно изменять параметры для нескольких стилей.

Ввод команды: ДИСПСТИЛЬ


Задание типа линий в стиле печати - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание веса и типа линий
Понятия
Процедуры
Команды

Задание типа линий в стиле печати

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль для редактирования.
  4. Раскройте список параметра "Тип линий" и выберите необходимое значение. Чтобы указать необходимость использования типа линий объекта, следует выбрать параметр "Взять из объекта".
  5. Для регулирования масштаба типа линий таким образом, чтобы в каждом объекте укладывалось целое число элементарных образцов, на вкладке "Карточка" для параметра "Подстройка масштаба" установите значение "Вкл".
  6. Нажмите кнопку "Принять & Закрыть".

    7. Редактор таблиц стилей печати позволяет одновременно изменять параметры для нескольких стилей.

Ввод команды: ДИСПСТИЛЬ


Масштабирование типов линий и образцов закрашивания, не относящихся к стандарту ISO - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание веса и типа линий
Понятия
Процедуры
Команды

Масштабирование типов линий и образцов закрашивания, не относящихся к стандарту ISO

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Общие" Редактора таблиц стилей печати установите флажок "Применить глобальный масштаб к типам линий, не относящимся к ISO".

    4. Эта опция позволяет выполнять масштабирование типов линий и образцов закрашивания с учетом заданного значения масштаба.

  4. Введите значение масштаба в поле "Масштаб".
  5. Нажмите кнопку "Принять & Закрыть".

Ввод команды: ДИСПСТИЛЬ


Задание веса и типа линий - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Задание веса и типа линий
Понятия
Процедуры
Команды

Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание стилей окончаний и соединений линий - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Задание стилей окончаний и соединений линий
Понятия
Процедуры
Команды

Стили окончаний и соединений линий можно задавать в свойствах объекта или переопределять с помощью стиля печати.

Задание стиля окончаний линий

Программа поддерживает следующие стили окончаний линий:

  • срез
  • квадрат
  • полукруг
  • треугольник

По умолчанию устанавливается значение "Взять из объекта", при котором используется полукруглый стиль окончания. При печати стиль окончания, установленный в стиле печати, переопределяет стиль, заданный в свойствах объекта.

Примечание Тексты, набранные SHX-шрифтом, лучше печатать, используя полукруглые окончания и дуговые соединения линий.

Задание стиля соединений линий

Программа поддерживает следующие стили соединений линий:

  • угол
  • скос
  • дуга
  • треугольник

По умолчанию устанавливается значение "Взять из объекта", при котором используется стиль соединения "Дуга". При печати стиль соединений, установленный в стиле печати, переопределяет стиль, заданный в свойствах объекта.


Задание стиля окончаний или соединений линий - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание стилей окончаний и соединений линий
Понятия
Процедуры
Команды

Задание стиля окончаний или соединений линий

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Нажмите правую кнопку мыши на файле CTB или STB и выберите в контекстном меню "Открыть".
  3. На вкладке "Таблица" редактора таблиц стилей печати выберите поле "Стиль окончаний линий" или "Стиль соединений линий" для стиля печати, в который требуется внести изменения.
  4. Выберите нужную опцию из выпадающего списка.

Ввод команды: ДИСПСТИЛЬ


Задание стилей окончаний и соединений линий - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Задание стилей окончаний и соединений линий
Понятия
Процедуры
Команды

Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание стиля закрашивания - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Задание стиля закрашивания
Понятия
Процедуры
Команды

Программа поддерживает следующие стили закрашивания для печати широких полилиний, колец, объектов со сплошной закраской и тел:

  • сплошное
  • решетка
  • штриховка
  • шахматы
  • горизонтальные полосы
  • наклонные влево
  • наклонные вправо
  • квадраты
  • точки
  • вертикальные полосы

По умолчанию в стиле печати установлено значение стиля закрашивания "Взять из объекта". При печати стиль закрашивания, установленный в стиле печати, переопределяет стиль, заданный в свойствах объекта.

Пользователь может применить в стилях печати глобальный масштабный коэффициент к типам линий и образцам закрашивания, не относящимся к стандарту ISO.

См. также

Выбор образцов штриховки и сплошной заливки


Задание стиля закрашивания - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Задание стиля закрашивания
Понятия
Процедуры
Команды

Задание стиля закрашивания

  1. Нажмите "Файл" » "Диспетчер стилей печати".
  2. Нажмите правую кнопку мыши на файле CTB или STB и выберите в контекстном меню "Открыть".
  3. На вкладке "Таблица" редактора таблиц стилей печати выберите поле "Стиль закрашивания" стиля печати, в который требуется внести изменения.
  4. Выберите стиль закрашивания из выпадающего списка.

Ввод команды: ДИСПСТИЛЬ


Задание стиля закрашивания - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Задание стиля закрашивания
Понятия
Процедуры
Команды

Команды
ДИСПСТИЛЬ | Вызов диспетчера стилей печати
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Предварительный просмотр - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Предварительный просмотр
Понятия
Процедуры
Команды

Прежде чем выводить чертеж на печать, рекомендуется выполнять предварительный просмотр чертежа. Это позволит сократить затраты времени и расходных материалов, необходимых для выполнения печати.

Для предварительного просмотра можно создать изображение всего чертежа с помощью диалогового окна "Печать". На таком изображении виден результат печати чертежа с учетом весов линий, образцов штриховок и других параметров стилей печати.

При предварительном просмотре активные панели и инструментальные палитры исчезают с экрана, а вместо них отображается панель "Предварительный просмотр", обеспечивающая доступ к функциям печати, панорамирования и увеличения чертежа.

В диалоговых окнах "Печать" и "Параметры листа" также содержится простой образец для просмотра, отображающий печатаемую область и положение чертежа при печати.


Предварительный просмотр - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Предварительный просмотр
Понятия
Процедуры
Команды

Предварительный просмотр

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" нажмите кнопку "Просмотр".

    3. Открывается окно просмотра, курсор в котором приобретает форму, аналогичную курсору зумирования.

  3. Нажмите правую кнопку мыши для вызова контекстного меню со следующими параметрами: "Печать", "Панорамирование", "Зумирование", "Показать рамкой" или "Исходный вид" (для возврата к исходному коэффициенту экранного увеличения).
  4. Нажмите ESC для закрытия окна просмотра и возврата в диалоговое окно "Печать".
  5. Если необходимо, перенастройте параметры печати и снова просмотрите чертеж.
  6. После завершения корректировки параметров нажмите "ОК" для печати чертежа.

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Предварительный просмотр - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Предварительный просмотр
Понятия
Процедуры
Команды

Команды
ПАН | Перемещение изображения на текущем видовом экране
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПОКАЗАТЬ | Увеличение или уменьшение видимого размера объектов на текущем видовом экране
ПРЕДВАР | Предварительный просмотр на экране выводимого на печать листа
Системные переменные
RASTERPREVIEW | Управляет сохранением вместе с чертежом образцов для просмотра в формате BMP
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Печать в файлы различных форматов - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Печать в файлы различных форматов
Понятия
Процедуры
Команды

Имеется возможность экспорта или(посредством процедур печати) чертежей в файлы различных форматов, включая форматы DWF, DXF, PDF и WMF (метафайлы Windows). Вывод чертежей в файлы можно выполнять с помощью специальных драйверов печати.

Все перечисленные варианты предусматривают настройку драйвера несистемного плоттера для вывода чертежей в файлы. Пользовательские параметры несистемных драйверов можно настраивать с помощью редактора параметров плоттера. Справочные сведения по каждому драйверу можно получить, нажав кнопку "Справка" в окне настройки его дополнительных свойств (доступно из редактора параметров плоттера).

  • Печать в DWF-файлы
    Чертеж можно вывести в файл формата DWF™ (Design Web Format™), представляющий собой плотно упакованный набор двумерных векторов. DWF-файлы активно используются для обмена чертежами через Интернет и корпоративные сети.
  • Печать в DXB-файлы
    Формат DXB (файлы обмена двоичными графическими данными) поддерживается несистемным драйвером вывода в DXB. Он используется обычно для преобразования трехмерных чертежей в двумерные.
  • Печать в файлы растровых форматов
    Несистемным драйвером растровой печати поддерживается несколько форматов, включая Windows BMP, CALS, TIFF, PNG, TGA, PCX и JPEG. Растровые форматы часто используются для создания файлов публикаций рабочего стола.
  • Печать в файлы Adobe PDF
    С помощью драйвера для преобразования формата DWG в PDF можно создавать файлы формата PDF (Adobe® Portable Document Format) на основе чертежей .
  • Печать в файлы Adobe PostScript
    Использование драйвера Adobe PostScript позволяет в файлах чертежей формата DWG использовать элементы постраничной верстки и средства для просмотра. Примером может служить формат Adobe Acrobat Portable Document Format (PDF).
  • Создание файлов вывода на печать
    Используя любую конфигурацию плоттера, можно создавать файлы вывода на печать, которые в дальнейшем могут обрабатываться приложениями для вывода данных.

См. также

Публикация чертежей


Печать в файлы различных форматов - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Печать в файлы различных форматов
Понятия
Процедуры
Команды

Печать в файлы DWF

Создание файла DXB

Создание файла растрового формата

Печать файла PDF

Печать файла PDF в альбомной ориентации

Печать в файл PostScript

Создание файла вывода на печать


Печать в файлы различных форматов - Команды

Печать и публикация чертежей
Вывод чертежей на печать
Печать в файлы различных форматов
Понятия
Процедуры
Команды
Команды
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ЭКСПОРТБМП | Сохранение выбранных объектов в файле аппаратно-независимого растрового формата (BMP)
ЭКСПОРТДЖ | Сохраняет выбранные объекты в файл в формате JPEG
ЭКСПОРТПНГ | Сохраняет выбранные объекты в файл в формате Portable Network Graphics
ЭКСПОРТТИФ | Сохранение выбранных объектов в файл формата TIFF
Системные переменные
RASTERDPI | Управляет размером листа и масштабом печати при переключении с устройств вывода размерных файловых форматов на устройства вывода безразмерных файловых форматов и наоборот
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Печать в DWF-файлы - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Печать в DWF-файлы
Понятия
Процедуры
Команды

Программу можно использовать для создания файлов Design Web Format (DWF). Файл DWF - это файл двумерных векторов, который можно использовать для публикации чертежа в Интернете или во внутренней сети. Каждый DWF файл может содержать один или несколько листов чертежа.

Файлы DWF можно открыть, просмотреть и распечатать, воспользовавшись программой Autodesk® Design Review или программой Autodesk® DWF™ Viewer. С помощью приложений Autodesk Design Review или Autodesk DWF Viewer файлы DWF можно также просматривать в Microsoft® Internet Explorer 5.01 или более поздней версии. DWF-файлы поддерживают функции зумирования и панорамирования в реальном времени, а также функции управления отображением слоев и именованных видов.

См. также

Публикация чертежей


Печать в файлы DWF - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Печать в DWF-файлы
Понятия
Процедуры
Команды

Печать в файлы DWF

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Принтер/Плоттер" в поле "Имя" выберите из списка драйвер DWF6 ePlot.pc3.
  3. Если необходимо, настройте параметры печати в DWF-файл.
  4. Нажмите "ОК".
  5. В диалоговом окне "Поиск файла чертежа" задайте путь к файлу и введите имя DWF-файла.
  6. Нажмите кнопку "Сохранить".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Печать в DWF-файлы - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Печать в DWF-файлы
Понятия
Процедуры
Команды

Команды
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Печать в DXB-файлы - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Печать в DXB-файлы
Понятия
Процедуры
Команды

Формат DXB (файлы обмена двоичными графическими данными) поддерживается несистемным драйвером вывода в DXB. Он используется обычно для преобразования трехмерных чертежей в двумерные.

Формат вывода совместим с командой ИМПОРТД и драйвером ADI DXB, поставлявшимся с более ранними версиями. Данный DXB-драйвер имеет те же ограничения, что и драйвер ADI:

  • Все графические данные в DXB-файле представляются только в виде векторов, задаваемых 16-битовыми целыми числами.
  • Графика в файле формата DXB является монохромной, всем векторным данным присваивается цвет номер 7.
  • Растровые изображения и внедренные OLE-объекты не поддерживаются.
  • Не учитываются веса линий, заданные в свойствах объектов и в стилях печати.

См. также

Настройка вывода в файл в документе Руководство по периферийным устройствам


Создание файла DXB - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Печать в DXB-файлы
Понятия
Процедуры
Команды

Создание файла DXB

  1. Проверьте, установлен ли драйвер плоттера, сконфигурированный для вывода в DXB-файлы. (См. раздел Настройка вывода в файл в документе Руководство по периферийным устройствам.)
  2. Нажмите "Файл" » "Печать".
  3. В диалоговом окне "Печать" в группе "Принтер/Плоттер" в поле "Имя" выберите из списка драйвер вывода в формат DXB.
  4. Если необходимо, настройте параметры печати для вывода в DXB-файл.
  5. Нажмите "ОК".
  6. В диалоговом окне "Поиск файла чертежа" задайте путь к файлу и ввести имя DXB-файла.
  7. Нажмите кнопку "Сохранить".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Печать в DXB-файлы - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Печать в DXB-файлы
Понятия
Процедуры
Команды

Команды
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Печать в файлы растровых форматов - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Печать в файлы растровых форматов
Понятия
Процедуры
Команды

Несистемным драйвером растровой печати поддерживается несколько форматов, включая Windows BMP, CALS, TIFF, PNG, TGA, PCX и JPEG. Растровые форматы часто используются для создания файлов публикаций рабочего стола.

Все поддерживаемые драйвером форматы, кроме одного, создают “безразмерные” растровые файлы, которые не сохраняют сведения о размерах чертежа в миллиметрах или дюймах. Для растровых изображений известны лишь размеры в пикселах. Единственным форматом, сохраняющим размеры, является формат Dimensional СALS, который поддерживается некоторыми плоттерами. Если используемый плоттер принимает файлы в формате CALS, то необходимо задать реальные размеры листа и разрешение. Разрешение указывается в точках на дюйм в разделе структуры "Векторная графика" редактора параметров плоттера.

По умолчанию вывод для драйвера растровой печати направлен только в файл. Однако можно выбрать параметр "Показать все порты" на странице "Порты" Мастера установки плоттеров или на вкладке "Порты" окна Редактора параметров плоттера, после чего все имеющиеся на компьютере порты будут доступны для настройки. Если указать вывод на печать через один из портов, то драйвер будет выводить чертеж сначала в файл, а затем файл будет передаваться в назначенный порт. Для вывода чертежа на устройство необходимо убедиться в том, что оно подсоединено к указанному порту и способно принимать и обрабатывать посылаемые данные. Дополнительную информацию по данному вопросу можно найти в документации, прилагаемой к используемому устройству печати.

Тип, размер и глубина цветности растрового изображения определяют размер создаваемого растрового файла. В результате, файлы растровых изображений могут иметь очень большие размеры. В связи с этим, при выводе чертежа следует ограничиваться только теми размерами в точках и глубиной цветности, которые необходимы.

Для растровых чертежей можно задавать цвет фона с помощью диалогового окна дополнительных свойств, вызываемого из редактора параметров плоттера. Все объекты чертежа, цвет которых совпадает с цветом фона, на печати становятся невидимыми.

См. также

Настройка вывода в файл в документе Руководство по периферийным устройствам


Создание файла растрового формата - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Печать в файлы растровых форматов
Понятия
Процедуры
Команды

Создание файла растрового формата

  1. Удостоверьтесь в том, что драйвер плоттера подготовлен для вывода файла растрового формата. (См. раздел Настройка вывода в файл в Руководстве по периферийным устройствам.)
  2. Нажмите "Файл" » "Печать".
  3. В диалоговом окне "Печать" в группе "Принтер/Плоттер" в поле "Имя" выберите из списка драйвер вывода в растровый формат.
  4. Если необходимо, настройте параметры печати для вывода в файл растрового формата.
  5. Нажмите "ОК".
  6. В диалоговом окне "Поиск файла чертежа" задайте путь к файлу и введите имя растрового файла.
  7. Нажмите кнопку "Сохранить".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Печать в файлы растровых форматов - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Печать в файлы растровых форматов
Понятия
Процедуры
Команды

Команды
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ЭКСПОРТБМП | Сохранение выбранных объектов в файле аппаратно-независимого растрового формата (BMP)
ЭКСПОРТДЖ | Сохраняет выбранные объекты в файл в формате JPEG
ЭКСПОРТПНГ | Сохраняет выбранные объекты в файл в формате Portable Network Graphics
ЭКСПОРТТИФ | Сохранение выбранных объектов в файл формата TIFF
Системные переменные
RASTERDPI | Управляет размером листа и масштабом печати при переключении с устройств вывода размерных файловых форматов на устройства вывода безразмерных файловых форматов и наоборот
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Печать в файлы Adobe PDF - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Печать в файлы Adobe PDF
Понятия
Процедуры
Команды

С помощью драйвера для преобразования формата DWG в PDF можно создавать файлы формата PDF (Adobe® Portable Document Format) на основе чертежей .

Формат Adobe® Portable Document Format (PDF) является стандартом для обмена информацией в электронном виде. Файлы PDF легко распространяются для просмотра и печати в программе Adobe Reader, которую можно получить бесплатно на веб-сайте компании Adobe. Применяя файлы PDF, можно совместно использовать чертежи практически с любым пользователем.

Как и файлы DWF6, файлы PDF формируются, для сохранения точности, в формате с векторной основой. Чертежи, преобразованные в формат PDF, можно без труда распространять для просмотра и печати из приложения Adobe Reader 6-й версии или более поздней.

Для настройки параметров вывода следует воспользоваться диалоговым окном дополнительных свойств, который можно вызвать из редактора параметров плоттера. Для этого необходимо перейти на вкладку "Параметры устройства и документа" и в области структуры выбрать "Дополнительные свойства". Затем в группе "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".

Результирующий файл PDF можно настраивать, задавая разрешение. В диалоговом окне дополнительных свойств редактора параметров печатающего устройства можно задать разрешение для векторных и растровых изображений в диапазоне от 150 до 4800 точек на дюйм максимум. Можно также указать пользовательские разрешения для векторного, градиентного, цветного и черно-белого результирующего файла.

Примечание Хотя прозрачные объекты и удаленные объекты правильно отображаются в программе просмотра файлов PDF, они могут быть напечатаны не так точно, как при использовании параметров печати по умолчанию. Если в чертеже имеются прозрачные объекты, может потребоваться регулировка некоторых параметров в программе Adobe Acrobat. В программе Adobe Acrobat задайте для параметра "Выравнивание прозрачности" значение "Печатать как изображение" или уменьшите значение параметра "Баланс растровый/векторный". Дополнительные сведения см. в документации Adobe.

См. также

Настройка вывода в файл в документе Руководство по периферийным устройствам


Печать в файлы Adobe PDF - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Печать в файлы Adobe PDF
Понятия
Процедуры
Команды

Печать файла PDF

Печать файла PDF в альбомной ориентации


Печать файла PDF - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Печать в файлы Adobe PDF
Понятия
Процедуры
Команды

Печать файла PDF

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать", в группе "Принтер/плоттер" в поле "Имя" выберите из списка имен драйвер DWG to PDF.pc3.
  3. Если необходимо, настройте параметры печати для вывода в файл PDF.
  4. Нажмите "ОК".
  5. В диалоговом окне "Поиск файла чертежа" выберите местоположение или введите имя PDF-файла.
  6. Нажмите кнопку "Сохранить".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Печать файла PDF в альбомной ориентации - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Печать в файлы Adobe PDF
Понятия
Процедуры
Команды

Печать файла PDF в альбомной ориентации

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать", в группе "Принтер/плоттер" в поле "Имя" выберите из списка имен драйвер DWG to PDF.pc3.
  3. Из списка "Формат" выберите формат листа, больший размер которого указан первым. Например, ANSI A (11,00 x 8,50 дюймов)
  4. Нажмите "ОК".
  5. В диалоговом окне "Поиск файла чертежа" выберите местоположение или введите имя PDF-файла.
  6. Нажмите кнопку "Сохранить".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Печать в файлы Adobe PDF - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Печать в файлы Adobe PDF
Понятия
Процедуры
Команды

Команды
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Печать в файлы Adobe PostScript - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Печать в файлы Adobe PostScript
Понятия
Процедуры
Команды

Использование драйвера Adobe PostScript позволяет в файлах чертежей формата DWG использовать элементы постраничной верстки и средства для просмотра. Примером может служить формат Adobe Acrobat Portable Document Format (PDF).

Для вывода чертежей на принтеры, поддерживающие формат PostScript, или в PostScript-файлы можно использовать несистемный драйвер PostScript. Для вывода на принтеры следует указывать формат PS, а для вывода в файлы - EPS. При печати непосредственно на PostScript-устройство автоматически выбирается формат PS. Если же для вывода выбран файл, который затем планируется распечатывать на принтере, то пользователь должен сам установить формат PS.

Для настройки параметров вывода следует воспользоваться диалоговым окном дополнительных свойств, который можно вызвать из редактора параметров плоттера. Для этого необходимо перейти на вкладку "Параметры устройства и документа" и в области структуры выбрать "Дополнительные свойства". Затем в группе "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".

Драйвер поддерживает три разновидности формата PostScript.

  • Level 1: используется большинством плоттеров.
  • Level 1.5: используется для плоттеров с поддержкой цветной печати.
  • Level 2: если используемый плоттер поддерживает PostScript Level 2, то имеется возможность существенно уменьшить размер выходных файлов и увеличить скорость вывода на печать.

Опции "Использовать двоичный код (2-го уровня)" и "Сжатие растровых изображений" в диалоговом окне "Дополнительные свойства" позволяют уменьшить размер выходного файла и ускорить процесс печати на устройствах, поддерживающих эти функции. При возникновении проблем с печатью можно попытаться отключить все опции. В случае успеха выполненных действий можно повторно выполнять печать, каждый раз включая по одной опции, с тем, чтобы определить те опции, которые поддерживаются принтером.

Некоторые издательские системы поддерживают только PostScript Level 1. Поэтому, если возникают проблемы при работе с EPS-файлами, следует попытаться выбрать более простой тип PostScript и отключить параметры оптимизации формата, как это было описано выше.

Имеется возможность включения в EPS-файлы графических образцов изображений. Это значительно увеличивает размеры файлов, однако позволяет быстро просматривать эти файлы с помощью многих приложений. В Windows для предварительного просмотра используется формат WMF; для Macintosh и других платформ используется формат EPSF.

Примечание Включение образцов для предварительного просмотра в обоих форматах может привести к увеличению размера результирующего файла в три раза.

См. также

Экспорт файлов формата PostScript

Настройка вывода в файл в документе Руководство по периферийным устройствам


Печать в файл PostScript - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Печать в файлы Adobe PostScript
Понятия
Процедуры
Команды

Печать в файл PostScript

  1. Проверьте, установлен ли драйвер плоттера, сконфигурированный для вывода в файл формата PostScript. (См. раздел Настройка вывода в файл в документе Руководство по периферийным устройствам.)
  2. Нажмите "Файл" » "Печать".
  3. В диалоговом окне "Печать" в группе "Принтер/Плоттер" в поле "Имя" выберите из списка драйвер вывода в формат PostScript.
  4. Если необходимо, настройте параметры печати для вывода в PostScript-файл.
  5. Нажмите "ОК".
  6. В диалоговом окне "Поиск файла чертежа" задайте путь к файлу и введите имя PostScript-файла.
  7. Нажмите кнопку "Сохранить".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Печать в файлы Adobe PostScript - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Печать в файлы Adobe PostScript
Понятия
Процедуры
Команды

Команды
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание файлов вывода на печать - Понятия

Печать и публикация чертежей
Вывод чертежей на печать
Создание файлов вывода на печать
Понятия
Процедуры
Команды

Используя любую конфигурацию плоттера, можно создавать файлы вывода на печать, которые в дальнейшем могут обрабатываться приложениями для вывода данных.

Например, файлы форматов HP-GL и HP-GL/2 используются в качестве промежуточных файлов различными программными средствами разработки, а также для хранения данных и использования многими устройствами вывода.

Драйвер несистемного устройства HP-GL поддерживает формат HP-GL (Hewlett-Packard Graphics Language), широко используемый перьевыми плоттерами и сохраняющий только векторную графику. Растровые объекты драйвером устройства HP-GL не поддерживаются.

Драйвер несистемного устройства HP-GL/2 объединяет возможности перьевых плоттеров формата HP-GL/2 и струйных плоттеров. Этот драйвер является базовым и не оптимизирован для работы со специфическими устройствами. Например, он не посылает команд PJL устройству, как это делает драйвер фирмы Hewlett-Packard. Драйвер HP-GL/2 поддерживает устаревшие графопостроители и более новые устройства других производителей, не только фирмы Hewlett-Packard.

См. также

Информация о настройке конкретных моделей устройств в документе Руководство по периферийным устройствам


Создание файла вывода на печать - Процедуры

Печать и публикация чертежей
Вывод чертежей на печать
Создание файлов вывода на печать
Понятия
Процедуры
Команды

Создание файла вывода на печать

  1. Нажмите "Файл" » "Печать".
  2. В диалоговом окне "Печать" в группе "Принтер/Плоттер" в поле "Имя" выберите из списка драйвер вывода на плоттер.
  3. Если имеется такая возможность, установите флажок "Печать в файл".
  4. Если необходимо, настройте параметры печати для вывода в файл.
  5. Нажмите "ОК".
  6. В диалоговом окне "Поиск файла чертежа" задайте путь к файлу и введите имя файла чертежа.
  7. Нажмите кнопку "Сохранить".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Создание файлов вывода на печать - Команды

Вывод чертежей на печать
Вывод чертежей на печать
Создание файлов вывода на печать
Понятия
Процедуры
Команды

Команды
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Публикация чертежей - Понятия

Печать и публикация чертежей
Публикация чертежей
Понятия
Процедуры
Команды

Имеется возможность без труда опубликовать всю подшивку из Диспетчера подшивок как комплект чертежей на бумаге или как единый, содержащий много листов файл формата Design Web Format™ (DWF™).

  • Коротко о публикации
    С помощью диалогового окна "Публикация" можно на основе целого набора чертежей одним нажатием кнопки мыши получить в бумажном или электронном виде набор готовых чертежей.
  • Общие сведения о публикации
    Публикация предлагает удобный способ получения набора бумажных чертежей или их электронного аналога.
  • Создание и изменение набора чертежей для публикации
    Имеется возможность сформировать комплект листов чертежей для их публикации на плоттере, в файлах для вывода на печать или в файл формата Design Web Format™ (DWF™). Полученный набор чертежей можно сохранять и редактировать.
  • Вывод набора для публикации на плоттер или в файл печати
    Набор чертежей можно при публикации вывести на печатающее устройство или в файл печати.
  • Публикация электронного набора чертежей
    Для публикации набора чертежей в электронном виде используется формат DWF (Design Web Format).
  • Публикация подшивки
    С помощью Диспетчера подшивок можно опубликовать целую подшивку листов.
  • Повторная публикация набора чертежей
    Существует возможность повторной публикации листов чертежей, списки которых были ранее сохранены в формате описаний наборов чертежей (DSD).
  • Просмотр опубликованного электронного набора чертежей
    Для просмотра и печати опубликованного электронного набора чертежей может быть использована программа Autodesk™ DWF™ Viewer.
  • Настройка параметров публикации
    Можно настраивать такие параметры процесса публикации, как расположение выходного файла, тип DWF-файла, именование листов в многолистовом DWF, защита DWF-файла паролем и включение в него информации о слоях. Можно указать, какая информация будет содержаться в опубликованных файлах DWF.
  • Публикация 3D DWF
    Имеется возможность создания и публикации файлов DWF, содержащие трехмерные модели, и их просмотра с помощью приложения Autodesk® DWF™ Viewer.
  • Настройка драйвера DWF6
    Изменение настроек драйвера публикаций DWF6 ePlot требуется довольно редко. Но если это действительно нужно, то можно воспользоваться окном свойств этого драйвера для оптимизации вывода. Здесь можно настроить глубину цветности, экранное разрешение, сжатие файла, параметры обработки шрифтов, параметры перьев и другие опции. При создании DWF6-файлов используется файл параметров плоттера, определяющий некоторые особенности формата DWF6. Для печати в файлы формата DWF6 необходимо использовать DWF6 ePlot.pc3.


Публикация чертежей - Процедуры

Печать и публикация чертежей
Публикация чертежей
Понятия
Процедуры
Команды

Проверка статуса задания на публикацию, выполнявшегося в фоновом режиме

Отмена всех или части заданий на публикацию, выполняющихся в фоновом режиме

Просмотр подробных сведений о задании на публикацию

Включение/отключение фонового режима публикации

Создание набора чертежей для публикации

Добавление листов из чертежа в набор для публикации

Добавление листов из DSD-файла в набор для публикации

Исключение листа из набора для публикации

Исключение всех листов из набора для публикации

Изменение порядка следования листов в наборе для публикации

Копирование листов в наборе для публикации

Переименование листов в наборе для публикации

Изменение набора настроек листа в наборе для публикации

Изменение набора настроек одного или нескольких листов в наборе для публикации

Импорт набора параметров листов из другого чертежа для применения к публикуемому листу

Публикация нескольких листов чертежа

Вывод набора для публикации на плоттер или в файл печати

Создание электронного набора чертежей

Публикация подшивки в файл DWF

Печать подшивки в файл PDF

Публикация группы листов подшивки или отдельного листа в DWF-файл

Публикация листов подшивки на заданном в параметрах листов плоттере

Публикация листов подшивки с переопределением параметров листов

Добавление штемпеля на публикуемые листы подшивки

Задание параметров публикации подшивок

Открытие окна публикации из Диспетчера подшивок и модификация публикуемого набора листов

Повторная публикация набора чертежей

Просмотра последнего опубликованного DWF-файла в Autodesk DWF Viewer

Для изменения папки, в которой по умолчанию хранятся публикуемые файлы DWF и чертежи, выполните следующие действия.

Чтобы указать тип выходного файла DWF (однолистовые файлы или многолистовой файл DWF), выполните следующие действия.

Для задания имени многостраничных файлов DWF

Для установки режима запроса имени для многолистовых DWF-файлов

Установка режима защиты публикуемых DWF-файлов паролями

Добавление информации о слоях в публикуемый файл DWF

Включение сведений о блоках в публикуемый файл DWF

Включение сведений о шаблонах блоков в публикуемый файл DWF

Создание файла шаблона блока (BLK)

Редактирование файла шаблона блока (BLK)

Публикация одного 3D файла DWF

Экспорт в 3D файл DWF

Публикация нескольких файлов 3D DWF или сочетания файлов 2D и 3D DWF

Публикация в 3D файл DWF избранных объектов модели

Просмотр и печать опубликованного 3D файла DWF

Создание файла параметров плоттера для вывода в файл DWF

Задание или модификация параметров печати в файлы DWF

Задание глубины цветности при печати в файлы DWF

Задание экранного разрешения DWF-файлов

Задание сжатия DWF-файлов

Задание способа обработки шрифтов в файлах DWF

Редактирование списка шрифтов, доступных для включения в DWF-файл

Редактирование наборов перьев для вывода в DWF-файлы


Публикация чертежей - Команды

Печать и публикация чертежей
Публикация чертежей
Понятия
Процедуры
Команды
Команды
3DДВФ | Создает 3D DWF-файл пользовательской трехмерной модели и отображает ее в программе просмотра DWF
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПОДШИВКА | Вызов диспетчера подшивок
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
3DDWFPREC | Управляет точностью публикации 3D ДВФ
BACKGROUNDPLOT | Управление включением/отключением режима фонового вывода для операций печати и публикации
PUBLISHALLSHEETS | Управляет заполнением списка диалогового окна публикации при выдаче команды ПУБЛ
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о публикации - Понятия

Печать и публикация чертежей
Публикация чертежей
Коротко о публикации
Понятия
Процедуры
Команды

Наборы чертежей являются основным итогом работы большинства проектных коллективов. Создание набора чертежей с дальнейшим рассмотрением его в различных инстанциях может оказаться довольно долгим и сложным процессом.

С помощью диалогового окна "Публикация" можно на основе целого набора чертежей одним нажатием кнопки мыши получить в бумажном или электронном виде набор готовых чертежей.

Электронные наборы чертежей сохраняются как файлы формата Design Web Format™ (DWF™). Имеется возможность просматривать или выводить на печать файлы DWF с помощью распространяемого бесплатно приложения для просмотра файлов DWF - Autodesk® DWF™ Viewer.

Для печати отдельного чертежа используется диалоговое окно "Печать".

См. также

Коротко о процессе печати


Публикация чертежей

Печать и публикация чертежей
Публикация чертежей
Публикация чертежей
Понятия
Процедуры
Команды

Нет процедур.


Коротко о публикации - Команды

Публикация чертежей
Публикация чертежей
Коротко о публикации
Понятия
Процедуры
Команды

Команды
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Общие сведения о публикации - Понятия

Печать и публикация чертежей
Публикация чертежей
Общие сведения о публикации
Понятия
Процедуры
Команды

Публикация предлагает удобный способ получения набора бумажных чертежей или их электронного аналога. Электронный набор чертежей - это аналог набора чертежей, распечатанных на бумаге. Электронный набор чертежей можно получить, опубликовав чертежи в файле формата Design Web Format™ (DWF™).

С помощью Диспетчера подшивок можно опубликовать целую подшивку листов. Публикация в едином многолистовом файле формата DWF позволяет одним нажатием кнопки мыши создать готовый электронный набор чертежей.

Набор бумажных чертежей создается публикацией каждого листа подшивки на заданном в его параметрах плоттере.

С помощью диалогового окна "Публикация" можно не только собрать в одно целое набор различных чертежей для публикации, но и сохранить их перечень в файле описаний наборов чертежей формата DSD (Drawing Set Descriptions). Этот набор для публикации можно адаптировать под нужды конкретного пользователя, добавляя и удаляя листы по мере развития проекта. Созданный в диалоговом окне "Публикация" перечень листов можно опубликовать любым из следующих способов:

  • На плоттер, заданный в параметрах каждого листа подшивки (включая чертежи, которые необходимо вывести в файл).
  • В единый многолистовой файл формата DWF, содержащий как 2D, так и 3D объекты.
  • В несколько состоящих из одного листа файлов DWF, содержащих как 2D, так и 3D объекты.

Используя процедуру "3D публикация DWF", имеется возможность создания и публикации в файлы формата DWF трехмерных моделей и просмотра их в Autodesk DWF Viewer.

Подробнее о публикации файлов 3D DWF см. описание процедуры 3D публикация DWF.

Публикация электронного набора чертежей в виде DWF файла экономит время и увеличивает производительность, поскольку позволяет создавать точное и сжатое представление чертежей в удобном для просмотра и распространения файле. Она также позволяет обеспечивать целостность и взаимосвязь исходных чертежей.

При публикации в файлы DWF формируются файлы DWF6, которые создаются в формате на векторной основе (кроме вставленных растровых изображений), что гарантирует сохранение точности. Имеется возможность просматривать или выводить на печать файлы DWF с помощью распространяемого бесплатно приложения для просмотра файлов DWF - Autodesk® DWF™ Viewer. Файлы DWF можно передать по электронной почте, выложить на FTP-серверах и веб-узлах проектов или распространить на компакт-дисках.

Свойства и атрибуты, относящиеся к блоку, можно сделать доступными для других пользователей, использующих Autodesk DWF Viewer для просмотра или печати опубликованных файлов DWF. Например, можно опубликовать для водопроводного подрядчика файл DWF, содержащий информацию атрибутов блока чертежа о водопроводной арматуре. В такой же подшивке для подрядчика по электротехнике можно указать только данные атрибута блока об осветительной арматуре.

По умолчанию задания публикации выполняются в фоновом режиме, что позволяет пользователю сразу же вернуться к работе над своими чертежами. Задания публикации выполняются по очереди (не могут выполняться одновременно). Для проверки статуса задания, выполняющегося в фоновом режиме, достаточно навести курсор на значок плоттера в правом углу строки состояния. Можно также просмотреть подробные сведения обо всех заданиях, которые были опубликованы или напечатаны в ходе текущего сеанса.

См. также

Публикация, комплектование и архивация подшивок

Задание настроек параметров листа

Публикация 3D DWF


Общие сведения о публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Общие сведения о публикации
Понятия
Процедуры
Команды

Проверка статуса задания на публикацию, выполнявшегося в фоновом режиме

Отмена всех или части заданий на публикацию, выполняющихся в фоновом режиме

Просмотр подробных сведений о задании на публикацию

Включение/отключение фонового режима публикации


Проверка статуса задания на публикацию, выполнявшегося в фоновом режиме - Процедуры

Печать и публикация чертежей
Публикация чертежей
Общие сведения о публикации
Понятия
Процедуры
Команды

Проверка статуса задания на публикацию, выполнявшегося в фоновом режиме

  • Поместите курсор на значок плоттера в строке состояния. Всплывающая подсказка отображает статус задания.

Строка состояния


Отмена всех или части заданий на публикацию, выполняющихся в фоновом режиме - Процедуры

Печать и публикация чертежей
Публикация чертежей
Общие сведения о публикации
Понятия
Процедуры
Команды

Отмена всех или части заданий на публикацию, выполняющихся в фоновом режиме

  • Нажмите правую кнопку мыши на значке в строке состояния. Выберите "Отмена задания для листа" <имя листа> или "Прервать все задание".

Строка состояния


Просмотр подробных сведений о задании на публикацию - Процедуры

Печать и публикация чертежей
Публикация чертежей
Общие сведения о публикации
Понятия
Процедуры
Команды

Просмотр подробных сведений о задании на публикацию

  1. Выполните одно из следующих действий:
    • Нажмите "Файл" » "Подробности о печати/публикации".
    • В строке состояния нажмите левую кнопку мыши на значке плоттера.
  2. В диалоговом окне "Подробности о печати/публикации" просмотрите сведения о заданиях на публикацию.

Ввод команды: ПОДРОБНОСТИПП

Контекстное меню: Нажмите правую кнопку мыши на значке плоттера. Выберите "Подробности о печати/публикации".


Включение/отключение фонового режима публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Общие сведения о публикации
Понятия
Процедуры
Команды

Включение/отключение фонового режима публикации

  1. Нажмите "Сервис" » "Настройки".
  2. В диалоговом окне "Настройка" на вкладке "Печать/Публикация" в группе опций "Параметры фоновой обработки" установите или сбросьте для настройки "Поддержка фонового вывода" флажки "Печать" и "Публикация".
  3. Нажмите "ОК".

Ввод команды: НАСТРОЙКА


Общие сведения о публикации - Команды

Публикация чертежей
Публикация чертежей
Общие сведения о публикации
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
Системные переменные
BACKGROUNDPLOT | Управление включением/отключением режима фонового вывода для операций печати и публикации
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и изменение набора чертежей для публикации - Понятия

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Имеется возможность сформировать комплект листов чертежей для их публикации на плоттере, в файлах для вывода на печать или в файл формата DWF™. Набор для публикации можно адаптировать под нужды конкретного пользователя, добавляя, удаляя, меняя местами, копируя и переименовывая листы по мере развития проекта.

Набор чертежей можно вывести непосредственно на бумагу или в один или несколько DWF-файлов для дальнейшей пересылки по электронной почте, размещения на FTP-сайтах или web-сайтах проектов или распространения на компакт-дисках. Описание набора чертежей, собранных для публикации, можно сохранить в файле формата DSD (Drawing Set Descriptions).


Создание и изменение набора чертежей для публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Создание набора чертежей для публикации

Добавление листов из чертежа в набор для публикации

Добавление листов из DSD-файла в набор для публикации

Исключение листа из набора для публикации

Исключение всех листов из набора для публикации

Изменение порядка следования листов в наборе для публикации

Копирование листов в наборе для публикации

Переименование листов в наборе для публикации

Изменение набора настроек листа в наборе для публикации

Изменение набора настроек одного или нескольких листов в наборе для публикации

Импорт набора параметров листов из другого чертежа для применения к публикуемому листу

Публикация нескольких листов чертежа


Создание набора чертежей для публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Создание набора чертежей для публикации

  1. При открытом чертеже нажмите "Файл" » "Публикация".

    2. На экране появляется диалоговое окно "Публикация". Если задана настройка добавления разметок листов (в контекстном меню или в диалоговом окне "Публикация") в списке листов перечисляются все вкладки разметок листов из текущего чертежа.

  2. Для редактирования списка листов в диалоговом окне "Публикация" требуется выполнить одно из следующих действий:
    • Добавление листов. Для того чтобы добавить листы из других чертежей, нажмите кнопку "Добавить листы" (или перетащите чертежи с рабочего стола). В диалоговом окне "Выбор чертежей" выберите чертежи. Нажмите кнопку "Выберите", чтобы добавить их к списку листов диалогового окна "Публикация". Каждая разметка листа чертежа становится отдельным листом в списке диалогового окна. Отдельные листы, которые не требуется включать в набор чертежей, можно удалить. Публикация возможна только для инициализированных разметок листов (т.е. тех листов, в параметрах которых задан любой формат листа, отличный от 0 x 0).

    Примечание Для включения всех разметок при добавлении листов в набор чертежей следует задать опцию "Включать разметки при добавлении листов" в контекстном меню диалогового окна "Публикация".

    • Добавление разметок листов модели. Если включить неинициализированную разметку модели (формат листа для которой не задан или имеет размеры 0 x 0 ), она будет иметь статус "Лист не инициализирован" в поле "Статус" списка листов. Для вывода на печать такой вкладки следует выбрать в качестве переопределения набор параметров листа из раскрывающегося списка в столбце "Параметры листа" в списке листов диалогового окна "Публикация".

    Примечание Для включения модели при добавлении листов в набор чертежей следует задать опцию "Включать модель при добавлении листов" в контекстном меню диалогового окна "Публикация".

    • Исключение листов. Для исключения листов из списка выберите один или несколько листов. Нажмите кнопку "Исключить листы". Для исключения всех листов нажмите правую кнопку мыши. Выберите "Исключить все".
    • Изменение порядка листов. Для того чтобы переместить лист в списке на один уровень вверх или вниз, выберите лист. Нажмите кнопку "Сдвинуть лист вверх" или "Сдвинуть лист вниз". Просмотр и печать листов набора чертежей выполняется в том порядке, в котором они расположены в списке.
    • Переименование листов. Для изменения имени листа выберите его в списке и нажмите правую кнопку мыши. Выберите "Переименовать лист". Ввести новое имя листа.
    • Изменение набора параметров листа. Для изменения набора параметров для разметки выберите лист, в столбце "Параметры листа" из раскрывающегося списка выберите именованный набор параметров или же выберите один или несколько листов и нажмите правую кнопку мыши. Выберите "Изменить параметры листа". В списке "Параметры листа" выберите набор параметров или "Импорт" для импорта набора параметров из другого чертежа или шаблона. В диалоговом окне "Импорт наборов параметров листов" выберите чертеж, содержащий один или более наборов параметров листа. Нажмите "Импорт". В списке "Параметры листа" выберите требуемый набор параметров.

    Примечание Рекомендуется изменять параметры листа для каждой разметки листа в соответствии с желаемым видом на публикации. Наборы параметров листов пространства модели могут применяться только к листам пространства модели; наборы параметров пространства листов могут применяться только к листам пространства листов.

    • Копирование листов. Чтобы скопировать один или несколько листов чертежей, выберите листы из списка и нажмите правую кнопку мыши. Выберите "Копировать выбранные листы". Копии добавляются в конец списка и выделяются подсвечиванием. Имя копии создается путем добавления слова -Копия(n) к имени исходного листа. Например, при копировании листа под названием Водопровод его копия будет называться Водопровод-Копия(1). При каждом копировании одного и того же листа n увеличивается на 1. Создавая копии листа, можно применять к одному и тому же листу разные наборы параметров листа и другие настройки.
  3. Когда список листов чертежа будет скомпонован и настроен требуемым образом, нажмите кнопку "Сохранить список листов".
  4. Введите имя списка в поле "Имя файла" диалогового окна "Сохранение списка". Нажмите кнопку "Сохранить".

    5. Список сохраняется в DSD-файле (файле описания наборов чертежей).

Панель "Стандартная"

Ввод команды: ПУБЛ


Добавление листов из чертежа в набор для публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Добавление листов из чертежа в набор для публикации

  1. Нажмите "Файл" » "Публикация".
  2. В диалоговом окне "Публикация" нажмите кнопку "Добавить листы".
  3. В диалоговом окне "Выбор чертежей" выберите чертежи. Нажмите кнопку "Выбрать", чтобы добавить их к списку листов диалогового окна "Публикация".

    4. Примечание Можно также для добавления листов в список перетащить чертежи с рабочего стола в окно "Публикация".

    Все разметки листов чертежа становятся отдельными листами в списке диалогового окна.

    Листы, которые не требуется включать в набор, следует исключить из списка. Перед публикацией разметки листов необходимо инициализировать. (Разметка листа считается инициализированной, если в наборе параметров листа задан любой формат, кроме 0 x 0.)

Панель "Стандартная"

Ввод команды: ПУБЛ


Добавление листов из DSD-файла в набор для публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Добавление листов из DSD-файла в набор для публикации

  1. Нажмите "Файл" » "Публикация".
  2. В диалоговом окне "Публикация" нажмите кнопку "Загрузить список листов".
  3. В диалоговом окне "Загрузка списка листов" выберите файл DSD. Выберите "Загрузить".
  4. В диалоговом окне "Замена или добавление" нажмите кнопку "Заменить" для замены текущих листов в DSD-файле или нажмите "Добавить" для добавления листов из DSD-файла в список листов в диалоговом окне "Публикация".

Панель "Стандартная"

Ввод команды: ПУБЛ


Исключение листа из набора для публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Исключение листа из набора для публикации

  1. Нажмите "Файл" » "Публикация".
  2. Убедитесь, что листы, которые требуется исключить из набора, присутствуют в списке диалогового окна "Публикация".
  3. В списке "Листы" выберите один или несколько листов для исключения. Нажмите кнопку "Исключить листы".

Панель "Стандартная"

Ввод команды: ПУБЛ


Исключение всех листов из набора для публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Исключение всех листов из набора для публикации

  1. Нажмите "Файл" » "Публикация".
  2. Убедитесь, что листы, которые требуется исключить из набора, присутствуют в списке диалогового окна "Публикация".
  3. Нажмите правую кнопку мыши в списке листов. Выберите "Исключить все".

    4. Примечание Отменить операцию исключения всех листов нельзя.

Панель "Стандартная"

Ввод команды: ПУБЛ


Изменение порядка следования листов в наборе для публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Изменение порядка следования листов в наборе для публикации

  1. Нажмите "Файл" » "Публикация".
  2. Убедитесь, что листы, которые требуется поменять местами, присутствуют в списке диалогового окна "Публикация".
  3. Выберите лист. Нажмите кнопку "Сдвинуть лист вверх" или "Сдвинуть лист вниз".

    4. Примечание Просмотр и вывод на печать листов, входящих в набор для публикации, осуществляется в порядке следования листов в списке диалогового окна "Публикация".

Панель "Стандартная"

Ввод команды: ПУБЛ


Копирование листов в наборе для публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Копирование листов в наборе для публикации

  1. Нажмите "Файл" » "Публикация".
  2. Убедитесь, что листы, которые требуется скопировать, присутствуют в списке диалогового окна "Публикация".
  3. Выберите один или несколько листов из списка и нажмите правую кнопку мыши. Выберите "Копировать выбранные листы".

    4. Копии добавляются в конец списка и выделяются подсвечиванием. Имя копии создается путем добавления слова -Копия(n) к имени исходного листа. Например, при копировании листа под названием Водопровод его копия будет называться Водопровод-Копия(1). При каждом копировании одного и того же листа n увеличивается на 1. Создавая копии листа, можно применять к одному и тому же листу разные наборы параметров листа и другие настройки.

Панель "Стандартная"

Ввод команды: ПУБЛ


Переименование листов в наборе для публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Переименование листов в наборе для публикации

  1. Нажмите "Файл" » "Публикация".
  2. Убедитесь, что листы, которые требуется переименовать, присутствуют в списке диалогового окна "Публикация".
  3. Выберите лист из списка а затем выполнить одно из следующих действий:
    • Нажмите правую кнопку мыши. Выберите "Переименовать лист".
    • Нажмите F2.
  4. Введите новое имя листа.

Панель "Стандартная"

Ввод команды: ПУБЛ


Изменение набора настроек листа в наборе для публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Изменение набора настроек листа в наборе для публикации

  1. Нажмите "Файл" » "Публикация".
  2. Убедитесь, что лист, для которого требуется сменить набор параметров, присутствует в списке диалогового окна "Публикация".
  3. Выберите лист из списка.
  4. В столбце "Параметры листа" выберите набор параметров для применения к листу.

Панель "Стандартная"

Ввод команды: ПУБЛ


Изменение набора настроек одного или нескольких листов в наборе для публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Изменение набора настроек одного или нескольких листов в наборе для публикации

  1. Нажмите "Файл" » "Публикация".
  2. Убедитесь, что листы, для которых требуется сменить набор параметров, присутствуют в списке диалогового окна "Публикация".
  3. Выберите один или несколько листов из списка и нажмите правую кнопку мыши. Выберите "Изменение набора параметров листа".
  4. В столбце "Параметры листа" выберите набор параметров для применения к листам.

    5. Примечание Рекомендуется изменять параметры листа для каждой разметки листа в соответствии с желаемым видом на публикации. Для вкладки "Модель" можно применять только наборы параметров листа, созданные для пространства модели, а для разметок листов можно применять только наборы параметров, созданные для разметок.

Панель "Стандартная"

Ввод команды: ПУБЛ


Импорт набора параметров листов из другого чертежа для применения к публикуемому листу - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Импорт набора параметров листов из другого чертежа для применения к публикуемому листу

  1. Нажмите "Файл" » "Публикация".
  2. Убедитесь, что лист, для которого требуется сменить набор параметров, присутствуют в списке диалогового окна "Публикация".
  3. Выберите лист из списка.
  4. В столбце "Параметры листа" выберите из раскрывающегося списка "Импорт".
  5. В диалоговом окне "Импорт наборов параметров листов" выберите чертеж, из которого необходимо импортировать наборы параметров листов. Нажмите "Импорт".

Панель "Стандартная"

Ввод команды: ПУБЛ


Публикация нескольких листов чертежа - Процедуры

Печать и публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Публикация нескольких листов чертежа

  1. В области чертежа выберите вкладку разметки листа для публикации.
  2. Удерживая нажатой клавишу CTRL, указать мышью другие вкладки разметок листов, которые требуется опубликовать.
  3. Нажмите правую кнопку мыши на одной из выбранных вкладок. Выберите "Опубликовать выбранные разметки листов".
  4. В диалоговом окне "Публикация" задайте, как требуется, настройки выбранных разметок листов.
  5. Нажмите кнопку "Публикация".

Ввод команды: ПУБЛ


Создание и изменение набора чертежей для публикации - Команды

Публикация чертежей
Публикация чертежей
Создание и изменение набора чертежей для публикации
Понятия
Процедуры
Команды

Команды
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вывод набора для публикации на плоттер или в файл печати - Понятия

Печать и публикация чертежей
Публикация чертежей
Вывод набора для публикации на плоттер или в файл печати
Понятия
Процедуры
Команды

Набор чертежей можно при публикации вывести на печатающее устройство или в файл печати.

Существует возможность компоновки листов чертежей в адаптируемый набор чертежей и его публикации с выводом каждого листа на заданное для него устройство печати или в файл печати. Если в качестве устройства печати указан плоттер, то результатом вывода на печать будет набор бумажных чертежей.

Если задана печать в файл, то листы сохраняются в файлах, расположение которых зависит от настроек в диалоговом окне "Параметры публикации". Файл печати для каждого из листов сохраняется под тем же именем, что и лист, с соответствующим расширением (например, .plt, .jpg или .bmp). По умолчанию расположение можно изменить в диалоговом окне "Настройка" на вкладке "Печать/Публикация" в группе опций "Печать в файл".

См. также

Настройка параметров публикации


Вывод набора для публикации на плоттер или в файл печати - Процедуры

Печать и публикация чертежей
Публикация чертежей
Вывод набора для публикации на плоттер или в файл печати
Понятия
Процедуры
Команды

Вывод набора для публикации на плоттер или в файл печати

  1. При открытом чертеже нажмите "Файл" » "Публикация".
  2. В диалоговом окне "Публикация" в списке листов чертежа отображаются его вкладки. Создание набора для публикации путем выполнения одного из следующих действий:
    • Добавление листов. Для того чтобы добавить листы из других чертежей, нажмите кнопку "Добавить листы" (или перетащить чертежи с рабочего стола). В диалоговом окне "Выбор чертежей" выберите чертежи. Нажмите кнопку "Выбрать", чтобы добавить их к списку листов диалогового окна "Публикация". Каждая разметка листа чертежа становится отдельным листом в списке диалогового окна. Отдельные листы, которые не требуется включать в набор чертежей, можно удалить. Публикация возможна только для инициализированных разметок листов (т.е. тех листов, в параметрах которых задан любой формат листа, отличный от 0 x 0).

    Примечание Для включения всех разметок при добавлении листов в набор чертежей следует задать опцию "Включать разметки при добавлении листов" в контекстном меню диалогового окна "Публикация".

    • Добавление разметок листов модели. Если включена неинициализированная вкладка разметки листа модели (формат листа для которой не задан или имеет размеры 0 x 0 ), она будет иметь в статус "Лист не инициализирован" в поле "Статус" списка листов. Эта разметка может быть напечатана, если заменить для нее набор параметров листа.

    Примечание Для включения вкладки разметки листа модели при добавлении листов в набор чертежей следует убедиться, что в контекстном меню включена опция "Включать модель при добавлении листа".

    • Исключение листов. Для исключения листов из списка выберите один или несколько листов. Нажмите кнопку "Исключить листы". Для исключения всех листов нажмите правую кнопку мыши. Выберите "Исключить все".
    • Изменение порядка листов. Для того чтобы переместить лист в списке на один уровень вверх или вниз, выберите лист. Нажмите кнопку "Сдвинуть лист вверх" или "Сдвинуть лист вниз". Просмотр и печать листов набора чертежей выполняется в том порядке, в котором они расположены в списке.
    • Переименование листов. Для изменения имени листа выберите его в списке и нажмите правую кнопку мыши. Выберите "Переименовать лист". Введите новое имя листа.
    • Изменение набора параметров листа. Для изменения набора параметров листа выберите лист. В столбце "Параметры листа" из раскрывающегося списка выберите требуемый набор параметров или же выберите один или несколько листов из списка и нажмите правую кнопку мыши. Выберите "Изменение набора параметров листа". В списке "Параметры листа" выберите набор параметров или "Импорт" для импорта набора параметров из другого чертежа или шаблона. В диалоговом окне "Импорт наборов параметров листов" выберите чертеж, содержащий один или более наборов параметров листа. Нажмите "Импорт". В списке "Параметры листа" выберите требуемый набор параметров.

    Примечание Рекомендуется изменять параметры листа для каждой разметки листа в соответствии с желаемым видом на публикации.

    • Копирование листов. Чтобы скопировать один или несколько листов чертежей, выберите листы из списка и нажмите правую кнопку мыши. Выберите "Копировать выбранные листы". Копии добавляются в конец списка и выделяются подсвечиванием. Имя копии создается путем добавления слова -Копия(n) к имени исходного листа. Например, при копировании листа под названием Водопровод его копия будет называться Водопровод-Копия(1). При каждом копировании одного и того же листа n увеличивается на 1. Создавая копии листа, можно применять к одному и тому же листу разные наборы параметров листа и другие настройки.
  3. Когда список листов чертежа будет скомпонован и настроен требуемым образом, нажмите кнопку "Сохранить список листов".
  4. Введите имя списка в поле "Имя файла" диалогового окна "Сохранение списка". Нажмите кнопку "Сохранить".

    5. Список сохраняется в DSD-файле (файле описания наборов чертежей).

  5. В диалоговом окне "Публикация" в группе опций "Вывод при публикации" установите переключатель в положение "На плоттер, заданный в параметрах".
  6. Нажмите кнопку "Публикация" для запуска процесса.

    7. Если был включен режим фоновой публикации, в правой части строки состояния отображается значок плоттера, обозначающий ход процесса: печать бумажных чертежей или создание файлов печати.

  7. Для просмотра сведений о ходе выполнения задания на публикацию нажмите правую кнопку мыши на значке плоттера в правой части строки состояния. Выберите "Подробности о печати/публикации".

Панель "Стандартная"

Ввод команды: ПУБЛ


Вывод набора для публикации на плоттер или в файл печати - Команды

Публикация чертежей
Публикация чертежей
Вывод набора для публикации на плоттер или в файл печати
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Публикация электронного набора чертежей - Понятия

Печать и публикация чертежей
Публикация чертежей
Публикация электронного набора чертежей
Понятия
Процедуры
Команды

Для публикации набора чертежей в электронном виде используется формат DWF (Design Web Format).

Существует возможность компоновки листов чертежей в адаптируемый набор чертежей с последующей публикацией в электронном виде. Электронный набор чертежей - это аналог набора чертежей, распечатанных на бумаге. Электронный набор чертежей можно сохранить в виде одного многолистового DWF-файла и использовать для демонстрации хода проектов заказчикам, поставщикам и сотрудникам собственной компании - то есть всем, кому чертежи необходимы для изучения и протоколирования.

Также можно отправить опубликованный электронный чертеж как дополнение к письму электронной почты, предоставить его в общее пользование на электронной странице проекта, например Autodesk® Buzzsaw®, или разместить его на сайте в Интернете. С помощью программы просмотра Autodesk DWF Viewer получатели могут просматривать и печатать только нужные им вкладки.

Набор чертежей можно также опубликовать в виде набора однолистовых DWF-файлов, где каждый файл соответствует листу чертежа.

При публикации в файл формата DWF используется файл конфигурации плоттера DWF6 ePlot.pc3. Стандартный драйвер плоттера DWF6 ePlot.pc3 может использоваться в установленном виде или же можно вносить изменения в такие параметры, как глубина цвета, экранное разрешение, сжатие файла, обработка шрифтов и другие. Перед тем как вносить изменения в исходный файл DWF6 ePlot.pc3, следует убедиться, что создана резервная копия файла на случай, если потребуется вернуться к стандартным настройкам.

Предупреждение Для создания электронного набора чертежей

См. также

Настройка параметров публикации


Создание электронного набора чертежей - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация электронного набора чертежей
Понятия
Процедуры
Команды

Создание электронного набора чертежей

  1. При открытом чертеже нажмите "Файл" » "Публикация".

    2. На экране появляется диалоговое окно "Публикация". Если задана настройка добавления вкладок разметок листов в контекстном меню диалогового окна "Публикация", в списке листов перечисляются все вкладки разметок листов из текущего чертежа.

  2. Для редактирования списка листов в диалоговом окне "Публикация" следует выполнить одно из следующих действий:
    • Добавление листов. Для того, чтобы добавить листы из других чертежей, нажмите кнопку "Добавить листы" (или перетащить чертежи с рабочего стола). В диалоговом окне "Выбор чертежей" выберите чертежи. Нажмите кнопку "Выберите", чтобы добавить их к списку листов диалогового окна "Публикация". Каждая разметка листа чертежа становится отдельным листом в списке диалогового окна. Листы, которые не требуется включать в набор, следует исключить из списка. Публикация возможна только для инициализированных разметок листов (т.е. тех листов, в параметрах которых задан любой формат листа, отличный от 0 x 0).

    Примечание Для включения всех разметок при добавлении листов в набор чертежей следует задать опцию "Включать разметки при добавлении листов" в контекстном меню диалогового окна "Публикация".

    • Добавление разметок листов модели. Если включить неинициализированную вкладку модели (формат листа для которой не задан или имеет размеры 0 x 0 ), она будет иметь статус "Разметка листа не инициализирована" в поле "Статус" списка листов. Для вывода на печать такой вкладки следует выбрать в качестве переопределения набор параметров листа из раскрывающегося списка в столбце "Параметры листа" в списке листов диалогового окна "Публикация".

    Примечание Для включения модели при добавлении листов в набор чертежей для публикации в файл DWF следует задать опцию "Включать модель при добавлении листов" в контекстном меню диалогового окна "Публикация".

    • Исключение листов. Для исключения листов из списка выберите один или несколько листов. Нажмите кнопку "Исключить листы". Для исключения всех листов нажмите правую кнопку мыши. Выберите "Исключить все".
    • Изменение порядка листов. Для того, чтобы переместить лист в списке на один уровень вверх или вниз, выберите лист. Нажмите кнопку "Сдвинуть лист вверх" или "Сдвинуть лист вниз". Просмотр и печать листов набора чертежей выполняется в том порядке, в котором они расположены в списке.
    • Переименование листов. Для изменения имени листа выберите его в списке и нажмите правую кнопку мыши. Выберите "Переименовать лист". Введите новое имя листа.
    • Изменение набора параметров листа. Для изменения набора параметров разметки листа выберите лист, в столбце "Параметры листа" из раскрывающегося списка выберите именованный набор параметров или же выберите один или несколько листов и нажмите правую кнопку мыши. Выберите "Изменение набора параметров листа". В списке "Параметры листа" выберите набор параметров или "Импорт" для импорта набора параметров из другого чертежа или шаблона. В диалоговом окне "Импорт наборов параметров листов" выберите чертеж, содержащий один или более наборов параметров листа. Нажмите "Импорт". В списке "Параметры листа" выберите требуемый набор параметров.

    Примечание Рекомендуется изменять параметры листа для каждой разметки листа в соответствии с желаемым видом на публикации. Для вкладки "Модель" можно применять только наборы параметров листа, созданные для пространства модели, а для вкладок разметок листов можно применять только наборы параметров, созданные для разметок.

    • Копирование листов. Чтобы скопировать один или большее количество листов чертежей, выберите листы из списка и нажмите правую кнопку мыши. Выберите "Копировать выбранные листы". Копии добавляются в конец списка и выделяются подсвечиванием. Имя копии создается путем добавления слова -Копия(n) к имени исходного листа. Например, при копировании листа под названием Водопровод его копия будет называться Водопровод-Копия(1). При каждом копировании одного и того же листа n увеличивается на 1. Создавая копии листа, можно применять к одному и тому же листу разные наборы параметров листа и другие настройки.
  3. Когда список листов чертежа будет скомпонован и настроен требуемым образом, нажмите кнопку "Сохранить список".
  4. Введите имя списка в поле "Имя файла" диалогового окна "Сохранение списка". Нажмите кнопку "Сохранить".

    5. Список сохраняется в DSD-файле (файле описания наборов чертежей).

  5. В диалоговом окне "Публикация" в группе "Вывод при публикации" выбрать опцию "В DWF-файл". Нажмите кнопку "Публикация".
  6. Введите имя файла в диалоговом окне "Выбор файла DWF". Нажмите кнопку "Выбрать", чтобы задать имя и путь к файлу DWF.

    7. Примечание Можно также ввести URL-адрес, чтобы загрузить DWF-файл на FTP-сервер или сайт в Интернете.

  7. Нажмите кнопку "Сохранить" для запуска процедуры создания электронного набора чертежей.

    8. Если был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса.

  8. Для просмотра сведений о ходе выполнения задания на публикацию нажмите правую кнопку мыши на значке плоттера в правой части строки состояния. Выберите "Подробности о печати/публикации".

    9. Информация, выводимая в диалоговое окно "Подробности о печати/публикации", также сохраняется в файле журнала печати/публикации.

  9. Если режим фоновой печати включен, пользователь может сразу просмотреть опубликованный DWF-файл. Щелкните правой кнопкой мыши на значке плоттера в правой части строки состояния. Выберите "Просмотр файла DWF".

Панель Стандартная

Ввод команды: ПУБЛ


Публикация электронного набора чертежей - Команды

Публикация чертежей
Публикация чертежей
Публикация электронного набора чертежей
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Публикация подшивки - Понятия

Печать и публикация чертежей
Публикация чертежей
Публикация подшивки
Понятия
Процедуры
Команды

С помощью Диспетчера подшивок можно опубликовать целую подшивку листов, группу листов из подшивки или отдельный лист. Публикация листов, порожденных Диспетчером подшивок, осуществляется намного проще в нем самом, нежели в диалоговом окне "Публикация".

При публикации из Диспетчера подшивок электронный набор чертежей может быть выведен либо в DWF-файл, либо на плоттер, заданный в наборе параметров для каждого листа. Публикация может также выполняться с использованием переопределений параметров, заданных в связанном с подшивкой DWF-файле. Переопределение имеет силу только для текущего задания на публикацию.

Если диалоговое окно "Публикация" открывается из Диспетчера подшивок, в список в нем автоматически заносятся все листы, которые были выбраны в подшивке. В дальнейшем имеется возможность редактировать список.

См. также

Использование наборов параметров листов в подшивках

Работа с листами в подшивке

Настройка параметров публикации


Публикация подшивки - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация подшивки
Понятия
Процедуры
Команды

Публикация подшивки в файл DWF

Печать подшивки в файл PDF

Публикация группы листов подшивки или отдельного листа в DWF-файл

Публикация листов подшивки на заданном в параметрах листов плоттере

Публикация листов подшивки с переопределением параметров листов

Добавление штемпеля на публикуемые листы подшивки

Задание параметров публикации подшивок

Открытие окна публикации из Диспетчера подшивок и модификация публикуемого набора листов


Публикация подшивки в файл DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация подшивки
Понятия
Процедуры
Команды

Публикация подшивки в файл DWF

  1. В Диспетчере подшивок выберите в группе "Листы" имя подшивки.
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Публикация в DWF".

    3. Примечание Подшивки не могут содержать элементы 3D DWF.

    Если был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса. Нажатие правой кнопкой на этом значке вызывает контекстное меню, с помощью которого можно просматривать DWF-файлы и получать информацию о процессе публикации.

    Производительность публикации можно повысить отключением публикации в фоновом режиме. Возможность выполнения печати в фоновом режиме отключается на вкладке "Печать/Публикация" диалогового окна "Параметры".

Панель "Стандартная"

Ввод команды: ПОДШИВКА

Ввод команды: Укажите правой кнопкой мыши узел подшивки или ее имя. Выберите "Публикация" » "Опубликовать в DWF".


Печать подшивки в файл PDF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация подшивки
Понятия
Процедуры
Команды

Печать подшивки в файл PDF

  1. В Диспетчере подшивок нажмите правую кнопку мыши на имени подшивки или узла. Выберите в меню "Публикация" » "Диспетчер параметров листов".
  2. В диалоговом окне "Диспетчер параметров листов" выберите "Создать".
  3. В диалоговом окне "Создание набора параметров листа", в разделе "Имя набора параметров листа" введите имя для PDF набора параметров листа. Нажмите "ОК".
  4. В диалоговом окне "Параметры листа", в разделе "Принтер/плоттер", выберите файл настройки DWG to PDF.pc3.

    5. Если отображается диалоговое окно "Не найден формат листа", выберите формата листа для подшивки.

  5. В диалоговом окне "Параметры листа", задайте требуемые параметры листа. Нажмите "ОК".
  6. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
  7. В Диспетчере подшивок нажмите правую кнопку мыши на подшивке для выполнения публикации. Выберите "Публикация" » "Опубликовать без учета параметров листа" » созданный набор параметров листа.

    8. Файл PDF печатается в каталог, приведенный в списке диалогового окна "Подробности о печати/публикации"ПОДРОБНОСТИПП.

    Производительность публикации можно повысить отключением публикации в фоновом режиме. Возможность выполнения печати в фоновом режиме отключается на вкладке "Печать/Публикация" диалогового окна "Параметры".

Окно "Диспетчер подшивки"

Ввод команды: ПОДШИВКА


Публикация группы листов подшивки или отдельного листа в DWF-файл - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация подшивки
Понятия
Процедуры
Команды

Публикация группы листов подшивки или отдельного листа в DWF-файл

  1. В Диспетчере подшивок выберите в группе "Листы" имя группы листов или отдельный лист.
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Публикация в DWF".

    3. Примечание Если был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса. Нажатие правой кнопкой на этом значке вызывает контекстное меню, с помощью которого можно просматривать DWF-файлы и получать информацию о процессе публикации.

Панель "Стандартная"

Ввод команды: ПОДШИВКА

Контекстное меню: Нажмите правую кнопку мыши на узле или имени группы листов или отдельного листа. Выберите "Публикация" » "Опубликовать в DWF".


Публикация листов подшивки на заданном в параметрах листов плоттере - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация подшивки
Понятия
Процедуры
Команды

Публикация листов подшивки на заданном в параметрах листов плоттере

  1. В Диспетчере подшивок выберите в группе "Листы" имя подшивки, группы листов или отдельный лист.
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Публикация". Выберите "Опубликовать на плоттер".

    3. Примечание Если был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса. Нажатие правой кнопкой на этом значке вызывает контекстное меню, с помощью которого можно просматривать DWF-файлы и получать информацию о процессе публикации.

Панель "Стандартная"

Ввод команды: ПОДШИВКА

Контекстное меню: Нажмите правую кнопку мыши на узле или имени подшивки, группы листов или отдельного листа. Выберите "Публикация" » "Опубликовать на плоттер".


Публикация листов подшивки с переопределением параметров листов - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация подшивки
Понятия
Процедуры
Команды

Публикация листов подшивки с переопределением параметров листов

  1. В Диспетчере подшивок выберите в группе "Листы" имя подшивки, группы листов или отдельный лист.
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Публикация". Выберите "Опубликовать без учета параметров листа" » <имя_файла.dwt>. (Отображаются все именованные наборы параметров листов, которые сохранены в файле DWT без учета параметров листа.)

    3. Параметры листа, заданные в файле переопределений, имеют приоритет перед параметрами, которые заданы в самих публикуемых листах. Переопределения имеют силу только для текущего задания на публикацию.

    Примечание Если был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса. Нажатие правой кнопкой на этом значке вызывает контекстное меню, с помощью которого можно просматривать DWF-файлы и получать информацию о процессе публикации.

Панель "Стандартная"

Ввод команды: ПОДШИВКА

Контекстное меню: Нажмите правую кнопку мыши на узле или имени группы листов или отдельного листа. Выберите "Опубликовать без учета параметров листа" » <имя_файла.dwt>.


Добавление штемпеля на публикуемые листы подшивки - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация подшивки
Понятия
Процедуры
Команды

Добавление штемпеля на публикуемые листы подшивки

  • В правом верхнем углу Диспетчера подшивок нажмите кнопку "Публикация". Выберите "Добавить штемпель".

    • На все публикуемые листы добавляется штемпель.

Примечание Для изменения параметров штемпеля нажмите кнопку "Публикация". Выберите "Параметры штемпеля".

Панель "Стандартная"

Ввод команды: ПОДШИВКА

Контекстное меню: Нажмите правую кнопку мыши на узле или имени группы листов или отдельного листа. Выберите "Публикация" » "Добавить штемпель".


Задание параметров публикации подшивок - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация подшивки
Понятия
Процедуры
Команды

Задание параметров публикации подшивок

  1. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Публикация". Выберите "Параметры публикации подшивки".
  2. В диалоговом окне "Параметры публикации подшивки" настройте параметры.
  3. Нажмите "ОК".

Панель "Стандартная"

Ввод команды: ПОДШИВКА

Контекстное меню: Нажмите правую кнопку мыши на узле или имени группы листов или отдельного листа. Выберите "Публикация" » "Параметры публикации подшивки".


Открытие окна публикации из Диспетчера подшивок и модификация публикуемого набора листов - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация подшивки
Понятия
Процедуры
Команды

Открытие окна публикации из Диспетчера подшивок и модификация публикуемого набора листов

  1. В Диспетчере подшивок выберите в группе "Листы" имя подшивки, группы листов или отдельный лист.
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Публикация". Выберите "Диалоговое окно публикации".

    3. Открывается диалоговое окно "Публикация". В список публикуемых листов заносятся все листы, которые были выбраны в Диспетчере подшивок.

  3. В диалоговом окне "Публикация" отредактируйте список и настройте параметры, как это требуется.
  4. Нажмите кнопку "Публикация" для публикации подшивки с текущими настройками.

    5. Примечание Если был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса. Нажатие правой кнопкой на этом значке вызывает контекстное меню, с помощью которого можно просматривать DWF-файлы и получать информацию о процессе публикации.

Панель "Стандартная"

Ввод команды: ПОДШИВКА

Контекстное меню: Нажмите правую кнопку мыши на узле или имени группы листов или отдельного листа. Выберите "Публикация" » "Диалоговое окно публикации".


Публикация подшивки - Команды

Публикация чертежей
Публикация чертежей
Публикация подшивки
Понятия
Процедуры
Команды

Команды
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПОДШИВКА | Вызов диспетчера подшивок
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Повторная публикация набора чертежей - Понятия

Печать и публикация чертежей
Публикация чертежей
Повторная публикация набора чертежей
Понятия
Процедуры
Команды

Существует возможность повторной публикации листов чертежей, списки которых были ранее сохранены в формате описаний наборов чертежей (DSD).

После внесения изменений в чертежи может понадобиться заново опубликовать набор чертежей для его просмотра или печати. Подшивку (DST-файл) или набор листов чертежей можно с легкостью опубликовать повторно, если сведения о них ранее были сохранены как DSD-файл (файл описания наборов чертежей). Также можно загружать и выполнять повторную публикацию BP3-файлов (списков пакетной печати).


Повторная публикация набора чертежей - Процедуры

Печать и публикация чертежей
Публикация чертежей
Повторная публикация набора чертежей
Понятия
Процедуры
Команды

Повторная публикация набора чертежей


Повторная публикация набора чертежей - Процедуры

Печать и публикация чертежей
Публикация чертежей
Повторная публикация набора чертежей
Понятия
Процедуры
Команды

Повторная публикация набора чертежей

  1. Нажмите "Файл" » "Публикация".

    2. Если имеется открытый чертеж, все его разметки заносятся в список диалогового окна "Публикация". Нажмите правую кнопку мыши в списке листов. Выберите "Исключить все", чтобы удалить разметки листов из списка.

  2. В диалоговом окне "Публикация" нажмите кнопку "Загрузить список листов".
  3. В диалоговом окне "Загрузка списка листов" выберите расположение файла DSD или файла BP3. Выберите "Загрузить".

    4. Теперь в списке диалогового окна "Публикация" отображаются листы, входящие в загруженный файл списка.

  4. В диалоговом окне "Публикация" выполните одно из следующих действий:
    • Если набор чертежей публикуется в DWF-файл, установите переключатель "Вывод при публикации" в положение "В DWF-файл".
    • Если набор чертежей публикуется на плоттер или принтер, установите переключатель "Вывод при публикации" в положение "На плоттер, заданный в параметрах".
  5. Нажмите кнопку "Публикация".

    6. Если был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса.

  6. Если режим фоновой печати включен, можно сразу просмотреть сведения о выполненном задании на публикацию. Нажмите правую кнопку мыши на значке плоттера в правой части строки состояния. Выберите "Подробности о печати/публикации". Информация, выводимая в диалоговое окно "Подробности о печати/публикации", также сохраняется в файле журнала печати/публикации.

Панель "Стандартная"

Ввод команды: ПУБЛ


Повторная публикация набора чертежей - Команды

Публикация чертежей
Публикация чертежей
Повторная публикация набора чертежей
Понятия
Процедуры
Команды

Команды
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Просмотр опубликованного электронного набора чертежей - Понятия

Печать и публикация чертежей
Публикация чертежей
Просмотр опубликованного электронного набора чертежей
Понятия
Процедуры
Команды

Для просмотра и печати опубликованного электронного набора чертежей может быть использована программа Autodesk™ DWF™ Viewer.

Опубликованный набор чертежей является электронным эквивалентом набора печатных чертежей, созданным на основе чертежей. Набор чертежей, сохраненный в файле формата Design Web Format™ (DWF™ ), можно просматривать и печатать с помощью программы Autodesk DWF Viewer. С помощью программы Autodesk DWF Viewer можно открывать, просматривать и печатать все файлы формата DWF и другие растровые изображения. Можно производить панорамирование, зумирование и просматривать изображения отдельных листов и видовых экранов. Также можно просматривать информацию о слоях, свойства листов и подшивки, информацию о блоках, атрибутах и дополнительные свойства, если эти сведения записаны в файле DWF. При перемещении курсора в программе просмотра вдоль геометрии DWF связанные с объектами данные подсвечиваются красным цветом.

Получателям наборов чертежей в формате DWF не обязательно иметь программу или уметь с ней работать. Они могут просматривать и печатать листы с высоким качеством с помощью программы Autodesk DWF Viewer.

AutodeskDWF Viewer работает как автономное приложение или внедряется в любое приложение, поддерживающее технологию управления ActiveX, например Microsoft® Internet Explorer.

Для получения сведений о продукте и ссылки для загрузки программы Autodesk DWF Viewer обратитесь к странице "Продукты" на веб-сайте Autodesk.

Подробнее об использовании Autodesk DWF Viewer см. справочную систему этой программы.


Просмотра последнего опубликованного DWF-файла в Autodesk DWF Viewer - Процедуры

Печать и публикация чертежей
Публикация чертежей
Просмотр опубликованного электронного набора чертежей
Понятия
Процедуры
Команды

Просмотра последнего опубликованного DWF-файла в Autodesk DWF Viewer

  • Нажмите правую кнопку мыши на значке плоттера в правой части строки состояния программы. Выберите "Просмотр файла DWF".

Примечание Пункт доступен, только если включен режим фоновой публикации.


Просмотр опубликованного электронного набора чертежей - Команды

Публикация чертежей
Публикация чертежей
Просмотр опубликованного электронного набора чертежей
Понятия
Процедуры
Команды

Команды
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка параметров публикации - Понятия

Печать и публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Можно настраивать такие параметры процесса публикации, как расположение выходного файла, тип DWF-файла, именование листов в многолистовом DWF, защита DWF-файла паролем и включение в него информации о слоях. Можно указать, какая информация будет содержаться в опубликованных файлах DWF.

Можно включить следующие типы метаданных.

  • Свойства подшивки (необходима публикация с помощью Диспетчера подшивок)
  • Свойства листов для публикации (необходима публикация с помощью Диспетчера подшивок)
  • Стандартные свойства, а также настраиваемые свойства и атрибуты блока
  • Свойства настраиваемых объектов

Используйте файл шаблона блока (BLK), чтобы указать те свойства блока, которые требуется включить в публикуемые файлы DWF. Можно использовать диалоговое окно "Шаблон блока" для создания или изменения настроек файла шаблона блока (BLK). Можно также использовать файлы BLK, созданные с помощью Мастера извлечения атрибутов.

При изменении настроек в диалоговом окне "Параметры публикации" можно сохранить их в файл описания наборов чертежей (DSD), чтобы воспользоваться ими в следующий раз при публикации чертежей. Их также можно сохранить в файле DSD.


Настройка параметров публикации - Процедуры

Печать и публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Для изменения папки, в которой по умолчанию хранятся публикуемые файлы DWF и чертежи, выполните следующие действия.

Чтобы указать тип выходного файла DWF (однолистовые файлы или многолистовой файл DWF), выполните следующие действия.

Для задания имени многостраничных файлов DWF

Для установки режима запроса имени для многолистовых DWF-файлов

Установка режима защиты публикуемых DWF-файлов паролями

Добавление информации о слоях в публикуемый файл DWF

Включение сведений о блоках в публикуемый файл DWF

Включение сведений о шаблонах блоков в публикуемый файл DWF

Создание файла шаблона блока (BLK)

Редактирование файла шаблона блока (BLK)


Для изменения папки, в которой по умолчанию хранятся публикуемые файлы DWF и чертежи, выполните следующие действия. - Процедуры

Печать и публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Для изменения папки, в которой по умолчанию хранятся публикуемые файлы DWF и чертежи, выполните следующие действия.

  1. Нажмите "Файл" » "Публикация".
  2. В группе опций "Вывод при публикации" диалогового окна "Публикация" выберите заданный в параметрах листа плоттер или файл DWF, затем щелкните "Параметры публикации".
  3. В группе "Папка для вывода по умолчанию" (для DWF и печати в файл) диалогового окна "Параметры публикации" выполните одно из следующих действий.
    • Нажмите кнопку "Размещение" и произвести выбор из раскрывающегося списка.
    • Нажмите кнопку [...] и выберите папку в диалоговом окне "Выбор папки для сформированных чертежей". Нажмите "Выбрать".
  4. В диалоговом окне "Параметры публикации" нажмите "OK".

Панель "Стандартная"

Ввод команды: ПУБЛ


Чтобы указать тип выходного файла DWF (однолистовые файлы или многолистовой файл DWF), выполните следующие действия. - Процедуры

Печать и публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Чтобы указать тип выходного файла DWF (однолистовые файлы или многолистовой файл DWF), выполните следующие действия.

  1. Нажмите "Файл" » "Публикация".
  2. В группе опций "Вывод при публикации" диалогового окна "Публикация" выберите файл DWF, затем щелкните "Параметры публикации".
  3. В группе "Общие параметры DWF" диалогового окна "Параметры публикации" щелкните "Тип файла DWF" и укажите в раскрывающемся списке следующее.
    • Одностраничный файл DWF. Создание для каждого публикуемого листа отдельного одностраничного файла DWF.
    • Многостраничный файл DWF. Создание одного многостраничного файла DWF.
  4. Нажать "ОК".
  5. В диалогом окне "Публикация" продолжите выполнение задач публикации или закройте диалоговое окно.

Панель "Стандартная"

Ввод команды: ПУБЛ


Для задания имени многостраничных файлов DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Для задания имени многостраничных файлов DWF

  1. Нажмите "Файл" » "Публикация".
  2. В группе опций "Вывод при публикации" диалогового окна "Публикация" выберите "В DWF-файл", а затем нажмите "Параметры публикации".
  3. В группе "Общие параметры DWF" диалогового окна "Параметры публикации" щелкните "Тип файла DWF" и выберите в раскрывающемся списке "Многостраничный файл DWF".
  4. В группе "Общие параметры DWF" диалогового окна "Параметры публикации" щелкните "Тип файла DWF" и выберите в раскрывающемся списке "Многостраничный файл DWF".
  5. Нажать "ОК".
  6. В диалогом окне "Публикация" продолжите выполнение задач публикации или закройте диалоговое окно.

Панель "Стандартная"

Ввод команды: ПУБЛ


Для установки режима запроса имени для многолистовых DWF-файлов - Процедуры

Печать и публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Для установки режима запроса имени для многолистовых DWF-файлов

  1. Нажмите "Файл" » "Публикация".
  2. В диалоговом окне "Публикация" в разделе "Опубликовать" выберите "Файл DWF", затем щелкните "Параметры публикации".
  3. В группе "Общие параметры DWF" диалогового окна "Параметры публикации" щелкните "Тип файла DWF" и выберите в раскрывающемся списке "Многостраничный файл DWF".
  4. В группе "Параметры многостраничных файлов DWF" диалогового окна "Параметры публикации" выберите "Запрос имени", чтобы при каждой публикации файла DWF выводился запрос на ввод имени.
  5. Нажать "ОК".
  6. В диалогом окне "Публикация" продолжите выполнение задач публикации или закройте диалоговое окно.

Панель "Стандартная"

Ввод команды: ПУБЛ


Установка режима защиты публикуемых DWF-файлов паролями - Процедуры

Печать и публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Установка режима защиты публикуемых DWF-файлов паролями

  1. Нажмите "Файл" » "Публикация".
  2. В группе опций "Вывод при публикации" диалогового окна "Публикация" выберите "В DWF-файл", а затем нажмите "Параметры публикации".
  3. В группе "Общие параметры DWF" диалогового окна "Параметры публикации" нажмите "Защита паролем" и выберите в раскрывающемся списке один из следующих пунктов:
    • Выберите параметр "Заданный здесь пароль" и в поле "Пароль" введите пароль, который будет использоваться для файла DWF.
    • Выберите параметр "Запрос пароля". При открытии опубликованного файла DWF будет выдаваться запрос на ввод пароля или фразы.

    Пароли для DWF-файлов вводятся с учетом регистра. Пароль или фраза могут содержать буквы, цифры, знаки препинания и символы, которые не входят в стандартный набор ASCII.

    Предупреждение Забытый или утерянный пароль не может быть восстановлен. Список паролей и имен соответствующих DWF-файлов рекомендуется хранить в надежном месте.

  4. Нажмите "ОК".
  5. В диалогом окне "Публикация" продолжите выполнение задач публикации или закройте диалоговое окно.

Панель "Стандартная"

Ввод команды: ПУБЛ


Добавление информации о слоях в публикуемый файл DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Добавление информации о слоях в публикуемый файл DWF

  1. Нажмите "Файл" » "Публикация".
  2. В группе опций "Вывод при публикации" диалогового окна "Публикация" выберите "В DWF-файл", а затем нажмите "Параметры публикации".
  3. В группе "Параметры данных DWF" диалогового окна "Параметры публикации" нажмите "Информация о слоях" и выберите "Включать" из раскрывающегося списка.

    4. Примечание По умолчанию параметру "Информация о слоях" присвоено значение "Не включать", чтобы сократить затрачиваемое на публикацию время. Если изменить значение параметра, при просмотре и печати сформированных после этого DWF-файлов можно будет делать отдельные слои невидимыми.

  4. Нажмите "ОК".
  5. В диалогом окне "Публикация" продолжите выполнение задач публикации или закройте диалоговое окно.

Панель "Стандартная"

Ввод команды: ПУБЛ


Включение сведений о блоках в публикуемый файл DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Включение сведений о блоках в публикуемый файл DWF

  1. Нажмите "Файл" » "Публикация".
  2. В группе опций "Вывод при публикации" диалогового окна "Публикация" выберите "В DWF-файл", а затем нажмите "Параметры публикации".
  3. В группе "Параметры данных DWF" диалогового окна "Параметры публикации" нажмите "Сведения о блоке" и выберите "Включать" из раскрывающегося списка.

    4. Примечание По умолчанию для параметра "Сведения о блоке" установлено значение "Не включать". При изменении настройки включения сведений о блоках можно использовать программу просмотра для просмотра или печати информации о свойствах и атрибутах блоков в файле DWF.

  4. Нажмите "ОК".
  5. В диалогом окне "Публикация" продолжите выполнение задач публикации или закройте диалоговое окно.

Панель "Стандартная"

Ввод команды: ПУБЛ


Включение сведений о шаблонах блоков в публикуемый файл DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Включение сведений о шаблонах блоков в публикуемый файл DWF

Примечание Можно использовать файлы шаблонов блоков (BLK), созданные в диалоговом окне "Параметры публикации", или файлы BLK, созданные с помощью Мастера извлечения атрибутов.

  1. Нажмите "Файл" » "Публикация".
  2. В группе опций "Вывод при публикации" диалогового окна "Публикация" выберите "В DWF-файл". Нажмите кнопку "Параметры публикации".
  3. В группе "Параметры данных DWF" диалогового окна "Параметры публикации" нажмите "Сведения о блоке" для отображения раскрывающегося списка. Выберите "Включать".
  4. В группе "Параметры данных DWF" диалогового окна "Параметры публикации" нажмите "Файл шаблона блока" для отображения раскрывающегося списка. Выберите файл шаблона блока (BLK), содержащий описания свойств и атрибутов, которые должны быть доступны в опубликованном файле DWF. Нажмите "ОК".

    5. Примечание В списке также представлены параметры создания и редактирования. При использовании параметра создания открывается диалоговое окно "Публикация шаблона блока", в котором можно создать новый файл шаблона блока. При использовании параметра редактирования открывается диалоговое окно "Редактирование опубликованного шаблона", в котором можно выберите существующий файл шаблона блока для изменения.

  5. Нажмите "ОК".
  6. В диалогом окне "Публикация" продолжите выполнение задач публикации или закройте диалоговое окно.

Панель "Стандартная"

Ввод команды: ПУБЛ


Создание файла шаблона блока (BLK) - Процедуры

Печать и публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Создание файла шаблона блока (BLK)

  1. Нажмите "Файл" » "Публикация".
  2. В группе опций "Вывод при публикации" диалогового окна "Публикация" выберите "В DWF-файл", а затем нажмите "Параметры публикации".
  3. В группе "Параметры данных DWF" диалогового окна "Параметры публикации" нажмите "Сведения о блоке" и выберите "Включать" из раскрывающегося списка.
  4. В группе "Параметры данных DWF" диалогового окна "Параметры публикации" нажмите "Файл шаблона блока" для отображения раскрывающегося списка и выберите "Создать".

    5. В диалоговом окне "Публикация шаблона блока" имеется область "Исходный чертеж блока", в котором отображается текущий чертеж.

    Примечание Рабочий набор чертежей для этого списка не зависит от того, какие чертежи будут включаться в операцию публикации.

  5. Выполните одно из следующих действий:
    • Если этот чертеж содержит свойства блоков, которые планируется включить в публикуемый файл DWF, нажмите кнопку "Поиск блоков".

      • Программа выполняет поиск в файле DWG всех уникальных описаний блоков и связанных с ними свойств и атрибутов.

    • Если этот чертеж не содержит свойства блоков, которые планируется включить в публикуемый файл DWF, нажмите кнопку "Добавить".

      • Открывается диалоговое окно "Выбор чертежей". Выберите чертежи для добавления в список исходных чертежей для блоков. Можно также добавлять и удалять чертежи, содержащие целевые блоки, свойства которых необходимо включить в публикуемый файл DWF. Нажмите кнопку "Поиск блоков".

      Поиск в файле DWG выполняется для всех уникальных описаний блоков и связанных с ними свойств и атрибутов.

      Примечание По умолчанию включаются параметры для вложенных блоков и блоков во внешних ссылках. Если не требуется включать параметры этих блоков, нажмите "Параметры" в диалоговом окне "Публикация шаблона блока" и опустите соответствующие флажки.

  6. В диалоговом окне "Публикация шаблона блока" в разделах "Данные блока для публикации", "Уникальные блоки в исходных чертежах" и "Проверить блоки для публикации" выберите имена блоков, которые необходимо включить в публикуемые файлы DWF. Для установки или снятия всех флажков нажмите правую кнопку мыши.
  7. В разделах "Данные блока для публикации", "Свойства выбранных блоков" и "Проверить свойства для публикации" выберите свойства, которые необходимо включить в публикуемые файлы DWF. Для установки или снятия всех флажков нажмите правую кнопку мыши.

    8. В списке отображается набор свойств всех выбранных блоков.

    Примечание При выборе блока в списке блоков и снятии для него флажков всех свойств в формируемый файл DWF будет опубликовано только имя блока; сведения о свойствах не будут добавлены.

  8. Нажмите "Сохранить" для ввода имени и сохранения файла шаблона блока. Нажмите "ОК".

    9. Новый файл шаблона блока теперь будет доступен в разделе "Параметры данных DWF" диалогового окна "Публикация шаблона блока".

  9. В диалогом окне "Публикация" продолжите выполнение задач публикации или закройте диалоговое окно.

Панель "Стандартная"

Ввод команды: ПУБЛ


Редактирование файла шаблона блока (BLK) - Процедуры

Печать и публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Редактирование файла шаблона блока (BLK)

  1. Нажмите "Файл" » "Публикация".
  2. В группе опций "Вывод при публикации" диалогового окна "Публикация" выберите "В DWF-файл", а затем нажмите "Параметры публикации".
  3. В группе "Параметры данных DWF" диалогового окна "Параметры публикации" нажмите "Сведения о блоке" и выберите "Включать" из раскрывающегося списка.
  4. В группе "Параметры данных DWF" диалогового окна "Параметры публикации" нажмите "Файл шаблона блока" для отображения раскрывающегося списка и выберите "Редактировать".
  5. В диалоговом окне "Выбор шаблона блока" выберите файл шаблона блока (BLK) для редактирования, а затем нажмите "Выберите".

    6. Примечание Рабочий набор чертежей для этого списка не зависит от того, какие чертежи будут включаться в операцию публикации.

  6. В диалоговом окне "Публикация шаблона блока" нажмите "Поиск блоков".

    7. Программа выполняет поиск в файлах DWG всех уникальных описаний блоков и связанных с ними свойств и атрибутов.

    Примечание По умолчанию включаются параметры для вложенных блоков и блоков во внешних ссылках. Если не требуется включать эти параметры блоков, нажмите "Параметры" в диалоговом окне "Публикация шаблона блока" и опустите соответствующие флажки.

  7. В разделах "Данные блока для публикации", "Уникальные блоки в исходных чертежах" и "Проверить блоки для публикации" установите или опустите флажки имен блоков, которые необходимо включить в публикуемые файлы DWF.
  8. В разделах "Данные блока для публикации", "Уникальные блоки в исходных чертежах" и "Проверить блоки для публикации" установите или опустите флажки имен блоков, которые необходимо включить в публикуемые файлы DWF.

    9. В этом списке отображается набор свойств всех выбранных блоков.

    Примечание При выборе блока в списке блоков и снятии для него флажков всех свойств в формируемый файл DWF будет опубликовано только имя блока; сведения о свойствах не будут добавлены.

  9. Нажмите кнопку "Сохранить". Нажмите "ОК".

    10. Измененный файл шаблона блока теперь будет доступен в разделе "Параметры данных DWF" диалогового окна "Публикация шаблона блока".

  10. В диалогом окне "Публикация" продолжите выполнение задач публикации или закройте диалоговое окно.

Панель "Стандартная"

Ввод команды: ПУБЛ


Настройка параметров публикации - Команды

Публикация чертежей
Публикация чертежей
Настройка параметров публикации
Понятия
Процедуры
Команды

Команды
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Публикация 3D DWF - Понятия

Печать и публикация чертежей
Публикация чертежей
Публикация 3D DWF
Понятия
Процедуры
Команды

Имеется возможность создания и публикации файлов DWF, содержащие трехмерные модели, и их просмотра с помощью приложения Autodesk® DWF™ Viewer.

Можно генерировать файлы DWF трехмерных моделей почти с тем же визуальным разрешением, что и у исходных файлов в формате DWG. Можно создавать одно- или многолистовой файл формата DWF, который будет содержат как 2D, так и 3D объекты пространства модели. Для доступа к процедурам 3D публикации DWF используются команды 3DДВФ, ЭКСПОРТ или ПУБЛ.

Получатели файлов 3D DWF могут просматривать и печатать их с помощью программы просмотра Autodesk DWF Viewer. Для получения сведений о продукте и ссылки для загрузки программы Autodesk DWF Viewer обратитесь к странице "Продукты" на веб-сайте Autodesk.

Для получения дополнительной информации по использованию программы просмотра Autodesk DWF Viewer см. справочную систему Autodesk DWF Viewer.

Публикация одного и нескольких файлов 3D DWF

Для публикации одного файла 3D DWF используются команды ЭКСПОРТ и 3DДВФ. При исполнении любой из этих команд модель, с которой в настоящее время работает пользователь, сохраняется в виде 3D DWF-файла.

Для одновременной публикации нескольких 3D DWF-файлов используется команда ПУБЛ. В диалоговом окне "Публикация" отображается список всех имен листов файлов чертежей, открытых в текущий момент. Можно определить, какие листы требуется опубликовать в 3D файл DWF, добавляя листы к списку имен листов или исключая их из него.

Примечание Управление списком листов, отображаемых в списке "Имя листа" диалогового окна "Публикация", осуществляется посредством системной переменной PUBLISHALLSHEETS. По умолчанию отображаются все листы всех открытых чертежей.

Публикация материалов

Если для объектов модели назначены материалы с соответствующей текстурой, эти материалы могут быть опубликованы в 3D файл DWF. Ориентация и масштаб текстуры, заданные в графическом редакторе, сохраняются в опубликованном 3D файле DWF.

Имеются некоторые ограничения публикации материалов.

  • Единственным наложением, подлежащим публикации, является канал "Текстура рассеяния". Если материал содержит текстуры непрозрачности, отражения или выдавливания, они не будут опубликованы.
  • Такие производственные материалы, как дерево или мрамор, публикации не подлежат.

Примечание Так как приложение для просмотра DWF и средство тонирования отличаются друг от друга, могут возникнуть некоторые отклонения внешнего вида текстур в приложении DWF Viewer.

Увеличение степени сглаживания 3D моделей DWF

Усиление сглаживания 3D моделей DWF достигается изменением значения системной переменной 3DDWFPREC. Переменная 3DDWFPREC может принимать значение от 1 до 6. Чем выше значение, тем лучше выглядят объекты в приложении для просмотра DWF.

Примечание Значение переменной 3DDWFPREC имеет глобальное действие, влияющее на все объекты 3D модели. Поэтому повышение ее значения приводит к значительному увеличению размера 3D файлов DWF.

Повышение производительности при работе с большими моделями

При публикации файла DWF обрабатываются все объекты модели. При работе с большими моделями производительность значительно повышается, если используются блоки. Например, модель офиса содержит базовую конфигурацию секции из восьми перегородок, письменного стола и стула. Обработка только этих десяти объектов не требует много времени. Однако, если эта базовая конфигурация секции используется 100 раз, это приводит к обработке 1000 объектов, и соответственно возрастает время публикации. Если базовая конфигурация секции вставлена в модель в качестве отдельного блока, эти десять объектов обрабатываются один раз для каждой вставки.

Повысить производительность выполнения публикации можно еще больше, группируя разнообразные объекты во временные блоки. По завершении публикации эти блоки можно расчленить и продолжать работу над этими объектами.

По мере приближения проекта к завершению можно создавать блоки, состоящие из частей модели, которые, скорее всего, не требуют дальнейших изменений. Если первый этаж офиса не будет подвергаться большим изменениям, рекомендуется создать блок, содержащий все его компоненты. Во время публикации вместо обработки каждого отдельного объекта этого этажа такой блок обрабатывается как один объект.

Содержимое, неподдерживаемое в 3D DWF

При публикации 3D файла DWF некоторая часть объектов чертежа может не воспроизводиться при просмотре в приложении DWF Viewer. В следующей таблице представлено содержимое, которое не поддерживается при выводе в 3D файл DWF.

Неподдерживаемое содержимое

Подробности

Анимации и сквозной контроль

Типы шрифтов (разные)

См. таблицу "Поддерживаемы текстовые шрифты"

Градиентные заливки (штриховки)

Невидимые ребра

Гиперссылки

Изображения

Информация о слоях

Источники света и тени

Компоненты материалов
  • Текстуры "Выдавливание", "Непрозрачность" и "Цвет блика"
  • Процедурные материалы (дерево и мрамор)
  • Отражение и преломление
  • Самосвечение
  • Блеск
  • Степень прозрачности

МТекст (частичный)

Курсивный и полужирный текст не поддерживается

Именованные виды и камеры

Объекты OLE

Лучи и X-линии

Создание сечений и XClipping

Высота текста

Визуальные стили

Поддерживаемые текстовые шрифты

При публикации в файл 3D DWF многие текстовые шрифты не поддерживаются. Шрифты, которые можно публиковать, приведены в следующей таблице.

Поддерживаемые текстовые шрифты

Arial

Arial Black

Comic Sans MS

Courier New

Impact

Lucinda Console

Lucinda Sans Unicode

Martlett

Tahoma

Times New Roman

Verdana

Verdana Italic

Webdings

Wingdings


Публикация 3D DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация 3D DWF
Понятия
Процедуры
Команды

Публикация одного 3D файла DWF

Экспорт в 3D файл DWF

Публикация нескольких файлов 3D DWF или сочетания файлов 2D и 3D DWF

Публикация в 3D файл DWF избранных объектов модели

Просмотр и печать опубликованного 3D файла DWF


Публикация одного 3D файла DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация 3D DWF
Понятия
Процедуры
Команды

Публикация одного 3D файла DWF

  1. В командной строке введите 3dдвф.
  2. В диалоговом окне "Экспорт 3D DWF" задайте имя и местоположение файла DWF. Нажмите кнопку "Сохранить".

    3. По умолчанию все объекты пространства модели публикуются в 3D файл DWF и, если в чертеже содержатся внешние ссылки, опция "Группировать по иерархии внешних ссылок" активизирована.

  3. (Дополнительно) Нажмите "Да", чтобы открыть окно программы просмотра Autodesk DWF Viewer и просмотреть публикуемый 3D файл DWF.

Панель "Стандартная"

Ввод команды: 3DДВФ


Экспорт в 3D файл DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация 3D DWF
Понятия
Процедуры
Команды

Экспорт в 3D файл DWF

  1. Нажмите "Файл" » "Экспорт".
  2. В диалоговом окне "Экспорт данных" задайте имя и местоположение файла DWF.
  3. При необходимости из списка "Типы файлов" выберите "3D DWF (*.dwf)". Нажмите кнопку "Сохранить".

    4. По умолчанию все объекты пространства модели экспортируются в 3D файл DWF и, если в чертеже содержатся внешние ссылки, опция "Группировать по иерархии внешних ссылок" активизирована.

  4. (Дополнительно) Нажмите "Да", чтобы открыть окно программы просмотра Autodesk DWF Viewer и просмотреть публикуемый 3D файл DWF.

Ввод команды: ЭКСПОРТ


Публикация нескольких файлов 3D DWF или сочетания файлов 2D и 3D DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация 3D DWF
Понятия
Процедуры
Команды

Публикация нескольких файлов 3D DWF или сочетания файлов 2D и 3D DWF

  1. Нажмите "Файл" » "Публикация".
  2. В диалоговом окне "Публикация" в группе "Публикуемые листы" выберите листы, которые требуется опубликовать, и измените значение их параметра "Параметры листа / 3D DWF" на "3D DWF".

    3. Управление листами, отображаемыми в группе "Публикуемые листы", осуществляется посредством системной переменной PUBLISHALLSHEETS.

  3. В списке "Вывод при публикации" выберите файл DWF, если он еще не активен.

    4. Примечание В поле "Статус" для выбранного листа отображается "Не будет публиковаться", пока не будет выбран файл формата DWF.

  4. Нажмите "Параметры публикации". В разделе "Общие параметры DWF" для параметра "Тип DWF-файлов" задайте значение "Многолистовые DWF-файлы".
  5. Укажите, требуется ли публикация материалов. Нажмите "ОК".
  6. Нажмите кнопку "Публикация".

Панель "Стандартная"

Ввод команды: ПУБЛ


Публикация в 3D файл DWF избранных объектов модели - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация 3D DWF
Понятия
Процедуры
Команды

Публикация в 3D файл DWF избранных объектов модели

  1. Нажмите "Файл" » "Экспорт".
  2. В диалоговом окне "Экспорт данных" задайте имя и местоположение файла DWF.
  3. Нажмите кнопку "Сервис" в верхнем правом углу окна.
  4. Нажмите "Сервис" » "Настройка".
  5. В диалоговом окне "Публикация 3D DWF" в группе "Объекты для публикации" нажмите "Выбранные объекты пространства модели", а затем кнопку "Выбор объектов".
  6. В пространстве модели выберите объекты, которые требуется опубликовать.
  7. Нажмите клавишу ENTER или ПРОБЕЛ по завершению выбора объектов.
  8. В диалоговом окне "Публикация 3D DWF" нажмите "ОК".
  9. В диалоговом окне "Экспорт данных" нажмите кнопку "Сохранить".
  10. (Не обязательно) Нажмите "Да", чтобы открыть окно программы просмотра Autodesk DWF Viewer и просмотреть публикуемый 3D файл DWF.

Ввод команды: ЭКСПОРТ


Просмотр и печать опубликованного 3D файла DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Публикация 3D DWF
Понятия
Процедуры
Команды

Просмотр и печать опубликованного 3D файла DWF

  1. Для просмотра 3D файла DWF выполнить следующие действия:
    • Непосредственно после публикации 3D файла DWF и отображения запроса "Просмотреть его?" выберите "Да". Файл DWF откроется в Autodesk DWF Viewer.
    • В проводнике Windows дважды нажать кнопку мыши на 3D файле DWF, чтобы запустить Autodesk DWF Viewer и просмотреть файл.
    • Открыть Autodesk DWF Viewer. Нажмите "Файл" » "Открыть". Выберите 3D файл DWF, который необходимо просмотреть.
  2. Если необходимо распечатать 3D файл DWF, в окне Autodesk DWF Viewer нажмите "Файл" » "Печать". Для получения дополнительной информации см. справочную систему Autodesk DWF Viewer.


Публикация 3D DWF - Команды

Публикация чертежей
Публикация чертежей
Публикация 3D DWF
Понятия
Процедуры
Команды

Команды
3DДВФ | Создает 3D DWF-файл пользовательской трехмерной модели и отображает ее в программе просмотра DWF
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
3DDWFPREC | Управляет точностью публикации 3D ДВФ
PUBLISHALLSHEETS | Управляет заполнением списка диалогового окна публикации при выдаче команды ПУБЛ
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка драйвера DWF6 - Понятия

Печать и публикация чертежей
Публикация чертежей
Настройка драйвера DWF6
Понятия
Процедуры
Команды

Изменение настроек драйвера публикаций DWF6 ePlot требуется довольно редко. Но если это действительно нужно, то можно воспользоваться окном свойств этого драйвера для оптимизации вывода. Здесь можно настроить глубину цветности, экранное разрешение, сжатие файла, параметры обработки шрифтов, параметры перьев и другие опции. При создании DWF6-файлов используется файл параметров плоттера, определяющий некоторые особенности формата DWF6. Для печати в файлы формата DWF6 необходимо использовать DWF6 ePlot.pc3.

  • Коротко о создании и редактировании файла параметров DWF6
    Модуль публикаций использует только файл параметров плоттера DWF6 ePlot.pc3. Можно либо воспользоваться настройками по умолчанию входящего в стандартную поставку файла параметров плоттера DWF6 ePlot.pc3, либо внести в него изменения.
  • Задание экранного разрешения DWF-файлов
    Можно установить значение разрешения для векторных и растровых изображений при создании DWF6-файлов.
  • Задание сжатия DWF-файлов
    По умолчанию DWF-файлы создаются в упакованном двоичном формате. Данный формат рекомендуется для большинства файлов DWF.
  • Задание способа обработки шрифтов в файлах DWF
    При создании DWF-файлов имеется возможность задания параметров обработки и включения шрифтов в файл.
  • Редактирование наборов перьев для вывода в DWF-файлы
    В диалоговом окне "Редактирование набора перьев" можно задать узор пера, его толщину, форму, эффекты, а также другие параметры, например, масштабирование и глобальные параметры толщины.


Настройка драйвера DWF6 - Процедуры

Печать и публикация чертежей
Публикация чертежей
Настройка драйвера DWF6
Понятия
Процедуры
Команды

Создание файла параметров плоттера для вывода в файл DWF

Задание или модификация параметров печати в файлы DWF

Задание глубины цветности при печати в файлы DWF

Задание экранного разрешения DWF-файлов

Задание сжатия DWF-файлов

Задание способа обработки шрифтов в файлах DWF

Редактирование списка шрифтов, доступных для включения в DWF-файл

Редактирование наборов перьев для вывода в DWF-файлы


Настройка драйвера DWF6 - Команды

Печать и публикация чертежей
Публикация чертежей
Настройка драйвера DWF6
Понятия
Процедуры
Команды
Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о создании и редактировании файла параметров DWF6 - Понятия

Печать и публикация чертежей
Публикация чертежей
Коротко о создании и редактировании файла параметров DWF6
Понятия
Процедуры
Команды

Модуль публикаций использует только файл параметров плоттера DWF6 ePlot.pc3. Можно либо воспользоваться настройками по умолчанию входящего в стандартную поставку файла параметров плоттера DWF6 ePlot.pc3, либо внести в него изменения, нажав на кнопку "Свойства" в диалоговом окне "Печать". В результате этого открывается редактор рс3-файлов, который позволяет внести непосредственные изменения в файл DWF6 ePlot.pc3. Хотя для использования в команде вывода на печать можно сохранять файлы DWF6 ePlot.pc3 под другими именами, другое имя для команды "Публикация" не подойдет. Все изменения, внесенные в файл DWF6 ePlot.pc3, действуют при выводе на печать или публикаций файлов DWF6, пока параметры DWF6 ePlot.pc3 не будут снова изменены.

Примечание Если планируется внести изменения в файл DWF6 ePlot.pc3, следует вначале создать резервную копию данного файла на тот случай, если впоследствии потребуется вернуться к параметрам по умолчанию. При необходимости исходный файл DWF6 ePlot.pc3 можно восстановить с помощью Мастера установки плоттеров.

Настраивая параметры, можно изменять размер выходного файла и качество печати в зависимости от содержимого исходного чертежа, на основе которого генерируется файл формата DWF™ (Design Web Format™). При редактировании файла параметров DWF6 ePlot.pc3 могут устанавливаться следующие параметры:

  • глубина цветности
  • экранное разрешение
  • режимы сжатия
  • режимы включения в файл и обработки шрифтов
  • цвет фона
  • параметры виртуальных перьев и узоров
  • режим включения в файл информации о слоях
  • режим включения в файл контура границ листа
  • режим включения образца для просмотра

Примечание Если планируется вывод DWF-файлов на печать, необходимо устанавливать в них белый цвет фона. Если задан черный цвет фона, то объекты, имеющие цвет с номером 7, печатаются белыми. При других цветах фона эти же объекты печатаются черным цветом.


Коротко о создании и редактировании файла параметров DWF6 - Процедуры

Печать и публикация чертежей
Публикация чертежей
Коротко о создании и редактировании файла параметров DWF6
Понятия
Процедуры
Команды

Создание файла параметров плоттера для вывода в файл DWF

Задание или модификация параметров печати в файлы DWF

Задание глубины цветности при печати в файлы DWF


Создание файла параметров плоттера для вывода в файл DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Коротко о создании и редактировании файла параметров DWF6
Понятия
Процедуры
Команды

Создание файла параметров плоттера для вывода в файл DWF

  1. Нажмите "Файл" » "Диспетчер плоттеров...".
  2. Дважды нажмите кнопку мыши на ярлыке "Мастер установки плоттеров".
  3. На страничке "Установка плоттера - Введение" нажмите "Далее".
  4. На страничке "Установка плоттера - Начало" выберите "Мой компьютер". Нажмите "Далее".
  5. На страничке "Модель плоттера" в списке "Производители" выберите "Autodesk ePlot (DWF)". В списке "Модели" выберите нужный тип создаваемого DWF6 ePlot-файла. Нажмите "Далее".
  6. (Не обязательно) Если необходимо импортировать уже существующую конфигурацию плоттера, на странице "Импорт PCP или PC2" нажмите "Импорт файла". Выберите файл PCP или PC2 для импорта. Нажмите кнопку "Импорт".
  7. Нажмите "Далее".
  8. На страничке "Порты" установить переключатель в положение "Вывод в файл". Нажмите "Далее".
  9. На странице "Имя плоттера" введите имя файла параметров плоттера. Нажмите "Далее".
  10. На страничке "Окончание" нажмите кнопку "Готово".

    11. Создается новый PC3-файл параметров плоттера.

Ввод команды: ДИСППЕЧ


Задание или модификация параметров печати в файлы DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Коротко о создании и редактировании файла параметров DWF6
Понятия
Процедуры
Команды

Задание или модификация параметров печати в файлы DWF

  1. Нажмите "Файл" » "Печать".
  2. В области "Принтер/плоттер" в списке "Имя" диалогового окна "Печать" выберите устройство печати DWF. Нажмите кнопку "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" на вкладке "Устройство и документ" выделите элемент "Дополнительные свойства" в зоне структуры свойств.
  4. Нажмите кнопку "Дополнительные свойства".
  5. В диалоговом окне "Свойства DWF6 ePlot" выберите необходимые параметры. Нажмите "OK".
  6. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  7. В диалоговом окне "Изменения в файле параметров плоттера" выберите одну из описанных ниже опций. Затем нажмите "OK".
    • "Применить изменения только к текущему чертежу" - если изменение параметров является разовым и не должно сохраняться для последующего использования.
    • "Сохранить изменения в следующем файле" - если необходимо пользоваться измененными параметрами и в дальнейшем.
  8. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Задание глубины цветности при печати в файлы DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Коротко о создании и редактировании файла параметров DWF6
Понятия
Процедуры
Команды

Задание глубины цветности при печати в файлы DWF

  1. Нажмите "Файл" » "Печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите устройство печати DWF. Нажмите кнопку "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" перейти на вкладку "Устройство и документ" и развернуть вложенный список пункта "Графика" в окне дерева.
  4. Нажмите элемент "Векторная графика".
  5. В области "Глубина цветности" укажите глубину цветности. Нажмите "ОК".
  6. В диалоговом окне "Изменения в файле параметров плоттера" выберите одну из описанных ниже опций. Затем нажмите "OK".
    • "Применить изменения только к текущему чертежу" - если изменение параметров является разовым и не должно сохраняться для последующего использования.
    • "Сохранить изменения в следующем файле" - если необходимо пользоваться измененными параметрами и в дальнейшем.
  7. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Коротко о создании и редактировании файла параметров DWF6 - Команды

Публикация чертежей
Публикация чертежей
Коротко о создании и редактировании файла параметров DWF6
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание экранного разрешения DWF-файлов - Понятия

Печать и публикация чертежей
Публикация чертежей
Задание экранного разрешения DWF-файлов
Понятия
Процедуры
Команды

Можно установить значение разрешения для векторных и растровых изображений при создании DWF6-файлов. Чем больше значение разрешения, тем выше точность отображения объектов, но в то же время тем больше размер файла.

Предупреждение Значение разрешения растрового изображения и градиентного разрешения не может превышать значение векторного разрешения.

В следующем списке отображаются значения векторного разрешения и разрешения растрового изображения по умолчанию.

  • Векторное разрешение: 1200 т/д
  • Настраиваемое векторное разрешение: 40000 т/д
  • Градиентное разрешение: 200 т/д
  • Настраиваемое градиентное разрешение: 200 т/д
  • Разрешение цветного и полутонового изображения: 200 т/д
  • Настраиваемое разрешение цветного и полутонового изображения: 200 т/д
  • Разрешение черно-белого изображения: 400 т/д
  • Настраиваемое разрешение черно-белого изображения: 400 т/д

При создании файла DWF, предназначенного для вывода на печать, установленное значение разрешения для этого файла должно совпадать с разрешением устройства печати. Высокие разрешения (более 2400 т/дюйм) предназначены для просмотра чертежей. Например, при создании DWF-файлов чертежей с большим числом элементов, таких как топографическая карта большого региона, рекомендуется задавать более высокое разрешение для качественной детализации. Очень большие значения разрешения (более 40000 т/д) приводят к созданию файлов очень большого размера. Не следует устанавливать такие значения без крайней необходимости. При увеличении значения разрешения увеличивается качество изображения, но уменьшается скорость печати и возрастают требования к объему оперативной памяти.

Чтобы проиллюстрировать различия между возможными значениями экранного разрешения, предположим, что в DWF-файл выводится карта мира. При среднем экранном разрешении максимальное зумирование дает на экране участок, эквивалентный по площади области, провинции или штату; при высоком разрешении - городу. Наилучшее разрешение позволяет рассматривать даже отдельные дома.


Задание экранного разрешения DWF-файлов - Процедуры

Печать и публикация чертежей
Публикация чертежей
Задание экранного разрешения DWF-файлов
Понятия
Процедуры
Команды

Задание экранного разрешения DWF-файлов

  1. Нажмите "Файл" » "Печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите устройство печати DWF. Нажмите кнопку "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" на вкладке "Устройство и документ" выделите элемент "Дополнительные свойства" в зоне структуры свойств.
  4. В группе опций "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".

    5. Примечание Можно ввести целое число между 150 и 100000000 для значения разрешения цветного и полутонового изображения. Это значение не должно превышать текущее значение векторного разрешения.

  5. В области "Векторное и градиентное разрешение (точек на дюйм)" диалогового окна "Свойства DWF6 ePlot" выберите значение из списка "Векторное и градиентное разрешение" или выберите "Настройка" и введите значения параметров вручную. Нажмите "ОК".
  6. В области "Разрешение растрового изображения (точек на дюйм)" диалогового окна "Свойства DWF6 ePlot" выберите значение из списка "Разрешение цветного и полутонового изображения" или выберите "Настройка" и введите значения параметров вручную. Нажмите "ОК".
  7. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  8. В диалоговом окне "Изменения в файле параметров плоттера" выберите одну из описанных ниже опций. Затем нажмите "OK".
    • "Применить изменения только к текущему чертежу" - если изменение параметров является разовым и не должно сохраняться для последующего использования.
    • "Сохранить изменения в следующем файле" - если необходимо пользоваться измененными параметрами и в дальнейшем.
  9. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Задание экранного разрешения DWF-файлов - Команды

Публикация чертежей
Публикация чертежей
Задание экранного разрешения DWF-файлов
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание сжатия DWF-файлов - Понятия

Печать и публикация чертежей
Публикация чертежей
Задание сжатия DWF-файлов
Понятия
Процедуры
Команды

По умолчанию DWF6-файлы создаются в упакованном двоичном формате. Упаковка (сжатие) не вызывает потери данных и рекомендуется к использованию в большинстве случаев. Другой возможный вариант формата - упакованный 2D ASCII-поток (текстовый файл). Уровень сжатия может устанавливаться при создании или редактировании файла параметров DWF-драйвера.


Задание сжатия DWF-файлов - Процедуры

Печать и публикация чертежей
Публикация чертежей
Задание сжатия DWF-файлов
Понятия
Процедуры
Команды

Задание сжатия DWF-файлов

  1. Нажмите "Файл" » "Печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите устройство печати DWF. Нажмите кнопку "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" на вкладке "Устройство и документ" выделите элемент "Дополнительные свойства" в зоне структуры свойств.
  4. В группе опций "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
  5. В поле "Формат DWF" области "Дополнительные настройки вывода" диалогового окна "Свойства DWF6 ePlot" выберите параметр сжатия файла. Нажмите "ОК".
  6. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  7. В диалоговом окне "Изменения в файле параметров плоттера" выберите одну из описанных ниже опций. Затем нажмите "OK".
    • "Применить изменения только к текущему чертежу" - если изменение параметров является разовым и не должно сохраняться для последующего использования.
    • "Сохранить изменения в следующем файле" - если необходимо пользоваться измененными параметрами и в дальнейшем.
  8. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Задание сжатия DWF-файлов - Команды

Публикация чертежей
Публикация чертежей
Задание сжатия DWF-файлов
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание способа обработки шрифтов в файлах DWF - Понятия

Печать и публикация чертежей
Публикация чертежей
Задание способа обработки шрифтов в файлах DWF
Понятия
Процедуры
Команды

При создании DWF-файлов имеется возможность задания параметров обработки и включения шрифтов в DWF6-файл. По умолчанию в диалоговом окне "Свойства DWF6 ePlot" установлен параметр "Включить по выбору"; с его помощью можно выбирать шрифты, включаемые в DWF-файл. Рекомендуется использовать именно эту опцию.

Примечание Размер файла DWF зависит от параметров обработки шрифтов, а также от количества текста, числа и типа используемых шрифтов. Если размер файла слишком велик, рекомендуется изменить параметры обработки шрифтов.


Задание способа обработки шрифтов в файлах DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Задание способа обработки шрифтов в файлах DWF
Понятия
Процедуры
Команды

Задание способа обработки шрифтов в файлах DWF

Редактирование списка шрифтов, доступных для включения в DWF-файл


Задание способа обработки шрифтов в файлах DWF - Процедуры

Печать и публикация чертежей
Публикация чертежей
Задание способа обработки шрифтов в файлах DWF
Понятия
Процедуры
Команды

Задание способа обработки шрифтов в файлах DWF

  1. Нажмите "Файл" » "Печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите устройство печати DWF. Нажмите кнопку "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" на вкладке "Устройство и документ" выделите элемент "Дополнительные свойства" в зоне структуры свойств.
  4. В группе опций "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
  5. В области "Шрифты" диалогового окна "Свойства DWF6 ePlot" выберите параметр включения шрифта. Нажмите "ОК".
  6. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  7. В диалоговом окне "Изменения в файле параметров плоттера" выберите одну из описанных ниже опций. Затем нажмите "OK".
    • "Применить изменения только к текущему чертежу" - если изменение параметров является разовым и не должно сохраняться для последующего использования.
    • "Сохранить изменения в следующем файле" - если необходимо пользоваться измененными параметрами и в дальнейшем.
  8. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Редактирование списка шрифтов, доступных для включения в DWF-файл - Процедуры

Печать и публикация чертежей
Публикация чертежей
Задание способа обработки шрифтов в файлах DWF
Понятия
Процедуры
Команды

Редактирование списка шрифтов, доступных для включения в DWF-файл

  1. Нажмите "Файл" » "Печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите устройство печати DWF. Нажмите кнопку "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" на вкладке "Устройство и документ" выделите элемент "Дополнительные свойства" в зоне структуры свойств.
  4. В группе опций "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
  5. В области "Шрифты" диалогового окна "Свойства DWF6 ePlot" выберите "Включить по выбору".
  6. Нажмите кнопку "Список шрифтов".

    7. Примечание Включение шрифтов в файл DWF приводит к увеличению его размера. Для уменьшения размера файла шрифты TrueType, использующиеся всеми платформами Microsoft® Windows®, по умолчанию не отмечаются в списке. Несмотря на то, что рядом с этими шрифтами нет пометки, они правильно отображаются в DWF6-файле, просматриваемом в операционной системе Windows. Необходимо отметить все остальные установленные шрифты True Type, чтобы удостовериться, что они будут включены в DWF6. В файл включаются только необходимые шрифты.

  7. В диалоговом окне "Шрифты TrueType" выберите шрифты, которые необходимо включить в файл DWF. Нажмите "ОК".
  8. В диалоговом окне "Свойства DWF6 ePlot" нажмите "ОК".
  9. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  10. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Задание способа обработки шрифтов в файлах DWF - Команды

Публикация чертежей
Публикация чертежей
Задание способа обработки шрифтов в файлах DWF
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование наборов перьев для вывода в DWF-файлы - Понятия

Печать и публикация чертежей
Публикация чертежей
Редактирование наборов перьев для вывода в DWF-файлы
Понятия
Процедуры
Команды

В диалоговом окне "Редактирование набора перьев" можно задать узор пера, его толщину, форму, эффекты, а также другие параметры, например, масштабирование и глобальные параметры толщины. Изменения, произведенные в диалоговом окне "Редактирование набора перьев", сохраняются в файле параметров плоттера.

Примечание Для редактирования узоров перьев и других параметров в файле параметров DWF6 ePlot выберите глубину цветности "255 виртуальных перьев".


Редактирование наборов перьев для вывода в DWF-файлы - Процедуры

Печать и публикация чертежей
Публикация чертежей
Редактирование наборов перьев для вывода в DWF-файлы
Понятия
Процедуры
Команды

Редактирование наборов перьев для вывода в DWF-файлы

  1. Нажмите "Файл" » "Печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите устройство печати DWF. Нажмите кнопку "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" перейдите на вкладку "Устройство и документ" и разверните вложенный список пункта "Графика" в окне структуры. Выберите "Векторная графика". В группе параметров "Глубина цветности" выберите в раскрывающемся списке "255 виртуальных перьев". Затем в зоне структуры свойств выберите элемент "Дополнительные свойства".
  4. В группе опций "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
  5. В диалоговом окне "Свойства DWF6 ePlot" нажмите "Правка".
  6. В диалоговом окне "Редактирование набора перьев" нажмите правую кнопку мыши на нужном поле.
  7. Из контекстного меню выберите одну из стандартных настроек или пункт "Свойства" для вывода диалогового окна свойств пера, в котором можно изменять свойства каждого пера индивидуально.
  8. В диалоговом окне свойств пера нажмите "ОК".
  9. В диалоговом окне "Редактирование набора перьев" нажмите "ОК".
  10. В диалоговом окне "Свойства DWF6 ePlot" нажмите "ОК".
  11. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  12. В диалоговом окне "Изменения в файле параметров плоттера" установите переключатель в одно из перечисленных ниже положений:
    • "Применить изменения только к текущему чертежу".
    • "Сохранить изменения в следующем файле". (Ввести имя файла.)
  13. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".

Панель "Стандартная"

Ввод команды: ПЕЧАТЬ


Редактирование наборов перьев для вывода в DWF-файлы - Команды

Публикация чертежей
Публикация чертежей
Редактирование наборов перьев для вывода в DWF-файлы
Понятия
Процедуры
Команды

Команды
ДИСППЕЧ | Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера
ПАРАМЛИСТ | Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Совместное использование данных в чертежах и приложениях

Внешние ссылки
Имеется возможность вставки в текущий чертеж целого чертежа в качестве внешней ссылки. Внешняя ссылка обеспечивает внесение в текущий чертёж изменений, сделанных в исходном чертеже.

Составные документы и технология OLE
С помощью технологии связывания и внедрения объектов (OLE), реализованной в Microsoft Windows, можно копировать и размещать информацию из одного приложения в другое, сохраняя возможность редактирования ее в исходном приложении.

Работа с данными других форматов
Можно работать с различными графическими файлами, которые могут быть созданы в других приложениях или в более ранних версиях программы. Кроме того, можно задать пути к папкам, в которых происходит поиск чертежей или вспомогательных файлов.

Внешние базы данных
С графическими объектами чертежа можно связывать данные из внешних баз данных.


Совместное использование данных в чертежах и приложениях - Понятия

Совместное использование данных в чертежах и приложениях
Совместное использование данных в чертежах и приложениях
Совместное использование данных в чертежах и приложениях
Понятия
Процедуры
Команды

С текущим чертежом можно связывать другие чертежи в качестве внешних ссылок. Обновления в исходном чертеже, вставленном в качестве внешней ссылки, отражаются в тех чертежах, где он используется.

Глава 33 Составные документы и технология OLE Составные документы и технология OLE

С помощью технологии связывания и внедрения объектов (OLE) можно копировать и перемещать информацию из одного приложения в другое, сохраняя возможность редактирования ее в исходном приложении.

Глава 34 Работа с данными других форматов Работа с данными других форматов

Имеется возможность работы с файлами различных типов, включая файлы, созданные другими приложениями или в более ранних версиях AutoCAD и AutoCAD LT. Кроме того, можно задать пути к папкам, в которых происходит поиск чертежей или вспомогательных файлов.

Внешние базы данных

С графическими объектами чертежа можно связывать данные из внешних баз данных.


Совместное использование данных в чертежах и приложениях - Процедуры

Совместное использование данных в чертежах и приложениях
Совместное использование данных в чертежах и приложениях
Совместное использование данных в чертежах и приложениях
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Совместное использование данных в чертежах и приложениях - Команды

Совместное использование данных в чертежах и приложениях
Совместное использование данных в чертежах и приложениях
Совместное использование данных в чертежах и приложениях
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Внешние ссылки - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Понятия
Процедуры
Команды

Имеется возможность вставки в текущий чертеж целого чертежа в качестве внешней ссылки. Внешняя ссылка обеспечивает внесение в текущий чертёж изменений, сделанных в исходном чертеже.

Имеется возможность вставки в текущий чертеж целого чертежа в качестве внешней ссылки. Внешняя ссылка обеспечивает внесение в текущий чертёж изменений, сделанных в исходном чертеже. Внешние ссылки устанавливают лишь связь с другими чертежами без вставки содержимого самих чертежей. Таким образом, можно добавлять элементы в чертеж, не увеличивая значительно его размера.

  • Коротко о внешних ссылках
  • Вставка и удаление вхождений чертежей
    Можно выполнять некоторые операции с файлами чертежей, на которые была произведена ссылка. Среди них - вставка, задание пути и удаление.
  • Обновление и внедрение внешних чертежей
    Кроме вставки и удаления вхождений чертежей (внешних ссылок), их можно обновлять и внедрять.
  • Понятие о контурах подрезки
    Контуры подрезки используются для отображения особых участков вставленных внешних чертежей или блоков.
  • Редактирование внешних чертежей
    Вставленные в качестве внешних ссылок чертежи можно редактировать, открыв их непосредственно или редактируя внешнюю ссылку по месту, из текущего чертежа. Можно также редактировать описание блока непосредственно через любое его вхождение.
  • Ошибки обработки чертежей-ссылок
    Если при открытии чертежа не удается загрузить чертеж-внешнюю ссылку, то появляется сообщение об ошибке.
  • Увеличение производительности при работе с большими внешними чертежами
    Имеется несколько функций, которые могут повысить производительность при работе с большими чертежами, вставленными в качестве внешних ссылок.

См. также

Центр управления DesignCenter


Внешние ссылки - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Понятия
Процедуры
Команды

Вставка внешней ссылки

Вставка или наложение внешней ссылки с помощью центра управления DesignCenter

Просмотр файлов ссылок по типу на палитре "Внешние ссылки"

Изменение пути к вхождению DWG

Просмотр имен имеющихся проектов

Добавление имени проекта

Удаление имени проекта

Изменение имени проекта

Добавление пути доступа

Удаление пути доступа

Изменение пути доступа

Установка проекта текущим

Отмена установки проекта текущим

Удаление внешней ссылки

Наложение внешней ссылки

Обновление вставленной внешней ссылки

Внедрение внешней ссылки в текущий чертеж

Подрезка ссылки

Редактирование внешней ссылки в отдельном окне

Редактирование внешней ссылки или блока в контексте чертежа

Добавление объектов в рабочий набор

Исключение объектов из рабочего набора

Сохранение изменений в результате редактирования внешних ссылок и блоков

Отказа от изменений внешних ссылок и блоков

Изменение пути ко внешней ссылке

Внедрение зависимых от ссылок именованных объектов в текущий чертеж

Переименование слоев, размерных стилей и других именованных объектов

Использование файла журнала внешних ссылок

Выгрузка внешней ссылки

Включение режима подгрузки ссылок

Сохранение чертежа с пространственным и слоевым указателями

Задание пути к копиям файлов внешних ссылок


Внешние ссылки - Команды

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Понятия
Процедуры
Команды
Команды
TRAYSETTINGS | Управление отображением значков и уведомлений на панели строки состояния
БАЗА | Задание базовой точки вставки для текущего чертежа
ВНЕДРИТЬ | Внедрение одного или нескольких описаний именованных объектов во внешней ссылке в текущий чертеж
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ВНССЫЛКИЗАКРЫТЬ | Закрывает палитру внешних ссылок
НОВОЕИМЯ | Изменяет имена именованных объектов
РЕЖИМРАСКР | Запускает команду ТЕКВИЗСТИЛЬ
ССВСТАВИТЬ | Вставка внешних ссылок в текущий чертеж
ССОТКРЫТЬ | Открывает выбранную внешнюю ссылку на чертеж (xref) в новом окне
ССПОДРЕЗАТЬ | Задание контура подрезки, а также передней и задней плоскости подрезки для внешней ссылки или блока
ССЫЛЗАКР | Сохранение или отказ от изменений, произведенных в ходе редактирования вхождений блоков и ссылок
ССЫЛКА | Запуск команды ВНССЫЛКИ
ССЫЛНАБ | Добавление и исключение объектов из рабочего набора при редактировании вхождений блоков и ссылок
ССЫЛРЕД | Выбирает внешнюю ссылку или вхождение блока для редактирования
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
BINDTYPE | Управление обработкой имен внешних ссылок при внедрении или редактировании внешних ссылок.
ERSTATE | Определяет активность палитры внешних ссылок
INDEXCTL | Управляет созданием слоевых и пространственных индексов и сохранением их в файле чертежа
INSBASE | Сохраняет базовую точку вставки, установленную с помощью команды БАЗА, в текущей ПСК текущего пространства
PROJECTNAME | Присваивает имя проекта текущему чертежу
REFEDITNAME | Отображает имя редактируемого вхождения
TRAYICONS | Управляет отображением панели в строке состояния
TRAYNOTIFY | Управляет отображением уведомлений служб в панели строки состояния
TRAYTIMEOUT | Управляет временем (в секундах), в течение которого отображаются уведомления служб
TREEDEPTH | Указывает максимальное количество ветвлений древовидного пространственного индекса
TREEMAX | Снижает использование памяти при регенерации чертежа путем ограничения числа узлов в пространственном индексе (дерево октантов)
VISRETAIN | Управляет свойствами зависимых от внешних ссылок слоев.
XCLIPFRAME | Управляет видимостью контуров подрезки внешних ссылок
XEDIT | Управляет возможностью редактирования текущего чертежа на месте при использовании его в качестве внешней ссылки
XFADECTL | Управляет процентом интенсивности затенения для редактируемых ссылок
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
XLOADPATH | Создает путь для хранения временных копий файлов подгруженных внешних ссылок
XREFCTL | Управляет созданием файлов журналов внешних ссылок (XLG)
XREFNOTIFY | Управляет уведомлением для обновленных или отсутствующих внешних ссылок
XREFTYPE | Управляет типом ссылки по умолчанию при вставке или наложении внешней ссылки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о внешних ссылках - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Коротко о внешних ссылках
Понятия
Процедуры
Команды

Имеется возможность вставки в текущий чертеж целого чертежа в качестве внешней ссылки. Внешняя ссылка обеспечивает внесение в текущий чертёж изменений, сделанных в исходном чертеже. Внешние ссылки устанавливают лишь связь с другими чертежами без вставки содержимого самих чертежей. Таким образом, можно добавлять элементы в чертеж, не увеличивая значительно его размера.

За счет вставки чертежей в виде внешних ссылок можно осуществлять следующие действия:

  • Координировать свои действия с действиями других разработчиков, ссылаясь на другие чертежи и учитывая изменения, произведенные в них другими участниками проекта. Имеется также возможность собирать главный чертеж из фрагментов, которые могут изменяться в ходе разработки проекта.
  • Гарантировать наличие на экране последних версий фрагментов чертежей. При открытии чертежа производится автоматическая повторная загрузка всех чертежей, вставленных в качестве внешних ссылок, таким образом, чертеж всегда отражает самые последние изменения, внесенные в связанный файл чертежа.
  • Логически разделять имена слоев, размерных стилей, текстовых стилей и других именованных элементов главного чертежа и связанных с ним чертежей.
  • Осуществлять постоянное объединение (внедрение) связанных чертежей с текущим чертежом по завершению проекта и его готовности к архивации.

Примечание Как и блок, внешняя ссылка представляет собой в текущем чертеже единый объект. Однако внешнюю ссылку нельзя расчленить, предварительно ее не внедрив.

См. также

Центр управления DesignCenter


Внешние ссылки

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Внешние ссылки
Понятия
Процедуры
Команды

Нет процедур.


Коротко о внешних ссылках - Команды

Внешние ссылки
Внешние ссылки
Коротко о внешних ссылках
Понятия
Процедуры
Команды

Команды
БАЗА | Задание базовой точки вставки для текущего чертежа
ВНЕДРИТЬ | Внедрение одного или нескольких описаний именованных объектов во внешней ссылке в текущий чертеж
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ВНССЫЛКИЗАКРЫТЬ | Закрывает палитру внешних ссылок
ССВСТАВИТЬ | Вставка внешних ссылок в текущий чертеж
ССПОДРЕЗАТЬ | Задание контура подрезки, а также передней и задней плоскости подрезки для внешней ссылки или блока
ССЫЛЗАКР | Сохранение или отказ от изменений, произведенных в ходе редактирования вхождений блоков и ссылок
ССЫЛКА | Запуск команды ВНССЫЛКИ
ССЫЛНАБ | Добавление и исключение объектов из рабочего набора при редактировании вхождений блоков и ссылок
ССЫЛРЕД | Выбирает внешнюю ссылку или вхождение блока для редактирования
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
BINDTYPE | Управление обработкой имен внешних ссылок при внедрении или редактировании внешних ссылок.
ERSTATE | Определяет активность палитры внешних ссылок
INDEXCTL | Управляет созданием слоевых и пространственных индексов и сохранением их в файле чертежа
INSBASE | Сохраняет базовую точку вставки, установленную с помощью команды БАЗА, в текущей ПСК текущего пространства
PROJECTNAME | Присваивает имя проекта текущему чертежу
VISRETAIN | Управляет свойствами зависимых от внешних ссылок слоев.
XCLIPFRAME | Управляет видимостью контуров подрезки внешних ссылок
XEDIT | Управляет возможностью редактирования текущего чертежа на месте при использовании его в качестве внешней ссылки
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
XLOADPATH | Создает путь для хранения временных копий файлов подгруженных внешних ссылок
XREFNOTIFY | Управляет уведомлением для обновленных или отсутствующих внешних ссылок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вставка и удаление вхождений чертежей - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Вставка и удаление вхождений чертежей
Понятия
Процедуры
Команды

Можно выполнять некоторые операции с файлами чертежей, на которые была произведена ссылка. Среди них - вставка, задание пути и удаление.

  • Вставка вхождений чертежей (внешних ссылок)
    Если чертеж вставляется в качествевнешней ссылки, осуществляется его привязка к текущему чертежу; любые изменения в чертеже, на который есть ссылка, отображаются в текущем чертеже при его открытии или повторной загрузке.
  • Задание путей к внешним чертежам
    При поиске конкретной внешней ссылки чертежа можно просматривать и изменять имя файла и путь к нему. Эта возможность полезна, если файл ссылки был перемещён в другую папку или переименован после того, как он был вставлен впервые.
  • Удаление вхождений чертежей
    Для окончательного удаления вхождения DWG (внешней ссылки) из чертежа простого ее стирания недостаточно.


Вставка и удаление вхождений чертежей - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Вставка и удаление вхождений чертежей
Понятия
Процедуры
Команды

Вставка внешней ссылки

Вставка или наложение внешней ссылки с помощью центра управления DesignCenter

Просмотр файлов ссылок по типу на палитре "Внешние ссылки"

Изменение пути к вхождению DWG

Просмотр имен имеющихся проектов

Добавление имени проекта

Удаление имени проекта

Изменение имени проекта

Добавление пути доступа

Удаление пути доступа

Изменение пути доступа

Установка проекта текущим

Отмена установки проекта текущим

Удаление внешней ссылки


Вставка и удаление вхождений чертежей - Команды

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Вставка и удаление вхождений чертежей
Понятия
Процедуры
Команды
Команды
TRAYSETTINGS | Управление отображением значков и уведомлений на панели строки состояния
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ВНССЫЛКИЗАКРЫТЬ | Закрывает палитру внешних ссылок
ССВСТАВИТЬ | Вставка внешних ссылок в текущий чертеж
ССЫЛКА | Запуск команды ВНССЫЛКИ
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
ERSTATE | Определяет активность палитры внешних ссылок
INDEXCTL | Управляет созданием слоевых и пространственных индексов и сохранением их в файле чертежа
PROJECTNAME | Присваивает имя проекта текущему чертежу
TRAYICONS | Управляет отображением панели в строке состояния
TRAYNOTIFY | Управляет отображением уведомлений служб в панели строки состояния
TRAYTIMEOUT | Управляет временем (в секундах), в течение которого отображаются уведомления служб
VISRETAIN | Управляет свойствами зависимых от внешних ссылок слоев.
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
XLOADPATH | Создает путь для хранения временных копий файлов подгруженных внешних ссылок
XREFNOTIFY | Управляет уведомлением для обновленных или отсутствующих внешних ссылок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вставка вхождений чертежей (внешних ссылок) - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Вставка вхождений чертежей (внешних ссылок)
Понятия
Процедуры
Команды

Если чертеж вставляется в качествевнешней ссылки, осуществляется его привязка к текущему чертежу; любые изменения в чертеже, на который есть ссылка, отображаются в текущем чертеже при его открытии или повторной загрузке.

Чертеж может быть вставлен в качестве ссылки сразу в несколько чертежей. И наоборот, в один чертеж можно вставить несколько внешних ссылок.

Примечание Объекты во внешней ссылке, вставленной в текущий чертёж, являются объектами только пространства модели. Внешнюю ссылку можно вставить в текущий чертёж либо в пространстве модели, либо в пространстве листа. Местоположение внешней ссылки, масштаб и ориентация могут быть произвольными.

Средства вставки внешних ссылок

Для вставки внешних ссылок используется команда ВНССЫЛКИ, открывающая палитру "Внешние ссылки", команда ССВСТАВИТЬ или производится выбор пункта "Вхождение DWG" меню "Вид".

Также для вставки внешних ссылок в чертеж можно использовать центр управления DesignCenter™. С его помощью процедура вставки упрощается, так как он позволяет не только просматривать вхождения чертежей и пояснения к ним, но и быстро вставлять внешние ссылки в чертеж путем простого перетаскивания.

Можно вставить внешнюю ссылку, перетащив ее из DesignCenter или выбрав "Вставить как внешнюю ссылку" из контекстного меню.

Сохраненный путь ссылки может быть абсолютным (полным), относительным (указанным частично) или пустым.

Если внешняя ссылка содержит какие-либо переменные атрибуты блоков, они игнорируются.

Примечание При работе с палитрой "Внешние ссылки" рекомендуется активизировать функцию автоматического скрытия или прикрепить палитру якорем. При указании точки вставки внешней ссылки палитра будет автоматически убираться с экрана.

Уведомление о внешних ссылках

В правом нижнем углу окна приложения (в строке состояния) размещается значок, свидетельствующий о наличии в чертеже внешних ссылок.

Если по адресу, указанному во внешней ссылке, не обнаружен чертеж или если ссылка должна быть обновлена, на значке ссылки появляется восклицательный знак. При нажатии на значке внешних ссылок открывается палитра "Внешние ссылки".

Видимость, цвет и тип линий

Можно включать и отключать слои внешних ссылок, а также задавать для них цвет, тип линий и другие свойства. Вносимые изменения могут быть временными или постоянными. Если значение системной переменной VISRETAIN приравнено к 0, эти изменения относятся только к текущему сеансу работы с чертежом. Значения свойств восстанавливаются по завершению сеанса работы или при повторной загрузке или удалении внешней ссылки.

Подрезка внешних ссылок контурами

Чертежи могут содержать подрезанные внешние ссылки. Для вывода контура подрезки следует включить системную переменную XCLIPFRAME.

Работа в режиме "Интерфейс единственного документа"

Управление внешними ссылками происходит иным способом при работе в режиме интерфейса единственного документа.

Если в качестве режима работы выбирается режим интерфейса единственного документа (SDI), палитра "Внешние ссылки" недоступна для целей управления связанными с чертежом вхождениями файлов. Режим интерфейса единственного документа устанавливается с помощью системной переменной SDI.

Если на момент включения режима SDI палитра "Внешние ссылки" выведена на экран, она остается видимой, но становится неактивной. Единственный доступный элемент управления позволяет только закрыть или скрыть палитру.

Попытка открыть палитру "Внешние ссылки" приводит к открытию оставшегося из прежних версий диалогового окна "Диспетчер внешних ссылок". "Диспетчер внешних ссылок" также открывает команда ССЫЛКА. Палитру "Внешние ссылки" можно восстановить, задав для системной переменной SDI значение 0 (ноль).

Вставка из учебных версий приложений

Если открыть, вставить или добавить внешнюю ссылку, созданную в учебной версии приложения Autodesk, то при выводе чертежей на печать на чертеже появится надпись: “СОЗДАНО УЧЕБНОЙ ВЕРСИЕЙ ПРОДУКТА AUTODESK. ”

См. также

Вложенные и наложенные внешние чертежи.

Подрезка внешних чертежей и блоков

Задание путей к внешним чертежам

Центр управления DesignCenter

Задание параметров интерфейса


Вставка вхождений чертежей (внешних ссылок) - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Вставка вхождений чертежей (внешних ссылок)
Понятия
Процедуры
Команды

Вставка внешней ссылки

Вставка или наложение внешней ссылки с помощью центра управления DesignCenter

Просмотр файлов ссылок по типу на палитре "Внешние ссылки"


Вставка внешней ссылки - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Вставка вхождений чертежей (внешних ссылок)
Понятия
Процедуры
Команды

Вставка внешней ссылки

  1. Нажмите "Вставка" » "Вхождение DWG".
  2. В диалоговом окне "Выбор файла внешней ссылки" выберите файл для вставки. Нажмите кнопку "Открыть".
  3. В поле "Тип ссылки" диалогового окна "Внешняя ссылка" выберите тип ссылки "Вставленная".
  4. Задайте точку вставки, масштаб и угол поворота. Для того чтобы задать какой-либо параметр с помощью устройства указания, нужно установить флажок "Указать на экране" в соответствующей группе опций.

    5. Чертеж вставляется вместе со всеми вложенными в него внешними ссылками.

  5. Нажмите "ОК".

Панель "Ссылки"

Ввод команды: ССВСТАВИТЬ


Вставка или наложение внешней ссылки с помощью центра управления DesignCenter - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Вставка вхождений чертежей (внешних ссылок)
Понятия
Процедуры
Команды

Вставка или наложение внешней ссылки с помощью центра управления DesignCenter

  1. Нажмите "Сервис" » "Палитры" » "DesignCenter".
  2. В диалоговом окне "Поиск" в области содержимого выделите вхождение DWG, которое требуется вставить или наложить.
  3. Нажмите правую кнопку мыши. Перетащите вхождение DWG в открытый чертеж.
  4. Отпустите правую кнопку мыши. В контекстном меню выберите "Вставить как ссылку".
  5. В поле "Тип ссылки" диалогового окна "Внешняя ссылка" выберите "Вставленная" или "Наложенная".
  6. Задайте точку вставки, масштаб и угол поворота. Для любого из этих параметров можно поднять флажок "Указать на экране"; это сигнализирует о том, что параметр будет задан с помощью устройства указания.
  7. Нажмите "ОК".

    8. Можно также вставить внешнюю ссылку, перетащив ее или выбрав в контекстном меню "Вставить как внешнюю ссылку".

  8. Нажмите "ОК".

Панель "Стандартная"

Ввод команды: ЦУВКЛ


Просмотр файлов ссылок по типу на палитре "Внешние ссылки" - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Вставка вхождений чертежей (внешних ссылок)
Понятия
Процедуры
Команды

Просмотр файлов ссылок по типу на палитре "Внешние ссылки"

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки", на панели "Файл ссылок", нажмите кнопку "Просмотр списка".
  3. Нажмите кнопку мыши на столбце "Значок".

    4. Соответствующие ссылочные файлы сортируются в списке по типу.

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ


Вставка вхождений чертежей (внешних ссылок) - Команды

Внешние ссылки
Внешние ссылки
Вставка вхождений чертежей (внешних ссылок)
Понятия
Процедуры
Команды

Команды
TRAYSETTINGS | Управление отображением значков и уведомлений на панели строки состояния
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ВНССЫЛКИЗАКРЫТЬ | Закрывает палитру внешних ссылок
ССВСТАВИТЬ | Вставка внешних ссылок в текущий чертеж
ССЫЛКА | Запуск команды ВНССЫЛКИ
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
Системные переменные
ERSTATE | Определяет активность палитры внешних ссылок
INDEXCTL | Управляет созданием слоевых и пространственных индексов и сохранением их в файле чертежа
TRAYICONS | Управляет отображением панели в строке состояния
TRAYNOTIFY | Управляет отображением уведомлений служб в панели строки состояния
TRAYTIMEOUT | Управляет временем (в секундах), в течение которого отображаются уведомления служб
VISRETAIN | Управляет свойствами зависимых от внешних ссылок слоев.
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
XLOADPATH | Создает путь для хранения временных копий файлов подгруженных внешних ссылок
XREFNOTIFY | Управляет уведомлением для обновленных или отсутствующих внешних ссылок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание путей к внешним чертежам - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Имя файла и путь к нему, используемые программой при поиске ссылки чертежа, можно просматривать и изменять. Эта возможность полезна, если файл ссылки был перемещён в другую папку или переименован после того, как он был вставлен впервые.

Существует три типа путей к папке, используемых во внешней ссылке: абсолютный путь, относительный путь и "без пути".

Задание абсолютного пути

Абсолютный путь представляет собой полностью определенное дерево папок, ведущее к файлу ссылки. В абсолютный путь входит имя локального диска, URL-адрес сайта в Интернете или имя диска сетевого сервера. Это наиболее точный, но негибкий способ задания пути.

Задание относительного пути

Относительные пути - это лишь частично определенные иерархии папок, задаваемые относительно текущего чертежа (папки, в которой он хранится). Это наиболее гибкий способ описания пути, позволяющий перенести всю структуру папок с чертежами на другой жесткий диск.

Если файл, на который есть ссылка, находится на другом жёстком диске или сетевом сервере, возможность использования относительного пути недоступна.

Правила формирования относительных путей таковы:

\

Корневая папка жесткого диска, на котором находится текущий чертеж

путь

Путь, начиная от папки, в которой находится текущий чертеж

\путь

Путь, начиная от корневой папки

.\путь

Путь, начиная от папки, в которой находится текущий чертеж

..\путь

Путь, начиная от папки, лежащей уровнем выше папки текущего чертежа

..\..\путь

Путь, начиная от папки, лежащей двумя уровнями выше папки текущего чертежа

Примечание Если чертёж, содержащий файлы ссылок, перемещён или сохранён по другому пути, на другой локальный жёсткий диск или на другой сетевой сервер, необходимо отредактировать все относительные пути, чтобы привести их в соответствие с новым расположением чертежа, или изменить местонахождение файлов ссылок.

Задание пустого пути

В случае, если вместе со внешней ссылкой не сохранена информация о пути, программа предпринимает поиск. Он происходит в следующем порядке.

  • Текущая папка главного чертежа
  • Пути поиска файлов проекта, заданные в диалоговом окне "Настройка" (вкладка "Файлы") или с помощью системной переменной PROJECTNAME
  • Пути поиска вспомогательных файлов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Папка запуска, указанная в ярлыке приложения Microsoft® Windows®

Задание пустого пути удобно при перемещении набора чертежей в другую структуру папок, а также в тех случаях, когда структура папок неизвестна.

Информация о переносе внешнего чертежа

Если редактируемый чертеж содержит внешнюю ссылку на файл, который был перемещен в другую папку, при загрузке чертежа появится сообщение об изменении пути внешней ссылки. Сообщение говорит о том, что внешняя ссылка не может быть загружена по старому пути. После указания нового пути будет произведена повторная загрузка внешней ссылки в чертеж.

Задание пути к внешнему чертежу по имени проекта

Задание имен проектов в настройках продукта упрощает работу с внешними ссылками в случаях, когда разработчики активно обмениваются чертежами, а также если используемый совместно ресурс сервера сети отображается на различные локальные диски рабочих станций. Имя проекта указывает на отдельный раздел системного реестра, в который записываются один или несколько путей поиска относящихся к проекту файлов.

Если программа не находит внешнюю ссылку в папке по указанному пути, от имени ссылки отделяются все префиксы (если они имеются). Если для чертежа установлено значение системной переменной PROJECTNAME (т.е. чертеж является частью какого-либо проекта) и в реестре имеется соответствующая запись, программа выполняет поиск файла во всех папках данного проекта. Если после этого внешняя ссылка все еще не найдена, программа будет искать ее в своих стандартных папках.

Имеется возможность создавать, удалять и изменять занесенные в реестр имена проектов. Те же операции можно производить и с именами путей к файлам проектов.

Пути доступа к файлам проектов можно добавлять, удалять и изменять точно так же, как и имена проектов. Порядок просмотра папок можно изменить. Редактирование путей доступа к проектам можно выполнить только на вкладке "Файлы" диалогового окна "Настройка". Средства работы с ними в командной строке отсутствуют.

Проект, для которого заданы имя и пути доступа к файлам, в любой момент может быть установлен текущим. Программа выполняет поиск внешних ссылок, не обнаруженных при поиске по полному пути, в папке текущего чертежа или папках программы, используя пути доступа к текущему проекту.

Расширенные возможности изменения путей поиска для нескольких чертежей

При переносе файлов чертежей или внешних файлов, на которые они ссылаются, включая другие файлы чертежей, шрифты текстов, изображения и параметры плоттеров, пути поиска, сохраняемые в чертеже, требуют обновления. "Диспетчер ссылок" Autodesk приводит перечень файлов, на которые произведена ссылка из выбранных чертежей, и обеспечивает инструментами изменения сохраненных путей поиска без необходимости в открытии каждого файла чертежа. Также "Диспетчер ссылок" можно использовать для выявления и устранения необработанных ссылок.

"Диспетчер ссылок" представляет собой автономное приложение с собственной справочной системой. Доступ к нему можно получить из меню "Пуск"(Windows) » "(Все) Программы" » "Autodesk" » "AutoCAD" » "Диспетчер ссылок". При работе в сети он может быть не установлен на локальном компьютере.

Предупреждение "Диспетчер ссылок", прежде всего, предназначен для специалистов по САПР, которые точно осведомлены о местоположениях файлов проекта. Он позволяет одновременно изменить несколько путей, отмена результатов его действий невозможна. Необходимо быть предельно осторожным, в особенности при работе в сети.


Задание путей к внешним чертежам - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Изменение пути к вхождению DWG

Просмотр имен имеющихся проектов

Добавление имени проекта

Удаление имени проекта

Изменение имени проекта

Добавление пути доступа

Удаление пути доступа

Изменение пути доступа

Установка проекта текущим

Отмена установки проекта текущим


Изменение пути к вхождению DWG - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Изменение пути к вхождению DWG

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" выберите имя внешнего чертежа.
  3. В группе "Найдено в" выполните одно из следующих действий:
    • Введите новый путь непосредственно к внешней ссылке.
    • Нажмите кнопку "Обзор". Выберите внешнюю ссылку по новому пути.
  4. Нажмите "ОК".

    5. Программа загрузит внешнюю ссылку и регенерирует чертеж с обновленной внешней ссылкой.

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ


Просмотр имен имеющихся проектов - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Просмотр имен имеющихся проектов

  1. Нажмите "Сервис" » "Настройки".
  2. На вкладке "Файлы" диалогового окна "Параметры" дважды нажмите кнопку мыши на элементе "Путь доступа к файлам проектов".
  3. Нажмите имя нужного проекта, чтобы просмотреть заданные для него пути доступа.
  4. Нажмите кнопку "OK" (или "Применить").


Добавление имени проекта - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Добавление имени проекта

  1. Нажмите "Сервис" » "Настройки".
  2. На вкладке "Файлы" диалогового окна "Параметры" дважды нажмите кнопку мыши на элементе "Путь доступа к файлам проектов". Нажмите "Добавить".

    3. AutoCAD создает новую папку проекта с именем projectx (где x - следующий доступный номер).

  3. Введите новое имя или нажмите ENTER для подтверждения имени projectx.

    4. Длина имени проекта должна быть не более 31 символа; оно не может начинаться с пробелов или заканчиваться ими.

  4. Нажмите кнопку "OK" (или "Применить").


Удаление имени проекта - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Удаление имени проекта

  1. Нажмите "Сервис" » "Настройки".
  2. На вкладке "Файлы" диалогового окна "Параметры" дважды нажмите кнопку мыши на элементе "Путь доступа к файлам проектов".
  3. Выберите имя проекта. Нажмите кнопку "Исключить".
  4. Нажмите кнопку "OK" (или "Применить").


Изменение имени проекта - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Изменение имени проекта

  1. Нажмите "Сервис" » "Настройки".
  2. На вкладке "Файлы" диалогового окна "Параметры" выберите имя проекта. Введите новое имя.
  3. Нажмите кнопку "OK" (или "Применить").

    4. Также можно изменить имя проекта, выбрав имя в папке проекта и нажав клавишу F2.


Добавление пути доступа - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Добавление пути доступа

  1. Нажмите "Сервис" » "Настройки".
  2. На вкладке "Файлы" диалогового окна "Параметры" выберите имя проекта. Нажмите "Добавить".
  3. Под именем проекта введите новый путь или выберите его, нажав кнопку "Обзор".
  4. Нажмите кнопку "OK" (или "Применить").

    5. Новый путь записывается с отступом под выбранным именем проекта.


Удаление пути доступа - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Удаление пути доступа

  1. Нажмите "Сервис" » "Настройки".
  2. На вкладке "Файлы" диалогового окна "Параметры" выберите имя проекта. Выберите "Исключить".
  3. Нажмите "ОК".


Изменение пути доступа - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Изменение пути доступа

  1. Нажмите "Сервис" » "Настройки".
  2. На вкладке "Файлы" диалогового окна "Параметры" выберите имя проекта. Нажмите кнопку "Обзор".
  3. В окне обзора выберите нужную папку.
  4. Нажмите "OK" для закрытия каждого диалогового окна.

    5. Путь доступа к проекту можно также изменить, если выделить его и нажать F2.


Установка проекта текущим - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Установка проекта текущим

  1. Нажмите "Сервис" » "Настройки".
  2. На вкладке "Файлы" диалогового окна "Параметры" дважды нажмите кнопку мыши на элементе "Путь доступа к файлам проектов".
  3. Выберите имя проекта. Нажмите кнопку "Установить".
  4. Нажмите кнопку "OK" (или "Применить").

    5. Для установки текущего проекта можно также ввести в командной строке projectname, а затем имя проекта.


Отмена установки проекта текущим - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Отмена установки проекта текущим

  1. Нажмите "Сервис" » "Настройки".
  2. На вкладке "Файлы" диалогового окна "Параметры" укажите элемент "Путь доступа к файлам проектов".
  3. Выберите "Отменить путь".

    4. Установка текущего проекта отменяется.

  4. Нажмите кнопку "OK" (или "Применить").

    5. Также отмену установки проекта текущим можно, введя в командной строке projectname, а затем - точку (.).


Задание путей к внешним чертежам - Команды

Внешние ссылки
Внешние ссылки
Задание путей к внешним чертежам
Понятия
Процедуры
Команды

Команды
ССЫЛКА | Запуск команды ВНССЫЛКИ
Системные переменные
PROJECTNAME | Присваивает имя проекта текущему чертежу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Удаление вхождений чертежей - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Удаление вхождений чертежей
Понятия
Процедуры
Команды

Для окончательного удаления внешней ссылки из чертежа ее необходимо удалить (открепить). Так, например, обычное стирание внешней ссылки не приводит к удалению описаний слоев, связанных с внешней ссылкой. Для окончательного удаления внешних ссылок со всеми связанными данными необходимо использовать опцию "Удалить".


Удаление внешней ссылки - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Удаление вхождений чертежей
Понятия
Процедуры
Команды

Удаление внешней ссылки

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" выберите имя внешнего чертежа.
  3. Нажмите правую кнопку мыши на вхождении DWG и выберите из контекстного меню "Удалить".

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ


Удаление вхождений чертежей - Команды

Внешние ссылки
Внешние ссылки
Удаление вхождений чертежей
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обновление и внедрение внешних чертежей - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Обновление и внедрение внешних чертежей
Понятия
Процедуры
Команды

Кроме вставки и удаления вхождений чертежей (внешних ссылок), их можно обновлять и внедрять.

  • Вложенные и наложенные внешние чертежи.
    Вставленные вхождения DWG (внешние ссылки) могут быть вложенными: это означает, что можно вставить внешнюю ссылку, которая в свою очередь содержит другую внешнюю ссылку.
  • Обновление вставленных внешних чертежей
    При открытии чертежа все вхождения DWG (внешние ссылки) автоматически обновляются. Можно также обновить внешние ссылки, чтобы убедиться, что на главном чертеже отображаются самые последние версии чертежей внешних ссылок.
  • Архивные чертежи, содержащие внешние чертежи (внедрение)
    При архивации окончательных версий чертежей можно выбрать способ сохранения внешних ссылок.


Обновление и внедрение внешних чертежей - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Обновление и внедрение внешних чертежей
Понятия
Процедуры
Команды

Наложение внешней ссылки

Обновление вставленной внешней ссылки

Внедрение внешней ссылки в текущий чертеж


Обновление и внедрение внешних чертежей - Команды

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Обновление и внедрение внешних чертежей
Понятия
Процедуры
Команды
Команды
TRAYSETTINGS | Управление отображением значков и уведомлений на панели строки состояния
ВНЕДРИТЬ | Внедрение одного или нескольких описаний именованных объектов во внешней ссылке в текущий чертеж
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
BINDTYPE | Управление обработкой имен внешних ссылок при внедрении или редактировании внешних ссылок.
INDEXCTL | Управляет созданием слоевых и пространственных индексов и сохранением их в файле чертежа
TRAYICONS | Управляет отображением панели в строке состояния
TRAYNOTIFY | Управляет отображением уведомлений служб в панели строки состояния
TRAYTIMEOUT | Управляет временем (в секундах), в течение которого отображаются уведомления служб
XEDIT | Управляет возможностью редактирования текущего чертежа на месте при использовании его в качестве внешней ссылки
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
XLOADPATH | Создает путь для хранения временных копий файлов подгруженных внешних ссылок
XREFNOTIFY | Управляет уведомлением для обновленных или отсутствующих внешних ссылок
XREFTYPE | Управляет типом ссылки по умолчанию при вставке или наложении внешней ссылки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вложенные и наложенные внешние чертежи. - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Вложенные и наложенные внешние чертежи.
Понятия
Процедуры
Команды

Одни внешние ссылки могут быть вложенными в другие: это означает, что можно вставить внешнюю ссылку, которая в свою очередь также содержит внешнюю ссылку. Одна и та же ссылка может быть вставлена в чертеж неограниченное число раз, причем с различными масштабными коэффициентами и углами поворота.

В следующем примере чертеж master.dwg ссылается на чертежи a.dwg и b.dwg. Чертеж a.dwg ссылается на чертеж c.dwg. В чертеже master.dwg чертеж c.dwg является вложенной внешней ссылкой.

Кроме того, можно выполнять наложение внешних ссылок на чертеж. Отличие наложения от вставки заключается в том, что, когда чертеж со ссылками сам вставляется в другой чертеж или накладывается на него, его вставленные ссылки загружаются и отображаются на экране, а наложенные - нет. Наложенные ссылки применяются при совместной работе нескольких пользователей над данными. Они позволяют проследить, как чертеж согласуется с чертежами, выполняемыми другими разработчиками, без выполнения вставки внешних ссылок, изменяющих чертеж.

Пусть, например, несколько человек работают над чертежами, на которые ссылается чертеж master.dwg. Пользователь, который работает над чертежом a.dwg должен видеть результат работы того, кто редактировал b.dwg, при этом файл b.dwg не должен быть внешней ссылкой, поскольку в этом случае в главном чертеже master.dwg он будет представлен дважды. Вместо этого, пользователь должен наложить файл b.dwg, тогда при использовании файла a.dwg в главном чертеже master.dwg наложенный файл открываться не будет.

Относительные сохраненные пути и вложенные внешние ссылки

Сохраненный путь ссылки путь может быть абсолютным, относительным или пустым. Для вложенной ссылки относительный путь, как правило, указывает на непосредственное расположение ссылки, частным случаем которого может быть текущий открытый чертеж.


Наложение внешней ссылки - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Вложенные и наложенные внешние чертежи.
Понятия
Процедуры
Команды

Наложение внешней ссылки

  1. Нажмите "Вставка" » "Вхождение DWG".
  2. В диалоговом окне "Выбор файла внешней ссылки" выберите файл для вставки. Нажмите кнопку "Открыть".
  3. В поле "Тип ссылки" диалогового окна "Внешняя ссылка" выберите "Наложенная".
  4. Задайте точку вставки, масштаб и угол поворота. Для того чтобы задать какой-либо параметр с помощью устройства указания, нужно установить флажок "Указать на экране" в соответствующей группе опций.

    5. Использование опции "Наложенная" исключает вложенность внешних ссылок.

  5. Нажмите "ОК".

Панель "Ссылки"

Ввод команды: ССВСТАВИТЬ


Вложенные и наложенные внешние чертежи. - Команды

Внешние ссылки
Внешние ссылки
Вложенные и наложенные внешние чертежи.
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
XREFTYPE | Управляет типом ссылки по умолчанию при вставке или наложении внешней ссылки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обновление вставленных внешних чертежей - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Обновление вставленных внешних чертежей
Понятия
Процедуры
Команды

При открытии чертежа все внешние ссылки автоматически обновляются. Для обновления внешних ссылок используется команда обновления палитры "Внешние ссылки", если требуется гарантировать отображение на чертеже самых последних версий внешних ссылок.

После сохранения отредактированного чертежа внешней ссылки в локальной сети любой другой можно отобразить изменения на своем чертеже, обновив внешнюю ссылку.

Уведомление об изменении внешних ссылок

При вставке в чертеж внешних ссылок программа периодически проверяет, не изменились ли файлы, на которые они ссылаются с момента последней загрузки или обновления чертежей. Уведомлениями о состоянии внешних ссылок управляет системная переменная XREFNOTIFY.

По умолчанию при изменении файла, на который есть ссылка, рядом со значком внешней ссылки в правом нижнем углу окна приложения (в строке состояния) появляется всплывающее уведомление. Необходимо нажать ссылку в уведомлении, чтобы обновить все изменившиеся внешние ссылки.

Если закрыть всплывающее уведомление, не обновив ссылку, на значке внешней ссылки появится восклицательный знак. При нажатии кнопки мыши на значке внешней ссылки открывается палитра "Внешние ссылки".

По умолчанию программа проверяет изменение файлов внешних ссылок каждые пять минут. Интервал времени между проверками можно изменить, установив значение переменной реестра XNOTIFYTIME(setenv "XNOTIFYTIME" "n"), где n - количество минут от 1 до 10080 (семь дней).

Примечание При изменении значения переменной XNOTIFYTIME необходимо ввестиXNOTIFYTIME заглавными буквами, как показано.

Обновление внешних ссылок в режиме подгрузки

Режим подгрузки при загрузке или обновлении внешней ссылки

  • Если для системной переменной XLOADCTL установлено значение 1, чертеж внешней ссылки будет оставаться открытым в заблокированном состоянии. Никто, кроме открывшего его пользователя, не сможет изменить чертеж внешней ссылки.
  • Если для системной переменной XLOADCTL установлено значение 2, то будет открыта и заблокирована временная копия последней сохраненной версии файла внешней ссылки. Другие пользователи могут открывать и изменять чертеж внешней ссылки.

Дополнительную информацию о подгрузке см. в разделе Увеличение производительности при работе с большими внешними чертежами.


Обновление вставленной внешней ссылки - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Обновление вставленных внешних чертежей
Понятия
Процедуры
Команды

Обновление вставленной внешней ссылки

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" выберите имя вхождения, которое требуется обновить.
  3. Нажмите правую кнопку мыши и выберите "Обновить".

Примечание Если чертеж выбранной ссылки был изменен уже после открытия основного чертежа, то внешняя ссылка обновляется.

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ


Обновление вставленных внешних чертежей - Команды

Внешние ссылки
Внешние ссылки
Обновление вставленных внешних чертежей
Понятия
Процедуры
Команды

Команды
TRAYSETTINGS | Управление отображением значков и уведомлений на панели строки состояния
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
INDEXCTL | Управляет созданием слоевых и пространственных индексов и сохранением их в файле чертежа
TRAYICONS | Управляет отображением панели в строке состояния
TRAYNOTIFY | Управляет отображением уведомлений служб в панели строки состояния
TRAYTIMEOUT | Управляет временем (в секундах), в течение которого отображаются уведомления служб
XEDIT | Управляет возможностью редактирования текущего чертежа на месте при использовании его в качестве внешней ссылки
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
XLOADPATH | Создает путь для хранения временных копий файлов подгруженных внешних ссылок
XREFNOTIFY | Управляет уведомлением для обновленных или отсутствующих внешних ссылок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Архивные чертежи, содержащие внешние чертежи (внедрение) - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Архивные чертежи, содержащие внешние чертежи (внедрение)
Понятия
Процедуры
Команды

Существует два способа сохранения внешних ссылок в окончательной версии чертежа:

  • сохранение файлов-ссылок вместе с основным чертежом;
  • внедрение файлов-ссылок в основной чертеж.

Файлы внешних ссылок, сохраняемые вместе с основным чертежом, должны всегда размещаться вместе с основным файлом. При любом изменении файлов-ссылок происходит обновление внешних ссылок в основном чертеже.

Чтобы избежать случайного обновления внешних ссылок в окончательном чертеже, следует выполнить их внедрение.

При внедрении в чертеж ссылка перестает быть простым указателем на внешний файл и становится постоянной частью текущего чертежа. С помощью опции "Внедрить" команды ССЫЛКА можно внедрить всю базу данных файла-ссылки, включая именованные объекты (блоки, размерные стили, слои, типы линий и текстовые стили). Дополнительную информацию см. в разделе Управление именованными объектами внешних ссылок.

Внедрение внешних ссылок в чертеж можно также использовать в целях подготовки чертежа для просмотра другими пользователями. После внедрения внешних ссылок исчезает необходимость отсылать вместе с файлом чертежа все его внешние ссылки.

Примечание Нельзя внедрять внешние ссылки, содержащие объекты-заместители. Дополнительную информацию см. в разделе Работа со сторонними объектами и заместителями.


Внедрение внешней ссылки в текущий чертеж - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Архивные чертежи, содержащие внешние чертежи (внедрение)
Понятия
Процедуры
Команды

Внедрение внешней ссылки в текущий чертеж

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" выберите имя вхождения, которое требуется внедрить.
  3. Нажмите правую кнопку мыши и выберите "Внедрить".
  4. В диалоговом окне "Внедрение ссылок" выберите одну из нижеприведенных опций.
    • Внедрение: преобразовывает объекты, содержащиеся во внешней ссылке, во вхождения блоков. Описания именованных объектов добавляются в текущий чертеж с префиксом "имя_блока$n$".
    • Слияние: также преобразовывает объекты, содержащиеся во внешней ссылке, во вхождения блоков. Однако описания именованных объектов вносятся в текущий чертеж без использования префиксов.
  5. Нажмите "OK" для закрытия каждого диалогового окна.

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ


Архивные чертежи, содержащие внешние чертежи (внедрение) - Команды

Внешние ссылки
Внешние ссылки
Архивные чертежи, содержащие внешние чертежи (внедрение)
Понятия
Процедуры
Команды

Команды
ВНЕДРИТЬ | Внедрение одного или нескольких описаний именованных объектов во внешней ссылке в текущий чертеж
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
BINDTYPE | Управление обработкой имен внешних ссылок при внедрении или редактировании внешних ссылок.
XEDIT | Управляет возможностью редактирования текущего чертежа на месте при использовании его в качестве внешней ссылки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Понятие о контурах подрезки - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Понятие о контурах подрезки
Понятия
Процедуры
Команды

Контуры подрезки используются для отображения особых участков вставленных внешних чертежей или блоков.

  • Подрезка внешних чертежей и блоков
    Имеется возможность подрезать внешние ссылки и блоки, вставленные в чертеж, для отображения только определенных их частей путем задания контуров подрезки.
  • Задание контуров подрезки
    Имеется возможность подрезать внешние ссылки и блоки, вставленные в чертеж, для отображения только определенных их частей путем задания контуров подрезки.


Понятие о контурах подрезки - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Понятие о контурах подрезки
Понятия
Процедуры
Команды

Подрезка ссылки


Понятие о контурах подрезки - Команды

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Понятие о контурах подрезки
Понятия
Процедуры
Команды
Команды
ССПОДРЕЗАТЬ | Задание контура подрезки, а также передней и задней плоскости подрезки для внешней ссылки или блока
Системные переменные
XCLIPFRAME | Управляет видимостью контуров подрезки внешних ссылок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Подрезка внешних чертежей и блоков - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Подрезка внешних чертежей и блоков
Понятия
Процедуры
Команды

Имеется возможность подрезать внешние ссылки и блоки, вставленные в чертеж, с помощью команды ССПОДРЕЗАТЬ. При этом вывод на экран геометрических объектов, расположенных за пределами контуров подрезки, подавляется. Подрезка применяется только к конкретному экземпляру ссылки, а не к ее описанию в целом. Объекты, оказавшиеся внутри контура подрезки, остаются видимыми, а остальная часть внешней ссылки или блока не видна. Подрезка определяет только состояние видимости объектов; с объектами на исходном чертеже изменений не происходит.

Команда ССПОДРЕЗАТЬ используется для создания и удаления контуров подрезки, а также для создания полилиний, повторяющих очертания контуров подрезки. Режим подрезки можно включать и отключать. Если подрезка отключена, контур не виден, и на экран выводятся все объекты ссылки, расположенные на включенных и размороженных слоях. При отключении контур подрезки не удаляется из чертежа, и в любой момент может быть включен вновь. Имеющийся контур подрезки можно также удалить.

Подрезанную внешнюю ссылку или блок можно редактировать, перемещать и копировать точно так же, как и не подрезанную. При этом контур подрезки перемещается вместе со ссылкой. Операция подрезки действует одинаково как на ссылки первого уровня, так и на вложенные ссылки. Если подрезана главная ссылка, все вложенные ссылки также выводятся подрезанными.

Для вывода контура подрезки следует включить системную переменную XCLIPFRAME. Системная переменная XCLIPFRAME управляет отображением контура подрезки. Включенный контур подрезки (если переменной присвоено значение 1) виден на экране и может быть выбран как объект или вычерчен на плоттере.

Параметры контуров подрезки

Контур подрезки может иметь прямоугольную или многоугольную форму. Он либо очерчивается пользователем, либо генерируется на основании имеющейся в чертеже полилинии. В первом случае допускается указание любых точек 3D пространства; программа затем проецирует полученный контур на плоскость текущей ПСК. Во втором случае плоскость контура совпадает с плоскостью исходной полилинии.


Понятие о контурах подрезки

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Понятие о контурах подрезки
Понятия
Процедуры
Команды

Нет процедур.


Подрезка внешних чертежей и блоков - Команды

Внешние ссылки
Внешние ссылки
Подрезка внешних чертежей и блоков
Понятия
Процедуры
Команды

Команды
ССПОДРЕЗАТЬ | Задание контура подрезки, а также передней и задней плоскости подрезки для внешней ссылки или блока
Системные переменные
XCLIPFRAME | Управляет видимостью контуров подрезки внешних ссылок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание контуров подрезки - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание контуров подрезки
Понятия
Процедуры
Команды
Прямоугольные контуры подрезки

Для прямоугольного контура подрезки задаются его угловые точки. Контур строится параллельно текущей ПСК, а подрезка распространяется по нормали к его плоскости.

Многоугольные контуры подрезки

Для многоугольного контура подрезки задаются все его вершины. При указании точек подрезки последний сегмент многоугольника строится таким образом, что контур всегда остается замкнутым. Если во внешней ссылке имеются растровые изображения, они подрезаются не по многоугольному контуру, а по описанному вокруг него прямоугольному.

Подрезка полилинией

Для задания такого контура подрезки необходимо указать на экране 2D полилинию. Созданный контур полностью повторяет очертания выбранной полилинии. В качестве контуров подрезки можно использовать 2D полилинии с прямыми или сглаженными сплайнами сегментами. Полилинии, имеющие дуговые сегменты или сглаженные дугами, линейно аппроксимируются. Если полилиния содержит дуги, контур подрезки создается с их преобразованием в линейные участки. Разомкнутые полилинии автоматически замыкаются.

Глубина подрезки

Для ссылок можно также установить переднюю и заднюю плоскости подрезки. Для задания глубины подрезки необходимо, чтобы в чертеже уже присутствовал контур подрезки. Значение глубины подрезки всегда отсчитывается по нормали к контуру. Задание глубины производится либо путем указания точек передней и задней плоскостей, либо вводом численного значения. Независимо от текущей ПСК, передняя и задняя плоскости подрезки располагаются параллельно контуру подрезки.


Подрезка ссылки - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание контуров подрезки
Понятия
Процедуры
Команды

Подрезка ссылки

  1. В командной строке введите ссподрезать.
  2. Выберите ссылку.
  3. В командной строке выберите опцию "Новый контур", нажав ENTER.
  4. Выберите тип контура подрезки: прямоугольный или многоугольный. Укажите углы или вершины контура.

    5. Подрезка изображения выполняется с учетом указанной области, при этом отключается видимость части чертежа внешней ссылки за пределами контура подрезки.

Ввод команды: ССПОДРЕЗАТЬ


Задание контуров подрезки - Команды

Внешние ссылки
Внешние ссылки
Задание контуров подрезки
Понятия
Процедуры
Команды

Команды
ССПОДРЕЗАТЬ | Задание контура подрезки, а также передней и задней плоскости подрезки для внешней ссылки или блока
Системные переменные
XCLIPFRAME | Управляет видимостью контуров подрезки внешних ссылок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование внешних чертежей - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Редактирование внешних чертежей
Понятия
Процедуры
Команды

Вставленные в качестве внешних ссылок чертежи можно редактировать, открыв их непосредственно или редактируя внешнюю ссылку по месту, из текущего чертежа. Можно также редактировать описание блока непосредственно через любое его вхождение.

  • Редактирование внешних чертежей в отдельном окне
    Наиболее простой способ редактирования внешней ссылки - открыть чертеж-ссылку в новом окне. Этот способ открывает доступ ко всем объектам чертежа-ссылки.
  • Редактирование выбранных объектов во внешних чертежах и вставленных блоках
    Редактировать внешние ссылки и описания можно не выходя из текущего чертежа, т.е. посредством редактирования их вхождений. Как блоки, так и внешние ссылки вставляются в чертеж в виде вхождений.
  • Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
    Для редактирования вставленного в качестве внешней ссылки чертежа из текущего чертежа создается рабочий набор, позволяющий определить объекты, принадлежащие внешней ссылке или описанию блока, а не текущему чертежу.
  • Сохранение отредактированных внешних чертежей и вставленных блоков
    Изменения, произведенные при редактировании вставленного в качестве внешней ссылки чертежа или описания блока в текущем чертеже, можно сохранить в исходном чертеже или отменить.
  • Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами
    Существуют ограничения при редактировании из текущего чертежа внешних чертежей и вставленных блоков с вложенными объектами.


Редактирование внешних чертежей - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Редактирование внешних чертежей
Понятия
Процедуры
Команды

Редактирование внешней ссылки в отдельном окне

Редактирование внешней ссылки или блока в контексте чертежа

Добавление объектов в рабочий набор

Исключение объектов из рабочего набора

Сохранение изменений в результате редактирования внешних ссылок и блоков

Отказа от изменений внешних ссылок и блоков


Редактирование внешних чертежей - Команды

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Редактирование внешних чертежей
Понятия
Процедуры
Команды
Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
РЕЖИМРАСКР | Запускает команду ТЕКВИЗСТИЛЬ
ССОТКРЫТЬ | Открывает выбранную внешнюю ссылку на чертеж (xref) в новом окне
ССЫЛЗАКР | Сохранение или отказ от изменений, произведенных в ходе редактирования вхождений блоков и ссылок
ССЫЛНАБ | Добавление и исключение объектов из рабочего набора при редактировании вхождений блоков и ссылок
ССЫЛРЕД | Выбирает внешнюю ссылку или вхождение блока для редактирования
Системные переменные
BINDTYPE | Управление обработкой имен внешних ссылок при внедрении или редактировании внешних ссылок.
REFEDITNAME | Отображает имя редактируемого вхождения
XEDIT | Управляет возможностью редактирования текущего чертежа на месте при использовании его в качестве внешней ссылки
XFADECTL | Управляет процентом интенсивности затенения для редактируемых ссылок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование внешних чертежей в отдельном окне - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Редактирование внешних чертежей в отдельном окне
Понятия
Процедуры
Команды

Наиболее простой способ редактирования внешней ссылки - открыть чертеж-ссылку в новом окне. Этот способ открывает доступ ко всем объектам чертежа-ссылки.

Вместо того, чтобы искать внешнюю ссылку с помощью диалогового окна "Выбор файла", можно выбрать ее вхождение в текущем чертеже и открыть чертеж-ссылку в новом окне. Для такого способа редактирования внешних ссылок используется палитра "Внешние ссылки" или команда ССОТКРЫТЬ.


Редактирование внешней ссылки в отдельном окне - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Редактирование внешних чертежей в отдельном окне
Понятия
Процедуры
Команды

Редактирование внешней ссылки в отдельном окне

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" выберите имя вхождения, которое требуется отредактировать.
  3. Нажмите правую кнопку мыши и выберите "Открыть".
  4. Выбранный внешний чертеж открывается в новом окне, в котором его редактируют, сохраняют, а затем закрывают чертеж.

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ


Редактирование внешних чертежей в отдельном окне - Команды

Внешние ссылки
Внешние ссылки
Редактирование внешних чертежей в отдельном окне
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование выбранных объектов во внешних чертежах и вставленных блоках - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Редактирование выбранных объектов во внешних чертежах и вставленных блоках
Понятия
Процедуры
Команды

Редактировать внешние ссылки и описания можно не выходя из текущего чертежа, т.е. посредством редактирования их вхождений. Как блоки, так и внешние ссылки вставляются в чертеж в виде вхождений.

Редактируя вхождение внешней ссылки в контексте текущего чертежа, проектировщик может вносить изменения в ссылку и видеть, как это отразится на всем чертеже.

Часто чертежи содержат в себе несколько различных вхождений внешних ссылок и блоков. Работая с вхождениями блоков, можно выбрать блок, отредактировать его, осуществить просмотр и редактирование его свойств и обновить описание блока. Нельзя редактировать вхождение блока, вставленного с помощью команды МВСТАВИТЬ.

Также с помощью вхождений можно выбрать и отредактировать внешнюю ссылку, а затем записать изменения в исходный файл внешней ссылки. Таким образом, отпадает необходимость постоянно переключаться из одного чертежа в другой при необходимости внести незначительные изменения.

Примечание Значительные изменения внешних ссылок и блоков рекомендуется выполнять непосредственно в исходном внешнем чертеже. Редактирование вхождения внешней ссылки в контексте текущего чертежа может сильно увеличить размер файла (если производятся существенные изменения).

Понятие рабочего набора

Выбирать можно только объекты, принадлежащие предназначенному для редактирования вхождению. Программа извлекает требуемые объекты из выбранного вхождения и делает их доступными для редактирования в текущем чертеже. Набор извлеченных объектов, или рабочий набор, можно изменить, а затем сохранить в исходный файл внешней ссылки или описание блока. Объекты, входящие в рабочий набор, визуально выделяются среди других объектов чертежа. По сравнению с объектами, входящими в рабочий набор, все остальные объекты выглядят более бледно.

Затенение объектов

Интенсивностью отображения объектов в ходе редактирования вхождений управляет системная переменная XFADECTL. Все объекты, извлеченные из вхождения, отображаются обычным образом. Все остальные объекты текущего чертежа, не входящие в рабочий набор, выглядят более бледно. Переменная управляет интенсивностью отображения объектов, не входящих в рабочий набор. Чем больше значение переменной XFADECTL, тем менее ярко выглядят объекты.

Примечание Если в команде РЕЖИМРАСКР установлен режим, отличный от "2D каркас", объекты, не входящие в рабочий набор, не затеняются.

Панель "Редактирование вхождений"

После выбора объектов для редактирования появляется панель инструментов "Редактирование вхождений". С помощью кнопок этой панели можно добавить или исключить объекты из рабочего набора, а также сохранить или отказаться от сохранения изменений вхождения. Панель "Редактирование вхождений" автоматически сворачивается после завершения редактирования вхождения, если только она не фиксирована у границ окна.


Редактирование внешней ссылки или блока в контексте чертежа - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Редактирование выбранных объектов во внешних чертежах и вставленных блоках
Понятия
Процедуры
Команды

Редактирование внешней ссылки или блока в контексте чертежа

  1. Нажмите "Сервис" » "Внешняя ссылка или блок для местного редактирования" » "Редактирование вхождений".
  2. В текущем чертеже выберите вхождение, которое необходимо отредактировать.

    3. Если выбранный объект принадлежит одному из вложенных вхождений, все доступные для редактирования вхождения выводятся в диалоговом окне "Редактирование вхождений".

  3. В диалоговом окне "Редактирование вхождений" выберите ссылку для редактирования.

    4. Файл вхождения будет заблокирован для предотвращения одновременного открытия файла несколькими пользователями. Если исходный файл ссылки используется каким-либо другим пользователем, ее вхождение становится недоступным для редактирования в текущем чертеже.

  4. Нажмите "ОК".
  5. Выберите принадлежащие вхождению объекты, которые нужно отредактировать, и нажмите ENTER.

    6. Выбранные объекты образуют рабочий набор. По умолчанию все остальные объекты будут заблокированы и затенены.

  6. Отредактировать объекты в рабочем наборе. Нажмите кнопку "Сохранить изменения".

    7. Объекты рабочего набора сохраняются; вхождение ссылки или блока в текущий чертеж обновляется.

Ввод команды: ССЫЛРЕД


Редактирование выбранных объектов во внешних чертежах и вставленных блоках - Команды

Внешние ссылки
Внешние ссылки
Редактирование выбранных объектов во внешних чертежах и вставленных блоках
Понятия
Процедуры
Команды

Команды
РЕЖИМРАСКР | Запускает команду ТЕКВИЗСТИЛЬ
ССЫЛЗАКР | Сохранение или отказ от изменений, произведенных в ходе редактирования вхождений блоков и ссылок
ССЫЛНАБ | Добавление и исключение объектов из рабочего набора при редактировании вхождений блоков и ссылок
ССЫЛРЕД | Выбирает внешнюю ссылку или вхождение блока для редактирования
Системные переменные
BINDTYPE | Управление обработкой имен внешних ссылок при внедрении или редактировании внешних ссылок.
REFEDITNAME | Отображает имя редактируемого вхождения
XEDIT | Управляет возможностью редактирования текущего чертежа на месте при использовании его в качестве внешней ссылки
XFADECTL | Управляет процентом интенсивности затенения для редактируемых ссылок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование рабочего набора для редактирования внешних чертежей и вставленных блоков - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Понятия
Процедуры
Команды

Для редактирования вставленного в качестве внешней ссылки чертежа из текущего чертежа создается рабочий набор, позволяющий определить объекты, принадлежащие внешней ссылке или описанию блока, а не текущему чертежу.

В ходе редактирования вхождений в рабочий набор можно добавлять новые объекты, а также исключать из него уже имеющиеся. Новые объекты, создаваемые в процессе редактирования вхождения, практически всегда добавляются в рабочий набор автоматически. Объекты, не включенные в рабочий набор, отображаются в чертеже более бледно.

Новые объекты, созданные в результате изменения объектов, не входящих в рабочий набор, не добавляются в рабочий набор. Например, пусть в чертеже имеются два отрезка, не входящие в рабочий набор. При выполнении команды СОПРЯЖЕНИЕ между отрезками создается дуга. При этом вновь созданная дуга не добавляется в рабочий набор.

Объект, входящий в рабочий набор, можно выбирать для редактирования, даже если слой, на котором он расположен в исходном файле, блокирован. Слой можно разблокировать и после этого отредактировать объект. Хотя изменения в объекте могут быть сохранены, это не влияет на состояние слоя (блокированный или нет) в исходном файле.

Объект, исключенный из рабочего набора, добавляется в основной чертеж и удаляется из вхождения при сохранении изменений. Объект, добавленный в рабочий набор, удаляется из основного чертежа и заносится во вхождение при сохранении изменений. Вновь созданные или удаленные объекты автоматически добавляются или удаляются из рабочего набора. Например, после применения команды СТЕРЕТЬ в ходе редактирования вхождения, стертые объекты удаляются из рабочего набора. Можно определить, принадлежит ли объект рабочему набору, по способу его отображения - если объект затенен, он не принадлежат рабочему набору.

Панель "Редактирование вхождений"

В ходе редактирования вхождений появляется панель инструментов "Редактирование вхождений". В ней указывается имя выбранного вхождения. Кнопки редактирования, расположенные на этой панели ("Добавить объекты в рабочий набор", "Исключить объекты из рабочего набора", "Отказаться от изменений" и "Сохранить изменения"), активны только в процессе редактирования вхождения. Кнопка "Редактирование блока или внешней ссылки" доступна всегда, даже если режим редактирования вхождения в текущем чертеже не включен. Панель "Редактирование вхождений" автоматически сворачивается после завершения редактирования вхождения.


Использование рабочего набора для редактирования внешних чертежей и вставленных блоков - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Понятия
Процедуры
Команды

Добавление объектов в рабочий набор

Исключение объектов из рабочего набора


Добавление объектов в рабочий набор - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Понятия
Процедуры
Команды

Добавление объектов в рабочий набор

  1. Нажмите "Сервис" » "Внешняя ссылка или блок для местного редактирования" » "Добавить в рабочий набор" или введите в командной строке ссылнаб.
  2. Если в командной строке введена команда ссылнаб, на панели инструментов "Редактирование вхождений" нажмите кнопку "Добавить объекты в рабочий набор".

  3. Выберите объекты для добавления. Можно также присвоить переменной PICKFIRST значение 1, чтобы создать набор объектов перед добавлением.

    4. Команда ССЫЛНАБ применяется только для объектов, находящихся в том пространстве (листа или модели), из которого была вызвана команда ССЫЛРЕД.


Исключение объектов из рабочего набора - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Понятия
Процедуры
Команды

Исключение объектов из рабочего набора

  1. Нажмите "Сервис" » "Внешняя ссылка или блок для местного редактирования" » "Исключить из рабочего набора" или ввести в командной строке ссылнаб.
  2. Если в командной строке введена команда ссылнаб, на панели инструментов "Редактирование вхождений" нажмите кнопку "Исключить объекты из рабочего набора".

  3. Выберите объекты для исключения. Можно также присвоить переменной PICKFIRST значение 1, чтобы создать набор объектов перед исключением.

    4. Команда ССЫЛНАБ применяется только для объектов, находящихся в том пространстве (листа или модели), из которого была вызвана команда ССЫЛРЕД.


Использование рабочего набора для редактирования внешних чертежей и вставленных блоков - Команды

Внешние ссылки
Внешние ссылки
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Понятия
Процедуры
Команды

Команды
ССЫЛЗАКР | Сохранение или отказ от изменений, произведенных в ходе редактирования вхождений блоков и ссылок
ССЫЛНАБ | Добавление и исключение объектов из рабочего набора при редактировании вхождений блоков и ссылок
ССЫЛРЕД | Выбирает внешнюю ссылку или вхождение блока для редактирования
Системные переменные
XEDIT | Управляет возможностью редактирования текущего чертежа на месте при использовании его в качестве внешней ссылки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение отредактированных внешних чертежей и вставленных блоков - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Сохранение отредактированных внешних чертежей и вставленных блоков
Понятия
Процедуры
Команды

Изменения, произведенные при редактировании описания блока в текущем чертеже, можно сохранить в текущем чертеже или отменить. При сохранении изменений вхождения будет выполнена регенерация чертежа.

После сохранения изменений описание блока будет обновлено, а все экземпляры блока будут регенерированы с учетом произведенных изменений. Если пользователь отказывается от изменений, то рабочий набор удаляется, и вхождение блока возвращается в исходное состояние.

Аналогично, при редактировании внешней ссылки в текущем чертеже сделанные изменения можно сохранить или отменить. Новые свойства, ранее не присутствовавшие во внешнем файле, заданные для объектов рабочего набора, сохраняются в исходном чертеже. Например, пусть внешняя ссылка содержит слои A, B и C, а в текущем чертеже имеется также слой D. Если в ходе редактирования вхождения по месту новые объекты создавались на слое D и изменения сохранялись в исходном чертеже, то этот слой при сохранении изменений копируется в чертеж внешней ссылки.

Объекты, исключенные из рабочего набора, при сохранении изменений удаляются из вхождения и добавляются в основной чертеж. Изменения, произведенные с объектами текущего чертежа (не входящими во внешнюю ссылку или блок), остаются в чертеже. Удаленные объекты, не входящие в рабочий набор, не восстанавливаются даже после отказа от изменений. Вернуть чертеж в его начальное состояние можно с помощью команды ОТМЕНИТЬ. Отменить нежелательные изменения, записанные в исходный файл внешней ссылки при выполнении команды ССЫЛЗАКР также можно с помощью команды ОТМЕНИТЬ. Отменив все нежелательные изменения, нужно снова воспользоваться командой ССЫЛЗАКР, чтобы записать восстановленные объекты в исходный файл внешней ссылки.

Предупреждение Удаленные в ходе редактирования вхождения в текущем чертеже объекты, не входящие в рабочий набор, не восстанавливаются даже после отказа от изменений вхождения.

Объекты текущего чертежа, наследующие свойства из внешнего файла, сохраняют свои новые свойства, полученные после изменения. Свойства, изначально взятые из внешнего файла, внедряются в текущий чертеж. Так, например, слой с именем SITE, если он был присвоен объекту, не входившему в рабочий набор, появляется в текущем чертеже с именем $#$SITE. Если переменной BINDTYPE присвоено значение 0, то ко всем внедряемым именам символов добавляется префикс $#$. Если переменной BINDTYPE присвоено значение 1, то имена символов при внедрении в текущий чертеж остаются без изменений.

Примечание После редактирования вхождения внешней ссылки в текущем чертеже, изображение, использовавшееся для предварительного просмотра внешнего файла, становится недоступным и возобновляется только после открытия и сохранения файла внешней ссылки.


Сохранение отредактированных внешних чертежей и вставленных блоков - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Сохранение отредактированных внешних чертежей и вставленных блоков
Понятия
Процедуры
Команды

Сохранение изменений в результате редактирования внешних ссылок и блоков

Отказа от изменений внешних ссылок и блоков


Сохранение изменений в результате редактирования внешних ссылок и блоков - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Сохранение отредактированных внешних чертежей и вставленных блоков
Понятия
Процедуры
Команды

Сохранение изменений в результате редактирования внешних ссылок и блоков

  • Нажмите "Сервис" » "Внешняя ссылка или блок для местного редактирования" » "Сохранить изменения вхождения" или кнопку "Сохранить изменения" на панели инструментов "Редактирование вхождений".

Панель "Редактирование вхождений"

Ввод команды: ССЫЛЗАКР


Отказа от изменений внешних ссылок и блоков - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Сохранение отредактированных внешних чертежей и вставленных блоков
Понятия
Процедуры
Команды

Отказа от изменений внешних ссылок и блоков

  • На панели инструментов "Редактирование вхождений" нажмите кнопку "Отказаться от изменений".

Панель "Редактирование вхождений"

Ввод команды: ССЫЛЗАКР

Контекстное меню: Если при редактировании вхождений по месту нет выбранных объектов, нажмите правую кнопку мыши в области чертежа. Выберите "Завершение сеанса ССЫЛРЕД".


Сохранение отредактированных внешних чертежей и вставленных блоков - Команды

Внешние ссылки
Внешние ссылки
Сохранение отредактированных внешних чертежей и вставленных блоков
Понятия
Процедуры
Команды

Команды
ССОТКРЫТЬ | Открывает выбранную внешнюю ссылку на чертеж (xref) в новом окне
ССЫЛЗАКР | Сохранение или отказ от изменений, произведенных в ходе редактирования вхождений блоков и ссылок
Системные переменные
BINDTYPE | Управление обработкой имен внешних ссылок при внедрении или редактировании внешних ссылок.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами
Понятия
Процедуры
Команды

Существуют ограничения при редактировании из текущего чертежа внешних чертежей и вставленных блоков с вложенными объектами.

Если в выбранном для редактирования вхождении есть вставленные внешние ссылки или описания блоков, то ссылки и вложенные в них ссылки будут отображены и могут быть выбраны в диалоговом окне "Редактирование вхождений". Однако при этом здесь появляются только те вхождения, которым принадлежат выбранные объекты. Пользователь не может редактировать одновременно несколько вхождений. OLE-объекты, содержащиеся в редактируемых вхождениях, хотя и отображаются, но не могут быть отредактированы.

Если для редактирования выбран блок с атрибутами, их описания можно отображать в исходном файле и сделать доступными для редактирования. При этом атрибуты становятся невидимыми, а описания атрибутов становятся доступными для редактирования вместе с графическими объектами выбранного вхождения. При сохранении изменений в исходный чертеж описания блока атрибуты в имеющихся вхождениях остаются без изменений. Новые описания атрибутов вступают в силу только для последующих вхождений блока.


Редактирование внешних чертежей

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Редактирование внешних чертежей
Понятия
Процедуры
Команды

Нет процедур.


Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами - Команды

Внешние ссылки
Внешние ссылки
Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ССЫЛНАБ | Добавление и исключение объектов из рабочего набора при редактировании вхождений блоков и ссылок
ССЫЛРЕД | Выбирает внешнюю ссылку или вхождение блока для редактирования
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Ошибки обработки чертежей-ссылок - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Ошибки обработки чертежей-ссылок
Понятия
Процедуры
Команды

Если при открытии чертежа не удается загрузить чертеж-внешнюю ссылку, то появляется сообщение об ошибке.

  • Обработка отсутствующих внешних ссылок
    Если при открытии чертежа не удается обнаружить файл внешней ссылки, то появляется сообщение об ошибке. Пользователю предлагается несколько способов решения этой проблемы.
  • Обработка циклических внешних ссылок
    Если внешний чертеж содержит цепь вложенных ссылок, один из элементов которой ссылается на элемент цепи из числа предыдущих, выдается сообщение об ошибке.
  • Управление именованными объектами внешних ссылок
    При вставке внешней ссылки имена содержащихся в ней блоков, размерных стилей, слоев, типов линий и текстовых стилей должны отличаться от имен элементов текущего чертежа.
  • Работа с файлом журнала внешних ссылок
    Программа может вести журнал действий при выполнении операций вставки, удаления и обновления ссылок, а также при загрузке чертежей, содержащих внешние ссылки.


Ошибки обработки чертежей-ссылок - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Ошибки обработки чертежей-ссылок
Понятия
Процедуры
Команды

Изменение пути ко внешней ссылке

Внедрение зависимых от ссылок именованных объектов в текущий чертеж

Переименование слоев, размерных стилей и других именованных объектов

Использование файла журнала внешних ссылок


Ошибки обработки чертежей-ссылок - Команды

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Ошибки обработки чертежей-ссылок
Понятия
Процедуры
Команды
Команды
ВНЕДРИТЬ | Внедрение одного или нескольких описаний именованных объектов во внешней ссылке в текущий чертеж
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
НОВОЕИМЯ | Изменяет имена именованных объектов
ССЫЛКА | Запуск команды ВНССЫЛКИ
Системные переменные
BINDTYPE | Управление обработкой имен внешних ссылок при внедрении или редактировании внешних ссылок.
XREFCTL | Управляет созданием файлов журналов внешних ссылок (XLG)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обработка отсутствующих внешних ссылок - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Обработка отсутствующих внешних ссылок
Понятия
Процедуры
Команды

Если при открытии чертежа не удается обнаружить файл внешней ссылки, то появляется сообщение об ошибке. Пользователю предлагается несколько способов решения этой проблемы.

Программа запоминает полное имя файла чертежа, используемого для создания вхождения. Программа проверяет путь внешней ссылки каждый раз при загрузке или выводе на печать чертежа или при обновлении внешней ссылки с помощью параметра "Обновить" палитры "Внешние ссылки", чтобы определить имя и местоположение файла внешнего чертежа. Если имя или местоположение файла чертежа было изменено, программа не сможет загрузить внешнюю ссылку.

Если программа не может загрузить внешнюю ссылку при открытии главного чертежа, выводится сообщение об ошибке. Например, программа не может найти внешнюю ссылку HOUSE:

"\acad\dwg\house.dwg": Не удалось открыть файл

** Ошибка при обработке Вн-ссылки HOUSE.

В точках вставки внешнего чертежа программа выводит текст (в том же месте и с использованием масштаба и угла поворота исходной ссылки), который содержит путь ненайденной ссылки. Откорректировать и сохранить путь к ссылке можно с помощью опции "Путь" команды ССЫЛКА.

Для избежания таких ошибок при передаче чертежа другим пользователям следует предоставлять все связанные файлы.

Изменение путей вложенных внешних ссылок

При последующем открытии чертежа и загрузке вложенной внешней ссылки программа сначала попытается найти внешнюю ссылку по ее исходному пути. Если это не удается, производится следующий поиск:

  • Текущая папка главного чертежа
  • Пути поиска файлов проекта, заданные в диалоговом окне "Настройка" (вкладка "Файлы") или с помощью системной переменной PROJECTNAME
  • Пути поиска вспомогательных файлов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Папка запуска, указанная в ярлыке приложения Microsoft® Windows®

Это гарантирует отражение в чертеже всех изменений ссылок и делает возможным автоматический поиск перемещенных ссылок.

Например, пусть в текущий чертеж A вставлены ссылки, образующие структуру A>B>C, и владелец чертежа B изменил путь к ссылке C так, что теперь он указывает на файл C1.dwg. При последующем открытии чертежа A загружается ссылка B, из которой извлекается информация о текущем положении ссылки C1.dwg. Однако если файл C1.dwg не найден, программа вновь обращается к чертежу A в поисках последнего сохраненного в нем пути к отсутствующей ссылке С.

См. также

Обновление вставленных внешних чертежей


Изменение пути ко внешней ссылке - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Обработка отсутствующих внешних ссылок
Понятия
Процедуры
Команды

Изменение пути ко внешней ссылке

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" выберите внешнюю ссылку.
  3. В группе "Найдено в" выполните одно из следующих действий:
    • Непосредственно введите новый путь ко внешней ссылке.
    • Нажмите кнопку [...] и найдите файл внешней ссылки по его новому пути.

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ


Обработка отсутствующих внешних ссылок - Команды

Внешние ссылки
Внешние ссылки
Обработка отсутствующих внешних ссылок
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обработка циклических внешних ссылок - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Обработка циклических внешних ссылок
Понятия
Процедуры
Команды

Циклической называется цепь вложенных ссылок, один из элементов которой ссылается на элемент цепи из числа предыдущих. Например, если чертеж A ссылается на чертеж B, чертеж B на чертеж C, а последний вновь на чертеж A, цепь ссылок A>B>C>A является циклической.

Если при вставке внешней ссылки программа обнаруживает появление цикличности, отображается предупреждение с вопросом, желает ли пользователь продолжить обработку ссылок. В случае положительного ответа программа считывает внешнюю ссылку и все вложенные в нее ссылки пока не обнаружит некорректный элемент. В случае отрицательного ответа процесс будет остановлен, а внешняя ссылка не будет вставлена в чертеж.

Если при загрузке чертежа встречается циклическая ссылка, отображается сообщение об ошибке и циклическая ссылка разрывается на время текущего сеанса работы. Например, если имеется цепь внешних ссылок A>B>C>A, и пользователь открывает файл a.dwg, программа находит и разрывает циклическую связь между чертежами c.dwg и a.dwg. При этом выводится сообщение:

Разрывается циклическая ссылка из С на текущий чертеж.


Ошибки обработки чертежей-ссылок

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Ошибки обработки чертежей-ссылок
Понятия
Процедуры
Команды

Нет процедур.


Обработка циклических внешних ссылок - Команды

Внешние ссылки
Внешние ссылки
Обработка циклических внешних ссылок
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление именованными объектами внешних ссылок - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Управление именованными объектами внешних ссылок
Понятия
Процедуры
Команды

При вставке внешней ссылки имена содержащихся в ней блоков, размерных стилей, слоев, типов линий и текстовых стилей должны отличаться от имен элементов текущего чертежа.

Как правило, описание внешней ссылки содержит такие графические объекты, как отрезки, дуги и др. Во внешнюю ссылку могут также входить описания блоков, размерные стили, слои, типы линий, а также текстовые стили. При вставке внешней ссылки программа различает имена зависящих от ссылки именованных объектов и объектов текущего чертежа: имени зависящего от ссылки объекта предшествует имя внешнего чертежа и вертикальная черта ( | ). Например, в Диспетчере свойств слоев относящийся к внешней ссылке именованный объект, который находится во внешнем чертеже, названном stair.dwg, на слое с именем STEEL, упоминается в списке как STAIR|STEEL.

Описания зависимых объектов из внешней ссылки не становятся частью текущего чертежа. При каждом обновлении внешней ссылки они заново загружаются из исходного файла.

Внедрение зависящих от внешних ссылок описаний

Описание объекта, зависящего от внешней ссылки, может измениться при изменении исходного файла. Например, имя слоя из внешнего чертежа может измениться в процессе редактирования этого чертежа. Если слой будет удален из чертежа-ссылки, то исчезнет и его имя. Поэтому программа не позволяет использовать зависимые от ссылок слои или другие именованные объекты непосредственно. Нельзя, например, вставить в чертеж описанный в ссылке блок или сделать один из ее слоев текущим и начать создавать на нем новые объекты.

Такие операции становятся возможны только после внедрения внешне-зависимых объектов в чертеж. В результате внедрения внешне-зависимые именованные объекты становятся элементами текущего чертежа.

Внедренные зависимые объекты можно редактировать так же, как и именованные объекты самого чертежа. При внедрении зависимого от внешней ссылки именованного объекта программа преобразует его имя, заменяя символ вертикальной черты (|) на два знака доллара ($$), между которыми ставится число (обычно это ноль); например, имя связанного слоя STAIR|STEEL изменяется на STAIR$0$STEEL. Для изменения STAIR$0$STEEL на STEEL можно впоследствии воспользоваться командой НОВОЕИМЯ.

При внедрении слоя, которому присвоен тип линий, отличный от CONTINUOUS, этот тип линий также будет внедрен в чертеж. Если команда ВНЕДРИТЬ применяется к блоку, то все именованные объекты, на которые ссылаются объекты этого блока, также внедряются в чертеж. Если блок содержит в себе ссылку на внешнюю ссылку, эта внешняя ссылка и все зависимые от нее описания также будут внедрены.


Управление именованными объектами внешних ссылок - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Управление именованными объектами внешних ссылок
Понятия
Процедуры
Команды

Внедрение зависимых от ссылок именованных объектов в текущий чертеж

Переименование слоев, размерных стилей и других именованных объектов


Внедрение зависимых от ссылок именованных объектов в текущий чертеж - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Управление именованными объектами внешних ссылок
Понятия
Процедуры
Команды

Внедрение зависимых от ссылок именованных объектов в текущий чертеж

  1. Нажмите "Редактирование" » "Объекты" » "Внешние ссылки" » "Внедрить".
  2. В диалоговом окне "Внедрение символов" нажмите значок "+" рядом с именем ссылки.

    3. Разворачивается ветвь, соответствующая выбранной ссылке, со списком имен пяти типов описаний именованных объектов (блоки, размерные стили, слои, типы линий и текстовые стили).

  3. Нажмите значок "+" рядом с именем типа описания.

    4. Появляется список имен элементов таблицы описаний.

  4. Выберите описание именованного объекта. Нажмите "Добавить".

    5. В группе "Внедряемые описания" появляется список описаний именованных объектов.

  5. При необходимости повторить пункты 3 и 4.
  6. Нажмите "ОК".

Ввод команды: ВНЕДРИТЬ


Переименование слоев, размерных стилей и других именованных объектов - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Управление именованными объектами внешних ссылок
Понятия
Процедуры
Команды

Переименование слоев, размерных стилей и других именованных объектов

  1. Нажмите "Формат" » "Переименовать".
  2. В диалоговом окне "Задание нового имени" выберите тип объекта и объект для переименования.
  3. Введите новое имя в поле "Новое имя", расположенное под старым именем.
  4. Нажмите кнопку "Новое имя". Нажмите "OK".

Ввод команды: НОВОЕИМЯ


Управление именованными объектами внешних ссылок - Команды

Внешние ссылки
Внешние ссылки
Управление именованными объектами внешних ссылок
Понятия
Процедуры
Команды

Команды
ВНЕДРИТЬ | Внедрение одного или нескольких описаний именованных объектов во внешней ссылке в текущий чертеж
НОВОЕИМЯ | Изменяет имена именованных объектов
Системные переменные
BINDTYPE | Управление обработкой имен внешних ссылок при внедрении или редактировании внешних ссылок.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с файлом журнала внешних ссылок - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Работа с файлом журнала внешних ссылок
Понятия
Процедуры
Команды

Программа может вести журнал действий при выполнении операций вставки, удаления и обновления ссылок, а также при загрузке чертежей, содержащих внешние ссылки. Запись в журнал производится, если системной переменной XREFCTL присвоено значение 1. По умолчанию значение переменной равно 0.

Журнал представляет собой обычный текстовый ASCII-файл с тем же именем, что и у текущего чертежа, и с расширением .xlg. При загрузке чертежа с именем файла, например, sample.dwg, программа ищет в текущей папке файл журнала sample.xlg. Если файл не существует, будет создан новый файл с таким именем.

Если для чертежа создан файл журнала, программа будет добавлять в него информацию о чертеже. Каждый раз при открытии файла программа записывает в файл журнала основную надпись. Файл журнала, имеющий слишком большой размер, можно удалить.

Пример: образец блока заголовка в файле журнала внешних ссылок

Данный блока заголовка содержит имя текущего чертежа, дату, время и произведенные в файле операции.

=============================
Чертеж: деталь
Дата/Время: 09/28/99 10:45:20
Операция: вставка внешней ссылки
=============================

При удалении или обновлении ссылок сразу после блока заголовка программа указывает уровни вложенности всех обрабатываемых внешних ссылок. Таким образом, в файле журнала можно просмотреть дерево набора внешних ссылок текущего чертежа как результат использования опции "Удалить" или "Обновить".

Пример: образец записи в файле журнала с указанием вложенных внешних ссылок

В следующем примере ссылка ENTRY_DR содержит в себе две вложенных внешних ссылки: HARDWARE и PANELS. Каждая из последних двух ссылок, в свою очередь, также содержит по две внешних ссылки.

==============================
 Чертеж: деталь
 Дата/Время: 10/05/99 15:47:39
 Операция: обновление внешней ссылки
=============================
Дерево ссылок для ENTRY_DR:

Вн-ссыл. ENTRY_DR Xref

-Вн-ссыл.HARDWARE

--Вн-ссыл. LOCKSET

--Вн-ссыл. HINGES

-Вн-ссыл.PANELS

--Вн-ссыл. UPPER

--Вн-ссыл. LOWER

 Программа заносит в журнал сведения о каждом зависимом именованном объекте, временно добавленном в текущий чертеж, и о каждой обнаруженной ошибке. Большинство сообщений об ошибках выводится и на экран, и в файл журнала.

Пример: образец файла журнала с результатом вставки внешней ссылки

В следующем примере показана часть файла журнала, содержащая записи о процессе вставки в рабочий чертеж test.dwg внешней ссылки STAIR. Записи свидетельствуют об изменениях в таблице описаний (символов) и включают в себя имена добавленных описаний и статусные сообщения.

==============================

 Чертеж: тест

 Дата/Время: 12/18/99 14:06:34

 Операция: вставка внешней ссылки

=============================

Вставка внешней ссылки STAIR: \ACAD\DWGS\STAIR.dwg

    Поиск в стандартных папках ACAD

    Обновление символьной таблицы блоков:

     Добавление символа: STAIR|BOLT

     Добавление символа: STAIR|BOLT-HALF

     ...

    Обновление блоков завершено.

    Обновление символьной таблицы типов линий:

     Добавление символа: STAIR|DASHED

     Добавление символа: STAIR|CENTER

     Добавление символа: STAIR|PHANTOM

    Обновление типов линий завершено.

    Обновление символьной таблицы слоев:

     Добавление символа: STAIR|STEEL-HIDDEN

     Добавление символа: STAIR|OAK

     ...

    Обновление слоев завершено.

Чертеж STAIR загружен.


Использование файла журнала внешних ссылок - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Работа с файлом журнала внешних ссылок
Понятия
Процедуры
Команды

Использование файла журнала внешних ссылок

  1. В командной строке введите xrefctl.
  2. Введите 1 для включения режима ведения журнала или 0 для отключения.
  3. Нажмите ENTER.

    4. По умолчанию журнал не ведется.


Работа с файлом журнала внешних ссылок - Команды

Внешние ссылки
Внешние ссылки
Работа с файлом журнала внешних ссылок
Понятия
Процедуры
Команды

Команды
ССЫЛКА | Запуск команды ВНССЫЛКИ
Системные переменные
XREFCTL | Управляет созданием файлов журналов внешних ссылок (XLG)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Увеличение производительности при работе с большими внешними чертежами - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Увеличение производительности при работе с большими внешними чертежами
Понятия
Процедуры
Команды

Имеется несколько функций, которые могут повысить производительность при работе с большими чертежами, вставленными в качестве внешних ссылок.

  • Коротко о подгрузке
    Краткое обзорное описание использования режима подгрузки для повышения скорости обработки чертежей с внешними ссылками больших размеров.
  • Выгрузка внешних ссылок
    Временная выгрузка вхождений DWG (внешних ссылок) из чертежа позволяет сократить время, требующееся на его чтение с диска, и уменьшить объем используемой памяти.
  • Использование подгрузки
    Использование подгрузки позволяет загружать в память только необходимую для регенерации текущего чертежа информации.
  • Использование слоевых и пространственных указателей
    Для обеспечения максимальной производительности при использовании подгрузки рекомендуется сохранять все файлы внешних ссылок с пространственным и слоевым указателями.
  • Задание пути к временным копиям внешних ссылок
    При включении режима подгрузки ссылок с копированием, можно задать путь к создаваемым копиям файлов внешних чертежей.


Увеличение производительности при работе с большими внешними чертежами - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Увеличение производительности при работе с большими внешними чертежами
Понятия
Процедуры
Команды

Выгрузка внешней ссылки

Включение режима подгрузки ссылок

Сохранение чертежа с пространственным и слоевым указателями

Задание пути к копиям файлов внешних ссылок


Увеличение производительности при работе с большими внешними чертежами - Команды

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Увеличение производительности при работе с большими внешними чертежами
Понятия
Процедуры
Команды
Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ССЫЛКА | Запуск команды ВНССЫЛКИ
Системные переменные
INDEXCTL | Управляет созданием слоевых и пространственных индексов и сохранением их в файле чертежа
TREEDEPTH | Указывает максимальное количество ветвлений древовидного пространственного индекса
TREEMAX | Снижает использование памяти при регенерации чертежа путем ограничения числа узлов в пространственном индексе (дерево октантов)
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
XLOADPATH | Создает путь для хранения временных копий файлов подгруженных внешних ссылок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о подгрузке - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Коротко о подгрузке
Понятия
Процедуры
Команды

Краткое обзорное описание использования режима подгрузки для повышения скорости обработки чертежей с внешними ссылками больших размеров.

Программа использует режим подгрузки и сохранения чертежей с указателями, позволяющий повысить производительность обработки больших внешних чертежей, которые были подрезаны в программе или содержащие много объектов на замороженных слоях. При подгрузке внешних ссылок программа загружает в память только те фрагменты ссылок, которые необходимы для регенерации текущего чертежа. Другими словами внешняя информация считывается “по требованию.” На режим подгрузки влияют значения системных переменных INDEXCTL, XLOADCTL и XLOADPATH.


Увеличение производительности при работе с большими внешними чертежами

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Увеличение производительности при работе с большими внешними чертежами
Понятия
Процедуры
Команды

Нет процедур.


Коротко о подгрузке - Команды

Внешние ссылки
Внешние ссылки
Коротко о подгрузке
Понятия
Процедуры
Команды

Команды
ССЫЛКА | Запуск команды ВНССЫЛКИ
Системные переменные
INDEXCTL | Управляет созданием слоевых и пространственных индексов и сохранением их в файле чертежа
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
XLOADPATH | Создает путь для хранения временных копий файлов подгруженных внешних ссылок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выгрузка внешних ссылок - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Выгрузка внешних ссылок
Понятия
Процедуры
Команды

Временная выгрузка ссылок из чертежа позволяет сократить время, требующееся на его чтение с диска, и уменьшить объем используемой памяти. Описание ссылки удаляется из чертежа; в нем остается лишь указатель на используемый внешний чертеж. Графические объекты выгруженной ссылки на экран не выводятся; зависимые от ссылки символы также не читаются и не заносятся в символьную таблицу. Для восстановления ссылки необходимо обновить ее. Если системная переменная XLOADCTL (режим подгрузки ссылок) равна 1, при выгрузке ссылки происходит разблокирование ее файла.

Ссылки рекомендуется выгружать в случае, если они более не используются в текущем сеансе, но могут понадобиться при дальнейшем выводе чертежа на печать. Для удобства можно составить список выгруженных ссылок, которые потребуется обновить впоследствии.


Выгрузка внешней ссылки - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Выгрузка внешних ссылок
Понятия
Процедуры
Команды

Выгрузка внешней ссылки

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" выберите имя ссылки, которое требуется выгрузить.
  3. Нажмите правую кнопку мыши и выберите "Выгрузить".

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ


Выгрузка внешних ссылок - Команды

Внешние ссылки
Внешние ссылки
Выгрузка внешних ссылок
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование подгрузки - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Использование подгрузки
Понятия
Процедуры
Команды

Использование подгрузки позволяет загружать в память только необходимую для регенерации текущего чертежа информации.

Сохранение чертежей-ссылок со слоевыми и пространственными указателями дает возможность почувствовать преимущества использования подгрузки. Повышение производительности особенно заметно в следующих случаях:

  • Выполнение подрезки внешней ссылки с помощью программы для отображения ее небольшого фрагмента. Пространственный указатель сохраняется в чертеже внешней ссылки.
  • Замораживание нескольких слоев внешней ссылки. Чертёж внешней ссылки сохраняется с указателем слоёв.

При включенном режиме подгрузки после подрезки внешних ссылок, имеющих пространственные указатели, из ссылок читаются только те объекты, которые расположены в пределах контура подрезки. При изменении контура подрезки, выполняется дополнительная загрузка объектов, оказавшихся в его границах. Аналогичным образом, после замораживания слоев в ссылках, имеющих указатели слоев, из ссылок читаются только объекты, находящиеся на размороженных слоях. При размораживании слоев, зависимых от внешних ссылок, программа считывает данные об их геометрии с внешнего чертежа.

Если подгрузка ссылок включена, программа блокирует все связанные чертежи, чтобы обеспечить возможность считывания любых требуемых для подгрузки объектов. В результате пользователь, работающий с главным файлом, всегда может беспрепятственно получить доступ к файлам ссылок и подгрузить требуемые объекты. Другим пользователям в это время разрешен лишь просмотр блокированных чертежей; внесение изменений в них не допускается. Если такая стратегия не устраивает коллектив разработчиков, следует применять подгрузку с копированием.

При включении подгрузки с копированием программа создает временную копию файла внешнего чертежа и осуществляет подгрузку временного файла. Никакой блокировки исходных файлов не производится, и они остаются доступными для любых изменений. При отключении режима подгрузки программа считывает ссылку полностью, независимо от состояния слоев и наличия контуров подрезки.

Пространственные и слоевые указатели впервые были реализованы в приложениях AutoCAD Release 14 и AutoCAD LT 97. При вставке в качестве внешней ссылки чертежа, сохраненного в формате более ранних версий программы, преимущества использования указателей не так ощутимы. Для достижения максимальной производительности следует выполнять подгрузку чертежей, сохраненных с пространственными и слоевыми указателями в приложениях AutoCAD Release 14, AutoCAD LT 97 или более поздних версий.


Включение режима подгрузки ссылок - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Использование подгрузки
Понятия
Процедуры
Команды

Включение режима подгрузки ссылок

  1. Нажмите "Сервис" » "Настройки".
  2. На вкладке "Открытие/Сохранение" диалогового окна "Параметры" выберите "Запрещена", "Разрешена" или "Разрешена с копированием".
  3. Нажмите "ОК".


Использование подгрузки - Команды

Внешние ссылки
Внешние ссылки
Использование подгрузки
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
INDEXCTL | Управляет созданием слоевых и пространственных индексов и сохранением их в файле чертежа
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование слоевых и пространственных указателей - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Использование слоевых и пространственных указателей
Понятия
Процедуры
Команды

Для обеспечения максимальной производительности при использовании подгрузки рекомендуется сохранять все файлы внешних ссылок с пространственным и слоевым указателями.

Указатель слоя представляет собой список слоев с перечнем объектов, расположенных на каждом из них. Этот список используется программой при обращении к чертежу в ходе подгрузки, чтобы определить, какие объекты необходимо считать и отобразить. При наличии у внешнего чертежа указателя слоя и включенном режиме подгрузки объекты с замороженных слоев внешнего чертежа не считываются.

Пространственный указатель организует объекты по их положению в 3D пространстве. Это позволяет эффективно определять, какие объекты подлежат считыванию в ходе подгрузки подрезанной внешней ссылки. Если подгрузка включена, а чертеж вставлен как внешняя ссылка и выполнена его подрезка, при обращении к файлу внешней ссылки в ходе подгрузки программа использует пространственный указатель, чтобы определить, какие объекты лежат в пределах контура подрезки. Затем программа считывает только эти объекты в текущий рабочий сеанс.

Наиболее эффективно пространственный и слоевой указатели используются в процессе подгрузки файла внешней ссылки, вставленной в другой чертеж. Выигрыш в производительности при обработке файлов, не используемых в качестве внешних ссылок, с помощью слоевых и пространственных указателей или подгрузки достигнут быть не может.


Использование слоевых и пространственных указателей - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Использование слоевых и пространственных указателей
Понятия
Процедуры
Команды

Сохранение чертежа с пространственным и слоевым указателями


Сохранение чертежа с пространственным и слоевым указателями - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Использование слоевых и пространственных указателей
Понятия
Процедуры
Команды

Сохранение чертежа с пространственным и слоевым указателями

  1. Нажмите "Файл" » "Сохранить как".
  2. В диалоговом окне "Сохранение чертежа" выберите "Сервис" » "Параметры".

  3. В диалоговом окне "Параметры сохранения" из списка "Тип указателя" выберите "Слоевой", "Пространственный" или "Оба". Нажмите "ОК".

    4. Примечание При сохранении частично открытого чертежа, не имеющего пространственного и слоевого указателей, эта опция недоступна.

  4. Нажмите кнопку "Сохранить".


Использование слоевых и пространственных указателей - Команды

Внешние ссылки
Внешние ссылки
Использование слоевых и пространственных указателей
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
INDEXCTL | Управляет созданием слоевых и пространственных индексов и сохранением их в файле чертежа
TREEDEPTH | Указывает максимальное количество ветвлений древовидного пространственного индекса
TREEMAX | Снижает использование памяти при регенерации чертежа путем ограничения числа узлов в пространственном индексе (дерево октантов)
XLOADCTL | Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание пути к временным копиям внешних ссылок - Понятия

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание пути к временным копиям внешних ссылок
Понятия
Процедуры
Команды

При включении режима подгрузки ссылок с копированием можно использовать системную переменную XLOADPATH для указания пути к копиям внешних чертежей. Заданный путь действует для всех сеансов работы с чертежом вплоть до указания иного пути. Если значение для переменной XLOADPATH не задано, временные копии файлов записываются в стандартную папку для временных файлов.

Если скорость работы с внешними ссылками в сети недостаточно высока, следует присвоить переменной XLOADCTL значение 2 (подгрузка с копированием) и задать в переменной XLOADPATH одну из локальных папок для сохранения копий файлов внешних ссылок. И наоборот, чтобы сократить число создаваемых различными пользователями временных файлов, относящихся к одному и тому же файлу, необходимо задать для копий в переменной XLOADPATH одну из совместно используемых папок сети. Тогда несколько пользователей могут обращаться к одной и той же временной копии чертежа внешней ссылки.

Установка переменной XLOADPATH может быть выполнена в диалоговом окне "Настройка"; она задает путь размещения копий внешних файлов, на которых производились ссылки.


Задание пути к временным копиям внешних ссылок - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание пути к временным копиям внешних ссылок
Понятия
Процедуры
Команды

Задание пути к копиям файлов внешних ссылок


Задание пути к копиям файлов внешних ссылок - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние ссылки
Задание пути к временным копиям внешних ссылок
Понятия
Процедуры
Команды

Задание пути к копиям файлов внешних ссылок

  1. Нажмите "Сервис" » "Настройки".
  2. На вкладке "Файлы" диалогового окна "Параметры" выберите папку Папка для временных файлов внешних ссылок.

    3. Здесь выводится путь, по которому производится размещение копий файлов внешних ссылок. Если путь не задан, временные копии сохраняются в папку, заданную элементом "Папка для временных файлов".

  3. Выберите нужный путь и отредактировать его.
  4. Нажмите кнопку "OK" (или "Применить") для задания пути.


Задание пути к временным копиям внешних ссылок - Команды

Внешние ссылки
Внешние ссылки
Задание пути к временным копиям внешних ссылок
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
XLOADPATH | Создает путь для хранения временных копий файлов подгруженных внешних ссылок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Составные документы и технология OLE - Понятия

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Понятия
Процедуры
Команды

С помощью технологии связывания и внедрения объектов (OLE), реализованной в Microsoft Windows, можно копировать и размещать информацию из одного приложения в другое, сохраняя возможность редактирования ее в исходном приложении.

С помощью технологии связывания и внедрения объектов (OLE), реализованной в Windows, можно копировать и размещать информацию из разных приложений в одном документе. Это может быть, например, страница Adobe PageMaker, включающая в себя чертеж AutoCAD, или чертеж AutoCAD, содержащий таблицу Microsoft Excel или ее часть.

  • Коротко о связывании и внедрении объектов
  • Импорт OLE-объектов
    Имеется возможность импорта данных из приложений, поддерживающих OLE, в чертеж.
  • Экспорт OLE-объектов из чертежей
    Виды чертежа можно связывать или внедрять в документы других приложений, поддерживающих технологию OLE.
  • Редактирование OLE-объектов в чертежах
    Пользователь может отредактировать связанные или внедренные в чертеж OLE-объекты. Для этого нужно дважды нажать на объекте, чтобы открыть приложение-сервер, с помощью которого выполняется редактирование.

См. также

Использование буфера обмена Windows


Составные документы и технология OLE - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Понятия
Процедуры
Команды

Установка качества печати OLE-объектов

Связывание объектов с чертежом

Связывание с чертежом целого файла как OLE-объекта

Обновление связей вручную

Редактирование связи с OLE-объектом

Разрыв связи с OLE-объектом

Внедрение OLE-объекта в чертеж

Создание объекта в другом приложении и его внедрение в чертеж

Изменение размеров OLE-объекта

Масштабирования текста в OLE-объекте согласно его шрифту

Внедрение OLE-объекта в другой документ

Связывание вида с другим документом

Редактирование связанного чертежа из приложения-приемника

Изменение связанного чертежа в исходном приложении

Редактирование внедренных объектов AutoCAD

Восстановление исходных размеров и формы OLE-объекта

Управление отображением OLE-объектов

Включение-отключение отображения рамок OLE-объекта


Составные документы и технология OLE - Команды

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Понятия
Процедуры
Команды
Команды
ВБУФЕР | Занесение объектов в буфер обмена с удалением их из чертежа
ВСТБУФЕР | Вставка содержимого буфера обмена
КБУФЕР | Копирует объекты или текст из командной строки в буфер обмена
КОПИРВИД | Копирование текущего вида в буфер обмена для связывания с другими OLE-приложениями
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
О | Отмена самой последней операции
ОЛЕСВОЙСТВА | Настройка размера, масштаба и других свойств выбранного OLE-объекта
СТЕРЕТЬ | Удаление объектов из чертежа
Системные переменные
MSOLESCALE | Управляет размером объектов OLE, в которых текст вставлен в пространство модели
OLEFRAME | Управляет отображением и печатью рамок для всех объектов OLE чертежа
OLEHIDE | Управляет отображением и выводом на печать объектов OLE
OLEQUALITY | Устанавливает качества печати объектов OLE по умолчанию
OLESTARTUP | Управляет загрузкой исходного приложения, в котором был создан внедренный OLE объект, при печати
WMFBKGND | Управляет отображением фона при вставке объектов в формат метафайлов Windows (WMF)
WMFFOREGND | Управляет назначением цвета переднего плана при вставке объектов в формат метафайла Windows (WMF)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о связывании и внедрении объектов - Понятия

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Коротко о связывании и внедрении объектов
Понятия
Процедуры
Команды

Связывание и внедрение объектов позволяет использовать информацию из одного приложения в другом. Для использования технологии OLE необходимо, чтобы и исходное приложение, и целевое приложение поддерживали OLE.

И при связывании, и при внедрении производится вставка информации из одного документа в другой. Далее, в обоих случаях редактирование объекта производится в документе приложения-приемника. Однако результаты связывания и внедрения объектов отличаются друг от друга методом хранения информации.

По своей сути внедрение объектов и их связывание подобны вставке блоков и созданию внешних ссылок.

Внедрение объектов

При внедрении методом OLE в составном документе размещается копия внедренных данных. Эта копия теряет связь с исходным документом. Внедренные данные в составном документе могут редактироваться с помощью приложения, в котором они были созданы; но исходный документ при этом не изменяется. При внедрении объектов связь с исходным файлом не поддерживается. Внедрение следует применять, если модификация исходного документа при редактировании составного нежелательна.

Связывание объектов

При связывании методом OLE создается ссылка между документом сервера и составным документом. Связь является удобным способом использования одних и тех же данных в различных документах: если исходные данные модифицируются, для изменения составных документов требуется лишь обновление связей. Большинство приложений-приемников могут также быть настроены на автоматическое их обновление.

При установлении связи чертежа необходимо поддерживать доступ и к исходному приложению, и к документу. Если что-либо из них переименовано или перемещено, может потребоваться повторное задание связи.

Управление качеством представления OLE-объектов при печати

При использовании растрового устройства печати OLE-объекты рассматриваются как растровые. Так как крупные, полноцветные растровые изображения с высоким разрешением весьма неэкономичны при печати, можно управлять выводом каждого объекта на печать с помощью системной переменной OLEQUALITY. По умолчанию она настроена на автоматический выбор, при этом значении качество печати задается в соответствии с типом объекта. Объем затраченных на печать времени и памяти напрямую зависит от заданного качества печати.

Качество печати объектов OLE может также настраиваться в редакторе параметров плоттера. При разворачивании опции "Графика" появляется элемент "Растровая графика", в котором можно настроить качество печати OLE-объектов.

Примечание Вложенные OLE-объекты могут служить причиной возникновения проблем. Например, если в чертеж вставляется документ Word, в который внедрена таблица Excel, это может привести к сбою в ходе печати. Кроме того, OLE-объекты, которые не лежат в плоскости текущего вида, не выводится на печать, однако у них (в зависимости от значения системной переменной OLEFRAME) могут оказаться напечатаны ограничивающие рамки.

См. также

Использование буфера обмена Windows


Установка качества печати OLE-объектов - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Коротко о связывании и внедрении объектов
Понятия
Процедуры
Команды

Установка качества печати OLE-объектов

  1. Нажмите "Сервис" » "Настройки".
  2. В диалоговом окне "Настройка" перейдите на вкладку "Печать/публикация" и из списка "Качество печати OLE" выберите один из следующих параметров:
    • Монохромное. Например таблицы
    • Простая графика. Например цветной текст и круговые диаграммы
    • Сложная графика. Например фотографии
    • Автоматический выбор. Параметры качества печати задаются в соответствии с типом файла
  3. Чтобы продолжить выбор параметров, нажмите "Применить"; для закрытия диалогового окна нажать "ОК".


Коротко о связывании и внедрении объектов - Команды

Составные документы и технология OLE
Составные документы и технология OLE
Коротко о связывании и внедрении объектов
Понятия
Процедуры
Команды

Команды
КОПИРВИД | Копирование текущего вида в буфер обмена для связывания с другими OLE-приложениями
Системные переменные
OLEHIDE | Управляет отображением и выводом на печать объектов OLE
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Импорт OLE-объектов - Понятия

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Импорт OLE-объектов
Понятия
Процедуры
Команды

Имеется возможность импорта данных из приложений, поддерживающих OLE, в чертеж.

  • Коротко об импорте OLE-объектов в чертежи
  • Связывание OLE-объектов с чертежами
    Связывание данных документа с чертежом позволяет при модифицировании исходного документа обновлять данные в чертеже.
  • Внедрение OLE-объектов в чертежи
    Внедренные в чертежи данные при модифицировании исходного документа не обновляются.


Импорт OLE-объектов - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Импорт OLE-объектов
Понятия
Процедуры
Команды

Связывание объектов с чертежом

Связывание с чертежом целого файла как OLE-объекта

Обновление связей вручную

Редактирование связи с OLE-объектом

Разрыв связи с OLE-объектом

Внедрение OLE-объекта в чертеж

Создание объекта в другом приложении и его внедрение в чертеж

Изменение размеров OLE-объекта

Масштабирования текста в OLE-объекте согласно его шрифту


Импорт OLE-объектов - Команды

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Импорт OLE-объектов
Понятия
Процедуры
Команды
Команды
ВСТБУФЕР | Вставка содержимого буфера обмена
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОЛЕСВОЙСТВА | Настройка размера, масштаба и других свойств выбранного OLE-объекта
Системные переменные
MSOLESCALE | Управляет размером объектов OLE, в которых текст вставлен в пространство модели
OLEHIDE | Управляет отображением и выводом на печать объектов OLE
OLEQUALITY | Устанавливает качества печати объектов OLE по умолчанию
OLESTARTUP | Управляет загрузкой исходного приложения, в котором был создан внедренный OLE объект, при печати
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко об импорте OLE-объектов в чертежи - Понятия

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Коротко об импорте OLE-объектов в чертежи
Понятия
Процедуры
Команды

Для вставки информации из другого приложения в качестве OLE-объекта может использоваться один из следующих способов:

  • Копирование или вырезание данных из существующего файла и вставка их в чертеж.
  • Импорт существующего файла, созданного в другом приложении.
  • Открытие другого приложения из чертежа и создание в нем данных для дальнейшего использования.

При вставке информации необходимо указать точку вставки.

По умолчанию OLE-объекты отображаются в рамке, которая не выводится на печать. OLE-объекты являются непрозрачными; при печати они скрывают объекты, расположенные за ними. Для OLE-объектов поддерживается настройка порядка прорисовки. Пользователь может управлять отображением OLE-объектов двумя способами:

  • изменить значение системной переменной OLEHIDE для отображения или подавления OLE-объектов в пространстве листа и/или модели;
  • отключить или заморозить слой, на котором размещаются OLE-объекты, для подавления их вывода.

При печати OLE-объектов, которые содержат текст, размер текста масштабируется так, чтобы приближенно соответствовать размеру текста в исходном приложении.

Примечание OLE-объекты не отображаются и не печатаются во внешних ссылках и вхождениях блоков.


Импорт OLE-объектов

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Импорт OLE-объектов
Понятия
Процедуры
Команды

Нет процедур.


Коротко об импорте OLE-объектов в чертежи - Команды

Составные документы и технология OLE
Составные документы и технология OLE
Коротко об импорте OLE-объектов в чертежи
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОЛЕСВОЙСТВА | Настройка размера, масштаба и других свойств выбранного OLE-объекта
Системные переменные
MSOLESCALE | Управляет размером объектов OLE, в которых текст вставлен в пространство модели
OLEHIDE | Управляет отображением и выводом на печать объектов OLE
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Связывание OLE-объектов с чертежами - Понятия

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Связывание OLE-объектов с чертежами
Понятия
Процедуры
Команды

Имеется возможность связывания данных документов, созданных в других приложениях, с чертежами. Например, в чертеж можно вставить автоматически обновляемую электронную таблицу. Можно также устанавливать в чертеже значки средств мультимедиа, активизируемые двойным щелчком.

Обновление связей

Можно настроить либо автоматическое, либо ручное обновление связей при изменении данных в документе-сервере. По умолчанию связи автоматически обновляются. Переключение режима обновления связей производится системной переменной OLELINKS.

Повторное задание связей

Так как установленная связь является ссылкой на источник данных сервера, при перемещении или переименовании файла-сервера необходимо задать ее вновь.

Разрыв связей

При разрыве связи данные, вставленные ранее в чертеж, не уничтожаются, удаляется только связь. Связь следует разорвать, как только отпадает необходимость обновления данных.


Связывание OLE-объектов с чертежами - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Связывание OLE-объектов с чертежами
Понятия
Процедуры
Команды

Связывание объектов с чертежом

Связывание с чертежом целого файла как OLE-объекта

Обновление связей вручную

Редактирование связи с OLE-объектом

Разрыв связи с OLE-объектом


Связывание объектов с чертежом - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Связывание OLE-объектов с чертежами
Понятия
Процедуры
Команды

Связывание объектов с чертежом

  1. Запустите исходное приложение и открыть в нем документ.
  2. Выделите и скопируйте в буфер обмена связываемые данные документа.
  3. Откройте чертеж.
  4. Нажмите "Правка" » "Специальная вставка...".
  5. В диалоговом окне "Специальная вставка" выбрать опцию "Вставить связь".

    6. В этом случае при вставке содержимого буфера обмена устанавливается связь с исходным файлом. В противном случае (при активной опции "Вставить") происходит внедрение объекта.

  6. Из списка "Как" выберите требуемый формат данных.
  7. Нажмите "ОК".

Ввод команды: ВСТАВПРБ


Связывание с чертежом целого файла как OLE-объекта - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Связывание OLE-объектов с чертежами
Понятия
Процедуры
Команды

Связывание с чертежом целого файла как OLE-объекта

  1. Откройте чертеж.
  2. Нажмите "Вставка" » "Объект...".
  3. В диалоговом окне "Вставка объекта" установите текущей опцию "Создать из файла".
  4. Поднимите флажок "Связь". Нажмите кнопку "Обзор".
  5. В диалоговом окне "Обзор" выберите файл, который необходимо связать. Нажмите кнопку "Открыть".
  6. В диалоговом окне "Вставка объекта" нажмите "ОК".

    7. Файл связывается с чертежом.

Ввод команды: ВСТ ОБКТ


Обновление связей вручную - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Связывание OLE-объектов с чертежами
Понятия
Процедуры
Команды

Обновление связей вручную

  1. Нажмите "Правка" » "Связи...".
  2. В диалоговом окне "Связи" выберите обновляемые связи.
  3. Нажмите "Обновить".
  4. Нажмите кнопку "Закрыть".

Примечание Если обновляемые связи необходимо выбрать непосредственно в области чертежа без использования списка диалогового окна "Связи", то нужно выбрать объекты перед тем, как выполнить действие пункта 1.

Ввод команды: ВНЕДРСВЯЗИ


Редактирование связи с OLE-объектом - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Связывание OLE-объектов с чертежами
Понятия
Процедуры
Команды

Редактирование связи с OLE-объектом

  1. В чертеже выберите OLE-объект, связь которого должна быть отредактирована.
  2. Нажмите "Правка" » "Связи...".
  3. В диалоговом окне "Связи" нажмите кнопку "Сменить источник".
  4. В диалоговом окне "Смена источника" найдите новый файл-источник.
  5. Выберите исходный файл. Нажать кнопку "Открыть".
  6. Нажмите "ОК".

Ввод команды: ВНЕДРСВЯЗИ


Разрыв связи с OLE-объектом - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Связывание OLE-объектов с чертежами
Понятия
Процедуры
Команды

Разрыв связи с OLE-объектом

  1. Выберите объект, связь которого разрывается.
  2. Из меню "Правка" выберите "Связи".
  3. В диалоговом окне "Связи" нажмите кнопку "Разорвать связь".
  4. Нажмите "Да".
  5. Нажмите кнопку "Закрыть".

Ввод команды: ВНЕДРСВЯЗИ


Связывание OLE-объектов с чертежами - Команды

Составные документы и технология OLE
Составные документы и технология OLE
Связывание OLE-объектов с чертежами
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОЛЕСВОЙСТВА | Настройка размера, масштаба и других свойств выбранного OLE-объекта
Системные переменные
OLEHIDE | Управляет отображением и выводом на печать объектов OLE
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Внедрение OLE-объектов в чертежи - Понятия

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Внедрение OLE-объектов в чертежи
Понятия
Процедуры
Команды

Внедренные в чертежи данные при модифицировании исходного документа не обновляются.

Объекты можно внедрять в чертежи путем их копирования в буфер обмена с последующей вставкой в файл чертежа. Таким образом, например, производится добавление логотипа фирмы, созданного в другом приложении, в чертеж.

Перетаскивание объектов в чертеж

Данные и графику, выбранные в окне другого приложения, можно добавить в чертеж, перетаскивая их мышью по экрану. Как окно AutoCAD, так и окно другого приложения при этом должно быть открыто и не свернуто. Перетаскивание между приложениями возможно, только если второе приложение поддерживает технологию ActiveX. Объекты, перенесенные таким образом, становятся внедренными (а не связанными).

Обычное перетаскивание данных аналогично их последовательному вырезанию и вставке. Данные полностью удаляются из документа-сервера и вставляются в составной документ. Если же перетаскивание производится при нажатой клавише CTRL, вместо вырезания осуществляется копирование; в составном документе создается копия данных, а исходный их вариант остается неизменным.


Внедрение OLE-объектов в чертежи - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Внедрение OLE-объектов в чертежи
Понятия
Процедуры
Команды

Внедрение OLE-объекта в чертеж

Создание объекта в другом приложении и его внедрение в чертеж

Изменение размеров OLE-объекта

Масштабирования текста в OLE-объекте согласно его шрифту


Внедрение OLE-объекта в чертеж - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Внедрение OLE-объектов в чертежи
Понятия
Процедуры
Команды

Внедрение OLE-объекта в чертеж

  1. Откройте документ в исходном приложении.
  2. Скопируйте внедряемые данные в буфер обмена.
  3. Откройте чертеж.
  4. Нажмите "Правка" » "Вставить".
  5. Нажмите "ОК".

Ввод команды: ВСТБУФЕР


Создание объекта в другом приложении и его внедрение в чертеж - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Внедрение OLE-объектов в чертежи
Понятия
Процедуры
Команды

Создание объекта в другом приложении и его внедрение в чертеж

  1. Откройте чертеж.
  2. Нажмите "Вставка" » "Объект...".
  3. В диалоговом окне "Вставка объекта" в разделе "Тип объекта" выберите параметр "Создать новый".
  4. Из списка "Тип объекта" выберите приложение. Нажмите кнопку "OK".

    5. Открывается исходное приложение.

  5. С помощью приложения-сервера создайте данные для вставки. Сохраните документ.
  6. Из меню "Файл" исходного приложения выберите "Обновить".
  7. Закройте исходное приложение.

    8. OLE-объект внедряется в чертеж.

Ввод команды: ВСТ ОБКТ


Изменение размеров OLE-объекта - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Внедрение OLE-объектов в чертежи
Понятия
Процедуры
Команды

Изменение размеров OLE-объекта

  1. Укажите правой кнопкой мыши объект OLE. Выберите "Свойства".
  2. На палитре свойств введите новые значения ширины и высоты, или введите процент масштаба для высоты и ширины.

    3. Примечание Если при поднятом флажке "Не изменять пропорции" изменить одно из значений ("Ширина" или "Высота"), то другое изменится автоматически. Например, если задать значение высоты в пятьдесят процентов, значение ширины также изменится и станет равным пятидесяти процентам. Если необходимо изменить только высоту или ширину, следует сбросить флажок "Не изменять пропорции".

  3. Нажмите "OK" для принятия изменений.

Ввод команды: ОКОНСВ


Масштабирования текста в OLE-объекте согласно его шрифту - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Внедрение OLE-объектов в чертежи
Понятия
Процедуры
Команды

Масштабирования текста в OLE-объекте согласно его шрифту

  1. Выберите OLE-объект.
  2. Нажмите правую кнопку мыши. Выберите пункт "OLE" » "Размер текста".
  3. В группе "Размер текста" выберите шрифт из раскрывающегося списка.

    4. В списке перечисляются все шрифты, появляющиеся в выбранном OLE-объекте.

  4. Выберите размер шрифта.

    5. В этом списке перечисляются все размеры, доступные для выбранного шрифта.

  5. В поле "Высота" введите значение в единицах чертежа.

    6. Это будет высота текста в чертеже, набранного указанным шрифтом указанного размера. Например, если выбрать шрифт Arial и размер 10 пунктов, а затем введите 0,5 в поле "Высота текста", то все тексты в выбранном OLE-объекте, набранные изначально шрифтом Arial размером 10 пунктов, в чертеже примут высоту 0,5 единиц чертежа. Все остальные тексты в объекте изменяют свой размер пропорционально выбранному базовому шрифту. Рамка объекта также перенастраивается в соответствии с новыми размерами текстов.

Ввод команды: ОЛЕСВОЙСТВА


Внедрение OLE-объектов в чертежи - Команды

Составные документы и технология OLE
Составные документы и технология OLE
Внедрение OLE-объектов в чертежи
Понятия
Процедуры
Команды

Команды
ВСТБУФЕР | Вставка содержимого буфера обмена
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОЛЕСВОЙСТВА | Настройка размера, масштаба и других свойств выбранного OLE-объекта
Системные переменные
OLEHIDE | Управляет отображением и выводом на печать объектов OLE
OLEQUALITY | Устанавливает качества печати объектов OLE по умолчанию
OLESTARTUP | Управляет загрузкой исходного приложения, в котором был создан внедренный OLE объект, при печати
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Экспорт OLE-объектов из чертежей - Понятия

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Экспорт OLE-объектов из чертежей
Понятия
Процедуры
Команды

Виды чертежа можно связывать или внедрять в документы других приложений, поддерживающих технологию OLE.

Связывание видов с другими документами

Чертеж может играть роль документа-сервера и иметь связи с одним или несколькими составными документами. Копирование вида в буфер обмена из текущего видового экрана или пространства листа выполняется командой КСВЯЗЬ. Можно затем вставить вид в документ-приемник.

При вставке в документ неименованного вида ему назначается имя, подобное OLE1. При выходе из чертежа предлагается сохранить изменения в новом именованном виде. Для того чтобы сформировать связь и сохранить вид под именем OLE1, необходимо выполнить сохранение чертежа.

Внедрение объектов чертежей в другие документы

Имеется возможность выбирать и внедрять объекты чертежей в документы других приложений. При этом происходит размещение копии выбранного объекта в составном документе. При вызове AutoCAD из другого приложения для редактирования OLE-объекта изменения никак не отображаются в исходном чертеже.


Экспорт OLE-объектов из чертежей - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Экспорт OLE-объектов из чертежей
Понятия
Процедуры
Команды

Внедрение OLE-объекта в другой документ

Связывание вида с другим документом


Внедрение OLE-объекта в другой документ - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Экспорт OLE-объектов из чертежей
Понятия
Процедуры
Команды

Внедрение OLE-объекта в другой документ

  1. Нажмите "Правка" » "Копировать".
  2. В области чертежа выберите объекты, которые требуется внедрить, и нажмите ENTER.

    3. Выбранные объекты копируются в буфер обмена Windows.

  3. Откройте приложение-приемник. Создайте в нем новый или откройте существующий документ.
  4. Вставьте содержимое буфера обмена в документ, следуя подсказкам приложения по внедрению содержимого буфера обмена.

Ввод команды: КБУФЕР


Связывание вида с другим документом - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Экспорт OLE-объектов из чертежей
Понятия
Процедуры
Команды

Связывание вида с другим документом

  1. Сохраните чертеж, который требуется связать, так как он обязательно должен иметь имя.
  2. Если открыто несколько видовых экранов, выберите один из них.
  3. Нажмите "Правка" » "Копировать вид".

    4. Вид копируется в буфер обмена.

  4. Создайте новый или откройте существующий документ в приложении-приемнике.
  5. Вставьте содержимое буфера обмена в документ, следуя подсказкам приложения по вставке связанных данных.

    6. Вставленный OLE-объект отображается в документе и может редактироваться в AutoCAD через приложение-приемник.

Ввод команды: КСВЯЗЬ


Экспорт OLE-объектов из чертежей - Команды

Составные документы и технология OLE
Составные документы и технология OLE
Экспорт OLE-объектов из чертежей
Понятия
Процедуры
Команды

Команды
ВБУФЕР | Занесение объектов в буфер обмена с удалением их из чертежа
КБУФЕР | Копирует объекты или текст из командной строки в буфер обмена
КОПИРВИД | Копирование текущего вида в буфер обмена для связывания с другими OLE-приложениями
Системные переменные
WMFBKGND | Управляет отображением фона при вставке объектов в формат метафайлов Windows (WMF)
WMFFOREGND | Управляет назначением цвета переднего плана при вставке объектов в формат метафайла Windows (WMF)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование OLE-объектов в чертежах - Понятия

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Редактирование OLE-объектов в чертежах
Понятия
Процедуры
Команды

Пользователь может отредактировать связанные или внедренные в чертеж OLE-объекты. Для этого нужно дважды нажать на объекте, чтобы открыть приложение-сервер, с помощью которого выполняется редактирование.

Выбранные любым способом OLE-объекты могут редактироваться с помощью большинства команд редактирования, палитры свойства, а также с помощью ручек. Если для размеров объекта задан режим сохранения пропорций и для изменения OLE-объекта используются ручки, форма объекта не меняется. Для OLE-объектов недоступны следующие команды редактирования: РАЗОРВАТЬ, ФАСКА, СОПРЯЖЕНИЕ и УВЕЛИЧИТЬ.

Если OLE-объект повернут или находится не на виде в плане, его содержимое становится временно скрытым; отображается только рамка объекта.

Заданные на палитре свойств общие свойства OLE-объекта применяются к его рамке.

Ручки отображаются на рамке, поэтому редактирование с помощью ручек невозможно, если рамка не отображается. Для отображения рамки требуется изменить значение системной переменной OLEFRAME.

Редактирование информации в OLE-объектах

Пользователь может отредактировать связанные или внедренные в чертеж OLE-объекты. Для этого нужно дважды нажать на объекте, чтобы открыть приложение-сервер, с помощью которого выполняется редактирование.

Редактирование OLE-объекта в случае, если исходным приложением является AutoCAD

Если чертеж связан с документом, то в этом документе хранится информация о расположении связанного файла чертежа. Это позволяет редактировать связанный чертеж непосредственно в конечном приложении либо в исходной программе. Программа должна быть загружена или доступна для запуска во время редактирования документа.

Чертеж AutoCAD, внедренный в документ, можно редактировать только в конечном приложении. Для запуска программы следует дважды нажать кнопку мыши на OLE-объекте. Редактирование исходного чертежа в программе не оказывает никакого действия на внедренный чертеж.

См. также

Копирование объектов


Редактирование OLE-объектов в чертежах - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Редактирование OLE-объектов в чертежах
Понятия
Процедуры
Команды

Редактирование связанного чертежа из приложения-приемника

Изменение связанного чертежа в исходном приложении

Редактирование внедренных объектов AutoCAD

Восстановление исходных размеров и формы OLE-объекта

Управление отображением OLE-объектов

Включение-отключение отображения рамок OLE-объекта


Редактирование связанного чертежа из приложения-приемника - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Редактирование OLE-объектов в чертежах
Понятия
Процедуры
Команды

Редактирование связанного чертежа из приложения-приемника

  1. Откройте документ, содержащий связанный чертеж AutoCAD (например документ Microsoft Word).
  2. Дважды нажмите кнопку мыши на связанном чертеже.

    3. Откроется чертеж.

  3. Отредактируйте чертеж.
  4. Нажмите "Файл" » "Сохранить" для сохранения внесенных в чертёж изменений.
  5. Нажмите "Файл" » "Выход" для возврата в конечное приложение.

    6. Чертеж обновляется во всех документах, с которыми он связан.

    Способ обновления связи зависит от самого приложения-приемника. Некоторые приложения обновляют связи автоматически; в других это делается вручную.


Изменение связанного чертежа в исходном приложении - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Редактирование OLE-объектов в чертежах
Понятия
Процедуры
Команды

Изменение связанного чертежа в исходном приложении

  1. Запустите программу и откройте связанный чертеж.
  2. Отредактируйте чертеж и связанный вид.
  3. Нажмите "Файл" » "Сохранить" для сохранения внесенных в чертёж изменений.
  4. Если необходимо, обновите связь в составном документе.

    5. Чертеж обновляется во всех документах, с которыми он связан.

    Способ обновления связи зависит от самого приложения-приемника. Некоторые приложения обновляют связи автоматически; в других это делается вручную.


Редактирование внедренных объектов AutoCAD - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Редактирование OLE-объектов в чертежах
Понятия
Процедуры
Команды

Редактирование внедренных объектов AutoCAD

  1. Откройте документ, содержащий внедренные объекты AutoCAD (например файл Microsoft Word).
  2. Дважды нажмите на внедренных объектах для запуска программы и отображения объектов.
  3. Отредактируйте объекты.
  4. Нажмите "Файл" » "Обновить" для сохранения изменений во внедренных объектах.
  5. Нажмите "Файл" » "Выход" для возврата в конечное приложение.


Восстановление исходных размеров и формы OLE-объекта - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Редактирование OLE-объектов в чертежах
Понятия
Процедуры
Команды

Восстановление исходных размеров и формы OLE-объекта

  1. Выберите OLE-объект.
  2. Нажмите правую кнопку мыши. Выберите "OLE" » "Сброс".

    3. Опция "Сброс" также доступна из диалогового окна "Размер текста".


Управление отображением OLE-объектов - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Редактирование OLE-объектов в чертежах
Понятия
Процедуры
Команды

Управление отображением OLE-объектов

  1. В командной строке введите olehide.
  2. Установите одно из возможных значений переменной:
    • 0Объекты OLE отображаются как в пространстве листа, так и в пространстве модели.
    • 1 Объекты OLE отображаются только в пространстве листа.
    • 2 Объекты OLE отображаются только в пространстве модели.
    • 3 Объекты OLE не отображаются.


Включение-отключение отображения рамок OLE-объекта - Процедуры

Совместное использование данных в чертежах и приложениях
Составные документы и технология OLE
Редактирование OLE-объектов в чертежах
Понятия
Процедуры
Команды

Включение-отключение отображения рамок OLE-объекта

  1. В командной строке введите oleframe.
  2. Установите одно из возможных значений переменной:
    • 0 - рамка не отображается и не выводится на печать.
    • 1 - рамка отображается и выводится на печать.
    • 2 - рамка отображается, но на печать не выводится.

    Для того, чтобы были доступны ручки, рамка должна отображаться.


Редактирование OLE-объектов в чертежах - Команды

Составные документы и технология OLE
Составные документы и технология OLE
Редактирование OLE-объектов в чертежах
Понятия
Процедуры
Команды

Команды
ВБУФЕР | Занесение объектов в буфер обмена с удалением их из чертежа
ВСТБУФЕР | Вставка содержимого буфера обмена
КБУФЕР | Копирует объекты или текст из командной строки в буфер обмена
О | Отмена самой последней операции
СТЕРЕТЬ | Удаление объектов из чертежа
Системные переменные
OLEFRAME | Управляет отображением и печатью рамок для всех объектов OLE чертежа
OLEHIDE | Управляет отображением и выводом на печать объектов OLE
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с данными других форматов - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Понятия
Процедуры
Команды

Можно работать с различными графическими файлами, которые могут быть созданы в других приложениях или в более ранних версиях программы. Кроме того, можно задать пути к папкам, в которых происходит поиск чертежей или вспомогательных файлов.

  • Импорт и вставка файлов других форматов
    Имеется возможность импорта или вставки в свои чертежи файлов, не имеющих формат DWG, созданных в других приложениях.
  • Создание файлов в других форматах
    При необходимости использовать информацию из файла чертежа в другом приложении его преобразуют в требуемый формат процедурами экспорта. При этом можно использовать буфер обмена.
  • Использование чертежей из разных приложений и версий
    Допустим обмен чертежами между разными версиями AutoCAD и AutoCAD LT, а также экспорт и импорт файлов, содержащих сторонние объекты. Однако в некоторых случаях существуют ограничения.

См. также

Восстановление поврежденного файла чертежа


Работа с данными других форматов - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Понятия
Процедуры
Команды

Для импорта файлов 3D Studio

Для импорта ACIS-файлов

Вставка подложки DWF

Удаление подложки DWF

Редактирование положения, масштаба или угла поворота подложки DWF с палитры свойств

Редактирование положения подложки DWF с помощью базовой ручки

Регулировка параметров контрастности, слияния с фоном, "Монохромный" и цветов подложки DWF

Подрезка подложки DWF

Указание нового контура для подрезанной подложки DWF

Редактирование существующего контура у подрезанной подложки DWF

Показ или скрытие подрезанной части подложки DWF

Удаление контура подрезанной подложки DWF

Показ и скрытие контуров подложки DWF

Просмотр списка подложек DWF, вставленных в чертеж

Отображение имен подложек DWF и уровней их вложения во внешние ссылки и блоки

Изменение пути к подложке DWF

Проверка подложек DWF с помощью Диспетчера ссылок

Открытие файла DXF

Для открытия DXB-файла

Вставка изображения

Для вставки и масштабирования изображения из Интернета

Вставка и масштабирование изображения

Удаление изображения

Включение и отключение видимости контуров изображений

Подрезка изображения

Изменение контура подрезки изображения

Показа или скрытие подрезанной части изображения

Удаление контура подрезки изображения

Регулировка яркости, контрастности и слияния с фоном

Изменение цвета и прозрачности монохромного изображения

Изменение только прозрачности монохромного изображения

Просмотр списка изображений, вставленных в чертеж

Отображение имен изображений и уровней их вложения в ссылки на DWG и блоки

Просмотр изображения и подробных сведений о файле

Предварительный просмотр еще не вставленного изображения

Просмотра сведений об изображении в текстовом окне

Изменение имени изображения

Изменение пути к изображению

Выгрузка и повторная загрузка изображения

Изменения видимости отдельных экземпляров изображения

Изменение качества представления изображений

Скрытие и повторный вывод изображения

Импорт файла WMF

Управление видимостью сплошных закрасок и широких линий в WMF-файлах

Создание файла DXF

Создание WMF-файла (метафайла Windows)

Создание файла BMP

Создание JPEG-файла (JPG)

Создание TIFF-файла (TIF)

Создание файла формата PNG (переносимая сетевая графика)

Экспорт чертежа в файл формата Encapsulated PostScript (EPS)

Создание файла ACIS

Сохранение изображений тел в SLA-файлах

Сохранение чертежа AutoCAD в формате предыдущей версии


Работа с данными других форматов - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Понятия
Процедуры
Команды
Команды
3DДВФ | Создает 3D DWF-файл пользовательской трехмерной модели и отображает ее в программе просмотра DWF
EXPORTTOAUTOCAD | Создание нового DWG-файла со всеми расчлененными AD-объектами
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ДВФВСТАВИТЬ | Вставка подложки DWF в текущий чертеж
ДВФРЕГУЛ | Позволяет выполнять настройку подложки DWF из командной строки
ДВФРЕЗ | Определение подобласти подложки DWF с помощью секущих контуров.
ИЗОБ | Открытие палитры "Внешние ссылки"
ИЗОБВСТАВИТЬ | Вставка нового изображения в текущий чертеж
ИЗОБКАЧЕСТВО | Управление качеством вывода изображений на экран
ИЗОБКОНТУР | Управляет видимостью рамок изображения и выводом их на печать
ИЗОБРЕГУЛ | Регулировка яркости, контрастности и степени слияния с фоном изображений
ИЗОБРЕЗ | Использует контуры подрезки для определения подобласти объекта изображения.
ИМПОРТ | Импортирует файлы в различных форматах
ИМПОРТМТФ | Импорт метафайла Windows
ИМПОРТТЕЛ | Импортирует файлы формата ACIS и создает в чертеже соответствующие объекты: тела ACIS, 3D тела и области.
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОПЦИИМТФ | Задание опций для команды ИМПОРТМТФ
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПРЕОБРАЗОВАТЬ | Преобразование 2D полилиний и ассоциативных штриховок, созданных в AutoCAD Release 13 или ранее
ПРОЗРАЧНОСТЬ | Управление прозрачностью фоновых пикселов растровых изображений
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
ПУБЛ3DДВФ | Устар.
СОХРАНИТЬ | Сохранение чертежа под текущим или заданным именем
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
ЭКСПОРТБМП | Сохранение выбранных объектов в файле аппаратно-независимого растрового формата (BMP)
ЭКСПОРТДЖ | Сохраняет выбранные объекты в файл в формате JPEG
ЭКСПОРТМТФ | Сохранение объектов в метафайл Windows (WMF)
ЭКСПОРТПНГ | Сохраняет выбранные объекты в файл в формате Portable Network Graphics
ЭКСПОРТСТЛ | Сохранение тел в двоичном или ASCII-файле
ЭКСПОРТТЕЛ | Экспортирует в файл ACIS тела ACIS, 3D тела и области.
ЭКСПОРТТИФ | Сохранение выбранных объектов в файл формата TIFF
Системные переменные
ACISOUTVER | Управление версией ACIS файлов SAT, созданных с помощью команды ACISOUT
DWFFRAME | Определяет видимость контура подложки DWF
DWFOSNAP | Определяет активность привязки объекта для геометрии в подложках DWF, прикрепленных к чертежу
FACETRES | Регулирует гладкость раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями
FIELDDISPLAY | Управляет отображением полей на сером фоне
IMAGEHLT | Управляет режимом подсветки растровых изображений при выборе
PLINETYPE | Указывает, используется ли оптимизированные двухмерные полилинии
PROJECTNAME | Присваивает имя проекта текущему чертежу
PROXYGRAPHICS | Управляет сохранением объектов-заместителей в чертеже
PROXYNOTICE | Отображает сообщение при создании объекта-заместителя
PROXYSHOW | Управляет отображением объектов-заместителей на чертеже
PROXYWEBSEARCH | Устанавливает в программе режим поиска адаптеров объектов
WMFBKGND | Управляет отображением фона при вставке объектов в формат метафайлов Windows (WMF)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Импорт и вставка файлов других форматов - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Импорт и вставка файлов других форматов
Понятия
Процедуры
Команды

Имеется возможность импорта или вставки в свои чертежи файлов, не имеющих формат DWG, созданных в других приложениях.

Имеется возможность импорта или вставки в свои чертежи файлов, не имеющих формат DWG, созданных в других приложениях. Можно быстро вставлять растровые изображения и файлы DWF, а внутренние функции преобразования позволяют импортировать файлы, сохраненные в форматах 3DS, ACIS, DXF и WMF. Преобразование форматов производится соответствующими командами.

  • Файлы 3DS
    Имеется возможность импортировать файлы в формате 3DS, созданные с помощью 3D Studio.
  • Файлы ACIS SAT
    Геометрические объекты, хранящиеся в SAT-файлах (ASCII), импортируются командой ИМПОРТТЕЛ.
  • Файлы DWF
    Файл формата DWF (Design Web Format) - это файл с очень сжатым форматом, созданный на основе файла DWG. Файл DWF можно вставить в файл чертежа в качестве подложки. При вставке файла DWF можно сослаться на него, не увеличивая размера файла чертежа.
  • Файлы DXF и DXB
    Файлы DXF и DXB - это две формы файлов обмена чертежами, с которыми можно работать в программе.
  • Файлы растровых изображений
    В чертежах можно просматривать и манипулировать растровыми изображениями и соответствующими путями файлов.
  • WMF-файлы
    Метафайлы Windows (файлы формата WMF) часто используются для хранения графических изображений.


Импорт и вставка файлов других форматов - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Импорт и вставка файлов других форматов
Понятия
Процедуры
Команды

Для импорта файлов 3D Studio

Для импорта ACIS-файлов

Вставка подложки DWF

Удаление подложки DWF

Редактирование положения, масштаба или угла поворота подложки DWF с палитры свойств

Редактирование положения подложки DWF с помощью базовой ручки

Регулировка параметров контрастности, слияния с фоном, "Монохромный" и цветов подложки DWF

Подрезка подложки DWF

Указание нового контура для подрезанной подложки DWF

Редактирование существующего контура у подрезанной подложки DWF

Показ или скрытие подрезанной части подложки DWF

Удаление контура подрезанной подложки DWF

Показ и скрытие контуров подложки DWF

Просмотр списка подложек DWF, вставленных в чертеж

Отображение имен подложек DWF и уровней их вложения во внешние ссылки и блоки

Изменение пути к подложке DWF

Проверка подложек DWF с помощью Диспетчера ссылок

Открытие файла DXF

Для открытия DXB-файла

Вставка изображения

Для вставки и масштабирования изображения из Интернета

Вставка и масштабирование изображения

Удаление изображения

Включение и отключение видимости контуров изображений

Подрезка изображения

Изменение контура подрезки изображения

Показа или скрытие подрезанной части изображения

Удаление контура подрезки изображения

Регулировка яркости, контрастности и слияния с фоном

Изменение цвета и прозрачности монохромного изображения

Изменение только прозрачности монохромного изображения

Просмотр списка изображений, вставленных в чертеж

Отображение имен изображений и уровней их вложения в ссылки на DWG и блоки

Просмотр изображения и подробных сведений о файле

Предварительный просмотр еще не вставленного изображения

Просмотра сведений об изображении в текстовом окне

Изменение имени изображения

Изменение пути к изображению

Выгрузка и повторная загрузка изображения

Изменения видимости отдельных экземпляров изображения

Изменение качества представления изображений

Скрытие и повторный вывод изображения

Импорт файла WMF

Управление видимостью сплошных закрасок и широких линий в WMF-файлах


Импорт и вставка файлов других форматов - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Импорт и вставка файлов других форматов
Понятия
Процедуры
Команды
Команды
3DДВФ | Создает 3D DWF-файл пользовательской трехмерной модели и отображает ее в программе просмотра DWF
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ДВФВСТАВИТЬ | Вставка подложки DWF в текущий чертеж
ДВФРЕГУЛ | Позволяет выполнять настройку подложки DWF из командной строки
ДВФРЕЗ | Определение подобласти подложки DWF с помощью секущих контуров.
ИЗОБ | Открытие палитры "Внешние ссылки"
ИЗОБВСТАВИТЬ | Вставка нового изображения в текущий чертеж
ИЗОБКАЧЕСТВО | Управление качеством вывода изображений на экран
ИЗОБКОНТУР | Управляет видимостью рамок изображения и выводом их на печать
ИЗОБРЕГУЛ | Регулировка яркости, контрастности и степени слияния с фоном изображений
ИЗОБРЕЗ | Использует контуры подрезки для определения подобласти объекта изображения.
ИМПОРТ | Импортирует файлы в различных форматах
ИМПОРТМТФ | Импорт метафайла Windows
ИМПОРТТЕЛ | Импортирует файлы формата ACIS и создает в чертеже соответствующие объекты: тела ACIS, 3D тела и области.
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОПЦИИМТФ | Задание опций для команды ИМПОРТМТФ
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПРОЗРАЧНОСТЬ | Управление прозрачностью фоновых пикселов растровых изображений
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
ПУБЛ3DДВФ | Устар.
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
DWFFRAME | Определяет видимость контура подложки DWF
DWFOSNAP | Определяет активность привязки объекта для геометрии в подложках DWF, прикрепленных к чертежу
IMAGEHLT | Управляет режимом подсветки растровых изображений при выборе
PROJECTNAME | Присваивает имя проекта текущему чертежу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Файлы 3DS - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы 3DS
Понятия
Процедуры
Команды

Имеется возможность импортировать файлы в формате 3DS, созданные с помощью 3D Studio ®. Считывается геометрия 3D Studio и данные тонирования, включая сети, материалы, наложение, источники свети и камеры. Процедурные материалы 3D Studio, группы сглаживания и данные ключевых кадров не могут быть импортированы.

Импортированным объектам назначается цвет, максимально приближенный к цвету объекта в 3D Studio.

Для источников света и материалов применяются команды ПРЕОБРУСТАРСВЕТ и ПРЕОБРУСТАРМАТЕРИАЛ. Источники света в 3D Studio преобразуются в наиболее близкий эквивалент. Источники рассеянного света теряют цветовую окраску. Источники ненаправленного света становятся точечными источниками. Прожекторы остаются прожекторами. Камеры 3D Studio становятся именованными видами.

Возможен конфликт между именами объектов 3D Studio и AutoCAD. В этом случае имени объекта 3D Studio присваивается следующий по порядку номер. При этом имя объекта может оказаться усеченным.


Для импорта файлов 3D Studio - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы 3DS
Понятия
Процедуры
Команды

Для импорта файлов 3D Studio

  1. Выберите меню "Вставка" » "3D Studio".
  2. В диалоговом окне "Импорт файла 3D Studio" найдите и выберите импортируемый файл.
  3. Нажмите "Открыть".

Панель "Вставка"

Ввод команды: ИМПОРТ3DC


Файлы 3DS - Команды

Работа с данными других форматов
Работа с данными других форматов
Файлы 3DS
Понятия
Процедуры
Команды

Команды
ИМПОРТ | Импортирует файлы в различных форматах
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Файлы ACIS SAT - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы ACIS SAT
Понятия
Процедуры
Команды

Геометрические объекты, хранящиеся в SAT-файлах (ASCII), импортируются командой ИМПОРТТЕЛ.

Геометрические объекты, хранящиеся в SAT-файлах (ASCII), импортируются командой ИМПОРТТЕЛ. Команда "ИМПОРТТЕЛ" преобразует модель в объект тела или в 3D тела и области, если объект в действительности является телом или областью.


Для импорта ACIS-файлов - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы ACIS SAT
Понятия
Процедуры
Команды

Для импорта ACIS-файлов

  1. Выберите меню "Вставка" » "ACIS".
  2. В диалоговом окне "Выбор ACIS-файла" найдите и выберите импортируемый файл.
  3. Нажмите "Открыть".

Панель "Вставка"

Ввод команды: ИМПОРТТЕЛ


Файлы ACIS SAT - Команды

Работа с данными других форматов
Работа с данными других форматов
Файлы ACIS SAT
Понятия
Процедуры
Команды

Команды
ИМПОРТ | Импортирует файлы в различных форматах
ИМПОРТТЕЛ | Импортирует файлы формата ACIS и создает в чертеже соответствующие объекты: тела ACIS, 3D тела и области.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Файлы DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы DWF
Понятия
Процедуры
Команды

Файл формата DWF (Design Web Format) - это файл с очень сжатым форматом, созданный на основе файла DWG. Файл DWF можно вставить в файл чертежа в качестве подложки. При вставке файла DWF можно сослаться на него, не увеличивая размера файла чертежа.

  • Вставка и удаление подложки DWF
    Имеется возможность вставки или удаления подложки DWF (вхождения файлов DWF) в файлы чертежей. Также можно изменять положение, масштаб и ориентацию подложек DWF.
  • Работа с файлами подложек DWF
    После вставки файла DWF в чертеж в качестве подложки геометрия остается видимой и доступной. Можно в любой момент изменить положение, масштаб или угол поворота.
  • Изменение графических свойств и границ подрезки подложки DWF
    После вставки подложки DWF можно производить регулировку внешнего вида подложки или задавать контуры подрезки, позволяющие сфокусироваться на определенной части подложки.
  • Управление и публикация чертежей, содержащих подложки DWF
    Имеется возможность просмотра и работы с подложками DWF и изменения путей к подложкам с палитры "Внешние ссылки".


Файлы DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы DWF
Понятия
Процедуры
Команды

Вставка подложки DWF

Удаление подложки DWF

Редактирование положения, масштаба или угла поворота подложки DWF с палитры свойств

Редактирование положения подложки DWF с помощью базовой ручки

Регулировка параметров контрастности, слияния с фоном, "Монохромный" и цветов подложки DWF

Подрезка подложки DWF

Указание нового контура для подрезанной подложки DWF

Редактирование существующего контура у подрезанной подложки DWF

Показ или скрытие подрезанной части подложки DWF

Удаление контура подрезанной подложки DWF

Показ и скрытие контуров подложки DWF

Просмотр списка подложек DWF, вставленных в чертеж

Отображение имен подложек DWF и уровней их вложения во внешние ссылки и блоки

Изменение пути к подложке DWF

Проверка подложек DWF с помощью Диспетчера ссылок


Файлы DWF - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы DWF
Понятия
Процедуры
Команды
Команды
3DДВФ | Создает 3D DWF-файл пользовательской трехмерной модели и отображает ее в программе просмотра DWF
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ДВФВСТАВИТЬ | Вставка подложки DWF в текущий чертеж
ДВФРЕГУЛ | Позволяет выполнять настройку подложки DWF из командной строки
ДВФРЕЗ | Определение подобласти подложки DWF с помощью секущих контуров.
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
ПУБЛ3DДВФ | Устар.
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
DWFFRAME | Определяет видимость контура подложки DWF
DWFOSNAP | Определяет активность привязки объекта для геометрии в подложках DWF, прикрепленных к чертежу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вставка и удаление подложки DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Вставка и удаление подложки DWF
Понятия
Процедуры
Команды

Имеется возможность вставки или удаления подложки DWF (вхождения файлов DWF) в файлы чертежей. Также можно изменять положение, масштаб и ориентацию подложек DWF.

  • Вставка файлов DWF как подложек
    Файл DWF можно вставить в файл чертежа в качестве подложки.
  • Удаление файлов подложек DWF
    Подложки DWF могут быть удалены из файла чертежа.


Вставка и удаление подложки DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Вставка и удаление подложки DWF
Понятия
Процедуры
Команды

Вставка подложки DWF

Удаление подложки DWF


Вставка и удаление подложки DWF - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Вставка и удаление подложки DWF
Понятия
Процедуры
Команды
Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ДВФРЕГУЛ | Позволяет выполнять настройку подложки DWF из командной строки
ДВФРЕЗ | Определение подобласти подложки DWF с помощью секущих контуров.
Системные переменные
DWFFRAME | Определяет видимость контура подложки DWF
DWFOSNAP | Определяет активность привязки объекта для геометрии в подложках DWF, прикрепленных к чертежу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вставка файлов DWF как подложек - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Вставка файлов DWF как подложек
Понятия
Процедуры
Команды

Файл DWF можно вставить в файл чертежа в качестве подложки.

Показать: "Вставка файла DWF в качестве подложки"

Для запуска анимации нажмите на стрелку "Показать".

На файлы DWF ссылаются и размещают их в файлах чертежей таким же способом как файлы растровых изображений, но на самом деле они не являются частью файла чертежа. Как и при работе с растровыми изображениями, связь файла чертежа и подложки DWF устанавливается заданием пути. Можно в любой момент редактировать пути связей с файлами DWF или удалять их. За счет вставки подложек DWF с помощью связанных путей к файлам DWF имеется возможность использовать файлы DWF без существенного увеличения размера файла чертежа.

Примечание Хотя файлы подложки DWF являются воспроизведением своих исходных чертежей, они не так точны, как файлы чертежей. В подложках DWF могут наблюдаться расхождения по точности.

Перетаскивание и вставка файлов подложек DWF

Также имеется возможность непосредственного перетаскивания подложек DWF в чертеж. После перетаскивания файла DWF в чертеж выдается запрос на ввод в командной строке имени листа из файла DWF. После этого требуется указать точку вставки, масштабный коэффициент и угол поворота.

Допускается многократная вставка в чертеж одной и той же подложки DWF; общая стратегия здесь полностью совпадает с используемой для блоков. Каждая подложка имеет собственную границу подрезки и отличающиеся от других вхождений значения контрастности, степени слияния с фоном и наличия цвета. Тем не менее, невозможно внедрить подложку в чертёж, и невозможно внести изменения в содержимое чертежа подложки.

Слои в файлах подложки DWF

При вставке файла DWF в качестве подложки структура любого количества слоев сводится на один слой. Подложка помещается на текущий слой листа.

Файлы подложек DWF во внешних ссылках

При работе с чертежами, в которых имеются ссылки на файлы DWG (внешние ссылки), существует вероятность наличия в одной из них вставленной подложки DWF. В такой ситуации геометрия DWF будет видна в исходном чертеже.

Например, "Чертеж А" содержит подложку DWF, на которой показаны некоторые особенности конструкции. Требуется содержимое "Чертежа А" вставить в текущий чертеж, "Чертеж Б". Если вставить "Чертеж А" в "Чертеж Б" в качестве внешней ссылки, подложка DWF, уже вставленная в "Чертеж А", также будет присутствовать.

Все настройки свойств объектов, сделанные для подложки в ссылке DWG, например границы подрезки, отображаются так же, как в исходном чертеже.

Файлы подложек DWF с защитой паролем

Если файл DWF, который требуется вставить как подложку, защищен паролем, после выбора файла будет выдан запрос на ввод пароля. Нельзя завершить процедуру вставки, пока пароль не будет введен правильно.

После вставки подложки DWF в файл DWG запрос на ввод пароля файла DWF будет выдаваться при последующем открытии файла чертежа. Если файл DWG также защищен паролем или в него вставлено несколько ссылок на разные защищенные чертежи, может запрашиваться несколько паролей.

Если возникла необходимость перенаправить путь к подложке DWF на файл DWF, требующий ввода пароля, будет выдан соответствующий запрос.

Пароль DWF вводится с учетом регистра, а пароль DWG -без. Для упрощения согласования между паролями DWG и DWF рекомендуется вводить пароль DWF, совпадающий с паролем DWG и полностью набираемый в верхнем регистре. Например, если пароль DWG - "МойПроект", вводится следующий пароль DWF: "МОЙПРОЕКТ".


Вставка подложки DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Вставка файлов DWF как подложек
Понятия
Процедуры
Команды

Вставка подложки DWF

  1. Нажмите "Вставка" » "Подложка DWF".
  2. В диалоговом окне "Выбор DWF-файла" выберите файл, который требуется вставить.
  3. Нажмите "Открыть".
  4. В диалоговом окне "Вставка подложки DWF", если файл DWF содержит несколько листов, выберите вставляемый лист.
  5. Воспользуйтесь одним из следующих способов для указания точки вставки, масштаба или угла поворота файла подложки:
    • Установите флажок "Указать на экране", чтобы использовать устройство указания для вставки подложки DWF в определенную точку с необходимым масштабом и под нужным углом.
    • Уберите флажок "Указать на экране" и введите значения в поля групп "Точка вставки", "Масштаб" или "Угол поворота".
  6. Нажмите "ОК".

Панель "Вставка"

Ввод команды: ДВФВСТАВИТЬ


Вставка файлов DWF как подложек - Команды

Работа с данными других форматов
Работа с данными других форматов
Вставка файлов DWF как подложек
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ДВФРЕГУЛ | Позволяет выполнять настройку подложки DWF из командной строки
ДВФРЕЗ | Определение подобласти подложки DWF с помощью секущих контуров.
Системные переменные
DWFFRAME | Определяет видимость контура подложки DWF
DWFOSNAP | Определяет активность привязки объекта для геометрии в подложках DWF, прикрепленных к чертежу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Удаление файлов подложек DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Удаление файлов подложек DWF
Понятия
Процедуры
Команды

Имеется возможность удалять подложки DWF, которые больше не нужны на чертеже. При удалении подложки DWF из чертежа убираются все ее экземпляры, очищается описание подложки и удаляется путь связи с файлом DWF.

Примечание Стирание отдельного экземпляра подложки DWF не эквивалентно ее удалению. Подложку DWF необходимо удалять для разрыва связи чертежа с файлом DWF.


Удаление подложки DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Удаление файлов подложек DWF
Понятия
Процедуры
Команды

Удаление подложки DWF

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" в окне "Вхождения файлов" выберите подложку DWF, которую требуется удалить.
  3. Укажите подложку DWF правой кнопкой мыши и нажмите "Удалить".

    4. Подложка DWF больше не связана с файлом чертежа. Все экземпляры подложки удаляются из чертежа.

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ

Контекстное меню: Выберите подложку DWF и нажмите правую кнопку мыши в области чертежа. Выберите палитру "Внешние ссылки".


Удаление файлов подложек DWF - Команды

Работа с данными других форматов
Работа с данными других форматов
Удаление файлов подложек DWF
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ДВФРЕГУЛ | Позволяет выполнять настройку подложки DWF из командной строки
ДВФРЕЗ | Определение подобласти подложки DWF с помощью секущих контуров.
Системные переменные
DWFFRAME | Определяет видимость контура подложки DWF
DWFOSNAP | Определяет активность привязки объекта для геометрии в подложках DWF, прикрепленных к чертежу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с файлами подложек DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Работа с файлами подложек DWF
Понятия
Процедуры
Команды

После вставки файла DWF в чертеж в качестве подложки геометрия остается видимой и доступной. Можно в любой момент изменить положение, масштаб или угол поворота.

  • Редактирование файлов подложек DWF
    После вставки подложки DWF в чертеж еще имеется возможность в любой момент изменить ее положение, масштаб или угол поворота.


Работа с файлами подложек DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Работа с файлами подложек DWF
Понятия
Процедуры
Команды

Редактирование положения, масштаба или угла поворота подложки DWF с палитры свойств

Редактирование положения подложки DWF с помощью базовой ручки


Работа с файлами подложек DWF - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Работа с файлами подложек DWF
Понятия
Процедуры
Команды
Команды
ДВФВСТАВИТЬ | Вставка подложки DWF в текущий чертеж
ДВФРЕЗ | Определение подобласти подложки DWF с помощью секущих контуров.
Системные переменные
DWFOSNAP | Определяет активность привязки объекта для геометрии в подложках DWF, прикрепленных к чертежу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование файлов подложек DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Редактирование файлов подложек DWF
Понятия
Процедуры
Команды

Хотя точка вставки, масштабный коэффициент и угол поворота могут быть указаны в момент вставки файла DWF, может возникнуть необходимость изменения этих параметров по мере работы над чертежом. По умолчанию, точка вставки файла DWF имеет координаты (0,0,0), масштабный коэффициент равен 1, а угол поворота - 0.

Так как вставленная подложка DWF ведет себя так же, как вставленное растровое изображение, общие команды редактирования используются в том же режиме, позволяя перемещать ее, масштабировать, поворачивать, симметрично отражать, создавать массив и т.д. Также можно производить изменения после выбора подложки DWF и активизации команд контекстного меню или с палитры свойств.

Двойное нажатие кнопки мыши на подложке DWF откроет палитру свойств для данной подложки.

Объектная привязка к подложкам DWF

Если требуется чертить поверх подложки DWF, можно включить объектную привязку для файлов DWF. При включении объектной привязки она становится активной для всех подложек DWF, вставленных в чертеж. Объектная привязка к геометрии DWF - то же, что и объектная привязка к геометрии DWG. Объектная привязка для подложек DWF включается и отключается с помощью системной переменной DWFOSNAP.

Объектную привязку к DWF также можно включить и отключить из контекстного меню. Выберите файл подложки DWF, затем нажмите правую кнопку мыши. В контекстном меню выберите "Объектная привязка к DWF".

Ручки подложки DWF

Хотя режимы работы с подложкой DWF в основном соответствуют принятым для растровых изображений, имеется одно отличие в способе действия ручек. В данном случае режим ближе к принятому для блоков.

Подложки DWF обычно отображают только базовую ручку. Базовая ручка используется для изменения положения подложки на чертеже. Если настроен контур подрезки, у каждого угла контура появляются дополнительные ручки. Края граней, расположенных под большим углом, не сглаживаются. См. раздел Изменение графических свойств и границ подрезки подложки DWF.

Ручка базовой точки выглядит аналогично базовой точке стандартного блока. Базовую точку нельзя перенастроить изнутри основного файла DWG. Она определяется при публикации DWF на основании начала координат исходного файла DWG. Если существующий (унаследованный) файл DWF не имеет определенной базовой точки, в качестве базовой точки (0,0,0) используется левый нижний угол.


Редактирование файлов подложек DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Редактирование файлов подложек DWF
Понятия
Процедуры
Команды

Редактирование положения, масштаба или угла поворота подложки DWF с палитры свойств

Редактирование положения подложки DWF с помощью базовой ручки


Редактирование положения, масштаба или угла поворота подложки DWF с палитры свойств - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Редактирование файлов подложек DWF
Понятия
Процедуры
Команды

Редактирование положения, масштаба или угла поворота подложки DWF с палитры свойств

  1. На видовом экране чертежа дважды нажмите кнопку мыши на подложке DWF, которую требуется отредактировать.
  2. На палитре свойств выведите на экран группу "Геометрия" и выполните одну из следующих операций:
    • Для изменения положения подложки DWF измените значения параметров "Положение X", "Положение Y" или "Положение Z".
    • Для изменения масштаба, ширины или высоты подложки DWF внесите изменения значений параметров "Масштаб", "Ширина" и "Высота".
    • Для изменения угла поворота подложки DWF измените значение параметра "Угол поворота".


Редактирование положения подложки DWF с помощью базовой ручки - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Редактирование файлов подложек DWF
Понятия
Процедуры
Команды

Редактирование положения подложки DWF с помощью базовой ручки

  1. Укажите контур вставленной подложки DWF.
  2. Для изменения положения подложки DWF нажмите базовую ручку.
  3. Перетащить курсор в новое положение, а затем нажмите кнопку мыши снова, чтобы разместить подложку DWF.


Редактирование файлов подложек DWF - Команды

Работа с данными других форматов
Работа с данными других форматов
Редактирование файлов подложек DWF
Понятия
Процедуры
Команды

Команды
ДВФВСТАВИТЬ | Вставка подложки DWF в текущий чертеж
ДВФРЕЗ | Определение подобласти подложки DWF с помощью секущих контуров.
Системные переменные
DWFOSNAP | Определяет активность привязки объекта для геометрии в подложках DWF, прикрепленных к чертежу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение графических свойств и границ подрезки подложки DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение графических свойств и границ подрезки подложки DWF
Понятия
Процедуры
Команды

После вставки подложки DWF можно производить регулировку внешнего вида подложки или задавать контуры подрезки, позволяющие сфокусироваться на определенной части подложки.

  • Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона подложки DWF
    Помимо палитры "Свойства" для редактирования положения, масштаба и угла поворота подложки DGN предусмотрена возможность изменения параметров слияния с фоном, контрастности, "Монохромный" и цвета фона подложки DGN.
  • Подрезка подложек DWF
    Для подрезки изображения подложки DWF на чертеже можно использовать прямоугольный или многоугольный контур подрезки.
  • Показ и скрытие контуров подложки DWF
    Имеется возможность управления видимостью контура, который описывает границы подложки DWF или видимостью контура, который определяется контуром подрезки.


Изменение графических свойств и границ подрезки подложки DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение графических свойств и границ подрезки подложки DWF
Понятия
Процедуры
Команды

Регулировка параметров контрастности, слияния с фоном, "Монохромный" и цветов подложки DWF

Подрезка подложки DWF

Указание нового контура для подрезанной подложки DWF

Редактирование существующего контура у подрезанной подложки DWF

Показ или скрытие подрезанной части подложки DWF

Удаление контура подрезанной подложки DWF

Показ и скрытие контуров подложки DWF


Изменение графических свойств и границ подрезки подложки DWF - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение графических свойств и границ подрезки подложки DWF
Понятия
Процедуры
Команды
Команды
ДВФРЕГУЛ | Позволяет выполнять настройку подложки DWF из командной строки
ДВФРЕЗ | Определение подобласти подложки DWF с помощью секущих контуров.
Системные переменные
DWFFRAME | Определяет видимость контура подложки DWF
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона подложки DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона подложки DWF
Понятия
Процедуры
Команды

Помимо палитры "Свойства" для редактирования положения, масштаба и угла поворота подложки DGN предусмотрена возможность изменения параметров слияния с фоном, контрастности, "Монохромный" и цвета фона подложки DGN.

Также можно установить значения параметров контрастности, слияния с фоном, "Монохромный" и цвета для вывода на печать без влияния на исходный файл DWF и без влияния на другие экземпляры DWF на чертеже.

Изменения контрастности, степени слияния с фоном, цветов и параметра "Монохромный" выполняются в группе "Регулировка DWF" на палитре "Свойства" при выбранной подложке DWF.

Контрастность

Управляет внешним видом самой тусклой рабочей линии, присутствующей в подложке DWF. Действует совместно с параметром "Слияние с фоном". Если для параметра "Контрастность" задано значение 100, все контурные изображения соответствуют интенсивности значения параметра "Слияние с фоном". Если значение контрастности равно 20, интенсивность самых тусклых линий уменьшается на 20 процентов от значения параметра "Слияние с фоном".

Слияние с фоном

Параметр "Слияние с фоном" определяет насколько светлыми или темными отображаются линии. Высокие значения обеспечивают светлые линии; и наоборот, низкие значения параметра слияния с фоном приводят к отображению темных линий.

Монохромный

Параметр "Монохромный" используется для управления насыщенностью цвета всех контурных изображений, одновременно обеспечивая яркость. При его включении контурные изображения отображаются разными оттенками серого цвета, начиная от черного, если яркость цвета фона составляет 50% или выше. Если яркость цвета фона ниже 50%, происходит инверсия цветов, так что самая темная линия контура отображается белым цветом, а самая светлая - черным. Такая инверсия используется для отображения подложки на экране, но для печати осуществляется возврат в исходное состояние.

Регулировка цвета заднего плана

Параметр "Регулировка цвета заднего плана" регулирует, будут ли видны фоновые цвета подложки DWF через цвет фона чертежа. Значение по умолчанию "Да" позволяет проводить анализ цветов фона подложки DWF и среды построений чертежа для проверки, не являются ли они оба светлыми или темными, или же один - темный, а другой - светлый. Если один фон - светлый, а другой - темный, цвета подложки DWF инвертируются так, чтобы подложка была видна. При изменении значения параметра на "Нет", используется исходные цвета подложки. В зависимости от цветов фона, подложку DWF может не быть видно.


Регулировка параметров контрастности, слияния с фоном, "Монохромный" и цветов подложки DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона подложки DWF
Понятия
Процедуры
Команды

Регулировка параметров контрастности, слияния с фоном, "Монохромный" и цветов подложки DWF

  1. Выберите подложку DWF, параметры которой требуется отредактировать.
  2. Нажмите "Редактирование" » "Свойства".
  3. На палитре свойств подложки DWF выполните одно из следующих действий:
    • Отрегулируйте контрастность, вводя новое значение.

      • Значение по умолчанию для контрастности - 25 на шкале от 0 (низкая) до 100 (высокая).

    • Отрегулируйте степень слияния с фоном, вводя новое значение.

      • Значение по умолчанию для слияния с фоном - 25 на шкале от 0 (темное) до 80 (светлое).

    • Включите или отключите параметр "Монохромный".

    Значением по умолчанию для параметра "Монохромный" является "Откл".

    • Задайте для параметра "Регулировка цвета заднего плана" значение "Да" или "Нет".

    По умолчанию значение параметра "Регулировка цвета заднего плана" - "Да".

Обновление внешнего вида подложки DWF происходит в реальном времени, одновременно с регулировкой значений параметров на палитре свойств.

Контекстное меню: Дважды нажмите кнопку мыши на подложке DWF.


Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона подложки DWF - Команды

Работа с данными других форматов
Работа с данными других форматов
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона подложки DWF
Понятия
Процедуры
Команды

Команды
ДВФРЕГУЛ | Позволяет выполнять настройку подложки DWF из командной строки
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Подрезка подложек DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка подложек DWF
Понятия
Процедуры
Команды

Для подрезки изображения подложки DWF на чертеже можно использовать прямоугольный или многоугольный контур подрезки.

Можно определить часть подложки DWF, которую требуется отображать и выводить на печать, путем задания контура подрезки. Дополнительным преимуществом от задания контура подрезки является увеличение скорости перерисовки за счет выделения только частей подложки, которые должны быть видимыми. Контуром подрезки может служить прямоугольник или двумерный (2D) многоугольник, вершины которого лежат внутри границ подложки. Контур подрезки для каждого экземпляра подложки DWF может быть только один. Разные экземпляры одной и той же подложки могут иметь разные контуры. Контур подрезанной подложки можно изменить в любой момент.

Подрезанную подложку можно отображать с использованием контура подрезки или можно его скрыть, чтобы отображать подложку в её исходных границах.

Если контур подрезки более не нужен, его можно удалить из подложки. После удаления контура подрезки подложка отображается в своих исходных границах.

Далее приводится пример подложки DWF с вкладками, демонстрирующий многоугольный (м) и прямоугольный (п) контур подрезки:


Подрезка подложек DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка подложек DWF
Понятия
Процедуры
Команды

Подрезка подложки DWF

Указание нового контура для подрезанной подложки DWF

Редактирование существующего контура у подрезанной подложки DWF

Показ или скрытие подрезанной части подложки DWF

Удаление контура подрезанной подложки DWF


Подрезка подложки DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка подложек DWF
Понятия
Процедуры
Команды

Подрезка подложки DWF

  1. Нажмите правую кнопку мыши на объекте, являющемся частью подложки DWF. Выберите "Подрезка DWF...".
  2. В командной строке введите н (Новый контур).
  3. Введите м (Многоугольный) или п (Прямоугольный); затем очертите контур подрезки.

    4. Задание многоугольного контура производится последовательным указанием его вершин. Для завершения построения многоугольника нажмите клавишу ENTER или правую кнопку мыши в любой точке области чертежа.

Контекстное меню: Нажмите правую кнопку мыши на объекте подложки DWF. Выберите "Подрезка DWF...".

Ввод команды: ДВФРЕЗ


Указание нового контура для подрезанной подложки DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка подложек DWF
Понятия
Процедуры
Команды

Указание нового контура для подрезанной подложки DWF

  1. Нажмите правую кнопку мыши на объекте, являющемся частью подложки DWF. Выберите "Подрезка DWF...".
  2. В командной строке введите н (Новый контур).
  3. Введите н (Нет) или д (Да) в ответ на запрос об удалении старого контура.
  4. Введите м (Многоугольный) или п (Прямоугольный); затем очертите контур подрезки.

    5. Задание многоугольного контура производится последовательным указанием его вершин. Для завершения построения многоугольника нажмите клавишу ENTER или правую кнопку мыши в любой точке области чертежа.

    Контуры подрезки могут редактироваться с помощью ручек. См. раздел Редактирование с помощью ручек.

Контекстное меню: Нажмите правую кнопку мыши на подрезанной подложке DWF. Выберите "Подрезка DWF...".

Ввод команды: ДВФРЕЗ


Редактирование существующего контура у подрезанной подложки DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка подложек DWF
Понятия
Процедуры
Команды

Редактирование существующего контура у подрезанной подложки DWF

  1. Выберите подрезанную подложку DWF.
  2. Нажмите одну из угловых ручек и перетащить ее в новое положение.
  3. Нажмите кнопку мыши повторно для установки угловой ручки.

Контекстное меню: Нажмите правую кнопку мыши на подрезанной подложке DWF. Выберите "Подрезка DWF...".

Ввод команды: ДВФРЕЗ


Показ или скрытие подрезанной части подложки DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка подложек DWF
Понятия
Процедуры
Команды

Показ или скрытие подрезанной части подложки DWF

  1. Выберите подрезанную подложку DWF, часть которой требуется показать или скрыть.
  2. Нажмите правую кнопку мыши и выберите "Свойства".
  3. Осуществите прокрутку до группы "Прочие" и выберите "Да" или "Нет" для параметра "Показ подрезанного".

    4. Контекстное меню: После выбора подрезанной подложки DWF нажмите правую кнопку мыши. Нажмите кнопку "Свойства".

    Ввод команды: ОКОНСВ


Удаление контура подрезанной подложки DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка подложек DWF
Понятия
Процедуры
Команды

Удаление контура подрезанной подложки DWF

  1. Выберите подрезанную подложку DWF.
  2. Нажмите правую кнопку мыши и выберите "Подрезка DWF...".
  3. Нажмите кнопку "Удалить".

    4. Контур подрезанной подложки удаляется, и восстанавливается исходный контур подложки.

Контекстное меню: Нажмите правую кнопку мыши на подрезанной подложке DWF. Выберите "Подрезка DWF...".

Ввод команды: ДВФРЕЗ


Подрезка подложек DWF - Команды

Работа с данными других форматов
Работа с данными других форматов
Подрезка подложек DWF
Понятия
Процедуры
Команды

Команды
ДВФРЕЗ | Определение подобласти подложки DWF с помощью секущих контуров.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Показ и скрытие контуров подложки DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Показ и скрытие контуров подложки DWF
Понятия
Процедуры
Команды

Имеется возможность управления видимостью контура, который описывает границы подложки DWF или видимостью контура, который определяется контуром подрезки.

Можно скрывать контуры подложки DWF. Контур - это визуальная граница, которая показывает предельные размеры подложки DWF или контур ее подрезки. Скрытие контура подложки предотвращает печать границы или ее представление на экране. Тем не менее, при невидимом контуре можно выбрать подложку с помощью устройства указания. Однако подложки DWF все же можно выбирать, если они не находятся на заблокированном слое, например, если подложка является частью именованного набора объектов, выбранных с использованием параметра "Все". Если контуры подложки скрыты, подрезанные подложки все же отображаются в заданных для них пределах; операция относится только к контуру. Включение и отключение отображения контуров подложки относится ко всем подложкам, вставленным в чертеж.

Приведенный на переднем плане пример показывает подложку DWF с видимым контуром DWF.

Приведенный на переднем плане пример показывает подложку DWF с видимым контуром DWF.


Показ и скрытие контуров подложки DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Показ и скрытие контуров подложки DWF
Понятия
Процедуры
Команды

Показ и скрытие контуров подложки DWF

  1. В командной строке введите dwfframe.
  2. На запрос в командной строке произведите одну из следующих операций:
    • Для скрытия контуров подложки DWF введите 0.
    • Для отображения и вывода на печать контуров подложки DWF введите 1.
    • Для показа контуров подложки DWF на экране без вывода на печать введите 2.

Ввод команды: DWFFRAME


Показ и скрытие контуров подложки DWF - Команды

Работа с данными других форматов
Работа с данными других форматов
Показ и скрытие контуров подложки DWF
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
DWFFRAME | Определяет видимость контура подложки DWF
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление и публикация чертежей, содержащих подложки DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Управление и публикация чертежей, содержащих подложки DWF
Понятия
Процедуры
Команды

Имеется возможность просмотра и работы с подложками DWF и изменения путей к подложкам с палитры "Внешние ссылки".

  • Просмотр сведений о подложке DWF
    Можно просматривать относящуюся к файлам информацию о подложках DWF, вставленных в чертеж, на палитре "Внешние ссылки". Также имеется возможность загружать и выгружать подложки и производить иные операции.
  • Изменение путей к файлам подложек DWF
    Имеется возможность изменения пути к файлу DWF, на который имеется ссылка, или поиска необнаруженной подложки DWF.
  • Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DWF
    Файлы чертежей, содержащие вставки подложек DWF, можно выводить на печать или публиковать как файлы DWF. При формировании комплекта для электронной пересылки происходит отслеживание и управление файлами DWF. Более того, подложки DWF не будут потеряны при сохранении в формате чертежа прежних версий.
  • Диспетчер ссылок и подложки DWF
    С помощью Диспетчера ссылок можно просматривать вхождения файлов, вставленных в файл DWF, и редактировать пути вставляемых файлов.


Управление и публикация чертежей, содержащих подложки DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Управление и публикация чертежей, содержащих подложки DWF
Понятия
Процедуры
Команды

Просмотр списка подложек DWF, вставленных в чертеж

Отображение имен подложек DWF и уровней их вложения во внешние ссылки и блоки

Изменение пути к подложке DWF

Проверка подложек DWF с помощью Диспетчера ссылок


Управление и публикация чертежей, содержащих подложки DWF - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Управление и публикация чертежей, содержащих подложки DWF
Понятия
Процедуры
Команды
Команды
3DДВФ | Создает 3D DWF-файл пользовательской трехмерной модели и отображает ее в программе просмотра DWF
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ДВФВСТАВИТЬ | Вставка подложки DWF в текущий чертеж
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
ПУБЛ3DДВФ | Устар.
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Просмотр сведений о подложке DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Просмотр сведений о подложке DWF
Понятия
Процедуры
Команды

Можно просматривать относящуюся к файлам информацию о подложках DWF, вставленных в чертеж, на палитре "Внешние ссылки". Также имеется возможность загружать и выгружать подложки и производить иные операции.

На палитре "Внешние ссылки" можно просматривать сведения о подложке или в виде списка, или в режиме древовидного представления. Способ отображения информации на палитре "Внешние ссылки" выбирается кнопками "Список" или "Дерево" в верхнем правом углу. В режиме списка для каждой подложки на чертеже отображаются имя, статус ее загрузки, размер файла, дата последнего изменения и путь поиска файла. В режиме просмотра дерева подложки представлены в рамках иерархической структуры, отображающей уровень их вложенности во внешние ссылки и блоки. Сведения о статусе, размере и т.д. не выводятся.

Для любого вида можно отобразить информацию о подложке; вставить или удалить подложку; выгрузить или обновить подложку; а также выберите и сохранить новый путь поиска.

Работа с режимом списка

В режиме просмотра списка отображаются все подложки, вставленные в текущий чертеж, но нет никакой информации о количестве экземпляров. Этот режим установлен по умолчанию. Сортировка подложек по категориям осуществляется нажатием кнопки мыши на заголовке соответствующего столбца. Для изменения ширины столбца необходимо установить курсор на вертикальную границу, разделяющую заголовки столбцов, и перетащить ее влево или вправо.

В список включаются следующие сведения:

  • имя файла DWF
  • положение (загружена, выгружена или не найдена)
  • размер файла
  • тип файла
  • дата и время последнего сохранения
  • сохраненный путь

Если программе не удается обнаружить подложку, ее положение становится "Не найдена". Подложка со статусом "Не найдена" отображается на чертеже своими контурами, даже их показ в команде DWFFRAME отключен. Если на подложку нет ссылок, то ее экземпляры в чертеж не вставляются. Если подложка не загружена, ее положение становится "Выгружена". Подложки в положении "Выгружена" или "Не найдена" на чертеже не отображаются.

Работа с режимом древовидного представления

На верхнем уровне в режиме дерева файлы DWF перечисляются в алфавитном порядке. В большинстве случаев файл подложки связывается непосредственно с чертежом и упоминается на верхнем уровне. Однако, если внешняя ссылка или блок содержит вставленную подложку, отображаются дополнительные уровни.

Просмотр подробных сведений о файле DWF

Имеется возможность предварительного просмотра выбранной подложки и файла DWF и получения подробных данных о нем, среди которых:

  • имя
  • положение
  • размер файла
  • тип файла
  • дата создания файла
  • сохраненный путь
  • обнаружен в... (путь, по которому изображение найдено)

    • Примечание Параметр "Обнаружен в..." отключен, если выбрана вложенная ссылка.

  • Монохромное состояние
Работа в режиме "Интерфейс единственного документа"

Управление подложками DWF выполняется другим способом при работе в режиме интерфейса единственного документа (SDI).

Если в качестве режима работы выбирается режим SDI, палитра "Внешние ссылки" недоступна для целей управления связанными с чертежом подложками DWF. Режим интерфейса единственного документа устанавливается с помощью системной переменной SDI.

Если при включении режима SDI видна палитра "Внешние ссылки", она остается видимой, но становится неактивной. Единственный доступный элемент управления позволяет только закрыть или скрыть палитру.


Просмотр сведений о подложке DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Просмотр сведений о подложке DWF
Понятия
Процедуры
Команды

Просмотр списка подложек DWF, вставленных в чертеж

Отображение имен подложек DWF и уровней их вложения во внешние ссылки и блоки


Просмотр списка подложек DWF, вставленных в чертеж - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Просмотр сведений о подложке DWF
Понятия
Процедуры
Команды

Просмотр списка подложек DWF, вставленных в чертеж

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" нажмите кнопку "Вид".

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ

Контекстное меню: Выберите подложку и нажмите правую кнопку мыши в области рисования. Выберите "Внешние ссылки".


Отображение имен подложек DWF и уровней их вложения во внешние ссылки и блоки - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Просмотр сведений о подложке DWF
Понятия
Процедуры
Команды

Отображение имен подложек DWF и уровней их вложения во внешние ссылки и блоки

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" нажмите кнопку "Дерево".

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ


Просмотр сведений о подложке DWF - Команды

Работа с данными других форматов
Работа с данными других форматов
Просмотр сведений о подложке DWF
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ДВФВСТАВИТЬ | Вставка подложки DWF в текущий чертеж
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение путей к файлам подложек DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение путей к файлам подложек DWF
Понятия
Процедуры
Команды

Имеется возможность изменения пути к файлу DWF, на который имеется ссылка, или поиска необнаруженной подложки DWF.

При открытии чертежа с вставленным файлом DWF путь к выбранной подложке DWF отображается в палитре "Внешние ссылки", в поле "Обнаружен в..." в списке "Подробности". Отображаемый путь - это фактическое местоположение файла DWF. В поле "Сохраненный путь" отображается путь, по которому находился файл DWF на момент вставки.

Для обнаружения файла DWF программа выполняет поиск путей и папок в следующей последовательности.

  • Путь, указанный при вставке подложки DWF
  • Папка, в которой хранится текущий чертеж
  • Стандартные пути поиска файлов проектов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Стандартные пути поиска вспомогательных файлов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Рабочая папка, указанная в ярлыке программы

Если открыть чертеж, содержащий файл DWF, который не обнаружить ни по сохраненному пути, ни по одному из путей поиска, в столбце "Положение" списка "Вхождения файлов" палитры "Внешние ссылки" отображается "Не найдена", а поле "Обнаружен в..." списка "Подробности" остается незаполненным.

Можно удалить путь из имени файла или указать относительный путь путем ручного редактирования пути в поле "Обнаружен в..." или после нажатия кнопки [...] в правой части поля "Обнаружен в...". Последняя операция открывает диалоговое окно "Выбор DWF-файла".

Дополнительную информацию об использовании абсолютных и относительных путей, а также имен проектов см. в разделе Задание путей к внешним чертежам.

Листы в подложках DWF

Если файлы DWF используются в качестве подложек, появляется дополнительный ссылочный уровень, который отображается за именем файла DWF. Также указывается лист, который вставлен как подложка. При смене путей возможна ситуация, при которой подложка DWF будет считаться ненайденной, если новый путь, заданный для файла DWF, содержит не такое же имя листа, что и файл, на который происходила ссылка первоначально.


Изменение пути к подложке DWF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение путей к файлам подложек DWF
Понятия
Процедуры
Команды

Изменение пути к подложке DWF

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" выберите подложку DWF, путь к которой требуется изменить. Нажмите кнопку [...] в правой части поля "Обнаружен в...".
  3. В диалоговом окне "Выбор DWF-файла" задайте новый путь. Нажмите "Открыть".

    4. Новый путь отображается в столбце "Сохраненный путь".

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ

Контекстное меню: Выберите подложку DWF и нажмите правую кнопку мыши в области рисования. Выберите "Внешние ссылки".


Изменение путей к файлам подложек DWF - Команды

Работа с данными других форматов
Работа с данными других форматов
Изменение путей к файлам подложек DWF
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DWF
Понятия
Процедуры
Команды

Файлы чертежей, содержащие вставки подложек DWF, можно выводить на печать или публиковать как файлы DWF. При формировании комплекта для электронной пересылки происходит отслеживание и управление файлами DWF. Более того, подложки DWF не будут потеряны при сохранении в формате чертежа прежних версий.

Печать и публикация

Если файл чертежа, содержащий вставленную подложку DWF, выводить на печать или публиковать в новый файл DWF, вся видимая геометрия DWF включается в новый отпечатанный или опубликованный файл DWF. Однако в новый файл DWF не будут опубликованы сведения о слоях, относящиеся к исходному файлу DWF, вставленному в чертеж.

Сохранение в формате DWG прежних версий

Если чертеж сохранен в формате DWG предыдущей версии,подложка DWF не будет отображаться при открытии чертежа в устаревшей версии программы, она не будет отображена и как объект-заместитель или прокси-контур. Если же открыть чертеж в текущей версии программы, подложка DWF появится на изображении снова.

Формирование комплекта

Отслеживание и управление вставками DWF при формировании комплекта для электронной пересылки происходит тем же образом, что и при работе с растровыми изображениями.


Управление и публикация чертежей, содержащих подложки DWF

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Управление и публикация чертежей, содержащих подложки DWF
Понятия
Процедуры
Команды

Нет процедур.


Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DWF - Команды

Работа с данными других форматов
Работа с данными других форматов
Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DWF
Понятия
Процедуры
Команды

Команды
3DДВФ | Создает 3D DWF-файл пользовательской трехмерной модели и отображает ее в программе просмотра DWF
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
ПУБЛ3DДВФ | Устар.
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Диспетчер ссылок и подложки DWF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Диспетчер ссылок и подложки DWF
Понятия
Процедуры
Команды

С помощью Диспетчера ссылок можно просматривать вхождения файлов, вставленных в файл DWF, и редактировать пути вставляемых файлов.

Диспетчер ссылок - это внешнее приложение, позволяющее проверять связи файла чертежа с другими файлами. Диспетчер ссылок отображает следующие свойства:

  • тип файла
  • положение
  • имя файла
  • имя
  • сохраненный путь
  • путь обнаружения
  • основной чертёж
  • основная версия

Имеется возможность просмотра списка ссылок, относящихся к чертежу, или списка ссылок одного типа.


Проверка подложек DWF с помощью Диспетчера ссылок - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Диспетчер ссылок и подложки DWF
Понятия
Процедуры
Команды

Проверка подложек DWF с помощью Диспетчера ссылок

  1. Нажмите "Пуск" » "Программы" » "Autodesk" » "AutoCAD 2007" » "Диспетчер ссылок".
  2. В окне "Диспетчер ссылок" нажмите кнопку "Добавить чертежи".
  3. В диалоговом окне "Добавление чертежей" выберите чертеж и нажмите кнопку "Открыть".


Диспетчер ссылок и подложки DWF - Команды

Работа с данными других форматов
Работа с данными других форматов
Диспетчер ссылок и подложки DWF
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Файлы DXF и DXB - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы DXF и DXB
Понятия
Процедуры
Команды

Файлы DXF и DXB - это две формы файлов обмена чертежами, с которыми можно работать в программе.

DXF-файл (формат обмена чертежами) - это описание файла чертежа в текстовом (ASCII) формате. Такие файлы применяются для обмена данными с другими приложениями, чаще всего другими программами САПР.

Файл DXB (двоичный формат обмена чертежами) - это особым образом закодированная двоичная версия файла DХF, создающаяся такими программами, как AutoShade.

Преобразование DXF- или DXB-файла в DWG-формат осуществляется путем его открытия с последующим сохранением в формате DWG. После этого с полученным фалом можно работать так же, как и с любым другим файлом чертежа, и можно импортировать его в другой чертеж в виде внешней ссылки или блока.


Файлы DXF и DXB - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы DXF и DXB
Понятия
Процедуры
Команды

Открытие файла DXF

Для открытия DXB-файла


Открытие файла DXF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы DXF и DXB
Понятия
Процедуры
Команды

Открытие файла DXF

  1. Нажмите "Файл" » "Открыть".
  2. В списке "Тип файла" диалогового окна "Выбор файла" выберите "DXF (*.dxf)".
  3. Найдите и выберите импортируемый DXF-файл или введите имя файла в соответствующем поле.
  4. Нажмите "Открыть".

    5. Ввод команды: DXFIN


Для открытия DXB-файла - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы DXF и DXB
Понятия
Процедуры
Команды

Для открытия DXB-файла

  1. Нажмите "Вставка" » "DXB".
  2. В диалоговом окне "Выбор DXB-файла" найдите и выберите импортируемый DXB-файл.
  3. Нажмите "Открыть".

Ввод команды: ИМПОРТД


Файлы DXF и DXB - Команды

Работа с данными других форматов
Работа с данными других форматов
Файлы DXF и DXB
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Файлы растровых изображений - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы растровых изображений
Понятия
Процедуры
Команды

В чертежах можно просматривать и манипулировать растровыми изображениями и соответствующими путями файлов.

Можно добавлять растровые изображения в векторные чертежи, а затем выполнять просмотр и печать полученного файла. Благодаря использованию растровых изображений в векторных файлах, можно работать с отсканированными и полученными по факсу документами, микрофильмами, результатами аэро- и спутниковой фотосъемки, цифровыми фотографиями, создавать и вставлять в чертеж водяные знаки и логотипы, а также включать в выпускаемую документацию тонированные изображения.

  • Коротко о растровых изображениях
  • Вставка, масштабирование и удаление растровых изображений
    Можно добавлять к файлам чертежей ссылки на растровые изображения или удалять их или же изменять их относительные размеры.
  • Редактирование растровых изображений и их контуров
    Имеется возможность управлять контурами подрезки и видимыми свойствами растровых изображений.
  • Управление растровыми изображениями
    Имеется возможность управления и манипуляции растровыми изображениями и изменения путей к файлам изображений с помощью палитры "Внешние ссылки".
  • Настройка скорости обработки изображений
    Пути повышения производительности системы при обработке больших или множества маленьких растровых изображений.


Файлы растровых изображений - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы растровых изображений
Понятия
Процедуры
Команды

Вставка изображения

Для вставки и масштабирования изображения из Интернета

Вставка и масштабирование изображения

Удаление изображения

Включение и отключение видимости контуров изображений

Подрезка изображения

Изменение контура подрезки изображения

Показа или скрытие подрезанной части изображения

Удаление контура подрезки изображения

Регулировка яркости, контрастности и слияния с фоном

Изменение цвета и прозрачности монохромного изображения

Изменение только прозрачности монохромного изображения

Просмотр списка изображений, вставленных в чертеж

Отображение имен изображений и уровней их вложения в ссылки на DWG и блоки

Просмотр изображения и подробных сведений о файле

Предварительный просмотр еще не вставленного изображения

Просмотра сведений об изображении в текстовом окне

Изменение имени изображения

Изменение пути к изображению

Выгрузка и повторная загрузка изображения

Изменения видимости отдельных экземпляров изображения

Изменение качества представления изображений

Скрытие и повторный вывод изображения


Файлы растровых изображений - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы растровых изображений
Понятия
Процедуры
Команды
Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ИЗОБ | Открытие палитры "Внешние ссылки"
ИЗОБВСТАВИТЬ | Вставка нового изображения в текущий чертеж
ИЗОБКАЧЕСТВО | Управление качеством вывода изображений на экран
ИЗОБКОНТУР | Управляет видимостью рамок изображения и выводом их на печать
ИЗОБРЕГУЛ | Регулировка яркости, контрастности и степени слияния с фоном изображений
ИЗОБРЕЗ | Использует контуры подрезки для определения подобласти объекта изображения.
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПРОЗРАЧНОСТЬ | Управление прозрачностью фоновых пикселов растровых изображений
Системные переменные
IMAGEHLT | Управляет режимом подсветки растровых изображений при выборе
PROJECTNAME | Присваивает имя проекта текущему чертежу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о растровых изображениях - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Коротко о растровых изображениях
Понятия
Процедуры
Команды

Растровые изображения представляют собой прямоугольную сетку мелких квадратиков или точек, называемых пикселами. Рассмотрим, например, фотографию дома: она составлена из множества разноцветных пикселов, которые, будучи взятыми вместе, передают его внешний вид. Пикселы растрового изображения образуют сетку.

Растровые изображения, как и многие другие объекты чертежа, можно копировать, перемещать или подрезать. Изображение можно редактировать с помощью ручек, изменять его контрастность, подрезать прямоугольными и многоугольными контурами; кроме того, изображение само может быть использовано в качестве кромок для обрезки.

Форматы файлов изображений, поддерживаемые программой, включают большинство распространенных форматов, используемых в основных областях применения приложений для работы с изображениями: компьютерная графика, обработка документов, проектирование, картография и географические информационные системы (GIS). По глубине палитры картинки могут быть монохромными, 8-битовыми в уровнях серого, а также 8- и 24-битовыми цветными. Изображения с глубиной цветности 16-бит не поддерживаются, начиная с AutoCAD 2007.

В некоторых растровых форматах существует понятие прозрачных пикселов. При включении режима прозрачности изображения программа распознает прозрачные пикселы и позволяет “просматривать сквозь нихcquote; графические объекты в области чертежа (В монохромных изображениях фоновые пикселы считаются прозрачными.) Прозрачные изображения могут быть черно-белыми или цветными.

Примечание Несмотря на то, что расширения имен файлов перечислены в следующей таблице, формат файла определяется по его содержимому, а не по расширению.

Поддерживаемые форматы файлов изображений
Тип | Описание и версии | Расширения файлов
BMP | Растровые форматы Windows и OS/2 | ..bmp,.dib, rle
CALS-I | Mil-R-Raster I | .gp4, .mil, .rst, .cg4, .cal
FLIC | Анимация FLIC Autodesk Animator | .flc, .fli
GeoSPOT | GeoSPOT (для каждого BIL-файла в той же папке должны иметься HDR-файл и PAL-файл с параметрами совмещения) | .bil
IG4 | Image Systems Group 4 | .ig4
IGS | Image Systems Grayscale | .igs
JFIF или JPEG | Joint Photographics Expert Group | .jpg или .jpeg
PCX | Рисунок PC Paintbrush Picture | .pcx
PICT | Рисунок Macintosh Picture | .pct
PNG | Portable Network Graphic (переносимая сетевая графика) | .png
RLC | Run-Length Compressed | .rlc
TARGA | Формат растровой графики фирмы True Vision | .tga
TIFF | формат TIFF (теговый формат файлов изображений) | .tif или .tiff


Файлы растровых изображений

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы растровых изображений
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Коротко о растровых изображениях - Команды

Работа с данными других форматов
Работа с данными других форматов
Коротко о растровых изображениях
Понятия
Процедуры
Команды

Команды
ИЗОБ | Открытие палитры "Внешние ссылки"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вставка, масштабирование и удаление растровых изображений - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Вставка, масштабирование и удаление растровых изображений
Понятия
Процедуры
Команды

Можно добавлять к файлам чертежей ссылки на растровые изображения или удалять их или же изменять их относительные размеры.

  • Вставка растровых изображений
    Можно вставить в файл чертежа растровое изображение, указав путь к соответствующему файлу. Доступ к изображениям может осуществляться через Интернет.
  • Масштабирование растровых изображений
    Имеется возможность управлять размерами растрового изображения на чертеже, так чтобы оно соответствовало его масштабу.
  • Удаление растровых изображений
    Ссылку на файл изображения можно удалить из чертежа.


Вставка, масштабирование и удаление растровых изображений - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Вставка, масштабирование и удаление растровых изображений
Понятия
Процедуры
Команды

Вставка изображения

Для вставки и масштабирования изображения из Интернета

Вставка и масштабирование изображения

Удаление изображения


Вставка, масштабирование и удаление растровых изображений - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Вставка, масштабирование и удаление растровых изображений
Понятия
Процедуры
Команды
Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ИЗОБ | Открытие палитры "Внешние ссылки"
ИЗОБВСТАВИТЬ | Вставка нового изображения в текущий чертеж
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вставка растровых изображений - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Вставка растровых изображений
Понятия
Процедуры
Команды

Вставленные в файл чертежа изображения, как и внешние ссылки, в действительности не являются его составной частью. Связь чертежа и картинки устанавливается заданием пути. Можно в любой момент редактировать пути связей с изображениями и удалять их. Путем вставки изображений с использованием путей связей с изображениями или их перетаскивания с помощью DesignCenter™ можно поместить изображения в чертеж, увеличив его размер лишь незначительно. См. раздел Добавление содержимого с помощью центра управления DesignCenter.

Допускается многократная вставка в чертеж одного и того же изображения; общая стратегия здесь полностью совпадает с используемой для блоков. Каждое вхождение изображения может иметь собственный контур подрезки и отличающиеся от других вхождений значения яркости, контрастности, прозрачности и степени слияния с фоном.

Доступ к растровым изображениям через Интернет

В наши дни дизайнеры и производители все чаще размещают образцы предлагаемой ими продукции в сети Интернет. Доступ к файлам изображений можно легко получить из Интернета. URL-адреса и имена файлов изображений сохраняются в чертеже.

Использование хранящихся в Интернете изображений ускоряет работу над проектами и облегчает движение чертежей по цепи "исполнитель-руководитель-заказчик". Например, архитектор, которому требуется показать заказчику, как будут выглядеть разработанные кабинеты, просит создать тонированное изображение кабинетов, разместить его на Интернет-сайте, а затем вставить изображение в файл чертежа с помощью URL-адреса; все изменения в проекте можно будет немедленно обновлять. Дополнительную информацию см. в разделе Внешние ссылки.

Примечание AutoCAD 2000, AutoCAD LT 2000, и более поздние версии не поддерживают TIFF файлы, сжатые с помощью LZW. Исключением являются англоязычные версии программ, территории США и Канады. Если необходимо вставить в чертеж TIFF файлы, которые были созданы с использованием сжатия LZW, пересохраните файлы, отключив сжатие LZW.


Вставка растровых изображений - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Вставка растровых изображений
Понятия
Процедуры
Команды

Вставка изображения

Для вставки и масштабирования изображения из Интернета


Вставка изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Вставка растровых изображений
Понятия
Процедуры
Команды

Вставка изображения

  1. Нажмите "Вставка" » "Растровое изображение".
  2. В диалоговом окне "Выбор файла изображения" выберите имя файла из списка или введите имя файла изображения в поле "Имя файла". Нажмите "Открыть".
  3. В диалоговом окне "Растровое изображение" задайте точку вставки, масштаб и угол поворота одним из следующих способов:
    • Установите флажок "Указать на экране", чтобы использовать устройство указания для вставки изображения в определенную точку с необходимым масштабом и под нужным углом.
    • Уберите флажок "Указать на экране" и введите значения в поля групп "Точка вставки", "Масштаб" или "Угол поворота".

    Для просмотра единиц измерения для изображения нажмите кнопку "Подробнее".

  4. Нажмите "ОК".

Панель "Ссылки"

Ввод команды: ИЗОБВСТАВИТЬ


Для вставки и масштабирования изображения из Интернета - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Вставка растровых изображений
Понятия
Процедуры
Команды

Для вставки и масштабирования изображения из Интернета

  1. Нажмите "Вставка" » "Растровое изображение".
  2. В диалоговом окне "Выбор файла изображения" нажмите кнопку "Поиск в Интернете".
  3. В окне "Открытие" браузера Web введите адрес (URL) файла изображения в поле "Искать в".
  4. Введите имя файла изображения в поле "Имя файла". Нажмите "Открыть".

    5. Можно также выбрать изображение, нажав на нем правую кнопку мыши. Нажмите кнопку "Свойства". Можно выделить, скопировать и вставить полный URL-адрес изображения в поле "Имя файла".

  5. В диалоговом окне "Изображение" нажмите "ОК".
  6. При запросе указать точку вставки и масштаб.

Панель "Ссылки"

Ввод команды: ИЗОБВСТАВИТЬ


Вставка растровых изображений - Команды

Работа с данными других форматов
Работа с данными других форматов
Вставка растровых изображений
Понятия
Процедуры
Команды

Команды
ИЗОБ | Открытие палитры "Внешние ссылки"
ИЗОБВСТАВИТЬ | Вставка нового изображения в текущий чертеж
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Масштабирование растровых изображений - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Масштабирование растровых изображений
Понятия
Процедуры
Команды

Можно задайте масштабный коэффициент растрового изображения при его вставке таким образом, что масштаб объектов в изображении будет соответствовать масштабу объектов в чертеже. По умолчанию в момент вставки масштаб равен 1, а единицы измерения для всех изображений не определены. В файле изображения могут храниться сведения о его экранном разрешении (в точках на дюйм, DPI), заданные, например, в ходе сканирования.

Если в изображении содержатся сведения о его разрешении, программа объединяет эти сведения с масштабным коэффициентом и единицами измерения чертежа для масштабирования изображения в чертеже. Например, если растровое изображение является отсканированной копией, масштаб которой составляет 1 дюйм на 50 футов, или 1:600, а на чертеже 1 единица представляет 1 дюйм, то в диалоговом окне "Изображение" в разделе "Масштаб" выберите "Указать на экране". Для масштабирования изображения удалите флажок параметра "Указать на экране", а затем введите 600 в поле "Масштаб". Изображение вставляется с таким масштабом, что объекты на изображении выравниваются в соответствии с объектами на чертеже.

Если сведения о разрешении вставляемого файла изображения отсутствуют, для ширины растрового изображения устанавливается значение в одну единицу. Таким образом, при вставке файла изображения его ширина равна масштабному коэффициенту растрового изображения.


Вставка и масштабирование изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Масштабирование растровых изображений
Понятия
Процедуры
Команды

Вставка и масштабирование изображения

  1. Нажмите "Вставка" » "Растровое изображение".
  2. В диалоговом окне "Выбор файла изображения" выберите имя файла из списка или введите имя файла изображения в поле "Имя файла". Нажмите "Открыть".
  3. В диалоговом окне "Растровое изображение" задайте точку вставки, масштаб и угол поворота одним из следующих способов:
    • Установите флажок "Указать на экране", чтобы использовать устройство указания для вставки изображения в определенную точку с необходимым масштабом и под нужным углом.
    • Уберите флажок "Указать на экране" и введите значения в поля групп "Точка вставки", "Масштаб" или "Угол поворота".

      • Для просмотра единиц измерения для изображения нажмите кнопку "Подробнее".

  4. Нажмите "ОК".

Панель "Ссылки"

Ввод команды: ИЗОБВСТАВИТЬ


Масштабирование растровых изображений - Команды

Работа с данными других форматов
Работа с данными других форматов
Масштабирование растровых изображений
Понятия
Процедуры
Команды

Команды
ИЗОБ | Открытие палитры "Внешние ссылки"
ИЗОБВСТАВИТЬ | Вставка нового изображения в текущий чертеж
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Удаление растровых изображений - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Удаление растровых изображений
Понятия
Процедуры
Команды

Растровые изображения, которые больше не нужны в чертеже, следует удалять. При удалении изображения происходит стирание всех его экземпляров, описания и относящихся к нему связей (но не файла, в котором изображение хранится на диске!).

Примечание Стирание отдельного экземпляра изображения и его удаление - не одно и то же. Изображение необходимо удалить из чертежа для разрыва связи между чертежом и файлом изображения.


Удаление изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Удаление растровых изображений
Понятия
Процедуры
Команды

Удаление изображения

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" укажите имя изображения, используя правую кнопку мыши.
  3. Выберите "Удалить".

    4. Связь между чертежом и растровым изображением разрывается, и все экземпляры изображения удаляются из чертежа.

Ввод команды: ВНССЫЛКИ

Панель "Ссылки"


Удаление растровых изображений - Команды

Работа с данными других форматов
Работа с данными других форматов
Удаление растровых изображений
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование растровых изображений и их контуров - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Редактирование растровых изображений и их контуров
Понятия
Процедуры
Команды

Имеется возможность управлять контурами подрезки и видимыми свойствами растровых изображений.

  • Включение и отключение контуров растровых изображений
    Имеется возможность управления видимостью контуров подрезки растрового изображения на чертеже.
  • Подрезка растровых изображений
    Изображения на чертеже можно подрезать с помощью многоугольного контура.
  • Изменение яркости, контрастности и степени слияния с фоном растрового изображения
    Для улучшения восприятия или достижения специальных эффектов некоторые видимые свойства растровых изображений на чертеже можно изменять.
  • Изменение цвета и прозрачности монохромных изображений
    В монохромных изображениях различают цвета переднего плана и фона. Имеется возможность изменять цвет переднего плана, а также включать и отключать прозрачность фона.


Редактирование растровых изображений и их контуров - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Редактирование растровых изображений и их контуров
Понятия
Процедуры
Команды

Включение и отключение видимости контуров изображений

Подрезка изображения

Изменение контура подрезки изображения

Показа или скрытие подрезанной части изображения

Удаление контура подрезки изображения

Регулировка яркости, контрастности и слияния с фоном

Изменение цвета и прозрачности монохромного изображения

Изменение только прозрачности монохромного изображения


Редактирование растровых изображений и их контуров - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Редактирование растровых изображений и их контуров
Понятия
Процедуры
Команды
Команды
ИЗОБКОНТУР | Управляет видимостью рамок изображения и выводом их на печать
ИЗОБРЕГУЛ | Регулировка яркости, контрастности и степени слияния с фоном изображений
ИЗОБРЕЗ | Использует контуры подрезки для определения подобласти объекта изображения.
ПРОЗРАЧНОСТЬ | Управление прозрачностью фоновых пикселов растровых изображений
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Включение и отключение контуров растровых изображений - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Включение и отключение контуров растровых изображений
Понятия
Процедуры
Команды

Имеется возможность управления видимостью контуров подрезки растрового изображения на чертеже.

Видимость границы растровой картинки может быть отключена. Скрытие контура изображения предотвращает печать контура или ее отображение на экране. Кроме того, скрытие контура изображения не позволяет выбирать его устройством указания, а это гарантирует, что изображение не будет непреднамеренно сдвинуто или изменено. Однако изображения все же можно выбирать, если они не находятся на заблокированном слое, например, если изображение является частью именованного набора объектов, выбранных с использованием параметра "Все". Если контуры изображения скрыты, подрезанные изображения все же отображаются в заданных для них пределах; операция относится только к контурам. Включение и отключение контуров изображения относится ко всем изображениям, вставленным в чертеж.

Примечание При отключенных контурах выбор изображений указанием или с помощью опции "Рамка" команды ВЫБОР невозможен.


Включение и отключение видимости контуров изображений - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Включение и отключение контуров растровых изображений
Понятия
Процедуры
Команды

Включение и отключение видимости контуров изображений

  1. Нажмите "Редактирование" » "Объект" » "Изображение" » "Контур".
  2. Для скрытия контуров изображения введите 0; для показа контуров изображения на экране и вывода их на печать введите 1; для отображения контуров изображения без вывода на печать введите 2.

Панель "Ссылки"

Ввод команды: ИЗОБКОНТУР


Включение и отключение контуров растровых изображений - Команды

Работа с данными других форматов
Работа с данными других форматов
Включение и отключение контуров растровых изображений
Понятия
Процедуры
Команды

Команды
ИЗОБКОНТУР | Управляет видимостью рамок изображения и выводом их на печать
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Подрезка растровых изображений - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка растровых изображений
Понятия
Процедуры
Команды

Изображения на чертеже можно подрезать с помощью многоугольного контура.

Скорость перерисовки чертежа можно повысить, ограничив имеющиеся в нем растровые изображения так, чтобы на экране остались видны только нужные их части. Определить часть изображения, которую требуется отображать и выводить на печать, можно путем подрезки изображения. Контуром может служить прямоугольник или двумерный (2D) многоугольник, вершины которого лежат внутри границы изображения. Контур подрезки для каждого вхождения картинки может быть только один; но для разных вхождений разрешается задание отдельных контуров. AutoCAD позволяет изменять контуры подрезки изображений.

Имеется возможность отображать подрезанное изображение с использованием контура подрезки или же можно отключить контур подрезки, чтобы отображать изображение в его исходных границах.

Контур подрезки изображения можно удалить. После его удаления изображение восстанавливается на экране в своих исходных границах.

Примечание Для выполнения подрезки контур изображения должен быть видимым. См. раздел Включение и отключение контуров растровых изображений.


Подрезка растровых изображений - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка растровых изображений
Понятия
Процедуры
Команды

Подрезка изображения

Изменение контура подрезки изображения

Показа или скрытие подрезанной части изображения

Удаление контура подрезки изображения


Подрезка изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка растровых изображений
Понятия
Процедуры
Команды

Подрезка изображения

  1. Нажмите "Редактирование" » "Подрезка" » "Изображение".
  2. Выберите подрезаемое изображение, указав его границу.
  3. Введите н (Новый контур).
  4. Введите м (Многоугольный) или п (Прямоугольный); затем очертите контур подрезки.

    5. Задание многоугольного контура производится последовательным указанием его вершин. Для завершения построения многоугольника нажмите клавишу ENTER или правую кнопку мыши в любой точке области чертежа.

Панель "Ссылки"

Ввод команды: ИЗОБРЕЗ

Контекстное меню: Выберите изображение и нажмите правую кнопку мыши в области чертежа. Выберите "Изображение" » "Подрезка".


Изменение контура подрезки изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка растровых изображений
Понятия
Процедуры
Команды

Изменение контура подрезки изображения

  1. Нажмите "Редактирование" » "Подрезка" » "Изображение".
  2. Выберите подрезаемое изображение, указав его границу.
  3. Введите н (Новый контур).
  4. Введите н (Нет) или д (Да) в ответ на запрос об удалении старого контура.
  5. Введите м (Многоугольный) или п (Прямоугольный); затем очертите новый контур в пределах изображения.

    6. Задание многоугольного контура производится последовательным указанием его вершин. Для завершения построения многоугольника нажмите клавишу ENTER или правую кнопку мыши в любой точке области чертежа.

    Контуры подрезки могут редактироваться с помощью ручек. См. раздел Редактирование с помощью ручек.

Панель "Ссылки"

Ввод команды: ИЗОБРЕЗ

Контекстное меню: Выберите изображение и нажмите правую кнопку мыши в области чертежа. Выберите "Изображение" » "Подрезка".


Показа или скрытие подрезанной части изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка растровых изображений
Понятия
Процедуры
Команды

Показа или скрытие подрезанной части изображения

  1. Выберите подрезанное изображение, часть которого требуется показать или скрыть.
  2. Нажмите правую кнопку мыши в области чертежа. Нажмите кнопку "Свойства".
  3. На "Палитре свойств" выберите "Да" или "Нет" в списке "Показ изображения".

Панель "Стандартная"

Ввод команды: ОКОНСВ


Удаление контура подрезки изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Подрезка растровых изображений
Понятия
Процедуры
Команды

Удаление контура подрезки изображения

  1. Нажмите "Редактирование" » "Подрезка" » "Изображение".
  2. Выберите подрезанное изображение, содержащее контур, который требуется удалить.
  3. Введите у (Удалить).

    4. Контур подрезки удаляется; изображение восстанавливается в исходных границах.

Панель "Ссылки"

Ввод команды: ИЗОБРЕЗ

Контекстное меню: Выберите изображение и нажмите правую кнопку мыши в области чертежа. Выберите "Изображение" » "Подрезка".


Подрезка растровых изображений - Команды

Работа с данными других форматов
Работа с данными других форматов
Подрезка растровых изображений
Понятия
Процедуры
Команды

Команды
ИЗОБРЕЗ | Использует контуры подрезки для определения подобласти объекта изображения.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение яркости, контрастности и степени слияния с фоном растрового изображения - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение яркости, контрастности и степени слияния с фоном растрового изображения
Понятия
Процедуры
Команды

Для улучшения восприятия или достижения специальных эффектов некоторые видимые свойства растровых изображений на чертеже можно изменять.

Имеется возможность регулировать яркость, контрастность и степень слияния с фоном отдельного изображения как на экране, так и при выводе на печать. Эти изменения не влияют на параметры исходного файла растрового изображения и другие экземпляры изображения на чертеже. При регулировке яркости картинка становится ярче или темнее. Регулировка контрастности в некоторых случаях повышает читаемость низкокачественных изображений. Регулировка слияния с фоном полезна, если векторные объекты чертежа должны выделяться на фоне изображений; она, в частности, используется при создании водяных знаков во время печати.

Для монохромных изображений регулировка яркости, контрастности и слияния с фоном не разрешена. Находящееся на экране изображение сливается с цветом фона экрана, а при выводе на печать - с белым цветом бумаги.


Регулировка яркости, контрастности и слияния с фоном - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение яркости, контрастности и степени слияния с фоном растрового изображения
Понятия
Процедуры
Команды

Регулировка яркости, контрастности и слияния с фоном

  1. Нажмите "Редактирование" » "Объект" » "Изображение" » "Регулировка".
  2. Выберите изображение для редактирования.
  3. В диалоговом окне "Регулировка изображения" настройте яркость, контрастность и слияние с фоном, используя соответствующие шкалы с движками или непосредственно вводя значения в поля.

    4. По умолчанию и яркость, и контрастность имеют значение 50. Его можно изменять в диапазоне от 0 до 100. Степень слияния с фоном по умолчанию установлена в 0. Ее максимальное значение равно 100.

  4. Нажмите "ОК".

Панель "Ссылки"

Ввод команды: ИЗОБРЕГУЛ

Контекстное меню: Выберите изображение и нажмите правую кнопку мыши в области чертежа. Выберите "Изображение" » "Регулировка".


Изменение яркости, контрастности и степени слияния с фоном растрового изображения - Команды

Работа с данными других форматов
Работа с данными других форматов
Изменение яркости, контрастности и степени слияния с фоном растрового изображения
Понятия
Процедуры
Команды

Команды
ИЗОБРЕГУЛ | Регулировка яркости, контрастности и степени слияния с фоном изображений
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение цвета и прозрачности монохромных изображений - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение цвета и прозрачности монохромных изображений
Понятия
Процедуры
Команды

В монохромных изображениях присутствуют всего два цвета: цвет переднего плана и цвет фона. При вставке такого изображения пикселы, окрашенные в файле в цвет переднего плана, изменяют цвет на установленный текущим в AutoCAD. В дополнение к общим для всех типов картинок операциям редактирования, описанным выше, у монохромных изображений допускается изменение цвета переднего плана и включение/отключение прозрачности фона.

Примечание Монохромные изображения и их границы всегда имеют один и тот же цвет.


Изменение цвета и прозрачности монохромных изображений - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение цвета и прозрачности монохромных изображений
Понятия
Процедуры
Команды

Изменение цвета и прозрачности монохромного изображения

Изменение только прозрачности монохромного изображения


Изменение цвета и прозрачности монохромного изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение цвета и прозрачности монохромных изображений
Понятия
Процедуры
Команды

Изменение цвета и прозрачности монохромного изображения

  1. Выберите изображение для редактирования.
  2. Нажмите правую кнопку мыши в области чертежа. Выберите "Свойства".
  3. Для изменения цвета изображения на палитре свойств выберите "Цвет".
  4. В списке цветов выберите цвет или воспользоваться пунктом "Выбор цвета" для вызова диалогового окна "Выбор цвета". В диалоговом окне "Выбор цвета" указать цвет. Нажмите "OK".
  5. Для переключения состояния прозрачности фона выбранного изображения выберите "Да" или "Нет" в списке "Прозрачность".

Панель "Стандартная"

Ввод команды: ОКОНСВ


Изменение только прозрачности монохромного изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение цвета и прозрачности монохромных изображений
Понятия
Процедуры
Команды

Изменение только прозрачности монохромного изображения

  1. Нажмите "Редактирование" » "Объект" » "Изображение" » "Прозрачность".
  2. Выберите изображение для редактирования.

    3. Чтобы изменить фон выбранного изображения на прозрачный, введите вкл Введите откл, чтобы изменить фон на непрозрачный.

Панель "Ссылки"

Ввод команды: ПРОЗРАЧНОСТЬ

Контекстное меню: Выберите изображение и нажмите правую кнопку мыши в области чертежа. Выберите "Изображение" » "Прозрачность".


Изменение цвета и прозрачности монохромных изображений - Команды

Работа с данными других форматов
Работа с данными других форматов
Изменение цвета и прозрачности монохромных изображений
Понятия
Процедуры
Команды

Команды
ПРОЗРАЧНОСТЬ | Управление прозрачностью фоновых пикселов растровых изображений
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление растровыми изображениями - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Управление растровыми изображениями
Понятия
Процедуры
Команды

Имеется возможность управления и манипуляции растровыми изображениями и изменения путей к файлам изображений с помощью палитры "Внешние ссылки".

  • Просмотр сведений о растровых изображениях
    Можно просматривать относящуюся к файлам информацию о растровых изображениях, вставляемых в чертеж. Также можно загружать и выгружать изображения и проводить другие операции с палитры "Внешние ссылки".
  • Присвоение имен-описаний растровым изображениям
    Если для идентификации изображения недостаточно только имени файла, на палитре "Внешние ссылки" можно добавить к нему имя-описание.
  • Изменение путей к файлам растровых изображений
    С помощью палитры "Внешние ссылки" можно изменить путь к файлу вставленного растрового изображения или отыскать файл для изображения в положении "Не найдено".


Управление растровыми изображениями - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Управление растровыми изображениями
Понятия
Процедуры
Команды

Просмотр списка изображений, вставленных в чертеж

Отображение имен изображений и уровней их вложения в ссылки на DWG и блоки

Просмотр изображения и подробных сведений о файле

Предварительный просмотр еще не вставленного изображения

Просмотра сведений об изображении в текстовом окне

Изменение имени изображения

Изменение пути к изображению


Управление растровыми изображениями - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Управление растровыми изображениями
Понятия
Процедуры
Команды
Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ИЗОБВСТАВИТЬ | Вставка нового изображения в текущий чертеж
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
PROJECTNAME | Присваивает имя проекта текущему чертежу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Просмотр сведений о растровых изображениях - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Просмотр сведений о растровых изображениях
Понятия
Процедуры
Команды

Можно просматривать относящуюся к файлам информацию о растровых изображениях, вставляемых в чертеж. Также можно загружать и выгружать изображения и проводить другие операции с палитры "Внешние ссылки".

На палитре "Внешние ссылки" можно просматривать сведения об изображениях в области "Вхождения файлов" или в виде списка, или в режиме древовидной структуры. Способ отображения информации на палитре "Внешние ссылки" выбирается кнопками "Список" или "Дерево" в верхнем правом углу. В режиме списка отображаются имя каждого изображения на чертеже, статус его загрузки, размер, дата последнего изменения и путь поиска файла. В режиме просмотра дерева изображения представлены в рамках иерархической структуры, отображающей уровень их вложенности в чертежи, на которые сделаны ссылки, и блоки. Положение, размер и иная информация отображаются ниже, в области "Подробности".

Оба режима просмотра позволяют просматривать сведения об изображении, вставлять изображения и удалять их, производить выгрузку и повторную загрузку, осуществлять поиск изображения и сохранять его по новому пути.

Работа с режимом списка

В режиме просмотра списка перечисляются изображения и другие внешние ссылки, вставленные в текущий чертеж, но нет никакой информации о количестве экземпляров. Этот режим установлен по умолчанию. Внешние ссылки можно отсортировать по категориям нажатием по заголовкам столбцов. Для изменения ширины столбца необходимо установить курсор на вертикальную границу, разделяющую заголовки столбцов, и перетащить ее влево или вправо.

В список включаются следующие сведения:

  • имя изображения или выбранной внешней ссылки
  • положение (загружено, выгружено или не найдено)
  • размер файла
  • тип файла
  • дата и время последнего сохранения
  • сохраненный путь

Если изображение не обнаружено, для него указывается статус "Не найдено". Изображение со статусом "Не найдено" представляется в чертеже только своим контуром, даже если в команде ИЗОБКОНТУР установлен параметр "Откл". Если на изображение нет ссылок, то его экземпляры в чертеж не вставляются. Если изображение не загружено, его положение - "Выгружено". Изображения в положении "Не найдено" или "Выгружено" на чертеже не отображаются.

Работа с режимом дерева

В режиме просмотра дерева файлы, на которые имеются ссылки, перечисляются в той последовательности, в которой они вставлялись в чертеж. В большинстве случаев файл изображения связывается непосредственно с чертежом и упоминается на верхнем уровне. Однако если ссылка на DWG или блок содержит связанное изображение, отображаются дополнительные уровни.

Просмотр подробных сведений о файле изображения

В нижних окнах палитры "Внешние ссылки" можно производить предварительный просмотр выбранного изображения или просматривать сведения о файлах изображений, среди которых:

  • имя изображения
  • сохраненный путь
  • активный путь (по которому изображение найдено)
  • дата создания файла
  • размер файла
  • тип файла
  • цвет
  • глубина цветности
  • размеры изображения (ширина и высота в пикселах, разрешение и размеры при вставке по умолчанию)
Просмотр сведений об изображениях в текстовом окне

Сведения об изображениях можно просматривать в командной строке. Данные об изображениях в командной строке содержат имя изображения, путь к нему, количество описаний и количество экземпляров вставки изображения в чертеж.

Работа в режиме "Интерфейс единственного документа"

Управление ссылками на изображения происходит иным способом при работе в режиме интерфейса единственного документа.

Если в качестве режима работы выбирается режим интерфейса единственного документа (SDI), палитра "Внешние ссылки" недоступна для целей управления связанными с чертежом вхождениями файлов. Режим интерфейса единственного документа устанавливается с помощью системной переменной SDI.

Если при включении режима SDI видна палитра "Внешние ссылки", она остается видимой, но становится неактивной. Единственный доступный элемент управления позволяет только закрыть или скрыть палитру.

В режиме SDI команда ИЗОБ будет открывать унаследованный Диспетчер изображений, в котором можно работать со ссылками на изображения. Палитру "Внешние ссылки" можно восстановить, задав для системной переменной SDI значение 0 (ноль).


Просмотр сведений о растровых изображениях - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Просмотр сведений о растровых изображениях
Понятия
Процедуры
Команды

Просмотр списка изображений, вставленных в чертеж

Отображение имен изображений и уровней их вложения в ссылки на DWG и блоки

Просмотр изображения и подробных сведений о файле

Предварительный просмотр еще не вставленного изображения

Просмотра сведений об изображении в текстовом окне


Просмотр списка изображений, вставленных в чертеж - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Просмотр сведений о растровых изображениях
Понятия
Процедуры
Команды

Просмотр списка изображений, вставленных в чертеж

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" нажмите кнопку "Вид".

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ

Контекстное меню: Выберите изображение и нажмите правую кнопку мыши в области чертежа. Нажмите "Изображение" » "Внешние ссылки".


Отображение имен изображений и уровней их вложения в ссылки на DWG и блоки - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Просмотр сведений о растровых изображениях
Понятия
Процедуры
Команды

Отображение имен изображений и уровней их вложения в ссылки на DWG и блоки

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" нажмите кнопку "Дерево".

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ


Просмотр изображения и подробных сведений о файле - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Просмотр сведений о растровых изображениях
Понятия
Процедуры
Команды

Просмотр изображения и подробных сведений о файле

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" выберите файл изображения.
  3. Если панель видов не открыта, нажмите кнопку "Просмотр".

    4. На экран выводится образец изображения.

  4. Для просмотра сведений о файле нажмите кнопку "Подробнее".

    5. Отображаются сведения о файле (размер изображения).

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ


Предварительный просмотр еще не вставленного изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Просмотр сведений о растровых изображениях
Понятия
Процедуры
Команды

Предварительный просмотр еще не вставленного изображения

  1. Нажмите "Вставка" » "Растровое изображение".
  2. В диалоговом окне "Выбор файла изображения" выделить файл, который нужно просмотреть.

    3. Если изображение не отображается в окне предварительного просмотра, нажмите кнопку "Показать образец".

  3. Нажмите "Открыть".
  4. В диалоговом окне "Изображение" нажмите "Подробнее".

    5. На экране появляются сведения о файле изображения.

Панель "Ссылки"

Ввод команды: ИЗОБВСТАВИТЬ


Просмотра сведений об изображении в текстовом окне - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Просмотр сведений о растровых изображениях
Понятия
Процедуры
Команды

Просмотра сведений об изображении в текстовом окне

  1. В командной строке введите -изоб.
  2. Введите ? (список).
  3. Нажмите ENTER для перечисления всех изображений.

    4. В текстовом окне сведения об изображении отображаются в виде списка.


Просмотр сведений о растровых изображениях - Команды

Работа с данными других форматов
Работа с данными других форматов
Просмотр сведений о растровых изображениях
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ИЗОБВСТАВИТЬ | Вставка нового изображения в текущий чертеж
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Присвоение имен-описаний растровым изображениям - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Присвоение имен-описаний растровым изображениям
Понятия
Процедуры
Команды

Если для идентификации изображения недостаточно только имени файла, на палитре "Внешние ссылки" можно добавить к нему имя-описание.

Имена изображений не обязательно такие же, как и имена файлов изображений. При вставке изображения в чертеж в качестве его имени программа использует имя файла без расширения. Имена изображений хранятся в символьных таблицах чертежа; поэтому операция изменения имени изображения никак не отражается на имени файла. Имена фалов изображений могут содержать до 255 символов. Кроме букв и цифр, имена могут содержать пробелы и любые специальные символы, не используемые Microsoft® Windows® или AutoCAD в других целях.

При вставке изображений с одинаковыми именами из разных папок к их именам добавляются номера.


Изменение имени изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Присвоение имен-описаний растровым изображениям
Понятия
Процедуры
Команды

Изменение имени изображения

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки", в области сведений, выберите имя изображения и отредактируйте его.

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ


Присвоение имен-описаний растровым изображениям - Команды

Работа с данными других форматов
Работа с данными других форматов
Присвоение имен-описаний растровым изображениям
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение путей к файлам растровых изображений - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение путей к файлам растровых изображений
Понятия
Процедуры
Команды

С помощью палитры "Внешние ссылки" можно изменить путь к файлу вставленного растрового изображения или отыскать файл для изображения в положении "Не найдено".

Если открыть чертеж со вставленным изображением, путь выбранного изображения появляется на палитре "Внешние ссылки" в области сведений в поле "Обнаружен в...". Отображаемый путь - это фактическое местоположение файла изображения. В поле "Сохраненный путь" отображается путь, по которому находился файл изображения на момент вставки.

Для обнаружения файла изображения программа выполняет поиск путей и папок в следующей последовательности.

  • Путь, указанный при вставке изображения
  • Папка, в которой хранится текущий чертеж
  • Стандартные пути поиска файлов проектов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Стандартные пути поиска вспомогательных файлов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Рабочая папка, указанная в ярлыке программы

Если в ходе открытия чертежа какое-либо изображение не найдено ни по сохраненному пути, ни по любому из заданных путей поиска, оно получает положение "Не найдено" в списке изображений палитры "Внешние ссылки", а поле свойства "Обнаружено в" для него остается незаполненным.

Можно удалить путь из имени файла или задать относительный путь редактированием свойств "Обнаружено в" и последующего нажатия "ОК" в диалоговом окне "Выбор файла изображения".

Дополнительную информацию об использовании абсолютных и относительных путей, а также имен проектов см. в разделе Задание путей к внешним чертежам.


Изменение пути к изображению - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Изменение путей к файлам растровых изображений
Понятия
Процедуры
Команды

Изменение пути к изображению

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" выберите изображение, путь к которому требуется изменить.
  3. В области сведений нажмите кнопку "Обзор" в группе "Обнаружено в".
  4. В диалоговом окне "Выбор файла изображения" перейдите к новой папке и нажмите "ОК".

    5. В свойствах "Обнаружено в" отображается новый путь.

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ

Контекстное меню: Выберите изображение и нажмите правую кнопку мыши в области чертежа. Нажмите "Изображение" » "Внешние ссылки".


Изменение путей к файлам растровых изображений - Команды

Работа с данными других форматов
Работа с данными других форматов
Изменение путей к файлам растровых изображений
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
PROJECTNAME | Присваивает имя проекта текущему чертежу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка скорости обработки изображений - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Настройка скорости обработки изображений
Понятия
Процедуры
Команды

Пути повышения производительности системы при обработке больших или множества маленьких растровых изображений.

  • Загрузка и выгрузка растровых изображений
    Производительность работы можно повысить путем выгрузки из чертежа изображений, если они не требуются в данном сеансе работы с чертежом.
  • Увеличение скорости вывода растровых изображений на экран
    Для увеличения скорости вывода изображений на экран можно изменить качество вывода изображений, скрыть не используемые в настоящее время изображения, использовать мозаичные изображения или отключить подсветку изображений.

См. также

Удаление растровых изображений


Настройка скорости обработки изображений - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Настройка скорости обработки изображений
Понятия
Процедуры
Команды

Выгрузка и повторная загрузка изображения

Изменения видимости отдельных экземпляров изображения

Изменение качества представления изображений

Скрытие и повторный вывод изображения


Настройка скорости обработки изображений - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Настройка скорости обработки изображений
Понятия
Процедуры
Команды
Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
ИЗОБКАЧЕСТВО | Управление качеством вывода изображений на экран
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
IMAGEHLT | Управляет режимом подсветки растровых изображений при выборе
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Загрузка и выгрузка растровых изображений - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Загрузка и выгрузка растровых изображений
Понятия
Процедуры
Команды

Производительность работы можно повысить путем выгрузки из чертежа изображений, если они не требуются в данном сеансе работы с чертежом. Выгруженные изображения не выводятся ни на экран, ни на печать; отображается только контур изображения. С хранящейся в чертеже связью, однако, никаких изменений не происходит. Если для открытия нескольких вставленных на чертеж изображений недостаточно памяти, изображения выгружаются автоматически.

Для загрузки ранее выгруженных изображений, а также для обновления загруженных изображений путем повторной загрузки изображения из файла по заданному пути, служит кнопка "Обновить" палитры "Внешние ссылки". Если чертеж был закрыт после выгрузки изображения, файл изображения не будет загружаться при следующем открытии чертежа. Его необходимо загрузить повторно.


Загрузка и выгрузка растровых изображений - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Загрузка и выгрузка растровых изображений
Понятия
Процедуры
Команды

Выгрузка и повторная загрузка изображения

Изменения видимости отдельных экземпляров изображения


Выгрузка и повторная загрузка изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Загрузка и выгрузка растровых изображений
Понятия
Процедуры
Команды

Выгрузка и повторная загрузка изображения

  1. Нажмите "Вставка" » "Внешние ссылки".
  2. На палитре "Внешние ссылки" в области "Вхождения файлов" с помощью правой кнопки мыши выберите имя изображения, а затем нажмите "Выгрузить" или "Обновить".

    3. Статус изображения изменяется в зависимости от выполненной операции.

    Операции выгрузки и повторной загрузки действуют на все экземпляры выбранных вставленных изображений.

Панель "Ссылки"

Ввод команды: ВНССЫЛКИ

Контекстное меню: Выберите изображение, которое необходимо загрузить или выгрузить, и нажмите правую кнопку мыши в области чертежа. Нажмите "Изображение" » "Внешние ссылки".


Изменения видимости отдельных экземпляров изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Загрузка и выгрузка растровых изображений
Понятия
Процедуры
Команды

Изменения видимости отдельных экземпляров изображения

  1. Выберите изображения, отображение которых требуется переключить.
  2. Нажмите правую кнопку мыши в области чертежа. Нажмите кнопку "Свойства".
  3. На "Палитре свойств" выберите "Да" или "Нет" в списке "Показ изображения".

Панель "Стандартная"

Ввод команды: ОКОНСВ


Загрузка и выгрузка растровых изображений - Команды

Работа с данными других форматов
Работа с данными других форматов
Загрузка и выгрузка растровых изображений
Понятия
Процедуры
Команды

Команды
ВНССЫЛКИ | Открытие палитры "Внешние ссылки"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Увеличение скорости вывода растровых изображений на экран - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Увеличение скорости вывода растровых изображений на экран
Понятия
Процедуры
Команды

Для повышения скорости вывода изображений на экран можно изменить уровень качества их представления с высокого (оно принято по умолчанию) на черновое. Изображения, имеющие черновое качество, выглядят более зернистыми (в зависимости от типа файла изображения), однако загружаются они быстрее, чем высококачественные изображения.

На вкладке "Экран" диалогового окна "Настройка" имеется ряд параметров, управляющих качеством показа изображений при использовании точной цветопередачи (24 или 32 бита на пиксел). При отображении изображений с оптимальным качеством время, необходимое для регенерации, значительно увеличивается. Для того чтобы повысить производительность при работе с чертежом, следует установить меньшую глубину цветности в системных настройках экрана.

Для повышения скорости перерисовки объектов можно также воспользоваться функцией скрытия растровых картинок, которые больше не потребуются в данном сеансе работы. Скрытые изображения не выводятся ни на экран, ни на печать; видны только их контуры. Положение пользовательской системы координат (ПСК) на текущем видовом экране никак не влияет на скрытие изображений.

Работа с мозаичными изображениями

Мозаичные изображения представляют собой маленькие части (набор плиток) больших изображений, загрузка которых выполняется быстрее, чем немозаичных изображений. При редактировании или изменении свойств изображения осуществляется регенерация только измененной части, что способствует экономии времени. Единственным мозаичным форматом, который поддерживается программой, является TIFF (Tagged Image File Format - теговый формат файлов изображений). Процедура чтения TIFF-файлов обрабатывает все стандартные глубины цветности:

  • монохромные (1 бит на пиксел)
  • в оттенках серого и с индексацией цветов (8 бит на пиксел)
  • с полной палитрой (24 или 32 бита на пиксел)

Мозаичные TIFF-изображения могут быть порождены большинством программ сканирования. Размер фрагментов мозаики должен составлять не меньше 64 x 64 пиксела и не больше 512 x 512 пикселов. Сторонние разработчики предлагают драйверы и для других мозаичных графических форматов, таких как CALS Type II.

Отключение подсветки изображения при выборе

Управление стилем подсветки растровых изображений при выборе (все изображение или только его контуры) осуществляется с помощью опции "Подсвечивать только контуры растра" на вкладке "Экран" диалогового окна "Настройка". Это значение можно задайте с помощью системной переменной IMAGEHLT. По умолчанию IMAGEHLT равна 0; это означает, что подсвечиваются только контуры растрового изображения. Отключение подсветки всего изображения ускоряет его обработку.


Увеличение скорости вывода растровых изображений на экран - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Увеличение скорости вывода растровых изображений на экран
Понятия
Процедуры
Команды

Изменение качества представления изображений

Скрытие и повторный вывод изображения


Изменение качества представления изображений - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Увеличение скорости вывода растровых изображений на экран
Понятия
Процедуры
Команды

Изменение качества представления изображений

  1. Нажмите "Редактирование" » "Объект" » "Изображение" » "Качество".
  2. Введите ч (Черновое) или в (Высокое).

    3. Изображение перерисовывается с заданным качеством.

Панель "Ссылки"

Ввод команды: ИЗОБКАЧЕСТВО


Скрытие и повторный вывод изображения - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Увеличение скорости вывода растровых изображений на экран
Понятия
Процедуры
Команды

Скрытие и повторный вывод изображения

  1. Выберите изображение для редактирования.
  2. Нажмите правую кнопку мыши в области чертежа. Выберите "Свойства".
  3. На "Палитре свойств" выберите "Да" или "Нет" в списке "Показ изображения", чтобы показать или скрыть изображение.
  4. Для переключения состояния прозрачности фона выбранного изображения выберите "Да" или "Нет" в списке "Прозрачность".

Панель "Стандартная"

Ввод команды: ОКОНСВ


Увеличение скорости вывода растровых изображений на экран - Команды

Работа с данными других форматов
Работа с данными других форматов
Увеличение скорости вывода растровых изображений на экран
Понятия
Процедуры
Команды

Команды
ИЗОБКАЧЕСТВО | Управление качеством вывода изображений на экран
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
IMAGEHLT | Управляет режимом подсветки растровых изображений при выборе
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


WMF-файлы - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
WMF-файлы
Понятия
Процедуры
Команды

Метафайлы Windows (файлы формата WMF) часто используются для хранения графических изображений. WMF-файлы можно вставлять в чертежи в виде блоков. В отличие от растровых картинок, в метафайлах информация хранится в векторном формате, поэтому их можно масштабировать без потери разрешающей способности. Если WMF-файл содержит изображения 2D фигур или широких линий, для повышения скорости рисования можно отключить их вывод на экран.

Формат WMF позволяет хранить и векторную, и растровую графику. Однако программой используется только векторная информация из файла WMF. При импортировании файлов WMF в программу растровая графика игнорируется.

См. также

Импорт текстовых файлов


WMF-файлы - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
WMF-файлы
Понятия
Процедуры
Команды

Импорт файла WMF

Управление видимостью сплошных закрасок и широких линий в WMF-файлах


Импорт файла WMF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
WMF-файлы
Понятия
Процедуры
Команды

Импорт файла WMF

  1. Нажмите "Вставка" » "Метафайл Windows".
  2. В диалоговом окне "Импорт WMF-файла" выберите файл, который требуется открыть. Нажмите "Открыть".
  3. Указать точку вставки для WMF-файла.
  4. Установить масштаб одним из следующих способов:
    • Введите в командной строке у (Угол) для задания масштаба с помощью воображаемой рамки, размеры которой соответствуют масштабу вставки. Второй угол рамки должен лежать выше и правее точки вставки, иначе будет вставлено зеркальное отражение изображения.
    • Введите xyz для задания масштабных коэффициентов для трехмерного пространства.
    • Введите значения масштабов по осям X и Y в командной строке. Масштабы по горизонтали и вертикали могут быть различными. Для сохранения текущего масштаба введите 1. Введите более высокое значение, чтобы увеличить размер изображения метафайла. (Для увеличения размера изображения в два раза нужно введите 2). Введите положительное число, меньшее 1, чтобы уменьшить размеры изображения. (Для сокращения размера изображения в два раза нужно введите 0,5). Следует учесть, что использование этого параметра затрудняет импорт файла WMF определенных масштабов и размеров.
  5. Задайте угол поворота.

Панель "Вставка"

Ввод команды: ИМПОРТМТФ


Управление видимостью сплошных закрасок и широких линий в WMF-файлах - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
WMF-файлы
Понятия
Процедуры
Команды

Управление видимостью сплошных закрасок и широких линий в WMF-файлах

  1. Нажмите "Вставка" » "Метафайл Windows".
  2. В диалоговом окне "Импорт WMF-файла" выберите "Сервис" » "Настройка".
  3. В диалоговом окне "Параметры импорта из WMF" поднять или сбросить флажки "В каркасном виде" и "С широкими линиями". По умолчанию эти флажки подняты.
  4. Нажмите "ОК".
  5. Выполнить импорт WMF-файла обычным образом.

Ввод команды: ИМПОРТМТФ


WMF-файлы - Команды

Работа с данными других форматов
Работа с данными других форматов
WMF-файлы
Понятия
Процедуры
Команды

Команды
ИМПОРТ | Импортирует файлы в различных форматах
ИМПОРТМТФ | Импорт метафайла Windows
ОПЦИИМТФ | Задание опций для команды ИМПОРТМТФ
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание файлов в других форматах - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Создание файлов в других форматах
Понятия
Процедуры
Команды

При необходимости использовать информацию из файла чертежа в другом приложении его преобразуют в требуемый формат процедурами экспорта. При этом можно использовать буфер обмена.

  • DXF-файлы
    Чертеж можно экспортировать в файл формата DXF для передачи в другие системы автоматизированного проектирования.
  • Экспорт файлов WMF
    Формат WMF поддерживается многими приложениями Windows.
  • Файлы растровых форматов
    Из объектов чертежа можно создавать растровые изображения, независимые от устройства вывода.
  • Экспорт файлов формата PostScript
    Чертеж можно преобразовать в формат PostScript, который поддерживается многими издательскими системами.
  • Экспорт ACIS-файлов
    Можно экспортировать некоторые типы объектов в ACIS-файлы формата ASCII (SAT).
  • Экспорт файлов Stereolithograph
    Изображения твердых тел могут быть сохранены в формате, совместимом со Stereolitograph Apparatus (SLA).


Создание файлов в других форматах - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Создание файлов в других форматах
Понятия
Процедуры
Команды

Создание файла DXF

Создание WMF-файла (метафайла Windows)

Создание файла BMP

Создание JPEG-файла (JPG)

Создание TIFF-файла (TIF)

Создание файла формата PNG (переносимая сетевая графика)

Экспорт чертежа в файл формата Encapsulated PostScript (EPS)

Создание файла ACIS

Сохранение изображений тел в SLA-файлах


Создание файлов в других форматах - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Создание файлов в других форматах
Понятия
Процедуры
Команды
Команды
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
ЭКСПОРТБМП | Сохранение выбранных объектов в файле аппаратно-независимого растрового формата (BMP)
ЭКСПОРТДЖ | Сохраняет выбранные объекты в файл в формате JPEG
ЭКСПОРТМТФ | Сохранение объектов в метафайл Windows (WMF)
ЭКСПОРТПНГ | Сохраняет выбранные объекты в файл в формате Portable Network Graphics
ЭКСПОРТСТЛ | Сохранение тел в двоичном или ASCII-файле
ЭКСПОРТТЕЛ | Экспортирует в файл ACIS тела ACIS, 3D тела и области.
ЭКСПОРТТИФ | Сохранение выбранных объектов в файл формата TIFF
Системные переменные
ACISOUTVER | Управление версией ACIS файлов SAT, созданных с помощью команды ACISOUT
FACETRES | Регулирует гладкость раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями
WMFBKGND | Управляет отображением фона при вставке объектов в формат метафайлов Windows (WMF)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


DXF-файлы - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
DXF-файлы
Понятия
Процедуры
Команды

Чертеж можно экспортировать в файл формата DXF (формат графического обмена). DXF-файл представляет собой текстовый или двоичный файл с информацией о чертеже, которая может быть прочитана другими программами, в том числе другими программами автоматизированного проектирования. Сохранение чертежа в DXF-формате может пригодиться, например, если у консультантов проекта имеется другая программа автоматизированного проектирования, воспринимающая DXF-файлы.

Для величин с плавающей точкой может задаваться точность (до 16 десятичных знаков); чертеж можно сохранять либо в формате ASCII, либо в двоичном виде. Результатом сохранения в формате ASCII является текстовый файл, доступный для чтения и редактирования, а результатом сохранения в двоичном формате является файл меньшего размера, скорость работы с которым значительно выше.

Если требуется сохранение только части чертежа, указываются сохраняемые объекты. Эту опцию можно использовать для удаления из файлов чертежей посторонних объектов.


Создание файла DXF - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
DXF-файлы
Понятия
Процедуры
Команды

Создание файла DXF

  1. Нажмите "Файл" » "Сохранить как".
  2. В списке "Тип файла" диалогового окна "Сохранение чертежа" выберите формат DXF.
    • Для сохранения всего чертежа перейдите к выполнению этапа 4.
    • Для сохранения в формате DXF определенных объектов нажмите "Сервис" » "Настройка". В диалоговом окне "Параметры сохранения" выберите формат DXF и поднять флажок "С выбором объектов". Введите значение, соответствующее количеству знаков после запятой. Нажмите "ОК".
  3. В диалоговом окне "Сохранение чертежа" выберите папку и введите имя файла. Нажмите кнопку "Сохранить".

    4. К имени файла будет добавлено расширение .dxf.

  4. Если задан режим сохранения с выбором объектов, то укажите объекты и нажмите ENTER.

Ввод команды: СОХРАН В


DXF-файлы - Команды

Работа с данными других форматов
Работа с данными других форматов
DXF-файлы
Понятия
Процедуры
Команды

Команды
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Экспорт файлов WMF - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Экспорт файлов WMF
Понятия
Процедуры
Команды

Формат WMF поддерживается многими приложениями Windows. WMF-файлы (метафайлы Windows) используется для представления векторной графики и растровой графики. Файлы WMF создаются только в векторной графике. Векторный формат позволяет значительно ускорить выполнение панорамирования и зумирования.


Создание WMF-файла (метафайла Windows) - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Экспорт файлов WMF
Понятия
Процедуры
Команды

Создание WMF-файла (метафайла Windows)

  1. Нажмите "Файл" » "Экспорт".
  2. В списке "Тип файла" диалогового окна "Экспорт данных" выберите "Метафайл (*.wmf)".
  3. Выберите папку и введите имя файла. Нажмите кнопку "Сохранить".

    4. К имени файла будет добавлено расширение .wmf.

Ввод команды: ЭКСПОРТ


Экспорт файлов WMF - Команды

Работа с данными других форматов
Работа с данными других форматов
Экспорт файлов WMF
Понятия
Процедуры
Команды

Команды
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
ЭКСПОРТМТФ | Сохранение объектов в метафайл Windows (WMF)
Системные переменные
WMFBKGND | Управляет отображением фона при вставке объектов в формат метафайлов Windows (WMF)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Файлы растровых форматов - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы растровых форматов
Понятия
Процедуры
Команды

Из объектов чертежа можно создавать растровые изображения, независимые от устройства вывода.

Для экспорта объектов в растровые изображения форматов BMP, JPEG, TIFF и PNG существует несколько команд.

Объекты появляются в растровом изображении по мере возникновения их на экране. Это относится также к объектам на раскрашенных и тонированных видовых экранах.

Файлы таких форматов, как JPEG, при создании сжимаются. Сжатие файлов сокращает их размеры, однако такие файлы могут не поддерживаться некоторыми приложениями.


Файлы растровых форматов - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы растровых форматов
Понятия
Процедуры
Команды

Создание файла BMP

Создание JPEG-файла (JPG)

Создание TIFF-файла (TIF)

Создание файла формата PNG (переносимая сетевая графика)


Создание файла BMP - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы растровых форматов
Понятия
Процедуры
Команды

Создание файла BMP

  1. В командной строке введите экспортбмп.
  2. В диалоговом окне "Создание растрового файла" выберите папку и введите имя файла. Нажмите кнопку "Сохранить".

    3. К имени файла будет добавлено расширение .bmp.

  3. Выберите объекты для сохранения.

Ввод команды: ЭКСПОРТБМП


Создание JPEG-файла (JPG) - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы растровых форматов
Понятия
Процедуры
Команды

Создание JPEG-файла (JPG)

  1. В командной строке введите экспортдж.
  2. В диалоговом окне "Создание растрового файла" выберите папку и введите имя файла. Нажмите кнопку "Сохранить".

    3. К имени файла будет добавлено расширение.jpg.

  3. Выберите объекты для сохранения.

Ввод команды: ЭКСПОРТДЖ


Создание TIFF-файла (TIF) - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы растровых форматов
Понятия
Процедуры
Команды

Создание TIFF-файла (TIF)

  1. В командной строке введите экспорттиф.
  2. В диалоговом окне "Создание растрового файла" выберите папку и введите имя файла. Нажмите кнопку "Сохранить".

    3. К имени файла будет добавлено расширение .tif.

  3. Выберите объекты для сохранения.

Ввод команды: ЭКСПОРТТИФ


Создание файла формата PNG (переносимая сетевая графика) - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Файлы растровых форматов
Понятия
Процедуры
Команды

Создание файла формата PNG (переносимая сетевая графика)

  1. В командной строке введите экспортпнг.
  2. В диалоговом окне "Создание растрового файла" выберите папку и введите имя файла. Нажмите "ОК".

    3. К имени файла будет добавлено расширение .png.

  3. Выберите объекты для сохранения.

Ввод команды: ЭКСПОРТПНГ


Файлы растровых форматов - Команды

Работа с данными других форматов
Работа с данными других форматов
Файлы растровых форматов
Понятия
Процедуры
Команды

Команды
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
ЭКСПОРТБМП | Сохранение выбранных объектов в файле аппаратно-независимого растрового формата (BMP)
ЭКСПОРТДЖ | Сохраняет выбранные объекты в файл в формате JPEG
ЭКСПОРТПНГ | Сохраняет выбранные объекты в файл в формате Portable Network Graphics
ЭКСПОРТТИФ | Сохранение выбранных объектов в файл формата TIFF
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Экспорт файлов формата PostScript - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Экспорт файлов формата PostScript
Понятия
Процедуры
Команды

Чертеж можно преобразовать в формат PostScript, который поддерживается многими издательскими системами.

Формат PostScript используется во многих издательских системах. Возможность вывода файлов PostScript на печать с высоким разрешением делает этот формат более предпочтительным по сравнению с растровыми форматами, такими как GIF, PCX и TIFF. Для чертежа, преобразованного в формат PostScript, можно использовать PostScript-шрифты.

Экспорт в формат PostScript

При экспорте файла в формате PostScript как файла EPS обработка некоторых объектов происходит по-особому.

  • Уплотненный текст, кодs управления текстом. Если плотность текста больше 0 или текст содержит управляющие коды (например, %%O или %%D), он не выводится на печать как текст PostScript, несмотря на то, что текст отображается правильно. При записи в PostScript-файл можно выводить тексты, содержащие международные и специальные символы (например %%213).
  • Набор символов ISO 8859 Latin/1. Если в тексте используются коды символов в диапазоне от 127 до 255, текст интерпретируется на основе набора символов ISO 8859 Latin/1. Если в тексте появляется символ, связанный с PostScript, генерируется версия шрифта, вектор кодирования которого переназначен для отображения набора символов ISO. Полученный текст, совместимый с заданным шрифтом, выводится в PostScript-файл.
  • Круги, дуги, эллипсы, эллиптические дуги. Дуги и круги преобразуются в эквивалентные объекты PostScript за исключением случаев, когда они обладают толщиной.
  • Закрашенные фигуры. Сплошная закраска выводится в PostScript как закрашенные контуры.
  • Двумерные полилинии. 2D (плоские) полилинии с постоянной шириной выводятся в PostScript в виде контуров. Для переменных торцевого ограничителя и ограничителя угла PostScript установлены значения, аппроксимирующие объединение сегментов.

См. также

Печать в файлы Adobe PostScript


Экспорт чертежа в файл формата Encapsulated PostScript (EPS) - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Экспорт файлов формата PostScript
Понятия
Процедуры
Команды

Экспорт чертежа в файл формата Encapsulated PostScript (EPS)

  1. Нажмите "Файл" » "Экспорт".
  2. В диалоговом окне "Экспорт данных" задайте имя и путь для EPS-файла.
  3. Из списка "Тип файла" выберите значение "Encapsulated PS (*.eps)".
  4. Нажмите кнопку "Сохранить".

Ввод команды: ПЕЧАТЬ


Экспорт файлов формата PostScript - Команды

Работа с данными других форматов
Работа с данными других форматов
Экспорт файлов формата PostScript
Понятия
Процедуры
Команды

Команды
ПЕЧАТЬ | Вывод чертежа на плоттер, принтер или в файл
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Экспорт ACIS-файлов - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Экспорт ACIS-файлов
Понятия
Процедуры
Команды

Можно экспортировать некоторые типы объектов в ACIS-файлы формата ASCII (SAT).

Объекты ShapeManager, представляющие собой усеченные NURBS-поверхности, области и твердые тела, можно экспортировать в ACIS-файлы формата ASCII (с расширением .sat). Все другие объекты (отрезки, дуги и т.п.) при этом игнорируются.

Cистемная переменная ACISOUTVER задает версию ACIS для вывода команды ЭКСПОРТТЕЛ.


Создание файла ACIS - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Экспорт ACIS-файлов
Понятия
Процедуры
Команды

Создание файла ACIS

  1. Нажмите "Файл" » "Экспорт".
  2. В диалоговом окне "Экспорт данных" введите имя файла.
  3. В списке "Тип файла" выберите "ACIS" (*.sat). Нажмите кнопку "Сохранить".
  4. Выберите экспортируемые в ACIS-файл объекты.

    5. Автоматически добавляется расширение файла .sat.

Ввод команды: ЭКСПОРТ, ЭКСПОРТТЕЛ


Экспорт ACIS-файлов - Команды

Работа с данными других форматов
Работа с данными других форматов
Экспорт ACIS-файлов
Понятия
Процедуры
Команды

Команды
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
ЭКСПОРТТЕЛ | Экспортирует в файл ACIS тела ACIS, 3D тела и области.
Системные переменные
ACISOUTVER | Управление версией ACIS файлов SAT, созданных с помощью команды ACISOUT
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Экспорт файлов Stereolithograph - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Экспорт файлов Stereolithograph
Понятия
Процедуры
Команды

Изображения твердых тел могут быть сохранены в формате, совместимом со Stereolitograph Apparatus (SLA). Объекты передаются в SLA в виде многогранной сети с гранями в форме треугольников. Рабочая станция SLA извлекает из информации о гранях наборы контуров, определяющих слои генерируемой детали.


Сохранение изображений тел в SLA-файлах - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Экспорт файлов Stereolithograph
Понятия
Процедуры
Команды

Сохранение изображений тел в SLA-файлах

  1. Нажмите "Файл" » "Экспорт".
  2. В диалоговом окне "Экспорт данных" введите имя файла.
  3. В списке "Тип файла" выберите "Литография (*.stl)". Нажмите кнопку "Сохранить".
  4. Выберите один или несколько твердотельных объектов. Все объекты должны располагаться внутри октанта МСК с положительными значениями координат X, Y и Z. Это значит, что значения координат X, Y и Z должны быть больше нуля.

    5. К имени файла будет автоматически добавлено расширение.stl.

Ввод команды: ЭКСПОРТСТЛ


Экспорт файлов Stereolithograph - Команды

Работа с данными других форматов
Работа с данными других форматов
Экспорт файлов Stereolithograph
Понятия
Процедуры
Команды

Команды
ЭКСПОРТСТЛ | Сохранение тел в двоичном или ASCII-файле
Системные переменные
FACETRES | Регулирует гладкость раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование чертежей из разных приложений и версий - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Использование чертежей из разных приложений и версий
Понятия
Процедуры
Команды

Допустим обмен чертежами между разными версиями AutoCAD и AutoCAD LT, а также экспорт и импорт файлов, содержащих сторонние объекты. Однако в некоторых случаях существуют ограничения.

  • Сохранение чертежей в форматах прежних версий
    Имеется возможность сохранения чертежей в форматах, поддерживаемых прежними версиями продукта.
  • Работа с чертежами AutoCAD в AutoCAD LT
    AutoCAD LT полностью поддерживает чертежи AutoCAD. Однако следует учитывать то, как AutoCAD LT обрабатывает специфичные для AutoCAD элементы.
  • Работа со сторонними объектами и заместителями
    Использование сторонних объектов открывает дополнительные возможности применения программы и родственных продуктов. Если приложение, в котором был создан сторонний объект, не загружено, то используется объект-заместитель.


Использование чертежей из разных приложений и версий - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Использование чертежей из разных приложений и версий
Понятия
Процедуры
Команды

Сохранение чертежа AutoCAD в формате предыдущей версии


Использование чертежей из разных приложений и версий - Команды

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Использование чертежей из разных приложений и версий
Понятия
Процедуры
Команды
Команды
EXPORTTOAUTOCAD | Создание нового DWG-файла со всеми расчлененными AD-объектами
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПРЕОБРАЗОВАТЬ | Преобразование 2D полилиний и ассоциативных штриховок, созданных в AutoCAD Release 13 или ранее
СОХРАНИТЬ | Сохранение чертежа под текущим или заданным именем
Системные переменные
FIELDDISPLAY | Управляет отображением полей на сером фоне
PLINETYPE | Указывает, используется ли оптимизированные двухмерные полилинии
PROXYGRAPHICS | Управляет сохранением объектов-заместителей в чертеже
PROXYNOTICE | Отображает сообщение при создании объекта-заместителя
PROXYSHOW | Управляет отображением объектов-заместителей на чертеже
PROXYWEBSEARCH | Устанавливает в программе режим поиска адаптеров объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение чертежей в форматах прежних версий - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Сохранение чертежей в форматах прежних версий
Понятия
Процедуры
Команды

Имеется возможность сохранения чертежей, созданных с помощью текущей версии продукта, в форматах, поддерживаемых ее прежними версиями. С помощью этой процедуры создается чертеж, содержащий информацию, относящуюся к текущей версии программы. Эта информация выделяется или преобразуется в объект другого типа. После преобразования чертежа в другой формат создается журнал со списком внесенных или удаленных данных.

Если текущая версия используется для открытия чертежа, созданного с помощью прежней версии, а информация, относящаяся к текущей версии, добавлена не будет, можно сохранить чертеж в формате прежней версии без потери данных.

Примечание Чтобы чертежи были доступны в AutoCAD Release 12 или AutoCAD LT Release 2, их следует сохранять в формате AutoCAD R12/LT2 DXF.

Если требуется сохранить чертеж, созданный с помощью прежней версии в исходном формате, можно пометить файл атрибутом "только для чтения" или открыть его с помощью текущей версии программы и использовать параметры списка "Тип файла" диалогового окна "Сохранение файла", чтобы сохранить его в исходном формате.

Так как сохранение чертежа в формате ранних версий может привести к потере некоторых данных, следует сохранять чертеж с новым именем, чтобы избежать удаления файла текущего чертежа. Если происходит перезапись текущего чертежа, имеется возможность восстановить переписанную версию на основании резервного файла (имя_файла.bak), созданного в процессе сохранения.

Поддержка ассоциативных размеров

Ассоциативные размеры, созданные в AutoCAD 2002 или более поздних версиях, обычно сохраняют ассоциативность при сохранении в предыдущих версиях и последующем открытии в текущей версии. Однако, если в одной из прежних версий изменить формы объектов с нанесенными размерами, то при загрузке чертежа в текущую версию происходит изменение ассоциативных связей размеров с объектами. Так, например, если отрезок с нанесенными размерами разорвать на две части, получив при этом два отрезка, то ассоциативный размер сохранит связь только с одним из них.

Ассоциативность размеров не поддерживается, если чертеж сохранить как файл формата AutoCAD R12/LT 2 DXF, а затем вновь открыть его в текущей версии.

Примечание Для чертежей, сохраненных в формате версии более ранней, чем AutoCAD 2002, сохраняется значение системной переменной DIMASSOC. Если чертеж вновь открывается в AutoCAD 2002 или более поздней версии программы, настройки ассоциативности размеров восстанавливаются. При открытии чертежа из прежней версии в AutoCAD 2002 или более поздней, системной переменной DIMASSOC присваивается значение системной переменной DIMASO, хранящееся в этом чертеже.

Ограничения сохранения в прежние версии

При сохранении чертежа в формате версий 2000/LT 2000 действуют следующие ограничения:

  • Размер файла может увеличиться.
  • Шифрование и цифровые подписи не сохраняются.

При сохранении чертежа в формате версий 14/LT 98/LT 97 действуют следующие ограничения:

  • Гиперссылки преобразуются в прикрепленные поля URL версий 14/LT 98/LT 97.
  • Связи с базами данных и автономные ярлыки преобразуются в связи и отображаемые атрибуты версий 14/LT 98/LT 97.
  • Прикрепленные к базам данных ярлыки преобразуются в объекты многострочного текста и выносок, причем информация о связях становится недоступной. Прикрепленные ярлыки восстанавливаются, если открыть чертеж в AutoCAD 2000 или более поздней версии.
  • Геометрия динамических блоков может переопределена независимо от динамических элементов блоков, а геометрия во вхождении блока не обновляется, если чертеж открыть в AutoCAD 2007 или более поздней версии программы.
  • Размеры, созданные с помощью команд РЗМДУГА и РЗМИЗЛОМ, могут в версиях 14/LT 98/LT 97 потерять свой исходный цвет.

При сохранении чертежа в формате Release 12/LT 2 DXF действуют следующие ограничения:

  • Компактные полилинии и образцы штриховки преобразуются в полилинии и образцы штриховки формата R12.
  • Все тела, ACIS-тела, области, эллипсы, выноски, мультилинии, лучи, рамки допусков и прямые преобразуются в отрезки, дуги и круги.
  • Группы, сложные типы линий, OLE-объекты и изображения для предварительного просмотра не выводятся.
  • После сохранения чертежа в формате R12 и последующего его открытия в версиях AutoCAD 2000/AutoCAD LT 2000 или более поздних версиях многие объекты могут оказаться потерянными.
  • Информация о нескольких листах и именах листов чертежа теряется. Сохраняются только вкладка "Модель" и вкладка разметки текущего листа.
  • Пробелы в именах слоев и других объектов преобразуются в символы подчеркивания. Максимальная длина имени не может превышать тридцати двух символов.
  • Файлы подложек DWF, вставленных в чертежи, в формате версии 12/LT 2 DXF не сохраняются.
  • Положение внешних ссылок "Выгружена" теряется.


Сохранение чертежа AutoCAD в формате предыдущей версии - Процедуры

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Сохранение чертежей в форматах прежних версий
Понятия
Процедуры
Команды

Сохранение чертежа AutoCAD в формате предыдущей версии

  1. Нажмите "Файл" » "Сохранить как".
  2. В диалоговом окне "Сохранение чертежа" в поле "Имя файла" введите имя чертежа.
  3. В группе "Тип файла" выберите формат требуемой версии AutoCAD или AutoCAD LT.
  4. Нажмите "ОК".

Ввод команды: СОХРАН В


Сохранение чертежей в форматах прежних версий - Команды

Работа с данными других форматов
Работа с данными других форматов
Сохранение чертежей в форматах прежних версий
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПРЕОБРАЗОВАТЬ | Преобразование 2D полилиний и ассоциативных штриховок, созданных в AutoCAD Release 13 или ранее
СОХРАНИТЬ | Сохранение чертежа под текущим или заданным именем
Системные переменные
PLINETYPE | Указывает, используется ли оптимизированные двухмерные полилинии
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с чертежами AutoCAD в AutoCAD LT - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Работа с чертежами AutoCAD в AutoCAD LT
Понятия
Процедуры
Команды

AutoCAD LT полностью поддерживает чертежи AutoCAD. Однако следует учитывать то, как AutoCAD LT обрабатывает специфичные для AutoCAD элементы.

Работа с полями

AutoCAD включает в себя поля, являющиеся текстовыми строками, обновляющимися при изменении их значения. Если чертеж с полями открывается в AutoCAD LT, поля обновляются на основе значения системной переменной FIELDEVAL. Если для системной переменной FIELDEVAL установлено значение 0 или файл DST для подшивки AutoCAD недоступен, отображаются последние значения, помещенные в кэш чертежа. Если файл впоследствии открывается в AutoCAD, поля обновляются обычным способом. Значение переменной FIELDEVAL в AutoCAD LT установить нельзя.

Отображением полей в чертеже управляет системная переменная FIELDDISPLAY, доступная в AutoCAD LT. В AutoCAD LT можно удалить поле, но нельзя его редактировать. Если вручную ввести выражение для кода поля, оно вычисляется, но при этом преобразовывается в необновляемую текстовую строку.

Редактирование видовых экранов произвольной формы на разметке листа

В AutoCAD преобразованием объекта пространства листа можно получить видовой экран произвольной формы на листе. Такие видовые экраны можно редактировать в AutoCAD LT, открыв чертеж, в котором они содержатся. Видовые экраны произвольной формы можно, например, перемещать, копировать или поворачивать. Кроме того, пользователь имеет возможность наносить размеры, а также панорамировать и масштабировать модель на видовом экране. Однако в AutoCAD LT нельзя создавать новые видовые экраны произвольной формы.

Работа с несколькими пользовательскими системами координат

В AutoCAD можно задавать для каждого видового экрана свою пользовательскую систему координат (ПСК). В AutoCAD LT можно использовать в одном чертеже только одну ПСК. В этом отношении AutoCAD LT ничем не отличается от AutoCAD прежних версий.

При открытии в AutoCAD LT чертежа AutoCAD используется только одна ПСК, взятая из текущего видового экрана. Если такой чертеж отредактировать в AutoCAD LT и сохранить, а затем повторно открыть в AutoCAD, то может появиться сообщение о несоответствии используемых ПСК. Это связано с тем, что при активизации в AutoCAD LT видовых экранов, для которых с помощью AutoCAD были заданы свои ПСК, эти системы координат могут измениться.

Работа с раскрашенными объектами 2D фигур и 3D тел AutoCAD

В AutoCAD визуальные стили позволяют работать с параметрами тонирования и каркасной модели объектов на текущем видовом экране. В AutoCAD LT визуальные стили не поддерживаются. Команда РЕЖИМРАСКР в AutoCAD LT предлагает только опции "2D каркас" и "Скрытие". Имеется возможность использовать РЕЖИМРАСКР в AutoCAD LT для отключения визуальных стилей на видовых экранах, ранее созданных в AutoCAD. Это позволяет отобразить элементы заднего плана, что упрощает редактирование и дает возможность применения таких средств обеспечения точности, как объектная привязка.


Использование чертежей из разных приложений и версий

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Использование чертежей из разных приложений и версий
Понятия
Процедуры
Команды

Нет процедур.


Работа с чертежами AutoCAD в AutoCAD LT - Команды

Работа с данными других форматов
Работа с данными других форматов
Работа с чертежами AutoCAD в AutoCAD LT
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
FIELDDISPLAY | Управляет отображением полей на сером фоне
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа со сторонними объектами и заместителями - Понятия

Совместное использование данных в чертежах и приложениях
Работа с данными других форматов
Работа со сторонними объектами и заместителями
Понятия
Процедуры
Команды

Использование сторонних объектов открывает дополнительные возможности применения программы и родственных продуктов. Если приложение, в котором был создан сторонний объект, не загружено, то используется объект-заместитель.

Сторонний объект - это тип объекта, созданного в приложении ObjectARX® (AutoCAD Run-Time Extension), у которого обычно имеются более специализированные характеристики по сравнению со стандартными объектами AutoCAD. К сторонним объектам относятся параметрические тела (Autodesk® Mechanical Desktop), интеллектуальные интерактивные обозначения дверей (Autodesk Architectural Desktop), объекты-полигоны (Autodesk Map™) и объекты ассоциативных размеров (AutoCAD и AutoCAD LT).

Кроме Autodesk, существуют производители программного обеспечения, использующие ObjectARX для создания приложений, с помощью которых можно строить графические и неграфические сторонние объекты. Эти объекты можно использовать в приложениях AutoCAD.

Объекты-заместители

Объекты-заместители используются в AutoCAD и других приложениях вместо сторонних объектов, созданных с помощью приложения ObjectARX, если последнее недоступно. В дальнейшем, когда приложение становится доступным, объект-заместитель заменяется сторонним объектом.

Объекты-заместители сильно упрощены по сравнению с исходными сторонними объектами. Возможности редактирования сторонних объектов определяются приложениями ObjectARX, в котором объекты были созданы. Например, такие операции, как стирание или перемещение объекта, а также изменение его свойств могут быть допустимы или нет в зависимости от создавшего их приложения.

Открывая чертеж, следует обратить внимание на диалоговое окно "Информация о заместителях". В этом окне выводится общее количество объектов-заместителей (как графических, так и неграфических), имя приложения, необходимого для нормального вывода замещенных объектов, а также дополнительная информация о типе и способе отображения объектов-заместителей. С помощью опций данного диалогового окна можно управлять выводом объектов-заместителей на чертеже.

Адаптеры объектов

Адаптер объектов - это средство доступа для специального просмотра и стандартного редактирования сторонних объектов в других приложениях, использующееся, если приложение, в котором был создан сторонний объект, в системе не установлено.

Использование адаптеров объектов обеспечивает большую гибкость работы со сторонними объектами, чем непосредственное использование объектов-заместителей. Адаптеры объектов также обеспечивают возможность коллективной работы с другими продуктами Autodesk.

Если приложение ObjectARX не установлено в системе, можно выполнить поиск доступных адаптеров объектов в Интернете. Например, при получении чертежа, созданного с помощью программы Autodesk Architectural Desktop, которая не установлена в системе, выполняется загрузка адаптера объектов AEC для просмотра чертежа в исходном виде. Поиск адаптеров объектов можно включить и отключить с помощью параметров в списке "Адаптер объектов" вкладки "Система" диалогового окна "Параметры".

Для ознакомления с полным списком имеющихся в распоряжении "Адаптеров объектов" обратитесь к веб-сайту Autodesk по адресу http://www.autodesk.com/liveenablers-rus.

Классификация объектов

Если в приложении (например Autodesk Map) объекту была присвоена классификация, ее можно просмотреть на палитре "Свойства" в группе "Имя класса". Если классификация объекта удалена из XML-файла, или удален сам файл классификаций, в группе имен классов выводится восклицательный знак. Подробнее о классификациях см. документацию по Autodesk Map.

Можно также использовать опцию "Быстрый выбор" для выбора объектов по именам или свойствам классов.


Работа со сторонними объектами и заместителями - Команды

Работа с данными других форматов
Работа с данными других форматов
Работа со сторонними объектами и заместителями
Понятия
Процедуры
Команды

Команды
EXPORTTOAUTOCAD | Создание нового DWG-файла со всеми расчлененными AD-объектами
Системные переменные
PROXYGRAPHICS | Управляет сохранением объектов-заместителей в чертеже
PROXYNOTICE | Отображает сообщение при создании объекта-заместителя
PROXYSHOW | Управляет отображением объектов-заместителей на чертеже
PROXYWEBSEARCH | Устанавливает в программе режим поиска адаптеров объектов
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Внешние базы данных - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Понятия
Процедуры
Команды

С графическими объектами чертежа можно связывать данные из внешних баз данных.

С помощью программы можно подключать к графическим объектам чертежа данные, хранящиеся во внешних базах данных, таких как dBASE, Oracle и Microsoft Access. Данные средства можно с успехом применять, не имея специальных знаний по базам данных и языкам запросов. Однако, для получения максимального эффекта желательно наличие некоторого опыта работы с языком SQL.

  • Обзор использования внешних баз данных
    При подключении к графическим объектам чертежа записей базы данных применяются запросы - это мощное средство отбора и сортировки информации. Результаты выполнения запросов могут быть представлены графически.
  • Доступ к базе данных из AutoCAD
    После настройки источника данных можно просматривать и редактировать записи базы данных непосредственно из программы.
  • Подключение записей базы данных к графическим объектам
    Процесс подключения записей базы данных к графическим объектам заключается в создании связей между объектами чертежа и таблицами внешней базы данных.
  • Использование ярлыков
    Ярлыки представляют собой многострочные текстовые объекты, содержимое которых определяется содержимым выбранных полей тех или иных записей таблицы внешней базы данных.
  • Использование запросов для выбора информации из базы данных
    Запросы позволяют извлекать из базы данных требуемые записи.
  • Совместное использование запросов, шаблонов связей и шаблонов ярлыков
    Запросы, шаблоны связей и ярлыков можно экспортировать и импортировать.
  • Работа со связями в файлах предыдущих версий
    ASE-связи чертежей форматов Release 12, 13 и 14 можно преобразовывать в связи формата AutoCAD 2000 и более поздние. Кроме того, связи формата AutoCAD 2000 можно сохранять в форматах Release 13 и Release 14.


Внешние базы данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Понятия
Процедуры
Команды

Для открытия или закрытия Диспетчера подключения к БД

Для изменения конфигурационного файла jet_dbsamples.udl

Для открытия таблицы БД в режиме просмотра или редактирования

Для открытия таблицы БД непосредственно из Диспетчера подключения к БД

Для настройки режима открытия таблиц БД по двойному нажатию

Для перемещения столбца в таблице

Для изменения ширины столбца в таблице

Для скрытия столбца в таблице

Для показа всех скрытых столбцов в таблице

Для задания порядка расположения записей в окне просмотра данных

Для фиксации положения одного или нескольких столбцов

Для освобождения зафиксированных столбцов

Для задания режима выравнивания текста в ячейках одного или нескольких столбцов

Для выбора шрифта и размера символов, используемых в окне просмотра данных

Для экспорта записей из окна просмотра данных

Для редактирования записи базы данных

Для добавления новой записи в базу данных

Для удаления записи базы данных

Для поиска определенного значения в окне просмотра данных

Для поиска и замены определенного значения в окне просмотра данных

Для закрытия окна просмотра данных с сохранением изменений в базу данных

Для закрытия окна просмотра данных с восстановлением исходных значений

Для создания шаблона связи в текущем чертеже

Для создания связи между объектом и записью во внешней базе данных

Для редактирования шаблона связи

Для обновления свойств шаблона связи

Для удаления из текущего чертежа всех связей, использующих определенный шаблон связи

Для изменения ключевого значения связи с помощью Диспетчера связей

Для просмотра графических объектов, связанных с записями таблицы

Для просмотра записей базы данных, связанных с выбранными графическими объектами

Для автоматического просмотра графических объектов, связанных с записями таблицы

Для автоматического просмотра записей таблицы, связанных с выбранными графическими объектами

Для задания дополнительных режимов просмотра связей

Для синхронизации связей в чертеже

Для экспорта связей из чертежа

Для создания шаблона ярлыка

Для создания связи со свободным ярлыком

Для создания прикрепленного ярлыка

Для редактирования шаблона ярлыка

Для задания параметров форматирования ярлыка

Для обновления надписей ярлыков текущего чертежа

Для вызова Редактора запросов

Для создания простого запроса

Для создания запроса по интервалу

Для создания запроса с одним условием отбора на вкладке "Формирователь"

Для создания запроса с несколькими условиями отбора на вкладке "Формирователь"

Для задания столбцов таблицы, которые следует выводить по запросу

Для задания порядка сортировки записей, выводимых по запросу

Для создания SQL-запроса

Для создания набора объектов на основе связей

Для выполнения сохраненного запроса

Для редактирования сохраненного запроса

Для переименования сохраненного запроса

Для удаления сохраненного запроса

Для копирования сохраненного запроса в другой чертеж

Для автоматического сохранения всех создаваемых запросов в текущем чертеже

Для импорта набора шаблонов в текущий чертеж

Для экспорта набора шаблонов из текущего чертежа

Для импорта набора запросов в текущий чертеж

Для экспорта набора запросов из текущего чертежа

Для преобразования связей из форматов AutoCAD версии 13 и 14\\

Для преобразования связей из формата Release 12


Внешние базы данных - Команды

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Понятия
Процедуры
Команды
Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
DBCSTATE | Сохранение состояния Диспетчера подключения к БД: активен или неактивен
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор использования внешних баз данных - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Обзор использования внешних баз данных
Понятия
Процедуры
Команды

При подключении к графическим объектам чертежа записей базы данных применяются запросы - это мощное средство отбора и сортировки информации. Результаты выполнения запросов могут быть представлены графически.

База данных представляет собой совокупность логически связанной информации, которая обычно представляется в табличном виде как, например, в электронных таблицах. Следующая таблица представляет собой пример содержимого простейшей базы данных, которая может использоваться техническим отделом для проведения плановых работ по техническому обслуживанию оборудования. Таблица состоит из четырех столбцов, имеющих названия "Вид работ", "Время на выполнение", "Периодичность" и "Исполнитель". Значения переменных хранятся в отдельных полях (ячейках). Каждая строка таблицы называется записью.

Техническое обслуживание
Вид работ | Время на выполнение | Периодичность | Исполнитель
ОБСЛУЖ. ЛИФТА | 3,5 | РАЗ В КВАРТАЛ | ПЕТРОВ Д.
ЧИСТКА ПОКРЫТИЙ | 5,25 | РАЗ В НЕДЕЛЮ | МАРИНИНА А.
ПРОВЕРКА ЭЛ. ОБОРУДОВАНИЯ | 2,00 | РАЗ В ДВЕ НЕДЕЛИ | СИДОРОВ Д.
ПРОВЕРКА ВОЗДУХООЧИСТИТЕЛЯ | 3,00 | РАЗ В МЕСЯЦ | ИВАНЦОВ Р.

Современные системы управления базами данных обладают большой гибкостью и легко адаптируются. Имеется возможность добавлять в таблицы новые столбцы или удалять ненужные. Аналогично, можно добавлять, удалять или изменять записи таблицы. При наличии нескольких баз данных можно также определить взаимосвязи между несколькими таблицами баз данных. Предположим, например, что имеются две таблицы, каждая из которых содержит в отдельном столбце информацию о номерах комнат. С использованием реляционной базы данных эти две таблицы можно объединить на основе общего столбца. При этом отпадает необходимость в повторном вводе одних и тех же данных в разные таблицы.

Программа предоставляет возможность связывать с графическими объектами чертежа информацию из таблиц внешних баз данных. Связь - это указатель на определенную запись таблицы базы данных. Программа также позволяет создавать ярлыки, представляющие собой текстовые объекты, содержимое которых определяется содержимым выбранных полей таблицы.

Модуль взаимодействия с внешними базами данными включает в себя следующие элементы:

  • Средство настройки источников данных, которое позволяет программе работать с информацией, хранящейся в той или иной внешней базе данных.
  • Диспетчер подключения к БД, который позволяет создавать в чертежах AutoCAD связи, ярлыки и формировать запросы.
  • Окно просмотра данных, которое позволяет просматривать записи таблицы внешней базы данных непосредственно из программы
  • Редактор запросов, который позволяет формировать, выполнять и сохранять SQL-запросы.
  • Средство преобразования связей и отображаемых атрибутов прежних версий в формат AutoCAD 2000 и более поздних версий.
  • Средство выбора по связи, которое позволяет итеративно создавать наборы объектов с помощью запросов и прямого выбора графических объектов на чертеже.


Внешние базы данных

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Внешние базы данных
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Обзор использования внешних баз данных - Команды

Внешние базы данных
Внешние базы данных
Обзор использования внешних баз данных
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
DBCSTATE | Сохранение состояния Диспетчера подключения к БД: активен или неактивен
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Доступ к базе данных из AutoCAD - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Доступ к базе данных из AutoCAD
Понятия
Процедуры
Команды

После настройки источника данных можно просматривать и редактировать записи базы данных непосредственно из программы.

  • Настройка базы данных для использования в чертежах AutoCAD
    Для получения доступа к внешней базе данных (БД) из программы ее необходимо настроить с помощью программы Microsoft ODBC или OLE DB.
  • Просмотр таблицы базы данных
    После настройки источника данных, используя окно просмотра данных, можно просматривать и редактировать записи базы данных непосредственно из программы.
  • Редактирование таблиц баз данных
    В окне просмотра данных можно находить требуемые записи таблицы базы данных и редактировать их. Кроме того, можно удалять имеющиеся записи и добавлять новые.


Доступ к базе данных из AutoCAD - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Доступ к базе данных из AutoCAD
Понятия
Процедуры
Команды

Для открытия или закрытия Диспетчера подключения к БД

Для изменения конфигурационного файла jet_dbsamples.udl

Для открытия таблицы БД в режиме просмотра или редактирования

Для открытия таблицы БД непосредственно из Диспетчера подключения к БД

Для настройки режима открытия таблиц БД по двойному нажатию

Для перемещения столбца в таблице

Для изменения ширины столбца в таблице

Для скрытия столбца в таблице

Для показа всех скрытых столбцов в таблице

Для задания порядка расположения записей в окне просмотра данных

Для фиксации положения одного или нескольких столбцов

Для освобождения зафиксированных столбцов

Для задания режима выравнивания текста в ячейках одного или нескольких столбцов

Для выбора шрифта и размера символов, используемых в окне просмотра данных

Для экспорта записей из окна просмотра данных

Для редактирования записи базы данных

Для добавления новой записи в базу данных

Для удаления записи базы данных

Для поиска определенного значения в окне просмотра данных

Для поиска и замены определенного значения в окне просмотра данных

Для закрытия окна просмотра данных с сохранением изменений в базу данных

Для закрытия окна просмотра данных с восстановлением исходных значений


Доступ к базе данных из AutoCAD - Команды

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Доступ к базе данных из AutoCAD
Понятия
Процедуры
Команды
Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка базы данных для использования в чертежах AutoCAD - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Настройка базы данных для использования в чертежах AutoCAD
Понятия
Процедуры
Команды

Для получения доступа к внешней базе данных (БД) из программы ее необходимо настроить с помощью программы Microsoft® ODBC или OLE DB. Драйверы ODBC и OLE DB позволяют использовать в программе информацию из различных баз данных независимо от формата и платформы, использовавшихся для создания БД. Процедура настройки базы данных предполагает создание нового источника данных, в котором хранится информация о наборе данных и драйверах, необходимых для доступа к данным.

Источником данных может служить либо отдельная таблица, либо набор таблиц, место хранения которых описывается понятиями среды, каталога и схемы. Среда, каталог и схема являются теми элементами, которые поддерживаются большинством систем управления БД и упрощают структурирование и манипуляцию данными. Их можно сравнить с файловой системой Windows: среда как бы соответствует папке, в которую вложены другие папки каталогов. Каталоги, в свою очередь, также содержат вложенные папки схемы. Каждая схема представляет собой набор таблиц.

В зависимости от типа используемой базы данных процесс ее настройки несколько различается. Например, базы данных серверного типа, такие как Oracle и Microsoft SQL Server, требуют ввода имени пользователя и пароля, а также задания сетевого расположения базы данных. Файловые базы данных, такие как Microsoft Access и dBASE III, не требуют задания подобной информации. По этой причине невозможно использовать единую процедуру настройки, подходящую для баз данных различного типа. Процедура настройки каждого типа БД, поддерживаемого в программе, приводится в разделе Настройка внешних баз данных. Для получения дополнительной информации следует обратиться к соответствующей документации используемой системы управления базами данных (СУБД), а также к справочной системе по ODBC и OLE DB.

Средство взаимодействия с БД поддерживает следующие внешние приложения:

  • Microsoft Access
  • dBASE
  • Microsoft Excel
  • Oracle
  • Базы данных Paradox
  • Microsoft Visual FoxPro®
  • SQL Server

Программа содержит файл примера базы данных Microsoft Access и настроенный драйвер (jet_dbsamples.udl), который можно использовать для работы с базой данных. Для использования этих файлов не требуется наличие приложения Access, установленного в системе. Данный файл находится в папке Sample, которая находится в папке установки. Если же папка Sample перемещена в другое место, то для возможности работы с данными таблицами следует обновить путь к ней в файле настройки jet_dbsamples.udl.

Диспетчер подключения к БД

Диспетчер подключения к базам данных представляет собой специальное окно, содержащее область структуры и набор кнопок. Положение и размер данного окна можно изменять. Из Диспетчера подключения к БД можно быстро вызывать окно просмотра данных, предназначенное для просмотра и редактирования таблиц базы данных. С помощью Диспетчера можно быстро создавать объекты базы данных (шаблоны связей, шаблоны ярлыков и запросы), которые хранятся в файле чертежа.

Область структуры Диспетчера подключения к БД содержит разделы (узловые элементы) двух основных типов:

  • Узлы чертежа. Каждый такой элемент соответствует одному открытому чертежу и объединяет все объекты базы данных, связанные с данным чертежом.
  • Источники данных. Объединяет все настроенные источники данных.

С каждым элементом области структуры Диспетчера подключения к БД связано контекстное меню. С помощью контекстного меню можно, например, настроить источник данных или изменить сохраненный запрос.


Настройка базы данных для использования в чертежах AutoCAD - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Настройка базы данных для использования в чертежах AutoCAD
Понятия
Процедуры
Команды

Для открытия или закрытия Диспетчера подключения к БД

Для изменения конфигурационного файла jet_dbsamples.udl


Для открытия или закрытия Диспетчера подключения к БД - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Настройка базы данных для использования в чертежах AutoCAD
Понятия
Процедуры
Команды

Для открытия или закрытия Диспетчера подключения к БД

  • Выберите "Сервис" » "Палитры" » "Базы данных".

Ввод команды: БДСВЯЗЬ


Для изменения конфигурационного файла jet_dbsamples.udl - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Настройка базы данных для использования в чертежах AutoCAD
Понятия
Процедуры
Команды

Для изменения конфигурационного файла jet_dbsamples.udl

  1. Выберите "Сервис" » "Палитры" » "Базы данных".
  2. Нажмите правую кнопку мыши на элементе "Источники данных" и выберите "Настройка источника данных".
  3. В списке "Источники данных" диалогового окна "Настройка источника данных" выделите "Jet_dbsamples". Нажмите "ОК".
  4. На вкладке "Connection" диалогового окна "Data Link Properties" нажмите кнопку [...].
  5. В диалоговом окне "Select Access Database" выберите файл db_samples.mdb. Нажмите "Открыть".

    6. Данный файл находится в папке Sample.

  6. Нажмите кнопку "Test Connection" для проверки работоспособности подключения.
  7. Если тест подключения к базе данных завершился неудачно, необходимо убедиться в правильности выбора файла БД.
  8. Нажмите "OK" для закрытия каждого диалогового окна.


Настройка базы данных для использования в чертежах AutoCAD - Команды

Внешние базы данных
Внешние базы данных
Настройка базы данных для использования в чертежах AutoCAD
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Просмотр таблицы базы данных - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

После настройки источника данных с его таблицами можно работать непосредственно из программы. Делается это с помощью окна просмотра данных, которое позволяет просматривать и редактировать записи таблиц. Таблицы БД можно открывать в режиме "Только чтение" или в режиме "Редактирование". В режиме "Только чтение" не допускается добавление, удаление или изменение записей таблицы. При открытии таблицы выполняется подключение к той базе данных, к которой принадлежит данная таблица. Подключение к базам данных некоторых типов требует ввода имени пользователя и пароля.

В окне просмотра данных выводятся записи из таблицы базы данных. Для перехода между записями можно использовать полосы прокрутки и кнопки управления перемещением, которые располагаются около правой и нижней границ окна.

Основным компонентом окна просмотра данных является таблица, которая состоит из следующих элементов:

  • Заголовок столбца. При нажатии на нем выделяются все ячейки, расположенные в данном столбце.
  • Заголовок записи. При нажатии на нем выделяются все поля (ячейки) данной записи.
  • Ячейки таблицы. При нажатии на ней выделяется содержимое данного поля записи.
  • Заголовок таблицы. При нажатии на нем выделяется вся таблица базы данных.

Окно просмотра данных предоставляет широкие возможности по управлению параметрами отображения записей таблицы. Имеется возможность:

  • Перемещать столбцы или изменять их ширину
  • Скрывать столбцы (отключать их видимость в окне просмотра данных)
  • Сортировать записи по возрастанию или убыванию содержимого столбцов
  • Фиксировать один или несколько столбцов для того, чтобы их положение не изменялось при горизонтальной прокрутке
  • Задавать режим выравнивания содержимого ячеек для каждого столбца
  • Изменять параметры шрифта (тип, размер, начертание), используемого в окне просмотра данных.

Форматирование столбцов и порядок сортировки записей действуют только во время просмотра текущей таблицы. При открытии другой таблицы или закрытии окна просмотра данных эта информация теряется. Если необходимо сохранить отчет, отформатированный определенным образом, содержимое окна просмотра данных следует сначала скопировать в буфер обмена, а затем вставить во внешнее приложение типа Microsoft Excel. Дальнейшее форматирование таблицы можно выполнить уже во внешнем приложении. Для получения информации о создании шаблонов следует обратиться к документации внешнего приложения, которое планируется использовать для форматирования таблиц.

Окно просмотра данных и внешние запросы

Некоторые системы управления базами данных поддерживают использование так называемых видов. Виды позволяют отображать данные из таблицы различными способами. Например, с помощью видов можно отображать только определенную часть информации, имеющейся в таблице. Виды также можно использовать для определения связей между таблицами, а также создания новой таблицы, являющейся производной от нескольких других таблиц.

В системах управления базами данных, не поддерживающих использование видов, аналогичные результаты можно получить с помощью запросов. Более подробную информацию о создании и использовании видов и запросов можно найти в документации по применяемой СУБД.

Виды и внешние запросы отображаются в Диспетчере подключения к БД в разделе "Источники данных". Внешними запросами называются запросы, которые созданы и хранятся во внешней базе данных, а не в программе. С внешними запросами и видами можно работать точно так же, как с обычными запросами и таблицами. Их можно просматривать и редактировать в окне просмотра данных, использовать при формировании запросов, создании связей и ярлыков.


Просмотр таблицы базы данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для открытия таблицы БД в режиме просмотра или редактирования

Для открытия таблицы БД непосредственно из Диспетчера подключения к БД

Для настройки режима открытия таблиц БД по двойному нажатию

Для перемещения столбца в таблице

Для изменения ширины столбца в таблице

Для скрытия столбца в таблице

Для показа всех скрытых столбцов в таблице

Для задания порядка расположения записей в окне просмотра данных

Для фиксации положения одного или нескольких столбцов

Для освобождения зафиксированных столбцов

Для задания режима выравнивания текста в ячейках одного или нескольких столбцов

Для выбора шрифта и размера символов, используемых в окне просмотра данных

Для экспорта записей из окна просмотра данных


Для открытия таблицы БД в режиме просмотра или редактирования - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для открытия таблицы БД в режиме просмотра или редактирования

  1. Из меню "Базы данных" выполните одну из следующих операций:
    • Нажмите "Просмотр данных" » "Просмотреть внешнюю таблицу" для открытия таблицы базы данных в режиме "Только чтение".
    • Нажмите "Просмотр данных" » "Редактировать внешнюю таблицу" для открытия таблицы базы данных в режиме "Редактирование".

    Если требуется, при подключении в БД выдается запрос имени пользователя и пароля.

  2. В диалоговом окне "Выбор объекта данных" выберите таблицу, которую необходимо открыть. Нажмите "ОК".

Примечание Некоторые типы баз данных требуют наличия у пользователя прав доступа на просмотр или изменение таблиц БД. Для получения более подробной информации следует обратиться к документации по системе управления БД или к администратору БД.


Для открытия таблицы БД непосредственно из Диспетчера подключения к БД - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для открытия таблицы БД непосредственно из Диспетчера подключения к БД

  • Дважды нажмите левую кнопку мыши на имени таблицы в Диспетчере подключения к БД.

    • По умолчанию при двойном нажатии таблица базы данных открывается в режиме "Редактирование". При необходимости двойное нажатие можно настроить для открытия таблицы в режиме "Только чтение".


Для настройки режима открытия таблиц БД по двойному нажатию - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для настройки режима открытия таблиц БД по двойному нажатию

  1. Выберите "Сервис" » "Настройка".
  2. На вкладке "Система" установите или снимите флажок "Открывать таблицы только для чтения".
  3. Нажмите "ОК".


Для перемещения столбца в таблице - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для перемещения столбца в таблице

  1. Нажмите кнопку мыши в области заголовка того столбца, который нужно переместить.
  2. Нажмите кнопку мыши еще раз и, не отпуская ее, перетащите столбец в требуемую позицию.


Для изменения ширины столбца в таблице - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для изменения ширины столбца в таблице

  1. В окне просмотра данных захватите линию рамки, расположенную справа от заголовка того столбца, ширину которого нужно изменить.
  2. Для увеличения ширины столбца перетащите линию вправо, для уменьшения - влево.


Для скрытия столбца в таблице - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для скрытия столбца в таблице

  1. В окне просмотра данных выделите заголовок того столбца, видимость которого нужно отключить.
  2. Нажмите правую кнопку мыши на заголовке столбца. Выберите "Скрыть".


Для показа всех скрытых столбцов в таблице - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для показа всех скрытых столбцов в таблице

  • Нажмите правую кнопку мыши в области заголовка любого из столбцов в окне "Просмотр данных". Выберите "Показать все".


Для задания порядка расположения записей в окне просмотра данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для задания порядка расположения записей в окне просмотра данных

  1. Нажмите правую кнопку мыши в области заголовка любого из столбцов в окне "Просмотр данных". Выберите "Сортировка".
  2. Выберите столбец для сортировки в списке "Сортировать по". Выберите сортировку "По возрастанию" или "По убыванию".

    3. При сортировке по возрастанию запись с наименьшим значением в сортируемом столбце размещается первой, с наибольшим - последней. При сортировке по убыванию запись с наибольшим значением в сортируемом столбце размещается первой, с наименьшим - последней.

  3. При необходимости дополнительной сортировки записей выбрать имя столбца из списка "Затем по". Выберите сортировку "По возрастанию" или "По убыванию".

    4. При использовании дополнительной сортировки все записи сначала сортируются по столбцу, заданному в списке "Сортировать по"; после этого записи, имеющие совпадающее значение в уже упорядоченном столбце, сортируются по столбцу, выбранному из списка "Затем по".

  4. Повторить действия пункта 2 для задания дополнительных условий сортировки записей.

    5. Сортировка записей таблицы может осуществляться не более чем по пяти столбцам одновременно.


Для фиксации положения одного или нескольких столбцов - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для фиксации положения одного или нескольких столбцов

  1. В окне просмотра данных выделите один или несколько заголовков тех столбцов, положение которых нужно зафиксировать.
  2. Нажмите правую кнопку мыши на одном из выбранных заголовков столбцов. Выберите "Фиксировать".

Примечание Функция "Фиксировать" доступна только в том случае, если выделен один либо несколько смежных столбцов. Если нужно зафиксировать несколько несмежных столбцов, их следует переставить так, чтобы они располагались друг за другом (см. раздел Для перемещения столбца в таблице).


Для освобождения зафиксированных столбцов - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для освобождения зафиксированных столбцов

  • Нажмите правую кнопку мыши в области заголовка любого из столбцов в окне "Просмотр данных". Выберите "Освободить все".


Для задания режима выравнивания текста в ячейках одного или нескольких столбцов - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для задания режима выравнивания текста в ячейках одного или нескольких столбцов

  1. В окне просмотра данных выделите один или несколько заголовков тех столбцов, для которых нужно изменить режим выравнивания текста в ячейках.
  2. Нажмите правую кнопку мыши на заголовке столбца. Выберите "Выравнивание".
  3. Выберите один из следующих режимов выравнивания текста:
    • Стандартное. Для полей числового типа задает выравнивание по правому краю столбца, а для полей любого другого типа - по левому краю столбца.
    • Левое. Задает выравнивание содержимого ячеек по левому краю столбца.
    • По центру. Задает центрирование содержимого ячеек столбца.
    • Правое. Задает выравнивание содержимого ячеек по правому краю столбца.


Для выбора шрифта и размера символов, используемых в окне просмотра данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для выбора шрифта и размера символов, используемых в окне просмотра данных

  1. Нажмите правую кнопку мыши на левой верхней ячейке в окне просмотра таблицы базы данных. Выберите меню "Формат".
  2. Задайте нужные параметры шрифта. Нажмите "OK".


Для экспорта записей из окна просмотра данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Для экспорта записей из окна просмотра данных

  1. Откройте таблицу базы данных, дважды нажав на ее имени в Диспетчере подключения к БД.
  2. В окне просмотра данных выделите записи, которые необходимо экспортировать.
  3. Нажмите правую кнопку мыши в любой ячейке. Выберите "Копировать".
  4. Откройте внешнее приложение, в которое необходимо экспортировать данные, и выберите меню "Правка" » "Вставить".

    5. Содержимое буфера обмена вставляется во внешнее приложение в виде текста, причем ячейки каждой записи отделяются друг от друга символами табуляции.


Просмотр таблицы базы данных - Команды

Внешние базы данных
Внешние базы данных
Просмотр таблицы базы данных
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Редактирование таблиц баз данных - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Редактирование таблиц баз данных
Понятия
Процедуры
Команды

В окне просмотра данных можно находить требуемые записи таблицы базы данных и редактировать их. Кроме того, можно удалять имеющиеся записи и добавлять новые.

Для получения возможности изменять таблицу базы данных ее следует открыть в окне просмотра данных в режиме "Правка". В этом случае можно добавлять, удалять записи, а также редактировать содержимое полей записи. Кроме того, имеется возможность выполнять поиск нужного значения среди всех ячеек определенного столбца.

Примечание Область поиска при работе функции "Найти" ограничивается тем столбцом, в котором находится выделенная в текущий момент ячейка. С помощью функции "Найти" нельзя выполнять глобальный поиск по всем ячейкам таблицы. Для поиска значения по всей таблице необходимо поочередно выбирать столбцы и выполнять поиск для каждого столбца.

Любые изменения содержимого таблицы в окне просмотра данных сохраняются в базе данных только после выполнения операции принятия. Функция "Принять" обновляет таблицу базы данных в соответствии со значениями, заданными в окне просмотра данных во время сеанса редактирования таблицы, после чего закрывает окно просмотра данных. Функция "Восстановить" отменяет любые изменения, внесенные в окне просмотра данных во время сеанса редактирования таблицы, после чего закрывает окно просмотра данных.

Примечание При выходе из программы, открытии новой таблицы или закрытии окна просмотра данных любые изменения, внесенные в текущую открытую таблицу, автоматически принимаются и сохраняются в базе данных.

Для облегчения отслеживания изменений заголовки отредактированных записей помечаются специальным значком в виде треугольника. Ориентируясь по этим значкам, можно быстро найти и просмотреть модифицированные записи перед сохранением изменений в базу данных.


Редактирование таблиц баз данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Редактирование таблиц баз данных
Понятия
Процедуры
Команды

Для редактирования записи базы данных

Для добавления новой записи в базу данных

Для удаления записи базы данных

Для поиска определенного значения в окне просмотра данных

Для поиска и замены определенного значения в окне просмотра данных

Для закрытия окна просмотра данных с сохранением изменений в базу данных

Для закрытия окна просмотра данных с восстановлением исходных значений


Для редактирования записи базы данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Редактирование таблиц баз данных
Понятия
Процедуры
Команды

Для редактирования записи базы данных

  1. В окне просмотра данных выделите ячейку, содержимое которой нужно изменить.
  2. Введите в ячейке новое значение.
  3. Повторите процедуру для всех ячеек, значения которых требуется изменить.

    4. Для перемещения между ячейками можно использовать клавиши-стрелки.


Для добавления новой записи в базу данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Редактирование таблиц баз данных
Понятия
Процедуры
Команды

Для добавления новой записи в базу данных

  1. Нажмите правую кнопку мыши в области заголовка записи (пустой прямоугольник слева от записи). Выберите "Добавить запись".

    2. Все поля новой записи получают пустые значения, а сама запись добавляется в конец таблицы.

  2. Выделите ячейку новой записи и введите нужное значение.
  3. Повторите пункт 2 для всех дополнительных полей.


Для удаления записи базы данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Редактирование таблиц баз данных
Понятия
Процедуры
Команды

Для удаления записи базы данных

  • Нажмите правую кнопку мыши в области заголовка записи, которую требуется удалить (пустой прямоугольник слева от записи). Выберите "Удалить запись".


Для поиска определенного значения в окне просмотра данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Редактирование таблиц баз данных
Понятия
Процедуры
Команды

Для поиска определенного значения в окне просмотра данных

  1. Нажмите правую кнопку мыши на одной из ячеек того столбца, в котором нужно выполнить поиск. Нажмите "Найти".
  2. В поле "Что" введите искомое значение.
  3. Задайте направление поиска:
    • Вверх. Поиск осуществляется, начиная от выделенной ячейки по направлению к самой первой записи таблицы.
    • Вниз. Поиск осуществляется, начиная от выделенной ячейки по направлению к самой последней записи таблицы.
  4. Нажмите кнопку "Найти далее".
  5. Повторите пункт 4 для поиска других ячеек, имеющих заданное значение.

Примечание Область поиска при работе функции "Найти" ограничивается тем столбцом, в котором находится выделенная в текущий момент ячейка. С помощью функции "Найти" нельзя выполнять глобальный поиск по всем ячейкам таблицы. Для поиска значения по всей таблице необходимо поочередно выбирать столбцы и выполнять поиск для каждого столбца.


Для поиска и замены определенного значения в окне просмотра данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Редактирование таблиц баз данных
Понятия
Процедуры
Команды

Для поиска и замены определенного значения в окне просмотра данных

  1. Нажмите правую кнопку мыши на одной из ячеек того столбца, в котором нужно выполнить поиск. Выберите "Заменить".
  2. В поле "Что" введите искомое значение.
  3. В поле "Заменить на" введите значение, на которое следует заменить найденное значение.
  4. Нажмите кнопку "Найти далее".
  5. Выполните одно из следующих действий:
    • Нажмите кнопку "Заменить" для замены только текущего найденного фрагмента.
    • Нажмите кнопку "Заменить все" для поиска и замены сразу всех искомых фрагментов.
  6. Повторите пункты 4 и 5 для поиска и замены остальных фрагментов, совпадающих с образцом.

Примечание Область поиска при работе функции "Заменить" ограничивается тем столбцом, в котором находится выделенная в текущий момент ячейка. С помощью функции "Заменить" нельзя выполнять глобальный поиск по всем ячейкам таблицы. Для поиска и замены значений во всей таблице необходимо поочередно выбирать столбцы и выполнять поиск и замену для каждого столбца.


Для закрытия окна просмотра данных с сохранением изменений в базу данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Редактирование таблиц баз данных
Понятия
Процедуры
Команды

Для закрытия окна просмотра данных с сохранением изменений в базу данных

  • Нажмите правую кнопку мыши на левой верхней ячейке в окне просмотра таблицы базы данных. Нажмите "Принять".


Для закрытия окна просмотра данных с восстановлением исходных значений - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Редактирование таблиц баз данных
Понятия
Процедуры
Команды

Для закрытия окна просмотра данных с восстановлением исходных значений

  • Нажмите правую кнопку мыши на левой верхней ячейке в окне просмотра таблицы базы данных. Нажмите "Восстановить".

Примечание При выходе из программы, открытии новой таблицы или закрытии окна просмотра данных любые изменения, внесенные в текущую открытую таблицу, автоматически принимаются и сохраняются в базе данных.


Редактирование таблиц баз данных - Команды

Внешние базы данных
Внешние базы данных
Редактирование таблиц баз данных
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Подключение записей базы данных к графическим объектам - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Подключение записей базы данных к графическим объектам
Понятия
Процедуры
Команды

Процесс подключения записей базы данных к графическим объектам заключается в создании связей между объектами чертежа и таблицами внешней базы данных.

  • Создание и редактирование связей и шаблонов связей
    Для создания связи требуется шаблон связи, который определяет, значения каких столбцов таблицы подключаются к объектам при создании связи.
  • Просмотр и выбор существующих связей
    Можно выбирать записи таблицы, выбирая объекты чертежа, к которым эти записи подключены, и наоборот, можно выбирать объекты чертежа, выбирая записи таблицы.
  • Поиск и исправление поврежденных связей
    Функция синхронизации позволяет обнаруживать поврежденные связи.
  • Экспорт связей
    Информацию об имеющихся связях можно экспортировать в текстовый файл.


Подключение записей базы данных к графическим объектам - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Подключение записей базы данных к графическим объектам
Понятия
Процедуры
Команды

Для создания шаблона связи в текущем чертеже

Для создания связи между объектом и записью во внешней базе данных

Для редактирования шаблона связи

Для обновления свойств шаблона связи

Для удаления из текущего чертежа всех связей, использующих определенный шаблон связи

Для изменения ключевого значения связи с помощью Диспетчера связей

Для просмотра графических объектов, связанных с записями таблицы

Для просмотра записей базы данных, связанных с выбранными графическими объектами

Для автоматического просмотра графических объектов, связанных с записями таблицы

Для автоматического просмотра записей таблицы, связанных с выбранными графическими объектами

Для задания дополнительных режимов просмотра связей

Для синхронизации связей в чертеже

Для экспорта связей из чертежа


Подключение записей базы данных к графическим объектам - Команды

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Подключение записей базы данных к графическим объектам
Понятия
Процедуры
Команды
Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и редактирование связей и шаблонов связей - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование связей и шаблонов связей
Понятия
Процедуры
Команды

Для создания связи требуется шаблон связи, который определяет, значения каких столбцов таблицы подключаются к объектам при создании связи.

Основным назначением модуля взаимодействия с базами данных является подключение внешних данных к графическим объектам программы. Это позволяет, например, подключать к полилинии чертежа, представляющей стены комнаты, информацию об этом помещении, хранящуюся во внешней базе данных. Подключение внешних данных к графическому объекту осуществляется путем создания связи между объектом и одной или несколькими записями таблицы базы данных. С неграфическими объектами, например, слоями или типами линий, связи устанавливать нельзя.

Связи с графическими объектами обладают ассоциативностью. При переносе или копировании объекта все имеющиеся у него связи также переносятся или копируются. При удалении объекта все его связи удаляются.

При подключении записи базы данных к графическому объекту между ними устанавливается динамическая связь. Это значит, что можно, например, изменить тип помещения со склада на офис в базе данных, и программа обновит данные, хранящиеся в чертеже в соответствии с данными в базе данных.

Для установления связей между записями таблицы и графическими объектами требуется наличие шаблона связи. Шаблон связи определяет, значения каких столбцов таблицы подключаются к объектам при создании связи. Например, можно создать шаблон связи, использующий столбец "Номер комнаты" базы данных о помещениях здания. Далее этот шаблон связи можно применять для создания связей с различными записями данной таблицы базы данных.

Шаблон связи также служит своеобразным ярлыком таблицы базы данных, на основании которой он создан. С помощью имеющихся в чертеже шаблонов связи можно открывать таблицы, указанные в этих шаблонах, для просмотра и редактирования. Данная возможность может оказаться весьма полезной при наличии в системе большого числа настроенных источников данных. При этом вместо того, чтобы искать таблицу в списке всех источников данных, нужную таблицу можно быстро открыть из раздела того чертежа, который ее использует. Для открытия таблицы, заданной в шаблоне связи, следует нажать правую кнопку мыши на имени шаблона в Диспетчере подключения к БД. Выберите команду "Просмотреть таблицу" или "Редактировать таблицу".

К любому графическому объекту чертежа можно подключать данные с использованием разных шаблонов связи. Это позволяет подключать к одному объекту информацию сразу из нескольких таблиц базы данных.

Связи во внешних ссылках и блоках

Из текущего чертежа нельзя просматривать или изменять связи, имеющиеся во внешних ссылках (чертежах, вставленных в текущий чертеж в виде внешних ссылок). Такие связи доступны только при открытии самого исходного чертежа.

Связи, имеющиеся в блоках, доступны, однако не могут редактироваться командой ССЫЛРЕД.

Редактирование шаблонов связей

Иногда возникает необходимость внесения изменений в шаблоны связи. Например, может понадобиться добавить в шаблон еще один ключевой столбец или удалить ранее заданный. Кроме того, обновление шаблона связи может потребоваться в результате изменения источника данных, на который ссылается шаблон, например, после переименования таблицы базы данных или изменения места ее расположения.

Примечание Допускается изменение только тех полей шаблонов связи, для которых не определены связи в чертеже. В противном случае происходит нарушение связей с таблицей базы данных. Для редактирования шаблона связи в чертеже необходимо предварительно удалить все связи, использующие данный шаблон.

Редактирование связей

После создания связей может потребоваться изменить используемые этими связями ключевые значения. Например, можно изменить порядок нумерации некоторых офисов или передать часть комнат бухгалтерии отделу продаж. Для изменения ключевого значения у выбранной связи можно использовать Диспетчер связей. Ключевые значения должны соответствовать тем значениям, которые имеются в таблице базы данных.


Создание и редактирование связей и шаблонов связей - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование связей и шаблонов связей
Понятия
Процедуры
Команды

Для создания шаблона связи в текущем чертеже

Для создания связи между объектом и записью во внешней базе данных

Для редактирования шаблона связи

Для обновления свойств шаблона связи

Для удаления из текущего чертежа всех связей, использующих определенный шаблон связи

Для изменения ключевого значения связи с помощью Диспетчера связей


Для создания шаблона связи в текущем чертеже - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование связей и шаблонов связей
Понятия
Процедуры
Команды

Для создания шаблона связи в текущем чертеже

  1. Нажмите правую кнопку мыши на файле-источнике данных в окне Диспетчера подключения к БД. Выберите "Новый шаблон связи".
  2. В диалоговом окне "Новый шаблон связи" в поле "Имя нового шаблона связи" введите имя шаблона связи. Нажмите кнопку "Далее".
  3. Выберите один или несколько ключевых столбцов, установив соответствующие флажки.

    4. Число ключевых столбцов должно быть минимальным. Большое количество ключевых столбцов может ухудшить скорость выполнения функций работы с базами данных.

  4. Нажмите "ОК" для создания шаблона.


Для создания связи между объектом и записью во внешней базе данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование связей и шаблонов связей
Понятия
Процедуры
Команды

Для создания связи между объектом и записью во внешней базе данных

  1. Из Диспетчера подключения к БД откройте таблицу, для которой создан хотя бы один шаблон связи.
  2. В окне просмотра данных из списка "Шаблон связи" выберите нужный шаблон связи.
  3. В окне просмотра данных выделите одну или несколько записей, которые необходимо подключить.
  4. Нажмите на стрелку рядом с кнопкой "Связь!" для раскрытия выпадающего списка.
  5. Из раскрытого списка выберите "Создавать связи".
  6. Выберите один или несколько объектов чертежа, к которым необходимо подключить данные.
  7. Нажмите ENTER.


Для редактирования шаблона связи - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование связей и шаблонов связей
Понятия
Процедуры
Команды

Для редактирования шаблона связи

  1. Выберите меню "Базы данных" » "Шаблоны" » "Редактировать шаблон связи"
  2. В диалоговом окне "Выбор объекта базы данных" выберите шаблон связи, который нужно изменить. Нажмите кнопку "Далее".
  3. Выберите один или несколько ключевых столбцов, установив соответствующие флажки.
  4. Нажмите "OK" для сохранения изменений, внесенных в шаблон связи.


Для обновления свойств шаблона связи - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование связей и шаблонов связей
Понятия
Процедуры
Команды

Для обновления свойств шаблона связи

  1. Выберите меню "Базы данных" » "Шаблоны" » "Свойства шаблона связи"
  2. В диалоговом окне "Выбор объекта базы данных" выберите шаблон связи. Нажмите кнопку "Далее".
  3. В диалоговом окне "Свойства шаблона связи" обновите информацию об источнике данных. Нажмите "ОК".


Для удаления из текущего чертежа всех связей, использующих определенный шаблон связи - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование связей и шаблонов связей
Понятия
Процедуры
Команды

Для удаления из текущего чертежа всех связей, использующих определенный шаблон связи

  1. Выберите меню "Базы данных" » "Связи" » "Удалить связи".
  2. В диалоговом окне "Выбор объекта базы данных" выберите шаблон связи, связи которого нужно удалить. Нажмите "ОК".


Для изменения ключевого значения связи с помощью Диспетчера связей - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование связей и шаблонов связей
Понятия
Процедуры
Команды

Для изменения ключевого значения связи с помощью Диспетчера связей

  1. Выберите меню "Базы данных" » "Связи" » "Диспетчер связей".
  2. Выберите на чертеже графический объект, к которому подключены внешние данные.
  3. Следует особо отметить, что Диспетчер связей одновременно может работать только с одним графическим объектом.
  4. В Диспетчере связей выберите одну из связей объекта, которая создана с помощью шаблона связи, указанного в списке "Шаблоны связи".
  5. Введите новое значение в ячейку "Значение" той связи, которую нужно изменить, или нажмите кнопку [...]. Повторите процедуру для других ключевых полей, если необходимо.

    6. Нажатие кнопки [...] позволяет выбрать значение из списка всех имеющихся значений в указанном столбце таблицы. После выбора значения нажмите "ОК".

    Примечание Кнопка [...] доступна только в том случае, если используемый связью источник данных подключен к чертежу.

  6. Нажмите "OK" для обновления связи и закрытия диалогового окна.


Создание и редактирование связей и шаблонов связей - Команды

Внешние базы данных
Внешние базы данных
Создание и редактирование связей и шаблонов связей
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Просмотр и выбор существующих связей - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр и выбор существующих связей
Понятия
Процедуры
Команды

Можно выбирать записи таблицы, выбирая объекты чертежа, к которым эти записи подключены, и наоборот, можно выбирать объекты чертежа, выбирая записи таблицы.

Внешние данные, подключенные к графическим объектам с помощью связей, можно просматривать. Пусть, например, имеется план офисов, к которому подключены записи базы данных с информацией обо всех сотрудниках фирмы. В этом случае не составит большого труда найти офис любого из сотрудников. Выбрав сотрудника фирмы в окне просмотра данных, можно выделить связанные с ним графические объекты. И наоборот, выбрав объекты чертежа, в окне просмотра данных можно выделить связанные с ними записи и определить, какие сотрудники работают в данном офисе.

Автоматический выбор связанных объектов

Имеется возможность автоматически выбирать на чертеже графические объекты по мере выделения связанных с ними записей в окне просмотра данных. И наоборот, можно автоматически выделять записи базы данных по мере выбора связанных с ними графических объектов чертежа. Однако текущим может быть только один из этих режимов автопросмотра.

Дополнительные режимы просмотра

Для задания различных режимов просмотра связанных графических объектов и записей используется диалоговое окно "Параметры окна просмотра данных и запросов".

Режим "Автоматическое панорамирование" позволяет автоматически панорамировать чертеж так, чтобы объекты, связанные с выделенным в окне просмотра данных набором записей, располагались в области рисования. Однако при фиксированном (текущем) коэффициенте экранного увеличения не всегда возможно разместить в области рисования все объекты, связанные с выделенными записями. Чтобы исключить подобные ситуации, можно активизировать режим автоматического зумирования.

Режим "Автоматическое зумирование" позволяет автоматически подбирать экранное увеличение таким образом, чтобы все объекты, связанные с текущим набором записей, умещались в области рисования. При этом требуется задать коэффициент, определяющий какую часть (в процентах) от области рисования должен занимать выбранный набор объектов. Возможный диапазон значений лежит в переделах от 20 до 90 процентов, по умолчанию используется значение 50 процентов. Если коэффициент равен 50 процентам, то экранное увеличение подбирается таким образом, чтобы высота или ширина набора объектов (большее из этих значений) составляла 50 процентов от области рисования.

Кроме того, имеются следующие группы режимов просмотра связей:

  • Режимы пометки записей. Здесь можно выбрать, какие записи следует отображать в окне просмотра данных - все или только связанные с текущими выбранными графическими объектами. При использовании режима "Все записи, с выделением выбранных" имеется возможность выбрать цвет пометки.
  • Режимы накопления. Здесь можно установить, следует ли по мере выбора графических объектов или записей окна просмотра данных добавлять их в набор объектов или всегда создавать новый набор.

Подробнее о режимах просмотра см. раздел Диалоговое окно "Параметры окна просмотра данных и запросов" описания команды БДСВЯЗЬ в Справочнике команд.


Просмотр и выбор существующих связей - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр и выбор существующих связей
Понятия
Процедуры
Команды

Для просмотра графических объектов, связанных с записями таблицы

Для просмотра записей базы данных, связанных с выбранными графическими объектами

Для автоматического просмотра графических объектов, связанных с записями таблицы

Для автоматического просмотра записей таблицы, связанных с выбранными графическими объектами

Для задания дополнительных режимов просмотра связей


Для просмотра графических объектов, связанных с записями таблицы - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр и выбор существующих связей
Понятия
Процедуры
Команды

Для просмотра графических объектов, связанных с записями таблицы

  1. Из Диспетчера подключения к БД откройте таблицу, дважды нажав на ее имени.
  2. В окне просмотра данных из списка "Выбор шаблона связи" выберите требуемый шаблон связи.
  3. В окне просмотра данных выделите одну или несколько записей.
  4. Нажмите правую кнопку мыши на выбранной записи. Выберите "Просмотреть связанные объекты".

    5. Все объекты чертежа, связанные с выделенными записями, подсвечиваются.


Для просмотра записей базы данных, связанных с выбранными графическими объектами - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр и выбор существующих связей
Понятия
Процедуры
Команды

Для просмотра записей базы данных, связанных с выбранными графическими объектами

  1. Из Диспетчера подключения к БД откройте таблицу, дважды нажав на ее имени.
  2. В окне просмотра данных из списка "Выбор шаблона связи" выберите требуемый шаблон связи.
  3. В области рисования выберите один или несколько объектов.
  4. Нажмите кнопку "Просмотр связанных записей в окне просмотра данных" на панели инструментов окна просмотра данных.

    5. По умолчанию в окно просмотра данных выводятся только те записи, которые связаны с выбранными объектами. При необходимости в диалоговом окне "Параметры запросов и окна просмотра данных" можно задать вывод всех записей.


Для автоматического просмотра графических объектов, связанных с записями таблицы - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр и выбор существующих связей
Понятия
Процедуры
Команды

Для автоматического просмотра графических объектов, связанных с записями таблицы

  1. Из Диспетчера подключения к БД откройте таблицу, дважды нажав на ее имени.
  2. В окне просмотра данных из списка "Выбор шаблона связи" выберите требуемый шаблон связи.
  3. Нажмите кнопку "Автопросмотр связанных объектов в чертеже" на панели инструментов окна просмотра данных.
  4. В окне просмотра данных выделите одну или несколько записей.

    5. Все графические объекты, связанные с выделенными записями, подсвечиваются в области рисования.

  5. Повторите пункт 4 для выделения дополнительных связанных графических объектов.
  6. Повторите пункт 3 для отключения режима автопросмотра связанных объектов.


Для автоматического просмотра записей таблицы, связанных с выбранными графическими объектами - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр и выбор существующих связей
Понятия
Процедуры
Команды

Для автоматического просмотра записей таблицы, связанных с выбранными графическими объектами

  1. Из Диспетчера подключения к БД откройте таблицу, дважды нажав на ее имени.
  2. В окне просмотра данных из списка "Выбор шаблона связи" выберите требуемый шаблон связи.
  3. Нажмите кнопку "Автопросмотр связанных записей в окне просмотра данных" на панели инструментов окна просмотра данных.
  4. В области рисования выберите один или несколько объектов.

    5. По умолчанию в окно просмотра данных выводятся только те записи, которые связаны с выбранными объектами. При необходимости в диалоговом окне "Параметры запросов и окна просмотра данных" можно задать вывод всех записей.

  5. Повторите пункт 4 для выделения дополнительных связанных записей.
  6. Повторите пункт 3 для отключения режима автопросмотра связанных записей.


Для задания дополнительных режимов просмотра связей - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Просмотр и выбор существующих связей
Понятия
Процедуры
Команды

Для задания дополнительных режимов просмотра связей

  1. Нажмите кнопку "Параметры окна просмотра данных и запросов" на панели инструментов окна просмотра данных.
  2. В диалоговом окне "Параметры окна просмотра данных и запросов" задайте требуемые значения параметров.
  3. Нажмите "OK" для сохранения изменений и закрытия диалогового окна.


Просмотр и выбор существующих связей - Команды

Внешние базы данных
Внешние базы данных
Просмотр и выбор существующих связей
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Поиск и исправление поврежденных связей - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Поиск и исправление поврежденных связей
Понятия
Процедуры
Команды

Функция синхронизации позволяет обнаруживать поврежденные связи.

Рекомендуется периодически проверять связи чертежей, чтобы обновить или удалить поврежденные связи. Для обнаружения поврежденных связей можно использовать функцию синхронизации, которая выполняет анализ связей выбранного шаблона связи. После запуска функции синхронизации в диалоговом окне выдается список обнаруженных ошибок. Определенные типы ошибок (например изменение формата столбца в таблице базы данных) можно исправить непосредственно с помощью диалогового окна "Синхронизация". Другие типы ошибок (например, подключение к несуществующей записи) следует исправлять в самой таблице базы данных.


Для синхронизации связей в чертеже - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Поиск и исправление поврежденных связей
Понятия
Процедуры
Команды

Для синхронизации связей в чертеже

  1. Нажмите правую кнопку мыши на шаблоне связи в окне Диспетчера подключения к БД. Нажмите "Синхронизация".

    2. Если ошибки не обнаружены, отображается соответствующее сообщение. В случае выявления ошибок их список выводится в диалоговом окне "Синхронизация".

  2. В диалоговом окне "Синхронизация" выберите ошибку из списка и выполните одно или несколько из следующих действий:
    • Нажмите кнопку "Выделить объекты чертежа" для выбора объектов, имеющих поврежденные связи.
    • Нажмите кнопку "Исправить" для корректировки поврежденной связи.
    • Нажмите кнопку "Удалить" для удаления поврежденной связи.
  3. Повторите пункт 3 для оставшихся ошибок.
  4. Нажмите кнопку "Закрыть".


Поиск и исправление поврежденных связей - Команды

Внешние базы данных
Внешние базы данных
Поиск и исправление поврежденных связей
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Экспорт связей - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Экспорт связей
Понятия
Процедуры
Команды

Имеющиеся у графических объектов чертежа связи можно экспортировать. Эту возможность удобно использовать в тех случаях, когда к различным записям одной таблицы подключено по несколько графических объектов. Пусть, например, требуется составить перечень используемых на схеме источников освещения с указанием числа источников каждого типа. Очевидно, что необходимая для этого информация отсутствует во внешней базе данных. Записи базы данных предоставляют информацию о самих источниках света (например, типе, технических характеристиках и т.д.). Однако в таблице не хранятся данные о количестве подключений той или иной записи к объектам чертежа. Для получения подобной информации нужно выполнить экспорт имеющихся в чертеже связей.


Для экспорта связей из чертежа - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Экспорт связей
Понятия
Процедуры
Команды

Для экспорта связей из чертежа

  1. Выберите меню "Базы данных" » "Связи" » "Экспорт связей".
  2. Выберите графические объекты чертежа, связи которых нужно экспортировать.

    3. Если к выбранным графическим объектам внешние данные подключены с помощью нескольких шаблонов связи, в диалоговом окне "Выбор объекта базы данных" выберите нужный шаблон. Если все выбранные объекты используют только один шаблон связи, сразу же вызывается диалоговое окно "Экспорт связей".

  3. В диалоговом окне "Экспорт связей" в списке "Включая поля" выберите поля записей, которые нужно экспортировать.

    4. Ключевые столбцы шаблона связи выбираются автоматически. Кроме полей записей, для каждой связи также экспортируется идентификатор того объекта, который использует данную связь.

  4. В поле "Имя файла" введите имя выходного файла.
  5. Выберите формат из списка "Тип файла".

    6. Файл можно сохранить либо в формате исходной базы данных, либо в текстовом файле с отделением полей записи друг от друга запятыми или пробелами.

  6. Нажмите "Сохранить" для экспорта связей и закрытия диалогового окна.
  7. Повторите, если необходимо, пункты с 1 по 6 для экспорта связей других шаблонов связи.


Экспорт связей - Команды

Внешние базы данных
Внешние базы данных
Экспорт связей
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование ярлыков - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование ярлыков
Понятия
Процедуры
Команды

Ярлыки представляют собой многострочные текстовые объекты, содержимое которых определяется содержимым выбранных полей тех или иных записей таблицы внешней базы данных.

  • Создание и редактирование ярлыков и шаблонов ярлыков
    Ярлыки могут быть свободными и прикрепленными. Шаблон ярлыка задает, информация из каких полей таблицы базы данных отображается в ярлыках, созданных по этому шаблону.
  • Обновление ярлыков в соответствии с новыми значениями полей базы данных
    Для того чтобы отобразить в чертеже измененные значения полей базы данных, ярлыки требуется обновить.


Использование ярлыков - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование ярлыков
Понятия
Процедуры
Команды

Для создания шаблона ярлыка

Для создания связи со свободным ярлыком

Для создания прикрепленного ярлыка

Для редактирования шаблона ярлыка

Для задания параметров форматирования ярлыка

Для обновления надписей ярлыков текущего чертежа


Использование ярлыков - Команды

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование ярлыков
Понятия
Процедуры
Команды
Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и редактирование ярлыков и шаблонов ярлыков - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование ярлыков и шаблонов ярлыков
Понятия
Процедуры
Команды

Ярлыки могут быть свободными и прикрепленными. Шаблон ярлыка задает, информация из каких полей таблицы базы данных отображается в ярлыках, созданных по этому шаблону.

Связи являются мощным средством, которое используется для подключения внешних данных к графическим объектам. Выбирая объекты, имеющие связи, можно быстро просматривать подключенные к ним записи внешней базы данных. Однако поскольку связи являются невидимыми элементами чертежа, они имеют некоторые ограничения. Например, пусть требуется распечатать чертеж и вместе с чертежом вывести внешние данные, связанные с отдельными связями. Но внешние данные не распечатаются. Связано это с тем, что связи являются всего лишь указателями на записи внешней базы данных. Поэтому при необходимости вывести на чертеж содержимое записей внешних таблиц следует использовать так называемые ярлыки.

Ярлыки представляют собой многострочные текстовые объекты, содержимое которых определяется содержимым выбранных полей тех или иных записей внешней таблицы базы данных.

Ярлыки могут быть свободными или прикрепленными к графическим объектам. Свободный ярлык не зависит ни от каких графических объектов чертежа. Ярлык, прикрепленный к графическому объекту, обладает ассоциативностью. При переносе графического объекта прикрепленный к нему ярлык перемещается вместе с ним. При копировании объекта в буфер обмена ярлык также копируется. При удалении объекта все прикрепленные к нему ярлыки также удаляются. Надпись прикрепленного к графическому объекту ярлыка располагается на выноске.

Для создания ярлыков требуется наличие шаблона ярлыка, который задает параметры форматирования ярлыка, а также столбцы таблицы, значения которых определяют текст надписи ярлыка.

Редактирование шаблонов ярлыков

После создания шаблона ярлыка может возникнуть необходимость изменить его. Например, может потребоваться добавить в шаблон другие столбцы таблицы или изменить шрифт или размер символов текста ярлыка. Кроме того, можно задать ряд параметров, которые влияют на выбор точки вставки ярлыка и конфигурацию выноски (только для прикрепленных ярлыков).

Значения смещений по координатам X и Y начала выноски и надписи задаются на вкладке "Смещение ярлыка" диалогового окна "Шаблон ярлыка". В следующей таблице приводятся сведения о назначении данных параметров применительно к свободным и прикрепленным ярлыкам.

Параметры вкладки "Смещение ярлыка"
Флажок | Свободный ярлык | Прикрепленный ярлык
Начало | Отсутствует | Задает начальную точку объекта-выноски. Положение точки определяется относительно границ графического объекта, к которому прикрепляется ярлык. Предположим, например, что для ярлыка, прикрепленного к объекту типа прямоугольник, выбрано значение "Вверх влево". В этом случае начало выноски размещается в левом верхнем углу прямоугольника.
Выноска Отступ | Отсутствует | Задает смещение полки и надписи ярлыка по координатам X и Y относительно начала выноски. По умолчанию смещение полки по X и Y устанавливается равным 1, что задает смещение надписи ярлыка относительно начала выноски (стрелки) на одну единицу чертежа по каждой из координат X и Y.
Начало Отступ | Задает смещение надписи ярлыка по координатам X и Y относительно указанной точки вставки ярлыка. Например, если смещение по X и Y равно -1, то надпись ярлыка смещается от точки вставки ярлыка на одну единицу чертежа в отрицательном направлении каждой из координат. | Задает смещение выноски по координатам X и Y относительно начальной точки. Предположим, например, что для ярлыка, прикрепленного к объекту типа прямоугольник, выбрано значение "Вверх влево". Пусть смещение выноски по координатам X и Y равно 1. В этом случае начало выноски смещается на одну единицу чертежа по осям X и Y относительно левого верхнего угла прямоугольника.
Редактирование ярлыков

Имеется возможность осуществлять различные манипуляции над имеющимися на чертеже ярлыками. Надписи ярлыков и их выноски можно переносить и масштабировать с помощью стандартных команд КОПИРОВАТЬ, ПЕРЕНЕСТИ и МАСШТАБ. Необходимо отметить, что изменение параметров отдельного ярлыка не влияет на шаблон ярлыка. Подробнее о редактировании шаблона ярлыка см. раздел Для редактирования шаблона ярлыка.

Примечание Текст надписи ярлыка не рекомендуется изменять с помощью редактора, используемого в месте редактирования. Связано это с тем, что подобные изменения не заносятся в базу данных, а потому после выполнения обновления ярлыков восстанавливаются исходные значения. Поэтому для изменения содержимого ярлыка следует изменить подключенные данные, как описано в разделе Создание и редактирование связей и шаблонов связей, и выбрать "Обновить".


Создание и редактирование ярлыков и шаблонов ярлыков - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование ярлыков и шаблонов ярлыков
Понятия
Процедуры
Команды

Для создания шаблона ярлыка

Для создания связи со свободным ярлыком

Для создания прикрепленного ярлыка

Для редактирования шаблона ярлыка

Для задания параметров форматирования ярлыка


Для создания шаблона ярлыка - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование ярлыков и шаблонов ярлыков
Понятия
Процедуры
Команды

Для создания шаблона ярлыка

  1. В окне Диспетчера подключения к БД нажмите кнопку "Новый шаблон ярлыка".
  2. В диалоговом окне "Новый шаблон ярлыка" в списке "Имя нового шаблона ярлыка" введите имя шаблона ярлыка.
  3. Для открытия диалогового окна "Шаблон ярлыка" нажмите кнопку "Далее".
  4. В диалоговом окне "Шаблон ярлыка" на вкладке "Поля ярлыка" в списке "Столбец" выберите столбец таблицы, значения из которого должны содержать ярлыки. Нажмите кнопку "Добавить", чтобы добавить его в ярлык.

    5. Кроме того, шаблон ярлыка может содержать статический текст, общий для всех ярлыков. Например, можно создать шаблон ярлыка, использующий столбец "Номер комнаты" базы данных о помещениях здания. Для того чтобы надпись каждого ярлыка кроме значения из базы данных содержала еще и имя столбца, в диалоговом окне "Шаблон ярлыка" перед добавлением в шаблон столбца следует ввести Номер комнаты:.

  5. Повторите действия пункта 5 для добавления других столбцов, значения которых должны отображаться в ярлыке.
  6. Нажмите "ОК".


Для создания связи со свободным ярлыком - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование ярлыков и шаблонов ярлыков
Понятия
Процедуры
Команды

Для создания связи со свободным ярлыком

  1. Из Диспетчера подключения к БД откройте таблицу, для которой создан хотя бы один шаблон связи и один шаблон ярлыка.
  2. В окне просмотра данных из списка "Выбор шаблона связи" выберите требуемый шаблон связи.
  3. В окне просмотра данных из списка "Выбор шаблона ярлыка" выберите требуемый шаблон ярлыка.
  4. В окне просмотра данных выделить запись, которую необходимо подключить.
  5. Нажмите правую кнопку мыши в области заголовка выделенной записи (пустой прямоугольник слева от записи). Выберите "Параметры связей и ярлыков" » "Создавать свободные ярлыки".
  6. В меню "Просмотр данных" выберите "Связь!".
  7. Задайте положение ярлыка на чертеже.


Для создания прикрепленного ярлыка - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование ярлыков и шаблонов ярлыков
Понятия
Процедуры
Команды

Для создания прикрепленного ярлыка

  1. Из Диспетчера подключения к БД откройте таблицу, для которой создан хотя бы один шаблон связи и один шаблон ярлыка.
  2. В окне просмотра данных из списка "Выбор шаблона связи" выберите требуемый шаблон связи.
  3. В окне просмотра данных из списка "Выбор шаблона ярлыка" выберите требуемый шаблон ярлыка.
  4. В окне просмотра данных выделите запись, которую необходимо подключить.
  5. Выберите меню "Просмотр данных" » "Параметры связей и ярлыков" » "Создавать прикрепленные ярлыки".
  6. Выберите меню "Просмотр данных" » "Связь".
  7. Выберите один или несколько объектов чертежа, для которых нужно создать прикрепленные ярлыки.
  8. Нажмите ENTER.


Для редактирования шаблона ярлыка - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование ярлыков и шаблонов ярлыков
Понятия
Процедуры
Команды

Для редактирования шаблона ярлыка

  1. В окне Диспетчера подключения к БД нажмите правую кнопку мыши на шаблоне ярлыка, который требуется отредактировать. Нажмите кнопку "Изменить".
  2. Внесите необходимые изменения в диалоговом окне "Шаблон ярлыка", как описано в разделе Для создания шаблона ярлыка.
  3. Нажмите "ОК".


Для задания параметров форматирования ярлыка - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Создание и редактирование ярлыков и шаблонов ярлыков
Понятия
Процедуры
Команды

Для задания параметров форматирования ярлыка

  1. Создайте новый шаблон ярлыка, как описано в разделе Для создания шаблона ярлыка.
  2. В диалоговом окне "Шаблон ярлыка" выберите параметры форматирования текста с помощью вкладок "Символ" и "Свойства", как описано в разделе МТЕКСТ в Справочнике команд.
  3. На вкладке "Смещение ярлыка" выберите из списка "Начало" способ задания точки вставки начала выноски.

    4. Значение параметра "Начало" игнорируется при создании свободных ярлыков.

  4. В поля "Смещ. полки" введите значение X и Y, определяющие величину смещения полки и надписи ярлыка относительно начала выноски.

    5. По умолчанию смещение полки выноски по X и Y устанавливается равным 1, что задает смещение надписи ярлыка относительно начала выноски на одну единицу чертежа по каждой из координат.

  5. В поля "Смещение выноски" введите значения X и Y, которые для свободных ярлыков задают величину смещения надписи от точки вставки, а для прикрепленных ярлыков величину смещения начала выноски.


Создание и редактирование ярлыков и шаблонов ярлыков - Команды

Внешние базы данных
Внешние базы данных
Создание и редактирование ярлыков и шаблонов ярлыков
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обновление ярлыков в соответствии с новыми значениями полей базы данных - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Обновление ярлыков в соответствии с новыми значениями полей базы данных
Понятия
Процедуры
Команды

Использованные при создании ярлыков записи базы данных впоследствии можно изменять. В случае частого изменения базы данных рекомендуется периодически выполнять обновление ярлыков, для того чтобы содержимое ярлыков соответствовало текущим значениям полей базы данных.


Для обновления надписей ярлыков текущего чертежа - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Обновление ярлыков в соответствии с новыми значениями полей базы данных
Понятия
Процедуры
Команды

Для обновления надписей ярлыков текущего чертежа

  • В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени файла чертежа. Выберите "Обновить ярлыки".


Обновление ярлыков в соответствии с новыми значениями полей базы данных - Команды

Внешние базы данных
Внешние базы данных
Обновление ярлыков в соответствии с новыми значениями полей базы данных
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование запросов для выбора информации из базы данных - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование запросов для выбора информации из базы данных
Понятия
Процедуры
Команды

Запросы позволяют извлекать из базы данных требуемые записи.

  • Основные понятия
  • Формирование простых запросов
    Самые простые запросы позволяют отбирать записи по одному столбцу, одному значению и с использованием одного оператора. Запросы по интервалу позволяют отбирать записи, у которых значение определенного поля лежит в заданном интервале.
  • Использование вкладки "Формирователь"
    Для формирования запросов по двум и более критериям используются логические операторы и группировка условий.
  • Использование вкладки "SQL-запрос"
    Если используемая база данных совместима со стандартом SQL 92, для формирования запросов одновременно к нескольким таблицам базы данных можно использовать SQL-выражения.
  • Комбинирование запросов
    Специальное средство выбора по связи (модификация редактора запросов) позволяет создавать сложные наборы графических объектов и записей базы данных путем комбинирования имеющихся наборов.
  • Сохранение и повторное использование запросов
    Часто используемые запросы можно сохранять в чертеже. Сохраненные запросы можно редактировать, переименовывать и копировать в другие чертежи.


Использование запросов для выбора информации из базы данных - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование запросов для выбора информации из базы данных
Понятия
Процедуры
Команды

Для вызова Редактора запросов

Для создания простого запроса

Для создания запроса по интервалу

Для создания запроса с одним условием отбора на вкладке "Формирователь"

Для создания запроса с несколькими условиями отбора на вкладке "Формирователь"

Для задания столбцов таблицы, которые следует выводить по запросу

Для задания порядка сортировки записей, выводимых по запросу

Для создания SQL-запроса

Для создания набора объектов на основе связей

Для выполнения сохраненного запроса

Для редактирования сохраненного запроса

Для переименования сохраненного запроса

Для удаления сохраненного запроса

Для копирования сохраненного запроса в другой чертеж

Для автоматического сохранения всех создаваемых запросов в текущем чертеже


Использование запросов для выбора информации из базы данных - Команды

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование запросов для выбора информации из базы данных
Понятия
Процедуры
Команды
Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Основные понятия - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Основные понятия
Понятия
Процедуры
Команды

Основным преимуществом хранения информации в базах данных является возможность построения запросов для поиска записей, удовлетворяющих определенным условиям. Например, пусть имеется таблица базы данных, содержащая записи всех комнат в здании штаб-квартиры компании. Допустим, требуется составить список всех залов для совещаний, способных вместить более 20 человек. С помощью Редактора запросов AutoCAD можно без труда сформировать запрос для нахождения нужного набора записей или графических объектов (к объектам должны быть подключены внешние данные).

Окно Редактора запросов состоит из четырех вкладок, предназначенных для составления запросов. Каждая вкладка позволяет формировать запросы определенной степени сложности, причем в простейших случаях от пользователя даже не требуется знание языка SQL (Structured Query Language). Вкладки "Простой запрос" и "Запрос по интервалу" предназначены для тех пользователей, которые не знакомы с языком запросов. Вкладки "Формирователь" и "SQL-запрос" могут использоваться более подготовленными пользователями.

Формирование запроса можно начать на одной вкладке, а затем продолжить на другой. Например, на вкладке "Простой запрос" можно составить простейший запрос, а затем задать дополнительные условия поиска на вкладке "Формирователь". При этом после перехода на вкладку "Формирователь" в таблице данной вкладки выводятся условия запроса, заданные на вкладке "Простой запрос". Можно добавить в запрос и другие условия. Переключение на одну из последующих вкладок позволяет формировать более сложные условия поиска, которые нельзя задать на предыдущих вкладках. После модификации запроса при попытке перейти на одну из предыдущих вкладок выдается сообщение о том, что будут восстановлены параметры запроса по умолчанию.

Наличие в Редакторе запросов отдельных вкладок для формирования запросов различной степени сложности облегчает и ускоряет освоение языка SQL. Например, запрос можно сформировать на вкладке "Простой запрос", а затем переключиться на вкладку "SQL-запрос" и посмотреть, как данный запрос выглядит на языке SQL.

Для построения запросов можно использовать следующие вкладки Редактора запросов:

  • Простой запрос. Позволяет формировать простейшие запросы, осуществляющие отбор записей по одному столбцу, одному значению и с использованием одного оператора. Например, в текущей базе данных можно найти все записи, поле "тип комнаты" которых имеет значение "офис."
  • Запрос по интервалу. Позволяет формировать запросы для нахождения тех записей, у которых значение определенного поля лежит в заданном интервале. Например, в текущей базе данных можно найти все записи, поле "площадь комнаты" которых имеет значение большее или равное 9 кв. м., но меньшее или равное 12 кв. м.
  • Формирователь. Позволяет формировать более сложные запросы, осуществляющие отбор записей по нескольким критериям. Например, в текущей базе данных можно найти все записи, поле "тип комнаты" которых имеет значение "кабинет", а площадь комнаты превышает 8 кв. м.
  • SQL-запрос. Позволяет формировать сложные запросы на языке стандарта SQL 92. Например, можно выбрать * из таблицы казань.гармония.комната, где

    • казань.гармония.комната.тип = "кабинет"

    и

    казань.гармония.комната.площадь < 8.

Подробнее о составлении простых запросов и использовании операторов см. раздел Формирование простых запросов. Подробнее о формировании более сложных запросов см. раздел Использование вкладки "Формирователь".


Для вызова Редактора запросов - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Основные понятия
Понятия
Процедуры
Команды

Для вызова Редактора запросов

  1. Выберите таблицу в окне Диспетчера подключения к БД.
  2. Нажмите кнопку "Новый запрос".
  3. В диалоговом окне "Новый запрос" в список "Имя нового запроса" введите имя запроса.
  4. Нажмите кнопку "Далее" для открытия окна Редактора запросов.


Основные понятия - Команды

Внешние базы данных
Внешние базы данных
Основные понятия
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Формирование простых запросов - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Формирование простых запросов
Понятия
Процедуры
Команды

Самые простые запросы позволяют отбирать записи по одному столбцу, одному значению и с использованием одного оператора. Запросы по интервалу позволяют отбирать записи, у которых значение определенного поля лежит в заданном интервале.

Использование вкладки "Простой запрос"

Вкладка "Простой запрос" предназначена для облегчения освоения языка запросов и может использоваться пользователями, не имеющими опыта работы с базами данных. Формирование простого запроса заключается в указании столбца текущей таблицы базы данных, выборе условного оператора и задании значения поля.

Условные операторы (например, равно, больше или меньше) определяют условия, по которым производится отбор записей. В следующей таблице приводятся сведения о назначении операторов, используемых при формировании запросов.

Операторы запросов
Операторы запросов
Оператор | Описание
Равно (=) | Возвращает все записи, значение которых в указанном столбце полностью совпадает с заданным значением.
Не равно (<>) | Возвращает все записи, значения которых в указанном столбце не равны заданному значению.
Больше (>) | Возвращает все записи, значения которых в указанном столбце больше заданного значения.
Меньше (<) | Возвращает все записи, значения которых в указанном столбце меньше заданного значения.
Больше чем или равно (>=) | Возвращает все записи, значения которых в указанном столбце больше или равны заданному значению.
Меньше или равно (<=) | Возвращает все записи, значения которых в указанном столбце меньше или равны заданному значению.
Like | Возвращает все записи, значения которых в указанном столбце содержат заданное значение. При использовании оператора like (подобие) допускается применение необязательного символа-шаблона %. Например, если необходимо найти все записи, заканчивающиеся на "вол", нужно задать значение %вол. Если необходимо найти все записи, начинающиеся с "вол", нужно задать значение вол% Если символ-шаблон % отсутствует, выполняется поиск записей, значение которых полностью совпадает с заданным значением.
In | Возвращает все записи, значения которых в указанном столбце совпадают с одним из заданных значений. Например, если необходимо найти запись сотрудника, но точно не известно, какое имя хранится в базе (Лена или Елена), тогда можно применить оператор In, задать оба варианта имени и произвести поиск всех записей, содержащих либо значение Лена, либо Елена. Варианты значений должны отделяться друг от друга запятой.
Is null | Возвращает все записи, которые имеют пустое значение в указанном столбце. Данный оператор удобно использовать для поиска записей в таблице базы данных, в которых отсутствуют данные.
Is not null | Возвращает все записи, которые имеют какое-либо не пустое значение в указанном столбце. Данный оператор удобно использовать для исключения записей, полям которых не присвоены значения.

Примечание Все операторы могут применяться к столбцам как числового, так и строкового типа. Например, в результате применения оператора "больше" и значения "в" к столбцу строкового типа будут возвращены все записи, начинающиеся с сочетаний "ва..." - "я...". Кроме того, необходимо помнить о том, что при выполнении запросов учитывается регистр символов, то есть "КОМНАТА" и "комната" считаются разными значениями.

Использование вкладки "Запрос по интервалу"

Вкладка "Запрос по интервалу", так же как и вкладка "Простой запрос", предназначена для тех пользователей, которые не знакомы с языком запросов. С помощью вкладки "Запрос по интервалу" можно отбирать записи, определенное поле которых имеет значения, лежащие в заданном интервале. Например, можно определить все комнаты, площадь которых больше или равна 8 кв. м., но меньше или равна 12 кв. м. По внешнему виду и назначению элементов управления данная вкладка подобна вкладке "Простой запрос", за тем исключением, что список "Оператор" отсутствует, а поле "Значение" заменено двумя другими полями: "От" и "До". Все остальные элементы вкладок "Простой запрос" и "Запрос по интервалу" одинаковы.


Формирование простых запросов - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Формирование простых запросов
Понятия
Процедуры
Команды

Для создания простого запроса

Для создания запроса по интервалу


Для создания простого запроса - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Формирование простых запросов
Понятия
Процедуры
Команды

Для создания простого запроса

  1. Откройте Редактор запросов, как описано в разделе Для вызова Редактора запросов.
  2. На вкладке "Простой запрос" выберите требуемый столбец в списке "Столбец".
  3. Выберите оператор из списка "Оператор".
  4. Введите значение в текстовое поле "Значение" или нажмите кнопку "Просмотр значений".

    5. Нажатие кнопки "Просмотр значений" позволяет выбрать значение из списка всех имеющихся значений в указанном столбце таблицы. После выбора значения нажмите "ОК".

  5. Установите или снимите флажки:
    • Пометить записи в окне просмотра. Задает выделение цветом в окне просмотра данных тех записей, которые удовлетворяют условиям запроса.
    • Пометить объекты в чертеже. Задает подсвечивание тех объектов чертежа, с которыми связаны записи, удовлетворяющие условиям запроса.
  6. Чтобы сохранить запрос в текущем чертеже для последующего использования, нажмите кнопку "Сохранить".
  7. Нажмите кнопку "Выполнить" для выполнения запроса и закрытия диалогового окна.

    8. В окно просмотра данных выводится набор записей, удовлетворяющих условиям запроса. Для повторного вызова Редактора запросов и уточнения запроса нажмите кнопку "Возврат к запросу".


Для создания запроса по интервалу - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Формирование простых запросов
Понятия
Процедуры
Команды

Для создания запроса по интервалу

  1. Откройте Редактор запросов, как описано в разделе Для вызова Редактора запросов.
  2. На вкладке "Запрос по интервалу" выберите требуемое поле в списке "Поле".
  3. Введите значение в текстовое поле "От" или нажмите кнопку "Просмотр значений" (От).

    4. Нажатие кнопки "Просмотр значений" позволяет выбрать значение из списка всех имеющихся значений в указанном столбце таблицы. После выбора значения нажмите "ОК".

    При выполнении запроса отбираются только те записи, значения которых в указанном столбце больше или равны заданному значению.

  4. Введите значение в текстовое поле "До" или нажмите кнопку "Просмотр значений" (До).

    5. При выполнении запроса отбираются только те записи, значения которых в указанном столбце меньше или равны заданному значению.

  5. Чтобы сохранить запрос в текущем чертеже для последующего использования, нажмите кнопку "Сохранить".
  6. Нажмите кнопку "Выполнить" для выполнения запроса и закрытия диалогового окна.


Формирование простых запросов - Команды

Внешние базы данных
Внешние базы данных
Формирование простых запросов
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование вкладки "Формирователь" - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование вкладки "Формирователь"
Понятия
Процедуры
Команды

Для формирования запросов по двум и более критериям используются логические операторы и группировка условий.

Вкладка "Формирователь" является основным средством для формирования запросов. В отличие от вкладок "Простой запрос" и "Запрос по интервалу", данная вкладка позволяет составлять запросы, содержащие сразу несколько критериев отбора. При этом имеется возможность группировать отдельные выражения с помощью скобок, а также задавать, какие столбцы следует выводить в окно просмотра данных, и порядок сортировки отобранных записей.

При создании сложных запросов на вкладке "Формирователь" отдельные условия можно объединять с помощью скобок и логических операторов. Например, используя логические операторы, можно сформировать запрос, позволяющий найти все источники уличного освещения определенного типа, которые были установлены после определенной даты.

  • Оператор And (И). Задает отбор только тех записей, которые удовлетворяют всем заданным критериям. Пусть, например, необходимо найти все помещения, которые предназначены для использования под офис и в настоящее время никем не заняты. Для этого условия запроса следует объединить логическим оператором And.
  • Оператор Or (ИЛИ). Задает отбор только тех записей, которые удовлетворяют хотя бы одному из заданных критериев. Пусть, например, необходимо найти все помещения, которые предназначены для использования под офис или в настоящее время ни кем не заняты. Для этого условия запроса следует объединить логическим оператором Or.
  • Скобки. Используются для группировки отдельных условий запроса. Например, может потребоваться найти

    • (Все помещения, которые являются офисами и в настоящее время свободны)

    или

    (Все помещения, которые являются кабинетами и в настоящее время свободны)

    В результате выполнения запроса с подобными условиями будут отобраны все свободные офисы и кабинеты.

    Уровень вложенности скобок в выражении не может превышать четырех.


Использование вкладки "Формирователь" - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование вкладки "Формирователь"
Понятия
Процедуры
Команды

Для создания запроса с одним условием отбора на вкладке "Формирователь"

Для создания запроса с несколькими условиями отбора на вкладке "Формирователь"

Для задания столбцов таблицы, которые следует выводить по запросу

Для задания порядка сортировки записей, выводимых по запросу


Для создания запроса с одним условием отбора на вкладке "Формирователь" - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование вкладки "Формирователь"
Понятия
Процедуры
Команды

Для создания запроса с одним условием отбора на вкладке "Формирователь"

  1. Откройте Редактор запросов, как описано в разделе Для вызова Редактора запросов.
  2. На вкладке "Формирователь" выберите поле в раскрывающемся списке в ячейке "Поле".
  3. Выберите оператор из раскрывающегося списка ячейки "Оператор".
  4. Введите значение в ячейку "Значение" или нажмите кнопку [...].

    5. Нажатие кнопки [...] позволяет выбрать значение из списка всех имеющихся значений в указанном столбце таблицы. После выбора значения нажмите "ОК".

  5. Чтобы сохранить запрос в текущем чертеже для последующего использования, нажмите кнопку "Сохранить".
  6. Нажмите кнопку "Выполнить" для выполнения запроса и закрытия диалогового окна.


Для создания запроса с несколькими условиями отбора на вкладке "Формирователь" - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование вкладки "Формирователь"
Понятия
Процедуры
Команды

Для создания запроса с несколькими условиями отбора на вкладке "Формирователь"

  1. Задайте первое условие запроса, как описано в процедуре Для создания запроса с одним условием отбора на вкладке "Формирователь".
  2. Выберите логический оператор And (И) или Or (Или) в ячейке "Логический".

    3. Для вставки оператора And (И) следует нажать на ячейке "Логический". Для вставки оператора Or следует повторно нажать на этой же ячейке.

  3. Задайте дополнительные условия запроса в ячейках последующих строк.
  4. Повторите действия пункта 2 для всех дополнительных условий запроса, кроме самого последнего.
  5. Расставьте скобки, если необходимо. Нажмите ячейку, расположенную левее той ячейки "Поле", которая должна служить началом группы условий. При этом вставляется одна открывающая скобка. Нажмите ячейку, расположенную правее той ячейки "Значение", которая должна служить концом группы условий. При этом вставляется одна закрывающая скобка.
  6. Чтобы сохранить запрос в текущем чертеже для последующего использования, нажмите кнопку "Сохранить".
  7. Нажмите кнопку "Выполнить" для выполнения запроса и закрытия диалогового окна.


Для задания столбцов таблицы, которые следует выводить по запросу - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование вкладки "Формирователь"
Понятия
Процедуры
Команды

Для задания столбцов таблицы, которые следует выводить по запросу

  1. Задайте условие запроса, как описано в процедурах Для создания запроса с одним условием отбора на вкладке "Формирователь" и Для создания запроса с несколькими условиями отбора на вкладке "Формирователь".
  2. Выделите в списке "Столбцы таблицы" тот столбец, поля которого должны выводиться после выполнения запроса.
  3. Нажмите кнопку "Добавить", расположенную над списком "Показать столбцы".
  4. Повторите пункты 2 и 3 для других столбцов, которые также должны отображаться в окне просмотра данных после выполнения запроса.


Для задания порядка сортировки записей, выводимых по запросу - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование вкладки "Формирователь"
Понятия
Процедуры
Команды

Для задания порядка сортировки записей, выводимых по запросу

  1. Задайте условие запроса, как описано в процедурах Для создания запроса с одним условием отбора на вкладке "Формирователь" и Для создания запроса с несколькими условиями отбора на вкладке "Формирователь".
  2. Выделите в списке "Показать столбцы" тот столбец, по которому нужно отсортировать записи в первую очередь.
  3. Нажмите кнопку "Добавить", расположенную над списком "Сортировка".

    4. По умолчанию выполняется сортировка по возрастанию. Нажмите кнопку "Сортировка" для упорядочивания записей по убыванию.

  4. Повторите пункты 2 и 3 для других столбцов, по которым следует отсортировать записи, отобранные при выполнении запроса.


Использование вкладки "Формирователь" - Команды

Внешние базы данных
Внешние базы данных
Использование вкладки "Формирователь"
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование вкладки "SQL-запрос" - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование вкладки "SQL-запрос"
Понятия
Процедуры
Команды

Если используемая база данных совместима со стандартом SQL 92, для формирования запросов одновременно к нескольким таблицам базы данных можно использовать SQL-выражения.

Вкладка "SQL-запрос" содержит специальную область для ввода и редактирования произвольных запросов на языке SQL, а также вспомогательные средства, облегчающие формирование запросов. AutoCAD поддерживает выполнение SQL-запросов, соответствующих стандарту SQL 92 фирмы Microsoft. Поскольку не все системы управления базами данных полностью совместимы со стандартом SQL 92, необходимо обратиться к документации по СУБД и выяснить, какие команды SQL она поддерживает.

В отличие от остальных вкладок Редактора запросов, вкладка "SQL-запрос" позволяет с помощью SQL-оператора объединения формировать запросы, обеспечивающие поиск записей сразу в нескольких таблицах базы данных. Более подробную информацию об использовании оператора объединения можно найти в документации по применяемой СУБД или описании языка SQL 92.

На вкладке "SQL-запрос" имеется ряд дополнительных элементов управления:

  • Список таблиц. Список всех таблиц баз данных, имеющихся в текущем источнике данных. Для добавления имени таблицы в область редактирования SQL-запросов можно либо дважды нажать на ее имени, либо выделить таблицу в списке и нажать кнопку "Добавить", либо ввести ее имя непосредственно в редакторе.
  • Проверить. Позволяет проверить запрос на соответствие правилам языка SQL без выполнения запроса. Данная функция предназначена для выявления синтаксических ошибок.


Для создания SQL-запроса - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Использование вкладки "SQL-запрос"
Понятия
Процедуры
Команды

Для создания SQL-запроса

  1. Откройте Редактор запросов, как описано в разделе Для вызова Редактора запросов.
  2. Перейдите на вкладку "SQL-запрос".
  3. Введите запрос в области редактирования запроса или задайте его условия с помощью элементов управления, как описано в разделе Использование вкладки "Формирователь".
  4. Чтобы сохранить запрос в текущем чертеже для последующего использования, нажмите кнопку "Сохранить".
  5. Нажмите кнопку "Выполнить" для выполнения запроса и закрытия диалогового окна.


Использование вкладки "SQL-запрос" - Команды

Внешние базы данных
Внешние базы данных
Использование вкладки "SQL-запрос"
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Комбинирование запросов - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Комбинирование запросов
Понятия
Процедуры
Команды

Специальное средство выбора по связи (модификация редактора запросов) позволяет создавать сложные наборы графических объектов и записей базы данных путем комбинирования имеющихся наборов.

Специальное средство выбора по связи является модификацией редактора запросов и позволяет итеративно создавать наборы графических объектов и записей базы данных.

Средство выбора по связи используется для облегчения формирования набора объектов, удовлетворяющего определенным требованиям. Прежде всего, с помощью запроса или путем непосредственного выбора графических объектов создается исходный набор. Данный набор считается набором А. Далее можно задать второй набор, выбрав дополнительные графические объекты или выполнив другой запрос. Этот вторичный набор объектов считается набором В. Для получения результирующего набора требуется задать операцию, устанавливающую отношения между наборами А и В. Доступны следующие операции:

  • Выбор. Создает исходный запрос или набор объектов. Полученный таким образом набор можно уточнять с помощью повторного выполнения операций выбора по связи.
  • Объединение. Добавляет в исходный набор объектов результат выполнения дополнительного запроса или повторного выбора объектов. Данная операция возвращает все записи или объекты, находящиеся в наборах А или В.
  • Пересечение. Возвращает пересечение исходного набора с результатом выполнения дополнительного запроса или повторного выбора объектов. Данная операция возвращает только те записи или объекты, которые имеются одновременно в наборах А и В.
  • Вычитание A - B. Вычитает из текущего набора результат выполнения дополнительного запроса или повторного выбора объектов.
  • Вычитание B - A. Вычитает из результата выполнения дополнительного запроса или повторного выбора объектов текущий набор.

После выполнения любой из описанных выше операций результирующий набор становится новым текущим набором и считается набором А. Далее можно продолжить процедуру формирования набора объектов, создав очередной набор В.


Для создания набора объектов на основе связей - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Комбинирование запросов
Понятия
Процедуры
Команды

Для создания набора объектов на основе связей

  1. Нажмите правую кнопку мыши на шаблоне связи в окне Диспетчера подключения к БД. Нажмите "Выбор по связи".
  2. Выберите способ получения результирующего набора из списка "Операция".
  3. Выберите шаблон связи из списка "Шаблон".
  4. Выбрать одно из следующих значений:
    • По запросу. Позволяет сформировать запрос с помощью одной из вкладок Редактора запросов.
    • Выбрать в чертеже. Позволяет временно выйти из диалогового окна для выбора объектов на чертеже. Если переключатель установлен в положение "Выбрать в чертеже", название кнопки "Выполнить" заменяется на "Выбрать".
  5. Нажмите кнопку "Выполнить" или "Выбрать" для создания исходного набора объектов.
  6. Выберите тип операции из списка "Операция": "Объединение", "Пересечение", "Вычитание A-B" или "Вычитание B-A".
  7. Повторите пункты 3-5 для создания дополнительного набора В.
  8. Установите или снимите следующие флажки, после чего нажмите кнопку "Закрыть":
    • Пометить записи в окне просмотра. После нажатия кнопки "Готово" результаты выполнения текущей операции выбора по связи выводятся в окно просмотра данных. Для уточнения набора можно нажать кнопку "Возврат к выбору по связи" в окне "Просмотр данных".
    • Пометить объекты в чертеже. После нажатия кнопки "Готово" на чертеже создается соответствующий набор объектов. Для уточнения набора объектов можно нажать ENTER.

Примечание При выполнении операций выбора сразу по нескольким таблицам баз данных флажок "Пометить записи в окне просмотра" рекомендуется снимать. Связано это с тем, что средство выбора по связи может отображать записи только той таблицы, которая задана в текущем шаблоне связи. Поэтому в окно просмотра данных могут выводиться не все записи.


Комбинирование запросов - Команды

Внешние базы данных
Внешние базы данных
Комбинирование запросов
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение и повторное использование запросов - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Сохранение и повторное использование запросов
Понятия
Процедуры
Команды

Часто используемые запросы можно сохранять в чертеже. Сохраненные запросы можно редактировать, переименовывать и копировать в другие чертежи.

Часто используемые запросы можно сохранять в чертеже. Все сохраненные запросы отображаются в Диспетчере подключения к БД в разделе того чертежа, в котором они созданы. Имеющиеся запросы можно редактировать, переименовывать, а также копировать в другие чертежи.


Сохранение и повторное использование запросов - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Сохранение и повторное использование запросов
Понятия
Процедуры
Команды

Для выполнения сохраненного запроса

Для редактирования сохраненного запроса

Для переименования сохраненного запроса

Для удаления сохраненного запроса

Для копирования сохраненного запроса в другой чертеж

Для автоматического сохранения всех создаваемых запросов в текущем чертеже


Для выполнения сохраненного запроса - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Сохранение и повторное использование запросов
Понятия
Процедуры
Команды

Для выполнения сохраненного запроса

  • В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени сохраненного запроса. Нажмите "Выполнить".


Для редактирования сохраненного запроса - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Сохранение и повторное использование запросов
Понятия
Процедуры
Команды

Для редактирования сохраненного запроса

  1. В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени сохраненного запроса. Нажмите "Изменить".
  2. В Редакторе запросов внесите необходимые изменения. Нажмите кнопку "Сохранить" для записи измененного запроса в текущий чертеж.


Для переименования сохраненного запроса - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Сохранение и повторное использование запросов
Понятия
Процедуры
Команды

Для переименования сохраненного запроса

  1. В Диспетчере подключения к БД нажмите правую кнопку мыши на запросе, который следует переименовать. Нажмите "Переименовать".
  2. Введите новое имя запроса. Нажмите ENTER.


Для удаления сохраненного запроса - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Сохранение и повторное использование запросов
Понятия
Процедуры
Команды

Для удаления сохраненного запроса

  • В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени сохраненного запроса. Нажмите "Удалить".


Для копирования сохраненного запроса в другой чертеж - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Сохранение и повторное использование запросов
Понятия
Процедуры
Команды

Для копирования сохраненного запроса в другой чертеж

  1. В Диспетчере подключения к БД выделите копируемый запрос.
  2. Перетащите запрос в раздел того чертежа, в который нужно скопировать запрос.


Для автоматического сохранения всех создаваемых запросов в текущем чертеже - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Сохранение и повторное использование запросов
Понятия
Процедуры
Команды

Для автоматического сохранения всех создаваемых запросов в текущем чертеже

  1. Из Диспетчера подключения к БД откройте таблицу, дважды нажав на ее имени.
  2. Нажмите кнопку "Запрос" на панели инструментов окна просмотра данных.
  3. В диалоговом окне "Новый запрос" нажмите кнопку "Далее".
  4. В Редакторе запросов нажмите кнопку "Настройка".
  5. В группе "Параметры запросов" диалогового окна "Параметры окна просмотра данных и запросов" выберите параметр "Автоматическое сохранение". Нажмите "OK".


Сохранение и повторное использование запросов - Команды

Внешние базы данных
Внешние базы данных
Сохранение и повторное использование запросов
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Совместное использование запросов, шаблонов связей и шаблонов ярлыков - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Совместное использование запросов, шаблонов связей и шаблонов ярлыков
Понятия
Процедуры
Команды

Запросы, шаблоны связей и ярлыков можно экспортировать и импортировать.

В некоторых случаях желательно иметь возможность обмениваться запросами, шаблонами связей и ярлыков между пользователями. Это позволяет различным членам команды, работающим над одним проектом, использовать одни и те же запросы и шаблоны и не тратить время на повторное воспроизведение уже разработанных запросов и шаблонов. Программа предоставляет возможность импортировать и экспортировать запросы и шаблоны. При экспорте в набор шаблонов (запросов) включаются все шаблоны (запросы), имеющиеся в текущем чертеже.


Совместное использование запросов, шаблонов связей и шаблонов ярлыков - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Совместное использование запросов, шаблонов связей и шаблонов ярлыков
Понятия
Процедуры
Команды

Для импорта набора шаблонов в текущий чертеж

Для экспорта набора шаблонов из текущего чертежа

Для импорта набора запросов в текущий чертеж

Для экспорта набора запросов из текущего чертежа


Для импорта набора шаблонов в текущий чертеж - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Совместное использование запросов, шаблонов связей и шаблонов ярлыков
Понятия
Процедуры
Команды

Для импорта набора шаблонов в текущий чертеж

  1. В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени файла чертежа. Выберите "Импорт набора шаблонов".
  2. В диалоговом окне "Импорт набора шаблонов" выберите файл набора шаблонов.
  3. Нажмите кнопку "Открыть" для импорта набора шаблонов в текущий чертеж.

    4. Если имя импортируемого шаблона совпадает с именем одного из уже имеющихся в текущем чертеже шаблонов, отображается окно предупреждения, в котором можно указать уникальное имя для шаблона.


Для экспорта набора шаблонов из текущего чертежа - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Совместное использование запросов, шаблонов связей и шаблонов ярлыков
Понятия
Процедуры
Команды

Для экспорта набора шаблонов из текущего чертежа

  1. В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени файла чертежа. Нажмите "Экспорт набора шаблонов".
  2. В диалоговом окне "Экспорт набора шаблонов" выберите папку, в которую следует сохранить файл набора шаблонов.
  3. В поле "Имя файла" задайте имя файла набора шаблонов. Нажмите кнопку "Сохранить".


Для импорта набора запросов в текущий чертеж - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Совместное использование запросов, шаблонов связей и шаблонов ярлыков
Понятия
Процедуры
Команды

Для импорта набора запросов в текущий чертеж

  1. В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени файла чертежа. Нажмите "Импорт набора запросов".
  2. В диалоговом окне "Импорт набора запросов" выберите файл набора запросов.
  3. Нажмите кнопку "Открыть" для импорта набора запросов в текущий чертеж.

    4. Если имя импортируемого запроса совпадает с именем одного из уже имеющихся в текущем чертеже запросов, открывается окно, в котором можно задать уникальное имя для запроса.


Для экспорта набора запросов из текущего чертежа - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Совместное использование запросов, шаблонов связей и шаблонов ярлыков
Понятия
Процедуры
Команды

Для экспорта набора запросов из текущего чертежа

  1. В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени файла чертежа. Выберите "Экспорт набора запросов".
  2. В диалоговом окне "Экспорт набора запросов" выберите папку, в которую следует сохранить файл набора запросов.
  3. В поле "Имя файла" задайте имя файла набора запросов. Нажмите кнопку "Сохранить".


Совместное использование запросов, шаблонов связей и шаблонов ярлыков - Команды

Внешние базы данных
Внешние базы данных
Совместное использование запросов, шаблонов связей и шаблонов ярлыков
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа со связями в файлах предыдущих версий - Понятия

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Работа со связями в файлах предыдущих версий
Понятия
Процедуры
Команды

ASE-связи чертежей форматов Release 12, 13 и 14 можно преобразовывать в связи формата AutoCAD 2000 и более поздние. Кроме того, связи формата AutoCAD 2000 можно сохранять в форматах Release 13 и Release 14.

В AutoCAD 2000 и более поздних версиях программы связи с внешними базами данных хранятся в формате, отличном от формата предыдущих версий. Поэтому чтобы иметь возможность работать со связями прежних версий, такие связи следует преобразовать. В терминологию (по сравнению с Release 14) внесены следующие изменения: понятие ключевой столбец заменено на ключевое значение, имя маршрута связи на шаблон связи, а отображаемый атрибут на ярлык. При этом может потребоваться создание файла настройки, содержащего перечень использовавшихся ранее источников данных.

При открытии чертежа, содержащего связи в формате предыдущих версий, программа пытается автоматически преобразовать все имеющиеся связи. Например, если открыть чертеж R14, содержащий связи с источником данных db3.ase.db3sample.computer(com), программа попробует установить связи с компонентами источника данных "один к одному".

В некоторых случаях использовавшиеся в прежней версии настройки источника данных могут несколько отличаться от настроек того же источника данных в этой версии программы. Например, в прежней версии мог использоваться каталог, не описанный в настройках источника данных новой версии. Для тех связей, которые не удается автоматически преобразовать при открытии чертежа, можно воспользоваться диалоговым окном "Преобразование связей" для задания соответствия между источниками данных в прежних версиях и в новой версии. Кроме того, с помощью диалогового окна "Свойства шаблона связи" можно изменить параметры источника данных для выбранного шаблона связи.

Во время преобразования связей создается файл asi.ini, содержащий сведения о сопоставлении источников данных. Если необходимо, хранящуюся в данном файле информацию о параметрах преобразования связей можно отредактировать вручную.

Примечание Программа пытается произвести автоматическое преобразование только тех связей, источники данных которых не описаны в файле asi.ini. Если же какой-либо источник данных уже описан в таблице преобразования связей, то при открытии любого чертежа прежней версии, содержащего связи с этим источником, используются параметры, заданные в файле asi.ini.

Сохранение связей в форматы предыдущих версий

Связи с внешними базами данных, созданные в AutoCAD 2000 и более поздних версиях программы, можно преобразовывать в связи формата R13 или R14. Преобразовать связи AutoCAD 2000 и более поздних версий в формат R12 невозможно. При сохранении чертежа в формат R13 или R14 с помощью команды СОХРАНИТЬКАК, связи автоматически преобразуются в соответствующий формат. При этом необходимо задать параметры преобразования связей (соответствие источников данных), как описано выше.


Работа со связями в файлах предыдущих версий - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Работа со связями в файлах предыдущих версий
Понятия
Процедуры
Команды

Для преобразования связей из форматов AutoCAD версии 13 и 14\\

Для преобразования связей из формата Release 12


Для преобразования связей из форматов AutoCAD версии 13 и 14\\ - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Работа со связями в файлах предыдущих версий
Понятия
Процедуры
Команды

Для преобразования связей из форматов AutoCAD версии 13 и 14\\

  1. Выберите "Базы данных" » "Преобразование связей."
  2. В группе "Прежний формат связи" выполните все перечисленные ниже операции:
    • Установите переключатель "Формат связи" в положение "R13/R14".
    • В поле "Среда" введите имя среды, использовавшейся в R13 или R14, связи с которой нужно преобразовать.
    • В поле "Каталог" введите имя каталога, использовавшегося в R13 или R14, связи с которым нужно преобразовать.
    • В поле "Схема" введите имя схемы, использовавшейся в R13 или R14, связи с которой нужно преобразовать.
    • В поле "Таблица" введите имя таблицы, использовавшейся в R13 или R14, связи с которой нужно преобразовать.
    • В поле "Имя маршрута связи" введите имя маршрута связи, использовавшегося в R13 или R14, связи с которым нужно преобразовать.
  3. В группе "Новый формат связи" выполните все перечисленные ниже операции:
    • Выберите из списка "Источник данных" подходящий источник данных.
    • Выберите из списка "Каталог" подходящий каталог.
    • Выберите из списка "Схема" подходящую схему.
    • Выберите из списка "Таблица" подходящую таблицу.
    • Выберите из списка "Шаблон связи" подходящий шаблон связи.
  4. Нажмите "ОК".
  5. Откройте чертеж, связи которого необходимо преобразовать, и сохраните его.

    6. Примечание Среду, таблицу и имя маршрута связи требуется задавать при преобразовании связей с любыми базами данных. Каталог и схему нужно задавать только для тех баз данных, которые поддерживают их использование.


Для преобразования связей из формата Release 12 - Процедуры

Совместное использование данных в чертежах и приложениях
Внешние базы данных
Работа со связями в файлах предыдущих версий
Понятия
Процедуры
Команды

Для преобразования связей из формата Release 12

  1. Выберите "Базы данных" » "Преобразование связей."
  2. В группе "Прежний формат связи" выполните все перечисленные ниже операции:
    • Установите переключатель "Формат связи" в положение "R12".
    • В поле "СУБД" введите имя системы управления базами данных, использовавшейся в R12, связи с которой нужно преобразовать.
    • В поле "База данных" введите имя базы данных, использовавшейся в R12, связи с которой нужно преобразовать.
    • В поле "Таблица" введите имя таблицы базы данных, использовавшейся в R12, связи с которой нужно преобразовать.
  3. В группе "Новый формат связи" выполните все перечисленные ниже операции:
    • Выберите из списка "Источник данных" подходящий источник данных.
    • Выберите из списка "Каталог" подходящий каталог.
    • Выберите из списка "Схема" подходящую схему.
    • Выберите из списка "Таблица" подходящую таблицу.
    • Выберите из списка "Шаблон связи" подходящий шаблон связи.
  4. Нажмите "ОК".
  5. Откройте чертеж, связи которого необходимо преобразовать, и сохраните его.

    6. После задания таблицы преобразования связей при открытии и сохранении чертежей прежних версий в новом формате (AutoCAD 2000 и более поздние версии), все связи с источниками данных, описанными в данной таблице, преобразуются в связи нового формата.


Работа со связями в файлах предыдущих версий - Команды

Внешние базы данных
Внешние базы данных
Работа со связями в файлах предыдущих версий
Понятия
Процедуры
Команды

Команды
БДСВЯЗЬ | Интерфейс между программой и таблицами внешних баз данных
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Совместная работа над проектами

Защита чертежей и добавление цифровой подписи
Пароли и цифровые подписи можно использовать при совместной работе над проектом. Для открытия защищенного чертежа необходимо ввести пароль. При наличии подписи чертежа она однозначно определяет лицо или организацию с помощью цифрового удостоверения (сертификата).

Совместная работа с чертежами в Интернете
Пользователь может хранить чертежи AutoCAD и связанные с ними файлы в глобальной сети Интернет. Необходимо, чтобы на пользовательском компьютере был установлен Microsoft Internet Explorer 6.1 с пакетом обновления SP1 (или более поздняя версия) и существовал доступ в Интернет или корпоративную сеть.

Использование пометок для рецензирования проектов
На последних этапах работы над проектом чертежи обычно публикуются для итогового просмотра и последних исправлений. Замечания и комментарии могут быть размещены в электронной версии чертежа. На основании полученных комментариев проект дорабатывают, а публикацию исправленных чертежей повторяют. Такая работа с электронными пометками упрощает этап согласования, сокращает цикл разработки и в результате повышает эффективность процесса проектирования.


Совместная работа над проектами - Понятия

Совместная работа над проектами
Совместная работа над проектами
Совместная работа над проектами
Понятия
Процедуры
Команды

Защита чертежей и добавление цифровой подписи

Особое внимание в продукте уделяется безопасной отправке и получению данных, а также защите от несанкционированного изменения чертежей. Используя пароль, можно зашифровать содержимое чертежа. Цифровая подпись однозначно определяет лицо или организацию с помощью цифрового удостоверения (сертификата).

Совместная работа с чертежами в Интернете

С помощью AutoCAD можно получать и сохранять чертежи и связанные файлы в Интернете.

Использование пометок для рецензирования проектов

Использование электронных пометок для размещения комментариев и замечаний упрощает этап согласования, сокращает цикл разработки и, в результате, повышает эффективность процесса проектирования.


Совместная работа над проектами - Процедуры

Совместная работа над проектами
Совместная работа над проектами
Совместная работа над проектами
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Совместная работа над проектами - Команды

Совместная работа над проектами
Совместная работа над проектами
Совместная работа над проектами
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Защита чертежей и добавление цифровой подписи - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Понятия
Процедуры
Команды

Пароли и цифровые подписи можно использовать при совместной работе над проектом. Для открытия защищенного чертежа необходимо ввести пароль. При наличии подписи чертежа она однозначно определяет лицо или организацию с помощью цифрового удостоверения (сертификата).

Особое внимание в продукте уделяется безопасной отправке и получению данных, а также защите от несанкционированного изменения чертежей. Используя пароль, можно зашифровать содержимое чертежа. Цифровая подпись однозначно определяет лицо или организацию с помощью цифрового удостоверения (сертификата).

  • Шифрование чертежей
    Если чертеж снабжен паролем, последний шифрует чертеж и защищает его от просмотра посторонними лицами.
  • Добавление цифровой подписи к чертежам
    Цифровые подписи обеспечивают подлинность сообщений и безопасность их передачи. Пользователь может принимать участие в работе над коллективными проектами, обмениваясь файлами через Интернет, и быть уверенным в том, что содержимое отправленного файла абсолютно идентично содержимому файла, полученного адресатом.


Защита чертежей и добавление цифровой подписи - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Понятия
Процедуры
Команды

Для задания пароля в процессе работы над чертежом

Для задания пароля при сохранении чертежа

Для удаления пароля

Для выбора поставщика услуг шифрования чертежа и задания длины ключа

Для открытия файла чертежа, защищенного паролем

Для открытия чертежа, содержащего внешние ссылки с паролями

Для просмотра свойств чертежа, защищенного паролем

Для получения цифрового удостоверения через Интернет

Для включения опции автоматического добавления цифровой подписи после сохранения файла

Для добавления цифровых подписей к нескольким файлам

Для подтверждения допустимости цифровой подписи при открытии файла чертежа AutoCAD

Для подтверждения допустимости цифровой подписи файла чертежа с помощью значка "Проверка цифровых подписей"

Для подтверждения допустимости цифровой подписи в Проводнике

Для отыскания файлов с цифровой подписью в Проводнике

Для включения-отключения отображения значка цифровой подписи в Проводнике

Для отключения отображения свойств действительных цифровых подписей

Для получения корневого сертификата

Для выбора службы времени и ввода пояснений

Для добавления службы времени в список


Защита чертежей и добавление цифровой подписи - Команды

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Понятия
Процедуры
Команды
Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
ПДПРОВЕРИТЬ | Вывод информации о цифровой подписи файла
Системные переменные
SIGWARN | Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Шифрование чертежей - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Шифрование чертежей
Понятия
Процедуры
Команды

Если чертеж снабжен паролем, последний шифрует чертеж и защищает его от просмотра посторонними лицами.

  • Коротко о шифровании
    Шифрование на основе пароля позволяет предотвратить доступ посторонних лиц к данным чертежа при работе над совместными проектами. Шифрование особенно актуально при пересылке данных по линиям связи.
  • Защита чертежей шифрованием
    Если чертеж снабжают паролем и сохраняют, он шифруется и не может быть открыт без ввода пароля.
  • Открытие файлов чертежей, защищенных паролями
    Для просмотра информации чертежа, защищенного паролем, необходимо вначале получить и ввести пароль. При редактировании и сохранении чертежа пароль остается неизменным до его удаления или изменения.


Шифрование чертежей - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Шифрование чертежей
Понятия
Процедуры
Команды

Для задания пароля в процессе работы над чертежом

Для задания пароля при сохранении чертежа

Для удаления пароля

Для выбора поставщика услуг шифрования чертежа и задания длины ключа

Для открытия файла чертежа, защищенного паролем

Для открытия чертежа, содержащего внешние ссылки с паролями

Для просмотра свойств чертежа, защищенного паролем


Шифрование чертежей - Команды

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Шифрование чертежей
Понятия
Процедуры
Команды
Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о шифровании - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Коротко о шифровании
Понятия
Процедуры
Команды

Если чертеж снабжен паролем, последний шифрует чертеж и защищает его от просмотра посторонними лицами. Пользователь может выбирать способы шифрования. При совместной работе над проектом шифрование предотвращает доступ посторонних лиц к данным.

Пароли шифрования чертежей отличаются от других видов паролей, например от паролей функции формирования комплектов (eTransmit) тем, что здесь пользователь может выбирать способы шифрования.

Основная функция пароля – предотвращение хищения данных чертежа. Шифрование также позволяет обеспечить сохранность сведений, носящих конфиденциальный характер.

Например, проектная фирма, выполняющая дорогостоящий заказ для машиностроительного предприятия, может защитить паролем (или фразой) электронные чертежи, отсылаемые заказчику для просмотра. Парольная защита электронных документов может являться одной из многих мер защиты информации и правилом внутренней безопасности разработок.

Пароли работают только на файлах чертежей AutoCAD 2007® и более поздних версий (файлы DWG, DWS и DWT).

Примечание Если файл чертежа требуется и зашифровать, и добавить к нему цифровую подпись, то сначала нужно выполнить шифрование. Изменение файла, в том числе шифрованием, делает цифровую подпись недействительной.


Шифрование чертежей

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Шифрование чертежей
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Коротко о шифровании - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Коротко о шифровании
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Защита чертежей шифрованием - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Защита чертежей шифрованием
Понятия
Процедуры
Команды

Если чертеж снабжают паролем и сохраняют, он шифруется и не может быть открыт без ввода пароля.

Пароль может быть задан при редактировании чертежа или при его сохранении. Пароль задается для каждого файла, который требуется зашифровать, по отдельности.

Предупреждение Восстановление чертежа при утере пароля невозможно. Перед тем как защитить чертеж паролем, необходимо создать его резервную копию, не защищенную паролем.

  • Защита чертежа паролем
    Паролем может служить слово или фраза. В качестве пароля рекомендуется использовать несвязанный набор символов. Чем больше длина пароля, тем труднее его извлечь с помощью “программ-взломщиков”.
  • Выбор способа шифрования
    Можно выбирать способы шифрования для своих чертежей.


Защита чертежей шифрованием - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Защита чертежей шифрованием
Понятия
Процедуры
Команды

Для задания пароля в процессе работы над чертежом

Для задания пароля при сохранении чертежа

Для удаления пароля

Для выбора поставщика услуг шифрования чертежа и задания длины ключа


Защита чертежей шифрованием - Команды

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Защита чертежей шифрованием
Понятия
Процедуры
Команды
Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Защита чертежа паролем - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Защита чертежа паролем
Понятия
Процедуры
Команды

Паролем может служить слово или фраза. В качестве пароля рекомендуется использовать несвязанный набор символов. Чем больше длина пароля, тем труднее его извлечь с помощью “программ-взломщиков”.

Можно выбирать способ шифрования и длину ключа. Свойства чертежа также могут быть зашифрованы.

После ввода пароля и сохранения чертежа требуется ввод пароля, прежде чем какая-либо программа или ее часть сможет считать данные из чертежа, даже если чертеж является внешней ссылкой. Как правило, в сеансе работы с чертежом пароль требуется вводить только один раз.

Если свойства чертежа (поля "Автор", "Название", "Тема" и "Ключевые слова") зашифрованы, то для их просмотра также потребуется ввести пароль. Пароль запрашивается еще и при открытии зашифрованного чертежа с опцией просмотра образца. Число систем шифрования и длина ключа зависят от операционной системы, установленной на компьютере пользователя.

Примечание Настройки при задании пароля распространяются только на текущий чертеж.


Защита чертежа паролем - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Защита чертежа паролем
Понятия
Процедуры
Команды

Для задания пароля в процессе работы над чертежом

Для задания пароля при сохранении чертежа

Для удаления пароля


Для задания пароля в процессе работы над чертежом - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Защита чертежа паролем
Понятия
Процедуры
Команды

Для задания пароля в процессе работы над чертежом

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" нажмите "Безопасность".
  3. В диалоговом окне "Параметры безопасности" на вкладке "Пароль" введите пароль.
  4. Для защиты паролем таких свойств чертежа, как название, имя автора, тема и ключевые слова, нажмите "Шифровать свойства чертежа".
  5. Нажмите "ОК".
  6. В диалоговом окне "Подтверждение пароля" введите пароль еще раз. Нажмите "OK".

    7. Предупреждение В случае утери пароля его восстановление невозможно. Перед тем как защитить чертеж паролем, необходимо создать его резервную копию, не защищенную паролем.

Ввод команды: БЕЗОПНАСТР


Для задания пароля при сохранении чертежа - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Защита чертежа паролем
Понятия
Процедуры
Команды

Для задания пароля при сохранении чертежа

  1. Выберите "Файл" » "Сохранить как".
  2. В диалоговом окне "Сохранение чертежа" перед сохранением файла выберите в меню "Сервис" » "Параметры безопасности".
  3. В диалоговом окне "Параметры безопасности" на вкладке "Пароль" введите пароль.
  4. Для защиты паролем таких свойств чертежа, как название, имя автора, тема и ключевые слова, нажмите "Шифровать свойства чертежа".
  5. Нажмите "ОК".
  6. В диалоговом окне "Подтверждение пароля" введите пароль еще раз. Нажмите "OK".

    7. Предупреждение В случае утери пароля его восстановление невозможно. Перед тем как защитить чертеж паролем, необходимо создать его резервную копию, не защищенную паролем.

Ввод команды: БЕЗОПНАСТР


Для удаления пароля - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Защита чертежа паролем
Понятия
Процедуры
Команды

Для удаления пароля

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" нажмите "Безопасность".
  3. В диалоговом окне "Параметры безопасности" на вкладке "Пароль" снимите флажок "Для открытия этого чертежа необходимо ввести пароль (слово или фразу)".
  4. Нажмите "ОК".

Ввод команды: БЕЗОПНАСТР


Защита чертежа паролем - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Защита чертежа паролем
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор способа шифрования - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Выбор способа шифрования
Понятия
Процедуры
Команды

Можно выбирать способы шифрования для своих чертежей.

По умолчанию используется стандартный способ шифрования, обеспечиваемый операционной системой пользователя. Усовершенствованные алгоритмы шифрования RC4 можно выбрать из списка поставщиков услуг шифрования операционной системы. Можно также задать длину ключа (чем больше длина, тем выше степень защиты). Поставщики услуг шифрования используют стандартный алгоритм шифрования RC4 и различаются только предлагаемыми способами защиты.

Перед тем как использовать усовершенствованную систему шифрования (поставщик, способ и длина ключа), необходимо удостовериться в том, что на компьютере заказчика установлена такая же система. Подробную информацию о поставщиках услуг шифрования, системах и алгоритмах шифрования можно найти в Интернете.


Для выбора поставщика услуг шифрования чертежа и задания длины ключа - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Выбор способа шифрования
Понятия
Процедуры
Команды

Для выбора поставщика услуг шифрования чертежа и задания длины ключа

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" нажмите "Безопасность".
  3. В диалоговом окне "Параметры безопасности" на вкладке "Пароль" введите пароль или фразу, чтобы открыть чертеж. Нажмите "Дополнительные параметры".
  4. В диалоговом окне "Дополнительные параметры" выберите поставщика услуг шифрования, длину ключа или оба параметра. Нажмите "OK".
  5. Нажмите "ОК" в диалоговом окне "Параметры безопасности".

Ввод команды: БЕЗОПНАСТР


Выбор способа шифрования - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Выбор способа шифрования
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Открытие файлов чертежей, защищенных паролями - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Открытие файлов чертежей, защищенных паролями
Понятия
Процедуры
Команды

Для просмотра информации чертежа, защищенного паролем, необходимо вначале получить и ввести пароль. При редактировании и сохранении чертежа пароль остается неизменным до его удаления или изменения.

Защищенный паролем чертеж может содержать внешние ссылки на чертежи, которые также могут быть защищены паролями. При открытии чертежа, содержащего внешние ссылки, сначала запрашивается пароль для текущего чертежа. Затем запрашивается ввод паролей для всех внешних ссылок, пароли которых отличаются от пароля, введенного в ходе данного сеанса работы. Определенный пароль, относящийся к чертежу или внешней ссылке, требуется вводить один раз за сеанс.

Если данные в чертеже, защищенном паролем, считываются программой по какой-либо причине, необходимо ввести пароль как минимум один раз за сеанс использования программы.

Пароли файлов чертежей и внешних ссылок действуют до тех пор, пока не будут удалены. Удаление паролей может потребоваться, например, при пакетной обработке файлов (но не при добавлении цифровых подписей).

  • Ввод пароля при открытии чертежа
    Процедура открытия защищенного паролем файла ничем не отличается от стандартной, кроме дополнительного диалогового окна для ввода пароля. Для паролей использование регистров учитывается.
  • Открытие внешних ссылок, защищенных паролями
    Пользователь может открывать чертежи, которые содержат в себе внешние ссылки на чертежи, защищенные паролями.
  • Просмотр свойств чертежа, защищенного паролем
    Если при шифровании файла чертежа не была выбрана опция шифрования его свойств (поля "Автор", "Название", "Тема" и "Ключевые слова"), то они доступны для просмотра.


Открытие файлов чертежей, защищенных паролями - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Открытие файлов чертежей, защищенных паролями
Понятия
Процедуры
Команды

Для открытия файла чертежа, защищенного паролем

Для открытия чертежа, содержащего внешние ссылки с паролями

Для просмотра свойств чертежа, защищенного паролем


Открытие файлов чертежей, защищенных паролями - Команды

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Открытие файлов чертежей, защищенных паролями
Понятия
Процедуры
Команды
Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Ввод пароля при открытии чертежа - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Ввод пароля при открытии чертежа
Понятия
Процедуры
Команды

Процедура открытия защищенного паролем файла ничем не отличается от стандартной, кроме дополнительного диалогового окна для ввода пароля. Для паролей использование регистров учитывается.

Если при шифровании файла чертежа не была выбрана опция шифрования его свойств (поля "Автор", "Название", "Тема" и "Ключевые слова"), то они доступны для просмотра в диалоговом окне "Свойства" Проводника Microsoft® .


Для открытия файла чертежа, защищенного паролем - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Ввод пароля при открытии чертежа
Понятия
Процедуры
Команды

Для открытия файла чертежа, защищенного паролем

  1. Выберите меню "Файл" » "Открыть".
  2. В диалоговом окне "Выбор файла" выберите файл. Нажмите кнопку "Открыть".
  3. В диалоговом окне "Пароль" введите пароль.
  4. Нажмите "ОК".

Ввод команды: БЕЗОПНАСТР


Ввод пароля при открытии чертежа - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Ввод пароля при открытии чертежа
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Открытие внешних ссылок, защищенных паролями - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Открытие внешних ссылок, защищенных паролями
Понятия
Процедуры
Команды

Пользователь может открывать чертежи, которые содержат в себе внешние ссылки на чертежи, защищенные паролями.

В этом случае сначала запрашивается пароль на открытие чертежа, затем последовательно на все внешние ссылки, пароли которых отличаются от введенного в первую очередь.

Запрашиваются только те пароли, которые не были введены ни разу. Например, если во внешней ссылке и чертеже, доступ к которому осуществлялся в текущем сеансе программы (открытие чертежа или внешней ссылки), используется один и тот же пароль, повторный ввод этого пароля не требуется.


Для открытия чертежа, содержащего внешние ссылки с паролями - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Открытие внешних ссылок, защищенных паролями
Понятия
Процедуры
Команды

Для открытия чертежа, содержащего внешние ссылки с паролями

  1. Выберите меню "Файл" » "Открыть".
  2. В диалоговом окне "Выбор файла" выберите файл. Нажмите кнопку "Открыть".
  3. Если в диалоговом окне "Пароль" появился запрос на ввод пароля, введите необходимый пароль. Нажмите "OK".

Ввод команды: БЕЗОПНАСТР


Открытие внешних ссылок, защищенных паролями - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Открытие внешних ссылок, защищенных паролями
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Просмотр свойств чертежа, защищенного паролем - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Просмотр свойств чертежа, защищенного паролем
Понятия
Процедуры
Команды

Если при шифровании файла чертежа не была выбрана опция шифрования его свойств (поля "Автор", "Название", "Тема" и "Ключевые слова"), то они доступны для просмотра.

Если при шифровании файла чертежа не была выбрана опция шифрования его свойств, то их можно просмотреть с помощью диалогового окна "Свойства" операционной системы.


Для просмотра свойств чертежа, защищенного паролем - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Просмотр свойств чертежа, защищенного паролем
Понятия
Процедуры
Команды

Для просмотра свойств чертежа, защищенного паролем

  1. В Проводнике найдите файл, свойства которого требуется просмотреть.
  2. Нажмите правую кнопку мыши на имени файла. Нажать кнопку "Свойства".

Ввод команды: БЕЗОПНАСТР


Просмотр свойств чертежа, защищенного паролем - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Просмотр свойств чертежа, защищенного паролем
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление цифровой подписи к чертежам - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Добавление цифровой подписи к чертежам
Понятия
Процедуры
Команды

Цифровые подписи обеспечивают подлинность сообщений и безопасность их передачи. Пользователь может принимать участие в работе над коллективными проектами, обмениваясь файлами через Интернет, и быть уверенным в том, что содержимое отправленного файла абсолютно идентично содержимому файла, полученного адресатом.

  • Коротко о цифровых подписях
    Цифровые подписи делают работу над коллективными проектами более безопасной. Вместе с чертежами адресат получает достоверную информацию об их авторе, а также о внесении изменений в чертежи после добавления цифровой подписи.
  • Чертежи с цифровой подписью
    Получатели файлов с цифровой подписью могут быть уверены в неизменности файлов с момента их подписания. Любые вносимые изменения делают цифровую подпись недействительной.
  • Открытие файлов чертежей с цифровой подписью
    Вместе с файлами чертежей, имеющих цифровую подпись, отправляются электронные средства оценки (проверки подлинности) подписей.


Добавление цифровой подписи к чертежам - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Добавление цифровой подписи к чертежам
Понятия
Процедуры
Команды

Для получения цифрового удостоверения через Интернет

Для включения опции автоматического добавления цифровой подписи после сохранения файла

Для добавления цифровых подписей к нескольким файлам

Для подтверждения допустимости цифровой подписи при открытии файла чертежа AutoCAD

Для подтверждения допустимости цифровой подписи файла чертежа с помощью значка "Проверка цифровых подписей"

Для подтверждения допустимости цифровой подписи в Проводнике

Для отыскания файлов с цифровой подписью в Проводнике

Для включения-отключения отображения значка цифровой подписи в Проводнике

Для отключения отображения свойств действительных цифровых подписей

Для получения корневого сертификата

Для выбора службы времени и ввода пояснений

Для добавления службы времени в список


Добавление цифровой подписи к чертежам - Команды

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Добавление цифровой подписи к чертежам
Понятия
Процедуры
Команды
Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
ПДПРОВЕРИТЬ | Вывод информации о цифровой подписи файла
Системные переменные
SIGWARN | Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о цифровых подписях - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Коротко о цифровых подписях
Понятия
Процедуры
Команды

Цифровые подписи делают работу над коллективными проектами более безопасной. Вместе с чертежами адресат получает достоверную информацию об их авторе, а также о внесении изменений в чертежи после добавления цифровой подписи.

Цифровые подписи обладают следующими преимуществами:

  • Получатель файлов с цифровой подписью может быть уверен в том, что они пришли именно от заявленного отправителя (организации или лиц).
  • Цифровая подпись гарантирует неизменность файлов с момента их подписания.
  • Файл с цифровой подписью не может быть признан недействительным. Отправитель файла с цифровой подписью не может позднее отказаться от него под предлогом того, что подпись была подделана.

Цифровая подпись - это не оцифрованное изображение подписи. Цифровая подпись гарантирует подлинность и достоверность передаваемых данных, в то время как цифровое изображение подписи - это всего лишь отсканированная личная подпись. Она может быть подделана, размножена и не имеет ценности с точки зрения безопасности.

В цифровых удостоверениях используются два ключа - —открытый ключ, используемый любым пользователем для проверки цифровой подписи, и закрытый ключ, известный только владельцу цифрового удостоверения. Закрытый ключ используется для создания цифровой подписи. Подробную информацию о цифровых удостоверениях, цифровых подписях, открытых и закрытых ключах можно найти в Интернете.

Цифровую подпись можно добавить к файлам форматов AutoCAD 2000 и более поздних версий, включая файлы, созданные с помощью функции eTransmit. Для получения информации о добавлении цифровой подписи одновременно к нескольким файлам или к файлу чертежа, совместимому с форматом AutoCAD 2000 или более поздней версии, см. раздел Диалоговое окно "Добавление цифровых подписей" Справочника команд.

Примечание Добавленная к чертежу цифровая подпись может быть либо действительной, либо недействительной. Удалить цифровую подпись из файла чертежа невозможно. Если цифровая подпись была добавлена ошибочно, необходимо сохранить чертеж в формате DXF, затем открыть DXF-файл и сохранить его в DWG-формате.


Добавление цифровой подписи к чертежам

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Добавление цифровой подписи к чертежам
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Коротко о цифровых подписях - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Коротко о цифровых подписях
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
ПДПРОВЕРИТЬ | Вывод информации о цифровой подписи файла
Системные переменные
SIGWARN | Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Чертежи с цифровой подписью - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Чертежи с цифровой подписью
Понятия
Процедуры
Команды

Получатели файлов с цифровой подписью могут быть уверены в неизменности файлов с момента их подписания. Любые вносимые изменения делают цифровую подпись недействительной.

Для того чтобы отправлять файлы с цифровой подписью, необходимо получить цифровое удостоверение (сертификат). Цифровое удостоверение однозначно определяет лицо или организацию, подписавшую файл. Для получения дополнительной информации о цифровых удостоверениях выполните поиск в Интернете по ключевым словам “цифровое удостоверение. ”

Пользователь может включить опцию автоматического добавления цифровой подписи к чертежу при его сохранении. Существует возможность одновременного подписывания нескольких файлов, а также подписывания комплекта файлов, сформированного функцией eTransmit.

Примечание Для предотвращения изменения чертежа присоединение цифровой подписи к файлу чертежа автоматически устанавливает системную переменную FIELDEVAL в 0 (ручное обновление).

  • Получение цифрового удостоверения
    Для того чтобы отправлять файлы с цифровой подписью, необходимо получить цифровое удостоверение (сертификат). Цифровые удостоверения выдаются независимыми центрами сертификации. Существуют удостоверения для отдельных лиц и для организаций.
  • Добавление цифровой подписи к одному файлу
    Добавление цифровой подписи к файлу гарантирует, что получатели будут извещены о внесенных в файл изменениях.
  • Добавление цифровых подписей к нескольким файлам
    Добавление цифровой подписи к набору файлов гарантирует, что любой просматривающий файлы будет знать обо всех изменениях, внесенных в файлы, после того как они были подписаны.
  • Добавление цифровой подписи к зашифрованным чертежам
    Файл чертежа может быть одновременно и зашифрован с помощью пароля, и защищен цифровой подписью. Пароль добавляется в первую очередь


Чертежи с цифровой подписью - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Чертежи с цифровой подписью
Понятия
Процедуры
Команды

Для получения цифрового удостоверения через Интернет

Для включения опции автоматического добавления цифровой подписи после сохранения файла

Для добавления цифровых подписей к нескольким файлам


Чертежи с цифровой подписью - Команды

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Чертежи с цифровой подписью
Понятия
Процедуры
Команды
Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
ПДПРОВЕРИТЬ | Вывод информации о цифровой подписи файла
Системные переменные
SIGWARN | Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Получение цифрового удостоверения - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Получение цифрового удостоверения
Понятия
Процедуры
Команды

Для того чтобы отправлять файлы с цифровой подписью, необходимо получить цифровое удостоверение (сертификат). Цифровые удостоверения выдаются независимыми центрами сертификации. Существуют удостоверения для отдельных лиц и для организаций.

Цифровое удостоверение содержит имя, серийный номер, срок действия и другую информацию, подтверждающую цифровую подпись. От центра сертификации можно получить цифровые удостоверения, различающиеся по уровню безопасности: "Низкого", "Среднего" или "Высокого".

  • Низкий. Используется при необходимости быстрого добавления цифровой подписи к нескольким файлам. Цифровая подпись автоматически добавляется ко всем выбранным типам файлов.
  • Средний. Используется при необходимости уведомления о попытке создать приложением подпись с цифровым удостоверением пользователя. Таким образом, пользователь получает уведомления обо всех файлах с цифровыми подписями, использующих его цифровое удостоверение.
  • Высокий. Применяется при необходимости исключить возможность несанкционированного использования цифровой подписи пользователя. При подписывании каждого файла запрашивается ввод пароля.


Для получения цифрового удостоверения через Интернет - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Получение цифрового удостоверения
Понятия
Процедуры
Команды

Для получения цифрового удостоверения через Интернет

  1. Запустите Интернет-браузер, перейдите на страницу поисковой системы и наберите в строке поиска “цифровой сертификат. ”
  2. В результатах поиска можно найти подробную информацию о центрах сертификации и порядке получения цифрового удостоверения.

Ввод команды: БЕЗОПНАСТР


Получение цифрового удостоверения - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Получение цифрового удостоверения
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
ПДПРОВЕРИТЬ | Вывод информации о цифровой подписи файла
Системные переменные
SIGWARN | Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление цифровой подписи к одному файлу - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Добавление цифровой подписи к одному файлу
Понятия
Процедуры
Команды

Добавление цифровой подписи к файлу гарантирует, что получатели будут извещены о внесенных в файл изменениях.

Пользователь может включить опцию автоматического добавления цифровой подписи после сохранения файла. К одному файлу можно добавить только одну цифровую подпись.

Если несколько файлов чертежей требуется и зашифровать, и добавить к ним цифровую подпись, то сначала нужно выполнить шифрование, а затем пакетное добавление цифровой подписи. Любое изменение файла, в том числе при шифровании, делает цифровую подпись недействительной.

Примечание Утилита добавления цифровых подписей освобождает от необходимости проведения этой операции с каждым файлом по отдельности.


Для включения опции автоматического добавления цифровой подписи после сохранения файла - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Добавление цифровой подписи к одному файлу
Понятия
Процедуры
Команды

Для включения опции автоматического добавления цифровой подписи после сохранения файла

  1. Выполните одно из следующих действий:
    • Выберите "Сервис" » "Настройка". В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" нажмите "Безопасность".
    • Выберите "Файл" » "Сохранить как". В диалоговом окне "Сохранение чертежа" выберите "Сервис" » "Параметры безопасности".
  2. В диалоговом окне "Параметры безопасности" на вкладке "Цифровая подпись" установите флажок "Присоединить цифровую подпись после сохранения чертежа".
  3. Нажмите "ОК".

    4. Примечание В диалоговом окне "Параметры безопасности" можно добавлять цифровые подписи к файлам, совместимым с форматом чертежей AutoCAD 2007 и более поздних версий.

Ввод команды: БЕЗОПНАСТР


Добавление цифровой подписи к одному файлу - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Добавление цифровой подписи к одному файлу
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
ПДПРОВЕРИТЬ | Вывод информации о цифровой подписи файла
Системные переменные
SIGWARN | Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление цифровых подписей к нескольким файлам - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Добавление цифровых подписей к нескольким файлам
Понятия
Процедуры
Команды

Добавление цифровой подписи к набору файлов гарантирует, что любой просматривающий файлы будет знать обо всех изменениях, внесенных в файлы, после того как они были подписаны.

Цифровую подпись можно добавлять к файлам следующих типов:

  • EXE- и ZIP-файлы, полученные функцией формирования комплектов (eTransmit)
  • DWS-файлы
  • DWG- и DWT-файлы, совместимые с форматом чертежей AutoCAD 2000 и более поздних версий

При добавлении цифровой подписи к набору файлов можно выбирать файлы по одному в утилите добавления цифровой подписи или перетаскивать их в утилиту из окна Проводника.


Для добавления цифровых подписей к нескольким файлам - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Добавление цифровых подписей к нескольким файлам
Понятия
Процедуры
Команды

Для добавления цифровых подписей к нескольким файлам

  1. Выберите в меню "Пуск" (Windows), » "Все программы" » Autodesk » AutoCAD 2007 » "Добавление цифровых подписей".
  2. В диалоговом окне "Добавление цифровых подписей" нажмите кнопку "Добавить".
  3. В диалоговом окне "Выбор файлов" выберите файлы, к которым необходимо добавить цифровую подпись. Нажмите кнопку "Открыть".

    4. Примечание В диалоговом окне "Добавление цифровых подписей" можно добавить цифровые подписи к файлам, совместимым с форматами чертежей AutoCAD 2000 и более поздних версий.

  4. В диалоговом окне "Добавление цифровых подписей" в поле "Имеющиеся сертификаты" выберите цифровое удостоверение, которое необходимо добавить к файлам, выбранным в списке "Список файлов".
  5. В списке "Источник для отметки времени" выберите службу времени, если необходимо добавить штемпель времени к подписываемым файлам. Если отметка времени не требуется, используйте значение по умолчанию - "Без отметки времени".
  6. В поле "Пояснение" можно добавить текстовые комментарии для файлов, к которым добавляется цифровая подпись.
  7. Нажмите кнопку "Добавить подпись".
  8. Если выбранный файл имеет атрибут "только чтение", появляется диалоговое окно с соответствующим запросом. Выполните одно из следующих действий:
    • Для добавления цифровой подписи в диалоговом окне нажмите "Да".
    • Чтобы подписать все файлы с атрибутом "только чтение", выберите параметр "Применить для всех таких файлов в данном списке". Нажмите "Да".
    • Для отказа от добавления цифровой подписи к файлу с атрибутом "только чтение" нажмите "Нет".
    • Для отказа от добавления цифровой подписи ко всем файлам с атрибутом "только чтение" нажмите "Отмена".

    Примечание Если при получении цифрового сертификата установлен средний или высокий уровень безопасности, то при добавлении цифровой подписи к каждому файлу выдается информационное сообщение.

  9. После добавления цифровой подписи ко всем файлам выдается сообщение с числом подписанных файлов. Нажмите "ОК".

    10. В группе "Список файлов" подписанные файлы приобретают статус “Подписано”.

  10. Нажмите кнопку "Закрыть".

Примечание Подписанные файлы приобретают атрибут "только чтение" для защиты от случайного изменения.


Добавление цифровых подписей к нескольким файлам - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Добавление цифровых подписей к нескольким файлам
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
ПДПРОВЕРИТЬ | Вывод информации о цифровой подписи файла
Системные переменные
SIGWARN | Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление цифровой подписи к зашифрованным чертежам - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Добавление цифровой подписи к зашифрованным чертежам
Понятия
Процедуры
Команды

Файл чертежа может быть одновременно и зашифрован с помощью пароля, и защищен цифровой подписью. Пароль добавляется в первую очередь

Изменение файла, в том числе шифрованием, делает цифровую подпись недействительной.


Чертежи с цифровой подписью

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Чертежи с цифровой подписью
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Добавление цифровой подписи к зашифрованным чертежам - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Добавление цифровой подписи к зашифрованным чертежам
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
ПДПРОВЕРИТЬ | Вывод информации о цифровой подписи файла
Системные переменные
SIGWARN | Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Открытие файлов чертежей с цифровой подписью - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Открытие файлов чертежей с цифровой подписью
Понятия
Процедуры
Команды

Вместе с файлами чертежей, имеющих цифровую подпись, отправляются электронные средства оценки (проверки подлинности) подписей.

Цифровая подпись однозначно определяет лицо или организацию с помощью цифрового удостоверения (сертификата) и позволяет подтвердить неизменность файла. Подписывание файлов особенно актуально при пересылке данных по линиям связи. Цифровая подпись позволяет предотвратить доступ посторонних лиц к данным при работе над совместными проектами. Цифровую подпись можно проверить или в программе, или в Проводнике.

Цифровая подпись содержит следующие сведения о подписанном файле:

  • Изменялся ли чертеж после добавления подписи.
  • Сведения о подлинности подписи.
  • Сведения о пользователе, подписавшем файл.

Цифровую подпись считают недействительной в следующих случаях:

  • При добавлении цифровой подписи файл был поврежден.
  • Файл был поврежден при пересылке.
  • Срок действия цифрового удостоверения истек.

Примечание Для сохранения действительности цифровой подписи не следует изменять или шифровать файлы, имеющие цифровую подпись. Вносить изменения, а также шифровать файлы необходимо до добавления цифровой подписи. Свойства цифровой подписи изменяются при редактировании, сохранении или экспорте данных чертежа.

  • Просмотр свойств цифровой подписи
    Получив файл с цифровой подписью, пользователь может проверить, вносились ли в файл изменения с момента его подписания, и просмотреть другую информацию.
  • Установка корневого сертификата
    При получении из центра сертификации файла с цифровой подписью, которая не распознается операционной системой, может потребоваться установка корневого сертификата (наивысший сертификат в иерархии сертификации).
  • Использование пояснений и штемпеля времени в цифровых подписях
    Пользователь может добавить пояснения и отметку (штемпель) времени к цифровой подписи.


Открытие файлов чертежей с цифровой подписью - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Открытие файлов чертежей с цифровой подписью
Понятия
Процедуры
Команды

Для подтверждения допустимости цифровой подписи при открытии файла чертежа AutoCAD

Для подтверждения допустимости цифровой подписи файла чертежа с помощью значка "Проверка цифровых подписей"

Для подтверждения допустимости цифровой подписи в Проводнике

Для отыскания файлов с цифровой подписью в Проводнике

Для включения-отключения отображения значка цифровой подписи в Проводнике

Для отключения отображения свойств действительных цифровых подписей

Для получения корневого сертификата

Для выбора службы времени и ввода пояснений

Для добавления службы времени в список


Открытие файлов чертежей с цифровой подписью - Команды

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Открытие файлов чертежей с цифровой подписью
Понятия
Процедуры
Команды
Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
ПДПРОВЕРИТЬ | Вывод информации о цифровой подписи файла
Системные переменные
SIGWARN | Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Просмотр свойств цифровой подписи - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Просмотр свойств цифровой подписи
Понятия
Процедуры
Команды

Получив файл с цифровой подписью, пользователь может проверить, вносились ли в файл изменения с момента его подписания, и просмотреть другую информацию.

Если файл содержит данные о цифровой подписи, в строке состояния программы отображается соответствующий значок. Нажав на значке, можно извлечь следующую информацию:

  • Действительность цифровой подписи
  • Были ли изменения в чертеже после добавления подписи.
  • Сведения об организации или разработчике, подписавшем файл
  • Дату и время подписи, а также пояснения к файлу.
  • Сведения о центре сертификации.
  • Даты “действительно до” и “действительно с” для цифрового удостоверения

Цифровые подписи работают с файлами, совместимыми с форматами чертежей AutoCAD 2000 и более поздних версий. Если пользователь сохраняет файл, полученный с цифровой подписью, то считается, что файл изменен, и цифровая подпись становится недействительной. Информация о цифровой подписи при этом не теряется и может быть просмотрена. При получении и сохранении подписанного файла чертежа сведения о подписи могут быть утеряны.

Примечание Если значение системной переменной SIGWARN равно 1, то при открытии файла с цифровой подписью отображаются свойства цифровой подписи. Если системная переменная SIGWARN приравнена к нулю и выполняется открытие файла, состояние цифровой подписи отображается только если она недействительна.

Также для проверки и подтверждения допустимости цифровой подписи можно просматривать свойства файла чертежа в Проводнике. Некоторые операционные системы модифицируют значки файлов, имеющих действительную цифровую подпись. Отображение такого значка может привести к некоторому снижению производительности системы (в зависимости от тактовой частоты процессора и размера файла), поэтому данную функцию можно отключить.


Просмотр свойств цифровой подписи - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Просмотр свойств цифровой подписи
Понятия
Процедуры
Команды

Для подтверждения допустимости цифровой подписи при открытии файла чертежа AutoCAD

Для подтверждения допустимости цифровой подписи файла чертежа с помощью значка "Проверка цифровых подписей"

Для подтверждения допустимости цифровой подписи в Проводнике

Для отыскания файлов с цифровой подписью в Проводнике

Для включения-отключения отображения значка цифровой подписи в Проводнике

Для отключения отображения свойств действительных цифровых подписей


Для подтверждения допустимости цифровой подписи при открытии файла чертежа AutoCAD - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Просмотр свойств цифровой подписи
Понятия
Процедуры
Команды

Для подтверждения допустимости цифровой подписи при открытии файла чертежа AutoCAD

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/сохранение" установите флажок "Отображать информацию о цифровой подписи".
  3. Нажмите "ОК".
  4. Откройте подписанный файл.

    5. В раскрывающемся списке "Другие поля" диалогового окна "Свойства цифровой подписи" пользователь может выбирать и просматривать интересующие его сведения о цифровой подписи, например даты начала и прекращения действия цифрового удостоверения и серийный номер.

  5. Нажмите кнопку "Закрыть".

Ввод команды: ПДПРОВЕРИТЬ


Для подтверждения допустимости цифровой подписи файла чертежа с помощью значка "Проверка цифровых подписей" - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Просмотр свойств цифровой подписи
Понятия
Процедуры
Команды

Для подтверждения допустимости цифровой подписи файла чертежа с помощью значка "Проверка цифровых подписей"

  1. Откройте подписанный файл.
  2. В строке состояния программы нажмите значок "Проверка цифровых подписей".
  3. Если цифровая подпись файла действительна, в диалоговом окне "Проверка цифровых подписей" нажмите кнопку "Основная подпись".

    4. Диалоговое окно "Свойства цифровой подписи" содержит подробные сведения о цифровой подписи, такие как подписавшийся, дату окончания действия цифрового удостоверения, серийный номер, пояснения к цифровой подписи, временной штемпель и службу времени.

  4. Нажмите кнопку "Закрыть".
  5. Если файл содержит внешние ссылки с цифровой подписью, в диалоговом окне "Проверка цифровых подписей" выберите параметр "Просмотр чертежей внешних ссылок". Для просмотра внешних ссылок, связанных с файлом, нажмите кнопку "Подписи в ссылках".
  6. Нажмите кнопку "Закрыть".

Ввод команды: ПДПРОВЕРИТЬ


Для подтверждения допустимости цифровой подписи в Проводнике - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Просмотр свойств цифровой подписи
Понятия
Процедуры
Команды

Для подтверждения допустимости цифровой подписи в Проводнике

  1. В Проводнике найдите файл, цифровую подпись которого требуется проверить.

    2. Некоторые операционные системы модифицируют значки файлов, имеющих действительную цифровую подпись.

  2. Нажмите правую кнопку мыши на имени файла. Нажмите кнопку "Свойства".
  3. При наличии у файла цифровой подписи в диалоговом окне "Свойства" отображается вкладка "Цифровая подпись". На вкладке "Цифровая подпись" содержатся сведения о цифровой подписи.

    4. Если цифровая подпись действительна, отображается значок действительной цифровой подписи. Для недействительной цифровой подписи отображается значок недействительной цифровой подписи.

  4. В раскрывающемся списке "Другие поля" свойств цифровой подписи пользователь может выбирать и просматривать интересующие его сведения о цифровой подписи, например сведения о центре сертификации, описание и дату прекращения действия цифрового удостоверения. Также можно просматривать временной штемпель и сведения о службе времени.
  5. Для закрытия окна с информацией о цифровой подписи нажмите "ОК".


Для отыскания файлов с цифровой подписью в Проводнике - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Просмотр свойств цифровой подписи
Понятия
Процедуры
Команды

Для отыскания файлов с цифровой подписью в Проводнике

  • В Проводнике найдите файл, цифровую подпись которого требуется проверить. Для файлов с цифровой подписью отображается соответствующий значок.


Для включения-отключения отображения значка цифровой подписи в Проводнике - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Просмотр свойств цифровой подписи
Понятия
Процедуры
Команды

Для включения-отключения отображения значка цифровой подписи в Проводнике

  1. В Проводнике найдите файл, у которого имеется значок цифровой подписи.
  2. Нажмите правую кнопку мыши на имени файла. Выберите "Включение и отключение значков цифровых подписей".
  3. Установите или снимите флажок параметра "Проверять цифровые подписи и отображать специальные значки" для, соответственно, включения или отключения отображения значка в Проводнике.
  4. Нажмите "ОК". Выйдите, а затем снова войдите в Windows.


Для отключения отображения свойств действительных цифровых подписей - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Просмотр свойств цифровой подписи
Понятия
Процедуры
Команды

Для отключения отображения свойств действительных цифровых подписей

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/сохранение" снимите флажок "Отображать информацию о цифровой подписи".
  3. Нажмите "ОК".

Ввод команды: SIGWARN


Просмотр свойств цифровой подписи - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Просмотр свойств цифровой подписи
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
ПДПРОВЕРИТЬ | Вывод информации о цифровой подписи файла
Системные переменные
SIGWARN | Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Установка корневого сертификата - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Установка корневого сертификата
Понятия
Процедуры
Команды

При получении из центра сертификации файла с цифровой подписью, которая не распознается операционной системой, может потребоваться установка корневого сертификата (наивысший сертификат в иерархии сертификации).

Работа цифровых удостоверений основана на принципе доверительной иерархии. Корневой сертификат - это сертификат, выданный и подписанный одним и тем же центром сертификации. Распространенные браузеры, например Microsoft Internet Explorer, содержат корневые сертификаты основных их распространителей, что автоматически удостоверяет соответствующие цифровые удостоверения.

При получении файла, подписанного цифровым удостоверением, выданным, например службой информационных технологий вашей организации, становится невозможно проверить цифровое удостоверение и может потребоваться установка корневого сертификата.


Для получения корневого сертификата - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Установка корневого сертификата
Понятия
Процедуры
Команды

Для получения корневого сертификата

  1. Для получения корневого сертификата обратитесь в организацию или к пользователю, добавившему цифровую подпись к данному файлу.
  2. При получении корневого сертификата нажмите "Пуск" (Windows) » "Настройка" » "Панель управления" » "Свойства обозревателя".
  3. В диалоговом окне "Свойства Интернета" на вкладке "Содержимое" выберите "Сертификаты".
  4. В окне "Сертификаты" нажмите кнопку "Импорт" для вызова Мастера импорта сертификатов.
  5. Для получения корневого сертификата следуйте экранным подсказкам Мастера импорта сертификатов.


Установка корневого сертификата - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Установка корневого сертификата
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
ПДПРОВЕРИТЬ | Вывод информации о цифровой подписи файла
Системные переменные
SIGWARN | Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование пояснений и штемпеля времени в цифровых подписях - Понятия

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Использование пояснений и штемпеля времени в цифровых подписях
Понятия
Процедуры
Команды

Пользователь может добавить пояснения и отметку (штемпель) времени к цифровой подписи.

Серверы времени позволяют добавить отметку времени. При пересылке файлов чертежей через Интернет или в процессе разработки совместного проекта можно выбрать определенную службу времени для добавления точного и непротиворечивого штемпеля времени.

Существуют правительственные (например, National Institute of Standards and Technology или the US Naval Observatory) и общедоступные (California Institute of Technology) службы точного времени. Можно также воспользоваться собственной службой для создания штемпеля времени.


Использование пояснений и штемпеля времени в цифровых подписях - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Использование пояснений и штемпеля времени в цифровых подписях
Понятия
Процедуры
Команды

Для выбора службы времени и ввода пояснений

Для добавления службы времени в список


Для выбора службы времени и ввода пояснений - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Использование пояснений и штемпеля времени в цифровых подписях
Понятия
Процедуры
Команды

Для выбора службы времени и ввода пояснений

  1. Выполните одно из следующих действий:
    • Выберите "Сервис" » "Настройка". В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" нажмите "Безопасность".
    • Выберите "Файл" » "Сохранить как". В диалоговом окне "Сохранение чертежа" выберите "Сервис" » "Параметры безопасности".
  2. В диалоговом окне "Параметры безопасности" на вкладке "Цифровая подпись" установите флажок "Присоединить цифровую подпись после сохранения чертежа".
  3. В выпадающем списке "Источник для отметки времени" выберите службу времени.
  4. В поле "Пояснение" введите необходимые пояснения.
  5. Нажмите "ОК".

Ввод команды: БЕЗОПНАСТР


Для добавления службы времени в список - Процедуры

Совместная работа над проектами
Защита чертежей и добавление цифровой подписи
Использование пояснений и штемпеля времени в цифровых подписях
Понятия
Процедуры
Команды

Для добавления службы времени в список

  1. Найдите и откройте файл timesrvr.txt.

    2. В файле timesrvr.txt содержатся данные о службах времени.

  2. Добавьте требующуюся службу времени в файл timesrvr.txt. Используйте следующий формат:

    3. Описание (адрес службы)

    Например:

    National Institute of Standards and Technology (time.nist.gov)

  3. Сохраните файл.

Примечание Чтобы вместо файла timesrvr.txt для задания параметров служб времени использовать другой файл, следует изменить значение переменной среды ADSKSIGTIMESRVR. Например, измените значение переменной на c:\temp\mytimelist.txt.

Ввод команды: БЕЗОПНАСТР


Использование пояснений и штемпеля времени в цифровых подписях - Команды

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Использование пояснений и штемпеля времени в цифровых подписях
Понятия
Процедуры
Команды

Команды
БЕЗОПНАСТР | Задание параметров безопасности в диалоговом окне "Параметры безопасности"
ПДПРОВЕРИТЬ | Вывод информации о цифровой подписи файла
Системные переменные
SIGWARN | Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Совместная работа с чертежами в Интернете - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Понятия
Процедуры
Команды

Пользователь может хранить чертежи AutoCAD и связанные с ними файлы в глобальной сети Интернет. Необходимо, чтобы на пользовательском компьютере был установлен Microsoft Internet Explorer 6.1 с пакетом обновления SP1 (или более поздняя версия) и существовал доступ в Интернет или корпоративную сеть.

Пользователь может хранить чертежи AutoCAD и связанные с ними файлы в глобальной сети Интернет. Необходимо, чтобы на пользовательском компьютере был установлен Microsoft Internet Explorer 6.1 с пакетом обновления SP1 (или более поздняя версия) и существовал доступ в Интернет или корпоративную сеть.

  • Основные принципы
    Для того, чтобы воспользоваться Интернет-средствами продукта, необходимо иметь доступ к Интернету или корпоративной сети и установить в системе Microsoft Internet Explorer 6.1 с пакетом обновления SP1 (или более поздней версии).
  • Добавление гиперссылок в чертеж
    Можно добавлять гиперссылки в чертежи - это указатели переходов на логически связанные файлы или веб-сайты.
  • Работа с чертежами в Интернете
    Имеется возможность открывать чертежи с сетевых серверов, сохранять их там, вставлять блоки путем перетаскивания чертежей с сайтов, вставлять в чертежи гиперссылки, а также создавать комплекты, объединяющие в себе чертежи и все связанные с ними файлы.
  • Создание веб-страниц с помощью Мастера публикации в Интернете
    Создание DWF-файлов и форматирование их для вывода в HTML-страницах значительно упрощается при использовании Мастера публикации в Интернете.


Совместная работа с чертежами в Интернете - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Понятия
Процедуры
Команды

Для создания абсолютной гиперссылки на другой файл

Для создания гиперссылки на именованную позицию в файле другого приложения (не AutoCAD)

Для редактирования гиперссылки, подключенной к графическому объекту

Для удаления гиперссылки из графического объекта

Для открытия файла, на который указывает гиперссылка

Для включения и отключения курсора на гиперссылках

Для задания пути, используемого для всех относительных гиперссылок в чертеже

Для создания относительной гиперссылки

Для создания гиперссылки на сообщение электронной почты

Для открытия файла, на который указывает гиперссылка внутри блока

Для создания нового чертежа на основе DWT-файла гиперссылки

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

Для открытия файла AutoCAD из Интернета с выбором в веб-папке

Для сохранения файла AutoCAD в Интернете с заданием сетевого адреса (URL)

Для сохранения чертежа AutoCAD в Интернете на FTP-сервере

Для сохранения файла AutoCAD в Интернете с выбором в веб-папке

Для задания начальной страницы диалогового окна "Поиск в Web"

Для открытия файла AutoCAD из Интернета с помощью диалогового окна "Поиск в Web"

Для сохранения чертежа AutoCAD в Интернете с помощью диалогового окна "Поиск в Web"

Для доступа к веб-сайту Buzzsaw в первый раз

Для доступа к веб-сайту Buzzsaw

Для добавления ярлыка папки Buzzsaw

Для переименования ярлыка папки Buzzsaw

Для изменения ярлыка папки Buzzsaw

Для удаления ярлыка папки Buzzsaw

Для сохранения файла, открытого на веб-сайте Buzzsaw, на другом веб-сайте Buzzsaw

Для сохранения файла, открытого в другой папке, на веб-сайте Buzzsaw

Для отправки набора комплектов на веб-узел Buzzsaw

Для отправки набора комплектов Buzzsaw из "Диспетчера подшивок"

Для публикации файла на веб-сайте Buzzsaw

Для публикации подшивки на веб-сайте Buzzsaw

Для вставки в чертеж внешней ссылки из Интернета

Для вставки компонента из i-drop в чертеж

Для настройки параметров вставки из i-drop

Для задания типа i-drop по умолчанию

Для просмотра файла журнала

Для просмотра адреса гиперссылки содержимого i-drop

Для формирования комплекта файлов в заданной папке

Для формирования комплекта файлов в самораспаковывающемся EXE-файле или ZIP-файле

Для создания комплекта файлов на основе подшивки

Для распаковки самораспаковывающегося комплекта файлов

Для использования Мастера публикации


Совместная работа с чертежами в Интернете - Команды

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Понятия
Процедуры
Команды
Команды
GOTOURL | Открывает файл или web-страницу, ассоциированную с гиперссылкой, прикрепленной к объекту
АРХИВАЦИЯ | Упаковывает файлы текущей подшивки для архивирования
БРАУЗЕР | Запускает обозреватель Интернета по умолчанию, указанный в системном реестре
ГИПЕРСВОЙСТВА | Управляет отображением курсора, подсказок и контекстного меню для гиперссылок
ГИПЕРССЫЛКА | Создание гиперссылки для объекта или изменение существующей гиперссылки
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ОПУБЛИКОВАТЬ | Создание HTML-страниц с изображениями выбранных чертежей
ОТКРЫТЬ | Открытие существующего файла чертежа
СВОЙСТВАРИС | Задание и просмотр свойств текущего чертежа
ТЗАГРТИП | Задание типа точки загрузки (i-drop) по умолчанию для текущего приложения Autodesk
УРЛРАЗОРВАТЬ | Удаление гиперссылок в чертеже
УРЛСВЯЗАТЬ | Создает гиперссылки для объектов или областей чертежа
ФОРМКОМПЛЕКТ | Формирование комплекта файлов для передачи другим пользователям через Интернет
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
HYPERLINKBASE | Указывает путь, используемый для всех относительных гиперссылок в чертеже
INETLOCATION | Сохраняет адрес Интернета, используемый в команде БРАУЗЕР и в диалоговом окне "Просмотр Web"
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Основные принципы - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Основные принципы
Понятия
Процедуры
Команды

Чтобы воспользоваться Интернет-средствами с помощью этой программы, необходимо иметь доступ к Интернету или интрасети и установить в системе Microsoft Internet Explorer 6.1 с пакетом обновления SP1 (или более поздней версии). Здесь и далее термин Интернет будет использоваться для обозначения как глобальной, так и корпоративной сети. Для того, чтобы сохранять файлы в Интернете, нужны соответствующие права доступа к сетевой папке. Их можно получить у администратора сети или у поставщика Интернет-услуг (провайдера).

Если подключение к Интернету осуществляется через локальную сеть организации, возможно, потребуется конфигурация прокси-сервера. Прокси-серверы выступают в роли барьеров, ограждающих рабочие станции сети от опасности несанкционированного вторжения извне и порчи данных. О том, как настроить систему на работу через прокси-сервер, можно узнать в справочной системе по Windows® (Панель управления, элемент "Интернет") или у администратора сети.


Совместная работа с чертежами в Интернете

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Основные принципы - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Основные принципы
Понятия
Процедуры
Команды

Команды
БРАУЗЕР | Запускает обозреватель Интернета по умолчанию, указанный в системном реестре
ГИПЕРССЫЛКА | Создание гиперссылки для объекта или изменение существующей гиперссылки
Системные переменные
HYPERLINKBASE | Указывает путь, используемый для всех относительных гиперссылок в чертеже
INETLOCATION | Сохраняет адрес Интернета, используемый в команде БРАУЗЕР и в диалоговом окне "Просмотр Web"
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление гиперссылок в чертеж - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Добавление гиперссылок в чертеж
Понятия
Процедуры
Команды

Можно добавлять гиперссылки в чертежи - это указатели переходов на логически связанные файлы или веб-сайты.

  • Основные понятия использования гиперссылок в чертежах
    Использование гиперссылок - это удобный способ связывания с чертежом дополнительных документов: других чертежей, спецификаций, организационных планов.
  • Использование гиперссылок для доступа к файлам и веб-страницам
    Гиперссылки могут указывать на файлы, хранящиеся на диске компьютера, в локальной сети и в Интернете или на именованные места в чертежах, такие как виды.
  • Гиперссылки для создания сообщений электронной почты
    Обычно гиперссылки используются для подключения к графическим объектам логически связанных документов. Но в некоторых случаях бывает необходимо, чтобы при выборе гиперссылки создавалось сообщение электронной почты.
  • Гиперссылки в блоках
    Гиперссылки можно подключать к блокам и даже к объектам, заключенным в блоки. Все относительные гиперссылки, заданные для объектов блока, после вставки начинают опираться на базовый путь текущего чертежа.
  • Использование гиперссылок для создания новых чертежей
    При активизации гиперссылки, указывающей на DWT-файл шаблона чертежа, программа не открывает файл шаблона, а создает вместо этого новый чертеж, использующий указанный шаблон как основу.


Добавление гиперссылок в чертеж - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Добавление гиперссылок в чертеж
Понятия
Процедуры
Команды

Для создания абсолютной гиперссылки на другой файл

Для создания гиперссылки на именованную позицию в файле другого приложения (не AutoCAD)

Для редактирования гиперссылки, подключенной к графическому объекту

Для удаления гиперссылки из графического объекта

Для открытия файла, на который указывает гиперссылка

Для включения и отключения курсора на гиперссылках

Для задания пути, используемого для всех относительных гиперссылок в чертеже

Для создания относительной гиперссылки

Для создания гиперссылки на сообщение электронной почты

Для открытия файла, на который указывает гиперссылка внутри блока

Для создания нового чертежа на основе DWT-файла гиперссылки


Добавление гиперссылок в чертеж - Команды

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Добавление гиперссылок в чертеж
Понятия
Процедуры
Команды
Команды
GOTOURL | Открывает файл или web-страницу, ассоциированную с гиперссылкой, прикрепленной к объекту
ГИПЕРСВОЙСТВА | Управляет отображением курсора, подсказок и контекстного меню для гиперссылок
ГИПЕРССЫЛКА | Создание гиперссылки для объекта или изменение существующей гиперссылки
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
СВОЙСТВАРИС | Задание и просмотр свойств текущего чертежа
УРЛРАЗОРВАТЬ | Удаление гиперссылок в чертеже
УРЛСВЯЗАТЬ | Создает гиперссылки для объектов или областей чертежа
Системные переменные
HYPERLINKBASE | Указывает путь, используемый для всех относительных гиперссылок в чертеже
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Основные понятия использования гиперссылок в чертежах - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Основные понятия использования гиперссылок в чертежах
Понятия
Процедуры
Команды

Использование гиперссылок - это удобный способ связывания с чертежом дополнительных документов: других чертежей, спецификаций, организационных планов.

Гиперссылки в чертежах - это указатели переходов на логически связанные файлы. При выборе гиперссылки, например, может выполняться вызов текстового процессора с загрузкой в него указанного файла, или же активизация веб-браузера и переход в нем на заданный сайт в Интернете. Открываемый файл может быть сразу установлен на именованную позицию (вид в файле чертежа или закладка в программе текстового редактора). Гиперссылки разрешается подключать к любым графическим объектам чертежей AutoCAD. Использование гиперссылок - это удобный способ связывания с чертежом AutoCAD дополнительных документов: других чертежей, спецификаций, организационных планов.

В чертежах можно создавать как абсолютные, так и относительные гиперссылки. Абсолютные гиперссылки хранят полный путь к вызываемому файлу, а относительные только часть пути, которая отсчитывается от некоторого стандартного адреса или от папки, указанной в системной переменной HYPERLINKBASE.


Добавление гиперссылок в чертеж

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Добавление гиперссылок в чертеж
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Основные понятия использования гиперссылок в чертежах - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Основные понятия использования гиперссылок в чертежах
Понятия
Процедуры
Команды

Команды
GOTOURL | Открывает файл или web-страницу, ассоциированную с гиперссылкой, прикрепленной к объекту
ГИПЕРССЫЛКА | Создание гиперссылки для объекта или изменение существующей гиперссылки
УРЛРАЗОРВАТЬ | Удаление гиперссылок в чертеже
УРЛСВЯЗАТЬ | Создает гиперссылки для объектов или областей чертежа
Системные переменные
HYPERLINKBASE | Указывает путь, используемый для всех относительных гиперссылок в чертеже
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование гиперссылок для доступа к файлам и веб-страницам - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование гиперссылок для доступа к файлам и веб-страницам
Понятия
Процедуры
Команды

Гиперссылки могут указывать на файлы, хранящиеся на диске компьютера, в локальной сети и в Интернете или на именованные места в чертежах, такие как виды.

По умолчанию, когда перекрестье курсора располагается над объектом, к которому прикреплена гиперссылка, возникает курсор гиперссылки и всплывающая подсказка. Для перехода по ссылке следует нажать клавишу CTRL и затем нажать на данной ссылке (CTRL + щелчок).

Примечание Для открытия файлов, связанных с гиперссылками, системная переменная PICKFIRST должна иметь значение 1. Отключить курсор гиперссылки, всплывающие подсказки и контекстное меню можно в диалоговом окне "Настройка" на вкладке "Пользовательские".

Если была создана гиперссылка в чертеже и определен именованный вид, куда должен осуществляться переход, то открытие гиперссылки приводит к восстановлению данного вида. Можно также создать гиперссылку, которая открывает чертеж в определенном расположении.

Использование относительных и абсолютных путей в гиперссылках

Относительные пути обладают большей гибкостью и проще в редактировании, чем абсолютные гиперссылки. В случае, если вся структура файлов перемещена в другую папку, для обновления относительных гиперссылок достаточно всего одной операции.

Абсолютные гиперссылки следует создавать, когда необходимо установить связь с документом, который не находится в том же файле или чей относительный путь неизвестен. Например, абсолютная гиперссылка нужна для связи с чертежом, который находится на другом диске в сети. Любое перемещение файлов, на которые указывают абсолютные гиперссылки, в другие папки приводит к необходимости исправления всех гиперссылок. Чем больше их в чертеже, тем больше времени на это тратится.


Использование гиперссылок для доступа к файлам и веб-страницам - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование гиперссылок для доступа к файлам и веб-страницам
Понятия
Процедуры
Команды

Для создания абсолютной гиперссылки на другой файл

Для создания гиперссылки на именованную позицию в файле другого приложения (не AutoCAD)

Для редактирования гиперссылки, подключенной к графическому объекту

Для удаления гиперссылки из графического объекта

Для открытия файла, на который указывает гиперссылка

Для включения и отключения курсора на гиперссылках

Для задания пути, используемого для всех относительных гиперссылок в чертеже

Для создания относительной гиперссылки


Для создания абсолютной гиперссылки на другой файл - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование гиперссылок для доступа к файлам и веб-страницам
Понятия
Процедуры
Команды

Для создания абсолютной гиперссылки на другой файл

  1. В области рисования выберите один или несколько объектов.
  2. Выберите "Вставка" » "Гиперссылка".
  3. Выполнить одно из следующих действий:
    • В поле "Введите имя файла или веб-страницы" введите имя файла (вместе с путем), на который должен производиться переход.
    • Нажмите кнопку "Файл". Перейдите к файлу, который необходимо связать с гиперссылкой. Нажмите кнопку "Открыть".
  4. (Дополнительно) Если создается гиперссылка на чертеж AutoCAD, выберите "Позиция", чтобы указать именованную позицию в чертеже, куда должен осуществляться переход по гиперссылке, а затем выполните следующие действия.
    • Выберите именованную позицию.
    • Нажмите "ОК".
  5. (Дополнительно) В поле "Пояснение к гиперссылке" введите текст отображаемого на экране пояснения.
  6. Нажмите "ОК".

Ввод команды: ГИПЕРССЫЛКА


Для создания гиперссылки на именованную позицию в файле другого приложения (не AutoCAD) - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование гиперссылок для доступа к файлам и веб-страницам
Понятия
Процедуры
Команды

Для создания гиперссылки на именованную позицию в файле другого приложения (не AutoCAD)

  1. Создайте гиперссылку (см. процедуру Для создания абсолютной гиперссылки на другой файл).
  2. Выберите "Вставка" » "Гиперссылка".
  3. Выберите графические объекты для связывания с гиперссылкой.
  4. В поле "Введите имя файла или веб-страницы" после введенного имени файла, на который должен выполняться переход, введите символ решетки (#) и имя позиции. Между именем файла, символом решетки (#) и именем позиции не должно быть пробелов.
  5. Нажмите "ОК".

Ввод команды: ГИПЕРССЫЛКА


Для редактирования гиперссылки, подключенной к графическому объекту - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование гиперссылок для доступа к файлам и веб-страницам
Понятия
Процедуры
Команды

Для редактирования гиперссылки, подключенной к графическому объекту

  1. Выберите "Вставка" » "Гиперссылка".
  2. В области рисования выберите один или несколько объектов, имеющих одну и ту же гиперссылку.
  3. Введите новые значения в диалоговом окне "Редактирование гиперссылки". Нажмите "ОК".

Ввод команды: ГИПЕРССЫЛКА


Для удаления гиперссылки из графического объекта - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование гиперссылок для доступа к файлам и веб-страницам
Понятия
Процедуры
Команды

Для удаления гиперссылки из графического объекта

  1. В области рисования выберите один или несколько объектов, имеющих одну и ту же гиперссылку.
  2. Выберите "Вставка" » "Гиперссылка".
  3. В области рисования выберите один или несколько объектов, имеющих одну и ту же гиперссылку.
  4. Нажмите "Удалить гиперссылку". Нажмите "ОК".

Ввод команды: ГИПЕРССЫЛКА


Для открытия файла, на который указывает гиперссылка - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование гиперссылок для доступа к файлам и веб-страницам
Понятия
Процедуры
Команды

Для открытия файла, на который указывает гиперссылка

  1. В области рисования выберите объект, имеющий гиперссылку.
  2. Используйте один из следующих методов для перехода по ссылке:
    • Удерживайте в нажатом состоянии клавишу CTRL и нажмите кнопку мыши.
    • Нажмите правую кнопку мыши. Выберите "Гиперссылка". Выберите имя нужной гиперссылки. Каждая гиперссылка имеет либо пояснение, либо полный URL до файла, на который она указывает.

    Примечание Если пользователь отключил отображение курсора гиперссылки, то параметры "Гиперссылка" становятся недоступными в контекстном меню. В диалоговом окне "Настройка" на вкладке "Пользовательские" можно включить курсор гиперссылки, всплывающие подсказки и контекстное меню. Для открытия файлов, связанных с гиперссылками, системная переменная PICKFIRST должна иметь значение 1.


Для включения и отключения курсора на гиперссылках - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование гиперссылок для доступа к файлам и веб-страницам
Понятия
Процедуры
Команды

Для включения и отключения курсора на гиперссылках

  1. Выберите "Сервис" » "Настройка".
  2. В диалоговом окне "Настройка" на вкладке "Пользовательские" выберите или отключите параметр "Курсор, подсказки и контекстное меню".
  3. Нажмите "Применить" или "ОК".

Ввод команды: НАСТРОЙКА


Для задания пути, используемого для всех относительных гиперссылок в чертеже - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование гиперссылок для доступа к файлам и веб-страницам
Понятия
Процедуры
Команды

Для задания пути, используемого для всех относительных гиперссылок в чертеже

  1. Выберите "Файл" » "Свойства чертежа..."
  2. На вкладке "Документ" введите относительный путь в поле "База гиперссылки".
  3. Нажмите "ОК".

Ввод команды: СВОЙСТВАРИС


Для создания относительной гиперссылки - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование гиперссылок для доступа к файлам и веб-страницам
Понятия
Процедуры
Команды

Для создания относительной гиперссылки

  1. Выберите "Вставка" » "Гиперссылка".
  2. В области рисования выберите один или несколько объектов.
  3. Введите имя файла, подключаемого к гиперссылке, в поле "Введите имя файла или веб-страницы".

    4. Сведения о пути вводить не нужно, иначе гиперссылка будет абсолютной.

  4. Нажмите "ОК".

Ввод команды: ГИПЕРССЫЛКА


Использование гиперссылок для доступа к файлам и веб-страницам - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Использование гиперссылок для доступа к файлам и веб-страницам
Понятия
Процедуры
Команды

Команды
GOTOURL | Открывает файл или web-страницу, ассоциированную с гиперссылкой, прикрепленной к объекту
ГИПЕРСВОЙСТВА | Управляет отображением курсора, подсказок и контекстного меню для гиперссылок
ГИПЕРССЫЛКА | Создание гиперссылки для объекта или изменение существующей гиперссылки
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
СВОЙСТВАРИС | Задание и просмотр свойств текущего чертежа
УРЛРАЗОРВАТЬ | Удаление гиперссылок в чертеже
УРЛСВЯЗАТЬ | Создает гиперссылки для объектов или областей чертежа
Системные переменные
HYPERLINKBASE | Указывает путь, используемый для всех относительных гиперссылок в чертеже
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Гиперссылки для создания сообщений электронной почты - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Гиперссылки для создания сообщений электронной почты
Понятия
Процедуры
Команды

Обычно гиперссылки используются для подключения к графическим объектам логически связанных документов. Но в некоторых случаях бывает необходимо, чтобы при выборе гиперссылки создавалось сообщение электронной почты.

В качестве примера можно рассмотреть проект, над которым работают несколько разработчиков, каждый из которых имеет возможность обновлять различные компоненты чертежа. В этом случае разработчики могут связывать новые помещаемые в чертеж компоненты с гиперссылками, в которых указываются их адреса электронной почты. Это позволяет легко идентифицировать автора какого-то компонента чертежа и послать ему по электронной почте сообщение с вопросами по поводу этого компонента.


Для создания гиперссылки на сообщение электронной почты - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Гиперссылки для создания сообщений электронной почты
Понятия
Процедуры
Команды

Для создания гиперссылки на сообщение электронной почты

  1. В области рисования выберите один или несколько объектов.
  2. Выберите "Вставка" » "Гиперссылка".
  3. В диалоговом окне "Вставка гиперссылки" нажмите "Адрес электронной почты".
  4. Введите адрес получателя в поле "Адрес электронной почты".
  5. (Дополнительно) Введите тему сообщения в поле "Тема".
  6. Нажмите "ОК".

    7. После нажатия на гиперссылке происходит создание нового сообщения в установленном по умолчанию клиенте электронной почты. При формировании сообщения используются заданный адрес электронной почты и тема, если последняя была определена при создании гиперссылки. Затем можно ввести текст сообщения и отправить его получателю.

Ввод команды: ГИПЕРССЫЛКА


Гиперссылки для создания сообщений электронной почты - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Гиперссылки для создания сообщений электронной почты
Понятия
Процедуры
Команды

Команды
ГИПЕРССЫЛКА | Создание гиперссылки для объекта или изменение существующей гиперссылки
Системные переменные
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Гиперссылки в блоках - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Гиперссылки в блоках
Понятия
Процедуры
Команды

Гиперссылки можно подключать к блокам и даже к объектам, заключенным в блоки. Все относительные гиперссылки, заданные для объектов блока, после вставки начинают опираться на базовый путь текущего чертежа.

Если элемент блока, выбранный для перехода, и сам блок содержат различные гиперссылки, обе они перечисляются в контекстном меню. Выбрав соответствующий пункт меню, можно перейти по нужной ссылке; однако, редактирование и удаление может производиться только для гиперссылок верхнего уровня.

Пусть, например, в чертеже имеется блок, содержащий отрезок и круг. К отрезку подключена гиперссылка по имени отрезок, а к кругу - гиперссылка по имени круг. Вхождение блока также имеет гиперссылку (назначенную уже после его вставки в чертеж); ее имя блок. Тогда пользователь, указывая курсором элемент блока, получает возможность выбора ссылки для перехода: либо связанной с вложенным элементом, либо со всем блоком. Например, при выборе элемента блока линии можно перейти по гиперссылке линия или блок. При выборе элемента блока окружности можно перейти по гиперссылке окружность или блок. В обоих случаях операции редактирования и удаления разрешены только для гиперссылки блок.

Чтобы выполнить редактирование или удаление гиперссылок вложенных элементов, следует предварительно расчленить блок или использовать команду ССЫЛРЕД.


Для открытия файла, на который указывает гиперссылка внутри блока - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Гиперссылки в блоках
Понятия
Процедуры
Команды

Для открытия файла, на который указывает гиперссылка внутри блока

  1. В области рисования выберите блок, имеющий гиперссылки.
  2. Используйте один из следующих методов для перехода по ссылке:
    • Удерживайте в нажатом состоянии клавишу CTRL и нажмите кнопку мыши.
    • Нажмите правую кнопку мыши. Выберите "Гиперссылка". Выберите имя нужной гиперссылки. Каждая гиперссылка имеет либо пояснение, либо полный URL до файла, на который она указывает.


Гиперссылки в блоках - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Гиперссылки в блоках
Понятия
Процедуры
Команды

Команды
GOTOURL | Открывает файл или web-страницу, ассоциированную с гиперссылкой, прикрепленной к объекту
ГИПЕРССЫЛКА | Создание гиперссылки для объекта или изменение существующей гиперссылки
УРЛРАЗОРВАТЬ | Удаление гиперссылок в чертеже
УРЛСВЯЗАТЬ | Создает гиперссылки для объектов или областей чертежа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование гиперссылок для создания новых чертежей - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование гиперссылок для создания новых чертежей
Понятия
Процедуры
Команды

При активизации гиперссылки, указывающей на DWT-файл шаблона чертежа, программа не открывает файл шаблона, а создает вместо этого новый чертеж, использующий указанный шаблон как основу.

Это позволяет держать в Интернете набор стандартных шаблонов, не беспокоясь об их несанкционированной модификации пользователями. Файлы шаблонов, на которые имеются гиперссылки, открывают новый чертеж, поэтому нет опасности случайной перезаписи исходного шаблона.


Для создания нового чертежа на основе DWT-файла гиперссылки - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование гиперссылок для создания новых чертежей
Понятия
Процедуры
Команды

Для создания нового чертежа на основе DWT-файла гиперссылки

  1. В области рисования выберите объект, имеющий гиперссылку на DWT-файл.
  2. Используйте один из следующих методов для перехода по ссылке:
    • Удерживайте в нажатом состоянии клавишу CTRL и нажмите кнопку мыши.
    • Нажмите правую кнопку мыши. Выберите "Гиперссылка". Выберите имя нужной гиперссылки. Каждая гиперссылка имеет либо пояснение, либо полный URL до файла, на который она указывает.

    Открывается новый чертеж, созданный на основе DWT-файла гиперссылки.

    Примечание Если пользователь отключил отображение курсора гиперссылки, то параметры гиперссылки становятся недоступными в контекстном меню. В диалоговом окне "Параметры" на вкладке "Пользовательские" можно включить курсор гиперссылки, всплывающие подсказки и контекстное меню.


Использование гиперссылок для создания новых чертежей - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Использование гиперссылок для создания новых чертежей
Понятия
Процедуры
Команды

Команды
GOTOURL | Открывает файл или web-страницу, ассоциированную с гиперссылкой, прикрепленной к объекту
ГИПЕРССЫЛКА | Создание гиперссылки для объекта или изменение существующей гиперссылки
Системные переменные
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с чертежами в Интернете - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Работа с чертежами в Интернете
Понятия
Процедуры
Команды

Имеется возможность открывать чертежи с сетевых серверов, сохранять их там, вставлять блоки путем перетаскивания чертежей с сайтов, вставлять в чертежи гиперссылки, а также создавать комплекты, объединяющие в себе чертежи и все связанные с ними файлы.

  • Открытие и сохранение файлов в Интернете
    Команды, осуществляющие файловый ввод-вывод, распознают в заданных путях к файлам элементы Интернет-адресов (Uniform Resource Locator, URL).
  • Совместное использование файлов пользователями из разных стран
    Программные продукты на базе AutoCAD 2007 и более поздних версий используют для чертежей и связанных с ними файлов стандарт Unicode. Благодаря этому при сохранении и открытии файлов чертежей обеспечивается точность отображения международных символов и целостность данных.
  • Доступ Buzzsaw для совместной работы
    При использовании Autodesk® Buzzsaw® можно хранить, совместно использовать документы с веб-сайта, а также управлять ими.
  • Работа с внешними ссылками в Интернете
    В чертежи, хранящиеся на локальном диске компьютера, можно вставлять внешние ссылки из Интернета.
  • Вставка содержимого с веб-страниц
  • Формирование комплектов файлов
    С помощью функции формирования комплектов пользователь может группировать файлы для пересылки через Интернет. В комплекты автоматически включаются все связанные с чертежом файлы, такие как файлы внешних ссылок и шрифтов.


Работа с чертежами в Интернете - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Работа с чертежами в Интернете
Понятия
Процедуры
Команды

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

Для открытия файла AutoCAD из Интернета с выбором в веб-папке

Для сохранения файла AutoCAD в Интернете с заданием сетевого адреса (URL)

Для сохранения чертежа AutoCAD в Интернете на FTP-сервере

Для сохранения файла AutoCAD в Интернете с выбором в веб-папке

Для задания начальной страницы диалогового окна "Поиск в Web"

Для открытия файла AutoCAD из Интернета с помощью диалогового окна "Поиск в Web"

Для сохранения чертежа AutoCAD в Интернете с помощью диалогового окна "Поиск в Web"

Для доступа к веб-сайту Buzzsaw в первый раз

Для доступа к веб-сайту Buzzsaw

Для добавления ярлыка папки Buzzsaw

Для переименования ярлыка папки Buzzsaw

Для изменения ярлыка папки Buzzsaw

Для удаления ярлыка папки Buzzsaw

Для сохранения файла, открытого на веб-сайте Buzzsaw, на другом веб-сайте Buzzsaw

Для сохранения файла, открытого в другой папке, на веб-сайте Buzzsaw

Для отправки набора комплектов на веб-узел Buzzsaw

Для отправки набора комплектов Buzzsaw из "Диспетчера подшивок"

Для публикации файла на веб-сайте Buzzsaw

Для публикации подшивки на веб-сайте Buzzsaw

Для вставки в чертеж внешней ссылки из Интернета

Для вставки компонента из i-drop в чертеж

Для настройки параметров вставки из i-drop

Для задания типа i-drop по умолчанию

Для просмотра файла журнала

Для просмотра адреса гиперссылки содержимого i-drop

Для формирования комплекта файлов в заданной папке

Для формирования комплекта файлов в самораспаковывающемся EXE-файле или ZIP-файле

Для создания комплекта файлов на основе подшивки

Для распаковки самораспаковывающегося комплекта файлов


Работа с чертежами в Интернете - Команды

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Работа с чертежами в Интернете
Понятия
Процедуры
Команды
Команды
АРХИВАЦИЯ | Упаковывает файлы текущей подшивки для архивирования
ГИПЕРССЫЛКА | Создание гиперссылки для объекта или изменение существующей гиперссылки
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
ОТКРЫТЬ | Открытие существующего файла чертежа
ТЗАГРТИП | Задание типа точки загрузки (i-drop) по умолчанию для текущего приложения Autodesk
ФОРМКОМПЛЕКТ | Формирование комплекта файлов для передачи другим пользователям через Интернет
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Открытие и сохранение файлов в Интернете - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Понятия
Процедуры
Команды

Команды, осуществляющие файловый ввод-вывод, распознают в заданных путях к файлам элементы Интернет-адресов (Uniform Resource Locator, URL).

Работая в AutoCAD, можно открывать и сохранять файлы в сети Интернет. Команды AutoCAD, осуществляющие файловый ввод-вывод (ОТКРЫТЬ, ЭКСПОРТ и так далее) распознают любой правильно сформулированный URL-путь к файлу AutoCAD. Чертеж, загружаемый из Интернета, копируется на компьютер и открывается в окне AutoCAD. Выполнив редактирование, пользователь может либо сохранить файл на своем локальном диске, либо вернуть его в Интернет (в последнем случае необходимо наличие прав доступа на запись в сетевую папку).

Если известен полный адрес открываемого файла, его вводят в диалоговом окне "Выбор файла". Кроме того, файл можно выбрать на FTP-сервере, заданном в качестве хранилищ в диалоговом окне "Выбор файла", разыскать в Интернете с помощью диалогового окна "Поиск в Web" или найти в ресурсах службы размещения проектов Autodesk® Buzzsaw®, используя значок Buzzsaw в диалоговом окне "Выбор файла" или "Сохранение чертежа".

Диалоговое окно "Поиск в Web"

Диалоговое окно "Поиск в Web" предназначено для перемещения по Интернету в поисках папки, где открывается или сохраняется файл. Пользователь может указать, какая веб-страница должна загружаться по умолчанию (т.е. быть начальной) при открытии этого окна. Применение окна "Поиск в Web" оправдано в случаях, когда неизвестен точный адрес файла или длина адреса слишком велика.


Открытие и сохранение файлов в Интернете - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Понятия
Процедуры
Команды

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

Для открытия файла AutoCAD из Интернета с выбором в веб-папке

Для сохранения файла AutoCAD в Интернете с заданием сетевого адреса (URL)

Для сохранения чертежа AutoCAD в Интернете на FTP-сервере

Для сохранения файла AutoCAD в Интернете с выбором в веб-папке

Для задания начальной страницы диалогового окна "Поиск в Web"

Для открытия файла AutoCAD из Интернета с помощью диалогового окна "Поиск в Web"

Для сохранения чертежа AutoCAD в Интернете с помощью диалогового окна "Поиск в Web"


Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL) - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Понятия
Процедуры
Команды

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

  1. Выберите меню "Файл" » "Открыть".
  2. В диалоговом окне "Выбор файла" введите URL-адрес в поле "Имя файла". Нажмите "Открыть".

    3. Адрес должен включать в себя признак протокола передачи гипертекстов или файлов (например, http:// или ftp://), а также расширение (например, .dwg или .dwt) файла, который надо открыть.

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL) - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Понятия
Процедуры
Команды

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

  1. Выберите меню "Файл" » "Открыть".
  2. В диалоговом окне "Выбор файла" выберите "Сервис" » "Добавление/изменение FTP-адресов".
  3. В диалоговом окне "Добавление/изменение FTP-адресов" в разделе "Адрес FTP-сервера" введите адрес для FTP-сервера (например, ftp.autodesk.com).
  4. В разделе "Способ входа" выберите один из следующих вариантов.
    • Анонимно. Вход на FTP-сервер без указания имени пользователя. Если FTP-сервер не допускает такого способа входа, необходимо перевести переключатель в положение "С именем" и ввести имя.
    • С именем. Вход на FTP-сервер с указанием имени пользователя.
  5. Введите пароль, если это требуется FTP-сервером.
  6. Нажмите "Добавить". Нажмите "ОК".
  7. В списке хранилищ информации диалогового окна "Выбор файла" нажмите "FTP".
  8. Дважды нажмите на обозначении нужного FTP-сервера, а затем выберите файл.
  9. Нажмите "Открыть".

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для открытия файла AutoCAD из Интернета с выбором в веб-папке - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Понятия
Процедуры
Команды

Для открытия файла AutoCAD из Интернета с выбором в веб-папке

  1. Выберите меню "Файл" » "Открыть".
  2. В диалоговом окне "Выбор файла" в разделе "Поиск" выберите "Веб-папки" (или "Сетевое окружение", в зависимости от версии системы Microsoft® Windows® ).
  3. Дважды нажмите на обозначении нужной веб-папки, а затем выберите файл.

    4. С помощью Проводника Windows можно создать новые веб-папки. Дополнительную информацию о веб-папках можно получить у администратора или в справочной системе по Проводнику Windows.

  4. Нажмите "Открыть".

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для сохранения файла AutoCAD в Интернете с заданием сетевого адреса (URL) - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Понятия
Процедуры
Команды

Для сохранения файла AutoCAD в Интернете с заданием сетевого адреса (URL)

  1. Выберите "Файл" » "Сохранить как".
  2. Введите сетевой адрес (URL) в поле "Имя файла".

    3. Адрес должен включать в себя признак протокола передачи гипертекстов или файлов (например, ftp:// или http://), а также расширение (например, .dwg или .dwt) файла, который надо сохранить. Сохранение файлов в Интернете возможно только при наличии соответствующих прав доступа к заданному адресу.

  3. Выберите формат в списке "Тип файла". Нажмите кнопку "Сохранить".

Ввод команды: СОХРАНИТЬ


Для сохранения чертежа AutoCAD в Интернете на FTP-сервере - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Понятия
Процедуры
Команды

Для сохранения чертежа AutoCAD в Интернете на FTP-сервере

  1. Выберите "Файл" » "Сохранить как".
  2. В списке хранилищ информации диалогового окна "Сохранение чертежа" нажмите "FTP".
  3. Если FTP-сервер не был добавлен в доступные FTP-адреса, выберите "Сервис" » "Добавление/изменение FTP-адресов" и определите FTP-адреса, как описано в разделе Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL).
  4. Дважды нажмите на обозначении нужного FTP-сервера, а затем выберите файл.
  5. Выберите формат в списке "Тип файла". Нажмите кнопку "Сохранить".

Ввод команды: СОХРАНИТЬ


Для сохранения файла AutoCAD в Интернете с выбором в веб-папке - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Понятия
Процедуры
Команды

Для сохранения файла AutoCAD в Интернете с выбором в веб-папке

  1. Выберите "Файл" » "Сохранить как".
  2. В диалоговом окне "Выбор файла" в разделе "Поиск" выберите "Веб-папки" (или "Сетевое окружение", в зависимости от версии системы Windows).
  3. Дважды нажмите на обозначении нужной веб-папки.

    4. С помощью Проводника Windows можно создать новые веб-папки. Дополнительную информацию о веб-папках можно получить у администратора или в справочной системе по Проводнику Windows.

  4. Введите имя файла и выберите формат из списка "Тип файла".
  5. Нажмите кнопку "Сохранить".

    6. Сохранение файлов в Интернете возможно только при наличии соответствующих прав доступа к заданному адресу.

Ввод команды: СОХРАНИТЬ


Для задания начальной страницы диалогового окна "Поиск в Web" - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Понятия
Процедуры
Команды

Для задания начальной страницы диалогового окна "Поиск в Web"

  1. Выберите "Сервис" » "Настройка".
  2. На вкладке "Файлы" нажмите кнопку мыши на значке "плюс" рядом с элементом "Имена файлов справок и других файлов".
  3. Выберите параметр "Начальный узел Интернета". Нажмите кнопку "Обзор".
  4. В диалоговом окне "Выбор файла" выполните одну из следующих операций:
    • Введите URL-адрес для веб-сайта. Нажмите "Открыть".
    • Нажмите кнопку поиска в Интернете и введите Интернет-адрес в поле "Искать в".
  5. Нажмите "ОК".

Ввод команды: НАСТРОЙКА


Для открытия файла AutoCAD из Интернета с помощью диалогового окна "Поиск в Web" - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Понятия
Процедуры
Команды

Для открытия файла AutoCAD из Интернета с помощью диалогового окна "Поиск в Web"

  1. Выберите меню "Файл" » "Открыть".
  2. Нажмите кнопку поиска в Интернете.

    3. В большинстве случаев для получения доступа к файлам в Интернете требуется указание имени пользователя и пароля. AutoCAD предлагает ввести эту информацию.

  3. В диалоговом окне "Поиск в Web" выполните одну из следующих операций:
    • Нажмите гиперссылку в отображаемой странице.
    • В поле "Искать в" введите полный адрес или его начальную часть; затем нажмите клавишу ENTER.
  4. Повторяйте действия пункта 3 до тех пор, пока не будет найден нужный файл.
  5. Нажмите "Открыть".

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для сохранения чертежа AutoCAD в Интернете с помощью диалогового окна "Поиск в Web" - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Понятия
Процедуры
Команды

Для сохранения чертежа AutoCAD в Интернете с помощью диалогового окна "Поиск в Web"

  1. Выберите "Файл" » "Сохранить как".
  2. Нажмите кнопку поиска в Интернете.

    3. В большинстве случаев для получения доступа к файлам в Интернете требуется указание имени пользователя и пароля. AutoCAD предлагает ввести эту информацию.

  3. В диалоговом окне "Поиск в Web" выполните одну из следующих операций:
    • Нажмите гиперссылку в отображаемой странице.
    • В поле "Искать в" введите полный адрес или его начальную часть; затем нажмите клавишу ENTER.
  4. Повторяйте действия пункта 3 до тех пор, пока не будет найдена нужная папка для сохранения файла.
  5. Нажмите кнопку "Сохранить".

Ввод команды: СОХРАНИТЬКАК


Открытие и сохранение файлов в Интернете - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Понятия
Процедуры
Команды

Команды
ГИПЕРССЫЛКА | Создание гиперссылки для объекта или изменение существующей гиперссылки
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
ОТКРЫТЬ | Открытие существующего файла чертежа
ЭКСПОРТ | Сохранение объектов в файлах различных форматов
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Совместное использование файлов пользователями из разных стран - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Совместное использование файлов пользователями из разных стран
Понятия
Процедуры
Команды

Программные продукты на базе AutoCAD 2007 и более поздних версий используют для чертежей и связанных с ними файлов стандарт Unicode. Благодаря этому при сохранении и открытии файлов чертежей обеспечивается точность отображения международных символов и целостность данных.

Основные сведения о стандарте Unicode

Операционная система компьютера обрабатывает все символы в числовом виде, присвоив каждому символу некоторое число. В прошлом использовались различные системы числового кодирования, однако, эти системы зачастую вступали в конфликт. В результате операционные системы и приложения использовали кодовые страницы с собственным набором символов и нумерацией, которые менялись в зависимости от страны или региона.

Для упрощения международной совместимости программ большинством производителей был принят стандарт Unicode, разработанный и поддерживаемый консорциумом Unicode.

Применение в чертежах

Допускается использование характерных для данного языка символов в именах файлов и текстах внутри чертежей и связанных с ними файлах. Основные примеры применения:

  • Имена файлов чертежей
  • Имена путей к папке
  • Файлы данных подшивки
  • Именованные объекты, например, слои и блоки в чертеже
  • Типы линий и имена файлов образцов штриховки, а также их содержимое
  • Тексты, используемые в примечаниях и размерах чертежа
  • DWF-файлы пометок

Это означает, что чертежи можно открывать, изменять и сохранять, не беспокоясь о правильности отображения характерных символов данного языка. Единственное требование - до начала работы с файлом должен быть установлен пакет соответствующего языка.

При сохранении текстовых файлов, например, файлов типа линии (LIN), образцов штриховки (PAT) и пакетных файлов (SCR) в приложениях типа редактора Блокнот рекомендуется указать кодировку Unicode внизу диалогового окна "Сохранить как" для обеспечения совместимости файлов.

Ограничения

Большинство международных проектов могут быть выполнены в данной программной среде. Однако некоторые типы файлов и функций не поддерживаются применительно к странам и регионам, использующим разные кодовые страницы Windows. К этим функциям относятся:

  • Формирование комплекта
  • Совместимость по файлам и данным, требующим передачи лицензии "туда и обратно" для продуктов, не поддерживающих стандарт Unicode
  • Проверка орфографии
  • Файлы форматов PC3, STB и CTB, используемые при печати
  • Файлы Visual LISP

Примечание При этом допускается формирование наборов комплектов для передачи в страны и регионы, использующие одну и ту же кодовую страницу.


Совместное использование файлов пользователями из разных стран - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Совместное использование файлов пользователями из разных стран
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Доступ Buzzsaw для совместной работы - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

При использовании Autodesk® Buzzsaw® можно хранить, совместно использовать документы с веб-сайта, а также управлять ими.

Buzzsaw является безопасной интерактивной службой совместной работы над проектом, с помощью которой различные пользователи могут размещать файлы на основном веб-сайте, а также загружать с него файлы. Можно сохранять файлы, отправлять наборы комплектов и публиковать листы в Buzzsaw.

Подписку на пробное бесплатное использование в течение 30 дней можно получить двумя способами: выполнить процедуры для доступа к Buzzsaw или выбрать меню "Справка" > Веб-узел Autodesk и нажать Buzzsaw в списке "Продукты". Подписка Buzzsaw включает лицензии пользователя для доступа к Buzzsaw. Программное обеспечение Buzzsaw загружается автоматически, когда вы приглашаете на веб-узел консультантов и подрядчиков.

Подготовка к использованию Buzzsaw

Для использования программного обеспечения Buzzsaw необходимо иметь учетную запись для управления проектами или получить доступ к веб-сайту Buzzsaw подписчика. Подписчик предоставит URL-адрес для программы Buzzsaw, имя пользователя и пароль для входа в систему, доступа к файлам и их отправке.

Использование Buzzsaw

Доступ к программе Buzzsaw можно получить из разных стандартных диалоговых окон выбора файлов (например, "Создать" или "Открыть"). Значок Buzzsaw отображается в списке хранилищ информации для обеспечения быстрого доступа.

Поддержка сервисов Autodesk Buzzsaw обеспечивает следующие функции:

  • Поддержка "Диспетчером подшивок". Хранит информацию, необходимую для публикации подшивок и наборов комплектов. Подробнее о "Диспетчере подшивок" см. раздел Работа с листами в подшивке.
  • Поддержка модулем публикаций. Публикация DWF-файлов непосредственно в папки Autodesk Buzzsaw. Подробнее о публикации на Autodesk Buzzsaw см. раздел Настройка параметров публикации.
  • Поддержка формирования комплектов. Можно отправить набор комплектов файлов DWG на веб-узел Buzzsaw, а также создать и отправить набор комплектов с помощью Диспетчера подшивок.

Если для совместной работы над проектом планируется использовать Buzzsaw, установите несколько ярлыков, чтобы можно было быстро перемещаться по часто используемым веб-сайтам. Используя значок Buzzsaw в списке хранилищ информации, можно выбрать ярлык для существующего веб-сайта совместной работы над проектом или создать новый ярлык с помощью параметра "Добавить ярлык папки Buzzsaw".

Если нажать правой кнопкой мыши в поле адреса в диалоговом окне, которое поддерживает Buzzsaw, появится контекстное меню, предоставляющее параметры для добавления, управления или удаления папок Autodesk Buzzsaw для текущего чертежа.


Доступ Buzzsaw для совместной работы - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для доступа к веб-сайту Buzzsaw в первый раз

Для доступа к веб-сайту Buzzsaw

Для добавления ярлыка папки Buzzsaw

Для переименования ярлыка папки Buzzsaw

Для изменения ярлыка папки Buzzsaw

Для удаления ярлыка папки Buzzsaw

Для сохранения файла, открытого на веб-сайте Buzzsaw, на другом веб-сайте Buzzsaw

Для сохранения файла, открытого в другой папке, на веб-сайте Buzzsaw

Для отправки набора комплектов на веб-узел Buzzsaw

Для отправки набора комплектов Buzzsaw из "Диспетчера подшивок"

Для публикации файла на веб-сайте Buzzsaw

Для публикации подшивки на веб-сайте Buzzsaw


Для доступа к веб-сайту Buzzsaw в первый раз - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для доступа к веб-сайту Buzzsaw в первый раз

  1. В диалоговом окне поиска файла, например в диалоговом окне "Выбор файла", в списке хранилищ информации нажмите значок Buzzsaw.

    2. Примечание Если Buzzsaw выбирается впервые, запустится Internet Explorer, и отобразится веб-страница Autodesk Buzzsaw.

    Параметр "Ярлыки папки Buzzsaw" отобразится в окне "Искать в".

  2. Дважды нажмите левую кнопку мыши на параметре "Добавить ярлык папки Buzzsaw".
  3. В диалоговом окне "Вход на веб-узел Buzzsaw" в разделе "Сайт Buzzsaw" введите имя папки для веб-сайта Buzzsaw, к которому требуется получить доступ.
  4. В разделе "ИмяДляВхода", "Имя пользователя Buzzsaw" введите имя для входа.

    5. Это имя предоставляется лицом, обеспечивающим доступ к веб-сайту Buzzsaw.

  5. В окне "Пароль" введите пароль. Нажмите "ОК".

    6. AutoCAD проверяет, имеет ли пользователь доступ к указанному веб-сайту. В случае предоставления доступа отобразится окно "Создание ярлыка папки Buzzsaw". Если доступ не предоставлен, появится сообщение об ошибке.

    Примечание Установите флажок "Сохранить имя пользователя и пароль", если требуется сохранить их для использования в будущем.

  6. В диалоговом окне "Создание ярлыка папки Buzzsaw" в разделе "Выберите папку Buzzsaw, проект или набор документов" нажмите кнопку "Обзор".
  7. В диалоговом окне "Выбор папки Buzzsaw" перейдите к проекту или папке, к которым необходимо получить доступ. Нажмите "ОК".

    8. Путь будет отображаться в окне "Выберите папку Buzzsaw, проект или набор документов".

  8. В разделе "Введите имя для этого ярлыка папки Buzzsaw" введите имя для ярлыка. Нажмите "ОК".

    9. Отобразится диалоговое окно выбора файла, и будет создан ярлык. Для доступа к папке Buzzsaw, обозначенной ярлыком, можно дважды нажать на ярлыке. Пользователь может создать необходимое количество ярлыков Buzzsaw.

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для доступа к веб-сайту Buzzsaw - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для доступа к веб-сайту Buzzsaw

  1. В диалоговом окне выбора файла, поддерживающем Buzzsaw, в списке хранилищ информации нажмите значок Buzzsaw.

    2. В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  2. Дважды нажмите левую кнопку мыши на ярлыке Buzzsaw.

    3. Если пользователь не выполнил вход на веб-узел, отобразится диалоговое окно "Вход на веб-узел Buzzsaw". После регистрации на веб-сайте будет выполнен переход к папке, обозначенной этим ярлыком.

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для добавления ярлыка папки Buzzsaw - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для добавления ярлыка папки Buzzsaw

  1. В диалоговом окне выбора файла, поддерживающем Buzzsaw, в списке хранилищ информации нажмите значок Buzzsaw.

    2. В окне "Икать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  2. Нажмите правую кнопку мыши на ярлыке Buzzsaw. Выберите "Добавить ярлык папки Buzzsaw".
  3. В диалоговом окне "Вход на веб-узел Buzzsaw" в разделе "Веб-узел Buzzsaw" выберите веб-узел Buzzsaw, к которому требуется получить доступ.
  4. При необходимости в разделе "ИмяДляВхода" в поле "Имя пользователя Buzzsaw" введите имя для входа.

    5. (Имя пользователя предоставляется лицом, обеспечивающим доступ к веб-сайту Buzzsaw.)

  5. В разделе "Вход" в поле "Пароль" введите пароль. Нажмите "ОК".

    6. Примечание Установите флажок "Сохранить имя пользователя и пароль", если требуется сохранить их на этом компьютере для использования в будущем.

  6. В диалоговом окне "Создание ярлыка папки Buzzsaw" в разделе "Выберите папку Buzzsaw, проект или набор документов" нажмите кнопку "Обзор" для перехода к проекту или папке.
  7. В дереве диалогового окна "Выбор папки Buzzsaw" нажмите имя веб-сайта для просмотра содержимого папки и перехода к проекту или папке. Нажмите "ОК".

    8. Путь отобразится в диалоговом окне "Создание ярлыка папки Buzzsaw" в разделе "Выберите папку Buzzsaw, проект или набор документов".

  8. В разделе "Введите имя для этого ярлыка папки Buzzsaw" введите имя. Нажмите "ОК".

    9. Это имя папки будет добавлено в список веб-сайта в диалоговом окне выбора файла.

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для переименования ярлыка папки Buzzsaw - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для переименования ярлыка папки Buzzsaw

  1. В диалоговом окне выбора файла, поддерживающем Buzzsaw, в списке хранилищ информации нажмите значок Buzzsaw.

    2. В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  2. Нажмите правую кнопку мыши на ярлыке Buzzsaw. Нажмите "Управление ярлыками папок Buzzsaw".
  3. В диалоговом окне "Ярлыки папки Buzzsaw" выберите ярлык. Выберите "Переименовать".
  4. Введите новое имя для ярлыка папки Buzzsaw. Нажмите кнопку "Закрыть".

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для изменения ярлыка папки Buzzsaw - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для изменения ярлыка папки Buzzsaw

  1. В диалоговом окне выбора файла, поддерживающем Buzzsaw, в списке хранилищ информации нажмите значок Buzzsaw.

    2. В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  2. Нажмите правую кнопку мыши на ярлыке Buzzsaw. Нажмите "Управление ярлыками папок Buzzsaw".
  3. В диалоговом окне "Ярлыки папки Buzzsaw" выберите ярлык. Нажмите кнопку "Изменить".
  4. В диалоговом окне "Вход на веб-узел Buzzsaw" выполните вход на веб-узел Buzzsaw.
  5. В диалоговом окне "Изменение ярлыка местоположения Buzzsaw" измените папку или имя ярлыка.
  6. Нажмите "ОК". Нажмите кнопку "Закрыть".

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для удаления ярлыка папки Buzzsaw - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для удаления ярлыка папки Buzzsaw

  1. В диалоговом окне выбора файла, поддерживающем Buzzsaw, в списке хранилищ информации нажмите значок Buzzsaw.

    2. В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  2. Нажмите правую кнопку мыши на ярлыке Buzzsaw. Нажмите "Управление ярлыками папок Buzzsaw".
  3. В диалоговом окне "Ярлыки папки Buzzsaw" выберите ярлык. Нажмите кнопку "Удалить".

    4. Выбранный ярлык будет удален.

  4. Нажмите кнопку "Закрыть".

    5. Контекстное меню: Нажмите правую кнопку мыши на ярлыке Buzzsaw. Нажмите кнопку "Удалить".

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для сохранения файла, открытого на веб-сайте Buzzsaw, на другом веб-сайте Buzzsaw - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для сохранения файла, открытого на веб-сайте Buzzsaw, на другом веб-сайте Buzzsaw

  1. Выберите "Файл" » "Сохранить".
  2. В диалоговом окне "Сохранение чертежа" в разделе "Имя файла" отобразится полный путь к файлу чертежа. Нажмите кнопку "Сохранить".

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для сохранения файла, открытого в другой папке, на веб-сайте Buzzsaw - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для сохранения файла, открытого в другой папке, на веб-сайте Buzzsaw

  1. Выберите "Файл" » "Сохранить как".
  2. В диалоговом окне "Сохранение чертежа" в списке хранилищ информации нажмите значок Buzzsaw.
  3. Дважды нажмите левую кнопку мыши на существующем ярлыке или создайте новый ярлык.

    4. Примечание Если пользователь не выполнил вход на веб-узел, отобразится диалоговое окно "Вход на веб-узел Buzzsaw". После регистрации на веб-сайте будет выполнен переход к папке, обозначенной этим ярлыком.

  4. Введите имя файла и нажмите "Сохранить".

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для отправки набора комплектов на веб-узел Buzzsaw - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для отправки набора комплектов на веб-узел Buzzsaw

  1. Выберите "Файл" » "Сформировать комплект".
  2. В диалоговом окне "Формирование комплекта файлов" нажмите "OK".
  3. В диалоговом окне "Выбор ZIP-файла" в списке хранилищ информации нажмите значок Buzzsaw.

    4. Параметр "Ярлыки папки Buzzsaw" отобразится в окне "Сохранить в". Существующие ярлыки Buzzsaw отобразятся в столбце "Сайт".

  4. Дважды нажмите левую кнопку мыши на существующем ярлыке или создайте новый ярлык.

    5. Примечание Если пользователь не выполнил вход на веб-узел, отобразится диалоговое окно "Вход на веб-узел Buzzsaw". После регистрации на веб-сайте будет выполнен переход к папке, обозначенной этим ярлыком.

  5. Нажмите кнопку "Сохранить".

    6. Создан комплект файлов.

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для отправки набора комплектов Buzzsaw из "Диспетчера подшивок" - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для отправки набора комплектов Buzzsaw из "Диспетчера подшивок"

  1. Нажмите правую кнопку мыши в "Диспетчере подшивок" на вкладке "Список листов". Нажмите "Сформировать комплект".

    2. Программа собирает информацию для создания комплекта файлов.

  2. В диалоговом окне "Формирование комплекта файлов" нажмите "OK".
  3. В диалоговом окне "Выбор ZIP-файла" в списке хранилищ информации нажмите значок Buzzsaw.

    4. В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  4. Дважды нажмите левую кнопку мыши на существующем ярлыке или создайте новый ярлык.

    5. Примечание Если пользователь не выполнил вход на веб-узел, отобразится диалоговое окно "Вход на веб-узел Buzzsaw". После регистрации на веб-сайте будет выполнен переход к папке, обозначенной этим ярлыком.

  5. Нажмите кнопку "Сохранить".

    6. Создан комплект файлов.

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для публикации файла на веб-сайте Buzzsaw - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для публикации файла на веб-сайте Buzzsaw

  1. На чертеже выберите "Файл" » "Публикация".
  2. В диалоговом окне "Публикация" в разделе "Вывод при публикации" выберите один из следующих параметров и нажмите "Параметры публикации".
    • На плоттер, заданный в параметрах
    • В DWF-файл
  3. В диалоговом окне "Параметры публикации" в разделе "Папка для вывода по умолчанию" нажмите "Размещение". Нажмите кнопку [...].
  4. В диалоговом окне "Выбор папки для сформированных чертежей" в списке хранилищ информации нажмите значок Buzzsaw.

    5. В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  5. Дважды нажмите левую кнопку мыши на существующем ярлыке или создайте новый ярлык.

    6. Примечание Если пользователь не выполнил вход на веб-узел, отобразится диалоговое окно "Вход на веб-узел Buzzsaw". После регистрации на веб-сайте будет выполнен переход к папке, обозначенной этим ярлыком.

  6. Нажмите "Выбрать".
  7. В диалоговом окне "Параметры публикации" нажмите "OK".
  8. В диалоговом окне "Публикация" нажмите "Опубликовать"
  9. В диалоговом окне "Выбор DWF-файла" нажмите кнопку "Выбрать".

    10. Запустится операция публикации. В окне состояния отобразится сообщение о завершении публикации.

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Для публикации подшивки на веб-сайте Buzzsaw - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Для публикации подшивки на веб-сайте Buzzsaw

  1. В "Диспетчере подшивок" на вкладке "Список листов" нажмите правую кнопку мыши и выберите "Публикация" » диалоговое окно "Публикация".
  2. В диалоговом окне "Публикация" выберите "Параметры публикации подшивки".
  3. В диалоговом окне "Параметры публикации подшивки" в разделе "Папка для вывода по умолчанию" нажмите "Размещение". Нажмите кнопку [...].
  4. В диалоговом окне "Выбор папки для сформированных чертежей" в списке хранилищ информации нажмите значок Buzzsaw.

    5. В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  5. Дважды нажмите левую кнопку мыши на существующем ярлыке или создайте новый ярлык.

    6. Примечание Если пользователь не выполнил вход на веб-узел, отобразится диалоговое окно "Вход на веб-узел Buzzsaw". После регистрации на веб-сайте будет выполнен переход к папке, обозначенной этим ярлыком.

  6. Нажмите "Выбрать".
  7. В диалоговом окне "Параметры публикации подшивки" нажмите "OK".
  8. В диалоговом окне "Публикация" нажмите "Опубликовать"
  9. В диалоговом окне "Выбор DWF-файла" нажмите кнопку "Выбрать".

    10. Запустится операция публикации. В окне состояния отобразится сообщение о завершении публикации.

Панель Стандартная

Ввод команды: ОТКРЫТЬ


Доступ Buzzsaw для совместной работы - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Понятия
Процедуры
Команды

Команды
ОТКРЫТЬ | Открытие существующего файла чертежа
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с внешними ссылками в Интернете - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Работа с внешними ссылками в Интернете
Понятия
Процедуры
Команды

В чертежи, хранящиеся на локальном диске компьютера, можно вставлять внешние ссылки из Интернета.

Пусть, например, над отдельными элементами проекта трудится несколько инженеров из разных организаций. Они сохраняют свои чертежи в общей сетевой папке в Интернете. Руководитель проекта держит на своем компьютере главный чертеж, а результаты работы своих подчиненных он подключает к нему как внешние ссылки. Если кто-то из инженеров вносит коррективы в свой фрагмент, они отражаются в главном чертеже при его следующем открытии. Приведенный в качестве примера механизм почти идеален для разработки сложных распределенных проектов.

Примечание Если скорость соединения с Интернетом низка, а также, если в главном чертеже имеется множество внешних ссылок, загрузка ссылок может занять достаточно долгое время.


Для вставки в чертеж внешней ссылки из Интернета - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Работа с внешними ссылками в Интернете
Понятия
Процедуры
Команды

Для вставки в чертеж внешней ссылки из Интернета

  1. Выберите меню "Вставка" » "Внешние ссылки".
  2. В диалоговом окне "Выбор файла внешней ссылки" выполните одну из следующих операций:
    • Введите сетевой адрес (URL) в поле "Имя файла".

      • Адрес должен включать в себя признак протокола передачи (например, http:// или ftp://).

    • Нажмите кнопку поиска в Интернете, а затем в диалоговом окне "Поиск в Web" перейдите к файлу, который требуется прикрепить.

    Если для входа в локальную сеть или в Интернет требуется имя пользователя и пароль, появится запрос на ввод этой информации.

  3. Нажмите кнопку "Открыть".
  4. В диалоговом окне "Внешние ссылки" нажмите "OK".
  5. Укажите точку вставки ссылки.

Панель Вставка

Ввод команды: ССЫЛКА


Работа с внешними ссылками в Интернете - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Работа с внешними ссылками в Интернете
Понятия
Процедуры
Команды

Команды
ГИПЕРССЫЛКА | Создание гиперссылки для объекта или изменение существующей гиперссылки
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вставка содержимого с веб-страниц - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Вставка содержимого с веб-страниц
Понятия
Процедуры
Команды

С помощью функциональных возможностей точек загрузки Autodesk® i-drop® можно перетаскивать в чертеж содержимое веб-страниц.

  • Коротко об i-drop (точках загрузки)
    При помощи технологии, использующей так называемые точки загрузки (i-drop), можно перетаскивать необходимые компоненты из Интернета в текущий чертеж.
  • Использование i-drop
    Работа с i-drop заключается в простом перетаскивании образцов компонентов с веб-страницы в область рисования. Можно также задавать тип i-drop для своего проекта.


Вставка содержимого с веб-страниц - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Вставка содержимого с веб-страниц
Понятия
Процедуры
Команды

Для вставки компонента из i-drop в чертеж

Для настройки параметров вставки из i-drop

Для задания типа i-drop по умолчанию

Для просмотра файла журнала

Для просмотра адреса гиперссылки содержимого i-drop


Вставка содержимого с веб-страниц - Команды

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Вставка содержимого с веб-страниц
Понятия
Процедуры
Команды
Команды
ТЗАГРТИП | Задание типа точки загрузки (i-drop) по умолчанию для текущего приложения Autodesk
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко об i-drop (точках загрузки) - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Коротко об i-drop (точках загрузки)
Понятия
Процедуры
Команды

При помощи технологии, использующей так называемые точки загрузки (i-drop), можно перетаскивать необходимые компоненты из Интернета в текущий чертеж. Данная технология позволяет легко вставлять чертежи и другие объекты из Web-страниц в открытый чертеж. Примером содержимого i-drop, которое можно перетащить, является блок стула, окна или растровое изображение образца линолеума.

С помощью Мастера публикации в Интернете можно создать веб-страницу с содержимым i-drop для файла чертежа. О других способах создания веб-страниц с i-drop можно прочитать на веб-сайте компании Autodesk по адресу:

http://www.autodesk.com/idrop-rus


Вставка содержимого с веб-страниц

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Вставка содержимого с веб-страниц
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Коротко об i-drop (точках загрузки) - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Коротко об i-drop (точках загрузки)
Понятия
Процедуры
Команды

Команды
ТЗАГРТИП | Задание типа точки загрузки (i-drop) по умолчанию для текущего приложения Autodesk
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование i-drop - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование i-drop
Понятия
Процедуры
Команды

Работа с i-drop заключается в простом перетаскивании образцов компонентов с веб-страницы в область рисования. Образец компонента - это обычно уменьшенное и упрощенное изображение объекта, который появится в чертеже после перетаскивания.

Для i-drop существуют следующие настройки:

  • Задание типа i-drop по умолчанию. Можно задать тип содержимого i-drop по умолчанию, которое будет приниматься программой. С помощью данной настройки задается тип содержимого, перетаскиваемого в чертеж с веб-страницы. Например, при выборе параметра "Блок" добавленным содержимым будет являться блок.
  • Задание типа i-drop правой кнопкой мыши в процессе перетаскивания. Путем перетаскивания образца содержимого i-drop при нажатии правой кнопкой мыши можно выбрать тип содержимого i-drop для добавления в чертеж.
  • Задание связанных файлов данных правой кнопкой мыши в процессе перетаскивания. Можно указать связанные файлы данных, которые необходимо загрузить, путем перетаскивания содержимого i-drop в чертеж при нажатии правой кнопки мыши.
  • Задание расположения загружаемых связанных файлов данных. Можно указать место для загрузки файлов данных, связанных с содержимым i-drop.
  • Просмотр файла журнала. Можно просмотреть файл журнала с информацией о содержимом i-drop, который создается для каждого чертежа. Файл журнала располагается в папке, где хранится чертеж.


Использование i-drop - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование i-drop
Понятия
Процедуры
Команды

Для вставки компонента из i-drop в чертеж

Для настройки параметров вставки из i-drop

Для задания типа i-drop по умолчанию

Для просмотра файла журнала

Для просмотра адреса гиперссылки содержимого i-drop


Для вставки компонента из i-drop в чертеж - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование i-drop
Понятия
Процедуры
Команды

Для вставки компонента из i-drop в чертеж

  1. Откройте чертеж, в который нужно вставить компонент.
  2. Перетащите образец компонента с веб-страницы в открытый чертеж.

    3. Курсор, перемещаемый над образцом компонента, приобретает вид пипетки. Компонент переходит в режим вставки.

  3. Переместите курсор в нужную позицию чертежа и установите компонент нажатием левой кнопки мыши.

    4. Компонент из i-drop помещается в чертеж.


Для настройки параметров вставки из i-drop - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование i-drop
Понятия
Процедуры
Команды

Для настройки параметров вставки из i-drop

При добавлении содержимого i-drop в чертеж можно указать путь и место размещения связанных файлов данных.

  1. Перетащите образец компонента с веб-страницы в открытый чертеж с помощью правой кнопки мыши.

    2. Курсор, перемещаемый над образцом компонента, приобретает вид пипетки.

  2. Из контекстного меню выберите "Вставить как" » "Блок".
  3. В диалоговом окне "Параметры вставки из i-drop" в области "Выбор связанного файла" выберите связанные файлы данных, которые требуется загрузить с помощью содержимого i-drop.
  4. В поле "Путь к папке назначения" указывается путь, куда по умолчанию помещаются связанные файлы. Нажав на кнопку [...], можно задать другой путь.
  5. Нажмите "ОК".
  6. Переместите курсор в нужную позицию чертежа и установите компонент нажатием левой кнопки мыши.


Для задания типа i-drop по умолчанию - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование i-drop
Понятия
Процедуры
Команды

Для задания типа i-drop по умолчанию

  1. В командной строке введите тзагртип.
  2. В открывшемся диалоговом окне выберите тип i-drop по умолчанию.

    3. В раскрывающемся списке содержатся только поддерживаемые технологией i-drop типы содержимого i-drop.

    Перетаскиваемый в чертеж объект может быть нескольких типов содержимого. Данная настройка определяет, какой тип содержимого вставляется в чертеж. Выбор "Блок" указывает на то, что добавляется блок. В чертеж можно поместить любой блок, созданный в программе семейства AutoCAD.


Для просмотра файла журнала - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование i-drop
Понятия
Процедуры
Команды

Для просмотра файла журнала

  • Откройте файл <имя файла чертежа>_idrop.txt в папке, где хранится чертеж.

    • Файл журнала содержит информацию о дате и времени загрузки, имени целевого файла, имени i-drop и загруженного компонента (в конце URL-адреса), а также подробную информацию о каждом связанном файле.


Для просмотра адреса гиперссылки содержимого i-drop - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Использование i-drop
Понятия
Процедуры
Команды

Для просмотра адреса гиперссылки содержимого i-drop

  1. Выберите загруженный компонент на чертеже.
  2. Разместите над ним курсор.

    3. Адрес гиперссылки отображается в виде контекстной подсказки указателя.


Использование i-drop - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Использование i-drop
Понятия
Процедуры
Команды

Команды
ТЗАГРТИП | Задание типа точки загрузки (i-drop) по умолчанию для текущего приложения Autodesk
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Формирование комплектов файлов - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Формирование комплектов файлов
Понятия
Процедуры
Команды

С помощью функции формирования комплектов пользователь может группировать файлы для пересылки через Интернет. В комплекты автоматически включаются все связанные с чертежом файлы, такие как файлы внешних ссылок и шрифтов.

Как правило, при отправке чертежа получателю возникает проблема добавления к нему связанных файлов (шрифтов, внешних ссылок и др.). В некоторых случаях отсутствие связанных файлов делает невозможным использование файлов чертежей получателем. Функция формирования комплектов включает зависимые файлы в комплект автоматически, уменьшая тем самым возможность ошибки.

Выбор файлов для комплекта

В диалоговом окне "Формирование комплекта файлов" присутствует две вкладки, если функция вызывается для отдельных файлов чертежей, или три вкладки, если функция вызывается для подшивок и файлов чертежей, на которые есть ссылки в подшивках. Используя эти вкладки, пользователь может просмотреть и изменить файлы, которые должны быть включены в комплект.

  • Листы. Эта вкладка доступна, только когда открыта подшивка. На ней отображается иерархический список листов в текущей подшивке. При выборе листа все его зависимые файлы автоматически включаются в комплект.
  • Дерево файлов. На этой вкладке отображается список файлов. Пользователь может развернуть любое имя файла чертежа, чтобы увидеть его зависимые файлы. По умолчанию все зависимые файлы автоматически включаются в комплект; если какой-либо файл не нужен в комплекте, необходимо убрать флажок около его имени.
  • Таблица файлов. На этой вкладке отображается таблица файлов, местоположение их папки и дополнительные сведения о файле. Можно установить или убрать флажок около каждого файла, тем самым соответственно включив файл в комплект или исключив его оттуда. Для каждого файла это делается индивидуально.
Добавление инструкций для получателя

При формировании комплекта генерируется файл отчета, который включает в себя список файлов комплекта. В отчет также добавляются инструкции, описывающие необходимые действия с зависимыми от чертежей файлами, такими как файлы внешних ссылок и шрифтов, чтобы сохранить их связь с основным файлом чертежа. Пользователь может также добавить свои примечания к файлу отчета.

Сохранение наборов параметров комплектов

В ходе выполнения проекта может понадобиться посылать комплекты файлов несколько раз. Функция формирования комплектов предоставляет возможность сохранить настройки параметров комплекта как именованный набор параметров комплекта. В диалоговом окне "Наборы параметров комплектов" отображается список имеющихся наборов параметров, которыми можно воспользоваться всякий раз при формировании нового комплекта. Набор параметров комплекта по умолчанию называется "Standard".

Настройка параметров комплекта

Порядок формирования комплекта файлов регулируется рядом параметров. Используя эти параметры, можно:

  • Заархивировать комплект в ZIP-файл, в самораспаковывающийся EXE-файл или скопировать его в определенную папку.
  • Определить структуру организации папок файлов комплекта (иерархическая структура, одна папка для всех файлов) или оставить структуру папок “как есть”. Если комплект сохраняется в Интернете (по протоколу FTP или HTTP), то все файлы принудительно записываются в одну папку.
  • Добавить защиту паролем к комплекту, автоматически внедрить внешние ссылки, установить “пустое” устройство в качестве плоттера по умолчанию и др.

После того как комплект создан, его можно разместить на каком-либо сервере в Интернете или послать другим разработчикам в качестве прикрепленного к электронному письму файла. Если необходимо послать комплект по электронной почте, то пользователь может использовать опцию в диалоговом окне "Изменение набора параметров комплекта", которая автоматически вызывает зарегистрированное в системе почтовое приложение. При этом сам комплект и файл отчета автоматически прикрепляются к новому электронному письму.

Примечание Независимо от того, какая структура папок выбрана для комплекта файлов, все абсолютные пути зависимых файлов преобразуются в относительные пути или переходят в состояние “без пути”, чтобы гарантировать, что зависимые файлы можно найти по файлу чертежа.

Формирование комплектов из подшивок

В Диспетчере подшивок можно создать комплект на основе всей подшивки, группы листов или отдельного листа. В Диспетчере подшивок укажите, какой комплект требуется создать.

Примечание В Диспетчере подшивок на вкладке "Список листов" нажмите правую кнопку мыши на узле подшивки, узле группы или узле отдельного листа в дереве листов. В контекстном меню есть пункт "Сформировать комплект", который осуществляет формирование комплекта, основываясь на том, какой элемент выделен. Для включения в комплект больших или сложных наборов листов удобно пользоваться именованными наборами листов.

С помощью вкладок диалогового окна "Формирование комплекта файлов" можно определить, какие файлы должны быть включены в данный комплект.

  • На вкладке "Листы" можно легко выбирать листы для формирования комплекта, ставя или убирая флажки около их имен.
  • На вкладках "Дерево файлов" и "Таблица файлов" можно добавлять и убирать файлы чертежей и зависимые файлы. В комплект можно также добавить любые другие файлы, не связанные с основными чертежами.

Примечание Если из одного файла чертежа в комплект взяты несколько листов, то с помощью флажка на вкладке "Листы" можно управлять только первым из них; другие листы будут недоступны. Поэтому рекомендуется в каждом файле чертежа создавать только одну вкладку-лист.

Взаимодействие комплектов с AutoCAD LT и более ранними версиями AutoCAD

Комплекты файлов пересылаются между различными людьми и организациями, и вполне возможно, что некоторые из получателей подобных комплектов имеют у себя AutoCAD LT или более ранние версии AutoCAD.

Пересылка комплектов файлов может производиться между пользователями различных продуктов на основе AutoCAD; кроме того, функция формирования комплектов обладает способностью преобразования файлов в DWG-форматы предыдущих версий. Кроме того, комплекты файлов, созданные в AutoCAD 2005 и более поздних версиях программы, могут содержать подшивки, недоступные в AutoCAD LT и в более ранних версиях AutoCAD. Файлы этих подшивок могут пересылаться и приниматься в AutoCAD LT и более ранних версиях AutoCAD. Однако если для передачи файлов требуется более действенный и удобный способ, используйте подшивки в комплектах файлов.

Пересылка файлов пользователям других стран

Начиная с AutoCAD 2007 и AutoCAD LT 2007, в именах файлов, созданных в программах на базе продуктов AutoCAD, используются стандарты Unicode, что обеспечивает совместную работу над проектом людям из разных стран. Однако функция "Сформировать комплект" использует технологию WinZip для формирования комплектов. Так как WinZip не поддерживает стандарт Unicode, рекомендуется использовать одну из следующих операций:

  • Пересылка файлов по отдельности.
  • Использование функции "Сформировать комплект" для создания папки, содержащей пересылаемые файлы, и копирование этой папки на общий сервер.
  • Формирование пакетов файлов с помощью коммерческого приложения, поддерживающего стандарт Unicode.
  • Перед использованием функции формирования комплектов убедитесь, что все имена файлов используют символы, шестнадцатеричные значения которых не превосходят 80.


Формирование комплектов файлов - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Формирование комплектов файлов
Понятия
Процедуры
Команды

Для формирования комплекта файлов в заданной папке

Для формирования комплекта файлов в самораспаковывающемся EXE-файле или ZIP-файле

Для создания комплекта файлов на основе подшивки

Для распаковки самораспаковывающегося комплекта файлов


Для формирования комплекта файлов в заданной папке - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Формирование комплектов файлов
Понятия
Процедуры
Команды

Для формирования комплекта файлов в заданной папке

  1. Выберите "Файл" » "Сформировать комплект".
  2. В диалоговом окне "Формирование комплекта файлов" на вкладке "Дерево файлов" или "Таблица файлов" нажмите кнопку "Добавить файл".
  3. (Дополнительно) В диалоговом окне "Добавление файла в комплект" найдите и выберите файлы, которые необходимо включить. Нажмите кнопку "Открыть". Повторите этот шаг для дополнительных файлов, если необходимо.
  4. В диалоговом окне "Формирование комплекта файлов" на вкладке с деревом или таблицей файлов снимите флажки около тех файлов, которые не должны входить в комплект. Пользователь может развернуть любой файл чертежа, чтобы увидеть зависимые от него файлы.
  5. Нажмите "Наборы параметров...". Выберите "Изменить".
  6. В диалоговом окне "Изменение набора параметров комплекта" нажмите стрелку рядом со списком "Тип комплекта" и затем выберите "Папка с файлами". Задайте необходимые дополнительные параметры комплекта.
  7. Нажмите кнопку "Обзор" под списком "Папка с файлом комплекта" для определения папки, в которую должен быть помещен комплект. Появляется стандартное диалоговое окно выбора файлов.
  8. Перейдите к папке, в которой требуется создать комплект файлов. Нажмите кнопку "Открыть".
  9. Нажмите кнопку "OK" для закрытия диалогового окна "Изменение набора параметров комплекта".
  10. Нажмите кнопку "Закрыть" для закрытия диалогового окна "Наборы параметров комплектов".
  11. (Дополнительно) В диалоговом окне "Формирование комплекта файлов" в области для примечаний можно записать любые дополнительные комментарии, которые будут включены в файл отчета.
  12. Нажмите "OK" для создания комплекта файлов в заданной папке.

Ввод команды: ФОРМКОМПЛЕКТ


Для формирования комплекта файлов в самораспаковывающемся EXE-файле или ZIP-файле - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Формирование комплектов файлов
Понятия
Процедуры
Команды

Для формирования комплекта файлов в самораспаковывающемся EXE-файле или ZIP-файле

  1. Выберите "Файл" » "Сформировать комплект".
  2. В диалоговом окне "Формирование комплекта файлов" на вкладке "Дерево файлов" или "Таблица файлов" нажмите кнопку "Добавить файл".
  3. (Дополнительно) В диалоговом окне "Добавление файла в комплект" найдите и выберите файлы, которые необходимо включить. Нажмите кнопку "Открыть". Повторите этот шаг для файлов, находящихся в дополнительных папках, если необходимо.
  4. В диалоговом окне "Формирование комплекта файлов" на вкладке с деревом или таблицей файлов снимите флажки около тех файлов, которые не должны входить в комплект. На вкладке "Дерево файлов" пользователь может развернуть любой файл чертежа, чтобы увидеть зависимые от него файлы.
  5. Нажмите "Наборы параметров...". Выберите "Изменить".

    6. Примечание Рекомендуется создать и сохранить несколько именованных наборов параметров комплектов. Теперь для создания комплекта файлов не нужно выполнять шаги с 5 по 11, можно лишь выбрать набор параметров.

  6. В диалоговом окне "Изменение набора параметров комплекта" нажмите стрелку, чтобы отобразить список в разделе "Тип комплекта". Выберите Zip-файл (*.zip) или Самораспаковывающийся EXE-файл (*.exe). Задайте необходимые дополнительные параметры комплекта.
  7. Нажмите кнопку "Обзор" под списком "Папка с файлом комплекта" для определения папки, в которую должен быть помещен комплект. Появляется стандартное диалоговое окно выбора файлов.
  8. Перейдите к папке, в которой требуется создать комплект файлов. Нажмите кнопку "Открыть".
  9. Нажмите кнопку "OK" для закрытия диалогового окна "Изменение набора параметров комплекта".
  10. Нажмите кнопку "Закрыть" для закрытия диалогового окна "Наборы параметров комплектов".
  11. (Дополнительно) В диалоговом окне "Формирование комплекта файлов" в области для примечаний можно записать любые дополнительные комментарии, которые будут включены в файл отчета.
  12. Нажмите "OK" для создания комплекта файлов в заданной папке.

Ввод команды: ФОРМКОМПЛЕКТ


Для создания комплекта файлов на основе подшивки - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Формирование комплектов файлов
Понятия
Процедуры
Команды

Для создания комплекта файлов на основе подшивки

  1. Откройте подшивку, на основе которой формируется комплект.
  2. В Диспетчере подшивок на вкладке "Список листов" нажмите правую кнопку мыши на одном из следующих типов узлов в списке дерева листов:
    • Подшивка (узел верхнего уровня). Комплект формируется из всей подшивки.
    • Группа листов (узел среднего уровня). Комплект формируется из группы листов или набора листов подшивки.
    • Лист (узел нижнего уровня). Комплект формируется из выбранного листа или набора листов подшивки.
  3. Из контекстного меню выберите "Сформировать комплект".

    4. Если листы принадлежат одному и тому же файлу чертежа, то в диалоговом окне "Формирование комплекта файлов" на вкладке "Листы" они отображаются с отступом относительно других листов. Выбор или отказ от включения листа в комплект приводит автоматически к такому же выбору или отказу для остальных листов того же чертежа.

    Примечание Рекомендуется создать и сохранить несколько именованных наборов параметров комплектов. Теперь для создания комплекта файлов не нужно выполнять шаги с 4 по 11, можно лишь выбрать набор параметров.

  4. В диалоговом окне "Формирование комплекта файлов" нажмите кнопку "Наборы параметров". Нажмите "Изменить".
  5. В диалоговом окне "Изменение набора параметров комплекта" нажмите стрелку возле списка "Тип комплекта" и выберите тип комплекта, который должен быть создан. Задайте необходимые дополнительные параметры комплекта. В группе "Опции для комплекта" рекомендуется использовать первый параметр - "Организованная структура папок". Корневой в данном случае считается папка, где хранится файл данных подшивки (.dst). Используйте параметр "Текущая структура файлов и папок" для обеспечения логики AutoCAD 2007 eTransmit.
  6. Нажмите кнопку "Обзор" под списком "Папка с файлом комплекта" для определения папки, в которую должен быть помещен комплект. Появляется стандартное диалоговое окно выбора файлов.
  7. Перейдите к папке, в которой требуется создать комплект файлов. Нажмите кнопку "Открыть".
  8. Нажмите кнопку "OK" для закрытия диалогового окна "Изменение набора параметров комплекта".
  9. Нажмите кнопку "Закрыть" для закрытия диалогового окна "Наборы параметров комплектов".
  10. (Дополнительно) В диалоговом окне "Формирование комплекта файлов" в области для примечаний можно записать любые дополнительные комментарии, которые будут включены в файл отчета.
  11. Нажмите "OK" для создания комплекта файлов в заданной папке.

Ввод команды: ФОРМКОМПЛЕКТ


Для распаковки самораспаковывающегося комплекта файлов - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Формирование комплектов файлов
Понятия
Процедуры
Команды

Для распаковки самораспаковывающегося комплекта файлов

  1. В Проводнике Windows дважды нажмите левую кнопку мыши на значке файла комплекта.
  2. В диалоговом окне "Формирование комплекта" нажмите кнопку "Обзор" для задания папки, в которую требуется распаковать файлы комплекта.
  3. Нажмите "ОК".
  4. Если для защиты комплекта был задан пароль, появляется запрос на ввод пароля.
  5. Нажмите "OK" для закрытия каждого диалогового окна.


Формирование комплектов файлов - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Формирование комплектов файлов
Понятия
Процедуры
Команды

Команды
АРХИВАЦИЯ | Упаковывает файлы текущей подшивки для архивирования
ГИПЕРССЫЛКА | Создание гиперссылки для объекта или изменение существующей гиперссылки
ФОРМКОМПЛЕКТ | Формирование комплекта файлов для передачи другим пользователям через Интернет
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание веб-страниц с помощью Мастера публикации в Интернете - Понятия

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Создание веб-страниц с помощью Мастера публикации в Интернете
Понятия
Процедуры
Команды

Упрощенный интерфейс Мастера публикации в Интернете позволяет создавать форматированные веб-страницы, которые включают образы чертежей DWF, JPEG или PNG.

  • В формате DWF файлы чертежей не сжимаются.
  • Формат JPEG использует сжатие информации с потерями; т.е. происходит сознательный отказ от некоторых данных для более компактного сжатия файла.
  • PNG-формат (Portable Network Graphics) использует сжатие информации без потерь; т.е. не происходит потери данных ради уменьшения размера файла.

С помощью Мастера публикации можно легко и быстро создавать наглядные веб-страницы, не имея никаких навыков в выполнении HTML-верстки. Созданные таким образом веб-страницы могут размещаться в Интернете или корпоративной сети.

Ниже перечислены элементы оформления, с помощью которых в Мастере создаются веб-страницы:

  • Шаблоны. Можно выбрать один из четырех шаблонов для листа веб-страницы или создать собственный шаблон.
  • Темы. Для выбранного шаблона можно задать одну из тем. Темы определяют цветовое и шрифтовое оформление веб-страницы.
  • i-drop. На веб-странице можно включить поддержку технологии i-drop. Посетители страницы могут перетаскивать файлы чертежей в сеанс программы. i-drop идеально подходят для публикации библиотек компонентов в Интернете.

Для получения информации об использовании i-drop с целью создания метки i-drop на веб-сайте см. документацию по i-drop на веб-сайте Autodesk по адресу: http://www.autodesk.com/idrop-rus.

Примечание Шаблон, используемый для создания веб-страницы, можно настраивать. Подробнее об использовании шаблонов см. раздел Настройка шаблонов Интернет-публикаций в Руководстве по адаптации.


Для использования Мастера публикации - Процедуры

Совместная работа над проектами
Совместная работа с чертежами в Интернете
Создание веб-страниц с помощью Мастера публикации в Интернете
Понятия
Процедуры
Команды

Для использования Мастера публикации

  1. Выберите меню "Файл" » "Публикация в Интернете"
  2. Следуйте инструкциям по созданию веб-страницы.

Ввод команды: ОПУБЛИКОВАТЬ


Создание веб-страниц с помощью Мастера публикации в Интернете - Команды

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Создание веб-страниц с помощью Мастера публикации в Интернете
Понятия
Процедуры
Команды

Команды
ОПУБЛИКОВАТЬ | Создание HTML-страниц с изображениями выбранных чертежей
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование пометок для рецензирования проектов - Понятия

Совместная работа над проектами
Использование пометок для рецензирования проектов
Понятия
Процедуры
Команды

На последних этапах работы над проектом чертежи обычно публикуются для итогового просмотра и последних исправлений. Замечания и комментарии могут быть размещены в электронной версии чертежа. На основании полученных комментариев проект дорабатывают, а публикацию исправленных чертежей повторяют. Такая работа с электронными пометками упрощает этап согласования, сокращает цикл разработки и в результате повышает эффективность процесса проектирования.

На последних этапах работы над проектом чертежи обычно публикуются для итогового просмотра и последних исправлений. Замечания и комментарии могут быть размещены в электронной версии чертежа. На основании полученных комментариев проект дорабатывают, а публикацию исправленных чертежей повторяют. Такая работа с электронными пометками упрощает этап согласования, сокращает цикл разработки и в результате повышает эффективность процесса проектирования.

  • Коротко об использовании электронных пометок
    При наличии программы Autodesk® Design Review можно вносить пометки в файлы DWF, отправляемые на рецензирование. Затем можно просмотреть эти пометки в программе AutoCAD, внести изменения в чертежи и изменить статус пометок.
  • Публикация чертежей для рецензирования
    Публикация чертежей для рецензирования выполняется на последнем этапе работы над проектом.
  • Вставка пометок
    Для вставки пометок в файл DWF используется программа Autodesk DWF Review. Пометка - это текстовый комментарий или исправление геометрии, выполненное красным цветом и вставленное в DWF-файл.
  • Просмотр пометок
    Для просмотра и управления электронными пометками используется Диспетчер наборов пометок. Для просмотра пометок к проекту их нужно загрузить в Диспетчер наборов пометок.
  • Реакция на пометки
    После изучения полученных пометок можно менять их статус и добавлять комментарии, которые сохраняются вместе с пометкой.
  • Повторная публикация набора пометок
    После того как набор пометок изучен и в чертежи внесены изменения, набор пометок можно повторно опубликовать для дополнительного рецензирования.


Использование пометок для рецензирования проектов - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Понятия
Процедуры
Команды

Для открытия Диспетчера наборов пометок

Для открытия набора пометок

Для просмотра подробностей об отдельной пометке в Диспетчере наборов пометок

Для открытия листа чертежа с пометками из Диспетчера наборов пометок

Для отображения или скрытия DWG-геометрии для листов чертежа с пометками

Отображение или скрытие геометрии файла DWF в области рисования

Отображение или скрытие геометрии пометок в области рисования

Для вывода чертежа с пометками на печать

Для закрытия Диспетчера наборов пометок

Для изменения статуса пометки

Для добавления комментариев к пометке

Для сохранения изменений в пометках

Для повторной публикации чертежа с набором пометок


Использование пометок для рецензирования проектов - Команды

Совместная работа над проектами
Использование пометок для рецензирования проектов
Понятия
Процедуры
Команды
Команды
НПОТКРЫТЬ | Открывает файл DWF, который содержит пометки
ПМТЗАКРЫТЬ | Закрывает Диспетчер наборов пометок
ПМТНАБОР | Отображает сведения о пометках с возможностью изменения их статуса
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко об использовании электронных пометок - Понятия

Совместная работа над проектами
Использование пометок для рецензирования проектов
Коротко об использовании электронных пометок
Понятия
Процедуры
Команды

При наличии программы Autodesk® Design Review можно вносить пометки в файлы DWF, отправляемые на рецензирование. Затем можно просмотреть эти пометки в программе AutoCAD, внести изменения в чертежи и изменить статус пометок.

При необходимости получения рецензии на проект можно опубликовать его в виде файла в формате Design Web Format™ (DWF™) и разослать клиентам или рецензентам. Рецензент может открыть файл DWF в программе Autodesk® Design Review, внести в файл пометки в электронном виде и отправить его обратно. Если DWF-файл с пометками открыть в AutoCAD®, отображающиеся красным цветом пометки можно просмотреть в области рисования, отключить их, внести изменения, изменить статус пометок и снова опубликовать файл DWF для отправки на повторное рецензирование.

Примечание С помощью программы Autodesk® DWF™ Viewer можно открыть и просмотреть файл DWF, содержащий пометки; однако, создавать пометки можно только в программе Autodesk Design Review.


Использование пометок для рецензирования проектов

Совместная работа над проектами
Использование пометок для рецензирования проектов
Использование пометок для рецензирования проектов
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Коротко об использовании электронных пометок - Команды

Использование пометок для рецензирования проектов
Использование пометок для рецензирования проектов
Коротко об использовании электронных пометок
Понятия
Процедуры
Команды

Команды
НПОТКРЫТЬ | Открывает файл DWF, который содержит пометки
ПМТЗАКРЫТЬ | Закрывает Диспетчер наборов пометок
ПМТНАБОР | Отображает сведения о пометках с возможностью изменения их статуса
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Публикация чертежей для рецензирования - Понятия

Совместная работа над проектами
Использование пометок для рецензирования проектов
Публикация чертежей для рецензирования
Понятия
Процедуры
Команды

Чертежи для рецензирования публикуются на последнем этапе работы над проектом. Для того, чтобы электронные пометки, созданные в программе Autodesk Design Review, совместить с исходной геометрией чертежа, важно не изменять в файле чертежа элементы, которые могут оказать влияние на это совмещение после публикации файла DWF для рецензирования. К этим элементам относятся:

  • слои и состояния слоев
  • слои, на которых расположены объекты
  • количество и размещение видовых экранов на листах
  • расположение и масштаб объектов на видовых экранах
  • углы поворота видов
  • большинство объектов чертежа


Публикация чертежей для рецензирования - Команды

Использование пометок для рецензирования проектов
Использование пометок для рецензирования проектов
Публикация чертежей для рецензирования
Понятия
Процедуры
Команды

Команды
ПУБЛ | Публикует чертежи в DWF-файлах или на плоттерах
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вставка пометок - Понятия

Совместная работа над проектами
Использование пометок для рецензирования проектов
Вставка пометок
Понятия
Процедуры
Команды

Для вставки пометок в файл DWF используется программа Autodesk DWF Review. Пометка - это текстовый комментарий или исправление геометрии, выполненное красным цветом и вставленное в DWF-файл.

С помощью программы Autodesk DWF Composer можно вносить в чертеж электронные пометки, аналогичные пометкам на листе бумаги. Кроме внесения геометрических исправлений красным шрифтом, в DWF-файле можно назначать статус пометок и добавлять комментарии. Пометки и их статус сохраняются в DWF-файле. Дополнительные сведения о создании пометок с помощью программы Autodesk Design Review см. документацию "Справочная система Autodesk Design Review".


Вставка пометок - Команды

Использование пометок для рецензирования проектов
Использование пометок для рецензирования проектов
Вставка пометок
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Просмотр пометок - Понятия

Совместная работа над проектами
Использование пометок для рецензирования проектов
Просмотр пометок
Понятия
Процедуры
Команды

Набор пометок - это группа пометок, содержащихся в отдельном DWF-файле. При загрузке набора пометок в Диспетчер наборов пометок в области структуры отображаются все листы чертежа и связанные с ними пометки. В Диспетчере наборов пометок можно выбирать отдельные пометки, просматривать их статус и другие подробности, такие как сведения об авторе пометки, дате и времени ее создания и любые комментарии, связанные с пометкой.

Другие типы пометок, которые можно создавать в Autodesk DWF Review и просматривать в файле DWF, это текстовые блоки, геометрические объекты красного цвета, размеры и штампы. Но из всех этих пометок только комментарии имеют статус и отображаются в Диспетчере наборов пометок.

В программе Autodesk DWF Review предусмотрены следующие способы внесения изменений в файлы DWF:

  • Изменение порядка листов в DWF-файле
  • Добавление листов в DWF-файл
  • Удаление листов из файла DWF

Если открытый набор пометок хранится в файле DWF, к которому были добавлены листы, из которого были удалены листы или в котором был изменен порядок листов (с помощью Autodesk DWF Review), в окне "Диспетчер наборов пометок" будет отображаться новый порядок листов. Все листы, добавленные в файл DWF с помощью Autodesk DWF Review, выделяются курсивным шрифтом. Если дважды нажать кнопку мыши на листе, добавленном с помощью Autodesk DWF Review, или на пометке, нанесенной для такого листа, этот лист из файла DWF открывается в программе Autodesk DWF Viewer (или Autodesk DWF Review, если эта программа установлена в системе).

При попытке загрузить набор пометок, открыв в программе AutoCAD файл DWF, в котором нет пометок, файл не будет открыт. Такой DWF-файл можно открыть только с помощью Autodesk DWF Viewer.

При двойном нажатии в Диспетчере наборов пометок на пометке, нанесенной в пространстве модели, исходный файл чертежа открывается в пространстве модели и принимает тот угол поворота вида, который был текущим при сохранении чертежа. Если в дальнейшем изменить угол поворота вида, пометки не будут отображаться в чертеже до тех пор, пока пользователь не вернется к исходному виду, повторно произведя двойное нажатие на пометке.

С помощью Диспетчера наборов пометок можно указать объекты для отображения в области рисования. Можно показывать и скрывать исходный файл чертежа, геометрию файла DWF и геометрию электронных пометок. Благодаря этому пользователь может просмотреть электронные пометки, отключить их для внесения изменений в файл чертежа, а затем снова просмотреть пометки в программе AutoCAD для проверки исправлений.

При просмотре пометок полезны следующие рекомендации:

  • Для просмотра в программе AutoCAD геометрии DWF после получения файла DWF с пометками следует изменить цвет фона в пространстве модели чертежа на светлый оттенок, отличный от черного.
  • Для того чтобы при загрузке набора пометок был корректно выполнен поиск соответствующих файлов чертежей, следует занести файлы чертежей, на основе которых был сформирован файл DWF, в путь поиска. (Путь поиска задается на вкладке "Файлы" диалогового окна "Настройка".)

Примечание Пометки можно просмотреть в программе AutoCAD, только если файл DWF был создан в AutoCAD 2005 или более поздней версии. Чтобы просмотреть пометки с помощью программы AutoCAD, требуется исходный файл чертежа. В программе Autodesk DWF Viewer можно открыть файлы DWF, созданные в более ранних версиях программы AutoCAD.


Просмотр пометок - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Просмотр пометок
Понятия
Процедуры
Команды

Для открытия Диспетчера наборов пометок

Для открытия набора пометок

Для просмотра подробностей об отдельной пометке в Диспетчере наборов пометок

Для открытия листа чертежа с пометками из Диспетчера наборов пометок

Для отображения или скрытия DWG-геометрии для листов чертежа с пометками

Отображение или скрытие геометрии файла DWF в области рисования

Отображение или скрытие геометрии пометок в области рисования

Для вывода чертежа с пометками на печать

Для закрытия Диспетчера наборов пометок


Для открытия Диспетчера наборов пометок - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Просмотр пометок
Понятия
Процедуры
Команды

Для открытия Диспетчера наборов пометок

  • Выберите в меню "Сервис" » "Палитры" » "Диспетчер наборов пометок".

Панель "Стандартная"

Ввод команды: ПМТНАБОР


Для открытия набора пометок - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Просмотр пометок
Понятия
Процедуры
Команды

Для открытия набора пометок

  1. Для открытия набора пометок воспользоваться одним из следующих способов:
    • Выберите "Файл" » "Загрузить набор пометок".
    • В Диспетчере наборов пометок нажмите элемент "Список наборов пометок". Нажмите кнопку "Открыть".
  2. В диалоговом окне "Открытие файла пометок DWF" выберите DWF-файл, содержащий пометки. Нажмите кнопку "Открыть".

    3. Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

    Примечание При попытке загрузить набор пометок, открыв в программе AutoCAD файл DWF, в котором нет пометок, не будет открыт. Такой DWF-файл можно открыть только с помощью Autodesk DWF Viewer.

Панель "Стандартная"

Ввод команды: НПОТКРЫТЬ


Для просмотра подробностей об отдельной пометке в Диспетчере наборов пометок - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Просмотр пометок
Понятия
Процедуры
Команды

Для просмотра подробностей об отдельной пометке в Диспетчере наборов пометок

  1. Выберите "Файл" » "Загрузить набор пометок".
  2. В диалоговом окне "Открытие файла пометок DWF" выберите DWF-файл, содержащий пометки. Нажмите кнопку "Открыть".

    3. Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере наборов пометок выделите нужную пометку.

    4. В группе "Подробности" в нижней части Диспетчера наборов пометок отображаются сведения о выбранной пометке.

Панель "Стандартная"

Ввод команды: НПОТКРЫТЬ


Для открытия листа чертежа с пометками из Диспетчера наборов пометок - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Просмотр пометок
Понятия
Процедуры
Команды

Для открытия листа чертежа с пометками из Диспетчера наборов пометок

  1. Выберите "Файл" » "Загрузить набор пометок".
  2. В диалоговом окне "Открытие файла пометок DWF" выберите DWF-файл, содержащий пометки. Нажмите кнопку "Открыть".

    3. Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере наборов пометок дважды нажмите лист чертежа или узел пометки.

    4. При двойном нажатии узла пометки в области рисования откроется лист чертежа, соответствующий пометке. Для просмотра листа чертежа, связанного с DWF-файлом с пометками, требуется доступ к исходному DWG-файлу, на основе которого был создан DWF-файл.

    Примечание Для просмотра пометок в области чертежа необходим визуальный стиль "2D каркас".

Панель "Стандартная"

Ввод команды: НПОТКРЫТЬ


Для отображения или скрытия DWG-геометрии для листов чертежа с пометками - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Просмотр пометок
Понятия
Процедуры
Команды

Для отображения или скрытия DWG-геометрии для листов чертежа с пометками

  1. Выберите "Файл" » "Загрузить набор пометок".
  2. В диалоговом окне "Открытие файла пометок DWF" выберите DWF-файл, содержащий пометки. Нажмите кнопку "Открыть".

    3. Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере наборов пометок дважды нажмите лист чертежа, чтобы открыть исходный DWG-файл.
  4. Нажмите кнопку "Просмотр геометрии DWG" для скрытия DWG-геометрии. Для отображения DWG-геометрии нажмите эту кнопку еще раз.

    5. Примечание При открытии файла DWG, с которым не связаны пометки, или в случае, если набор пометок не загружен в Диспетчер наборов пометок, следующие кнопки Диспетчера наборов пометок недоступны: "Повторить публикацию файла DWF", "Просмотр геометрии DWG", "Просмотр геометрии DWF", "Просмотр геометрии пометок".

Панель "Стандартная"

Ввод команды: НПОТКРЫТЬ


Отображение или скрытие геометрии файла DWF в области рисования - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Просмотр пометок
Понятия
Процедуры
Команды

Отображение или скрытие геометрии файла DWF в области рисования

  1. Выберите "Файл" » "Загрузить набор пометок".
  2. В диалоговом окне "Открытие файла пометок DWF" выберите DWF-файл, содержащий пометки. Нажмите кнопку "Открыть".

    3. Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере наборов пометок дважды нажмите лист чертежа, чтобы открыть исходный DWG-файл.
  4. Для отображения DWF-геометрии в Диспетчере наборов пометок нажмите кнопку "Просмотр геометрии DWF". Для скрытия DWF-геометрии нажмите эту кнопку еще раз.

Панель "Стандартная"

Ввод команды: НПОТКРЫТЬ


Отображение или скрытие геометрии пометок в области рисования - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Просмотр пометок
Понятия
Процедуры
Команды

Отображение или скрытие геометрии пометок в области рисования

  1. Выберите "Файл" » "Загрузить набор пометок".
  2. В диалоговом окне "Открытие файла пометок DWF" выберите DWF-файл, содержащий пометки. Нажмите кнопку "Открыть".

    3. Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. Для отображения геометрии пометки в области рисования выделите ее в Диспетчере пометок.
  4. Нажмите кнопку "Просмотр геометрии пометок" для скрытия электронной пометки. Для отображения электронной пометки нажмите эту кнопку еще раз.

Панель "Стандартная"

Ввод команды: НПОТКРЫТЬ


Для вывода чертежа с пометками на печать - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Просмотр пометок
Понятия
Процедуры
Команды

Для вывода чертежа с пометками на печать

  • В Проводнике произведите двойное нажатие содержащего пометки файла DWF. DWF-файл открывается в Autodesk DWF Viewer. Из этой программы можно его распечатать.


Для закрытия Диспетчера наборов пометок - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Просмотр пометок
Понятия
Процедуры
Команды

Для закрытия Диспетчера наборов пометок

  • При открытом Диспетчере наборов пометок выберите в меню "Сервис" » "Палитры" » "Диспетчер наборов пометок".

Панель "Стандартная"

Ввод команды: ПМТЗАКРЫТЬ


Просмотр пометок - Команды

Использование пометок для рецензирования проектов
Использование пометок для рецензирования проектов
Просмотр пометок
Понятия
Процедуры
Команды

Команды
НПОТКРЫТЬ | Открывает файл DWF, который содержит пометки
ПМТЗАКРЫТЬ | Закрывает Диспетчер наборов пометок
ПМТНАБОР | Отображает сведения о пометках с возможностью изменения их статуса
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Реакция на пометки - Понятия

Совместная работа над проектами
Использование пометок для рецензирования проектов
Реакция на пометки
Понятия
Процедуры
Команды

При выборе пометки в структуре Диспетчера наборов пометок информация о ней отображается в группе "Подробности". Статус пометки можно изменять либо непосредственно в этой области, либо нажатием правой кнопки мыши на пометке и выбором одной из команд из контекстного подменю "Статус".

Статус по умолчанию для новых пометок - <нет>. Можно изменить статус пометки на "Вопрос", "Рассмотрение" или "Выполнено".

Для выбранной пометки можно добавлять комментарии или примечания в области "Примечания", расположенной под группой "Подробности".

Изменения статуса пометки и добавленные комментарии автоматически сохраняются в DWF-файле и включаются в него при повторной публикации. Изменения можно также сохранить, нажав правую кнопку мыши на имени набора пометок и выбрав из контекстного меню пункт "Сохранить журнал пометок".


Реакция на пометки - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Реакция на пометки
Понятия
Процедуры
Команды

Для изменения статуса пометки

Для добавления комментариев к пометке

Для сохранения изменений в пометках


Для изменения статуса пометки - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Реакция на пометки
Понятия
Процедуры
Команды

Для изменения статуса пометки

  1. Выберите "Файл" » "Загрузить набор пометок".
  2. В диалоговом окне "Открытие файла пометок DWF" выберите DWF-файл, содержащий пометки. Нажмите кнопку "Открыть".

    3. Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере пометок нажмите на пометке правую кнопку мыши. Выберите статус в подменю "Статус пометки".

    4. Добавленные комментарии автоматически сохраняются в DWF-файле и включаются в него при повторной публикации. Изменения также можно сохранить, нажав правую кнопку мыши на узле набора пометок. Выберите "Сохранить журнал пометок".

Панель "Стандартная"

Ввод команды: НПОТКРЫТЬ


Для добавления комментариев к пометке - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Реакция на пометки
Понятия
Процедуры
Команды

Для добавления комментариев к пометке

  1. Выберите "Файл" » "Загрузить набор пометок".
  2. В диалоговом окне "Открытие файла пометок DWF" выберите DWF-файл, содержащий пометки. Нажмите кнопку "Открыть".

    3. Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере пометок выделите нужную пометку.
  4. Добавьте комментарии в области "Примечания" под группой "Подробности".

    5. Комментарии сохраняются в DWF-файле и добавляются в него при повторной публикации. Изменения также можно сохранить, нажав правую кнопку мыши на узле набора пометок. Выберите "Сохранить журнал пометок".

Панель "Стандартная"

Ввод команды: НПОТКРЫТЬ


Для сохранения изменений в пометках - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Реакция на пометки
Понятия
Процедуры
Команды

Для сохранения изменений в пометках

  1. Выберите "Файл" » "Загрузить набор пометок".
  2. В диалоговом окне "Открытие файла пометок DWF" выберите DWF-файл, содержащий пометки. Нажмите кнопку "Открыть".

    3. Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере наборов пометок выделите пометку, измените ее статус или добавьте комментарии.
  4. Нажмите правую кнопку мыши на узле набора пометок. Выберите "Сохранить журнал пометок".

    5. Изменения статуса пометки и любые дополнительные комментарии также сохраняются в DWF-файле при закрытии или повторной публикации чертежа.

Панель "Стандартная"

Ввод команды: НПОТКРЫТЬ


Реакция на пометки - Команды

Использование пометок для рецензирования проектов
Использование пометок для рецензирования проектов
Реакция на пометки
Понятия
Процедуры
Команды

Команды
НПОТКРЫТЬ | Открывает файл DWF, который содержит пометки
ПМТЗАКРЫТЬ | Закрывает Диспетчер наборов пометок
ПМТНАБОР | Отображает сведения о пометках с возможностью изменения их статуса
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Повторная публикация набора пометок - Понятия

Совместная работа над проектами
Использование пометок для рецензирования проектов
Повторная публикация набора пометок
Понятия
Процедуры
Команды

При повторной публикации пометки и все внесенные изменения сохраняются в DWF-файле. При просмотре повторно опубликованного файла DWF в Autodesk DWF Composer в нем можно проследить все изменения, внесенные в чертеж, а также увидеть изменения статуса и другие подробности о пометках.

При повторной публикации файла DWF, листы в котором были удалены или переставлены в Autodesk DWF Review, новый порядок листов будет отражен в повторно опубликованном файле DWF; если же какие-либо листы добавлялись в Autodesk DWF Review к файлу DWF, они не будут входить в повторно опубликованный файл DWF.


Для повторной публикации чертежа с набором пометок - Процедуры

Совместная работа над проектами
Использование пометок для рецензирования проектов
Повторная публикация набора пометок
Понятия
Процедуры
Команды

Для повторной публикации чертежа с набором пометок

  1. Выберите "Файл" » "Загрузить набор пометок".
  2. В диалоговом окне "Открытие файла пометок DWF" выберите DWF-файл, содержащий пометки. Нажмите кнопку "Открыть".

    3. Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере наборов пометок нажмите пометку или лист чертежа для открытия исходного DWG-файла.
  4. В области рисования внесите необходимые изменения в файл DWG.
  5. В Диспетчере наборов пометок выделите нужные пометки, измените их статус или добавьте комментарии.
  6. По окончании редактирования чертежа и связанных с ним пометок нажмите кнопку "Повторить публикацию файла DWF" в верхней части Диспетчера набора пометок.

  7. Выберите один из следующих параметров.
    • Повторить публикацию всех листов. При выборе данного параметра производится повторная публикация всех листов файла DWF, содержащего пометки.
    • Повторить публикацию листов с пометками.При выборе данного параметра производится повторная публикация только тех листов файла DWF, которые содержат связанные пометки.
  8. В диалоговом окне "Выбор файла DWF" выберите DWF-файл или введите имя файла DWF. Нажмите "Выбрать".

    9. Если новое имя файла DWF не введено, то в процессе сохранения DWF-файл с пометками, созданный ранее, будет заменен файлом с отредактированным чертежом и пометками, а имя файла останется прежним.

Панель "Стандартная"

Ввод команды: НПОТКРЫТЬ


Повторная публикация набора пометок - Команды

Использование пометок для рецензирования проектов
Использование пометок для рецензирования проектов
Повторная публикация набора пометок
Понятия
Процедуры
Команды

Команды
НПОТКРЫТЬ | Открывает файл DWF, который содержит пометки
ПМТЗАКРЫТЬ | Закрывает Диспетчер наборов пометок
ПМТНАБОР | Отображает сведения о пометках с возможностью изменения их статуса
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание реалистичных графических изображений

Построение 2D изометрических видов
Изометрический стиль шаговой привязки и сетки помогает строить двумерные чертежи, представляющие трехмерные объекты.

Добавление освещения в модель
Для улучшения визуализации модели во время работы или подготовки её к тонированию, можно добавить освещение.

Применение материалов и текстур к объектам
Наряду с освещением, материалы повышают уровень реалистичности моделей.

Реалистичное тонирование 3D объектов
Благодаря реалистичному тонированию модели проект становится более наглядным по сравнению с напечатанным чертежом.


Создание реалистичных графических изображений - Понятия

Создание реалистичных графических изображений
Создание реалистичных графических изображений
Создание реалистичных графических изображений
Понятия
Процедуры
Команды

Построение 2D изометрических видов

Изометрический стиль шаговой привязки и сетки помогает строить двумерные чертежи, представляющие трехмерные объекты.

Глава 33 Добавление освещения в модель

В ходе операций подавления скрытых линий, раскрашивания и тонирования трехмерных объектов программа AutoCAD по-разному обрабатывает различные типы поверхностей.

Применение материалов и текстур к объектам

Для объектов текущего видового экрана возможно подавление вывода скрытых линий и включение раскрашивания.

Реалистичное тонирование 3D объектов

Для объектов текущего видового экрана возможно подавление вывода скрытых линий и включение раскрашивания.

Реалистичное тонирование 3D объектов

Для получения реалистичного изображения 3D объектам можно присваивать различные материалы, а также добавлять в сцены освещение.


Создание реалистичных графических изображений - Процедуры

Создание реалистичных графических изображений
Создание реалистичных графических изображений
Создание реалистичных графических изображений
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Создание реалистичных графических изображений - Команды

Создание реалистичных графических изображений
Создание реалистичных графических изображений
Создание реалистичных графических изображений
Понятия
Процедуры
Команды
Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Построение 2D изометрических видов - Понятия

Создание реалистичных графических изображений
Построение 2D изометрических видов
Понятия
Процедуры
Команды

Изометрический стиль шаговой привязки и сетки помогает строить двумерные чертежи, представляющие трехмерные объекты.

Изометрический стиль шаговой привязки и сетки помогает строить двумерные чертежи, представляющие трехмерные объекты. Изометрическая шаговая привязка (сетка) позволяет расположить объекты в трех изометрических плоскостях. Однако несмотря на имитацию трехмерности в изометрических чертежах, в действительности они являются двумерными. Поэтому для таких видов вычисление 3D расстояний и площадей, просмотр объектов в различных ракурсах, а также автоматическое подавление скрытых линий невозможно.

  • Задание изометрического стиля шаговой привязки и сетки
    Имитация трехмерности за счет расположения объектов по трем изометрическим осям.
  • Построение изометрических кругов
    Изображение кругов в изометрических плоскостях с помощью эллипсов.


Построение 2D изометрических видов - Процедуры

Создание реалистичных графических изображений
Построение 2D изометрических видов
Понятия
Процедуры
Команды

Для включения изометрии

Для быстрой смены изометрической плоскости

Для построения изометрического круга


Построение 2D изометрических видов - Команды

Создание реалистичных графических изображений
Построение 2D изометрических видов
Понятия
Процедуры
Команды
Команды
ИЗОМЕТР | Выбор текущей изометрической плоскости
ОРТО | Ограничивает перемещение курсора в вертикальном или горизонтальном направлении
СЕТКА | Отображение точечной сетки на текущем видовом экране, которая не выводится на печать
ШАГ | Ограничение перемещения курсора определенными интервалами
ЭЛЛИПС | Построение эллипсов и эллиптических дуг
Системные переменные
ISOLINES | Указывает количество линий контура для изображения поверхностей объектов
SNAPISOPAIR | Управляет плоскостью изометрии для текущего видового экрана
SNAPSTYL | Задает стиль шаговой привязки для текущего видового экрана
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание изометрического стиля шаговой привязки и сетки - Понятия

Создание реалистичных графических изображений
Построение 2D изометрических видов
Задание изометрического стиля шаговой привязки и сетки
Понятия
Процедуры
Команды

Имитация трехмерности в изометрических чертежах достигается расположением объектов по трем изометрическим осям.

Изометрическая шаговая привязка (сетка) позволяет расположить объекты в трех изометрических плоскостях. Однако несмотря на имитацию трехмерности в изометрических чертежах, в действительности они являются двумерными. Поэтому для таких видов вычисление 3D расстояний и площадей, просмотр объектов в различных ракурсах, а также автоматическое подавление скрытых линий невозможно.

При нулевом угле поворота шаговой привязки направления изометрических осей следующие: 30, 90 и 150 градусов. Изометрический стиль шаговой привязки позволяет работать в трех плоскостях, каждая из которых определяется своей парой осей:

  • Левая.Сетка и шаговая привязка ориентируются вдоль осей, направленных под углами 90 и 150 градусов.
  • Верхняя.Сетка и шаговая привязка ориентируются вдоль осей, направленных под углами 30 и 150 градусов.
  • Правая.Сетка и шаговая привязка ориентируются вдоль осей, направленных под углами 30 и 90 градусов.

При выборе одной из трех изометрических плоскостей шаговая привязка, сетка и перекрестье курсора поворачиваются соответственно выбранным изометрическим осям. Например, при включенном режиме "Орто" указываемые при рисовании точки располагаются в текущей изометрической плоскости. Таким образом, можно вначале выполнить построения на верхней плоскости модели, затем переключиться в левую плоскость и построить эту сторону модели, и наконец завершить рисование, выбрав правую плоскость.


Задание изометрического стиля шаговой привязки и сетки - Процедуры

Создание реалистичных графических изображений
Построение 2D изометрических видов
Задание изометрического стиля шаговой привязки и сетки
Понятия
Процедуры
Команды

Для включения изометрии

Для быстрой смены изометрической плоскости


Для включения изометрии - Процедуры

Создание реалистичных графических изображений
Построение 2D изометрических видов
Задание изометрического стиля шаговой привязки и сетки
Понятия
Процедуры
Команды

Для включения изометрии

  1. Выберите "Сервис" » "Режимы черчения".
  2. В диалоговом окне "Режимы черчения" на вкладке "Шаг и сетка" в поле "Тип привязки" выберите "Изометрическая".
  3. Нажмите "ОК".

Для циклического переключения между тремя плоскостями можно воспользоваться клавишей F5.

Ввод команды: РЕЖИМЧРТ


Для быстрой смены изометрической плоскости - Процедуры

Создание реалистичных графических изображений
Построение 2D изометрических видов
Задание изометрического стиля шаговой привязки и сетки
Понятия
Процедуры
Команды

Для быстрой смены изометрической плоскости

  • Нажмите F5 или CTRL+E для смены изометрической плоскости.

Программа циклически переключается между верхней, правой и левой изометрическими плоскостями.


Задание изометрического стиля шаговой привязки и сетки - Команды

Построение 2D изометрических видов
Построение 2D изометрических видов
Задание изометрического стиля шаговой привязки и сетки
Понятия
Процедуры
Команды

Команды
ИЗОМЕТР | Выбор текущей изометрической плоскости
ОРТО | Ограничивает перемещение курсора в вертикальном или горизонтальном направлении
СЕТКА | Отображение точечной сетки на текущем видовом экране, которая не выводится на печать
ШАГ | Ограничение перемещения курсора определенными интервалами
Системные переменные
ISOLINES | Указывает количество линий контура для изображения поверхностей объектов
SNAPISOPAIR | Управляет плоскостью изометрии для текущего видового экрана
SNAPSTYL | Задает стиль шаговой привязки для текущего видового экрана
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Построение изометрических кругов - Понятия

Создание реалистичных графических изображений
Построение 2D изометрических видов
Построение изометрических кругов
Понятия
Процедуры
Команды

Изображение кругов в изометрических плоскостях с помощью эллипсов.

При рисовании на изометрических плоскостях круги, рассматриваемые под углом к плоскости, представляются эллипсами. Наиболее удобный способ построения таких эллипсов обеспечивает параметр "Изокруг" команды ЭЛЛИПС. Функция изоцикличности доступна, только если для параметра "Тип привязки" режима шаговой привязки установить значение "Изометрическая" (см. команду РЕЖИМЧРТ).

Примечание Для создания концентрических кругов следует построить другие эллипсы с таким же центром. Функция построения подобных объектов дает здесь неверный результат, а именно сплайн овальной формы.


Для построения изометрического круга - Процедуры

Создание реалистичных графических изображений
Построение 2D изометрических видов
Построение изометрических кругов
Понятия
Процедуры
Команды

Для построения изометрического круга

  1. Выберите "Сервис" » "Режимы черчения".
  2. В диалоговом окне "Режимы черчения" на вкладке "Шаг и сетка" выберите "Изометрическая".
  3. Нажмите "ОК".
  4. Выберите "Рисование" » "Эллипс" » "Ось, конец".
  5. Введите и (изокруг).
  6. Укажите центр круга.
  7. Задайте радиус или диаметр круга.

    8. Панель "Рисование"

Ввод команды: ЭЛЛИПС


Построение изометрических кругов - Команды

Построение 2D изометрических видов
Построение 2D изометрических видов
Построение изометрических кругов
Понятия
Процедуры
Команды

Команды
ИЗОМЕТР | Выбор текущей изометрической плоскости
ЭЛЛИПС | Построение эллипсов и эллиптических дуг
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление освещения в модель - Понятия

Создание реалистичных графических изображений
Добавление освещения в модель
Понятия
Процедуры
Команды

Для улучшения визуализации модели во время работы или подготовки её к тонированию, можно добавить освещение.

  • Обзор функции освещения
  • Создание и управление источниками света
    В процессе работы можно добавлять различные виды освещения (точечное, прожектор, удалённое), менять их расположение и свойства.
  • Симуляция солнечного света
    Солнечный свет - это вид освещения, который создает эффект естественного освещения и используется для демонстрации влияния теней от объекта на окружающий вид.


Добавление освещения в модель - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Понятия
Процедуры
Команды

Трансформация типов освещения, созданных в предыдущих версиях, в формат AutoCAD 2007

Создание точечного источника света

Создание прожектора

Создание удалённого источника света

Создание инструмента точечного источника света или прожектора

Управление видом обозначения источников света

Отображение/отключение обозначений источников света

Печать обозначений источников света

Выбор освещения

Удаление источника света

Установка параметров затухания точечного света и прожектора

Определение исходного вектора источника удаленного освещения.

Для перемещения точечного источника света и прожектора

Изменение цвета освещения

Включение и выключение освещения солнечным светом на чертеже

Для изменения яркости солнца

Для изменения географического положения модели

Изменение угла солнечного света

Изменение цвета солнечного света


Добавление освещения в модель - Команды

Создание реалистичных графических изображений
Добавление освещения в модель
Понятия
Процедуры
Команды
Команды
ГЕОПОЛОЖЕНИЕ | Задание широты и долготы расположения
ГЕОПОЛОЖЕНИЕ | Задание широты и долготы расположения
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПРЕОБРУСТАРСВЕТ | Преобразует формат отображения источников света, созданных в предыдущих версиях, в формат программы AutoCAD 2007
ПРОЖЕКТОР | Создание прожектора
ПРОЖЕКТОР | Создание прожектора
СВЕТ | Создает источник света
СВОЙСТВАСОЛНЦА | Вызов окна "Свойства солнца" для определения свойств солнца
СВОЙСТВАСОЛНЦА | Вызов окна "Свойства солнца" для определения свойств солнца
СВОЙСТВАСОЛНЦАЗАКР | Закрытие окна "Свойства Солнца"
СПИСОКСВЕТ | Открывает источники света в окне "Модель", чтобы добавить и изменить источники света.
СПИСОКСВЕТЗАКР | Закрывает источники света в окне "Модель"
ТОЧСВЕТ | Создается точечный источник света
ТОЧСВЕТ | Создается точечный источник света
УДАЛСВЕТ | Эта команда создает удаленный источник света
УДАЛСВЕТ | Эта команда создает удаленный источник света
Системные переменные
DEFAULTLIGHTING | Управляет освещением по умолчанию в текущем видовом экране
DEFAULTLIGHTINGTYPE | Указывает тип освещения по умолчанию
LIGHTGLYPHDISPLAY | Управляет отображением обозначений источников света
LIGHTLISTSTATE | Указывает, открыто ли окно источников света в модели
NORTHDIRECTION | Задает угол смещения Вс от севера
SUNPROPERTIESSTATE | Указывает, открыто окно Свойств солнца или нет.
SUNSTATUS | Управляет излучением солнечного света на текущем видовом экране
TIMEZONE | Устанавливает часовой пояс для вс в чертеже
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор функции освещения - Понятия

Создание реалистичных графических изображений
Добавление освещения в модель
Обзор функции освещения
Понятия
Процедуры
Команды

Хорошее освещение может оказаться очень полезным для осмотра раскрашенной трёхмерной модели во время создания тонировки.

Освещение по умолчанию

Во время работы в окне просмотра в трёхмерном раскрашенном виде освещение, по умолчанию, подаётся из двух точек, которые перемещаются вслед за движением модели. Все поверхности модели освещаются таким образом, чтобы визуально отличаться друг от друга. Можно контролировать яркость и контраст, но нет необходимости создавать или располагать источники света самостоятельно. Освещение по умолчанию можно отключить, если необходимо показать солнечное освещение или освещение, созданное пользователем.

Создание пользовательских источников света

Для улучшения вида объекта и получения необходимых эффектов освещение можно изменить на точечное, удалённое или прожекторное. С помощью инструментов ручек источники света можно перемещать и вращать, включать и выключать, а также менять их свойства, например цвет. Все изменения сразу же отображаются на экране.

Точечные источники света и прожектора отображаются различными обозначениями источников света. Удалённые источники освещения, а также солнечный свет не отображаются обозначениями на чертеже. При необходимости, обозначения источников света можно включать или выключать. По умолчанию обозначения источников света не печатаются.

Солнечный свет

Солнечный свет - это особый вариант удалённого освещения. Угол солнечного освещения определяется географическим местоположением, а также датой и временем, которые задаются для конкретной модели. В зависимости от желания пользователя, интенсивность и цвет освещения также могут меняться.


Трансформация типов освещения, созданных в предыдущих версиях, в формат AutoCAD 2007 - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Обзор функции освещения
Понятия
Процедуры
Команды

Трансформация типов освещения, созданных в предыдущих версиях, в формат AutoCAD 2007

  • Ввестипреобрустарсвет.


Обзор функции освещения - Команды

Добавление освещения в модель
Добавление освещения в модель
Обзор функции освещения
Понятия
Процедуры
Команды

Команды
ГЕОПОЛОЖЕНИЕ | Задание широты и долготы расположения
ПРЕОБРУСТАРСВЕТ | Преобразует формат отображения источников света, созданных в предыдущих версиях, в формат программы AutoCAD 2007
ПРОЖЕКТОР | Создание прожектора
СВЕТ | Создает источник света
СВОЙСТВАСОЛНЦА | Вызов окна "Свойства солнца" для определения свойств солнца
ТОЧСВЕТ | Создается точечный источник света
УДАЛСВЕТ | Эта команда создает удаленный источник света
Системные переменные
DEFAULTLIGHTING | Управляет освещением по умолчанию в текущем видовом экране
DEFAULTLIGHTINGTYPE | Указывает тип освещения по умолчанию
LIGHTGLYPHDISPLAY | Управляет отображением обозначений источников света
SUNSTATUS | Управляет излучением солнечного света на текущем видовом экране
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и управление источниками света - Понятия

Создание реалистичных графических изображений
Добавление освещения в модель
Создание и управление источниками света
Понятия
Процедуры
Команды

В процессе работы можно добавлять различные виды освещения (точечное, прожектор, удалённое), менять их расположение и свойства.

  • Выбор типа источника освещения
    Разные варианты освещения могут создавать различные эффекты на чертеже.
  • Управление расположением и свойствами источников света
    Каждый вариант освещения, который добавляется в чертёж, перечислен в "Источниках света" окна "Модель" (СПИСОКСВЕТ). Источники освещения в группах и ссылках, солнечный свет и освещение по умолчанию не отображаются.


Создание и управление источниками света - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Создание и управление источниками света
Понятия
Процедуры
Команды

Создание точечного источника света

Создание прожектора

Создание удалённого источника света

Создание инструмента точечного источника света или прожектора

Управление видом обозначения источников света

Отображение/отключение обозначений источников света

Печать обозначений источников света

Выбор освещения

Удаление источника света

Установка параметров затухания точечного света и прожектора

Определение исходного вектора источника удаленного освещения.

Для перемещения точечного источника света и прожектора

Изменение цвета освещения


Создание и управление источниками света - Команды

Создание реалистичных графических изображений
Добавление освещения в модель
Создание и управление источниками света
Понятия
Процедуры
Команды
Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПРОЖЕКТОР | Создание прожектора
СВЕТ | Создает источник света
СПИСОКСВЕТ | Открывает источники света в окне "Модель", чтобы добавить и изменить источники света.
СПИСОКСВЕТЗАКР | Закрывает источники света в окне "Модель"
ТОЧСВЕТ | Создается точечный источник света
УДАЛСВЕТ | Эта команда создает удаленный источник света
Системные переменные
LIGHTGLYPHDISPLAY | Управляет отображением обозначений источников света
LIGHTLISTSTATE | Указывает, открыто ли окно источников света в модели
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выбор типа источника освещения - Понятия

Создание реалистичных графических изображений
Добавление освещения в модель
Выбор типа источника освещения
Понятия
Процедуры
Команды

Разные варианты освещения могут создавать различные эффекты на чертеже.

Для создания источника света можно использовать команду, кнопку на панели "Источники света" или на панели источников света пульта управления. Цвет и другие особенности выбранного освещения можно изменить во вкладке "Свойства" Освещение и его настройки можно сохранить в палитре инструментов и использовать в дальнейшем как для исходного чертежа, так и для других чертежей.

Точечные источники света

Точечный источник света испускает лучи во всех направлениях. Интенсивность освещения при его использовании снижается пропорционально расстоянию, если опция затухания не отключена. Точечный свет также используется для создания общих эффектов освещения.

Прожекторы

Прожектор испускает направленный конус света. Имеется возможность управлять направлением света и размером конуса. Интенсивность освещения при его использовании снижается пропорционально расстоянию. Прожекторы применяют для выборочной подсветки отдельных элементов и областей модели.

Удалённые источники света

Удаленный источник света испускает параллельные лучи только в одном направлении. Для задания направления распространения света в любом месте видового экрана задаются точки ОТКУДА и КУДА. Обозначения источников света не отображаются при освещении от удалённого источника.

Интенсивность освещения в этом случае не зависит от расстояния, оставаясь постоянной в любой точке. Это очень удобно для равномерного освещения и объекта, и фона.


Выбор типа источника освещения - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Выбор типа источника освещения
Понятия
Процедуры
Команды

Создание точечного источника света

Создание прожектора

Создание удалённого источника света

Создание инструмента точечного источника света или прожектора

Управление видом обозначения источников света

Отображение/отключение обозначений источников света

Печать обозначений источников света


Создание точечного источника света - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Выбор типа источника освещения
Понятия
Процедуры
Команды

Создание точечного источника света

  1. Выберите в меню "Вид" » "Тонирование" » "Источники света" » "Новый точечный источник света".

    2. Также источник света можно перетащить со вкладки "Источники света" из окна инструментальных палитр.

  2. Нажатием кнопки мыши в области чертежа устанавливается расположение источника света.
  3. Введите n и задайте имя.

    4. Можно продолжит задание свойств, вводя значения параметров, или выйти из окна и задать свойства в интерактивном режиме. При использовании интерактивного способа результаты вносимых изменений отображаются в процессе работы.

  4. Нажмите ENTER для завершения команды.

    5. Выбрав тип освещения, можно менять его характеристики с помощью ручек и палитры "Свойства".

    Панель инструментов "Источники света"

    Ввод команды: ТОЧСВЕТ

    Пульт управления: Панель "Источники света" (разворачивается щелчком кнопки мыши), "Создание точечного источника света"


Создание прожектора - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Выбор типа источника освещения
Понятия
Процедуры
Команды

Создание прожектора

  1. Выберите в меню "Вид" » "Тонирование" » "Источники света" » "Новый прожектор".

    2. Также источник света можно перетащить со вкладки "Источники света" из окна инструментальных палитр.

  2. Нажатием кнопки мыши в области чертежа устанавливается расположение источника света.
  3. Затем таким же образом определяется объект освещения.
  4. Введите n и задайте имя.

    5. Можно продолжит задание свойств, вводя значения параметров, или выйти из окна и задать свойства в интерактивном режиме. При использовании интерактивного способа результаты вносимых изменений отображаются в процессе работы.

  5. Нажмите ENTER для завершения команды.

    6. Выбрав тип освещения, можно менять его характеристики с помощью ручек и палитры "Свойства".

    Панель инструментов "Источники света"

    Ввод команды: ПРОЖЕКТОР

    Пульт управления: Панель "Источники света" (разворачивается нажатием кнопки мыши), "Создание прожектора"


Создание удалённого источника света - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Выбор типа источника освещения
Понятия
Процедуры
Команды

Создание удалённого источника света

  1. Выберите в меню "Вид" » "Тонирование" » "Источники света" » "Новый удалённый свет".
  2. Нажатием кнопки мыши в области чертежа устанавливается расположение источника света.
  3. Затем определяется направление светового луча.
  4. Введите n и задать имя.

    5. Можно продолжить задание свойств, вводя значения параметров, или выйти из окна и задать свойства в интерактивном режиме. При использовании интерактивного способа результаты вносимых изменений отображаются в процессе работы.

  5. Нажмите ENTER для завершения команды.

    6. Введите списоксвет, чтобы открыть "Источники света" в окне "Модель". После выбора типа освещения, можно менять его цвет и другие характеристики с помощью палитры "Свойства".

    Панель инструментов "Источники света"

    Ввод команды: УДАЛСВЕТ

    Пульт управления: Панель "Источники света" (разворачивается нажатием кнопки мыши), "Создание удалённого источника света"


Создание инструмента точечного источника света или прожектора - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Выбор типа источника освещения
Понятия
Процедуры
Команды

Создание инструмента точечного источника света или прожектора

  1. Выберите в меню "Сервис" » "Палитры" » "Инструментальные палитры".
  2. Выберите точечный источник света или прожектор, свойства которого будут использованы для инструмента.
  3. Перетащите источник света в действующую палитру инструментов.

    4. При этом у нового инструмента источника света сохранятся все исходные свойства, исключая местоположение.


Управление видом обозначения источников света - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Выбор типа источника освещения
Понятия
Процедуры
Команды

Управление видом обозначения источников света

  1. Выберите в меню "Сервис" » "Настройки" » вкладка "Построения" » "Установка обозначения источников света".
  2. В диалоговом окне "Вид обозначений источников света" выберите "Точка" или "Пятно", чтобы отобразить обозначение текущего точечного источника света или прожектора в качестве "Образца обозначения".
  3. Изменить цвет можно в диалоговом окне "Цвета окна построения", активировав "Редактор цветов обозначений".

    4. Дополнительную информацию см. в разделе Для настройки цветов элементов окна приложения

  4. Для изменения размера обозначения используется бегунок "Размер обозначения".
  5. Для выхода из любого диалогового окна нажмите на "ОК".

    6. Ввод команды: НАСТРОЙКА


Отображение/отключение обозначений источников света - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Выбор типа источника освещения
Понятия
Процедуры
Команды

Отображение/отключение обозначений источников света

  1. Выберите "Сервис" » "Палитры" » "Пульт управления".
  2. На панели "Источники света" нажмите на стрелку для разворачивания.
  3. Затем выберите "Обозначения источников света вкл" или "Обозначения источников света выкл".

    4. Экранные установки не позволяют обеспечить отображение обозначений источников света при печати.

Ввод команды: LIGHTGLYPHDISPLAY


Печать обозначений источников света - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Выбор типа источника освещения
Понятия
Процедуры
Команды

Печать обозначений источников света

  1. Выберите в меню "Сервис" » "Палитры" » "Свойства".
  2. Выберите точечный источник света или прожектор.
  3. На палитре "Свойства" задайте для параметра "Печать обозначений" значение "Да".

Панель Стандартная

Ввод команды: ОКОНСВ


Выбор типа источника освещения - Команды

Добавление освещения в модель
Добавление освещения в модель
Выбор типа источника освещения
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
ПРОЖЕКТОР | Создание прожектора
СВЕТ | Создает источник света
СПИСОКСВЕТ | Открывает источники света в окне "Модель", чтобы добавить и изменить источники света.
СПИСОКСВЕТЗАКР | Закрывает источники света в окне "Модель"
ТОЧСВЕТ | Создается точечный источник света
УДАЛСВЕТ | Эта команда создает удаленный источник света
Системные переменные
LIGHTGLYPHDISPLAY | Управляет отображением обозначений источников света
LIGHTLISTSTATE | Указывает, открыто ли окно источников света в модели
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление расположением и свойствами источников света - Понятия

Создание реалистичных графических изображений
Добавление освещения в модель
Управление расположением и свойствами источников света
Понятия
Процедуры
Команды

Каждый вариант освещения, который добавляется в чертёж, перечислен в "Источниках света" окна "Модель" (СПИСОКСВЕТ). Источники освещения в группах и ссылках, солнечный свет и освещение по умолчанию не отображаются.

Если выбрать источник света в списке, он окажется выбранным и в чертеже, и наоборот. Характеристики источников света в списке сохраняются в соответствии с чертежом. Всех характеристики могут изменяться в палитре "Свойства". Когда источник света для чертежа выбран, можно использовать ручки для его перемещения или вращения, а также менять отдельные свойства, такие как бликование или угол конуса у прожектора. Эффекты освещения меняются одновременно с изменением свойств источника.

Ряд свойств будет общим для всех видов освещения в списке:

  • Тип. Определяет тип освещения: точечный, прожектор или удалённый.
  • Статус. Определяет, светит ли источник, если освещение по умолчанию выключено.
  • Тени. Определяет, отбрасываются ли тени. Для отображения тени должны быть включены в параметры стиля изображения текущего видового экрана. Отключение теней увеличивает производительность.
  • Интенсивность. Устанавливает коэффициент, контролирующий яркость. Интенсивность не связана с затуханием освещения.
  • Цвет. Устанавливает цвет испускаемого света.
Расположение (для точечного источника света и прожектора)

Можно использовать позиционные ручки для перемещения точечного источника света или установить его местоположение в палитре "Свойства". Позиционные ручки перемещают источник света, но не меняют целевую область освещения. Для перемещения и того, и другого необходимо перетащить само изображение обозначения источника света.

Исходный вектор (для удалённого источника света)

Удаленный свет требует задания направления, которое задается определением исходного вектора. Для задания точек распространения света ОТ и ДО можно использовать устройство указания или ввести направление вектора.

Затухание (для точечного источника света и прожектора)

Эта функция определяет ослабление света в зависимости от дистанции. Чем дальше расположен объект от источника света, тем темнее он выглядит. Можно задать отсутствие затухания, линейную инверсию или квадратичную инверсию (ТОЧСВЕТ, ПРОЖЕКТОР).

Другим способом контроля точек источника и объекта освещения является использование пределов. Пределы используются в виде секущих плоскостей, определяющих, откуда свет испускается и где прекращается. Использование пределов может увеличить производительность посредством отмены необходимости для программы рассчитывать уровень света там, где он практически невидим.

Примечание Ограничения затухания поддерживаются только для тонирования, но не для видовых экранов. Драйвер OpenGL (wopengl9.hdi) не поддерживает начальные и конечные пределы затухания. Для идентификации драйвера надо ввести команду графнастр, выбрать ручную настройку и посмотреть имя выбранного драйвера в диалоговом окне "Ручная оптимизация параметров".

Максимальное пятно и спад освещённости (прожектор)

Попадая на освещаемую поверхность, свет от прожектора дает в центре пятно максимальной освещенности, окруженное переходной областью меньшей интенсивности.

  • Угол конуса максимальной освещенности. Определяет наиболее яркую часть светового пучка. Также может называться угол светового пучка.
  • Полный световой конус. Задаёт параметры светового конуса. Также может называться угол поля.
  • Зона быстрого рассеивания. Представляет собой пространство между зоной максимальной освещённости и углом ограничения светового конуса.

Чем больше разница между ярким пятном и полным световым конусом, тем мягче граничная кромка освещаемого пятна. Если угол наибольшей освещённости равен углу ограничения светового конуса, или близки по величине, освещаемое пятно имеет чёткие очертания. Оба этих угла могут принимать значения в пределах от 0 до 160 градусов. Эти значения можно задать напрямую соответствующими ручками спада освещенности.


Управление расположением и свойствами источников света - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Управление расположением и свойствами источников света
Понятия
Процедуры
Команды

Выбор освещения

Удаление источника света

Установка параметров затухания точечного света и прожектора

Определение исходного вектора источника удаленного освещения.

Для перемещения точечного источника света и прожектора

Изменение цвета освещения


Выбор освещения - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Управление расположением и свойствами источников света
Понятия
Процедуры
Команды

Выбор освещения

  • Можно использовать чередование для выбора обозначения источников света или выбора освещения в "Источниках света" окна модели.

    • Примечание Удалённые источники не обозначаются на чертеже. Панель "Источники света" используется в окне "Модель" для выбора удалённого освещения.

    В меню "Вид" » "Тонирование" » "Источники света" » "Список источников света"

    Панель "Источники света"

    Ввод команды: СПИСОКСВЕТ

    Пульт управления: Панель "Источники света", "Список источников"


Удаление источника света - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Управление расположением и свойствами источников света
Понятия
Процедуры
Команды

Удаление источника света

  1. Выберите в меню "Вид" » "Тонирование" » "Источники света" » "Список источников света".
  2. Выберите один или несколько источников света для удаления
  3. Нажмите правую кнопку мыши на выбранном наборе. Выберите "Удалить источник света" или "Удалить источники света".

    4. Панель "Источники света"

    Ввод команды: СПИСОКСВЕТ

    Пульт управления: Панель "Источники света", "Список источников"


Установка параметров затухания точечного света и прожектора - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Управление расположением и свойствами источников света
Понятия
Процедуры
Команды

Установка параметров затухания точечного света и прожектора

  1. Выберите в меню "Сервис" » "Палитры" » "Свойства".
  2. Нажмите кнопку мыши на обозначении источника света или выберите освещение в панели "Источники света" окна модели.
  3. В панели "Свойства затухания" установите "Да" напротив "Использования пределов" или выберите тип затухания.
    • Отсутствие. Затухание отсутствует. И далекие, и близкие к источнику света объекты освещаются одинаково.
    • Линейная инверсия. Затухание в зависимости от дистанции можно сделать инверсивным. Например, на дистанции в две единицы свет будет вполовину слабее, чем на объекте, на дистанции в 4 единицы - только в четверть силы. По умолчанию, интенсивность при линейной инверсии равна половине максимальной интенсивности.
    • Квадратичная инверсия. Затухание в зависимости от дистанции можно сделать квадратично инверсным. Например, на расстоянии 2 единиц от источника освещенность равна 1/4 от освещенности на источнике, на расстоянии 4 единиц — 1/16.
  4. Если для позиции "Использование пределов" установлено "Да", введите эти значения в палитру свойств или используйте инструмент ручек на чертеже для установки этих пределов:
    • Смещение начального предела. Определяет точку испускания света как смещение от центра освещения. По умолчанию определена как 0.
    • Смещение конечного предела. Определяет точку окончания светового луча как смещение от центра освещения. За эту точку свет не проникает.

      • Примечание Начальные и конечные ограничения затухания не поддерживаются драйвером OpenGLwopengl8.hdi. Для идентификации драйвера надо ввести командуграфнастр, затем нажать на "Просмотр протокола оптимизации". Посмотреть на строку драйвера в "Протоколе мастера оптимизации параметров".


Определение исходного вектора источника удаленного освещения. - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Управление расположением и свойствами источников света
Понятия
Процедуры
Команды

Определение исходного вектора источника удаленного освещения.

  1. Выберите в меню "Вид" » "Тонирование" » "Источники света" » "Список источников света".
  2. В панели "Источники света" окна "Модель" выберите удалённый свет.
  3. Выберите в меню "Сервис" » "Палитры" » "Свойства".
  4. На палитре "Свойства", в группе "Геометрия" одним из следующих способов измените значение.
    • Введите значение в ячейку.
    • Нажмите кнопку "Калькулятор" для использования функции "БыстрКальк"
    • Нажмите кнопку "Выбрать в чертеже" и укажите точку "Откуда" и точку "Куда" с помощью устройства указания. На чертеже отображается отрезок, представляющий собой вектор.

    При изменении значений "Вектора от точки" и "Вектор к точке" значения "Исходного вектора" обновляются. При непосредственном изменении значений "Исходного вектора" обновляются значения "Вектора от точки" и "Вектора к точке".

    Панель "Источники света"

    Ввод команды: СПИСОКСВЕТ

    Пульт управления: Панель "Источники света", "Список источников света"


Для перемещения точечного источника света и прожектора - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Управление расположением и свойствами источников света
Понятия
Процедуры
Команды

Для перемещения точечного источника света и прожектора

  1. Выберите обозначения источников света или позицию списка в "Источниках света" окна "Модель".
  2. Выберите позиционную ручку,

    3. которая находится у нижней границы прожектора или в центре точечного источника света.

  3. Перетащите источник света на новое место и нажатием кнопки мыши оставьте его там.

    4. Примечание Прожектор для нацеливания на объект вращается также, как и двигается. При необходимости передвинуть и объект освещения, и источник света, перетаскивается обозначение источника света, а не позиционная ручка.


Изменение цвета освещения - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Управление расположением и свойствами источников света
Понятия
Процедуры
Команды

Изменение цвета освещения

  1. Выберите в меню "Сервис" » "Палитры" » "Свойства".
  2. Выберите обозначение источника света или позицию списка в "Источниках света" окна модели.
  3. В палитре "Свойства" активизируйте ячейку "Цвет" и выберите соответствующий. Активизация "Выбора цвета" открывает диалоговое окно "Выбор цвета".

    4. Ввод команды: ОКОНСВ


Управление расположением и свойствами источников света - Команды

Добавление освещения в модель
Добавление освещения в модель
Управление расположением и свойствами источников света
Понятия
Процедуры
Команды

Команды
ПРОЖЕКТОР | Создание прожектора
СВЕТ | Создает источник света
СПИСОКСВЕТ | Открывает источники света в окне "Модель", чтобы добавить и изменить источники света.
СПИСОКСВЕТЗАКР | Закрывает источники света в окне "Модель"
ТОЧСВЕТ | Создается точечный источник света
УДАЛСВЕТ | Эта команда создает удаленный источник света
Системные переменные
LIGHTGLYPHDISPLAY | Управляет отображением обозначений источников света
LIGHTLISTSTATE | Указывает, открыто ли окно источников света в модели
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Симуляция солнечного света - Понятия

Создание реалистичных графических изображений
Добавление освещения в модель
Симуляция солнечного света
Понятия
Процедуры
Команды

Солнечный свет - это вид освещения, который создает эффект естественного освещения и используется для демонстрации влияния теней от объекта на окружающий вид.

Лучи при этом параллельны и имеют одинаковую интенсивность на всём протяжении. Тени могут быть как включены, так и выключены. Если в тенях нет необходимости, их можно отключить - это увеличит производительность. Все настройки для солнечного света, за исключением географического местоположения, сохраняются на видовом экране, а не в чертеже. Географическое местоположение сохраняется в чертеже.

Угол освещения при использовании солнечного света определяется географическим положением, задающимся для модели, а также датой и временем. Эти свойства могут быть изменены в "Свойствах солнечного света"и диалоговом окне "Географическое положение". Используемый временной пояс зависит от местоположения, но можно изменить его и независимо (системаTIMEZONEизменяема).


Симуляция солнечного света - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Симуляция солнечного света
Понятия
Процедуры
Команды

Включение и выключение освещения солнечным светом на чертеже

Для изменения яркости солнца

Для изменения географического положения модели

Изменение угла солнечного света

Изменение цвета солнечного света


Включение и выключение освещения солнечным светом на чертеже - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Симуляция солнечного света
Понятия
Процедуры
Команды

Включение и выключение освещения солнечным светом на чертеже

  1. Выберите в меню "Вид" » "Тонирование" » "Источники света" » "Свойства солнечного света".
  2. В "Общих параметрах" выберите "Установка положения" и задайте "Вкл" или "Откл".

    3. Панель "Источники света"

    Ввод команды: СВОЙСТВАСОЛНЦА

    Пульт управления: Панель "Источники света", "Положение солнца"


Для изменения яркости солнца - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Симуляция солнечного света
Понятия
Процедуры
Команды

Для изменения яркости солнца

  1. Выберите в меню "Вид" » "Тонирование" » "Источники света" » "Свойства солнечного света".
  2. В "Общих параметрах" выберите "Коэффициент интенсивности" и задайте новое значение.

    3. Панель "Источники света"

    Ввод команды: СВОЙСТВАСОЛНЦА

    Пульт управления: Панель "Источники света" (нажмите кнопку мыши для разворачивания), бегунок "Яркость" (действует на все источники свет на видовом экране)


Для изменения географического положения модели - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Симуляция солнечного света
Понятия
Процедуры
Команды

Для изменения географического положения модели

  1. Выберите в меню "Вид" » "Тонирование" » "Источники света" » "Географическое положение".
  2. В диалоговом окне "Географическое положение" выполните одно из следующих действий:
    • В "Области" выберите область. Установите флажок "Ближайший крупный город". Нажатием кнопки мыши задайте местоположение на интерактивной карте.
    • В "Области" выберите область. В списке "Ближайший город" выберите город.
    • Введите широту и её направление и долготу и её направление.
  3. Проверьте временной пояс и, если он неверный, выберите соответствующий из списка.
  4. В "Направлении на север" выберите интерактивное изображение или введите значение для определения азимута на плоскости XY в МСК на чертеже. Диаграмма обновится и отобразит текущие установки.
  5. Нажмите "ОК".

    6. Панель "Источники света"

    Ввод команды: ГЕОПОЛОЖЕНИЕ

    Пульт управления: Панель "Источники света" (разворачивается нажатием кнопки мыши), "Географическое положение"


Изменение угла солнечного света - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Симуляция солнечного света
Понятия
Процедуры
Команды

Изменение угла солнечного света

  1. Выберите в меню "Вид" » "Тонирование" » "Источники света" » "Свойства солнечного света".
  2. В параметрах "Положения солнца" нажмите на "Установку даты" и выберите новую дату.
  3. Выберите "Установку времени" и задайте новое время.

    4. Если необходимо, используйте параметр "Летнее время".

    Панель "Источники света"

    Ввод команды: СВОЙСТВАСОЛНЦА

    Пульт управления: Панель "Источники света", регулятор "Дата", регулятор "Время"


Изменение цвета солнечного света - Процедуры

Создание реалистичных графических изображений
Добавление освещения в модель
Симуляция солнечного света
Понятия
Процедуры
Команды

Изменение цвета солнечного света

  1. Выберите в меню "Вид" » "Тонирование" » "Источники света" » "Свойства солнечного света".
  2. В "Общих параметрах" выберите "Установки цвета" и задайте соответствующий цвет.

    3. Активизация "Выбора цвета" открывает диалоговое окно "Выбор цвета".

    Панель "Источники света"

    Ввод команды: СВОЙСТВАСОЛНЦА

    Пульт управления: Панель "Источники света", изменение цвета солнечного света


Симуляция солнечного света - Команды

Добавление освещения в модель
Добавление освещения в модель
Симуляция солнечного света
Понятия
Процедуры
Команды

Команды
ГЕОПОЛОЖЕНИЕ | Задание широты и долготы расположения
СВОЙСТВАСОЛНЦА | Вызов окна "Свойства солнца" для определения свойств солнца
СВОЙСТВАСОЛНЦАЗАКР | Закрытие окна "Свойства Солнца"
Системные переменные
NORTHDIRECTION | Задает угол смещения Вс от севера
SUNPROPERTIESSTATE | Указывает, открыто окно Свойств солнца или нет.
SUNSTATUS | Управляет излучением солнечного света на текущем видовом экране
TIMEZONE | Устанавливает часовой пояс для вс в чертеже
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Применение материалов и текстур к объектам - Понятия

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Понятия
Процедуры
Команды

Наряду с освещением, материалы повышают уровень реалистичности моделей.

  • Применение материалов к объектам и поверхностям
    Материал можно применять к отдельным граням и объектам или к объектам слоя.
  • Создание и изменение материалов
    Материал определяется рядом своих свойств. Доступные свойства зависят от шаблона.
  • Для добавления к материалу текстуры используются карты.
    Это придает материалу дополнительный реализм.


Применение материалов и текстур к объектам - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Понятия
Процедуры
Команды

Применение материала из палитры инструментов

Применение материалов к объектам из окна "Материалы"

Отделение материала от объекта

Создание инструмента материала

Применение материала через слой

Создание нового материала с использованием шаблонов "Реалистично" или "Реалистичное тонирование металла"

Создание нового материала с использованием шаблонов "Дополнительно" или "Улучшенное тонирование металла"

Добавление текстуры в материал.

Регулировка положения текстуры на объекте или грани


Применение материалов и текстур к объектам - Команды

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Понятия
Процедуры
Команды
Команды
МАТЕРИАЛПРИСВ | Назначает материалы объектам по слоям
МАТЕРИАЛСООТВ | Отображается ручка блока наложения материалов для корректировки наложений на грань или на объект
МАТЕРИАЛЫ | Администрирование, применение и редактирование материалов
МАТЕРИАЛЫЗАКР | Закрывается окно "Материалы".
Системные переменные
MATSTATE | Указывает состояние окна "Материалы": открыто или нет
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Применение материалов к объектам и поверхностям - Понятия

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Применение материалов к объектам и поверхностям
Понятия
Процедуры
Команды

Материал можно применять к отдельным граням и объектам или к объектам слоя.

Для применения материала к объекту или грани нужно перетащить его из инструментальной палитры на объекты. Материал добавляется в чертеж и одновременно отображается в виде образца в окне "Материалы".

При создании или изменении материала в окне "Материалы" можно перетаскивать образец непосредственно на объекты чертежа или на активную инструментальную палитру для создания инструмента материала.

Дерево и мрамор доступны в окне "Материалы" в виде процедурных соответствий. Имеется опция зернистости, которая может изменяться, также как и цвет.

Материал можно применять к объектам послойно (МАТЕРИАЛПРИСВ). Материал применяется ко всем объектам слоя, у которых для свойства "Материал" задано значение ПОСЛОЮ (значение по умолчанию).

Библиотека материалов

Вместе с продуктом поставляется библиотека, содержащая более 300 материалов и текстур. Материалы находятся на инструментальных палитрах и они все отображаются вместе с клетчатой подложкой.

Установка компонентов библиотеки материалов (инструментальных палитр и текстур) является необязательной. По умолчанию они устанавливаются в папке, задаваемой в поле "Папки для файлов инструментальных палитр", на вкладке "Файлы" диалогового окна "Параметры". (Для определения местонахождения текстур см. "Папка для поиска текстур" на вкладке "Файлы".)

Примечание Компоненты библиотеки материалов всегда устанавливаются в папке по умолчанию. Если перед установкой библиотеки материалов пути изменены, новые материал не отображаются на инструментальных палитрах, и на текстуры нет ссылок от материалов. Следует либо скопировать вновь установленные файлы в нужное место, либо изменить путь на путь по умолчанию.


Применение материалов к объектам и поверхностям - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Применение материалов к объектам и поверхностям
Понятия
Процедуры
Команды

Применение материала из палитры инструментов

Применение материалов к объектам из окна "Материалы"

Отделение материала от объекта

Создание инструмента материала

Применение материала через слой


Применение материала из палитры инструментов - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Применение материалов к объектам и поверхностям
Понятия
Процедуры
Команды

Применение материала из палитры инструментов

  1. Выберите "Сервис" » "Палитры" » "Инструментальные палитры"

    2. Если в окне "Инструментальные палитры" не отображаются материалы, нажмите кнопку мыши на значке панели "Материалы" на пульте управления.

  2. Нажмите кнопку мыши на инструментальной палитре для её активизации.
  3. Перетащите материал из инструментальной палитры на объект.

Устройство указания: Нажмите кнопку мыши на инструменте материала и выберите объекты указателем в виде кисти руки.

Устройство указания: Перетащите инструмент материала на объект.

Контекстное меню: Нажмите правую кнопку мыши на материале и выберите "Применить материал к объектам".

Ввод команды: ИНСТРПАЛВКЛ


Применение материалов к объектам из окна "Материалы" - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Применение материалов к объектам и поверхностям
Понятия
Процедуры
Команды

Применение материалов к объектам из окна "Материалы"

  1. Выберите в меню "Сервис" » "Палитры" » "Материалы".
  2. В окне материалов выберите материал, который требуется применить.
  3. Выберите"Применить материал к объектам" в строке инструментов под образцами.
  4. Указателем в виде кисти выберите объекты.

    5. Материал отображается на каждом выбираемом объекте.

Панель "Тонирование" :

Устройство указания: Выберите объекты и дважды нажмите кнопку мыши на образце материала.

Устройство указания: Перетащите образец материала на объекты.

Ввод команды: МАТЕРИАЛЫ

Пульт управления: Панель "Материалы", окно "Отображение материалов"


Отделение материала от объекта - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Применение материалов к объектам и поверхностям
Понятия
Процедуры
Команды

Отделение материала от объекта

  1. Выберите "Сервис" » "Палитры" » "Материалы".
  2. В окне "Материалы" нажмите "Удалить материалы из выбранных объектов" в строке инструментов под образцами.
  3. Указателем в виде кисти выберите объекты.

При открытой палитре "Свойства" также можно выбрать объекты и изменить значение свойства "Материалы" на "Глобально".

Панель "Тонирование" :

Ввод команды: МАТЕРИАЛЫ

Пульт управления: Панель "Материалы", окно "Отображение материалов"


Создание инструмента материала - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Применение материалов к объектам и поверхностям
Понятия
Процедуры
Команды

Создание инструмента материала

  1. Выберите из меню "Сервис" » "Палитры" » "Материалы".
  2. Выберите "Сервис" » "Палитры" » "Инструментальные палитры"
  3. Нажмите кнопку мыши на инструментальной палитре для её активизации.
  4. В окне "Материалы" выберите шаблон.
  5. Перетащите образец на инструментальную палитру.

    6. Создается инструмент материала и помещается на активную инструментальную палитру, где он доступен для использования в других чертежах.

Примечание Если впоследствии свойства материала изменяются в окне "Материалы", автоматическое обновление инструмента не выполняется. Нужно удалить старый инструмент материала и создать новый.

Панель "Тонирование" :

Контекстное меню: Нажмите правую кнопку мыши и выберите "Экспортировать в активную инструментальную палитру".

Ввод команды: МАТЕРИАЛЫ

Пульт управления: Панель "Материалы", окно "Отображение материалов"


Применение материала через слой - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Применение материалов к объектам и поверхностям
Понятия
Процедуры
Команды

Применение материала через слой

  1. Ввести материалприсв.
  2. В диалоговом окне "Параметры назначения материала" перетащить материал на слой.

    3. Материал будет применён ко всем объектам слоя, у которых в свойствах материалов установлено ПОСЛОЮ. При создании объекта по умолчанию для свойства "Материал" используется значение ПОСЛОЮ.

Пульт управления: Панель материалов, применение через слой


Применение материалов к объектам и поверхностям - Команды

Применение материалов и текстур к объектам
Применение материалов и текстур к объектам
Применение материалов к объектам и поверхностям
Понятия
Процедуры
Команды

Команды
МАТЕРИАЛПРИСВ | Назначает материалы объектам по слоям
МАТЕРИАЛЫ | Администрирование, применение и редактирование материалов
МАТЕРИАЛЫЗАКР | Закрывается окно "Материалы".
Системные переменные
MATSTATE | Указывает состояние окна "Материалы": открыто или нет
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и изменение материалов - Понятия

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Создание и изменение материалов
Понятия
Процедуры
Команды

Материал определяется рядом своих свойств. Доступные свойства зависят от шаблона.

Тип материала выбирается из списка "Шаблоны" окна "Материалы":

  • Шаблоны "Реалистично" и "Реалистичное тонирование металла". Материалы определяются физическими свойствами.
  • Шаблоны "Дополнительно" и "Улучшенное тонирование металла". Материалы с большим набором параметров, включая свойства, которые можно использовать для создания специальных эффектов, например имитации отражений.

В чертеже всегда есть один материал, ГЛОБАЛЬНЫЙ, использующий шаблон "Реалистично". Этот или любой другой материал можно использовать в качестве основы для создания нового материала. От используемого шаблона зависит, какое количество свойств будет недоступно.

Цвет

Цвет материала на объекте меняется в зависимости от области. Например, если смотреть на красный шар, он не покажется монотонно красным. Поверхности, не освещённые напрямую, покажутся темнее, чем те, на которые непосредственно падает свет. Бликовое отражение покажется самым ярким, и если сфера очень блестящая, то блики могут показаться даже белыми.

Для материала, использующего шаблон "Дополнительно" или "Улучшенное тонирование металла", можно задать три цвета. В шаблонах "Реалистично" и "Реалистичное тонирование металла" используется только цвет "Диффузный".

  • Диффузный. Главный цвет материала.
  • Рассеянный. Это цвет, который виден на поверхности, освещённой только рассеянным светом. При этом рассеянный цвет может полностью совпадать с диффузным.
  • Зеркальный. Это цвет блика на освещенном материале. Зеркальный цвет может быть таким же, как диффузный.
Блеск

Отражающая способность поверхности материала определяет уровень блеска или шероховатости. Для симуляции блестящей поверхности материал должен иметь точечные блики, цвет которых намного ярче, в некоторых случаях даже белый. Шероховатая поверхность даёт блики большей площади, которые по цвету близки к основному цвету материала.

Другие свойства

Некоторые свойства используются для создания специфических эффектов:

  • Прозрачность. Полупрозрачный объект не только пропускает свет, но и рассеивает часть его внутри себя, как, например, покрытое инеем стекло. Степень прозрачности выражается в процентах: при значении 0 материал не является просвечивающим; при 100 материал является просвечивающим в максимально возможной степени. (Не применимо к шаблонам металлов.)
  • Самосвечение. Создается впечатление, будто сам объект испускает свет. Например, для того чтобы изобразить неоновый свет без самостоятельного источника, надо установить значение самосвечения выше нуля. На другие объекты свет не отбрасывается. (Не применимо к шаблонам металлов.)
  • Преломление. При прохождении через полупрозрачные материалы лучи изменяют свое направление, в результате сквозь этот материал другие объекты видны в искаженном виде. Например, при значении 1,0 объект за прозрачным объектом не искажается. При коэффициенте, равном 1,5, происходит сильное искажение объекта, как при взгляде сквозь стеклянный шарик. (Не применимо к шаблонам металлов.)
    • Материал | Коэффициент преломления
Вакуум | 1,0 (точно)
Воздух | 1,0003
Вода | 1,3333
Стекло | 1,5 - 1,7
Алмаз | 2,419

См. также

Для добавления к материалу текстуры используются карты.


Создание и изменение материалов - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Создание и изменение материалов
Понятия
Процедуры
Команды

Создание нового материала с использованием шаблонов "Реалистично" или "Реалистичное тонирование металла"

Создание нового материала с использованием шаблонов "Дополнительно" или "Улучшенное тонирование металла"


Создание нового материала с использованием шаблонов "Реалистично" или "Реалистичное тонирование металла" - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Создание и изменение материалов
Понятия
Процедуры
Команды

Создание нового материала с использованием шаблонов "Реалистично" или "Реалистичное тонирование металла"

  1. Выберите из меню "Сервис" » "Палитры" » "Материалы".
  2. В окне "Материалы" выберите "Создать новый материал" в полосе кнопок под образцами.
  3. В диалоговом окне "Создать новый материал" ввести название, а при необходимости - и описание материала. Нажмите "ОК".
  4. В окне "Материалы" выберите шаблон.
  5. Нажмите кнопку мыши на "Диффузный" для присвоения материалу цвета или выберите "По объекту" для использования цвета объекта, к которому применен материал.
  6. (Не применимо к шаблонам металлов.)
    • Блеск. Устанавливается степень блеска материала. Блик на грани тела с очень высокой степенью блеска имеет уменьшенные размеры и повышенную яркость. На менее блестящей грани происходит отражение света во многих направлениях, в результате чего создается блик большего размера с пониженной яркостью.
    • Коэффициент преломления . Определяется способ преломления света при прохождении через объект, которому назначен частично прозрачный материал. (Не применимо к шаблонам металлов.)
    • Прозрачность. Задается степень прозрачности материала. Полупрозрачный объект пропускает свет, но свет рассеивается также внутри объекта. (Не применимо к шаблонам металлов.)
    • Самосвечение. При значении, большем 0, объект представляется испускающим свет независимо от источников света в чертеже. (Не применимо к шаблонам металлов.)
  7. (Не применимо к шаблонам металлов.) (См. раздел Для добавления к материалу текстуры используются карты..)

Панель "Тонирование" :

Ввод команды: МАТЕРИАЛЫ

Пульт управления: Панель "Материалы", окно "Отображение материалов"


Создание нового материала с использованием шаблонов "Дополнительно" или "Улучшенное тонирование металла" - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Создание и изменение материалов
Понятия
Процедуры
Команды

Создание нового материала с использованием шаблонов "Дополнительно" или "Улучшенное тонирование металла"

  1. Выберите из меню "Сервис" » "Палитры" » "Материалы".
  2. В окне "Материалы" выберите "Создать новый материал" в полосе кнопок под образцами.
  3. В диалоговом окне "Создать новый материал" ввести название, а при необходимости - и описание материала. Нажмите ОК.
  4. В окне "Материалы" выберите шаблон.
  5. Нажмите кнопку мыши на "Рассеянный" для задания цвета, появляющегося на гранях, освещенных только рассеянным светом, или выберите "По объекту" для использования цвета объекта, к которому применен материал.
  6. Нажмите кнопку мыши на "Диффузный" для присвоения материалу цвета или выберите "По объекту" для использования цвета объекта, к которому применен материал.
  7. Нажмите кнопку мыши на "Цвет блика" для задания цвета блика на блестящем материале или выберите "По объекту" для использования цвета объекта, к которому применен материал. (Не применимо к шаблонам "Улучшенное тонирование металла".)
  8. (Дополнительно) Нажмите кнопку мыши на первом значке блокировки для настройки диффузного цвета на рассеянный цвет. Нажмите кнопку мыши на втором значке блокировки для настройки диффузного цвета на цвет блика.

    9. Если цвет связан с другим цветом, то изменение одного приводит к изменению другого.

  9. Для задания следующих свойств используются регуляторы.
    • Блеск. Устанавливается степень блеска материала. Блик на грани тела с очень высокой степенью блеска имеет уменьшенные размеры и повышенную яркость. На менее блестящей грани происходит отражение света во многих направлениях, в результате чего создается блик большего размера с пониженной яркостью.
    • Коэффициент преломления. Определяется способ преломления света при прохождении через объект, которому назначен частично прозрачный материал. (Не применимо к шаблонам металлов.)
    • Прозрачность. Задается степень прозрачности материала. Полупрозрачный объект пропускает свет, но свет рассеивается также внутри объекта. (Не применимо к шаблонам металлов.)
    • Самосвечение. При значении, большем 0, объект представляется испускающим свет независимо от источников света в чертеже. (Не применимо к шаблонам металлов.)
  10. (Не применимо к шаблонам металлов.) (См. раздел Для добавления к материалу текстуры используются карты..)

Панель "Тонирование" :

Ввод команды: МАТЕРИАЛЫ

Пульт управления: Панель "Материалы", окно "Отображение материалов"


Создание и изменение материалов - Команды

Применение материалов и текстур к объектам
Применение материалов и текстур к объектам
Создание и изменение материалов
Понятия
Процедуры
Команды

Команды
МАТЕРИАЛЫ | Администрирование, применение и редактирование материалов
МАТЕРИАЛЫЗАКР | Закрывается окно "Материалы".
Системные переменные
MATSTATE | Указывает состояние окна "Материалы": открыто или нет
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Для добавления к материалу текстуры используются карты. - Понятия

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Для добавления к материалу текстуры используются карты.
Понятия
Процедуры
Команды

Это придает материалу дополнительный реализм.

  • Определение типа карты
    В процессе создания материала можно включить 2D изображение или текстуру, проектируемую на поверхность 3D объекта для создания реалистичных эффектов.
  • Настройка наложений на объектах и гранях
    После применения материала с текстурой можно выполнить настройку ориентации текстуры на объектах или гранях.


Для добавления к материалу текстуры используются карты. - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Для добавления к материалу текстуры используются карты.
Понятия
Процедуры
Команды

Добавление текстуры в материал.

Регулировка положения текстуры на объекте или грани


Для добавления к материалу текстуры используются карты. - Команды

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Для добавления к материалу текстуры используются карты.
Понятия
Процедуры
Команды
Команды
МАТЕРИАЛСООТВ | Отображается ручка блока наложения материалов для корректировки наложений на грань или на объект
МАТЕРИАЛЫ | Администрирование, применение и редактирование материалов
МАТЕРИАЛЫЗАКР | Закрывается окно "Материалы".
Системные переменные
MATSTATE | Указывает состояние окна "Материалы": открыто или нет
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Определение типа карты - Понятия

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Определение типа карты
Понятия
Процедуры
Команды

В процессе создания материала можно включить 2D изображение или текстуру, проектируемую на поверхность 3D объекта для создания реалистичных эффектов.

Текстурное рассеяние распределяет узор или текстуру по диффузному цвету материала. Цвета текстуры заменяют диффузный цвет материала. Например, если нужно представить стену из кирпича, можно выбрать текстуру, похожую на кирпич. Это наиболее общий вариант наложения текстуры.

Можно использовать любую текстуру или один из производственных материалов - дерево или мрамор. У процедурных материалов есть свойства, которые можно регулировать для получения требуемых эффектов, например распределения зернистости в деревянном материале.

Схему, добавляемую к материалу, можно масштабировать или вписывать в объект. Образец можно делать мозаичным или поворачивать его.

Текстуры также подходят и для других целей. Для одного и того же материала можно использовать разные текстуры:

  • Текстуры выдавливания. Имитируют эффект выпуклости или барельефа. Тёмные зоны представляются провалами, а светлые - выступающими частями. Если изображение цветное, можно использовать полутонирование. Любое изображение можно использовать как текстуру выдавливания. Наложение текстуры выдавливания значительно увеличивает время тонирования, но повышает реалистичность сцены.
  • Текстуры отражения. Для моделирования сцены, отражающейся на поверхности блестящего объекта, используется текстура среды. Для хорошего отображения текстур отражения материал должен быть блестящим, а картинка текстуры отражения должна иметь высокое разрешение (по меньшей мере, 512х480 пикселов). ("Не применимо к реалистичным шаблонам" или "Реалистичное тонирование металла".)
  • Текстуры непрозрачности. Текстуры непрозрачности определяют зоны прозрачности и непрозрачности. Например, если взять растровое изображение черного круга в середине белого прямоугольника и наложить его на объект в качестве текстуры прозрачности, то поверхность будет выглядеть так, будто на объекте имеется круглое прозрачное отверстие. Если изображение цветное, то для каждого цвета можно использовать полутонирование.

В качестве текстур можно использовать следующие типы файлов:

  • BMP (.bmp, .rle, .dib)
  • GIF (.gif)
  • JFIF (.jpg, .jpeg)
  • PCX (.pcx)
  • PNG (.png)
  • TGA (.tga)
  • TIFF (.tif)

После применения текстуры ее можно вписать в грань или объект с помощью наложения материала.


Добавление текстуры в материал. - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Определение типа карты
Понятия
Процедуры
Команды

Добавление текстуры в материал.

  1. Выберите из меню "Сервис" » "Палитры" » "Материалы".
  2. Создайте новый материал или выберите материал.
  3. Выберите "Текстура рассеяния" и выберите "Текстура".
  4. Нажмите кнопку мыши на "Выбрать изображение" и найдите файл в диалоговом окне "Выбор изображения". Нажмите "Открыть".

    5. Для изменения формы, отображаемой на образце, можно воспользоваться кнопкой "Геометрия образцов" в полосе инструментов под образцами.

  5. (Дополнительно) В полосе инструментов нажмите кнопку "Настройка значения масштаба/фрагментации, смещения и угла поворота растрового изображения".
  6. В диалоговом окне "Настроить растровое изображение" выберите "Масштаб" или "Вписать в объект".
  7. Выберите режим "Мозаика" или отмените его выбор.
  8. Отрегулируйте смещение и угол поворота.
  9. Нажмите кнопку "Закрыть".

Панель "Тонирование" :


Определение типа карты - Команды

Применение материалов и текстур к объектам
Применение материалов и текстур к объектам
Определение типа карты
Понятия
Процедуры
Команды

Команды
МАТЕРИАЛСООТВ | Отображается ручка блока наложения материалов для корректировки наложений на грань или на объект
МАТЕРИАЛЫ | Администрирование, применение и редактирование материалов
МАТЕРИАЛЫЗАКР | Закрывается окно "Материалы".
Системные переменные
MATSTATE | Указывает состояние окна "Материалы": открыто или нет
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка наложений на объектах и гранях - Понятия

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Настройка наложений на объектах и гранях
Понятия
Процедуры
Команды

После применения материала с текстурой можно выполнить настройку ориентации текстуры на объектах или гранях.

При наложении материала выполняется его вписывание в форму объекта. Применение подходящего типа наложения материала на объект улучшает качество вписывания:

  • Плоское наложение. Изображение накладывается на объект, как если бы оно проектировалось со слайда на двумерную поверхность. Изображение не искажается, а только масштабируется для вписывания в объект. Обычно это наложение используется для граней.
  • Соответствие прямоугольников. Изображение накладывается на коробчатые тела. Изображение повторяется на всех сторонах объекта.
  • Сферическое наложение. Изображение деформируется как по горизонтали, так и по вертикали. Верх наложения стягивается в точку, располагающуюся в "северном полюсе" сферы, в то время как низ стягивается в "южный полюс".
  • Цилиндрическое наложение. Изображение накладывается на цилиндрический объект; горизонтальные края загибаются и соединяются, верх и низ не затрагиваются. Высота изображения масштабируется вдоль оси цилиндра.
Захватный блок для наложения материала

Если необходимо продолжить настройки, можно воспользоваться захватным блоком для наложения материала, который отображается на объекте, для перемещения или поворота текстуры на объекте.


Регулировка положения текстуры на объекте или грани - Процедуры

Создание реалистичных графических изображений
Применение материалов и текстур к объектам
Настройка наложений на объектах и гранях
Понятия
Процедуры
Команды

Регулировка положения текстуры на объекте или грани

  1. На пульте управления нажмите кнопку мыши на управляющей панели "Материалы".
  2. Нажмите и удерживайте нажатой кнопку мыши на всплывающем меню "Схема наложения координат" для отображения существующих типов наложения.

    3. Функции, доступные во всплывающем меню "Схема наложения координат", реализованы также в виде кнопок на панели "Схема наложения координат".

  3. Задержите указатель над требуемым для объекта наложением, затем отпустите кнопку мыши. Типы наложений
    • Плоское наложение
    • Соответствие прямоугольников
    • Сферическое наложение
    • Цилиндрическое наложение

    Инструмент ручки для наложения материала отображается на объекте.

  4. Инструменты ручки и представление объекта служат для настройки отображения изображения на объекте или грани.

Панель "Тонирование"

Ввод команды: МАТЕРИАЛСООТВ


Настройка наложений на объектах и гранях - Команды

Применение материалов и текстур к объектам
Применение материалов и текстур к объектам
Настройка наложений на объектах и гранях
Понятия
Процедуры
Команды

Команды
МАТЕРИАЛСООТВ | Отображается ручка блока наложения материалов для корректировки наложений на грань или на объект
МАТЕРИАЛЫ | Администрирование, применение и редактирование материалов
МАТЕРИАЛЫЗАКР | Закрывается окно "Материалы".
Системные переменные
MATSTATE | Указывает состояние окна "Материалы": открыто или нет
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Реалистичное тонирование 3D объектов - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Понятия
Процедуры
Команды

Благодаря реалистичному тонированию модели проект становится более наглядным по сравнению с напечатанным чертежом.

В процессе проектирования большая часть графических работ приходится на создание каркасных представлений модели. Однако иногда возникает необходимость получить более реалистичное изображение (раскрашенное или в перспективе) — например, для проверки правильности спроектированной модели или при предъявлении законченного проекта заказчику.

  • Коротко о тонировании
    При тонировании создается 2D изображение на основе 3D сцены. Геометрия сцены тонируется с помощью настроенного пользователем освещения, применяемых материалов и особенностей окружающей среды, например, фона или тумана.
  • Подготовка моделей для тонирования
    Важную роль для оптимизации производительности системы тонирования и качества изображения играет способ построения модели.
  • Настройка системы тонирования
    Можно менять параметры, управляющие процессом тонирования, например при тонировании изображений высокого разрешения.
  • Основные сведения о тонировании
    Основной целью работы является создание высококачественного изображения фотографического качества, поэтому для достижения этой цели потребуется создать множество различных вариантов тонирования.
  • Дополнительные функции тонирования
    С помощью дополнительных функций тонирования можно выполнять тонирование изображений высокого уровня детальности и фотографического качества.
  • Журнал тонированных изображений
    Журнал тонирования включает список последних тонированных изображений текущей загруженной модели.
  • Сохранение и повторное воспроизведение изображений
    Тонированное изображение можно сохранить на диске, а затем в любой момент воспроизвести его на экране. Повторное воспроизведение тонированного изображения выполняется намного быстрее повторного тонирования.


Реалистичное тонирование 3D объектов - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Понятия
Процедуры
Команды

Для тонирования обеих нормалей грани

Для изменения разрешающей способности при тонировании пространственных объектов

Для изменения разрешения отображения дуг и кругов

Для создания пользовательского набора параметров тонирования из палитры "Дополнительные параметры тонирования"

Для создания пользовательского набора параметров тонирования из "Диспетчера наборов стандартных параметров тонирования"

Для изменения пользовательского набора параметров тонирования

Для работы с туманом / затемнением

Задание фона для именованного вида

Изменение фона для именованного вида

Для подавления или отображения панели тонирования пульта управления

Для указания места назначения тонирования

Для тонирования вида

Для тонирования набора объектов

Для тонирования выделенной области

Просмотр теней на видовом экране

Создание теней, полученных применением текстур теней, в тонированном изображении

Создание теней трассировки луча в тонированном изображении

Для тонирования с записью в файл

Для сохранения тонированного изображения, отображаемого на видовом экране

Для сохранения тонированного изображения из "Окна тонирования"

Для сохранения тонированного изображения из окна тонирования


Реалистичное тонирование 3D объектов - Команды

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Понятия
Процедуры
Команды
Команды
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
ИЗОБВСТАВИТЬ | Вставка нового изображения в текущий чертеж
МАТЕРИАЛПРИСВ | Назначает материалы объектам по слоям
МАТЕРИАЛСООТВ | Отображается ручка блока наложения материалов для корректировки наложений на грань или на объект
МАТЕРИАЛЫ | Администрирование, применение и редактирование материалов
НАБПАРАМТОНИР | Задает предварительные настройки и повторно используемые параметры тонирования изображения
НАСТРВИД | Задание точности аппроксимации объектов на текущем видовом экране
ПУЛЬТУПР | Открывает окно "Пульт управления"
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
РЕЖИМТОНОТКЛ | Закрывается палитра "Параметры тонирования" (если открыта).
СОХРИЗОБ | Сохранение тонированных изображений в файлах
СРЕДАТОН | Управление туманом и затемнением объектов для визуального представления удаленных расстояний
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
ТОНИРОКНО | Отображается окно тонирования без вызова задачи тонирования.
ТОНИРПОДРЕЗ | Задает конкретный участок (окно кадрирования) в изображении для тонирования
Системные переменные
FACETRES | Регулирует гладкость раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о тонировании - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Коротко о тонировании
Понятия
Процедуры
Команды

При тонировании создается 2D изображение на основе 3D сцены. Геометрия сцены тонируется с помощью настроенного пользователем освещения, применяемых материалов и особенностей окружающей среды, например, фона или тумана.

Система тонирования - это универсальная система, создающая физически правильную модель освещения, включающую отражения и преломления лучей, а также общее освещение.

В программе предусмотрены разнообразные стандартные наборы параметров тонирования, параметры тонирования для многократного использования. Некоторые наборы параметров предназначены для быстрого создания тонирования, другие наборы - для получения высококачественного тонирования.


Реалистичное тонирование 3D объектов

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Коротко о тонировании - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Коротко о тонировании
Понятия
Процедуры
Команды

Команды
НАБПАРАМТОНИР | Задает предварительные настройки и повторно используемые параметры тонирования изображения
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
РЕЖИМТОНОТКЛ | Закрывается палитра "Параметры тонирования" (если открыта).
СОХРИЗОБ | Сохранение тонированных изображений в файлах
СРЕДАТОН | Управление туманом и затемнением объектов для визуального представления удаленных расстояний
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
ТОНИРОКНО | Отображается окно тонирования без вызова задачи тонирования.
ТОНИРПОДРЕЗ | Задает конкретный участок (окно кадрирования) в изображении для тонирования
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Подготовка моделей для тонирования - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Подготовка моделей для тонирования
Понятия
Процедуры
Команды

Важную роль для оптимизации производительности системы тонирования и качества изображения играет способ построения модели.

  • Нормали к граням и скрытые поверхности
    Чтобы минимизировать время, необходимое для тонирования модели, обычно удаляют скрытые поверхности или скрывают объекты, расположенные вне зоны действия камеры. Кроме того, тонирование выполняется быстрее, если все нормали к граням обращены в одну сторону.
  • Уменьшение числа пересечений и копланарных граней
    Некоторые типы геометрических объектов могут вызывать определенные трудности при тонировании.
  • Изменение плотности сети для сглаживания геометрии
    При тонировании модели на гладкость поверхностей влияет плотность сети.


Подготовка моделей для тонирования - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Подготовка моделей для тонирования
Понятия
Процедуры
Команды

Для тонирования обеих нормалей грани

Для изменения разрешающей способности при тонировании пространственных объектов

Для изменения разрешения отображения дуг и кругов


Подготовка моделей для тонирования - Команды

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Подготовка моделей для тонирования
Понятия
Процедуры
Команды
Команды
НАСТРВИД | Задание точности аппроксимации объектов на текущем видовом экране
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
FACETRES | Регулирует гладкость раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Нормали к граням и скрытые поверхности - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Нормали к граням и скрытые поверхности
Понятия
Процедуры
Команды

Чтобы минимизировать время, необходимое для тонирования модели, обычно удаляют скрытые поверхности или скрывают объекты, расположенные вне зоны действия камеры. Кроме того, тонирование выполняется быстрее, если все нормали к граням обращены в одну сторону.

Каждая поверхность модели состоит из граней. Грани могут быть треугольными или четырехугольными; для каждой грани определена внутренняя и внешняя сторона. Направление грани определяется вектором, который называется нормалью. Направление нормали указывает переднюю, или внешнюю, сторону грани.

Если все нормали направлены во внешнюю сторону, процесс тонирования применяется к каждой грани модели. Если же какие-то нормали направлены во внутреннюю сторону, то система тонирования их игнорирует и не тонирует соответствующие треугольники или четырехугольники.

Неокрашенные области, как правило, появляются по одной из двух причин: либо в палитре "Параметры тонирования" снят флажок "Вынужденное 2-стороннее", либо грань физически отсутствует в модели.

В случае отсутствия грани необходимо ее восстановить вручную. Направление нормали определяется тем, как нарисована грань в правоориентированной системе координат: если грань нарисована против часовой стрелки, нормаль ориентирована наружу, если по часовой стрелке - внутрь. Все грани следует строить одним и тем же методом.

Примечание Твердотельные объекты имеют заведомо правильно ориентированные сети и нормали, что очень удобно для задач тонирования.

В процессе тонирования система вычисляет все нормали, направленные от точки зрения, и удаляет из сцены связанные с ними грани. Этот этап подавления называется выбраковкой задней грани и контролируется параметром "Вынужденное 2-стороннее" палитры "Параметры тонирования".

После того, как задние грани подавлены, система тонирования сравнивает относительные расстояния по оси Z при помощи Z-буфера. Если Z-буфер указывает, что одна из граней перекрывает другую, система тонирования подавляет скрытую грань.

Выигранное таким образом время пропорционально отношению числа скрытых граней к общему их количеству.

В некоторых случаях нужно пропустить этап выбраковки задних граней и оставить задние грани видимыми (например, если объект прозрачен, если в связи с формой и ориентацией объекта можно видеть обе его стороны, если при тонировании разомкнутого объекта видны его внутренние участки). Прозрачность также учитывается при определении видимости граней, скрытых за другими. В таком случае убедитесь, что параметр "Вынужденное 2-стороннее" включен и что производится тонирование всех граней, вне зависимости от направления нормалей.

При выполнении тонирования чертежа, первоначально не предназначенного для тонирования или выполненного в другом приложении, необходимо установить флажок "Вынужденное 2-стороннее". Это обеспечивает правильность тонирования всех поверхностей.

Примечание Применение параметра "Вынужденное 2-сторонее" лишь незначительно влияет на производительность процесса тонирования.

Система тонирования обрабатывает каждый объект сцены, включая объекты, которые "не попадают" в камеру и которые не будут видны на тонированном виде. Модель, построенная с учетом системы тонирования, отличается рациональным расположением слоев. Можно значительно увеличить скорость тонирования, отключив слои, объекты которых не попадают в поле зрения.

См. также

Работа с моделями в других приложениях

Использование стиля отображения для модели


Для тонирования обеих нормалей грани - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Нормали к граням и скрытые поверхности
Понятия
Процедуры
Команды

Для тонирования обеих нормалей грани

  1. Выберите меню "Вид" » "Тонирование" » "Дополнительные параметры тонирования".
  2. В разделе "Материалы" палитры "Дополнительные параметры тонирования" убедитесь, что для параметра "Вынужденное 2-стороннее" выбрано значение "Вкл".
  3. Выполните тонирование сцены.

Панель "Тонирование"

Ввод команды: РЕЖИМТОН

Пульт управления: Развернутая панель "Тонирование" » "Дополнительные параметры тонирования"


Нормали к граням и скрытые поверхности - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Нормали к граням и скрытые поверхности
Понятия
Процедуры
Команды

Команды
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Уменьшение числа пересечений и копланарных граней - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Уменьшение числа пересечений и копланарных граней
Понятия
Процедуры
Команды

Некоторые типы геометрических объектов могут вызывать определенные трудности при тонировании.

Сложность объекта зависит от числа его вершин и граней. Чем больше у модели граней, тем больше времени занимает процесс тонирования. Простота геометрии чертежа позволит сократить время, необходимое на выполнение тонирования. При создании поверхностей нужно стремиться к минимизации числа граней.

Пересечение граней

Иногда случается так, что одна грань в модели проходит через другую. При создании эскизных проектов для наглядности бывает удобно расположить объекты так, чтобы один проходил сквозь другой. Однако кромка, возникающая при пересечении двух объектов, может быть волнистой.

В следующем примере волнистая кромка изображения слева значительно улучшается после применения логического объединения.

Если кромки выглядят недостаточно аккуратными, используйте логические операции, например объединение, пересечение и вычитание. Более точные и аккуратные кромки лучше отражают вид объекта.

Копланарные грани

Тонирование граней, лежащих в одной плоскости (копланарные грани)и перекрывающих друг друга, может приводить к неоднозначным результатам, особенно если этим граням присвоены разные материалы.

В следующем примере дефекты появляются, если грани занимают одно и то же местоположение.

Для устранения дефектов изображения следует переместить объект так, чтобы его грани не лежали в плоскости другого объекта.

Скрученные грани

Тонирование граней, скрученных на 180 градусов и поэтому самоперекрывающихся, также может приводить к неоднозначным результатам из-за неопределенности направления нормалей.

В следующем примере дефекты изображения возникают при скручивании граней, образующемся при пересечении второй и третьей угловых точек.

Эта ситуация часто возникает при попытке исправить модель с отверстием на поверхности. Например, пусть выбираются угловые точки для новой грани. Возможно они будут пересекаться вместо того, чтобы разместиться вокруг отверстия в направлении против часовой стрелки. Во избежания этого дефекта выбирайте угловые точки в правильном порядке.


Подготовка моделей для тонирования

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Подготовка моделей для тонирования
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Уменьшение числа пересечений и копланарных граней - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Уменьшение числа пересечений и копланарных граней
Понятия
Процедуры
Команды

Команды
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменение плотности сети для сглаживания геометрии - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Изменение плотности сети для сглаживания геометрии
Понятия
Процедуры
Команды

При тонировании модели на гладкость поверхностей влияет плотность сети.

Компоненты сети включают в себя вершины, грани, многоугольники и кромки.

  • Вершина - это точка, образующая угол грани или многоугольника.
  • Грань - это треугольный участок поверхности.
  • Многоугольник - это четырехугольный участок объекта поверхности.
  • Кромка - это линия периметра грани или многоугольника.

В чертежах все грани имеют три вершины, за исключением многогранных сетей, состоящих из смежных треугольников. С точки зрения алгоритмов тонирования каждая четырехугольная грань состоит из двух треугольных граней с одной общей кромкой.

Сглаживание объекта выполняется системой тонирования автоматически. При тонировании существует два типа сглаживания. Первый тип сглаживания выполняет интерполяцию нормалей к граням поверхности. В другой операции учитывается число граней, счётчик граней, определяющих геометрию; чем больше число граней, тем более гладкие получаются поверхности, но увеличивается время обработки.

Интерполяцией нормалей к граням управлять нельзя, однако можно изменять аккуратность отображения криволинейных объектов с помощью команды НАСТРВИД и системной переменной FACETRES.

Управление отображением кругов и дуг

Аккуратность отображения криволинейных 2D объектов, например, кругов и дуг, в текущем виде можно изменять с помощью команды НАСТРВИД.

В следующем примере отрезки становятся более заметными при уменьшении значений команды НАСТРВИД - до значений "Левый верхний" = 1000, "Середина" = 100, "Правый нижний = 10.

Эти объекты отображаются на экране как множество коротких прямолинейных сегментов. При увеличении значений параметров НАСТРВИД дуги и круги становятся более гладкими, но при этом требуется больше времени для их создания. Для повышения производительности рекомендуется в ходе рисования устанавливать для параметра НАСТРВИД как можно меньшее значение.

Управление отображением тел с криволинейными поверхностями

Системная переменная FACETRES регулирует плотность сети и гладкость раскрашенных и тонированных тел с криволинейными поверхностями.

В следующем примере отображаются ячейки на криволинейной геометрической структуре с низким значением переменной FACETRES. FACETRES = 0,25.

Если значение FACETRES равно 1, то устанавливается взаимнооднозначное соответствие между разрешением кругов и дуг при просмотре и аппроксимацией линий кривизны (посредством подразделения граней) твердотельных объектов. Например, если значение FACETRES равно 2, аппроксимация будет в два раза больше аппроксимации, установленной командой НАСТРВИД. Для параметра FACETRES по умолчанию установлено значение 0,5. Диапазон допустимых значений: от 0,01 до 10.

Изменение значения точности аппроксимации в команде НАСТРВИД оказывает соответствующее воздействие как на объекты, управляемые командой НАСТРВИД, так и на объекты, управляемые системной переменной FACETRES. Изменение значения переменной FACETRES отражается только на твердотельных объектах.

В следующем примере отображается гладкая геометрическая структура с высокими значениями переменной FACETRES. FACETRES = 5.

См. также

Создание сетей


Изменение плотности сети для сглаживания геометрии - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Изменение плотности сети для сглаживания геометрии
Понятия
Процедуры
Команды

Для изменения разрешающей способности при тонировании пространственных объектов

Для изменения разрешения отображения дуг и кругов


Для изменения разрешающей способности при тонировании пространственных объектов - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Изменение плотности сети для сглаживания геометрии
Понятия
Процедуры
Команды

Для изменения разрешающей способности при тонировании пространственных объектов

  1. В командной строке введите facetres.
  2. Выполните одно из следующих действий:
    • Для увеличения гладкости криволинейных поверхностей введите значение, большее чем 0,5.
    • Для уменьшения гладкости криволинейных поверхностей введите значение, меньшее чем 0,5.


Для изменения разрешения отображения дуг и кругов - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Изменение плотности сети для сглаживания геометрии
Понятия
Процедуры
Команды

Для изменения разрешения отображения дуг и кругов

  1. В командной строке введите настрвид.
  2. Подсказку, касающуюся быстрого зумирования, можно игнорировать, если единственной целью вызова команды является улучшение вида кругов и дуг.
  3. В ответ на запрос "Точность аппроксимации" выполните одно из следующих действий:
    • Для увеличения гладкости дуг и кругов введите значение, большее чем 1000.
    • Для уменьшения гладкости дуг и кругов введите значение, меньшее чем 1000.


Изменение плотности сети для сглаживания геометрии - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Изменение плотности сети для сглаживания геометрии
Понятия
Процедуры
Команды

Команды
НАСТРВИД | Задание точности аппроксимации объектов на текущем видовом экране
Системные переменные
FACETRES | Регулирует гладкость раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка системы тонирования - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Настройка системы тонирования
Понятия
Процедуры
Команды

Можно менять параметры, управляющие процессом тонирования, например при тонировании изображений высокого разрешения.

  • Использование палитры "Параметры тонирования"
    Палитра "Параметры тонирования" содержит основные элементы управления системой тонирования. В ней можно выбрать стандартные параметры тонирования или установить собственные значения.
  • Создание пользовательских наборов параметров тонирования
    При задании совокупности параметров тонирования, обеспечивающих требуемые результаты, рекомендуется сохранить их в виде пользовательского набора параметров для последующего применения.
  • Управление средой при тонировании
    Функции среды можно использовать для создания атмосферных эффектов или фона изображений.


Настройка системы тонирования - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Настройка системы тонирования
Понятия
Процедуры
Команды

Для создания пользовательского набора параметров тонирования из палитры "Дополнительные параметры тонирования"

Для создания пользовательского набора параметров тонирования из "Диспетчера наборов стандартных параметров тонирования"

Для изменения пользовательского набора параметров тонирования

Для работы с туманом / затемнением

Задание фона для именованного вида

Изменение фона для именованного вида


Настройка системы тонирования - Команды

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Настройка системы тонирования
Понятия
Процедуры
Команды
Команды
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
НАБПАРАМТОНИР | Задает предварительные настройки и повторно используемые параметры тонирования изображения
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
СРЕДАТОН | Управление туманом и затемнением объектов для визуального представления удаленных расстояний
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование палитры "Параметры тонирования" - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Использование палитры "Параметры тонирования"
Понятия
Процедуры
Команды

Палитра "Параметры тонирования" содержит основные элементы управления системой тонирования. В ней можно выбрать стандартные параметры тонирования или установить собственные значения.

Палитру "Параметры тонирования", в которой задаются параметры системы тонирования, можно открыть с помощью команды РЕЖТОНИР

Палитра разделена на несколько групп параметров, от основных до дополнительных. В разделах "Общие" содержатся параметры, влияющие на способ тонирования модели, способ управления материалами и тенями и способ выполнения сглаживания. (Процедура сглаживания уменьшает эффект зубчатости криволинейных линий и кромок.) С помощью параметров группы "Отслеживание лучей" осуществляется управление способом раскрашивания. Параметрами группы "Отраженное освещение" осуществляется управление свойствами освещения и задаётся использование общего освещения и метода чистовых проб. Имеются также элементы управления "Диагностические", которые могут помочь выяснить причины, почему изображение тонируется непредусмотренным образом.

Наборы стандартных параметров тонирования

Раскрывающийся список содержит стандартные параметры тонирования, называемые наборы параметров тонирования. В "Наборе параметров тонирования" хранятся группы параметров, позволяющие системе тонирования создавать изображения разного качества. Стандартные параметры обеспечивают изображения разного качества: от качества "Черновое", предназначенного для быстрого получения проверочных изображений, до качества "Презентационное", обеспечивающего изображения фотографического качества. Кроме того, можно открыть "Диспетчер наборов стандартных параметров тонирования", предназначенный для создания пользовательских наборов тонирования.

См. также

Создание пользовательских наборов параметров тонирования


Для создания пользовательского набора параметров тонирования из палитры "Дополнительные параметры тонирования" - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Использование палитры "Параметры тонирования"
Понятия
Процедуры
Команды

Для создания пользовательского набора параметров тонирования из палитры "Дополнительные параметры тонирования"

  1. В командной строке введите режтонир
  2. В палитре "Дополнительные параметры тонирования" выберите существующий стандартный или пользовательский набор.
  3. Внесите изменения в значения параметров, необходимых для тонирования.

    4. Обратите внимание, что перед исходным набором параметров тонирования расположен знак звездочки (*), указывающий, что набор был изменен.

  4. Выполните тонирование модели.
  5. Для сохранения внесенных изменений в качестве пользовательского набора параметров тонирования выполните одно из следующих действий:
    • Выберите поле имени набора наверху палитры "Дополнительные параметры тонирования" и введите новое имя.
    • Выберите поле набора параметров тонирования в панели "Тонирование" пульта управления и введите новое имя.


Использование палитры "Параметры тонирования" - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Использование палитры "Параметры тонирования"
Понятия
Процедуры
Команды

Команды
НАБПАРАМТОНИР | Задает предварительные настройки и повторно используемые параметры тонирования изображения
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание пользовательских наборов параметров тонирования - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Создание пользовательских наборов параметров тонирования
Понятия
Процедуры
Команды

При задании совокупности параметров тонирования, обеспечивающих требуемые результаты, рекомендуется сохранить их в виде пользовательского набора параметров для последующего применения.

Используя стандартный набор параметров в качестве основы, можно менять настройки параметров и отслеживать изменения в отображении тонированных изображений. По достижении требуемых результатов можно создать новый пользовательский набор параметров.

Пользователь может просмотреть параметры тонирования чертежа для любого набора и изменить их следующими методами:

  • Изменить настройки существующего набора параметров тонирования.
  • Изменить параметры в стандартном или созданном пользовательском наборе.
  • Создать, обновить или удалить пользовательские наборы параметров тонирования.
  • Задать набор параметров для использования системой тонирования.

В панели просмотра дерева отображаются все наборы параметров, сохраненные для текущего чертежа. Дерево разделено на две части: стандартные наборы параметров тонирования и созданные пользовательские наборы. Можно изменить порядок расположения стандартных и пользовательских наборов, перетаскивая их в режиме дерева. Новый созданный набор параметров всегда добавляется в раздел "Пользовательские наборы параметров тонирования". Кроме того, он отображается в списках "Наборы стандартных параметров тонирования" пульта управления "Тонирование" и в палитре "Параметры тонирования".

Большинство параметров тонирования палитры "Параметры тонирования" можно найти и в "Диспетчере наборов стандартных параметров тонирования". Используя стандартный набор параметров в качестве основы, можно изменить настройки параметров и увидеть, как выглядят тонированные изображения. По достижении требуемых результатов рекомендуется создать новый пользовательский набор параметров.

Предусмотрено удаление только пользовательских наборов параметров тонирования. При выборе стандартного набора кнопка "Удалить" недоступна.

Для того чтобы набор параметров тонирования использовался системой тонирования, необходимо выбрать его в качестве текущего. Работая с "Диспетчером наборов стандартных параметров тонирования" можно выбирать наборы для редактирования. Однако, если требуется, чтобы набор использовала система тонирования, необходимо нажать кнопку "Установить как текущее". В противном случае, используется набор, выбранный в панели "Тонирование" пульта управления или в палитре "Дополнительные параметры тонирования".

При внесении изменений в стандартный набор параметров тонирования рядом с его именем отображается звездочка. По достижении требуемых результатов рекомендуется сохранить набор, введя новое имя в списке установленных наборов в панели управления "Тонирование" или в палитре "Параметры тонирования".

При изменении параметров пользовательского набора параметров тонирования можно ввести новое имя для создания нового, пользовательского набора, или обновить текущий набор в списке пульта управления "Тонирование" или в палитре "Параметры тонирования".


Создание пользовательских наборов параметров тонирования - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Создание пользовательских наборов параметров тонирования
Понятия
Процедуры
Команды

Для создания пользовательского набора параметров тонирования из "Диспетчера наборов стандартных параметров тонирования"

Для изменения пользовательского набора параметров тонирования


Для создания пользовательского набора параметров тонирования из "Диспетчера наборов стандартных параметров тонирования" - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Создание пользовательских наборов параметров тонирования
Понятия
Процедуры
Команды

Для создания пользовательского набора параметров тонирования из "Диспетчера наборов стандартных параметров тонирования"

  1. В командной строке введите набпарамтонир.
  2. В "Диспетчере наборов стандартных параметров тонирования" выберите существующий стандартный или пользовательский набор.
  3. Нажмите кнопку "Создать копию" и укажите имя нового набора. Нажмите "ОК".

    4. Новый набор отображается в дереве в разделе "Пользовательские наборы параметров тонирования".


Для изменения пользовательского набора параметров тонирования - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Создание пользовательских наборов параметров тонирования
Понятия
Процедуры
Команды

Для изменения пользовательского набора параметров тонирования

  1. В командной строке введите набпарамтонир.
  2. В "Диспетчере наборов стандартных параметров тонирования" выберите существующий пользовательский набор.
  3. Внесите изменения в разделе параметров тонирования.

    4. Рядом с именем набора отображается звездочка, указывающая, что набор был изменен.

  4. Нажмите кнопку "Установить как текущее" и выполните тонирование сцены.

    5. По достижении требуемых результатов можно обновить текущий набор или вновь открыть "Диспетчер наборов параметров тонирования" и создать новый пользовательский набор параметров.


Создание пользовательских наборов параметров тонирования - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Создание пользовательских наборов параметров тонирования
Понятия
Процедуры
Команды

Команды
НАБПАРАМТОНИР | Задает предварительные настройки и повторно используемые параметры тонирования изображения
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление средой при тонировании - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Управление средой при тонировании
Понятия
Процедуры
Команды

Функции среды можно использовать для создания атмосферных эффектов или фона изображений.

Тонированное изображение можно улучшить с помощью атмосферных эффектов, например, тумана или затемнения, или добавить изображение растрового формата в качестве фона.

Эффекты "Туман / Затемнение"

Туман и затемнение - похожие атмосферные явления, размывающее объекты по мере его удаления от камеры. Однако для создания эффекта тумана используется белый цвет, а для создания затемнения - черный.

Для настройки параметров тумана и затемнения используется команда СРЕДАТОН. Основные настраиваемые параметры тумана и затемнения - цвет, близкое и далекое расстояние и размытость тумана в процентах.

Эффекты тумана и затемнения основаны на применении секущих плоскостей с учетом расстояний, указанных в диалоговом окне "Тонировать среду". Пусть, например, активная задняя секущая плоскость камеры расположена на расстоянии 30 метров от камеры. Если требуется, чтобы эффект тумана начинался на расстоянии 15 метров и распространялся неограниченно, установите для параметра "Близкое расстояние" значение 50, а для параметра "Далекое расстояние" - 100.

Параметры "Процент близкого тумана" и "Процент далекого тумана" регулируют плотность тумана и затемнения. Эти параметры могут принимать значения в диапазоне от 0,0001 до 100. Чем выше значение параметра, тем сильнее эффект тумана или затемнения.

Для небольших масштабных моделей может потребоваться установить значения параметров "Процент близкого тумана" и "Процент далекого тумана" ниже 1,0 для достижения требуемого эффекта.

Фон

Фон располагается позади модели. Фон может быть одноцветным или многоцветным градиентным, либо являться изображением растрового формата.

Фон лучше всего применять при тонировании неподвижных изображений либо анимации с неизменяемым видом или неподвижной камерой. Фон настраивается из Диспетчер видов. После настройки фон сопоставляется с именованным видом или камерой и сохраняется вместе с чертежом.


Управление средой при тонировании - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Управление средой при тонировании
Понятия
Процедуры
Команды

Для работы с туманом / затемнением

Задание фона для именованного вида

Изменение фона для именованного вида


Для работы с туманом / затемнением - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Управление средой при тонировании
Понятия
Процедуры
Команды

Для работы с туманом / затемнением

  1. Выберите камеру и откройте палитру "Свойства".
  2. Включите переднюю или заднюю секущую плоскость.
  3. Установите значение смещения для секущей плоскости.
  4. В командной строке введите средатон.
  5. Установите флажок "Включить туман" и задайте цвет тумана или затемнения.

    6. Светлые цвета обычно используются для тумана, а темные - для затемнения.

  6. Установите значения близкого и далекого расстояния, чтобы указать начало и конец тумана.
  7. Установите непрозрачность тумана или затемнения в параметрах процента близкого и далекого тумана. Нажмите "ОК".
  8. Выполните тонирование модели.

Панель "Тонирование"


Задание фона для именованного вида - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Управление средой при тонировании
Понятия
Процедуры
Команды

Задание фона для именованного вида

  1. В командной строке введите вид.
  2. Выберите существующий именованный вид в списке "Виды моделей".
  3. Откройте меню "Переопределение фона" и выберите пункт "Заливка", "Градиент" или "Изображение".
  4. Выберите для фона цвет или изображение в растровом формате. Нажмите "ОК".
  5. Нажмите "ОК", чтобы закрыть Диспетчер видов.
  6. В панели "3D орбита" пульта управления выберите именованный вид.
  7. Выполните тонирование сцены.

Панель "Вид"


Изменение фона для именованного вида - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Управление средой при тонировании
Понятия
Процедуры
Команды

Изменение фона для именованного вида

  1. В командной строке введите вид.
  2. Выберите существующий именованный вид в списке "Виды моделей".
  3. Откройте меню "Переопределение фона" и выберите пункт "Правка".
  4. Выберите для фона новый цвет или новое изображение. Нажмите "ОК".
  5. Нажмите "ОК", чтобы закрыть Диспетчер видов.
  6. В панели "3D орбита" пульта управления выберите именованный вид.
  7. Выполните тонирование сцены.

Панель "Вид"


Управление средой при тонировании - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Управление средой при тонировании
Понятия
Процедуры
Команды

Команды
ВИД | Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды
СРЕДАТОН | Управление туманом и затемнением объектов для визуального представления удаленных расстояний
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Основные сведения о тонировании - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Основные сведения о тонировании
Понятия
Процедуры
Команды

Основной целью работы является создание высококачественного изображения фотографического качества, поэтому для достижения этой цели потребуется создать множество различных вариантов тонирования.

На начальном этапе можно использовать команду ТОНИРОВАТЬ для тонирования модели без применения дополнительных материалов, источников освещения или настройки сцены. При тонировании новой модели по умолчанию используется виртуальный удаленный источник света, расположенный за спиной наблюдателя. Этот источник нельзя ни переместить, ни изменить.

  • Пульт управления "Тонирование"
    Быстрый доступ к основным функциям тонирования предоставляет пульт "Тонирование".
  • Задание места назначения тонирования
    Изображения с тонированием отображаются на видовом экране или в окне тонирования.
  • Тонирование видов, выбранных объектов или части содержимого
    Предусмотрено тонирование всего вида, набора выбранных объектов или части видимого на экране изображения.
  • Задание выходного разрешения
    Установите разрешение тонированного изображения, указав его ширину и высоту в пикселах.
  • Изменения материалов
    Добавление материалов к объектам делает модель более реалистичной.
  • Регулировка выборки для улучшения качества изображения
    Для устранения зазубрин в наклонных или кривых линиях можно использовать несколько стандартных наборов параметров тонирования.
  • Тонирование с тенями
    С помощью теней можно придать тонированным изображениям больше глубины и сделать их более реалистичными.


Основные сведения о тонировании - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Основные сведения о тонировании
Понятия
Процедуры
Команды

Для подавления или отображения панели тонирования пульта управления

Для указания места назначения тонирования

Для тонирования вида

Для тонирования набора объектов

Для тонирования выделенной области

Просмотр теней на видовом экране

Создание теней, полученных применением текстур теней, в тонированном изображении

Создание теней трассировки луча в тонированном изображении


Основные сведения о тонировании - Команды

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Основные сведения о тонировании
Понятия
Процедуры
Команды
Команды
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
МАТЕРИАЛПРИСВ | Назначает материалы объектам по слоям
МАТЕРИАЛСООТВ | Отображается ручка блока наложения материалов для корректировки наложений на грань или на объект
МАТЕРИАЛЫ | Администрирование, применение и редактирование материалов
НАБПАРАМТОНИР | Задает предварительные настройки и повторно используемые параметры тонирования изображения
ПУЛЬТУПР | Открывает окно "Пульт управления"
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
СОХРИЗОБ | Сохранение тонированных изображений в файлах
СРЕДАТОН | Управление туманом и затемнением объектов для визуального представления удаленных расстояний
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
ТОНИРОКНО | Отображается окно тонирования без вызова задачи тонирования.
ТОНИРПОДРЕЗ | Задает конкретный участок (окно кадрирования) в изображении для тонирования
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Пульт управления "Тонирование" - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Пульт управления "Тонирование"
Понятия
Процедуры
Команды

Быстрый доступ к основным функциям тонирования предоставляет пульт "Тонирование".

При первом открытии чертежа панель "Тонирование" обычно отображается в сокращенном виде.

Он предоставляет возможность выполнить тонирование всего вида или какой-то его области, выбрать набор параметров тонирования либо отменить выполняемую задачу тонирования. Кроме того, в окне "Тонирование" расположен счетчик, показывающий ход выполнения тонирования.

Также в меню "Набор параметров тонирования" можно открыть Диспетчер наборов стандартных параметров тонирования, предназначенный для создания и изменения пользовательских наборов параметров тонирования.

При необходимости доступа к дополнительным параметрам можно развернуть пульт управления "Тонирование", нажав на значок в виде чайника.

Элементы расширенного пульта управления тонирования предлагают дополнительные функции и параметры тонирования, включая следующие:

  • Диалоговое окно "Среда", в котором можно установить эффекты тумана и затемнения.
  • Палитра "Параметры тонирования" с дополнительными параметрами.
  • "Окно тонирования" для просмотра изображений и записей журнала тонирования, сохраненных с текущим чертежом.
  • Регуляторы изменения качества изображения для тонирования изображений разного уровня детальности.
  • Местоположение, имя и спецификации формата файла для сохранения изображения по завершению процесса тонирования.
  • Параметры выходного разрешения тонирования.


Для подавления или отображения панели тонирования пульта управления - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Пульт управления "Тонирование"
Понятия
Процедуры
Команды

Для подавления или отображения панели тонирования пульта управления

По умолчанию на пульте управления отображается панель тонирования, однако ее можно скрыть.

  1. Правой кнопкой мыши нажмите любую другую панель пульта управления.
  2. Выберите "Панели управления".
  3. Выберите "Панель управления тонированием".

    4. Панель "Тонирование" скрыта на пульте управления. Панель не будет отображаться до тех пор, пока пользователь не повторит приведенные выше действия, чтобы вновь отобразить панель тонирования.


Пульт управления "Тонирование" - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Пульт управления "Тонирование"
Понятия
Процедуры
Команды

Команды
НАБПАРАМТОНИР | Задает предварительные настройки и повторно используемые параметры тонирования изображения
ПУЛЬТУПР | Открывает окно "Пульт управления"
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
СРЕДАТОН | Управление туманом и затемнением объектов для визуального представления удаленных расстояний
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
ТОНИРОКНО | Отображается окно тонирования без вызова задачи тонирования.
ТОНИРПОДРЕЗ | Задает конкретный участок (окно кадрирования) в изображении для тонирования
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание места назначения тонирования - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Задание места назначения тонирования
Понятия
Процедуры
Команды

Изображения с тонированием отображаются на видовом экране или в окне тонирования.

После выполнения тонирования сцены изображение отображается на видовом экране или в окне тонирования. Это и называется местом назначения тонирования.

Место назначения тонирования указывается в разделе "Контекстное меню тонирования" палитры "Дополнительные параметры тонирования". По умолчанию устанавливается значение "Окно".

Если местом назначения тонирования является "Окно", система тонирования автоматически открывает "Окно тонирования" и обрабатывает изображение. По окончанию обработки изображение появляется в окне и создается запись журнала. При выполнении других заданий тонирования записи добавляются в журнал, что позволяет быстро открывать и сравнивать предыдущие изображения для достижения наилучших результатов. Изображения можно сохранять из окна тонирования.

Если место назначения тонирования задать как "Видовой экран", полученное изображение тонируется и отображается непосредственно на активном видовом экране. По существу это является однократным тонированием, так как записи журнала тонирования не создаются и нет возможности сравнить результаты разных задач тонирования. Для сохранения тонированного изображения из видового экрана используйте команду СОХРИЗОБ.

При тонировании с выводом на видовой экран изображение объектов всегда создается на фоне, заданном для области рисования. Цвет фона окна тонирования может совпадать с цветом основного фона. Используйте команду РЕГЕН для обновления экрана.

См. также

Окно тонирования


Для указания места назначения тонирования - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Задание места назначения тонирования
Понятия
Процедуры
Команды

Для указания места назначения тонирования

  1. В командной строке введите режимтон
  2. При необходимости в палитре "Дополнительные параметры тонирования" перейдите к началу списка и откройте меню "Общие" » "Контекстное меню тонирования".
  3. Откройте список "Назначение" и выберите значение "Окно" или "Видовой экран".
  4. Выполните тонирование сцены.

    5. Панель "Тонирование"

    Ввод команды: РЕЖИМТОН

    Пульт управления: Панель "Тонирование" (нажмите значок, чтобы раскрыть), "Дополнительные параметры тонирования"


Задание места назначения тонирования - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Задание места назначения тонирования
Понятия
Процедуры
Команды

Команды
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
СОХРИЗОБ | Сохранение тонированных изображений в файлах
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Тонирование видов, выбранных объектов или части содержимого - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Тонирование видов, выбранных объектов или части содержимого
Понятия
Процедуры
Команды

Предусмотрено тонирование всего вида, набора выбранных объектов или части видимого на экране изображения.

Тонирование вида

По умолчанию в процесс тонирования вовлекаются все объекты, принадлежащие текущей сцене чертежа. Если именованный вид или вид камеры не был открыт, тонируется текущий вид. Процесс тонирования только основных объектов или небольших участков вида проходит быстрее, однако тонирование вида целиком позволяет определить ориентацию всех объектов по отношению друг к другу.

Если текущий чертеж содержит именованные виды или к модели были добавлены камеры, их можно быстро отобразить с помощью команды ВИД или выбрать из списка "Виды" пульта управления "3D орбита".

В следующем примере демонстрируется процесс тонирования именованного вида.

В зависимости от выбранного места назначения тонированный вид отображается в окне тонирования или непосредственно на видовом экране. Подробное описание окна тонирования см. в разделе ТОНИРОВАТЬ документа "Справочник команд".

Тонирование выбранных объектов

При добавлении элемента к определенным объектам нет необходимости терять время на тонирование всего видового экрана. Можно изменить процедуру тонирования на "Выбранные", которая позволяет выбирать объекты для тонирования.

В следующем примере демонстрируется результат тонирования первой бутылки, ее пробки и фужера.

Тонирование набора объектов эффективно при тестировании различных материалов, особенно материалов, включающих текстуры. Благодаря тонированию выбранного объекта можно посмотреть материал и при необходимости изменить координаты текстуры.

Тонирование выделенной области

Иногда необходимо выполнить тонирование части изображенного на экране чертежа, сохранив при этом окружающую среду.

В следующем примере тонируется только область, окружающая третью бутылку и фужер.

Выбрав для процедуры тонирования значение "Обрезать", следует указать небольшую область видового экрана для тонирования. Можно не только выбирать объекты в окне, но и указать прямоугольную область на видовом экране. При этом тонируются все объекты в указанной области, а объекты вне ее игнорируются.

Примечание Тонированная область отображается только на видовом экране. Используйте команду РЕГЕН для обновления экрана.


Тонирование видов, выбранных объектов или части содержимого - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Тонирование видов, выбранных объектов или части содержимого
Понятия
Процедуры
Команды

Для тонирования вида

Для тонирования набора объектов

Для тонирования выделенной области


Для тонирования вида - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Тонирование видов, выбранных объектов или части содержимого
Понятия
Процедуры
Команды

Для тонирования вида

  1. Воспроизведите на экране трехмерный вид модели.
  2. В командной строке введите режимтон
  3. В наборе параметров тонирования измените качество и скорость тонирования.

    4. Набор "Черновое" предлагает очень быстрый способ тонирования, но низкого качества. Набор "Презентационное" создает изображение высокого качества, но при этом процесс тонирования занимает существенно больше времени.

  4. Укажите место размещения тонированного изображения, выбрав для параметра "Назначение" значение "Окно" или "Видовой экран".

    5. Если указать место расположения изображения, оно не только отобразится на экране, но и сохранится в файле.

  5. Выполните тонирование сцены.

Панель "Тонирование"

Ввод команды: РЕЖИМТОН

Пульт управления: Панель "Тонирование" (нажмите значок, чтобы раскрыть), "Дополнительные параметры тонирования"


Для тонирования набора объектов - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Тонирование видов, выбранных объектов или части содержимого
Понятия
Процедуры
Команды

Для тонирования набора объектов

  1. В командной строке введите режмитон
  2. В наборе параметров тонирования измените качество и скорость тонирования.

    3. Набор "Черновое" предлагает очень быстрый способ тонирования, но низкого качества. Набор "Презентационное" создает изображение высокого качества, но при этом процесс тонирования занимает существенно больше времени.

  3. Установите для процедуры тонирования значение "Выбранные".
  4. Выберите объекты модели для тонирования.
  5. Выполните тонирование сцены.

Панель "Тонирование"

Ввод команды: РЕЖИМТОН

Пульт управления: Панель "Тонирование" (нажмите значок, чтобы раскрыть), "Дополнительные параметры тонирования"


Для тонирования выделенной области - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Тонирование видов, выбранных объектов или части содержимого
Понятия
Процедуры
Команды

Для тонирования выделенной области

  1. В командной строке введите тонирподрез.
  2. Выделите рамкой область на экране для тонирования.
  3. Выполните тонирование сцены.

Ввод команды: ТОНИРПОДРЕЗ

Пульт управления: Панель "Тонирование", окно области тонирования


Тонирование видов, выбранных объектов или части содержимого - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Тонирование видов, выбранных объектов или части содержимого
Понятия
Процедуры
Команды

Команды
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
ТОНИРПОДРЕЗ | Задает конкретный участок (окно кадрирования) в изображении для тонирования
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание выходного разрешения - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Задание выходного разрешения
Понятия
Процедуры
Команды

Установите разрешение тонированного изображения, указав его ширину и высоту в пикселах.

Отображением тонированного изображения управляют три параметра разрешения: ширина, высота и пропорции изображения.

Ширина и высота указывают размер тонированного изображения в пикселах. Пиксел (от Picture Element, элемент изображения) - это одна точка графического изображения.

По умолчанию установлено выходное разрешение 640 x 480, максимально возможное расширение - 4096 x 4096. Чем больше установлено значение разрешения, тем меньше размер пикселов и точнее отображаются элементы. Для тонирования изображений с высоким разрешением требуется больше времени.

Значения выходного разрешения устанавливаются в Диалоговое окно "Формат вывода". Значения параметров можно ввести непосредственно в полях ширины и высоты либо изменить разрешение с помощью элементов управления.

Установленное выходное разрешение хранится вместе с текущим чертежом и добавляется в список разрешений в панели "Тонирование" пульта управления. В большинстве случаев при тестировании внешнего вида объектов модели используются низкие значения разрешения - 320 x 200 и ниже. По мере добавления элементов и материалов рекомендуется переходить к разрешениям среднего диапазона, например, 640 x 480. Для тонирования на последних этапах работы следует применять наибольшее разрешение, необходимое для проекта (1024 x 768 и выше), так как именно это изображение будет представлено заказчику или напечатано.

Пропорция указывает размеры неподвижного изображения или рамки анимации. Она вычисляется как отношение ширины к высоте без учета разрешения изображения. Значение пропорции задается параметром "Пропорции изображения". Значение пропорции обычно указывается в виде отношения ширины к высоте (например, 4:3) или коэффициента (1,333). При изменении этого значения меняется параметр "Высота", чтобы сохранить правильные размеры выходного разрешения.

В следующем примере демонстрируются различные пропорции.

При фиксации пропорции изображения параметры ширины и высоты становятся зависимыми друг от друга: при изменении одного автоматически меняется другой в соответствии со значением пропорци.


Основные сведения о тонировании

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Основные сведения о тонировании
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Задание выходного разрешения - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Задание выходного разрешения
Понятия
Процедуры
Команды

Команды
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменения материалов - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Изменения материалов
Понятия
Процедуры
Команды

Добавление материалов к объектам делает модель более реалистичной.

При тонировании в зависимости от используемого материала меняется способность объекта отражать и пропускать свет. Программа имитирует текстуру материала, эффекты выдавливания, а также отражения и преломления света.

В палитре "Дополнительные параметры тонирования" можно задать, требуется ли использовать материалы и их фильтрацию, а также способ тонирования поверхностей объекта.

Как правило, созданные и прикрепленные к объектам модели материалы включаются при процессе тонирования. Если же их отключить, всем объектам модели присваиваются характеристики глобального материала.

Фильтр текстур

В программе предусмотрено управление фильтрацией текстур атмосферных явлений, а также усреднением пикселов, применяемым процедурой сглаживания во время тонирования модели.

Если фильтрация текстур включена, система тонирования использует пирамидальные методы фильтрации - фильтрации как функции от расстояния.

Примечание Для сужающихся в перспективе поверхностей при наложении подробных текстур могут возникать зазубрины.

Фильтрация текстур вызывает небольшие погрешности тонирования. Для пирамидальной фильтрации требуются значительные ресурсы памяти - около 133% размера текстуры. По сравнению с текстурными материалами тонирование предлагает меньший уровень детальности и реалистичности.

Если фильтрация текстур отключена, при тонировании модели текстуры не сглаживаются.

2-стороннее тонирование

Так как направление нормалей к граням изменить нельзя, иногда возникает необходимость работы с моделью с отраженными нормалями. Задняя сторона граней невидима для системы тонирования. Это означает, что грань, видимая с задней стороны, не тонируется и создается впечатление, что эта грань отсутствует. Обычно объекты создаются с направленными наружу нормалями к поверхностям. Однако можно создать объекты с отраженными гранями или импортировать сложную геометрию, в которой нормали к граням не унифицированы.

Если установлен флажок "Вынужденное 2-стороннее", в отношении обеих сторон граней применяется отслеживание лучей с тенями. Хотя это увеличивает время тонирования, обычно применение процедуры занимает меньше времени, чем поиск и обработка отраженных граней вручную.


Изменения материалов - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Изменения материалов
Понятия
Процедуры
Команды

Команды
МАТЕРИАЛПРИСВ | Назначает материалы объектам по слоям
МАТЕРИАЛСООТВ | Отображается ручка блока наложения материалов для корректировки наложений на грань или на объект
МАТЕРИАЛЫ | Администрирование, применение и редактирование материалов
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Регулировка выборки для улучшения качества изображения - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Регулировка выборки для улучшения качества изображения
Понятия
Процедуры
Команды

Для устранения зазубрин в наклонных или кривых линиях можно использовать несколько стандартных наборов параметров тонирования.

На мониторе изображение строится из отдельных пикселов фиксированной сетки. Поэтому сцены, тонированные с помощью наборов параметров "Черновое" или "Низкое", получаются неаккуратными и с зубчатыми краями.

В следующем примере качество изображения очень низкое - "Мин". Выборка = 1/64; "Макс". Выборка = 1/4.

Чем выше разрешение (и, соответственно, мельче пикселы), тем менее заметен эффект зазубрин. Однако, лучше всего уменьшить эффект зазубрин с помощью процедуры сглаживания. Процедура сглаживания, используемая системой тонирования, называется выборкой. Выборкой можно управлять с помощью параметров образца и фильтра палитры "Дополнительные параметры тонирования".

Процедура выборки определяет наилучший цвет для каждого тонируемого пиксела. Система тонирования сначала выбирает произвольные пикселы вокруг рассматриваемого пиксела, затем использует фильтр для определения оптимального цвета обрабатываемого пиксела. Увеличение минимума и максимума диапазона выборки значительно улучшает качество тонирования.

В следующем примере увеличено сглаживание кромок - "Мин". Выборка = 1; "Макс". Выборка = 16.

Предусмотрено пять методов фильтрации: "Прямоугольник", "По Гауссу", "Треугольник", "По Митчеллу" или "По Ланчосу". По умолчанию установлен самый быстрый метод - "Прямоугольник". Фильтр "По Митчеллу" обычно самый точный. Фильтр "Прямоугольник" равномерно обрабатывает выборку, весовые коэффиценты не используются. Каждый фильтр применяет собственную систему весов для обработки пикселов.

У процедуры сглаживания зазубрин есть по крайней мере два недостатка.

  • Дополнительные вычисления. Чтобы добавить промежуточные оттенки, программе необходимо анализировать как пикселы, образующие линию, так и соседние пикселы фона.
  • Утолщение линий. Хотя линии с устраненными зазубринами выглядят более плавными, они получаются толще, чем исходные.

Использовать или нет устранение зазубрин - решает пользователь, основываясь на требованиях, предъявляемых к продолжительности тонирования и качеству полученного изображения. Следует искать разумный компромисс между возможностями аппаратных средств и запросами аудитории, которой будет демонстрироваться результат.

Стандартные наборы параметров тонирования предлагают пять уровней сглаживания. Набор "Черновое" использует низший уровень устранения зазубрин, при этом процесс тонирования занимает наименьшее количество времени. Чем выше установленный уровень устранения зазубрин, тем больше времени требуется на вычисления при тонировании. При использовании алгоритма устранения зазубрин повышается эффективность процесса, поскольку программа может снижать количество требуемых проб для отдельных пикселов изображения.


Регулировка выборки для улучшения качества изображения - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Регулировка выборки для улучшения качества изображения
Понятия
Процедуры
Команды

Команды
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Тонирование с тенями - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Тонирование с тенями
Понятия
Процедуры
Команды

С помощью теней можно придать тонированным изображениям больше глубины и сделать их более реалистичными.

Система тонирования генерирует тени посредством наложения теней или посредством трассировки лучей. Тени, полученные применением текстур теней, основаны на растровом формате, генерируемым системой тонирования во время предварительного тонирования сцены. При использовании наложения теней получаются более мягкие края и требуется меньшее расчетное время, чем при создании теней трассировки луча, но тени получаются менее точными. Функция "Отслеживание лучей" отслеживает путь лучей, исходящих из источника света. Тени появляются в тех местах, где распространению лучей препятствуют объекты. У теней трассировки луча более точные и четкие границы, и для их получения требуется большее расчётное время.

Тени, полученные наложением

Только с помощью карт теней можно получать тени с мягкими границами, не отображают цвет, отбрасываемый прозрачными или полупрозрачными объектами. Тени, полученные наложением, рассчитываются быстрее, чем тени трассировки луча.

В следующем примере демонстрируется, как карты теней обеспечивают мягкие, менее точные тени, обработка которых выполняется быстрее, чем обработка теней трассировки луча.

Во время предварительного тонирования создаётся растровый формат карты теней. Качество теней регулируется увеличением или уменьшением размера карты теней. По умолчанию размер карты теней равен 256 x 256 пикселов. Если отображается слишком зернистая тень, можно улучшить её качество, увеличивая размер карты. Не следует использовать тени, полученные применением текстур теней, если свет проходит через прозрачную поверхность (например, если требуется получить тени от рамы и средников окна с большим числом панелей). Чтобы средники отбрасывали тени, потребовалось бы удалить стёкла.

Тени трассировки луча

Тени трассировки лучей (так же, как эффекты отражения и преломления) генерируются алгоритмом трассировки лучей, исходящих от источника света. Этот вид теней более точный, чем тени на основе карт.

В следующем примере демонстрируется, что трассировка луча, требующая более длительной обработки, обеспечивает получение более точных и реалистичных теней.

Тени трассировки лучей имеют четко очерченные границы, они передают изменение цвета при прохождении луча сквозь прозрачные и полупрозрачные объекты. Поэтому тени от рамы и средников окна с большим числом панелей будут тонироваться. Так как этот вид теней вычисляется без использования карты, они не требует настройки разрешения, в отличие от теней на основе карт.

Режимы теней

Можно выбрать один из трех режимов теней: Для режима теней можно задать значение "Простой", "Сортировка" или "Сегмент".

  • Простой Система тонирования выбирает модули тонирования в произвольном порядке. Этот режим теней установлен по умолчанию.
  • Отсортировано Система тонирования последовательно выбирает модули тонирования от объекта до источника освещения.
  • Сегмент Система тонирования последовательно выбирает модули тонирования вдоль светового луча между объектом и источником света.
Отображение теней

Для того, чтобы в модели присутствовали тени, необходимо установить источник света. Необходимо ввести в сцену источник света и указать, создаёт ли этот источник света тени. Чтобы на видовом экране отображались тени, при настройке сцены необходимо включить использование теней для визуального стиля. Если требуется, чтобы в тонированном изображении отображались тени, необходимо на палитре "Дополнительные параметры тонирования" включить режим теней и выбрать тип теней для тонирования.


Тонирование с тенями - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Тонирование с тенями
Понятия
Процедуры
Команды

Просмотр теней на видовом экране

Создание теней, полученных применением текстур теней, в тонированном изображении

Создание теней трассировки луча в тонированном изображении


Просмотр теней на видовом экране - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Тонирование с тенями
Понятия
Процедуры
Команды

Просмотр теней на видовом экране

  1. В командной строке введите визстили.
  2. В окне "Диспетчер визуальных стилей" выберите стиль "Концептуальный" или "Реалистический".

    3. Параметр "Отображение тени" не оказывает влияния на стили "3D скрытый" или "3D каркас".

  3. Задайте для параметра "Отображение тени" значение "Тени на земле" или "Полные тени".
  4. Закройте окно "Диспетчер визуальных стилей".

Ввод команды: ВИЗСТИЛИ

Пульт управления: Панель "Визуальный стиль", управление визуальными стилями


Создание теней, полученных применением текстур теней, в тонированном изображении - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Тонирование с тенями
Понятия
Процедуры
Команды

Создание теней, полученных применением текстур теней, в тонированном изображении

  1. В командной строке введите режимтон
  2. Убедитесь, что в палитре "Дополнительные параметры тонирования" установлен флажок "С тенями".
  3. Выберите требуемый режим создания теней.
  4. Включите параметр "Текстура теней".
  5. Выполните тонирование модели.

Панель "Тонирование"

Ввод команды: РЕЖТОНИР


Создание теней трассировки луча в тонированном изображении - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Тонирование с тенями
Понятия
Процедуры
Команды

Создание теней трассировки луча в тонированном изображении

  1. В командной строке введите режмитон
  2. Убедитесь, что в палитре "Дополнительные параметры тонирования" установлен флажок "С тенями".
  3. Выберите требуемый режим создания теней.
  4. Отключите параметр "Текстура теней".
  5. Выполните тонирование модели.

Панель "Тонирование"

Ввод команды: РЕЖТОНИР


Тонирование с тенями - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Тонирование с тенями
Понятия
Процедуры
Команды

Команды
ВИЗСТИЛИ | Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Дополнительные функции тонирования - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Дополнительные функции тонирования
Понятия
Процедуры
Команды

С помощью дополнительных функций тонирования можно выполнять тонирование изображений высокого уровня детальности и фотографического качества.

  • Отражения и преломления лучей
    Функция "Отслеживание лучей" отслеживает путь лучей, исходящих из источника света. Возникающие при этом отражения и преломления лучей точны с физической точки зрения.
  • Преимущества отраженного освещения
    Функции отраженного освещения, например общее освещение и метод чистовых проб, повышает реалистичность сцены благодаря имитации диффузионного отражения или взаимного отражения света.
  • Чистовая проба
    Метод чистовых проб - дополнительный алгоритм, используемый для улучшения общего освещения. Он увеличивает число лучей, используемых при сглаживании общего освещения, и подавляет дефекты освещения.


Дополнительные функции тонирования - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Дополнительные функции тонирования
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Дополнительные функции тонирования - Команды

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Дополнительные функции тонирования
Понятия
Процедуры
Команды
Команды
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Отражения и преломления лучей - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Отражения и преломления лучей
Понятия
Процедуры
Команды

Функция "Отслеживание лучей" отслеживает путь лучей, исходящих из источника света. Возникающие при этом отражения и преломления лучей точны с физической точки зрения.

Для уменьшения времени, необходимого для генерации отражений и преломлений, на лучи накладывается ограничение глубина трассировки Глубина трассировки ограничивает число отражений или преломлений луча, либо оба эти значения. В палитре "Дополнительные параметры тонирования" можно установить максимальную глубину трассировки, максимальное число отражений или максимальное число преломлений

В следующем примере демонстрируется, как значительно отражения и преломления, полученные при трассировке луча, повышают реалистичность сцены. Макс. глубина = 8; макс. отражений и преломлений = 4.

Если режим трассировки луча отключён, отражения и преломления отсутствуют.

В следующем примере демонстрируется точно такая же модель с отключенным режимом трассировки луча.

Глубина трассировки задает количество возможных отражений или преломлений светового луча. Увеличение этих значений приводит к повышению сложности и реалистичности тонируемого изображения за счет увеличения затрачиваемого времени.

В следующем примере демонстрируется, как увеличение глубины трассировки улучшает тонирование. Макс. глубина = 4; макс. отражений и преломлений = 2.

Управляющие параметры режима трассировки луча

Параметр "Макс. глубина" ограничивает суммарно возможное число преломлений и отражений. Трассировка луча прекращается при достижении суммой чисел отражения и преломления значения максимальной глубины. Например, если для параметра "Макс. глубина" установлено значение 3, а для параметров "Макс отражений" и "Макс преломлений" - 2, луч может дважды отразиться и один раз преломиться, или наоборот, но он не может отразиться и преломиться четыре раза.

Параметр "Макс отражений" задает число возможных отражений луча. При значении, равном 0, отражения отсутствуют. При значении, равном 1, допускается однократное отражение луча. При значении, равном 2, допускается двукратное отражение луча и т.д.

Параметр "Макс преломлений" задает число возможных преломлений луча. При значении, равном 0, преломления отсутствуют. При значении, равном 1, допускается однократное преломление луча. При значении, равном 2, допускается двукратное преломление луча и т.д.

Примечание При увеличении числа отражений и преломлений также увеличивается продолжительность процесса тонирования.


Дополнительные функции тонирования

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Дополнительные функции тонирования
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Отражения и преломления лучей - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Отражения и преломления лучей
Понятия
Процедуры
Команды

Команды
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Преимущества отраженного освещения - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Преимущества отраженного освещения
Понятия
Процедуры
Команды

Функции отраженного освещения, например общее освещение и метод чистовых проб, повышает реалистичность сцены благодаря имитации диффузионного отражения или взаимного отражения света.

Функция "Общее освещение" допускает эффект смешивания цветов. Например, если рядом с белой стеной расположена красная столешница, стена приобретает светло-розовый оттенок. Может показаться, что это незначительная деталь, но если розовый оттенок будет отсутствовать на изображении, оно будет выглядеть ненастоящим. Данный эффект невозможен при обычных вычислениях трассировки луча.

При расчете общего освещения система тонирования использует фотонные схемы - метод создания эффектов отраженного освещения и общего освещения. Побочным эффектом использования фотонных схем является появление дефектов тонирования, как например, темных углов и низкочастотных колебаний освещения. Подобные дефекты можно частично или полностью подавить, включив метод чистовых проб, который увеличивает число лучей, используемых при обсчитывании эффекта общего освещения.

При подготовке окончательной процедуры тонирования, перед заданием каких-либо параметров общего освещения, следует убедиться в том, что указаны единицы чертежа, которые должны использоваться. Изменение единиц чертежа после того, как получено удовлетворительное общее освещение, отрицательно сказывается на результатах тонирования.

Точность и мощность общего освещения зависит от числа порождаемых фотонов, радиуса выборки и глубины трассировки. Этот пример демонстрирует эффекты, определяемые низким числом фотонов и слишком малым радиусом выборки.

Фотоны и радиус выборки

Мощность общего освещения зависит от указанного числа фотонов. При уменьшении числа фотонов уровень шума общего освещения увеличивается, но при этом оно становится более рассеянным. При уменьшении числа фотонов уровень шума в общем освещении увеличивается, но освещение становится менее рассеянным. Чем больше используется фотонов, тем дольше выполняется процесс тонирования.

Для предварительного просмотра общего освещения рекомендуется для параметров "Фотоны/образцы" или "Фотоны/Источник света" установить минимальные значения. Эти значения следует увеличить при выполнении окончательного тонирования.

Радиус выборки определяет размер фотонов. В большинстве случаев установленное по умолчанию значение размера фотона - 1/10 от размера сцены ("Использовать радиус"=откл) - обеспечивает приемлемый результат. Но иногда размер фотона по умолчанию оказывается слишком большим или слишком маленьким.

Значение радиуса выборки ("Радиус") определяет, перекрываются ли фотоны. При наложении фотонов друг на друга система тонирования сглаживает их. Увеличение радиуса улучшает качество сглаживания и создает более естественное освещение. Если фотоны маленького радиуса и не перекрываются друг другом, процедура сглаживания не выполняется. Рекомендуется устанавливать такие значения, чтобы фотоны накладывались друг на друга. Для достижения хороших результатов рекомендуется включить параметр "Использовать радиус" и увеличить значение радиуса.

Глубина трассировки общего освещения

Алгоритмы вычисления параметра "Глубина трассировки" аналогичны алгоритмам вычисления отражения и преломления. Однако параметр глубины трассировки применяется к фотонам, использующимся при общем освещении, а не к отражениям и преломлениям лучей.

Параметр максимальной глубины ограничивает суммарно возможное число преломлений и отражений. Отражения и преломления фотона прекращаются по достижении их суммы значения максимальной глубины. Например, если для параметра "Макс глубина" установлено значение 3, а для параметров "Макс отражений" и "Макс преломлений" - 2, фотон может дважды отразиться и один раз преломиться, или наоборот, но он не может отразиться и преломиться четыре раза.

Параметр "Макс отражений" задает число возможных отражений фотона. При значении, равном 0, отражения отсутствуют. При значении, равном 1, возможно только однократное отражение фотона. При значении, равном 2, возможно двукратное отражение фотона и т.д.

Параметр "Макс преломлений" задает число возможных преломлений фотона. При значении, равном 0, преломления отсутствуют. При значении, равном 1, возможно только однократное преломление фотона. При значении, равном 2, возможно двукратное преломление фотона и т.д.


Преимущества отраженного освещения - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Преимущества отраженного освещения
Понятия
Процедуры
Команды

Команды
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Чистовая проба - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Чистовая проба
Понятия
Процедуры
Команды

Метод чистовых проб - дополнительный алгоритм, используемый для улучшения общего освещения. Он увеличивает число лучей, используемых при сглаживании общего освещения, и подавляет дефекты освещения.

Для создания общего освещения используется алгоритм, основанный на фотонных схемах. Следствием этого является возникновение дефектов тонирования, например, темных углов и низкочастотных колебаний освещения.

Метод чистовых проб увеличивает число лучей, используемых при создании общего освещения, тем самым полностью или частично подавляя эти дефекты освещения.

Пользователь сам решает, следует ли применять метод чистовых проб. Метод чистовых проб значительно увеличивает продолжительность процесса тонирования. Однако он очень удобен для сцен с общим диффузным освещением.

Отключите метод чистовых проб во время предварительного просмотра, затем включите его при окончательной процедуре тонирования. (Увеличение числа фотонов, используемых для создания общего освещения, также улучшает качество освещения.)

Для включения и регулировки метода чистовых проб используйте палитру "Дополнительные параметры тонирования".


Чистовая проба - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Чистовая проба
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Журнал тонированных изображений - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Журнал тонированных изображений
Понятия
Процедуры
Команды

Журнал тонирования включает список последних тонированных изображений текущей загруженной модели.

Каждое изображение, местом расположения тонирования которого является файл или "Окно тонирования", сохраняется вместе с чертежом в качестве записи журнала.

Понятие о записях журнала

Записи журнала хранят информацию о тонированиях текущего чертежа.

Каждая запись журнала содержит информацию о последних тонированных изображениях. Записи журнала предоставляют следующую информацию:

  • Дата и время выполнения тонирования
  • Статистика задачи тонирования
  • Текущий вид или имя сохраненного вида
  • Имя активного набора параметров тонирования
  • Активные параметры тонирования, например, выходное разрешение
  • Размеры выделенной области, если задачей тонирования использовалось выделение

Примечание В записях журнала хранится не тонированное изображение, а ссылка на его местоположение.

Информация записи журнала

Помимо статистики записи журнала содержат пять элементов:

Имя выходного файла

Содержит два элемента: имя задачи тонирования и ее состояние. При выборе выходного файла в поле отображается имя этого файла. Если выходной файл не указан, отображается имя чертежа с временным суффиксом.

Формат вывода

Сообщает выходное разрешение тонированного изображения.

Вид

Всегда отображается текущий вид, за исключением задач тонирования сохраненного вида. В таком случае отображается имя вида.

Время тонирования

Указывается дата и продолжительность процесса тонирования изображения.

Набор параметров тонирования

Указывается, использовался ли системой набор параметров тонирования при создании изображения.

Время создания записи журнала

Если запись журнала сохраняется с текущим чертежом, она создается с учетом некоторых правил. Параметр назначения - основной фактор, определяющий, будет ли создана запись журнала. Подробнее о том, когда создается запись журнала и где она хранится, см. в следующей таблице.

Назначение | Запись журнала создана? | Запись сохранена с чертежом?
Файл | Да | Да
Окно тонирования | Да | Только при сохранении вида окна тонирования
"Видовой экран" | Нет | Неприменимо

Все созданные записи журнала, но не сохраненные вместе с чертежом, доступны только во время текущего сеанса работы. После закрытия файла или выхода из программы несохраненные записи теряются.

Состояния записи журнала

Существует четыре состояния отображения записи журнала в окне тонирования.

Нормальное

При задании папки для вывода и имени файла для тонирования создается запись журнала, она сохраняется вместе с чертежом. Запись журнала имеет обычный вид, и заданное пользователем имя файла отображается в столбце "Имя файла" в разделе журнала тонирования в окне тонирования.

Временное

Временные записи журнала создаются, если местом расположения тонирования является окно тонирования и пользователем не задано имя выходного файла. Запись журнала хранится в памяти до завершения текущего сеанса работы. Имена временных записей в списке "Имя выходного файла" имеют суффикс - -TempXXX.

Пустой

При задании папки для вывода и имени файла для тонирования создается запись журнала; она сохраняется вместе с чертежом. Запись журнала имеет обычный вид, а заданное пользователем имя файла отображается в столбце "Имя выходного файла" в разделе журнала тонирования в окне тонирования.


Журнал тонированных изображений - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Журнал тонированных изображений
Понятия
Процедуры
Команды

Команды
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
ТОНИРОКНО | Отображается окно тонирования без вызова задачи тонирования.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение и повторное воспроизведение изображений - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Сохранение и повторное воспроизведение изображений
Понятия
Процедуры
Команды

Тонированное изображение можно сохранить на диске, а затем в любой момент воспроизвести его на экране. Повторное воспроизведение тонированного изображения выполняется намного быстрее повторного тонирования.

  • Запись тонированного изображения
    Можно выполнить тонирование с записью в файл или сохранить запись журнала в одном из доступных форматов файлов.
  • Повторное воспроизведение тонированного изображения
    Сохраненное в файле тонированное изображение можно в любой момент воспроизвести на экране монитора.
  • Сохранение копий тонированных изображений
    Можно сохранить копии изображений из журнала тонирования чертежа.
  • Работа с моделями в других приложениях
    Для улучшения качества модели рекомендуется использовать и другие продукты Autodesk.
  • Обновление чертежей более ранней версии продукта
    При открытии чертежей прежних версий AutoCAD содержимое преобразуется для обеспечения совместимости с системой тонирования.


Сохранение и повторное воспроизведение изображений - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Сохранение и повторное воспроизведение изображений
Понятия
Процедуры
Команды

Для тонирования с записью в файл

Для сохранения тонированного изображения, отображаемого на видовом экране

Для сохранения тонированного изображения из "Окна тонирования"

Для сохранения тонированного изображения из окна тонирования


Сохранение и повторное воспроизведение изображений - Команды

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Сохранение и повторное воспроизведение изображений
Понятия
Процедуры
Команды
Команды
ИЗОБВСТАВИТЬ | Вставка нового изображения в текущий чертеж
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
СОХРИЗОБ | Сохранение тонированных изображений в файлах
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
ТОНИРОКНО | Отображается окно тонирования без вызова задачи тонирования.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Запись тонированного изображения - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Запись тонированного изображения
Понятия
Процедуры
Команды

Можно выполнить тонирование с записью в файл или сохранить запись журнала в одном из доступных форматов файлов.

Созданное тонированное изображение можно сохранить на диске, а затем в любой момент воспроизвести его. Длительность выполнения процесса тонирования зависит от выбранных параметров и наборов параметров тонирования. В то же время, повторное воспроизведение изображения, которое было тонировано ранее, происходит мгновенно.

Предусмотрены следующие способы сохранения тонированного изображения: тонирование с одновременной записью в файл; тонирование с выводом на экран и последующим сохранением изображения; тонирование с выводом в окно тонирования и дальнейшим сохранением изображения или его копии. Сохраненное изображение можно воспроизвести в любое время. Кроме того, сохраненные изображения можно использовать в качестве текстур создаваемых материалов.

Тонирование с записью в файл

Независимо от типа установленного в конфигурации монитора, можно вывести тонированное изображение сразу в файл, минуя экран. Преимущество такого способа заключается в том, что тонирование может быть произведено с разрешением, превышающим разрешение имеющегося монитора. Впоследствии изображение можно рассматривать на других системах, обладающих мониторами с более высокой разрешающей способностью. Для задания папки хранения и имени используйте параметр "Цель для изображения" в палитре "Дополнительные параметры тонирования" или на расширенном пульте управления "Тонирование". Тонированное изображение хранится в файле одного из следующих форматов: BMP, TGA, TIF, PCX, JPG или PNG.

Сохранение тонированного изображения, отображаемого на экране

Программой предусмотрено тонирование с выводом изображения на видовой экран. После того как на видовом экране получено тонированное изображение, с помощью команды СОХРИЗОБ его можно сохранить в файле одного из следующих форматов: BMP, TGA, TIF, PCX, JPG или PNG. Доступные для сохранения форматы файлов предлагают большой выбор оттенков серого и значений глубины цвета.

Сохранение тонированного изображения, отображаемого в окне тонирования

Если местом расположения тонирования является окно тонирования, изображение или его копию можно сохранить в файле одного из следующих форматов: BMP, TGA, TIF, PCX, JPG или PNG. В зависимости от выбранного формата файла доступны оттенки серого и значения глубины цвета в диапазоне от 8 до 32 бит на пиксел.


Запись тонированного изображения - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Запись тонированного изображения
Понятия
Процедуры
Команды

Для тонирования с записью в файл

Для сохранения тонированного изображения, отображаемого на видовом экране

Для сохранения тонированного изображения из "Окна тонирования"


Для тонирования с записью в файл - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Запись тонированного изображения
Понятия
Процедуры
Команды

Для тонирования с записью в файл

  1. В командной строке введите режтонир
  2. На палитре "Дополнительные параметры тонирования" установите флажок "Сохранить тонирование в файл".
  3. Нажмите кнопку [...] рядом с полем "Имя выходного файла".
  4. В диалоговом окне "Сохранить как" выберите тип файла и папку для хранения изображения. Нажмите кнопку "Сохранить".
  5. Нажмите кнопку "Тонирование".

    6. Панель "Тонирование"

    Ввод команды: РЕЖИМТОН

    По завершению процесса тонирования изображение выводится в окне тонирования. Кроме того, оно сохраняется в папке с указанным именем.


Для сохранения тонированного изображения, отображаемого на видовом экране - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Запись тонированного изображения
Понятия
Процедуры
Команды

Для сохранения тонированного изображения, отображаемого на видовом экране

  1. После того, как выполнено тонирование изображения, отображаемого на видовом экране, введите в командной строке сохризоб.
  2. В диалоговом окне "Выходной файл тонирования" укажите папку для сохранения изображения.
  3. Введите имя изображения и формат выходного файла.
  4. Нажмите кнопку "Сохранить".

    5. Ввод команды: СОХРИЗОБ


Для сохранения тонированного изображения из "Окна тонирования" - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Запись тонированного изображения
Понятия
Процедуры
Команды

Для сохранения тонированного изображения из "Окна тонирования"

  1. В "Окне тонирования" выберите запись журнала.
  2. Выберите "Файл" » "Сохранить".
  3. В диалоговом окне "Выходной файл тонирования" выберите формат файла, введите местоположение его хранения и имя. Нажмите кнопку "Сохранить".

    4. Изображение сохраняется в выбранном формате файла.


Запись тонированного изображения - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Запись тонированного изображения
Понятия
Процедуры
Команды

Команды
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
СОХРИЗОБ | Сохранение тонированных изображений в файлах
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
ТОНИРОКНО | Отображается окно тонирования без вызова задачи тонирования.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Повторное воспроизведение тонированного изображения - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Повторное воспроизведение тонированного изображения
Понятия
Процедуры
Команды

Сохраненное тонированное изображение можно просмотреть в любое время, открыв его в приложении просмотра изображений Windows.

Кроме того, изображение можно просмотреть, вставив его в чертеж с помощью команды ИЗОБВСТАВИТЬ.


Сохранение и повторное воспроизведение изображений

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Сохранение и повторное воспроизведение изображений
Понятия
Процедуры
Команды

Нет процедур для данного раздела.


Повторное воспроизведение тонированного изображения - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Повторное воспроизведение тонированного изображения
Понятия
Процедуры
Команды

Команды
ИЗОБВСТАВИТЬ | Вставка нового изображения в текущий чертеж
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сохранение копий тонированных изображений - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Сохранение копий тонированных изображений
Понятия
Процедуры
Команды

Можно сохранить копии изображений из журнала тонирования чертежа.

Используйте элемент "Сохранить копию", который имеется в "Окне тонирования" для сохранения тонированного изображения в другой папке, даже если уже установлен путь для выходного файла. Благодаря этому можно выполнить повторное тонирование записи журнала и сравнить новое изображение с предыдущим.


Для сохранения тонированного изображения из окна тонирования - Процедуры

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Сохранение копий тонированных изображений
Понятия
Процедуры
Команды

Для сохранения тонированного изображения из окна тонирования

  1. В окне тонирования выберите запись журнала.
  2. Выберите "Файл" » "Сохранить копию".
  3. В диалоговом окне "Выходной файл тонирования" выберите формат файла, введите местоположение его хранения и имя. Нажмите кнопку "Сохранить".

    4. Изображение сохраняется в выбранном формате файла.


Сохранение копий тонированных изображений - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Сохранение копий тонированных изображений
Понятия
Процедуры
Команды

Команды
РЕЖИМТОН | Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
ТОНИРОКНО | Отображается окно тонирования без вызова задачи тонирования.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с моделями в других приложениях - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Работа с моделями в других приложениях
Понятия
Процедуры
Команды

Для улучшения качества модели рекомендуется использовать и другие продукты Autodesk.

Программы Autodesk®, в том числе 3ds max®, Autodesk® VIZ, Autodesk® Architectural Desktop® и Autodesk® Mechanical Desktop®, постоянно улучшаются для обеспечения совместимости при работе с чертежами и моделями.

3ds max или Autodesk VIZ

С помощью этих программ можно существенно улучшить модели. Программы предоставляют возможность открыть файлы DWG или DXF без преобразования, кроме того можно использовать Диспетчер связей файлов для создания связи с файлом чертежа. 3ds max или Autodesk VIZ предлагает расширенные возможности анимации, широкий выбор источников освещения, материалов и возможностей тонирования, которые повышают реалистичность графических объектов.

Autodesk Architectural Desktop

Геометрию чертежа AutoCAD можно открыть в Autodesk Architectural Desktop в формате DWG. Преобразование файла не требуется. Открыв модель, использовуйте программу VIZ Render - упрощенный вариант приложения Autodesk VIZ. Также доступны "Связь файла", функции создания материалов и дополнительные функции тонирования.

Autodesk Mechanical Desktop

Если требуется использовать данные о геометрии чертежа и тонировании AutoCAD в программе Autodesk Mechanical Desktop, их экспортируют при помощи меню "Файл" » "Экспорт", или импортируют файл, выбрав "Вставка" » "DXB".


Работа с моделями в других приложениях - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Работа с моделями в других приложениях
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Обновление чертежей более ранней версии продукта - Понятия

Создание реалистичных графических изображений
Реалистичное тонирование 3D объектов
Обновление чертежей более ранней версии продукта
Понятия
Процедуры
Команды

При открытии чертежей прежних версий AutoCAD содержимое преобразуется для обеспечения совместимости с системой тонирования.

Источники света, материалы и камеры

Источники света, материалы и камеры улучшены, однако некоторые старые чертежи могут содержать информацию системы AutoShade, например источники света, блоки сцен и камер.

Источники света и материалы старых чертежей также могут быть преобразованы. Содержимое обновляется с использованием следующих методов.

  • Источники света Для блоков источников света сохраняются исходные точки вставки. Для преобразования источника света в новый формат служит команда ПРЕОБРУСТАРСВЕТ.
  • Материалы Для преобразования материалов объектов старых чертежей служит команда ПРЕОБРУСТАРМАТЕРИАЛ.

Если содержимое вставляется в модель командой ИМПОРТ3DC, следует использовать также команды ПРЕОБРУСТАРСВЕТ и ПРЕОБРУСТАРМАТЕРИАЛ. Это обеспечивает правильное преобразование 3dsmax и источников света и материалов Autodesk VIZ.


Обновление чертежей более ранней версии продукта - Команды

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Обновление чертежей более ранней версии продукта
Понятия
Процедуры
Команды

Команды
ТОНИРОВАТЬ | Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Словарь терминов

ObjectARX (AutoCAD Runtime Extension)

Среда программирования, позволяющая разрабатывать компилируемые приложения AutoCAD.

B-сплайновая кривая

Кусочно-гладкая полиномиальная кривая, проходящая вблизи набора управляющих точек. См. также кривая Безье. (СПЛАЙН)

CMYK

От cyan, magenta, yellow, and key color (голубой, фиолетовый, желтый и цвет фонового экрана). Цвет определяется системой исходя из процентного содержания голубого, фиолетового, желтого и фонового экранного (обычно это черный) цветов.

CTB-файл

SТаблица цветозависимых стилей печати.

DIESEL

Direct Interpretively Evaluated String Expression Language (прямая интерпретация содержания текстовой строки). Макроязык, предназначенный для модификации статусной строки AutoCAD с помощью системной переменной MODEMACRO, а также для адаптации пунктов меню.

DSD

От drawing set descriptions (описания наборов чертежей). Формат файлов для хранения описаний наборов чертежей, использующихся в диалоговом окне "Публикация".

DST

От sheet set data (данные подшивки). Формат файлов типа XML, использующийся для хранения сведений о подшивке.

DWF

От Design Web Format (формат для использования в сети Интернет). Формат плотно упакованного файла, создаваемого из чертежа AutoCAD. Файлы формата DWF используются для публикации и просмотра чертежей в сети Интернет. См. также DWG и DXF.

DWG

Стандартный формат файлов для хранения векторной графики. См. также DWF и DXF.

DXF

От drawing interchange format (формат для обмена черетежами). Текстовый (ASCII) или двоичный формат файлов для экспорта чертежей в другие приложения или для импорта чертежей из других приложений. См. также DWF и DWG.

HDI

От Heidi Device Interface (интерфейс устройств Heidi). Интерфейс с драйверами устройств, необходимыми для взаимодействия периферийного оборудования с программой и другими продуктами Autodesk.

HLS

От hue, lightness, saturation (оттенок, яркость, насыщенность). Задание цвета на основе его оттенка, яркости и насыщенности.

i-drop

Элементы, с помощью которых можно перетаскивать файлы чертежей с веб-страниц.

IGES

От Initial graphics exchange specification (исходный стандарт обмена графическими данными). Стандартный формат для двоичного представления данных и обмена ими между различными системами САПР.

ISO

От International Standards Organization (Международная организация стандартов). Организация, занимающаяся разработкой международных стандартов во всех отраслях, кроме электротехники и электроники. Штаб-квартира ISO находится в Женеве (Швейцария).

NURBS

От Nonuniform rational B-spline curve (неоднородный рациональный В-Сплайн). B-сплайновая кривая или поверхность, задаваемая набором управляющих точек с определенными весами и одним или более узловыми векторами. См. также B-сплайновая кривая.

OLE

От Object linking and embedding (присоединенный или встроенный в другие файлы объект). Механизм, с помощью которого данные из исходного документа, созданного с помощью одного приложения, могут быть внедрены в целевой документ, созданный в другом приложении, или связаны с ним. Выбор таких данных в целевом документе инициирует подгрузку исходного приложения, что обеспечивает возможность их редактирования. См. также внедрение и связь.

PC2-файл

Общий файл конфигурации печати. Файлы PC2 содержат все настройки печати и специализированные параметры устройств, сохраненные в прежних версиях программы. См. также файл PCP и файл PC3.

PC3-файл

Частный файл конфигурации плоттера. Содержит параметры печати, включая выбор драйвера и модели устройства, выбор порта для вывода на печать и различные сведения для конкретного устройства печати. Однако в этот набор параметров не входят пользовательские настройки плоттера и сведения о нестандартном формате листа. См. также файл PMP, файл STB и файл CTB.

PCP-файл

Частный файл конфигурации плоттера. Файлы PCP содержат основные параметры печати и перьев, сохраненные в предыдущих версиях программы. К этим параметрам относятся присвоения перьев, единицы измерения для печати, формат листа, поворот чертежа, коэффициент масштабирования и выбор режима оптимизации перемещений перьев. См. также файл PC2 и файл PC3.

PMP-файл

Plot Model Parameter. Файл, содержащий пользовательские сведения о калибровке плоттера и форматах листа. Связан с файлом конфигурации плоттера.

RGB

От Red, green, blue (красный, зеленый, синий). Задание цвета на основе процентного содержания красной, зеленой и синей составляющих.

STB-файл

Файл таблицы стилей печати. Содержит стили печати и их параметры.

TILEMODE

Системная переменная, управляющая режимом создания видовых экранов (либо в виде перемещаемых, масштабируемых объектов, либо как неперекрывающихся элементов экрана со смежными кромками). См. также видовой экран.

X,Y,Z фильтры точек

См. фильтры координат.

абсолютные координаты

Значения координат, измеренные относительно начальной точки системы координат. См. также начало координат, относительные координаты, пользовательская система координат, мировые координаты и Мировая система координат (МСК).

адаптер объектов

Средство просмотра и редактирования сторонних объектов, использующееся, если приложение ObjectARX, в котором был создан сторонний объект, в системе не установлено. См. также пользовательский объект и объект-заместитель.

адаптивная выборка

Метод, ускоряющий процесс устранения зазубрин в пределах границ пробной матрицы. См. также сглаживание.

адаптивное ухудшение

Метод управления производительностью, заключающийся в отключении функций в определенном порядке, когда производительность падает ниже заданного уровня.

активация

Часть процесса регистрации программного обеспечения. Позволяет запускать продукт в соответствии с лицензионным соглашением конечного пользователя продукта.

альфа-канал

"Альфа" представляет собой тип данных, содержащихся в 32-битовых растровых файлах, с помощью которых присваивается прозрачность пикселам изображения.

В файле с 24-битовой точной цветопередачей содержится три канала информации о цвете: красный, зеленый и синий, или RGB. Каждый канал файла с точной цветопередачей задается 8-ю битами, обеспечивая 256 уровней интенсивности. Интенсивность каждого канала определяет цвет пиксела в изображении. Таким образом, файл RGB является 24-битовым с 256 уровнями для каждого цвета: красного, зеленого и синего.

За счет добавления четвертого, альфа-канала, файл может задавать прозрачность или непрозрачность каждого из пикселов. Значение альфа 0 означает прозрачность, значение 255 - непрозрачность, а промежуточные значения означают полупрозрачность. Файл RGBA (красный, зеленый, синий, альфа) является 32 битовым, с дополнительными 8 битами альфа, обеспечивающими 256 уровней прозрачности.

Для вывода изображения, тонированного с использованием альфа, его нужно сохранить в формате, совместимом с альфа, например, PNG, TIFF или Targa.

ассоциативная штриховка

Штриховка замкнутой области, автоматически изменяющаяся при любых модификациях ограничивающего контура. (КШТРИХ)

ассоциативный размер

Размер, автоматически обновляющийся при изменении объекта с нанесенными размерами. Управляется системной переменной DIMASSOC. См. также неассоциативный размер и расчленённый размер.

аффинная калибровка

Метод калибровки планшета, основанный на линейном преобразовании координат в двумерном пространстве. Аффинная калибровка требует ввода трех контрольных точек для вычисления преобразования координат планшета, включая перемещение, независимое масштабирование осей X и Y, а также поворот и искажения. Аффинную калибровку следует использовать, если наблюдается неравномерность в вертикальном и горизонтальном масштабном отображении чертежа при его оцифровке с помощью дигитайзера. (ПЛАНШЕТ)

базовая линия

Воображаемая линия, на которой устанавливаются символы текста. Нижние элементы некоторых символов могут опускаться ниже базовой линии. См. также базовый размер.

базовая точка

1. При редактировании с помощью ручек - ручка, выделяемая цветом после выбора и являющаяся центром последующей операции редактирования. 2. Точка, относительно которой задаются расстояние и угол при копировании, перемещении и повороте объектов. 3. Точка, используемая в качестве опорной при вставке текущего чертежа в другой чертеж. (БАЗА) 4. Точка вставки блока. (БЛОК)

базовый размер

Совокупность размеров, проведенных от одной базовой линии. Также называются параллельные размеры. См. также базовый.

библиотека компонентов

Набор описаний блоков, хранящийся в одном файле чертежа.

библиотека слайдов

Набор файлов слайдов, скомпилированных для хранения и последующего просмотра. Файлы библиотек слайдов имеют расширение .slb и создаются с помощью программы slidelib.exe.

блок

Один или несколько объектов, сгруппированные в единый объект. Иногда, для краткости, используется вместо терминов "описание блока" и "вхождение блока". См. также описание блока и вхождение блока. (БЛОК)

блок метки

Блок, используемый для маркировки видов и подробностей. Метки содержат связанные с видом сведения, такие как имя, номер вида и масштаб. См. также блок-идентификатор.

блок-идентификатор

Блок, используемый в качестве обозначения для ссылки на другой лист. Блоки-идентификаторы могут называться по-разному (в зависимости от отрасли промышленности): ссылочные метки, коды выносных элементов, метки выносных элементов, коды разрезов зданий и т.д. См. также блок метки.

ведомость листов

Таблица с перечнем всех листов в подшивке. Ведомость листов можно сгенерировать автоматически с помощью Диспетчера подшивок.

вектор

Математический объект, обладающий направлением и длиной, но не имеющий фиксированного положения в пространстве.

вершина

Место пересечения кромок объекта или сегментов полилинии.

вес линий

Значение ширины, которое может быть присвоено всем графическим объектам, кроме шрифтов TrueType® и растровых изображений.

вид

Графическое представление двумерного чертежа или трехмерной модели из заданного места (точки зрения) в пространстве. См. также точка зрения и видовой экран. (3DОРБИТА, ТЗРЕНИЯ, ДВИД, ВИД)

вид в перспективе

Вид, на котором 3D объекты рассматриваются из некоторой точки пространства. Чем дальше объект находится от точки наблюдения, тем меньше его видимые размеры. Хотя вид в перспективе достаточно реалистичен, на нем возможно искажение формы объектов. Параллельные линии как будто сходятся. Настройки видов в перспективе задаются в программе для элементов таблиц видовых экранов, а также для объектов видовых экранов, с помощью параметра ВЭКРАН.

вид в плане

Ориентация вида от точки на положительной осиZ к начальной точке (0,0,0). (PLAN)

видовой экран

Ограниченная область экрана, на которой отображается некоторая часть пространства модели чертежа. Тип создаваемого видового экрана определяется системной переменной TILEMODE. 1. Если TILEMODE выключена (0), видовые экраны являются объектами, которые можно перемещать на листе и изменять их размер. (СВИД) 2. Если TILEMODE включена (1), то вся область рисования делится на неперекрывающиеся видовые экраны. См. также TILEMODE, вид и точка зрения. (ВЭКРАН)

видовые экраны пространства модели

Состояние экрана монитора, при котором графическая область разбивается на две или более смежных неперекрывающихся прямоугольных области с видами чертежа. См. также видовые экраны листа, TILEMODE и видовой экран. (ВЭКРАН)

визуальный стиль

Совокупность параметров, определяющих отображение

виртуальное экранное пространство

Область, в пределах которой программа может выполнять панорамирование и зумирование чертежа без необходимости его регенерации.

внедрение

Один из методов использования данных исходного документа в целевом документе. Позволяет вставлять копию объекта из одного документа в другой без ссылки на исходный документ. См. также связывание.

внешние именованные объекты

См. зависимые именованные объекты во внешних ссылках.

внешняя ссылка

Файл чертежа, связанный с другим чертежом или вставленный в него. (ССЫЛКА)

внешняя ссылка

См. внешняя ссылка (ссылка).

временные файлы

Файлы данных, создаваемые в ходе сеанса работы программы. Файлы удаляются по окончании сеанса. При аварийном завершении (например, из-за отключения электропитания), временные файлы могут остаться на диске.

вхождение блока

Составной объект, вставленный в чертеж и отображающий данные из описания блока. Также называется экземпляром. См. также блок и описание блока. (ВСТАВИТЬ)

выбор рамкой

Прямоугольник, позволяющий выбирать группы объектов. Очерчивается в области рисования. См. также секущая рамка, многоугольник выбора.

выбор секущей рамкой

Прямоугольная рамка выбора, захватывающая все объекты, которые попадают в нее целиком или пересекают ее границы.

выборка

Выборка представляет собой методику сглаживания цветов. Эта процедура определяет наилучший цвет для каждого тонируемого пиксела. Система тонирования сначала выбирает произвольные пикселы вокруг рассматриваемого пиксела, затем использует фильтр для определения оптимального цвета обрабатываемого пиксела.

выдавливание

Процесс получения трехмерного тела путем смещения объекта вдоль линейной траектории.

выделение зависимости

В описании динамического блока это способ отображения связанных объектов при выборе параметра, ручки или операции.

выплывающая панель

Это область пульта управления, связанная с управляющей панелью. Выплывающая панель содержит дополнительные инструменты и настройки, она может быть отображена или спрятана нажатием кнопки мыши на большом ярлыке в левой части управляющей панели. См. также управляющая панельи пульт управления.

высота

Расстояние, на которое двумерный объект AutoCAD выдавлен выше или ниже уровня, на котором он создан. (ОКОНСВ, СВОЙСТВА, УРОВЕНЬ, ВЫСОТА)

геометрия чертежа

Все графические объекты - отрезки, круги, дуги, полилинии, размеры и т.д. Неграфическая информация (типы линий, веса линий, текстовые стили, слои и т.д.) не считается геометрией. См. также именованный объект.

границы

См. границы чертежа.

границы чертежа

Наименьший прямоугольник, который может вместить в себя все объекты в чертеже, расположенные на экране таким образом, чтобы выглядеть наиболее крупно. (ПОКАЗАТЬ)

грань

Треугольный или четырехугольный участок поверхности.

графическая область

См. область рисования.

графическое окно

См. окно AutoCAD и область рисования.

группа листов

Именованный набор листов в подшивке, часто составляемый на основе этапа моделирования. См. также категория видов.

допуск сплайна

Значение максимально допустимого отклонения B-сплайна от его определяющих точек.

журнал тела

Свойство тела, позволяющее, просматривать и изменять исходные формы тела.

зависимые именованные объекты во внешних ссылках

Именованные объекты (например слои, блоки или типы линий), появившиеся в результате вставки или наложения внешней ссылки. См. также именованный объект и символьная таблица.

зависимые символы

См. зависимые именованные объекты во внешних ссылках.

задняя грань

Противоположная (относительно передней грани) сторона объекта. Задние грани не видны на тонированном изображении модели. См. также передние грани.

зазубрины

Эффект ступенчатости границ объектов на растровом мониторе, не способном гладко отображать диагональные отрезки, дуги и круги. См. также устранение зазубрин.

закрашивание

Сплошное заполнение цветом области, ограниченной отрезками или кривыми. (ЗАКРАСИТЬ)

закрепляемое окно

Элемент интерфейса пользователя, который в области рисования может быть закрепленным, прикрепленным якорем или плавающим. В закрепляемых окнах находятся окна команд, инструментальные палитры, палитра свойств и т.д.

замораживание

Подавление отображения объектов, расположенных на указанных слоях. Объекты на замороженных слоях не выводятся на экран, не регенерируются и не вычерчиваются. Замораживание слоев ускоряет регенерацию чертежа. См. также размораживание. (СЛОЙ)

затухание

Ослабление интенсивности света с расстоянием.

захватываемая точка

При использовании таких способов указания положения точки, как отслеживание или отслеживание привязки объектов, в качестве опорной точки используется промежуточное положение.

зеркальное отражение

Создание объектов, симметричных выбранным относительно заданной оси или плоскости. (ЗЕРКАЛО)

зеркальное отражение

Узкий световой конус, для которого угол падения луча равен углу его отражения.

значение атрибута

Текстовая информация, связанная с именем атрибута. См. также описание атрибута, подсказка атрибута и имя атрибута.

значение по умолчанию

Изначально заданное значение вводимой величины или параметра. Значения и параметры по умолчанию отображаются в угловых скобках (<>).

значок ПСК

Это значок, который показывает ориентацию осей пользовательской системы координат. (ЗНАКПСК)

зумирование

Процесс уменьшения или увеличения видимых размеров области рисования на экране. (ПОКАЗАТЬ)

изометрический стиль шаговой привязки

Режим рисования, позволяющий выровнять курсор и изображение двух или трех из изометрических осей и отобразить сетку, облегчающую создание 2D изометрических чертежей.

именованная траектория

Сохраненная траектория перемещения объекта, связанная с камерой или целью.

именованный вид

Вид, сохраненный с возможностью последующего восстановления. (ВИД)

именованный объект

Описывает различные виды неграфической информации (например, стили или описания), хранящейся в чертежах. Именованными объектами являются типы линий, слои, размерные стили, текстовые стили, описания блоков, листы, виды и конфигурации видовых экранов. Именованные объекты записываются в символьные таблицы.

имя атрибута

Связанная с атрибутом текстовая строка, позволяющая различать атрибуты при их извлечении из базы данных. См. также описание атрибута, подсказка атрибута и значение атрибута.

индекс слоя

Список объектов и слоев, на которых они находятся. Слоевой индекс используется для определения области чертежа, загружаемой при его частичном открытии. Сохранение чертежа со слоевым индексом также улучшает производительность обработки внешних ссылок. Для управления сохранением слоевых и пространственных индексов в чертеже служит системная переменная INDEXCTL.

инструмент ручки

Значок, используемый в 3D виде для того, чтобы простым способом ограничивать перемещение или вращение выбранного набора объектов до оси или плоскости. (3DПЕРЕНЕСТИ, 3DПОВЕРНУТЬ)

инструменты вариаций блоков

Операции, параметры и наборы параметров на вкладках окна "Палитры вариации блоков". Используется в редакторе блоков для создания динамических блоков.

кадр

Отдельное статическое изображение в анимационной цепочке. См. также траектория перемещения

камера

Задается текущее положение уровня глаз в 3D модели. Камера хранит координаты XYZ расположения, координаты XYZ цели и поле зрения или фокусное расстояние, определяющее коэффициент увеличения или зумирования.

каркасная модель

Представление объемного объекта с использованием линий и кривых.

карта цветов

Таблица, задающая интенсивность красной, зеленой и синей составляющих (в системе RGB) для каждого из цветов палитры.

карты теней

Карта теней - изображение растрового формата, создаваемое системой тонирования во время предварительного просмотра сцены. Карты теней не отображают цвет, отбрасываемый прозрачными или полупрозрачными объектами. С другой стороны, карты теней могут отображать тени с мягкими краями, что невозможно для теней трассировки луча.

Тени, полученные посредством карты теней, обеспечивают более мягкие края и требуют меньше расчетного времени, чем тени трассировки луча, но являются менее точными. На палитре "Дополнительные параметры тонирования" тени, полученные посредством карты теней, активны при включенном режиме "Карта теней".

категория

См. категория вида.

категория вида

Именованный набор видов в подшивке, часто составляемый на основе общности их функционального назначения. См. также группа.

клавиши быстрого вызова

Это клавиши и их комбинации, которые используются для запуска команд, например, комбинация CTRL+S запускает сохранение файла. Сюда же относятся и функциональные клавиши (F1, F2 и др.). Также известны под названием клавиш ускоренного вызова.

ключевая точка

В описание динамического блока - точка на параметре, запускающая связанную с ней операцию при редактировании во вхождении блока.

кнопка выбора

Кнопка устройства указания, используемая для выбора объектов или точек на экране. Например, на двухкнопочной мыши кнопкой выбора по умолчанию является левая кнопка.

кнопочное меню

Меню для устройств указания, имеющих несколько кнопок. Каждая кнопка на устройстве указания (кроме кнопки выбора) может быть определена в файле адаптации (acad.cui).

командная строка

Текстовая область, предназначенная для ввода с клавиатуры, отображения запросов и сообщений.

контекстное меню

Меню, которое появляется в месте расположения графического курсора при нажатии правой кнопки устройства указания. Набор предлагаемых функций зависит от того, в какой области экрана находится курсор, а также от других факторов (наличие выбранного объекта, выполняемая команда и т.п.).

конфигурация видовых экранов

Именованная совокупность видовых экранов модели, которую можно сохранять и восстанавливать. (ВЭКРАН)

координатные фильтры

Средство, позволяющее извлекать значения координат точек отдельно по каждой из осей X, Y и Z с целью последующего их использования для задания положения новой точки. Также называются точечными фильтрами X,Y,Z.

корпоративный файл настройки

Файл НПИ, управление которым обычно осуществляет менеджер по САПР. Обычно файл хранится в сетевой папке, и к нему имеют доступ многие пользователи. Пользователи имеют доступ только для чтения для предотвращения изменения данных в файле. Менеджер по САПР создает файл НПИ предприятия путем изменения основного файла НПИ и сохранения его в папку файлов поддержки, задаваемой на вкладке "Файлы" диалогового окна "Настройки".

кривая Безье

Полиномиальная кривая, задаваемая набором определяющих точек. Представляет уравнение, порядок которого на одну ступень меньше количества учитываемых точек. Кривая Безье - частный случай B-сплайновой кривой. См. также B-сплайновая кривая.

кривая профиля

Объект, который сдвигается, выдавливается или вращается, задавая форму результирующего тела или поверхности. (СДВИГ, ВЫДАВИТЬ, ВРАЩАТЬ)

криволинейная траектория

Определяет направление и длину для поднятия, сдвига или выдавливания кривой профиля при построении тела или поверхности. (СДВИГ, ПОСЕЧЕНИЯМ, ВЫДАВИТЬ)

кромка

Ограничивающая линия грани.

круговой массив

Расположение заданного количества копий объекта вокруг указанной центральной точки. (МАССИВ)

курсор

См. указатель и курсор в форме перекрестия.

лимиты

См. лимиты чертежа.

лимиты чертежа

См. лимиты сетки.

лимиты чертежа

Заданные пользователем размеры области чертежа, также называются лимиты чертежа. (ЛИМИТЫ)

линии кривизны

Линии, предназначенные для повышения наглядности при визуализации поверхностей.

линия выбора

Ломаная линия, захватывающая все объекты, пересеченные ей.

линия отражения

Во вхождении динамического блока это ось, относительно которой выполняется отражение набора операции отражения при редактировании связанного параметра с помощью ручки или палитры свойств.

лист

Вкладка, выбранная из файла чертежа и включенная в подшивку. См. также подшивка.

Логическое группирование данных, подобное наложению друг на друга прозрачных пленок с элементами чертежа.

Логическое группирование данных, подобное наложению друг на друга прозрачных пленок с элементами чертежа. Слои могут отображаться по отдельности или в комбинации. (СЛОЙ)

маркеры

Временные метки на экране, отображаемые в области рисования при указании точек и выборе объектов. (МАРКЕР)

маскирующий объект

Полигональная область, использующаяся для скрытия находящихся под ней объектов. Скрытие производится текущим цветом фона. Область ограничивается контурами, видимость которых можно включать при редактировании и отключать при печати.

массив

1. Совокупность объектов, полученная копированием исходного объекта в узлы прямоугольной или круговой структуры. (МАССИВ) 2. Набор записей данных, каждая из которых идентифицируется ключом.

меню курсора

См. контекстное меню.

метка

Уникальный буквенно-цифровой идентификатор объекта в базе данных программы.

метод "направление-расстояние"

Метод указания второй точки путем перемещения курсора в нужном направлении и ввода значения расстояния с клавиатуры.

Мировая система координат, МСК

Система координат, используемая как основа для построения всех объектов и определения других систем координат. См. также пользовательская система координат (ПСК).

мировые координаты

Координаты, заданные в Мировой системе координат (МСК).

многолистовой DWF-файл

DWF-файл, состоящий из нескольких листов.

многоугольник выбора

Опция выбора объектов с помощью произвольного многоугольника (в набор попадают все объекты, полностью расположенные внутри него). См. также секущая рамка и рамка выбора.

модель

Двух- или трехмерное представление объекта.

МСК

См. Мировая система координат (МСК).

набор значений

В описании динамического блока - диапазон или список значений, указанный для параметров линии, круга, координат XY и вращения.

набор листов

Именованный набор листов в подшивке, который можно с удобством использовать для операций архивирования, формирования комплекта и публикации.

набор объектов

Один или несколько объектов, выбранных для последующей обработки.

В описание динамического блока - геометрия, связанная с операцией.

набор параметров

Средство на вкладке "Наборы параметров" окна "Палитры вариации блоков", используемое для добавления одного или нескольких параметров и одной или нескольких операций к описанию динамического блока.

набор параметров листа

Набор параметров устройства печати и других настроек, которые влияют на внешний вид и форматирование печатаемого листа. Эти параметры можно изменять и применять к другим листам.

набор пометок

Группа пометок, содержащаяся в одном DWF-файле.

набор чертежей

Набор чертежей, использующийся в диалоговом окне "Публикация".

направляющие кривые

Отрезки или кривые, пересекающие каждое поперечное сечение полученных методом сечений тела или поверхности, задающие форму посредством добавления к объекту дополнительной каркасной информации. (ПОСЕЧЕНИЯМ)

начало координат

Точка пересечения осей системы координат. Например, точкой начала прямоугольной системы координат является точка пересечения осей X, Y и Z; ее координаты равны (0,0,0).

начальная среда

Значения переменных и другие установки для новых чертежей, задаваемые в шаблоне чертежа, например, acad.dwg, aclt.dwg или acadiso.dwg, acltiso.dwg. См. также чертеж шаблона.

начертание линий

См. тип линий.

неассоциативный размер

Размер, не обновляющийся автоматически при изменении объекта с нанесенными размерами. Управляется системной переменной DIMASSOC. См. также ассоциативный размер и расчлененный размер.

неименованный блок

Блок без имени, используемый при нанесении штриховки, размеров и других подобных объектов.

неперекрывающиеся видовые экраны

См. видовые экраны модели.

нестандартные ручки

Используется для манипулирования геометрией и настраиваемыми свойствами вхождения динамического блока.

нормаль

Нормаль представляет собой вектор, определяющий, в какую сторону направлена грань. Направление нормали указывает переднюю, или внешнюю, сторону грани.

нормаль поверхности

Ориентированный в положительном направлении перпендикуляр к поверхности объекта.

области рисования

области рисования

Область экрана, в которой отображается и редактируется чертеж. Размер области зависит от размера окна AutoCAD и количества видимых в нем панелей и других элементов интерфейса. См. также окно AutoCAD.

обозначения источников света

Графическое представление точечного источника света или прожектора.

обратный выбор

Добавление ручки выбора во вхождение динамического блока. При нажатии этой ручки отображается раскрывающийся список значений поиска для этого свойства поиска (столбец в таблице выбора). При выборе значения из этого списка соответствующие значения свойства входа присваиваются этому вхождению блока. В зависимости от того, как был определен блок, это обычно приводит к изменению геометрии вхождения блока. (БЛОКТАБЛВЫБ)

общее освещение

Отраженное освещение - это способ, позволяющий создавать такие эффекты, как цветовое рассеивание. Свет, падая на цветной объект модели, отражается от него на смежные объекты, добавляя к ним оттенок цвета исходного объекта.

объект

Один или более элементов чертежа (текст, размеры, отрезки, круги, полилинии и т.п.), рассматриваемые как единое целое при создании, обработке и модификации. В прежних версиях программы назывался существующим объектом.

объект-заместитель

Используется вместо сторонних объектов, созданных с помощью приложения ObjectARX, если последнее недоступно. См. также пользовательский объект и адаптер объектов.

объектная привязка

Механизм выбора определенных точек в процессе редактирования чертежа. См. также текущий режим объектной привязки и подавление объектной привязки.

объемные тени

Фотореалистически тонированные области пространства; представляют собой тени, отбрасываемые объектами.

окно AutoCAD

Собирательное название области, занимаемой чертежом, меню, панелями и командной строкой.

операция

Определяет способ перемещения или изменения геометрии вхождения динамического блока при выполнении операций с настраиваемыми свойствами вхождения блока в чертеже. Описание динамического блока обычно содержит по меньшей мере одну операцию, связанную с параметром. (БЛОКРЕАКТ)

описание атрибута

Объект, включаемый в описание блока и предназначенный для хранения буквенно-цифровой информации. Значения атрибутов задаются либо при их описании, либо в момент вставки блока в чертеж. Существует возможность извлечения значений атрибутов из чертежа с выводом в текстовые файлы. (АТОПР)

описание блока

Информация об имени, базовой точке и геометрических объектах, входящих в блок. Хранится в символьной таблице чертежа. См. также блок и вхождение блока.

определяющие точки

Точки, используемые для создания размеров. Программа использует эти точки для изменения вида и значения неассоциативного размера при изменении измеряемого объекта. Эти точки также называются точками описания и хранятся в специальном слое DEFPOINTS.

определяющие точки

Точки, через которые B-сплайн должен проходить либо точно, либо в пределах заданного допуска. См. также точки интерполяции и точки аппроксимации.

оптимизация параметров

Способ оптимизации производительности 3D графики Мастер оптимизации параметров производительности проверяет графическую плату и драйвер 3D дисплея и принимает решение об использовании программной либо аппаратной реализации тех функций, которые поддерживают оба варианта.

опущенная нулевая плоскость

Это плоскость XY в пользовательской системе координат при включённом перспективном проецировании. Опущенная нулевая плоскость отображается с помощью изменения цвета между опущенным дальним планом (ближайшим к горизонту) и опущенным ближним планом (ближайшим к зрителю). См. также цвет неба и поднятая нулевая плоскость.

ортогональность

Свойство объектов, когда касательные к ним в точке пересечения перпендикулярны друг другу.

освежить

Быстрое обновление или очистка изображения на текущем видовом экране от лишних элементов без внесения изменений в базу данных чертежа. См. также регенерировать. (ОСВЕЖИТЬ)

освещение по умолчанию

Освещение на раскрашенном видовом экране при отключенном солнце и отключенных пользовательских источниках света. Грани освещаются двумя удаленными источниками, которые перемещаются при изменении направления взгляда на модель.

основной файл адаптации

Файл НПИ с возможностью записи в него, определяющий большую часть элементов интерфейса пользователя (включая стандартные меню, панели инструментов, клавиши быстрого запуска и т.д.). Файл acad.cui (основной файл CUI по умолчанию) загружается автоматически при запуске AutoCAD.

островок

Замкнутый контур, расположенный внутри другого замкнутого контура. Понятие островков связано с процессами штрихования, построения полилиний и областей. (КШТРИХ, КОНТУР)

относительные координаты

Координаты, заданные относительно предыдущих.

отражённое освещение

Функции освещения, например общее освещение и метод чистовых проб, повышающие реалистичность сцены благодаря имитации диффузионного отражения или взаимного отражения света присутствующими объектами.

пакетный файл

Набор команд программы, выполняемых последовательно с помощью команды "ПАКЕТ". Пакетные файлы создаются вне программы с помощью текстового редактора, сохраняются в текстовом формате и записываются во внешний файл с расширением .scr.

палитры вариации блоков

Инструментальные палитры, используемые в редакторе блоков для добавления операций и параметров к описаниям динамических блоков.

панель

Элемент интерфейса, содержащий значки, которые обозначают команды.

Панель управления

Это область пульта управления, которая содержит необходимые инструменты и элементы управления. См. также пульт управленияи выплывающая панель.

панорамирование

Перемещение вида чертежа без изменения экранного увеличения. См. также зумирование. (ПАН)

параллельный размер

Указывает расстояние между двумя точками под любым углом. Размерная линия параллельна линии, которая соединяет определяющие точки на объекте. (РЗМПАРАЛ)

параметр

В описании динамического блока определяет настраиваемые свойства для динамического блока путем указания положений, расстояний и углов для геометрии в блоке.

передние грани

Грани объекта, нормали к которым направлены от экрана.

перекрестье

Тип графического курсора, состоящий из двух пересекающихся линий.

переменная среды

Переменная, управляющая работой программы.

персонализация

Настройка выполняемого файла во время установки с указанием имени пользователя, компании и другой информации.

плавающие видовые экраны

См. видовые экраны.

планарная проекция

Проецирование объектов или изображений на плоскость.

плиния

См. полилиния.

плоская грань

Плоская грань, расположенная в любом месте 3D пространства.

плоская поверхность

Плоская поверхность, расположенная в любом месте 3D пространства. (ПЛОСКПОВ)

плоскость построений

См. рабочая плоскость.

ПОБЛОКУ

Специальное свойство объекта. Объекты, обладающие данным свойством, наследуют цвета и типы линий блоков, в которые они входят. См. также ПОСЛОЮ.

поверхность Кунса

В 3D поверхностном моделировании - бикубическая (в направлениях M и N) поверхность, натянутая на четыре кромки.

подавление объектной привязки

Механизм временного отключения или изменения текущих режимов объектной привязки для ввода одной точки. См. также объектная привязка и текущий режим объектной привязки.

подложка

Это внешняя ссылка, которая используется для поддержки визуального окружения и некоторых моментальных видов объекта (с ограниченной чёткостью). Подложки не могут быть отредактированы и не обеспечивают полного диапазона обозначений внешних ссылок. Подложки не могут быть привязаны к чертежу.

поднятая нулевая плоскость

Это плоскость XY в пользовательской системе координат при включённом перспективном проецировании и просмотре снизу. Поднятая нулевая плоскость отображается с помощью изменения цвета между поднятым дальним планом (ближайшим к горизонту) и поднятым ближним планом (ближайшим к зрителю). См. также опущенная нулевая плоскостьи цвет неба.

подобъект

Любая часть тела: грань, ребро или вершина. А также исходная индивидуальная форма, являющаяся частью составного тела.

подсказка

Сообщение в командной строке, в котором содержится запрос на ввод данных или указание точки.

подсказка атрибута

Текстовая строка, которая выводится при вставке блока, имеющего атрибуты с не определенными заранее значениями. См. также описание атрибута, имя атрибута и значение атрибута.

подшивка

Именованный и структурированный набор листов из различных чертежей. См. также лист. (ПОДШИВКА)

поле

Специальный текстовый объект, предназначенный для отображения данных, которые могут поменяться в ходе редактирования чертежа. При обновлении поля отображается его последнее значение. (ПОЛЕ)

полилиния

Объект, состоящий из одного или нескольких связанных между собой прямолинейных и дуговых сегментов, Также называется плиния. (PLINE, PEDIT)

политело

Тело сдвига, вычерчиваемое таким же способом, как и полилиния, или на основе существующей линии. По умолчанию у политела всегда прямоугольные контуры. Предусмотрено задание высоты и ширины политела. (ПОЛИТЕЛО)

пользовательская система координат, ПСК

Определяемая пользователем система координат, устанавливающая ориентацию осей X, Y и Z в трехмерном пространстве. Текущая ПСК задает расположение геометрии чертежа по умолчанию. См. также Мировая система координат (МСК).

полярная привязка

Средство обеспечения точности построений. Позволяет привязываться к точкам, расположенным с определенными интервалами вдоль полярных лучей, которые расходятся из исходной точки. См. также полярное отслеживание.

полярное отслеживание

Средство обеспечения точности построений. Выдает пользователю набор временных линий, проходящих под заданными углами. См. также полярная привязка.

пометка

Отдельные комментарий или исправление, вставленное в DWF-файл с помощью средства просмотра проектов Autodesk.

пометки

Текстовая информация в чертеже: заголовки, размеры, допуски, символы, примечания и пояснения.

поперечные сечения

Как правило, это кривые или отрезки, определяющие контур (форму) тела или поверхности, получаемых с помощью сечений. Поперечные сечения могут быть разомкнутыми или замкнутыми. Тело или поверхность, получаемые с помощью сечений, рисуются в пространстве между поперечными сечениями. (ПОСЕЧЕНИЯМ)

ПОСЛОЮ

Специальное свойство объекта. Объекты, обладающие данным свойством, наследуют цвета и типы линий слоев, на которых они расположены. См. также ПОБЛОКУ.

предварительный выбор

Режим, позволяющий выбрать объект еще до ввода команды его обработки.

прозрачная команда

Команда, которую можно вызывать в ходе выполнения другой команды. Для использования команды в прозрачном режиме перед ее именем следует ввести апостроф.

производственные материалы

Материалы, получаемые путем генерации трехмерного образца с использованием двух или более цветов, с последующим наложением на поверхность объекта. Они обеспечивают имитацию мрамора и дерева. Также называются шаблонами материалов.

промежуточный маркер

Это используемый в отслеживании и объектном отслеживании значок "плюс", временно устанавливаемый в захватываемых точках.

пропорция

Отношение ширины экрана монитора к его высоте.

пространственный индекс

Список объектов и их положений в пространстве. Пространственный индекс используется для определения области чертежа, загружаемой при его частичном открытии. Сохранение чертежа с пространственным индексом также улучшает производительность обработки внешних ссылок. Для управления сохранением слоевых и пространственных индексов в чертеже служит системная переменная INDEXCTL.

пространство листа

Одно из двух основных пространств для размещения объектов. В нем производится окончательная компоновка видов для вычерчивания (в отличие от построения моделей, которое выполняется в пространстве модели). Ее построение выполняется на вкладке "Модель". См. также пространство модели и видовой экран. (ЛИСТ)

пространство модели

Одно из двух основных пространств для размещения объектов. Обычно геометрическая модель располагается в трехмерном пространстве модели, а отдельные виды модели и пояснения в пространстве листа. См. также пространство листа. (МОДЕЛЬ)

псевдоним

Сочетание клавиш для команды. Например, КПявляется псевдонимом для команды КОПИРОВАТЬ, а ПО - псевдонимом для команды ПОКАЗАТЬ. Псевдоимена определяются в файле acad.pgp.

ПСК

См. пользовательская система координат (ПСК).

пульт управления

Это специальная палитра, на которой отображаются кнопки и элементы управления, использующиеся, в основном, для 3D моделирования, просмотра и тонирования. См. также панель управления и выплывающая панель. (ПУЛЬТУПР)

путь поиска библиотек AutoCAD

Программа выполняет поиск файла поддержки в следующем порядке: текущая папка, папка чертежа, папка, указанная в пути поддержки и папка, содержащая исполняемый файл acad.exe.

рабочая плоскость

Альтернативное название для плоскости XY в пользовательской системе координат. См. также подъем и пользовательская система координат (ПСК).

рабочее пространство

Наборы меню, панелей инструментов и закрепляемых окон (таких, как "Палитра свойств", "DesignCenter", "Инструментальные палитры"), объединенных и организованных таким образом, что можно работать в настроенной и удобной для рисования среде.

рабочий набор

Группа объектов, выбранных в ходе редактирования вхождений ссылок.

рабочий чертеж

Чертеж, предназначенный для непосредственного применения в производстве или строительстве.

размер шага

Интервал между точками сетки шаговой привязки.

размерная дуга

Дуга (обычно со стрелками или засечками на концах), проходящая между двумя выносными линиями размера, которые образуют измеряемый угол. Размерный текст пишется рядом с размерной дугой, иногда деля ее на две части. См. также угловой размер.

размерная стрелка

Символ (стрелка, засечка, точка и т.п.), наносимый на концах размерной линии для отметки начала и конца размера.

размерная цепочка

Вид линейного размера, использующий начало второй выносной линии выбранного размера в качестве начала своей первой выносной линии. При сложении сегментов размерной цепи получается полный размер. (РЗМПРОДОЛЖ)

размерные переменные

Набор числовых величин, текстовых строк и переключателей, управляющих способом нанесения размеров. (РЗМСТИЛЬ)

размерный стиль

Именованная группа установок всех размерных переменных, определяющих вид размера.

размерный текст

Текстовая строка с результатом измерения объекта.

разметка листа

Среда, в которой создаются и компонуются видовые экраны пространства листа, предназначенные для печати. Один чертеж может иметь несколько вариантов разметок.

разметочные видовые экраны

Объекты, создаваемые в пространстве листа для отображения различных видов чертежа. См. также пространство листа. (ВЭКРАН)

размораживание

Включение отображения ранее замороженных слоев. См. также заморозить. (СЛОЙ)

размывание

Способ получения дополнительных оттенков путем составления пространственных комбинаций из точек, окрашенных в разные цвета.

рамка допуска формы и расположения

Задает отклонения геометрических свойств и характеристик. Рамка допуска формы и расположения состоит по меньшей мере из двух частей. В первой находится графический символ, обозначающий вид допуска (формы, расположения и т. п.), а во второй численное значение допуска.

рамка растягивания

В описании динамического блока, содержащем операцию растягивания или операцию полярного растягивания, определяет способ редактирования объектов внутри рамки или пересекаемых рамкой во вхождении блока.

рассеянный свет

Свет, который освещает все поверхности модели с равной интенсивностью. Не имеет ни источника, ни направления; интенсивность рассеянного света не изменяется при любых перемещениях.

растровый формат

Цифровое представление изображения, в котором каждому пикселу соответствует определенное количество бит. Цвет пиксела обычно передается как сумма уровней цветовых составляющих (красного, зеленого и синего).

расчленение

Операция, разбивающая сложный объект (блок, размер, тело или полилинию) на более простые. Описание блока при этом не изменяется. Вхождение блока заменяется на составляющие его объекты. См. также блок, описание блока и вхождение блока. (РАСЧЛЕНИТЬ)

расчлененный размер

Размер, сформированный из отдельных объектов, которые не имеют связи ни друг с другом, ни с объектом с нанесенными размерами. Управляется системной переменной DIMASSOC. См. также ассоциативный размер, неассоциативный размер и расчленить. (РАСЧЛЕНИТЬ)

ребра-модификаторы

Определяют выступание и мерцание ребер при их отображении на раскрашенной модели.

регенерация

Процесс обновления изображения на экране монитора путем пересчета координат в базе данных чертежа. См. также обновление. (РЕГЕН)

режим

Действующие установки программы или ее текущее состояние.

режим "Орто"

Режим работы, допускающий ввод с помощью устройства указания только горизонтальных и вертикальных (по отношению к ПСК и к повороту сетки шаговой привязки) смещений. См. также угол привязки и пользовательская система координат (ПСК).

режим видимости

Отображает или не отображает геометрию (выделена серым цветом), невидимую в состоянии видимости. (BVMODE)

режим цвета грани

Настройка визуального стиля, определяющая способ отображения цвета на грани.

режимы редактирования с помощью ручек

Средства редактирования, активизируемые при включенных ручках: растягивание, перемещение, поворот, масштабирование и зеркальное отображение.

резиновая линия

Временная линия, динамически растягивающаяся и сжимающаяся при перемещении курсора. Один конец линии прикреплен к фиксированной точке на чертеже, а другой к перекрестью курсора.

ручки

Небольшие квадратики и треугольники, отображаемые на выбранных объектах. После выбора ручки объект можно редактировать путем перетаскивания, не прибегая к вводу команд редактирования.

свойство входа

В описании динамического блока - свойство параметров, кроме таких, как поиск, выравнивание и параметр базовой точки, которые можно добавить в таблицу выбора в виде столбца. Когда значения параметров вхождения динамического блока соответствуют ряду значений свойств входа, значения соответствующего свойства поиска присваиваются этому вхождению блока. (БЛОКТАБЛВЫБ)

свойство выбора

В описании динамического блока - параметр выбора, добавляемый в таблицу выбора. Метка параметра выбора используется в качестве имени свойства. Когда значения параметров вхождения динамического блока соответствуют ряду значений свойств входа, значения соответствующего свойства поиска присваиваются этому вхождению блока. (БЛОКТАБЛВЫБ)

связь

Один из методов использования данных исходного документа в целевом документе. При этом любые изменения объекта в исходном документе влекут за собой изменения этого объекта во всех других документах, использующих данный объект посредством связи. См. также внедрение.

сглаженное тонирование

Сглаживание зазубрин и плавные переходы цветов на многогранных тонированных поверхностях.

сглаживание

Процесс уменьшения неровности границ объектов путем подбора оттенка пикселов, смежных с пикселами, определяющими линию границы объекта. См. также зазубрины

секущие плоскости

Границы, определяющие или подрезающие поле вида.

сетка

Область, покрытая точками или отрезками с равными интервалами между ними, облегчающая построение чертежа. Шаг сетки можно регулировать. Точки сетки никогда не распечатываются. См. также лимиты сетки. (СЕТКА)

сетка шаговой привязки

Невидимая сетка, к точкам которой привязывается перемещение курсора при включенном режиме "Шаг". Шаг привязки может быть не равен интервалу видимой на экране сетки, контролируемому независимо командой СЕТКА. (ШАГ)

символ

Повсеместно используемый в чертежах графический элемент. Символы вставляются в чертежи в виде блоков.

символьная таблица

См. таблица описаний и таблица блоков.

системная переменная

Имя, с которым связан какой-либо режим, размер или ограничение. Системные переменные, доступные только для чтения (например, DWGNAME), не могут непосредственно изменяться пользователем.

слежение

Способ задания положения некоторой точки относительно других точек чертежа.

сопоставление слоев

Отображение имеющихся слоев в слои, заданные в стандарте оформления. Стандарты регулируют именование слоев и их свойства. Также называется соответствием слоев.

составное тело

Тело, созданное на основе двух или более отдельных тел. (ОБЪЕДИНЕНИЕ, ВЫЧЕСТЬ, ПЕРЕСЕЧЕНИЕ)

состояние видимости

В динамическом блоке - настраиваемое свойство, позволяющее отображать во вхождении блока только выбранную геометрию. (БЛОКСОСТВИД)

сохранение в исходный чертеж

Обновление объектов исходного чертежа внешней ссылки или описания блока после того, как были отредактированы их вхождения.

спираль

Открытая 2D или 3D спираль. (СПИРАЛЬ)

ссылка

Определение, известное как внешняя ссылка или вхождение блока. Применяется и хранится в самом чертеже. См. также блок (БЛОК) и внешняя ссылка (ССЫЛКА). (ССЫЛКА)

стиль грани

Настройка визуального стиля, определяющая раскрашивание грани.

стиль печати

Свойство объекта, задающее его вид при вычерчивании (цвет, размывание, оттенки серого, присвоения перьев, прозрачность, тип и вес линии, торцы и соединения, способ закраски). Прикладывается только в процессе печати.

сторонний объект

Тип объектов, созданных в приложениях ObjectARX и обладающих обычно более специализированными функциями по сравнению со стандартными объектами. Сторонними объектами являются, например, параметрические тела (Autodesk Mechanical Desktop), настраиваемые интерактивные обозначения дверей (Autodesk Architectural Desktop), многоугольные объекты (Autodesk Map) и ассоциативные размеры (AutoCAD и AutoCAD LT). См. также объект-заместитель и адаптер объектов.

таблица

Прямоугольный массив ячеек, содержащих текстовые объекты или блоки. В архитектуре и строительстве таблицы часто относятся к спецификациям и содержат информацию о материалах, необходимых для возведения проектируемого здания. В обрабатывающей промышленности, таблицы часто используются как перечни материалов. (ТАБЛИЦА)

таблица выбора

Определяет и указывает значения свойств для динамического блока. Указывает значения свойств для вхождения динамического блока в зависимости от манипулирования блоком в чертеже. (БЛОКТАБЛВЫБ)

таблица описаний

Неграфическая часть файла чертежа, в которой хранятся описания блоков.

таблица описаний блоков

Неграфическая часть файла чертежа, в которой хранятся описания блоков. См. также именованный объект.

таблица стилей печати

Набор стилей печати. Стили печати заносятся в таблицу; к объектам они применяются только после назначения таблицы листу или видовому экрану.

текстовый стиль

Именованный, сохраненный набор установок, определяющий вид текстовых символов, например, растянутых, сжатых, наклоненных, зеркально отображаемых или расположенных вертикально в столбце.

текстура

Проецирование изображения образца поверхности определенного материала на поверхность заданного объекта.

текстура выдавливания

Текстура, значения яркости в точках которой преобразуются в кажущуюся высоту поверхности объекта.

текстура отражения

Используется для создания эффекта отражения сцены от поверхности освещенного материала.

текстура прозрачности

Наложение прозрачных и непрозрачных областей на объекты.

текущий режим объектной привязки

Постоянно действующий режим, который можно использовать для указания нескольких точек. См. также объектная привязка и подавление объектной привязки. (ПРИВЯЗКА)

текущий чертеж

Файл чертежа, открытый в программе, на который направлены все команды и операции, задаваемые пользователем.

тело

Объект, представляющий общий объём объекта, например, параллепипед.

тело/поверхность сдвига

Тело или поверхность, очертания которых получены в результате сдвига заданного контура (объект сдвига) вдоль заданной траектории. (СДВИГ)

тело/поверхность, построенные методом сечений

Тело или поверхность, вычерченные с помощью набора из двух или нескольких кривых поперечных сечений. Поперечные сечения определяют контур (форму) результирующего тела или поверхности. Поперечные сечения (как правило, кривые или отрезки) могут быть разомкнутыми или замкнутыми. (ПОСЕЧЕНИЯМ)

тени трассировки луча

Способ, используемый системой тонирования для получения теней. Функция "Отслеживание лучей" отслеживает путь лучей, исходящих из источника света. Тени появляются в тех местах, где распространению лучей препятствуют объекты. Тени трассировки лучей имеют резкие границы.

Тени трассировки луча активны, если на палитре "Дополнительные параметры тонирования" отключена "Карта теней".

тип линий

Определяет внешний вид отрезка или кривой. Именно благодаря этому свойству, например, непрерывная линия отличается от прерывистой. Также называется начертание линий . (ТИПЛИН)

тонирование по Гучу

Тип раскрашивания, при котором в большей степени используется переход от холодных к теплым тонам, чем переход от темного к светлому.

точка

Точка в трехмерной системе координат, заданная с помощью значений X, Y и Z. 2. Объект, состоящий из одной точки в системе координат. (ТОЧКА)

точка зрения

Точка в трехмерном пространстве, из которой рассматривается модель. См. также вид и точка зрения. (3DОРБИТА, ДВИД, ТЗРЕНИЯ)

точки аппроксимации

Точки, задающие вид B-сплайна, который может отклоняться от них на величину, заданную допуском аппроксимации. См. также определяющие точки и точки интерполяции.

точки интерполяции

Точки, задающие вид B-сплайна и принадлежащие ему. См. также точки аппроксимации и определяющие точки.

траектория перемещения

Определяет траекторию или цель камеры. Траектория может представлять собой отрезок, дугу, эллиптическую дугу, окружность, полилинию, трехмерную полилинию или сплайн.

трассировка лучей

Система тонирования генерирует отражения и преломления. Функция "Отслеживание лучей" отслеживает путь лучей, исходящих из источника света. Возникающие при этом отражения и преломления лучей точны с физической точки зрения.

Трассировка лучей включается на палитре "Дополнительные параметры тонирования".

тройка осей

Значок с изображением осей X, Y и Z, используемый для задания точки зрения (направления взгляда) в трехмерном чертеже. (ТЗРЕНИЯ)

угловой размер

Размер для углов и дуговых сегментов, включающий размерную дугу, текст, выносные линии и выноски. (РЗМУГЛОВОЙ)

угловые единицы

Единицы измерения углов. Углы могут измеряться в десятичных градусах, градусах-минутах-секундах, градах и радианах.

угол поворота сетки привязки

Угол, на который повернута сетка привязки.

узел

Режим привязки к объектам-точкам, определяющим точкам размеров и точкам вставки размерного текста.

указатель

Курсор на экране монитора. Его текущая позиция определяет положение наносимой текстовой и графической информации. См. также курсоры в форме перекрестия.

управляющая точка

См. управляющая рамка.

управляющий контур

Набор управляющих точек, соединенных линейными сегментами. Используется как механизм управления формой B-сплайна. Вывод управляющего контура обеспечивает более наглядное представление для визуального контроля за отклонением сплайна от его определяющих точек. Для вывода управляющего контура на экран должна быть включена переменная SPLFRAME.

уровень

Координата Z (над или под плоскостью XY текущей ПСК), назначаемая по умолчанию при вводе координат и оцифровке точек. (УРОВЕНЬ)

файл адаптации (НПИ)

Файл XML, в котором хранятся данные об адаптации. Файл адаптации можно изменить в диалоговом окне "Настройка интерфейса пользователя". Файлы НПИ заменяют файлы MNU, MNS и MNC, которые использовались для определения параметров меню в более ранних версиях.

файл вывода атрибутов

Текстовый файл, в который выводятся значения атрибутов. Содержание и формат данного файла определяются с помощью файла шаблона вывода атрибутов. См. также файл шаблона вывода атрибутов.

файл слайда

Файл, содержащий растровое изображение или снимок объектов, отображаемых в области рисования. Имеет расширение .sld. (ДСЛАЙД, СЛАЙД)

файл частичной адаптации

Любой файл НПИ, который не определен как основной файл НПИ. Частичные файлы НПИ можно загружать и выгружать по мере необходимости во время сеанса работы с чертежом.

файл шаблона вывода атрибутов

Текстовый файл, в котором определяется, какие атрибуты заносятся в файл вывода и в каком формате. См. также файл вывода атрибутов.

фильтры

См. фильтры координат.

фильтры точек

См. фильтры координат.

фокусное расстояние

Определяет увеличительные свойства объектива камеры. Чем больше фокусное расстояние объектива, тем ближе поле зрения.

Формат файлов шаблонов для Интернет-публикаций чертежей.

Формат файлов шаблонов для Интернет-публикаций чертежей.

фотонная схема

Способ создания эффектов отражённого освещения для общего освещения, используемый системой тонирования. При расчёте отражённого освещения устройство тонирования отслеживает фотоны, испускаемые источником света. Фотон проходит через модель, отражаясь или передаваясь от объекта, пока не достигнет диффузной поверхности. После этого параметры фотона сохраняются в фотонной схеме.

фотореалистичное тонирование

Тонирование с получением изображений фотографического качества.

цвет диффузного отражения

Основной цвет объекта.

цвет неба

Это цвет фона в области чертежа при включённом перспективном проецировании. Он отображается изменением цвета между дальним (ближайшим к горизонту) и ближним (ближайшим к зрителю) планами неба. См. также опущенная нулевая плоскость

цвет отражения

Цвет блика на освещенном материале. Также называется цвет блика

цвет рассеянного света

Цвет, полученный действием только рассеянного света.

цель камеры

Определяет рассматриваемую точку: координаты центра вида.

Центр подписки

Средство, доступное с помощью меню "Справка", обеспечивает подписчикам доступ к последним версиям программных продуктов Autodesk, программам-расширениям, технической поддержке через Интернет и электронному обучению (e-Learning).

Цепочка операций

В описании динамического блока свойство параметров точки, линии, круга, координат XY и вращения. Если для параметра установлено значение "Да", изменение операции, содержащей параметр из набора объектов для операции, запускает все операции, связанные с этим параметром. Это аналогично редактированию параметра во вхождении блока с помощью ручек или настраиваемых свойств.

циклическая внешняя ссылка

Внешняя ссылка, которая явно или неявно ссылается сама на себя. Ссылки, создающие цикличность, игнорируются.

чертеж по умолчанию

См. начальная среда.

чистовые пробы

"Чистовые пробы" являются необязательным дополнительным шагом при вычислении общего освещения. Применение фотонной схемы для вычисления общего освещения может приводить к возникновению дефектов тонирования, таких как темные углы и низкочастотные колебания освещения. Подобные дефекты можно частично или полностью подавить, включив метод чистовых проб, который увеличивает число лучей, используемых при обсчитывании эффекта общего освещения.

Метод чистовых проб значительно увеличивает продолжительность процесса тонирования. Он наиболее удобен для сцен с общим диффузным освещением и меньше подходит для сцен с яркими точкам отражённого освещения.

Режим чистовых проб включается на палитре "Дополнительные параметры тонирования". См. также общее освещение

шаблон чертежа

Файл чертежа, установки которого используются как основа для новых чертежей, например acad.dwt, aclt.dwt и acadiso.dwt, acltiso.dwt;. Каждый чертеж, однако, можно использовать в качестве шаблона. См. также исходная среда.

Шаговая привязка

Привязка перемещения графического курсора к точкам воображаемой прямоугольной сетки. При включенном режиме "Шаг" курсор и все введенные координаты привязываются к ближайшей точке такой сетки. Размер шага перемещения курсора определяется заданным интервалом сетки шаговой привязки. См. также объектная привязка. (ШАГ)

шрифт

Набор символов (буквы, цифры, знаки препинания и специальные значки), имеющих определенные размеры и форму.

экземпляр блока

См. вхождение блока.

электронный набор чертежей

Электронный аналог набора чертежей, распечатанных на бумаге. Электронный набор чертежей можно получить, опубликовав чертежи в файле формата DWF.

элемент интерфейса

Объекты интерфейса пользователя, такие как панель инструментов, контекстное меню, сочетание клавиш, закрепляемое окно, могут быть настраиваемыми.

элементарное тело

Базовая форма тела. К элементарным телам относятся: параллепипед, клин, конус, цилиндр, сфера, тор и пирамида.


Комментарии пользователя

Данная форма предназначена для ввода замечаний и предложений, которые будут отправлены в группу технической документации компании Autodesk.

Заголовок и расположение раздела (не изменять):
Имя и фамилия (не обязательно):
         E-mail (не обязательно):
Текст комментария:

Замечание: Форма не может служить средством получения советов или технической поддержки. Информация из нее будет использована для улучшения документации по продукту. Благодарим Вас!